顿悟大乘正理决

《顿悟大乘正理决》暨《大乘二十二问》

     顿悟大乘正理决（摩诃衍撰 依据敦煌本辑校）

     大乘二十二问（昙旷 撰；巴宙 辑校）

    附录：

         中国禅宗在西藏（释慧严）

         大乘二十二问之研究（巴宙）

敦煌文献整理·中华佛典宝库录入

下一页


顿悟大乘正理决

敦煌文献整理·中华佛典宝库录入

上一页　下一页

顿悟大乘正理决

 摩诃衍撰 (依据敦煌本辑校)

    顿悟大乘正理决
    摩诃衍撰 (依据敦煌本辑校)

    叙
    前河西观察判官朝散大夫殿中侍御史锡撰

    （此叙原为敦煌所出·有巴黎伯希和本（简称P本）及伦敦史坦因本（简称S卷）。此处所录，据伯希和本，而校以史坦因本。

    自释迦化灭，年代逾远，经编贝叶，部袟虽多，其或真言，意兼秘密，理既深邃，非易涯津。是乃诸部竞兴，邪执纷糺。爰有小乘浅智，大义全乖，肆荧火之微光，与太阳而争耀。厥兹蕃国，俗习邪风，佛教无传，禅宗莫测。粤我圣赞普，夙植善本，顿悟真筌，愍（一）万性以长迷，演三乘之奥旨。固知真违言说，则乘［一］实非乘，性离有无，信法而非法。盖随世谛，广被［二］根机，不舍声闻，曲存文字，颁传境内，备遣精修。交聘（二）邻邦，大延（三）龙象。于五天竺国，请婆罗门僧等卅人，于大唐国，请汉僧大禅师摩诃衍等三人。会同净域，互（四）说真宗。我大师密授禅门，明标法印，皇后没卢氏，一自虔（五）诚，划然开悟，剃除绀发，披挂缁衣，朗戒（六）珠于情田，洞禅宗于定水，虽莲花不深，犹未足为喻也。善能为方便，化诱生灵，常为赞普姨（七）母悉囊南氏，及诸大臣夫人卅余人说大乘法，皆一时出家矣！亦何异波阇波提为比丘尼之唱首尔。又有僧统大德宝真，俗本姓鶂禅师，律不昧于情田，经论备［三］谈于口海，护持佛法，倍（八）更精修，或支解色身，曾[四]非娆动，并禅习然也。又有僧苏毗王嗣子须伽提，节操精修，戒珠明朗，身披百衲（九），心契三空。谓我大师曰：恨大师来晚，不得早闻此法耳。首自申年，我大师忽奉明诏曰：婆罗门僧等奉言：汉僧所教授顿悟禅宗，并非金口所说，请即停废。我禅师乃犹然而笑曰：异（一〇）哉！此土（一一）众生，岂无大乘种性，而感［五］魔军娆动耶？为我所教禅法，不契佛理，而自取殄灭耶？悲愍（一二）含灵，泫然流泪，遂于佛前恭虔（一三）稽首而言曰：若此土众生，与大乘有缘，复所开禅法不谬，请与小乘论议，商榷（一四）是非，则法鼓振而动乾坤，法螺吹而倒（一五）山岳；若言不称理，则愿密迹金刚，碎贫道为微尘圣主之前也。于是奏曰：伏请圣上，与婆罗门僧，责其问目，对相诘难，校勘经义，须有指归；少似差违，便请停废。帝曰：俞！婆罗门僧等，以月系年，搜索经义，屡奏问目，务掇瑕玼。我大师乃心湛真筌，随问便答，若清风之卷雾，豁覩遥天，喻宝镜以临轩，明分众像。婆罗门等随言理屈，约义词穷，分已摧锋，犹思拒辙，遂复眩惑大臣，谋结朋（一六）［六］党。有吐番僧乞奢弥尸毗磨罗等二人，知身聚沫，深契禅枝（一七）［七］为法捐躯，何曾顾己，或头燃炽火，或身解霜刀，曰：“吾不忍见朋（一八）［八］党相结，毁谤禅法”，遂而死矣！又有吐蕃僧卅余人，皆深悟真理，同词而奏曰：“若禅法不行，吾等请尽脱袈裟，委命沟壑。”婆罗门等乃瞪目卷舌，破胆惊魂，顾影修墙，怀惭战股。既小乘辙乱，岂复能军，看大义旗扬，犹然贾勇。至戌年正月十五日，大宣诏命曰：摩诃衍所开禅义，究畅经文，一无差错，从今已后，任道俗依法修习。小子非才，大师徐谓锡曰：公文墨者，其所问答，颇为题目，兼制叙焉。因目为顿悟大乘正理决。


顿悟大乘正理决

顿悟大乘正理决

摩诃衍撰 (依据敦煌本辑校)

    顿悟大乘正理决
    摩诃衍撰 (依据敦煌本辑校)

    问曰：今看心除习气，出何经文？
    谨答：准佛顶经云：一根既反源，六根成解脱。据金刚经及诸大乘经皆云：离一切妄想习气，则名诸佛。所以令看心，除一切心想妄想习气。

    问：所言大乘经者，何名大乘义？
    答：楞伽经曰：缘有妄想，则见有大小乘，若无妄想，则离大小乘，无乘及乘者，无有乘建立，我说为大乘。

    第一问：或有人言，佛者无量多劫已来，无量（一九）功德，智聚圆备，然始成佛；独离妄想，不得成佛。何以故？若只离（二〇）妄想得成佛者，亦不要说六波罗蜜，十二部经，只合说令灭妄想，既若不如是说，于理相违。
    答：一切众生，缘无量劫已来，常不离得三毒烦恼，无始心想习气妄想，所以流浪生死，不得解脱。准诸法无行经上卷云：若一切法中，除却其心缘相不可得故，是人名为已得度者。又金刚三昧经云：佛言一念心动，五蔭俱生，令彼众生，安坐心神，住金刚地，既无一念。此如如之理，具一切法，又金光明经第二云：一切烦恼，究竟灭尽。是故法如如，如如之智，摄一切佛法。又楞伽经第二云：但离心想妄想（二一）㈨则诸佛如来法身不思（二二）议智慧，自然显现。又法身即顿现，示报身及以化身。又诸法无行经：佛告文殊师利，若有人问汝断一切不善法，成就一切善法，名如来。汝云何答？文殊师利言：如佛坐于道场，颇见法有生灭不？佛言不也。世尊！若法不生不灭，是法可得说断一切不善法（二三）成就一切善法不？佛言不也。世尊！若法不生不灭，不断一切不善法（二四）不成就一切善法，是何所见？何所断？何所证？何所修？何所得？但离心想妄想，即卅七道品，自然具足，一切功德，亦皆圆备，经文广述，不可尽说，任自检寻，当见经义据理。

    问：所对于理不相违，若有众生，离得三毒烦恼，无始心想，习气妄想，便得解脱，亦得成佛，如是功德，不可比量。
    又答：十二部经、准楞伽经云：佛所说经，皆有是义。大慧，诸修多罗，随顺一切众生心说，而非真实在于言中。譬如阳炎，诳惑诸（二五）兽，令生水想，而实无水。众经所说，亦复如是。随诸愚夫，自所分别，令生欢喜，非皆显示圣智所证真实之法。大慧，应随顺义，莫著（二六）言说。又经云：佛言我某夜成道，某夜入涅槃，于此二中间，不说一字，不已说，今说，当说。不说者是佛说。又涅槃经云：闻佛不说法者，是人具足多闻。又金刚经云：“乃至无有少法可得，是为无上菩提。”又经云：“无法可说，是名说法。”据此道理，应不相违。

    又问：有天人制于妄想，以制妄想故，生无想天，此等不至佛道，明知除想，不得成佛。
    谨答：彼诸天人，有观有趣，取无想定，因此妄想，而生彼天（二七），若能离观，离无想定，则无妄想，不生彼天。金刚经云：“离一切诸相（二八），则名诸佛。”若言离妄想不成佛者，出何经文？准楞伽经云：无三乘者谓五种性，众生中谓不定性者假说，不应如是执也。又答：所言五种性者，只缘众生有五种妄想不同，所以说有五种名，若离得妄想，一种性亦无，何处有五耳？岂更立余方便耶？

    问：楞伽经云：所言与声闻授记；化佛化声闻授记，据此只是方便调伏众生，数个义中，涅槃道是三乘也。若离于想，大小之乘，无可言者，谓无想不？观大小乘，非无大小；譬如声闻，证涅槃后，大小之乘，更无所观，此声闻人，岂得言入大乘道不？
    谨答：所言化佛与化声闻授记者，声闻人为未见法身，及以报身；唯见化身。所以化身授记，正合其理。
    又答（二九）：准楞伽经云：“我所说者分别，尔焰识灭，名为涅槃；不言涅槃道，是三乘也。楞伽经偈（三〇）：预流一乘果，不还阿罗汉。是等诸圣人，其心悉迷惑。我所立三乘，一乘及非乘，为愚夫少智，乐寂诸圣说，第一义法门，远离于三趣，住于无境界。何建立三乘，诸禅及无量，无色三摩地（三一），乃至灭受想，唯心不可得”。准斯经义理所说，三乘皆是方便导引（三二）众生法门。又思益经（三三）云：“网明菩萨问思（三四）益梵天言，何为行一切行非行？梵天言：若人千万亿劫行道，于法性理不增不减，是故名行一切行非行。我念过去（三五）无量阿僧祇劫，逢无量阿僧祇诸佛如来，承事无空过者，并行苦行十二头陀，入山学道，持戒精进，所闻智慧（三六）读、诵、思惟。”问：是诸如来，亦不见受记，何以故？依止所行故。以是当知，若是菩萨出过一切诸行，则得授记。据此道理，法性理中，大乘（三七）之见，并是虚妄想，妄想（三八），若离妄想，则无大小之见。又（三九）准楞伽、密严经云：“声闻虽离妄想烦恼，处于习气淈（四〇）譬如昏醉之人，酒醒然后觉；彼声闻亦然，贪著寂灭乐，三昧乐所醉，乃至劫不觉。觉后当成佛。”声闻（四一）贪着寂灭乐，所以不得入（四二）大乘。

    又问：所言声闻住无相（四三），得入大乘否？
    答：准楞伽经云：“若住无相（四四），不见于大乘”，所以不得取无相（四五）定。是故经文：“应无所住而生其心”。

    第二问：离一切相名诸佛，是何经说？
    谨答：金刚经云：“离一切诸相，则名诸佛”。又大般若经，楞伽、华严等经中，亦具广说。

    又再新（四六）问：金刚经云：“若了达诸法，观了然后不观者，是智慧（四七）。”若具修一切善已，然始无修，为化众生，生（四八）大智自然成就，言先愿力，故为凡夫妄想不生，凡夫本来不达一切（四九），犹未具诸功德，雄灭妄想，不得成佛。以要言之：解一切法是智，修一切善法（五〇）是福，为成就如是一切故，所以经历多劫，因诸福智力故，三昧无观，从此方显。又首楞严（五一）三昧经云：“初习观故，然得此三昧，譬如学射，初射竹箪，大如牛身；已后渐小，由（五二）如毛发，并亦皆中。”从习于观，是渐修行，诸佛所说，皆是渐门，不见顿门。
    答第二新问：准楞伽经云：“佛告大慧（五三）菩萨，应莫著（五四）文字，随宜说法，我及诸佛，皆随众生烦恼解故，欲（五五）种种不同，而（五六）为开演，令知诸法自心所现。”又思益经云：“说法性理，若人千万亿劫行道，于法性理不增不减。”若了知此理，是名大智慧（五七），于法性理中，修以不修，皆是妄想。据法性道理，若离妄想，大智本自然成就，若论福智，更无过（五八）法性道理，及以法性三昧，所言渐顿，皆为众生心想，妄想见。是故经云：“（五九）大慧（六〇）是故应离因缘所作和合想中，渐顿生见。”若离一切想（六一）妄想，渐顿不可得；若言离妄想不成佛者，出何经文所言？首楞严（六二）经云：“学射渐渐者，不缘增长心想妄想；只合令除妄想。”

    旧问第三，问：（六三）言一切想者，其想云何？
    答：想者，心念起动，及取外境，言一切者，下（六四）至地狱，上至诸佛已下。楞伽经云：“诸法无自性，皆是妄想心见。”

    新问第三：上至诸佛，下至地狱之想，切要兹（六五）长，成就善法，违离恶法，因此而行。若不识佛，不知地狱，如说十二因缘中无明，凡夫中不合修行此法。
    新问第三，答：一切众生，缘无始已来，妄想分别；取著妄想善恶法，或长善，或长恶。以是因缘，流浪生死，出离不得：所以经文，凡所有想［十］皆是虚妄，若见诸想（六六）非想，则见（六七）如来。若了知此一（六八）念功德，经无量劫修习善法（六九）不如此（七〇）一念功德。又所言凡夫位中，不合学此法者，一切诸佛菩萨，无量劫所修习善法，成等正（七一）觉，皆留与后代末法众生，教令修学，既言凡夫众生不合学此法，是诸佛法教，留与阿谁？凡夫不合学此法，出何经文？

    旧问：想有何过？
    答：想过者，能障众生本来一切智，及三恶道久远轮回，故有此过。金刚经说，亦令离一切诸想，则名诸佛。

    新问第四，问或有故令生长之想，或有不令生想，处凡夫地，初修行时，不得除一切想。
    答：诸大乘经云：“一切众生，缘有妄想分别（七二），取著生不生妄想，是故流浪生死；若能不取（七三）著生不生妄想，便得（七四）解脱。凡夫众生，不得除想，出何经文？

    旧问：云何看心？
    答：返照心源看心，心（七五）想若动，有无净不净、空不空等，尽皆不思（七六）不观者亦不思。（七七），故净名经中说：“不观是菩提”。

    新问第五，问：据十地经中：“八地菩萨，唯入不观，佛令入修行。”据此事，凡夫初地犹未得，唯不观如何可得（七八）？
    答：准楞伽经云：“八地菩萨，离一切观及分别习气，无量劫来，所受善恶业者，如乾闼婆城，如幻化等。了知菩萨（七九）者超过一切行，得无生法（八〇）忍，然后得授记。不闻八地菩萨，教令修行，经文何如说，只合细寻（八一）诸经所说（八二）。凡夫未得初地，不合不（八三）观者，此义合行不行，前问说讫。

    旧问：作何方便，除得妄想及以习气？
    答：妄想起不觉，名生死；觉竟，不随妄想作业，不取不住，念念即是解脱般若。宝积（八四）经云：“不得少法，名无上菩提。”

    新问第六，问：如前所说，凡夫初学，岂得喻佛，佛是已成就者。
    答：凡夫虽不（八五）共佛，同诸佛所悟之法，准经文皆留与后代末法众生，教令修学；若不如是，法教留与阿谁？又佛言（八六）无有少法可得者，不可执著言说，若无少法可得，无思无观，利益一切者，可不是得否？
    答：此义前者已答了，今更重（八七）来，又再说者：佛从无量劫来，己离得不得心？亦无心无思，犹如明镜。无心无思，离得不得，但随众生，应物现形，水喻宝喻，日月等喻，皆亦同等。又据入如来功德经云：非是不得少法，是得一切法，与义相违者。前问所言，凡夫不合学此法，所以攀大乘经文时，得如是无量无边功德，何况信受修行，因此言故，答如此事。以无所得故，是名为得。于理实不（八八）相违。

    旧问：“六波罗蜜等（八九）及诸法门，要不要？”
    答：如世谛法、六波罗蜜等，为方便显胜义故，非是不要。如胜义离言说，六波罗蜜及诸法门，不可说言要与（九〇）不要，诸经广说。

    新问第七，问：世间及第一义谛，是一是异（九一）。
    答：不一不异。云何不一（九二）？妄想未尽，已来见有世谛，云何（九三）不异？离（九四）一切妄想习气时，一异不可分别（九五）。

    又问：此方便为显示第一义故，只为钝根［十一］者；为复利钝（九六）俱要？
    答：钝根不了（九七）胜义者要；利根者不论要不要。

    又问：六波罗蜜等及余法门，不（九八）言说要不要者，何为不可说？
    答：为法性理，即不可说。据法性理中，要不要，有无，一异，俱不可得。

    又问：言经文广说，如何说为说言要不要不会。
    答：经文广说者，钝根说要；利根不论要不要，譬如病人要药，求渡河人要船，无病之人不言要不要，渡河了，更不要船。

    旧问：六波罗蜜等要时，如何修行？
    答：修行（九九）六波罗蜜者为内为外。内外有二种：内为自渡，外为利益众生，所修行方便者。据般若经、楞伽、思益经（一〇〇）：“修（一〇一）六波罗蜜时，于一切法，无思无观，三业清净，由如阳炎，于一切不取不住。”

    新问第八，问：所言三业清净时，六波罗蜜，凡夫未能行得，且修习不观，中间不修行，待三业清净，然后修习。为复未能净得三业，强修，如何修行？
    答：所言六波罗蜜有四种：一、世间波罗蜜，二、出世间波罗蜜，三、出世间上六（一〇二）波罗蜜，四、内六波罗蜜。准愣伽经云：广说、略（一〇三）说时，若得不观不思时，六波罗蜜自然圆满；未得不观不思，中间事须行六波罗蜜，不希（一〇四）望果报。

    又问云：（一〇五）［十二］其野马、阳炎，实是不会！
    答：野马喻妄想心，阳炎喻一切（一〇六）世间一切法。譬如渴野马，见阳炎是水，非实（一〇七）是水（一〇八）；若（一〇九）如是了达世间法时，即是三业清净。

    旧问：修此法门，早晚得解脱？
    答：如楞伽及金刚经云：“离一切想（一一〇）则名诸佛”随其根性利钝，如是修习，妄想习气亦歇，即得解脱。

    旧问：又行此法义，有何功德？
    答：无观无想之功德，思及观照，不可测量，佛所有功德，应如是见，且如此之少分。据般若经云：“假令一切众生、天、人、声闻、缘觉、尽证无上菩提，不如（一一一）闻此般若波罗蜜义，敬信功德，算数所不能及。何以故？人天声闻缘觉，及诸菩萨等，皆从般若波罗蜜出；人天及菩萨等，不能出得般若波罗蜜。又问：何名般若波罗蜜？所谓无想无取，无舍无著，是名般若波罗蜜（一一二）。及入如来功德经（一一三），或有于三千大千世界微尘数佛所供养，承（一一四）彼佛灭度后，又以七宝庄严其塔，高广例如大千世界，又经无量劫供养之功德（一一五）不及闻斯法义，生无疑心，而听所获福德，过彼无量百千倍数。又金刚经云：“若有人满三千大千世界七宝，已用布施，及以恒河沙数身命布施，不如闻一四句偈，其福甚多，不可（一一六）比（一一七）喻。”大乘经中，广说此义，其福德除佛无有知者。

    新问第九，问：令一切众生尽证无上菩提，犹（一一八）不及此福者，此无上菩提，乃成有上，此乃是否？次后说言无上菩提等，从般若（一一九）波罗蜜出：无上菩提，不出般若波罗蜜；不出者说是阿舟＋己箇（一二〇）个菩萨。若说无上菩提，据如今现（一二一）般若波罗蜜，似如此：只如此说者，不可是无上菩提。
    答：所言令一切众生尽证无上菩提，犹［十三］不及此福者：前者（一二二）所言，凡夫众生，不合行此法，所以攀诸大乘经典，及般若波罗蜜。众生闻此法（一二三）生一念净信者，得如是无量无边功德。为比量功德故作如是说。现有经文，说一切诸佛，及诸佛阿耨多罗三藐三菩提法，皆从此经出。

    今再问：有上、无上，及阿舟＋己箇菩萨者，经文现在，请检即知。旧问：若离想不思（一二四）不观，云何（一二五）得一切种智？
    答：若妄心不起，离一切妄想者，真（一二六）性本有，及一切种智，自然显现。如花严及楞伽等经云：“如日出云，浊水澄清；镜得明净，如银离矿等。”

    新问第十，问：此言是实，乃是已成就具势力者之法，非是凡（一二七）夫之法者！
    答：此义前者已答了，今更再问，譬如莲花出离淤泥（一二八），皎洁清净，离诸尘垢，诸天贵人见之弥［十四］敬。阿赖耶识，亦复如是，出习气泥，而得明洁，为诸佛菩萨、天人所重。凡夫众生，亦复如是，若得出离无量劫来，三毒、妄想，分别习气淤泥，还得成就大力之势；凡夫缘有三毒妄想盖覆，所以不出得大势之力。

    旧问：若不观智：云何利益众生？
    答：不思不观，利益众生者，入如来功德经中广说：“由如日月，光照一切；如意宝珠，具出一切。大地能生一切。”

    又问：说执境、执识、执中论此三法中，今依何宗？
    答：此义是般若波罗蜜，无思大乘禅门，无思义中，何论有三，一（一二九）亦不立。般若经中（一三〇）广说。

    新问第十一，问：此义是般若波罗蜜者，纵令是般若波罗蜜智慧（一三一）可得，论禅不相当。佛由［十五］自于般若波罗蜜，分别作六种，共智慧（一三二）各自别说？
    答：所行六波罗蜜者，为求般若波罗蜜，若智慧波罗蜜具者：余五波罗蜜修与不修亦得。又答（一三三）言：所言（一三四）禅不相似者：如宝积经中说：“善住意天子白文殊师利云，大士所言禅行比丘者，何等名（一三五）为禅行比丘耶？文殊师利言，天子！（一三六）无有少法可取（一三七）是为禅行。”又密严经中，“若有能修行如来，微妙定善，知蕴无我，诸见悉除灭。”思益经云：“于诸法无所住，是名禅波罗蜜。”楞伽经云：“不生分别，不起外道涅槃之见，是则名为禅波罗蜜。”及诸大乘经典，皆说如是。据此道理，末法众生，教令修学，何以得知。诸大乘经云：“为末法众生，智慧狭劣，所以广说，若有人闻此法者，即功德不可量，何况信受奉行？”

    旧问：义即如此，何为诸经广说？
    答：如诸经所说，只说众生妄想，若离妄想，更无法可说。所以楞伽经云：“一切诸经，只说众生妄想，真如不在言说之中。”

    又问：众生本来有佛性者，何以得知本来有？如外道言有我，有何差别？
    答：本来有佛性者，如日出云，浊水澄清，镜磨明净。如九十五（一三八）外道者，以要言之，不知三界唯心所变。矿中出银，热[十六]铁却冷，先已说讫，不同外道有所言，有我等者（一三九）见，有（一四〇）作者（一四一）见，有时变者，或执有（一四二）无，观空住著（一四三）于边，以此不同楞伽经广说。

    又问：何名为（一四四）众生？
    答：众生者，从具足（一四五）妄想及五荫、三毒，故有。

    又问：何名二（一四六）乘人？
    答：二乘人者因见一切有，从因缘生：觉一切因缘和合所生者：无常、苦、空、厌于苦，故乐于涅槃，住于空寂。缘有取舍，故名二乘。偈言：“本无而有生，生已而复灭，因缘有非有，不住我教法。待有故成无，待无故成有，无既不可取，有亦不可说。不了我无我，但着于语言，彼溺于二边，自坏亦坏他。若能了此事（一四七），不毁大道师，是名为正观。若随言取义，建立于诸法，以彼建立故，死堕地狱中。”
    臣沙门摩诃衍言：臣闻人能弘道，非道弘人，赖大圣临朝，阐扬正法，虽以三乘所化，令归不二之门，为迷愚苍生，频穷胜谛，臣之所说，无义可思，般若真宗，难（一四八）信难入，非大智能措意，岂小识造次堪闻。当佛启教之秋，五百比丘起出。如来尚犹不制言，退亦甚（一四九）佳。况臣老耄心风[十七]，所说忘（一五〇）前失后，特蒙陛（一五一）下福力加护，理性助宣，实冀广及慈（一五二）悲，绝斯争论，即诸天必皆欢喜，僧尼彼我自无。臣据问而演经，非是信口而虚说，颇依贝叶传，直启禅门。若寻文究源，还同说药而求愈疾，是知居士，默语吉祥，称扬心契（一五三），相应名何有。若须诘难，臣有上足学徒，且聪明利根，复后生可畏，伏望允臣所请，遣缁俗钦承。兼臣本习禅宗，谨录如左进上（一五四）。
    准思益经云：“网（一五五）明菩萨问梵天何为一切行非行。梵天言：若人于千万亿劫行道，于理法性（一五六）不增不减。又思益梵天白佛：菩萨以何行，诸佛授记？佛言：若菩萨不行一切（一五七）诸佛则授记。佛言：我念过去，逢值无量阿僧祇诸佛如来，承事无空过者。及行六波罗蜜，兼行苦行头陀，佛总不授记。何以故？依（一五八）止所行故。以是当知，若菩萨出过一切诸行，佛则受记。我念过去行无量苦行头陀，及六波罗蜜，行一切行，不如一念无作功德。又问：文殊师利叵有无所行，名为正行否？答言：有。若不行一切有为法，是名正行。不退转菩萨白佛言：所说随法行者，何谓也？佛告天子，随法行者：不行一切法，是名随法行。楞伽经中说：大慧菩萨白佛言：“修多罗中说，如来藏本性清净，常恒不断，无有变易（一五九）。具卅二相，在于一切众生身中，为蕴界处垢衣所缠，贪著（一六〇）恚痴等妄想分别垢之所污染，如无价宝在垢衣中。”并密严、花严、金刚、三昧、法华、普超（一六一）三昧，及诸一切大乘经，具载此义。据斯道理，佛性本有，非是（一六二）修成．但离三毒、虚妄、妄想、习气垢衣，则得解脱，如阿赖耶识（一六三）出习气泥，诸佛菩萨，悟皆尊重。思益经云：若有善男子、善女人，能信解如是法义者，当知是人，得解（一六四）脱诸见；当（一六五）知是人，得陀罗尼；当知是人，行于正念观；当知是人，解达诸法义趣。准楞伽、思益等经：“禅宗云：无乘及乘者，无有乘建立，我说为一乘。”法华经云：“十方诸佛国，无二亦无三，唯有一佛乘，除佛方便说。”窃以斯见，三乘乃是引导众生法门。大佛顶经云：“为迷故说悟，若悟竟，迷悟俱不可得。”缘众生迷妄想故，则言离妄想；若迷得醒悟，自无妄想可离。
    臣今所（一六六）对问目，皆引经文，佛为信者施行［十八］使功德不朽。蹔［十九］繁圣德（一六七），永润黎庶，谨奉表以闻。无任对敡之至。臣沙门摩诃衍诚欢诚喜，顿首顿首谨言，六月十七日，臣沙门摩诃衍表上。
    一切义法（一六八）虽是无为（一六九）无思，若钝根众生，入此法不得者。佛在世时，此娑婆世界，钝根罪重，所以立三乘，说种种方便，示令莫毁胜义，莫轻少许善法。

    问：万一或有人言，十二部经中说云：“三毒烦恼合除，若不用对治，准用无心想，离三毒烦恼不可得。”宝积经中说：“了贪病，用不净观药医治；了嗔病，用慈悲药医治；了愚痴病，须因缘和合药医治；如是应病与药，以对治为药，各依方药治，则三毒烦恼，始除得根本，”又喻有一囚，被枷锁缚等；开鏁要钥匙，脱枷须出钉鍱，解缚须解结，狱中拔出，须索称上，过大碛须与粮（一七〇），具足如是，方得解脱。开鏁喻解脱贪著，出（一七一）钉喻解脱嗔恚，结喻解脱愚痴，狱中称上喻拔出三恶道，粮食喻（一七二）度脱轮回大苦烦恼，具足如是等，则得除尽烦恼（一七三）。若枷鏁不脱，狱中不拔出，不与粮食；若枷锁等，以衣裳覆之，虽目不下（一七四）见枷鏁，其人终不得解脱。既知如此，准修无心想，拟除烦恼者，暂时不见，不能除得根本。有如是说，将何对？
    答：准涅槃经云：“有药名阿伽陁，若有众生服者，治一切病。”药喻无（一七五）思、无观。三毒、烦恼、妄想，皆从思惟分别变化生。所言缚者，一切众生已来，皆是三毒、烦恼、无想习气系缚，非是铁叶绳（一七六）索，系缚在狱，须得绳索粮食等，此则是第二重邪见、妄想，请除却！是故惣不思惟，一切三毒烦恼妄想习气，一时惣得解脱。

    又问：唯用无心想，离三毒烦恼，不可得者。
    答：准愣伽经云：佛言，复次，大慧菩萨摩诃萨，若欲了知能取所取分（一七七）别境界，皆是自心之所现者，当（一七八）离愦闹昏滞睡眠，初中后夜（一七九）远离增闻［二十］外道邪论，通达自心分别境界，远离分别，亦离妄想心，及生、住、灭，如是了知，恒住不舍。大慧，此菩萨摩诃萨，不久当得生死涅槃，二性平等。唯用无心想，离三毒烦恼，不可得者，见经文说。离烦恼妄想分别，此菩萨不久当得生死涅槃二种平等。唯用无心想，离三毒烦恼，不可得解脱者（一八〇），出何经文？

    又问：看心妄想起觉时，出何经文？
    答：涅槃经第十八云：“云何名为（一八一）佛，佛者名觉，既自觉悟，复能觉他。善男子，譬如有人，觉知有贼，贼无（一八二）能为；菩萨摩诃萨（一八三），能觉一切无量烦恼，既觉了已，令诸烦恼，无所（一八四）能为，是故名佛。”是故坐禅看心，妄想念起，觉则不（一八五）取不住，不顺烦恼作业，是名念念解脱。

    问：诸大乘中说无二者是实，无二即是智慧（一八六），分别即（一八七）是方便智慧（一八八），不可分离（一八九）。维摩经云（一九〇）分明具说，此“二”，言一要，一不要，无有如此分别。若有如（一九一）此分别，即有取舍。有如此（一九二）说请答者。
    答：诸佛如来无量劫已来，离三毒、妄想、烦恼分别，是故悟得（一九三）无二无分别智。以此无二无分别智，善能分别诸法相，非是愚痴妄想分别。据此道理，智慧方便不相离，若（一九四）言取舍，于无二法中，有何（一九五）取舍？

    问：（一九六）或有人言，诸经中说，曰（一九七）禅天名为大果。彼天无心想，虽然还有所观（一九八），还有趣向；得无心想定者，于成就灭心想之人，岂有如此分别？初入无想念之时，初从此分别门观察（一九九），无想念，虽不现如（二〇〇）此分别（二〇一）本从此门入，所以有是［十九］分别。此二若箇是？有人问，如何对（二〇二）。
    答：准楞伽经云：“诸（二〇三）禅及无量、无色、三摩地，乃至灭受想，唯心不可得。”据此经文，所问天乘者，皆是自心妄想分别（二〇四）。此问早已（二〇五）两度答了。据此经文，皆（二〇六）自心妄想，缘有心相妄想分别，生于彼天，是故经言：“离一切诸相，则名诸佛。”所言若个是者；于佛法中，若有是非，皆是邪见。

    问：万一（二〇七）或有人言，缘初未灭心想时，从此门观，所以有分（二〇八）别者；则楞伽七卷中说：从此（二〇九）门观察入顿门，亦入分别非想（二一〇）天，现无心想（二一一）。若言缘有趣向分别者，即是有心想；得不言无心想。若有人问，如何对（二一二）。
    谨答：所言缘初未灭心想时，从此门观，所以有分别者；则楞伽经七卷中说“从此（二一三）门观察入顿门”者：答此义，前文已答了，今更再问者：众生有妄想分别心，即有若干种问。若离妄想分别心，皆惣不可得。又言，亦入分别非想天，现无心想（二一四）。又言缘有趣向分别者则（二一五）是有心想；不可（二一六）得言无心想。若有人问，如何对答者？答：此问同前问（二一七）天乘有想、无想，有分别、无分别，皆是自心妄想分别，是故（二一八）楞伽经云：“三界唯心”。若离心想，皆不可得。

    又问：“万一或有人言，缘住在修行，所以不授记者；非是缘修行不授记。尚在修行中，似未合到授记时。首楞严三昧经中说，言“分明授记，不深密（二一九）授记。”如此三授记，既处高上。所修行欲近成就，修行功用渐少者：喻如耕种，初用功多；成熟即（二二〇）用人功渐少，从此即有喫（二二一）［二二］用功（二二二）课。或云，非是不要修行者，若为对答？
    答：思益经第二云：梵天白佛言：菩萨以何行，诸佛授记？佛言：若菩萨不行生法，不行灭不（二二三）行不善法，不行世间法（二二四）不行出世间法（二二五），不行有罪法，不行无罪法，不行有漏法（二二六），不行无漏法（二二七）不行有为法，不行无为法（二二八）不行涅槃法（二二九），不行见法，不行闻法，不行觉法，不行知法，不行施法（二三〇），不行舍法（二三一）不行戒法（二三二），不行覆，不行忍，不行（二三三）善，不行法，不行精进，不行禅，不行三昧，不行慧，不行行，不行知，不行得（二三四），若菩萨如是行者，诸佛则授记（二三五）。授记者，有何义？佛言：离诸法二相，是授记义，不分别生灭，是授记义（二三六）；离身口意业相（二三七），是授记义，我念过去无量阿僧祇劫（二三八），逢值诸佛如来，承事无空过者，惣不授记；何以故？为依止所行故。我于后时（二三九），遇燃灯（二四〇）佛得授记者，出过一切诸行。又问：文殊师利颇有无所行，名正行不？答言：有。若不行一切有为法，是名正行。尔时会中有（二四一）天子名不退转，白佛言：“世尊所说随法行者，为何谓也。”佛告天子：“随法行者：不行一切法，是名随法行。所以者何？若不行（二四二）诸法，则不分别是正是邪。”准经文胜义如此。若（二四三）修行得授记者，未取（二四四）哉！”

    又问：万一或有一言，一切法（二四五）依自所思［二三］令知所观善事，则为功德；所观恶事，则为罪咎［二四］；二俱不观，则是假说。若有人言，合观善事，则（二四六）为功德者，若为对答？
    答：“不著（二四七）文字，缘功德事入者，喻如合字，一人（二四八）口莫作一人口（二四九）思量，须作和合义思量。答言（二五〇）所言观善恶假说，和合离文字等事者，皆是众生自心妄想分别。但离自心妄想分别，善恶假说，“和合”“一人口”思量，离文字等俱不可得，即是和合义入功德，亦不可比量。”

    问：万一（二五一）有人言；其法（二五二）虽不离罪（二五三）、福，佛性（二五四）但住著法济，亦具无量功德。喻如三十二相皆须遍修，然得成就如是果，各有分折［二五］（二五五）。放如是光，于众生得如是益，承前（二五六）修如是善，得如是果慧（二五七），从淳熟中现其功德，从积（二五八）贮然后成就。不得（二五九）言新积贮中无功德，若有人问，云何以答者（二六〇）？
    谨答：准思益经云：“千万亿劫行道，于法性理不增不减。”又准金刚三昧经（二六一）：“如如之理，具一切法。”若一切众生离三毒，自心妄想、烦恼、习气、分别，通达（二六二）如如之理，则具足一切法及诸功德。

    又问：（二六三）或有人言说，佛法深奥，兼神力变化，凡下虽不能修，犹如无前后，一时示现一切色相于大众（二六四）前，并以一切语，说一切法（二六五），亦凡下所能；但示现（二六六）佛之广大，令生爱乐，务在闻此（二六七）功德。若有人（二六八）问，云（二六九）何答？又问：万一或有人言，缘缘想后，如上所说；但是圣智若是无想，非是无二。有人问，如何答？又问：万一或有人言：凡下不远离心想者，或有经中云，令思量在前，或言惠先行，或言亦置如是想中，亦有处分令生心想，或处分远离心想；不可执一，所以用诸方便演说。或有人言，何以对如前三段问？
    谨答：皆是自心妄想分别，若能离自心妄想分别，如是三段问皆不可得。准楞伽思益经云，离一切诸见，名为正见。

    又问：万一或有人言：发心觉不依想念，则各得念念解脱者，出何经文？觉者，觉何物？愿答。
    答：所言发心觉，不依想念，则各得念念解脱者，出何经文？其义先以准涅槃经具答了；今更重问者，一切众生无量劫来为三毒自心妄想分别，不觉不知，流浪生死。今一时觉悟，念念妄想起，不顺妄想作业，念念解脱，觉者，觉如此事。是故楞伽经云：菩萨念念入正受，念念离妄想，念念即解脱。佛顶第三云：阿难，汝犹未明一切浮尘诸幻化，当处出生，随处灭尽，幻妄称相，其性真为妙觉妙明体，如是乃至五（二七〇）蕴六入，从十二处至十八界，因缘和合，虚妄有生，因缘别离，虚妄名灭。殊不能知生、死、去来，本如来藏，常住妙明，不动周圆，妙真如性。性真常[二六］中，求于去来，迷悟死生，了无（二七一）所得。
    臣前后（二七二）说，皆依经文（二七三），非是本宗。若论本宗者，离言说相（二七四）[二七]离自（二七五）心分别相（二七六），若（二七七）论说（二七八）胜义，即如此。准（二七九）法华经文：“十方诸佛国，无二亦无三，唯有一佛乘，除佛方便说。”何为方便？三归、五戒、十善，一称南无佛（二八〇），至一（二八一）合掌，及以小低头等，乃至六波罗蜜。诸佛菩萨以（二八二）此方便，引导（二八三）众生，令入胜义，此则（二八四）是方便。夫胜义者，难会难入，准善住（二八五）意天子经云：“佛在世（二八六）时，文殊师利菩萨说胜义法时（二八七），五百比丘在众听法，闻文殊师利说胜义法（二八八）时，不信受毁谤。当时地裂，五百比丘堕在阿鼻地狱。”是故一味之水，各见不同；一切众生，亦复如是，知见各各不同。譬如龙王一云所覆，一雨所润（二八九），一切树木及以药草，随其根机性（二九〇）而得增长。一切众生，亦复如是。佛以一音演说法界（二九一）众生随类各得解。一切众生根机（二九二）不同，譬如小泉流入大海。伏望圣主，任随根机方便，离妄想分别，令入于无二胜义法海，此亦是诸佛方便。

    问：卅七道品法（二九三）要不要？
    答：准诸法无行经上卷云：“但离心想、妄想，—切分别思维，则是自然具足三十七道品法。”此问（二九四）两度答了，今更再问者，若悟得不思、不观、如如之理，一切法自然具足，修与不修亦得。如未（二九五）得不思、不观、如如之理事，须行（二九六）六波罗蜜，三十（二九七）七助（二九八）道法。准金刚三昧经云：“如如之理，具足一切法。”若论如如之理，法离修不修。
    臣沙门摩诃衍言：当沙州降下之日，奉（二九九）赞普恩命，远追令开示禅门。及至逻娑，众人共问禅法，为未奉进止，罔敢即说。后追到讼割（三〇〇），屡蒙圣主诘[二八]（三〇一）讫，却发遣赴逻娑，教令说禅。复于章蹉，及特便逻娑，数月盘诘。又于勃碧漫寻究其源，非是一度。陛下了知臣之所说[二九]禅门宗旨是正，方遣与达摩摩低（三〇二）同开禅教。然始勅命（三〇三）颁下诸处，令百姓官寮（三〇四）尽知。复陛下一览具明，胜义洞晓。臣之朽昧，纵说（三〇五）人罕依行（三〇六），自今若有疑徒，伏望天恩与决。且（三〇七）臣前后所说，皆依问准经文对之，亦非臣禅门本宗。臣之所宗，离一切言说相，离自心分别相，即是真谛。皆默传默授，言语道断。若苦论（三〇八）是非得失，却成有诤三味。如一味之水，各见不同，小大智能，实难等用。特望随所乐者修行，自当杜绝法我，则臣荣幸之甚，允众之甚。谨奉表陈情以闻，无任战汗之至。臣摩诃衍诚惶（三〇九）诚恐，顿首顿首，谨言。
    摩诃衍闻，奏为佛法义，寂禅教理，前后频蒙赐问，余有见解，尽以对答：其六波罗蜜等，及诸善要修不修？恩敕屡诘。兼师僧官（三一〇）寮（三一一）亦论六波罗蜜等诸善，自身不行，弟子及余人亦不教修行，诸弟子亦学如是。复有人（三一二）奏闻。但臣所教授（三一三）弟子，皆（三一四）依经文指示，臣所行行（三一五），及教弟子法门，兼弟子所修行处（三一六）各各具（三一七）见解进上。缘凡夫众生力微，据修行理，与六波罗蜜亦不相违。其六波罗蜜与诸善，要行不行者，前后所对者，是约胜义，不言行不行。论世间法，乃至三皈依，一合掌发愿，大小诸善，上下尽皆为说，悉令修行。衍和（三一八）上教门徒子弟（三一九）处。
    沙门释衍曰：法性遍言说智所（三二〇）不及，其习禅者令看心，若心（三二一）念起时，不观不思（三二二）有无等；不思者亦不思。若心想起时不觉，随顺修行，即轮回生死；若觉，不顺妄想作业，即念念解脱，离一切。诸佛（三二三）于胜义中，离修不修。若论世间法，假三业清净，不住，不着（三二四），则是行六波罗蜜。又外持声闻戒，内持菩萨戒，此两种戒则能除三毒习气。所修行者，空言说无益事；须修行（三二五）依无取舍。虽说三（三二六）恶道，天、人、外道二乘禅，令其知解，不遣依行。一切三界众生，自家业现，犹如幻化阳焰，心之所变。若通达真如理性，即是坐禅。若未通达者；即须转经（三二七），合掌礼拜修善。凡修功德，不过教示大乘法门令会。犹如一灯然百千灯事，法施以利群生。摩诃衍一生已来，唯习大乘禅，不是法师；若欣听法相，令于婆罗门法师边听。摩诃衍所说，不依疏论，准大乘经文指示。摩诃衍所修习者：依大般若、楞伽、思益、密严、金刚、维摩、大佛顶、花严、涅槃、宝积、普起（三二八）三昧等经，信受奉行。摩诃衍依止和（三二九）上法号降魔，小福，张和上，雄仰（三三〇），大福（三三一）六和上，同教示大乘禅门。自从闻法已来，经五六十年，亦曾（三三二）久居山林树下。出家已来，所得信施财物，亦不（三三三）曾贮（三三四）积，随时尽皆转施，每日早（三三五）朝，为施主及一切众生转大乘经一卷，随世间法焚（三三六）香，皆发愿愿四方宁静，万姓安乐，早得成佛。亦曾于京（三三七）中已上三处开（三三八）法，信受弟子约有五千余人。现今弟子沙弥，未能修禅，已教诵得楞伽一部，维摩一部，每日长诵。
    摩诃衍向此所教弟子，今者各问所见解缘布施事由，若（三三九）有人乞身头目，及须诸物等，誓愿尽舍，除十八事外（三四〇），少有人畜直一钱物，当直[三〇]亦有。除声闻戒外，更持菩萨戒，及行十二头陁，兼忍（三四一）坚固，复信胜（三四二）义。精进坐禅，仍长习陀罗尼，为利益众生，出家供养三宝，转诵修善。
    于大乘无观禅中无别缘事，常习不阙（三四三）以智慧，每诵大乘（三四四）取义，信乐般若波罗蜜者甚多。亦为三宝益得众生时，不惜身命，其愿甚多，为他人说涅槃义时，[走@又]超（三四五）过言说计度境（三四六）界。若不（三四七）随世间，归依三宝，渐次修善，空学文字，亦无益事。须学修（三四八）行，未（三四九）坐禅时，依戒波罗蜜、四无量心等，及修诸善，承事三宝，一切经中所说，师僧所教，闻者如说修行。但是修诸善，若未能不观时，所（三五〇）有功德，回施众生，皆令成佛。
＝＝＝＝＝＝＝＝＝
    注：《顿悟大乘正理决》正文由中华佛典宝库录自张曼涛主编《现代佛教学术丛刊79卷·汉藏佛教关系研究》1979年版。原校记略，需要者可点此下载、参考扫描图像。


大乘二十二问

大乘二十二问

昙旷 撰；巴宙（美国爱渥华大学宗教学院教授） 辑校
中华佛学学报第三期

    大乘二十二问
    昙旷 撰；巴宙 辑校
    美国爱渥华大学宗教学院教授
    中华佛学学报第三期(1990.04出版)页83～114

    提要
    此作品为唐代昙旷大师所撰。迄至西元785年左右，他尚活著。但是，他确实的生卒年月无从知悉。
    全书共有二十二个问题及回答，题名为“大乘二十二间”。这些关于大小乘佛教教理的问是是由一个西藏国王提出，诸如：佛性、三身、空、真如、涅槃、菩提心、阿赖耶识，及声闻与菩萨证取涅槃的差异等等。我们将这些问题列入七个子目之内，藉作对本书的指南：
    Ⅰ菩萨的行持--这有六个问题：NO.1,2,9,10,12,13。 Ⅱ凡夫的修行--这有四个问题：NO.3,4,8,14。 Ⅲ三乘间之各种差异--这有四个问题：NO.15,16,17,18。Ⅳ佛陀之成就--这有三个问题：NO.5,6,7。Ⅴ法身与涅槃的种类--这有三个问题：NO.11,19,20。 Ⅵ阿赖耶识与大智慧--这有一个问题：NO.21。Ⅶ佛教宗派的发展 -- 这有一个问题：NO.22。
    现时的写本是根据三个颇为残缺与错误百出的敦煌写卷，编号为斯2690，来自大英博物馆，及伯2690与伯2674，来自巴黎国家图书馆，经细心勘查，校对及编辑之后而成。卷末附有将近四百个小注以说明各卷之许多错误、缺漏、修正、填补、以及其他有关各方面。
    再者，在本写卷之首端有一“简介”短序，那对本书的优点、性质、内容、历史及其影响等作了扼要陈述，那或可对其在佛学领域内的重要地位有较好的了解。

    简介
    我想说几句话，作为对“大乘二十二问”的简单介绍。
    本刊(中华佛学学报)第二期曾刊载拙著“大乘二十二问之研究”一文，其文旨是想介绍唐代佛学大师昙旷及其作品“大乘二十二问”给读者。在该文梩我曾提及当时的社会情况，汉藏的外交关系，西藏的佛教，中国佛学研究的趋向，昙旷的生活背景，求学的教育机构，写作成就，以及他对敦煌佛教的影响等等。他之八种有纪录的作品中，七种是关于大乘经论如：金刚经、起信论及百法明门论等的研究与疏释，而其“大乘二十二问”是他唯一有创造性的论著。那是回答一位西藏国王向他提出的一连串有关大小乘佛教教理的问题。兹举例如下：
    “佛有三身，其法身周遍法界，化身各各在一切佛，而其应身有一有异？”(第六问)
    “菩萨法身与佛法身同不同者？”(第十一问)
    “声闻、圆觉、菩萨涅槃，义如何者？”(第十七问)
    “或说二乘皆得成佛，或说二乘不得成佛，义如何者？”(第十八问)
    “大乘经说一切诸法皆无自性，无有生灭，本来涅槃。既尔，如何更须修道，一切自然得涅槃故？”(第二十问)
    从面表上看去它们好像是很简单，其实它们含义深邃。若非对佛学有湛深的研究，及博览经籍，它们确实为很不容易回答的问题。但昙旷的佛学知识渊博，写作经验丰富，他引证了大小乘经论及分析各宗教理的同异，秩序谨严，一点也不混乱；于是，对所有的难题皆给以圆满的解答。举例说，第六问关于“佛之三身”，他不厌其详地陈列不同的意见与观点，使读者明了其究竟而有所抉择。若读者先读这个问答，聊作初步尝试，他或许同意那是名不虚传的。
    除了因回答藏王的问题而阐释佛教的高深的教义之外，此作品是与唐代在西藏召开的中印佛教辩论会有密切关系。这在中印佛教史，及汉藏佛教史上是一重要事件，故西方学者如杜吉(G. Tucci)，戴密微(Paul Demieville)等对此颇为注意。他们曾为专文，或出专书讨论其事“拉萨结集”(Le Concile De Lhasa)一书即是戴氏对此事件的专著。此辩论会的核心及主因为在八世纪时有一位中国禅师名摩诃衍(Mahayana)或大乘和尚者从中国赴西藏传授禅宗顿教。这与当时在西藏流行的传统印度佛教(渐教)实为南辕北辙，遂发生冲突。该派的发言人说：禅宗顿教非佛说。他们请求藏王召开一公开辩论会，以决定是非，并约定若辩论理屈者将被驱逐出境，及禁止传教。根据汉藏两方面的文献，很显然地中国摩诃衍惨遭失败，且被驱逐出境(参看本刊第二期，81-85页)，虽然说在短时期内禅法是又被获准传授及行持了。
    举行此辩论会的日期约在西元781-782年左右，因为藏兵攻陷沙州，包括敦徨地区，是在唐建中二年(西元781年)，就在该年，或稍前数月，藏王邀请摩诃衍入藏弘宣禅法。公开辩论之事，或许发生在其赴藏后的一年之内。戴密微氏提议该会是在西元792-794年召开。如此，则迟延到十年之后了。
    开会的地点，依照戴氏是西藏拉萨，而意大利的杜吉则认为在桑耶(Bsam Yas)举行。他的理由为于西元八世纪时，西藏的文化与宗教中心是“在亚珑(Yar Klun)，古时的宫殿与王冢均设置于此；或在朗玛(Bragmar)，略近桑耶的北部。”我们以为桑耶一说较拉萨为可接受。
    关于辩论会中所提出的争点，与“二十二问”中的各个问题是否有关，因篇幅有限，不能在此重述，请读者参查拙稿“大乘二十二问之研究”(本刊第二期，86-85页)。
    本作品的完成时期大约是在辩论会(781)发生后的数年间，因为藏在大英博物馆敦煌写卷编号为斯2674号的书跋说该卷丁卯年被比丘法灯抄出，该年即西元787。如当时(787)是有本可抄，那末，“大乘二十二问”之问世，应该是在那时期之前写成的。同时，这也证明戴密微氏所提议的792-794年为召开辩论会的日期是不可置信。
    现在略说一说本书敦煌写卷的实况，编辑，校对的过程，以及我们所采取的方法。
    本作品采用了三个敦煌写卷，它们是：
    原卷：斯2674号，标题为“大乘二十二问”，开端残缺，约缺去150字，但其他部份甚完整，今以此为底本。大正藏卷85，古逸部，1184-1192页收录此卷，但讹误与遗漏甚多，其编号为2818。
    甲卷：伯 2690 号，首全，用补原卷开端残缺部分。 缺尾，只有 19 问。 其标题为“二十二问”，无“大乘”二字。
    乙卷：伯 2287 号，开端残缺， 其第一问及第二问太破损，零碎不可辨识，尾全。
    冠于上列各卷番号之前的“斯”字是指收藏在英国大英博物馆的敦煌写卷；而“伯”字是指收藏在法国巴黎国家图书馆的敦煌写本。前者为斯坦因(STEIN)氏所搜集，故有“斯”字，后者为法国伯希和(PELLIOT)氏所珍藏，故有“伯”字，以示区别。
    很显然地，上列各个写卷都是“断简残篇”，没有一个完整的写本。它们都有缺漏，误写，白(别字)字，错字，及其他错讹的地方。我费时数年(包括英译)，将各卷仔细对照及校勘之后，始将正确的语句及段节录下。在原则上我们不改换其原来字句。凡被认为有应改正的错误及讹字，或别字时，其未经改正者则以适当的字置于括弧( )之内；其已经改正者则有小注号码置于其侧，表示有所解释。循著这种方法及互相勘查各写卷，其结果为现时陈列在读者眼前的“新本子”。它与上列各写卷都不同，但它之产生是基于各卷的优点。这是一个综合产品。我们希望它能与最初写成时的原稿相近。它约有13,000字，附以将近四百个小注及解释。
    前些时期我已将此作品译成英文，并发表于英文“中国文化” ( Chinese Culture, Vol.XX, No. 1 and 2,1979,Taiwan)。若读者对此有兴趣的话，请参照该学报。
    为便利读者起见，兹将“大乘二十二问”分为七类。那是依照它们的内容与性质而区分的。如此则界线清晰而不再有摸索之烦：
    Ⅰ. 菩萨的行持。
    此项共有六个问题，即：1，2，9，10，12，13。
    Ⅱ. 凡夫的修行。
    此项共有四个问题，即：3，4，8，14。
    Ⅲ. 三乘间的趋向，行持及证取的差异。
    此项共有四个问题，即：15，16，17，18。
    Ⅳ. 佛陀之成就。
    此项共有三个问题，即：5，6，7。
    Ⅴ. 法身与涅槃的种类。
    此项共有三个问题，即11，19，20。
    Ⅵ. 含藏识与大智慧的关系。
    此项只有一个问题，即：21。
    Ⅶ. 佛教宗派的发展。
    此项只有一个问题，即：22。
    上来各节似已将关于本作品的各个要点一一扼要提出。如此，那或可略尽辑校者的应尽责任。另方面我们希望这或可引起海内外同仁兴趣，因而大家共同去保存，阅读及研究敦煌石窟的珍品。
    最后，若读者能先将拙稿“大乘二十二问之研究”一文(本刊第二期65--110页)略一过目，然后才开始读此作品，那是会事半功倍的。
    *巴宙一九八九，九月一日于楞伽岛(斯里兰卡)。


大乘二十二问

大乘二十二问

昙旷 撰；巴宙（美国爱渥华大学宗教学院教授） 辑校
中华佛学学报第三期

    大乘二十二问(注1)

    夫至教幽深，下凡不测，微言该远，上智犹迷，况昙旷识量荒唐，学业肤浅，博闻既懵于经论，精解又迷于理事。卧病既久，所苦弥深，气力转微，莫能登涉，伏枕边外，驰恋圣颜，深(注2)问忽临，心神惊骇；将欲辞避，恐负(□□)(注3)，力(注4)课疾苦之中，恭答甚深之义，敢申狂简，窃效微诚。然其问端，至极幽隐，或有往年曾学，或有昔岁不闻，所解者以知见而释之，未晓者以通理而畅之。所惧不契圣情，乖于本旨，特乞哀恕，远察衷情。
    第一问云：菩萨离世俗之地，不向(同)声闻缘觉之行，欲令一切众生除烦恼苦，作何法者？
    谨对：谓诸凡夫有人我执；由执我故起烦恼业，沉溺三界，轮转四生，受苦无穷，莫能自出；即此三界，可住(注5)可坏，故名为世，隐覆真理，显现妄法。又名为俗地者，即是依持之义，既依人执，世俗事成，故人我执名世俗地。若二乘人修我空观，了人我空，不起凡夫诸漏烦恼，不发世间生死漏业，虽离凡夫世俗之地，犹有法执见，有五蕴生灭之法执，有世间三界之苦，深厌生死，乐求涅槃，不乐住世，救拔群品，故是(注6)声闻缘觉之行。
    若初发心修行菩萨，自信已身有真如法，知心妄动，无前境界，修无相法，离一切相，都无所得，了人法空：了人空故不著三界能离凡夫世俗之地；了法空故不乐涅槃，不向(同)声闻缘觉之行；了人法空能离凡夫二乘之行，名菩萨行。故维摩经云：
    ‘非凡夫行，贤圣行，是菩萨行’。
    此菩萨行契顺真如，离一切相，一切分别，故离凡夫世俗之地，不向(同)声闻缘觉之行。能为众生说如是法，令离一切烦恼之苦，故修无念，离一切相，即是此中所作法也。(注7)
    第二问云：又不退、入行菩萨内所思意，外身显现法中，内修第一行法，何是外行？第一法是何？
    谨对：所问深远，文意难知，须述两解，以通妙趣。第一释云：夫云不退总有三种。一信不退、即十住初，自信已身有真如法性，无动念是本原(注8)心，由有此性，决定成佛，深信解故，分证真如，决定不退大乘正信(注9)，亦不退转趣入二乘，亦能权现化作佛身，八相成道，利众生事，由得定信，成此功能。故此菩萨名信不退。二证不退，即初地位断分别障，正证真如，一念能至百佛世界供养百佛，请转法轮，开导群生，拔济含(注10)识，由证真如离分别故，不起一切烦恼过失(注11)，永不退失真如(注12)无漏心(注13)，故此菩萨名证不退。三行不退，即入八地，常任运住纯无相(注14)心，在法駃(驶)流，任运而转，刹刹那那(注15)万行倍增。外虽起化，不动无相，内虽无动，外化无穷，由不退动无相行故。此位菩萨名行不退。今此文中言不退者，即此三位不退人也。言入行者，行谓行位，即入此三不退位也。此诸菩萨内心所有思惟意乐，为化众生外起作用，是故名为外身显现，即彼所修无相妙行名(注16)为内修第一行法(注17)第二释云(注18)言不退者即不动也，若心无念名。
    第三问云：修身口意、从初至终(注19)、行(修)、行如何？
    谨对：修身口意须戒定慧(注20)、言修戒者复有三种。一摄律仪戒，离身口意所有十恶。二摄善法戒，即身口意所行(注21)十善。三摄众生戒，即行十善利益众生。修行如此三聚净戒，即是初修身口意也。言修定(注22)者，身定，谓即结跏趺坐，不低不昂，不傍不侧。故经偈云：‘见诸(注23)跏趺像，魔王尚惊布，何况入道人，端坐不倾动。’口定谓即言成准的，语行相应，心口皆顺，如说能行，如行能说，楷定正邪，令(注24)物归信。心定谓即远离散乱，常在有相无相三昧，恒不远离心一境性。有相定者，即经所说观佛三昧，观净土等。无相定者，即经所说离一切，一切分别。身口意业能如是定，即是次修三业地也。
    言修慧者， 身慧有二，有相无相二种别故。身谓：眼耳鼻舌身也，身者聚义，聚此五种，总名为身。此五虽无计度随念，而亦得有微细分别，能取色声香味(注25)触境而生恋著。于此五尘有二种慧，若能了知是非好恶，不迷不谬，名为世间有分别慧。若于此五无所分别，虽了了(注26)知而不贪著，是则(注27)名为无分别慧，即修身业所有慧也。
    口业慧者亦有二种，有相无相二种别故，辩(注28)说善恶令(注29)众生知，是名有相口业慧也。虽能计(注30)别得(注31)失差别，而于其中不(注32)著语相，虽终日语而无所语，虽常说法而无所说，是即名为无分别语，是名依慧所修语也。
    言意慧者亦有二种，有相无相二种别故。若意了知一切诸法善恶得(注33)失，因果差别，舍恶从善名有相慧。能于此中都无所得，于一切法无所取舍，心念不生，名无相慧。若身口意依如是慧而修行者，是究竟修身口意也。
    第四问云：又今处于五浊恶世，自既(注34)无缚，彼亦无解，义如何者？
    谨对：浊者滓秽不清净义，众生所以处浊劫者，由自身命不清净故。众生及命皆浑浊者，由烦恼浊。有烦恼者，由其见浊，妄见尘沙，遍处生执不清净故，名之为浊。众生本性即是真如，常乐我净具恒沙德，自背(注35)本源，妄生诸见，起烦恼业受苦无穷。真乐本有(注36)失而不知，妄苦本空，得而不觉。如是一切皆从见生。见浊不生，诸浊皆净(注37)。若离妄念，照达心源，净相尚无，浊相宁有，离净浊相，不见身心，无挂无碍，谁缚谁解，了无解缚，乃能离缚，但自无缚，彼亦能解。如斯妙义，著在群经，伏愿披(注38)寻，昭(注39)然自见。
    第五问云：佛有有余无余涅槃，此二涅槃(注40)为别实有，为复假说？
    谨对：言涅槃者是圆寂义。圆谓圆满，具众德(注41)故。寂谓寂静(注42)异苦障故。涅槃不同，诸教异说，就要而言，不过四种：一者自性清净涅槃，谓一切众生(注43)，本真如理，虽有容染而本性净，具无边德，湛若虚空，一切有情平等共有，其性本寂，故名涅槃。
    二有余依涅槃，谓即真如出烦恼障。此有二种：若二乘人至无学位，依(注44)此生死苦身之上，断烦恼障，显真如性，心德寂静，名为涅槃。而此苦身尚未弃舍，苦未寂静，名(注45)有余依。言余依者即苦身也。若佛世尊烦恼虽尽，身心寂静名得(注46)涅槃，有余无漏，常乐我净，功德身在，依此身上所得涅槃，是故名为有余依涅槃。
    三无余依涅槃，谓即真如出生死苦。此有二种：若二乘人至无学位，一切烦恼，先已(注47)断尽，今复更厌此苦依身，以灭尽定灭其心知(注48)，又自化火焚分段身，无苦依身，诸苦永寂，是故名曰无余依涅槃。若佛世尊无漏功德所依身上，一切烦恼，生死苦恼悉已(注49)寂静，永无苦恼余所依故，是故名曰无余依涅槃。
    四无住处涅槃，谓即真如出所知障，大悲大智常所辅翼。由斯不住生死涅槃，利乐有情，穷未来际，用而常寂，故曰涅槃。若诸菩萨至第五地能断下乘般涅槃障，能证真如无住真理，外为分得无住涅槃。若佛世尊一切障尽摩诃般若解脱法身三事圆满，名大涅槃。
    四涅槃中一切众生皆有初一，二乘无学容有前三，唯我世尊可言具四。既四涅槃皆依真立，就其出障，立四(注50)不同，据其真如，体无差别，故佛身上有余无余，但约(注51)义存，实无有二。
    第六问云：佛有三身，其法身者周(周)遍法界，化身各各在一切佛，而其(注52)应身有一有异？
    谨对：然其佛身诸教异说，或开或合，义理多门。今者先明佛身之相，次则显其开合之门，然后答其所问之义。统论诸(注53)教有五佛身。第一身者是诸如来真净法界，具无数量真(注54)常功德，无生无灭，湛若虚空，一切如来平等共有。此有二名：一名法身，是报化身，诸功德法所依止故。二名自性身真如，乃是诸法自性，是报化身，实自性故。第二身者是诸如来三无数劫所集无边真实无漏自利功德，感得如是净妙色身，诸根相好，一一无边，相续湛然，尽未来际。此有三名：一名法身，诸功德法所集成故，二名报身，以果酬因受乐报故。三名自受用，唯自受用妙法乐故。第三身者，谓诸如来三无数劫所集无边利他功德，随住十地菩萨所宣所显渐胜相好之身。此有五名：一名他受用(注55)，令他受用妙(注56)法乐故。二名报身，酬报菩萨见佛因故。三名应身，应诸菩萨净心现故。四名化身，前后改转如变化故。五名法身，诸功德法所庄严故。第四身者是诸如来大慈悲故为未登地诸菩萨众，二乘凡夫所现微妙(注57)鹿功德身(注58)。此有三名：一名化身，以非真身如化现故。二名应身，但应凡小心所现故。三名法身，亦功德法所集聚故。第五身者是诸如来为化六道外道等类诸众生故所现种种异类身相。此有二名：一名化身，但是暂时变化现故。二名应身，暂应六道众生现故。非法身(注59)者，非功德法集成相故。
    明佛身(注60)已显开合者，或有圣教开为五身，依广义门具(注61)分别故；或有圣教开为四身，即五身中前之四身，不说第五，第四摄故，暂时化现，非久住故；或有圣教合为三身，谓法，报，化。此有三义：或合五中前之二身名为法身，其第一身是真如理，其第二身是真实(注62)智，理智无别合为一故。金光明经说法如如及如如(注63)智，名法身故。其报身者即是五中第三佛身，报诸菩萨功德因故。其化身者即五身(注64)中第四化身，谓化(注65)地前凡小现故。第二义者，或初法身(注66) 即前五中第一佛身是诸功德法之体故。言报身者，合前五中第二第三，有经论中皆名受用，为自为他受乐报故。化身即是五中第四，义如前说，此依大乘经论说也。
    小乘经论说(注67)法，报，化三身之义与此不同。言法身者即是如来无漏戒蕴，定蕴，慧蕴，解脱蕴，解脱智见蕴，此五是其功德之法，是诸圣贤所依体，故名为法身。言报身者即是王宫父母所生三十二相，八十种好，酬报过去因之(注68)果故。言化身者即是如来所现神通化相身(注69)是。此有二种：一者共有，即同二乘所有化现(注70)十八变等；二不共有，即如经说如来所现大神变身。或有圣教合为二身，一者法身，即合五中前之二身，二者化身，即合五中后之三身，义如前说。或有圣教合为一身，即是五中前之四身皆功德法，总名为法。自体依止聚集义故，总名为身。
    显开合竟答所问者。所言法身周遍法界，此依五中前二身说真如妙理，及能证智，理智(注71)平等皆遍周(注72)故。化身各各在一切佛，即是五中第四佛身，随彼佛所现别故。应身为一为异义者，此言(注73)应身即当五中第三佛身。此佛应身随应十地菩萨所现。初地菩萨所现佛身坐于(注74)百叶莲花台上，一叶(注75)有一大千世界，其佛身量称彼莲花，二地所见坐(注76)千叶莲花，三地所见坐万叶莲花，乃至十地如(注77)是转增。初地见小，二地见大，同处同时不相障碍。不可言一，不可言异。不可言一者，十地所见各不同故；不可言(注78)异者，所见之佛无别处故。菩萨所见，一异若斯，诸佛应身，一异亦尔，一微尘中有无量佛(注79)，一刹那中含三世劫，一佛住处有一切佛，一切(注80)佛国有一切佛，一即一切，一切即一，同处同时，不相障碍，以诸色法无实体故，真如理智无限碍故。如众翳者，同于一处所见差别，不相障碍。如众灯光，各遍似一。由是义故，非但诸佛所现应身非一非异，乃至报化身亦尔。
    第七问云：佛有一切智，因从(注81)修行六波罗蜜，但本性清净湛然不动，是一切智，此二种如何？
    谨对：佛一切智有因有缘，因缘具足乃得成就，本性清净，湛然不动，是一切智者，据有因说也。因从(注82)修行(注83)六波罗蜜成一切智者，就具缘说也。因缘具足，一切智成，随阙一种则不成就。此中随阙因缘义者，虽有内因，若不修行十波罗蜜无由能成佛一切智，若虽修行十波罗蜜，而心取相乖背本因，亦不能成佛一切智，故起信论云：如是报身功德之相，因波罗蜜无漏行薰，及(注84)由真如不思议薰(注85)。内外二薰(注86)之所成就一切智用在于报身，报身尚然，智何不尔。
    第八问云：众生若行诸菩萨行，发菩提心，如何发行？
    谨对：夫欲修行诸(注87)菩萨行者，先须发起大菩提心，然此发心有其二种：一令初根发有相心，二令久(注88)机发无相心，所言有相菩提心者，复有三种：一、厌离有(注89)为心，为说世间生死苦恼，令其厌离不乐有为，永断诸恶为出离因。二、欣乐菩提心，为说佛身无量功德，究竟安乐，令其欣乐修行诸善为成佛因。三、悲愍有情心，为说悲愍一切众生自得无量胜妙功德，令生广大救度之心。此三名为大菩提心，由有此心能行万行，故经说(注90)此名加行持，能持六度加胜行故。所言无相菩提心者，菩提名觉，即是真如，此性澄清离一切(注91)相，但离妄念，觉道自成，何假起心外念求取。若发心念，外求菩提，此乃妄心返成流浪，纵修万行，岂成菩提。今(注92)者但能一切不发，是名真实发菩提心。所言菩提既即是觉，不被一切烦恼破坏，即是诸法(注93)真实之(注94)心。所言发者，即是显发，但能不起一切妄情，菩提真心，自然显发，是名真实发菩提心；虽名发心而无所发，由无所发，无所不发，乃是广发大菩提心，非但名(注95)为发菩提心，亦名真行菩萨妙行，如前三种发菩提(注96)心，若无后说真实发心，纵多劫修行(注97)终滞生死。如斯解释深契佛心，亦顺大乘无相妙理。
    第九问云：十地菩萨，几地有相(注98)？几(地)无想？有想无想，何者是行？
    谨对：夫想与相(注99)心境不同，想谓心想，相谓境相，心境互依，不可离别。今所问者，约心想言，经论所明，就境相(注100)说，故摄大乘，唯识等论说：五地前有相观多，无相观少，至第六地有相观少，无相观(注101)多，七地能得纯无相观，虽恒相续，犹(注102)有功用，若至第八不动地中，常任运住纯无相观，有相功用永不现行(注103)故。此八地初一念心所生功德，过前两大阿僧祇劫所行万行功德善根。第二念后(注104)倍倍增胜。以(注105)此故知修无相行百千万亿恒河沙倍胜有相行。然菩萨道(注106)万行皆修，但于所修心无所住，是则(注107)名为无相胜行。不以无相都无所修，只以有相心有碍故，不能遍修一切诸行，是故无相，心无碍故，乃能遍修一切妙行。故经论说八地已上心无碍故，一切行中起一切行法，驶流中任运而转，刹那刹那功德增进，如是皆由得无相行，是故无(注108)相是真实行。
    第十问云：菩萨具修诸解脱门，行法如何？
    谨对：然解脱门有其多种，如华严经善财童子百二十处求善知识，一一皆为说解脱门，事具经文，难(注109)以备载，就本而论(注110)，且(注111)说一种。若入此门，诸门皆具，谓一切法皆不离心，若心离念无所分别，心无挂碍，即心解脱。诸解脱门从兹证得。故经偈云：若分别境相，即堕于魔网，不动不分别，是则为解脱，又经偈云：相缚缚众生，亦由尘(注112)重缚，善双修止(注113)观，方乃(注114)得解脱。
    第十一问云：菩萨法身与佛法身，同不同者？
    谨对：大般若经最胜天会所说法喻正与此同。今者谨依经文而说。最胜天王重白佛言：“如来法身，菩萨法身，如是(注115)二身有何差别？”佛告最胜天王：“当知，身无差别，功德有异，身无别者，同一真如，无别体故。功德异者，由满未满有差别故。菩萨法身功德未满，如来法身功德已满。譬如无价末尼宝珠若未施功莹磨(注116)庄饰，与施功力磨莹(注117)庄严(注118)，如是二相，虽有差别，而其珠体即无差别。当知此中道理亦尔。”同不同义，如经可知。
    第十二问云：菩萨涅槃及与轮(注119)回并不分别，义如何者？
    谨对：夫见涅槃由执生死，不见生死，何执涅槃，既都无见，于何分别。且(注120)如二乘未离法执，不了诸法皆从念生，执有离心生死苦法，见身心外别有涅槃，执涅槃故，妄起欣求，著生死故，妄生厌离。是故欣厌皆是妄心，其犹(注121)怖梦虎而生嫌(注122)，玩空花而自乐，菩萨了达照见心源，生死本空，亦何(注123)所厌。涅槃无相，于何所欣。了空无相(注124)，心(注125)念不生，轮回涅槃故不分别。
    第十三问云：菩萨所知不著(注126)涅槃，不染世间，依何法者？
    谨对：菩萨了知法从缘起，如幻如化，非久非坚，既知诸法虚妄不真，何被(注127)世间法所染污。此依初教作缘起观，知世如幻，能不染也。若能了达一切唯心，法从心生，心外无法，今所见者，但见自心，离心(注128)之外，都无所见，既无外法，何染世间，此依终教作唯识观，乃能不染世间法也。若了境界唯是自心，外境既无，内(注129)心何见，心既无见，念本不生，一切皆如，何所染污，此依顿教作真如观，则于世法(注130)无能所染，既知世法一切皆如，本来涅槃，何所取著，虽在世间，世法不染，虽得涅槃，而不乐著，即是无住大般涅槃。是故菩萨依此三种所说法门无染著也。
    第十四问云：又大乘法，智慧方便二种双行，众生欲行，如何(注131)起行？菩萨自在则可能行，众生不然，何能行者？
    谨对：此中义理意趣(注132)难知，若不审详，讵申(注133)妙旨。今于此中略述两解：一云大乘之法有俗有真，俗则诸法若有若空，真谓都无空之与有。为照空有，智慧要存，为泯有空，方便须立。照空有故俗智得生，泯空有故真智成就。若唯照俗未免轮回，若但观真，不起悲济。照俗之行由智慧成，证真之功(注134)，由方便得，智慧方便故要双行，若阙一门不达二谛。二云大乘之法悲智双行，自行化他阙一不可，若无自行不异凡夫，如不化他乃同小圣，此中智慧即是自行，以实智慧，证(注135)真如故。言方便者即是化他，以权方便化众生故。鸟具二翼，乃得翔空，车有两轮，方能载陆，既(注136)知智慧方便二门，凡夫欲行，但依此理不能依学(注137)，即是凡夫，若能修行是称菩萨。凡夫不学(注138)是系缚人，菩萨(注139)能行，成自在者。要(注140)先修学(注141)成自在人，非先自在，然后修学(注142)，故凡夫者亦能修行。
    第十五问云：声闻，缘觉，菩萨三乘于六尘境各如何见？
    谨对：三乘所见理合不同，然其二乘多分相似，故有圣教合名下乘，故(注143)见六尘不分(注144)差别，而与菩萨显不同者。佛法理门总有四种，因缘，唯识，无相，真如。二乘之人唯了初一，知一切法皆从缘(注145)生，六尘境界皆是实有，见染(注146)见净，有爱有憎；不了第二唯识门故，未达诸法皆从心生，执六尘境心外实有；不达第三无相门故，不识(注147)诸法本性皆空，遂执六尘实有自性；不悟(注148)第四真如门故，不信(注149)诸法平等皆如，遂执六尘一一差别。菩萨具解四种理门，悟六尘境假从缘起，缘无自性，一切皆空，心生则(注150)生，心灭则(注151)灭，若心(注152)离妄，平等皆如，无是无非，无取无舍，宛然而有，宛然而空，此是菩萨所见相也。声闻缘觉执相未亡，故与菩萨所见全(注153)别。
    第十六问云：菩萨，(注154)缘觉，声闻三乘初发心相，行法如何？
    谨对：夫发心者皆由因缘(注155)，因谓众生出世本性，此性(注156)即是诸法真如，由有此性当得出离，然为无明所覆障故，轮转三界，沉溺死(注157)生，受苦无穷，不能出者，皆由不闻三乘正法。此三乘正法法界所流，故能薰(注158)发真如本性，令其发(注159)起三乘之心。此义云何？谓佛世尊证真如性，此性即是出世正因。如其所证为众生说，击发本性故能发心。故发心因是真如性。发心缘者，由闻三乘。闻大乘法发大心者即名菩萨；闻缘觉(注160)法发缘觉心，名为缘觉；闻声闻法发声闻心，即名声闻。今此菩萨发心相者，谓闻大乘所说正法，说有为法过患极多，世间诸法皆可(注161)破坏，诸佛功德最胜无边，二乘极果非是究竟，四生五趣同一真如，一切众生(注162)曾为父母，流浪生死，受苦无穷。发心救度，功德无量。行菩萨行，能利自他，勇猛修行，速成佛果，由闻正法，能起信心，深厌世间有为过患，于佛功德深起愿求，于诸众生普欲救度，因此能发大菩提心，勇猛修行菩萨妙行(注163)，此是菩萨发心相也。
    缘觉乘人发心相者，此由宿世善根所成，于证果时出无佛世，故发心相微隐难知，谓于过去种善根(注164)时，遇缘便修，不念果报，所(注165)闻正法便起信心，亦不思惟胜劣得(注166)失。但乐早得出离涅槃，不乐世间生死果报，由此成就解脱善根，善得人身生无佛世，宿世所种善根力强，暂遇(注167)外缘，成缘觉果，及得果已，不乐度人，当厌喧烦，乐独善寂，故有经中名为独觉，此是缘觉发心之相。
    声闻乘人发心相者(注168)，谓曾闻说四谛法门，知苦断寂，证灭修道，知此苦(注169)身困烦恼集，若欲出苦要断集因，若永(注170)断集，证涅槃乐，修八圣道以为正因。闻此法已，深起愿求，便能修行戒定(注171)智慧，解脱分善从此得成，因此善根生于佛世遇佛闻法便得涅槃，此即声闻发心相。
    第十七问云：又此三种皆入涅槃，声闻，缘觉，菩萨涅槃，各如何者？
    谨对：经说三乘皆同涅槃，然其涅槃应有差别。声闻缘觉胜劣虽殊，而彼所证同我空理，故二乘者涅槃不殊。今以二乘同一位说，谓二乘人于此身上所得涅槃名有余依，烦恼虽尽，苦身在故，饥渴寒热，众苦极多，深厌此身，欲求弃舍，以灭尽定灭其心智，又自(注172)化，火焚灭此身，身心都无，如灯炎灭，众苦俱寂名无余依，如太虚空寂无一物。此是二乘所涅得槃，二乘之人作如是见。
    菩萨所得涅槃义者，于此义中有其二说：一依唯识渐教说者，地前菩萨未得涅槃，一切苦障皆未断故，地上虽得百法明门，能证二空真如妙理，为化众生起烦恼故，不得名曰有余涅槃；未舍生死有微苦故，不得名曰无余涅槃，犹(注173)有下乘般涅槃障，由是未得无住涅槃，要至第(注174)五地方断此障，故至五地方能证得无住涅槃，此是菩萨涅槃相也。二乘所得是有无余，菩萨所得是无住处，故与二乘涅槃别也。此依渐教作此分别。若依顿教分别说者，菩萨能了一切皆空，一切万法从心起，心(注175)若不动一切皆如，能除分别执著心故，了真实相不起妄心，即是清净涅槃妙理，虽得此理，都无所得，由无所得，无所不得，无所得故，离诸苦障，是无余依。无不得故功德成就，是有余依。生死涅槃俱(注176)无所住，是无住处，由无所得，自性无染，是名自性清净涅槃。此是顿教涅槃相也。是谓三乘涅槃差别。
    第十八问云：大乘经中有说三乘是方便说，或说究竟，或说二乘皆得成佛，或说二乘不得成佛，义如何者？
    谨对：佛法教旨(注177)深广无边，随所化宜，隐显异说，显即究竟真实理门，隐即方便随转理门。随转理门是不了义，随小乘宗义可转故。真实理门是真了义，是实大乘圆极理故。由有二种理门别，故经或说有定性(注178)二乘，或经说有不定性(注179)二乘，或得成佛，或(注180)不成佛，总说(注181)虽然，别(注182)分别者。略明种性(注183)有其二门。一就种子别立五乘，二就真如唯立一性(注184)。初约种子立五性(注185)者，无尽意等诸经所说，一切众生有五种性(注186)：一无种性(注187) 谓无三乘出世(注188)种子，由此毕竟常处凡夫。二声闻性(注189)，谓即本有声闻种子，由此定成声闻菩提。三缘觉性(注190)谓即(注191)本有缘觉种子，由此定成缘觉菩提。四佛种性(注192)，谓即本有成(注193)佛种子，由此定成(注194)无上菩提。五不定性，谓具三乘无漏种子，由此渐得三乘菩提。此五(注195)种子非是新生，从本已来，法尔而有。诸经论中言佛性者，即是第四成佛正因，由有此性当成佛故，故此种子名为佛性，不以真如名为佛性，若以真如为佛性者，草木瓦石皆有真如，则草木等皆应成佛。经说众生得成佛者，唯约有此佛种性(注196)人说(注197)，而说一切皆成佛者，即是一切有佛种者，非前三类皆得成佛。经说二乘不成佛者。说第二三决定(注198)性人，定入涅槃不成佛故。有说二乘得成佛者，唯约第五不定性人(注199)，回心向大乃成佛故。经说阐提不出世者，但约第一无种性(注200)人，无三乘因永沈(注201)溺故。众生既有如是五性(注202)，故佛为说五乘法门，为第一人说人天法，五戒十善生人天故。为第二人说四谛法，令(注203)观染净成阿罗汉故(注204)。为第三人说十二因缘(注205)，令观因缘成缘觉故。为第四人说波罗蜜，令修万行得成佛(注206)故。为第五人具说三乘，令渐修行成佛果故。即有如是定性(注207)三乘，故三乘法是其实理，而有经中说一乘者，但为引(注208)摄不定性(注209)人，令舍二乘向佛果故，就权方便假说一乘。定性二乘若成佛者，则一乘法应是真实，何故深密(注210)及诸经中说一乘法是不了义。
    复约真如立一性者，即涅槃等诸经皆说一切众生皆有佛性，此性(注211)即是诸法真如，一切众生平等共有，由有此性皆得成佛，故说众生皆唯一性。即诸众生皆当得佛，即一切行皆顺真如，是故唯立一乘正法：而经有(注212)说五乘性者，但由无明厚薄不同，出世(注213)因缘有小有大，故有五乘种性(注214)差别。无明厚者未起信心，是阿阐提名无种性(注215)。无明薄者发出世心，随闻(注216)三乘成三乘性(注217)，故有三乘决定性人。若于三乘俱可爱乐，是故名为不定性(注218)人。此五种性(注219)即近熏成，近可令其得利乐故，故佛随性(注220)为说三乘。为无性(注221)人说人天法，为三乘人说三乘法。然其三乘有隐有显，初为引(注222)摄小乘性(注223)人，令其证得小乘果故，是故隐覆为说小乘，不言所说是小乘法，不道别有无上大乘，佛说自身是阿罗汉，我与汝等同在一乘，众生由(注224)是得成圣果，不知别有究竟大乘，执我与佛等无差别。世尊为破如是执著，及为引(注225)摄大乘性(注226)人，令普修大乘法故，更为显说三乘法门，乃说三乘是其实理。言一乘者是权教门，解深密(注227)经依此而说。此说粗浅近缘门说，有此五性三乘法门。若就真如微细正因，一切众生皆有佛性，是故究竟唯有一乘，一切二乘皆得成佛，决定实无定性二乘，十方佛土中(注228)唯有(注229)一乘法。故知实理唯一佛乘，法花(华)经等依此而说。而深密(注230)经言一乘法不了义者，一乘有二：一者方便，即前所说合三为一，权说一乘。二者真实，即法花(华)说会三归一，实说一乘。深密(注231)所言一乘之法不了义者，说前一乘，非说法花(华)后教一乘，在深密(注232)后说法花(华)故。即知众生皆有佛性，一切皆得成佛菩提，故无一分无“定”性众生，尽未来际不出离者，亦无一类定性二乘(注233)定入涅槃不回心者，如此说者是小乘教。设有大乘作此说者，当知皆是随转理门，非是大乘究竟实理。
    第十九问云：经说声闻所得涅槃与佛无异，后智三身一切并减，犹如灯焰灭即无余，此是定说，是不定说？
    谨对：声闻涅槃与佛全别，言无异者是小乘宗。佛为化彼下性众生，令其证得阿罗汉果，说身极苦令起厌心，但有身(注235)者皆是苦恼，故得涅槃一切皆灭，由此永寂，安乐无为，而我修行成(注236)此灭度。我所得者，汝亦得之，故说三乘同一解脱，说佛与彼同一涅槃，后智三身一切皆灭，如灯焰灭余烬亦无。依小乘宗而作此说，据其实理，或即不然。
    言涅槃者是圆寂义，圆谓圆满，三德具足，寂谓寂静，众苦皆无。三身若无说谁(注237)圆寂，四智既灭，谁证涅槃，故佛涅槃非是永灭，万德具足，众善斯圆，据此涅槃唯佛独有(注238)。故声闻等未得涅槃。方便门中说声闻得涅槃不同有其(注239)二种：一者方便，二者真实。方便涅槃又有二种：一者外道，二者声闻，外道即以生无想天，生无色界，离欲界苦，假说涅槃。声闻即以断粗烦恼入灭尽定，粗动息灭名曰涅槃，亦与外道涅槃差别。外道灭度不离死(注240)生，声闻涅槃乃出三界，虽与外道灭度不同，亦与大乘涅槃有(注241)异。大乘所得究竟无余，真实无为，常乐我净。声闻所得但名有余，未名无余究竟灭度。有三种余非无余故。言三余者，一烦恼余(注242)，即所知障，二业行余，即无漏业，三界报余，即意生身，总说虽然，别分别者，以诸圣凡有二种障，由此能感二种生死，以烦(注243)恼障从我执起，能发凡夫五趣漏业，能感凡夫分段苦身，以所知障从法执起(注244)，能发圣人净分别业，感得圣人变易苦身。二乘已能断烦恼障，灭有漏业，离三界生，能得有余涅槃乐故，厌此粗苦所依身心，欲入无余寂灭安乐，以灭尽定灭其心智(注245)，又以化火焚烧苦身，谓言一切如灯焰尽。所灭心者灭六识心，岂能灭得阿赖耶识。所焚身者焚分段身，岂能焚得变易身相(注246)。非彼(注247)知见不能除故，分段身心虽然灭已，由所知障不能灭故，复(注248)无漏业(注249)亦不舍故；阿赖耶识(注250)不可断(注251)故。法尔(注252)皆有，变易报续。此变易报名意生身，此身微细余不能见，欲入灭时灭六识故。意生身上六识(注253)不行，如重醉人都无知觉。后灭尽定势力尽故。佛悲愿力所资熏(注254)故，还从定起如醉醒，见意生身在佛净土，始知不是无余涅槃。故楞伽经依此偈云，三昧酒所醉，乃至劫不觉，酒醒(注255)然后(注256)觉，得佛无上身。又智度论依此说云：有妙净土，出过(注257)三界，诸阿罗汉生在其中。既声闻等未(注258)得涅槃，岂更与佛涅槃无异。故前所言二(注259)乘涅槃与佛同者，是不定言(注260)，执见小乘，妄兴此论，达观君子，讵可从之。
    第二十问云：大乘经说一切诸法皆无自性，无生无灭，本来涅槃，既尔 (注261)，如何更须修道，一切自然得涅槃故？
    谨对：佛说法空为除有执，有执除已，空法亦除，若更执空，却成重过。如药治病，病息药亡，既于药病，皆不合留，故于有空，并不可著。故深密(注262)经此依义云：“胜义生菩萨白佛言：‘世尊，世尊初说一切诸法生相灭相，未生令生、生已相续，增长广大。世尊复说一切诸法皆无自性，无生无灭，本来寂静，自性涅槃，未知世尊是何密 (注263)意？’世尊告言：‘我初为彼未种善根，令其(注264) 种故，未灭诸障，令其灭故，未成(注265)资粮，令成熟故，故为宣说生相灭相，未生令生，生已相续。若诸众生已种善根，已灭诸障，已能成熟福智(注266)资粮，然犹(注267)未能除其执著，未能证得安乐涅槃，故我为说一切诸法，皆无自性，无生无灭，本来寂静，自性涅槃。若诸众生已种善根，已灭诸障，已成资粮，是智慧类，非愚痴类，闻我说是无自性法，便能信受善解佛意，如理修行，而离执著，证得究竟安乐涅槃。此无自性，无生灭法，则于彼人成大利益。若诸众生未种善根，未灭诸障，未成资粮，闻我说是一切诸法皆无自性，无生灭法，虽能信受。不能善解所说意故，而定执著，由执著故(注268)起断灭见，执一切法实无性等，于诸善法不肯修行，不种善根，不灭诸障，不能成就(注269)福智资粮，诽谤(注270)一切有自性法，破灭一切功德善根，故无自性甚深妙法，即于彼人成大衰损。’经文极广，旨散文弘。故于今者探意而说。至教照著，自可依凭，如或广明，恐成繁重。
    第二十一问云：其含藏识与大智慧虽有清浊，是一是异，义如何者？
    谨对：含藏识者(注271)是阿赖耶，大智慧者即如来藏，有大智慧光明性故。清浊虽异，性相难分，由此言之，非一非异。故密严经依此偈云：‘如来清净藏，世间阿赖耶，如金与指环，展转无差别。’金与指环喻如来藏与阿赖耶非一异义。非一异者如楞伽经(注272)云：‘泥团微尘非一非异(注273)，金庄严具亦复如是。’谓金全体以成指环(注274)，故金与环不可一异。若金与环是一者，环相灭时金体应灭，环相若灭，金体不亡，故金与环不可言一。金与环相若是异者，岂难金外，环相得成，非可离环别求金体，金与环相非一异成，藏识与智，当知亦尔。如来藏者即是真心，阿赖耶者乃是妄识，真心清净即是本源，妄识生灭乃成流浪，总说虽然，别分别者，谓如来藏本源真心，性虽清净，常住无为，而亦不守本静性(注275)，故受无明熏，动成妄识，随流生死而作众生。虽成众生，不失本性，故离妄识，还归本源。若如来藏守常住性，不作众生有常边过。若如来藏成众生时，失其本性有断边过。既如来藏非断非常，故与妄识非一非异。若定一者，妄识灭时真心应灭，即堕(注276)断边；若定异者，妄识动时，真心不动，即堕常边。此二边故非一非(注277)异。所问之目(注278)依法性宗，所对之门依顿教立，与唯识等义稍不同，守旨有殊，伏惟昭鉴。
    第二十二问云：佛在世时众僧共行一法，乃佛灭后分为四部，不同于四部中何是一法？
    谨对：佛在世时大师导世，真风广扇(注279)，法雨遐(注280)沾，共禀慈尊，别无师范。大士怀(注281)道，不二法门，小乘遵途，混一知见，并无异辙，咸禀通达(注282)。及至觉归真，邪魔孔炽，群生失御(注283)正教(注284)陵夷，遂使一味之法，分成诸见之宗，三藏微言湮灭，群迷之口竞申别趣，各擅(注285)师资，互起憎嫌，更相党援(注286)，始分部执，盛开二十之名，终久流行，但闻四五(注287)之说所言四者。即是西域各有三藏，盛行四宗：一上座部，二说有部，三大众部，四正量部。言五部者，即是东方，但就律宗说(注288)有五部：一者萨婆多，即十诵律，汉地似行。二昙无德，即四分律，汉地盛行。三弥沙塞，即五分律，汉地少行。四摩诃僧祇，即僧祇律，汉地不用。五迦摄毗耶律，(注289)空传律名(注290)但有戒本。东方五部从西域来，西域四部咸传本有，皆称佛说，并号圣言。今者须明有之始末。部执初兴即二十别，乃传永久唯四五存，先明二十名之所因，后配四五教之同异。
    言二十部者，文殊经云：‘十八及本二，皆从大众出，无是亦无非，我说未来起。’所言本二有其两重：佛涅槃后十有二年，大迦摄波思集法藏，击(攀？)(注291)妙高山普告之曰：‘诸圣者等勿入涅槃，集王舍城当有法事。’是时四(注292)洲圣众咸集，未生怨王盛兴供养。过七日已，大迦摄波恐人众多难成法事，简取五百无学圣僧，精持三藏具多闻者，于七叶窟而坐(注293)安居。雨前三月集成三藏：一素怛罗，二毗奈耶，三阿毗达摩。余众亦有通三藏人，既被简退，共悲叹曰：‘如来在日，同一师学(注294)，法王寂灭，简异我曹，欲报佛恩，宜集法藏。.’于其窟外空闲林中，坐雨安居，集成五藏----前三，更加咒藏，杂藏。初以迦摄僧中上座(注295)名上座(注296)部，后以凡圣大众同居名大众部，此即是其第一重本。
    既结集已于二法藏随乐受持，不相非斥(注297)。
    至佛灭后百有余年，去圣时淹(注298)，如日久没，摩(注299)羯陀国俱苏摩城王号无忧，统摄瞻部，感一白盖，化洽(注300)人神。是时佛法大众初(注301)破，谓因四众，共议大天，五事不同，分成两部。言四众者，一龙象众，二边部众，三多闻众，四大(注302)德众。言大天者，未兔罗国有一商人婚娶幼妻，生一儿(注303)子，颜貌端正，字曰大天，商人货(注304)迁，久滞他国，子既年壮(注305)母逼行烝(注306)，后闻父还，心怀怖惧，与母设计，遂鸩杀之。恐事渐张，共窜他国，逃难展转至波吒厘。彼城遇逢门师罗汉，恐泄家事，矫请(注307)杀之。母后他非，其子遇见，悔恨交集，遂又杀之。虽造三逆，不断(注308)善根，忧悔罪深，何缘当灭。传闻沙门有灭罪法，遂至鸡园伽蓝门外，见一芯刍诵伽他曰：‘若人造重罪，修善能灭除，彼能照世间，如日出云翳。’大天闻偈踊跃知(注309)归，故请出家，有僧遂度。性识聪敏，三藏遽通，词论既清，善于化导。波吒厘有无不归仰，既耽名利，恶见乃生，矫言“我得阿罗汉果”。五恶见事从此而生。既称得圣，人惑圣凡，育王频请说法供养，见诸宫女，不正思维，于(注310)梦寐中漏失不净。浣衣弟子怪而问言(注311)‘岂阿罗汉有斯漏失？’大天矫答‘魔娆使然，以漏失因有其二种：烦恼漏失，罗汉即无，不净漏失，无学未免，罗汉岂无便痢涕唾。然诸天魔常嫉(注312)佛法，见行善者便往坏之，纵阿罗汉亦被娆乱，故我漏失，是彼所为，汝今不应有所疑怪。’
    又彼大天欲令弟子益生观喜，亲附情殷(注313)，次第矫受四沙门果。弟子怀(注314)疑，咸来白曰：‘阿罗汉等应各证知，如何我等都不自觉？’大天告曰：‘诸阿罗汉亦有无知，勿自不信，谓诸无知亦有二种：一者染污，罗汉即无。二不染污，无学(注315)犹(注316)有，由斯汝辈不能自知。’
    又于一时弟子启白：‘曾闻圣者已度诸疑，如何我等尚疑谛实(注317)？’大天又告：‘诸阿罗汉亦未免疑，疑有二故：随眠性疑罗汉已无，处非处疑，无学(注318)犹有，独觉于此而尚有之，况汝声闻能无疑惑。’后(注319)诸弟子披(注320)读诸经，因白师言：‘经说无学(注321)有圣慧眼，我于解脱应自证知，如何但由师言悟入？’彼即答言：‘有阿罗汉，但由他入，不能自知，如舍利子智慧第一，佛若不记，犹不自(注322)知，况汝等辈非由他入。是故汝等不应自轻。’
    然彼大天虽造众罪，不起邪见，不断善根，后于夜中自怀罪重，当于何处受诸极苦，忧惶所逼，数唱苦哉。近住弟子惊怪来闻，披便告言：‘我呼圣道，谓有圣道若不至诚，称苦命唤终不现前，故我昨(注333)夜唱“苦哉”矣。’
    大天于后集先所说五恶见事而作颂曰：
    余所诱无知 犹豫他令(注324)入 道由声故起 是名真佛教
    十五日夜布洒陀时次当大天升座诵戒，彼便自诵所造(注325)伽他。尔时众中有学(注326)无学(注327)多闻持戒修静虑者，闻彼所说无惊呵：‘咄哉(注328)！愚人宁作是说，此于三藏曾所未闻！’咸即翻彼所说颂云：
    余所诱无知 犹豫他令入 道因声故起 汝言非佛教
    于是竟斗(注329)诤纷然，乃至崇朝朋党转盛，城中仕庶乃至大臣，相次来和(注330)，皆不止息。王闻见已，亦复生疑，遂乃令僧两朋别住，贤圣朋内耆年虽多而僧数少，大天朋内耆年虽少而众数多。王遂从多依大天语，诃伏余众，事毕还宫。时(注331)请圣贤知众乖违，欲往他所。育王闻已，自怒令曰：‘宜载破船，中流坠溺，验其圣凡。’时诸圣众遂运神通，又接(注332)同志诸凡夫众，变种种形，凌(注333)空而去。王闻悲悔，遣人追寻，王躬固迎(注334)，僧壳(注335)辞命。王遂总舍迦湿弥罗，造僧伽蓝安置圣众。
    于后大天相者见之(注336)，窃记七日定当命尽。弟子闻已，忧惶白师，便矫答言(注337)：‘吾久知矣(注338)。’遣人散告涅槃之期，王庶悲哀，香薪(注339)焚葬。火至便灭(注340)，竟不能燃。占相者云：‘不消厚葬，宜狗粪(注341)汁而洒秽之’便依其言，火遂炎发，焚荡倏尽，飘散无遗(注342)。由是乘诤，僧成两部。大天朋党取结集时，大众为名，名大众部，诸贤圣众取结集时，上座(注343)为名，名上座(注344)部。此即本部第二重分，是十八部之根本也。
    大众部中既无贤圣，二百年初因有乖诤，前后四破流出八部。初第一破(注345)流出三部：一者说世出世法皆是假，既唯说假，名一说部。二者世法颠倒则不名实，说出世法实，名说出世部。三者上古有仙染鸡生子，部主姓氏名鸡胤部。第二破者又因乖诤流出一部。此师学广，玄悟佛经，胜过本部，名多闻部。第三破者，又有一师说世出世亦有少假，不同一说及说出世，名说假部。第四破者，二百年满有一外道，舍邪归正，亦名大天，重详五事，分出三部：一者此人所居山似灵庙，即位本处名制多山部。二者又有一类与此乖违，住(注346)制多山西，名西山住部。三者又有一类，乖前二见，住制多山北，名北山住部。故大众部四破别分，本末别说有其九部。
    其上座部贤圣住持，经尔所时一味和合，三百年初，四百年末，本末七破为十一部：第一破者有一大德造发智论，令后进者研究深(注347)宗，其诸上(注348)座先唯习定，既遭诘难，自耻无智，避诸(注349)论者，移居雪山，转立别名，名雪转部。其学论者说一切法皆有实体性，名说一切有部，又说有为因，亦名说因部。第二破者于有部中流出一部。上古有仙染牛生子，是部(主)(注350)姓(注351)，名犊子部。第三破者从犊子部流出四部：一谓部主有法可上，法在人上，名法上部。二显部主性(注352)贤且(注353)善，贤圣苗裔，名贤胄部。三显部主善立法义，刊定无邪，其量必正，名正(注354)量部。四谓部主所居近山，林木蓊郁，繁而且密，名密林山部。第四破者复从有部流出一部，谓此部主身虽出家，本是国王，名化地部。第五破者从化地部流出一部。部主业弘(注355)，含容正法如藏之密，名法藏部。第六破者，三百年末复从有部流出(注356)一部。部主上代有仙，身真金色，饮弊(注357)余光，名饮光部。第七破者，四百年末复从有部流出一部。自称我以庆喜为师，依经立量，名经量部。说有种子能从前世转至后世，名说转部。如是上座(注358)本末重破，兼本共成十一部计，通前九部，为二十焉：一大众部，二一说部，三说出世部，四鸡胤部，五说假部，六多闻部，七制多山部，八西山住部，九北(注359)山住部，十上座(注360)部，十一说一切有部，十二犊子部，十三法上部，十四贤胄部，十五正量部，十六密林山部，十七化地部，十八法藏部，十九饮光部，二十经量部，已明二十部因由竟。
    以四五部相配属者，汉地所明(注361)五部名中萨婆多者，即四部中说一切有，当二十中第十一部。昙无德者唐言法藏，四部中无，即二十中第十八部。弥沙塞者，唐言化地部，四部中无，是二十中第十七部。摩诃僧祇四中大众，即二十中第一部也。迦摄毗耶，唐言饮光，即二十中第十九部，其四部中初一上座(注362)，五部中无，即二十中是第十部。四中正量，五部中无，是二十中第十五部。如是东西共行六部：一上座(注363)部，二说有部，三大众部，四正量部，五化地部，六法藏部。余十四部两处不行。其化地部本出印度，印度已灭，于阗盛行。其法藏部本出西方，西方(注364)不行，东夏广阐。化地，有部，汉地似行，上座(注365)，正量，印度盛行，余方不见。
    初分部时二十具足，去圣渐远，法教沦潜(注366)，住持人无，部计即灭，住持人在，部计乃存。不以诸部有是有非，而其部执有存有没；不以法有(注367)用不用，而于诸部论正论邪。如析(注368)皆此俱金，但依修持皆得四果。如有毁谤并堕三涂，情见不乖，皆是一法。知见宜(窄)者(注369)即相是相非，识解宽者乃无彼无此。迷情执见则憎(注370)毁过生，若达士通情，岂有嫌(注371)谤正法。以斯解释用荡(注372)群疑，愿审参(注373)详，无迷一法。
    大乘二十二问本(注374)


大乘二十二问

大乘二十二问

昙旷 撰；巴宙（美国爱渥华大学宗教学院教授） 辑校
中华佛学学报第三期

    注解

    (注1) 本卷现存三个写本，其编号及次序如下：
    原卷：斯二六七四标题为“大乘二十二问本”，开端残缺，约缺漏一百五十字，但其他部份甚完整，今以此为底本。大正藏卷八十五古逸部，一一八四至一一九二页收录此卷，但讹误与遗漏甚多，其编号为二八一八。
    甲卷：伯二六九○，首全，用补原卷开端残缺部份。缺尾，只有十九问。其标题为“二十二问”，无“大乘”二字
    乙卷：伯二二八七，开端残缺，其第一问及第二问太破损，零碎不可辨识，尾全。凡原卷及其他二卷有错误及讹字未曾改正者，其被认为适当之字是列于括弧( )之内；其已经改正者则有小注号码于其侧，表示有所解释，请参看之。
    (注2) 上山大峻在其“昙旷上敦煌①佛教”一文中以“宸问”代替“深问”。若用其“至教幽深”之意，则“深问”未可厚非。参看东方学报第三十五卷，一五一页。
    (注3) 陈荣捷教授认为此处缺漏二字，笔者同意此建议。所有去之字或许为“恩宠”一类的字。
    (注4) “刀”字不可解释，此亦为陈先生的提议，此应为“力”之误。
    (注5) 甲方作“可治可坏”。若以世界之“成住坏空”而论，则“治”应作“住”。
    (注6) 原卷作“是故”。
    (注7) 原卷作“即此是”。并缺漏“此中所作法也”六字，今从甲卷。
    (注8) 原卷作“本源”，今从甲卷。
    (注9) 原卷多“心”字。
    (注10) 原卷作“云识”。
    (注11) 原卷缺“过失”二字。
    (注12) 原卷缺“如”字。
    (注13) 原卷缺“心”字。
    (注14) 原卷作“无性”。
    (注15) 原卷缺漏“刹刹那那”。
    (注16) 原卷作“多”。
    (注17) 原卷作“法行”。
    (注18) 原卷缺“云”字。
    (注19) 原卷及甲卷均作“修”，乙卷作“终”，今从乙卷。其“行行”或为“修行”之误。
    (注20) 原卷及乙两甲卷均作“惠”，应作“慧”。
    (注21) 原卷多一“修”字。
    (注22) 原卷缺“定”字。
    (注23) 原卷及乙卷作“见尽结跏……”，甲卷作“见尽跏……”此处之“尽”字，或为“诸”字之衍？
    (注24) 原卷缺“命”，今从甲乙丙卷。
    (注25) 原卷缺“香”字。
    (注26) 甲乙两卷作“了了知”，原卷作“声闻知”。
    (注27) 原卷作“是即”，今从甲乙两卷。 105页
    (注28) 原卷作“辩”，今从甲乙两卷。
    (注29) 原卷作“命”，今从甲乙两卷。
    (注30) 原卷作“说”，甲乙两卷作“记”，应为“计”之误。
    (注31) 各卷均作“德”，应为“得”之误。
    (注32) 原卷作“尔”，今从甲乙两卷。
    (注33) 乙卷作“德失”，今从有原卷及甲卷。
    (注34) 原卷作“说”，今从甲乙两卷。
    (注35) 原卷作“皆”，今从甲乙两卷。
    (注36) 原卷作“消”，今从甲乙两卷。
    (注37) 原卷及乙卷作“静”，今从甲卷。
    (注38) 原卷作“彼”，今从甲乙两卷。
    (注39) 原卷及甲卷作“照”，今从乙卷。
    (注40) 原卷缺漏“此二涅槃”四字，今据甲乙两卷添入。
    (注41) 原卷及甲卷作“得”，今从乙卷。
    (注42) 原卷及乙卷作“净”，今从甲卷。
    (注43) 甲卷作“众生”，原卷及乙卷作“法”，今从甲卷。
    (注44) 原卷缺“依”字，今从甲乙两卷。
    (注45) 原卷多“为”字，今从甲乙两卷。
    (注46) 原卷作“名为”，今从甲乙两卷；甲卷以“册册”代替“涅槃”。
    (注47) 原卷及甲卷作“以”，今从乙卷。
    (注48) 原卷及乙卷作“心智”，今从甲卷。
    (注49) 参看四七。
    (注50) 原卷缺漏“出障，立四”四字，今从甲乙两卷。
    (注51) 原卷作“幻”，今从甲乙两卷。
    (注52) 原卷缺“其”字。
    (注53) 甲卷作“之教”，原卷及乙卷作“诸教”今从后二者。
    (注54) 原卷作“其”，今从甲乙两卷。
    (注55) 甲卷缺漏“令他受用”四字；原卷作“命他受用”，“令”字系从乙卷。
    (注56) 原卷作“好”，今从甲乙两卷。
    (注57) 原卷作“少”，应为“妙”字之误。
    (注58) 原卷多“故”字，据甲乙两卷删去。
    (注59) 原卷缺“身”字，今从甲乙两卷。
    (注60) 同上。
    (注61) 原卷作“是”，今从甲乙两卷。
    (注62) 原卷作“如”，今从甲乙两卷。
    (注63) 原卷缺漏“及如如”二字，今从甲乙两卷。 106页
    (注64) 原卷缺“身”字，今从甲乙两卷。
    (注65) 原卷缺“化”字，今从甲乙两卷。
    (注66) 乙卷无“即”字，但留一空隙。
    (注67) 原卷缺“说”字，今从甲乙两卷。
    (注68) 原卷缺“之”字。
    (注69) 原卷误将“身”作“即”。
    (注70) 原卷作“现化”。
    (注71) 原卷及乙卷缺“理智”二字，今从甲卷。
    (注72) 原卷缺“周”字，今从甲乙两卷。
    (注73) 原卷缺“言”字，今从甲乙两卷。
    (注74) 原卷缺“于”字，今从甲乙两卷。
    (注75) 原卷缺“一叶”两字，今从甲乙两卷。
    (注76) 原卷缺“坐”字，今从甲乙两卷。
    (注77) 甲卷作“而”，今从原卷及乙卷。
    (注78) 参看七三。
    (注79) 原卷缺漏“菩萨所见……有无量佛”第二十四字，今从甲乙两卷，但甲卷缺“尘”字。
    (注80) 原卷缺“佛”字，今从甲乙两卷。
    (注81) 原卷误将“纵”作“从”。
    (注82) 同上。
    (注83) 原卷缺“行”字，今从甲乙两卷。
    (注84) 甲卷误将“及”作“乃”。
    (注85) 乙卷误将“董”作“薰”。
    (注86) 原卷及乙卷作“重”，今从甲卷。
    (注87) 原卷及乙卷缺“诸”字，今从甲卷。
    (注88) 原卷及乙卷误将“九”作“久”，今从甲卷。
    (注89) 原卷缺“有”，今从甲乙两卷。
    (注90) 原卷多“言”字，据甲乙两卷删去。
    (注91) 甲卷缺“切”字，今从原卷及乙卷。
    (注92) 原卷误将“令”作“今”，今从甲乙两卷。
    (注93) 甲卷与乙卷作“贞”，从今原卷。
    (注94) 原卷与乙卷作“真心”，今从甲卷。
    (注95) 原卷缺“名”字，今从甲乙两卷。
    (注96) 原卷作“菩萨”，今从甲乙两卷。
    (注97) 原卷与甲卷缺“行”字，今从甲卷。
    (注98) 甲卷与乙卷作“想”，今从原卷；乙卷缺“地有”二字。
    (注99) 甲卷作“想”，今从原卷及乙卷。
    (注100) 原卷作“相境”。
    (注101) 原卷缺“观”字，今从甲乙两卷。
    (注102) 原卷作“由”，今从甲乙两卷。
    (注103) 甲卷作“前”，今从原卷与乙卷。
    (注104) 甲卷作“须”，今从原卷与乙卷。
    (注105) 原卷作“此以知”，乙卷作“此以此故知”，今从甲卷。
    (注106) 甲误作 “菩提道”，今从原卷与乙卷；原卷缺“道”字。
    (注107) 原卷作“即”，今从甲乙两卷。
    (注108) 原卷缺“无”字，今从甲乙两卷。
    (注109) 原卷及乙卷作“虽”，今从甲卷。
    (注110) 甲卷作“证”，今从原卷及乙卷。
    (注111) 原卷及乙卷作“具”，今从甲卷。
    (注112) 甲卷作“粗”，今从原卷及乙卷。
    (注113) 原卷作“正”，今从甲乙两卷。
    (注114) 原卷作“万”，今从甲乙两卷。
    (注115) 甲卷误将“身”作“是”。
    (注116) 原卷作“莹莹”，缺“磨”字。
    (注117) 原卷缺“磨”字。
    (注118) 原卷作“饰”，今从甲乙两卷。
    (注119) 原卷作“转”，今从甲乙两卷。
    (注120) 原卷作“具”，今从甲乙两卷。
    (注121) 原卷作“由”，今从甲乙两卷。
    (注122) 原卷误将“侄”作“嫌”。
    (注123) 原卷与乙卷作“可”，今从甲卷。
    (注124) 乙卷作“想”，今从原卷及甲卷。
    (注125) 原卷作“别念”，今从甲乙两卷。
    (注126) 原卷误将“善”作“著”。
    (注127) 原卷误将“彼”作“被”。
    (注128) 原卷缺“心”字。
    (注129) 原卷作“心内”。
    (注130) 原卷作“世间”。
    (注131) 原卷多“何起”二字。
    (注132) 原卷作“意取”，今从甲乙两卷。
    (注133) 原卷与乙卷作“身”，今从甲卷。
    (注134) 原卷遗漏：“由方便得……大乘之法，悲智”等二十四字，今从甲乙两卷。108页
    (注135) 原卷误将“澄”作“证”。
    (注136) 原卷缺“知”，今从甲乙两卷。
    (注137) 原卷误将“孝”作“学”。
    (注138) 同上。
    (注139) 原卷遗漏“菩萨 ”二字，又用“共”来代替之。
    (注140) 原卷误将“妄”作“要”。
    (注141) 参看一三七。
    (注142) 同上。
    (注143) 原卷缺“故”，今从甲乙两卷。
    (注144) 原卷缺“分”，今从甲乙两卷。
    (注145) 原卷多“因”字，今从甲乙两卷。
    (注146) 甲卷缺“见染”，今从原卷及乙卷。
    (注147) 各卷均作“许”，此应为“识”之误。
    (注148) 原卷作“达”，乙卷模糊清皙，今从甲卷。
    (注149) 原卷缺“信”字。
    (注150) 原卷作“即”，今从甲乙两卷。
    (注151) 原卷作“即”，甲卷缺漏“则灭”二字，今从乙卷。
    (注152) 原卷作“若离心妄”，今从甲乙两卷。
    (注153) 原卷缺“全”字。
    (注154) 原卷之次序为“缘觉，声闻，菩萨”，今从甲乙两卷。
    (注155) 甲卷重述“因缘”二字。
    (注156) 甲卷无“性”字，今从原卷及乙卷。
    (注157) 乙卷作“四生”，应为“死生”之讹。
    (注158) 原卷与乙卷作“熏”。
    (注159) 原卷缺“发”字。
    (注160) 甲卷遣漏“法，发缘觉”四字，今从原卷及乙卷。
    (注161) 原卷缺“可”字，甲卷作“破怀”，今从乙卷。
    (注162) 原卷缺“生”字。
    (注163) 原卷缺“行”字。
    (注164) 原卷缺“根”字。
    (注165) 原卷作“佛闻”，甲乙两卷作“所闻”；乙卷作“政卷”，应为“正法”之讹
    (注166) 各卷皆作“德失”，应为“得失”之误。
    (注167) 原卷误将“过”作“遇”。
    (注168) 甲卷遗漏：“谓曾闻说……一依唯识渐教说者”等三十行，约三百字。
    (注169) 原卷缺“苦”字。
    (注170) 原卷误将“永”作“求”。109页
    (注171) 原卷误将“空”作“定”。
    (注172) 原卷误将“身”作“自”。
    (注173) 各卷皆作“由”，应为“犹”之误。
    (注174) 甲乙两卷无“第”字，今从原卷。
    (注175) 甲卷缺“心”字。
    (注176) 原卷误将“但”作“俱”。
    (注177) 原卷缺“旨”字。
    (注178) 原卷与乙卷误将“姓”作“性”。
    (注179) 原卷作“不定姓(性) ”，甲乙两卷作“不定”，今从原卷。
    (注180) 甲卷缺“或”字。
    (注181) 原卷与乙卷作“须然”。
    (注182) 甲卷作“分别者”，原卷与乙卷作“别分别者”。
    (注183) 原卷与乙卷作“姓”，今从甲卷。
    (注184) 同上。
    (注185) 原卷作“姓”，今从甲乙两卷。
    (注186) 参看一八三。
    (注187) 同上。
    (注188) 甲卷误将“性”作“世”，今从原卷及乙卷。
    (注189) 原卷误将“姓”作“性”。
    (注190) 同上。
    (注191) 原卷缺“即”字。
    (注192) 参看一八三。
    (注193) 原卷缺“成”字。
    (注194) 原卷与乙卷作“得”，今从甲卷。
    (注195) 原卷缺“五”字。
    (注196) 乙卷误将“姓”作“性”。
    (注197) 原卷缺“说”字。
    (注198) 参看一九六。
    (注199) 同上。
    (注200) 同上。
    (注201) 原卷误将“沈”作“沉”。
    (注202) 参看一九六。
    (注203) 原卷误将“命”作“令”。今从甲乙两卷。
    (注204) 甲卷缺“故”；乙卷作“成罗汉”，今从原卷。
    (注205) 甲卷遗漏“令观因缘，成缘”六字。
    (注206) 甲卷作“佛果”，今从原卷及乙卷。 110页
    (注207) 参看二○三。
    (注208) 原卷误将“别”作“引”。
    (注209) 参看(注202) 。
    (注210) 原卷误将“后”作“复”。
    (注211) 原卷及乙卷缺“此性”二字。
    (注212) 甲卷作“所”，今从原卷及乙卷。
    (注213) 甲卷于“出世”后多“不”字。
    (注214) 参看(注202) 。
    (注215) 同上。
    (注216) 原卷误将“同”作“闻”。
    (注217) 参看(注202) 。
    (注218) 同上。
    (注219) 同上。
    (注220) 原卷与乙卷误将“姓”作“性”。
    (注221) 同上。
    (注222) 参看(注208) 。
    (注223) 原卷误将“姓”作“性”。
    (注224) 原卷缺“是”字。
    (注225) 参看(注222) 。
    (注226) 参看(注220) 。
    (注227) 甲卷与乙卷误将“蜜”作“密”。
    (注228) 原卷与乙卷缺“中”字。
    (注229) 原卷与乙卷缺“有”字。
    (注230) 参看(注227) 。
    (注231) 同上。
    (注232) 同上。
    (注233) 原卷作“三乘”，今从甲乙两卷。
    (注234) 乙卷缺“云”字。
    (注235) 甲卷作“心身”今从原卷及乙卷。
    (注236) 甲卷作“皆”。今从原卷与乙卷。
    (注237) 原卷误将“难”作“谁”。
    (注238) 甲卷作“唯独佛德”，乙卷作“唯独佛得”，今从原卷。
    (注239) 甲卷作“其有”，今从乙卷及原卷。
    (注240) 乙卷与原卷作“四生”，今从甲卷。
    (注241) 甲卷误将“与”作“异”。
    (注242) 甲卷加入“故言三余者”五字，不见于其他二卷 111页
    (注243) 甲卷缺“恼”字。
    (注244) 原卷作“生”，今从甲乙两卷。
    (注245) 各卷皆作“心智”，应为“心知”之误。
    (注246) 甲卷误将“想”作“相”。
    (注247) 甲卷误将“被”作“彼”。
    (注248) 原卷与乙卷作“后”，今从甲卷。
    (注249) 甲卷作“障”，今从原卷及乙卷。
    (注250) 原卷缺“识”字。
    (注251) 原卷误将“段”作“断”。
    (注252) 原卷误将“示”作“尔”。
    (注253) 甲卷误添入“不识”二字。
    (注254) 原卷误将“重”作“熏”。
    (注255) 原卷与乙卷作“消”，今从甲卷。
    (注256) 原卷多“可”字。
    (注257) 甲卷至此而止，缺第十九问末端，第二十一及第二十二问。
    (注258) 原卷误将“求”作“未”。
    (注259) 原卷作“三乘”，今从乙卷。
    (注260) 原卷误将“定”作“言”。
    (注261) 原卷误将“示”作“尔”。
    (注262) 乙卷误将“蜜”作“密”。
    (注263) 同上。
    (注264) 原卷作“得”，今从乙卷。
    (注265) 原卷误将“灭”作“成”。
    (注266) 原卷误将“知”作“智”。
    (注267) 各卷均作“由”，应为“犹”之误。
    (注268) 原卷缺“故”字。
    (注269) 原卷作“熟”，今从乙卷。
    (注270) 乙卷缺“谤”字。
    (注271) 原卷缺“者”字。
    (注272) 乙卷缺“经”字。
    (注273) 原卷作“非一异”，今从乙卷。
    (注274) 原卷与乙卷“环”与“镮”同用，姑从之。
    (注275) 原卷缺“性”字；“静”似为“性”之误。
    (注276) 原卷误将“随”作“堕”。
    (注277) 乙卷缺“非”，今从原卷。
    (注278) 原卷作“因”，今从乙卷。
    (注279) 原卷误将“局”作“扇”。
    (注280) 原卷误将“段”作“遐”。
    (注281) 原卷误将“坏”作“怀”。
    (注282) 乙卷作“绕”，原卷作“达”。
    (注283) 原卷误将“脚”作“御”。
    (注284) 原卷作“法”，今从乙卷。
    (注285) 原卷误将“檀”作“擅”。
    (注286) 原卷误将“换”作“援”。
    (注287) 原卷误将“云”作“之”。
    (注288) 原卷缺“说”字。
    (注289) 乙卷缺“律”字。
    (注290) 原卷误将“各”作“名”。
    (注291) 各卷均作“击”，或许为“攀”之误。若不然，则在“击”字下应有如“击鼓”之类之字？
    (注292) 原卷之“润”字为笔误，乙卷特别指出之。
    (注293) 原卷误将“座”作“坐”。
    (注294) 原卷误将“孝”作“学”。
    (注295) 乙卷误将“坐”作“座”。
    (注296) 同上。
    (注297) 原卷误将“序”作“斥”。
    (注298) 原卷误将“俺”作“淹”。
    (注299) 乙卷作“摩揭□”，今从原卷。
    (注300) 原卷误将“冷”作“洽”。
    (注301) 原卷误“初”字。
    (注302) 原卷缺“大”字。
    (注303) 原卷误将“兀”作“儿”。
    (注304) 原卷与乙卷均作“贺”，应为“货”字之误？
    (注305) 乙卷误将“牡”作“壮”。
    (注306) 原卷误将“亟”作“烝”。
    (注307) 原卷误将“清”作“请”。
    (注308) 原卷缺“断”字。
    (注309) 原卷缺“知”字。
    (注310) 甲卷有“夜”字，乙卷缺乏。为行文计，“于梦寐中”似较顺口。
    (注311) 原卷作“之”今从乙卷。
    (注312) 原卷误将“疾”作“嫉”。
    (注313) 原卷误将“发”作“殷”。
    (注314) 原卷误将“怪”作“怀”。
    (注315) 原卷误将“觉”作“学”。
    (注316) 原卷误将“由”作“犹”。
    (注317) 乙卷作“谛宝”，原卷作“谛实”，今从原卷。
    (注318) 参看(注315) 。
    (注319) 原卷误将“设”作“后”。
    (注320) 原卷误将“被”作“披”。
    (注321) 参看(注315) 。
    (注322) 原卷作“能知”，今从乙卷。
    (注323) 原卷遗漏“昨”字。
    (注324) 原卷作“命”，今从乙卷。
    (注325) 原卷误将“告”作“造”。
    (注326) 参看(注315) 。
    (注327) 同上。
    (注328) 原卷误将“我”作“哉”。
    (注329) 原卷误将“闻”作“门”。
    (注330) 原卷误将“知”作“和”。
    (注331) 原卷误将“说”作“诸”。
    (注332) 乙卷作“□”，原卷作“接”，今从原卷。
    (注333) 各卷均作“陵”，应为“凌”之误。
    (注334) 原卷误将“仰”作“迎”。
    (注335) 此处或有错误，所云“僧壳”者，殆“僧伽SANGHA”之译音欤？
    (注336) 原卷误将“云”作“之”。
    (注337) 原卷误将“定”作“言”。
    (注338) 原卷缺“矣”。
    (注339) 原卷缺“薪”字。
    (注340) 原卷作“然”，今从乙卷。
    (注341) 原卷误将“番”作“粪”。
    (注342) 原卷误将“遣”作“遗”。
    (注343) 乙卷误将“坐”作“座”。
    (注344) 同上。
    (注345) 原卷缺“破”字。
    (注346) 乙卷误将“掣”作“制”。
    (注347) 原卷误将“染”作“深”。
    (注348) 参看(注343)
    (注349) 原卷缺“诸”字。
    (注350) 各卷均缺“主”，今按习惯用法加入之。
    (注351) 原卷误将“性”作“姓”。
    (注352) 各卷误作“姓”，应为“性”之误。
    (注353) 原卷缺“且”字。
    (注354) 原卷缺“必正”二字。
    (注355) 乙卷有“舍客”，似为“含容”之误；原卷缺“含”有“容”。
    (注356) 原卷缺“出”字。
    (注357) 乙卷作“弊”。
    (注358) 参看(注343) 。
    (注359) 乙卷误将“比”作“北”。
    (注360) 参看(注343) 。
    (注361) 原卷误将“的”作“明”。
    (注362) 参看(注343) 。
    (注363) 同上。
    (注364) 原卷缺第二次之“西方”二字。
    (注365) 参看(注343) 。
    (注366) 原卷作“□”，今从乙卷。
    (注367) 原卷多“法”字。
    (注368) 乙卷作“折”，原卷作“析”--有“分析”之意。
    (注369) 原卷误以“宣先”作“宜者”。但“宜者”或为“窄者”之误。
    (注370) 原卷误将“增”作“憎”。
    (注371) 原卷误将“慊”作“嫌”。
    (注372) 原卷缺“荡”字。
    (注373) 原卷误将“尔”作“参”。
    (注374) 乙卷有“丙申年一月日书记”；原卷有“丁卯年三月九日写毕，比丘法灯书”。

＝＝＝＝＝＝＝＝＝＝＝＝＝＝

    THE TWENTY TWO DIALOGUES ON MAHAYANA BUDDHISM
                By W. PachowSummary

    This work was written by Master T'an-kuang ofthe T'ang dynasty, who was fairly active till around785 C.E. However, his definite dates were uncertain.
    It consists of twenty-two dialogues entitled"Ta-cheng erh-shih-erh `wen` 大乘二十二问", or "The twenty-two dialogues on `Mahayana` Buddhism". The questions were put to him by a king of Tibet onvarious aspects of both Theravada and `Mahayana`Buddhism, such as Buddha nature, `dharmakaya`, `nirvana`, `sunyata`, bodhicitta, `alayavijnana`, `bhutatathata`, the difference of attainment of `nirvana` between a `sravaka` and a bodhisattva and so forth. As a guide to these dialogues, we have classified them into seven sub-divisions:
    I. The practices of a Bodhisattva--This consists of six questions: No. 1, 2, 9, 10, 12 and 13.
    II. The religious cultivation of the ordinary people--This consists of four questions: No. 3, 4, 8 and 14.
    III. The various differences among the three`yanas` --This consists of four questions: No. 15, 16, 17 and 18.
    IV. The accomplishments of the Buddha--This consists of three questions: No. 5, 6, and 7.
    V. The `dharmakaya` and `nirvana` --This consists of three questions: No. 11, 19 and 20.
    VI. The `alayavijnapa` and perfect wisdom--This consists of one question: No.21.
    VII. The development of Buddhist schools--This consists of one question: No.22.
    The present version was edited and collated onthe basis of three imperfect and fragmentary manuscripts bearing No. S2674 from the British Museum, London, and Nos. P2690 and P2674 from the `Bibliotheque` Nationale, Paris. There are nearly 400 footnotes explaining the various readings,errors, omissions, corrections and other aspects ofthe manuscripts.
    There is an editorial 'Preface' featuring abrief assessment of the quality, nature, contents,history and other areas of the text. It is hopedthat one may be enabled to better understand its importance in Buddhist studies.


中国禅宗在西藏

中国禅宗在西藏

释慧严
中华佛学学报第七期

    中国禅宗在西藏
    释慧严
    中华佛学研究所副研究员
    中华佛学学报第七期 1994.07 出版(pp.214-259)

    一、序言
    为完成博士论文的写作，而到京都大学亲近竺沙雅章教授成为京大东洋史的研修员。因此因缘引出了我对敦煌佛教的兴趣，特别是对西藏论诤(桑鸢宗论 BSam yas 寺诤论)的论旨之一，即顿渐之说的论辩，也就是印度佛教与汉传佛教的论诤的内容。因为明清时代顿渐之辩在佛教思想史上，占有相当的篇幅 (注1) 的缘故， 对发生于八世纪末叶(即792 年～)(注2) 中印佛教思想史上的顿渐实践论论辩的史实，遂有一探其真貌的欲望。在深入窥视这一历史事件的同时逐渐地对八、九世纪的西藏佛教感到兴趣，尤其是汉传佛教传入西藏的史实。到底汉传佛教是在怎样的时代背景下？经由怎样的途径传入西藏的？特别是汉传佛教中的禅宗在什么时候传入的？所传入的禅宗又是属于那些派系的？它们对西藏佛教的成长具有了怎样的影响力 ？ 为什么在墀松德赞(Khrisron lde brtsan 754～797)王的时代，会与来自印度的佛教僧团发生冲突，而有引人注目的西藏论诤事件发生呢？在这事件之后，西藏佛教的生态有了怎样的变化呢？以上所提出的问题，即是本论文探讨的主要对象。首先要探讨的是墀松德赞王以前的西藏佛教。

    二、西藏与佛教的接触
    佛教传入西藏的年代，一般西藏的史书都说是在松赞干布(Sron btsan sgam po 581 ～ 649)王的时代， 对此传说，学者中也有持否定意见者，(注3)不过西藏接触佛教的机会，是在吐蕃王朝成立之后，其势力不断往外扩张的时候，也就是弃宗弄赞 (即松赞干布)、 芒松芒赞(Man sronman btsan 650 ～ 679 在位) 及器弩悉弄 (Khri hdussron 676 ～ 704) 三王在位的时代。在此三王在位的时代里，由于禄东赞 (Mgar ston rtsan yul zun ？～ 667)。 赞悉若 (Mgar btean sna ldom bu) 、 钦陵 (Khrihbrin) 赞婆 (btsan ba) 父子兄弟，先后执掌吐蕃的军事政治，(注4)以他们的足智多谋，遂使这一时代的吐蕃势力，不仅是扩及到青海、甘肃方面，更远及到今日的东土耳其斯坦。(注5)
    由此可知，七世纪的吐蕃已俨然成为能与唐帝国对抗的大国。在吐蕃势力不断地往外扩张之际，由于所统治的地域如安西四镇，(注6)及紧邻的凉州(甘肃)、松州、茂州、嶲州(四川剑南道)，均是以佛教为信仰中心的地域。其中的安西四镇， 吐蕃从咸亨元年(670)攻陷之后，直到长寿元年(692)“武威军总管王孝杰大破吐蕃之众， 克复龟兹、于阗、疏勒、碎叶等四镇，乃于龟兹置安西都护府”为止，长达二十二年的统治，吐蕃与这地域的文化接触是必然的事。而这地域的文化面貌如何呢？根据开元十五年 (727)十一月由印度回国的新罗僧慧超所著的《往五天竺国传》(P ch 3532)中云︰
    又从葱领步入一月至疏勒，外国自呼名伽师只离国，此亦汉军马守捉，有寺有僧，行小乘法，吃肉及葱韭等，土人著叠布衣也。又从疏勒东行一月至龟兹国，即是安西都护府，汉国兵马大都集处。此龟兹国足寺足僧，行小乘法，食肉及葱韭等也。汉僧行大乘法。又安西南去于阗国二千里，亦足汉军马领押。足寺足僧，行大乘法，不食肉也。从此已东，并是大唐境界，诸人共知，不可言悉。开元十五年十一月上旬至安西，于时节度大使赵君 (赵颐贞) ，且于安西，有两所汉僧住持，行大乘法，不食肉也。大云寺主秀行，善能讲说，先是京中七宝台寺僧。大云寺都维那，名义超，善解律藏，旧是京中庄严寺僧也。大云寺上座名明恽，大有行义亦是京中僧，此等僧大好住持，甚有道心，乐崇功德。龙兴寺主名法海，虽是汉儿，生安西，学识人风，不殊华夏。于阗有一汉寺，名龙兴寺，有一汉僧名□□，是彼寺主，大好住持，彼僧是河北冀州人士。疏勒亦有汉大云寺，有一汉僧住持，即是崏州(注7)人士。又从安西东行□□，至焉耆国是汉军兵马领押，有王，百姓是胡，足寺足僧，行小乘法，□此即安西四镇名数 (大正五十一，979、a、b)。
    依上文看来，我们可窥知八世纪初叶安西四镇的佛教信仰状况，虽然这记载比吐蕃统治时期晚了三十多年，但不是不足凭信的，不过为了加强这个看法，我们可以参考贞观二十年(646) 7 月 13 日完成的《大唐西域记》的记载，以及有关的研究文献。首先谈到疏勒，疏勒即是佉沙，(注8)依《大唐西域记》卷十二佉沙国条中云︰
    笃信佛法，勤营福利，伽蓝数百所，僧徒万余人，习学小乘教的说一切有部。
    至于龟兹，则从二世纪开始，就有来自印度的僧侣在此，从事传教的活动，这从此地出土的，二世纪至五世纪的梵文残简等即可推测而知。(注9)又如众所知有名的鸠摩罗什(344 ～ 413 或 350 ～ 409)，即是出身于此，成长于此的一代高僧。(注10)龟兹的佛教在纪元 379 年顷，从龟兹留学回国的僧侣纯和、昙充等的报告，当时在龟兹就有五所寺庙，四百四十位僧侣，三所尼寺，二百六十位尼。如此看来，在鸠摩罗什的少年时代，龟兹已有属于说一切有部教团的僧侣七百多位了。(注11) 由此可以反映出龟兹佛教的状况了。但是值得注意的，是玄奘留学印度的时代(629 ～ 643)，唐朝的势力尚未远及于此，(注12) 故唐朝的佛教也尚未影响此地的佛教信仰才对。这点从《大唐西域记》卷一屈支国中所云之︰
    伽蓝百余所、僧徒五千余人，习学小乘教说一切有部，经教律仪取则印度， 其习读者即本文矣。尚拘渐教食杂三净。
    即可明白。此云屈支国者，即是龟兹。(注13)
    关于于阗国者，从曹魏以后就有佛教僧侣经常往来此地，是一崇佛的国家。(注14)
    而碎叶城者，依胡三省注是焉耆都督府治所也。(注15)故欲了解碎叶的宗教信仰的话，可参考焉耆。据《魏书》卷一○二“西域”焉耆国条云︰
    文字与婆罗门同。俗事天神，并崇信佛法。尤重二月八日，是日也，其国咸依释教，斋戒行道焉。
    由以上所叙述安西四镇的佛教信仰情况，可以知道早在吐蕃王朝的势力尚未伸张于阗国……其国出美玉。 俗多机巧，好事祅神，崇佛教(《旧唐书》卷一九八，西戎于阗国条)。及此地时，此地的佛教已相当盛行。在如此的地理环境下，当吐蕃势力染指于此时，吐蕃对当地的人文不可能视而不见，换句话说，吐蕃的侵陷安西四镇，是吐蕃接触佛教的因缘之一。又据《往五天竺国传》中云︰
    又迦叶弥罗国 (kasmir) 东北，隔山十五日程，即是大勃律国、扬同国、沙播慈国此三国并属吐蕃所管，衣著言音，人风并别……地狭小，山川极险， 亦有寺有僧敬信三宝。 若是已东吐蕃国……国王百姓等，总不识佛法，无有寺舍。(注16)
    由上文可以知道，八世纪的初叶，大勃律国、扬同国(羊同国)、沙播慈国等有佛教信仰的国家，为吐蕃所统治，这又增加了吐蕃接触佛教的机会。虽然慧超谈到此时代的吐蕃尚无寺舍，王室百姓也不知道有佛教。不过由吐蕃所统治过的安西四镇及上述三国，均有佛教僧侣活跃著的社会情况来看，可能有点言过其实，不如说慧超所载的资料，正足以反映这一时期，佛教在西藏是居于无足轻重的状态，(注17)比较合乎史实。而事实上，除了以上所叙述的地域之外，吐蕃与吐谷浑、唐朝的接触，也都可以证明此时的吐蕃，已有足够的机会接触到佛教。首先我们来看吐蕃与吐谷浑接触的情形︰
    一、吐蕃对吐谷浑动兵， 是始于贞观十一年 (637) ，(注18) “其王弃宗弄赞与羊同连合，发兵攻击吐谷浑，吐谷浑不能支，遁于青海之上，以避其锋，其国人畜并为吐蕃所掠”。(注19)
    二、后与吐谷浑不和，龙朔 (661～663)、麟德 (664～665)中，递相表奏，各论曲直，国家依违，未为与夺，吐蕃怨怒，遂率兵以击吐谷浑，吐谷浑大败。河源王慕容诺曷□及弘化公主脱身走投凉州，遣使告急。(注20)
    三、麟德二年 (665) 春正月丁卯，吐蕃遣使入见， 请复与吐谷浑和亲。仍求赤水(注21)地畜牧，上不许。(注22)
    四、咸亨元年 (670) 四月， 诏以右威卫大将军薛仁贵为逻娑道行军大总管、左卫员外大将军阿史那道真、右卫军郭待封自副，率众十余万以讨之，军至大非川、为吐蕃大将论钦陵所败，仁贵等并坐除名，吐谷浑全国尽没……。(注23)
    依以上史料来看，从贞观十一年起，吐蕃与吐谷浑之间和和战战的，直到咸亨元年吐蕃终于降服了吐谷浑。由于青海方面的吐谷浑，是为南北朝时代东西交通第二大道而繁荣，因此也带来了吐蕃积极进出东西交通大道的结果。(注24)因吐谷浑位居东西交通的要道，且自南北朝时代以来，国中已有佛教流布，又吐谷浑的佛教是以剑南为中心而展开。位于岷山(松州西北吐谷浑境内)的齐兴寺、通云寺，是吐谷浑佛教的代表。在七世纪的初叶，吐谷浑早已是高度化的佛教国家。吐蕃长期以来，处心积虑要将吐谷浑纳入统治范围，最初是基于贸易经济的考量，但是当吐蕃统治了吐谷浑之后，能不受当地佛教文化的影响吗？ (注25)
    吐蕃与唐朝的接触，是开始于唐太宗的时代。由于与唐朝的势力交接，促成了唐朝文化的输入西藏。唐朝文化传入吐蕃一事，也是我们在探讨佛教传入吐蕃的史实上，一个值得注意的对象。而唐朝文化传入吐蕃的史料如下︰
    一、贞观十五年 (641) 太宗以文成公主妻之……渐慕华风。仍遣酋豪子弟请入国学，以习诗书。又请中国识文之人典其表疏。(注26)
    二、因请蚕种及造酒、碾、硙、纸墨之匠，并许焉。(注27)
    三、贞观五年 (631) 以后，太宗数幸国学太学， 遂增筑学舍一千二百间……已而高丽、 百济、新罗、高昌、吐蕃诸国酋长，亦遣子弟，请入国学，于是国学之内八千余人，国学之盛近古未有。(注28)小□宏允〈チベット禅宗と历代法宝记〉─《禅宗文化研究所纪要》六，页146 ～ 147，1974年 5 月。
    四、显庆三年(658)……吐蕃遣使论仲琮，表吐谷浑罪……。(注29)
    五、咸亨元年(670)……吐蕃遣大臣仲琮入朝。琮少游太学，颇知书。(注30)
    六、景龙四年(710)正月，金城公主下降。(注31)
    七、 ［开元十八年(730)］使名悉腊(Myes slebs)随使者(惟明及张元方)入朝…… 悉腊略通华文，既宴与语。(注32)
    (开元) 十八年十月名悉腊等至京师，上御宣政殿，列羽林仗见之。悉腊颇晓书记，先曾迎金城公主至长安，当时朝廷皆称其才辩。(注33)
    八、［开元十九年 (731) 九月］时吐蕃使奏云︰“公主请毛诗、礼记、左传、文选各一部”，制令秘书省写与之。(注34)
    由以上史料来看，虽然唐蕃的交涉有将近一世纪之久，而有关唐蕃文化交流的汉文史料并不多。但我们也可以藉此明白唐蕃的文化交流开始于文成公主的入藏。因为文成公主的下嫁，吐蕃在对唐文化的仰慕之下，有留学生的派遣。留唐学生中如论仲琮、名悉腊者，列身于政治界，扮演唐蕃交涉的重要角色。在当时学汉语，似是一种时代的需求，这从‘汉蕃对音千字文’的断简 (现物存于巴黎国立图书馆) 也可窥知。(注35) 除了语言之外，农耕、产业、造纸等的技术，也传入西藏，儒学亦不例外。
    然而上述史料中并没有谈及佛教的事情，但因为那时的长安是个国际文化色彩浓厚的都市，佛教是其文化中重要的一环，长安佛教的鼎盛，是众所周知的，吐蕃留学生不可能不知道，也不可能忽视它。又事实上，随著文成、金城两位公主的下嫁吐蕃，唐朝佛教的传入吐蕃并非是不可能的。在墀松德赞(Khri sron lde brtsan)的第一诏□中云︰
    ［原文］ Rgya btags Ra mo Chehi gtsug lag khan
    ［译文］支那人建立的Ra mo che的伽蓝)。(注36)
    这座 Ra mo che 就是小昭寺， 在布顿著的《佛教史大宝藏论》(注37) 中，也谈及文成公主修了拉萨小昭寺(页170)。至于金城公主的入藏，据《布顿佛教史》中云︰
    ［原文］(Gzin'san kon jos) Sha' sakya mu ni btsal te mchod na byas so1.
    ［译文］(金城公主)寻得释迦牟尼像虔诚供养。(注38)
    由此可以知道因文成、金城两位公主入藏的因缘，汉传佛教传入西藏的情形。而此情形正告诉我们，那可能只是两位公主的私人信仰而已，汉传佛教在西藏，可能还不具有多大的影响力吧！不过基于个人的宗教信仰的缘故，会有保护同一宗教信仰人物的事。 所以在 Dgra b Com pa dge hdunhphel gyi lun bstan pa (《僧伽婆罗陀那的于阗悬记》)中，就载有如下有关金城公主护僧的事。
    和阗 (于阗) 的僧侣等，因其国的佛教衰颓后，欲求安住之地而到 Tshal byi 的地方时， 受到来自支那皇帝之女，赭面国 (吐蕃) 之王 Cidon dmar yul gyi rgyal po 的王妃深厚的保护。(注39)与此事有关的资料尚有法成译的《释迦牟尼如来像法灭尽之记》，(注40) 此记中云︰
    安息、疏勒……众僧多分移从于阗国……于阗塔寺妙法，故行法人多于余国，久住于世。 ……当尔之时，赤面国王有大威势，多侵余国，以为自境。 ……尔时于阗属彼赤面王，故广行正法，建立塔寺，置其三宝人户田园，兴大供养。 ……(于阗)国王大臣于出家众不生欢喜。后于异时有一菩萨为赤面国第七代王，彼王纳汉菩萨公主以为妃，后将六百侍从至赤面国。时彼公主极信佛法，大具福德，赤面国王亦大净信，过于先代，广兴正法。如是之时，于阗国王年少不行佛之正法，先诸苾刍曰︰不然归俗，不然随意出向他处。 以驱逐故， 众僧集拶摩寺，评议是事……。 一切众僧至赤面国萨田比田比(Tshal byi)之境，时萨田比田比军当道节度多闻众僧从西来至，走白赤面王知。尔时彼王夫人闻多众僧失土波进，白其王曰︰“我辨畜乘及以资具，愿请众僧来至赤面国”王亦许之，以辨畜乘。 便迎众僧，至赤面国。……时赤面国置七所寺，辨诸供具，常住人户倍胜往日，安置众僧住在七寺。后经三、四年，公主心上有恶疮出，病苦之时，公主白王︰“妾因此疾终不得免，所有僮仆及以财物，愿施三宝。”王亦许之。六百侍从亦放出家，然后公主，命将终尽。(注41)
    依注释 40， 可以知道法成由藏文所记成的《释迦牟尼如来像法灭尽之记》，就是《于阗国悬记》的第一章，而且它的内容，比现存藏文本要接近原有的形态。(注42) 由整章内容来看的话，我们可以由此窥出金城公主下嫁吐蕃，到她去世前后，也就是710年至740年间，吐蕃佛教实况。
    在此所说的赤面国， 就是赭面国 (Gdon dmar zul)，也就是指的吐蕃国。依《旧唐书》吐蕃传贞观十五年条有“公主恶其人赭面”，(注43) 亦可证明。如依佐藤氏所指摘的这位公主就是金城公主 (注44) 的话， 于阗国的佛教教难，是发生于金城公主逝世(注45) 前五、六年的时候， 也就是纪元 735 年的前后吧！依上述的资料， 当于阗国的僧侣于 735 年逃亡到吐蕃之后， 受到金城公主的保护。 当时的吐蕃王是赤德祖赞 (Khri lde gtsug brtasn 704 ～ 754)。 赤德祖赞接受了金城公主的请求，将他们安置在瓜曲 (即桑耶寺所在地的附近) (注46) 地方的七所寺院。由此可知，金城公主保护来自于阗国─僧侣的事。在此值得注意的，是赤德祖赞对佛教的态度。上述资料中言及“时彼公主极信佛法，大具福德，赤面国王亦大净信，过于先代，广兴正法”之事。赤德祖赞的佛教信仰比以前的吐蕃王来得深厚，这可能是受到金城公主的影响吧！依 SBa-bzed 的记载在他的晚年即天宝十年 (751) 他派遣了尚喜(san-shi)等四人为使者，出使中国求佛经。(注47) 在这件事以前，即金城公主逝世后没多久，吐蕃王朝内，发生了排斥佛教，驱逐僧侣的事件。这事件的始末，依《释迦牟尼如来像法灭尽之记》的记载的话，是这样子的︰
    公主终后，赤面国王境界之内，豆疮病起，大臣百官并诸子孙而死者众，时彼群臣而集会之白其王曰︰“王国界内，先无如是疮苦病恼，今诸波迸戎夷僧众来到此处，公主崩逝，大臣百官多有死者，是故此诸出家之众，不留王界，理合驱出。”王先之日，合驱不驱，委细详之，群臣同心，乐驱众僧，以白王知。欲驱众僧，出于王界。是时赤面国王境内旧住苾刍嗔恚而言︰“若以驱逐此诸僧，我等亦皆不住于此。”诸臣恚言︰“汝等亦当随意而去。”公主来至赤面国后，汉王兴崇道士法，故一切汉僧悉皆来至赤面国界。如是之时，彼界众僧，赤面国内所有舍利圣教经论，供养诸具常住财物，尽皆斋持，往至于西大乾陀罗国。(注48)
    由上文的资料，可以知道金城公主是因为生豆疮而逝世。在她逝世之后，也有不少的王公贵族因此病而逝世。这豆疮说不定是天花，很可能是因为天花的流行，导致金城公主及一些王公贵族的丧生，但这场流行病的扩大，正好给信仰苯教的反佛派一个很好的排佛借口。这事件的发生是在金城公主逝世后没多久， 依王森氏之见，是在纪元 739 年的时候。(注49) 因此事件而被驱逐出吐蕃之境的，除了于阗僧侣之外，还有在于阗僧侣入藏以前，就移住到吐蕃的僧侣。值得注目的，是这些僧侣是在金城公主入藏之后，由汉地来的，他们是因为“汉王兴崇道士法”而入吐蕃的。这里所说的汉王，可能是指的唐玄宗。(注50) 由于唐玄宗的崇奉道教，所以汉地的部份僧侣来到了吐蕃，金城公主可能基于民族的感情而保护他们。依上文来看，他们的身份的确是僧侣，决不是佐藤氏， F. W. Thomas 所说的，是道士的说法。(注51) 我们可以依此窥知，在金城公主的时代，吐蕃境内已有了汉僧；不过他们的影响力还不是很大，还无法与吐蕃的传统宗教苯教的势力相抗衡。 只是在纪元 751 年，即赤德祖赞的晚年，他还决定派遣尚喜等四人入汉地求佛法一事，可以说明，汉地的佛教在吐蕃王的心目中，还具有某种程度的吸引力。同时由有反佛派的排佛，也可以显示佛教在吐蕃，已逐渐形成了气候。还有直到八世纪中叶为止，吐蕃在整个国际大环境的影响之下，所接触到的佛教已包含了来自印度及中国的东西了。

    三、汉地佛教与西藏
    汉地佛教的传入西藏可以说是在吐蕃势力的壮大，与唐朝几经和战的情况下进行著。汉地僧侣的入藏，有的是由唐朝朝廷派遣的，有的是被吐蕃俘虏的。关于前者，《佛祖统记》卷四十一，建中二年(781)中云︰
    吐蕃遣使乞朝廷赐沙门善讲佛理者。帝令良琇、文素往赴说法教化，岁一更之(大正四十九，页 379a)。
    又《册府元龟》卷九八○，外臣部通好中亦云︰
    (建中) 二年二月以万年令崔汉衡为殿中少监，持节使西戎。初吐蕃遣使求沙门之善讲者，至是遣僧良琇、文素一人行二岁一更之。
    又《唐会要》卷九七吐蕃传︰
    (建中) 二年三月以万年令崔汉衡为殿中少监持节使西戎，初吐蕃遣使求沙门之善讲者，至是遣僧良琇、文素二人，每人一岁更之。
    建中二年，正是唐蕃建中会盟也就是清水会盟的前夕，当时负责与吐蕃缔结会盟者，是崔汉衡。这从如下资料即可得知︰
    一、初 (建中二年三月) (常) 鲁与其使崔汉衡至列馆，赞普令止之，先命取国信敕 ……其盟约，请依景龙二年(708) ……其定界盟， 并从之 (《旧唐书》下、吐蕃下)。
    二、建中三年为殿中少监兼御史大夫，充和蕃使，与吐蕃使区颊赞(khu rgza btsan)至自蕃中。时吐蕃大相尚结息(shan rgyal zigs)忍而好杀， 以常(尝？)覆败于剑南， 思刷其耻，不肯约和。 其次相尚结赞 (shanrgyal btsan)有材略，因言于赞普， 请定界盟约，以息边人，赞普然之，意以结赞代结息为大相，约和好，期以十月十五日会盟于境上。戊申以汉衡为鸿胪卿。四年吐蕃朝贡(《旧唐书》卷一二二，崔汉衡传)。
    三、初汉衡与吐蕃约定月日盟誓，汉衡到，商量未决，已过其期。 遂命泽谐结赞，复定盟会期……以来年 (四年)一月十五日会盟于清水西。(注52)
    崔汉衡的出使吐蕃，原是为与吐蕃交涉，以订和平条约的。而此时的吐蕃王正是墀松德赞( khri sron ldebrtsan 342 ～ 397)。如众所周知，墀松德赞是吐蕃王朝历代蕃王中最积极导入佛教信仰于吐蕃的人物。在他向唐朝要求派遣沙门入藏宣讲佛法以前，即在他二十岁(纪元 761)时，他就下定了决心，要积极输入佛教的信仰。(注53) 二十年后的唐蕃建中会盟，他要汉僧入藏，也正表明了他的宗教政策。其实在这会盟以前，吐蕃境内已有因战争而被俘虏的汉僧，这从如下资料即可证明。
    (建中) 三年四月，放先没蕃将士僧尼等八百人归还，报归蕃俘也(《旧唐书》卷一九六下，吐蕃下)。
    汉僧因被俘虏而入藏的例子，并不因唐蕃建中会盟的签定而中止。因唐蕃的战争，并不因建中会盟而停止的缘故。汉僧因被俘虏，强制送到拉萨的事例最多的，是吐蕃，统治敦煌的时期。 敦煌失陷于吐蕃，是在贞元二年 (786) 。(注54)从这一年开始到大中二年(846)为止，是敦煌史上所谓吐蕃统治时期。在这半世纪之久的吐蕃统治期中，敦煌佛教对吐蕃的影响应是不小才对。尤其是当敦煌失陷之后，在敦煌稍具盛名的僧侣被迫入藏，还有吐蕃统治者的直接接触佛教重镇的敦煌，想必也是一大震憾吧！当时身在敦煌的汉僧，如昙旷(？～ 788)、(注55) 摩诃衍(786 ～ 794在藏) (注56) 等，前者接受了来自吐蕃王对有关佛教问题的询问，后者即是被迫入藏，且于西藏诤论中，代表汉地佛教，在吐蕃王面前与印度僧侣，就顿悟渐修的问题进行辩论。以下我想就两者的人生经历，来一窥当时的吐蕃佛教的实况。
    与昙旷有关的研究文献，可参考上山大峻氏的〈西明寺学僧の敦煌の佛教学〉(《敦煌佛教の研究》页17～ 83)等的著作。(注57) 在此我将依上山氏的研究，简略地来介绍昙旷的生平经历︰
    一、出身河右，但出生年代不明。
    二、出家于河右，在此初学唯识、俱舍。
    三、后游学长安，于西明寺学《大乘起信论》及《金刚般若经》。
    四、天宝末年，长安因安史之乱陷于纷乱中，而欲回河右，以从事布教活动。
    五、由长安回河右途中，于朔方 (灵州) 撰述《金刚般若经旨赞《二卷，于凉城 (凉州) 撰述《大乘起信论广释》五卷，于甘州撰述《大乘起信论略述》二卷。
    六、于宝应二年(763)因避战火展转至沙州 (敦煌) 。
    七、于大历九年 (774) 三月二十三日完成 《大乘百法明门论开宗义决》的著作。在此以前，于敦煌先后有《大乘入道次第开决》及《大乘百法明门论开宗义记》的著作问世。
    八、于晚年即 774年以后，因回覆来自吐蕃王墀松德赞的询问，而有《大乘二十二问》之著作。
    九、于788年逝世。
    依以上所叙述的来看，昙旷是一位学兼瑜伽唯识与般若中观二系的僧侣。拥有如此学养的他，也就难怪会被指名，来回答吐蕃赞普的询问了。记载这一历史性的佛学问答，就是《大乘二十二问》一书。此书因敦煌遗书的重见天日而被发现。其写本中最长较完整的写本是 SCh2674，现被收录于《大正新修大藏经》第八十五册中，著作的年代，上山氏认为是在 786 ～ 788 年之间，(注58) 也就是敦煌沦陷于吐蕃不久的事，此时墀松德赞正值英年时期(44岁左右)，从他下定决心欲输入佛教信仰以来，已历经二十余年的岁月，此时的西藏有来自印度那烂陀寺中观学者的寂护(Santaraksi-ta ？～ 779)(注59) 等，还有西藏佛教的摇篮桑耶寺(bsam zas)，由寂护、莲华生(padmasambha)(注60) 等负责，正在兴建中。(注61) 桑耶寺的大殿完工于 779 年，在这一年有所谓“应试七人” (Sam mi mi drug) 的西藏人僧侣的出现，(注62) 墀松德赞在桑耶寺大殿落成时，为桑耶寺立了碑文，并藉此碑文召告全国人民，宣示了他以佛教为国教的决心。此碑文即是“桑耶寺兴佛证明碑”，其内容如下︰
    逻些 (拉萨) 及札玛 (Brag mar 在桑耶寺附近) 之诸神殿， 建立三宝所依处， 奉行缘觉之教法(Sans rgyaskyi chos)。此事，无论何时，均不离不弃所供养之资具，均不得减少，不得匮乏。今迩后，每一代子孙均需按照赞普父子所作之盟誓发愿。其咒誓书词不得弃置，不得变更。祈请一切诸天、神祇、非人来作盟证。赞普父子与小邦王子诸论臣工，与盟申誓。此诏□盟书之详细节目文字正本，存之于别室。(注63)
    由此碑文可以看出墀松德赞除了自己之外，亦要王公贵族，还有其后代子孙，都信奉佛教的决心。如众所知，这是长年以来，围绕在吐蕃王朝的迎佛派与信奉传统苯教(Bodkyi chos)反佛派政治斗争的一个结果， 可以说在这个阶段，迎佛派算是占了优势。
    763 年对墀松德赞来说是个重要的年代，在这一年因印度那烂陀寺的寂护第一次入藏，为他讲说了十善道、十八界、十二因缘等佛教教理，(注64)使他接触到印度佛教。 另一方面，这一年的十月，吐蕃的军队在马重英(Stag sgraklu khon)等指挥之下，攻占了长安城，并立邠王男广武王承宏为帝。虽然占领的时间仅是短暂的十五天，(注65) 但因当时长安，是个佛教都城，其繁华的市容给马重英等的印象必然很深。而他们的见闻，也必然会传到墀松德赞的耳里，这点从他对占领长安的功臣，在论功行赏时，任命迎佛派的 mGos khri bzan yab lhag 为宰相，(注66)即可窥知。换句话说，长安的占领，使他间接地知道了长安佛教。或许是这个因缘，促成他在770年左右，派遗□色朗(SBahgsal snan)到长安求佛法。(注67)由于吐蕃国内情势迎佛派的得势，加上他自己本身也可能在公务之余，潜心研究佛学吧！因此在吐蕃占领敦煌之后，他就向当地的硕僧昙旷，提出了二十二条有关佛教的问题。也因此这部《大乘二十二问》，是我们了解墀松德赞，在此阶段的佛学素养，及佛教在西藏的情况，最好的资料之一。
    当吐蕃攻陷敦煌之后，本来是要昙旷到拉萨的，但因昙旷已年迈， 且又卧病在床不良于行，(注68)墀松德赞才改用书面方式提出问题，让昙旷也以书面方式来回答。当时墀松德赞所提出的问题如下︰
    第一问云︰菩萨离世俗之地，不向声闻缘觉之行，欲令一切众生除烦恼苦，作何法者。
    第二问云︰又不退入行菩萨，内所思意，外身显现，法中内修第一法，何是外行，第一法是何。
    第三问云︰修身口意，从初至修行，行如何。
    第四问云︰又今处于五浊恶世，自既无缚，彼亦无解，义如何者。
    第五问云︰佛有有余无余涅槃，此二涅槃，为别实有，为复假说。
    第六问云︰佛有三身，其法身者，周遍法界，化身各各在一切佛，而其应身，有一有异。
    第七问云︰佛有一切智，因从修行六波罗蜜，但本性清净，湛然不动，是一切智，此二种如何。
    第八问云︰众生若行诸菩萨行，发菩提心，如何发行。
    第九问云︰十地菩萨，几地有相，几地无想，有想无想，何者是行。
    第十问云︰菩萨具修诸解脱门，行法如何。
    第十一问云︰菩萨法身，与佛法身，同不同者。
    第十二问云︰菩萨涅槃，及与轮回，并不分别，义如何者。
    第十三问云︰菩萨所知，不著涅槃，不染世间，依何法者。
    第十四问云︰又大乘法，智慧方便二种双行，众生欲行，如何起行，菩萨自在，则可能行，众生不然，何能行者。
    第十五问云︰声闻缘觉菩萨三乘，于六尘境，各如何见。
    第十六问云︰菩萨缘觉声闻三乘，初发心相，行法如何。
    第十七问云︰又此三种，皆入涅槃，声闻缘觉菩萨涅槃，各如何者。
    第十八问云︰大乘经中，有说三乘，是方便说，或说究竟，或说二乘，皆得成佛，或说二乘，不得成佛，义如何者。
    第十九问云︰经说声闻所得涅槃，与佛无异，后智三身，一切并灭，犹如灯焰，灭即无余，此是定说，是不定说。
    第二十问云︰大乘经说，一切诸法，皆无自性，无生无灭，本来涅槃。既尔如何更须修道，一切自然得涅槃故。
    第二十一问云︰其含藏识，与大智慧，虽有清浊，是一是异，义如何者。
    第二十二问云︰佛在世时，众僧共行一法，乃佛灭后分为四部不同，于四部中，何是一法。(注69)
    依以上的问题及寂护于 773 年第二次入藏以后， 就定居于藏地传教来看，墀松德赞的佛学素养大致来自寂护所传瑜伽行中观系的影响，应该不会错才对吧！也就是说他的佛学教养是奠基在大乘般若中观的基础上，这从第七问的“佛有一切智，因从修行六波罗蜜”、第八问的“行诸菩萨行，发菩提心”及第十四问的“大乘法，智慧方便二种双行”来判断，可以窥知。因为“发菩提心”、“修行六波罗蜜”、“智慧方便二种双行”都是般若思想的中心的缘故。又从序文中的“然其问端，至极幽隐，或有往年曾学，或有昔岁不闻”，(注70)可以知道此时传入西藏的印度佛教，有未流传于汉地者，甚至于印度佛教的新情势，在昙旷来说也是未曾有闻。关于这点最好的例子，就是第二十二问中所提到的“四部”。昙旷对此问的回答，可以说费了相当的篇幅，但我们从“但闻四五之说，所言四者，即是西域。各有三藏，盛行四宗︰一上座部、二说有部、三大众部、四正量部。言五部者，即是东方。但就律宗，说有五部，一者萨婆多，即十诵律、汉地似行。二昙无德，即四分律，汉地盛行。三弥沙塞，即五分律，汉地少行。四摩诃僧祇，即僧祇律，汉地不用。五迦叶田比田比耶，空传律名，但有戒本。东方五部，从西域来，西域四部，咸传本有……。”(注71) 的答覆，就可以知道昙旷对印度佛教的新情势一无所知的情形。事实上，墀松德赞所提的四部，是指的“有外境论者“唯识派、经中观、瑜伽行中观”吧！因为这是寂护的《中观庄严论》(Madhyamakalamkara)及 ye shes sdes 的《见差别》(“ lTa ba' i khyad par”)，对整个佛教的分类法的缘故。日后这种分类法，在西藏逐渐展开成“田比田比婆娑师、经量部、瑜伽行派、中观派”四部，且为西藏人理解佛教的方式，为种种的“佛教纲要书” (Grub mthah) 所采用。(注72)
    由此我们也可以知道瑜伽行中观佛教，对西藏佛教的影响力。然而此种情势的发展，是在 792 ～ 794 年 (注73)之间，在桑耶寺及拉萨等地所发生的“西藏诤论”，(注74) 也就是印度佛教与汉地佛教禅宗的大辩论之后才确定的，而这个诤论是由赞普墀松德赞主持的。因此，这诤论的内容，也可以帮助我们来了解这个时代的西藏佛教。
    西藏诤论成为学界的注目焦点，是开始于 1952 年法国学者戴密微氏在他的《 Le concile de Lhasa 》 Paris1952， 一书中，发表的敦煌写本 PCH4646 的《顿悟大乘正理决》在此论文中，证实了西藏史书所传承的“禅僧摩诃衍与婆罗门僧的教义诤论”的事件。在此以后义大利的杜奇氏、日本的上山氏、芳村修基氏等及中国的饶宗颐氏们，先后投入了此历史事件的研究。在此我想借用先学们研究的成果来达成我正探寻的上述课题，即此事件的主角之一摩诃衍就是因战争，而被迫入藏的事。
    有关此诤论的汉文资料，除了上揭述的 P Ch4646 之外， 尚有 S Ch2672 佛经疏释、P Ch4623 诸经要抄，藏文资料则有莲华戒的《修习次第论》后篇(Lam-rim chen mo)。
    《顿悟大乘正理决》中云︰
    臣沙门摩诃衍言︰当沙州降下之日，奉赞普恩命，远追令开示禅门，乃至逻娑，众人共问禅法，为未奉进止，罔敢即说。后追到讼割，屡蒙圣主诘讫，却发遣赴逻娑，教令说禅。复于章蹉，及特便逻娑，数月盘诘。又于勃礐漫寻究其源，非是一度。陛下了知臣之所说，禅门宗旨是正，方遣与达摩摩低同开禅教。然始敕命颁下诸处，令百姓官僚尽知。复陛下一览具明，胜义洞晓。臣之朽昧，纵说，人罕依行，自今若有疑徒，伏望天恩与决 (Pch4646、153a6 ～ 153b6)
    上述资料，唯《顿悟大乘正理决》述及，如果此资料无虚，则我们可以依此了解摩诃衍被迫入藏，是在敦煌沦陷于吐蕃的 786 年。 当他初到拉萨(逻娑)，就有人向他问禅法，但是因为没有赞普的首肯，只有沉默以对。之后，奉命到讼割(Zunkar) (注75)、 章蹉 (昌珠寺？) (注76)、勃礐漫 (Bragdmar)(注77)等处，接受了墀松德赞有关禅宗的寻问。最初他得到赞普的认可，得以同达摩摩低 (提？) 一起弘扬来自汉地的禅宗。岁月如驹，一转眼过了五、六年，就在 792年时，他接到了墀松德赞的旨令，代表汉地佛教与来自印度的僧侣，就有关佛教教义及修持问题进行辩论。当时的情况，《顿悟大乘正理决》中，叙述如下︰
    A. 首自申年(792)，我大师忽奉明诏曰︰婆罗门僧等奏言︰汉僧所教授顿悟禅宗， 并非金口所说，请即停废(Pch4646, 127b4 ～ 5)
    B. 交聘邻邦，大延龙象，于五天竺国， 请婆罗门僧等卅人，于大唐国， 请汉僧大禅师摩诃衍等三人，同会净域，互说真宗 (Pch4646, 127a2 ～ 3)
    C. 至戍年(794)正月十五日，大宣诏命曰︰摩诃衍所开禅义， 究畅经文，一无差错，从今已后，任道俗依法修习(Pch129a1 ～ 2)。
    与上揭文可作对照的，是《布顿佛教史》。 其相关叙述如下 (郭和卿译文) ︰
    A. 于是汉地和尚玛哈雅那(摩诃衍Mahayana)的门徒们势力大了起来。他们说 ︰“以身语作善法行，是不能成佛的。当住于一无所作中而成佛 。”他们固执此一断见而不修善行。当时西藏人大都喜学和尚之宗。伯央(dBah dpaldbyans) 和□惹达那 (dBah ratna) 等少数人仍宗菩提萨埵 (寂护) 之规。 因此发生了两种见行不同的争论。 藏王吩咐说︰“当依阿阇黎菩提萨陲的见行而行。”以此激怒了愚昧的导师们， 他们手持利刃，扬言凡不宗汉地和尚者全部被杀掉。藏王心中不安 (页 175)。
    B. 藏王立即遣使去迎请阿阇黎莲花戒(Kamalasila) 。这情况被和尚知道后，他们取来了《广本般若经》 等一切深奥经典进行讲习。.... 相继又迎来莲花戒大师，于是藏王坐在中间， 和尚座次排在右边，莲花戒座次排在左边。 不以和尚为宗的人们都附坐于莲花戒座次的后面。藏王将两串花髟曼 2 髟曼分交阿阇黎及和尚，并且说道︰“请你两人辩论吧， 负者应向胜者献上花鬘，而且不许留驻西藏，必须离开此土。”(页 176)。
    C. 藏王吩咐道︰“所有徒众侍众也都有参与辩论的机会。”伯央立刻说道……。耶喜旺波 (ye shes dban po) 说道……。说了诸如此类有理有据的话之后，宗和尚的顿门师们无言以对， 只好将花髟曼髟曼献给阿阇黎，承认自己失败。 传说那时如厥玛玛等人 (和尚之徒) 心生忧恼， 用石块捶击自身而死。于是藏王命令说︰“从今以后，“见”应依龙树的宗规而行持，“行”应以“十法行” (注78) 及《般若波罗蜜》而修学，不许再作顿门之宗规。 于是遣送和尚返回汉地，搜集了和尚的著作窖藏起来(页 177～188)。(注79)
    由以上汉文及藏文资料来看，有西藏诤论事件的发生，是两者的共同处，不过藏文资料则无年代的记载。有关该事件的始末及其结果，两者可说是各说各话，令人难以分辨其真相。然而依学者们的研究，知道摩诃衍入藏后，相当活跃，并得皇后没卢氏等王公贵族的皈依 (资料见页 16)。 在禅宗势力急速膨胀中，引发了印度僧团的抗议，向赞普进言说︰“摩诃衍所传的禅宗不是佛教，应加以禁止。”此时摩诃衍起而辩驳之，自 792 年起， 历经几次的交手，摩诃衍是占了上风，但仍不免遭禁的命运。此事引发了亲摩诃衍的藏僧以自杀相抗的激烈事件。赞普因此请出了耶喜旺布商讨对策，结果自印度请来寂护的弟子莲花戒，于赞普王面前与摩诃衍进行辩论。结果摩诃衍辞穷败北退出拉萨，时间是在 794 年，这就是有名的西藏诤论事件的始末。(注80) 由此可以知道上述藏汉两地的资料，是记载此一事件前后期的片段史实。


中国禅宗在西藏

中国禅宗在西藏

释慧严
中华佛学学报第七期

    四、汉地禅宗在西藏
    由西藏诤论的事件，可以知道汉地禅宗在西藏的势力，然而这股汉地禅宗在西藏的势力是如何呢？可从页 14 所揭述的墀松德赞几次向摩诃衍寻问有关禅门的事情，可以窥知。又《顿悟大乘正理决》中云︰
    我大师密授禅门，明标法印。皇后没卢氏一自虔诚，划然开悟，剃除绀发，披挂缁衣朗戒。珠于情田，洞禅宗于定水，虽莲花不深，犹未足为喻也。善能为方便，化诱生灵，常为赞普姨母悉囊南氏，及诸大臣夫人卅余人说大乘法，皆一时出家矣，亦何异波阇波提为比兵尼之唱首尔 (Pch4646, 127a3-127b1)。
    此中所云之“皇后没卢氏”，依戴密微氏及佐藤氏的研究，它是 Hbro bzah 的音译。她是墀松德赞的第三纪 Hbrobzah kha rgyal mo btsan(NIR. P.168)，《拔协》作 Khrirgyal man mo btsan，看似两人实是一人，她出身于没卢氏， 依《拔协》的记载， 她因没生子故， 后为尼名为 byanchub btsun， 也即是《王统镜》 (Rgyal rabs gsal bahime lon) 中所说的 Hbre bzah byan chub btsun。(注81)
    桑耶寺钟铭︰
    ［原文］ Jo mo rgyal mo brtsan yum │ Sras kyisphyog bcuhi │ dkon mchog gsum ga la │ mchod pahislad tu con │ hdi bgyis de dehi bsod │ nams kyistobs kyis │ lha btsan po khri sron lde brtsan │zab sros stans dpyal │ gsun dbyans drug │ cuhisgra dbyans dan ldan te │ bla na myed pahi byanchub du grub par smond to ││
    ［译文］王妃甲茂赞母子二人，为供奉十方三宝之故，铸造此钟。以此福德之力，祈愿天神赞普赤松德赞父子、眷属，具六十种妙音，证无上之菩提。(注82)
    又昌珠寺钟铭︰
    ［原文］ Tshal gyi sku zon dan │ sems can thamscad │ dge ba la bskul bahi phyir │ dril chen pohdi yan lha │ btsan po khri lde sron brtsan │ gyidu-snan hgrons pa bsrugs so sol │ lhhi rna sgra barsnan la │ grag pa dan hdra bar zon bdag Jo mo byanchub kyis │ bgyis nas mkhyen pho rgyahi │ dge slonrin chen gyis blugs so ││
    ［译文］ (没卢妃菩提明之劝请) 令一切众生齐归善业之故，特铸造此大钟。钟声有如天神鼓乐，嘹亮于浩渺虚空，此亦增天神赞普赤德松赞之住世寿元也。施主为王妃菩提氏，并由唐廷汉比兵大宝仁钦监铸。(注83)
    以上桑耶寺钟铭中的“王妃甲茂赞” Jo mo rgyal mobrtsan 及昌珠寺钟铭中的“王妃菩提氏” Jo mo byanchub 不是别人就是前述的 Khri rgyal mo btsan (注84)也就是《顿悟大乘正理决》中的“没卢氏”。在桑耶寺建筑时， 她与王子赤德松赞 (注85) 出资铸造了桑耶寺钟，庆祝桑耶寺的落成，也祈求佛祐赤松德赞父子。从名字上来看，此时的她尚未出家为尼才对，又从昌珠寺钟铭中“施主王妃菩提氏”来看，此时的甲茂赞已落发为尼，又因她是为赞普赤德松赞祈福，可见此钟的铸造，是在墀松德赞去世，赤德松赞继位的纪元 797 年前后。 由此推断，月她的出家可能是在 787 年桑耶寺落成以后，西藏诤论期中的 791 年吧！(注86) 依《顿悟大乘正理决》他是受了摩诃衍也就是禅宗的影响而出家，而且她自己出家之外，也影响了赞普的姨母悉囊南氏 Sna nam za (注87) 即墀松德赞的母亲 Snanam za man mo rje 、 bshi sten 的妹妹 SNa mams bTsanmo rgyal，(注88) 及诸大臣的夫人出家。因此她在西藏佛教史的角色，被赞叹有如释迦牟尼佛的姨母摩诃波阇波提夫人，可能她在西藏佛教史上，是第一位女性出家者。
    由上述来看，汉地禅宗在吐蕃王朝中，所占的份量应是不轻。从《顿悟大乘正理决》叙及西藏诤论事件的始末时所谈的︰
    婆罗门等随言理屈，约义词穷，分已摧锋，犹思拒辙遂复眩惑大臣，谋结朋党。有吐蕃僧乞奢弥 (Myan sha mi)、尸毗磨罗 (rNgegs Byi ma ba) 等二人，知身聚沫，深契禅枝，为法捐躯，何曾顾己，或头燃炽火，或身解霜刀曰︰“吾不忍见朋党相结，毁谤禅法。”遂而死矣。又有吐蕃僧卅余人皆深悟真理，同词而奏曰︰“若禅法不行，吾等请尽脱袈裟，委命沟壑。”婆罗门等乃瞠目卷舌，破胆惊魂，顾影修墙，怀斩心斩心战股。既小乘辙乱；岂复能军，看大乘旗扬，犹然贾勇 (pch4646, 128b1～129a1)。
    又《布顿佛教史》中亦云︰
    继后阿阇黎菩提萨埵 (寂护) 作授记说︰“将来西藏有外道出现，佛教将分为两派，且发生争论。那时可去迎请我的弟子嘎玛那西那(Kamalasila)(莲花戒) 来作辩论，将能息灭邪论， 显扬正法。 ”之后，阿阇黎因被马踢伤而示圆寂。……于是汉地和尚玛哈雅那 (Mahayana 摩诃衍) 的门徒们势力大了起来，他们说︰“以身语作善法行，是不能成佛的，当住于一无所作中而成佛。”他们固执此一断见，而不修善行。当时西藏人大都喜学和尚之宗；伯央 (dBah dpal dbyans) 和□惹达那 (dBah ratna) 等少数人仍宗菩提萨埵之规，因此发生了两种见行不同的争论。藏王吩咐说︰“当依阿阇黎菩提萨埵的见行而行。”以此激怒了愚昧的导师们，他们手持利刃，扬言凡不宗汉地和尚者全部被杀掉……。
    又说︰
    (莲花戒等) 说了诸如此类有理有据的话之后， 宗和尚的顿门师们无言以对，只好将花髟曼髟曼献给阿阇黎，承认自己失败。 传说那时， 如厥玛玛 (Co rma rma) 等人 (和尚之徒) 心生忧恼，用石块捶击自身而死。……后来和尚一边的四个汉人屠夫行刺莲花戒大师，因而大师肾脏受伤逝世。(注89)
    由以上汉藏两种资料来看，虽然内容情节有出入，但是在西藏诤论中，为了汉地禅宗能否于西藏传布一事，而有吐蕃僧殉身的事件，则是相同的。虽然《顿悟大乘正理决》中的乞奢弥、尸毗磨罗，与《布顿佛教史》中的厥玛玛是否同人物，现在无法判知。除此之外，有吐蕃僧扬言欲杀害婆罗门僧；又寂护因事故而丧生，及莲华戒遭汉人杀害而死的事件。由此来推测，可以知道汉地禅宗当时在西藏的势力。这股势力的成长，最后与印度佛教僧团发生了冲突。而冲突的原因，除了对佛教教理的认识与实践有了岐见之外，政治军事的考量也是促使吐蕃王朝，欲排除汉地僧侣在西藏的势力的因素之一吧！因为此时吐蕃与唐朝的关系紧张，又此时西藏的大论尚结赞 (Shan rgyal btsan) 虽是个迎佛派者，但却是最敌视中国的人物。在他的主政之下，与唐朝订下了平凉伪盟 (787 年) 及攻陷北庭都护府 (790 年) (注90) 的缘故。在此我想从宗教的层面来看，汉印佛教僧团的冲突。在《顿悟大乘正理决》中，摩诃衍自述了自宗的教理如下︰
    臣前后所说，皆依问准经文对之，亦非臣禅门本宗。臣之所宗，离一切言说相，离自心分别相，即是真谛。皆默传默授，言语道断。若苦论是非得失，却成有诤三昧， 如一味之水， 各见不同， 小大智能， 实难等用。……摩诃衍闻，奏为佛法义，寂禅教理， 前后频蒙赐问，余有见解，尽以对答。其六波罗蜜等，及诸善要修不修，恩敕屡诘。兼师僧官寮，亦论六波罗蜜等诸善，自身不行，弟子及余人亦不教修行，诸弟子亦学如是。复有人契奏闻，但臣所教授弟子，皆依经文所示，臣所行行及教弟子法门，兼弟子所修行处，各各具见解进上。缘凡夫众生力微，据修行理，与六波罗蜜亦不相违。其六波罗蜜与诸善，要行不行者，前后所对者，是约胜义，不言行不行。论世间法，乃至三归依，一合掌发愿，大小诸善，上下尽皆为说，悉令修行，衍和上教门徒子弟处。
    又说︰
    法性遍言说，智所不及，其习禅者令看心，若心念起时，不观不思有无等，不思者亦不思。若心想起时不觉，随顺修行，即轮回生死；若觉，不顺妄想作业，即令念解脱，离一切诸佛。于胜义中，离修不修。若论世间法，假三业清净，不住不著，则是行六波罗蜜。又外持声闻戒，内持菩萨戒，此两种戒则能除二毒习气。所修行者，空言说无益事，须修行依无取舍，虽说三恶道、天人外道二乘禅，令其知解，不遣依行。一切三界众生，自家业现，犹如幻化阳焰，心之所变。若通达真如理性，即是坐禅，若未通达者，即须转经合掌礼拜修善。凡修功德，不过教示大乘法门令会。犹如一灯然百千灯事，法施以利群生。摩诃衍一生已来，唯习大乘禅，不是法师，若欲听法相，令于婆罗门法师边听。摩诃衍所说，不依疏论，准大乘经文指示。 ……摩诃衍依止和上法号降魔、小福、张和上。唯仰大福、六和上同教示大乘禅门 (Pch4646, 154b6～156a1)。
    依上述资料来分析，以摩诃衍为首的汉人僧团，在修行方面以习大乘禅为主，而其修禅著重在看心、不思不观。因此主张“于胜义中，离修不修。若论世间法，假三业清净，不住不著，则是行六波罗蜜。”如此的见解，在印度僧侣及墀松德赞来说，似是无法认同。这从“其六波罗蜜等，及诸善要修不修，恩敕屡诘。”可以得到证明。又在莲花戒的《修习次第》 (sGom pai rim pa) 后篇中云︰
    有人 (摩诃衍作如下主张) “因由心的分别作善不善的业力，诸众生得天界等的果；轮回于生死之中。因此之故，若人什么都不思惟，什么也不做的话，可从轮回中得到解脱吧！是故，什么也不宜思，布施等的善行也不宜行。行布施等事者，是为愚者而说。”如此思惟的人 (指摩诃衍) 是弃舍一切的大乘。因为一切乘是以大乘为根本的缘故，弃舍它的话，就是弃舍一切的乘吧！何者，说︰“什么也不宜思”的人，就是弃舍以真实观察为特征的般若智！因为真实智慧的根本是真实观察的缘故，弃舍它的话，就等于是断弃根本的真实观察的缘故，也就成为弃舍出世间的智慧吧！又说︰“连布施等的善也不宜行”的人，就变成终究是要弃舍布施等的方便。简要地说的话，智慧和方便就是大乘。若《大乘伽耶山顶经》中云︰“总而言之，诸菩萨道略有二种，何等为二，即般若智与方便。”又《如来不思议秘密大乘经》中也云︰“此般若智与方便者，资摄诸菩萨道”。因此之故，舍大乘者，作大业障……(Bhk. III,13. 16 ～ 15.9)。(注91)
    如上所述，是为莲花戒对摩诃衍的禅的批判。在十四、五世纪，宗喀巴 (Tson kha pa Blo bzan grags pa1357 ～1419) 的《菩提道次第广论》卷二十三中，亦引用此文来说明“思惟分别”的适用性。在此先将法尊氏的译文陈述于下︰
    若谓任随分别何事，一切分别，皆系生死，故无分别住，是解脱道，前已广破。若如是者，则于和尚派，亦无少过可设。修次后篇云︰“起如是思，立如是论，诸分别心，起善不善业增上故，令诸有情受善趣等果流转生死。若全不思惟，全不造作，则解脱生死。以是因缘，当全不思惟，全不应修施等善行，修施等者，唯为愚夫增上而说。彼乃毁谤一切大乘，大乘既是一切乘本，由谤彼故谤一切乘。言不思惟，谤观察慧，审观察慧是正智本，谤彼即谤出世间慧，断其本故。言不应修施等善行，毕竟谤毁施等方便。总其智慧方便，是名大乘。如《圣伽耶经》说︰‘诸菩萨道略有二种，何等为二，谓慧及方便。’《圣如来秘密经》说︰‘方便智慧，由此二种，总摄菩萨一切正道，故谤大乘作大业障……。’(页 43，左) 此先安立和尚所许，显然说其若如是许，则是诽谤一切大乘。如是敌者，汝当了知。若谓我许修施等行不同彼者，若唯以修施等行故与他分别，是说我与和尚修了义见同，若不尔者，无分别定亦当分别，又一切分别皆系生死，汝岂非求解脱生死。若求解脱，则行惠施持净戒等皆须分别，修彼何益，前已广说。以是若许一切分别皆系生死，和尚尤善，汝被相违重担所压。又彼学者，有作是念，若多观察二我相执之境，其次乃断能执之心，如犬逐石，是名由外断截戏论。故从最初持心不散，如犬逐咬掷石之手，由修彼故，于相执境令心不散，一切戏论自内断截。故学教理决择正见，唯于名言漂流随转，此乃最下邪见，谤毁一切佛经六庄严等 (页 44，右)。(注92)
    由此文看来，莲花戒对摩诃衍禅的批判，直到后世仍然是一成不变地被引用来批评汉地所传的禅宗。其中“思惟与分别心”的区别究竟何在？从莲花戒的批判文中，汉地佛教似是将“分别心与思惟”混在一起，因此主张“不思不观”。对此，莲花戒等认为思惟不能与分别心画上等号，它亦是妙观察智的一种，不应弃舍的。宗喀巴也说︰“则诸恶友唱说一切思惟，皆是分别，悉应弃舍者，自知法中，无如是语，良师不许。”(注93) 汉地禅宗因主张不思不观，故对六波罗蜜的修持，也就抱持消极的态度，也因此招来莲花戒等的批判。莲花戒引用《大乘伽耶山顶经》及《如来不思议秘密大乘经》来说明，大乘佛教不出般若智与方便而此方便无它即是布施等五波罗蜜也。后世的宗喀巴，更广引经典，说明般若智与方便双运的重要，兹将其所引经文，陈述于下︰
    (一)《秘密不可思议经》︰
    智慧资粮者，谓能断除一切烦恼，福德资粮者，谓能长养一切有情，以是因缘菩萨摩诃萨当勤修习福智资粮。
    (二)《圣虚空库经》︰
    由慧智故而能偏舍一切烦恼， 由方便智故而能不舍一切有情。
    (三)《圣解深密经》︰
    我终不说一向弃背利益众生事者，一向弃背发起诸行所作者，能得无上正等菩提。
    (四)《无垢称经》︰
    何为菩萨系缚解脱，若无方便摄取三有，是为菩萨系缚，若以方便趣向三有是为解脱。若无智慧摄取三有，是为菩萨系缚，若以智慧趣向三有是为解脱方便未摄慧为系缚，方便所摄慧为解脱。慧所未摄方便为缚，慧摄方便是为解脱。
    (五)《伽耶经》︰
    诸菩萨道略有二种，何等为二，谓方便智慧。
    (六)《祥胜初品》︰
    般若波罗蜜多者是母，善巧方便者是父。
    (七)《迦叶请问经》︰迦叶譬如大臣，所保国王则能成办一切所作，如是菩萨所有智慧，若由方便之所摄持，能作一切诸佛事业。(注94)
    又值得我们注意的，是宗喀巴对他同时代的西藏佛教的部份情况，作了如下的指摘︰
    又诸有情多是薄福，虽于正法略有信仰，然其慧力最极羸劣，故现仍有轻毁行品持戒等事。于修道时弃舍此等，宛如和尚所教而修，又有一类除不毁谤方便而外，见解道理，许和尚说而为善哉。又有余者弃舍观慧，全不思惟，意许和尚修法为善。此等之道，全未接近修空方所，纵许修空，然若说云︰“已得无倒空性之义，无谬修习，有修证者唯当修空，不当更修世俗行品，或说行品，不须执为中心，多门修习。”亦与一切圣教相违，唯是违越正理之道。(注95)
    此文中所谈的和尚，显然地是指摩诃衍而言，因此文的开头，有“支那堪布等，于如此道颠倒分别，有作是云︰“凡是分别， 况恶分别即善分别亦能系缚生死....”(注96)的缘故。而此和尚所传的教法，宜到宗喀巴的时代，仍然存在于西藏一事，可由此文得到证明。同时也可以由此文知道，僧侣生活的堕落，不守教戒，不重视观慧者，都被归纳为汉地禅宗的事。以下我想先来探讨摩诃衍的师承、思想，再进一步了解，流传在西藏的禅宗，除了摩诃衍系统的以外，有何系统的禅宗，还有禅宗流入西藏的情形如何？
    在《顿悟大乘正理决》摩诃衍的上奏文中，自述自己的师承如下︰
    摩订衍依止和上法号降魔、小福张和上、唯仰大福六和上，同教示大乘禅门 (p.4646, 155b6 ～ 156a.1)。
依《景德传灯录》卷四“北宗神秀禅师法嗣一十九人”中，列有︰
    兖州降魔藏禅师
    西京义福禅师
    京兆小福禅师(注97)
    又《楞伽师资记》中有云︰
    第八唐朝洛州嵩山普寂禅师、嵩山敬贤禅师、长安兰山义福禅师、蓝田玉山惠福禅师，同一师学，法侣雁行，俱承大通和上后。少小出家，清净戒行，寻师门道，远访禅门。行至荆州玉泉寺，遇大通和上讳秀，蒙授禅法。诸师等奉事大师十有余年，豁然自证禅珠独照。(注98)
    在《楞伽师资记》中所列的神秀四大弟子中，长安兰山义福禅师 (658 ～ 736) 与蓝田玉山惠福禅师，据柳田圣山氏等的研究，此两人就是《顿悟大乘正理决》中，摩诃衍所自述的大福六和上及小福张和上。(注99) 如果此说无谬的话，降魔藏、大福六、小福张三人同属神秀门下之说，则可成立，同时摩诃衍的禅也就属于北宗禅了。(注100) 而实际上，我们也可以从《顿悟大乘正理决》来检验摩诃衍思想的归属，以证明他的师承。
    在页 35 中，摩诃衍自叙︰
    a. 是故坐禅看心，妄想念起，觉则不取不住， 不顺烦恼作业，是名念念解脱 (Pch 4646, 147b2 ～ 3)
    b. 其习禅者令看心，若心念起时，不观不思有无等， 不思者亦不思 (Pch 4646, 1 55.a1 ～ 2)
    c. 谨答︰准佛顶经云︰“一根既返源、六根成解脱。 ”据金刚经及诸大乘经皆云︰离一切妄想习气， 则名诸佛。所以令看心，除一切心想妄想习气 (129b5 ～ 6)
    d. 云何看心？返照心源看心， 心想若动，有无、净不净、空不空等，尽皆不思，不观者亦不思， 故净名经中说︰“不观是菩提。” (f.135a2 ～ 3, PT823)
    e. 若离想、不思不观， 云何得一切种智？答︰若妄心不起， 离一切妄想者，真性本有，及一切种智，自然显现。 如花严及楞伽等经云︰“如日出云，浊水澄清，镜得明净，如银离矿等。” (f.140a2 ～ 5)
    f. 楞伽经中说，大慧菩萨白佛言︰“修多罗中说︰如来藏本性清净，常恒不断，无有变易。 具卅二相，在于一切众生身中， 为蕴界处垢衣所缠，贪著恚痴等妄想分别垢之所污染，如无价宝在垢衣中。 ”并密严、花严、金刚三昧、法华、普超三昧及诸一切大乘经， 具载此义。 据斯道理，佛性本有，非是修成，但离三毒，虚妄、妄想，习气垢衣，则得解脱。(f.145a6～b4)
    g. 想过者， 能障众生本来一切智，及三恶道久远轮回，故有此过。 金刚经说︰“亦令离一切诸想，则名诸佛。” (f.136b3 ～ 4)
    以上是有关摩诃衍的“不思不观的看心论”的资料，此中 g 段中的“想”，是指妄想而言。有关妄想的过失，是它障蔽了一切众生的本来一切智，因此使众生无始劫来，轮回于三恶道生死之中。虽是如此，正如 f 段中所说， “如来藏本性清净，常恒不断，无有变易”， (注101) 众生虽轮回于生死中，但如来藏佛性本具有，它并不因贪著恚痴等妄想分垢的盖覆，而受到污染，产生变易。只要众生远离贪嗔痴三毒妄想习气的垢衣，就能如 e 段中说的“一切种智自然显现，如日出云， 浊水澄清，镜得明净，(注102) 如银离矿”。然而如 c 段中所说想要离一切心想妄想习气者，看心是必要的。因为透过看心，如能不思不观， 而 c 段中所引《维摩诘所说经》中的“不观是菩提”(注103) 所以能离一切妄想杂念。 如此的修行论，我们可以从他引用的《金刚三昧经》(注104)的“佛言一念心动，五荫俱生，令彼众生，安坐心神，住金刚地，既无一念。此如如之理，具一切法”(注105)(f.130b1～ 2) 中，窥测出其脉胳。 又如此以“脱垢衣”为目的，要求“离妄想” (即离念) 而进入“不思不观的看心”，其依据，是基于《金刚经》的“离一切诸想，则名诸佛”。(注106) 而其思想的骨干， 是不折不扣的北宗“清净禅”。这从《禅门师资承袭图》中的︰
    北宗意者，众生本有觉性，如镜有明性，烦恼覆之不见，如镜有尘。若依师言教，息灭妄念，念尽则心性觉悟，无所不知；如磨拂昏尘，尘尽则镜体明净，无所不照(《卍续藏》一一○，页 870，上)。(注107)
    可以窥知。又在《顿悟大乘正理决》中的“看心”“坐禅看心”，正是北宗禅的特色。(注108)属于北宗禅系统的敦煌写本中，《大乘无生方便门》里的“看心若净，名净心地”；(注109)《大乘开心显性顿悟真宗论》的“看净心，看心起处，即须觉知，心从本己来清净，不被外缘所染”，(注110) 及道信的“坐禅看心”(注111) 都足以证明“看心”之说，属于北宗禅。虽然神秀不言“看心”而提出“观心”，但从他的《观心论》(注112) 中的︰
    a.是观心可名为了。(注113)
    b.若唯观心，云何免彼之若？ ……但能摄心，离诸邪恶、三界六趣轮回之业自然消灭，能灭诸苦，即名解脱。 (注114)
    c.但能摄心内照，觉观常明，绝三毒永使消亡，六贼不令侵扰，自然恒沙功德种种庄严，无数法门悉皆成就。(注115)
    又与以上诸文可以对照的，是︰
    若欲摄妄归真，染净平等者，要须注意“观心”。本觉自现，意观有力，仍不出意念到彼岸，常入甚深禅定，久习不己，自然事是皆毕。(注116)
    由以上诸文，令人想起《菩提达摩南宗定是非论》中所述及的︰
    为秀禅师，教人凝心入定，住心看净，起心外照，摄心内证。 (注117)
    及︰
    嵩岳普寂禅师、东岳降魔藏禅师此二大德，皆教人坐禅，凝心入定，住心看净，起心外照，摄心内证，指此以为教门。(注118)
    在此诸文中，我们可以清楚地看出，“观心”的目的，在于“摄妄归真， 染净平等”，而这是要“摄心内照 (或内证) ”才能实现的。 也有神秀、普寂、降魔藏等所教导的禅法即“凝心入定、住心看净”，才可达到的。这“住心看净”，可以说是上文所说的“看净心”或“看心若净”。“看净心”的目的，是“身返悟心源”； (注119) 对此“观心”，则是要“觉察心源”； (注120) 由此再看摩诃衍的“看心，不思不观”、“返照心源， 看心”(注121) 的话，就能理出摩诃衍的禅，是出自北宗禅。
    关于摩诃衍的禅，是属何系统？在学界的看法，可以说是很极端的。山口氏指示，摩诃衍的“不思不观”代替了神秀的“观心”，是以“离念”为目的，以期达到“返照心源”的境地， (注122) 主张是属北宗禅。可是小白田白田宏允氏的见解，虽采用了相同的资料，却提出了与山口氏完全相反的结论，他认为摩诃衍的禅，是属于南宗禅的顿悟说。他视“返照心源”与“顿悟”同义，又把“看心与大乘顿教的见性成佛道画上等号”(注123) 。 其论理的根据，是摩诃衍对“令看心除习气，出何经文”的追问，所作的回答。此回答的内容如下︰
    谨答︰准佛顶经云︰一根既返源，六根成解脱。据金刚经及诸大乘经习皆云︰离一切妄想习气则名诸佛。所以令看心，除一切心想妄想习气 (f.129a4 ～ 6)。
    又在“云何看心”的寻问下，摩诃衍回答如下︰
    返照心源看心，心想若动，有无、净不净、空不空等，尽皆不思，不观者亦不思，故净名经中说︰不观是菩提(f.135a2 ～ 3)。
    如上述，有关“看心除习气”的理论根据，摩诃衍列出了《佛顶经》中的“一根既反源，六根成解脱”及《维摩诘经》中的“不观是菩提”。小白田白田氏因此指出《诸经要抄》中所引《大佛顶经》中的︰
    元是一精明，分为六和合，一处成休复，六用皆不行一根既反源，六根成解脱，反闻闻自性，性成无上道反见见自心，见性成佛道。(注124)
    及《金刚三昧经》中的︰
    此大乘顿教法门，为一切众生本来自有佛性，千经万论大小乘教文字言说，只指众生本性，见成佛道。此法亦名反源，亦名反照，亦名反流，亦名回向，亦名无生，亦名无漏，亦名不起，亦名法离见闻觉知。(注125)来证明他的看法。他曾指出《大佛顶经》与《金刚三昧经》是顿悟禅保唐宗的论述依据。 (注126) 然而我们由《诸经要抄》所引的文句来看，确实是可以证明“反源”即“返照心源”与“顿教”具有同义的说法。但是值得注意的，是《诸经要抄》中所引的《金刚三昧经》之文，实际上在此经中并无此文或类似此文的文句。同时如依《诸经要抄》中对大乘顿教的定义，是“为一切众生本来自有佛性，千经万论大小乘文字言说，只指众生本性，见成佛道”的话，如下二段各代表北宗禅与南宗禅的文句，就值得我们再三地省思︰
    一、北宗意者，众生本有觉性，如镜有明性，烦恼覆之不见，如镜有尘。若依师教，息灭妄念，念尽则心性觉悟，无所不知。(注127)
    二、一切众生本来涅槃，无漏智性本自具足，何为不见，今流浪生死，不得解脱。为被烦恼覆故，不能得见。要因善知识指授，方乃得见故，即离流浪生死，使得解脱。(注128)
    此二段文句与前揭《诸经要抄》之文，大义相同。由此可以知道唐朝宗密以前，即初期禅宗思想的特征。此特征是基于︰如来藏思想即一切众生自有佛性，只因烦恼盖覆不能显现，故能返照心源或觉察心源，即是见性成佛道。如果仅就此点就能与顿门连接的话，则此一时代的禅门应无顿渐之分。 又从属北宗系史料的《大乘开心显性顿悟真宗论》 (S4286、 P. 二一 2162、大正八五) 的书名来看顿悟并非是南京禅的专利品。同时神秀、神会的见解也无差异。且再回头看摩诃衍的“据斯道理，佛性本有，非是修成，但离三毒，虚妄、妄想、习气垢衣，则得解脱” (f.145b4)。也可以知道，摩诃衍与两者持有相同的见解。
    关于看心与大乘顿教的关系，由于《顿悟大乘正理决》中，前后六次引用了《金刚经》中的“离一切诸相，则名诸佛”，小□氏因而认为它是《顿悟大乘正理决》的思想主轴。同时也因此文句，为神会顿悟说的理论依据，也是“见性成佛”、“顿悟无念”的经证。因此主张摩诃衍的看心与大乘顿教见性成佛是可以画上等号的。(注129)
    在《顿悟大乘正理决》中，摩诃衍确实多次引用了此文句，不过他对“离一切诸相，则名诸佛”中“诸相”的理解，是值得我们注意的。他有三次将“诸相”作“诸想”又有一处作“妄想习气” (f.129a6)。又从“所以经文，凡所有想，皆是虚妄，若见诸想非想，则见如来”来看，不用置疑地，这是《金刚经》的文句， (注130) 只是“相”被当作“想”而已。在摩诃衍来说，因他对“相”、“想”的理解模糊，所以把它们视作是“妄想习气”，因此才将“离一切诸相，则名诸佛”与“令看心除一切妄想习气”，紧密地连系在一起。如此的思想，我们可以在《大乘无生方便门》中的“凡所有相，皆是虚妄，看心若净，名净心地”看出端倪。而在《大乘无生方便门》中，是以上句来说明它的离念说。摩诃衍说︰“缘众生迷妄想故，则言离妄想，若迷得醒悟，自无妄想可离”。又他二次向墀松德赞告白说︰
    且臣前后所说，皆依问，准经文对之，亦非臣禅门本宗。臣之所宗，离一切言说相，离自心分别相，即是真谛，皆默传默授。(f.153b6 ～ 154a1)。
    由此都可以证明，摩诃衍的看心，是属于北宗禅的离念说的范畴。从以上的申论来作结论，我认为小白田白田氏对摩诃衍禅的系统归属，所作的判断，是值得商榷的，且其所作的论理，也是有牵强之感。
    又有学者如饶宗颐者，指出摩诃衍的禅是调和了南北二宗，他的论证也是依“看心”及“返照心源”。 (注131)他认为“看心”是北宗禅的教法，这点是不用再赘言。但是饶氏认为“返照心源”是南宗禅之物的看法，笔者认为并不尽然。因为神秀在《观心论》中，谈及“觉察心源”，两者应是无差异才对，故“返照心源”应不是南宗禅才谈，已不用置疑。因此饶氏之说也有待商榷。关于饶氏的如此看法，冲本克己氏也持反对的看法，他认为摩诃衍是否明确地持有对抗南宗禅的北宗意识，都是个疑问。虽然冲本氏也认为“不思不观”是荷泽宗的主张，而摩诃衍的“不思不观”是受了荷泽宗的影响。 (注132) 关于这一点，与冲本氏持相同意见的学者，有山口瑞凤氏。山口氏与饶氏均依宗密的《禅门师资承袭图》，论述摩诃衍是属于荷泽禅是神会的弟子。(注133)不过针对山口氏的论述，长谷部好一氏则持有待商榷的看法。他认为︰
    一、根据宇井伯寿氏《禅宗史研究》中的《大乘无生方便门》，主张“不思不观”是北宗禅所说。(注134)
    二、依《大乘无生方便门》中“一念净心，顿超佛地”(注135)主张北宗禅也并非不谈顿悟。
    由此他把摩诃衍的禅，看作是以北宗的传统为基体，再混入净众宗的禅。(注136)
    有关摩诃衍禅的宗派归属，如上所述，学者的看法纷岐，而所以导致如此看法岐异的主因，是对《顿悟大乘正理决》(注137)问答部份内容的解析，及莲华戒《修习次第后篇》中，有关摩诃衍禅批判内容分析不同而来。若依王锡的序所述的师承来说，不用置疑地摩诃衍是北宗禅的人物，且《顿悟大乘正理决》是北宗禅的史料一事，学者亦不否认。但是随著对内容的解析，则出现了纷岐的看法，其主要原因，是它包含了二种的顿悟说及二个宗派的禅，也就是神会和无住；北宗禅和达摩禅的内容。(注138)也可以说它收藏了汉地所传的禅。我们似可把它视作是部汉传早期禅宗思想的代表作。(注139)因这部《正理决》的问答部份，是摩诃衍回答来自印度僧团的质问。而这些质问的材料，正是源自当时流传于西藏的汉地佛教的缘故，我们可藉此来了解，当时有那些汉传佛教流传于西藏。关于这点的结论，就如前揭小□氏及山口氏的论文所说的，当时有神秀系统的禅之外，尚有保唐宗及荷泽禅。关于这汉地禅的踪迹，我们也可以从莲花戒的《修习次第》后篇来作检验。 此中，如页 19 ～ 20之外，有如下诸文︰
    无正确的个别观察者，以何方法将无始以来，耽著于色受等尘劳的染心，置于断绝思量分别的状态上。如言对一切法无忆念、无作意可以到达断绝思量分别状态，那将是不合理。毕竟无正确的个别观察，似是不能做到无忆念一切诸法，无作意的。如果自己忆念了、作意了此法，心如此修习，对其心修习无忆念、无作意者，其时其人甚忆念、作意之其姑且不论，仅不忆念不作意，就言无忆念无作意者，其时二者是以何形消失、此需调查其物自体。单仅说是无忆念、无作意，是不能得到其该然的原因。即在无相、无作意处成为断绝思量分别的境界。仅以此理由，就主张为断绝思量分别者，因为失心状态也是无怀念，无作意的缘故，也是成了达到断绝思量分别的境地。无正确的个别观察，而说希望就他物无忆念、无作意，是无其他方法的。无忆念无作意，纵使执境，无正确的个别观察者，如何通达诸法无自性。执取诸法自性空，无正确的个别观察者，是无法悟得其性空吧！不悟空性罪障是不能舍的。(注140)
    上文是莲花戒对禅的批判，这在《布顿佛教史》中，也被引用，其文如下︰
    (摩诃衍) 和尚说道︰“作善不善业， 不外往善趣和恶趣两途，以此仍未解脱生死轮回，而且是成佛的障碍。譬如黑白两云，任何一种云都是障蔽天空的。须任何亦不作意，由任何立不思想而获得完全解脱生死轮回。任何亦不作意，不加分别，不去观察，即是无缘。这与一时顿入十地无异。”莲花戒大师说道︰“如你所说任何也不思想，它即是舍离妙观察智，须知清净慧的根本，亦即妙观察智。因此，如果舍离此智，必将舍离出世间智。如果没有妙观察智，瑜伽行者都住入无分别，如果一切佛法都是无想念 (无忆念) 、无作意的话，则一切修行的体验都不能想念、不能作意了。如果想我所修是不念法，那将成为极念想作意。如果仅作无想念，那末昏倒或迷失知觉的时候，就应成为证得无分别。在没有清净的妙观察智中，是无法证入无分别智的。仅遮止了想念，如果没有清净的妙观察智，如何能证入一切法无无自性呢？在还未通达空性时，是完全不断离障染的。因此，应知是以清净慧来远离颠倒相的。由于正念是不可不想念的，想念而无作意，如何能忆念往昔处所，如何能成为一切智、如何能离诸烦恼。因此，应知以清净慧抉择诸义的瑜伽行者，他通达了一切三时内外皆无自性，而分别也归寂静，远离了一切恶见依此善巧通达方便和智慧，断除一切障染，而能获证一切佛法。(注141)
    由以上诸文，可知莲花戒对摩诃衍所指摘的重点，是“无忆念、无作意”。但是莲花戒所指摘的，在《正理决》中是找不到的，而实际上，正如学者们所说的，那是保唐宗无住的思想。(注142)他曾引《维摩经》中的“不行是菩提，无忆念故”(注143)而加注云︰“常求无念，实相知惠”。(注144)由此可知他所言的“无念”，即是《维摩经》中所说的“无忆念”。又因神会的《南阳和上顿教解脱禅门直了性坛语》中有云︰《维摩经》云︰“不观是菩提，无忆念故，即是自性空寂心”。 (注145) 使我想到︰无住的“常求无念，实相知惠”，可能是来自于神会的“无忆念故，即是自性空寂心”。又与金和尚无相的“无忆、无念、莫妄”(注146) 三句语， 也并不是完全无关，又同神会的“说无念法立见性”(注147) 也有渊源。 由此看来，在西藏诤论发生的时候，除了摩诃衍所传的禅法之外，属于神会、无相、无住系统的禅法，已在西藏流传之事，大致可以得到佐证。不过这一系统的禅法，是何时？经由怎样的路途传入西藏的呢？
    无相、无住这两位禅僧是驻锡于四川的成都府的净众寺及保唐寺。(注148)而这净众寺的无相与保唐寺的无住，先后同来自西藏的遣唐使 dBah(Khri bsher) san shi(即dBah dpal dbyans) 及 dbah gsal snan 即 dBah ye shesdban po) 有过接触，又从纪元 751 年至 794 年为止， 因南诏国的反唐， 受吐蕃的册封，并联手占领了嶲州 (四川省南部)， (注149) 使吐蕃与剑南的文化得以交流，剑南两宗的禅也因此而传入西藏。 (注150) 根据学者们的研究，在摩诃衍入藏，也就是敦煌沦陷以前，汉地的禅就经由四川传入西藏。(注151)这汉地的禅包括了净众宗、保唐宗的顿悟无念禅及以菩提达摩多罗为初祖的禅，也就是八世纪中叶，发展于剑南 (四川) 地方的《历代法宝记》系统即智诜─处寂─无相─无住的禅，此中特别是净众宗无相，保唐宗无住二人的禅，大概于《历代法宝记》成立(774年以后) 以前即766年～771年起，至摩诃衍入藏(786年) 为止的期间中，就已逐渐落实于西藏。(注152)
    佐证以上学者们所论述的史料， 是“ Sba-bshed ”《拔协》这部有关 Sba 族的西藏古老的史书。 在此《拔协》一书中，记载 dBah(Khri bsher)San shi(尚喜) 及 dBahgsal snan 奉命出使唐朝，于归国途中，经剑南，遇益州金和尚无相受教的事。依《拔协》的记载︰
    尚喜是王子 (墀松德赞) 的玩伴，在赤德祖赞 (Khrilde gtsug brtsan 704 ～ 754) 的晚年， 赤德祖赞为了王子，想传入中国的佛法，遂派遣尚喜等四人到中国……。其后一行人于归国途中，遇到了以绳系虎，在散步的益州金和尚预言道︰父王崩不久，在西藏，因苯教大臣们而有毁佛的事发生。然后从王子的口中，可以说出外道之法时，应王子的要求说佛法的话，其时王子的信仰是会产生的吧！(注153)
    受王命而到中国求法的色朗 gsal snan，是马鸣菩萨的化身， 受中国皇帝的礼遇，催设盛大的飨宴。 对色朗(gsal snan) 学禅定事，皇帝将益州金和尚分配给他。色朗 (gsal snan) 受持止观经， 后从金和尚实际地修习它。(注154)
    以上两段文的叙述，传说的味道很浓厚。关于此事，在以后的《布顿佛教史》亦有类似的传述，其文如下︰
    因此，又将阿阇黎(指寂护)送回尼泊尔去了。过了一段时间，复命埧色朗(dBah gsal snan)前往汉地去求法(中略)那时汉地的和尚说︰经过六月零六天，有一马鸣的化身来到此间，并画出了来人的画像。藏人到汉地后，中原皇帝重赏他们，并对他们优礼有加，赐和尚修身教谕，对其徒众也赐以礼品。(注155)
    以上是与色朗有关的部份，致于尚喜方面的则如下︰
    赤松德赞在少年时，曾同尚喜等一行四人派到内地去求佛法。那时有一具有神通的和尚，事先说西藏派来的使者中，有一位是菩萨化身，他的相貌是这样，说后捏出了面相。他们到时，汉地皇帝对他们很优待，并给了许多经典，派了一位和尚同他们一起返藏。当抵西藏时，藏王已逝世，因王子年幼，由大臣们专权，破坏了善法之规律，驱逐信奉佛法的人们。(注156)
    关于尚喜与色朗入汉地求法一事，将《拔协》与《布顿佛教史》的上文对照的话，可以知道内容情节不致有太大差异，但可看出《拔协》的记载，较正确且完整。尚善一行人出使长安，是在赤德祖赞的晚年，他们在益州遇到的金和尚无相，是位神异的和尚，这在《历代法宝记》中所说的他也是位神异的人物。(注157)虽然在汉文的史料中，无法证实尚喜亲近过金和尚，但以金和尚逝于宝应元年(762)5 月 19日，(注158)且 751 年至 794 年之间，经由四川入藏之路畅通，二人的相遇并非不可能。 又因 754 年赤德袒赞逝世赤松德赞以十三岁之龄即位后至二十岁亲政为止，吐蕃的朝政，是由反佛派所掌控，佛教受到排挤的事传入四川也是极为自然。(注159)所以《拔协》的记载，与史实并不相悖。
    又从汉文史料中来作窥究。据《旧唐书》卷一九六下吐蕃传下︰
    a.永泰二年(764) 三月，命大理少卿兼御史中丞杨济修好于吐蕃。四月吐蕃遣首领论泣藏等百余人随济来朝，且谢申好。
    b.大历二年(767) 十月灵州破吐蕃二万余众，生擒五百人，获马一千五百匹。十一月和蕃使，检校户部尚书兼御史大夫薛景仙自吐蕃使还，首领论泣陵随景仙来朝。景仙奏云︰赞普请以凤林关为界。俄又遣使路悉等十五人来朝。
    a 段中的论泣藏 Blon khri bzan 是广德元年 (761)，挥军侵入长安的将领之一，(注160)764 年以他为首的百人使节团出使中国，在历史上的意义是值得注目的。又 769年以路悉 Sbran rGya sgra legs gzigs 为团长，尚喜 dBahkhri bsher San shi 为副团长的十五人使节团到长安。(注161)由此可见尚喜确实到过长安，且是在赤松德赞积极吸取佛教文化的时期。 不过 767 年的出使长安，在尚喜来说可能是第二次，而这次如果也是经由四川回藏的话，他所遇到的应该是保唐寺的无住吧！同时由尚喜两次入唐，返藏时都选择剑南道来看，四川的禅对他们具有某程度的吸引力，是可以窥测而知的。

    五、结论
    由上文看来，属于四川系统的净众宗及保唐宗的禅，在唐蕃清水会盟 (783 年) 以前，就经由四川传入西藏，是不用置疑的吧！在路悉、尚喜等出使唐朝以来，唐蕃之间，经过多年的交涉， 终于由崔汉衡、 尚结赞 (Shan rgzalbtsan) 代表唐蕃， 在建中四年 (783)1 月 15 日订立了清水会盟。 (注162) 在这期间，吐蕃要求唐朝朝廷派遣善讲的沙门入藏，唐朝也作了善意的回应，派遣良琇、文素等每隔一年轮流入藏传教。(注163)在这同一时期里，印度的寂护(Santaraksita)也第二次入藏 (771 年)，在赤松德赞的兴佛政策下，与莲花生 Padmasambha(773 年入藏) 携手建造桑耶寺。之后，786 年敦煌沦为吐蕃的属地，敦煌的佛教在时代趋势中，自然地传入西藏，以现存的敦煌写本中与禅宗有关的计有二百种三百点 (注164) 来看，禅宗在敦煌应是相当活跃，这也是摩诃衍被请入藏的时空背景。而随著摩诃衍的入藏，北宗系统的禅也传入了西藏，这是很自然的事。从存在于敦煌藏译的禅宗文献中《顿悟大乘正理决》 (注165) ，《不观义》 P.tib 21 、《波罗蜜义》P.tib 116、117、《禅定精要论》 P.tib 812、S.tib 706、709、《方便论》 P.tib 117、812、81 3、《禅定顿悟门》S.tib 468、709，(以上诸文学者皈纳为《摩诃衍遗文》)、《唯一无想义》 P.tib 116、 《诸方语录抄》 P.tib116、813 及《顿悟真宗要决》P.tib 116、《楞伽师资记》S.tib 7 10、 704 等(注166) 来看，也可以得到证明。因此透过此藏译禅宗典籍的研究，也可检验禅宗尤其是初期禅宗对西藏佛教的影响，限于篇幅，就留待次篇的论文，再来报告吧！


中国禅宗在西藏

中国禅宗在西藏

释慧严
中华佛学学报第七期

    注解：

    (注1) 荒木见悟《顿悟与渐修──阳明学の位相》 页 108～ 140 研文出版，1992 年 3 月 19 日。
    (注2) 参考上山大峻 《チベット宗论の始终──敦煌佛教の研究》页257 ～ 263 法藏馆，1990年3月31日。
    (注3) 佐藤长《古代チベット史研究》页798，东洋史研究会。
    (注4) 禄东赞有子五人...... 长曰赞悉若早死、次钦陵、次赞婆次悉多干( Mgar Sta gu )、次勃论(blon)，及东赞死、钦陵兄弟复专其国 ( 《旧唐书》卷一九六上(吐蕃传上)。
    (注5) (弃宗)弄赞乃遣其相禄东赞致礼， 献金五千两，自余宝玩数百事(同上)。
    永徽元年( 650 )弄赞卒；弄赞子早死，其孙继立，复号赞普，时年幼国事皆悉禄东赞，东赞姓艺氏(‘通典’卷一九○、边防天吐蕃、 及寰宇记卷一八五均作薛氏)。虽不识文记而性明毅严重，讲兵训师，雅有节制，吐蕃之并诸羌，雄霸本土，多其谋也 (同上)。
    仪凤四年(679)赞普(Man Sron Man btsan)卒，其子器弩悉弄嗣位， 复号赞普，时年八岁，国政复委于钦陆(同上)。
    钦陵应是赞悉若之误， 依佐藤长‘古代チベット史の研究’页 315 ，东赞死后吐蕃的指导者是赞悉若。 赞悉若位居大论( Bhon Chen 相当于宰相 )，执政十八年间最大的功绩， 是安西四镇的攻陷及对吐谷浑的彻底解决。吐蕃自论钦陵兄弟专统兵马...... 其兄弟皆有才略，诸番惮之(同上)。
    时吐蕃尽收羊同， 党项及诸羌之地，东与凉、松、茂隽等州相接， 南至婆罗门，西又攻陷龟兹、疏勒等四镇， 北抵突厥，地方万余里，自汉魏以来，西戎之盛未之有也(同上)。
    参考佐藤书，页319。
    (注6) 安西四镇即龟兹、疏勒、于阗、碎叶。
    咸亨元年( 670 )四月癸卯，吐蕃陷龟兹、拔换城废安西四镇(《新唐书》卷三，本纪第三高宗)。
    咸亨元年入残羁糜十八州， 率于阗取龟兹拔换城，于是安西四镇并废(同上卷二一六，吐蕃上)。
    夏四月吐蕃陷西城十八州， 又与于阗袭龟兹，拨换城陷之，罢龟兹、于阗、焉耆、疏勒四镇(《资治通鉴》卷二○一，唐纪十七高宗咸亨元年)。
    (注7) 崏州︰甘萧省岷县(桑山正进《慧超往五天竺国传研究》，页 194，京都大学人文科学研究所，1992年3月31日。
    (注8) 《新唐书》卷二二一上，西藏上疏勒条︰
    疏勒，一曰佉沙，距京师九千里而赢。
    (注9) 注七桑山氏书，页 188。
    (注10) 《高僧传》卷二 ， 鸠摩罗什传 ， 大正五○ ，330a～333a。
    (注11) 桑山氏书，页 188 ～ 189 。
    (注12) 同上书，页 19。
    (注13) 《游方记抄》悟空入竺记中云︰“龟玆国王白□亦云丘兹，正曰屈支城”，大正五十一，980C～。
    (注14) 自外风俗物产与龟兹略同。俗重佛法，寺塔僧尼甚众王尤信尚，每设斋日，必亲自洒扫馈食焉 (《魏书》卷一○二，西城于阗国条)。
    (注15) 《资治通鉴今注》十一筑碎叶城，页 326。
    焉耆都督府︰贞观十八年灭焉耆置。有碎叶城，调露元年( 679 )都护王方翼筑， 四面十二门，为屈曲隐出伏没之状云 (《新唐书》卷四十三下地理志七下)。
    安西四镇是唐太宗于贞观二十一年( 647 )破龟兹时以郭孝恪为都护兼统于阗、疏勒、碎叶时所置(《旧唐书》卷一九八西戎，又《册府元龟》卷九五六外臣部总序 )。直至开元年间，方弃碎叶改置焉耆( 桑山氏书页 194 )。
    参考佐藤氏书页 332。
    (注16) 大正五一， 977a。
    (注17) 王森《西藏佛教发展史略》页 7，中国社会科学出版社，1987 年 6 月。
    (注18) 《旧唐书》卷一九六上，吐蕃上。
    (注19) 佐藤氏书页 252 。
    (注20) 《新唐书》卷二一六，吐蕃上。
    (注21) 现在的柴集河方面和临洮方面(佐藤氏书页312)。
    (注22) 同注20，又《资治通鉴》卷二○一。
    (注23) 同注20及注19。
    (注24) 佐藤氏书页316。
    (注25) 参考松田寿南〈吐谷浑遣使考〉上、下─《史学杂志》 48 之11、 12、1939。
    (注26) 同注19。
    (注27) 同上。
    (注28) 《唐金要》卷三十五学校。
    (注29) 同注20。
    (注30) 同上。
    (注31) 金城公主下嫁吐蕃王弃隶蹜赞(704～754)的年代，《古代チベット史研究》页 393 中， 佐藤氏元︰“これらの记录によって， 景龙三年( 709 )顷に公主が入藏したことは、确实见られるであろう”。关于佐藤氏的景龙三年说，我想是四年才对。这依如下史料即可明白。
    一、中宗神龙元年( 705 )吐蕃使来告丧， 中宗为之举哀，废朝一日。俄而赞普之祖母遣其大臣悉董热来献方物，为其孙请婚，中宗以所养雍王守礼女为金城公主许嫁之。“自是频岁贡献。 景龙三年( 709 )十一月又遣大臣尚赞吐等来迎女，中宗宴之于苑内毬场。 ...... 四年正月制曰︰......期幸始平县以送公主(同上)。旧唐书卷一九六上，吐蕃上。
    二、景龙四年春正月丁丑，命左骁卫大将军、河源军使杨矩为送金城公主入吐蕃使 (《旧唐书》卷七史宗本纪)。
    (注32) 同注20。
    (注33) 同注19。
    (注34) 同注19。
    (注35) 参考佐藤书页794～795。
    (注36) 参考佐藤书页798～799。
    参考立花秀孝“唐蕃两国佛教之交涉”─《宗教研究所》第十一卷页667～。
    (注37) 郭和卿译，民族出版社，1986年 3 月。
    (注38) 参考佐藤长〈プトンのチベット佛教史和译〉──《古代チベット史研究》页 852 ～。郭和卿译《佛教史大宝藏论》页 171。
    (注39) 佐藤书页390。
    (注40) 此记存于Pch 二一三九，《大正藏》二○九○号。关于此记，日本学界有如下的看法。
    この本はチベット藏经所收Peking. ed.No5699: Lii yul lung bstang pa《于阗国悬记》の最初の部份に相当するもので (《敦煌遗书》第一集影印本 1928)，寺本婉雅氏の邦□でいえばその第一章に相当する(《于阗佛教史的研究》，1921)──上山大峻《敦煌佛教の研究》页182～186法藏馆1990年3月31日。
    (注41) 大正五十一，996a、b、c。
    (注42) 上山氏书，页183。
    (注43) 当时的吐蕃习以赤土涂面，此赤土类似化妆品故云赭面。
    (注44) 佐藤氏书页 391。
    (注45) 《旧唐书》吐蕃传上作“(开元)二十九年春，金城公主薨，吐蕃遣使来告哀，仍请和，上不许之”。
    但二十九年仍使者抵达长安的年代，金城公主的逝世要比此早二年， 即二十七年(739)才对──参考佐藤书页 478 ～。
    (注46) 参考王森氏书页 6。
    (注47) 佐藤氏书页774～775。
    小□宏允〈古代ア文化圈における顿门派 (禅宗の流れ〉─《佛教史学研究》第 18 卷 2 号，页 62～ 63， 1976 年 4 月。
    小□宏允〈チベット禅宗と历代法宝记〉──《禅宗文化研究所纪要》六，页 144，1 974 年 5 月。
    (注48) 大正五十一，页996c～997a。
    (注49) 王森氏书页 6，林冠群氏“因此在740年至741年之一场瘟疫，不但金城公主深疾薨逝，且为贵族与蕃(苯之误)教徒借口不请外教，激怒蕃神，引起灾疫、导致所有外来之僧侣，悉数被驱逐出境 (《吐蕃赞普墀松德赞研究》页151，台湾商务印书馆，1991年 4 月，依注45，知道金城公主是于739 年因感染流行病而逝世，所以知道这场瘟疫是发生于 739年。 吐蕃的初次排佛应是 739 年。
    (注50) 佐藤氏书页391。
    (注51) 佐藤氏书页390。
    (注52) 《旧唐书》卷一九八上吐蕃传上。
    (注53) 林冠群氏书页 201，山口瑞凤氏〈チベット佛教〉──《讲座东洋思想 5 》页 235 ，东京大学出版社。
    (注54) 敦煌即沙州的沦陷年代的确定，是历经二十余年在学界里，几经研究的成果。其相关的主要研究文献如下︰
    (1)藤技晃氏〈吐蕃支配期の敦煌〉── 《东方学报．京都》三十一， 京都大学人文科学研究所，1961 年 3 月 31 日。
    (2)史苇湘氏〈吐蕃王朝管辖沙州前后 ──敦煌遗书Ｓ一四三八背(书仪)残卷的研究〉── 《敦煌研究》创刊号，1983年。
    (3)白须净真氏〈吐蕃支配期の东西交通 ──关陇朝贡道の途绝と西域朝贡使 ──〉《东洋史苑》六，1973年。
    (4)土肥义和氏〈 敦煌寺领の直接生产者の性格をめぐる一、二の问题〉── 《东アジア文化圈成立をめぐって》，唐代史研究会，1978 年。
    (5)池田温氏〈丑年十二月僧龙藏牒〉── 《山本博士还历记年东洋史论丛》，1972 年。
    (6)山口瑞凤氏〈吐蕃支配时代〉── 《讲座敦煌2、敦煌の历史》，大东出版社，1980年。
    (7)陈国灿氏〈唐朝吐蕃陷沙州的时间问题〉──《敦煌学辑刊》第一期，1985 年。
    (8)P. Demieville氏"Le concile de Lhasa"(Paris 1952).
    (9)上山大峻氏《敦煌佛教の研究》页 25 ～ 31，法藏馆，1990 年 3月31日。
    (注55) 上山氏书页 33。
    (注56) 同上书页 298。
    (注57) 芳村修基氏〈河西僧昙旷の传历〉──《印度学佛教学研究》七之一，1958 年 12 月。 后收录于《インド大乘佛教思想研究カマランシ─ラ》页 65～ 74，百华苑，昭和 49 年 3 月 30 日。
    山口瑞凤氏〈昙旷と敦煌の传教学〉─《东洋学报》第四十七期第四号，1965年3月。
    巴宙氏〈大乘二十二问之研究〉──《中华佛学学报》第三期页65 ～ 110，1990 年4月。
    (注58) 上山氏书页 43。
    (注59) 第一次入藏是在七六三年只停留四个月，就因此时西藏境内发生了水灾及传染病的蔓延，苯教徒就藉题发挥，说是因为佛教传入的缘故，迫使寂护不得不离藏暂回尼泊尔。
    他第二次入藏是在 771 年── (山口瑞凤氏〈チベット佛教〉─ 《讲座东洋思想 5 》页 236 )。
    当即迎请阿阇黎(指寂护)来到藏王宫里， 由阿伦达( Aba, nanta )作译师，在藏王的弄楚宫中，经四月之久，阿阇黎讲说了十善道、十八界、十二因缘等教法。因此触怒了藏地的邪恶鬼神，发现澎塘(hphan than)被水冲塌，红山(Dmar po ri)被雷轰击，人疾畜瘟都同时发生。以此心怀恶意的人们说︰“这是作佛法所得的恶报。”因此，又将阿阇黎送回尼泊尔去了。 过了一段时间， 复命埧、色朗( sBah gsal snan ) 前往汉地去求法 ；又派尚喜(san shi)等三十人再去迎请阿阇黎(郭和卿说︰《佛教史大宝藏论》页173，民族出版社，1986．3)。
    佐滕长译︰〈プトンのチベット佛教史和译〉──《古代チベット史研究》页855～。
    (注60) 莲华生的入藏是在773年 (前揭山口氏文(前揭山口氏文──《讲座东洋思想 5 》页 237)。
    此后迎请阿阇黎莲华生来到桑野( Bsan yas )地区修土地仪轨法。阿阇黎菩提萨埵(寂护)作了土地观察，并按照阿□延那布尼寺(O tanta pu. ri)的图样，设计出须弥十二洲、日月双星、周围绕以铁围山以表庄严(右揭郭和卿译书页174)。
    同右佐滕氏译文──佐藤氏书页856。
    (注61) 有关桑耶寺(dpal bsam zal mi hgyur lhum gyisgrub pa位于拉萨南方藏布河流域)的兴建年代，现日本学界的说法，是775年奠基，779年完成大雄宝殿的一楼、787 年整座伽蓝完工，并由寂护举行落成典礼 ( 前揭山口氏文──《讲座东洋思想史5》页237 ) 。
    御牧克己氏〈顿悟と渐悟カマランシ─ラの修习次第〉──《讲座大乘佛教 7 中观思想》页222，春秋社，昭和 57年11月30日。
    由此看来林冠群氏的说法︰桑耶寺开工于木兔年(775)，完工于土羊年( 779 )，共费五年。表中诸书(指《布敦佛教史》、《红史》、《西藏王统记》、《拔协》、《贤者喜宴》、《西藏王臣记》、《青史》、《莲花遗教》)以青史最得其实(林氏书页 214) ，这说法值得商榷。 林氏的论证，与佐藤氏相同( 佐滕氏书页 768 ～ 770 )， 然而从“即ちサムイエ寺院は七七九年に础石ガ置かれ”来看，佐藤氏好像主张桑耶寺是于 779 年奠基似的。 佐藤氏的主张是针对 G. Tucci 氏所判断的 791 年而提出的 ( 页 768 )。他们的此年代 判定是对如下资料中的半年而下的。
    (A)在半年迎请来说一切有部的十二位比丘，为了考验在藏地能否建立出家僧伽，最初以应试七人来出家，即所谓三老三少一壮。所谓三老系埧曼殊西(Dbahmandsashrhi)、巴惹达那肯达(Dlah ratna raksbita)、郑嘎谟底嘎(Bran ka mu ti ka)等三人，三少为昆纳根扎(hkhon nha gendra)、巴阁毗若遮那(Pa gor pai rotsa na)、章德唉纳礼 (Rtsan de wendra) 等三人，一壮系朗嘎达那(Glan ba ta na)。……此即所谓“应试七人”(郭和卿识书页114)。
    (B)第一、诏敕(G. Tucci, The Tombs of the TibetanKings, Serie Orientale Roma I. Rome 1950, p.96)中云︰
    赞普父王逝后，由种种样相之型，伽蓝 Shun gyishgrub pa 之础，建于羊年春月十七日。自此以来，在西藏建立三宝之础，行世尊之法不坏。赞普父子和子之母作誓约，内外大小臣以下者也发誓。书记勒令于文字 ( 译自佐藤氏书页 768 )。
    此中的半年， Tucci 氏认为是 791 年，而佐藤氏认为是 779 年。 不用说有关此年代判定的研究，在今日已被确定为 779 年，这一年桑耶寺大殿落成， 且有西藏佛教史上所谓“应试七人”(Sad mi mi drug)在寂护门下出家，并请了来自北印度那烂陀寺说一切有部的十二位比丘为他们受戒，奠定了出家僧团的基础。
    (注62) 参考注61。
    (注63) 王尧氏《吐蕃金石录》页 169 ，文物出版社，1982年10月。
    (注64) 参考注59。
    (注65) 广德元年 (763)……十月……降将高晖引吐蕃入上都城，与吐蕃大将马重英等立故邠王男广武王承宏为帝，立年号、大赦；署置官员，寻以司封崔怀等为相。郭子仪退军南保商州，吐蕃居城十五日退，官军收上都，以郭子仪为留守(《旧唐书》)卷一九六上，吐蕃上，页 5237)。
    (注66) 佐藤氏书页538～539。
    (注67) 参考注59。
    (注68) 况昙旷识量荒塘、学业肤浅，博闻既懵于经论，精解又迷于理事。卧病既久、所苦弥深，气力转微，莫能登涉，伏枕边外，驰恋圣颜，深问忽临，心神惊骇 (PCH2690、PCH2287、PCH4297)。
    (注69) 参考上山氏书页485～503。
    (注70) PCH2690、PCH2287、SCH4297。
    (注71) 上山氏书页499～500。
    (注72) 参考山上氏书页55。
    一般西藏佛教纲要书中学派的分类，可参考御牧克己氏的 "Blo Gsal Grub MTHA' " 京都，1982。
    (注73) 有关西藏诤论发生的年代，戴密微(Paul Demieville)提出的 792～794 的说法 ("Le conaile de LhasaParis, 1952") ，在今日的学界，似已无异议。巴宙氏引用苏莹辉氏《敦煌论集》页 218 及 215 ～230 中论述沙州 ( 敦煌 ) 的沦陷，是在 781 年的缘故；主张诤论是在 780 ～ 782 之间举行，并由此推论《大乘二十二问》与此诤论有关，且具有仲裁的角色。巴宙氏在〈大乘二十二问之研究〉，主张︰“促使藏王寄出若干问题与昙旷的近因，好像似牵涉及与西藏顿门派及渐门派两者间的教义的分歧”(《中华佛学学报》第三期，页 67 )，在页85～87中，巴宙氏就此主张论述者。但是因为苏氏的沙州沦陷年代的判断错误，连带著巴氏所主张的诤论的年代判定也跟著错误。因此，可以说巴氏所提出的，有关上述大乘二十二问的主张，是不能成立的。
    (注74) 此诤论也叫“拉萨诤论” (戴密微说"Le Concilede Lhasa")，也被叫做“桑耶诤论”，因是发生在Bsam yas 的 chan chub lin ) 的缘故 ( 杜奇说Giuseppe Tucci: "Minor Buddhist Texts" PartII Chapter I. Roma 1958 pp. 3-155)。后来戴密微氏( 依据 "bka' than sde lna"五部教诫等的资料) 认为诤论的进行不是只有一次，而是多次，且地点并不是局限在桑耶寺或拉萨，故主张改为“西藏诤论”(P.Demilvill; Bililiographic; GuiseppeTucci, Minor Buddhist Texts part II. Toung Pao,Vol. XLVI, Leiden, 1958, pp.402-408)以上参考上山氏书页 248。
    (注75) 藏文依佐藤氏书页508。
    其他沿藏布江去桑鸢(bsan yas)之西数里，即乞黎苏笼猎赞者(khri sron lde brtsan)与东印度高僧莲华生 (Padmasambhava)相会之处，乞黎苏笼猎赞普亦驾崩于此 (饶宗颐氏〈王锡《顿悟大乘政理决》序说并校记〉──《大藏经补编》 35， 页 807。不过饶氏是依 Tucci: MBT. p. 32, TTK. P.79)。
    (注76) 参考饶氏前揭文注51 ︰王毅《西藏文物见闻记》︰山南之行昌珠寺─文物，1961，3 。如果章蹉是昌珠寺。昌珠寺今属山南地区，乃东县泽当区昌珠乡，是山南地区的政治中心(王尧氏书，页192)。
    (注77) 墀松德赞的诞生地 (Btsan po sron lde brtsanbray mar duh bltan/ yum man mo rje nons pha赞普松德赞诞生于Bray mar，母后 Man mo rje 守护者──《西藏年代记》马年 (752) 条 "DTH. txp.26, tr p.51)。
    桑耶寺所在地 (yab khri sron lde brtsan gyirin la//Bragmar gyi bsam yas las stsogs pa//dbud mthar gtsug lag khanbrtsigs ste dkonmchog gsum gyi rten ltsugs pa dan／父墀松德赞的时代里，于 Brag mar 札玛尔等中央及地方建立伽蓝，奠下三宝的基础──TTK. p. 105)。
    Brag mar清代译名作札玛尔，今属山南札囊县桑耶氏区(参考，饶文及王尧氏书页 169 )。
    (注78) 十法行者即缮写、供养、布施、听闻、朗诵、记忆、演说、默念、思惟和修习 (郭和卿译《佛教史大宝藏论》页208)。
    (注79) 以上有中文译本之外，尚有日文译本，即佐藤氏书页 859～863。
    (注80) 参考山口氏“中国禅とチベット传教”，《敦煌佛典と禅》页383 ～ 385，大东出版社，篠原寿雄氏、田中良昭氏编，平成2 年 12 月 6 日，二版。
    霍韬晦氏在《法言》 (1989，1，佛教法住学舍 )所发表的“禅与密──拉萨对辩所反映的文化问题”中，指摘莲华戒是密宗大师，故拉萨对辩 (即文中所说的西藏诤论) 是禅密之争。像这样的指摘，我认为是值得商榷的。首先莲华戒是否是位密宗大师就是个大问题。因为寂护与莲花戒无论是否如传说中所说的师生关系， 可暂置一旁， 但西藏佛教史上视两者为中观派 (dBu ma pa) 的论师， 且为瑜伽行中观 (rNal h byor spyod pahi dbu ma)派的论师，是学界众所周知的事的缘故，详细可参考如下研究文献。
    一乡正道氏〈瑜伽行中观派〉──《讲座大乘佛教7 中观思想》页 175 ～ 207，春秋社，昭 57 年11 月 30 日。 原田觉氏〈チベット佛教の中观思想〉，同上书页 283～308 。如此看来，论述的前题有了错误，结论可能就需要修正。我认为西藏的诤论，不是如霍氏所说的禅密之争，而是如御牧克己氏所说的， 中国禅宗与印度中观派的论争 ( 《顿悟と渐悟─カマランシ─ラの修习次第》，同右书页 218)。 在此值得注目的，是中国即汉传早期的禅宗思想，也是以龙树的中观思想为基础的。同是龙树的中观思想，一者在汉地发展成独自的思想，一者在原地的印度继续发展。不当当这两股思潮在西藏会聚时，却迸出冲突的火花。由此看来，同种的文化，历经异地文化的洗礼之后产生质变，是不可否认的事。
    资料部份见页 33 ～ 34。
    (注81) 参考佐藤氏书页 802。
    (注82) 以上录自王尧氏《吐蕃金石录》页 185 ～ 186。
    (注83) 同右页 191～192 。
    (注84) 参考右书页186。
    (注85) 参考右书页187。
    (注86) 山口瑞凤氏〈中国禅とチベット佛教〉─《敦煌佛典と禅》，页 383 ～。
    (注87) 参考佐藤氏书页804。
    (注88) 同注86，页 384。
    (注89) 郭和卿译《佛教史大宝藏论》页175～178。
    佐藤氏书页859～863。
    (注90) 佐藤氏书页806。
    (注91) 中文的翻译是参考了立花孝全氏〈 Lam-rim chenmo(菩提道次第广论 ) に见られる BAbsam yas の宗论について〉──《印度学佛教学研究》15之一，1966。
    上山氏书页311～312。
    御牧氏前揭文 ──《讲座大乘佛教 7 中观思想》页232。
    有关《修习次第》后篇的各国语言翻译，请参考御牧氏文，右书页 235 ～ 236。
    (注92) 宗喀巴著、法尊氏译《菩提道次广论》，新文丰出版社，民国 72 年 1月。
    (注93) 同右书卷十三，页45，左。
    (注94) 同右书卷十，页 2，右、左。
    (注95) 同右书卷十，页 1，左。
    (注96) 同右，页 1，右、左。
    (注97) 大正五一，页224 a、b。
    (注98) 大正八五，页1290 c。
    (注99) 柳田圣山氏《初期の禅史Ⅰ》页 324，筑摩书房，昭和46年 3 月 10 日。
    饶宗颐氏〈王锡‘顿悟大乘政理决’序说并校记〉──《大藏经补编 35》页 804 ～、华宇出版社。
    饶宗颐氏“神会门下摩诃衍之入藏兼论褝门南北宗之调和问题”─《现代佛学大系》53，页 384，弥勒出版社，民73年 5月。
    (注100) 山口瑞凤氏〈中国禅とチベット佛教〉── 《敦煌佛典と禅》页 402 ～ 403，大东出版社，平成2 年 12 月 6 日。
    冲本克己氏〈摩诃衍の思想〉── 《‘花园大学研究纪要’第 8 号》页 10，花园大学文学部，1979。
    原田觉氏于〈摩诃衍禅师考〉 一文注19 中，指出“大福六和上是指六祖大德神秀吧！”
    的看法。 (《佛教学》第 8 号，页 131，佛教学研究会，1979 年10 月 ) 虽然与义福相关的资料有︰严挺之的“大智禅师碑铭并序” ( 《全唐文》卷二八○ )、 阳伯成的“大智禅师碑阴记”(同上卷三三一 )、杜昱的“大智禅师塔铭”(《唐文拾遗》卷十九)、赞宁的“京兆慈恩寺义福传”( 《宋高僧传》卷九 ) 及《旧唐书》卷一九一方伎传神秀。 但是在这些资料中，没有具体的资料可作佐证， 同时降魔藏既为神秀弟子，不可能将神秀排列于降魔藏之后， 所以原田氏的看法似是值得商榷。
    (注101) 《七卷楞伽经》卷二，大正十六，页599b。
    (注102) “如来常住清净法界，随众生心示现涅槃。 佛子譬如日出普照世间， 于一切净水器中影无不现，普遍众处” ( 《八十华严》卷五十二，大正一，页 276b)。
    “诸佛如来净诸众生自心现流， 亦复如是，渐而非顿。譬如明镜顿现众像而无分别。 诸佛如来净诸众生自心现流，亦复如是， 顿现一切无相境界而无分别，如日月轮一时遍照一切色像 ( 《七卷楞伽经》卷二，大正十六，页596b)。
    (注103) 卷上，大正十四，页 542b。
    (注104) 水野弘元氏指出《金刚三昧经》乃纪元 649～665年间，在中国编撰的经典 ( 《菩提达摩の二入四行论と金刚三昧经》─ 《印度学佛教学研究》三之二，页 239 ～ 244，昭和 30 年 )。
    (注105) 原文如下︰
    佛言︰“一念心动，五阴俱生，五阴生中， 具五十恶。”无住菩萨言︰“远行遍计，游历十方 ，一念心生，具五十恶。云何令彼众生无生一念 。”佛言︰“令彼众生，安坐心神， 住金刚地，静念无起， 心常安泰， 即无一念。” ( 大正九，页 369a)。
    (注106) 原文应是“离一切诸相，则名诸佛” ( 大正八，页 750b 及页754b )。 摩诃衍将“想”作“相”解，且此“想”者作“妄想”又如 C 段作“妄想习气”解，显然是错误的。 但是最早作如此解释者，并不是摩诃衍， 而是窥基 (632 ～ 682) 的《金刚经赞述》 ( 原田觉氏《顿悟大乘正理决の妄想说について》《印度学佛教学研究》 25 之2，昭和 52 年 3 月 )。
    (注107) 参考山口氏前揭文，页 302。
    (注108) このテキスト全篇 (《大乘心行论》)に见える思想は， 大乘的な看心と中心とする禅法に，各种の思想や教义を总合した北宗禅の特色をすものである ( 篠原寿雄氏〈北宗禅と南宗禅〉─《敦煌佛典と禅》页 174 ～ )。
    (注109) 大正八五，页1273c。
    (注110) 大正八五，页1279a。
    (注111) 篠原氏前揭文──《敦煌佛典と禅》页 170。
    (注112) 神尾□春氏〈观心论私考〉── 《宗教研究》新九卷五号，1932年。
    参考篠原氏前揭文︰ 神尾□春氏の现存异本の对校， 及び慧琳の《一切经音义》にもとずいて本论の撰者を神秀と推定する论考 ( 《敦煌佛典と禅》页 174)。
    (注113) 大正八五，页1270c。
    (注114) 大正八五，页1270c～页1271a。
    (注115) 同右书，页1273a、b。
    (注116) 《大乘开心显性顿悟真宗论》 ，大正八五 ，页1279a～。
    (注117) 胡适氏《神会和尚遗集》页 285 ，胡适纪念馆，民国 57 年 12 月。
    (注118) 同右书页 287。
    (注119) 《大乘开心显性顿悟真宗论》，大正八五，页1278a。
    (注120) 《观心论》，大正八五，页 1273a。
    (注121) 页44，c 段。
    (注122) その不思不观は， 神秀の观心に代わっているだけのものであり， 离念を目的とし、その心源を返照する境地に至るためである( 山口氏前揭文，《敦煌佛典と禅》页 393 ～ )。
    又冲本克己氏，认为摩诃衍主张离念、看心，但又与《二入四行论》有一致的地方，因此主张不思不观是荷泽宗的主张，摩诃衍的禅是受了荷泽宗的影响 (《摩诃衍の思想》〉─《花园大学研究纪要》第 8 号，页 10 ， 花园大学文学部，1977) 又小□氏指出摩诃衍将神会，无住所主张的“无念”换作“不思不观” (〈古代チベットにおける顿门派 (禅宗) の 〉流わ ─《佛教史学研究》第 18 卷 2 号， 页 72 ，佛教史学会，1976 年3 月 )。
    (注123)“ この一段を介することによって、 マカエン禅师が引用《大佛顶经》の句は、 看心＝大乘顿教の见性成佛道であることガただちに理解されるだろう。 また第二番目の问答に见える“返照心源”も顿悟と同义であることが知られる ( 〈‘历代法宝记’と古代チベットの佛教〉─ 《初期の禅史》Ⅱ页 333，筑摩书局，昭和 59 年 5 月20 日。
    (注124) 大正八五，页1196c。
    (注125) 同右。
    (注126)〈古代チベットにおける顿门派 (禅宗)の 〉流わ─《佛教史学研究》第 18 卷 2 号，页 76 ，佛朝史学会，1976、3。
    (注127) 见页46。
    (注128)〈南阳和上顿教解脱禅门直了性坛语〉─《神会和尚遗集》页233～。
    (注129) 小□氏前揭文──《初期の禅史》Ⅱ页333～335。又小□氏在〈古代チベットにおける顿门派(禅宗)の流れ 〉 ( 《佛教史学研究》第 18 卷 2 号，1976 年 3 月 ) 中，亦有相同的论述。
    (注130) 大正八，页750b、及754b。
    (注131)〈神会门下摩诃衍之入藏兼论禅门南北宗之调和问题〉─ ( 参考《选堂选集》现代佛学大系 53 ，弥勒出版社，民73年5月～)。
    (注132)〈摩诃衍の思想〉──《花园大学研究纪要》第 8号， 页 20，花园大学文学部，1977。
    (注133) 饶氏前揭文山口氏〈チベット佛教〉──《讲座东洋思想》5，页244～247，东京大学出版会第一○版， 1981年11月30日。
    (注134) 该书页464，不过据笔者考，‘大乘无生方便门’，说的是“不思不议”。
    (注135) 大正八五，页1273c。
    (注136)〈吐蕃佛教と禅─顿悟大乘正理决をめぐって─〉─《爱知大学院大学文学部纪要》创刊号，1971。
    (注137) 《顿悟大乘正理决》是法国学者戴密微氏所发现，并于1952年以 "Le Concile Lhasa"一书发表之。它的内容， 除了前后三次的问答之外，有河西观察判官朝散大夫殿中侍御史王锡(不详)所撰的序文， 及前后三篇摩诃衍给赤松德赞的上奏文。其问答部分有旧问新问之别。旧问部份除了P464b之外，S2672亦收录之。 还有P823的藏文的写本。
    (注138) 小□氏〈古代チベットにおける顿门派 (禅宗)の流れ 〉─《佛教史学研究》第18卷 2 号页78。
    (注139) 详细请参考小□氏小岛氏一文 〈古代チベットにおける顿门派(禅宗)の流れ 〉─及山口氏〈中国禅とチベット佛教〉。
    140 以上的中文翻译，是参考前揭山口氏的论文──《敦煌佛典と禅》页400～401，《敦煌佛典と禅》页400～402及芳村修基氏《インド大乘佛教思想研究思想─カマラシ─ラ》页433 ～441，百华苑，昭49年3月30日。
    (注141) 《佛教史大宝藏论》页176～177。
    (注142) 前揭山口氏论文 ─── 《敦煌佛典と禅》页394～395。无住是位主张彻底“无念”者， 详见《历代法宝记》，大正五一，页 186a ～ 195c。此中，如下文︰
    无住行无缘，慈行无愿慈，行不热慈， 行无思慈，亦不彼亦不此，不行上中下法， 不行有为无为，实不实法，不为益不为损，无大福无小福， 以无所受而授诸受，未具佛法，亦不灭受。 若欲忏悔者，端坐念实相无念即实相，有念即虚妄， 忏悔咒愿皆是虚妄。和上说︰谁人报佛恩， 依法修行者，谁人堪受供养，世事不牵者， 谁人消供养，于法无取者，无念即无取，无念即无垢， 无念即无净，无念即无系，无念即无缚， 无念即无自，无念即无他，正无念时，无念不自， 无念即般若波罗蜜 ( 页 195b ～ c)。
    (注143) 大正十四，页542b。
    (注144) 大正五一，页189b。
    (注145) 胡适氏《神会和尚遗集》页237。
    《维摩诘经》菩萨品第四︰不观是菩提，离诸缘故；不行是菩提，无忆念故(大正十四，页 542b)。
    (注146) 详见 《历代法宝记》剑南城都府净泉寺无相禅师传(大正五一，页 184c)。
    (注147) 东京荷泽寺神会和上每月作檀场，为人说法， 破清净禅，立如来禅，立知见立言说，为戒定慧 ，不破言说云︰正说之时即是戒， 正说之时即是定，正说之时即是慧，说无念法立见性， 开元中滑台寺为天下学道者定其宗旨 ( 《历代法宝记》，大正五一，页 185b)。
    (注148) 成都府净众寺金和尚，法名无相 ( 宗密《圆觉经大疏钞》卷三下，《卍续藏经》十四，页 555c)。后章仇大夫请开禅法居净泉 ( 众 ) 寺， 化道众生，经二十余年 (《历代法宝记》， 大正五一，页184c)。
    剑南城都府大历保唐寺无住和上， 每为学道四众百千万人……(《历代法宝记》， 大正五一，页 185c)。
    (注149) ( 天宝 )十一载 (752) には南诏は吐蕃の封を受けているのである ( 《古代チベット史の研究》页 521。
    吐蕃、南诏は联合して嶲州を占领した ( 同上书页 522 )。
    天宝十年 (751) 剑南周边に一大变化ガ起った。唐朝の重税に背离した南诏国ガ吐蕃に归属したのである。これは 794 年まで继续した。この间，吐蕃は南诏と连合して蜀に入寇する事ガ多くなった。 それで最も重要なのは、この期间中，吐蕃は南诏经由で蜀に入る新ル─トを开いた事であろう。 ..... このル─トは、もともと唐朝ガ云南经营のために开いたもの (建昌路) であり重要な经济要路であった(小□氏の〈禅宗と历代法宝记〉─《禅宗文化研究纪要》六，页149，1974、5。
    (注150) 参考小□氏〈禅宗と历代法宝记〉─ 《禅宗文化研究纪要》山口氏〈中国禅とチベット佛教〉。
    (注151) 汉族佛教是从八世纪中叶开始， 经由四川而传入吐蕃的 ( 戴密微著，耿千译〈从敦煌写本看汉族佛教传入吐蕃的历史〉── 《西洋汉学家佛学论集》页 151 ～ 152，华宇出版社。
    禅宗是于中印僧诤会之前半世纪传入吐蕃的， 并且在那里与印度佛教进行过激烈争夺(同上书页 170)。
    (注152) 参考小□氏〈チベットと禅宗の‘历代法宝记’〉戴密微的前揭文。
    山口氏〈中国禅とチベット佛教〉。
    (注153) 译自小□氏前揭文 ──《禅文化研究所纪要》六，页 143c。
    (注154) 识自同右页144a。
    (注155) 郭和卿译，布顿著《佛教史大宝藏论》页173。
    (注156) 同右页171。
    (注157) 金和上得付法及信衣；遂居谷山石岩下， 草衣节食，食尽□土，感猛兽卫护 ( 《历代法宝记》，大正五一，页 184c)。
    (注158) 大正五一，页185a。
    (注159) 参考小□氏前揭文。
    (注160) 佐藤氏前揭书页769。
    (注161) 山口氏前揭文，《敦煌佛典と禅》页 381 ～。
    (注162) 参考本论文页15～17。
    (注163) 同注162。
    (注164) 田中良昭氏《敦煌禅宗文献の研究》页 8 ，大东出版社，昭和 58 年2月20日。
    (注165) 汉文的《顿悟大乘正理决》有 P4646、S2672二种，此中伯希和本，已有戴密微氏的 "Le concilede Lhasa", Paris (1952) 作了详尽的研究及翻译。 将伯希本和斯坦因本作校对研究的有长谷部好一氏的 〈吐蕃佛教と禅─顿悟大乘正理决をめぐって 〉 ( 《爱知学院大学文学部纪要 1 号，1971 》及饶宗颐氏的〈王锡‘顿悟大乘政理决’序说并校记〉 (《选堂选集》弥勒出版社，民 73年 5 月 )。致于藏文本则有 Ptib 21、823、827三本，但每本均是属于旧问部份， 其中也有汉文本中没有者，虽仅是断片，可看出是汉文本 P4646再编前的写本。
    (注166) 藏译《楞伽师资记》原典是 Stein Col. Poussin No. 710 也就是 Poussin 教授的 Catalogue ofthe Tibetan Mss from Tun-huang( 敦煌西藏文献目录 ) 的第七一○之二，题名是"Lin kahimkhan pho dan slob mahi mdo bam pho gcig go"。最早发现此资料的是上山大峻氏的 《チベット译楞伽师资记について》─《佛教学研究》25、26六合并号页19～209， 龙谷大学佛教学会，昭和43年5月15日。又西冈祖秀氏发现了S tib 704 《师资记》的断片， 以〈チベット译‘楞伽师资记’新出断片について〉发表于 《印度学佛教学研究》31之1，日本印度学佛教学会，昭和57年12日。


大乘二十二问之研究

大乘二十二问之研究

巴宙(美国爱渥华大学宗教学院教授)
中华佛学学报第二期(1988.10月出版)页65-108

    大乘二十二问之研究
    巴宙(美国爱渥华大学宗教学院教授)
    中华佛学学报第二期(1988.10月出版)页65-108

    提要
    唐代昙旷所写的“大乘二十二问”一书埋藏了一千多年之久始于本世纪初在敦煌石窟写卷里以断简残篇的姿出现于世。本文作者于 1973 年在法国巴黎国家书馆 `Bibliotheque` Nationale，Paris，及伦敦大英博馆搜遍及读尽有关该作品之写卷，后来费时数年，根据数写本，用校勘方法，辍长补短及改正讹误，始得恢复全貌我们希望它能与最初杀青时相近。本研究即是该书的导论该书全文及校注亦将发表于本文后。
    本文的主要讨论为：
    (一)在拉萨举行的中印佛教辩论会，是中国禅宗教与印度所传渐教的斗争。结果，它们各有负。
    (二)搜寻“二十二问”一书的主要扮演者及其与印辩论会之系。
    (三)西藏佛教的发展史及汉藏文化与外交的系。
    (四)对每一问题的哲学或历史的内容加以评论，析或解释。若称之为“大乘二十二问释论”亦无可。
    (五)作者昙旷之名不见载于中国佛教史籍，故费不鲜，藉以检讨；（甲）彼之生活与时代，（乙彼与西明寺之关系及该寺之文化活动，（丙）彼归返河西及其写作生活，（丁）彼对敦煌佛教的响。
    本文原用英文写出，且于数年前发表于“中国化”Chinese Culture, Vol. XX, Nos.I-2. 1979。现使以汉文出现，藉公诸同好。同时我们希望它能鼓励对敦煌教文献感兴趣的同仁继续向此方向努力云。
    藏于巴黎法国国家图书馆敦煌出土大乘二十二问写卷之影片

    一、前言
    此地吾人所注意的作品是卓然超群，不止一端。在敦煌千佛洞所发现的若干论著中，大多数是用散文写出关涉及大乘佛教研究之某方面，以问答体出现者则实不多见。此对话中的每一问题均冠以数目。这或许是这类作品的第一次从其问题的实际数字立名，故号称为：大乘二十二问。从巴利文的长阿含(注1) (Digha-nikaya)及其他经籍中的若干举例可观见佛教教主乔达摩佛陀所采取的会话方法，那是一个能将其旨意传达及他的弟子的手段，现时之作品反映到早期佛教的传袭。当检讨若干敦煌出土的变文文学作品时，诸如茶酒论(注2)，燕子赋(注3)等，吾人注意及会话体被采用。很显然地，它们是含有喻言及小说色彩，代表著诗人的想像创造。但我们的作品则大异其趣。它揭示一位追求真理者的恳诚，及一个博学卓识能巧妙地答解非常错杂及繁难的哲学问题的作家。它约略地与弥兰王问经 (注4)——弥兰王与那先比丘的讨论问答——(Questions of Milinda) 中的举例格式相仿佛。其相似处或可再进一步，那即是：在弥兰王的情况那是一位希腊后裔的国王与一印度上座部的大师两者间的交锋，而在我们所讨论的场合是西藏的国王与中国大乘学者间的互通声问。其促使此大乘二十二问之写作的环境涉及中国与西藏的政治与宗教情况，尤其是在八世纪时中国禅宗被传入西藏。使我们更为惊异者为位于唐帝国黄河西边十州以上，包括敦煌的土地竟“暂时”被西藏国王占领及统治有八十余年(762-848)之久(注5)。此诸区域的公民变作西藏征服的百姓。他们被强迫去著西藏服装及改变生活方式，虽然这些都非其心甘情愿 (注6)。当昙旷撰写其大乘二十二问时，他就是这样的一个顺民。在其序言中他得如此说道：“伏枕边外，驰恋圣颜”。很显然地，当一系列的问题驰送给他时，作者是被待以隆重礼敬。这一部分是因藏王的佛教信仰及操练，而另部分为昙旷是一著名佛学家，他是与几部重要佛学作品如：金刚经及大乘起信论有关的作者或注释者。复次，促使藏王寄出若干问题与昙旷的近因，好像似牵涉及与西藏顿门派及渐门派两者间的教义的分歧，前者代表来自中国的佛教传承，而后者则代表印度佛教。在实际上，藏王曾正式召开辩论会以讨论这些教理。其结果是胜负未定。在不同的时期，两方面皆宣告胜利。这些辩论会大约在西元(780~782)年间举行。关于此，且留待以后再说。
    给昙旷一个机会去解释大乘教理的各种意义，藏王或许期望昙旷的评价是会正确与公平无私，因他非辩论会的参预者。若此为藏王考虑之点，则此论著的重要性是非常大，而他在敦煌佛教的地位应被认为出类拔萃。
    据我们所知，以其卷帙浩繁的疏释，及公开讲演的方式，昙旷对佛学研究的贡献应获得极高的大众钦仰。但不幸的很，实事并不如此。中国大藏经于其殁后数世纪没有收入他的任何一件作品，各朝代的高僧传也没有为他列名作传。若非为了排列在大乘二十二问前面的简序，揭示昙旷是该文的作者，我们会的确不知撰者为谁，因此作品的书目并没有署名。此中的理由或许为：他的许多活动普通是限于靠近敦煌区域之内，而他的作品并没有在京城长安流行。根据他的全部著作是保存在写实，及只在十九世纪的开始(1900)它们才在敦煌石窟被发现的事实看来，在八世纪有刻印的书籍是鲜见的事。
    本研究拟搜寻现存的资料，主要是与他的疏释有关的序、跋、等件，而写一作者简传；去分析大乘二十二问被写成的环境，这自然地牵涉及中国与西藏的宗教与政治情况及其互相关系；去评估昙旷之弘宣大乘教理颇具湛深意义之各方面，及其在敦煌佛学圈内关于佛学研究之可能的影响。其出现次序约略地如上所述。

    二、昙旷的生活与时代
    若以那些有成就的佛学大师，其名字已刊列在各集高僧传里的事例来说，去探知他们的日期与活动是一极简单的事，不幸的事是我们的作者不属于此类。我们要从头开始，及仔细侦察每一断片知识，因而它能使我们建筑起一个他的生活与时代的简单轮廓。这或可帮助我们了解西元八世纪中国的佛教。
    于其大乘百法明门论开宗义决序中 (注7)，昙旷对于其所旅行过的地理区域，及学生时代度过岁月的场所给了我们一引路线。他说：
    余以冥昧，滥承传习。初在本乡攻唯识、俱舍。后游京镐，专起信、金刚。虽不造幽微，而粗知卤亩。及旋归河右，方事弘扬，当侥薄之时，属艰虞之代，慕道者急急于衣食，学者役役于参承。小论小经尚起悬崖之想，大章大疏皆怀绝尔之心。懵三宝于终身，愚四谛于卒寿。余慷兹虚度，慨彼长迷，或补前修之阙文，足成广释，或削古德之繁猥，裁就略章。始在朔方(注8)撰金刚旨赞，次于凉城造起信销文，后于敦煌撰入道次第开决，撰百法论开宗义记。所恐此疏旨夐文幽，学者难究，遂更傍求众义，开决疏文，使失学徒，当成事业。
    此序是作于唐代大历九年 (774)。关于此日期或许有两年的差误。汉文原卷有下列词句：“大历九年，岁在(□子”(注9)。若如此，那应当为大历七年，岁在壬子，西元772。这样第九年应为第七年，因为西元774是岁在甲寅。中文数字“七”与“九”很容易被抄书的人写错。
    关于他的创作生活，及与其当学生时或做作家时有关系的方所，上文给我们一个粗浅的轮廓。他的生活大约可分为三个阶段：一、在他的本乡；二、在首都长安念书做学生；三、回到河右(黄河右边)地区从事传教及写作。提到第一项人们不禁会发问：他是生于何时与何处，或他的本乡在何处？因为没有刊印的疏记可资参考，人们很难确指其所在地及准确时间。但，以研究那些尚存在，虽然是不够充分的资料，我们或许能陈述关于他及其活动的一般概念。在大乘起信论略述书名之下，他自署“建康沙门昙旷撰”(注10)在此书的第一章之末，抄书人作了一行小注说那是于宝应二年(763)在沙州龙兴寺抄写毕(注11)。但宝应(762)年号只流行了一年，上所提及的“二年”，应是错误。 很可能那是著想及763。澄漪为此著作所写的短序，他(昙旷)是被称为“建康沙门”(注12)。这或许意谓昙旷的本乡。这可以与适用于著名翻译家如“敦煌菩萨竺法护”的佛教惯例相比较(注13)。把地名依附于作者，这是唯一的例子，而在其他的场合，他的名字是与寺庙联系起来，诸如“西明寺”等。
    假设建康是昙旷的老家乡，我们将企图探知其方位。根据新唐书地理志甘州张掖郡条下，关于建康有著下列的略述：(注14)
    西北百九十里里，祁连山北，有建康军。证圣元年(695)王孝杰以甘肃二州相距回远，置军。
    如此，可见建康在七世纪之末是一个战略重要的地方，复次，依照昙旷于772，或774所写的序文，简述他的主要成就——他是一位有五种经典以上的注释者。他或许是出生于八世纪最初十年间——从701～710。若我们假设他出生于西元705年，在772他应有六十七岁。但，对于此我们不能确定。基于建康在695已甚为著名，而在772昙旷的若干注疏名单已被纪录的事实，我们或可猜想他可能生存在八十五年的范围之内——从705到790。从另一资料，他揭示于781他尚建在。此是根据大乘百法明门论开宗义记序释(注15)。在772之前的某一时间他为该书作序。后来他觉得该书的烦琐格调及晦涩引证需要解释清楚，否则他的将来的浅学弟子是不能了解其繁难杂错之处。此文是以演讲方式出现(注16)，而他在两三天之内即完成其谈论——辛酉年十二月十二，十三或十四日。这相当于西元781年。不幸的事是原写卷未曾提及此文的题目及作者之名。但其内容与写作风格的确是昙旷的作品。
    关于当其住在本乡时，他所接近的佛学或经典的种类，昙旷曾提及唯识与俱舍。此二者中之第一项一般是指无著Asanga与世亲Vasubandhu的瑜伽宗(Yogaca -ra School)对心识的研究；但在八世纪的初期，特别是与研究那约在公元663年被玄奘大师译成汉文的成唯识论有联系(注17)，该书是根据印度当时弘扬瑜伽师地论(Yogacara-bhumi-sastra) 大专家们的旨意与趋向。那是一种收入各种著名理论，包括戒贤Sila Bhadra的学说，他是玄奘在那烂陀寺时的老师之一的编纂。由于玄奘有才能的弟子及其再传徒众对此书(成唯识论Vijnapti-matrata-siddhi- sastra)作了许多注疏(注18)，有一新派被创立号称法相宗(Tthe school of characteristicsof dharma)。俱舍一名系指世亲的阿毗达摩俱舍论(Abhidharma-kosa-sastra) 约于563～568年为真谛 Paramartha第一次译成汉文(注19)。 那是处理心之范畴及作用，共有七十五法(75 elements of dharmay)之多。因其为世亲的早期著作之一，它是被列入小乘典籍。在大体上，此论于中国佛教学者间是甚为流行。任何人研究具有大乘性的“唯识”，也同时研习如阿毗达磨俱舍论所说的心理分析。据记载，于其赴印之前，玄奘曾在长安大觉寺从一位岳法师学俱舍论(注20)。于其归返中国之后，他再翻译了该书及阿毗达磨俱舍颂(Abhidharma-kosa-sastra)(注21)使其生徒获得利益。由于此二书有某种相同处，一为纲要，另一为深邃；如果两者同时并习，那是有很大利益的。
    因建康去京城并不很远，人们对瑜伽哲学研究的兴趣似很强。这样，昙旷获得被传授以相宗的奥义的机会。结果，奠下了他成为一位大注释家的基础。
    关于他的游历到唐代首都长安，他并未说明其师为谁，所住何处，住留时间，抵达与离去该城的日期，以及其他细节。他只说及他的专长是在金刚经(Vajraccedhika)及大乘起信论(注22)。这对他的高深佛学训练并未能给我们一个足够的线索。但是，从其某些著作及流行于当时的趋势，我们有理由相信他为什么喜好这些经典而舍弃其他。
    假设他是生于西元705，他赴京城求学的时间，应约在730～735之间，当他是25～30的年岁。他所住的地方，很可能有许多年，应是西明寺，它为首要佛学研究学府之一.。这是于其四种著述中昙旷自己所透露的(注23)。在每一题目下，有下列的署款：“京西明道场沙门昙旷撰 。”此西明寺学府系经唐高宗的御旨为其太子建于显庆三年(西元658)(注24)。玄奘是被邀请去充任首任住持，并给以十位上座僧为其助手(注25)。很显然地，玄奘在该处并未住留很久，在其后的短时期内，他又被高宗请其移居玉华寺为了去翻译那卷帙繁多的大般若波罗密多经(注26)。从其创始，该寺中的若干居住者均是著名的学者，讲道者及作家。下列的少数举例将证实此主张：
    (1)圆测——约在660～663之间，当玄奘译毕其成唯识论时他秘密地为其最得意的弟子窥基阐释其奥义(注27)。但西明寺的圆测因贿赂奘公的侍者，潜藏在屋内，不为演讲者发现而窃听此诸演讲。后来他公开宣讲此经的新义给其本寺的同人(注28)。这样，他比法相宗开山祖的高足窥基捷足先登。于683～685(高宗之末，天后之初)年间他被选入译经馆协助翻译大乘显识论(注29)。最后他编辑唯识疏钞。不幸此书是早被遗失。宋高僧传的作者对其祖先来源不大肯定(注30)。但欧阳竟无在其南京版成唯识论序言中声称他有著高丽关系(注31)，虽然他并未出经典上的引证。如此，圆测负担起了教授职责，在西明寺传授唯识宗精微的教义。
    (2)道宣——另一位杰出的学者及早期西明寺的居住者是道宣。他安居此寺的时间是西元658～659，刚建筑完毕之后(注32)。他被皇帝聘为上座藉以襄助玄奘的翻译工作。在其若干著作中，他的续高僧传三十卷应被认为是关于中国佛教历史卓越的作品之一(注33)。但是，他的主要兴趣及专注是四分律(Dharmagupta Vinaya)的研究。除了其他写作之外，他在此幅员内有十种著作以上(注34)。他是被认为南山律宗的初祖。关于作者的称号，其措词为“大唐西明寺沙门释道宣撰”。此种格式与昙旷所用的足相比较。
    据说道宣律师的盛名远被印度，随之而去的是西明寺的雅誉。此为于玄宗统治期内(713～775)到达长安的善无畏(Subhkara)三藏法师所证明(注35)。他表示他很希望到西明寺去安居，因其与道宣之严守戒条有连带关系。附注于此者为道宣于667去世。
    (3)道世——另一位学者与律师，因皇帝的要求而与道宣同时(659)居住在西明寺者为道世。他的贡献为编纂名叫法苑珠林，分为百类的佛学辞典(注36)。此书使他工作了十年，于西元668始完成。此外，他写了金刚经集注三卷，及关于戒律与禅定的作品(注37)。
    (4)慧琳——约在西明寺落成的一百三十年之后，慧琳是不空(Amoghavajra) (注38)弟子，原籍疏勒(Kashgar)表现了他在华梵语言及语音学的专长。若干世纪以来许多佛典被从梵文译成汉文，而若干实例是涉及音译。此际，一种用以来解释那从未见于中国传统文学的奇怪术语的字汇是甚为迫切需要。慧琳的贡献始满足此项需求。他从788—810(注39)，费去了二十二年的时间去完成那一百卷号称为一切经音义的字典(注40)，此书是存放在西明寺图书馆内，甚为全京城人士所钦羡。他于815去世享年八十有四。后来于显德中(954—959)高丽国王遣使请抄写此字典一部以便该国佛教徒众使用(注41)。
    上列各位学者除第四慧琳外，余者均早于昙旷数十年，住在西明寺内。从玄奘开始——最大的学者与翻译家，余者均为戒律，佛教史、语言学、哲学，辞典与注疏编辑者的专家。从西元658开始其生存，迄于815道宣去世之一百五十余年间，西明寺负起了佛学中心的责任，并培植了许多卓越学者。当昙旷旅行到首都时，他颇为该寺的盛名所诱引。既为该道场的共住同人，他被授以研究瑜伽师地论(Yogacarya-Bhumi-Sastra)哲学的方法。后来他作了许多与此论有关的典籍的疏释。他的训练与热忱促使他达到一位学者的极大成就。
    从另一资料，也证实西明寺是一学术中心。据说该寺拥有在京城两个最华丽的讲堂之一。那是用香泥筑成，而深度颇巨。其另一能与此相比的是崇福寺(注42)。除此讲堂外，它并为翻译梵典的场所。据良秀传，他是另一居住西明寺的同人，据说他被皇帝任命去与迦湿弥罗的般若共同译大乘理趣六般若蜜多经为汉文(注43)。此工作完成于贞元五年(西元789)。后来他对此经作一疏释(注44)。在某种情况下，我们或可以说，在当时，西明寺是中国的那烂陀大学。
    追溯那促使他在西明寺去专攻金刚经及大乘起信论的主因，那好像是当时佛教徒众，从皇帝开始，对它们的热忱，给了他以深厚的撞击。道氤传(注45)告诉我们说唐玄宗于开元二十三年(735)对金刚经作了一御注浅释。于此作品进行之际，皇帝曾屡次向他请教。于完毕之后，他特命他(道氤)去为该注作一包容丰丰富的疏释，其名曰：御注金刚般若波罗密多经宣演。那是一相当长的作品，共二卷，约六万三千五百字。该书不曾被收入于传统的中国大藏经，但很幸运地是被保存在敦煌石窟写卷内，而现在已被列入于大正藏(注46)。据说此御注金刚经是“刊勒金石”而流布于中国各地(注47)。若我们相信此记载，那意谓金刚经于一般民众是非常普及。
    除了为金刚经的注释者外，道氤并为成唯识论及妙法莲华经作疏解。附加于此的为他甚专精于瑜伽师地论，成唯识论，百论及因明等佛典(注48)。大约在此时(西元735)昙旷安居在西明寺。因秉性聪明及观察锐敏，他了解当时佛学研究的动向。他在稍后所作的若干疏释，很可能是深受于740去世的道氤，及其他诸师的影响(注49)。
    另一典籍为昙旷所专攻的是大乘起信论(Mahayana-Sraddhotapada-Sastra) 。据说那是马鸣(Asvaghosa)著，于西元550第一次被真谛(Pararartha)译为汉文(注50)，而于700被实叉难陀(Siksananda)重译。不过，现代的中日学者对其确实性发生疑惑，并倾向于暗示那是一位中国学者的作品(注51)。唐代初期于适用的疏释中法藏所作的大乘起信论义记，及大乘起信论义记别解(注52)甚引起昙旷的热心去专攻于此，而他应从彼获得利益。对于此我们将以后再说。
    可附带提及的为法藏是华严(Avatamsaka)宗的第三祖，一部份时间他曾参加玄奘的译场。他也是实叉难陀(Siksananda)的译经助手。他于先天元年(713)在洛阳去世(注53)。
    上列观察可供给我们一个粗疏轮廓关于昙旷在西明寺修学的背景，当时的佛教文化活动及几位著名大师及其贡献；他们或许直接与间接地影响了他。此诸影响是反映在他的注疏中，尤其是在他之选择那属于或与法相宗(Dharma-laksana School)有密切关系的经典。

    三、政局波动及其归去
    关于他在首都居留的时限，及何时归返故乡，我们不曾发现任何引证。根据他的大乘百法明门论开宗义决的序(大正藏：二八一二号)，他之弘扬佛教及宣讲工作开始于其回到“河右”之后。此名词与“河西”相同。为了熟知其方所，先介绍此区域的地理形势。
    河右区域是位于黄河的西边，现时包括绥远，陕西，宁夏及甘肃各省。它也被称为“河西”。甘肃省的西北曾叫做“甘肃河西”，或“河西走廊”，因为从汉(西元前206至西元220)及唐(618~907)它成为赴中亚与印度的“公路”。在其南为终年积雪的祁连山，在其北为北山；而在北山之北是那经常将干燥风沙吹向“走廊”的蒙古沙漠。除了少数城邑以外，一般是欠缺流水与湿润去作耕种之用。少数幸运的城邑包括张掖(昙旷的本乡)，甘州，武威，凉州(注54)及敦煌(注55)。于其归返河西地区以后，这些是与其写作活动有关的一些地方，并被昙旷所提及。
    我们或许会询问他在何时及为什么离去首都而回到他的本乡？西元755唐玄宗统治期内之政局骚动于其作品中颇有含蓄的暗示。此为安禄山与史思明之乱(注56)。反叛者的势力变得凶猛非常，唐明皇逼得放弃其长安与洛阳两个京城而逃奔西蜀。于此历程中皇帝的爱妃杨太真被逼令自缢于马嵬驿，而伊兄，宰相杨国忠也被处以极刑。由于他们的无数罪恶及皇帝的错误判断招致其政府的沦亡。从755到763全国陷入于全然毁灭，成千成万的人民遭杀戮，骨肉遭分离而房产也遭毁坏。食物非常欠缺，一只老鼠值四千文(注57)，而另一位将军得牺牲他的爱妾，藉充饥饿士兵的食品(注58)。若干省份，包括河右(黄河以西)均被叛贼沦陷。两个京城遭害更烈：“时洛阳四面，数百里州县皆为丘墟”(注59)。“长安大扰，官吏窜匿，狱囚自出。”(注60)后来一部份是由于从新疆来的军事援助，唐朝当局于763平乱及收复失去的省份与城邑。
    关于上列种种，昙旷在其百法明门论开宗义决序言中(大正：二八一二)只轻描淡写地说道：
    当侥薄之时，属艰虞之代，慕道者急急于衣食(注61)……。
    我们的理解是昙旷可能于755左右，叛变发生之年，尚住在长安。于755之后因生活艰难及毁灭，他不能在该处居留。结果他逃亡到安全地带，藉能继续其在文学上及宗教方面的活动。他之决心离开京城，颇为秉恩(注62)，另一位西明寺的同人，因叛变于天宝之末(755)离去长安赴姑臧(现甘肃武威县)有可参照之处。在其新的住所，他(昙旷)再编著了百法明门论注释(Commentary and Notes on the Sata Dharma Sastra)。后来昙旷对此作了同样的研究。

    四、他的写作生活
    于其归返河西以后，昙旷不曾回到长安，他去到朔方(现甘肃灵武)，凉州(现甘肃武威)及敦煌。在上列地点他编著了下面的疏释：
    1、金刚般若经旨赞——此是根据大英博物馆斯坦因所搜集的二卷，43页，其编号为S.二七四四及S.二七八二(大正：二七三五号卷八五，66～109页)，共有六六五五○字，对金刚经的教理作了分析解释。其书末之跋表示于广德二年(764)普遵在沙州龙兴寺将其抄写下来(注63)。此作品是在朔方写成，署有：“京西明寺道场沙门昙旷撰”。该件的完成期应在西元756及764年间。那即是说，于764是无法去抄写，若非已在该时期之前完成。
    2、大乘起信论广释(注64)——此是基于斯坦因所藏的S.二五五四及S二六七号共五卷(大正：二八一四号)。不幸者为最初两卷早被散失。现存的三卷约为七五四○○字，五三页；书跋揭示那是在大历八年(772)为齐奉道抄写出来(注65)。此著作的完成日期应置于763之前，因为昙旷于762或763写毕他的大乘起信论略述(注66)。与“广释”相对照那只是一个“概要”。抑有进者，澄漪沙门为“略述”所作的序文曾提及昙旷“先造广释”(注67)。这即是说“略述”是属于稍晚时期。我们相信它之完成应在761左右。
    3、大乘起信论略述——(大正：二八一三号)这是根据伯希和及斯坦因所藏的伯，二一四一号及斯，二四三六号，两卷，三三页，四八八○○字。澄漪为之作了一篇短序，意在说明其宗旨。他解释说“广释”或将使初学者惊惧。他们或许觉得面临“崇崖”，有“难于上青天”之感(注68)。这是简化本，但包含“广释”中的所有重要原素。略一改变作风，作者的题名是被署以“建康沙门昙旷撰”。在第一卷末书跋有“宝应二载九月初于沙州龙兴寺写讫”(注69)宝应元年即西元762。因宝应并没有第二年，那意在指示763，甚至762。此书跋可能是作者或抄书人的小注。若我们接受此二者中的后者，则此书的完成当更早于西元762。但昙旷并不曾在其大乘百法明门论开宗义决序言中提到此书。
    4、大乘入道次第开决——(注70)(大正：二八二三号)此是基于伯希和及斯坦因所藏的伯，二二○号及斯，二四六三号。因此卷残缺不全，我们无法决定其全部份量。现存之书有十六页，约二三六六○字，是智周的大乘入道次第的注释(注71)，书前有一小序，不载日期，很可能是作于763与773年间。此书是在敦煌完成，其署款为“京西明寺道场沙门昙旷撰”。
    5、大乘百法明门论开宗义记——(注72)(大正：二八一○号)此是根据伯希与斯坦因所藏的伯、一八○，伯、二一六一及斯、一九二三与斯、二○五一号。它只有一卷，二十页，二四九八○字。此为对世亲所著的大乘百法明门论(注73)(Mahayana-Sata-dharma-Prakasa-mukha-Sasra)的注释，被玄奘译成汉文。无疑地这是瑜伽宗(Yogacara school)最重要典籍之一。此作品有一相当长的序，不载年月。根据他的大乘百法明门论开宗义决的序，是在敦煌写出，其成书时期应在西元774前之某一时间。
    6、大乘百法明门论西开宗义决——(注74)(大正：二八一二号)这是基于伯希和与斯坦因的伯、二○七七，伯、二五七六及斯、二七二○与斯二七三二号。它只有一卷，二十页，约二九五○○字。这是对他自己的百法明门论开宗义记的注解，而该书又是对百法论(Sata-dharma-Sastra)的注释。此作品的短序对我们是极端重要，因其给了一个对其创作生活及其作品大约时期的概略。此书是写于大历九年，即西元774。但是，好像有一相差两年的小错误。我们已在“昙旷的生活与时代”中解释其可能的情况及其在计算方面的影响(注75)。
    下面两种作品是未曾被包括在百法明门论开宗义决的序里，但第七号与第五号“开宗义记”有密切的联系。
    7、大乘百法明门论开宗义记序释——(注76)(大正：二八一一号)此是基于斯坦因所藏的斯、一三一三号。它只有两页半。作者之名与题目均未被提及。它们是被编者添入。显然地这是昙旷自己在其晚年所作的解释。卷末的短跋说：“辛酉年十二月十三日了。”此辛酉年即西元781。此解说工作似费了三天的工夫。因在此文的中节写著：“辛酉年十二月十二日了”。因此为昙旷晚年作品之一，那暗示于西元781他尚生存著。
    8、大乘二十二问——(注77)这是他的最后著作，是关于佛教教义最重要的典籍之一。于此昙旷彰显了彼为一佛学专家的博学卓识及努力解答很困难的问题。与其在典籍方面的注释相比较，此则颇富于创造性。为了关怀及此超越的文学作品，我们努力去描绘此作家的写作活动，及追溯在某种环境之下它们得以产生。我们觉得那些与创造作品有联系的事实成为中国佛教史上最富兴趣的一章。

    五、关于大乘二十二问之写卷
    呈现于吾人之前的著作是根据三个现存写卷，即伯希和所藏的伯、二六九○与伯、二二八七及斯坦因所藏的斯、二六七四号经编辑校对而成。可注意者为每一写卷都不完整并有许多残缺。举例说，斯、二○七四缺卷首，伯、二六九○缺卷尾，而伯、二二八在卷首漏去若干页。此外，有不少地方我们发现一大段缺漏，误写，白字(别字)及其他错误，可说没有例外。将各卷仔细对照及校正之后，我们始将正确的语句及段节录下。在我们的面前基于三个旧本子而有一个新本子，但与它们三者均不同。我们或可声称有新本子是百分之九十九与最初原稿相近。
    以斯、二七四作底本(缺序及第一问的大部份)，此著作是被收入大正藏二八一八号。但并未提及与伯希和所藏各卷的编号(注78)。此新本约计一三○○○字附以将近四百小注及解释。此汉文写卷将附以英文翻译。不过，其英文译稿将不在此发表。
    在斯、二六七四号卷末之书跋揭示该卷于丁卯年为比丘法灯抄出。此年即西元787。这不是说昙旷在该年写成此作品。但那意谓该书是在787之前完成。为获取一适当日期，我们应该了解促使此写作的情况。我们渴欲知道谁，及为什么提出这些问题？昙旷在其序言中说：
    伏枕边外，驰恋圣颜。
    给了我们一个线索。
    那好像是将问题寄送给昙旷者是一极有权威的人，与一帝王相似。在此际我们的作者似已老耄，衰弱，患病及卧倒床榻。他是住在敦煌的一间寺庙里，并说那是“边外”。若我们假设在782左右唐朝的御旨降书信与他，那是不可能之事。第一、除了早期唐代的皇帝如太宗(627～649)，玄宗(713～755)对佛教表示兴趣外，其后裔并不以虔诚的佛教徒著称，而在深奥的佛教哲学学者方面则更少。在西元755到763年之间因唐代政府大遭破裂，及深被卷入平息安禄山与史思明的反叛，他们没有机会去追求宗教方面的事。于此内乱的同一时期，从西元640起，西藏发动了若干次的侵袭，攻击，陷落，洗劫陇右与河西，及靠近敦煌的许多城邑，这促使中国在军事与经济上的严重消耗(注79)。受害最烈的为敦煌的邻近地区，它被西藏军队沦陷并被藏人统治达八十六年以上(约从762～848)。只于848～851年间，敦煌本地爱国领袖张义潮(注80)把藏人驱逐出境，并将十一州，包括瓜州与沙州的版图及政权交还给唐天子。既然如此，很显然地，昙旷序言中所提及的“圣颜”是意谓西藏国王。这很自然地引起我们的好奇心，我们亟欲知道藏王对佛教哲学问题注意的原因所在。是否因为关于西藏佛教教理方面有问题？或是他不能决定两个敌对派的主张，因而将其质诸一位在敦煌有名望与博学的，且居于中立地位的佛学家？如果我们的假设正确，我们应当指示提出这些问题的是那一位藏王。同时我们认为对早期的藏王及其与唐朝关系作一素描甚为需要。

    六、西藏与唐朝
    从政治与军事观点上看，西藏于七世纪突起为一强权是很不平凡。在种族上他们是属于羌族。于太宗八年(西元634)始第一次遣使赴唐宫廷请婚，有二十万军队作其后援。其来使明白宣称，若此请遭拒绝，则藏军将攻击松州(现四川松潘县)并深入唐帝国。此威胁遭受了很坚强的军事拒绝，藏军被逼迫退出。于西元641藏王以黄金五千两及宝石等作为礼物重申前议。为了外交作用，唐帝室以宗女文成公主下嫁。此藏王之名为松赞冈保(注81)Srong-brtsan-sgam-po享寿约五十年，于西元650(永徽初)去世。据传说，早期他曾与一位尼泊尔公主结婚。(注82)很凑巧，这两位公主都是佛教徒。因她们的影响佛教得以传入西藏。从此以后，佛像、精舍、塔寺被建造，佛经被翻译，印度法师被邀请入藏弘宣佛法，以及他种活动。(注83)无数世纪以来因西藏有其固有本地宗教——本(Bon)教的信仰与行持，(注84)在开始时佛教的进展好像很缓慢。由于藏王对此新宗教的热忱，在其朝中的许多臣僚与贵族应表现出一些表面上的容忍，即使那并非是他们自己的喜好，这种假设应是近乎情理。当松赞冈保既已奠好基础，其逐渐发展及使西藏变成一佛教国的最后成功是走上了正轨，虽然时时有阻挠与反对发生。
    由于中国与印度有高度的文明，除宗教外，其对西藏的文化撞击很大。藏王采取了若干新的措施，诸如穿中国丝织品，禁止人民以红色涂面，派遣学生赴中国研习五经，请求以中国文学，养蚕、榨油、酿酒、音乐师及其他技术人员作为礼物(注85)当两位公主以新妇身份到达该地时这些物品与工艺是被传入。其中的第二位公主叫做金城公主于西元709～710下嫁给尺带珠丹王King Khri-Ide-gtsug-brtsan(注86)(他们的儿子赤松带赞Trhi-song-de-tsen)(注87)为西藏佛法最大护持者之一。西藏传袭说他于庚午年，即西元730年生于红岩(注88)。又说他的母亲中国公主(金城公主)去世时他正好五岁。新唐书表示她于开元二十七年(西元739)辞世(注89)。如此，则少年王子遭母丧应在九岁左右。根据史烈格罗Snell-grove及杜吉Tucci的推算，赤松带赞的生年为西元742(注90)。这好像不能接受，如我们考虑到他是金城公主的儿子，而伊又于西元739逝世。
    关于此藏王的生年有十二年的差异，这终会影响到西藏佛教辩论的日期。关于此点，将来再讨论之。
    从西元641到851，约二百一十年的时间，中国与西藏的关系是一系列的战争，对抗，胜利，失败，猜疑及暂时联盟，虽然说唐天子与藏王有著甥舅关系。每有机会到来，藏王及其将领无丝毫踌蹰去侵袭中国边境州县及洗劫城邑。有时他们遭受严重损失，数以万计的兵士死于战场。但是，在短时期内，他们鼓其勇气以同样的战略及军事行动再来侵犯。他们实力的举例可以从新唐书的数字推知。该书说于西元740藏人以四十万军队进攻承风堡及其他地方(注91)；于西元742，三万藏军被斩首(注92)。即使在西元740之前，当金城公主尚在世之日，藏王的作风很不谦逊，他要求与唐天子有同等地位。这激起唐天子的震怒，而拒绝去接见其来使(注93)。在大体上，一切诺言，庄重盟会，和平条约及婚姻同盟等西藏人认为是方便法门。这或许是为了文化与伦理价值差殊的缘故。从实利主义的观点看来，西藏人在该时是最好的外交家。
    从军事的观点来说，我们应当承认西藏人有很好的组织，训练，勇猛，熟于战术及善能适应困难。在中国史上应值得铭记的一件事是当中国遭受内患之际，藏军于西元764攻陷首都长安并作了下列之事(注94)。他们建立皇室中某一人为新天子，改年号，大赦天下囚犯，聘任臣僚百官等等。这是西藏军权极大的成就，虽然京城被占领只有十五日之久。当中国正匆忙地对抗叛变与经济问题，藏人大胆地去混水摸鱼。

    七、西藏佛教与赤松带赞
    在藏王中赤松带赞以迎请印度有名高僧赴藏弘宣各种佛教，诸如寂护Santa- rakshita莲花生Padmasambhava及莲花戒Kamalasila等，对佛教的弘传贡献最多。佛典被印度的无垢友Vimalamitra，及迦湿弥罗的阿难陀译为藏文。在寂护的指导之下，七名西藏沙弥受戒，因而西藏僧团Sangha获得初次建立。学生被派遣赴印学习声明。与其他窣堵波Stupa及宫室同时兴工的，他建造了著名的桑耶寺bsam yas monastery并费了十二年(开始与完毕均在卯年——西元763～775)的工夫始告完成(注95)。此外，那著名的中印佛教高僧辩论会也是此王发起的。若我们说松赞冈保是负责七世纪时将佛教传入西藏，而赤松带赞王应是于八世纪时西藏佛教最大的弘扬者，此或许是一客观估计。没有他们的专一热忱及继续努力，其后若干世纪西藏佛教的情况是不会一样的。
    关于此王的日期史烈格罗将其置于740～792之间，或说他生于742(注96)。但一些西藏史料并不同意此说。西藏王统记声称他是尺带珠丹与金城公主的儿子(注97)。当西元739其母去世时赤松带赞恰好五岁。依此说法他是生于734。但这与该书另一说，即是他生于庚午(西元730)有抵触之处。(注98)复次，那与其逝世日期也不完全相同。它说他死于乙丑年(785)，享年五十二岁。(注99)依此，他之生年应为733。戴密微鉴定新唐书里的乞立赞Ki-li-bcan是赤松带赞Khri-srong-Ide-tsan(注100)的简写。此王为唐德宗(779～804)的同时人，于贞元十三年(797)去世。另外，西藏历史家布敦Bu-ston说他于六十九岁时逝世(注101)。若我们接受他于797去世之中国日期，那意谓他是生于西元728。与西藏王统记所载他死于五十二岁相对比，则此地增加了十七年。基于上列各项，他的去世日期共有四种说法：728，730，733，734。因各种典籍相差的距离很大，我们不能决定他何时出生，但其西元797的死期似可接受。


大乘二十二问之研究

大乘二十二问之研究

巴宙(美国爱渥华大学宗教学院教授)
中华佛学学报第二期(1988.10月出版)页65-108

    八、佛教辩论与藏王的任务
    因佛教是在西元七世纪于藏王松赞冈保统治时期从中国与印度传入西藏，很自然地，经常有中国佛教徒传教士到该处弘宣中国式的佛教，著重在“顿悟”。此为当时的趋势，尤其是禅宗。在另方面，印度高僧传授传统的佛学与行持也被请赴该地。其中著名的为寂护，莲花戒与莲花生。在最初，此诸佛教学派精微的分别不很显著，但为时既久则磨擦渐生，甚至使得藏王发起正式辩论会。此辩论会的主要作用为决定顿门派是否优于渐门派，或者渐门派优于顿门派。两方面的代表为莲花戒来自印度，大乘和尚来自中国。这是西藏佛教史上一大事件，数种藏文典籍如布敦作于西元1323的印度与西藏佛教史(Bu-ston,A History of Buddhism)及于1955被译成汉文的西藏王统记都有详细记载。另一来自敦煌石窟的典籍叫做“顿悟大乘正理决”(注102)，其卷首序文曾提及此事，但对此课题作了不同的描述。那即是说它把传统性的失败事实转变为胜利。此次，印度诸师遭受了失败。近年来，欧洲学者对此事颇为注意，如法国汉学家戴密微Paul Demievile刊行了他的“拉萨结集”(注103))(Le Concil de Lhasa)。同样地，在下列学者的作品中如杜吉Tucci史烈格罗Snell-grove瓦德Warder及斯坦因Stein等都有显著的详载(注104)。日本学者中，上山大竣所写的“昙旷与敦煌佛教学”一文中也提到此辩论会(注105)。藏文典籍表示那是在赤松带赞王统治时期举行。其开会地点，依照杜吉是在桑耶 (注106)bsam Yas以代替戴密微所提拟的拉萨。关于开会日期戴密微认为于西元792～794年之间(注107)，杜吉赞同此说(注108)。支持杜吉的辩论为于西元八九世纪时西藏的文化与宗教中心是“在亚珑Yar Klun古时的宫殿与王冢均设置于此；或在朗玛Bragmar(dmar)略近桑耶bsam Yas的北部”(注109)。于此时际的西藏历史，我们深以为桑耶较拉萨为可接受。
    关于辩论会日期，坚强的证据指示那是在西元781，或780～782之间举行，并不如戴密微所提拟的792～794年。此为顿悟大乘正理决的序言所实证(注110)。此书的作者声称当沙州(包括敦煌)被藏兵沦陷，藏王(赞普)邀请大乘摩诃衍赴藏弘宣禅法。当其抵达逻娑(拉萨Lhasa)时许多人从其询问禅法。沙州被沦陷的日期，根据中国文献，诸如元和郡县志及西域水道记是“沙州以建中二年(781)陷蕃”(注111)。很可能，在781早期的数月辩论会不曾举行，虽然印度的学者及摩诃衍(Mahayana)均被迎请赴藏。但那被窒塞不和睦的火焰已埋伏了很久。于此时期始决然爆发。若干年以前寂护所说的预言是一肯定的表示。(注112)正理决的序言告诉我们说：于申年(780)的开始摩诃衍才被通知以婆罗门僧的控诉，大意为中国诸师所传的“顿悟”不是佛陀的教言，因此，应被禁止(注113)。此消息是被藏王亲自转达给摩诃衍。结果他向藏王建议将问题以写出的方式请与小乘论议。印度诸师“以月系年，披索经义，屡奏问目，务掇瑕疵”。后来，双方对立互相问难。摩诃衍和尚以适宜的答辩能防卫其立论。印度僧遭受失败：“随言屈理，约义词穷”。但他们心有不甘，“遂复眩惑大臣，谋结朋党，毁谤禅法”。摩诃衍一部份的西藏弟子为了抗议这种行动，以下列方法自杀：
    或头燃炽火，或身解霜刀……吾等请尽脱袈裟，委命沟壑。
    其结果则为：
    至戌年正月十五日大宣诏命曰：“摩诃衍所开禅义，畅究经文，一无差错。从今以后，任道俗依修习。”
    上列概略是中国文献关于辩论会的说法。那只提及一方面的故事，或许不是全部真理。摩诃衍弟子的自杀行动很令人疑惑。如果该派确实获得胜利，则该项举动是一点也不需要。此种记载的重要性是在其指出于西元781中国与印度有关人士间曾在西藏举行辩论。或许，禅门遭受失败，并在该年暂时被停止活动。但在西元782，禁止令被正式取消。附带提及的，此正理决序文的作者王锡是“前河西视察判官，朝散大夫，殿中侍御史。”他被摩诃衍亲自邀请去作序一篇并给一个书名：
    小子非才，大师徐谓锡曰：“公文墨者，其所问答，颇为题目，并制叙(序)焉。”因目为：《顿悟大乘正理决》(注114)。
    想去知道另一方面的故事，布敦给予我们一个生动的报告， 那是关于促成此辩论的因由，开会的主要人物及重要争点(注115) 。寂护的弟子遵奉传统的佛教及行持。那或为一切有部(Sarvastivadin)(注116)与中观(Madhyamika)教理的综合物。因此他们是被称为渐门派(Gradual method)(注117)这与中国禅宗有关的顿门派迥然不同(注118)。以大乘和尚为首的顿门派似乎是很普及，连一位皇后也出家修道：
    皇后没卢氏剃除绀发，披挂缁衣。(注119)
    为了向王家争宠，印度诸师觉得佛教发源于印度，彼等之教理是“真纯”，而顿门派所说应被认为“邪说”。一个正式辩论会的请求应当是合乎规则。其结果为中国人方面大受挫折。大乘和尚被命令向其敌人奉献花环，那是失败者的象征。稍后他被驱逐出境，而习禅也被禁止(注120)。辩论会的胜利者为寂护Santarakshita的弟子莲花戒Kamalasila来自印度。他与和尚(Hva-san)为辩论会的主要参予人物，虽然布敦的名单尚有其他两人：吉祥音Srighosa与智慧因陀罗Jnanendra他们也发言去拥护印度的立场(注121)。和尚的一群弟子包括柯麻麻Co-ma-ma觉得深受羞辱。“据传说他们以巨石撞击其身，遂死”(注122)。
    关于和尚弟子们的死去，上面的引证几乎与中文方面的说法完全相同。从印藏方面的陈述，我们获知他的徒众自杀的原因。中文说法好像隐藏了议论失败的事实。这样，它不能使我们相信其胜利的主张。
    关于此辩论会的进行程序，我们将从布敦所写的历史引证下列一段：(注123)
    其后莲花戒法师到来。国王坐在中间，大乘和尚在其右，而莲花戒在其左边。渐派的徒众环列，藉以形成莲花戒的侍从。国王将花环给与两位首领后，说道：“你们两位主持争论。失败者一定要向胜利者献花环，且不许居留此地！”
    当结果被揭晓后，藏王执行了他的决定：驱逐大乘和尚出藏并禁止习禅及阐扬(注124)。这一部份为正理决的序言所证实(注125)。该文提及于戌年(西元782)禅教重新建立。这是否可靠，无法确知﹞韖C的私人名字并不多见，但是被允许的。那提示，与小乘传袭相较他是代表大乘教义。换言之，“和尚”，或“摩诃衍”简单地是指“大乘师”。在如此情况之下，那位参加辩论的中国法师的真名仍是“未可知也”。

    九、赤松带赞与昙旷
    我们努力于决定中印辩论的日期是想发现在大乘二十二问的作者昙旷与一位藏王间是否有任何关系。因沙州是于西元781被西藏攻陷，并在同年摩诃衍或和尚于桑耶(bsam Yas)在一辩论会上遭受失败，若我们提议赤松带赞王Khri-srong- Ide-tsan为向昙旷提出二十二问者，那是会站在巩固的基础上。从西元763年起，昙旷是住在敦煌(沙州所属区之一)，而他的许多注疏与作品都是在沙州龙兴寺撰述或被人抄写，此事前已提及。在这一部份的中国，他是一位有名的佛学家，应是远近皆知。既为一位虔诚的佛徒，但不识佛教哲学的精微处，赤松带赞王，或许对那代表大乘与小乘教义的顿门与渐门的孰优孰劣有所犹豫。的确，他曾宣布莲花戒Kama-lasila为辩论的胜利者，但这并没有阻止他向一位与辩论会无关的第三者请教。从西元781年起沙州为西藏的征服地，向住在该处地一位佛学家咨询教理，好像是合乎情理。藏王送给昙旷一纸列陈二十二个问题，而他对每个问题都给以适当的回答。此通讯的结果为大乘二十二问，我们研究的题目。
    不幸的是，除了下列两处的用词，在昙旷为“二十二问”所作的短序中，我们并不曾发现藏王的名字：
    伏枕边外，驰恋圣颜；
    所惧不契圣情，乖于本旨。
    基于这些证据，无疑地他是称呼王族，其地位不卑于国王或皇帝。是否他向唐天子致其答词？那是极不可能的。第一，此际的唐天子为德宗(780～804)，他并不以对佛学研究有特别兴趣著名。第二，在其统治的第二年(建中二年，西元781)藏兵攻陷沙州及其附近区域，包括敦煌。以实际作用来说，该处应被认为敌人领土。即使他是一位佛学家，也没有理由去促使他特别向住在敦煌的昙旷请教及答覆他的问题。昙旷之名未被各集高僧传收录，在当时的佛教圈子里，他全然是无实体(non-entity)。换言之，对住在敦煌区外的人来说，他近似一种“谁是昙旷？”如此，则“圣颜”一词一定是与西藏国王有关。在西元781左右除赤松带赞王以外，西藏无其他国王。这并不是说昙旷与此国王两相认识。但是，不可否认的事实为在赤松带赞与昙旷间，他们曾互通消息，而“大乘二十二问”即其实证。

    十、辩论会与问答中的争点之比较
    为了实证我们的理论，将在桑耶召开的辩论会的主要问题及在二十二问中的重要题目一比较研究，那或许是很有益的。依照布敦，大乘和尚在辩论会上作了下列的提议(注129)：
    一、善业或恶业将招致受生于善趣或恶趣。
    二、此诸业行(善或恶)将不能帮助任何人出离轮回。
    三、任何人遵行无念能出离轮回。
    四、无念能成就个别实体的真理的无所知(non-perception)。
    五、住于真理无所知的境界中(A state of non-perception)，他能立即成佛道 (To attain Buddhahoodinstantaneously)。
    六、菩萨已证取第十地(The tenth stage)。
    莲花戒Kamalasila及其两位弟子对上列提议的反对是集中在下列五项：
    甲、“无念”的学说意谓去拒绝最高的分别智慧。那不是积极的，正如一人晕倒或饮酒致醉。如此，他将不会有非实体的识认，也不能消除障碍。同时他亦不能根绝爱缠。
    乙、有了最高的智慧他可以成佛。这意谓观想及分别。
    丙、立即成佛是不可能，正如一人爬山，他要一步一步的走。
    丁、当经过十地(Ten stages)的渐修，用十善业(Tenvirtues)他可以成佛(注130)。
    戊、于佛去世以后，历时久远，其教理不曾有离异。
    从大乘二十二问中录取的下列各点或能反映及在辩论会上所激起的争点。当然，有些后来添入的题目那在辩论会时未被包括进去：
    1、在第三问里修身，口，意的次序在第一问里众生消灭烦恼的方法，或许反映到“一”项。
    2、在第十二与第十六问关于三乘的初发心及其如何进行的回答，反映及“二”项与“三”项里所提及的轮回(Samsara)。
    3、在第九问关于十地中的菩萨是无念，无相，及第二问的内心寂照反映到“四”，“五”，“六”及“丁”各项。
    4、在第十四问里大乘教义：智慧与方便两者携手并行，及第十五问里的三乘与六尘境的关系，反映到“甲”项。
    5、在第二十二问里于佛去世之后僧团分为四派，反映到“戊”项。
    6、在第十问里菩萨具修诸解脱门反映到“二”项。
    扼要言之，若干争点在辩论会上所激起的关怀，大多是反映到大乘二十二问的问题里。那是集中在三乘，其宗教行持，及涅槃或佛果的最终目标。那对摩诃衍所拥护的“顿悟成佛”或“顿门”则置之不理。基于上列观察，显然地，赤松带赞王一定是将此二十二问题驰送给昙旷。通讯的日期尚未决定，但一定是在该王于西元797去世之前举行的。很可能那是在781或782，刚在辩论会之后。赞成此较早的日期的理由是藏王亟欲从住在敦煌的一位有名学者，且是第三者去解释若干论点。于此时期，昙旷是卧病在床很久，身体衰弱，痛苦难言(注131)。如果我们接受他生于西元705的提议，他或许是在其七十多岁的末叶或八十余岁的初叶。他之去世的日期也不能决定。或许他是在八十多岁辞世。此“二十二问”是其最后作品。斯坦因S.二六七四号写卷的跋尾说：
    丁卯年三月九日写毕，比丘法灯书。
    其年即为西元787；而伯希和P.二二八七；而伯希和P.二二八七写卷则有
    丙申年一月日书记。
    其年即等于西元816。如此，若我们说“二十二问”完成于西元787之前，因其距辩论会甚近，或许是合乎情理。于西元787，若昙旷仍在世的话，他应有八十二岁。这样，我们假定“大乘二十二问”是作于西元781与787之间。依其健康情况作决定，他不可能生活比八十多岁的中叶为更长。

    十一、二十二问的特质与分类
    如上所述，赤松带赞王的质问是与辩论会有联系，虽然其范围被扩充，籍以包括大乘教义诸如三身Trikaya涅槃等等。依照讨论性质作了下列分类，那给予我们对全部题目的范畴一个鸟瞰。
    I. 菩萨行持的各方面：
    甲、使众生离苦之道(第一问)。
    乙、内修第一行法是与其外在行为有关(第二问)。
    丙、在十地中的菩萨，有些有相有识，另一些则没有；行动是与相，识有关(第九问)。
    丁、菩萨证取解脱的准备次序(第十问)。
    戊、菩萨于涅槃与轮回无有差异(第十二问)。
    己、菩萨所知不著涅槃，亦不染世间(第十三问)。
    II. 凡夫的修行：
    甲、身、口、意修行的次序(第三问)。
    乙、于五浊恶世，自己无缚，他人亦未得解脱(第四
    问)。
    丙、众生行菩萨行及发菩心之道(第八问)。
    丁、众生修习菩萨的智慧与方便之道(第十四问)。
    III. 关于三乘间的趋向，行持及证取的差异：
    甲、他们间于六尘境所见之差异(第十五问)。
    乙、他们之初发心(第十六问)。
    丙、他们之涅槃不同的种类(第十七问)。
    丁、三乘之分类或为方便说，及声闻与圆觉成佛之不
    定性(第十八问)。
    IV. 佛陀之成就：
    甲、佛有有余涅槃及无余涅槃(第五问)。
    乙、佛有三身(第六问)。
    丙、佛有一切智(第七问)。
    V. 法身与涅槃的种类：
    甲、在佛与菩萨间的法身之差异(第十一问)。
    乙、佛之涅槃与声闻之涅槃是不相同(第十九问)。
    丙、涅槃于诸法自然而有(第二十问)。
    VI. 含藏识与大智慧的关系：
    甲、关于含藏识与大智的证同有所怀疑(第二十一问)。
    VII. 佛教各宗的发展：
    甲、于佛去世之后僧团分为两大部及二十派，人们欲知彼等间是否有任何相同点(第二十二问)。
    上述题目的陈列，得到了下列的统计：
    Ⅰ.六个问题：一、二、 九、十、十二、十三关系菩萨。
    Ⅱ.四个问题：三、四、八、十一关于众生。
    Ⅲ.四个问题：十五、十六、十七、十八关于三乘。
    Ⅳ.三个问题：五、六、七关于佛陀。
    Ⅴ.三个问题：十一、十九、二十关于法身与涅槃。
    Ⅵ.一个问题：二十一关于含藏识与智慧。
    Ⅶ.一个问题：二十二关于佛教史。

    十二、评论二十二问
    在二十二个问题中“菩萨”一题占篇幅最多，几乎整个作品百分之三十。当然，它是在这问答中被讨论到的最重要题目之一。我们将评论每一问题。
    Ⅰ. “菩萨”第一问：一位菩萨之不同于众生，声闻Sravaka及圆觉者Pratyekabuddha在于：当众生坚持我执Atman时他将长期轮转生死受诸苦恼。二乘已不执持此见，但坚滞法执。他们乐于追取涅槃，而不关心及他人的救度。一位菩萨是完全与他们相反。他自信己身有真如法。他修无相法，离一切相。既已湛深了解人空及法空，他将不乐涅槃亦不乐世间。他将向众生宣演此教，而彼等将获得解脱 。在此问之末有：
    故修无念，离一切相。
    此与大乘和尚在桑耶辩论会上的理论极相似。是否昙旷知悉辩论会的详情(注132)？
    Ⅰ. “菩萨”第二问：作者列出三种不退：一、信不退，二、证不退、三、行不退，在“一”项的著重点是相信菩萨有“真如法性”。他一定会成佛。在“二”项那是说他已“正证真如”，“断分别障”；他不会有烦恼过失升起，他常有无漏心(Anasrava)及永不退失真如。在“三”项指他已进入第八地(即不动地Imperturba-bility)，外面虽有若干变化，但不会干扰内在的无相。在表里间有微妙的合作。无论如何，虽有万象变化，菩萨是常住在不动地位。
    此中的第二个解释把不退等同于不动，这些依次成为与“无念”相同。这再引证及在辩论会上所提及的争点。
    Ⅰ. “菩萨”第九问：此问答是关于从初地(First bhumi)至第十地的禅观的进行。最初五地加强在所涉及的相，而无相方面则很少。在第六地恰好与此相反。在第七地可以成就有限的无相观。只有在第八地可以证取纯无相观，而其“有相功用，永不现行”。这是较其他有相的各地为优胜，因为“然菩萨道万行皆修，但于所修心无所住。”如此，这是叫做“无相、胜行”。
    在八地以上心无障碍。此由于证取与第八际有关的无相。
    此问的后半部可与Ⅰ、“菩萨”第二问相比较，因“无相”一词是与“无念”很相近！
    Ⅰ. “菩萨”第十问：此问的回答集中在“心离念”与“无所分别”。如此，则心获得解脱。于是，“诸解脱门，从兹证得”。心解脱是入其他解脱门的钥匙，一般来说，这是禅宗的教理。六祖慧能于其法宝坛经里屡次教以“无念”与“无相(注133)”这也是在桑耶辩论会上主要的争点。
    Ⅰ. “菩萨”第十二问，对那些还不曾证取法空，诸如声闻与缘觉等人还有涅槃与轮回的分别。因此，他们有追求前者与厌嫌后者的趋势。但菩萨已证得诸法皆从念生(注134)。他不作两极端的分别，且认为它们为同等。如此，他并没有特别喜好。这些是相对名词。当到达超越Tran-scendental地位时，其差异将泯灭，虽然一般人看来，那好像是不相同。
    Ⅰ.“菩萨”第十三问： 这是第十二问的相续。主要点是在于以何种方法菩萨既不乐涅槃，亦不随顺世间。作者以三种法门或教理回答之：1.初教缘起观——菩萨了知世间诸法互相连系，虚幻非实。2.终教唯识观——他深知一切诸法从心起。换言之，若无心，亦无法。3.顿教真如观——菩萨了知外界境物为心所现。若无虚妄外境则内心不见，如此则心不起作用。心既不生则一切皆属于真如境界。
    基于上列的分类，菩萨无论如何，不会对涅槃或世间境相生兴趣或留恋。复次，据说，即使他证得涅槃，他将不见其有可乐之处。这即是菩萨与声闻缘觉不相同之点。
    Ⅱ. “凡夫”第三问：此问答是处理初学者的宗教行持。初发心的身、口、意应当与戒、定、慧密切联系。在戒(Sila)方面他应当遵行戒律，因而避免十恶业，行十善业，且使它们利益众生。在定(Samadhi)方面，身口意需要相应，因而成为全部运行。此外，它把有相定从无相定区分出来。无相定意指它已从诸相及分别获得解脱。在慧(Prajna)方面，它列陈身慧、口慧及意慧。在上列三者之每一类，有相与无相慧皆有详细解释。无相慧的含义是集中在没有任何分别，及他既不接受，也不拒绝任何法，及心不起念的事实。
    可注意者为有相戒、定、慧属于传统的佛教，而无相戒、定、慧则属于大乘佛教的诠释。在桑耶的辩论会上，莲花戒Kamalasila与智慧因陀Jnaentra加强智慧的分析与行持十善的重要性。此问很密切地反映及辩论会的争点。
    Ⅱ. “凡夫”第四问：在五浊中计有(一)众生浊，(二)命浊，(三)劫浊，(四)烦恼浊及(五)见浊，第五项之见浊是被认为其他诸浊之来源。最初，众生本性自净，即是真如。若人违背“本源”，妄见自生。从此造作烦恼业，毕竟受苦无穷。
    从另方面看，若妄念已除，照达心源，则净浊之相即将消灭。如此则解缚之相将会消除。众生有能力去达到此超越Transcendental的地位，若他们努力以赴。
    Ⅱ. “凡夫”第八问：在凡人间，有些是初学，有些是先进。发菩提心亦依此分为(1)有相，(2)无相。在(1)项之有相菩提心再分为三种：(一)对一切不善及多诸苦恼的有为法发生厌离。(二)对菩提心发生欣乐，修一切善行，因而作证取佛果的准备，(三)对诸有情发生悲愍，藉六度使他们获得救度。此为初学修菩萨行的基本步骤。
    对于先进者，无相菩提心应占优胜。此“菩提 ”原被译为“觉”或“觉醒”，即等于真如。它本来是清净无相。若人向外搜求，即成妄念，也变作障碍。依照本书的作者，真实发菩提心者是指“一切不发”。因为“虽名发心，而无所发”。如此则名“真实发菩提心”，亦名“真行菩萨妙行”。这看来好像使人迷惑。若我们记著初级与超越级的分别，则此事将很易了解。
    Ⅱ. “凡夫”第十四问：此问涉及凡夫在大乘教里如何运用智慧与行方便。作者给了下列两种解释：(一)去了解俗谛中的空、有，宜用智慧，若欲泯绝此二者的意想则需要方便(Upaya_)。前者是叫做俗智，后者则为引导至真智的援助。智慧与方便应携手并行。(二)第二种解释是关于悲、智的行持。有悲愍心者是对他人关怀。采用方便可以使他人获得救度。但不要轻慢自行，因为去证悟真如(Bhutatathata)宜用真智。行菩萨道的凡夫，其进行在开始时是渐次与顺俗，而最终则为超越(Transcendental)。凡夫与菩萨之不同点是在于是否他已执行了菩萨所应作的修持，及是否已证得其最后目的。
    Ⅲ.“三乘”第十五问：声闻与缘觉对六尘(色、声、香、味、触、法)的看法与菩萨的看法是很不相同。二乘人只知(一)项之因缘法，而不知(二)项之唯识，(三)项之无相与(四)项之真如。因此，他们把六尘外境认为实有，不依靠心；他们执著六尘境有其自性(Svabhava)，这是因为他们不了解诸法本性皆空(Sunya)；因不觉知真如门，他们不相信诸法平等皆如。基于此，他们以为在六尘境中之项目各不相同。
    从另一角度看来，菩萨深知上列四种教理。他体验从因缘而生六尘境。因因缘无自性，一切皆空。因心之作用，一切现象或生或灭。他将不作任何批判，或是或非，亦无任何取舍。他们似乎若存若亡，或在两者之间。此因为对六尘境的了解，于菩萨与二乘人之间有不同之处。
    Ⅲ. “三乘”第十六问：“发心”是溯源于“因”；或可能性的种子及“因缘”。“因”是“众生出世本性”，即是“诸法真如”。当其为无明(Avidya)所覆盖，他将不能聆听三乘正法，且长远流转生死轮回(Samsara)。另方面当机会现前，他将求觅出离。乔答摩佛陀是一个很好举例。
    因缘将决定以某一乘(Yana)去接引他。举例说，如人闻大乘法，求证佛果，悲愍众生及欲救彼等出离虚幻世界之苦恼，则他将成为菩萨。同样地，此亦可用于声闻与缘觉。以声闻来说，因其能闻佛陀所说之四谛，八正道之教法，他成为声闻，可证涅槃。论及缘觉，因当时无佛出世，以其宿世所植善根，努力于修行正道。复次，因其喜乐寂静而离群独居，他不同于菩萨之悲愍施舍去为他人服务。
    某种特殊情况为三乘创造出不同的结果。但是，在它们中之每一员都有“因”或可能性的种子，在适当时间，它将成为有效去促使某些人发心并寻求高尚目标。
    关于“因，谓众生出世本性，此性即是诸法真如”一节，作者好像是把“因”拿来与“真如(Bhutathata)”证同。这种证同equation似稍近勉强。第一，因缘，以逻辑名词来说，是一可以用理解去处理的事物，而“真如”或真理是出乎语言与想象之外。第二，若一切众生毕竟离俗而在三乘中之一成为圣者，为何佛陀于其佛教组织给予在家众一个重要地位，诸如优婆塞，优婆夷(Upqsakas，Upqsikas)等？我们觉得，此地所宣说的教义不能使人心悦诚服。
    Ⅲ. “三乘”第十七问：三乘的涅槃之不同处，实际上是在声闻，缘觉与菩萨间的不同的涅槃。最初二乘的涅槃是比拟于灯焰的消灭，身心二者不更存在。作者说：“如太虚空寂无一物”。
    菩萨的涅槃有两种说法。依唯识宗的渐教，在五地以前，菩萨不能被认为已至于有余涅槃(Sopadhi-sesa-nirvana)
    或无余涅槃的地位(Nirupadhi-sesa-nirvana)，因基于若干原因，一切苦障尚未断除。换言之，在最初的数地，涅槃的障碍仍是很活动。但是，依照顿教，菩萨体验心是万法本源(一切万法从心起)。若心不动，一切皆如。此即是“清净涅槃妙理”，它将使菩萨离诸苦障。这是叫做无余涅槃。因实际上都无所得，那是叫做有余涅槃。复次，因轮回与涅槃都不存在，那是无住处，这是叫做“自性清净涅槃”。但是，涅槃的意想对于菩萨似不需要，因为“真如实理”是超越出思想的领域。
    依照大乘教理，在二乘与菩萨间涅槃的不同点实有显著差别。那好像有很大的罅隙亟需弥补。
    Ⅲ. “三乘”第十八问：“谁能证佛果？”的问题一定会给若干学佛者不少麻烦。依照早期佛教，只有少数人能登峰造极，这是显然的事。声闻与缘觉没有机会成佛，因他们是属于本因(种子)的某类(B类与C类)。如此，他们可走到其自身范畴所许可之处，但不会更远。他们与那些无种姓或无善因类的相比是好得多(A类)，因而此类的人常在生死道上流浪。
    属于D类与E类的人，其成佛的机会是优于其他各类(A、B、C)。但是，此二类是属于大乘教理，而早期佛教以证阿罗汉(Arhatship)为其弟子的最高目标。
    如此，在小乘教里，成佛的可能性是有限制。另方面，以涅槃经及法华经作代表的大乘教说：一切众生，包括一阐提人(Icchantika)皆有佛性，是以一定证取佛果。这一定是慷慨好施，把希望给予每个追求解脱的人。对大乘人来说只有一性，那即是诸法真如实性；只有一乘(Eka-yana)那即是一佛乘的究竟真理。其他圣者的各乘各类，除了为方便(Upaya)而设外，好像是重复申述。据我们所知，方便并不是究竟真理。
    此为二十二问中，我们所见到的繁复问题之一。作者把一困难的问题作了清晰的解述。无疑地，大乘教理的最后阶段是比早期佛教教理较为吸引人与慈悲为怀。
    Ⅳ. “佛陀”第五问：去回答此问，作者列出四种涅槃，那可以用于佛陀及其他，其四种为：
    一、一切众生本来具足的自性清净涅槃。
    二、有余依涅槃——此指受苦的色身，尤其是一般凡夫，尚存在，但亦可以用于佛陀。不过，对佛陀来说，那是“常、乐、我、净及无漏”，虽然他的色身尚存在。
    三、无余依涅槃——此指阿罗汉与佛陀当其色身已不存在。因此，一切烦恼，轮回，及苦障皆已除尽。当“无苦依身，诸苦永寂”名曰：无余依涅槃。
    四、无住处涅槃——对于一位到达了第五地的菩萨，此指他已证得真如无住处的真理。若在佛陀则他是诸障皆尽，且已证得大智慧，解脱及法身三事圆满。
    唯有佛陀及很少数的菩萨能获取上列的第四种涅槃。
    Ⅳ. “佛陀”第六问：众所周知的为佛有三身(Trikaya)：法身、报身及应身(Dharma-kaya.samborga-kaya.nirmana-kaya)。在此问里，作者根据各种典籍列陈之五身：
    一、第一身为如来真净法界身，那是“湛若虚空，不生不灭”。
    二、第二身为所集功德结果之自受用身。
    三、第三身为所集功德结果之他受用身，尤其是菩萨。
    四、第四身为最低级的菩萨，二乘及凡夫所现。
    五、第五身是为化六道外道等类诸众生所现。
    实际上，第一身应认为是真如法身。作者曾仔细描述三身的各方面。
    Ⅳ. “佛陀”第七问：此问涉及一切智的两方面，谓自性与修行六波罗密(Paramitas)作者以为去证取一切智需要它们两者的互相策应。若缺其一则将不能获取预期的效果。在技术方面说，他用了“因”与“缘”的名词去称呼它们。他以种子的长成及其需赖人工的照顾的譬喻来解释它们间的关系。若无种子则人工是徒劳无益；若无人工，因缺乏湿润及其他必需条件，则种子会枯萎而死。
    问者把一切智分为两类，而回答只有一类，那是籍“因”(Cause)及助“缘”而成。我们同意作者所采取的立场。
    Ⅴ. “法身与涅槃”第十一问：此问题是集中在佛之涅槃与菩萨的涅槃间是否有不同之处。回答的要点为在色身方面并无差别，因各种身皆“同一真如”，但他们的功德不同，如来法身的功德已满，而菩萨的功德尚未满。这是以两颗无价宝珠作譬喻，一颗是已施工磨莹及装饰，另一则仍然是一未曾施工的顽石，在实质上它们是等同而外貌有差。
    “法身”一词在各种释典里有不同的解说。现代学者很倾向于把它认为是“最高真理，万物皆从彼受生及律性(Derive their being and lawfulness)”。但它自己则超越一切有限条件(Transcends all limiting conditions)(注135)。 如此，则菩萨与佛是真理一部份的化现身。用真谛的名词来说，他们的法身应为等同。或许，因对佛表示尊敬，平等的观念不容易被人接受。
    Ⅴ. “法身与涅槃”第十九问：去回答所问：是否声闻能证取与佛同样的涅槃，作者以下列理由冰消了其可能性。一.以方便法门，佛陀提议说佛与声闻能证得同一涅槃。此为小乘宗的立场。二. 佛之涅槃是“万德具足，众善斯圆”。唯佛能证取，非声闻所能分享。三. 声闻涅槃是有余涅槃，那与大乘的无余涅槃恰好相反。四. 关于两种涅槃同一之说是小乘宗的邪见。
    为了去证实此理论，作者写了很长的申述以证明此两种涅槃绝对不相同。此可见于此问答的后半部。
    Ⅴ. “法身与涅槃”第二十问：此问集中在：如果诸法无自性，那即是本来涅槃。如此，任何修行似乎不需要。作者回答此问，引用了解深密经(Sandhinirmocana-sutra)并解释了法空教理的含义。依照他，其用途是欲除去有(Bhava)执，若能达到此目的，则法空的观想亦应扫除。他举一个譬喻说：药以治病，病息则药不必需要。依据此解，空、有两个概念均应舍弃，由此而证取有意义的中道哲学。
    复次，此问的主要点是涉及某一类的人，他是否需要修行，将以其特殊情况而定。
    Ⅵ. “阿赖耶识与智慧”第二十一问：去申述阿赖耶识(Alayavijnana)与如来藏(Tathagata-garbha)是没有甚么分别，金与指环的相互关系是拿来作比较；指环有金，金有指环。但此二者是截然两物。最后我们说它们是非一非异。
    复次，如来藏也是叫做大智慧。如此，那即是清净心与本源。在另方面，阿赖耶识是妄心，为导引至轮回的主因。但是，因如来藏是非常非断，它是被认为既与妄心为非异，亦为非同。很普遍的“水波”之喻可以应用于此。
    末了，作者指出此问是基于瑜伽宗(Yogacara School)而回答则是站在顿教的立场。如是，那与唯识宗的解说是微有不同。
    Ⅶ. “佛教史”第二十二问：关于佛教各宗在印度的发展，作者提及大众部与上座部的出生计有两次。第一次发生在佛灭后十二年，而第二次约一百年于阿育王Asoka之统治期内。此破裂为大天的五事所促成。我们将单独讨论这两次：
    根据巴利文所说，佛教经典的第一次结集，主要为毗尼(Vinaya)及经藏(Sutra-pitaka)是发生在佛陀刚去世之后。参加此举的人似不可能将经、律、论(Abhidharma)三藏都搜集完整。简单的理由是哲学论著的编写为时很晚(或许迟至数世纪)。如说五藏(于上述三藏加上陀罗尼藏及杂藏)都在第一结集时收毕似乎缺乏历史真实性。复次，在西元五世纪之前，个别的宗派如大众部Mahasanghika及上座部已形成似乎不可能。我们将拒绝在第一结集之时佛教有严重分歧的猜想。
    关于第二次的分歧(注136)作者依据大毗婆沙论(Maha-vibhasa-sastra)引证关于大天五事的整部，及大众部与上座部(Sthavirvadins)的各派的最终出现。于该描述中不见有新的成份。或许我们可以说他没有批评的判断，因他不曾确证该事发生的确切时期及大天的真实性格。据我们所知，此事有数种不同的日期，例如：佛灭后137年于难陀王统治期内(Nandas)；及100年，116年或160年在阿育王(Asoka)时期(注137)。如说：“至佛灭后，百有余年”那表示有不大确切之感。
    复次，各种典籍，基于作者的立场，把大天(Mahadeva)的人品描绘得各式各样。大毗婆沙的传承将其描述为大奸巨恶。像这样丑恶的罪人去破合和僧是很自然而合乎逻辑。或许这是为了某种作用而出此。在另方面，大天是被称誉为“大菩萨”(注138)及“大天名高德大，果证年卑，王贵钦风，僧徒仰道；既而卓牢无侣，遂为时俗所嫉，谤之以造三逆，加之以增五事。”(注139)此为八世纪时玄奘大师的大弟子窥基所作的评语，因尚有关于大天不同的意见，我们且以置疑待之。基于此，我们不依恃一面之词。结果，他或许并不像大毗婆沙要我们相信他之为恶多端。若此提议被接受，则破合和僧的因由是别有所在。
    佛学家们的一般趋向以为那毕竟引致各派的不和睦种子，或可追溯到戒律的行持，在毗舍离(Vaisali)的第二次结集关于十事的事是一个显著的举例。那也由于住在不同区域的弟子们之解说及弘宣佛之教言。为了交通不便，每组僧团基于其本地方言遵奉了其自身的传承及行持。最初，一切都似乎很寻常。当将各组作一比较之时则差异立见。大藏中之异部宗轮论(大正藏二○三一)及部执异论(大正：二○三二及二○三三)对佛教教理的不同意见有详细的描述(注140)。
    如此，破合和僧谴责的重担不应给大天一人负担，即使传说为可靠。他的牵连是涉及阿罗汉证果的解述。此种解说可能造成合和僧团团员们强烈分裂的局势。其结果为两次主要分裂及毕竟促成十八部或二十五部的成立(注141)。
    拉摩提Lamotte教授对此事的意见：
    于佛陀去世迄孔雀王朝阿育王统治期间，佛教团体遭受到离心的压力，那竟于完成最后分裂。破裂的因由不止一端。有些已证阿罗汉果的人主张垄断此神圣境地；他们激起凡夫(Prthagjana)的嫉妒，遂编造五事以羞辱阿罗汉，及迫害其尊荣(注142)。
    好像是正中要害。因此，很使人怀疑的，是否有一叫做“大天”的历史人物，或者此名是给与一位名高望重的人的尊称(注143)。
    这样说来，合和僧破裂的确切时间及负责的人是尚未肯定。或许那牵涉及很长的时间，许多人或团体。去回顾历史的远境，我们的处境是比昙旷好多了。他只重述一遍那保存在大毗婆沙论的传说。
    关于二十部中四部拥有三藏，即：上座部，一切有部，大众部及正理部——的话，那主要是指律藏，或在某种情况下指经藏，因为我们不能决定大众部有他们自己的经藏及论藏。
    他对在中国五家律宗文学的普遍评述是一正确的评价。他所提及的五部律中，四分律(Dharmagupta Vinaya)有特殊光荣被认为与天台禅、净土等同为中国佛教宗派之一。道宣，一位唐代学问精深的佛学家为四分律写了若干疏释，对此宗的建立有极大贡献(注144)。
    在第二十二问之末作者以妥协的态度说：各个宗派间或许有差异点存在，但人们不应企图去藐视其中之任何一个。若人毁谤各派的教义，他会一定沦落三涂受苦！在另方面，若人依教奉行，他将证取四果，包括阿罗汉位。我们以为这是作者的友谊劝告，而并不是他的精确的批评。

    十三、昙旷对敦煌佛教的影响
    关于昙旷对敦煌佛教的影响，下列各点应加以考虑。第一，他为最渊博的学者之一，他写了很多与唯识宗有关著名佛教作品的疏释。第二，他有激烈的热忱去鼓励青年学者从事研讨佛学奥义。为求达到此目的，他的流畅可读的注释，有时对同一作品他作了两个疏释，一个是提纲，另一涉及细节，都是瞄准对初学者给以援助。基于保存在敦煌写卷里，同一注释有数个写本的事实，他的写作一定是很流行与极孚众望。若干世纪以来，中国佛教的传承为著名的大师向人数众多的比丘与居士们宣讲有名佛典。很可能昙旷遵循了此项传承，虽然关于彼之宣讲的消息是很希罕。我们最低限度有一件证据是关于他之解释“大乘百法明门论开宗义记序释”(注145)。此事发生在西元781，且费时三日。基于此可推论其在早期似曾作过公开演讲。自然地，我们无法估计他对一般民众的影响。即使如此，我们可以说 ，每当有人读其疏释时，即有可能性的教育价值。他之作品的巨量写卷即为公众欣羡的象征，亦为最终影响的明白证据。
    有数个敦煌写卷确切地提及昙旷的作品：一个是斯一三一三号，那好像是一种讲稿与昙旷的“百法论”注释有关(大正藏：二八一○号)。此为他的杂记本用以解释术语与简句，因而能使学生容易了解书的内容。那是在辛酉年(西元781)写成。斯、一三一三卷关于大正藏二八一○号的序文部分的影片是收入上山大峻的文章里(注146)。与此相似的为斯、七二一号，那是关于他的“金刚经赞”(注147)的杂记(大正藏二七三五号)。其他写卷署以斯、二一○四号(大乘百法明门论开宗义记分别义趣记)及伯、二三一一号(百法手记)也同样为杂记关于彼对百法的疏释(大正：二八一○号)。在百法手记里对“二十二问”有一直接引证，它说：
    关于三菩提与涅槃之义，“二十二问”有详细解释。
    上所列斯、七二一，斯、一三一三及伯、二三一一等号的写卷均写成于西元781 左右。有人提及他的疏释与著作，那表示他的作品很普及，而每当涉及佛教教义时，它们似乎担当了令人接受的权威。对我们有特别兴味的是关于“二十二问的引证。我们获得下列的句子：于斯、二七○七号，一处理三乘区别的写卷，确然地将“二十二问”一部份包括进去，而略加改变。
    有一处它说：
    三乘所见理合不同，然其二乘所见相似。
    这可以与“二十二问”的第十五问互相参照：
    三乘所见理合不同，然其二乘多分相似。
    在另一处它说道：
    知此苦身，因烦恼集，若求出苦，须断集因，要证涅槃，修八圣道，为涅槃因(注148)。
    这几乎是从“二十二问”的第十六问将整部内容搬移过来：
    知此苦身，因烦恼集，若欲出苦，要断集因。若求断集，证涅槃乐，修八正道，以为正因(注149)
    依据“二十二问”的第十七问它更进一步讨论二乘与菩萨的涅槃之不同处(注150)
    他对敦煌佛学研究影响的另一证据是在法成的写作中窥见。法成是西藏人，且是一位有成就的中国佛学学者。他把梵文或藏文著作译成汉文，演讲过瑜伽师地论(Yogacarya-bhumi-sastra)，并编辑过稻芊经的中文讲义。他的著作活动时期约在西元830到860年左右(注151)。或许他不曾与昙旷会晤。但从其作品的内容，他受到昙旷对大乘各宗分类的影响是显然可见。于其“大乘稻芊经随听疏”的序文里(注152)，他把大乘各宗分为三类， 即：“依经中宗，唯识中宗，依论中宗”的经，唯识与论三者。 对于第一项他提及其他两个名称：“亦名胜义皆空宗，亦云破相宗”。 对第二项他加上两个称号“应理圆实宗”及“立相宗”， 而对第三项亦有两个称呼，即“法性圆融宗”及“法性宗”。 复次，他企图追溯各宗的历史发展。 他提名龙树，Nagarjuna (注153) 无著Asanga 及那多落尸多 ( 无著的弟子 ) 三人为上列各宗个别的开山祖。 此地所用的分类与术语确实是引证昙旷所写的“大乘百法明门论开宗义记” ( 注154) 一书。为了解释各宗的特点， 昙旷列出某一宗的著名典籍，举例说，他举出中观论(Madhyamika-sastra)百论：(Sata-sas-tra) 及般若论 (Prajnaparamita-sastra) 等来涉及第一项之“胜义皆空宗”。但是，法成似乎对基本教义有较浓厚兴趣，而对艺文方面则淡淡然。
    复次，因法成曾对一群听众宣讲瑜伽师地论，他对唯识宗的兴趣是与昙旷的相同。我们猜想他有机会接近昙旷所作的若干疏释。作为昙旷晚辈的同时人，前者的作品对后者的影响一定是很深刻。他们两人在西藏占领敦煌时期(西元762-848)均被认为大佛学家，因其写有注释及作了其他文艺方面的贡献。抑有进者，于西元860之后，我们不复见到有如此二人在写作方面质与量的重要贡献。在敦煌，学问的进展及佛学研究的发育似乎告一段落。最低限度，没有凭据去证明那慧炬仍继续发出晶莹的光辉与以前无异的主张。

    十四、结论
    上列各章所执行的勘测给我们一个关于昙旷的时代与文艺生产的清皙轮廓。现在我们知道他之活动的大约时期(西元705-790)。此为其自述及有关文艺作品所提示，虽然他之确切生卒日期仍然无从知悉。
    在这个研究计划开始以前，因关于作者的消息很缺乏。我们对于最终结果是未能肯定。每当我们面临困难及复杂的问题时，幸有坚决的努力及冒险精神来支持我们。复次，依照公平无私及无偏见的主义，此地的任何估价皆基于笃实道理。因此，我们的裁判是与其他学者相异。若未来的研究者基于理性的立场而获得不同的结论，我们将欣然聆听其辩论。依此公式可以完成学问的进步。
    在此工作的进行中，我们的确遇见不少未曾预料的发现。其中之第一项是“二十二问”的作者身份authorship是两个人的合作而成：藏王赤松带赞的问题及昙旷的回答。各种有关写卷对此事实未见提及，那要等待我们将若干碎片式的消息缀合起来始有端绪。复次，此“二十二问”是与在桑耶召开的佛学辩论会有密切关系一事亦毫未见暗示或提及。当我们比较辩论的争点及“二十二问”的内容，那证实了我们的假设。这等于说后者与前者有相同处。如此，“二十二问”，关于西藏佛教史及汉藏文化关系方面，是一件很重要的文献。不幸的事是中国佛教史籍，包括各集高僧传都未曾提及昙旷之名，或大乘和尚与印度论师间的辩论，要等待至本世纪之初当汉文写卷在敦煌发现时始知其事。因从事研究它们，我们很高兴，若干有价值关于汉藏佛教发展的消息始第一次出现在我们眼前。这一定能帮助，在佛学研究领域里去展开我们的眼界。
    “二十二问”作者的博学很值得我们的景仰与钦羡。很有秩序地，昙旷对于若干很困难而涉及涅槃、真如、三身、空、佛性、菩提心，中国与印度佛教宗派史，各乘人间证取涅槃之不同处等等问题皆作了适当的回答。他很公平地，及优然自适地去解释它们，虽然他的专长是在瑜伽哲学。
    我们深信尚有涉及佛教某方面，同样有兴趣的敦煌写卷。若被辑校及研究，它们一定会对佛学投射晶莹的光辉。我们希望未来世的学者将鼓起勇气，冒险向敦煌石窟的仙境前进。
    1988，元月一日寄自美洲艾城。


大乘二十二问之研究

上一页

大乘二十二问之研究

巴宙(美国爱渥华大学宗教学院教授)
中华佛学学报第二期(1988.10月出版)页65-108

    注解
    (注1) T.W.Rhys (tr.), The Dialogues of the Buddha, London: The Pali Text Society,1973.
    (注2) 王重民等：敦煌变文集，267～269页，北京人民文学出版社，1956。
    (注3) 同上，262～265页。
    (注4) 英译弥兰王问经T.W.Rhys (tr.) ,The Questionsof Milinda, in the Sacred Books of the East,Vol.31, New York: Dover Publications, Inc .,1963.
    (注5) 苏莹辉：敦煌论集，264页，台北学生书店，1967。
    (注6) 同上，234 页。
    (注7) 大正藏二八一二号，卷八五，1068～1088页。
    (注8) 上山大竣：昙旷と敦煌の佛教学，东方学报三五期，151页，1964；臧励和等编：中国古今地名大辞典，706页，台北：台湾商务印书馆，1966。
    (注9) 参看大正藏卷八五，1068页。
    (注10) 同上，1089页。
    (注11) 同上，1105页“宝应二载九月初于沙州龙兴寺写讫”
    (注12) 同上，1089页“有建康沙门昙旷者”。
    (注13) 敦煌菩萨竺法护。
    (注14) 欧阳修：新唐书，卷三○。
    (注15) 大乘百法明门论开宗义记序释，大正藏卷八五，页1066～1067及斯、一三一二号。
    (注16) 在作品之末有以下数字：“十四日说竟”。其后继以“辛酉年十二月十三(五)日了。”大正藏卷八五，1067页。
    (注17) 道宣：续高僧传，大正卷五○，458页；大正藏一五八五号，卷三一，1～59页。
    (注18) 关于此书比较著名的疏释为：1，窥基：成唯识论述记，大正一八三○号。2，窥基：成唯识论掌中枢要，大正一八三一号；3，慧沼：成唯识论了义灯，大正一八三二号；4，智周：成唯识论演秘，大正一八三三号。
    (注19) 续高僧传卷一，大正卷五○，430页。
    (注20) “止大觉寺就岳法师学俱舍论”，续高僧传卷四，大正卷五○，222页。
    (注21) 大正藏一五五八及一五六○号依次刊载。真谛所译者为一五五九号。
    (注22) “专起信，金刚”。
    (注23) 参看大正藏二七三五，二八一四，二八二三及二八一○号。
    (注24) 显庆36年，即西元658。
    (注25) 续高僧传卷四，大正卷五○，457页。
    (注26) 同上，457～458页。
    (注27) 同上，458 页。
    (注28) 赞宁：宋高僧传卷四，大正卷五○，725页。
    (注29) 大正藏三四七号，大乘显识经。
    (注30) “未详氏族”。大正卷五○，727页。
    (注31) 新罗圆测，参看成唯识论，藏要第一辑，二二号，南京支那内学院 ，1937。
    (注32) 宋高僧传卷一四，大正卷五○，790页。
    (注33) 大正藏二○六○号。
    (注34) 大正藏一八○四，一八○六，一八○八，一八九二，一八九三，一八九四，一八九五，一八九六，一八九七，一八九八，一八九九，二○四一，二一○三，二一○四，二一○六及二一○七号。
    (注35) 善无畏于开元二三年(西元七三五年)去世。其碑铭序文并未提及他居于长安何处。大正卷五○，290～宋高僧传卷一四。
    (注36) 大正藏二一二二号。
    (注37) 赞宁宋高僧传，大正卷五○，726～727页。
    (注38) 不空传，大正卷五○，726～727页。
    (注39) 同上：“起贞元四年，迄元和五载”。738页。
    (注40) 大正藏二一二八号。
    (注41) 赞宁：宋高僧传，大正卷五○，738页。
    (注42) 同上，735页。
    (注43) 大正藏二六一六号。
    (注44) 赞宁：宋高僧传，大正卷五○，737～738页。
    (注45) 同上，734～735页；大正藏卷八五，9页。
    (注46) 大正藏二七三三号，卷八五，9～52页；伯：二一七三号。
    (注47) “刊勒金石，溥天率土，班宣句味。”同上，
    (注48) 赞宁：宋高僧传，大正卷五○，734～735页。
    (注49) 同上，735页。
    (注50) 大正藏一六六六号及一六六七号。
    (注51) 梁启超：大乘起信论考证，23～30页。台北：台湾商务印书馆，一九六六。
    (注52) 大正藏一八四六及一八四七号。
    (注53) 赞宁：(参看(注48))732页及285页。但是，在续高僧传卷九另外有一个法藏。大正卷五○，580～581页。卒于西元629去世。
    (注54) 臧励和等编：中国古今地名大辞典，821页，台北：台湾商务印书馆，1964。
    (注55) 苏莹辉：敦煌论集231～232页，台北：学生书局，1967。
    (注56) 袁枢：通鉴纪事本末，2061～2104页，台北：三民书局，1956。
    (注57) 同上，2092页
    (注58) 同上，2082页。
    (注59) 同上，2100。
    (注60) 同上，2068。
    (注61) 大正藏卷八五，1089页。
    (注62) “及天宝末，关中版荡，因避地姑臧。”宋高僧传卷六，大正卷五○，743页。
    (注63) 金刚般若经旨赞：“广德二年六月五日释普遵于沙州龙兴寺写口”大正卷八五，109页。
    (注64) 大乘起信论广释，大正卷八五，1121～1174页。
    (注65) “大历八年六月十七日齐奉道写。”大正卷八五，
    (注66) 大乘起信论略述，同上，1105页。在本书第一卷末之跋有“宝应二载”等字(西元763)，但宝应没有“二年”，那应指西元762。
    (注67) 同上，1089页。
    (注68) “恐初心者仰崇崖而起退……”同上，1089页。
    (注69) 同上，1105页。
    (注70) 大乘入道次第开决，大正卷八五，1206～1222页。
    (注71) 智周：大乘入道次第，大正藏一八六四号，卷四五，446～449页。
    (注72) 大乘百法明门论开宗义记，大正藏二八一○号，卷八五，1046～1065页。
    (注73) 大正藏一六一四号。
    (注74) 大乘百法明门论开宗义决，大正卷八五，1068～1088页。
    (注75) 参看(注9)
    (注76) 大乘百法明门论开宗义记序释，大正卷八五，1065～1067页。
    (注77) 大乘二十二问，大正卷八五，1184～1192页。
    (注78) 大正二八一八号，卷八五，1184～1192页。
    (注79) 袁枢：通鉴纪事本末，2127～2137页，台北：三民书局，1956。
    (注80) 苏莹辉：敦煌论集，263～264页，274～275页，台北：学生书店，1967。
    (注81) 宋祁：新唐书，吐蕃传，卷一四一，上卷，2～3页，台湾：二十五史出版社，1954；史列格罗；西藏文化史David Snellgrove, A Cultural History of Tibet, pp.23 and 73. New York: Frederick A Praeger, 1968。
    (注82) 王沂暖：西藏王统记，35、41、43、49、52页，上海商务印书馆，1955；史列格罗，西藏文化史，50页。
    (注83) 王沂暖：西藏王统记，25、31、45～53，102页。此书共有四章，计33页，描述松赞冈保王之生活及成就。不幸的是原来的书名及作者之名均未提及。它是在桑耶寺写毕。它既然提及阿提沙(Atisa)的著作(公元1042他曾赴西藏一游)及其他典籍，其成书日期应约在十一世纪或十二世纪，若非更晚的话。显然地，它是萨迦派(Sa-skya)所提倡襄助的。
    (注84) 史列格罗，如上所引，96，112页。
    (注85) 新唐书，卷一四一，上册，3 页及7页。
    (注86) 同上：7～8页及10页；史烈格罗，如上所引，275页。
    (注87) 王沂暖：如上所引，60～62页。
    (注88) 同上，62页。
    (注89) 新唐书卷一四一，上卷，11页。
    (注90) 史列格罗，如上所引，11页。
    (注91) 同上，11页。
    (注92) 新唐书卷一四一，上卷，11页。
    (注93) 同上，8 页。
    (注94) 同上，12页：史坦因：西藏文明R.A. Stein, Tibetan Civilization, P.65, Stan-ford University Press, 1972.
    (注95) 王沂暖：如前所引，64～76页。
    (注96) 史列格罗：如前所引，73，77及275页；杜吉：Guiseppe Tucci, Minor Buddhist Texts, Part 2,P.29. Roma: Instituto Italiano Per Il medioed Estremo Oriente, 1958.
    (注97) 王沂暖：如前所引，62～63页。新唐书，11页。(卷一四一，上卷)。
    (注98) 同上，62 页。
    (注99) 同上，76 页。
    (注100) Paul Demieville, Le Concile de Lhasa, P.8,Paris: Imprimerie Nationale de France,1952,新唐书卷一四一，中卷，4页。
    (注101) 布敦，西藏佛教史Bu-ston, A History of Buddhism, PP.192-196, translated by E.E.Obermiller in 2 Parts. Heidelberg,1931; 王沂暖，如前所引，7475页。
    (注102) 伯希和，伯、四六四六号。在戴密微之“拉萨结集”也对此写卷作详细研究，并附有一汉文原写卷的影片于其末端；上山大竣，如前所引，155～166页。
    (注103) 戴密微：如前所引“拉萨结集”。
    (注104) 杜吉：Guiseppe Tucci, Minor Buddhist Texts,Part 2, PP.26、32、36、40、41、52、65,and 82.；史烈格罗，如前所引，78～80页；A.K. Warader, Indian Buddhism, PP.476-7, Delhi: Motilal, Banarsidass, 1970; R.A. Stein, TibetanCivilization, P.67, Stanford: Stanford UniversityPress,1972.
    (注105) 上山大峻，如前所引，155～156页。
    (注106) 杜吉，如前所引Minor Buddhist Texts, Part 2,The Debate of bsam Yas according to Tibetansources,P.33.
    (注107) 戴密微，如前所引，177页。
    (注108) 杜吉：如前所引，32页。
    (注109) 同上，32页。
    (注110) 伯希和所藏，伯、四六四六号；戴密微，如前所引，影片插图，F、一五四A-B。
    (注111) 苏莹辉：如前所引，218，215～230页。
    (注112) 布敦：如前所引，191页。
    (注113) 戴密微：如前所引，F·一二七B，一二八A；上山大峻：如前所引，155～156页。
    (注114) 同上。
    (注115) 布敦：如前所引，191～196页。
    (注116) 同上，190，195页。
    (注117) 渐门或渐修。
    (注118) 顿门或顿悟。
    (注119) 戴密微：如前所引，F·一二七A ；上山大峻：如前所引，155页。
    (注120) 布敦：如前所引，195～196页。
    (注121) 同上，194页。
    (注122) 同上，195页。
    (注123) 同上，193页。
    (注124) 同上，195-196页。
    (注125) 戴密微：如前所引，F·一二七F，一二八T。
    (注126) 苏莹辉：如前所引，218页。
    (注127) 戴密微：如前所引，177页。
    (注128) 同上，F·一五四A-B.
    (注129) 布敦：如前所引，193-195页。
    (注130) 同上，194-195页。
    (注131) “卧病既久，所苦弥深，气力转微，莫能登涉，伏枕边外…”参看大乘二十二问短序。
    (注132) 布敦，如前所引，193页。
    (注133) 陈荣捷：英译六祖法宝坛经，17页. Chan, Wing-tsit (tr.), The Platform Scipture , P.17,New York: St. John's University Press, 1963.
    (注134) 布敦：如前所引，193-195页。
    (注135) 铃木大拙夫人：英文：大乘佛教，43页，B、L、Suzuki，Mahayana Buddhism，P、43，London:David Marlowe Ltd.，1948、This is a quotationfrom D、S.Suzuki's Studies in the Lankavatara
    Sutra，P、308
    (注136) 大正藏卷二七，510～512页。
    (注137) Eu，Lamotte,〝Buddhist Controversy over theFive Propositions〞，Indian Historical Quarterly，(1956)，160～162
    (注138) 分别功德论，大正卷二五，32页。
    (注139) 瑜咖师地论略纂，大正卷四三，1页。
    (注140) 大正卷四九，15～20页。
    (注141) A、K、Warder，Indian Buddhism，P.289，Delhi: Motilal Banarsidas，1970。
    (注142) 见、(注137)
    (注143) 依照印度传承，国王是被称为Deva，当前的惯例，印度诗人泰戈尔是被称为Gurudeva；女诗人VARMA，住于Allahabad是被称为Devi、
    (注144) 参看大正藏1804，1806及1808号(卷四。)
    (注145) 大正藏二八二号，卷八五，1065～1067页。
    (注146) 上山大竣：如前所引，191页；大正卷八五，1046页。
    (注147) 大正卷八五，66～109页。
    (注148) 上山大竣：如前所引，197～198页。
    (注149) 大正卷八五，1187，1188页。
    (注150) 上山大竣：如前所引，199页。
    (注151) 同上，204页。
    (注152) 大乘稻芉经随听疏，大正二七八二饱A卷八五，1046页。

===================

        A STUDY OF THE TWENTY-TWO-DIALOGUES
                ON MAHAYANA BUDDHISM
                          By W. Pachow

  Being buried in the dust for a period of over a thousand years, the Twenty-two-　Dialogues on `Mahayana` Buddhism by T'ang-Kuang of the T'ang dynasty was discovered at the Tun-huang caves in the beginning of this century in fragmentary manuscripts. In 1973 the author of the persent paperhad the opportunity of examining the various manuscripts related to this work at the `Bibliotheque` Nationale, Paris, and the British Museum, London. Later he spent several yearsediting, collating and correcting these versions, sothat it could be restored to its original form. Itis hoped that we now have a version which is veryclose to the original composition, This article is an introduction. The newly edited version very closeto the origined version along with notes will bepublished in due time.

The main points for discussion will be as follows:

1. To examine the Sino-Indian Buddhist debate heldin Lhasa which was a confrontation between thesudden enlightenment doctrines of the Chinese Ch'an school and the traditional teachings of Indian Buddhism. The result was that each side claimed victory based on its sectarian sources.

2. To search for references concerning the principal participants in the dialogues and their relation to the Sino-Indian debate.

3. To study the historical development of Tibetan Buddhism and the cultural as well as diplomatic relations between Tibet and China.

4. To analyse, explain or criticize the philosophical or historical content of the work. Thetitle of this paper may be called: "A Commentary on the Twenty-two Dialogues".

5. As the name of T'an-Kuang was no where included in the Chinese Buddhist historical records, much time was spent on the following areas: i. Hislife and times; ii. His relation with the Hsi-ming monastery and its cultural activities; iii. Hisreturn to the Ho-hsi region and his literary activities and iv. His influence on Tun-huang Buddhist studies.

This paper was originally written in English and published in "Chinese Culture". Vol.XX,Nos.1-2, 1979. As it has a Chinese version now, the Chinese reading public may share the fruit with us. At the same time we sincerely hope it may encourage those who are interested in the study of Tun-huang literature to continue to press forward in this direction.

上一页