Avatamsaka Sutra

Avatamsaka (or Hua Yen or Flower Ornament) Sutra

by Benjamin Root October, 2001 Buddhism Page

Introduction
Book 1: The Wonderful Adornments of the Leaders of the World
Book 2: Appearance of the Buddha
Book 33: Inconceivable Qualities of Buddhas
Links

This page is under development and is provided primarily for the scriptural excerpts. The comments are sketchy and incomplete.

Introduction The Avatamsaka Sutra is an enormous and fascinating Buddhist scripture depicting the path of the Bodhisattva (or Buddha in training) and the mystical vision of Reality that he sees as his mind approaches that of a Buddha. Other common names are the Hua Yen Sutra or the Flower Ornament Sutra. ('Avatamsaka' means 'flower ornament' in Sanskrit; 'Hua Yen' means the same in Chinese.)

Originating in India in the early centuries after Christ, written by an unknown author (or authors), this sutra would seem to be somewhat later than the seminal Prajnaparamita literature discussed already, since it elaborates on the basic concept of 'emptiness' with further ideas of a more positive nature, such as the famous doctrine of the identity and 'interpenetration' of all things. This sutra is very highly respected by all Mahayana Buddhist schools, particularly in the Far East, where it gave birth in China to an important 'syncretistic' school named after it, and where it also inspired the influential Chan (Zen) schools of meditation.

The Avatamsaka is rich in vivid and surprising imagery, much of it paradoxical, and some of it bordering on the seemingly nonsensical. An entire universe of 'transcendental vision' is contained within its more than 1600 pages, and I can barely claim to understand but a few aspects of it so far. The following will mostly consist of some brief excerpts, chosen rather haphazardly, which are intended to provide a mere taste of the vision. As time permits, I will offer some comments, which will interpret the scripture in light of the philosophy discussed on my Philosophy Page (and recapitulated on the Metaphysics Page of my Buddhism Page). Of course, you must decide for yourself whether my interpretation makes any sense and if it is helpful in understanding this very difficult scripture.

You may wonder why you or I should believe any of the abstruse ideas in this scripture. The same question could have been raised when we discussed the Prajnaparamita scriptures and their notion of emptiness. There are two points to be made in answering this objection. First, by reading the scriptures and by studying Indian and Asian philosophy in general, I have acquired faith that the greatest of these scriptures are the honest account of genuine 'mystical' experiences, that is, of genuine spiritual experiences of an advanced nature. I simply cannot believe that Indian philosophy is a 5,000+ year old joke. Surely something intense and interesting has been experienced by many honest and earnest seekers of truth, in India, in Asia and elsewhere.

The question then becomes whether these experiences were 'merely' psychological, in some sense, or whether they refer to some aspect of 'reality'. This is where my philosophical ideas become useful. (And as I have said many times, these ideas are not original but are in harmony with the 'perennial' philosophy of mankind.) It so happens that these ideas, based on an 'idealistic' understanding of reality, namely that 'all is consciousness', are entirely compatible with the spiritual vision of the great Indian (and Asian) saints, as well as with that of many mystics from other parts of the world. Many people have realized this, and my thoughts are quite in line with the growing movement of 'nondualistic' philosophy found, for example, in the Realization.org website (especially the topic of 'Advaita Vedanta'). So I believe that a rational 'explanation' for the mystical experience can be given, that refers to a reality beyond mere 'imagination', that is consistent with science, and that is based on the principles that Reality is consciousness and this consciousness is ultimately a unity, as we will now discuss in more detail.

Basically, the Avatamsaka retains the principle of emptiness that we have already encountered in the Prajnaparamita literature and adds a key new idea: the fundamental unity and 'interpenetration' of all things. Everything is literally 'contained' in everything else. This bold idea is the source of much that seems paradoxical and even unbelievable upon reading these pages. There is, of course, a wealth of other ideas in the sutra, but the idea of 'interpenetration' distinguishes this work from the rest of the Mahayana canon, so I will concentrate on it.

The word 'interpenetration' may come from the later Hua Yen school in China, rather than the Avatamsaka Sutra itself, but the philosophy of the school was based squarely on the vision of the Indian scripture.

What can it possibly mean to say that everything 'interpenetrates' or that everything is 'contained' in everything else? I cannot claim to fully understand what the author(s) of the Avatamsaka intended, but I have my own idea. I will briefly describe this idea, and then you can decide if it is consistent with the excerpts to follow.

Essentially, the idea of 'interpenetration' is equivalent to the fundamental unity of all 'things', that is, with the fundamental unity of consciousness. Let us discuss this in terms of the ideas on my Philosophy Page. First, I will review the core concept that everything is consciousness, and then I will expand upon this with a discussion of the alleged 'unity' of consciousness.

In my philosophy pages, I provide what I consider rather convincing arguments that everything is consciousness. Reality and consciousness are equivalent; we have never experienced any reality 'external' to consciousness, nor can we. The apparent externality of the material world is an illusion created by our conceptual mind and 'projected' or 'superimposed' onto the fundamental reality of consciousness (which includes perception as well as thought and emotion). So let us take this principle of 'subjective idealism' (that only consciousness exists) for granted. (You can read more about it on my Philosophy Page.)

Now the question arises, whether consciousness is composed of distinct 'parts' or whether it is fundamentally a 'unity' in some sense. On my philosophy page, I have tentatively come to the conclusion that it is indeed a unity. This idea was suggested by my readings of the mystical literature, where statements to this effect are surprisingly widespread. My reasons are still somewhat vague, but let me try to argue as best I can.

As I just said, my basic reason for denying a material world 'external' to consciousness is that no such world has ever been perceived, nor can it be, nor is it necessary to appeal to such a notion to explain reality. The world revealed by perception is contained within consciousness; its apparent externality and substantial reality are due to the vivid, orderly and largely uncontrollable nature of this perception. Furthermore, different 'people' share similar perceptions when they are in the same 'place'. In fact, being in the same place means that different minds are having similar perceptions. The spectacle of consciousness is organized (or choreographed) by a higher power, which we can call 'God'. This God can be conceived of as 'infinite consciousness', which is the source of our finite consciousness; the two are ultimately the same. (More on God below.)

Furthermore, external space must be denied along with external matter. The two are really inseparable, so if one goes then so must the other. (A fairly extended discussion of the illusion of space is provided on my Philosophy Page.) But once we have denied space, how can we really speak of 'parts'? Must we not have space, in order to divide 'things' up into 'parts'? I do not deny the vivid illusion of space, which seems to contain a multiplicity of shapes and colors. However, once we realize that space cannot be as it seems to be, then we must reexamine all notions that depend on the common understanding of space as composed of parts separated by boundaries.

This is not such a violation of 'rationality' as may appear at first glance. All I am saying is that the vivid and undeniable perception of an external space filled with distinct objects does not correspond to what we think it to be. It is not the direct experience that is denied but rather our conceptual interpretation. Really there is just one single 'snapshot' of consciousness at any given moment, which seems to refer to 'things' (i.e. discrete material objects) distinct from the consciousness itself but which does not.

A particularly easy way to see this is by analogy to a dream. We may be fooled in a dream into believing that space and objects are 'there', but no one believes this upon waking. The dream analogy is frequently used in both Advaita and Mahayana. The waking state is similar to a dream, as argued in more detail on my Philosophy Page.

Now if we just concentrate on the 'snapshot' of consciousness, taken as a whole, without becoming distracted by the multiplicity of shapes and colors, then does it not seem like a single unified experience? It is entirely embraced by the single phenomenon or reality which we call 'awareness'. Consider all the 'patches' of color present in any given snapshot of consciousness. Can you say that the awareness of a blue patch 'over here' is different from the awareness of a red patch 'over there'? The same 'awareness' sees all these patches simultaneously; they are all 'taken in' at once. This is really quite remarkable. Why does not consciousness dissolve into an infinity of pixels of consciousness? What binds it all together? What binds it together is the very unity that makes us say 'my consciousness'. This unity is taken for granted most of the time, but it becomes increasingly fascinating and mysterious as we ponder it with philosophical insight and acuity, instead of reflexively falling back on our usual preconceptions and mental habits.

And as alluded to previously, this unified phenomenon or presence called consciousness is not different from the fundamental source of consciousness, which may be called 'God' for lack of a better word. As explained on my Philosophy Page, this fundamental source of reality is intuitively necessary in order to explain the miracle of consciousness. Basically, I cannot believe that consciousness 'simply happens'; indeed, that is my fundamental reason for believing in what may be called 'God'. This 'reason' is really a primordial intuition, which I do not (and cannot) elaborate upon at any great length. It must be either accepted as intuitively self-evident or else rejected. Furthermore, God must be conceived of as 'infinite' consciousness that everywhere sustains the innumerable 'finite' consciousnesses that we are. What else could he be but consciousness? And how could he be finite? But if his omnipresent infinite consciousness everywhere sustains our finite consciousness, like an ocean containing drops of water, then the distinction between our consciousness and that of God ultimately vanishes.

A subtlety in this argument for 'God' should be recalled. It is only when I first conceive of consciousness as something distinct from God that I feel that it cannot 'simply happen' all by itself. Anything of a 'non-divine' nature seems to me utterly incapable of 'explaining' its existence and requires something corresponding to the common conception of God to account for the source of its being. This conception of God includes the notion of being 'self-created' in an utterly miraculous and incomprehensible way. However, once we identify reality with consciousness, and consciousness with God, as I just did, then we can in effect say that Reality does create itself and is the source of its own existence. It was only when we saw reality or consciousness as distinct from God that we required God, but that was an incorrect view. This is in accordance with the Hua Yen view of reality as 'self-creating'; see the Encyclopedia Britannica.

Now some people might argue that perhaps one can speak of reality as being 'self-creating' but that this is an empty statement: it is only another way of saying that reality is. However, I insist that it is unacceptable to say of anything non-divine that it simply is. It cannot simply be, if it is non-divine. To be anything is a tremendous and inconceivable miracle. The question of the source of its being must still be addressed. Failure to realize the necessity of this question amounts to philosophical blindness.

Furthermore, my conception of 'God' is adding a key new ingredient: he is infinite consciousness, which includes, among other things, intelligence, wisdom, love, bliss and all other good attributes of pure consciousness. By way of comparison, Einstein felt reverence for the 'laws of nature' and even felt that there was some kind of mysterious 'intelligence' to them. But he apparently did not believe in a 'conscious' God - let alone an infinitely conscious one - and this is the crucial difference. So, for example, I do believe that God 'loves' and 'cares' for us in some sense, as would an infinite consciousness rather than a human mother. The Mahayana scriptures also speak of Buddha's 'compassion' for all sentient beings, who must all be led to liberation, no matter how evil. God or Buddha must not be conceived of as some dry, abstract and cold principle.

The key difference between our consciousness and that of God is that ours is finite and his is infinite. So, for example, we have a limited perspective and can only see a tiny speck of reality from a narrow point of view, whereas he can instantaneously and simultaneously 'see' all of reality from every possible point of view. It is this unified and omniscient consciousness to which the Avatamsaka Sutra tends. This, perhaps better than anything, explains the astonishing philosophy of 'interpenetration' and totality for which the scripture is famous. It is reality as seen by God (called Buddha) rather than by mere unenlightened mortals. I seriously entertain the possibility that through sheer exalted meditation, the authors of this scripture may have attained such a consciousness or something resembling it. The basic message of the scripture is that the potentiality of our consciousness is tremendous, indeed infinite. It sends a shiver up my spine!

Your common sense may tell you that the human perspective on reality is finite and particular for a very simple reason: we have finite, discrete bodies with finite, discrete eyes! I would respond by saying that our limited perspective is not caused by our body; rather, our body is the manifestation of our finite consciousness. It is because we are not yet enlightened that we are temporarily 'trapped' in the body, with all its limitations. Upon full enlightenment, we will reunite with the Universal Consciousness and forsake our body like a butterfly emerging from its cocoon. However, some enlightened beings may assume bodies in order to help struggling beings, and then these teachers are called 'Buddhas'.

Furthermore, it seems quite credible to me that one may transcend the body in this very life, through sufficiently advanced meditation. This could explain such phenomena as telepathy and out of body experiences. I have not personally had any such experiences, and my overall philosophy does not depend on them. But if the Universal Consciousness is the source of everything, and if this consciousness dwells at the 'center' of our finite consciousness, sustaining it and 'projecting' the universe onto our awareness like a movie onto a screen, then anything is possible. For most of us, the display called the 'universe' is constrained by the laws of physics, for reasons having to do with our spiritual development, as discussed later in a bit more detail. But there is nothing absolute about the laws of physics. Why should they be, if God 'made' them?

I believe that God, thus conceived, is what Mahayana Buddhists refer to as 'Dharmakaya' or 'Buddha Nature'. The Dharmakaya is the 'reality body' of the Buddha - his ultimate, transcendental reality beyond his other manifestations, namely, the physical bodies of the historical Buddhas (i.e. all fully realized masters) or the 'bliss' bodies of the 'heavenly' Buddhas. The latter are splendid manifestations, rather like the Christian notion of angels, but because they can still be seen as a 'form' or shape, they are not the ultimate transcendental body, which is none other than the infinite consciousness that contains all reality. Rather than try to justify this interpretation of the Dharmakaya by quoting from the Mahayana canon as a whole, I will simply keep an eye open for similar ideas in the excerpts to follow.

So if all of Reality is ultimately the infinite consciousness called 'God' (or 'Buddha' or 'Buddha Mind' or 'Dharmakaya'), and if unity is the salient characteristic or quality of consciousness, then it is not so surprising that the Avatamsaka propounds on the 'interpenetration' and mutual identity of all things. It seems that most if not all mystical writings contain notions of the essential unity of the mystical experience, which is generally identified as union with God. The mystical experience may simply be a deep and intense realization of the fundamental unity of consciousness, of Reality as it truly is. This unity would seem to be inherent in the ultimate nature of consciousness, but it evidently 'recedes' from our apprehension under the influence of ordinary discriminative thinking, which analyzes experience into distinct elements.

Perhaps it is the belief that these elements correspond to real and distinct entities that fragments the fundamental unity of consciousness and produces the ordinary and uninspired consciousness that we are familiar with. In a very real sense, we are (or seem to be) what we believe we are. This ordinary consciousness sees only 'things', most of which appear inanimate, and many of which appear in conflict with the all-important 'thing' called ego. The very fragmentation of consciousness produces the ordinary and uninspired mentality or mood, that we find unsatisfying, and that incites a restless and vexing search for satisfaction in sense stimulation and ego gratification. Conversely, the restoration of our apprehension of the unity of consciousness may induce the bliss that mystics speak of, not to mention their powerful conviction that they have discovered 'Reality', that they see things as they really are.

The emphasis on unity in the Avatamsaka is not such a break with the emphasis on emptiness in the earlier Prajnaparamita literature. Consider the quotation below, given already on my Emptiness Page (see Prajnaparamita Sutra in 8000 Lines ).

Mirror Image of Pure Presence

Subhuti: The suchness of the Tathagata [Buddha], the one who has disappeared by awakening as Reality, is the very same as the suchness of all possible structures of relativity [phenomena, Samsara]. So the pure presence of Subhuti the Elder is universal pure presence. ... Thus it can be said that the unidentifiable Subhuti now speaking is simply indivisible, undifferentiated suchness and is therefore a living image of universal Buddha nature.

...

The transparent suchness of Buddha and the transparent suchness of all phenomena are simply suchness - not divided or divisible, not multiple, not even single. This pure presence, without any second reality or subreality, is not located anywhere, nor does it come from anywhere, nor does it belong anywhere, much less is it going anywhere or evolving in any way. It is precisely because this pure presence does not belong anywhere that it is total and simple.

In the Prajnaparamita Sutras, the immediate 'suchness' of phenomena, is equivalent to the 'emptiness' of all phenomena. In other words, the true suchness of phenomena is empty of all conceptual mediation or interpretation. 'Form is emptiness ... Samsara is Nirvana'. It is immediate non-dualistic consciousness, which is the only true reality. And it is the same everywhere and in everybody and everything. So Emptiness implies Suchness, which implies Unity, and All is in All. Despite appearances to the contrary, there is a spiritual continuity in the evolution of the Mahayana.

Finally, it must not be forgotten that 'mystical' literature such as the Avatamsaka can never be truly understood if we remain in an ordinary, discriminative, rational state of mind. Common sense is not appropriate here! We must accept that, through deep meditation, the consciousness of the aspirant becomes 'charged' in such a way that he sees an indescribable, shining 'magic' everywhere, and recognizes that this same 'suchness' is the true reality pervading all phenomena - the pure essence of his consciousness. Our inclination is to dismiss this as illusion, just as a dog that sees the world in black and white might be tempted to dismiss color as a 'pipe dream'. In reality, it is we who are living in the shadows. And any superficial resemblance in the vision of the Avatamsaka to 'irrationality' or 'insanity' is not so much wrong as irrelevant. A Buddha can interact seamlessly with the phenomenal world, understanding everything perfectly with direct intuition and spontaneity of mind. He has no need of discursive thought.

Another approach to all this is through the terminology of Advaita Vedanta. (I have argued elsewhere for a deep spiritual affinity between Mahayana and Advaita.) Advaita says that only Atman (the Seer) exists. Brahman (the seen, the apparently external universe) is not different from Atman. In fact, the two are identical. I interpret this according to my philosophical position of subjective idealism: Atman the consciousness is identical to Brahman the phenomena.

Now the Seer is like an infinitesimal point; if we could perceive any extension in it, it would be the seen and not the Seer. It is also immediately and intuitively self-evident that the seen is indeed identical to the Seer. Only conceptual confusion prevents us from realizing the utter indistinguishability between subject and object. These are only different words for the same immediate experience, the same immediate awareness.

Remark: To be sure, Advaita does insist that we cease all identification with body, senses, emotions, thoughts, etc. This is the 'Neti, Neti' of the Upanishads. However, this only applies when we are in our mistaken mode of dualistic thinking, where the illusion of a separate body must first be conceived before we can 'identify' with it and 'cling' to it, to the exclusion of all else. Once we have returned to the realm of non-dualistic consciousness, we can then identify Atman with Brahman. There is no longer any distinction between self and other.

But if the Seer is similar to a 'point', and if the seen and Seer are indistinguishable, then it is clear that all Reality is One and the Same. For there is no distinction in a point - there is only the absolute unity of an infinitesimal point without parts. Of course, I do not mean that the Seer can be observed as a point; this would totally contradict the nature of the Seer, which is to see and not to be seen. Normally, though, we get 'lost' in the phenomena and think that they are 'out there', extended in space and separate from each other.

Perhaps the mystic, upon fully realizing his true nature as Seer only, experiences a profound change in consciousness: the Seer, upon realizing itself, focuses like a laser, like a brilliant sun, as it is no longer distracted by its conceptual error in identifying with the phenomena, when perceived as separate and extended. This latter confusion and ignorance would appear to scatter and dilute consciousness, leading to our ordinary, unenlightened and torpid (or even painful) state of consciousness.

It is simply an intuitively self-evident fact that Seer and phenomena are the same, and there is nothing 'beyond' the phenomena. Subjective idealism is irrefutable when properly understood. But it is equally clear that the Seer must be like a point, if we can use any phenomenological analogy at all. So it follows logically that since a 'point' has no parts, then there is an utter unity and indivisibility of all Being, which is identical to Consciousness, i.e. to the Seer. This becomes self-evident to the mystic when his consciousness has focused in on its true nature, has become intensely self-aware in an immediate and non-dualistic fashion, without distinction of subject and object, and directly intuits the indescribable 'suchness' of its being. In this light, All is in All, not metaphorically, but according to the most fundamental ontological reality.

And since this infinitesimal point called the Seer is the basis for all Reality, which it 'projects' out like a movie screen, like a magnificent spectacle, then this incomprehensible and unimaginable center of our being is none other than God or Buddha, the source of all reality. As the source of all reality, it could make anything appear at any time - such a game would be child's play to it. For now, it has constrained phenomena according to the present laws of physics, for the sake of our spiritual evolution. But the infinite possibilities remain, and perhaps some of them are revealed to those further along on the spiritual path, whose awareness has penetrated closer to the Center of Being.

Finally, the apparently different 'Seers' (i.e. people) in the universe cannot be truly different. The same ultimate source of Being, the same Universal Consciousness, underlies them all. I have already explained how consciousness is not in space, but rather space (and time) are within consciousness. So it is erroneous to imagine different consciousnesses as scattered in some kind of enveloping superspace. Therefore, we are not distinct in any spatial or geometrical sense, and so we are not truly distinct at all.

Nevertheless, there appears to be what may be called a 'phenomenological' distinctness: my experience is not yours. This is a paradox that I have still not resolved. I think that I have some grasp of the unity that exists within a single consciousness, such as my own, but I do not understand how my consciousness is ultimately the same as yours. But the mystical superstars of human history say this is so, and I cannot cavalierly discard their insight. Furthermore, it follows logically from the unity of God (see below), as well as from the spatial considerations just mentioned. So I need to think about this some more. Understanding this paradox may prove to be one of the ultimate revelations of the spiritual adventure. I suspect that acquiring this splendid insight may have something to do with learning how to truly love others, which is not yet one of my strong points.

If the discussion above for the unity of consciousness seems inadequate, then we can approach the topic in a different way. As I said, I think that the idea that everything is consciousness is irrefutable, and the question that remains is in what sense consciousness is a unity. Now if consciousness and God are indeed fundamentally the same, for the reason given on my Philosophy Page and repeated above, namely that the presence of God is required to sustain the existence of any manifestation of consciousness, then we can ascertain (or perhaps I should say infer) the unity of consciousness from the unity of God. Indeed, it seems 'intuitively evident' that God must be a unity. How could we speak of God as having parts? It would be absurd to think of God as in any way like a machine, and a machine is but a collection of interacting parts.

And yet the appearance of a multiplicity of interacting shapes and colors remains. We cannot deny this, and neither does the Avatamsaka. Instead of resorting to an absolute and doctrinaire denial of multiplicity, as is sometimes done in Greek philosophy, the Avatamsaka in fact celebrates the multiplicity of the world as harmoniously contained within the fundamental unity of consciousness. The unity is the essential reality, but it manifests in a vast illusory spectacle of shape and color, and the Avatamsaka delights in fantastic and even riotous imagery to describe Reality. This theme of the harmonious interpenetration of all elements of reality, of the 'one in the many' is elaborated at length by the Chinese Hua Yen school. But instead of trying to clarify these perplexing notions any further, let us examine some excerpts and continue our discussion in light of the actual words of the scripture.

Excerpts from the Avatamsaka Sutra

with commentary

The following excerpts are from the translation of The Flower Ornament Scripture by Thomas Cleary, published by Shambhala. The book is attractive and well made and has over 1600 pages. Only a tiny portion of this work is provided by the following excerpts, and there is no guarantee that they are a representative sample.

Furthermore, the structure of the book, such as it exists, has been ignored, due to my ignorance; I too have only sampled this massive volume. Fortunately, the excerpts are sufficiently interesting that it is worthwhile considering them in isolation. This is further justified by the fact that the scripture is not a systematic exposition of a well-developed philosophy but rather a colorful and imaginative evocation of an ineffable vision. It does no violence to the text to pluck excerpts more or less at random. No line of thought seems to be developed for more than a few paragraphs at a time.

Despite the unsystematic nature of the scripture, these paragraphs do contain characteristically 'Mahayana' ideas that can be discussed to some extent, provided we proceed with caution, bearing in mind the ultimate ineffability of any mystical experience. In fact, the Avatamsaka gave rise to the famous Hua Yen school of Buddhist thought in China during the Tang dynasty (618-907 AD), in which a more or less systematic philosophy was indeed developed. I do not claim that my comments are equivalent to the interpretations of the Hua Yen school, which I have also not yet studied in detail. Rather, these comments are purely personal interpretations in light of my own philosophy. Hopefully, they will provide some insight into this challenging scripture, however flawed or partial that insight might be.

The text is a mixture of prose and poetry, divided into 39 chapters of varying length. We start with the introductory paragraphs of the scripture to set the scene. Then we jump to randomly chosen but sequential excerpts, mostly consisting of poetry. The excerpts are in purple; my comments are in black. Page references are to the edition published by Shambhala in 1993. 'Enlightening being' is Cleary's translation of 'Bodhisattva', a highly spiritually developed being who has temporarily forsaken Nirvana in order to save suffering beings by teaching them the Buddha's wisdom.

Book One: The Wonderful Adornments of the Leaders of the World

THUS HAVE I HEARD. At one time the Buddha was in the land of Magadha, in a state of purity, at the site of enlightenment, having just realized true awareness. The ground was solid and firm, made of diamond, adorned with exquisite jewel disks and myriad precious flowers, with pure clear crystals. The ocean of characteristics of the various colors appeared over an infinite extent. There were banners of precious stones, constantly emitting shining light and producing beautiful sounds. Nets of myriad gems and garlands of exquisitely scented flowers hung all around. The finest jewels appeared spontaneously, raining inexhaustible quantities of gems and beautiful flowers all over the earth. There were rows of jewel trees, their branches and foliage lustrous and luxuriant. By the Buddha's spiritual power, he caused all the adornments of this enlightenment site to be reflected therein.

The scene opens with the moment of enlightenment of the historical Buddha, yet the scene is fantastic. (Clearly, the authors knew what they were doing. They were intelligent monks and scholars!) So it is enlightenment that changes the 'ordinary' world into a paradise. Western mystics have also described this phenomenon, e.g. Jacob Boehme gazing at the grass and flowers in wonder. Also, note that the enjoyment of sense delights does not agree with any ascetic evaluation of Samsara (the everyday world of perception). The purpose of the Buddhist emphasis on 'detachment' from Samsara is to achieve purity of consciousness (enlightenment), one of whose effects is exquisite sensitivity to the beauty of all Samsara, without clinging to anything of a transient nature. It becomes a magical show that flows past unimpeded by any mental grasping arising from ego and desire. So Samsara is Nirvana, a key assertion of the Mahayana.

However, the enlightened state may sometimes also produce visions, perhaps containing some spiritual message. Furthermore, the enlightened mind may spontaneously produce visions, as a kind of creative play, without any message, not unlike some psychotropic drugs (which I do NOT advocate). This may be similar to the creativity of God's mind, which produces the universe out of consciousness. Perhaps approaching the divine state in meditation induces the mind to emulate some of God's creative power. It is not a mistake to associate the Buddha with a 'creative' God as found in other religions. Note the reference to the Buddha's spiritual power. He will increasingly assume a cosmic status, which, if anything, goes beyond the mere 'external creator and ruler God sitting on his throne' of Middle Eastern origin.

(Indeed, the essence of the distinction between the God of Judaism, Christianity and Islam, on the one hand, and of the 'God' of the Indo-Asian religions, on the other, is that for the former religions God is some kind of object (or 'superobject') out there somewhere, whereas for the latter religions God is immanent in our very consciousness, at the very center of consciousness, sustaining all of reality, which is nothing but consciousness.)

The tree of enlightenment was tall and outstanding. Its trunk was diamond, its main boughs were lapiz lazuli, its branches and twigs were of various precious elements. The leaves, spreading in all directions, provided shade, like clouds. The precious blossoms were of various colors, the branching twigs spread out their shadows. Also the fruits were jewels containing a blazing radiance. They were together with the flowers in great arrays. The entire circumference of the tree emanated light; within the light there rained precious stones, and within each gem were enlightening beings, in great hosts like clouds, simultaneously appearing.

The enlightening beings inside the gems: our first intimation of the 'all in all' (i.e. the characteristic doctrine, associated with the Hua Yen scripture and school, of the interpenetration and mutual identity of all elements of reality). This becomes especially evident when we consider the later identification of the 'reality body' of the Buddha with all of reality, that is, with the universe itself. (The 'reality body' or Dharmakaya is a key Mahayana tenet. It is the cosmic 'body' of the Buddha, or rather, the cosmic mind of the Buddha - his essential nature beyond any of his earthly or heavenly manifestations.) If Buddha or God (consciousness) is everything, and if God is fundamentally a 'unity' without distinction or parts, then a 'piece' of God (consciousness) here must be intimately linked with a piece there, so that the distinctions are only apparent. They all occur within a single overall consciousness, as explained in the Introduction. (Even the apparent 'brick wall' between your consciousness and mine must be ultimately illusory, if the same God or Buddha or Universal Consciousness sustains both of us. This is an ultimate paradox that is beyond my comprehension, but that I must accept as a logical implication of my philosophy, and which is confirmed by the mystical testimony.)

So the tree of enlightenment (the consciousness of Buddha) rains jewels which contain enlightening beings (budding buddhas) who in turn contain the universe within their consciousness. The consciousness of the enlightening beings is not different from the consciousness of the Buddha (or Buddhas). Consciousness emanates consciousnesses; Reality emanates reality.

Stated somewhat differently, we might say that in every 'particle' of consciousness is the essence of all consciousness, of everything. The English mystical poet William Blake believed that, if sufficiently inspired, you could see

... a World in a Grain of Sand
And a Heaven in a Wild Flower,
Hold Infinity in the palm of your hand
And Eternity in an hour.

And a remarkably similar idea was expressed by the Chinese Ch'an (Zen) Master Huang Po, who also connects the 'One in All' (or 'All in All') idea with the earlier Mahayana theme of Emptiness:

When your glance falls on a grain of dust, what you see is identical with all the vast world-systems with their great rivers and mighty hills. To gaze upon a drop of water is to behold the nature of all the waters of the universe. Moreover, in thus contemplating the totality of phenomena, you are contemplating the totality of Mind. All these phenomena are intrinsically void and yet this Mind to which they are identical is no mere nothingness. By this I mean that it does exist, but in a way too marvelous for us to comprehend. It is an existence that is no existence, a non-existence which is nevertheless existence. So this true Void does in some marvelous way 'exist'. (The Zen Teachings of Huang Po, P. 108)

I believe, based on my philosophical ideas, that the ultimate meaning of such a vision - which is not unlike that of the Avatamsaka - is more than metaphorical; it is an essential truth in the most real sense. The point is that consciousness cannot be divided into particles; it only seems to be that way. We have only one consciousness, and this consciousness is the same whether we are gazing at this particle of sand or that one. The shapes and colors come and go, like clouds; the conscious 'essence' is the enduring reality, like the sky. But it must not be conceived of as a 'thing' or 'object' or 'substantial' reality in its own right, separate and distinct from consciousness. This is patently absurd: consciousness distinct from consciousness! Hence the Buddhist insistence on the 'emptiness' of things, i.e. of consciousness. However, the entire universe springs as an illusion from this mysterious fundamental reality called consciousness.

Indeed, I will be so bold as to claim that the creative power of consciousness is so great that 'anything' could, in principle, spring out of 'anything'. Any illusion could appear anywhere, at any time, if God (i.e. consciousness) so desired. (Of course, God does not have 'desires'; this is a figure of speech.) The fact that our phenomenal world strictly obeys certain physical laws, at least most of the time, is closely related to our spiritual development. We need to be in a 'world' constrained by physical laws for the sake of the development of consciousness. I cannot tell you in complete detail exactly why, but this conclusion seems inevitable to me, once we believe in God, and once we believe that our life has a spiritual purpose.

And along the same lines, I think that highly developed beings may indeed be capable of 'miraculous' abilities, such as telepathy or even the manipulation of the phenomenal world. As their consciousness becomes purified, they approach the 'source' of reality, namely God or 'pure consciousness'. The constraints of physical law may indeed be loosened for them; they may acquire knowledge and creative powers not unlike those of God himself. Of course, due to their spiritual purity and love of all beings, they would never think of abusing these powers for their own aggrandizement. Furthermore, they would avoid working miracles to give ordinary beings a quick and easy escape from problems, if such an escape entails a circumvention of the usual physical laws. (They might, however, be willing to provide inspiration and spiritual guidance, in so far as this harmonizes with natural law.) The enlightened beings realize intuitively that unenlightened beings must dwell for a while in a world of physical laws such as ours as part of their spiritual development.

Although I cannot prove any of this, and I cannot claim certainty regarding these somewhat bold and extravagant claims, they do seem plausible to me in light of my overall philosophy. I also think it plausible that the highly developed masters who wrote the Avatamsaka may have had many experiences that we would consider wonderful or even miraculous. I cannot always tell what is metaphorical and what is 'real' in this scripture, since I am an ordinary being. However, my philosophical ideas leave me quite open-minded regarding levels of reality far more fantastic and wonderful than what I have experienced so far. This life is only a temporary dream - and not even a pure and beautiful one, due to our delusion, but rather a state of torpor and ignorance.

Also, by virtue of the awesome spiritual power of the Buddha, the tree of enlightenment constantly gave forth sublime sounds speaking various truths without end.

Many Chan and Zen masters, not to speak of other mystics, have spoken of suddenly attaining enlightenment upon hearing a splash of water or a bird chirping, or upon seeing the reflection of light in water, or by any other perceptual or mental stimulus. Enlightenment is being sensitive to the deep and beautiful nature of consciousness in all its aspects. Hence the Mahayana equivalence of Samsara and Nirvana. In this way can all reality speak the wisdom of the Buddha. Ultimately, reality is not different from the mind of the Buddha, as will become increasingly clear, so that wisdom can be contained in stones, trees and wind, for those who can see and hear.

The palace chamber in which the Buddha was situated was spacious and beautifully adorned. It extended throughout the ten directions. It was made of jewels of various colors and was decorated with all kinds of precious flowers. The various adornments emanated lights like clouds; the masses of their reflections from within the palace formed banners.

A boundless host of enlightening beings, the congregation at the site of enlightenment, were all gathered there: by means of the ability to manifest the lights and inconceivable sounds of the Buddhas, they fashioned nets of the finest jewels, from which came forth all the realms of action of the spiritual powers of the Buddhas, and in which were reflected images of the abodes of all beings.

Also, by virtue of the aid of the spiritual power of the Buddha, they embraced the entire cosmos in a single thought.

Their lion seats were high, wide, and beautiful. The bases were made of jewels, their nets of lotus blossoms, their tableaus of pure, exquisite gemstones. They were adorned with various flowers of all colors. Their roofs, chambers, steps, and doors were adorned by the images of all things. The branches and fruits of jewel trees surrounded them, arrayed at intervals.

Clouds of radiance of jewels reflected each other: the Buddhas of the ten directions conjured regal pearls, and exquisite jewels in the topknots of all the enlightening beings all emanated light, which came and illuminated them.

Furthermore, sustained by the spiritual powers of the Buddhas, they expounded the vast perspective of the Enlightened Ones, their subtle tones extending afar, there being no place they did not reach.

At that time, the Buddha, the World Honored One, in this setting, attained to the supreme, correct awareness of all things. His knowledge entered into all times with complete equanimity; his body filled all worlds; his voice universally accorded with all lands in the ten directions. Like space, which contains all forms, he made no discrimination among all objects. And, as space extends everywhere, he entered all lands with equanimity. His body forever sat omnipresent in all sites of enlightenment. Among the hosts of enlightening beings, his awesome light shone clearly, like the sun emerging, illumining the world. The ocean of myriad virtues which he practiced in all times was thoroughly pure, and he constantly demonstrated the production of all the buddha-lands, their boundless forms and spheres of light extending throughout the entire cosmos, equally and impartially.

We have further reference to the cosmic nature of the Buddha, as well as a new element: nondiscrimination. A salient characteristic of the mystical vision in all times and places is the emphasis on nonduality, on nondiscrimination, on the fundamental unity of all things, on the unity of the Cosmic Mind or Universal Consciousness in which all 'things' are contained as illusion. (Note: Some particularly explicit descriptions of the cosmic nature of the Buddha can be found in Book 33: Inconceivable Qualities of Buddhas.)

He expounded all truths, like spreading great clouds. Each of his hairtips was able to contain all worlds without interference, in each manifesting immeasurable spiritual powers, teaching and civilizing all spiritual beings. His body extended throughout the ten directions, yet without coming or going. His knowledge entered into all forms and realized the emptiness of all things. All the miraculous displays of the Buddhas of past, present, and future, were all seen in his light, and all the adornments of inconceivable eons were revealed.

Another allusion to the 'all in all', to the interpenetration of all things, to the fundamental unity and harmony of all things. There will be many references to the pores and hairtips of the Buddha in this scripture! The body extending in all directions is really the Cosmic Mind of the Buddha or God, which contains the universe within the illusion of consciousness. It is because the cosmic body is Cosmic Mind or Universal Consciousness that it does not either 'come or go'. There is really no external space containing things which may come or go, as explained on my Philosophy Page.

This Cosmic Mind can also be conceived of as emptiness, as explained on my Emptiness Page. Emptiness is, on the one hand, wisdom or the absence of discriminative thought which falsely divides reality (consciousness) into subject and object, and the object into a myriad of discrete things that seem to exist externally to mind. In reality, there is just one vast consciousness, which contains the universe as an illusion. Many mystics, such as Yogananda, Ramana Maharshi, various Chan/Zen masters, and many others, have attested with complete conviction to the direct experience of the unity of the Cosmic Mind. They insist that this is the fundamental Reality and that the world of multiplicity that we see is an illusion due to our discriminative mind. Of course, they still see the same shapes and colors as we do, but they see it as One Mind.

So Emptiness can, on the other hand, also refer to this One Mind, as well as to the absence of discriminative thinking which reveals the One Mind. Many Buddhist scholars and even practicing Buddhists may deny any such 'substantial' interpretation of emptiness (e.g. as the One Mind) as completely contrary to the essence of Buddhism, which denies, in principle, any kind of permanent being or inherent existence. However, I believe that this objection is unfounded. An external world of discrete, substantial, enduring objects is indeed being denied, as is the illusion called 'ego'; only the flow of consciousness remains, and no one can deny this.

There were great enlightenment beings numerous as the atoms in ten buddha-worlds surrounding him. Their names were: Universally Good (Samantabhadra), Light of the Supreme Lamp of Universal Virtue, Lion Banner of Universal Light, Subtle Light of Flames of Universal Jewels, Banner of Oceans of Qualities of Universal Sounds, Realm of Enlightenment of Radiance of Universal Knowledge, Banner of Flowers of a Topknot of Universal Jewels, Pleasing Voice of Universal Awareness, Light of Inexhaustible Virtue of Universal Purity, Mark of Universal Light, Great Brilliance of the Light of the Moon Reflected in the Ocean, Undefiled Treasury of Light of Oceans of Cloudlike Sounds, Born of Wisdom and Adorned with Virtue, Great Light of Sovereign Virtue, Brave Lotus Topknot, Sun Banner of Clouds of Universal Knowledge, Greatly Persevering with Indestructible Courage, Light Banner of Fragrant Flames, Deep Beautiful Sound of Great Enlightened Virtue, Born of Wisdom with the Light of Great Virtue. These and others were the leaders - there were as many as there are atoms in ten buddha-worlds.

The author(s) had a sense of humor, as well as a flamboyant poetic imagination. These various enlightening beings are different aspects of enlightenment itself. An enlightened consciousness reflects the Buddha's mind and hence Reality itself. Reality is the same as Consciousness, which contains the qualities of all things, either explicitly or implicitly. This suggests the Yogacara doctrine of the Alayavijnana or 'Storehouse Consciousness', but let us not digress too much. Notice also how 'Buddha' and 'Buddhas' are interchangeable in this text; they are all different aspects of the reality of consciousness. God or Consciousness is everything, manifesting himself in countless Buddhas and other beings, who are but different reflections of the universal light, like the sparkles on the surface of the water.

Now comes some poetry. These are the first verses of the first chapter.

The buddha body extends throughout all the great assemblies:
It fills the cosmos, without end
Quiescent, without essence, it cannot be grasped;
It appears just to save things.

The Buddha, King of the Teaching, appears in the world
Able to light the lamp of sublime truth which illumines the world;
His state is boundless and inexhaustible:
This is what Name of Freedom has realized.

The Buddha is inconceivable, beyond discrimination,
Comprehending forms everywhere as insubstantial.
For the sake of the world he opens wide the path of purity:
This is what Pure Eyes can see.

The Buddha's wisdom is unbounded -
No one in the world can measure it.
It forever destroys beings' ignorance and confusion:
Great Intelligence has entered this deeply and abides there in peace. p. 65

July 2003: The preceding was written in October 2001. I was hoping to add many more comments to these excerpts, but I guess that will not happen. It does not matter. I have expressed enough of my ideas and interpretations above, and now let us allow this fascinating text to speak for itself. As I reread what I wrote above, I am struck that my basic ideas have not changed. My writing above does seem a bit dense and indigestible, and I think that I have developed a slightly more agreeable style since then. Anyhow, these ideas are one possible interpretation, and it turns out that they are quite consistent with Advaita, which I had only begun to study at the time. Some may argue that it is 'illegitimate' to mix Advaita and Buddhism. I would answer by making two points: (1) Advaitic ideas seem to give a quite credible interpretation to these more poetic and esoteric words; I do not see that any violence to the texts has been perpetrated; and (2) if the truth is One, then this is to be expected, if Advaita and Mahayana are indeed two manifestations of the truth. This is one of my pet themes, which I am now pursuing at my discussion group ClearVoid.

The vast eye of the Buddha
Is pure and clear as space,
Seeing all beings
With complete clarity.

The great light of the Buddha body
Illumines the ten directions,
Manifesting in every place:
Traveling Everywhere sees the way.

The Buddha body is like space;
Unborn, it clings to nothing,
It is ungraspable and without inherent nature:
This is seen by Wind of Good Omen.

The Buddha, for countless eons,
Has expounded all holy paths,
Destroying barriers for all beings:
Sphere of Perfect Light understands this.

. . .

The realms of all sentient beings
Whirl in the sea of birth and death.
Buddha emits a pain-killing light:
The Unhindered spirit can see this. p. 104

Buddha sits in the hall of truth with steady gaze,
Brilliantly lighting up the palace.
In accordance with the disposition of all beings
His body appears throughout all lands.

The Buddha's palace is beyond conception,
Adorned with stores of precious jewels,
Each decoration shining with light;
Sitting there, the Buddha is most conspicuous of all.

With pillars of jewels of various hues,
Chimes of real gold hanging like clouds,
Jewel stairways in rows on four sides,
The gates open in every direction.

Arrays of banners of flowery silk,
Jewel trees with decorated branches and boughs,
Garlands of pearls draped on all sides;
The Ocean of Wisdom sits calmly therein.

Nets of jewels, exquisite fragrant banners,
Brilliant lamps hung like clouds;
Covered with various decorations,
The world-transcending true knower sits within.

Everywhere he manifests clouds of mystic displays,
Those clouds teaching throughout the world;
Harmonizing and calming down all sentient beings:
All this appears from the Buddha's palace.

Trees of gems bloom with fine flowers
Having no peer in all the world;
The embellishments of the lands of all times
Reveal their reflections therein.

Everywhere there are heaps of jewels;
Their light blazes in countless hues.
Gates and doors open at intervals all around;
The beams and ceiling are especially beautiful.

The Buddha's palace is inconceivable;
Its pure radiance contains every form-
In it appear all palaces,
A Buddha sitting in each.

The Buddha's palace is boundless;
The Naturally Awakened One abides therein.
All the masses from all ten directions
Come gather around the Buddha. pp. 140-141

The Buddha cultivated an ocean of blessings,
Many as the atoms in all lands;
Produced by the powers of his mind and will,
The enlightenment site is pure, without any taint.

Wish-fulfilling jewels are the roots of the trees,
Diamonds are their trunks;
Nets of jewels cover them
And a rich fragrance surrounds.

The tree branches are adorned by all kinds of gems,
The limbs are of precious stones, soaring high;
The branches and twigs hang thickly, like heavy clouds:
Underneath sits Buddha on the enlightenment site.

The site of enlightenment is unthinkably vast:
The trees surround it, covering all;
The dense foliage and luxurious flowers mutually cover and reflect,
While in the flowers grow gemstones fruits.

From among all the branches emanate beautiful lights
Illuminating the whole enlightenment scene;
Pure, bright, inexhaustible,
This appears by the powers of the Buddha's vows.

Banks of precious stones are the flowers,
Reflections shining like patterned clouds;
The encircling trees perfume all around:
The enlightenment site's adorned everywhere.

See in the site of the Buddha's enlightenment
Lotuses and jewel nets, all pure;
Flames of light in whorls appear from here,
Music of bells and chimes come from the clouds.

All the wonderfully adorned trees
Existing in all the lands
Appear in the enlightenment tree;
Buddha, beneath it, sheds all defilement.

The site of enlightenment is made of vast blessings;
The tree branches rain jewels without end.
In the jewels appear enlightening beings,
Going everywhere to serve the Buddhas.

The realm of the Buddhas is inconceivable;
They cause all the trees there to produce music-
In accord with the enlightened way developed by the Buddha,
The hosts of beings, hearing the music, can see it all. pp. 141-142

Book Two: Appearance of the Buddha

The Buddha's body fills the cosmos,
Appearing before all beings everywhere-
In all conditions, wherever sensed, reaching everywhere,
Yet always on this seat of enlightenment.

In each of the Buddha's pores
Sit Buddhas as many as atoms in all the lands,
Surrounded by masses of enlightening beings
Expounding the supreme practice of the universally good.

Buddha, sitting at rest on the enlightenment seat,
Displays in one hair oceans of fields;
The same is true of every single hair,
Thus pervading the cosmos.

He sits in each and every land,
Pervading the lands one and all;
Enlightening beings from everywhere gather,
All coming to the enlightening scene. p. 162

The profound knowledge of the Buddha
Enters everywhere in the cosmos:
Able to operate in accord with all times,
It is a clear guide for the world.

The Buddhas have the same reality-body -
It depends on nothing, is without distinction;
It causes beings to see Buddha in physical form
According to their intellects.

Replete with all knowledge,
Buddha knows all things:
In all lands,
Everything is evident.

Buddha's bodies, lights, and physical forms
Are all inconceivable.
Sentient beings who believe
He causes to see them according to potential.

In one Buddha-body
He produces infinite Buddhas,
Thunderous sound pervading all lands
Expounding the teaching, the deep ocean of thusness.

In each hair pore
Are webs of light pervading all quarters,
Intoning the sublime voices of Buddha,
Taming the hard to tame.

From the Buddha's light
Issues deep and wondrous sound
Extolling the Buddha's ocean of virtues
And the practices of enlightening beings. p. 163-164

Buddha's body is always apparent,
Filling the entire cosmos,
Always intoning far-reaching sound
Shaking all lands in all quarters.

Buddha manifests bodily everywhere,
Entering into all worlds,
Revealing occult spiritual power
According to the inclinations of beings.

Buddha appears before all beings
In accordance with their minds;
What the sentient beings see
Is the Buddha's mystic power.

His radiance has no bounds
And his teaching too is infinite;
Buddha children enter and observe
According to their knowledge.

The Buddha's body has no birth
Yet can appear to be born.
The nature of reality is like space:
Therein do the Buddhas dwell.

No abiding, yet no departing:
Everywhere the Buddha's seen;
His light reaches everywhere,
His fame is heard afar.

No substance, no abode,
And no origin that can be found;
No signs, no form:
What appears is like reflections. p. 164-165

Book Thirty Three: Inconceivable Qualities of Buddhas

The buddhas have ten things that pervade the infinite cosmos. What are these ten? All buddhas have unbounded bodies, with pure forms, entering into all states of being without defilement or attachment. All buddhas have unbounded, unobstructed eyes that can clearly see all things. All buddhas have unbounded, unobstructed ears that can understand all sounds and utterances. All buddhas have unbounded, unobstructed noses that can reach the other shore of freedom of the buddhas. All buddhas have universal tongues that utter sublime sounds pervading the cosmos. All buddhas have unbounded bodies that appear to sentient beings in accord with their minds. All buddhas have unbounded minds that dwell on the unobstructed impartial body of reality. All buddhas have unbounded, unobstructed liberation, manifesting inexhaustible great spiritual powers. All buddhas have unbounded pure worlds, manifesting buddha-lands according to the pleasures of sentient beings, replete with infinite adornments, yet without giving rise to any obsession or attachment to them. All buddhas have unbounded practical undertakings of enlightening beings, having complete knowledge, spiritual freedom, and ability to master all elements of buddhahood. These are the ten phenomena of buddhahood that pervade the cosmos without bound, which are in the perfectly enlightened ones. p. 909

The buddhas have ten kinds of instantly creative knowledge. What are these ten? All buddhas can, in a single instant, appear to descend from heaven in infinite worlds. All buddhas can, in a single instant, manifest birth as enlightening beings in infinite worlds. All buddhas can, in a single instant, manifest renunciation of the mundane and study of the way to liberation in infinite worlds. All buddhas can, in a single instant, manifest attainment of true enlightenment under enlightenment trees in infinite worlds. All buddhas can, in a single instant, manifest turning the wheel of Teaching in infinite worlds. All buddhas can, in a single instant, manifest education of sentient beings and service of the enlightened in infinite worlds. All buddhas can, in a single instant, manifest untold variety of buddha-bodies in infinite worlds. All buddhas can, in a single instant, manifest all kinds of adornments in infinite worlds, innumerable adornments, the freedoms of the enlightened, and the treasury of omniscience. All buddhas can, in a single instant, manifest countless pure beings in infinite worlds. All buddhas can, in a single instant, manifest the buddhas of past, present, and future in infinite worlds, with various faculties and characters, various energies, and various practical understandings, attaining true enlightenment in the past, present and future. p. 909

The buddhas have ten peerless inconceivable realms. What are they? All buddhas, once sitting, pervade infinite worlds in the ten directions. All buddhas, uttering one logical statement, can express all Buddha teachings. All Buddhas, emanating one light, can illumine all worlds. All buddhas, in one body, can manifest all bodies. All buddhas can show all worlds in one place. All buddhas can ascertain all things within one knowledge without any impediment. All buddhas can travel to all worlds in the ten directions in a single moment of thought. All buddhas can manifest the infinite spiritual powers of the enlightened in a single instant. All buddhas can focus on all the buddhas and sentient beings of past, present and future in a single instant without confusion of mind. All buddhas are in one instant essentially the same as all buddhas of past, future and present. p. 910

The buddhas can produce ten kinds of knowledge. What are they? All buddhas know all things have no aim, yet they can produce knowledge of dedicated undertaking. All buddhas know all things have no body, yet they can produce knowledge of pure bodies. All buddhas know all things are fundamentally nondual, yet they can produce knowledge capable of awareness and understanding. All buddhas know all things have no self and no being, yet they can produce knowledge to civilize beings. All buddhas know all things fundamentally have no marks, yet they can produce knowledge of all marks. All buddhas know all worlds have no becoming or decay, yet they can produce knowledge of becoming and decay. All buddhas know all things have no creation, yet they can produce knowledge of the effects of action. All buddhas know all things have no verbal explanation, yet they can produce knowledge of verbal explanation. All buddhas know all things have no defilement or purity, yet they can produce knowledge of defilement and purity. All buddhas know all things have no birth or extinction, yet they can produce knowledge of birth and extinction. p. 910

The buddhas have ten kinds of ways of entry into universality. What are they? All buddhas have immaculate bodies that penetrate past, present and future. All buddhas are endowed with three kinds of mastery - of diagnosis, prescription and occult powers - by which they edify beings everywhere. All buddhas are endowed with mnemonic powers able to receive and hold all Buddha teachings. All buddhas are endowed with four special knowledges - of principles, meanings, expressions, and elocution - and operate all cycles of pure teaching everywhere. All buddhas have impartial great compassion and never abandon all sentient beings. All buddhas have profound meditation concentration and always observe all sentient beings everywhere. All buddhas have roots of goodness beneficial to others, and civilize sentient beings unceasingly. All buddhas have unobstructed minds, able to abide calmly in all universes. All buddhas have unimpeded spiritual powers and are able to manifest the buddhas of past, present and future in one instant. All buddhas have unobstructed intellect, in a single instant defining sets of ages of past, present and future. pp. 910-911

Buddhas have ten great qualities that are hard to believe in. What are they? All buddhas can destroy all demons. All buddhas can overcome all false teachers. All buddhas can tame all sentient beings and make them all happy. All buddhas can go to all worlds and guide the myriad types of beings there. All buddhas can knowingly experience the most profound realm of reality. All buddhas can, by means of a nondual body, manifest various bodies, filling the world. All buddhas can, with pure voices, produce the special knowledges of principle, meaning, expression, and elocution, and expound truths endlessly, to the unfailing benefit of those who accept. All buddhas can manifest buddhas as numerous as atoms in all worlds in a single pore, without end. All buddhas can manifest in a single atom as many lands as atoms in all worlds, replete with all kinds of fine adornments, and continuously turning the wheel of sublime Teaching therein for the edification of sentient beings - yet the atom is not enlarged and the worlds are not small; they always abide in the realm of reality by realizational knowledge. All buddhas arrive at the pure realm of reality, shatter the darkness of ignorance of the world by means of the light of knowledge, cause all to gain understanding of the Buddha teachings, follow the enlightened, and dwell in the ten powers. pp. 911

Links

Manjushri Hua Yen Page: The Manjushri website contains a section on Chinese Buddhism, as well as much other information. (The photograph shown above of the interior of a Hua Yen temple was obtained from this site.)

Buddha's Light International Association has a publications section containing the pamphlet Different Practices, Same Path by the Venerable Hsing Yun, who gives a congenial and straightforward account of the eight schools of Chinese Buddhism, including Hua Yen. For more on Hsing Yun and his great work in spreading 'humanistic' Buddhism, see the rest of this site.

Huayen.org: Apparently a Hua Yen website in Taiwan - if you can read Chinese!

Buddhism and Blake: An interesting article on the relationship between William Blake and Chan (Zen) Buddhism, by Mark S. Ferrara.

Conceptions of the Absolute in Mahayana Buddhism and Shinran: A clear and informative discussion of how a concept of 'God' that transcends any merely theistic notion arose in Mahayana Buddhism, by Nityaprabha J. Paraskevopoulos.

Shinran was the founder Shin or Pure Land Buddhism, a type of Mahayana Buddhism that is popular in Japan. It is a religion of faith in the saving power of Amida Buddha, a transcendental (non-human) Buddha who dwells in the 'Pure Land'. By reciting the name of Amida with faith, one may be 'reborn' in the Pure Land, where conditions are favorable for further progress towards enlightenment. The Pure Land may be interpreted as both a specific place and a state of mind.

A reader of this page, E.R. Hu, was kind enough to suggest the following three links. The commentary is hers.

Resources for the Study of Buddhism: Extensive list of Buddhist resources in English, compiled by Dr Ron Epstein of the Philosophy Department of San Francisco State University.

Buddhist Text Translation Society (BTTS): founded in 1970 in San Francisco, California by the late Tripitaka Master Hsuan Hua of Manchuria China. The goal of BTTS is to translate the orthodox Buddhist canon from Sanskrit and Chinese into Western languages. To date, approximately 100 volumes of sutras and commentaries have been published in English, and a few volumes are offered in Spanish, French, and Polish. Select audio and visual materials are also available.

Dharma Realm Buddhist Association (DRBA): founded as the Sino-American Buddhist Association in San Francisco, California in the 1960's by the late Tripitaka Master Hua of Manchurai, China, the association has 28 temples and monasteries throughout north America and Asia. Currently headquartered at the City of Ten Thousand Buddhas in Ukiah, CA, DRBA houses a university, two high schools and two elementary schools.