Cheng-Tao-Ko [Shodoka]

[ Updates
& News ] [ Poetry & Stories ]
[ Theravada Writings ]
[ Zen / Ch'an Writings ]
[ Other Mahayana Writings ]
[ Buddhist Webrings ]
[ Buddhist Links ]
[ About this Page ]
[ Home ]

Cheng-Tao-Ko [Shodoka]

By Yung-chia Hsuan-chueh

CHENG-TAO-KO [Zhengdaoge] (C.); (J. Shodoka); Song of Enlightenment, Song of Immediate Satori, Song of Realization, Song of the Realization of the Way, Odes on Enlightenment is a Zen Buddhist didactical poem in 64 verses basic tenets of the Ch'an (Zen).

Its authorship is traditionally attributed to Yung-chia Hsuan-chueh [Yongjia Xuanjue] - one of the most gifted teachers of the Ch'an (Zen) school during the T'ang Dynasty China.

Yung-chia Hsuan-chueh [also known under the names of Yung-chia Hsuan-chio, Great Master Chen-chio, Yoka Genkaku (J.), Yoka Daishi (J.)] was a scholar and a monk who lived in the years 665-713. He was a Dharma heir of the 6th Zen Patriarch, Hui-neng (J. Eno) and Dharma brother to such personalities as Ch'ing-yuan Hsing-ssu (J. Seigen Gyoshi), Nan-yueh Huai-jang (J. Nangaku Ejo), Nan-yang Hui-chung (J. Nan'yo Echu) and Ho-tse Shen-hui (J. Kataku Jinne).

CHENG-TAO-KO

[Zhengdaoge] (C.); (J. Shodoka (J.); Song of Enlightenment.

English transl. copyright (c) 1991 by R. Aitken & the Diamond Sangha, Hawaii.

There is the leisurely one,

Walking the Tao, beyond philosophy,

Not avoiding fantasy, not seeking truth.

The real nature of ignorance is the Buddha-nature itself;

The empty delusory body is the very body of the Dharma.

When the Dharma body awakens completely,

There is nothing at all.

The source of our self-nature

Is the Buddha of innocent truth.

Mental and physical reactions come and go

Like clouds in the empty sky;

Greed, hatred, and ignorance appear and disappear

Like bubbles on the surface of the sea.

When we realize actuality,

There is no distinction between mind and thing

And the path to hell instantly vanishes.

If this is a lie to fool the world,

My tongue may be cut out forever.

Once we awaken to the Tathagata-Zen,

The six noble deeds and the ten thousand good actions

Are already complete within us.

In our dream we see the six levels of illusion clearly;

After we awaken the whole universe is empty.

No bad fortune, no good fortune, no loss, no gain;

Never seek such things in eternal serenity.

For years the dusty mirror has gone uncleaned,

Now let us polish it completely, once and for all.

Who has no-thought? Who is not-born?

If we are truly not-born,

We are not un-born either.

Ask a robot if this is not so.

How can we realize ourselves

By virtuous deeds or by seeking the Buddha?

Release your hold on earth, water, fire, wind;

Drink and eat as you wish in eternal serenity.

All things are transient and completely empty;

This is the great enlightenment of the Tathagata.

Transience, emptiness and enlightenment --

These are the ultimate truths of Buddhism;

Keeping and teaching them is true Sangha devotion.

If you don`t agree, please ask me about it.

Cut out directly the root of it all, --

This is the very point of the Buddha-seal.

I can't respond to any concern about leaves and branches.

People do not recognize the Mani-jewel.

Living intimately within the Tathagata-garbha,

It operates our sight, hearing, smell, taste, sensation, awareness;

And all of these are empty, yet not empty.

The rays shining from this perfect Mani-jewel

Have the form of no form at all.

Clarify the five eyes and develop the five powers;

This is not intellectual work, -- just realize, just know.

It is not difficult to see images in a mirror,

But who can take hold of the moon in the water?

Always working alone, always walking alone,

The enlightened one walks the free way of Nirvana

With melody that is old and clear in spirit

And naturally elegant in style,

But with body that is tough and bony,

Passing unnoticed in the world.

We know that Shakya's sons and daughters

Are poor in body, but not in the Tao.

In their poverty, they always wear ragged clothing,

But they have the jewel of no price treasured within.

This jewel of no price can never be used up

Though they spend it freely to help people they meet.

Dharmakaya, Sambogakaya, Nirmanakaya,

And the four kinds of wisdom

Are all contained within.

The eight kinds of emancipation and the six universal powers

Are all impressed on the ground of their mind.

The best student goes directly to the ultimate,

The others are very learned but their faith is uncertain.

Remove the dirty garments from your own mind;

Why should you show off your outward striving?

Some may slander, some may abuse;

They try to set fire to the heavens with a torch

And end by merely tiring themselves out.

I hear their scandal as though it were ambrosial truth;

Immediately everything melts

And I enter the place beyond thought and words.

When I consider the virtue of abusive words,

I find the scandal-monger is my good teacher.

If we do not become angry at gossip,

We have no need for powerful endurance and compassion.

To be mature in Zen is to be mature in expression,

And full-moon brilliance of dhyana and prajna

Does not stagnate in emptiness.

Not only can I take hold of complete enlightenment by myself,

But all Buddha-bodies, like sands of the Ganges,

Can become awakened in exactly the some way.

The incomparable lion-roar of doctrine

Shatters the brains of the one hundred kinds of animals.

Even the king of elephants will run away, forgetting his pride;

Only the heavenly dragon listens calmly, with pure delight.

I wandered over rivers and seas, crossing mountains and streams,

Visiting teachers, asking about the Way in personal interviews;

Since I recognized the Sixth Founding Teacher at Ts'ao Ch'i,

I know what is beyond the relativity of birth and death.

Walking is Zen, sitting is Zen;

Speaking or silent, active or quiet, the essence is at peace.

Even facing the sword of death, our mind is unmoved;

Even drinking poison, our mind is quiet.

Our teacher, Shakyamuni, met Dipankara Buddha

And for many eons he trained as Kshanti, the ascetic.

Many births, many deaths;

I am serene in this cycle,--there is no end to it.

Since I abruptly realized the unborn,

I have had no reason for joy or sorrow

At any honor or disgrace.

I have entered the deep mountains to silence and beauty;

In a profound valley beneath high cliffs,

I sit under the old pine trees.

Zazen in my rustic cottage

Is peaceful, lonely, and truly comfortable.

When you truly awaken,

You have no formal merit.

In the multiplicity of the relative world,

You cannot find such freedom.

Self-centered merit brings the joy of heaven itself,

But it is like shooting an arrow at the sky;

When the force is exhausted, it falls to the earth,

And then everything goes wrong.

Why should this be better

Than the true way of the absolute,

Directly penetrating the ground of Tathagata?

Just take hold of the source

And never mind the branches.

It is like a treasure-moon

Enclosed in a beautiful emerald.

Now I understand this Mani-jewel

And my gain is the gain of everyone endlessly.

The moon shines on the river,

The wind blows through the pines,--

Whose providence is this long beautiful evening?

The Buddha-nature jewel of morality

Is impressed on the ground of my mind,

And my robe is the dew, the fog, the cloud, and the mist.

A bowl once calmed dragons

And a staff separated fighting tigers;

The rings on this staff jingle musically.

The form of these expressions is not to be taken lightly;

The treasure-staff of the Tathagata

Has left traces for us to follow.

The awakened one does not seek truth--

Does not cut off delusion.

Truth and delusion are both vacant and without form,

But this no-form is neither empty nor not empty;

It is the truly real form of the Tathagata.

The mind-mirror is clear, so there are no obstacles.

Its brilliance illuminates the universe

To the depths and in every grain of sand.

Multitudinous things of the cosmos

Are all reflected in the mind,

And this full clarity is beyond inner and outer.

To live in nothingness is to ignore cause and effect;

This chaos leads only to disaster.

The one who clings to vacancy, rejecting the world of things,

Escapes from drowning but leaps into fire.

Holding truth and rejecting delusion--

These are but skillful lies.

Students who do zazen by such lies

Love thievery in their own children.

They miss the Dharma-treasure;

They lose accumulated power;

And this disaster follows directly upon dualistic thinking.

So Zen is the complete realization of mind,

The complete cutting off of delusion,

The power of wise vision penetrating directly to the unborn.

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Students of vigorous will hold the sword of wisdom;

The prajna edge is a diamond flame.

It not only cuts off useless knowledge,

But also exterminates delusions.

They roar with Dharma-thunder;

They strike the Dharma-drum;

They spread clouds of love, and pour ambrosial rain.

Their giant footsteps nourish limitless beings;

Sravaka, Pratyeka, Bodhisattva--all are enlightened;

Five kinds of human nature all are emancipated.

High in the Himalayas, only fei-ni grass grows.

Here cows produce pure and delicious milk,

And this food I continually enjoy.

One complete nature passes to all natures;

One universal Dharma encloses all Dharmas.

One moon is reflected in many waters;

All the water-moons are from the one moon.

The Dharma-body of all Buddhas has entered my own nature,

And my nature becomes one with the Tathagata.

One level completely contains all levels;

It is not matter, mind nor activity.

In an instant eighty-thousand teachings are fulfilled;

In a twinkling the evil of eons is destroyed.

All categories are no category;

What relation have have these to my insight?

Beyond praise, beyond blame, --

Like space itself it has no bounds.

Right here it is eternally full and serene,

If you search elsewhere, you cannot see it.

You cannot grasp it, you cannot reject it;

In the midst of not gaining,

In that condition you gain it.

It speaks in silence,

In speech you hear its silence.

The great way has opened and there are no obstacles.

If someone asks, what is your sect

And how do you understand it?

I reply, the power of tremendous prajna.

People say it is positive;

People say it is negative;

But they do not know.

A smooth road, a rough road --

Even heaven cannot imagine.

I have continued my zazen for many eons;

I do not say this to confuse you.

I raise the Dharma-banner and set forth our teaching;

It is the clear doctrine of the Buddha

Which I found with my teacher, Hui Neng,

Mahakashyapa became the Buddha-successor,

Received the lamp and passed it on.

Twenty-eight generations of teachers in India,

Then over seas and rivers to our land

Bodhi Dharma came as our own first founder,

And his robe, as we all know, passed through six teachers here,

And how many generations to come may gain the path,

No one knows.

The truth is not set forth;

The false is basically vacant.

Put both existence and non-existence aside,

Then even non-vacancy is vacant,

The twenty kinds of vacancy have no basis,

And the oneness of the Tathagata-being

Is naturally sameness.

Mind is the base, phenomena are dust;

Yet both are like a flaw in the mirror.

When the flaw is brushed aside,

The light begins to shine.

When both mind and phenomena are forgotten,

Then we become naturally genuine.

Ah, the degenerate materialistic world!

People are unhappy; they find self-control difficult.

In the centuries since Shakyamuni, false views are deep,

Demons are strong, the Dharma is weak, disturbances are many.

People hear the Buddha's doctrine of immediacy,

And if they accept it, the demons will be crushed

As easily as a roofing tile.

But they cannot accept, what a pity!

Your mind is the source of action;

Your body is the agent of calamity;

No pity nor blame to anyone else.

If you don't seek an invitation to hell,

Never slander the Tathagata's true teaching.

In the sandalwood forest, there is no other tree.

Only the lion lives in such deep luxuriant woods,

Wandering freely in a state of peace.

Other animals and birds stay far away.

Just baby lions follow the parent,

And three-year-olds already roar loudly.

How can the jackal pursue the king of the Dharma

Even with a hundred-thousand demonic arts?

The Buddha's doctrine of directness

Is not a matter for human emotion.

If you doubt this or feel uncertain,

Then you must discuss it with me.

This is not the free rein of a mountain monk's ego.

I fear your training may lead to wrong views

Of permanent soul or complete extinction.

Being is not being; non-being is not non-being;

Miss this rule by a hair,

And you are off by a thousand miles.

Understanding it, the dragon-child abruptly attains Buddhahood;

Misunderstanding it, the greatest scholar falls into hell.

From my youth I piled studies upon studies,

In sutras and sastras I searched and researched,

Classifying terms and forms, oblivious to fatigue.

I entered the sea to count the sands in vain

And then the Tathagata scolded me kindly

As I read "What profit in counting your neighbor's treasure?"

My work had been scattered and entirely useless,

For years I was dust blown by the wind.

If the seed-nature is wrong, misunderstandings arise,

And the Buddha's doctrine of immediacy cannot be attained.

Shravaka and Pratyeka students may study earnestly

But they lack aspiration.

Others may be very clever,

But they lack prajna.

Stupid ones, childish ones,

They suppose there is something in an empty fist.

They mistake the pointing finger for the moon.

They are idle dreamers lost in form and sensation.

Not supposing something is the Tathagata.

This is truly called Kwan-Yin, the Bodhisattva who sees freely.

When awakened we find karmic hindrances fundamentally empty.

But when not awakened, we must repay all our debts.

The hungry are served a king's repast,

And they cannot eat.

The sick meet the king of doctors;

Why don't they recover?

The practice of Zen in this greedy world --

This is the power of wise vision.

The lotus lives in the midst of the fire;

It is never destroyed.

Pradhanashura broke the gravest precepts;

But he went on to realize the unborn.

The Buddhahood he attained in that moment

Lives with us now in our time.

The incomparable lion roar of the doctrine!

How sad that people are stubbornly ignorant;

Just knowing that crime blocks enlightenment,

Not seeing the secret of the Tathagata teaching.

Two monks were guilty of murder and carnality.

Their leader, Upali, had the light of a glow-worm;

He just added to their guilt.

Vimalakirti cleared their doubts at once

As sunshine melts the frost and snow.

The remarkable power of emancipation

Works wonders innumerable as the sands of the Ganges.

To this we offer clothing, food, bedding, medicine.

Ten thousand pieces of gold are not sufficient;

Though you break your body

And your bones become powder, --

This is not enough for repayment.

One vivid word surpasses millions of years of practice.

The King of the Dharma deserves our highest respect.

Tathagatas, innumerable as sands of the Ganges,

All prove this fact by their attainment.

Now I know what the Mani-jewel is:

Those who believe this will gain it accordingly.

When we see truly, there is nothing at all.

There is no person; there is no Buddha.

Innumerable things of the universe

Are just bubbles on the sea.

Wise sages are all like flashes of lightning

However the burning iron ring revolves around my head,

With bright completeness of dhyana and prajna

I never lose my equanimity.

If the sun becomes cold, and the moon hot,

Evil cannot shatter the truth.

The carriage of the elephant moves like a mountain,

How can the mantis block the road?

The great elephant does not loiter on the rabbit's path.

Great enlightenment is not concerned with details.

Don't belittle the sky by looking through a pipe.

If you still don't understand,

I will settle it for you.

The Cheng-tao-ko poem was published 1924-1934 in Japan as a part of the Taisho Shinshu Daizokyo (Buddhist Canon Published in The Taisho Era) [ No. 2014, Vol. 48]. It was also translated from the Chinese into English and given extensive commentaries by the Ch'an Master Sheng-Yen in his 1990 book The Sword of Wisdom: Lectures on 'The Song of Enlightenment'. Elmhurst, N.Y.: Dharma Drum Publications.

This translation from Japanese was prepared in the 1960s by Mr Robert Aitken and Eido Shimano Sensei for the Diamond Sangha Zen Buddhist Society, Koko An, 2119 Kaloa Way, Honolulu, Hawaii, USA 96822. Their translation was subsequently re-printed in a book: Daily Sutras for Chanting and Recitation. n.d. New York: New York Zendo of the Zen Studies Society Inc. In December 1991 the Aitken-Shimano's translation was revised by Robert Aitken Roshi and incorporated (under its japanese title 'Shodoka') into a collection of the Daily Zen Sutras in use by the Diamond Sangha itself as well as by other affiliated Zen centers and communities, including the California Diamond Sangha; Sydney Zen Center and the Zen Group of Western Australia.

The text below has been also used to construct a "ANU-Cheng-Tao-Ko-Verses" WAIS database accessible world-wide via the standard WAIS client software and the Coombsquest gopher at coombs.anu.edu.au, port 70.

- T.Matthew Ciolek tmciolek@coombs.anu.edu.au