Earth Store Bodhisattva

Sutra of the Past Vows of Earth Store Bodhisattva

Translated into Chinese by Tripitaka Master Shikshananda of Udyana
in the Tang Dynasty (ca A.D. 700)
Translated from the Chinese into English
by Buddhist Text Translation Society (2000)

Part One of Sutra of the Past Vows
of Earth Store Bodhisattva

Chapter I
Spiritual Penetrations in the Palace of the Trayastrimsha Heaven

Chapter II
The Division Bodies Gather

Chapter III
Contemplating the Karmic Conditions of Beings

Chapter IV
Karmic Retributions of Beings of Jambudvipa

Mantra and Praise

Part Two of Sutra of the Past Vows
of Earth Store Bodhisattva

Chapter V
Names of Hells

Chapter VI
The Thus Come One's Praises

Chapter VII
Benefiting the Living and the Dead

Chapter VIII
Praises of King Yama and His Followers

Chapter IX
The Names of Buddhas

Mantra and Praise

Part Three of Sutra of the Past Vows
of Earth Store Bodhisattva

Chapter X
The Conditions and Comparative Merits and Virtues of Giving

Chapter XI
The Dharma Protection of an Earth Spirit

Chapter XII
Benefits Derived from Seeing and Hearing

Chapter XIII
The Entrustment of People and Gods

Mantra and Praise

>> Chapter I >>


Part One of Sutra
of the Past Vows of Earth Store Bodhisattva

CHAPTER I
Spiritual Penetrations in the Palace of the Trayastrimsha Heaven

Thus I have heard:

At one time, the Buddha was in the Trayastrimsha Heaven speaking Dharma for his mother.

At that time, uncountably many Buddhas and Great Bodhisattvas, Mahasattvas from infinite worlds in the Ten Directions assembled to praise how Shakyamuni Buddha is able to manifest powerfully great wisdom and spiritual penetrations in the evil world of the Five Turbidities. They lauded how he regulates and subdues obstinate beings so they learn what causes suffering and what brings bliss. Each sent his attendants to pay their respects to the World Honored One.

At that time the Thus Come One smiled and emitted billions of great light clouds. There was

a light cloud of great fullness, a light cloud of great compassion, a light cloud of great wisdom, a light cloud of great prajna, a light cloud of great samadhi, a light cloud of great auspiciousness, a light cloud of great blessings, a light cloud of great merit, a light cloud of great refuge, and a light cloud of great praise.

After emitting indescribably many light clouds, he also uttered many wonderful, subtle sounds

There was the sound of dana paramita, the sound of shila paramita, the sound of kshanti paramita, the sound of virya paramita, the sound of dhyana paramita, and the sound of prajna paramita.

There was the sound of compassion, the sound of joyous giving, the sound of liberation, the sound of no-outflows, the sound of wisdom, the sound of great wisdom, the sound of the Lion's roar, the sound of the Great Lion's roar, the sound of thunderclouds, and the sound of great thunderclouds.

After he uttered indescribably many sounds, countless millions of gods, dragons, ghosts, and spirits from the Saha and other worlds also gathered in the Palace of the Trayastrimsha Heaven.

They came from the Heaven of the Four Kings, the Trayastrimsha Heaven, the Suyama Heaven, the Tushita Heaven, the Blissful Transformations Heaven, and the Heaven of Comfort Gained Through Others' Transformations.

They came from the Heaven of the Multitudes of Brahma, the Heaven of the Ministers of Brahma, the Heaven of the Great Brahma Lord, the Heaven of Lesser Light, the Heaven of Limitless Light, the Heaven of Light Sound, the Heaven of Lesser Purity, the Heaven of Limitless Purity, and the Heaven of Universal Purity.

They came from the Birth of Blessings Heaven, the Love of Blessings Heaven, the Abundant Fruit Heaven, the No Thought Heaven, the No Affliction Heaven, the No Heat Heaven, the Good Views Heaven, the Good Manifestation Heaven, the Ultimate Form Heaven, the Maheshvara Heaven, and so forth, to the Heaven of the Station of Neither Thought Nor Non-Thought.

All those groups of gods, dragons, ghosts and spirits came and gathered together.

Moreover, sea spirits, river spirits, stream spirits, tree spirits, mountain spirits, earth spirits, brook and marsh spirits, sprout and seedling spirits, day, night, and space spirits, heaven spirits, food and drink spirits, grass and wood spirits, and other such spirits from the Saha and other worlds came and gathered together.

In addition, all the great Ghost Kings from the Saha and other worlds came and gathered together. They were:

the Ghost King Evil 'Eyes, the Ghost King Blood-drinker, the Ghost King Essence and Energy-eater, the Ghost King Fetus and Egg-eater, the Ghost King Spreader of Sickness, the Ghost King Collector of Poisons, the Ghost King Kind-hearted, the Ghost King Blessings and Benefits, the Ghost King Great Regard and Respect, and others.

At that time, Shakyamuni Buddha said to the Dharma Prince, Bodhisattva, Mahasattva, Manjushri, "As you regard these Buddhas, Bodhisattvas, gods, dragons, ghosts and spirits from this land and other lands who are now gathered in the Trayastrimsha Heaven, do you know their number?"

Manjushri said to the Buddha, "World Honored One, even if I were to measure and reckon with my spiritual powers for a thousand eons I would not be able to know their number."

The Buddha told Manjushri, "Regarding them with my Buddha Eye, I also cannot count them all. Those beings have been taken across, are being taken across, will be taken across, have been brought to accomplishment, are being brought to accomplishment, or will be brought to accomplishment by Earth Store Bodhisattva, throughout many eons."

Manjushri said to the Buddha, "World Honored One, throughout many eons I have cultivated good roots and my wisdom was certified as unobstructed. When I hear what the Buddha says, I immediately accept it with faith.

But Sound-hearers of small attainment, gods, dragons, and the rest of the Eightfold Division, and beings in the future who hear the Thus Come One's true and sincere words will certainly harbor doubts. Even if they receive the teaching most respectfully, they will still be unable to avoid slandering it.

My only wish is that the World Honored One will proclaim for everyone what practices Earth Store Bodhisattva did. Tell us what vows he made while on the level of planting causes that now enable him to succeed in doing such inconceivable deeds."

The Buddha said to Manjushri, "By way of analogy suppose that each blade of grass, tree, forest, rice plant, hemp stalk, bamboo, reed, mountain, rock and mote of dust in a Three Thousand Great Thousand-World System were a Ganges River. Then suppose that each grain of sand in each of those Ganges Rivers were a world and that each mote of dust in each of those worlds were an eon. Then suppose each mote of dust accumulated in each of those eons were itself an eon.

The time elapsed since Earth Store Bodhisattva was certified to the position of the Tenth Ground is a thousand times longer than that in the above analogy. Even longer was the time he dwelled on the levels of Sound-hearer and Pratyekabuddha.

Manjushri, the awesome spiritual strength and vows of this Bodhisattva are inconceivable.

If good men or women in the future hear this Bodhisattva's name, praise him, behold and bow to him, call his name, make offerings to him, or if they draw, carve, cast, sculpt or make lacquered images of him, such people will be reborn in the Heaven of the Thirty-Three one hundred times and will never fall into the Evil Paths.

"Manjushri, indescribably many eons ago, during the time of a Buddha named Lion Sprint Complete in the Ten Thousand Practices Thus Come One, Earth Store Bodhisattva, Mahasattva was the son of a great Elder.

That Elder's son, upon observing the Buddha's hallmarks and fine features and how the thousand blessings adorned him, asked that Buddha what practices and vows made him so magnificent.

Lion Sprint Complete in the Ten Thousand Practices Thus Come One then said to the Elder's son. If you wish to have a body like mine, you must first spend a long time liberating beings who are undergoing suffering.'

"Manjushri, that comment caused the Elder's son to make a vow: 'From now until the ends of future time throughout uncountable eons I will use expansive expedient means to help beings in the Six Paths who are suffering for their offenses. Only when they have all been liberated, will I myself become a Buddha.'

From the time he made that great vow in the presence of that Buddha until now, hundreds of thousands of nayutas of inexpressibly many eons have passed and still he is a Bodhisattva.

"Another time, inconceivable Asamkhyeya eons ago there was a Buddha named Enlightenment-Flower Samadhi Self-Mastery King Thus Come One. That Buddha's llfespan was four hundred billion Asamkhyeya eons.

During his Dharma-lmage Age, there lived a Brahman woman endowed with ample blessings from previous lives who was respected by everyone. Whether she was walking, standing, sitting, or lying down, gods surrounded and protected her.

Her mother, however, embraced a deviant faith and often slighted the Triple Jewel.

Her worthy daughter made use of many expedients in trying to convince her mother to hold right views, but her mother never totally believed. Before long the mother's life ended and her consciousness fell into the Relentless Hell.

"When that happened, the Brahman woman, knowing that her mother had not believed in cause and effect while alive, feared that her karma would certainly pull her into the Evil Paths.

For that reason, she sold the family house and acquired many kinds of incense, flowers, and other gifts. With those she performed a great offering in that Buddha's stupas and monasteries.

She saw an especially fine image of the Thus Come One Enlightenment Flower Samadhi Self-Mastery King in one of the monasteries.

As the Brahman woman beheld the honored countenance she became doubly respectful while thinking to herself, 'Buddhas are called Greatly Enlightened Ones who have gained All-Wisdom. If this Buddha were in the world I could ask him where my mother went after she died. He would certainly know.'

"The Brahman woman then wept for a long time as she gazed longingly upon the Thus Come One.

Suddenly a voice in the air said, '0 weeping, worthy woman, do not be so sorrowful. I shall now show you where your mother has gone."

"The Brahman woman placed her palms together as she addressed space saying, 'Which Virtuous Divinity is comforting me in my grief? From the day I lost my mother onward I have held her in memory day and night, but there is nowhere I can go to ask about the realm of her rebirth.'

"The voice in the air spoke to the woman again, I am the one you behold and worship, the former Enlightenment-Flower Samadhi Self-Mastery King Thus Come One. Because I have seen your regard for your mother is double that of ordinary beings, I have come to show you where she is.'

"The Brahman woman suddenly lunged toward the voice she was hearing and then fell, injuring herself severely. Those around her supported and attended upon her and after a long time she was revived.

Then she addressed the air saying, I hope the Buddha will be compassionate and quickly tell me into what realm my mother has been reborn. I am now near death myself.'

"Enlightenment-Flower Samadhi Self-Mastery King Thus Come One told the worthy woman, After you make your offerings, return home quickly. Sit upright and concentrate on my name. You will soon know where your mother has been reborn.'

"The Brahman woman bowed to the Buddha and returned home. The memory of her mother sustained her as she sat upright recollecting Enlightenment-Flower Samadhi Self-Mastery King Thus Come One.

"After doing so for a day and night, she suddenly saw herself beside a sea whose waters seethed and bubbled. Many evil beasts with iron bodies flew swiftly back and forth above the sea.

She saw hundreds of thousands of men and women bobbing up and down in the sea, being fought over, seized, and eaten by the evil beasts.

She saw Yakshas with different shapes. Some had many hands, some many eyes, some many legs, some many heads. With their sharp fangs they drove the offenders on towards the evil beasts. Or the Yakshas themselves seized the offenders and twisted their heads and feet together into shapes so horrible that no one would dare even look at them for long.

During that time the Brahman woman was naturally without fear due to the power of recollecting the Buddha.

"A ghost king named Poisonless bowed his head in greeting and said to the worthy woman, 'Welcome, 0 Bodhisattva. What conditions bring you here?'

"The Brahman woman asked the ghost king, 'What is this place?'

"Poisonless replied, 'We are on the western side of the Great Iron Ring Mountain and this is the first of the seas that encircle it.'

"The worthy woman said, 'I have heard that the hells are within the Iron Ring. Is that actually so?'

"Poisonless answered, 'Yes, the hells are here.'

"The worthy woman asked, 'How have I now come to the hells?'

"Poisonless answered, If it wasn't awesome spiritual strength that brought you here, then it was the power of karma. Those are the only two ways anyone comes here. "

The worthy woman asked, 'Why is this water seething and bubbling, and why are there so many offenders and evil beasts?'

Poisonless replied. These are beings of Jambudvipa who did evil deeds. They have just died and passed through forty-nine days without any surviving relatives doing any meritorious deeds on their behalf to rescue them from their distress. Besides that, during their lives they themselves didn't plant any good causes. Now their own karma calls forth these hells. Their first task is to cross this sea.

Ten thousand yojanas east of this sea is another sea in which they will undergo twice as much suffering. East of that sea is yet another sea where the sufferings are doubled still again.

What the combined evil causes of the three karmic vehicles evoke is called the sea of karma. This is that place.'

"The worthy woman asked the Ghost King Poisonless, 'Where are the hells?'

"Poisonless answered, 'Within the three seas are hundreds of thousands of great hells, each one different. Eighteen of those are known as the great hells. Five hundred subsequent ones inflict limitless cruel sufferings. Following those are hundreds of thousands that inflict limitless further sufferings.'

"The worthy woman again questioned the great ghost king, 'My mother died recently and I do not know where she has gone.'

"The ghost king asked the worthy woman, 'When the Bodhisattva's mother was alive, what habits did she have?"

"The worthy woman replied, 'My mother held deviant views and ridiculed and slandered the Triple Jewel. Even if she occasionally believed, she would soon become disrespectful again. She died recently and I still do not know where she was reborn.'

"Poisonless asked, 'What was the Bodhisattva's mother's name and clan?'

"The worthy woman replied, 'My parents were both Brahmans; my father's name was Shila Sudarshana, my mother's name was Yue Di Li.'

"Poisonless placed his palms together and implored the worthy woman, 'Please, Worthy One, quickly return home. There is no need for you to grieve further. The offender Yue Di Li was born in the heavens three days ago.

It is said that she received the benefit of offerings made and blessings cultivated by her filial child who practiced giving to Enlightenment-Flower Samadhi Self-Mastery King Thus Come One at stupas and monasteries.

Not only was the Bodhisattva's mother released from the hells. All the other offenders who were destined for the Relentless Hell received bliss and were reborn together with her.'

Having finished speaking, the ghost king put his palms together and withdrew.

"The Brahman woman returned swiftly as if from a dream, understood what had happened, and then made a profound and far-reaching vow before the stupas and images of Enlightenment-Flower Samadhi Self-Mastery King Thus Come One, saying, 'I vow that until the end of future eons I will respond to beings suffering for their offenses by using many expedient means to bring about their liberation.'"

The Buddha told Manjushri, "The Ghost King Poisonless is the present Bodhisattva Foremost Wealth. The Brahman woman is now Earth Store Bodhisattva."

>> Chapter II >>


CHAPTER II
The Division Bodies Gather

At that time the division bodies of Earth Store Bodhisattva began gathering in the Palace of the Trayastrimsha Heaven from billions of inexpressible, unutterable, immeasurable, ineffable, limitless Asamkhyeyas of worlds. They came from wherever hells were found.

Due to the spiritual powers of the Thus Come One, each came from his own direction and was joined by billions of nayutas of those who had obtained liberation from the force of bad karma. All came holding incense and flowers as offerings to the Buddha.

Those groups that came were irreversible from Anuttara- samyaksambodhi because they had been taught and transformed by Earth Store Bodhisattva.

For long eons they had wandered in birth and death, undergoing suffering within the Six Paths without even temporary respite. Now they had reached levels of Sagehood due to the great compassion and deep vows of Earth Store Bodhisattva.

They felt joyful as they arrived at the Trayastrimsha Heaven and gazed at the Thus Come One, their eyes not leaving him for a moment.

At that time, the World Honored One stretched forth his golden colored arm and rubbed the crowns of all the division bodies of Earth Store Bodhisattva, Mahasattva, gathered from billlons of Inexpressible, Inconceivable, immeasurable, ineffable, limitless Asamkhyeyas of worlds, and said,

"I teach and transform obstinate beings such as these within the evil worlds of the Five Turbidities, causing their minds to be regulated and subdued so they renounce the deviant and return to the proper.

But one or two of ten still cling to their bad habits. For them I again divide into billions of bodies and use numerous additional expedient means.

Those with keen roots will listen and immediately believe. Those with good rewards will respond to exhortation and strive to succeed. Those who are dark and dull will return only after being taught for a long time. Those whose karma is heavy fail to show any respect.

My division bodies take across and liberate all those different kinds of beings. I may appear in a male body. I may appear in a female body. I may appear in the body of a god or dragon. I may appear in the body of a spirit or ghost. I may appear as a mountain, as a forest, as a stream, as a spring, as a river, as a lake, as a fountain, or as a well in order to benefit people. I use all these ways to save beings.

I may appear in the body of God Shakra.
I may appear in the body of Lord Brahma.
I may appear in the body of a Wheel-Turning King.
I may appear in the body of a lay person.
I may appear in the body of a national leader.
I may appear in the body of a prime minister.
I may appear in the body of an official.
I may appear in the body of a Bhikshu, a Bhikshuni, an Upasaka, an Upasika, and so forth to my appearing in the body of a Sound-hearer, an Arhat, a Pratyekabuddha, or a Bodhisattva in order to teach and rescue beings.

It is not that I only appear to them in the body of a Buddha.

"Reflect on how I have toiled for repeated eons and endured acute suffering to take across and free stubborn beings who resist being taught and who continue to suffer for their offenses.

Those not yet subdued undergo retributions according to their karma. If they fall into the evil destinies and are enduring tremendous suffering, then you should remember the gravity of this entrustment I am now giving you here in the palace of the Trayastrimsha Heaven:

Find ways to liberate all beings in the Saha world from now until the time when Maitreya comes into the world. Help them escape suffering forever, encounter Buddhas, and receive predictions."

At that time all the division bodies of Earth Store Bodhisattva that came from all those worlds merged into single form. Then he wept and said to the Buddha, "Throughout long eons I have been receiving the Buddha's guidance and from that have developed inconceivable spiritual power and great wisdom.

My division bodies fill worlds as many as grains of sand in billions of Ganges Rivers. In each of those worlds, I transform myself into billions of bodies. Each body takes across billions of people, helping them to return respectfully to the Triple Jewel, escape birth and death forever, and reach the bliss of Nirvana.

Even if their good deeds within the Buddhadharma amount to as little as a strand of hair, a drop of water, a grain of sand, or a mote of dust, I will gradually take them across, liberate them, and help them gain great benefit.

I only hope that the World Honored One will not be concerned about beings of the future who have bad karma. " In that way he addressed the Buddha three times: "I only hope that the World Honored One will not be concerned about beings of the future who have bad karma."

At that time the Buddha praised Earth Store Bodhisattva and said, "Excellent! Excellent! I will help you in this work you so willingly undertake. When the vast vows that you keep making throughout so many eons are fulfilled and all those beings have been saved, then I will certify your ultimate Bodhi."

>> Chapter III >>


CHAPTER III
Contemplating the Karmic Conditions of Beings

At that time the Buddha's mother. Lady Maya, placed her palms together respectfully and asked Earth Store Bodhisattva, "Great Sage, could you tell us about the different kinds of karma that beings of Jambudvipa create and the resulting retributions that they undergo?"

Earth Store replied, "There are millions of worlds and lands that may or may not have hells, may or may not have women, may or may not have Buddhadharma, and so forth to having or not having Sound-hearers and Pratyekabuddhas. Since the worlds differ, the retributions in the hells also differ."

Lady Maya spoke again to the Bodhisattva, "Could you please tell us about the offenses done by those in Jambudvipa that result in retributions in the evil destinies?"

Earth Store replied, "Worthy Mother, please listen as I speak briefly about that."

The Buddha's mother answered, "Great Sage, please tell us about it."

Then Earth Store Bodhisattva said to the Worthy Mother, "Retributions that result from offenses done in Jambudvipa are described like this.

"Beings who are not filial to their parents, even to the extent of harming or killing them, will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who shed the Buddha's blood, slander the Triple Jewel, and do not venerate Sutras will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who usurp or damage the property of the Eternally Dwelling, who defile Bhikshus or Bhikshunis, who commit sexual-acts within the Sangharama, or who kill or harm beings there will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who seem to be Shramanas but in their minds are not Shramanas, who destroy the things of the Eternally Dwelling, who deceive lay people, who go against the precepts, and who do many other evil deeds will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who steal the wealth and property of the Eternally Dwelling including its grains, its food and drink, its clothing, or take anything at all that was not given to them will fall into the Relentless Hell where for billions of eons they will seek escape in vain."

Earth Store continued, "Worthy Mother, beings who commit such offenses will fall into the Fivefold Relentless Hell where they will constantly seek for temporary relief from their suffering but will never receive even a moment's respite."

Lady Maya further asked Earth Store Bodhisattva, "Why is that hell called Relentless?"

Earth Store replied, "Worthy Mother, the hells are all within the Great Iron Ring Mountain.

The eighteen great hells and the five hundred subsequent ones each have their own names. There are hundreds of thousands more that also have their own names.

The Relentless Hell is found within a city of hells that encompasses more than eighty thousand square miles. That city is made entirely of iron. Ten thousand miles above the city is an unbroken mass of fire.

Within the city are many interconnected hells, each with a different name.

"There is just one hell called Relentless. Its circumference is eighteen thousand miles.

The wall of that hell is a thousand miles high, totally made iron, and covered with a fire burning downward that is joined by a fire burning upward.

Iron snakes and dogs spewing fire race back and forth atop that wall.

"In that hell is a bed that extends for ten thousand miles. One person undergoing punishment sees his or her own body filling the entire bed. When millions of people undergo punishment simultaneously, each still sees his or her own body filling the bed. That is how retributions are undergone by those with the same karma.

"What is more, these offenders undergo extreme suffering. Thousands of Yakshas and other evil ghosts display fangs like swords and eyes like lightning as they pull and drag the offenders using their brass-clawed hands.

Other Yakshas wield huge iron halberds that they use to pierce the offenders' mouths and noses or stab their bellies and backs. They toss the offenders into the air and then catch them by skewering them with the halberds or they let them drop onto the bed.

Iron eagles peck at the offenders' eyes and iron serpents wrap around their necks. Long nails are driven into all their limbs. Their tongues are pulled out, stretched, and then plowed through. Their internal organs are gouged out, sliced, and minced. Molten copper is poured into their mouths, and their bodies are bound with hot iron.

Responses to their karma go on like that throughout thousands of deaths and rebirths. They pass through millions of eons seeking escape in vain.

"When this world is destroyed, they find themselves in another world. When that world is destroyed, they pass to another one. When that world, too, is destroyed, they move on to another. When this world comes into being again, they return here.

The situation involving Relentless retribution for offenses is like that.

"Moreover, five karmic responses account for the name Relentless. What are the five?

First, it is said to be Relentless since punishment is undergone day and night throughout many eons without ceasing for a moment.

Second, it is said to be Relentless since one person fills it in the same way that many people fill it.

Third, it is said to be Relentless since repeated punishments continue without cease throughout years that stretch into nayutas of eons. Those punishments are inflicted by instruments of torture such as forks and clubs; or by eagles, serpents, wolves, and dogs; or by pounding, grinding, sawing, drilling, chiseling, cutting and chopping; or by boiling liquids, iron nets, iron ropes, iron asses, and iron horses; or by raw hide bound around one's head and hot iron poured over one's body; or by meals of iron pellets and drinks of iron fluids.

Fourth, it is said to be Relentless since everyone undergoes karmic responses based on the offenses they committed, whether they be men, women, savages, old, young, honorable, or lowly; whether they be dragons, spirits, gods or ghosts.

Fifth, it is said to be Relentless since offenders continually undergo ten thousand deaths and as many rebirths each day and night from the moment they first enter this hell and on through thousands of eons. During that time they seek even a moment's relief but it never happens. Only when their karma is finished can they attain rebirth."

Earth Store Bodhisattva said to the Worthy Mother, "That is a brief description of the Relentless Hell. If I were to speak extensively about the names of all the implements of punishment in the hells and all the sufferings there, I could not finish speaking in an entire eon."

After hearing that, Lady Maya placed her palms together sorrowfully, made obeisance, and withdrew.

>> Chapter IV >>


CHAPTER IV
Karmic Retributions of Beings of Jambudvipa

At that time Earth Store Bodhisattva said to the Buddha, "World Honored One, because I receive the awesome spiritual strength of the Buddha, Thus Come One, I am able to divide my body and rescue beings who are undergoing karmic retributions everywhere in billions of worlds. If it were not for the great compassionate strength of the Thus Come One, I would be unable to perform such changes and transformations.

Now the World Honored One has entrusted me with rescuing and liberating beings in the Six Paths until Ajita becomes a Buddha. I accept the entrustment, World Honored One. Please have no further concern.

Then the Buddha told Earth Store Bodhisattva, "Beings who have not yet obtained liberation have unfixed natures and consciousnesses.

Their bad habits reap karma; their good habits bring rewards. Reacting to situations by doing good or evil acts causes them to turn in the Five Paths without a moment's rest. Throughout eons as numerous as motes of dust they remain confused, deluded, obstructed, and afflicted by difficulties.

They are like fish swimming through waters laced with nets. They may slip through and keep their freedom temporarily, but sooner or later they will be caught. I am concerned about such beings.

But since you keep making extensive vows repeatedly throughout successive eons to take such offenders across, what further worries need I have?

After that was said, a Bodhisattva, Mahasattva in the assembly named Samadhi Self-Mastery King said to the Buddha, "World Honored One, what vows has Earth Store Bodhisattva made during so many successive eons that he now receives the World Honored One's special praise? We hope the World Honored One will tell us about that."

Then the World Honored One said to Samadhi Self-Mastery King, "Listen attentively, listen attentively, and reflect well on the examples I am about to give you.

One time, limitless Asamkhyeyas of nayutas of inexpressible eons ago, a Buddha named All-Knowledge-Accomplished Thus Come One, One Worthy of Offerings, One of Proper and Pervasive Knowledge, One Perfect in Clarity and Conduct, Well-Gone One, Unsurpassed Knight Who Understands the World, Taming and Subduing Hero, Teacher of Gods and Humans, Buddha, World Honored One appeared in the world.

"That Buddha's lifespan was sixty thousand eons.

Before he became a monk, he was the king of a small country and was friendly with the king of a neighboring country. Both of them practiced the Ten Wholesome Acts and benefited beings.

Because the citizens of those two neighboring countries did many bad things, the two kings made a plan using far-reaching expedients.

"One king vowed to quickly become a Buddha and then cross over absolutely all the others.

"The other king vowed, 'I do not want to become a Buddha until I first take across all those who are suffering for their offenses, enable them to gain peace, and finally to reach Bodhi.'"

The Buddha told the Bodhisattva Samadhi Self-Mastery King, "The king who vowed to become a Buddha quickly is All-Knowledge-Accomplished Thus Come One.

The king who vowed to keep crossing over beings who are suffering for their offenses rather than to become a Buddha is Earth Store Bodhisattva.

"Another time, limitless Asamkhyeya eons ago, a Buddha named Pure-Lotus-Eyes Thus Come One appeared in the world. His lifespan was forty eons.

In his Dharma-image age, an Arhat who had blessings from rescuing beings met a woman named Bright Eyes who offered a meal to him once while he was teaching and transforming beings.

"'What is your wish?' asked the Arhat.

"Bright Eyes replied, 'On the day of my mother's death I performed meritorious deeds for her rescue, but I do not know where my mother is now.'

"Sympathizing with her, the Arhat entered into samadhi to contemplate and saw that Bright Eyes' mother had fallen into a bad destiny where she was undergoing extreme suffering.

The Arhat asked, 'Bright Eyes, what karma did your mother commit while alive that makes her now have to undergo such terrible suffering in a bad destiny?'

"Bright Eyes replied, 'My mother enjoyed eating fish, turtles, and the like. She especially liked to fry or broil the eggs of fish and turtles. Every time she ate those she took thousands of lives. Oh, Venerable One, please be compassionate and tell me how she can be saved."

"The Arhat took pity on Bright Eyes and used a skillful means. He urged Bright Eyes, saying, 'With sincere resolve, be mindful of Pure-Lotus-Eyes Thus Come One and also make carved and painted images of him. By doing so both the living and the dead will be rewarded.'

"Bright Eyes heard that, quickly renounced everything she loved, and swiftly commissioned painted images of the Buddha. Then she made offerings before them. The reverence she felt moved her to tears and she wept in grief as she beheld and bowed to the Buddha.

Suddenly near the end of night in a dream she saw that Buddha's body, dazzling gold in color and as large as Mount Sumeru, emitting great light. He said to Bright Eyes, 'Your mother will be born in your household before long and as soon as that child can feel hunger and cold he will speak.'

"Shortly thereafter a maidservant in the house bore a son who spoke before he was three days' old. Lowering his head and weeping he said to Bright Eyes, 'The karmic conditions we create during our lives and deaths result in retributions that we ourselves must undergo.

I am your mother and have been in darkness for a long time. Since you and I parted, I have repeatedly fallen into the great hells. Upon receiving the power of your blessings, I have been reborn as a servant's child with a short lifespan. Thirteen years from now, I will fall into the Evil Paths again. Do you have some way to free me so that I can avoid them?'

"When Bright Eyes heard those words, she knew without a doubt that they were her mother's. Choked with sobs, she said to the servant's child, 'Since you were my mother, you should know your own past offenses. What karma did you create that made you fall into the Evil Paths?'

"The maidservant's child answered, 'I am undergoing retribution for two kinds of karma: killing and slandering. Had I not received the blessings you earned to rescue me from difficulty, I would not yet be released from that karma.'

"Bright Eyes asked, 'What happens in the hells when beings undergo retributions for their offenses?'

"The maidservant's son answered, 'I can't bear to speak of the ways in which beings suffer for their offenses. Even if I lived for a hundred thousand years, I would find it hard to talk about.'

"When Bright Eyes heard that she wept bitterly and spoke into the air saying, 'I vow that my mother will be released from the hells forever. At the end of these thirteen years, she will be finished with her heavy offenses and will not go back to the Evil Paths.

0 Buddhas of the Ten Directions, with your compassion and sympathy, please listen to the vast and mighty vow that I am making for the sake of my mother.

If my mother will never again enter the Three Evil Paths, never again be born into low stations, and never again be female, then here before the image of Pure-Lotus-Eyes Thus Come One, I vow that from this day on, throughout billions of eons I will respond to all beings who are undergoing suffering for their offenses in the hells or the Three Evil Paths of any world.

'I vow to rescue them from the bad destinies of the hells, hungry ghosts, animals, and the like. Only after beings with such retributions have all become Buddhas will I myself achieve Proper Enlightenment.'

"After making that vow, she clearly heard Pure-Lotus-Eyes Thus Come One say to her, 'Bright Eyes, your own great compassion and sympathy reaches your mother by this mighty vow that you are making.

My contemplation shows me that after thirteen years your mother will finish this retribution and will be born a Brahman with a lifespan of one hundred years. After that retribution she will be born in the Land of No Concern with a lifespan of uncountable eons. Later she will realize the fruition of Buddhahood and cross over people and gods numbering as many as sand grains in the Ganges.'"

Shakyamuni Buddha told Samadhi Self-Mastery King, "The Arhat whose blessings helped Bright Eyes then is now Inexhaustible Intention Bodhisattva. The mother of Bright Eyes is now Liberation Bodhisattva. Bright Eyes herself is now Earth Store Bodhisattva. He has been extending his compassion and sympathy like that from distant eons onward by making vows as many as Ganges's sands, to rescue vast numbers of beings.

"Men and women in the future may fail to do good deeds and only do evil; may not believe in cause and effect; may indulge in sexual misconduct and false speech; may use divisive and harsh speech; and may slander the Great Vehicle. Beings with karma like that should certainly fall into bad destinies.

But if they encounter Good and Wise Advisors who exhort them and lead them quickly to take refuge with Earth Store Bodhisattva, those beings will just as quickly be released from their retributions in the Three Evil Paths.

If those beings are resolved and respectful, if they behold, bow to, and praise the Bodhisattva, and if they make offerings of flowers, incense, clothing, jewels, food and drink to him, they will enjoy supremely wonderful bliss in the heavens for billions of eons.

When their blessings in the heavens end and they are born as people, they will have the potential to be leaders of nations throughout billions of eons who are able to remember all aspects of causes and effects from previous lives.

"0,Samadhi Self-Mastery King, Earth Store Bodhisattva has such inconceivably great awesome spiritual power that he uses expansively for the benefit of beings. All of you Bodhisattvas should remember this Sutra and proclaim and widely spread it."

Samadhi Self-Mastery King said to the Buddha, "World Honored One, please do not be concerned. We billions of Bodhisattvas, Mahasattvas, based on the Buddha's awesome spiritual strength, will certainly proclaim this Sutra widely throughout Jambudvipa for the benefit of beings."

Having spoken thus to the World Honored One, Samadhi Self-Mastery King Bodhisattva put his palms together respectfully, bowed, and withdrew.

At that time the Four Heavenly Kings arose from their seats, put their palms together respectfully, and said to the Buddha, "World Honored One, Earth Store Bodhisattva has been making such great vows from distant eons onward.

Why is it that up to now he has not yet finished taking beings across? Why does he continue to renew his vast and mighty vows? Please, World Honored One, explain that for us."

The Buddha told the Four Heavenly Kings, "Excellent, excellent. Now to bring benefit to you and to extend that benefit to people and gods of the present and future, I will speak about how Earth Store Bodhisattva uses his compassion and sympathy within the paths of birth and death in Jambudvipa in the Saha world to rescue, take across, and liberate beings who are undergoing suffering for their offenses.

The Four Heavenly Kings replied, "Please, World Honored One, we would like to hear about his work."

The Buddha told the Four Heavenly Kings, "From distant eons onward to the present. Earth Store Bodhisattva has been taking across and liberating beings. Since his vows are still not finished, he continues with compassion and sympathy to help beings suffering for their offenses in this world.

Moreover, he sees the ceaseless tangle of their causes extending on through infinite, future eons. Because of that he renews his vows. Thus, in this Saha world on the continent of Jambudvipa, this Bodhisattva teaches and transforms beings by means of billions of expedient means.

"Four Heavenly Kings, To killers, Earth Store Bodhisattva says that short lifespans will be the retribution.

To robbers he says that poverty and acute suffering will be the retribution.

To those who indulge in improper sex he says that rebirth as pigeons or mandarin drakes or ducks will be the retribution.

To those who use harsh speech he says that quarrelling families will be the retribution.

To those who slander he says that being tongueless and having cankerous mouths will be the retribution.

To the hateful he says that being ugly and crippled will be the retribution.

To the stingy he says that not getting what they seek will be the retribution.

To gluttons he says that hunger, thirst and sicknesses of the throat will be the retribution.

To hunters he says that a frightening insanity that destroys one's life will be the retribution.

To those who oppose their parents he says that being killed in natural disasters will be the retribution.

To arsons who burn mountains and forests he says that trying to take one's own life in the confusion of insanity will be the retribution.

To cruel parents or step-parents, he says that being flogged in future lives will be the retribution.

To those who net and trap animals, he says that being separated from one's own relatives will be the retribution.

To those who slander the Triple Jewel he says that being blind, deaf, or mute will be the retribution.

To those who slight the Dharma and regard the teachings with arrogance, he says that remaining in the bad paths forever will be the retribution.

To those who destroy or misuse possessions of the Eternally Dwelling he says that revolving in the hells for billions of eons will be the retribution.

To those who defile the pure conduct of others and bear false witness against members of the Sangha he says that remaining in the animal realm forever will be the retribution.

To those who scald, burn, behead, maim, or otherwise harm beings he says that undergoing repayment in kind will be the retribution. To those who violate precepts and the regulations of pure eating he says that being born as birds or beasts that must suffer hunger and thirst will be the retribution.

To those who make unprincipled and destructive use of things he says that being unable to ever obtain what they seek will be the retribution.

To the arrogant and haughty he says that being servile and of low station will be the retribution.

To those who use back-biting to cause discord among others he says that being tongueless or having speech impediments will be the retribution.

To those with deviant views he says that being reborn in undeveloped regions will be the retribution.

"The bad habits involving body, mouth, and mind karma that beings of Jambudvipa perpetuate, result in hundreds of thousands of retributions like those. I have listed only a few examples here.

Since the karma created by beings of Jambudvipa calls forth different responses, Earth Store Bodhisattva uses hundreds of thousands of expedient means to teach and transform them.

Those beings must first undergo retributions such as those and then fall into the hells, where they pass through eons without being able to escape. You should therefore protect people and protect nations. Do not allow the accumulation of karma to confuse beings."

On hearing that, the Four Heavenly Kings wept in sorrow, placed their palms together, and withdrew.

End of Part One of Sutra of
the Past Vows of Earth Store Bodhisattva

>> Chapter V >>


Part Two of Sutra of the Past Vows
of Earth Store Bodhisattva

CHAPTER V
Names of Hells

At that time Universal Worthy Bodhisattva, Mahasattva said to Earth Store Bodhisattva, "Humane One, for the sake of gods and dragons, those in the Fourfold Assembly, and all other beings of the present and future, please tell us the names of the hells where beings in the Saha world on the continent of Jambudvipa must suffer retributions for offenses they commit.

Please also describe what happens during retributions undergone for evil deeds so that beings in the future Dharma Ending Age will know what those retributions are."

Earth Store Bodhisattva replied, "Humane One, based on the awesome spiritual power of the Buddha and relying on your strength, Great Bodhisattva, I will give a general list of the names of hells and describe some of what happens during retributions undergone for offenses and evil deeds.

"Humane One, in Eastern Jambudvipa is mountain range called Iron Ring. The mountain is pitch black because the light of sun and moon do not shine on it. A great hell is located there named Ultimately Relentless. Another hell is called Great Avichi.

There is also a hell called Four Horns, a hell called Flying Knives, a hell called Fiery Arrows, a hell called Squeezing Mountains,

a hell called Piercing Spears, a hell called Iron Carts,
a hell called Iron Beds, a hell called Iron Oxen,
a hell called Iron Clothing, a hell called Thousand Blades,
a hell called Iron Asses, a hell called Molten Copper,
a hell called Embracing Pillar, a hell called Flowing Fire,
a hell called Plowing Tongues, a hell called Hacking Heads,
a hell called Burning Feet, a hell called Pecking Eyes,
a hell called Iron Pellets, a hell called Quarreling,
a hell called Iron Ax, and a hell called Massive Hatred."

Earth Store Bodhisattva said, "Humane One, within the Iron Ring are endless hells like that.

There is also the hell of Crying Out, the hell of Pulling Tongues,
the hell of Dung and Urine, the hell of Copper Locks,
the hell of Fire Elephants, the hell of Fire Dogs,
the hell of Fire Horses, the hell of Fire Oxen,
the hell of Fire Mountains, the hell of Fire Rocks,
the hell of Fire Beds, the hell of Fire Beams,
the hell of Fire Eagles, the hell of Sawing Teeth,
the hell of Flaying Skin, the hell of Drinking Blood,
the hell of Burning Hands, the hell of Burning Feet,
the hell of Hanging Hooks, the hell of Fire Rooms,
the hell of Iron Cells, and the hell of Fire Wolves.

"Each of those hells contains lesser hells numbering from one, or two, or three, or four, to hundreds of thousands. Each of those lesser hells has its own name."

Earth Store Bodhisattva told Universal Worthy Bodhisattva, "Humane One, such are the karmic responses of beings in Jambudvipa who commit evil deeds.

The power of karma is extremely great. It rivals Mount Sumeru in its heights. It surpasses the great oceans in its depth. It obstructs the path leading to Sagehood. For that reason, beings should never think that minor bad deeds are unimportant or assume that they do not count as offenses. After death there will be retributions to undergo that cover all those details.

Fathers and sons have the closest relationship, but their roads diverge and each must go his own way. Even if they met, neither would consent to undergo suffering in the other's place.

Now, based on the awesome spiritual power of the Buddha, I will describe some of the retributions for offenses that take place in the hells. Please, Humane One, listen for a moment to what I am going to say."

Universal Worthy replied, "I have long known of the retributions that happen in the Three Evil Paths. My hope in asking the Humane One to describe them is that when beings in the future Dharma Ending Age who are doing evil deeds hear the Humane One's descriptions they will be moved to take refuge with the Buddha."

Earth Store said, "Humane One, this is what happens during retributions in the hells. Offenders may go to a hell in which their tongues are stretched out and plowed through by cattle;
or to a hell in which their hearts pulled out and eaten by Yakshas;
or to a hell in which their bodies are cooked In cauldrons of boiling liquid;
or to a hell in which they are forced to embrace red-hot copper pillars;
or to a hell in which they are burned by fire that constantly pursues them;
or to a hell in which cold and Ice are all-pervasive;
or to a hell in which excrement and urine are endless;
or to a hell in which flying maces are unavoidable;
or to a hell in which fiery spears stab them repeatedly;
or to a hell in which they are constantly beaten on the chests and backs;
or to a hell in which their hands and feet are burned;
or to a hell in which they are bound by Iron snakes that coil around them;
or to a hell in which they are pursued by racing Iron dogs;
or to a hell in which their bodies are stretched by Iron mules.

"Humane One, to inflict these retributions in each hell hundreds of thousands of instruments made of copper, iron, stone, or fire arise from karmic force. Those four materials come into being in response to the kinds of karma offenders created.

If I were to explain in detail what happens during retributions in the hells, then I would need to tell of the hundreds of thousands of sufferings that must be undergone in each specific hell. How much more would that be the case for the sufferings in all the many hells!

Now, having based myself upon the awesome spiritual power of the Buddha, I have given a general answer to the Humane One's question, for if I were to speak in detail, it would take eons."

>> Chapter VI >>


CHAPTER VI
The Thus Come One's Praises

At that time the World Honored One emitted a great bright light from his entire body, totally illuminating Buddhalands as many as grains of sand in billions of Ganges Rivers.

His strong voice reached to all the Bodhisattvas, Mahasattvas in those Buddhalands, as well as to the gods, dragons, ghosts and spirits, humans, non-humans and others, saying, "Listen today, as I praise Earth Store Bodhisattva, Mahasattva, who displays an inconceivable awesome spiritual strength and compassionate power throughout the Ten Directions as he rescues and protects beings when things happen to them as they suffer for offenses they have committed.

After I pass into Nirvana, all of you Bodhisattvas, Mahasattvas and all of you gods, dragons, ghosts, spirits, and others should use vast numbers of expedient means to protect this Sutra and to cause all beings to realize the bliss of Nirvana."

After that was said a Bodhisattva named Universally Expansive arose in the assembly, placed his palms together respectfully, and said to the Buddha, "We are now about to witness the World Honored One praise Earth Store Bodhisattva's inconceivably great awesome spiritual virtue.

We hope the World Honored One will also aid beings in the future Dharma Ending Age by telling us about how Earth Store Bodhisattva benefits people and gods and about the working out of cause and effect. That will help the gods, dragons, and the rest of the Eightfold Division, along with beings of the future to receive the Buddha's teaching respectfully."

At that time the World Honored One said to the Bodhisattva Universally Expansive, to the Fourfold Assembly, and others, "Listen attentively, listen attentively. I will briefly describe to you how Earth Store Bodhisattva's virtuous deeds keep benefiting people and gods."

Universally Expansive replied, "Excellent, World Honored One. We are happy to listen."

The Buddha told the Bodhisattva Universally Expansive, "If, in the future, good men or good women who, upon hearing Earth Store Bodhisattva, Mahasattva's name, place their palms together, praise him, bow to him, or gaze in worship, they will overcome thirty eon's worth of offenses.

Universally Expansive, if good men or good women gaze upon and bow but once to painted or drawn images of the Bodhisattva or images made using clay, stone, lacquer, gold, silver, copper and iron, they will be reborn one hundred times in the Heaven of the Thirty-Three and will eternally avoid falling into the Evil Paths.

If their blessings in the heavens come to an end and they are born in the human realm, they will become national leaders who suffer no loss of benefits.

"There may be women who dislike having female bodies. Suppose they whole-heartedly make offerings to images of Earth Store Bodhisattva that are paintings or are made using clay, stone, lacquer, copper, iron, or other materials.

If they continually make such offerings day after day without fail, using flowers, incense, food, drink, clothing, colored silks, banners, money, jewels, and other items as offerings, when those good women finish their current female retributions, then throughout hundreds of thousands of eons they will never again be born in worlds where there are women, much less be one, unless it be through the strength of their compassionate vows to liberate beings.

Based on the strength of their offerings to Earth Store Bodhisattva and the power of their meritorious virtues, they will not be born into female bodies throughout hundreds of thousands of eons.

"Moreover, Universally Expansive, women who are ugly or prone to sickness will dislike those problems. If they gaze at and bow to images of Earth Store Bodhisattva with sincere resolve for even just a few minutes, then throughout millions of eons, they will always be born with full and perfect features.

If those woman who are ugly do not dislike having female bodies, then throughout billions of lives they will always be born as women of royal lineage, or will marry into royalty, or will become daughters of prime ministers, prominent families, or great Elders.

They will be of upright birth and full-featured. They will receive such blessings from having sincerely beheld and worshipped Earth Store Bodhisattva.

"Moreover, Universally Expansive, there may be good men or good women who are able to play music, sing, or chant praises, and make offerings of incense and flowers before images of the Bodhisattva or who are able to exhort one or more others to do likewise.

Now and in the future, such people will be surrounded day and night by hundreds of thousands of ghosts and spirits who will even prevent bad news from reaching their ears, much less allow them to be personally involved in any accidents.

"Moreover, Universally Expansive, in the future, evil people, evil spirits, or evil ghosts may see good men or good women taking refuge with, respectfully making offerings to, praising, beholding, and bowing to images of Earth Store Bodhisattva.

Those beings may make the mistake of ridiculing such acts of worship, saying that they are of no merit. They may sneer at those good people, condemn them behind their backs, or get a group or even one other person to have even as little as one thought of condemnation.

Such beings will fall into the Avichi Hell and the extreme misery they will undergo as retribution for their slander will not end even after the thousand Buddhas of the Worthy Eon have passed into tranquility.

Only after that eon will they be reborn among the hungry ghosts, where they will pass a thousand more eons before being reborn as animals. Only after another thousand eons will they obtain human bodies, but they will be poor and lowly with incomplete faculties, and their evil karma will cause them to suffer mental afflictions. Before long they will fall into the Evil Paths again.

Universally Expansive, such are the retributions that will undergo those who ridicule and slander others' acts of worship. How much worse will the retributions be if besides their slandering, they have other evils views.

"Moreover, Universally Expansive, in the future, men or women may be bedridden for years and in spite of their wishes be unable either to get well or to die. At night they may dream of evil ghosts, or of family and relatives, or of wandering on dangerous paths. In numerous nightmares they may roam with ghosts and spirits.

As days, months, and years go by, such people may weaken and waste away, cry out in pain in their sleep, and become progressively depressed and melancholy.

Those things happen when the force of karma has not yet been determined, which makes it difficult for them to die and impossible for them to be cured. The ordinary eyes of men and women cannot recognize such things.

"In that situation some people should recite this Sutra aloud once before images of the Buddhas and Bodhisattvas.

They should also offer possessions which those sick people cherish, such as clothing, jewels, gardens, or houses. They should speak distinctly to the sick people saying, 'Now before this Sutra or these images, we are offering these items on behalf of these sick people.' They may offer sutras or images, or commission images of Buddhas or Bodhisattvas, or build stupas or monasteries, or light oil lamps, or give to the Eternally Dwelling.

They should tell the sick people three times about the offerings that are being made, informing them so they both hear and understand what is being done.

"If their consciousnesses are already scattered and their breathing has stopped, then for one, two, three, four, and on through seven days, others should continue to inform them clearly and to read this Sutra aloud.

When those people's lives end, they will gain liberation from all heavy and disastrous offenses they committed in previous lives, even offenses warranting Fivefold Relentless Retribution. They will be born in places where they will always know past lives.

How much greater will the karmic reward be if good men or good women can write out this Sutra themselves or commission others to do so. If they can carve or paint images themselves or commission others to do so, the benefits they receive will be great indeed!

"Therefore, Universally Expansive, if you see people reading and reciting this Sutra or even having a single thought of praise for it, or if you meet someone who reveres it, you should employ hundreds of thousands of expedients to exhort such people to be diligent and not retreat.

In both the present and the future they will be able to obtain billions of inconceivable meritorious virtues.

"Moreover, Universally Expansive, beings in the future may, while dreaming or drowsy, see ghosts, spirits, and other forms that are either sad, weeping, or worried, fearful, or terrified.

Those are all fathers, mothers, sons, daughters, brothers, sisters, husbands, wives, and relatives from one, ten, a hundred, or a thousand lives past who have not yet been able to leave the bad destinies.

They have no place from which to hope for the power of blessings to rescue them, and so they try to communicate with their closest descendants, hoping that those relatives will use some skillful means to help them get out of the Evil Paths.

"Universally Expansive, using your spiritual powers, exhort those descendants to recite this Sutra with sincere resolve before the images of Buddhas or Bodhisattvas or to request others to recite it, either three or seven times.

When the Sutra has been read aloud the proper number of times, relatives in the Evil Paths will obtain liberation and never again be seen by those who are dreaming or drowsy.

"Moreover, Universally Expansive, people of low station, and those who are slaves, or who are bonded, or who are deprived of their freedom in other ways may be aware of their past deeds and wish to repent of them and to reform.

If while beholding and bowing to Earth Store Bodhisattva's image with sincere resolve for seven days they are able to recite his name a full ten thousand times, then when their current retribution ends, those people will always be born into wealth and honor for thousands lives. How much the more will they avoid any of the sufferings of the Three Evil Paths.

"Moreover, Universally Expansive, in the future in Jambudvipa when the wives of Kshatriyas, Brahmans, Elders, Upasakas, and those of other names and clans are about to give birth to sons or daughters, the family members should recite this inconceivable Sutra and recite the Bodhisattva's name a full ten thousand times during the seven days before the birth of their children.

If those infants, whether male or female, were destined to undergone a terrible retribution for things done in past lives, they will be liberated from those retributions. They will be peaceful, happy, easily raised, and will have long lives.

If those children were due to receive blessings, then their peace and happiness will increase, as will their lifespans.

"Moreover, Universally Expansive, on the first, eighth, fourteenth, fifteenth, eighteenth, twenty-third, twenty-fourth, twenty-eighth, twenty-ninth, and thirtieth days of the lunar month, the offenses of beings are tabulated and their gravity assessed.

"Every single movement or stirring of thought on the part of beings of Jambudvipa creates karma and offenses. How much more is that the case when they blatantly indulge in killing, stealing, sexual misconduct, false speech and hundreds of thousands of other kinds of overt offenses.

"If they are able to recite this Sutra once on those ten vegetarian days, before the images of Buddhas, Bodhisattvas, or worthy one and sages, then there will be no disasters for within a radius of one hundred yojanas.

The relatives of those who recite, both old and young, now and in the future, will be apart from the Evil Paths throughout hundreds of thousands of years.

If they can recite this sutra once on each of these ten vegetarian days, then there will be no accidents or illnesses in the family, and there will be food and clothing in abundance.

"Universally Expansive, you should know of the beneficial deeds done by Earth Store Bodhisattva as he makes use of his indescribably many billions of great awesome spiritual powers.

The beings of Jambudvipa have strong affinities with this Bodhisattva. If they hear the Bodhisattva's name, see the Bodhsattva's image, or hear but a few words, a verse, or sentence of this Sutra, then they will enjoy particularly wonderful peace and happiness in this present life.

Through hundreds of thousands of ten thousands of future lives, they will always be handsome or beautiful, and they will be born into honorable and wealthy families."

Having heard the Buddha, Thus Come One, praise Earth Store Bodhisattva in that way. Universally Expansive Bodhisattva knelt, placed his palms together, and again addressed the Buddha, saying, "World Honored One, I have long known that this Bodhisattva has both inconceivable spiritual powers and mighty vows. I have questioned the Thus Come One so that beings in the future will know of these benefits. I receive this answer most respectfully.

World Honored One, how should this Sutra be titled and how should we propagate it?"

The Buddha said to Universally Expansive, "This Sutra has three titles:
the first is The Past Vows of Earth Store Bodhisattva;
it is also called Earth Store's Past Conduct; and
it is called Sutra of the Power of Earth Store's Past Vows.

Because this Bodhisattva repeatedly makes such great and mighty vows throughout long eons to benefit beings, you should all propagate this Sutra in accord with his vows."

After Universally Expansive had heard that, he placed his palms together respectfully, made obeisance, and withdrew.

>> Chapter VII >>


CHAPTER VII
Benefiting the Living and the Dead

At that time Earth Store Bodhisattva, Mahasattva said to the Buddha, "World Honored One, I see that every single movement or stirring of thought on the part of beings of Jambudvipa is an offense. Beings tend to use up the wholesome benefits they gain; many of them end up retreating from their initial resolve. If they encounter evil conditions, they augment them with every thought.

They are like people trying to carry heavy rocks while walking through mud. Each step becomes more difficult and the rocks more cumbersome as their feet sink deeper. If they meet a mentor, he may be strong enough to lighten or even totally remove their burdens. Helping them thus, the mentor will urge them to step on solid ground, pointing out that once they reach a level place they should remain aware of that bad path and never traverse it again.

"World Honored One, the bad habits of beings range from minor to major. Since all beings have such habits, their parents or relatives should create blessings for them when they are on the verge of dying in order to assist them on the road ahead.

That may be done by hanging banners and canopies; lighting oil lamps; reciting the sacred Sutras; making offerings before the images of Buddhas or sages.

Another way to assist them is by reciting the names of Buddhas, Bodhisattvas, and Pratyekabuddhas so that the recitation of each name passes by the ear of the dying one and is heard in his fundamental consciousness.

"Suppose the evil karma created by beings were such that they should fall into the evil destinies. If their relatives cultivate wholesome causes on their behalf when they are close to death, then their manifold offenses can be dissolved.

If relatives can further do many good deeds during the first forty-nine days after the death of such beings, then the deceased can leave the evil destinies forever, be born as humans and gods, and receive supremely wonderful bliss. The surviving relatives will also receive limitless benefits.

"Therefore, before the Buddhas, World Honored Ones, as well as before the gods, dragons, and the rest of the Eightfold Division, humans and non-humans, I now exhort beings of Jambudvipa to be careful to avoid harming, killing, and doing other unwholesome deeds; to refrain from worshipping ghosts and spirits or making sacrifices to them; and to never call on mountain sprites on the day of death.

Why is that?

"Killing, harming, and making sacrifices are not the least bit helpful to the deceased. Such acts only bind up the conditions of offenses so that they grow ever more deep and heavy.

The deceased might have been due to increase his potential for Sagehood or gain birth among humans or gods in his next life or in the future. But when his family commits offenses in his name, he will resent the disasters he inherits, and his good rebirth will be delayed.

How much more would that be the case for people on the verge of death who during their lives had planted few good roots. Each offender has to undergo the bad destinies according to his own karma. How could anyone bear to have relatives add to that karma?

"That would be like having a neighbor add a few more things to a load of over a hundred pounds being carried by someone who had already traveled a long distance and who had not eaten for three days. By adding that extra weight, that person's burden would become even more unbearable.

"World Honored One, I see that beings of Jambudvipa will themselves receive the benefit of any good deeds they are able to do within the Buddha's teaching. That holds true even when the deeds are as small as a strand of hair, a drop of water, a grain of sand, or a mote of dust."

After that had been said, an Elder named Great Eloquence arose in the assembly. He had long since realized Non-production and was only appearing in the body of an Elder to teach and transform those in the Ten Directions.

Placing his palms together respectfully, he asked Earth Store Bodhisattva, "Great Lord, after people in Jambudvipa die and their close and distant relatives generate merit by making meal offerings and doing other such good deeds, will the deceased obtain merit and virtue significant enough to bring about their liberation?

Earth Store replied, "Elder, based on the awesome power of the Buddhas, I will now proclaim this principle for the sake of beings of the present and future.

Elder, if beings of the present and future when on the verge of dying hear the name of one Buddha, one Bodhisattva, or one Pratyekabuddha, they will attain liberation whether they have offenses or not.

"When men or women laden with offenses who failed to plant good causes die, even they can receive one-seventh of any merit dedicated to them by relatives who do good deeds on their behalf. The other six-sevenths of the merit will return to the living relatives who did the good deeds.

It follows that men and women of the present and future who cultivate while they are strong and healthy will receive every portion of the benefit derived."

"The arrival of the Great Ghost of Impermanence is so unexpected that the deceased ones' consciousnesses first roam in darkness and obscurity, unaware of offenses and blessings.

For forty-nine days they are as if deluded or deaf, or as if in courts where their karmic retributions are being decided. Once judgment is fixed, rebirths are undergone according to their karma.

In the time before rebirths are determined, the deceased suffer thousands of myriads of concerns. How much more is that the case for those who are to fall into the bad destinies.

"Throughout forty-nine days those whose lives have ended and who have not yet been reborn will be hoping every moment that their immediate relatives will earn blessings powerful enough to rescue them.

At the end of that time the deceased will undergo retribution according to their karma. If someone is an offender, he may pass through hundreds of thousands of years without even a day's liberation.

If someone's offenses deserve Fivefold Relentless Retribution, he will fall into the great hells and undergo incessant suffering throughout hundreds of thousands of eons."

"Moreover, Elder, when beings who have committed karmic offenses die, their relatives may prepare vegetarian offerings to aid them on their karmic paths.

In the process of preparing the vegetarian meal and before it has been eaten, rice-washing water and vegetable leaves should not be thrown on the ground. Before the food is offered to the Buddhas and Sangha no one should eat it.

If there is laxness or transgression in this matter, then the deceased will receive no strength from it.

If purity is vigorously maintained in making the offering to the Buddhas and Sangha, the deceased will receive one-seventh of the merit.

Therefore, Elder, by performing vegetarian offerings on behalf of deceased fathers, mothers, and other relatives while making earnest supplication on their behalf, beings of Jambudvipa benefit both the living and the dead."

After that was said, hundreds of thousands of millions of nayutas of ghosts and spirits of Jambudvipa who were in the palace of the Trayastrimsha Heaven, made the unlimited resolve to attain Bodhi.

The Elder Great Eloquence made obeisance and withdrew.

>> Chapter VIII >>


CHAPTER VIII
Praises of King Yama and His Followers

At that time from within the Iron Ring Mountain, Lord Yama and his following of infinite ghost kings came before the Buddha in the Trayastrimsha Heaven. They were

the Ghost King Evil Poison, the Ghost King Many Evils,
the Ghost King Great Argument, the Ghost King White Tiger,
the Ghost King Blood Tiger, the Ghost King Crimson Tiger,
the Ghost King Spreading Disaster, the Ghost King Flying Body,
the Ghost King Lightning Flash, the Ghost King Wolf Tooth,
the Ghost King Thousand Eyes, the Ghost King Animal Eater,
the Ghost King Rock Bearer, the Ghost King Lord of Bad News,
the Ghost King Lord of Calamities, the Ghost King Lord of Food,
the Ghost King Lord of Wealth, the Ghost King Lord of Domestic Animals,
the Ghost King Lord of Birds, the Ghost King Lord of Beasts,
the Ghost King Lord of Mountain Sprites, the Ghost King Lord of Birth,
the Ghost King Lord of Life, the Ghost King Lord of Sickness,
the Ghost King Lord of Danger, the Ghost King Three Eyes,
the Ghost King Four Eyes, the Ghost King Five Eyes,
the Ch'i Li Shih King, the Great Ch'i Li Shih King,
the Ch'i Li Ch'a King, the Great Ch'i Li Ch'a King,
the No Ch'a King, the Great No Ch'a King,
and other such great ghost kings.

With them were hundreds of thousands of minor ghost kings who dwelt throughout Jambudvipa; each presiding over certain jurisdictions.

Aided by the Buddha's awesome spiritual strength and the power of Earth Store Bodhisattva, Mahasattva all these ghost kings joined Lord Yama in the Trayastrimsha Heaven and together they stood to one side.

Then Lord Yama knelt down, placed his palms together, and said to the Buddha, "World Honored One, aided by the Buddha's awesome spiritual strength and the power of Earth Store Bodhisattva, I have been able to come to this great assembly in the Trayastrimsha Heaven, with all these ghost kings and, to our benefit, join in together.

There is now a small doubt that I should like to express, and we hope the World Honored One will be compassionate and resolve it."

The Buddha told Lord Yama, "I will answer whatever you want to ask."

At that time Lord Yama looked respectfully at the World Honored One, made obeisance, turned his head to acknowledge Earth Store Bodhisattva, and then said to the Buddha, "World Honored One, I observe that Earth Store Bodhisattva uses hundreds of thousands of expedient means to take across beings who are suffering for their offenses within the Six Paths of rebirth. I see that he does so unstintingly, without the least fatigue.

Although this Great Bodhisattva uses his inconceivable spiritual penetrations to do such deeds, it doesn't take long for the beings whom he has helped in gaining release from retributions to fall again into the bad paths.

"World Honored One, since Earth Store Bodhisattva has such great inconceivable spiritual power, why are beings not able to rely on it, to stay in the good paths, and to be freed once and for all?

Please, World Honored One, explain that for us."

The Buddha told Lord Yama, "The beings of Jambudvipa have stubborn and obstinate natures, difficult to tame, difficult to subdue.

This Great Bodhisattva continually rescues such beings throughout hundreds of thousands of eons and causes them to obtain liberation quickly.

For those beings undergoing retributions even in the worst destinies, the Bodhisattva applies the strength of expedients to extricate them from their own basic karmic conditions and lead them to understand the events of their past lives.

But because beings of Jambudvipa are so bound by their own heavy bad habits, they keep revolving in and out of the various paths over and over as this Bodhisattva labors throughout many long eons to entirely effect their rescue and release.

"They are like people who in confusion, lost their way home and took a bad road by mistake. On that treacherous road were many Yakshas, tigers, wolves, lions, serpents, and vipers.

Those confused people were sure to be harmed in an instant on that dangerous path.

But then they met a knowledgeable guide, skilled in neutralizing all harm, including the toxins of the Yakshas and others.

The mentor began to guide the travelers off that road and told them, 'Beware, everyone! What business brought you onto this road? What kinds of special skills do you have to avoid all that harm?'

Hearing that, the confused travelers realized they were on a dangerous path and turned back, attempting to escape.

"The kind guide then told them to join hands, led them off the dangerous path, and helped them avoid the deadly peril. When they reached a safe path, the travelers grew happy and at peace.

Their mentor then said to them. 'Take care, confused ones, never to go back into that road again. Once on it, it is hard to get off; it can destroy a person's very nature and life.'

The travelers who had been confused expressed their deep gratitude and as they were about to part the mentor said to them, 'If you see any other travelers, whether you know them personally or not, be they men or women, tell them that the poisons and evils on that path could harm their natures and lives. Do not allow them to unwittingly bring about their own deaths.'

In the same way, Earth Store Bodhisattva, replete with great compassion, rescues beings who are suffering for their offenses and enables them to be born among humans and gods where they enjoy wonderful bliss.

"Once those offenders obtain release from the suffering they experienced in the paths where their karma took them, they should never go down those roads again.

They are like the lost people who mistakenly took a wrong road and were lead off it by a kind mentor. They now know to never take that road again.

Moreover, they exhort others not to enter that road by saying, 'We took that road ourselves when we got confused, but we escaped and now we know better than to ever enter that road again. If we were to set foot on it again, we would get confused and be unable to recognize it as the dangerous path we descended into before. That being the case, we might lose our lives.'

The same holds true for falling into the bad destinies. Due to the powerful expedient means of Earth Store Bodhisattva, beings can be freed and can gain rebirth as humans or gods.

If they were to then turn around and enter into the bad destinies again, then those with heavy karmic bonds might remain in the hells forever with no chance of escape."

At that time the Ghost King Evil Poison placed his palms together respectfully, addressed the Buddha, and said, "World Honored One, each of us countless ghost kings of Jambudvipa bestows benefit or inflicts harm on beings differently. But our karmic retributions are such that we and our followers roam in the world doing much evil and little good.

When we pass a household, a city, a town, a garden, a cottage or a hut where there are men or women who have cultivated as little as a hair's worth of good deeds, who have hung but one banner or one canopy, who have used a little incense or a few flowers as offerings to images of Buddhas or Bodhisattvas, or who have recited the sacred Sutras or burned incense as an offering to even one sentence or gatha in them, we ghost kings will respect such people as we would the Buddhas of the past, present, and future.

We will instruct the smaller ghosts, each of whom has great power, as well as the earth spirits, to protect such people. Bad situations, accidents, severe or unexpected illnesses, and all other unwelcome events will not even come near their residences or other places they may be, much less enter the door."

The Buddha praised the ghost kings, "Excellent, excellent, that all of you ghost kings join Lord Yama in protecting good men and women in that way. I shall tell Lord Brahma and Lord Shakra to see that you are protected as well."

When that was said, a ghost king in the assembly named Lord of Life said to the Buddha, "World Honored One, my karmic conditions are such that I have jurisdiction over the lifespans of people in Jambudvipa, governing both the time of their births and their deaths.

My fundamental vows are based on a great desire to benefit them, but people do not understand my intent and go through birth and death in distress. Why is that?

"When women in Jambudvipa have just borne children, be they boys or girls, or when they are just about to give birth, good deeds should be done to increase the benefits of the household, thus causing the local earth spirits to be immeasurably pleased. The spirits will then protect the mother and child so that they experience peace and happiness; they will bring benefit to the entire family.

After the birth, all killing for the purpose of offering fresh meat to the mother should be carefully avoided, as should parties that involve consumption of alcohol, eating of meat, singing, and playing musical instruments. All those things can keep the mother and child from being peaceful and happy. Why is that?

At the difficult time of birth, uncountable evil ghosts, including mountain sprites, goblins, and spirit-beings, desire to eat the strong-smelling blood. I quickly order the local earth spirits of that household to protect the mother and child, allowing them to be peaceful and happy and to receive other benefits.

When people in such households witness those benefits, they should do meritorious deeds to express their gratitude to the earth spirits. If instead, they harm and kill, and have big parties involving feasting and entertainment, then the retributions that result from such offenses will be born by they themselves and will bring harm to the mother and child as well.

"Moreover, when people of Jambudvipa are on the verge of death, I wish to keep them from falling into the Evil Paths, regardless of whether they have done good or evil.

But how much is this power of mine to help them increased when they have personally cultivated good roots!

When those who do good in Jambudvipa are about to die, hundreds of thousands of ghosts and spirits from the Evil Paths transform themselves and appear as the parents or other relatives in an attempt to lead such people to fall into the Evil Paths.

How much more is that the case for those who have done evil deeds!

"World Honored One, when men or women in Jambudvipa are on the verge of death, their consciousnesses and spirits become confused and dark. They are unable to discriminate between good and evil, and their eyes and ears are unable to see or hear.

That is why relatives of those deceased should make generous offerings, recite the sacred Sutras, and recite the names of Buddhas and Bodhisattvas. Such good conditions can cause the deceased to leave the Evil Paths, and all the demons, ghosts, and spirits will withdraw and disperse.

"World Honored One, if at the time of death beings of any kind have an opportunity to hear the name of one Buddha or Bodhisattva or to hear a sentence or gatha of a Mahayana Sutra, I observe that such beings can quickly be freed from the pull of their accumulated minor bad deeds that would otherwise send them to the bad paths.

The exception to that is crimes involving killing that warrant Fivefold Relentless Retribution."

The Buddha told the Ghost King Lord of Life, "Because of your great compassion, you are able to make such great vows and protect all beings in the midst of life and death.

When men or women in the future undergo birth and death, do not withdraw from your vow, but liberate them all so they gain eternal peace."

The ghost king told the Buddha, "Please do not be concerned. Until the end of my life I shall in every thought protect beings of Jambudvipa both at the time of birth and at the time of death, so that they all gain tranquility. I only wish that at the time of birth and of death they will believe what I say, so that they all can be liberated and gain many benefits."

At that time the Buddha told Earth Store Bodhisattva, "This great Ghost King Lord of Life has already passed through hundreds of thousands of lives as a ghost king, protecting beings during both birth and death. Only because of this Great Being's compassionate vows does he appear in the body of a ghost, for in reality he is not a ghost.

After one hundred seventy eons have passed, he will become a Buddha named No Appearance Thus Come One. His eon will be called Happiness, and his world will be named Pure Dwelling. That Buddha's lifespan will be incalculable eons.

Earth Store, the circumstances surrounding this great ghost king are thus. They are inconceivable, and the people and gods whom he takes across are countless."

>> Chapter IX >>


CHAPTER IX
The Names of Buddhas

At that time, Earth Store Bodhisattva, Mahasattva said to the Buddha, "World Honored One, I want to discuss some practices that will be helpful to beings of the future and will enable them to gain great benefit throughout their lives and deaths. World Honored One, please hear my words."

The Buddha told Earth Store Bodhisattva, "Now with your expansive compassion you wish to discuss the inconceivable events involved in rescuing all those in the Six Paths who are suffering for their offenses. This is the right time. Speak now, since my Nirvana is near, so that I may soon help you complete your vows. Then I too will have no need to be concerned about beings of the present or future."

Earth Store Bodhisattva said to the Buddha, "World Honored One, countless Asamkhyeya eons ago a Buddha named Boundless Body Thus Come One appeared in the world.

If men or women hear this Buddha's name and have a momentary thought of respect, those people will overstep the heavy offenses involved in birth and death for forty eons. How much more will that be the case for those who sculpt or paint this Buddha's image or praise and make offerings to him. The merit they obtain will be limitless and unbounded.

"Furthermore, in the past as many eons ago as there are grains of sand in the Ganges River, a Buddha named Jewel Nature Thus Come One appeared in the world.

If men or women hear this Buddha's name and instantly decide to take refuge, those people will never retreat from the Unsurpassed Path.

"Furthermore, in the past a Buddha named Padma Supreme Thus Come One appeared in the world. If men or women hear this Buddha's name or if the sound of the name merely passes into their ears, those people will be reborn one thousand times in the Six Desire Heavens. How much more will that be the case if those people sincerely recite the name of that Thus Come One.

"Furthermore, in the past inexpressibly ineffable Asamkhyeya eons ago, a Buddha named Lion's Roar Thus Come One appeared in the world. If men or women hear this Buddha's name and in a single thought take refuge, those people will encounter numberless Buddhas who will rub the crowns of their heads and bestow predictions of enlightenment upon them.

"Furthermore, in the past a Buddha named Krakucchanda appeared in the world. If men or women hear this Buddha's name and sincerely behold, worship, or praise him, those people will become Great Brahma Heaven kings in the assemblies of the thousand Buddhas of the Worthy Eon and will there receive superior predictions.

"Furthermore, in the past a Buddha named Vipashin appeared in the world. If men or women hear this Buddha's name, those people will eternally avoid falling into the Evil Paths, will always be born among people or gods, and will abide in supremely wonderful bliss.

"Furthermore, in the past as many eons ago as there are grains of sand in limitless and countless Ganges Rivers, a Buddha named Jewel Supreme appeared in the world. If men or women hear this Buddha's name, those people will never fall into the Evil Paths and will always abide in the heavens experiencing supremely wonderful bliss.

"Furthermore, in the past a Buddha named Jeweled Appearance Thus Come One appeared in the world. If men or women hear this Buddha's name and give rise to a thought of respect, those people will soon attain the fruitions of Arhatship.

"Furthermore, limitless Asamkhyeya eons ago, a Buddha named Kashaya Banner Thus Come One appeared in the world. If men or women hear this Buddha's name, those people will overcome the offenses of birth and death for one hundred great eons.

"Furthermore, in the past a Buddha named Great Penetration Mountain King Thus Come One appeared in the world. If men or women hear this Buddha's name, those people will encounter as many Buddhas as there are grains of sand in the Ganges, who will speak Dharma extensively for them, making certain that they realize Bodhi.

"Furthermore, in the past there were Buddhas named Pure Moon Buddha, Mountain King Buddha, Wise Victory Buddha, Pure Name King Buddha, Accomplished Wisdom Buddha, Unsurpassed Buddha, Wonderful Sound Buddha, Full Moon Buddha,

Moon-Face Buddha, and indescribably many other Buddhas.

"World Honored One, beings of the present and future, both gods and humans, both male and female, can amass such limitless merit and virtue by reciting only one Buddha's name. How much more merit will they amass by reciting many names.

Those beings will personally obtain benefits in their lives and deaths significant enough to keep them from ever falling into the Evil Paths.

"When people are on the verge of dying, a group of their relatives, or even just one of them, should recite Buddhas' names aloud for the people who are sick. By doing so, the karmic retributions of those people who are about to die will be dissolved, even offenses deserving Fivefold Relentless Retribution.

Offenses warranting Fivefold Relentless Retribution are so extremely heavy that those who commit them should not escape retribution for millions of eons. If, however, at the time of such offenders' deaths, someone recites the names of Buddhas on their behalf, then their offenses can gradually be dissolved.

How much more will that be the case for beings who recited those names themselves. The merit they attain will be limitless and will eradicate measureless offenses."

End of Part Two of Sutra of
the Past Vows of Earth Store Bodhisattva

>> Chapter X >>


Part Three of Sutra of
the Past Vows of Earth Store Bodhisattva

CHAPTER X
The Conditions and Comparative Merits and Virtues of Giving

At that time. Earth Store Bodhisattva, Mahasattva, based on the Buddha's awesome spiritual strength, arose from his seat, knelt on one knee, placed his palms together and said to the Buddha, "World Honored One, I have observed beings within the paths of karma and compared their acts of giving. Some do a little and some do a lot. Some receive blessings for one life, some for ten lives, and some receive great blessings and benefits for hundreds or thousands of lives. Why is that? Please, World Honored One, explain that for us."

At that time the Buddha told Earth Store Bodhisattva, "Here in this assembly in the palace of the Trayastrimsha Heaven, I will now discuss the comparative merit and virtue derived from acts of giving done by the beings in Jambudvipa. Listen attentively to what I say."

Earth Store said to the Buddha, "I have wondered about this matter and will be pleased to listen."

The Buddha told Earth Store Bodhisattva, "In Jambudvipa, leaders of nations, prime ministers, high officials, great Elders, great Ksatriyas, great Brahmans, and others may encounter those who are poor,

hunchbacked, crippled, dumb, mute, deaf, retarded, blind or handicapped in other ways.

Those leaders and good people may wish to give to those people and may be able to do so with great compassion, a humble heart, and a smile. They may arrange to give generously, either personally with their own hands, or by arranging for others to do so, using gentle words and sympathetic speech.

The blessings and benefits that such leaders and good people will accrue will be comparable to the meritorious virtues derived from giving to as many Buddhas as there are grains of sand in a hundred Ganges Rivers. Why is that?

Those leaders and good people will receive such rewards of blessings and benefits for having shown a great compassionate heart toward the most impoverished and handicapped individuals.

Throughout hundreds of thousands of lives to come they will always have an abundance of the seven gems, not to mention clothing, food, and the necessities of life.

"Moreover, Earth Store, in the future the leaders of nations, Brahmans, and others may encounter Buddhist stupas, monasteries, or images of Buddhas, Bodhisattvas, Sound-hearers, or Pratyekabuddhas and personally make offerings or give gifts to them.

From doing that, those leaders and good people will serve as Lord Shakra for a duration of three eons, enjoying supremely wonderful bliss.

If they are able to transfer the blessings and benefits of that giving and dedicate it to the Dharma Realm, then those leaders of nations and good people will reign as great Brahma Heaven kings for ten eons.

"Moreover, Earth Store, in the future leaders of nations, Brahmans, and others may, upon encountering ancient Buddhist stupas and monasteries or sutras and images that are damaged, decaying, or broken, resolve to restore them.

Those leaders and good people may then do so themselves or encourage others, as many as hundreds of thousands of people to help and thereby establish affinities.

Those leaders and good people will become Wheel-Turning Kings for hundreds of thousands of successive lives and those who made offerings with them will be leaders of small nations for as many lives.

If, before the stupas or monasteries, they resolve to dedicate that merit, then, based on that limitless and unbounded reward, those leaders, good people, and their helpers will eventually all complete the path to Buddhahood.

"Moreover, Earth Store, in the future, leaders of nations, Brahmans, and others may have compassionate thoughts upon seeing the old, the sick, or women in child birth, and may provide them with medicinal herbs, food, drink, and bedding so as to make them peaceful and comfortable.

The blessings and benefits derived from doing that are quite inconceivable. For one hundred eons they will always be lords of the Pure Dwelling Heavens, for two hundred eons they will be lords in the Six Desire Heavens, and they will ultimately attain Buddhahood. They will never fall into the Evil Paths, and for hundreds of thousands of lives they will hear no sounds of suffering.

"Moreover, Earth Store, if in the future, leaders of nations, Brahmans, and others can give in that way, they will receive limitless blessings.

"If they are in addition, able to dedicate that merit, be it great or small, they will ultimately attain Buddhahood. How much more easily will they be able to attain the rewards of becoming Shakra, Brahma, or a Wheel-Turning King.

Therefore, Earth Store, you should urge beings everywhere to learn to give in those ways.

"Moreover, Earth Store, in the future if good men or good women only manage to plant a few good roots within the Buddhadharma, equivalent to no more than a strand of hair, a grain of sand, or a mote of dust, they will receive incomparable blessings and benefits.

"Moreover, Earth Store, good men or women in the future may, upon encountering images of Buddhas, Bodhisattvas, Pratyekabuddhas, or Wheel-Turning Kings, give gifts or make offerings to them.

Such persons will attain limitless blessings and will always enjoy supremely wonderful bliss among people and gods.

If they can dedicate that merit to the Dharma Realm, their blessings and benefits will be beyond compare.

"Moreover, Earth Store, good men or good women in the future may, upon encountering Great Vehicle sutras or upon hearing but a single gatha or a sentence, be inspired to praise, venerate, give gifts, and make offerings to them.

Those people will attain great limitless and unbounded rewards. If they can dedicate that merit to the Dharma Realm, their blessings will be beyond compare.

"Moreover, Earth Store, in the future, good men or good women may, upon encountering new Buddhist stupas, monasteries, or sutras of the Great Vehicle, give gifts and make offerings to them, gaze at them in worship, and respectfully make praises with joined palms.

They may, upon encountering old ones or those that have been destroyed or damaged, either do the repairing or rebuilding themselves or encourage others to help them.

Those who help will become leaders of small nations throughout thirty successive lives. The donors themselves will always be Wheel-Turning Kings who will use the good Dharma to teach and transform those leaders of small nations.

"Moreover, Earth Store, in the future, good men or good women may plant good roots in the Buddhadharma by giving, making offerings, repairing stupas or monasteries, rebinding sutras, or doing other good deeds amounting to no more than a strand of hair, a mote of dust, a grain of sand, or a drop of water. Merely by transferring the merit from such deeds to the Dharma Realm, those people's meritorious virtues will enable them to enjoy superior and wonderful bliss for hundreds of thousands of lives.

If they dedicate the merit only to their immediate or extended families or to their own personal benefit, then the rewards received will be only three lives of happiness. By giving up one, a ten-thousandfold reward is obtained.

"So it is. Earth Store. The circumstances involved in the causes and conditions of giving are like that."

>> Chapter XI >>


CHAPTER XI
The Dharma Protection of an Earth Spirit

At that time the Earth Spirit Firm and Stable spoke to the Buddha and said, "World Honored One, from long ago I have personally beheld and bowed to limitless numbers of Bodhisattvas, Mahasattvas. All of them have inconceivable and great spiritual penetrations and wisdom that they use in taking vast numbers of beings across. Among all the Bodhisattvas, Earth Store Bodhisattva, Mahasattva has the deepest and most weighty vows.

"World Honored One, Earth Store Bodhisattva has great affinities in Jambudvipa. Manjushri, Samantabhadra, Avalokiteshvara, and Maitreya, also produce by transformation, hundreds of thousands of bodies to take across those in the Six Paths, but their vows have an end.

Earth Store Bodhisattva has made these vows to teach and transform beings in the Six Paths throughout eons as many as the number of sand grains in hundreds of thousands of millions of Ganges Rivers.

"World Honored One, as I regard beings of the present and future, I see those who make shrines of clay, stone, bamboo, or wood and set them on pure ground in the southern part of their dwellings. They place within the shrines images of Earth Store Bodhisattva, either sculpted, painted, or made of gold, silver, copper, or iron. They then light incense, make offerings, behold, worship, and praise him.

By doing those things, such people will receive ten kinds of benefits.

"What are those ten?
First, their lands will be fertile.
Second, their families and homes will always be peaceful.
Third, their ancestors will be born in the heavens.
Fourth, those of the current generation will enjoy benefits and long lives.
Fifth, they will easily obtain what they want.
Sixth, they will not encounter disasters of water and fire.
Seventh, they will avoid unforeseen calamities.
Eighth, they will never have nightmares.
Ninth, they will be protected by spirits in their daily comings and goings.
Tenth, they will encounter many causes that pertain to Sagehood.

World Honored One, beings of the present and future who make offerings in their homes in the prescribed manner will attain benefits like those."

He further said to the Buddha, "World Honored One, good men or good women in the future may keep this Sutra and an image of the Bodhisattva where they live. Further, they may recite the Sutra and make offerings to the Bodhisattva.

For those who do that, I shall constantly use my own spiritual powers to guard and protect them day and night so that nothing bad happens to them, including floods, fire, robbery and theft, major disasters, and minor accidents."

The Buddha told the Earth Spirit Firm and Stable, "There are few spirits who can match your great spiritual power. Why do I say that?

"All the lands in Jambudvipa receive your protection. All the grasses, woods, sands, stones, paddy fields, hemp, bamboo, reeds, grains, rice, and gems come forth from the earth because of your power.

Moreover, your constant praising of the beneficial deeds of Earth Store Bodhisattva makes your meritorious virtues and spiritual penetrations hundreds of thousands of times those of ordinary earth spirits.

"If good men or good women in the future make offerings to this Bodhisattva, or recite the Sutra of the Past Vows of Earth Store Bodhisattva and rely upon even a single aspect of it in their cultivation, you should use your own spiritual powers to protect them. Do not allow any disasters or unwelcome events even to be heard, much less undergone, by them.

Not only will those people be protected by you, they will also be protected by the followers of Shakra, Brahma, and other gods. Why will they receive protection from sages and worthies such as those?

It will be due to their having beheld and worshipped an image of Earth Store Bodhisattva and from having recited this Sutra of his past vows. Such people will quite naturally be able to leave the sea of suffering and ultimately be certified to the bliss of Nirvana. For those reasons they receive great protection."

>> Chapter XII >>


CHAPTER XII
Benefits Derived from Seeing and Hearing

At that time the World Honored One emitted hundreds of thousands of millions of great rays of light from the opening at the crown of his head. They were
the White Ray, the Great White Ray,
the Auspicious Ray, the Great Auspicious Ray,
the Jade Ray, the Great Jade Ray,
the Purple Ray, the Great Purple Ray,
the Blue Ray, the Great Blue Ray,
the Azure Ray, the Great Azure Ray,
the Red Ray, the Great Red Ray,
the Green Ray, the Great Green Ray,
the Gold Ray, the Great Gold Ray,
the Celebration Cloud Ray, the Great Celebration Cloud Ray,
the Thousand-wheeled Ray, the Great Thousand-wheeled Ray,
the Jeweled Wheel Ray, the Great Jeweled Wheel Ray,
the Solar Disc Ray, the Great Solar Disc Ray,
the Lunar Disc Ray, the Great Lunar Disc Ray,
the Palace Ray, the Great Palace Ray,
the Ocean Cloud Ray, and the Great Ocean Cloud Ray.

After emitting such rays of light from the opening at the crown of his head, he spoke in subtle and wonderful sounds to the great assembly of gods, dragons, the rest of the Eightfold Division, humans, non-humans and others, "Hear me today in the palace of the Trayastrimsha Heaven as I praise Earth Store Bodhisattva, telling of his beneficial deeds, of inconceivable events, of the matter of his transcendence to Sagehood, of the circumstances of his certification to the Tenth Ground, and of the situation leading to his being irreversible from Anuttarasamyaksambodhi."

As that was said, a Bodhisattva, Mahasattva named Contemplator of the World's Sounds arose from his seat in the assembly, knelt on one knee, and with palms together said to the Buddha, "World Honored One, Earth Store Bodhisattva, Mahasattva is replete with great compassion and pities beings who are suffering for their offenses.

In thousands of millions of worlds he creates thousands of millions of transformation bodies through the strength of his meritorious virtues and inconceivable awesome spiritual strength.

I have heard the World Honored One and the numberless of Buddhas of the Ten Directions praise Earth Store Bodhisattva with different mouths but in unison, saying that even if all the Buddhas of the past, present, and future were to speak of his meritorious qualities, they could never finish describing them.

Upon hearing the World Honored One tell the great assembly that he now wants to praise Earth Store Bodhisattva's beneficial deeds and so forth, I am beseeching the World Honored One to praise the inconceivable events pertaining to Earth Store Bodhisattva for the sake of beings of the present and future and to cause the gods, dragons, and the rest of the Eightfold Division to gaze in worship and attain blessings."

The Buddha replied to the Bodhisattva Contemplator of the World's Sounds, "You have great affinity with the Saha World. If gods, dragons, men, women, spirits, ghosts, or any other beings who are suffering for offenses within the Six Paths hear your name, see your image, behold you, or praise you, they will definitely become irreversible on the Unsurpassed Way.

They will always be born among people and gods and there experience wonderful bliss. When the effects of their causes come to maturity, they will encounter Buddhas who will give them predictions.

You now are replete with great compassion and pity for beings, for gods, dragons, and the rest of the Eightfold Division. Listen as I discuss events involving the inconceivable benefits bestowed by Earth Store Bodhisattva. Listen attentively, I will describe them for you."

The Contemplator of the World's Sounds said, "So be it. World Honored One, I will be pleased to hear."

The Buddha told the Bodhisattva Contemplator of the World's Sounds, "In worlds of the present and future, gods whose heavenly blessings are ending may be manifesting the Five Signs of Decay, indications that they may be about to fall into Evil Paths.

When those signs appear, if those gods, whether male or female, see Earth Store Bodhisattva's image or hear his name and gaze at him or bow once to him, their heavenly blessings will thereby increase. They will experience great happiness and will never have to undergo retributions in the Three Evil Paths.

How much more will that be the case for those who upon seeing and hearing the Bodhisattva use incense, flowers, clothing, food, drink, jewels, and necklaces as gifts and offerings to him. The meritorious virtues, blessings, and benefits they gain will be limitless and unbounded.

"Moreover, Contemplator of the World's Sounds, in the worlds in the present and future, when beings in the Six Paths are on the verge of death, if they can hear the name of Earth Store Bodhisattva, even the sound of it passing through their ears only once, such beings will never have to endure the sufferings of the Three Evil Paths again.

"How much more will that be the case if the parents and other relatives use the houses, wealth, property, jewels, and clothing of such people who are on the verge of death to commission the carving or painting of images of Earth Store Bodhisattva.

"If those sick people have not yet died, their relatives can try to help them see, hear, and understand that their houses, jewels, and so forth have been used for the carving or painting of images of Earth Store Bodhisattva.

If those people's karmic retributions were such that they should have to undergo severe sickness, then with such merit they can quickly be cured and their lifespans prolonged.

If those people's retributions send them to the evil destinies at death due to their karma and obstacles, then with such merit they can, when their lives end, be born among people or gods and there enjoy extremely wonderful bliss. All their obstacles due to offenses will dissolve.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future men or women may have lost their fathers, mothers, brothers, or sisters while still an infant or as a child of three, or five, or under ten years of age.

As adults, such people may think about those parents and other relatives, not knowing into what paths or worlds or heavens they have been born.

Suppose such people are able to sculpt or paint images of Earth Store Bodhisattva or to gaze upon and worship him once or for one through seven days without retreating. Upon hearing his name and seeing his image they gaze in worship and make offerings.

"If such people's relatives had fallen into bad paths and were destined to remain there for many eons, those relatives will quickly gain release, be born among people or gods, and experience supremely wonderful bliss.

That will happen because of the meritorious virtue generated by their sons, daughters, brothers, or sisters who carved or painted images of Earth Store Bodhisattva and then gazed upon and worshipped them.

If such people's relatives had already been born among people or gods on the strength of their own blessings and were already experiencing supremely wonderful bliss, then upon receiving that additional merit, their causes leading to Sagehood will increase, and they will experience limitless bliss.

"If such people are able to behold and worship images of Earth Store Bodhisattva single-mindedly during three weeks, reciting his name a full ten thousand times, the Bodhisattva may then manifest a boundless body and describe to those people the realms into which their relatives have been born. Or in their dreams the Bodhisattva may manifest great spiritual power and personally lead them to those worlds to see their relatives.

"If they can further recite the Bodhisattva's name one thousand times a day every day for one thousand days, the Bodhisattva will send the ghosts and earth spirits in the vicinity of such people to guard and protect them for their entire lives.

In this world their clothing and food will be abundant and they will have no suffering from sickness or other causes. No accidents will occur in their households, much less affect them personally. Finally, the Bodhisattva will rub the crowns of their heads and bestow predictions upon them.

"Moreover, Contemplator of the World's Sounds Bodhisattva, good men or good women in the future may want to practice great compassion in rescuing and taking across beings. They may want to cultivate unsurpassed Bodhi, and may want to leave the Triple World.

Those people may see Earth Store Bodhisattva's image, hear his name, and in their hearts take refuge with him. They may use incense, flowers, clothing, jewels, food and drink to make offerings while beholding and worshipping him. Such good people's wishes will quickly be realized and they will never have any further obstructions.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future, good men and women may want to fulfill hundreds of thousands of millions of vows and to succeed in as many undertakings in both the present and future.

They need only take refuge with, gaze upon, worship, make offerings to, and praise images of Earth Store Bodhisattva. In such a way, their vows and goals can all be realized.

Moreover, they may hope that Earth Store Bodhisattva, being endowed with great compassion, will always protect them. In dreams the Bodhisattva will rub the crowns of their heads and bestow predictions upon them.

"Moreover, Contemplator of the World's Sounds Bodhisattva, good men and women in the future may have high regard for the Great Vehicle Sutras and make the inconceivable resolve to read them and to recite them from memory.

They may then encounter a bright master who instructs them so that they may become familiar with the texts. But as soon as they learn them, they forget them. They may try for months or years and yet still be unable to read or recite them from memory.

Because those good men and good women have karmic obstructions from past lives that have not yet been resolved, they are unable to read and memorize Sutras of the Great Vehicle.

"Upon hearing Earth Store Bodhisattva's name or seeing his image, such people should, with deep respect and honesty, state their situation to the Bodhisattva.

In addition, they should use incense, flowers, clothing, food and drink, and other material objects they enjoy to make offerings to the Bodhisattva.

They should place a bowl of pure water before the Bodhisattva for one day and one night.

Afterwards, placing their palms together, they should state their request and then, while facing south, prepare to drink the water. As the water is about to enter their mouths they should be particularly sincere and solemn.

After drinking the water they should abstain from the five pungent plants, wine, meat, improper sexual activity, false speech, and all killing and harming for one to three weeks.

"In dreams those good men and good women may then see Earth Store Bodhisattva manifesting a boundless body and anointing the crowns of their heads with water.

When they awaken they may be endowed with keen intelligence.

Upon hearing this Sutra but one time, they will eternally remember it and never forget or lose a single sentence or verse.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future there may be people whose food and clothing are insufficient, who find their efforts thwarted, who endure much sickness or misfortune, whose families are not peaceful, whose relatives are scattered, who are accident prone, or who are often startled in their sleep by dreams.

Upon hearing Earth Store's name and seeing his image, such people should recite his name a full ten thousand times with extreme sincerity and respect. Those inauspicious circumstances will gradually disappear, and they will gain peace and happiness. Their food and clothing will be abundant and even in their dreams they will be peaceful and happy.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future, good men or good women may have to enter mountain forests, cross over rivers, seas, or other large bodies of water, or take dangerous routes either for the sake of earning their own livelihood, or for public or personal affairs, or matters of life and death, or other urgent business.

Such people should first recite the name of Earth Store Bodhisattva a full ten thousand times. The ghosts and spirits of the lands they pass through will then guard and protect them in their walking, standing, sitting, and lying down.

The peace and happiness of those people will constantly be preserved, so that even if they encounter tigers, wolves, lions, or any other harmful or poisonous creatures, they will not be harmed."

The Buddha told the Contemplator of the World's Sounds Bodhisattva, "Earth Store Bodhisattva has great affinities with beings in Jambudvipa. Hundreds of thousands of eons would not be time enough to describe the benefits derived by beings who see this Bodhisattva and hear his name.

"Therefore, Contemplator of the World's Sounds Bodhisattva, you should use your spiritual powers to propagate this Sutra, thus enabling beings in the Saha World to receive peace and happiness always, throughout hundreds of thousands of eons."

At that time the World Honored One spoke verses, saying:

I observe that Earth Store's awesome spiritual strength, Could not be fully described even in Ganges sands' eons. Seeing, hearing, beholding and bowing to him even once Benefits people and gods in endless numbers of ways.

Men and women, gods or dragons who are near the end Of their rewards and on the verge of falling into Evil Paths, Can, by sincerely taking refuge with this Great Being, Have their lifespans lengthened; their offenses dissolved.

Sometimes youngsters lose their kind and loving parents And do not know what paths they took. Quite often lost brothers, sisters, and other kin Were never known by their surviving relatives.

If such people sculpt or paint this Bodhisattva's image And then beseech, behold and bow to him intently, And if they hold his name in mind a full three weeks The Bodhisattva may display a boundless body.

He may reveal the realms where relatives were born And even quickly free those in bad destinies. If those praying can sustain their initial resolve, He may rub their heads and predict their Sagehood.

Since those determined to cultivate unsurpassed Bodhi And escape the suffering here in the Triple World, Have already discovered their great compassionate hearts, They should first behold and bow to this Great Being. Then every vow they make will soon be fulfilled And no karmic obstructions will ever hinder or stop them.

Some people may resolve to read the sutra texts Hoping to help those confused to reach the other shore. Although the vows they make are quite remarkable, Try as they may, they cannot remember what they read.

Because of their karmic obstructions and delusions, Those people cannot memorize the Mahayana sutras. But they can offer scents and flowers to Earth Store. They can give him clothing, food, and other things they like.

They can place pure water on an altar to the Bodhisattva, And leave it there a day and night before they drink it. With diligent intent they should abstain from pungent plants, Alcohol, meat, improper sex and false speech.

For three weeks they should not kill or harm any creature, While being mindful of the name of that Great Being. Then suddenly in a dream their vision may become boundless. Awakening, they may discover that they now have keen hearing.

From then on, once they hear the teachings of the sutras, They will never forget them throughout thousands of lives. How inconceivable this Bodhisattva is In helping people like that gain such wisdom!

Beings may be impoverished or plagued with disease, Their homes may be troubled; their relatives scattered. They may find no peace even in sleep or dreams. Their efforts may be thwarted so that nothing goes their way.

But if they earnestly behold and bow to Earth Store's image All those evil situations will simply disappear. And even their dreams will be totally peaceful. Food and clothes will be ample; spirits and ghosts protective.

People may need to enter mountain forests, cross great seas, Or go among venomous or evil birds and beasts, evil people, Evil spirits, evil ghosts, and even evil winds Or put themselves in other distressing situations.

They need only gaze in worship and make offerings To an image of the Great Being, Earth Store Bodhisattva. In response, all the evils in those mountain forests And on those vast seas will simply disappear.

Contemplator of Sounds, listen well to what I say. Earth Store Bodhisattva is an unending wonder! Hundreds of thousands of eons is time too brief To describe fully the powers of this Great Being.

If people can but hear the name "Earth Store," And when seeing his image revere him and bow in worship, And offer incense, flowers, clothing, food, and drink, Those gifts will bring them hundreds of thousands of joys.

If they can dedicate such merit to the Dharma Realm, They will become Buddhas, transcending birth and death. Contemplator of Sounds, know this well, And tell everyone everywhere in lands like Ganges sands."

>> Chapter XIII >>


CHAPTER XIII
The Entrustment of People and Gods

At that time the World Honored One extended his gold-colored arm, and again rubbed the crown of the head of Earth Store Bodhisattva while saying, "Earth Store, Earth Store, your spiritual powers, compassion, wisdom, and eloquence are inconceivable.

Even if all the Buddhas of the Ten Directions were to proclaim their praise of your inconceivable deeds, they could not finish in thousands eons.

"Earth Store, Earth Store, remember this entrustment that I am again making here in the Trayastrimsha Heaven in this great assembly of hundreds of thousands of millions of indescribably many Buddhas, Bodhisattvas, gods, dragons, and the rest of the Eightfold Division.

I again entrust to you the gods, people, and others who are still in the burning house and have not yet left the Triple World.

Do not allow those beings to fall into the evil destinies even for a single day and night, much less fall into the Fivefold Relentless Hell or the Avichi Hell, where they would have to pass through thousands of millions of eons with no chance of escape.

"Earth Store, the beings of southern Jambudvipa have irresolute wills and natures. They habitually do many evil deeds. Even if they resolve to do good, they soon renounce that resolve. If they encounter evil conditions, they tend to become increasingly involved in them.

For those reasons I reduplicate hundreds of thousands of millions of bodies to transform beings, take them across, and liberate them, all in accord with their own fundamental natures.

"Earth Store, I now earnestly entrust the multitudes of gods and people to you.

If in the future among gods and people there are good men or good women who plant a few good roots in the Buddhadharma, be they as few as a strand of hair, a mote of dust, a grain of sand, or a drop of water, then you should use your powers in the Way to protect them so that they gradually cultivate the Unsurpassed Way and do not get lost or retreat from it.

"Moreover, Earth Store, in the future, gods or people, according to the responses of their karmic retributions, may be due to fall into the evil destinies. They may be on the brink of falling or may already be at the very gates to those paths.

But if they can recite the name of one Buddha or Bodhisattva or a single sentence or verse of a Great Vehicle Sutra, then you should use your spiritual powers to rescue them with expedient means.

Display a boundless body in the places where they are, smash the hells, and lead them to be born in the heavens and to experience supremely wonderful bliss."

At that time the World Honored One spoke in verse, saying

I am entrusting to your care the multitudes
Of gods and people both now and in the future.
Use great spiritual powers and expedients to save them.
Do not allow them to fall into the evil destinies.

At that time Earth Store Bodhisattva, Mahasattva, knelt on one knee, placed his palms together, and said to the Buddha, "World Honored One, I beg the World Honored One not to be concerned.

In the future if good men and women have a single thought of respect toward the Buddhadharma, I shall use hundreds of thousands of expedients to take them across and free them. They will quickly be liberated from birth and death.

How much more will that be the case for those who, having heard about all these good matters, are inspired to cultivate. They will naturally become irreversible from the Unsurpassed Way."

After he finished speaking, a Bodhisattva named Empty Space Treasury, who was in the assembly, spoke to the Buddha, "World Honored One, I personally have come to the Trayastrimsha Heaven and have heard the Thus Come One praise Earth Store Bodhisattva's awesome spiritual strength, saying that it is inconceivable.

If in the future, good men, good women, gods, and dragons hear this Sutra and the name of Earth Store Bodhisattva and if they behold and bow to his image, how many kinds of blessings and benefits will they obtain?

Please, World Honored One, say a few words about this for the sake of beings of the present and future."

The Buddha told Empty Space Treasury Bodhisattva, "Listen attentively, listen attentively, I shall enumerate them and describe them to you.

"Good men or women in the future may see images of Earth Store Bodhisattva and hear this Sutra or read or recite it. They may use incense, flowers, food and drink, clothing, and gems to give gifts and make offerings. They may praise, behold and bow to him. Such beings will benefit in twenty-eight ways:

First, they will be protected by gods and dragons.
Second, their good roots will increase daily.
Third, they will amass supreme causes pertaining to Sagehood.
Fourth, they will not retreat from Bodhi.
Fifth, their clothing and food will be abundant.
Sixth, they will never be infected by epidemics.
Seventh, they will never be in disasters of fire and water.
Eighth, they will never be threatened by thieves.
Ninth, they will be respected by all who see them.
Tenth, they will be aided by ghosts and spirits.
Eleventh, women who want to can be reborn as men.
Twelfth, women who want to can be daughters of leaders of nations and officials.
Thirteenth, they will have an upright and proper appearance.
Fourteenth, they will often be born in the heavens.
Fifteenth, they may be emperors or leaders of nations.
Sixteenth, they will have the wisdom to know past lives.
Seventeenth, they will attain whatever they seek.
Eighteenth, their families will be happy.
Nineteenth, they will never undergo any disasters.
Twentieth, they will leave the bad karmic paths forever.
Twenty-first, they will always arrive at their destination.
Twenty-second, their dreams will be peaceful and happy.
Twenty-third, their deceased relatives will leave suffering behind.
Twenty-fourth, they will enjoy blessings earned in previous lives.
Twenty-fifth, they will be praised by sages.
Twenty-sixth, they will be intelligent and have keen faculties.
Twenty-seventh, they will be magnanimous and empathic.
Twenty-eighth, they will ultimately realize Buddhahood.

"Moreover, Empty Space Treasury Bodhisattva, if gods, dragons, or spirits of the present or future hear Earth Store's name, bow to Earth Store's image, or hear of Earth Store's past vows and the events of his practices, and then praise him, behold, and bow to him, they will benefit in seven ways:

First, they will quickly transcend to levels of Sagehood.
Second, their evil karma will dissolve.
Third, all Buddhas will protect and be near them.
Fourth, they will not retreat from Bodhi.
Fifth, their inherent powers will increase.
Sixth, they will know past lives.
Seventh, they will ultimately realize Buddhahood."

At that time, all the indescribable, indescribable, numbers of Buddhas, Thus Come Ones who had come from the Ten Directions, and Great Bodhisattvas, gods, dragons and the rest of the Eightfold Division, having heard Shakyamuni Buddha's praise of Earth Store Bodhisattva's great awesome spiritual powers, praised this unprecedented event.

Following that, incense, flowers, heavenly garments, and pearl necklaces rained down in the Trayastrimsha Heaven as offerings to Shakyamuni Buddha and Earth Store Bodhisattva, and everyone in the assembly joined together in beholding and making obeisance to them. Then they placed their palms together and withdrew.

End of Part Three of
Sutra of the Past Vows of Earth Store Bodhisattva

>> Mantra & Praise >>


The True Words of Seven Buddhas
for Eradicating Offenses

li pe li pe di chyou he chyou he di two la ni di ni he la di

pi li ni di mwo he chye di jen lin chyan di swo pe he (3x)

[Shiddham Sound]

Spirit Mantra For Rebirth in the Pure Land

na mwo e mi dwo pe ye dwo two chye dwo ye dwo di ye two

e mi li du pe pi e mi li dwo syi dan pe pi

e mi li dwo pi jya lan di e mi li dwo pi jya lan di

chye mi li chye chye nwo jr dwo jya li swo pe he (3x)

Mantra for Patching the Flaws in Recitation

Na mo he la da na duo la ye ye qie la qie la ju zhu ju zhu

mo la mo la hu la hong he he su da na hong po mo nu suo po he (3x)

[Shiddham Sound]

Praise

Earth Store's basic vows, and comparative causes of virtue,
Crippling illness, physical defects, come from past lives' deeds.
In this life, those who recite Great Vehicle Sutras,
Bring benefits without end, so that
All will surely be reborn from Jeweled Lotus flowers.
Homage to Earth Store Bodhisattva, Mahasattva (3X)

Earth Store Bodhisattva Praise

Earth Store Bodhisattva, wonderful beyond compare;
Gold-hued in his transformation body he appears;
Wondrous Dharma-sounds throughout the Three Paths and Six Realms;
Four Births and Ten Kinds of Beings gain his kindly grace.
His pearl, shining brightly, lights the way to heaven's halls;
Six-ringed golden staff shakes open wide the gates of hell.
Leads on those with causes garnered life and life again;
To bow at the Nine-flowered Terrace of the Honored One.

Namo Earth Store great vows and compassion,
Bodhisattva of the dark and dismal worlds;
On Nine Flower Mountain, Most Honored One,
With Ten Wheels of power you rescue all the suffering ones.
Homage to Earth Store Bodhisattva (circumbulating and reciting)