Intro Sutra

The Sutra of Innumerable Meanings

“In Forty years and more, the truth has not been revealed yet.”

Chapter I

Virtues

Thus Have I Heard. Once the Buddha was staying at the city of royal palaces on mount Grdhrakuta with a great assemblage of great Bhikkhus, in all twelve thousand. There were eighty thousand Bodhisattva-Mahasattvas. There were gods, dragons, yakshas, gandharvas, asuras, garudas, kimnaras, and mahoragas, besides all the Bhikshus (monks), Bhiksunis (nuns), Upasakas (laymen), and Upasikas (laywomen). There were Great wheel rolling kings, small wheel rolling kings, and kings of the golden wheel, silver wheel, and other wheels; further kings and princes, ministers and people, men and women, and great rich persons, each encompassed by a hundred thousand myriad followers. They went up to the Buddha, made obeisance at his feet, burned incense, and scattered flowers. After they variously worshipped, they retired and sat to one side.

Those Bodhisattvas’ names were Son of the Law-King Manjushri, Son of the Law-King Great Dignity Treasury, Son of the Law-King Great Eloquence Treasury, The Bodhisattva Maitreya, The Bodhisattva Leader, The Bodhisattva Medicine King, The Bodhisattva Medicine Lord, The Bodhisattva Flower Light Banner, The Bodhisattva King Commanding Dharanis At Will, The Bodhisattva Regarder Of The Cries Of The World, The Bodhisattva Great Power Obtained, The Bodhisattva Ever Zealous, The Bodhisattva Precious Stick, The Bodhisattva Above The Triple World, The Bodhisattva Vimabhara, The Bodhisattva Scented Elephant, The Bodhisattva Great Scented Elephant, The Bodhisattva King Of The Lions Roar, The Bodhisattva Lion’s Playing In The World, The Bodhisattva Lion’s Force, The Bodhisattva Lion’s Assiduity, The Bodhisattva Brave Power, The Bodhisattva Lion’s Overbearing, The Bodhisattva Adornment, And The Bodhisattva Great Adornment: such Bodhisattva-Mahasattvas as these, eighty thousand in all.

Of these Bodhisattvas there is none who is not a great saint of the Law Body. They have attained commands, meditations, Wisdom, emancipation, and the knowledge of emancipation. With Tranquil minds and constantly in contemplation they are peaceful, Indifferent, non-active, and free from desires. They are immune from any kind of delusion or distraction. Their minds are calm and clear, profound and infinite. They remain in this state for hundreds of thousands of kotis of kalpas, and all of the innumerable teachings have been revealed to them. Having obtained the great wisdom, they penetrate all things, they completely understand the reality of their nature and form, and clearly discriminate existing and non-existing, long and short.

Moreover, well knowing the capacities, natures, and inclinations of all, with Dharanis and the unhindered power of discourse, they roll the law wheel just as Buddhas do. First, dipping the dust of desire in a drop of the teachings, they remove the fever of the passions of life and realize the serenity of the law by opening the gate of nirvana, and fanning the wind of emancipation. Next, raining the profound law of the twelve causes, they pour it on the violent and intense rays of suffering—ignorance, old age, illness, death and so on; then pouring abundantly the supreme Mahayana, they dip all the good roots of living beings in it, scatter the seeds of goodness over the fields of merits, and make all put forth the sprout of Buddha hood. With their wisdom brilliant as the sun and the moon and their timely tactfulness, they promote the work of the Mahayana and make all accomplish Perfect Enlightenment speedily; and with eternal pleasure wonderful and true, and through infinite compassion, they relieve all from suffering.

These are the true good friends for all living beings, these are the great field of blessings for all living beings, these are the un-summoned teachers for all living beings, and these are the peaceful place of pleasure, relief, protection, and great support for all living beings. They become great good leaders or great leaders for living beings everywhere. They serve as eyes for blind beings, and as ears, nose, or tongue for those who are deaf, who have no nose, or who are dumb; make deficient organs complete; turn the deranged to the great right thought. As the master of a ship or the great master of a ship, they carry all living beings across the river of life and death to the shore of Nirvana. As the king of medicine or the great king of medicine, they discriminate the phases of a disease, know well the properties of medicines, dispense medicines according to the disease, and make people take them. As the controller or the great controller, they have no dissolute conduct; they are like a trainer of elephants and horses who never fails to train well, or like a majestic and brave lion that inevitably subdues and overpowers all beasts.

Bodhisattvas, playing in all the paramitas, being firm and immovable at the stage of Tathágata, and purifying the Buddha-country with the stability of their vow power, will rapidly accomplish Perfect Enlightenment. All these Bodhisattvas-Mahasattvas have such wonderful merit as seen above.

Those Bhikshus names were Great Wisdom Shariputra, Supernatural Power Maudgalyayana, Wisdom Life Subhuti, Maha-Katyayana, Maitrayani’s son Purna, Ajnata-Kaundinya, Divine Eye Aniruddha, Precept Keeping Upali, Attendant Ánanda, Buddha’s son Rahula, Upananda, Revada, Kapphina, Vakkula, Acyuta, Svagata, Dhuta Maha-Kasyapa, Uruvilva-Kasyapa, Gaya-Kasyapa, and Nadi-Kasyapa. There are twelve thousand Bhikshus such as these. All are Arhats, unrestricted by all bonds of faults, free from attachment, and truly emancipated.

At that time the Bodhisattva-Mahasattva Great Adornment, seeing that all the groups sat in settled mind, rose up from his seat, went up to the Buddha with the eighty thousand bodhisattvas-Mahasattvas in the assembly, made obeisance at his feet, a hundred thousand times made procession round him, burned celestial incense, scattered celestial flowers, and presented the Buddha with celestial robes, garlands, and jewels of priceless value which came rolling down from the sky and gathered over all like clouds. The celestial bins and bowls were filled with all sorts of celestial delicacies, which satisfied just by the sight of their color and the smell of their perfume. They placed celestial banners, flags, canopies, and playthings everywhere; pleased the Buddha with celestial music; then went forth to kneel with folded hands, and praised him in verse, saying with one voice and one mind:

“Great! The Great Enlightened, The Great Holy Lord,

In Him there is no defilement, no contamination, no

Attachment.

The Trainer of Gods and men, elephants and horses,

His moral breeze and virtuous fragrance

Deeply permeate all.

Serene is his wisdom, calm his emotion,

And stable his prudence.

His thought is settled, his consciousness extinct,

And thus his mind is quiet.

Long since, he removed false thoughts

And conquered all the laws if existence.

His body is neither existing nor non-existing;

Without cause or condition,

Without self or others;

Neither square nor round,

Neither long nor short;

Without appearance or disappearance,

Without birth or death;

Neither created nor emanating,

Neither made nor produced;

Neither sitting nor lying,

Neither walking nor stopping;

Neither moving nor rolling,

Neither calm nor quiet;

Without advance or retreat,

Without safety or danger;

Without right or wrong,

Without merit or demerit;

Neither that nor this,

Neither going nor coming;

Neither blue nor yellow,

Neither red nor white;

Neither crimson nor purple,

Without a variety of color.

Born of commandments, meditation,

Wisdom, Emancipation, and Knowledge;

Merit of contemplation, the six divine facilities,

And the practice of the way;

Sprung of benevolence and compassion,

The ten powers, and fearlessness;

He has come in response

To good karmas of living beings.

He reveals his body,

Ten feet, six inches in height,

Glittering with purple gold,

Well proportioned, brilliant,

And highly bright.

The mark of hair curls as the moon,

In the nape of the neck there is a light as of the sun.

The curling hair is deep blue,

On the head there is there is a protuberance.

The pure eyes, like a stainless mirror,

Blink up and down.

The eyebrows trail in dark blue,

The mouth and cheeks are well formed.

The lips and tongue appear pleasantly red,

Like a scarlet flower.

The White teeth, forty in number,

Appear as snowy agate.

Broad the forehead, high bridged the nose,

And majestic the face.

The chest, with a swastika mark,

Is like a lion’s breast.

The hands and feet are flexible,

With the mark of a thousand spokes.

The sides and palms are well rounded,

And show in fine lines.

The arms are elongated,

And the fingers are straight and slender.

The skin is delicate and smooth,

And the hair curls to the right.

The ankles and knees are well defined,

And the male organ is hidden

Like that of a horse.

The fine muscles and collarbone,

And the thigh bones are slim

Like those of a deer.

The chest and back are shining,

Pure and without blemish,

Untainted by any muddy water,

Unspotted by any speck of dust.

There are thirty two such signs,

The eighty kinds of excellence are visible,

And truly there is nothing

Of form or non-form.

All visible forms are transcended;

His body is formless and yet has form.

This is also true

Of the form of the body of all living beings.

Living beings adore him joyfully,

Devote their minds to him,

And pay their respects wholeheartedly.

By cutting off arrogance and egotism,

He has accomplished such a wonderful body.

Now we, the assemblage of eighty thousand,

Making obeisance all together,

Submit ourselves to the saint of nonattachment,

The Trainer of Elephants and horses,

Detached from the state of thinking,

Mind, thought, and perception.

We make obeisance,

And submit ourselves to the Law Body,

To all commands, meditation and wisdom,

Emancipation and knowledge.

We make obeisance,

And submit ourselves to the wonderful character.

We make obeisance,

And submit ourselves to the unthinkable.

The sacred voice sounds eight ways,

As the thunder sounds.

It is sweet, pure, and greatly profound.

He preaches the four noble truths,

The six paramitas, the twelve causes,

According to the working of the minds of living beings.

One never hears without opening one’s mind

And breaking the bonds of the infinite chain of life and death.

One never hears without reaching srota-apanna,

Sakrdagamin, Ana gamin, and arhat;

Reaching the state of Pratyekabuddha,

Of non-fault and non condition;

Reaching the state of Bodhisattva,

Of non life and non death;

Of obtaining infinite dharani

And the unhindered power of discourse,

With which ones recites profound and wonderful verses,

Plays and bathes in the pure pond on the law,

Or displays supernatural motion

By jumping and flying up,

Or freely goes in or out of water and fire,

The aspect of the Tathágata ’s Law-wheel is like this.

It is pure, boundless, and unthinkable.

Making obeisance all together,

We submit ourselves to him

When he rolls the Law-wheel.

We make obeisance ,

And submit ourselves to the sacred voice.

We make obeisance,

And submit ourselves to the Causes, Truths, and Paramitas.

For infinite past kalpas,

The World Honored One has practiced

All manner of virtues with effort

To Bring benefits to us human beings,

Heavenly beings, and dragon kings,

Universally to all living beings.

He abandoned all things hard to abandon,

His treasures, wife, and child,

His country, and his palace.

Unsparing of his person and possessions,

He gave all, his head, eyes, and brain,

To people as alms.

Keeping the Buddha’s precepts of purity,

He never did any harm,

Even at the cost of his life.

He never became angry,

Even though beaten with swords and staff,

Or though cursed and abused.

He never became tired,

In spite of long exertion.

He kept his mind at peace both day and night,

And was always in meditation.

Learning all the law ways,

With his deep wisdom

He has seen into the capacity of living beings.

As a result, obtaining free power,

He became the law king,

Who is free in the Law.

Making obeisance again all together,

We submit ourselves to the one who has completed all hard things.”

Chapter II

Preaching

At that time the Bodhisattva-Mahasattva Great Adornment, with the eighty thousand Bodhisattva-Mahasattvas, finished praising the Buddha with this verse and said to the Buddha in unison: “World Honored One, we, the assemblage, of the eighty thousand Bodhisattvas, want to ask you about the Tathágata ’s law.

We are anxious That the World Honored One should hear us with sympathy.”

The Buddha Addressed the Bodhisattva Great Adornment and the eighty thousand Bodhisattvas: “Excellent! Excellent! Good sons, you have well known that this is the time. Ask me what you like. Before long, the Tathágata will enter Parinirvana. After Nirvana, there shall not be a doubt left to anybody. I will answer any question you wish to ask.”

Thereupon the Bodhisattva Great Adornment, with the eighty thousand Bodhisattvas, said to the Buddha in unison, with one voice: “World Honored One! If the Bodhisattva-Mahasattvas want to accomplish perfect enlightenment quickly, what doctrine should they practice? What doctrine makes Bodhisattva-Mahasattvas attain perfect enlightenment quickly?”

The Buddha addressed the Bodhisattva Great Adornment and the eighty thousand Bodhisattvas: “Good Sons, there is one doctrine which makes Bodhisattvas attain perfect enlightenment quickly. If a Bodhisattva learns this doctrine, then he will accomplish perfect enlightenment.”

“World Honored One! What is this doctrine called? What is it’s meaning? How does the Bodhisattva practice it?”

The Buddha said “Good Sons! This one doctrine is called the doctrine of Innumerable Meanings. A Bodhisattva, If he wants to learn and master the doctrine the doctrine of Innumerable Meanings, should observe that all laws were originally, will be, and are in themselves void in nature and form; They are Neither great nor small, Neither appearing nor disappearing, Neither fixed or movable, and neither advancing nor retreating; they are non dualistic, just emptiness. All living beings, however, discriminate falsely: “It is this” or “it is that”, and “It is advantageous” or “It is disadvantageous”; they entertain evil thoughts, make various evil karmas, and thus transmigrate within the six realms of existence; and they suffer all manner of miseries, and cannot escape from there during infinite kotis of kalpas. Bodhisattva-Mahasattvas, observing rightly like this, should raise the mind of compassion, display the great mercy desiring to relieve others of suffering, and once again penetrate deeply into all laws. According to the nature of a law, such al law settles. According to the nature of a law, such a laws changes. According to the nature of a law, such a law vanishes. According to the nature of a law, such an evil law emerges. According to the nature of a law, such a good law appears. Settling, changing, and vanishing are also like this. Bodhisattvas, having completely observed and known these four aspects from beginning to end, should next observe that none of the laws settle down for even a moment, but all emerge and vanish anew every moment; and observe that they emerge, settle, change, and vanish instantly. After such observation, we see all manner of natural desires of living beings. As natural desires are innumerable, preaching is innumerable, and as preaching is innumerable, meanings are innumerable. The Innumerable Meanings originate from one law. This one law is, namely, non form. Such non form is formless, and not form. Being not form, and formless, it is called the real aspect of things. The mercy which Bodhisattva-Mahasattvas display after stabilizing themselves in such a real aspect is real, and not vain. They excellently relieve living beings from sufferings. Having given relieve from suffering they preach the law again, and let all living beings obtain pleasure.

“Good Sons! A Bodhisattva, if he practices completely the doctrine of Innumerable Meanings like this, will soon accomplish Perfect Enlightenment without fail. Good sons! The Sutra of Innumerable Meanings, such a profound and supreme Great-vehicle, is reasonable in its logic, unsurpassed in its worth, and protected by all the Buddhas of the three worlds. No kind of demon or heretic can break into it, nor can any wrong view of life and death destroy it . Therefore, good sons! Bodhisattva-Mahasattvas, if you want to accomplish supreme Buddha hood quickly, you should learn and master the Sutra of Innumerable Meanings, such a profound and supreme great vehicle.

“At that time the Bodhisattva Great Adornment said to the Buddha again: World-honored one! The preaching of the World-honored one is incomprehensible, the natures of living beings are also incomprehensible, and the doctrine of emancipation is also incomprehensible. Though we have no doubt about the laws preached by the Buddha, we repeatedly ask the World-honored one for fear that all living beings should be perplexed. For more then forty years since the Tathágata attained enlightenment, you have continuously preached all the laws to living beings—the four aspects, suffering, void ness, transience, selflessness, non-large, non-small, non-birth, non-death, one aspect, no-aspect, the nature of the law, the form of the law, void from the beginning, non-coming, non-going, non-appearance, and non-disappearance. Those who have heard it have obtained the law of warming, the law of the highest, the law of the best in the world (The law of warming, highest, and best in the world are three stages passed through by disciples not yet free of desire when they try to understand the Four Noble Truths.), the merit of srota-apanna, the merit of Sakrdagamin, the merit of Ana gamin, the merit of arhat, and the way of Pratyekabuddha; have aspired to enlightenment; and ascending the first stage, the second stage, and the third stage, have attained the tenth stage. Because of what difference between your past and present preaching on laws do you say that if a bodhisattva practices only the Sutra of Innumerable Meanings, a profound and Great-vehicle, he will soon accomplish supreme Buddha hood without fail? World-honored one! Be pleased to discriminate the Law widely for living beings out of compassion for all, and to leave no doubt to all Law-hearers in the present and future.

“Hereupon the Buddha said to the Bodhisattva Great Adornment: Excellent! Excellent! Great good sons, you have well questioned the Tathágata about such a wonderful meaning of the profound and supreme Great-vehicle. Do you know that you will bring many benefits, please men and gods, and relieve living beings from sufferings. It is truly the great benevolence, and the truth without falsehood. For this reason you will surely and quickly accomplish supreme Buddha hood. You will also make all living beings in the present and future accomplish supreme Buddha hood.

“Good Sons! After six years right sitting under the Bodhi tree of the wisdom throne, I could accomplish Perfect Enlightenment. With the Buddha’s eye I saw all the laws and understood that they were inexpressible. Wherefore? I knew that the natures of all living beings were not equal. As their natures and desires were not equal, I preached the law variously. It was with tactful power that I preached the law variously. In forty years and more, the truth has not been revealed yet. Therefore living beings’ powers of attainment are too different to accomplish supreme Buddha hood quickly.

“Good sons! The law is like water that washes off dirt. As a well, a pond, a stream, a river, a valley stream, a ditch, or a great sea each alike effectively washes off all kinds of dirt, so the law-water effectively washes off the dirt of all delusions of living beings.

“Good sons! The nature of water is one, but a stream, a river, a well, a pond, a valley stream, a ditch, and a great sea are different from one another. The nature of the law is like this. There is equality and no differentiation in washing off the dirt of delusions, but the three laws, the four merits, the and the two ways are not one and the same.

“Good Sons! Though each washes equally as water, a well is not a pond, a pond is not a stream or a river, nor is a valley stream or ditch a sea. As the Tathágata, the worlds hero, is free in the law, all the laws preached by him are also like this. Though preaching at the beginning, the middle, and the end all alike, effectively wash off the delusions of living beings, the beginning is not the middle, and the middle is not the end. Preaching at the beginning, in the middle, and at the end are the same in expression, but different in one another in meaning.

“Good Sons!” When I rolled the law wheel of the four noble truths for the five men, Ajnata-Kaundinya and the others, at the deer park in Varanasi after leaving the king of trees, I preached that the laws are naturally vacant, ceaselessly transformed, and instantly born and destroyed. When I discoursed explaining the twelve causes and the six paramitas for all the Bhikshus and Bodhisattvas in various places during the middle period, I preached also that all laws are naturally vacant, ceaselessly transformed, and instantly born and destroyed. Now in explaining the Sutra of Innumerable Meanings, a Great Vehicle, at the this time, I preach also that all laws are naturally vacant, ceaselessly transformed, and instantly born and destroyed. Good Sons! Therefore the preaching at the beginning, in the middle, and at the end are the same in expression but different from one another in meaning. As the meaning varies, the understanding of living beings varies. As the understanding varies, the attainment of the law, the merit, and the way also varies.

“Good sons! At the beginning, though I preached the Four Truths for those who sought to be Sravakas, eight Kotis of heavenly beings came down to hear the law and raised the desire for enlightenment. In the middle, though I preached in various places, the profound Twelve Causes, for those who sought to be Pratyekabuddha, Innumerable living beings raised the aspiration for enlightenment, or, remained in the stage of Sravaka. Next, although I explained the long term practice of Bodhisattvas (Religious exercises extending over billions of years), through preaching the twelve types of sutras of Great Extent, The Maha-Prajna, and the void ness of the Garland Sea, a hundred thousand Bhikshus, Myriad Kotis of men and gods, and innumerable living beings could remain in the merits of Srota-apanna, Sakrdagamin, Ana Gamin, and Arhat, or in the law appropriate to the Pratyekabuddha. Good Sons! For this reason, it is known that the preaching is the same, but the meaning varies, as the meaning varies, the understanding of living beings varies. As the understanding varies, the attainment of the law, merit, and the way also varies. So Good Sons! Since I attained the way, and stood to preach the law for the first time, till I spoke the Sutra Of Innumerable Meanings, The Great-vehicle, today, I have never ceased from preaching suffering, void ness, transience, selflessness, non truth, non reality, non large, non small, non birth and origin and also non death at present, one aspect, non aspect, the form of the law, the nature of the law, non coming, non going, and the four aspects by which all the living are driven.

“Good Sons! For this reason, all the Buddhas, without a double tongue, answer widely all voices with one word, though having one body, reveal bodies innumerable, and numberless as the sands of the Ganges of a hundred thousand myriad Kotis Nayutas; in each body, display various forms, countless as the sands of some hundred thousand myriad kotis nayutas asamkhyeya Ganges, and in each form show shapes countless as the sands of some hundred thousand myriad kotis nayutas asamkhyeya Ganges. Good Son! This is, namely, the incomprehensible and profound world of Buddhas. Men of the two vehicles cannot apprehend it, and even Bodhisattvas of the Ten stages cannot attain it. Only a Buddha, together with a Buddha can fathom it well.

“Good Sons! Thereupon I say: The Sutra Of Innumerable meanings, the wonderful, profound, and supreme Great vehicle, is reasonable in it’s logic, unsurpassed in it’s worth, and protected by all the Buddhas of the three worlds. No kind of demon or heretic can break into it, nor can any wrong view of life or death destroy it. Bodhisattva-Mahasattvas, if you want to accomplish supreme Buddha hood quickly, you should learn and master the Sutra of Innumerable Meanings, such a profound and supreme Great-vehicle.

“After the Buddha had finished explaining this, the three-thousand-great-thousand fold world was shaken in the six ways; various kinds of celestial flowers, such as utpala, padma, kumuda, and pundarika, rained down naturally from the sky; and innumerable kinds of celestial perfumes, robes, garlands, and treasures of priceless value also rained and came rolling down from the sky, and they were offered to the Buddha, all the Bodhisattvas and Sravakas, and the great assembly. So, too, was it in the southern, western, and northern quarters, in the four intermediate directions, in the zenith and the nadir.

“At this time thirty two thousand Bodhisattva-mahasattvas in the assembly attained to the contemplation of the innumerable meaning. Thirty four thousand Bodhisattva-Mahasattvas obtained the numberless and infinite realms of dharani and came to roll the never retrogressing law wheel of Buddhas all over the three worlds. All the Bhikshus and Bhiksunis, Upasakas, Upasikas, gods, dragons, yakshas, gandharvas, asuras, garudas, kimnaras, mahoragas, great wheel rolling kings, small wheel rolling kings, kings of the silver wheel, iron wheel, and other wheels, kings and princes, ministers and people, men and women, and great rich persons, and all the groups of a hundred thousand followers, hearing together, the Buddha, Tathágata preaching this sutra, obtained the law of warming, the law of the highest, the law of the best in the world, the merit of srota-apanna, the merit of Sakrdagamin, the merit of Ana gamin, the merit of Arhat, and the merit of Pratyekabuddha; attained to the Bodhisattvas assurance of the law of no birth; acquired one Dharani, two Dharanis, three Dharanis, four Dharanis, five, six, seven, eight, nine, ten Dharanis, a hundred thousand myriad kotis of Dharanis, and asamkhyeya Dharanis as innumerable as the sands of the Ganges; and all came to roll the never retrogressing law wheel rightly. Infinite living beings gained the aspiration to perfect enlightenment.

Chapter III

Ten Merits

AT THAT TIME the Bodhisattva-Mahasattva Great Adornment said to the Buddha again: “World Honored One! The World Honored One has preached this sutra of Innumerable Meanings, a wonderful, profound, and supreme Great Vehicle. It is truly profound. Wherefore? In this assembly, all the Bodhisattva-Mahasattvas, all the four groups, gods, dragons, demons, kings, subjects, and all the living beings, hearing this Sutra Of Innumerable Meanings, a profound and supreme great vehicle, never fail to obtain the realm of Dharanis, the three laws, the four merits, and the aspiration to enlightenment. It should be known that this law is reasonable in it’s logic, unsurpassed in it’s worth, and protected by all the Buddhas of the three worlds. No kind of demon or heretic break into it, nor an any wrong view of life and death destroy it. Wherefore? Because hearing it but once is keeping all the laws.

“If a living being can hear this sutra, he will acquire a great benefit. Wherefore? If he practices it sincerely, he will quickly accomplish supreme Buddha hood without fail. If a living being cannot hear it should be known that he loses a great benefit. He will never accomplish supreme Buddha hood even a after a lapse of infinite boundless, inconceivable asamkhyeya kalpas. Wherefore? Because he does not know the great way to enlightenment, he meets with many sufferings in walking steep ways.

“World Honored One! This sutra is inconceivable. World Honored One! Be pleased to explain the profound and inconceivable matter of this sutra out of benevolence for all the people. World Honored One! From What Place does this sutra come? From what place does it leave? At what place does it stay? Whereupon does this sutra make people quickly accomplish perfect enlightenment, having such infinite merits and inconceivable powers?

“At that time the World Honored One Addressed the Bodhisattva-Mahasattva Great Adornment: Excellent! Excellent! Good Sons; Just So, Just So, Just as you say. Good Sons! I preach this sutra as profound, profound, and truly profound. Wherefore? Because it makes people quickly accomplish supreme Buddha Hood; hearing it but once is keeping all the laws; it greatly benefits all the living; There is no suffering practicing the great direct way. Good Sons! You ask where this sutra comes from, where it leaves for, and where it stays. Do listen attentively. Good Sons! This sutra originally comes from the abode of all the Buddhas, leaves for the aspiration of all the living, and stays at the place where all the Bodhisattvas practice. Good Sons! This sutra comes like this, leaves like this, and stays like this. Therefore this sutra, having such infinite merits and inconceivable power, makes people quickly accomplish supreme Buddha hood.

“Good Sons! Do you want to hear how this sutra has ten inconceivable merit powers? The Bodhisattva Great Adornment Said: “we heartily want to hear. And the Buddha said: Good Sons! First, this sutra makes the un-awakened Bodhisattva aspire to Buddha hood, makes a merciless one raise the mind of mercy, Makes a homicidal one raise the mind of great compassion, makes a jealous one raise the mind of joy, makes an attached one raise the mind of detachment, makes a miserly one raise the mind of donation, makes an arrogant one raise the mind of keeping the commandments, makes an irascible one raise the mind of perseverance, makes an indolent one raise the mind of assiduity, makes a distracted one raise the mind of meditation, makes an ignorant one raise the mind of wisdom, makes one who lacks concern for saving others raise the mind of saving others, makes one who commits the ten evils raise the mind of the ten virtues, makes one who wishes for existence aspire to the mind of non existence, makes one who has an inclination toward apostasy build the mind of non retrogression, makes one who commits defiled acts raise the mind of un defilement, and makes one who suffers from delusions raise the mind of detachment. Good Sons! This is called the first inconceivable merit power of this sutra.

“Good Sons! Secondly the inconceivable merit power of this sutra is as follows: If a living being can hear this sutra but once, or only one verse and phrase, he will penetrate into a hundred thousand kotis of meanings, and the law kept by him cannot be explained fully even in infinite kalpas. Wherefore? It is because this sutra has innumerable meanings.

“Good Sons! Suppose that from one seed, a hundred thousand myriad seeds grow, from each of a hundred thousand myriad seeds, another hundred thousand myriad seeds grow, and in such a process seeds increase to an unlimited extent. This sutra is like this. From one law a hundred thousand meanings grow, from each of a hundred thousand meanings, a hundred thousand myriad meanings grow, and in such a process meanings increase to an unlimited and boundless extent. Such being the case, this sutra is called innumerable meanings. Good Sons This is the second inconceivable merit power of this sutra.

“Good Sons! Thirdly, the inconceivable merit power of this sutra is as follows: If a living being can hear this sutra but once, or only one verse and phrase, he will penetrate into a hundred thousand myriad kotis of meanings. After that, his delusions, even though existent, will become as if non existent; he will not be seized with fear, though he moves between birth and death; he will raise the mind of compassion for all of the living, and obtain the spirit of bravery to obey all the laws. A powerful wrestler can shoulder and hold any heavy thing. The keeper of this sutra is also like this. He can shoulder the heavy treasure of supreme Buddha hood, and carry living beings on his back out of the way of birth and death. He will be able to relieve others, even though he can not yet relieve himself. Just as a ferry master though he stays on this shore owing to his serious illness and unsettled body, can be made to cross over by means of a good and solid ship that has the quality of carrying anyone without fail, so also is it with the keeper of this sutra. Although he stays on this shore of ignorance, old age and death, owing to the hundred and eight kinds of serious illness (the one hundred and eight illusions, or obstacles to enlightenment), with which his body under the existence of all the five states is seized and ever afflicted, he can deliver from birth and death this strong Mahayana Sutra of Innumerable Meanings as it is preached, which realizes the deliverance of living beings. Good Sons! This is called the third inconceivable merit power of this sutra.

“Good Sons! Fourthly the inconceivable merit power of this sutra is as follows: if a living being can hear this sutra but once, only one verse and phrase, he will obtain the spirit of bravery, and relieve others, even though he cannot yet relieve himself. He will become the attendant of the Buddhas together with all of the Bodhisattvas, and all the Buddha-Tathágatas will always preach the law to him. On hearing it, he will keep the law entirely and follow it without disobeying. Moreover, he will interpret it for people extensively as occasion calls.

“Good Sons! Suppose that a new prince is born of a king and queen. A day, two days, or seven days, and a month, two months, or seven months passing away, he attain the age of one, two, or seven. Although he cannot yet manage national affairs, he will come to be revered by people and take all the great kings sons into his company. The King And Queen will always stay and converse with him, with special and deep affection because he is their little child. Good Sons! The keeper of this sutra is also like this. The King--The Buddha-- and the queen--this sutra--come together, and this son--a Bodhisattva-- is born of them. If the Bodhisattva can hear one phrase or verse of this sutra once, twice, ten times, a hundred times, a thousand time, myriad times, myriad kotis of time, or innumerable and numberless times like the sands of the Ganges, he will come to shake the Three-Thousand Great Thousand fold world, though he can not yet realize the Ultimate Truth, and will take all great Bodhisattvas into his attendance, while being admired by all of the four classes and eight guardians, though he can not yet roll the great law wheel, with the sacred voice like the roll of thunder. Entering deeply into the secret law of the Buddhas, he will interpret it without error or fault. He will always be protected by all of the Buddhas, and especially covered with affection, because he is a beginner in learning. Good Sons! This is called the fourth inconceivable merit power of this sutra.

“Good Sons! Fifthly, the inconceivable merit power of this sutra is as follows: If good sons or good daughters keep, read, and recite and copy the Sutra Of Innumerable Meanings, such a profound and supreme great vehicle, either during the Buddhas lifetime or after his extinction, they will realize the way of great Bodhisattvas though they cannot yet be delivered from all the faults of an ordinary man, and are still wrapped in delusions. They will fill with joy and convince those living beings, extending a day to a hundred Kalpas, or shortening a hundred Kalpas to a day. Good Sons! These good sons or good daughters are just like a dragon’s son who can raise clouds and cause a rainfall seven days after his birth. Good Sons! This is called the fifth inconceivable merit power of this sutra.

“Good Sons! Sixthly, the inconceivable merit power of this sutra is as follows: if good sons or good daughters keep, read, and recite this sutra either during the Buddhas lifetime, or after his extinction, even though clothed in delusions, they will deliver living beings from the life and death of delusions, and make them overcome all sufferings, by preaching the law for them. After hearing it, living beings will put it into practice, and attain the law, the merit, and the way, where there will be equality, and no difference from the Buddha Tathágata. Suppose that a king, in journeying, or falling ill, leaves the management of national affairs to his prince, though he is an infant. Then the prince, by order of the great king, leads all of the government officials according to the law, and propagates the right policy, so that every citizen of the country follows his orders exactly as if the king were governing. It is the same with good sons or good daughters keeping this sutra. During the Buddhas lifetime, or after his extinction, these good sons will propagate the doctrine, preaching exactly as the Buddha did, though they themselves cannot live in the first stage of immobility, and if living beings, after hearing their preaching, practice it intently, they will cut off delusions, and attain the law, the merit, and the way. Good Sons! This is called the sixth inconceivable merit power of this sutra.

“Good Sons! Seventhly, the inconceivable merit power of this sutra is as follows: If good sons or good daughters, hearing this sutra either during the Buddhas lifetime or after his extinction, rejoice, believe, and raise the rare mind; keep, read, recite, copy, and expound it; practice it as it has been preached; aspire to Buddha hood; cause all the good roots to sprout; raise the mind of great compassion; and want to relieve all living beings of sufferings, the six paramitas will be naturally present in them, though they cannot yet practice the six paramitas. They will attain the assurance of the law of no birth in their bodies; life and death, and delusions will be instantly destroyed; and they will rise to the seventh stage of Bodhisattva.

“Suppose there is a vigorous man who tries to destroy an enemy on behalf of his king, and after the enemy has been destroyed, with great joy, the king gives him half the kingdom as a prize. Good Sons or Good Daughters who keep this sutra are like this. They are the most vigorous of all ascetics. They come to attain the law treasure of the six paramitas, even though they are not consciously seeking it. The enemy of death and life will be naturally destroyed, and they will be made comfortable by the prize of a fief, realizing the assurance of no birth as the treasure of half the Buddha-country. Good Sons! This is called the seventh inconceivable merit power of this sutra.

“Good Sons! Eighthly the inconceivable merit power of this sutra is as follows: If good sons or good daughters, either during the Buddhas lifetime, or after his extinction, see someone who has received this sutra, they will make him revere and believe it exactly as if he saw the body of the Buddha; they will keep, read, recite, copy and worship this sutra with joy; serve and practice it as the law; firmly keep the commandments and perseverance; they will also practice almsgiving; raise a deep benevolence; and explain the sutra of Innumerable Meanings, this supreme great vehicle, widely to others. To one who for a long time does not at all recognize the existence of sinfulness and blessedness, they will show this sutra, and force him to have faith in it with all sorts of expedients. By the strong power of the sutra, he will be made to stir up faith and to convert suddenly. After stirring up faith, he will endeavor so valorously that he can acquire the virtue and power of this sutra, and attain the way and the merit. In this way, these good sons or good daughters will attain they assurance of the law of no birth in their bodies of men or women by the merit of having been enlightened, reach the upper stage, become the attendants of the Buddhas, together with all the Bodhisattvas convert living beings, quickly, purify Buddha lands, and attain supreme Buddha hood before long. Good Sons! This is called the eight inconceivable merit power of this sutra.

“Good Sons! Ninthly, the inconceivable merit power of this sutra is as follows: If good sons or good daughters, receiving this sutra either during the Buddhas lifetime or after his extinction, leap for joy; acquire the unprecedented; keep, read, recite, copy, and adore this sutra; and explain it’s meaning discriminately and widely for living beings, they will instantly destroy the heavy barrier of sins resulting from previous karma and become purified, acquire great eloquence, gradually realize all paramitas, accomplish all Samádhis and Shurangama-samádhi, enter the great gate of dharani and rise up to the upper stage quickly with strenuous efforts. They will spread their divided bodies in all of the lands of ten directions, and relieve and emancipate entirely all living beings who suffer greatly in the twenty five abodes. Thus such a power can be seen in this sutra. Good Sons, This is called the ninth inconceivable merit power of this sutra.

“Good Sons! Tenthly, the inconceivable merit power of this sutra is as follows: if good sons or good daughters, receiving this sutra either during the Buddhas lifetime or after his extinction, greatly rejoice; raise the rare mind; keep, read, recite, copy, adore, and expound this sutra, and practice it as the law, these good sons or good daughters will obtain the innumerable realms of Dharani in their bodies because it is wholly by the merciful and friendly instruction of these good sons or good daughters that other people obtain the way and the merit through the power of the practice of this sutra. They will make vast oaths and great vows of numberless asamkhyeya naturally and from the beginning in the stage of ordinary men, and raise a deep desire to relieve all living beings. They will realize the great compassion, thoroughly abolish all sufferings, gather many good roots, and bring benefit to all. They will explain the flavor of the law, and greatly enliven the withered; give all living beings the medicine of the law and set all at ease; gradually elevate their view, to live in the stage of the Law-Cloud (The stage of the Law-Cloud is the tenth and highest stage of the Bodhisattva-Way). They will spread favor extensively, grant mercy to all suffering living beings, and lead them to the Buddha way. Thereupon these persons (Good sons and daughters) will accomplish Perfect Enlightenment before long. Good Sons! This is called the tenth inconceivable merit power of this sutra.

Good sons! The sutra of innumerable meanings, such a supreme Great-Vehicle, has an extremely great divine power and is unsurpassed in it’s worth. It makes all ordinary men accomplish the sacred merit, and makes them free from life and death forever. Thereupon this sutra is called Innumerable Meanings. It makes all the living sprout the innumerable ways of all the Bodhisattvas in the stage of ordinary men, and makes the tree of merit grow dense, thick, and tall. Therefore this sutra is called inconceivable merit power.

At that time the Bodhisattva-Mahasattva Great Adornment, with the eighty thousand Bodhisattva-Mahasattvas, said to the Buddha with one voice: “World Honored One! The Sutra of Innumerable Meanings, Such a profound, Wonderful, and supreme great vehicle preached by the Buddha, is reasonable in it’s logic, unsurpassed in it’s worth and protected by all the Buddhas of the three worlds. No kind of demon or heretic can break into it, nor can any wrong view of life or death destroy it. Thereupon this sutra has ten such inconceivable merit powers. It greatly benefits innumerable living beings, makes all Bodhisattva-Mahasattvas attain the contemplation of innumerable meanings, a hundred thousand realms of Dharani, all the stages and assurances of Bodhisattva, and the accomplishments of the four way merits of Pratyekabuddha and arhat. The World Honored One has preached such a law willingly for us in compassion, and made us attain the benefits of the law abundantly. This is immensely marvelous and unprecedented. It is difficult to repay the merciful favor of the World Honored One.

At the close of these words, the three thousand, Great thousand fold world was shaken in the six ways; various kinds of celestial flowers, such as utpala, padma, kumuda, and Pundarika rained down from the sky; and numberless kinds of celestial perfumes, robes, garlands, and treasures of priceless value also rained and came rolling down from the sky, and they were offered to the Buddha, all the Bodhisattvas and Sravakas, and the great assembly. The celestial bins and bowls were filled with all manner of celestial delicacies, which gave satisfaction naturally to anyone who just saw them and smelled their perfume. The celestial banners, flags, canopies, and playthings, were placed everywhere, and celestial music was played in praise of the Buddha.

Also the Buddha worlds, as numerous as the sands of the Ganges, in the east were shaken in the six ways; celestial flowers, perfumes, robes, garlands, and treasures of priceless value rained down; the celestial bins and bowls, and all sorts of celestial delicacies gave satisfaction to anyone who just saw them and smelled their perfume. The celestial banners, flags, canopies, and playthings were placed everywhere, and celestial music was played in praise of those Buddhas, those Bodhisattvas and Sravakas, and the great assembly. So, too, was it in the southern, western, and northern quarters, in the four intermediate directions, and in the Zenith, and Nadir.

At that time the Buddha addressed the Bodhisattva-Mahasattva Great Adornment and the eighty thousand Bodhisattva-Mahasattvas: You should entertain a deep respect for this sutra, practice it as the law, instruct all widely, and propagate it earnestly. You should protect it heartily day and night, and make all living beings attain the benefits of the law. This is truly great mercy, and great compassion, so, offering the divine power of a vow, you should protect this sutra and not let anybody put obstacles in its way. Then you should have it practiced widely in Jambudvipa, and make all the living observe, read, recite, copy, and adore it without fail. Because of this you will be made to attain perfect enlightenment rapidly.

At that time the Bodhisattva-Mahasattva Great Adornment rose up from his seat, went up to the Buddha with the eighty thousand Bodhisattva-Mahasattvas, made obeisance at his feet, a hundred thousand times made procession around him, and then going forth to kneel, said to the Buddha with one voice: World Honored One! We have been placed under the mercy of the World Honored One to our delight. The sutra of Innumerable Meanings, This profound, wonderful, and supreme great vehicle, has been preached for us. We will widely propagate this sutra after the Tathágatas extinction in obedience to the Buddhas command, and let all keep, read, recite, copy, and adore it. Be pleased to have no anxiety! With the vow-power, we will let all the living observe, read, recite, copy, and adore this sutra, and acquire the marvelous merit of this sutra.

At that time the Buddha said in praise: Excellent! Excellent! All good sons; you are really and truly the Buddhas sons. You are persons who abolish sufferings and remove calamities thoroughly with great mercy and great compassion. You are the good field of blessings for all living beings. You have been the great good leaders extensively for all. You are the great support for all living beings. You are the great benefactors of all living beings. Always bestow the benefits of the law extensively on all. At that time all in the great assembly, greatly rejoicing together, made salutation to the Buddha and, taking possession of the sutra, withdrew.