The Vajracchedika Prajnaparamita Sutra

(This is a mirror page of http://www.plumvillage.org/DharmaDoors/Sutras/chantingbook/Diamond_Sutra.htm)

The Vajracchedika Prajnaparamita Sutra

1

This is what I heard one time when the Buddha was staying in the monastery in Anathapindika's park in the Jeta Grove near Sravasti with a community of 1,250 bhiksus, fully ordained monks.

That day, when it was time to make the round for alms, the Buddha put on his sanghati robe and, holding his bowl, went into the city of Sravasti to seek alms food, going from house to house. When the alms round was completed, he returned to the monastery to eat the midday meal. Then he put away his sanghati robe and his bowl, washed his feet, arranged his cushion, and sat down.

2

At that time, the Venerable Subhuti stood up, bared his right shoulder, put his knee on the ground, and, folding his palms respectfully, said to the Buddha, "World-Honored One, it is rare to find someone like you. You always support and show special confidence in the bodhisattvas.

"World-Honored One, if sons and daughters of good families want to give rise to the highest, most fulfilled, awakened mind, what should they rely on and what should they do to master their thinking?"

The Buddha replied, "Well said, Subhuti! What you have said is absolutely correct. The Tathagata always supports and shows special confidence in the bodhisattvas. Please listen

with all of your attention and the Tathagata will respond to your question. If daughters and sons of good families want to give rise to the highest, most fulfilled, awakened mind, they should rely on the following way."

The Venerable Subhuti said, "Lord, we are so happy to hear your teachings."

3

The Buddha said to Subhuti, "This is how the bodhisattva mahasattvas rnaster their thinking. 'However many species of living beings there are--whether born from eggs, from the womb, from moisture, or spontaneously; whether they have form or do not have form; whether they have perceptions or do not have perceptions; or whether it cannot be said of them that they have perceptions or that they do not have perceptions, we must lead all these beings to the ultimate nirvana so that they can be liberated. And when this innumerable, immeasurable, infinite number of beings has become liberated, we do not, in truth, think that a single being has been liberated,'

"Why is this so? If, Subhuti, a bodhisattva holds on to the idea that a self, a person, a living being, or a life span exists, that person is not an authentic bodhisattva."

4

"Moreover, Subhuti, when a bodhisattva practices generosity, he does not rely on any object--that is to say he does not rely on any form, sound, smell, taste, tactile object, or dharma--to practice generosity. That, Subhuti, is the spirit in which a bodhisattva should practice generosity, not relying on signs. Why? If a bodhisattva practices generosity without relying on signs, the happiness that results cannot be conceived of or measured. Subhuti, do you think that the space in the Eastern Quarter can be measured?"

"No, World-Honored One."

"Subhuti, can space in the Western, Southern, and Northern Quarters, above and below be measured?"

"No, World-Honored One."

"Subhuti, if a bodhisattva does not rely on any concept when practicing generosity, then the happiness that results from that virtuous act is as great as space. It cannot be measured. Subhuti, the bodhisattvas should let their minds dwell in the teachings I have just given."

5

"What do you think, Subhuti? Is it possible to grasp the Tathagata by means of bodily signs?"

"No, World-Honored One. When the Tathagata speaks of bodily signs, there are no signs being talked about."

The Buddha said to Subhuti: "In a place where there is something that can be distinguished by signs, in that place there is deception. If you can see the signless nature of signs, then you can see the Tathagata."

6

The Venerable Subhuti said to the Buddha, "In times to come, will there be people who, when they hear these teachings, have real faith and confidence in them?"

The Buddha replied, "Do not speak that way, Subhuti. Five hundred years after the Tathagata has passed away, there will still be people who enjoy the happiness that comes from

observing the precepts. When such people hear these words, they will have faith and confidence that here is the truth. We should know that such people have sown seeds not only during the lifetime of one Buddha, or even two, three, four, or five Buddhas, but have, in truth, planted wholesome seeds during the lifetimes of tens of thousands of Buddhas. Anyone who, for only a second, gives rise to a pure and clear confidence upon hearing these words of the Tathagata, the Tathagata sees and knows that person, and he or she will attain immeasurable happiness because of this understanding. Why?

"Because that kind of person is not caught up in the idea of a self, a person, a living being, or a life span. They are not caught up in the idea of a dharma or the idea of a non-dharma. They are not caught up in the notion that this is a sign and that is not a sign. Why? If you are caught up in the idea of a dharma, you are also caught up in the ideas of a self, a person, a living being, and a life span. If you are caught up in the idea that there is no dharma, you are still caught up in the ideas of a self, a person, a living being, and a life span. That is why we should not get caught up in dharmas or in the idea that dharmas do not exist. This is the hidden meaning when the Tathagata says,'Bhiksus, you should know that all of the teachings I give to you are a raft.?All teachings must be abandoned, not to mention non-teachings."

7

"What do you think, Subhuti, has the Tathagata arrived at the highest, most fulfilled, awakened mind? Does the Tathagata give any teaching?"

The Venerable Subhuti replied, "As far as I have understood the Lord Buddha's teachings, there is no independently existing object of mind called the highest, most fulfilled, awakened mind, nor is there any independently existing teaching that the Tathagata gives. Why? The teachings that the Tathagata has realized and spoken of cannot be conceived of as separate, independent existences and therefore cannot be described. The Tathagata's teaching is not self-existent nor is it non-self-existent. Why? Because the noble teachers are only distinguished from others in terms of the unconditioned."

8

"What do you think, Subhuti? If someone were to fill the 3,000 chiliocosms with the seven precious treasures as an act of generosity, would that person bring much happiness by this virtuous act?"

The Venerable Subhuti replied, "Yes, World-Honored One. It is because the very natures of virtue and happiness are not virtue and happiness that the Tathagata is able to speak about virtue and happiness."

The Buddha said, "On the other hand, if there is someone who accepts these teachings and puts them into practice, even if only a gatha of four lines, and explains them to someone else, the happiness brought about by this virtuous act far exceeds the happiness brought about by giving the seven precious treasures. Why? Because, Subhuti, all Buddhas and the dharma of the highest, most fulfilled, awakened mind of all Buddhas arise from these teachings. Subhuti, what is called Buddhadharma is everything that is not Buddhadharma."

9

"What do you think, Subhuti? Does a Stream-Enterer think, 'I have attained the fruit of stream-entry.'?"

Subhuti replied, "No, World-Honored One. Why? Stream-Enterer means to enter the stream, but in fact there is no stream to enter. One does not enter a stream that is form, nor a stream that is sound, smell, taste, touch, or object of mind. That is what we mean when we say entering a stream."

"What do you think, Subhuti? Does a Once-Returner think, 'I have attained the fruit of Once-Returning.'?"

Subhuti replied, "No, World-Honored One. Why? Once-Returner means to go and return once more, but in truth there is no going just as there is no returning. That is what we mean when we say Once-Returner."

"What do you think, Subhuti? Does a Non-Returner think like this,'l have attained the fruit of No-Return.'?"

Subhuti replied,"No, World-Honored One. Why? No-Return means not to return to this world, but in fact there cannot be any Non-Returning. That is what we mean when we say Non-Returner."

"What do you think, Subhuti? Does an Arhat think like this, 'I have attained the fruit of Arhatship?"

Subhuti replied, "No, World-Honored One. Why? There is no separately existing thing that can be called Arhat. If an Arhat gives rise to the thought that he has attained the fruit of Arhatship, then he is still caught up in the idea of a self, a person, a living being, and a life span. World-Honored One, you have often said that I have attained the concentration of peaceful abiding and that in the community, I am the Arhat who has most transformed need and desire. World-Honored One, if I were to think that I had attained the fruit of Arhatship, you certainly would not have said that I love to dwell in the concentration of peaceful abiding."

10

The Buddha asked Subhuti, "In ancient times when the Tathagata practiced under Buddha Dipankara, did he attain anything?"

Subhuti answered, "No, World-Honored One. In ancient times when the Tathagata was practicing under Buddha Dipankara, he did not attain anything."

"What do you think, Subhuti? Does a bodhisattva create a serene and beautiful Buddha field?"

"No, World-Honored One. Why? To create a serene and beautiful Buddha field is not in fact creating a serene and beautiful Buddha field. That is why it is called creating a serene and beautiful Buddha field."

The Buddha said, "So, Subhuti, all the bodhisattva mahasattvas should give rise to a pure and clear intention in this spirit. When they give rise to this intention, they should not rely on forms, sounds, smells, tastes, tactile objects, or objects of mind. They should give rise to an intention with their minds not dwelling anywhere.'

"Subhuti, if there were someone with a body as big as Mount Sumeru, would you say that his was a large body?"

Subhuti answered, "Yes, World-Honored One, very large. Why? What the Tathagata says is not a large body, that is known as a large body."

11

"Subhuti, if there were as many Ganges Rivers as the number of grains of sand in the Ganges, would you say that the number of grains of sand in all those Ganges Rivers is very many'"

Subhuti answered, "Very many indeed, World-Honored One. If the number of Ganges Rivers were huge, how much more so the number of grains of sand in all those Ganges Rivers."

"Subhuti, now I want to ask you this: if a daughter or son of good family were to fill the 3,000 chiliocosms with as many precious jewels as the number of grains of sand in all the Ganges Rivers as an act of generosity, would that person bring much happiness by her virtuous act?"

Subhuti replied, "Very much, World-Honored One."

The Buddha said to Subhuti, "If a daughter or son of a good family knows how to accept, practice, and explain this sutra to others, even if it is a gatha of four lines, the happiness that results from this virtuous act would be far greater."

12

"Furthermore, Subhuti, any plot of land on which this sutra is proclaimed, even if only one gatha of four lines, will be a land where gods, men, and asuras will come to make offerings just as they make offerings to a stupa of the Buddha. If the plot of land is regarded as that sacred, how much more so the person who practices and recites this sutra. Subhuti, you should know that that person attains something rare and profound. Wherever this sutra is kept is a sacred site enshrining the presence of the Buddha or one of the Buddha's great disciples."

13

After that, Subhuti asked the Buddha, "What should this sutra be called and how should we act regarding its teachings?"

The Buddha replied,"Thls sutra should be called The Diamond that Cuts through Illusion because it has the capacity to cut through allusions and afflictions and bring us to the shore of liberation. Please use this title and practice according to its deepest meaning. Why? What the Tathagata has called the highest, transcendent understanding is not, in fact, the highest, transcendent understanding. That is why it is truly the highest, transcendent understanding:"

The Buddha asked,"What do you think, Subhuti? Is there any dharma that the Tathagata teaches?"

Subhuti replied, "The Tathagata has nothing to teach, World-Honored One."

"What do you think, Subhuti? Are there many particles of dust in the 3,000 chiliocosms?"

"Very many, World-Honored One."

"Subhuti, the Tathagata says that these particles of dust are not particles of dust, That is why they are truly particles of dust. And what the Tathagata calls chiliocosms are not in fact chiliocosms. That is why they are called chiliocosmsl"

"What do you think, Subhuti? Can the Tathagata be recognized by the possession of the thirty-two marks?"

The Venerable Subhuti replied, "No, World-Honored One. Why? Because what the Tathagata calls the thirty-two marks are not essentially marks and that is why the Tathagata calls them the thirty-two marks."

"Subhuti, if as many times as there are grains of sand in the Ganges a son or daughter of a good family gives up his or her life as an act of generosity and if another daughter or son of a good family knows how to accept, practice, and explain this sutra to others, even if only a gatha of four lines, the happiness resulting from explaining this sutra is far greater."

14

When he had heard this much and penetrated deeply into its significance, the Venerable Subhuti was moved to tears. He said, "World-Honored One, you are truly rare in this world. Since the day I attained the eyes of understanding, thanks to the guidance of the Buddha, I have never before heard teachings so deep and wonderful as these. World-Honored One, if someone hears this sutra, has pure and clear confidence in it, and arrives at insight into the truth, that person will realize the rarest kind of virtue. World-Honored One, that insight into the truth is essentially not insight. That is what the Tathagata calls insight into the truth.

"World-Honored One, today it is not difficult for me to hear this wonderful sutra, have confidence in it, understand it, accept it, and put it into practice. But in the future, in 500 years, if there is someone who can hear this sutra, have confidence in it, understand it, accept it, and put it into practice, then certainly the existence of someone like that will be great and rare. Why? That person will not be dominated by the idea of a self, a person, a living being, or a life span. Why? The idea of a self is not an idea, and the ideas of a person, a living being, and a life span are not ideas either. Why? Buddhas are called Buddhas because they are free of ideas."

"The Buddha said to Subhuti, "That is quite right. If someone hears this sutra and is not terrified or afraid, he or she is rare. Why? Subhuti, what the Tathagata calls parama-paramita, the highest transcendence, is not essentially the highest transcendence, and that is why it is called the highest transcendence.

"Subhuti, the Tathagata has said that what is called transcendent endurance is not transcendent endurance. That is why it is called transcendent endurance. Why? Subhuti, thousands of lifetimes ago when my body was cut into pieces by King Kalinga, I was not caught in the idea of a self, a person, a living being, or a life span. If, at that time, I had been caught up in any of those ideas, I would have felt anger and ill-will against the king.

"I also remember in ancient times, for 500 lifetimes, I practiced transcendent endurance by not being caught up in the idea of a self, a person, a living being, or a life span. So, Subhuti, when a bodhisattva gives rise to the unequalled mind of awakening, he has to give up all ideas. He cannot not rely on forms when he gives rise to that mind, nor on sounds, smells, tastes, tactile objects, or objects of mind. He can only give rise to that mind that is not caught up in anything.

"The Tathagata has said that all notions are not notions and that all living beings are not living beings. Subhuti, the Tathagata is one who speaks of things as they are, speaks what is true, and speaks in accord with reality. He does not speak deceptively or to please people. Subhuti, if we say that the Tagthagata has realized a teaching, that teaching is neither graspable nor deceptive.

"Subhuti, a bodhisattva who still depends on notions to practice generosity is like someone walking in the dark. He will not see anything. But when a bodhisattva does not depend on notions to practice generosity, he is like someone with good eyesight walking under the bright light of the sun. He can see all shapes and colors.

"Subhuti, if in the future there is any daughter or son of good family who has the capacity to accept, read, and put into practice this sutra, the Tathagata will see that person with his eyes of understanding. The Tathagata will know that person, and that person will realize the measureless, limitless fruit of her or his virtuous act."

15

"Subhuti, if on the one hand, a daughter or son of a good family gives up her or his life in the morning as many times as there are grains of sand in the Ganges as an act of generosity, and gives as many again in the afternoon and as many again in the evening, and continues doing so for countless ages; and if, on the other hand, another person listens to this sutra with complete confidence and without contention, that person's happiness will be far greater. But the happiness of one who writes this sutra down, receives, recites, and explains it to others cannot be compared.

"In summary, Subhuti, this sutra brings about boundless virtue and happiness that cannot be conceived or measured. If there is someone capable of receiving, practicing, reciting, and sharing this sutra with others, the Tathagata will see and know that person, and he or she will have inconceivable, indescribable, and incomparable virtue. Such a person will be able to shoulder the highest, most fulfilled, awakened career of the Tathagata. Why? Subhuti, if one is content with the small teachings, if he or she is still caught up in the idea of a self, a person, a living being, or a life span, he or she will not be able to listen, receive, recite, and explain this sutra to others. Subhuti, any place this sutra is found is a place where gods, men, and asuras will come to make offerings. Such a place is a shrine and should be venerated with formal ceremonies, circumambulations, and offerings of flowers and incense."

16

"Furthermore, Subhuti, if a son or daughter of good family, while reciting and practicing this sutra, is disdained or slandered, his or her misdeeds committed in past lives, including those that could bring about an evil destiny, will be eradicated, and he or she will attain the fruit of the most fulfilled, awakened mind. Subhuti, in ancient times before I met Buddha Dipankara, I had made offerings to and had been attendant of all 84,000 multi-millions of buddhas. If someone is able to receive, recite, study, and practice this sutra in the last epoch, the happiness brought about by this virtuous act is hundreds of thousands times greater than that which I brought about in ancient times. In fact, such happiness cannot be conceived or compared with anything, even mathematically. Such happiness is immeasurable.

"Subhuti, the happiness resulting from the virtuous act of a son or daughter of good family who receives, recites, studies, and practices this sutra in the last epoch will be so great that if I were to explain it now in detail, some people would become suspicious and disbelieving, and their minds might become disoriented. Subhuti, you should know that the meaning of this sutra is beyond conception and discussion. Likewise, the fruit resulting from receiving and practicing this sutra is beyond conception and discussion."

17

At that time, the Venerable Subhuti said to the Buddha, "World-Honored One, may I ask you again that if daughters or sons of good family want to give rise to the highest, most fulfilled, awakened mind, what should they rely on and what should they do to master their thinking?"

The Buddha replied, "Subhuti, a good son or daughter who wants to give rise to the highest, most fulfilled, awakened mind should do it in this way: 'We must lead all beings to the shore of awakening, but, after these beings have become liberated, we do not, in truth, think that a single being has been liberated.' Why is this so? Subhuti, if a bodhisattva is still caught up in the idea of

a self, a person, a living being or a life span, that person is not an authentic bodhisattva. Why is that?

"Subhuti, in fact, there is no independently existing object of mind called the highest, most fulfilled, awakened mind. What do you think, Subhuti? In ancient times, when the Tathagata was living with Buddha Dipankara, did he attain anything called the highest, most fulfilled, awakened mind?"

"No, World-Honored One. According to what I understand from the teachings of the Buddha, there is no attaining of anything called the highest, most fulfilled, awakened mind."

The Buddha said, "Right you are, Subhuti. In fact, there does not exist the so-called highest, most fulfilled, awakened mind that the Tathagata attains. Because if there had been any such thing, Buddha Dipankara would not have predicted of me, 'In the future, you will come to be a Buddha called Shakyamuni.' This prediction was made because there is, in fact, nothing that can be attained that is called the highest, most fulfilled, awakened mind. Why? Tathagata means the suchness of all things (dharmas). Someone would be mistaken to say that the Tathagata has attained the highest, most fulfilled, awakened mind since there is not any highest, most fulfilled, awakened mind to be attained. Subhuti, the highest, most fulfilled, awakened mind that the Tathagata has attained is neither graspable nor elusive. This is why the Tathagata has said, 'All dharmas are Buddhadharma.' What are called all dharmas are, in fact, not all dharmas. That is why they are called all dharmas.

"Subhuti, a comparison can be made with the idea of a great human body."

Subhuti said, "What the Tathagata calls a great human body is, in fact, not a great human body."

"Subhuti, it is the same concerning bodhisattvas. If a bodhisattva thinks that she has to liberate all living beings, then she is not yet a bodhisattva. Why? Subhuti, there is no independently existing object of mind called bodhisattva. Therefore, the Buddha has said that all dharmas are without a self, a person, a living being, or a life span. Subhuti, if a bodhisattva thinks, 'I have to create a serene and beautiful Buddha field? that person is not yet a bodhisattva. Why? What the Tathagata calls a serene and beautiful Buddha field is not in fact a serene and beautiful Buddha field. And that is why it is called a serene and beautiful Buddha field. Subhuti, any bodhisattva who thoroughly understands the principle of non-self and non-dharma is called by the Tathagata an authentic bodhisattva."

18

"Subhuti, what do you think? Does the Tathagata have the human eye?"

Subhuti replied,"Yes, World-Honored One, the Tathagata does have the human eye."

The Buddha asked, "Subhuti, what do you think? Does the Tathagata have the divine eye?"

Subhuti said, "Yes, World-Honored One, the Tathagata does have the divine eye."

"Subhuti, what do you think? Does the Tathagata have the eye of insight?"

Subhuti replied,"Yes, World-Honored One, the Tathagata does have the eye of insight."

"Subhuti, what do you think? Does theTathagata have the eye of transcendent wisdom?"

"Yes, World-Honored One, the Tathagata does have the eye of transcendent wisdom."

The Buddha asked, "Does the Tathagata have the Buddha eye?"

"Yes, World-Honored One, the Tathagata does have the Buddha eye."

"Subhuti, what do you think? Does the Buddha see the sand in the Ganges as sand?"

Subhuti said, "World-Honored One, the Tathagata also calls it sand."

"Subhuti, if there were as many Ganges Rivers as the number of grains of sand of the Ganges and there was a Buddha land for each grain of sand in all those Ganges Rivers, would those Buddha lands be many?"

"Yes, World-Honored One, very many."

The Buddha said, "Subhuti, however many living beings there are in all these Buddha lands, though they each have a different mentality, the Tathagata understands them all. Why is that? Subhuti, what the Tathagata calls different mentalities are not in fact different mentalities. That is why they are called different mentalities."

"Why? Subhuti, the past mind cannot be grasped, neither can the present mind or the future mind."

19

"What do you think, Subhuti? If someone were to fill the 3,000 chiliocosms with precious treasures as an act of generosity, would that person bring great happiness by his virtuous act?" "Yes, very much, World-Honored One."

"Subhuti, if such happiness were conceived as an entity separate from everything else, the Tathagata would not have said it to be great, but because it is ungraspable, the Tathagata has said that the virtuous act of that person brought about great happiness."

20

"Subhuti, what do you think? Can the Tathagata be perceived by his perfectly formed body?"

"No, World-Honored One. What the Tathagata calls a perfectly formed body is not in fact a perfectly formed body. That is why it is called a perfectly formed body."

"What do you think, Subhuti? Can the Tathagata be perceived by his perfectly formed physiognomy?"

"No, World-Honored One. It is impossible to perceive the Tathagata by any perfectly formed physiognomy. Why? Because what the Tathagata calls perfectly formed physiognomy is not in fact perfectly formed physiognomy. That is why it is called perfectly formed physiognomy."

21

"Subhuti, do not say that the Tathagata conceives the idea 'I will give a teaching? Do not think that way. Why? If anyone says that the Tathagata has something to teach, that person slanders the Buddha because he does not understand what I say. Subhuti, giving a Dharma talk in fact means that no talk is given. This is truly a Dharma talk."

Then, Insight-Life Subhuti said to the Buddha, "World-Honored One, in the future, will there be living beings who will feel complete confidence when they hear these words?"

The Buddha said, "Subhuti, those living beings are neither living beings nor non-living beings. Why is that? Subhuti, what the Tathagata calls non-living beings are truly living beings."

22

Subhuti asked the Buddha, "World-Honored One, is the highest, most fulfilled, awakened mind that the Buddha attained the unattainable?"

The Buddha said, "That is right, Subhuti. Regarding the highest, most fulfilled, awakened mind, I have not attained anything. That is why it is called the highest, most fulfilled, awakened mind."

23

"Furthermore, Subhuti, that mind is everywhere equally. Because it is neither high nor low, it is called the highest, most fulfilled, awakened mind. The fruit of the highest, most fulfilled, awakened mind is realized through the practice of all wholesome actions in the spirit of non-self, nonperson, non-living being, and non-life span. Subhuti, what are called wholesome actions are in fact not wholesome actions. That is why they are called wholesome actions."

24

"Subhuti, if someone were to fill the 3,000 chiliocosms with piles of the seven precious treasures as high as Mount Sumeru as an act of generosity, the happiness resulting from this is much less than that of another person who knows how to accept, practice, and explain the Vajracchedika Prajnaparamita Sutra to others. The happiness resulting from the virtue of a person who practices this sutra, even if it is only a gatha of four lines, cannot be described by using examples or mathematics."

25

"Subhuti, do not say that the Tathagata has the idea, 'I will bring living beings to the shore of liberation.' Do not think that way, Subhuti. Why? In truth there is not one single being for the Tathagata to bring to the other shore. If the Tathagata were to think there was, he would be caught in the idea of a self, a person, a living being, or a life span. Subhuti, what the Tathagata calls a self essentially has no self in the way that ordinary persons think there is a self. Subhuti, the

Tathagata does not regard anyone as an ordinary person. That is why he can call them ordinary persons."

26

"What do you think, Subhuti? Can someone meditate on the Tathagata by means of the thirty-two marks?"

Subhuti said, "Yes, World-Honored One. We should use the thirty-two marks to meditate on the Tathagata."

The Buddha said, "If you say that you can use the thirty-two marks to see the Tathagata, then the Cakravartin is also a Tathagata?"

Subhuti said, "World-Honored One, I understand your teaching. One should not use the thirty-two marks to meditate on the Tathagata."

Then the World-Honored One spoke this verse:

"Someone who looks for me in form or seeks me in sound

is on a mistaken path and cannot see the Tathagata."

27

"Subhuti, if you think that the Tathagata realizes the highest, most fulfilled, awakened mind and does not need to have all the marks, you are wrong. Subhuti, do not think in that way. Do not think that when one gives rise to the highest, most fulfilled, awakened mind, one needs to see all objects of mind as nonexistent, cut off from life. Please do not think in that way. One who gives rise to the highest, most fulfilled, awakened mind does not contend that all objects of mind are nonexistent and cut off from life."

28

"Subhuti, if a bodhisattva were to fill the 3,000 chiliocosms with the seven precious treasures, as many as the number of sand grains in the Ganges as an act of generosity, the happiness brought about by his or her virtue is less than that brought about by someone who has understood and wholeheartedly accepted the truth that all dharmas are of selfless nature and is able to live and bear fully this truth. Why is that, Subhuti? Because a bodhisattva does not need to build up virtue and happmess."

Subhuti asked the Buddha, "What do you mean, World-Honored One, when you say that a bodhisattva does not need to build up virtue and happiness?"

"Subhuti, a bodhisattva gives rise to virtue but is not caught in the idea of virtue and happiness. That is why the Tathagata has said that a bodhisattva does not need to build up virtue and happiness."

29

"Subhuti, if someone says that the World-Honored One comes, goes, sits, and lies down, that person has not understood what I have said. Why? The meaning of Tathagata is 'does not come from anywhere and does not go anywhere? That is why he is called a Tathagata."

30

"Subhuti, if a daughter or son of a good family were to grind the 3,000 chiliocosms to particles of dust, do you think there would be many particles?"

Subhuti replied, "World-Honored One, there would be many indeed. Why? If particles of dust had a real self-existence, the Buddha would not have called them particles of dust. What the Buddha calls particles of dust are not, in essence, particles of dust. That is why they can be called particles of dust. World-Honored One, what the Tathagata calls the 3,000 chiliocosms are not chiliocosms. That is why they are called chiliocosms. Why? If chiliocosms are real, they are a compound of particles under the conditions of being assembled into an object. That which the Tathagata calls a compound is not essentially a compound. That is why it is called a compound."

"Subhuti, what is called a compound is just a conventional way of speaking. It has no real basis. Only ordinary people are caught up in conventional terms."

31

"Subhuti, if anyone says that the Buddha has spoken of a self view, a person view, a living-being view, or a life span view, has that person understood my meaning?"

"No, World-Honored One. Such a person has not understood the Tathagata. Why? What the Tathagata calls a self view, a person view, a living-being view, or a life span view are not in essence a self view, a person view, a living-being view, or a life span view. That is why they are called a self view, a person view, a living-being view, or a life span view."

"Subhuti, someone who gives rise to the highest, most fulfilled, awakened mind should know that this is true of all dharmas, should see that all dharmas are like this, should have confidence in the understanding of all dharmas without any conceptions about dharmas. Subhuti, what is called a conception of dharmas, the Tathagata has said, is not a conception of dharmas. That is why it is called a conception of dharmas."

32

"Subhuti, if someone were to offer an immeasurable quantity of the seven treasures to fill the worlds as infinite as space as an act of generosity, the happiness resulting from that virtuous act would not equal the happiness resulting from a son or daughter of a good family who gives rise to the awakened mind and reads, recites, accepts, and puts into practice this sutra, and explains it to others, even if only a gatha of four lines. In what spirit is this explanation given? Without being caught up in signs, just according to things as they are, without agitation. Why is this?

"All composed things are like a dream,

a phantom, a drop of dew, a flash of lightning.

That is how to meditate on them,

that is how to observe them."

After they heard the Lord Buddha deliver this sutra, the Venerable Subhuti, the bhiksus and bhiksunis, laymen and laywomen, and gods and asuras, filled with joy and confidence, undertook to put these teachings into practice.