New Page 1

此网页使用了框架，但您的浏览器不支持框架。


BIONA Version

The Lankavatara Sutra

Dream World {A Commentary}

Chapter I

Discrimination

Thus have I heard:

The Blessed One once appeared in the Castle of Lanka, which is on the summit of Mt. Malaya in the midst of the great Ocean. A great many Bodhisattvas-Mahasattvas had miraculously assembled from all the Buddha-lands, and a large number of Bhikshus were gathered there. The Bodhisattvas-Mahasattvas with Mahamati at their head were all perfect masters of the various Samádhis, the tenfold Self-mastery, the ten Powers, and the six Psychic Faculties. Having been anointed by the Buddha’s own hands, they all well understood the significance of the objective world; they all knew how to apply the various means, teachings and disciplinary measures according to the various mentalities and behaviors of beings; they were all thoroughly versed in the five Dharmas, the three Svabhavas, the eight Vijnanas, and the twofold Ego-less-ness.

The Blessed One, knowing the mental agitations going on in the minds of those assembled (like the surface of the ocean stirred into waves by the passing winds), and his great heart moved by compassion, smiled and said, "In the days of old the Tathágatas of the past who were Arhats and fully-enlightened Ones came to the Castle of Lanka on Mount Malaya and discoursed on the Truth of Noble Wisdom that is beyond the reasoning knowledge of the philosophers as well as being beyond the understanding of ordinary disciples and masters; and which is realizable only within the inmost consciousness; for your sakes, I too, would discourse on the same Truth. All that is seen in the world is devoid of effort and action because all things in the world are like a dream, or like an image miraculously projected. This is not comprehended by the philosophers and the ignorant, but those who thus see things see them truthfully. Those who see things otherwise walk in discrimination and, as they depend upon discrimination, they cling to dualism. The world as seen by discrimination is like seeing one’s own image reflected in a mirror, or one’s shadow, or the moon reflected in water, or an echo heard in a valley. People grasping their own shadows of discrimination become attached to this thing and that thing and failing to abandon dualism they go on forever discriminating and thus never attain tranquility. By tranquility is meant Oneness, and Oneness gives birth to the highest Samádhi, which is gained by entering into the realm of Noble Wisdom that is realizable only within one’s inmost consciousness.

Then all Bodhisattvas-Mahasattvas rose from their seats and respectfully paid him homage and Mahamati the Bodhisattva-Mahasattva sustained by the power of the Buddhas drew his upper garment over one shoulder, knelt and pressing his hands together, praised him in the following verses:

As you review the world with your perfect intelligence and compassion, it must seem to you like an ethereal flower of which one cannot say: it is born, it is destroyed, for the terms beings and non-being do not apply to it.

As you review the world with your perfect intelligence and compassion, it must seem to you like a dream of which it cannot be said: it is permanent or it is destructible, for the being and non-being do not apply to it.

As you review all things by your perfect intelligence and compassion, they must seem to you like visions beyond the reach of the human mind, as being and non-being do not apply to them.

With your perfect intelligence and compassion, which are beyond all limit, you comprehend the ego-less-ness of things and persons, and are free and clear from the hindrances of passion and learning and egoism.

You do not vanish into Nirvana, nor does Nirvana abide in you, for Nirvana transcends all duality of knowing and known, of being and non-being.

Those who see thee thus, serene and beyond conception, will be emancipated from attachment, will be cleansed of all defilements, both in this world and in the spiritual world beyond.

In this world whose nature is like a dream, there is place for praise and blame, but in the ultimate Reality of Dharmakaya, which is far beyond the senses and the discriminating mind, what is there to praise? O you who are most Wise!

Then said Mahamati the Bodhisattva-Mahasattva: O blessed One, Sugata, Arhat and Fully-Enlightened One, pray tell us about the realization of Noble Wisdom which is beyond the path and usage of philosophers; which is devoid of all predicates such as being and non-being, oneness and otherness, both-ness and non-both-ness, existence and non-existence, eternity and non-eternity; which has nothing to do with individuality and generality, nor false-imagination, nor any illusions arising from the mind itself; but which manifests itself as the Truth of Highest Reality. By which, going up continuously by the stages of purification, one enters at last upon the stage of Tathágata-hood, whereby, by the power of his original vows unattended by any striving, one will radiate its influence to infinite worlds, like a gem reflecting its variegated colors, whereby I and other Bodhisattvas-Mahasattvas will be enabled to bring all beings to the same perfection of virtue.

Said the Blessed One: Well done, well done, Mahamati! And again, well done, indeed! It is because of your compassion for the world; because of the benefit it will bring upon many people both human kind and celestial, that you have presented yourself before us to make this request. Therefore, Mahamati, listen well and truly reflect upon what I shall say, for I will instruct you.

Then Mahamati and the other Bodhisattva-Mahasattvas gave devout attention to the teaching of the Blessed One.

Mahamati, since the ignorant and simple-minded, not knowing that the world is only something seen of the mind itself, cling to the multitudinous-ness of external objects, cling to the notions of beings and non-being, oneness and otherness, both-ness and non-both-ness, existence and non-existence eternity and non-eternity, and think that they have a self-nature of their own, and all of which rises from the discriminations of the mind and is perpetuated by habit-energy, and from which they are given over to false imagination. It is all like a mirage in which springs of water are seen as if they were real. They are imagined by animals who, made thirsty by the heat of the season, run after them. Animals not knowing that the springs are merely hallucinations of their own minds, do not realize that there are no such springs. In the same way, Mahamati, the ignorant and simple-minded, their minds burning with the fires of greed, anger and folly, finding delight in a world of multitudinous forms, their thoughts obsessed with ideas of birth, growth and destruction, not well understanding what is meant by existence and non-existence, and being impressed by erroneous discriminations and speculations since beginning-less time, fall into the habit of grasping this and that and thereby becoming attached to them.

It is like the city of the Gandharvas which the unwitting take to be a real city when in fact it is not so. The city appears as in a vision owing to their attachment to the memory of a city preserved in the mind as a seed; the city can thus be said to be both existent and non-existent. In the same way, clinging to the memory of erroneous speculations and doctrines accumulated since beginning-less time, they hold fast to such ideas as oneness and otherness, being and non-being, and their thoughts are not at all clear as to what after all is only seen of the mind. It is like a man dreaming in his sleep of a country that seems to be filled with various men, women, elephants, horses, cars, pedestrians, villages, towns, hamlets, cows, buffalos, mansions, woods, mountains, rivers and lakes, and who moves about in that city until he is awakened. As he lies half awake, he recalls the city of his dreams and reviews his experiences there; what do you think, Mahamati, is this dreamer who is letting his mind dwell upon the various unrealities he has seen in his dream, is he to be considered wise or foolish? In the same way, the ignorant and simple-minded who are favorably influenced by the erroneous views of the philosophers do not recognize that the views that are influencing them are only dream-like ideas originating in the mind itself, and consequently they are held fast by their notions of oneness and otherness, of being and non-being. It is like a painter’s canvas on which the ignorant imagine they see the elevations and depressions of mountains and valleys.

In the same way there are people today being brought up under the influence of similar erroneous views of oneness and otherness, of both-ness and not-both-ness, whose mentality is being conditioned by the habit-energy of these false-imaginings and who later on will declare those who hold the true doctrine of no-birth which is free from the alternatives of being and non-being, to be nihilists and by so doing will bring themselves and others to ruin. By the natural law of cause and effect these followers of pernicious views uproot meritorious causes that otherwise would lead to unstained purity. They are to be shunned by those whose desires are for more excellent things.

It is like the dim-eyed ones who seeing a hairnet exclaim to one another: "It is wonderful! Look, Honorable sirs, it is wonderful!" But the hairnet has never existed; in fact; it is neither an entity, nor a non-entity, for it has both been seen and has not been seen. In the same manner those whose minds have been addicted to the discriminations of the erroneous views cherished by the philosophers which are given over to the unrealistic views of being and non-being, will contradict the good Dharma and will end in the destruction of themselves and others.

It is like a wheel of fire made by a revolving firebrand which is no wheel but which is imagined to be one by the ignorant. Nor is it a not a wheel because it has not been seen by some. By the same reasoning, those who are in the habit of listening to the discriminations and views of the philosophers will regard things born as non-existent and those destroyed by causation as existent. It is like a mirror reflecting colors and images as determined by conditions but without any partiality. It is like the echo of the wind that gives the sound of a human voice. It is like a mirage of moving water seen in a desert. In the same way the discriminating mind of the ignorant, which has been heated by false-imaginations and speculations, is stirred into mirage-like waves by the winds of birth, growth, and destruction. It is like the magician Pisaca, who by means of his spells makes a wooden image or a dead body to throb with life, though it has no power of its own. In the same way the ignorant and the simple-minded, committing themselves to erroneous philosophical views become thoroughly devoted to the ideas of oneness and otherness, but their confidence is not well grounded. For this reason, Mahamati, you and other Bodhisattvas-Mahasattvas should cast off all discriminations leading to the notions of birth, abiding, and destructions, of oneness and otherness, of both-ness and not-both-ness, of being and non-being and thus getting free of the bondage of habit-energy become able to attain reality realizable within yourselves of Noble Wisdom.

Then said Mahamati to the Blessed One: Why is it that the ignorant are given up to discrimination and the wise are not?

The Blessed One replied: it is because the ignorant cling to names, signs and ideas; as their minds move along these channels they feed on multiplicities of objects and fall into the notion of an ego-soul and what belongs to it; they make discriminations of good and bad among appearances and cling to the agreeable. As they thus cling there is a reversion to ignorance, and karma born of greed, anger and folly, is accumulated. As the accumulation of karma goes on they become imprisoned in a cocoon of discrimination and are thenceforth unable to free themselves from the round of birth and death.

Because of folly they do not understand that all things are like Maya, like the reflection of the moon in water, that there is no self-substance to be imagined as an ego-soul and its belongings, and that all their definite ideas rise from their false discriminations of what exists only as it is seen of the mind itself. They do not realize that things have nothing to do with qualify and qualifying, nor with the course of birth, abiding and destruction, and instead they assert that they are born of a creator, of time, of atoms, of some celestial spirit. It is because the ignorant are given up to discrimination that they move along with the stream of appearances, but it is not so with the wise.

Chapter II

False-Imaginations and Knowledge of Appearances

Then Mahamati the Bodhisattva-Mahasattva spoke to the Blessed One, saying: You speak of the erroneous views of the philosophers, will you please tell us of them, that we may be on our guard against them?

The Blessed One replied, saying: Mahamati, the error in these erroneous teachings that are generally held by the philosophers lies in this: they do not recognize that the objective world rises from the mind itself; they do not understand that the whole mind-system also arises from the mind itself; but depending upon these manifestations of the mind as being real they go on discriminating them, like the simple-minded ones that they are, cherishing the dualism of this and that, of being and non-being, ignorant to the fact that there is but one common Essence.

On the contrary my teaching is based upon recognition that the objective world, like a vision, is a manifestation of the mind itself; it teaches the cessation of ignorance, desire, deed and causality; it teaches the cessation of suffering that arises from the discriminations of the triple world.

There are some Brahman scholars who, assuming something out of nothing, assert that there is a substance bound up with causation, which abides in time, and that the elements that make up personality and its environment have their genesis and continuation in causation and after thus existing, pass away. Then there are other scholars who hold a destructive and nihilistic view concerning such subjects as continuation, activity, breaking-up, existence, Nirvana, the Path, karma, fruition and Truth. Why, because they have not attained an intuitive understanding of Truth itself and therefore they have no clear insight into the fundamentals of things. They are like a jar broken into pieces, which is no longer able to function as a jar; they are like a burnt seed, which is no longer capable of sprouting. But the elements that make up personality and its environment, which they regard as subject to change are really incapable of uninterrupted transformations. Their views are based upon erroneous discriminations of the objective world; they are not based upon the true conception.

Again, if it is true that something comes out of nothing and there is the rise of the mind-system by reason of the combinations of the three effect-producing causes, we could say the same of any non-existing thing: for instance, that a tortoise could grow hair, or sand produce oil. This proposition is of no avail; it ends up in affirming nothing. It follows that the deed, work and cause of which they speak is of no use, and so also is their reference to being and non-being, if they argue that there is a combination of the three effect-producing causes, they must do it on the principle of cause and effect, that is, that something comes out of something and not out of nothing. As long a world of relativity is asserted, there is an ever-recurring chain of causation, which cannot be denied under any circumstance; therefore we cannot talk of anything coming to an end or of cessation. As long as these scholars remain on their philosophical ground their demonstration must conform to logic and their textbooks, and the memory habit of erroneous intellection will ever cling to them. To make the matter worse, the simple-minded ones, poisoned by this erroneous view, will declare this incorrect way of thinking taught by the ignorant, to be the same as that presented by the All-knowing One.

But the way of instruction presented by the Tathágatas is not based on assertions and refutations by means of words and logic. There are four forms of assertion that can be made concerning things not in existence, namely, assertions made about individual marks that are not in existence; about objects that are not in existence, about a cause that is non-existent; and about philosophical views that are erroneous. By refutation is meant that one, because of ignorance, has not examined properly the error that lies at the base of these assertions.

The assertion about individual marks that really have no existence, concerns the distinctive marks as perceived by the eye, ear, nose, etc., as indicating individuality and generality in the elements that make up personality and its external world; and then, taking these marks for reality and getting attached to them, to get into the habit or affirming that things are just so and not otherwise.

The assertion about objects that are non-existent is an assertion that rises from attachment to these associated marks of individuality and generality. Objects in themselves are neither in existence nor in non-existence and are quite devoid of the alternative of being and non-being; and should only be thought of as one thinks of the horns of a hare, a horse, or a camel, which never existed. Objects are discriminated by the ignorant who are addicted to assertion and negation, because their intelligence has not been acute enough to penetrate into the truth that there is nothing but what is seen of the mind itself.

The assertion of a cause that is non-existent assumes the causeless birth of the first element of the mind-system, which later on comes to have only a Maya-like non-existence. That is to say, there are philosophers who assert that an originally unborn mind-system begins to function under the conditions of eye, form, light and memory, which functioning goes on for a time and then ceases. This is an example of a cause that is non-existent.

The assertion of philosophical views concerning the elements that make up personality and its environing world that are non-existent, assume the existence of an ego, a being, a soul, a living being, a "nourisher", or a spirit. This is an example of philosophical views that are not true. It is this combination of discrimination of imaginary marks of individuality, grouping them and giving them a name and becoming attached to them as objects, by reason of habit-energy that has been accumulated since beginning-less time, that one builds up erroneous views whose only basis is false-imaginations. For this reason Bodhisattvas should avoid all discussions relating to assertions and negations whose only basis is words and logic.

Word-discrimination goes on by the coordination of brain, chest, nose, throat, palate, tongue, teeth and lips. Words are neither different nor not different from discrimination. Words rise from discrimination as their cause; if words were different from discrimination they could not have discrimination for their cause; then again, if words are not different, they could not carry and express meaning. Words, therefore, are produced by causation and are mutually conditioning and shifting and, just like things, are subject to birth and destruction.

There are four kinds of word discrimination, all of which are to be avoided because they are alike unreal. First there are words indicating individual marks which rise from discriminating forms and signs as being real in themselves and, then, becoming attached to them. There are memory-words, which rise from the unreal surroundings, which come before the mind when it recalls some previous experience. Then there are words growing out of attachment to the erroneous distinctions and speculations of the mental processes. And finally, there are words growing out of inherited prejudices as seeds of habit-energy accumulated since beginning-less time, or which had their origin in some long forgotten clinging to false-imagination and erroneous speculation.

Then there are words where there are no corresponding objects, as for instance, the hare’s horns, a barren woman’s child, etc., there are no such things but we have the words, just the same. Words are an artificial creation; there are Buddha-lands where there are no words. In some Buddha-lands ideas are indicated by looking steadily, in others by gestures, in still others by a frown, by a movement of the eyes, by laughing, by yawning, by the clearing of the throat, or by trembling. For instance, in the Buddha-land of the Tathágata Samantabadra, Bodhisattvas, by a Dhyana transcending words and ideas, attain recognition of all things as un-born and they, also, experience various most excellent Samádhis that transcend words. Even in this world such specialized beings as ants and bees carry on their activities very well without recourse to words. No, Mahamati, the validity of things is independent of the validity of words.

Moreover, there are other things that belong to words, namely, the syllable-body of words, the name-body of words, and the sentence-body of words. By the syllable-body is meant that by which words and sentences are set up or indicated: there is a reason for some syllables, some are mnemonic, and some are chosen arbitrarily. By name-body is meant the object depending upon which a name-word obtains its significance, or in other words, name-body is the "substance" of a name-word. By sentence-body is meant the completion of the meaning by expressing the word more fully in a sentence. The name for this sentence-body is suggested by the footprints left in the road by elephants, horses, people, deer, cattle, goats, etc. But neither words nor sentences can exactly express meanings, for words are only sweet sounds that are arbitrarily chosen to represent things, they are not the things themselves, which in turn are only manifestations of mind. Discrimination of meaning is based upon the false-imagination that these sweet sounds which we call words and which are dependent upon whatever subjects they are supposed to stand for, and which subjects are supposed to be self-existent, all of which is based on error. Disciples should be on their guard against the seductions of words and sentences and their illusive meanings, for by them the ignorant and the dull-witted become entangled and helpless as an elephant floundering about in the deep mud.

Words and sentences are produced by the law of causation and are mutually conditioning they cannot express highest Reality. Moreover, in highest Reality there are no differentiations to be discriminated and there is nothing to be predicated in regards to it. Highest Reality is an exalted state of bliss, it is not a state of word-discrimination, and it cannot be entered into by mere statements concerning it. The Tathágatas have a better way of teaching, namely, through self-realization of Noble Wisdom.

Mahamati asked the Blessed One: Pray tell us about the causation of all things whereby I and other Bodhisattvas may see into the nature of causation and may no more discriminate it as to the gradual or simultaneous rising of all things?

The Blessed One replied: There are two factors of causation by reason of which all things come into seeming existence: external and internal factors. The external factors are a lump of clay, a stick, a wheel, a thread, water, a worker, his labor, and the combination of these produces a jar. As with a jar which is made from a lump of clay, or a piece of cloth made from thread, or matting made from fragrant grass, or a sprout growing out of a seed, or fresh butter made from sour milk by a man churning it; so it is with all things which appear one after another in continuous succession. As regards the inner factors of causation, they are of such kinds as ignorance, desire, purpose, all of which enter into the idea of causation. Born of these two factors there is the manifestation of personality and the individual things that make up its environment, but they are not individual and distinctive things: they are only so discriminated by the ignorant.

Causation may be divided into six elements: indifference-cause, dependence-cause, possibility-cause, agency-cause, objectivity-cause, manifesting-cause. Indifference-cause means that if there is no discrimination present, there is no power of combination present and so no combination takes place, or if present there is dissolution. Dependence-cause means that the elements must be present. Possibility-cause means that when a cause is to become effective there must be a suitable meeting of conditions both internal and external. Agency-cause means that there must be a principle vested with supreme authority like a sovereign king present and asserting itself. Objectivity-cause means that to be a part of the objective world the mind-system must be in existence and must be keeping up its continuous activity. Manifesting-cause means that as the discriminating faculty of the mind-system becomes busy individual marks will be revealed as forms are revealed by the light of a lamp.

All causes are thus seen to be the outcome of discrimination carried on by the ignorant and simple-minded, and there is, therefore, no such thing as gradual or simultaneous rising of existence. If such a thing as the gradual rising of existence is asserted, it can be disapproved by showing that there is no basic substance to hold the individual signs together which makes a gradual rising impossible. If simultaneous rising of existence is asserted, there would be no distinction between cause and effect and there will be nothing to characterize a cause as such. While a child is not yet born, the term father has no significance. Logicians argue that there is that which is born and that which gives birth by the mutual functioning of such causal factors as cause, substance, continuity, acceleration, etc., and so they conclude that there is a gradual rising of existence; but this gradual rising does not obtain except by reason of attachment to the notion of a self-nature.

When ideas of body, property and abode are seen, discriminated and cherished in what after all is nothing but what is conceived by the mind itself, an external world is perceived under the aspect of individuality and generality which, however, are not realities and, therefore, neither a gradual nor a simultaneous rising of things is possible. It is only when the mind-system comes into activity and discriminates the manifestations of mind that existence can be said to come into view. For these reasons, Mahamati, you must get rid of notions of graduation and simultaneity in the combination of causal activities.

Mahamati said: Blessed One; to what kind of discrimination and to what kind of thoughts should the term, false-imagination, be applied?

The Blessed One replied: So long as people do no understand the true nature of the objective world, they fall into the dualistic view of things. They imagine the multiplicity of external objects to be real and become attached to them and are nourished by their habit-energy. Because of this system of mentation-mind and what belongs to it-is discriminated and is thought of as real; this leads to the assertion of an ego-soul and its belongings, and thus the mind-system goes on functioning. Depending upon and attaching itself to the dualistic habit of mind, they accept the views of the philosophers founded upon these erroneous distinctions, of being and non-being, existence, and non-existence, and there evolves what we call, false-imaginations. But Mahamati, discrimination does not evolve nor is it put away because, when all that is seen is truly recognized to be nothing but the manifestation of mind, how can discrimination as regards being and non-being evolve? It is for the sake of the ignorant who are addicted to the discriminations of the multiplicity of things, which are of their own mind, that it is said by me that discrimination takes its rise owing to attachment to the aspect of multiplicity, which is characteristic of objects. How otherwise can the ignorant and simple-minded recognize that there is nothing but what is seen of the mind itself, and how otherwise can they gain an insight into the true nature of mind and be able to free themselves from wrong conceptions of cause and effect? How otherwise can they gain a clear conception of the Bodhisattva stages, and attain and "turning-about" in the deepest seat of their consciousness, and finally attain an inner self-realization of Noble Wisdom which transcends the five Dharmas, the three Self-natures, and the whole idea of a discriminated Reality? For this reason it is said by me that discrimination takes its rise from the mind becoming attached to the multiplicities of things, which in themselves are not real, and that emancipation comes from thoroughly understanding the meaning of Reality as it truly is. False-imaginations rise from the consideration of appearances; things are discriminated as to form, signs and shape; as to having color, warmth, humidity, motility or rigidity. False-imagination consists in becoming attached to these appearances and their names. By attachment to objects is meant, the getting attached to inner and outer things as if they were real. By attachment to names is meant, the recognition in these inner and outer things of the characteristic marks of individuation and generality, and to regard them as definitely belonging to the names of the objects.

False-imagination teaches that because all things are bound up with causes and conditions of habit-energy that has been accumulating since beginning-less time by not recognizing that the external world is of mind itself, all things are comprehensible under the aspects of individuality and generality. By reason of clinging to these false-imaginations there is multitudinous-ness of appearances, which are imagined, to be real but which are only imaginary. To illustrate: when a magician depending on grass, wood, shrubs and creepers, exercises his art, many shapes and beings take form that are only magically created; sometimes they even make figures that have bodies and that move and act like human beings; they are variously and fancifully discriminated but there is no reality in them; everyone but children and the simple-minded know that they are not real. Likewise based upon the notion of relativity false-imagination perceives a variety of appearances, which the discriminating mind proceeds to objectify and name and become attached to, and memory and habit-energy perpetuate. Here is all that is necessary to constitute the self-nature of false-imagination. The various features of false imagination can be distinguished as follows: as regards words, meaning, individual marks, property, self-nature, cause, philosophical views, reasoning, birth, no-birth, dependence, bondage and emancipation. Discrimination of words is the becoming attached to various sounds carrying familiar meanings. Discrimination of meaning comes when one imagines that words rise depending upon whatever subjects they express, and which subjects are regarded as self-existent. Discrimination of individual marks is to imagine that whatever is denoted in words concerning the multiplicities of individual marks (which in themselves are like a mirage) is true, and clinging tenaciously to them, to discriminate all things according to such categories as warmth, fluidity, motility, and solidity. Discrimination of property is to desire a state of wealth, such as gold, silver, and various precious stones.

Discrimination of self-nature is to make discriminations according to the views of the philosophers in reference to the self-nature of all things which they imagine and stoutly maintain to be true, saying: "This is just what it is and it cannot be otherwise." Discrimination of cause is to distinguish the notion of causation in reference to being and non-being and to imagine that there are such things as "cause-signs." Discrimination of philosophical views means considering different views relating to the notions of being and non-being, oneness and otherness, both-ness and not-both ness, existence and non-existence, all of which are erroneous, and becoming attached to particular views. Discrimination of reasoning means the teaching whose reasoning is based on the grasping of the notion and ego-substance and what belongs to it. Discrimination of birth means getting attached to the notion that things come into existence and pass out of existence according to causation. Discrimination of no-birth is to see that causeless substances which were not, come into existence by reason of causation. Discrimination of dependence means the mutual dependence of gold and the filaments made of it. Discriminations of bondage and imagination is like imagining that there is something bound because of something binding, as in the case of a man who ties a knot and loosens one. These are the various features of false-imagination to which all the ignorant and simple-minded cling. Those attached to the notion of relativity are attached to the notion of the multitudinous-ness of things, which arises from false-imagination. It is like seeing varieties of objects depending upon Maya, but these varieties thus revealing themselves are discriminated by the ignorant as something other than Maya itself, according to their way of thinking. Now the truth is, Maya and varieties of objects are neither different nor not different; if they were different, varieties of objects would not have Maya for their characteristic; if they were not different there would be no distinction between them. But as there is a distinction these two--Maya and variety of objects--are neither different nor not different, for the very good reason: they are one thing.

Mahamati said to the Blessed One: Is error an entity or not? The Blessed One replied: Error has no character in it making for attachment; if error had such a character no liberation would be possible from its attachment to existence, and the chain of origination would only be understood in the sense of creation as upheld by the philosophers. Error is like Maya, also, and as Maya is incapable from producing other Maya, so error in itself cannot produce error; it is discrimination and attachment that produce evil thoughts and faults. Moreover, Maya has no power of discrimination in itself; it only rises when invoked by the charm of the magician. Error has in itself no habit-energy; habit-energy only rises from discrimination and attachment. Error in itself has no faults; faults are due to the confused discriminations fondly cherished by the ignorant concerning ego-soul and its mind. The wise have nothing to do either with Maya or error.

Maya, however, is not an unreality because it only has the appearance of reality; all things have the nature of Maya. It is not because all things are imagined and clung to because of the multitudinous-ness of individual signs that they are like Maya; it is because they are alike unreal and as quickly appearing and disappearing. Being attached to erroneous thoughts they confuse and contradict themselves and others. As they do not clearly grasp the fact that the world is no more than mind itself, they imagine and cling to causation, work, birth and individual signs, and their thoughts are characterized by error and false-imaginations. The teaching that all things are characterized by the self-nature of Maya and a dream is meant to make the ignorant and simple-minded cast aside the idea of self-nature in anything.

False-imagination teaches that such things as light and shade, long and short, black and white are different and are to be discriminated; but they are not independent of each other; they are only different aspects of the same thing, they are terms of relation and not of reality. Conditions of existence are not of a mutually exclusive character; in essence things are not two but one. Even Nirvana and Samsára’s world of life and death are aspects of the same thing, for there is no Nirvana except where is Samsára, and no Samsára except where is Nirvana. All duality is falsely imagined.

Mahamati, you, and all Bodhisattvas should discipline yourselves in the realization and patience acceptance of the truths of the emptiness, un-born-ness, no self-nature-ness, and the non-duality of all things. This teaching is found in all the sutras of all the Buddhas and is presented to meet the varied dispositions of all beings, but it is not the Truth itself. These teachings are only a finger pointing towards Noble Wisdom. They are like a mirage with its springs of water, which the deer take to be real and chase after. So with the teachings in all the sutras: They are intended for the consideration and guidance of the discriminating minds of all people, but they are not the Truth itself, which can only be self-realized within one’s deepest consciousness.

Mahamati, you and all the Bodhisattvas must seek for this inner self-realization of Noble Wisdom, and not be captivated by word teaching.

Chapter III

Right Knowledge or Knowledge of Relations

Then Mahamati said: Pray tell us, Blessed One, about the being and the non-being of all things?

The Blessed One replied: People of this world are dependent in their thinking on one of two things: on the notion of being whereby they take pleasure in realism, or in the notion of non-being whereby they take pleasure in nihilism; in either case they imagine emancipation where there is no emancipation. Those who are dependent upon notions of being, regard the world as rising from a causation that is really existent, and that this actually existing and becoming world does not take its rise from a causation that is non-existent. This is the realistic view as held by some people. Then there are other people who are dependent on the notion of the non-being of all things. These people admit the existence of greed, anger and folly, and at the same time they deny the existence of the things that produce greed, anger and folly. This is not rational, for greed, anger and folly are no more to be taken hold of as real than are things; they neither have substance nor individual marks. Where there is a state of bondage, there is binding and means for binding; but where there is emancipation, as in the case of Buddhas, Bodhisattvas, masters and disciples, who have ceased to believe in both being and non-being, there is neither bondage, binding nor means for binding.

It is better to cherish the notion of an ego-substance than to entertain the notion of emptiness derived from the view of being and non-being, for those who so believe fail to understand the fundamental fact that the external world is nothing but a manifestation of mind. Because they see things as transient, as rising from cause and passing away from cause, now dividing, now combining into the elements which make up the aggregates of personality and its external world and now passing away, they are doomed to suffer every moment from the changes that follow one after another, and finally are doomed to ruin.

Then Mahamati asked the Blessed One, saying: Tell us, Blessed One, how all things can be empty, un-born, and have no self-nature, so that we may awakened and quickly realize highest enlightenment?

The Blessed One replied: What is emptiness, indeed! It is a term whose very self-nature is false-imagination, but because of one’s attachment to false-imagination we are obliged to talk of emptiness, no-birth, and no self-nature. There are seven kinds of emptiness: emptiness of mutuality which is non-existence; emptiness of individual marks; emptiness of self-nature; emptiness of no-work, emptiness of work; emptiness of all things in the sense that they are unpredictable, and emptiness in its highest sense of Ultimate Reality.

By the emptiness of mutuality, which is non-existent, is meant that when a thing is missing here, one speaks of it being empty here. For instance: in the lecture hall of Mrigarama there are no elephants present, nor bulls, nor sheep; but as to monks there are many present. We can rightly speak of the hall as being empty as far as animals are concerned. It is not asserted that the lecture hall is empty of its own characteristics, or that the monks are empty of that which makes up their monk hood, nor that in some other place there are no elephants, bulls, nor sheep to be found. In this case we are speaking of things in their aspect of individuality and generality, but from the point of view of mutuality some things do not exist somewhere. This is the lowest form of emptiness and is to be sedulously put away.

By emptiness of individual marks is meant that all things have no distinguishing marks of individuality and generality. Because of mutual relations and interactions things are superficially discriminated but when they are further and more carefully investigated and analyzed they are seen to be non-existent and nothing as to individuality and generality can be predicated of them. Thus when individual marks can no longer be seen, ideas of self, otherness and both-ness, no longer hold good. So it must be said that all things are empty of self-marks.

By emptiness of self-nature is meant that all things in their self-nature are un-born; therefore, it is said that things are empty as to self-nature. By emptiness of ‘no work’ is meant that the aggregate of elements that makes up personality and its external world is Nirvana itself and from the beginning there is no activity in them; therefore, one speaks of the emptiness of ‘no work’. By emptiness of work is meant that the aggregates being devoid of an ego and its belongings, go on functioning automatically as there is mutual conjunction of causes and conditions; thus one speaks of the emptiness of work. By emptiness of all things in the same sense that they are unpredictable is meant that, as the very nature of false-imagination is inexpressible, so all things are unpredictable, and, therefore, are empty in that sense. By emptiness in its highest sense of the emptiness of Ultimate Reality is meant that the in the attainment of inner self-realization of Noble Wisdom there is no trace of habit-energy generated by erroneous conceptions; thus one speaks of the highest emptiness of Ultimate Reality.

When things are examined by right knowledge there are no signs obtainable which could characterize them with marks of individuality and generality, therefore, they are said to have no self-nature. Because these signs of individuality and generality are seen both as existing and yet are known to be non-existent, are seen as going out and yet are known not to be going out, they are never annihilated. Why is this true? For this reason; because individual signs that should make up the self-nature of all things are non-existent. Again in their self-nature things are both eternal and non-eternal. Things are not eternal because the marks of individuality appear and disappear, that is, the marks of self-nature are characterized by non-eternality. On the other hand, because things are un-born and are only mind-made, they are in a deep sense eternal. That is, things are eternal because of their very non-eternality.

Further, besides understanding the emptiness of all things both in regard to substance and self-nature, it is necessary for Bodhisattvas to clearly understand that all things are un-born. It is not asserted that things are not born in a superficial sense, but that in a deep sense they are not born of themselves. All that can be said, is this, that relatively speaking, there is a constant stream of becoming, a momentary and uninterrupted change from one state of appearance to another. When it is recognized that the world as it presents itself is no more than a manifestation of mind, then birth is seen as no-birth, and all existing objects, concerning which discrimination asserts that they are and are not, are non-existent and, therefore, un-born; being devoid of agent and action things are un-born.

If things are not born of being and non-being, but are simply manifestations of mind itself, they have no reality, no self-nature: they are like the horns of a hare, a horse, a donkey, a camel. But the ignorant and simple-minded, who are given over to their false and erroneous imaginings, discriminate things where they are not. To the ignorant the characteristic marks of the self-nature of body-property-and-abode seem to be fundamental and rooted in the very nature of mind itself, so they discriminate their multitudinous-ness and become attached to them.

There are two kinds of attachment: attachment to objects as having a self-nature, and attachment to words as having self-nature. The first takes place by not knowing that the external world is only a manifestation of the mind itself; and the second arises from one’s clinging to words and names by reason of habit-energy. In the teaching of no-birth, causation is out of place because, seeing that all things are like Maya and a dream, one does not discriminate individual signs. That all things are un-born and have no self-nature because they are like Maya is asserted to meet the thesis of the philosophers that birth is by causation. They foster the notion that the birth of all things is derived from the concept of being and non-being, and fail to regard it as it truly is, as caused by attachments to the multitudinous-ness which arises from discriminations of the mind itself.

Those who believe in the birth of something that has never been in existence and, coming into existence, vanishes away, are obliged to assert that things come to exist and vanish away by causation – such people find no foothold in my teachings. When it is realized that there is nothing born, and nothing passes away, then there is no way to admit being and non-being, and the mind becomes quiescent.

Then Mahamati said to the Blessed One: The philosophers declare that the world rises from causal agencies according to the law of causation; they state that their cause is unborn and is not annihilated. They mention nine primary elements: Ishvara the Creator, the Creation, atoms, etc., which being elementary are unborn and not to be annihilated. The Blessed One, while teaching that all things are un-born and that there is no annihilation, also declares that the world takes its rise from ignorance, discrimination, attachment, deed, etc., working according to the law of causation. Though the two sects of elements may differ in form and name, there does not appear to be any essential difference between the two positions. If there is anything that is distinctive and superior in the Blessed One’s teaching, pray tell us, Blessed One, what is it?

The Blessed One replied: My teaching of no-birth and no-annihilation is not like that of the philosophers, nor is it like their doctrine of birth and impermanency. That to which the philosophers ascribe the characteristic of no-birth and no-annihilation is the self-nature of all things, which causes them to fall into the dualism of being and non-being. My teaching transcends the whole conception of being and non-being; it has nothing to do with birth, abiding and destruction; nor with existence and non-existence. I teach that the multitudinous-ness of objects have no reality in themselves but are only seen of the mind and, therefore, are of the nature of Maya and a dream. I teach the non-existence of things because they carry no signs of any inherent self-nature. It is true that in one sense they are seen and discriminated by the senses as individualized objects; but in another sense, because of the absence of any characteristic marks of self-nature, they are not seen but are only imagined. In one sense they are graspable, but in another sense, they are not graspable.

When it is clearly understood that there is nothing in the world but what is seen of the mind itself, discrimination no more rises, and the wise are established in their true abode, which is the realm of quietude. The ignorant discriminate and work trying to adjust themselves to external conditions, and are constantly perturbed in mind; unrealities are imagined and discriminated, while realities and unseen and ignored. It is not so with the wise. To illustrate: What the ignorant see is like the magically-created city of the Gandharvas, where children are shown, street and houses, and phantom merchants, and people going in and coming out. This imaginary city with its streets and houses and people going in and coming out, are not thought of as being born or being annihilated, because in their case there is no question as to their existence or non-existence. In like manner, I teach, that there is nothing made nor un-made; that there is nothing that has connection with birth and destruction except as the ignorant cherish falsely imagined notions as to the reality of the external world. When objects are not seen and judged as they truly are in themselves, there is discrimination and clinging to the notions of being and non-being, and individualized self-nature, and as long as these notions of individuality and self-nature persist, the philosophers are bound to explain the external world by a law of causation. This position raises the question of a first cause, which the philosophers meet by asserting that their first cause, Ishvara and the primal elements, are un-born and un-annihilate; which position is without evidence and is irrational.

Ignorant people and worldly philosophers cherish a kind of no-birth, but it is not the no-birth, which I teach. I teach the un-born-ness of the un-born essence of all things which teaching is established in the minds of the wise by their self-realization of Noble Wisdom. A ladle, clay, a vessel, a wheel, or seeds, or elements – these are external conditions; ignorance, discrimination, attachment, habit, karma, - these are inner conditions. When this entire universe is regarded as concatenation and as nothing else but concatenation, then the mind, by its patient acceptance of the truth that all things are un-born, gains tranquility.

Chapter IV

Perfect Knowledge or Knowledge of Reality

Then Mahamati asked the Blessed One: Pray tell us, Blessed One, about the five Dharmas, so that we may fully understand perfect knowledge?

The Blessed One replied: The five Dharmas are: appearance, name, discrimination, right-knowledge, and Reality. By appearance is meant that which reveals itself to the senses and to the discriminating-mind and is perceived as form, sound, odor, taste, and touch. Out of these appearances ideas are formed, such as clay, water, jar, etc., by which one says: this is such and such a thing and no other, this is name. When appearances are contrasted and names compared, as when we say: this is an elephant, this is horse, a cart, a pedestrian, a man, a woman, or, this is mind and what belongs to it, the things thus named are said to be discriminated. As these discriminations come to be seen as mutually conditioning, as empty of self-substance, as un-born, and thus come to be seen as they truly are, that is, as manifestations of the mind itself, this is right-knowledge. By it the wise cease to regard appearances and names as realities.

When appearances and names are put away and all discrimination ceases, that which remains is the true and essential nature of things and, as nothing can be predicated as to the nature of essence, it is called the "Suchness" of Reality. This universal, undifferentiated, inscrutable, "Suchness" is the only Reality, but it is variously characterized as Truth, Mind-essence, Transcendental Intelligence, Noble Wisdom, etc. This Dharma of the imageless-ness of the Essence-nature of Ultimate Reality is the Dharma, which has been proclaimed by all the Buddhas, and when all things are understood in full agreement with it, one is in possession of Perfect Knowledge, and is on his way to the attainment of the Transcendental Intelligence of the Tathágatas.

Then Mahamati said to the Blessed One: Are the three self-natures, of things, ideas, and Reality, to be considered as included in the Five Dharmas, or as having their own characteristics complete in themselves.

The Blessed One replied: The three self-natures, the eightfold mind-system, and the twofold ego-less-ness are all included in the Five Dharmas. The self-natures of things, of ideas, and of the six-fold mind-system, correspond with the Dharmas of appearance, name and discrimination; the self-nature of Universal Mind and Reality corresponds to the Dharmas of right-knowledge and "Suchness."

By becoming attached to what is seen of the mind itself, there is an activity awakened which is perpetuated by habit-energy that becomes manifest in the mind-system, from the activities of the mind-system there rises the notion of an ego-soul and its belongings; the discriminations, attachments, and notion of an ego-soul, rising simultaneously like the sun and its rays of light.

By the ego-less-ness of things is meant that the elements that make up the aggregates of personality and its objective world being characterized by the nature of Maya and destitute of anything that can be called self-substance are therefore un-born and have no self-nature. How can things be said to have an ego-soul? By the ego-less-ness of persons is meant is that in the aggregates that make up personality there is no ego-substance, nor anything that is like an ego-substance nor that belongs to it. The mind-system, which is the most characteristic mark of personality, originated in ignorance, discrimination, desire, and deed; and its activities are perpetuated by perceiving, grasping, and becoming attached to objects as if they were real. The memory of these discriminations, desires, attachments and deeds is stored in Universal Mind since beginning-less time, and is still being accumulated where it conditions the appearance of personality and its environment and brings about constant change and destruction from moment to moment. The manifestations are like a river, a seed, a lamp, a cloud, the wind; Universal mind in its voraciousness to store up everything, is like a monkey never at rest, like a fly ever in search of food and without partiality, like a fire that is never satisfied, like a water-lifting machine that goes on rolling. Universal mind as defiled by habit-energy is like a magician that causes phantom things and people to appear and move about. A thorough understanding of these things is necessary to an understanding of the ego-less-ness of persons.

There are four kinds of Knowledge: Appearance-knowledge, relative-knowledge, perfect-knowledge, and Transcendental Intelligence. Appearance-knowledge belongs to the ignorant and simple-minded who are addicted to the notion of being and non-being, and who are frightened at the thought of being un-born. It is produced by the concordance of the triple combination and attaches itself to the multiplicities of objects; it is characterized by attainability and accumulation; it is subject to birth and destruction. Appearance-knowledge belongs to wordmongers who revel in discriminations, assertions, and negations.

Relative-knowledge belongs to the mind-world of the philosophers. It rises from the mind’s ability to consider the relations which appearances bear to each other and to the mind considering them, it rises from the minds ability to arrange, combine, and analyze these relations by its powers of discursive logic and imagination, by reason of which it is able to peer into the meaning and significance of things.

Perfect-knowledge (jnana) belongs to the world of the Bodhisattvas who recognize that all things are but manifestations of mind; who clearly understand the emptiness, the un-born-ness, the ego-less-ness of all things; and who have entered into an understanding of the Five Dharmas, the twofold ego-less-ness, and into the truth of imageless-ness. Perfect-knowledge differentiates the Bodhisattva stages, and is the pathway and entrance into the exalted state of self-realization of Noble Wisdom.

Perfect-knowledge belongs to the Bodhisattvas who are entirely free from the dualisms of being and non-being, no-birth and no-annihilation, all assertions and negations, and who, by reason of self-realization, have gained an insight into the truths of ego-less-ness and imageless-ness. They no longer discriminate the world as subject to causation: they regard the causation that rules the world as something like the fabled city of the Gandharvas. To them the world is like a vision and a dream, it is like the birth and death of a barren-woman’s child; to them there is nothing evolving and nothing disappearing.

The wise who cherish Perfect-knowledge, may be divided into three classes, disciples, masters and Arhats. Common disciples are separated fro masters as common disciples continue to cherish the notion of individuality and generality; masters rise from common disciples when, forsaking the errors of individuality and generality, they still cling to the notion of an ego-soul by reasons of which they go off by themselves into retirement and solitude. Arhats rise when the error of all discrimination is realized. Error being discriminated by the wise turns into Truth by virtue of the "turning-about" that takes place within the deepest consciousness. Mind, thus emancipated, enters into perfect self-realization of Noble Wisdom.

But, Mahamati, if you assert that there is such a thing as Noble Wisdom, it no longer holds good, because anything of which something is asserted thereby partakes of the nature of being and is thus characterized with the quality of birth. The very assertion: "All things are un-born" destroys the truthfulness of it. The same is true of the statements: "All things are empty", and "All things have no self-nature," both are untenable when put in the form of assertions. But when it is pointed out that all things are like a dream and a vision, it means that in one way they are perceived, and in another way they are not perceived; that is, in ignorance they are perceived but in Perfect-knowledge they are not perceived. All assertions and negations being thought-constructions are un-born. Even the assertion that Universal Mind and Noble Wisdom are Ultimate Reality, is thought construction and, therefore, is un-born. As "things" there is no Universal Mind, there is no Noble Wisdom; there is no Ultimate Reality. The insight of the wise who move about in the realm of imageless-ness and its solitude is pure. That is, for the wise all "things" are wiped away and even the state of imageless-ness ceases to exist.

Chapter V

The Mind System

Then Mahamati said to the Blessed One: Pray tell us, Blessed One, what is meant by the mind (citta)?

The Blessed One replied: All things of this world, be they seemingly good or bad, faulty or faultless, effect producing or not effect-producing, receptive or non-receptive, may be divided into two classes: evil out-flowings and the non out-flowing good. The five grasping elements that make up the aggregates of personality, namely, form, sensation, perception, discrimination, and consciousness, and that are imagined to be good and bad, have their rise in the habit-energy of the mind-system, they are the evil out-flowings of life. The spiritual attainments and the joys of the Samádhis and the fruitage of the Samapatis that come to the wise through their self-realization of Noble Wisdom and that culminate in their return and participation in the relations of the triple world are called the non out-flowing good.

The mind-system, which is the source of the evil out-flowings, consists of the five sense organs and their accompanying sense-minds (Vijnanas) all of which are unified in the discriminating-mind (manovijnana). There is an unending succession of sense-concepts flowing into this discriminating or thinking-mind, which combines them and discriminates them and passes judgment upon them as to their goodness or badness. Then follows aversion to or desire for them and attachment and deed; thus the entire system moves on continuously and closely bound together. But it fails to see and understand that what it sees and discriminates and grasps is only a manifestation of its own activity and has no other basis, and so the mind goes on erroneously perceiving and discriminating differences of forms and qualities, not remaining still even for a minute.

In the mind-system there are three modes of activity distinguishable: the sense-minds functioning while remaining in their original nature, the sense-minds as producing effects, and the sense-minds as evolving. By normal functioning the sense-minds grasp appropriate elements of their external world, by which sensation and perception arise at once and by degrees in every sense-organ and every sense-mind, in the pores of the skin, and even in the atoms that make up the body, by which the whole field is apprehended like a mirror reflecting objects, and not realizing that the external world itself is only a manifestation of mind. The second mode of activity produces effects by which these sensations react on the discriminating mind to produce perceptions, attractions, aversions, grasping, deed and habit. The third mode of activity has to do with the growth, development and passing of the mind-system, that is, the mind-system is in subjection to its own habit-energy accumulated from beginning-less time, as for instance: the "eye-ness" in the eye that predisposes it to grasp and become attached to multiple forms and appearances. In this way the activities of the evolving mind-system by reason of its habit-energy stirs up waves of objectivity in the face of Universal Mind, which in turn conditions the activities and evolvement of the mind-system. Appearances, perception, attraction, grasping, deed, habit, reaction, condition one another incessantly, and the functioning sense-minds, the discriminating-mind and Universal Mind are thus bound up together. Thus, by reason of discrimination of that which by nature Maya-like and unreal false-imagination and erroneous reasoning takes place, action follows and its habit-energy accumulates thereby defiling the pure face of Universal Mind, and as a result the mind-system comes into functioning and the physical body has its genesis. But the discriminating-mind has no thought that by its discriminations and attachments it is conditioning the whole body and so the sense-minds and the discriminating-mind go on mutually related and mutually conditioned in a most intimate manner and building up a world of representations out of the activities of its own imagination. As a mirror reflects forms, the perceiving senses perceive appearances which the discriminating-mind gathers together and proceeds to discriminate, to name and become attached to. Between these two functions there is no gap, nevertheless, they are mutually conditioning. The perceiving senses grasp that for which they have an affinity, and there is a transformation takes place in their structure by reason of which the mind proceeds to combine, discriminate, apprise, and act; then follows habit-energy and the establishing of the mind and its continuance.

The discriminating-mine because of its capacity to discriminate, judge, select and reason about, is also called the thinking-mind, or intellectual-mind. There are three divisions of its mental activity: mentation which functions in connection with attachment to objects and ideas, mentation that functions in connection with general ideas, and mentation that examines into the validity of these general ideas. The mentation, which functions in connection with attachment to objects and ideas derived from discrimination, discriminates the mind from its mental processes and accepts the ideas from it as being real and becomes attached to them. A variety of false judgments are thus arrived at as to being, multiplicity, individuality, value, etc., a strong grasping takes place which is perpetuated by habit-energy and thus discrimination goes on asserting itself.

These mental processes give rise to general conceptions of warmth, fluidity, motility, and solidity, as characterizing the objects of discrimination, while the tenacious holding to these general ideas gives rise to proposition, reason, definition, and illustration, all of which lead to the assertions of relative knowledge and the establishment of confidence in birth, self-nature, and an ego-soul.

By mentation as an examining function is meant the intellectual act of examining into these general conclusions as to their validity, significance, and truthfulness. This is the faculty that leads to understanding, right-knowledge and points the way to self-realization.

Then Mahamati said to the Blessed One: Pray tell us, Blessed One, what relation ego-personality bears to the mind-system?

The Blessed One replied: To explain it, it is first necessary to speak of the self-nature of the five grasping aggregates that make up personality, although as I have already shown they are empty, un-born, and without self-nature. These five grasping aggregates are: form, sensation, perception, discrimination, consciousness. Of these, form belongs to what is made of the so-called primary elements, whatever they may be. The four remaining aggregates are without form and ought not to be reckoned as four, because they merge imperceptibly into one another. They are like space, which cannot be numbered; it is only due to imagination that they are discriminated and likened to space. Because things are endowed with appearances of being, characteristic-marks, perceivable-ness, abode, work, one can say that they are born of effect-producing causes, but this cannot be said of these four intangible aggregates for they are without form and marks. These four mental aggregates that make up personality are beyond calculability, they are beyond the four propositions, they are not to be predicated as existing or as not existing, but together they constitute what is known as mortal-mind. They are even more Maya-like and dream-like than are things, nevertheless, as discriminating mortal-mind they obstruct the self-realization of Noble Wisdom. But it is only by the ignorant that they are enumerated and thought of as an ego-personality; the wise do not do so. This discrimination of the five aggregates that make up personality and that serve as a basis for an ego-soul and ground for its desires and self-interests must be given up, and in its place the truth of image-less-ness and solitude should be established.

Then said Mahamati to the Blessed One: Pray tell us, Blessed One, about Universal Mind and its relation to the lower mind-system?

The Blessed One replied: The sense-minds and their centralized discriminating-mind are related to the external world, which is a manifestation of itself and is given over to perceiving, discriminating, and grasping its Maya-like appearances. Universal Mind (Alaya-Vijnana) transcends all individuation and limits. Universal Mind is thoroughly pure in its essential nature, subsisting unchanged and free from faults of impermanence, undisturbed by egoism, unruffled by distinctions, desires and aversions. Universal Mind is like a great ocean, its surface ruffled by waves and surges but its depths remaining forever unmoved. In itself it is devoid of personality and all that belongs to it, but by reason of the defilements upon its face it is like an actor and plays a variety of parts, among which a mutual functioning takes place and the mind-system arises. The principle of intellection becomes divided and mind the functions of mind, the evil out-flowings of mind, take on individuation. The sevenfold gradation of mind appears: namely, intuitive self-realization, thinking-desiring-discriminating, seeing, hearing, tasting, smelling, touching, and all their interactions and reactions take their rise.

The discriminating-mind is the cause of the sense-minds and is their support and with them is kept functioning as it describes and becomes attached to a world of objects, and then, by means of its habit-energy, it defiles the face of Universal Mind. Thus Universal Mind becomes the storage and clearinghouse of all the accumulated products of mentation and action since beginning-less time.

Between Universal Mind and the individual discriminating-mind is the intuitive-mind (manas), which is dependent upon Universal Mind for its cause and support and enters into relation with both. It partakes of the universality of Universal Mind, shares its purity, and like it, is above form and momentary-ness. It is through the intuitive-mind that the good non out-flowings emerge, are manifested and are realized. Fortunate it is that intuition is not momentary for if the enlightenment, which comes by intuition, were momentary the wise would loose their "wise-ness" which they do not. But the intuitive-mind enters into relations with the lower mind-system, shares its experiences and reflects upon its activities.

Intuitive-mind is one with Universal Mind by reason of its participation in Transcendental Intelligence (Arya-jnana), and is one with the mind-system by its comprehension of differentiated knowledge (Vijnana). Intuitive-mind has no body of its own nor any marks by which it can be differentiated. Universal Mind is its cause and support but it is evolved along with the notion of an ego and what belongs to it, to which it clings and upon which it reflects. Through intuitive-mind, by the faculty of intuition, which is a mingling of both identity and perceiving, the inconceivable wisdom of Universal Mind is revealed and made realizable. Like Universal Mind it cannot be the source of error.

The discriminating mind is a dancer and a magician with the objective world as his stage. Intuitive-mind is the wise jester who travels with the magician and reflects upon his emptiness and transiency. Universal Mind keeps the record and knows what must be and what may be. It is because of the activities of the discrimination mind that error rises and an objective world evolves and the nation of an ego soul becomes established. If and when the discriminating mind can be gotten rid of, the whole mind system will cease to function and universal Mind will alone remain. Getting rid of the discriminating mind removes the cause of all error.

Then said Mahamati to the Blessed One: Pray tell us, Blessed One, what is meant by the cessation of the mind-system?

The Blessed One replied: The five sense-functions and their discriminating and thinking function have their risings and complete ending from moment to moment. They are born with discrimination as cause, with form and appearance and objectivity closely linked together as condition. The will-to-live is the mother and ignorance is the father. By setting up names and forms greed is multiplied and thus the mind goes on mutually conditioning and being conditioned. By becoming attached to names and forms, not realizing that they have no more basis than the activities of the mind itself, error rises, false-imagination as to pleasure and pain rises, and the way to emancipation is blocked. The lower system of sense-minds and the discriminating-mind do not really suffer pleasure and pain – they only imagine they do. Pleasure and pain are the deceptive reactions of mortal-mind as it grasps an imaginary objective world.

There are two ways in which the ceasing of the mind-system may take place: as regards form, and as regards continuation. The sense organs function as regards form by the interaction of form, contact and grasping; and they cease to function when this contact is broken. As regards continuation, when these interactions of form, contact and grasping cease, there is no more continuation of the seeing, hearing and other sense functions; with the ceasing of these sense functions, the discriminations, grasping and attachments of the discriminating-mind cease; and with their ceasing act and deed and their habit-energy cease, and there is no more accumulation of karma-defilement on the face of Universal Mind.

If the evolving mortal-mind were of the same nature as Universal Mind the cessation of the lower mind-system would mean the cessation of Universal Mind, but they are different for Universal Mind is not the cause of mortal-mind. There is no cessation of Universal Mind in its pure and essence-nature. What ceases to function is not Universal Mind in its essence-nature, but is the cessation of the effect-producing defilements upon its face that have been caused by the accumulation of the habit-energy of the activities of the discriminating and thinking mortal-mind. There is no cessation of Divine Mind, which in itself, is the abode of Reality and the Womb of Truth.

By the cessation of the sense-minds is meant, not the cessation of their perceiving functions, but the cessation of their discriminating and naming activities, which are centralized, in the discriminating mortal-mind. By the cessation of the mind-system as a whole is meant, the cessation of discrimination, the clearing away of the various attachments, and, therefore, the clearing away of the defilements of habit-energy in the face of Universal Mind which have been accumulating since beginning-less time by reason of these discriminations, attachments, erroneous reasoning’s, and following acts. The cessation of the continuation aspect of the mind-system, namely, the discriminating mortal-mind the entire world of Maya and desire disappears. Getting rid of the discriminating mortal mind. With the cessation of mortal mind the entire world of Maya and desire disappears. Getting rid of the discriminating mortal-mind is Nirvana.

But the cessation of the discriminating-mind cannot take place until there has been a "turning-about" in the deepest seat of consciousness. The mental habit of looking outward by the discriminating-mind upon an external objective world must be given up, and a new habit of realizing Truth within the intuitive-mind by becoming one with the Truth itself must be established. Until this intuitive self-realization of Noble Wisdom is attained, the evolving mind-system will go on. But when an insight into the five Dharmas, the three self-natures, and the twofold ego-less-ness is attained, then the way will be opened for this "turning-about" to take place. With the ending of pleasure and pain, of conflicting ideas, of the disturbing interests of egoism, a state of tranquilization will be attained in which the truths of emancipation will be fully understood and there will be no further evil out-flowings of the mind-system to interfere with the perfect self-realization of Noble Wisdom.

Chapter VI

Transcendental Intelligence

Then said Mahamati: Pray tell us, Blessed One, what constitutes Transcendental Intelligence?

The Blessed One replied: Transcendental Intelligence is the inner state of self-realization of Noble Wisdom. It is realized suddenly and intuitively as the "turning-about" takes place in the deepest seat of consciousness; it neither enters nor goes out – it is like the moon seen in water. Transcendental Intelligence is not subject to birth or destruction; it has nothing to do with combination or concordance; it is devoid of attachment and accumulation; it transcends all dualistic concepts.

When Transcendental Intelligence is considered, four things must be kept in mind: words, meanings, teachings and Noble Wisdom (Arya-Prajna). Words are employed to express meanings but they are dependent upon discriminations and memory as cause, and upon the employment of sounds or letters by which a mutual transference of meaning is possible. Words are only symbols and may or may not clearly and fully express the meaning intended and, moreover, words may be understood quite differently from what was intended by the speaker. Words are neither different nor not different from meaning and meaning stands in the same relation to words.

If meaning is different from words it could not be made manifest by means of words; but meaning is illumined by words as things are by a lamp. Words are just like a man carrying a lamp to look for his property, by which he can say: this is my property. Just so, by means of words and speech originating in discrimination, the Bodhisattva can enter into the meaning of the teachings of the Tathágatas and through the meaning he can enter the exalted state of self-realization of Noble Wisdom, which, in itself, is free from word discrimination. But if a man becomes attached to the literal meaning of words and holds fast to the illusion that words and meaning are in agreement, especially in such things as Nirvana which is un-born and un-dying, or as to distinctions of the Vehicles, the five Dharmas, the three self-natures, then he will fail to understand the true meaning and will become entangled in assertions and refutations. Just as varieties of objects are seen and discriminated in dreams and in visions, so ideas and statements are discriminated erroneously and error goes on multiplying.

The ignorant and simple-minded declare that meaning is not otherwise than words that as words are, so is meaning. They think that as meaning has no body of its own that it cannot be different from words and, therefore, declare meaning to be identical to words. In this they are ignorant of the nature of words, which are subject to birth and death, whereas meaning is not; words are dependent upon letters and meaning is not; meaning is apart from existence and non-existence, it has no substratum, it is un-born. The Tathágatas do not teach a Dharma that is dependent upon letters. Anyone who teaches a doctrine that is dependent upon letters and words is a mere prattler, because Truth is beyond letters and words and books.

This does not mean that letters and books never declare what is in conformity with meaning and truth, but it means that words and books are dependent upon discriminations, while meaning and truth are not; moreover, words and books are subject to the interpretation of individual minds, while meaning and truth are not. But if Truth were not expressed in words and books, the scriptures, which contain the meaning of Truth, would disappear, and when the scriptures disappear there will be no more disciples and masters and Bodhisattvas and Buddhas, and there will nothing to teach. But no one must become attached to the words of the scriptures because even the canonical texts sometimes deviate from their straightforward course owing to the imperfect functioning of sentient minds. Religious discourses are given by myself and other Tathágatas in response to the varying needs and faiths of all manner of being, in order to free them from dependence upon the thinking function of the mind-system, but they are not given to take the place of the self-realization of Noble Wisdom. When there is recognition that there is nothing in the world but what is seen of the mind itself, all dualistic discriminations will be discarded and the truth of image-less-ness will be understood, and will be seen to be in conformity with the meaning rather than with words and letters.

The ignorant and simple-minded being fascinated with their self-imaginations and erroneous reasoning’s, keep on dancing and leap about, but are unable to understand the discourse by words about the truth of self-realization, much less are they able to understand the Truth itself. Clinging to the external world, they cling to the study of books which are a means only, and do not know properly how to ascertain the truth of self-realization, which is Truth unspoiled by the four propositions. Self-realization is an exalted state of inner attainment which transcends all dualistic thinking and which is above the mind-system with its logic, reasoning, theorizing, and illustrations. The Tathágatas discourse to the ignorant, but sustain Bodhisattvas as they seek self-realization of Noble Wisdom.

Therefore, let every disciple take good heed not to become attached to words as being in perfect conformity with meaning, because Truth is not in the letters. When a man with his finger-tip points to something to somebody, the finger-tip may be mistaken for the thing pointed at; in the like manner the ignorant and simple-minded, like children, are unable even to the day of their death to abandon the idea that the finger-tip of words there is meaning itself. They cannot realize Ultimate Reality because of their intent, clinging to words, which were intended to be no more than a pointing finger. Words and their discrimination bind one to the dreary round of rebirths into the world of birth-and-death; meaning stands alone and is a guide to Nirvana. Meaning is attained by much learning, and much learning is attained by becoming conversant with the meaning and not with words; therefore, let seekers for truth reverently approach those who are wise and avoid the sticklers for particular words.

As for teachings: there are priests and popular preachers who are given to ritual and ceremony and who are skilled in the various incantations and in the art of eloquence; they should not be honored nor reverently attended upon, for what one gains from them is emotional excitement and worldly enjoyment; it is not the Dharma. Such preachers, by their clever manipulation of words and phrases and various reasoning’s and incantations, being the mere prattle of a child, as far as one can make out and not at all in accordance with truth nor in unison with meaning, only serves to awaken sentient and emotion, while it stupefies the mind. As he himself does not understand the meaning of all things, he only confuses the minds of his hearers with his dualistic views. Not understanding himself, that there is nothing but what is seen of the mind, and himself attached to the notion of self-nature in external things, and unable to know one path from another, he has no deliverance to offer others. Thus these priests and popular preachers who are clever in various incantations and skilled in the art of eloquence, themselves never being emancipated from such calamities as birth, old age, disease, sorrow, lamentation, pain and despair, lead the ignorant into bewilderment by means of their various words, phrases, examples, and conclusions.

Then there are the materialistic philosophers. No respect nor service is to be shown to them because their teachings, though they may be explained using hundred of thousands of words and phrases, do not go beyond the concerns of this world and this body and in the end they lead to suffering. As the materialists recognize no truth as existing by itself, they are split up into many schools, each of which clings to its own way of reasoning.

But there is that which does not belong to materialism and which is not reached by the knowledge of the philosophers who cling to false-discriminations and erroneous reasoning’s because they fail to see that, fundamentally, there is no reality in external objects. When it is recognized that there is nothing beyond what is seen of the mind itself, the discrimination of being and non-being ceases and, as there is thus no external world of object of perception, nothing remains but the solitude of Reality. This does not belong to the materialistic philosophers; it is the domain of the Tathágatas. If such things are imagined as the coming and going of the mind-system, vanishing and appearing, solicitation, attachment, intense affection, a philosophic hypothesis, a theory, an abode, a sense-concept, atomic attraction, organism, growth, thirst, grasping, these things belong to materialism, they are not mine. These are things that are the object of worldly interest, to be sensed, handled and tasted; these are things that are the object of worldly interest, to be sensed, handled and tasted; these are the things that attract one, that bind one to the external world; these are the things that appear in the elements that make up the aggregates of personality where, owing to the procreative force of lust, there arise all kinds of disaster, birth, sorrow, lamentation, pain, despair, disease, old age, death. All these things concern worldly interests and enjoyment; they lie along the path of the philosophers, which is not the path of the dharma. When the true ego-less-ness of things and persons is understood, discrimination ceases to assert itself; the lower mind-system ceases to function; the various Bodhisattva stages are followed one after another; the Bodhisattva is able to utter his ten inexhaustible vows and is anointed by all the Buddhas. The Bodhisattva becomes master of himself and of all things by virtue of a life of spontaneous and radiant effortlessness. Thus the Dharma, which is Transcendental Intelligence, transcends all discriminations, all false-reasoning's, all philosophical systems, and all dualism.

Then Mahamati said to the Blessed One: In the Scriptures mention is made of the Womb of Tathágata-hood and it is taught that that which is born of it is by nature bright and pure, originally unspotted and endowed with the thirty-two marks of excellence. As it is described it is a precious gem but wrapped in a dirty garment soiled by greed, anger, folly and false-imagination. We are taught that this Buddha-nature immanent in everyone is eternal, unchanging, and auspicious. It is not this, which is born of the Womb of Tathágata-hood the same as the soul-substance that is taught by the philosophers? The Divine Atman as taught by them is also claimed to be eternal, inscrutable, unchanging, and imperishable. Is there, or is there not a difference?

The Blessed One replied: No, Mahamati, my Womb of Tathágata-hood is not the same as the Divine Atman as taught by the philosophers. What I teach is Tathágata-hood in the sense of Dharmakaya, Ultimate Oneness, Nirvana, emptiness, unborn-ness, unqualified ness, devoid of will-effort. The reason why I teach the doctrine of Tathágata-hood is to cause the ignorant and simple-minded to lay aside their fears as they listen to the teaching of ego-less-ness and come to understand the state of non-discrimination and imageless-ness. The religious teaching of the Tathágatas are just like a potter making various vessels by his own skill of hand with the aid of rod, water and thread, out of the one mass of clay, so the Tathágatas by their command of skillful means issuing from Noble Wisdom, by various terms, expressions, and symbols, preach the twofold ego-less-ness in order to remove the last trace of discrimination that is preventing disciples from attaining a self-realization of Noble Wisdom. The doctrine of the Tathágata-womb is disclosed in order to awaken philosophers from their clinging to the notion of a Divine Atman as transcendental personality, so that their minds that have become attached to the imaginary notion of "soul" as being something self-existent may be quickly awakened to a state of perfect enlightenment. All such notions as causation, succession, atoms, primary elements, that make up personality, personal soul, Supreme Spirit, Sovereign God, Creator, are all figments of the imagination and manifestations of mind. No, Mahamati, the Tathágata’s doctrine of the Womb of Tathágata-hood is not the same as the philosopher’s Atman.

The Bodhisattva is said to have well grasped the teaching of the Tathágatas when, all alone in a lonely place, by means of his Transcendental Intelligence, he walks the path leading to Nirvana. Thereon his mind will unfold by perceiving, thinking, meditating, and, abiding in the practice of concentration until he attains the "turning-about" at the source of habit-energy, he will thereafter lead a life of excellent deeds. His mind concentrated on the state of Buddhahood, he will become thoroughly conversant with the noble truth of self-realization; he will become perfect master of his own mind; he will be like a gem radiating many colors; he will be able to assume bodies of transformation; he will be able to enter into the minds of all to help them; and; finally, by gradually ascending the stages he will become established in the perfect Transcendental Intelligence of the Tathágatas.

Nevertheless, Transcendental Intelligence (Arya-jnana) is not Noble Wisdom (Arya-prajña) itself, only an intuitive awareness of it. Noble Wisdom is a perfect state of imageless-ness; it is the Womb of "Suchness;" it is the all-conserving Divine Mind (Alaya-Vijnana), which in its pure Essence forever abides in perfect patience and undisturbed tranquility.

Chapter VII

Self-Realization

Then said Mahamati: Pray tell us, Blessed One, what is the nature of Self-realization by reason of which we shall be able to attain Transcendental Intelligence?

The Blessed One Replied: Transcendental Intelligence rises when the intellectual-mind reaches its limit and, if things are to be realized in their true and essence nature, its processes of mentation, which are based on particularized ideas, discriminations and judgments, must be transcended by an appeal to some higher faculty of cognition, if there be such a higher faculty. There is such a faculty in the intuitive-mind (Manas), which as we have seen is the link between the intellectual-mind and Universal Mind. While it is not an individualized organ like the intellectual-mind, it has that which is much better, direct dependence upon Universal Mind. While intuition does not give information that can be analyzed and discriminated, it gives that which is far superior, self-realization through identification.

Mahamati then asked the Blessed One, saying: Pray tell us, Blessed One, what clear understandings an earnest disciple should have if he is to be successful in the discipline that leads to self-realization?

The Blessed One replied: There are four things by the fulfilling of which an earnest disciple may gain self-realization of Noble Wisdom and become and Bodhisattva-Mahasattva: First, he must have a clear understanding that all things are only manifestations of the mind itself; second, he must discard the notion of birth, abiding and disappearance; third, he must clearly understand the ego-less-ness of both things and persons; and fourth, he must have a true conception of what constitutes self-realization of Noble Wisdom, provided with these four understandings, earnest disciples may become Bodhisattvas and attain Transcendental Intelligence.

As to the first; he must recognize and be fully convinced that this triple world is nothing but a complex manifestation of one’s mental activities; that it is devoid of selfness and its belongings; that there are no strivings, no comings, no goings. He must recognize and accept the fact that this triple world is manifested and imagined as real only under the influence of habit-energy that has been accumulated since the beginning-less past by reason of memory, false-imagination, false-reasoning, and attachments to the multiplicities of objects and reactions in close relationship and in conformity to ideas of body-property-and-abode.

As the to second; he must recognize and be convinced that all things are to be regarded as forms seen in a vision and a dream, empty of substance, un-born and without self-nature; that all things exist only by reason of a complicated network of causation which owes its rise to the discrimination and attachment and which eventuates in the rise of the mind-system and its belongings and evolvements.

As to the third, he must recognize and patiently accept the fact that his own mind and personality is also mind-constructed, that it is empty of substance, unborn and ego-less. With these three things clearly in mind, the Bodhisattva will be able to enter into the truth of image-less-ness.

As to the fourth, he must have a true conception of what constitutes self-realization of Noble Wisdom. First, it is not comparable to the perceptions attained by the sense-mind, and neither is it comparable to the cognition of the discriminating and intellectual-mind. Both of these presuppose a difference between self and not self and the knowledge so attained is characterized by individuality and generality. Self-realization is based on identity and oneness; there is nothing to be discriminated nor predicated concerning it. But to enter into it the Bodhisattva must be free from all presuppositions and attachments to things, ideas and selfness.

Then said Mahamati to the Blessed One: Pray tell us, Blessed One, concerning the characteristics of deep attachments to existence and as to how we may become detached from existence?

The Blessed One replied: When one tries to understand the significance of things by means of words and discriminations, there follow immeasurably deep-seated attachments to existence. For instance: there are the deep-seated attachments to signs of individuality, to causation, to the notion of being and non-being, to the discrimination of birth and death, of doing and of not-doing, to the habit of discrimination itself upon which philosophers are so dependent.

There are three attachments that are especially deep-seated in the minds of all: greed, anger and infatuation, which are based on lust, fear and pride. Back of these lies discrimination and desire which is procreative and is accompanied with excitement, avariciousness, and love of comfort and desire for eternal life; and, following, is a succession of rebirths on the five paths of existence and a continuation of attachments. But if these attachments are broken off, no signs of attachment nor of detachment will remain because they are based on things that are non-existent; when this truth is clearly understood the net of attachment is cleared away.

But depending upon and attaching itself to the triple combination which works in unison there is the rising and the continuation of the mind-system incessantly functioning, and because of it there is the deeply-felt and continuous assertion of the will-to-live. When the triple combination that causes the functioning of the mind-system ceases to exist, there is the triple emancipation and there is no further rising of any combination. When the existence and the non-existence of the external world are recognized as rising from the mind itself, then the Bodhisattva is prepared to enter into the state of imageless ness and therein to see into the emptiness which characterizes all discrimination and all the deep-seated attachments resulting there from. Therein he will see no signs of deep-rooted attachment nor detachment; therein he will see no one in bondage and no one in emancipation, expect those who themselves cherish bondage and emancipation, because in all things there is no "substance" to be taken hold of.

But so long as these discriminations are cherished by the ignorant and simple-minded they go on attaching themselves to them and, like the silkworms, go on spinning their thread of discrimination and enwrapping themselves and others, and are charmed with their prison. But to the wise there are no signs of attachment nor of detachment; all things are seen as abiding in solitude where there is no evolving of discrimination. Mahamati, you and all the Bodhisattvas should have your abode where you can see all things from the viewpoint of solitude.

Mahamati, when you and the other Bodhisattvas understand well the distinction between attachment and detachment, you will be in possession of skillful means for avoiding becoming attached to words according to which one proceeds to grasp meanings. Free from the domination of words you will be able to establish yourselves where there will be a "turning-about" in the deepest seat of consciousness by means of which you will attain self-realization of Noble Wisdom and be able to enter into all the Buddha-lands and assemblies. There you will be stamped with the stamp of the powers, self-command, the psychic faculties, and will be endowed with the wisdom and the power of the ten inexhaustible vows, and will become radiant with the variegated rays of the Transformation Bodies. Therewith you will shine without effort like the moon, the sun, the magic wishing-jewel, and at every stage will view things as being of perfect oneness with yourself, uncontaminated by any self-consciousness. Seeing that all things are like a dream, you will be able to enter into the stage of the Tathágatas and be able to deliver the discourses on the Dharma to the world of beings in accordance with their needs and be able to free them from all dualistic notions and false discriminations.

Mahamati, there are two ways of considering self-realization: namely, the teachings about it, and the realization itself. The teachings as variously given in the nine divisions of the doctrinal works, for the instructions of those who are inclined toward it, by making use of skillful means and expedients, are intended to awaken in all beings a true perception of the Dharma. The teachings are designed to keep one away from all the dualistic notions of being and non-being and oneness and otherness.

Realization itself is within the inner consciousness. It is an inner experience that has no connection with the lower mind-system and its discriminations of words, ideas and philosophical speculations. It shines out with its own clear light to reveal the error and foolishness of mind-constructed teachings, to render impotent evil influences from without, and to guide one unerringly to the realm of the good non-out-flowings. Mahamati, when the earnest disciple and Bodhisattva is provided with these requirements, the way is open to his perfect attainment of self-realization of Noble Wisdom, and to the full enjoyment of the fruits that arise there from.

Then Mahamati asked the Blessed One, saying: Pray tell us, Blessed One, about the One Vehicle which the Blessed One has said characterizes the attainment of the inner self-realization of Noble Wisdom?

The Blessed One replied: In order to discard more easily discriminations and erroneous reasoning's, the Bodhisattva should retire by himself to a quiet, secluded place where he may reflect within himself without relying on anyone else, and there let him exert himself to make successive advances along the stages; this solitude is the characteristic feature of the inner attainment of self-realization of Noble Wisdom.

I call this the One Vehicle, not because it is the One Vehicle, but because it is only in solitude that one is able to recognize and realize the path of the One Vehicle. So long as the mind is distracted and is making conscious effort, there can be no culmination as regards the various vehicles; it is only when the mind is alone and quiet that it is able to forsake the discriminations of the external world and seek realization of an inner realm where there is neither vehicle nor one who rides in it. I speak of the three vehicles in order to carry the ignorant. I do not speak much about the One Vehicle because there is no way by which earnest disciples and masters can realize Nirvana, unaided. According to the discourses of the Tathágatas earnest disciples should be segregated, disciplined, and trained in meditation and Dhyana whereby they are aided by many devices and expedients to realize emancipation. It is because earnest disciples and masters have not fully destroyed the habit-energy of karma and the hindrances of discriminative knowledge and human passion that they are often unable to accept the twofold ego-less-ness and the inconceivable transformation death, that I preach the triple vehicle and not the One Vehicle. When earnest disciples have gotten rid of all their evil habit-energy and been able to realize the twofold ego-less-ness, then they will not be intoxicated by the bliss of the Samádhis and will be awakened into the super-realm of the good non-out-flowings. Being awakened into the realm of the good non-out-flowings, they will be able to gather up all the requisites for the attainment of Noble Wisdom, which is beyond conception and is of sovereign power. But really, Mahamati, there are no vehicles, and so I speak of the One Vehicle. Mahamati, the full recognition of the One Vehicle has never been attained by either earnest disciples, masters, or even by the great Brahma; it has been attained only by the Tathágatas themselves. That is the reason that it is known as the One Vehicle. I do not speak much about it because there is no way by which earnest disciples can realize Nirvana unaided.

Then Mahamati asked the Blessed One, saying: What are the steps that will lead an awakened disciple toward the self-realization of Noble Wisdom?

The Blessed One replied: The beginning lies in the recognition that the external world is only a manifestation of the activities of the mind itself, and that the mind grasps it as an external world simply because of its habit of discrimination and false reasoning. The disciple must get into the habit of looking at things truthfully. He must recognize the fact that the world has no self-nature that it is un-born, that it is like a passing cloud, like an imaginary wheel made by a revolving firebrand, like the castle of the Gandharvas, like the moon reflected in the ocean, like a vision, a mirage, a dream. He must come to understand that mind in its essence-nature has nothing to do with discrimination nor causation; he must not listen to discourses based on the imaginary terms and qualifications; he must understand that Universal Mind in its pure essence is a state of image-less-ness, that it is only because of the accumulated defilements on its face that body-property-and-abode appear to be its manifestations, that in its own pure nature it is unaffected and unaffecting by such changes as rising, abiding and destruction; he must fully understand that all these things come with the awakening of the notion of an ego-soul and its conscious mind. Therefore, Mahamati, let those disciples who wish to realize Noble Wisdom by following the Tathágata Vehicle desist from all discrimination and erroneous reasoning about such notions as the elements that make up the aggregates of personality and its sense-world or about such ideas as causation, rising, abiding and destruction, and exercise themselves in the discipline of Dhyana that leads to the realization of Noble Wisdom.

To practice Dhyana, the earnest disciple should retire to a quiet and solitary place, remembering that life-long habits of discriminative thinking cannot be broken off easily nor quickly. There are four kinds of concentrative meditation (Dhyana): The Dhyana practiced by the ignorant; the Dhyana devoted to the examination of meaning; the Dhyana with "Suchness" (Tathata) for its object; and the Dhyana of the Tathágatas.

The Dhyana practiced by the ignorant is the one resorted to by those who are following the example of the disciples and masters but who do not understand its purpose and, therefore, it becomes "still-sitting" with vacant minds. This Dhyana is practiced, also, by those who, despising the body, see it as a shadow and a skeleton full of suffering and impurity, and yet who cling to the notion of an ego, seek to attain emancipation by the mere cessation of thought.

The Dhyana devoted to the examination of meaning, is the one practiced by those who, perceiving the un-tenability of such ideas as self, other and both, which are held by the philosophers, and who have passed beyond the twofold-ego-less-ness, devote Dhyana to an examination of the significance of ego-less-ness and the differentiations of the Bodhisattvas stages.

The Dhyana with Tathata, or "Suchness", or Oneness, or Divine Name, for its object is practiced by those earnest disciples and masters who, while fully recognizing the twofold ego-less-ness and the imageless-ness of Tathata, yet cling to the notion of an ultimate Tathata.

The Dhyana of the Tathágatas is the Dhyana of those who are entering upon the stage of Tathágata-hood and who, abiding in the triple bliss, which characterizes the self-realization of Noble Wisdom, are devoting themselves for the sake of all beings to the accomplishment of incomprehensible works for their emancipation. This is the pure Dhyana of the Tathágatas. When all lesser things and ideas are transcended and forgotten, and there remains only a perfect state of imageless-ness where Tathágata and Tathata are merged into perfect Oneness, then the Buddhas will come together from all their Buddha-lands and with shining hands resting on his forehead will welcome a new Tathágata.

Chapter VIII

The Attainment of Self-Realization

Then said Mahamati to the Blessed One: Pray tell us more as to what constitutes the state of self-realization?

The Blessed One replied: In the life of an earnest disciple there are two aspects that are to be distinguished: namely, the state of attachment to the self-natures arising from discrimination of himself and his field of consciousness to which he is related; and second, the excellent and exalted state of self-realization of Noble Wisdom. The state of attachment to the discriminations of the self-natures of things, ideas, and selfhood is accompanied by emotions of pleasure or aversion according to experience or as laid down in books of logic. Conforming himself to the ego-less-ness of things and holding back wrong views as to his own ego-ness, he should abandon these thoughts and hold himself firmly to the continuously ascending journey of the stages.

The exalted state of self-realization as it relates to an earnest disciple is a state of mental concentration in which he seeks to identify himself with Noble Wisdom. In that effort he must seek to annihilate all vagrant thoughts and notions belonging to the externality of things, and all ideas of individuality and generality, of suffering and impermanence, and cultivate the noblest ideas of ego-less-ness and emptiness and imageless-ness; thus will he attain a realization of truth that is free from passion and is ever serene. When this active effort at mental concentration is successful it is followed by a more passive, receptive state of Samádhi in which the earnest disciple will enter into the blissful abode of Noble Wisdom and experience its consummations in the transformations of Samapatti. This is an earnest disciple’s first experience of the exalted state of realization, but as yet there is no discarding of habit-energy nor escaping from the transformation of death.

Having attained this exalted and blissful state of realization as far as it can be attained by disciples, the Bodhisattva must not give himself up to the enjoyment of its bliss, for that would mean cessation, but should think compassionately of other beings and keep ever fresh his original vows; he should never let himself rest nor exert himself in the bliss of the Samádhis.

But, Mahamati, as earnest disciples go on trying to advance on the path that leads to full realization, there is one danger against which they must be on their guard. Disciples may not appreciate that the mind-system, because of its accumulated habit-energy, goes on functioning, more or less unconsciously, as long as they live. They may sometimes think that they can expedite the attainment of their goal of tranquilization by entirely suppressing the activities of the mind-system. This is a mistake, for even if the activities of the mind are suppressed, the mind will still go on functioning because the seeds of habit-energy will still remain in it. What they think is extinction of mind, is really the non-functioning of the mind’s external world to which they are no longer attached. That is, the goal if tranquilization is to be reached not by suppressing all mind activity but by getting rid of discriminations and attachments.

Then there are others who, afraid of the suffering incident to the discriminations of life and death, unwisely seek Nirvana. They have come to see that all things subject to discrimination have no reality and so imagine that Nirvana must consist in the annihilation of the senses and their fields of sensation; they do not appreciate that birth-and-death and Nirvana are not separate one from the other. They do not know that Nirvana is Universal Mind in its purity. Therefore, these stupid ones who cling to the notion that Nirvana is a world by itself that is outside what is seen of the mind, ignoring all the teachings of the Tathágatas concerning the external world, go on rolling themselves along the wheel of birth-and-death. But when they experience the "turning-about" in their deepest consciousness, which will bring with it the perfect self-realization of Noble Wisdom, then they will understand.

The true functioning of the mind is very subtle and difficult to be understood by young disciples, even masters with all their powers of right-knowledge and Samádhis often find it baffling. It is only the Tathágatas and the Bodhisattvas who are firmly established on the seventh stage who can fully understand its workings. Those earnest disciples and masters who wish to fully understand all the aspects of the different stages of Bodhisattva-hood by the aid of their right-knowledge must do so by becoming thoroughly convinced that objects of discrimination are only seen to be so by the mind and, thus, by keeping themselves away from all discriminations and false reasoning’s which are also of the mind itself, by ever seeking to see things truly (yathabhutam), and by planting roots of goodness in Buddha-lands that know no limits made by differentiations.

To do all this, the Bodhisattva should keep himself away from all turmoil, social excitements and sleepiness; let him keep away from the treatises and writings of worldly philosophers, and from the ritual and ceremonies of professional priest-craft. Let him retire to a secluded place in the forest and there devote himself to the practice of the various spiritual disciplines, because it is only by so doing that he will become capable of attaining in this world of multiplicities a true insight into the workings of Universal Mind in its Essence. There surrounded by his good friends the Buddhas, earnest disciples will become capable of understanding the significance of the mind-system and its place as a mediating agent between the external world and the Universal Mind and he will become capable of crossing the ocean of birth-and-death, which rises from ignorance, desire and deed.

Having gained a thorough understanding of the mind-system, the three self-natures, the twofold ego-less-ness, and established himself in the measure of self-realization that goes with that attainment, all of which may be gained by his right-knowledge, the way will be clear for the Bodhisattva’s further advance along the stages of Bodhisattva-hood. The disciple should then abandon the understanding of mind which he has gained by right-knowledge, which in comparison with Noble Wisdom is like a lame donkey, and entering on the eighth stage of Bodhisattva-hood, he should then disciple himself in Noble Wisdom according to its three aspects.

These aspects are: First, imageless-ness, which comes forth when all things belonging to discipleship, mastership, and philosophy are thoroughly mastered. Second, the power added by all the Buddhas by reason of their original vows including the identification of their lives and the sharing of their merit with all sentient lives. Third, the perfect self-realization that thus far has only been realized in a measure, as the Bodhisattva succeeds in detaching himself from viewing all things, including his own imagined ego-ness, in their phenomenality, and realizes the states of Samádhi and Samapatti whereby he surveys the world as a vision and a dream, and being sustained by all the Buddhas, he will be able to pass on to the full attainment of the Tathágata stage, which is Noble Wisdom itself. This is the triplicity of the noble life and being furnished with this triplicity the perfect self-realization of Noble Wisdom has been attained.

Then Mahamati asked the Blessed One, saying: Blessed One, is the purification of the evil out-flowings of the mind which come from clinging to the notions of an objective world and an empirical soul, gradual or instantaneous?

The Blessed One replied: There are three characteristic out-flows of the mind, namely, the evil out-flowings that rise from thirst, grasping and attachment; the evil out-flowings that arise from the illusions of the mind and the infatuations of egoism; and the good non-out-flowings that arise from Noble Wisdom.

The evil out-flowings that take place from recognizing an external world, which in truth is only a manifestation of mind, and from becoming attached to it, are gradually purified and not instantaneously. Good behavior can only come by the path of restraint and effort. It is like a potter making pots that is done gradually and with attention and effort. It is like the mastery of comedy, dancing, singing, lute playing, writing, and any other art; it must be acquired gradually and laboriously. Its reward will be a clearing insight into the emptiness and transiency of all things.

The evil out-flowings that arise from the illusions of the mind and the infatuations of egoism, concerns the mental life more directly and are such things as fear, anger, hatred and pride; these are purified by study and meditation and that, too, must be attained gradually and not instantaneously. It is like the ‘amra’ fruit that ripens slowly; it is like grass, shrubs, herbs and trees that grow up from the earth gradually. Each must follow the path of study and meditation by himself gradually and with effort, but because of the original vows of the Bodhisattvas and all the Tathágatas who have devoted their merits and identified their lives with all animate life that all may be emancipated, they are not without aid and encouragement; but even with the aid of the Tathágatas, the purification of the evil out-flowings of the mind are at best slow and gradual, requiring both zeal and patience. Its reward is the gradual understanding of the twofold ego-less-ness and its patience acceptance, and the feet well set on the stages of Bodhisattva-hood.

But the good non-out-flowings that come with the self-realization of Noble Wisdom is a purification that comes instantaneously by the grace of the Tathágatas. It is like a mirror reflecting all forms and images instantaneously and without discrimination; it is like the sun or moon revealing all forms instantaneously and illuminating them dispassionately with its light. In the same way the Tathágatas lead earnest disciples to a state of imageless-ness; all the accumulations of habit-energy and karma that had been collecting since beginning-less time because of attachment to erroneous views which have been entertained regarding an ego-soul and its external world, are cleared away, revealing instantaneously the realm of Transcendental Intelligence that belongs to Buddhahood. Just as Universal Mind defiled by accumulations of habit-energy and karma reveals multiplicities of ego-souls and their external worlds of false-imagination, so Universal Mind cleared of its defilements through the gradual purifications of the evil out-flowings that come by effort, study and meditation, and by the gradual self-realization of Noble Wisdom, at the long last, like the Dharmata Buddha shining forth spontaneously with the rays that issue from its pure Self-nature, shines forth instantaneously. By it the mentality of all Bodhisattvas is matured instantaneously: they find themselves in the palatial abodes of the Akanishtha heavens, themselves spontaneously radiating the various treasures of its spiritual abundance.

Chapter IX

The Fruit of Self-Realization

Mahamati asked the Blessed One: Pray tell us, Blessed One, what is the fruitage that comes with the self-realization of Noble Wisdom?

The Blessed One replied: First, there will come a clearing insight into the meaning and significance of things and following that will come an unfolding insight into the significance of the spiritual ideals (Paramitas) by reason of which the Bodhisattvas will be able to enter more deeply into the abode of imageless-ness and be able to experience the higher Samádhis and gradually to pass through the higher stages of Bodhisattva-hood.

After experiencing the "turning-about" in the deepest seat of consciousness, they will experience other Samádhis even to the highest, the Vajravimbopama, which belongs to the Tathágatas and their transformations. They will be able to enter into the realm of consciousness that lies beyond the consciousness of the mind-system, even the consciousness of Tathágata-hood. They will become endowed with all the powers, psychic faculties, self-mastery, loving compassion, skillful means, and ability to enter into other Buddha-lands. Before they had attained self-realization of Noble Wisdom they had been influenced by the self-interests of egoism, but after they attain self-realization they will find themselves reacting spontaneously to the impulses of a great and compassionate heart endowed with skillful and boundless means and sincerely and wholly devoted to the emancipation of all beings.

Mahamati said: Blessed One, tell us about the sustaining power of the Tathágatas by which the Bodhisattvas are aided to attain self-realization of Noble Wisdom?

The Blessed One replied: There are two kinds of sustaining power, which issue from the Tathágatas and are at the service of the Bodhisattvas, sustained by which the Bodhisattvas should prostrate themselves before them and show their appreciation by asking questions. The first kind of sustaining power is the Bodhisattva’s own adoration and faith in the Buddhas by reason of which the Buddhas are able to manifest themselves and render their aid and to ordain them with their own hands. The second kind of sustaining power is the power radiating from the Tathágatas that enables the Bodhisattvas to attain and to pass through the various Samádhis and Samapattis without becoming intoxicated by their bliss.

Being sustained by the power of the Buddhas, the Bodhisattva even at the first stage will be able to attain the Samádhi known as the Light of Mahayana. In that Samádhi Bodhisattvas will become conscious of the presence of the Tathágatas coming from all their different abodes in the ten quarters to impart to the Bodhisattvas their sustaining power in various ways. As the Bodhisattva Vajragarbha was sustained in his Samádhis and as many other Bodhisattvas of like degree and virtue have been sustained, so all earnest disciples and masters and Bodhisattvas may experience this sustaining power of the Buddhas in their Samádhis and Samapattis. The disciple’s faith and the Tathágata’s merit are two aspects of the same sustaining power and by it alone are the Bodhisattvas enabled to become one with the company of the Buddhas.

Whatever Samádhis, psychic faculties and teachings are realized by the Bodhisattvas, they are made possible only by the sustaining power of the Buddhas; if it were otherwise, the ignorant and the simple-minded might attain the same fruitage. Wherever the Tathágatas enter with their sustaining power there will be music, not only music made by human lips and played by human hands on various instruments, but there will be music among the grass and shrubs and trees, and in the mountains and towns and palaces and hovels; much more will there be music in the heart of those endowed with sentiency. The deaf, dumb and blind will be cured of their deficiencies and will rejoice in their emancipation. Such is the extraordinary virtue of the sustaining power imparted by the Tathágatas.

By the bestowal of this sustaining power, the Bodhisattvas are enabled to avoid the evils of passion, hatred and enslaving karma; they are enabled to transcend the Dhyana of the beginners and to advance beyond the experience and truth already attained; they are enabled to demonstrate the Paramitas; and finally, to attain the stage of Tathágata-hood. Mahamati, if it were not for this sustaining power, they would relapse into the ways and thoughts of the philosophers, easy-going disciples and the evil-minded, and would thus fall short of the highest attainment. For these reasons, earnest disciples and sincere Bodhisattvas are sustained by the power of all the Tathágatas.

Then said Mahamati: It has been said by the Blessed One that by fulfilling the six Paramitas, Buddhahood is realized. Pray tell us what the Paramitas are, and how they are to be fulfilled?

The Blessed One replied: The Paramitas are ideals of spiritual perfection that are to be the guide of the Bodhisattvas on the path to self-realization. There are six of them but they are to be considered in three different ways according to the progress of the Bodhisattva on the stages. At first they are to be considered as ideals for the worldly life; next as ideals for the mental life; and, lastly, as ideals of the spiritual and unitive life.

In the worldly life where one is still holding tenaciously to the notions of an ego-soul and what concerns it and holding fast to the discriminations of dualism, if only for worldly benefits, one should cherish ideals of charity, good behavior, patience, zeal, thoughtfulness and wisdom. Even in the worldly life the practice of these virtues will bring rewards of happiness and success.

Much more in the mind-world of earnest disciples and masters will their practice bring joys of emancipation, enlightenment and peace of mind, because the Paramitas are grounded on right-knowledge and lead to thoughts of Nirvana, even if the Nirvana of their thoughts is for themselves. In the mind-world the Paramitas become more ideal and more sympathetic; charity can no longer be expressed in the giving of impersonal gifts but will call for the more costly gifts of sympathy and understanding; good behavior will call for something more than outward conformity to the five precepts because in the light of the Paramitas they must practice humility, simplicity, restraint and self-giving. Patience will call for something more than forbearance with external circumstances and the temperaments of other people: it will now call for patience with one’s self. Zeal will call for something more than industry and outward show of earnestness: it will call for more self-control in the task of following the Noble Path and in manifesting the Dharma in one’s own life. Thoughtfulness will give way to mindfulness wherein discriminated meanings and logical deductions and rationalizations will give way to intuitions of significance and spirit. The Paramita of Wisdom (Prajna) will no longer be concerned with pragmatic wisdom and erudition, but will reveal itself in its true perfect-ness of All-inclusive Truth, which is Love.

The third aspect of the Paramitas as seen in the ideal perfection of the Tathágatas can only be fully understood by the Bodhisattva-Mahasattvas who are devoted to the highest spiritual discipline and have fully understood that there is nothing to be seen in the world but that which issues from the mind itself; in whose minds the discrimination of dualities has ceased to function; and seizing and clinging has become non-existent. Thus free from all attachments to individual objects and ideas, their minds are free to consider ways of benefiting and giving happiness to others, even to all sentient beings. To the Bodhisattva-Mahasattvas the ideal of charity is shown in the self-yielding of the Tathágata’s hope of Nirvana that all may enjoy it together. While having relations with an objective world there is no rising in the minds of the Tathágatas of discriminations between the interests of self and the interests of others, between good and evil, there is just the spontaneity and effortless actuality of perfect behavior. To practice patience with full knowledge of this and that, of grasp and grasping, but with no thought of discrimination nor of attachment, that is the Tathágatas Paramita of Patience. To exert oneself with energy from the first part of the night to its end in conformity with the disciplinary measures with no rising of discrimination as to comfort or discomfort, that is the Tathágata’s Paramita of Zeal. Not to discriminate between self and others in thoughts of Nirvana, but to keep the mind fixed on Nirvana, that is the Paramita of Mindfulness. As to the Prajna-Paramita, which is Noble Wisdom, who can predicate it? When in Samádhi the mind ceases to discriminate and there is only perfect and love-filled imageless-ness, then an inscrutable "turning-about" will take place in the inmost consciousness and one will have attained self-realization of Noble Wisdom that is the highest Prajna-Paramita.

Then Mahamati said to the Blessed One: You have spoken of an astral-body, a "mind-vision-body" (manomayakaya) which the Bodhisattvas are able to assume, as being one of the fruits of self-realization of Noble Wisdom: pray tell us, Blessed One, what is meant by such a transcendental body?

The Blessed One replied: There are three kinds of such transcendental bodies: First, there is one in which the Bodhisattva attains enjoyment of the Samádhis and Samapattis. Second, there is the one, which is assumed by the Tathágatas according to the class of beings to be sustained, and which achieves and perfects spontaneously with no attachment and no effort. Third, there is the one in which the Tathágatas receive their intuition of Dharmakaya.

The transcendental personality that enters into the enjoyment of the Samádhis comes with the third, fourth and fifth stages as the mentations of the mind-system become quieted and waves of consciousness are no more stirred on the face of Universal Mind. In this state, the conscious-mind is still aware, in a measure, of the bliss being experienced by this cessation of the mind’s activities.

The second kind of transcendental personality is the kind assumed by Bodhisattvas and Tathágatas as bodies of transformation by which they demonstrate their original vows in the work of achieving and perfecting; it comes with the eighth stage of Bodhisattva-hood. When the Bodhisattva has a thoroughgoing penetration into the Maya-like nature of things and understands the dharma of imageless-ness, he will experience the "turning-about" in his deepest consciousness and will become able to experience the higher Samádhis even to the highest. By entering into these exalted Samádhis he attains a personality that transcends the conscious-mind, by reason of which he obtains supernatural powers of self-mastery and activities because of which he is able to move as he wishes, as quickly as a dream changes as quickly as an image changes in a mirror. This transcendental body is not a product of the elements and yet there is something in it that is analogous to what is so produced; it is furnished with all the differences appertaining to the world of form but without their limitations; possessed of this "mind-vision-body" he is able to be present in all the assemblages in all the Buddha-lands. Just as his thoughts move instantly and without hindrance over walls, rivers, trees, and mountains, and just as in memory he recalls and visits the scenes of his past experiences, so, while his mind keeps functioning in the body, his thoughts may be a hundred thousand yojanas away. In the same fashion the transcendental personality that experiences the Samádhi Vajravimbopama will be endowed with supernatural powers and psychic faculties and self-mastery by reason of which he will be able to follow the noble paths that lead to the assemblages of the Buddhas, moving about as freely as he may wish. But his wishes will no longer be self-centered nor tainted by discrimination and attachment, for this transcendental personality is not his old body, but is the transcendental embodiment of his original vows of self-yielding in order to bring all beings to maturity.

The third kind of transcendental personality is so ineffable that it is able to attain intuitions of the Dharmakaya, that is, it attains intuitions of the boundless and inscrutable cognition of Universal Mind. As Bodhisattva-Mahasattvas attain the highest of the stages and become conversant with all the treasures to be realized in Noble Wisdom, they will attain this inconceivable transformation-body which is the true nature of all the Tathágatas past, present and future, and will participate in the blissful peace which pervades the Dharma of all the Buddhas.

Chapter X

Discipleship: Lineage of the Arhats

Then Mahamati asked the Blessed One: Pray tell us how many kinds of disciples there are?

The Blessed One replied: There are as many kinds of disciples as there are individuals, but for convenience they may be divided into two groups: disciples of the lineage of the Arhats, and disciples known as Bodhisattvas. Disciples of the lineage of the Arhats may be considered under two aspects: First, according to the number of times they will return to this life of birth-and-death; and second, according to their spiritual progress. Under the first aspect, they may be subdivided into three groups: The "Stream-entered," the "Once-returning," and the "Never-returning."

The Stream-entered are those disciples, who having freed themselves from the attachments to the lower discriminations and who have cleansed themselves from the twofold hindrances and who clearly understand the meaning of the twofold ego-less-ness, yet who still cling to the notion of individuality and generality and to their own ego-ness. They will advance along the stages to the sixth only to succumb to the entrancing bliss of the Samádhis. They will be reborn seven times, or five times, or three times, before they will be able to pass the sixth stage. The Once-returning are the Arhats, and the Never-returning are the Bodhisattvas who have reached the seventh stage.

The reasons for these gradations is because of their attachment to the three degrees of false-imagination: namely, faith in moral practices, doubt, and the view of their individual personality. When these three hindrances are overcome, they will be able to attain the higher stages. As to moral practices: the ignorant, simple-minded disciples obey the rules of morality, piety and penance, because they desire thereby to gain worldly advancement and happiness, with the added hope of being reborn in more favorable conditions. The Stream-entered ones do not cling to moral practices for any hope of reward for their minds are fixed on the exalted state of self-realization; the reason they devote themselves to the details of morality is that they wish to master such truths as are in conformity with the undefiled out-flowings. As regards the hindrance of doubt in the Buddha’s teaching, that will continue so long as any of the notions of discrimination are cherished and will disappear when they disappear. Attachment to the view of individual personality will be gotten rid of as the disciple gains a more thorough understanding of the notions of being and non-being, self-nature and ego-less-ness, thereby getting rid of the attachments to his own selfness that goes with those discriminations. By breaking up and clearing away these three hindrances the Stream-entered one will be able to discard all greed, anger and folly.

As for the Once-returning Arhats; there was once in them the discrimination of form, signs, and appearances, but as they gradually learned by right-knowledge not to view individual objects under the aspect of quality and qualifying, and as they became acquainted with what marks the attainment of the practice of Dhyana, they have reached the stage of enlightenment where in one more rebirth they will be able to put an end to the clinging to their own self-interests. Free from this burden of error and its attachments, the passions will no more assert themselves and the hindrances will be cleared away forever.

Under the second aspect disciples may be grouped according to the spiritual progress they have attained, into four classes, namely, disciples (Sravaka), masters (Pratyekabuddha), Arhats, and Bodhisattvas.

The first class of disciples means well but they find it difficult to understand unfamiliar ideas. Their minds are joyful when studying about and practicing the things belonging to appearances that can be discriminated, but they become confused by the notion of an uninterrupted chain of causation, and they become fearful when they consider the aggregates that make up personality and its object world as being Maya-like, empty and ego-less. They were able to advance to the fifth or sixth stage where they are able to do away with the rising of passions, but not with the notions that give rise to passion and, therefore, they are unable to get rid of the clinging to an ego-soul and its accompanying attachments, habits and habit-energy. In this same class the disciples are the earnest disciples of other faiths, who clinging to the notions of such things as, the soul as an external entity, Supreme Atman, Personal God, seek a Nirvana that is in harmony with them. There are others, more materialistic in their ideas, who think that all things exist in dependence upon causation and, therefore, that Nirvana must be in like dependence. But none of these, earnest though they be, have gained an insight into the truth of the twofold ego-less-ness and are, therefore, of limited spiritual insights as regards deliverance and non-deliverance; for them there is no emancipation. They have great self-confidence but they can never gain a true knowledge of Nirvana until they have learned to disciple themselves in the patient acceptance of the twofold ego-less-ness.

The second class of masters are those who have gained a high degree of intellectual understanding of the truths concerning the aggregates that make up personality and its external world but who are filled with fear when they face the significance and consequences of these truths, and the demands which their learning makes upon them, that is, not to become attached to the external world and its manifold forms making for comfort and power, and to keep away from the entanglements of its social relations. They are attracted by the possibilities that are attainable by so doing, namely, the possession of miraculous powers such as dividing the personality and appearing in different places at the same time, or manifesting bodies of transformation. To gain these powers they even resort to the solitary life, but this class of master never gets beyond the seductions of their learning and egoism, and their discourses are always in conformity with that characteristic and limitation. Among them are many earnest disciples who show a degree of spiritual insight that is characterized by sincerity and undismayed willingness to meet all the demands that the stages make upon them. When they see that all that makes up the objective world is only a manifestation of mind, that it is without self-nature, un-born and ego-less, they accept it without fear, and when they see their own ego-soul is also empty, un-born and ego-less, they are untroubled and undismayed, with earnest purpose they seek to adjust their lives to the full demands of these truths, but they cannot forget the notions that lie back of these facts, especially the notion of their own conscious ego-self and its relation to Nirvana. They are of the Stream-entered class.

The class known as Arhats are those earnest masters who belong to the returning class. But their spiritual insight they have reached the sixth and seventh stages. They have thoroughly understood the truth of the twofold ego-less-ness and the imageless-ness of Reality; with them there is no more discrimination, nor passions, nor pride of egoism; they have gained an exalted insight and seen into the immensity of the Buddha-lands. By attaining an inner perception of the true nature of Universal Mind they are steadily purifying their habit-energy. The Arhats has attained emancipation, enlightenment, the Dhyanas, the Samádhis, and his whole attention is given to the attainment of Nirvana, but the idea of Nirvana causes mental perturbations because he has the wrong idea of Nirvana. The notions of Nirvana in his mind are divided: he discriminates Nirvana from self, and self from others. He has attained some of the fruits of self-realization but he still thinks and discourses on the Dhyanas, subjects for meditation, the Samádhis, the fruits. He pride-fully says: "There are fetters, but I am disengaged from them." His is a double fault: he both denounces the vices of the ego, and still cling to its fetters. So long as he continues to discriminate notions of Dhyana, Dhyana practice, subjects for Dhyana, right-knowledge and truth, there is a bewildered state of mind; he has not attained perfect emancipation. Emancipation comes with the acceptance of imageless-ness.

He is master of the Dhyanas and enters into the Samádhis, but to reach the higher stages one must pass beyond the Dhyanas, the immeasurables, the world of no-form, and the bliss of the Samádhis into the Samapattis leading to the cessation of thought itself. The Dhyana practitioner, Dhyana, the subject of Dhyana, the cessation of thought, once-returning, never-returning, all these are divided and bewildering states of mind. Not until all discrimination is abandoned is there perfect emancipation. Thus the Arhats, master of the Dhyanas, participating in the Samádhis, but unsupported by the Buddhas yields to the entrancing bliss of the Samádhis – and passes to his Nirvana.

Disciples and masters and Arhats may ascend the stages up to the sixth. They perceive that the triple world is no more than mind itself; they perceive that there is no becoming attached to the multiplicities of external objects except through the discriminations and activities of the mind itself; they perceive that there is no ego-soul; and, therefore, they attain a measure of tranquilization. But their tranquilization is not perfect every minute of their lives, for with them there is something effect producing, some grasped and grasping, some lingering trace of dualism and egoism. Though disengaged from the actively functioning passions they are still bound in with the habit energy of passion and, becoming intoxicated with the wine of the Samádhis, they will have their abode in the realm of the out-flowings. Perfect tranquilization is possible only with the seventh stage. So long as their minds are in confusion, they cannot attain to a clear conviction as to the cessation of all multiplicity and the actuality of the perfect oneness of all things. In their minds the self-nature of things is still discriminated as good and bad, therefore, their minds are in confusion and they cannot pass beyond the sixth stage. But at the sixth stage all discrimination ceases as they become engrossed in the bliss of the Samádhis wherein they cherish the thought of Nirvana and, as Nirvana is possible at the sixth stage, they pass into their Nirvana, but it is not the Nirvana of the Buddhas.

Chapter XI

Bodhisattva-hood and Its Stages

Then said Mahamati to the Blessed One: Will you tell us now about the disciples who are Bodhisattvas?

The Blessed One replied: The Bodhisattvas are those earnest disciples who are enlightened by reason of their efforts to attain self-realization of Noble Wisdom and who have taken upon themselves the task of enlightening others. They have gained a clear understanding of the truth that all things are empty, un-born, and of a Maya-like nature; they have ceased from viewing things discriminatively and from considering them in their relations; they thoroughly understand the truth of twofold ego-less-ness and have adjusted themselves to it with patient acceptance; they have attained a definite realization of image-less-ness; and they are abiding in the perfect-knowledge that they have gained by self-realization of Noble Wisdom.

Well stamped by the seal of "Suchness" they entered upon the first of the Bodhisattva stages. The first stage is called the stage of Joy (Pranudita). Entering this stage is like passing out of the glare of the shadows into a realm of "no-shadows"; it is like passing out of the noise and tumult of the crowded city into the quietness of solitude. The Bodhisattva feels within himself the awakening of a great heart of compassion and he utters his ten original vows: To honor and serve all Buddhas; to spread the knowledge and practice of the Dharma; to welcome all coming Buddhas; to practice the six Paramitas; to persuade all beings to embrace the Dharma; to attain a perfect understanding of the universe; to attain a perfect understanding of the mutuality of all beings; to attain perfect self-realization of the oneness of all the Buddhas and Tathágatas in self-nature, purpose and resources; to become acquainted with all skillful means for the carrying out of these vows for the emancipation of all beings; to realize supreme enlightenment through the perfect self-realization of Noble Wisdom, ascending the stages and entering Tathágata-hood.

In the spirit of these vows the Bodhisattva gradually ascends the stages to the sixth. All earnest disciples, masters and Arhats have ascended thus far, but being enchanted by the bliss of the Samádhis and not being supported by the powers of the Buddhas, they pass to their Nirvana. The same fate would befall the Bodhisattvas except for the sustaining power of the Buddhas, by that they are enabled to refuse to enter Nirvana until all beings can enter Nirvana with them. The Tathágatas point out to them the virtues of Buddhahood, which are beyond the conception of the intellectual-mind, and they encourage and strengthen the Bodhisattvas not to give in to the enchantment of the bliss of the Samádhis, but to press on to further advancement along the stages. If the Bodhisattvas had entered Nirvana at this stage, and they would have done so without the sustaining power of the Buddhas, there would have been the cessation of all things and the family of the Tathágatas would have become extinct.

Strengthened by the new strength that comes to them from the Buddhas and with more perfect insight that is theirs by reason of their advance in self-realization of Noble Wisdom, they re-examine the nature of the mind-system, the ego-less-ness of personality, and the part that grasping and attachment and habit-energy play in the unfolding drama of life; they re-examine the illusions of the fourfold logical analysis, and the various elements that enter into enlightenment and self-realization, and, in the thrill of their new powers of self-mastery, the Bodhisattvas enter upon the seventh stage of Far-going (Durangama).

Supported by the sustaining power of the Buddhas, the Bodhisattvas at this stage enter into the bliss of the Samádhi of perfect tranquilization. Owing to their original vows they are transported by emotions of love and compassion as they become aware of the part they are to perform in the carrying out of their vows for emancipation of all beings. Thus they do not enter into Nirvana, but, in truth, they too are already in Nirvana because in their emotions of love and compassion there is no rising of discrimination; henceforth, with them, discrimination no more takes place. Because of Transcendental Intelligence only one conception is present – the promotion of the realization of Noble Wisdom. This is called the Bodhisattva’s Nirvana – the losing oneself in the bliss of perfect self-yielding. This is the seventh stage, the stage of Far-going.

The eighth stage is the stage of No-recession (Acala). Up to this stage, because of the defilements upon the face of Universal Mind caused by the accumulation of habit-energy since beginning-less time, the mind-system and all that pertains to it has been evolved and sustained. The mind-system functioned by the discriminations of an external and objective world to which it became attached and by which it was perpetuated. But with the Bodhisattva’s attainment of the eighth stage there come a "turning-about" within his deepest seat of consciousness from self-centered egoism to universal compassion for all beings, by which he attains perfect self-realization of Noble Wisdom. There is an instant of cessation of the delusive activities of the whole mind-system; the dancing of the waves of habit-energy on the face of Universal Mind are forever stilled, revealing its own inherent quietness and solitude, the inconceivable Oneness of the Womb of Tathágata-hood.

Henceforth there is no more looking outward upon an external world by senses and sense-minds, nor a discrimination of particularized concepts and ideas and propositions by an intellectual-mind, no more grasping, nor attachment, nor pride of egoism, nor habit-energy. Henceforth there is only the inner experience of Noble Wisdom, which has been attained by entering into its perfect Oneness.

Thus establishing himself at the eighth stage of No-recession, the Bodhisattva enters into the bliss of the ten Samádhis, but avoiding the path of the disciples and masters who yielded themselves up to their entrancing bliss and who passed to their Nirvanas, and supported by his vows and the Transcendental Intelligence which now is his and being sustained by the power of the Buddhas, he enters upon the higher paths that lead to Tathágata-hood. He passes through the bliss of the Samádhis to assume the transformation body of a Tathágata that through him all beings may be emancipated. Mahamati, If there had been no Tathágata-womb and no Divine Mind then there would have been no rising and disappearance of the aggregates that make up personality and its external world, no rising and disappearance of ignorant people nor holy people, and no task for Bodhisattvas; therefore, while walking in the path of self-realization and entering into the enjoyments of the Samádhis, you must never abandon working hard for the emancipation of all beings and your self-yielding love will never be in vain. To philosophers the conception of Tathágata-womb seems devoid of purity and soiled by these external manifestations, but it is not so understood by the Tathágatas, to them it is not a proposition of philosophy but an intuitive experience as real as though it was an amalaka fruit held in the palm of the hand.

With the cessation of the mind-system and all its evolving discriminations, there is cessation of all strain and effort. It is like a man in a dream who imagines he is crossing a river and who exerts himself to the utmost to do so, who is suddenly awakened. Being awake, he thinks: "Is this real or is it unreal?" Being now enlightened he knows that it is neither real nor unreal. Thus when the Bodhisattva arrives at the eighth stage, he is able to see all things truthfully and, more than that, he is able to thoroughly understand the significance of all dream-like things of his life as to how they came to pass and as to how they pass away. Ever since beginning-less time the mind-system has perceived multiplicities of forms, conditions, and ideas, which the thinking-mind has discriminated, and the empirical-mind has experienced, grasped, and clung to. From this has risen habit-energy that by its accumulation has conditioned the illusions of existence and non-existence, individuality and generality, and has thus perpetuated the dream-state of false-imagination. But now, to the Bodhisattvas of the eighth stage, life is past and is remembered, as it truly was – a passing dream.

As long as the Bodhisattva had not passed the seventh stage, even though he had attained an intuitive understanding of the true meaning of life and its Maya-like nature, and as to how the mind carried on its discriminations and attachments yet, nevertheless, the cherishing of the notions of these things had continued and, although he no longer experienced within himself any ardent desire for things nor any impulse to grasp them yet, nevertheless, the notions concerning them persisted and perfumed his efforts to practice the teachings of the Buddhas and to labor for the emancipation of all beings. Now, in the eighth stage, even the notions have passed away, and all effort and striving is seen to be unnecessary. The Bodhisattva’s Nirvana is perfect tranquilization, but it is not extinction nor inertness; while there is an entire absence of discrimination and purpose, there is the freedom and spontaneity of potentiality that has come with the attainment and patient acceptance of the truths of ego-less-ness and imageless-ness. Here is perfect solitude, undisturbed by any gradation or continuous succession, but radiant with the potency and freedom of its self-nature, which is the self-nature of Noble Wisdom, blissfully peaceful with the serenity of Perfect Love.

Entering upon the eighth stage, with the "turning-about" at the deepest seat of consciousness, the Bodhisattva will become conscious that he has received the second kind of Transcendental-body (Manomayakaya). The transition from mortal-body to Transcendental-body has nothing to do with mortal death, for the old body continues to function and the old mind serves the needs of the old body, but now it is free from the control of mortal mind. There has been an inconceivable transformation-death (accintya-parinama-cyuti) by which the false-imagination of his particularized individual personality has been transcended by a realization of his oneness with the universalized mind of Tathágata-hood, from which realization there will be no recession. With that realization he finds himself amply endowed with all the Tathágata’s powers, psychic faculties, and self-mastery, and, just as the good earth is the support of all beings in the world of desire (karmadathu), so the Tathágatas become the support of all beings in the Transcendental World of No-form.

The first seven of the Bodhisattva stages were in the realm of mind and the eighth, while transcending mind, was still in touch with it; but in the ninth stage of Transcendental Intelligence (Sadhumati), by reason of his perfect intelligence and insight into the imageless-ness of Divine Mind which he had attained by self-realization of Noble Wisdom, he is in the realm of Tathágata-hood. Gradually the Bodhisattva will realize his Tathágata-nature and the possession of all its powers and psychic faculties, self-mastery, loving compassion, and skillful means, and by means of them will enter into all the Buddha-lands. Making use of these new powers, the Bodhisattva will assume various transformation-bodies and personalities for the sake of benefiting others. Just as in the former mental life, imagination had risen from relative-knowledge, so now skillful means rise spontaneously from Transcendental Intelligence. It is like the magical gem that reflects instantaneously appropriate responses to one’s wishes. The Bodhisattva passes over to all the assemblages of the Buddhas and listens to them as they discourse on the dream-like nature of all things and concerning the truths that transcend all notions of being and non-being, that have no relation to birth and death, nor to eternality nor extinction. Thus facing the Tathágatas as they discourse on Noble Wisdom that is far beyond the mental capacity of disciples and masters, he will attain a hundred thousand Samádhis, indeed, a hundred thousand Nayutas of kotis of Samádhis, and in the spirit of these Samádhis he will instantly pass from one Buddha-land to another, paying homage to all the Buddhas, being born into all the celestial mansions, manifesting Buddha-bodies, and himself discoursing on the Triple Treasure to lesser Bodhisattvas that they too may partake of the fruits of self-realization of Noble Wisdom.

Thus passing beyond the last stage of Bodhisattva-hood, he becomes a Tathágata himself endowed with all the freedom of the Dharmakaya. The tenth stage belongs to the Tathágatas. Here the Bodhisattva will find himself seated upon a lotus-like throne in a splendid jewel-adorned palace and surrounded by Bodhisattvas of equal rank. Buddhas from all Buddha-lands will gather about him and with their pure and fragrant hands resting on his forehead will give him ordination and recognition as one of themselves. Then they will assign him a Buddha-land that he may posses and perfect as his own.

The tenth stage is called the Great Truth Cloud (Dharmamegha), inconceivable, inscrutable. Only the Tathágatas can realize perfect Imageless-ness and Oneness and Solitude. It is Mahesvara, the Radiant Land, the Pure Land, the Land of Far-distances; surrounding and surpassing the lesser worlds of form and desire (karmadathu), in which the Bodhisattva will find himself ‘atonement.’ Its rays of Noble Wisdom which is the self-nature of the Tathágatas, many-colored, entrancing, auspicious, are transforming the triple world as other worlds have been transformed in the past, and still other worlds will be transformed in the future. But in the Perfect Oneness of Noble Wisdom there is no gradation nor succession nor effort. The tenth stage is the first, the first is the eighth, and the eighth is the fifth, the fifth the seventh: what gradation can there be where perfect Image-less-ness and Oneness prevail? And what is the reality of Noble Wisdom? It is the ineffable potency of the Dharmakaya; it has no bounds nor limits; it surpasses all the Buddha-lands, and pervades the Akanistha and the heavenly mansions of the Tushita (Heavens).

Chapter XII

Tathágata-hood, Which Is Noble Wisdom

Then said Mahamati to the Blessed One: It has been taught in the canonical books that the Buddhas are subject to neither birth nor destruction, and you have said that "the Un-born" is one of the names of the Tathágatas; does that mean that the Tathágata is a non-entity?

The Blessed One replied: The Tathágata is not a non-entity nor is he to be conceived as other things are as neither born nor disappearing, nor is he subject to causation, not is he without significance; yet I refer to him as "The Un-born." There is yet another name for the Tathágata. "The Mind-appearing One" (Manomayakaya) which his Essence-body assumes at will in the transformations incident to his work of emancipation. This is beyond the understanding of common disciples and masters and even beyond the full comprehension of those Bodhisattvas who remain in the seventh stage. Yes, Mahamati, "The Un-born" is synonymous with Tathágata.

Then Mahamati said: If the Tathágatas are un-born, there does not seem to be anything to take hold of – no entity – or is there something that bears another name than entity? And what can that "something" be?

The Blessed One replied: Objects are frequently known by different names according to different aspects that they present, the god Indra is sometimes known as Shakra, and sometimes as Purandara. These different names are sometimes used interchangeably and sometimes they are discriminated, but different objects are not to be imagined because of the different names, nor are they without individuation. The same can be said of myself as I appear in this world of patience before ignorant people and where I am known by uncounted trillions of names. They address me by different names not realizing that they are all names of the one Tathágata. Some recognize me as Tathágata, some as the self-existent one, some as Gautama the Ascetic, some as Buddha. Then there are others who recognize me as Brahma, as Vishnu, as Ishvara; some see me as Sun, as Moon; some as a reincarnation of the ancient sages; some as one of "ten powers"; some as Rama, some as Indra, and some as Varuna. Still there are others who speak of me as The Un-born, as Emptiness, as "Suchness," as Truth, as Reality, as Ultimate Principle; still there are others who see me as Dharmakaya, as Nirvana, as the Eternal; some speak of me as sameness, as non-duality, as un-dying, as formless; some think of me as the doctrine of Buddha-causation, or of Emancipation, or of the Noble Path; and some think of me as Divine Mind and Noble Wisdom. Thus in this world and in other worlds am I known by these uncounted names, but they all see me as the moon is seen in the water. Though they all honor, praise and esteem me, they do not fully understand the meaning and significance of the words they use; not having their own self-realization of Truth they cling to the words of their canonical books, or to what has been told to them, or to what they have imagined, and fail to see that the name they are using is only one of the many names of the Tathágata. In their studies they follow the mere words of the text vainly trying to gain the true meaning, instead of having confidence in the one "text" where self-confirming Truth is revealed, that is, having confidence in the self-realization of noble Wisdom.

Then said Mahamati: Pray tell us, Blessed One, about the self-nature of the Tathágatas?

The Blessed One replied: If the Tathágata is to be described by such expressions as made or un-made, effect or cause, we would have to describe him as neither made, nor un-made, nor effect, nor cause; but if we so described him we would be guilty of dualistic discrimination. If the Tathágata is something made, he would be impermanent; if he is impermanent anything made would be a Tathágata. If he is something un-made, then all effort to realize Tathágata-hood would be useless. That which is neither an effect or cause, is neither a being nor a non-being, and that which is neither a being nor non-being is outside the four propositions. The four propositions belong to worldly usage; that which is outside them is no more than a word, like a barren-woman’s child; so are all the terms concerning the Tathágata to be understood.

When it is said that all things are ego-less, it means that all things are devoid of self-hood. Each thing may have its own individuality—the being of a horse is not of cow nature—it is such as it is of its own nature and is thus discriminated by the ignorant, but, nevertheless, its own nature is of the nature of a dream or vision. That is why the ignorant and the simpleminded, who are in the habit of discriminating appearances, fail to understand the significance of ego-less-ness. It is not until discrimination is gotten rid of that the fact that all things are empty, un-born and without self-nature can be appreciated.

Mahamati, all these expressions as applied to the Tathágatas are without meaning, for that which is none of these is something removed from all measurement, and that which is removed from all measurement turns into a meaningless word; that which is a mere word is something un-born; that which is un-born is not subject to destruction; that which is not subject to destruction is like space and space is neither effect nor cause; that which is neither effect nor cause is something unconditioned; that which is unconditioned is beyond all reasoning; that which is beyond all reasoning, -- that is the Tathágata. The self-nature of Tathágata-hood is far removed from all predicates and measurements; the self-nature of Tathágata-hood is Noble Wisdom.

Then Mahamati said to the Blessed One: Are the Tathágatas permanent or impermanent?

The Blessed One replied: The Tathágatas are neither permanent nor impermanent; if either is asserted there is error connected with the creating agencies for, according to the philosophers, the creating agencies are something uncreated and permanent. But the Tathágatas are not connected with the so-called creating agencies and in that sense he is impermanent. If he is said to be impermanent then he is connected with things that are created for they also are impermanent. For these reasons the Tathágatas are neither permanent nor impermanent.

Neither can the Tathágatas be said to be permanent in the sense that space is said to be permanent, or that the horns of a hare can be said to be permanent for, being unreal, they exclude all ideas of permanency or impermanency. This does not apply to the Tathágatas because they come fourth from the habit-energy of ignorance, which is connected with the mind-system and the elements that make up personality. The triple world originates from the discrimination of unrealities and where discrimination takes place there is duality and the notion of permanency and impermanency, but the Tathágatas do not rise from the discrimination of unrealities. Thus, as long as there is discrimination there will be the notion of permanency and impermanency; when discrimination is done away with, Noble Wisdom, which is based on the significance of solitude, will be established.

However, there is another sense in which the Tathágatas may be said to be permanent. Transcendental Intelligence rising with the attainment of enlightenment is of a permanent nature. This Truth-essence, which is discoverable in the enlightenment of all who are enlightened, is realizable as the regulative and sustaining principle of Reality, which forever abides. The Transcendental Intelligence attained intuitively by the Tathágatas by their self-realization of Noble Wisdom, is a realization of their own self-nature, in this sense the Tathágatas are permanent. The eternal-unthinkable of the Tathágatas is the "Suchness" of noble Wisdom realized within themselves. It is both eternal and beyond thought. It conforms to the idea of a cause and yet is beyond existence and non-existence. Because it is the exalted state of Noble-Wisdom, it has its own character. Because it is the cause of highest Reality, it is its own causation. Its eternality is not derived from reasoning’s based on external notions of being and non-being, nor of eternality nor non-eternality. Being classed under the same head as space, cessation, Nirvana, it is eternal. Because it has nothing to do with existence and non- existence, it is no creator; because it has nothing to do with creation, nor with being and non-being, but is only revealed in the exalted state of noble Wisdom, it is truly eternal.

When the twofold passions are destroyed, and the twofold hindrances are cleared away, and the twofold ego-less-ness is fully understood, and the inconceivable transformation death of the Bodhisattva is attained – that which remains is the self-nature of the Tathágatas. When the teachings of the Dharma are fully understood and are perfectly realized by the disciples and masters that which is realized in their deepest consciousness is their own Buddha-nature revealed as Tathágata.

In a true sense there are four kinds of sameness relating to Buddha-nature: there is sameness of letters, sameness of words, sameness of meaning, and sameness of Essence. The name of the Buddha is spelt: B-U-D-D-H-A; the letters are the same when used for any Buddha or Tathágata. When the Brahmans teach they use various words, and when the Tathágatas teach they use the very same words; in respect to the words there is a same-ness between us. In the teachings of all the Tathágatas there is a same-ness of meaning. Among all the Buddhas there is a sameness of Buddha nature. They all have the thirty-two marks of excellence and the eighty minor signs of bodily perfection; there is no distinction among them except as they manifest various transformations according to the different dispositions of beings who are to be disciplined and emancipated by various means. In the Ultimate Essence, which is Dharmakaya, all the Buddhas of the past, present and future, are of one same-ness.

Then said Mahamati to the Blessed One: It has been said by the Blessed One that from the night of Enlightenment to the night of the Parinirvana, the Tathágata has uttered no word nor ever will utter a word. In what deep meaning is this true?

The Blessed One replied: By two reasons of deepest meaning is it true: In the light of Truth self-realized by Noble Wisdom, and in the Truth of an eternally abiding Reality. The self-realization of Noble Wisdom by all Tathágatas is the same as my own self-realization of Noble Wisdom; there is no more, no less, no difference, and all the Tathágatas bear witness that the state of self-realization is free from words and discriminations and has nothing to do with the dualistic way of speaking, that is, all beings receive the teachings of the Tathágatas through self-realization of Noble Wisdom, not though words of discrimination.

Again Mahamati, there has always been an eternally abiding reality. The "substance" of Truth (Dharmadhatu) abides forever whether a Tathágata appears in the world or not. So does the Reason of all things (dharmata) eternally abide; so does Reality (paramartha) abide and keep its order. What has been realized by myself and all other Tathágatas is this Reality (Dharmakaya), the eternally abiding self-orderliness of Reality; the "Suchness" (tathata) of all things; the realness of things (bhutata); Noble Wisdom, which is Truth itself. The sun radiates its splendor spontaneously on all alike and with no words of explanation; in like manner do the Tathágatas radiate the Truth of Noble Wisdom with no recourse to words and to all alike. For these reasons is it stated by me that from the night of enlightenment to the night of the Tathágata’s Parinirvana, he has not uttered, nor will he utter, one word. And the same is true of all the Buddhas.

Then said Mahamati: Blessed one, you speak of the sameness of all Buddhas, but in other places you have spoken of Dharmata-Buddha, Nishyanda-Buddha and Nirmana-Buddha as though they were different from each other; how can they be the same and yet different?

The Blessed One replied: I speak of the different Buddhas as opposed to the views of the philosophers who base their teachings on the reality of an external world of from and who cherish discrimination and attachments arising there from; against the teachings of these philosophers I disclose the Nirmana-Buddha, the Buddha of Transformations. In the many transformations of the Tathágata stage, the Nirmana-Buddha establishes such matters as charity, morality, patience, thoughtfulness, and tranquillization: by right-knowledge he teaches the true understanding of Maya-like nature of the elements that make up personality and its external world; he teaches the true nature of the mind-system as a whole and in the distinctions of its forms, functions and ways of performance. In a deeper sense, the Nirmana-Buddha symbolizes the principles of differentiation and integration by reason of which all component things are distributed, all complexities simplified, all thoughts analyzed; at the same time it symbolizes the harmonizing, unifying power of sympathy and compassion; it removes all obstacles, it harmonizes all differences, it brings into perfect Oneness the discordant many. For the emancipation of all beings the Bodhisattvas and Tathágatas assume bodies of transformation and employ many skilful devices, this is the work of the Nirmana-Buddha.

For the enlightenment of the Bodhisattvas and their sustaining along the stages, the Inconceivable is made realizable. The Nishyanda-Buddha, the "Out-flowing-Buddha," though Transcendental Intelligence, reveals the true meaning and significance of appearances, discrimination, attachment; and of the power of habit-energy which is accumulated by them and conditions them; and of the un-born-ness, the emptiness, the ego-less-ness of all things. Because of Transcendental Intelligence and the purification of the evil out-flowings of life, all dualistic views of existence and non existence are transcended and by self realization of Noble Wisdom the true image-less-ness of Reality is made manifest. The inconceivable glory of Buddhahood is made manifest in rays of Noble Wisdom; Noble Wisdom is the self-nature of the Tathágatas. This is the work of the Nishyanda-Buddha. In a deeper sense, the Nishyanda-Buddha symbolizes the emergence of the principles of intellection and compassion but as yet undifferentiated and in perfect balance, potential but un-manifest. Looked at from the in-going side of the Bodhisattva, Nishyanda-Buddha is seen in the glorified bodies of the Tathágatas; looked at from the fourth-going side of Buddhahood, Nishyanda-Buddha is seen in the radiant personalities of the Tathágatas ready and eager to manifest the inherent Love and Wisdom of the Dharmakaya.

Dharmata-Buddha is Buddhahood in its self-nature of perfect oneness in whom absolute Tranquility prevails. As noble Wisdom, Dharmata-Buddha transcends all differentiated knowledge, is the goal of intuitive self-realization, and is the self-nature of the Tathágatas. As Noble Wisdom, Dharmata-Buddha is the ultimate Principle of Reality from which all things derive their being and truthfulness, but which in itself transcends all predicates. Dharmata-Buddha is the central sun, which holds all, illumines all. Its inconceivable Essence is made manifest in the "out-flowing" glory of Nishyanda-Buddha and in the transformations of the Nirmana-Buddha.

Then said Mahamati: Pray tell us, Blessed One, more about the Dharmakaya?

The Blessed One replied: We have been speaking of it in terms of Buddhahood, but it is inscrutable and beyond predicate we may just as well speak of it as the Truth-body, or the Truth-principle of ultimate Reality (Paramartha). This Ultimate Principle of Reality may be considered as it is manifested under seven aspects: First, as Citta-gocara, it is the world of spiritual experience and the abode of the Tathágatas on their outgoing mission of emancipation. It is Noble Wisdom manifested as the principle of irradiancy and individuation. Second, as Jnana, it is the mind-world and its principle of the intellection and consciousness. Third as Dristi, it is the realm of dualism which is the physical world of birth and death wherein are manifested all the differentiations of thinker, thinking, and thought about and where-in are manifested the principles of sensation, perception, discrimination, desire, attachment and suffering.

Fourth, because of the greed, anger, infatuation, suffering and need of the physical world incident to discrimination and attachment, it reveals a world beyond the realm of dualism wherein it appears as the integrating principle of charity and sympathy. Fifth, in a realm still higher, which is the abode of the Bodhisattva stages, and is analogous to the mind-world, where the interests of heart transcend those of the mind, it appears as the principle of compassion and self-giving. Sixth, in the spiritual realm where the Bodhisattvas attain Buddhahood, it appears as the principle of perfect Love (Karuna). Here the last clinging to an ego-self is abandoned and the Bodhisattva enters into his self-realization of noble Wisdom, which is the bliss of the Tathágata’s perfect enjoyment of his inmost nature. Seventh as Prajna it is the active aspect of the Ultimate Principle wherein both the forth going and the in-coming principles are alike implicit and potential, and wherein both Wisdom and Love are in perfect balance, harmony and the Oneness.

These are the seven aspects of the ultimate Principle of the Dharmakaya, by reason of which all things are made manifest and perfected and then reintegrated, and all remaining within its inscrutable Oneness, with no signs of individuation, nor beginning, nor succession, nor ending, we speak of it as Dharmakaya, as Ultimate Principle, as Buddhahood, as Nirvana; what matters it? They are only other names for Noble-Wisdom.

Mahamati, you and all Bodhisattva-Mahasattvas should avoid the erroneous reasoning of the philosophers and seek for self-realization of Noble Wisdom.

Chapter XIII

Nirvana

Then said Mahamati to the Blessed One: Pray tell us about Nirvana?

The Blessed one replied: the term, Nirvana, is used with many different meanings, by different people, but these people may be divided into four groups: There are people who are suffering, or who are afraid of suffering, and who think of Nirvana; there are philosophers who try to discriminate Nirvana; there are the class of disciples who think of Nirvana in relation to themselves; and finally there is the Nirvana of the Buddhas.

Those who are suffering or who fear suffering, think of Nirvana as an escape and recompense. They imagine that Nirvana consists in the future annihilation of the senses and the sense-minds; they are not aware that universal mind and nirvana are one, and that this life-and-death world and Nirvana are not to be separated. These ignorant ones, instead of meditating on the image-less-ness of Nirvana, talk of different ways of emancipation. Being ignorant of, or not understanding, the teachings of the Tathágatas, they cling to the notion of Nirvana that is outside what is seen of the mind and, thus, go on rolling themselves along with the wheel of life and death.

As to the Nirvanas discriminated by the philosophers: there really are none. Some philosophers conceive Nirvana to be found where the mind-system no more operates owing to the cessation of the elements that make up personality and its world; or is found where there is utter indifference to the objective world and its impermanency. Some conceive Nirvana to be a state where there is no recollection of the past or present, just as when a lamp is extinguished, or when a seed is burnt, or when a fire goes out; because then there is the cessation of all the substrata, which is explained by the philosophers as the non-rising of discrimination. But this is not Nirvana, because Nirvana does not consist in simple annihilation and vacuity.

Again, some philosophers explain deliverance as though it was the mere stopping of discrimination, as when the wind stops blowing, or as when one by self-effort gets rid of the dualistic view of knower and known, or gets rid of the notions of permanency and impermanency; or gets rid of the notions of good and evil; or overcomes passion by means of knowledge--to them Nirvana is deliverance. Some, seeing in "form" the bearer of pain alarmed by the notion of "form" and look for happiness in a world of "no-form." Some conceive that in consideration of individuality and generality recognizable in all things inner and outer, that there is no destruction and that all beings maintain their being forever and, in this eternality, see Nirvana. Others see the eternally of things in the conception of Nirvana as the absorption of the finite-soul in the supreme Atman; or who see all things as a manifestation of the vital-force of some Supreme Sprit to which all return; and some, who are especially silly, declare that there are two primary things, a primary substance and a primary soul, that react differently upon each other and thus produce all things from the transformations of qualities; some think that the world is born of action and interaction and that no other cause is necessary; others think that Ishvara is free creator of all things; clinging to these foolish notions, there is no awakening, and they consider Nirvana to consist in the fact that there is no awakening.

Some imagine that Nirvana is where self-nature exists in its own right, unhampered by other self-natures, as the variegated feathers of a peacock, or
various precious crystals, or the pointed-ness of a thorn. Some conceive being to be Nirvana, some non-being, while others conceive that all things and Nirvana are not to be distinguished from one another. Some, thinking that time is the creator and that as the rise of the world depends on time; they conceive that Nirvana consists in the recognition of time as Nirvana. Some think that there will be Nirvana when the "twenty-five" truths are generally accepted, or when the king observes the six virtues, and some religionists think that Nirvana is the attainment of paradise.

These views severally advanced by the philosophers with their various seasonings are not in accord with logic nor are they acceptable to the wise. They all conceive Nirvana dualistically and in some causal connection; by these discriminations philosophers imagine Nirvana, but where there is no rising and no disappearing, how can there be discrimination? Each philosopher
relying on his own textbook from which he draws his understanding, sins against the truth, because truth is not where he imagines it to be. The only result is that it sets his mind to wandering about and becoming more confused as Nirvana is not to be found by mental searching, the more his mind becomes confused the more he confuses other people.

As to the notion of Nirvana as held by disciples and masters who still cling to the notion of an ego-self, and who try to find it by going off by themselves into solitude: their notion of Nirvana is an eternity of bliss like the bliss of the Samádhis-for themselves. They recognize that the world is only a manifestation of mind and that all discriminations are of the mind, and so they forsake social relations and practice various spiritual disciplines and in solitude seek self-realization of Noble Wisdom by self-effort. They follow the stages to the sixth and attain the bliss of the Samádhis, but as they are still clinging to egoism they do not attain the "turning-about" at the deepest seat of consciousness and, therefore, they are not free from the thinking-mind and the accumulation of its habit-energy. Clinging to the bliss of the Samádhis, they pass to their Nirvana, but it is not the Nirvana of the Tathágatas. They are of those who have "entered the stream"; they must return to this world of life and death.

Then said Mahamati to the Blessed One: When the Bodhisattvas yield up their stock of merit for the emancipation of all beings, they become spiritually one with all animate life; they themselves may be purified, but in others there yet remain unexhausted evil and un-matured karma. Pray tell us, Blessed One, how the Bodhisattvas are given assurance of Nirvana? And what is the Nirvana of the Bodhisattvas?

The Blessed One replied: Mahamati, this assurance is not an assurance of numbers nor logic; it is not the mind that is to be assured but the heart. The Bodhisattva’s assurance comes with the unfolding insight that follows passion hindrances cleared away, knowledge hindrance purified, and ego-less-ness clearly perceived and patiently accepted. As the mortal-mind ceases to discriminate, there is no more thirst for life, no more sex-lust, no more thirst for learning, no more thirst for eternal life; with the disappearance of these fourfold thirsts, there is no more accumulation of habit-energy; with no more accumulation of habit-energy the defilements on the face of the Universal Mind clear away, and the Bodhisattva attains self-realization of Noble Wisdom that is the heart’s assurance of Nirvana.

There are Bodhisattvas here and in other Buddha-lands, who are sincerely devoted to the Bodhisattva’s mission and yet who cannot wholly forget the bliss of the Samádhis and the peace of Nirvana-for themselves. The teaching of Nirvana in which there is no substrate left behind, is revealed according to a hidden meaning for the sake of these disciples who still cling to thoughts of Nirvana for themselves, that they may be inspired to exert themselves in the Bodhisattva’s mission of emancipation for all beings. The Transformation-Buddhas teach a doctrine of Nirvana to meet conditions as they find them, and to give encouragement to the timid and selfish. In order to turn their thoughts away from themselves and to encourage them to a deeper compassion and more earnest zeal for others, they are given assurance as to the future by the sustaining power of the Buddhas of Transformation, but not by the Dharmata-Buddha.

The Dharma, which establishes the Truth of Noble Wisdom, belongs to the realm of the Dharmata-Buddha. To the Bodhisattvas to the seventh and eighth stages, Transcendental Intelligence is revealed by the Dharmata-Buddha and the Path is pointed out to them, which they are to follow. In the perfect self-realization of Noble Wisdom that fallows the inconceivable transformation death of the Bodhisattva’s individualized will-control, he no longer lives unto himself, but the life that he lives thereafter is the Tathágata’s universalized life as manifested in its transformations. In this perfect self-realization of Noble Wisdom the Bodhisattva realizes that for the Buddhas there is no Nirvana.

The death of a Buddha, the great Parinirvana, is neither destruction nor death, else would it be birth and continuation. If it were destruction, it would be an effect-producing deed, which is not. Neither is it a vanishing nor abandonment, neither is it attainment, nor is it of no attainment; neither is it of one significance nor of no significance, for there is no Nirvana for the Buddhas.

The Tathágata’s Nirvana is where it is recognized that there is nothing but what is seen of the mind itself; is where, recognizing the nature of the self-mind, one no longer cherishes the dualisms of discrimination; is where there is no more thirst nor grasping; is where there is no more attachment to external things. Nirvana is where the thinking-mind with all its discriminations, attachments, aversions and egoism is forever put away; is where logical measures, as they are seen to be inert, are no longer seized upon; is where even the notion of truth is treated with indifference because of its causing bewilderment; is where, getting rid of the four propositions, there is insight into the abode of Reality. Nirvana is where the twofold passions have subsided and the twofold hindrances are cleared away and the twofold ego-less-ness is patiently accepted; is where, by the attainment of the "turning-about" in the deepest seat of consciousness, self-realization of Noble Wisdom is fully entered into, that is the Nirvana of the Tathágatas.

Nirvana is where the Bodhisattva stages are passed one after another; is where the sustaining power of the Buddhas upholds the Bodhisattvas in the bliss of the Samádhis; is where compassion for others transcends all thoughts of self; is where the Tathágata stage is finally realized.

Nirvana is the realm of the Dharmata-Buddha; it is where the manifestation of Noble Wisdom that is Buddhahood expresses itself in Perfect Love for all; it is where the manifestation of Perfect Love that is Tathágata-hood expresses itself in Noble Wisdom for the enlightenment of all- -there, indeed, is Nirvana!

There are two classes of those who may not enter the Nirvana of the Tathágatas: there are those who have abandoned the Bodhisattva ideals, saying, they are not in conformity with the sutras, the codes of morality, nor with emancipation. Then there are the true Bodhisattvas who, on account of their original vows made for the sake of all beings, saying, "So long as they do not attain Nirvana, I will not attain it for myself," voluntarily keep themselves out of Nirvana. But no beings are left outside by the will of the Tathágatas; some day each and every one will be influenced by the wisdom and love of the Tathágatas of Transformation to lay up a stock of merit and ascend the stages. But, if they only realized it, they are already in the Tathágata’s Nirvana for, in Noble Wisdom, all things are in Nirvana from the beginning.

The End


New Page 3

    No. 672
    新译大乘入楞伽经序
    御　制
    盖闻。摩罗山顶。既最崇而最严。楞伽城中。实难往而难入。先佛弘宣之地。曩圣修行之所。爰有城主。号罗婆那。乘宫殿以谒尊颜。奏乐音而祈妙法。因鬘峰以表兴。指藏海以明宗。所言入楞伽经者。斯乃诸佛心量之玄枢。群经理窟之妙键。广喻幽旨。洞明深义。不生不灭。非有非无。绝去来之二途。离断常之双执。以第一义谛。得最上妙珍。体诸法之皆虚。知前境之如幻。混假名之分别。等生死与涅槃。大慧之问初陈。法王之旨斯发。一百八义。应实相而离世间。三十九门。破邪见而宣政法。晓名相之并假。袪妄想之迷衿。依正智以会真如。悟缘起而归妙理。境风既息。识浪方澄。三自性皆空。二无我俱泯。入如来之藏。游解脱之门。原此经文。来自西国。至若。元嘉建号。跋陀之译未弘。延昌纪年。流支之义多舛。朕虔思付嘱。情切绍隆。以久视元年岁次庚子。林钟纪律炎帝司辰。于时避暑箕峰。观风颖水。三阳宫内。重出斯经。讨三本之要诠。成七卷之了教。三藏沙门于阗国僧实叉难陀大德。大福先寺僧复礼等。并名追安远。德契腾兰。袭龙树之芳猷。探马鸣之秘府。戒香与觉花齐馥。意珠共性月同圆。故能了达冲微。发挥奥赜。以长安四年正月十五日。缮写云毕。自惟菲薄言谢圭璋。顾四辩而多惭。瞻一乘而罔测。难违缁俗之请。强申翰墨之文。词拙理乖。弥增愧恧。伏以此经微妙。最为希有。所冀破重昏之暗。传灯之句不穷。演流注之功。涌泉之义无尽。题目品次列于后云

    大乘入楞伽经卷第一

大周于阗国三藏法师实叉难陀奉　敕译

    罗婆那王劝请品第一
    如是我闻。一时佛住大海滨摩罗耶山顶楞伽城中。与大比丘众及大菩萨众俱。其诸菩萨摩诃萨。悉已通达五法三性诸识无我。善知境界自心现义。游戏无量自在三昧神通诸力。随众生心现种种形方便调伏。一切诸佛手灌其顶。皆从种种诸佛国土而来此会。大慧菩萨摩诃萨为其上首。尔时世尊。于海龙王宫说法。过七日已从大海出。有无量亿梵释护世诸天龙等。奉迎于佛。尔时如来。举目观见摩罗耶山楞伽大城。即便微笑而作是言。昔诸如来应正等觉。皆于此城说自所得圣智证法。非诸外道臆度邪见及以二乘修行境界。我今亦当为罗婆那王开示此法。尔时罗婆那夜叉王。以佛神力闻佛言音。遥知如来从龙宫出。梵释护世天龙围绕。见海波浪。观其众会藏识大海境界风动转识浪起。发欢喜心。于其城中高声唱言。我当诣佛请入此城。令我及与诸天世人于长夜中得大饶益。作是语已。即与眷属乘花宫殿往世尊所。到已下殿右绕三匝。作众伎乐供养如来。所持乐器皆是大青因陀罗宝。琉璃等宝以为间错。无价上衣而用缠裹。其声美妙音节相和。于中说偈而赞佛曰
心自性法藏 无我离见垢
证智之所知 愿佛为宣说
善法集为身 证智常安乐
变化自在者 愿入楞伽城
过去佛菩萨 皆曾住此城
此诸夜叉众 一心愿听法
    尔时罗婆那楞伽王。以都咤迦音歌赞佛已。复以歌声而说颂言
世尊于七日 住摩竭海中
然后出龙宫 安详升此岸
我与诸婇女 及夜叉眷属
输迦娑剌那 众中聪慧者
悉以其神力 往诣如来所
各下花宫殿 礼敬世所尊
复以佛威神 对佛称己名
我是罗刹王 十首罗婆那
今来诣佛所 愿佛摄受我
及楞伽城中 所有诸众生
过去无量佛 咸升宝山顶
住楞伽城中 说自所证法
世尊亦应尔 住彼宝严山
菩萨众围绕 演说清净法
我等于今日 及住楞伽众
一心共欲闻 离言自证法
我念去来世 所有无量佛
菩萨共围绕 演说楞伽经
此入楞伽典 昔佛所称赞
愿佛同往尊 亦为众开演
请佛为哀愍 无量夜叉众
入彼宝严城 说此妙法门
此妙楞伽城 种种宝严饰
墙壁非土石 罗网悉珍宝
此诸夜叉众 昔曾供养佛
修行离诸过 证知常明了
夜叉男女等 渴仰于大乘
自信摩诃衍 亦乐令他住
惟愿无上尊 为诸罗刹众
瓮耳等眷属 往诣楞伽城
我于去来今 勤供养诸佛
愿闻自证法 究竟大乘道
愿佛哀愍我 及诸夜叉众
共诸佛子等 入此楞伽城
我宫殿婇女 及以诸璎珞
可爱无忧园 愿佛哀纳受
我于佛菩萨 无有不舍物
乃至身给侍 惟愿哀纳受
    尔时世尊闻是语已。即告之言。夜叉王。过去世中诸大导师。咸哀愍汝受汝劝请。诣宝山中说自证法。未来诸佛亦复如是。此是修行甚深观行现法乐者之所住处。我及诸菩萨哀愍汝故受汝所请。作是语已默然而住。时罗婆那王。即以所乘妙花宫殿奉施于佛。佛坐其上。王及诸菩萨前后导从。无量婇女歌咏赞叹。供养于佛往诣彼城。到彼城已。罗婆那王及诸眷属。复作种种上妙供养。夜叉众中童男童女。以宝罗网供养于佛。罗婆那王施宝璎珞奉佛菩萨以挂其颈。尔时世尊及诸菩萨受供养已。各为略说自证境界甚深之法。时罗婆那王并其眷属。复更供养大慧菩萨。而劝请言
我今诸大士 奉问于世尊
一切诸如来 自证智境界
我与夜叉众 及此诸菩萨
一心愿欲闻 是故咸劝请
汝是修行者 言论中最胜
是故生尊敬 劝汝请问法
自证清净法 究竟入佛地
离外道二乘 一切诸过失
    尔时世尊以神通力。于彼山中复更化作无量宝山。悉以诸天百千万亿妙宝严饰。一一山上皆现佛身。一一佛前皆有罗婆那王及其众会十方所有一切国土皆于中现。一一国中悉有如来。一一佛前咸有罗婆那王并其眷属。楞伽大城阿输迦园。如是庄严等无有异。一一皆有大慧菩萨而兴请问。佛为开示自证智境。以百千妙音说此经已。佛及诸菩萨皆于空中隐而不现。罗婆那王唯自见身住本宫中。作是思惟。向者是谁谁听其说所见何物是谁能见。佛及国城众宝山林。如是等物今何所在。为梦所作为幻所成。为复犹如乾闼婆城。为翳所见。为炎所惑。为如梦中石女生子。为如烟焰旋火轮耶。复更思惟。一切诸法性皆如是。唯是自心分别境界。凡夫迷惑不能解了。无有能见亦无所见。无有能说亦无所说。见佛闻法皆是分别。如向所见不能见佛。不起分别是则能见。时楞伽王寻即开悟。离诸杂染证唯自心。住无分别。往昔所种善根力故。于一切法得如实见。不随他悟。能以自智善巧观察。永离一切臆度邪解。住大修行为修行师。现种种身善达方便。巧知诸地上增进相。常乐远离心意意识。断三相续见离外道执着。内自觉悟入如来藏趣于佛地。闻虚空中及宫殿内咸出声言。善哉大王。如汝所学。诸修行者应如是学应如是见。一切如来应如是见。一切诸法若异见者则是断见。汝应永离心意意识。应勤观察一切诸法。应修内行莫着外见。莫堕二乘及以外道。所修句义所见境界。及所应得诸三昧法。汝不应乐戏论谈笑。汝不应起围陀诸见。亦不应着王位自在。亦不应住六定等中。若能如是。即是如实修行者行。能摧他论能破恶见。能舍一切我见执着。能以妙慧转所依识。能修菩萨大乘之道。能入如来自证之地。汝应如是勤加修学。令所得法转更清净。善修三昧三摩钵底。莫着二乘外道境界以为胜乐。如凡修者之所分别。外道执我见有我相。及实求那而生取着。二乘见有无明缘行。于性空中乱想分别。楞伽王此法殊胜是大乘道。能令成就自证圣智。于诸有中受上妙生。楞伽王。此大乘行破无明翳。灭识波浪不堕外道诸邪行中。楞伽王。外道行者执着于我。作诸异论不能演说离执着见识性二义。善哉楞伽王。汝先见佛思惟此义。如是思惟乃是见佛
    尔时罗婆那王。复作是念。愿我更得奉见如来。如来世尊于观自在。离外道法能说自证圣智境界。超诸应化所应作事。住如来定入三昧乐。是故说名大观行师。亦复名为大哀愍者。能烧烦恼分别薪尽。诸佛子众所共围绕普入一切众生心中。遍一切处具一切智。永离一切分别事相。我今愿得重见如来大神通力。以得见故。未得者得已得不退。离诸分别住三昧乐。增长满足如来智地
    尔时世尊。知楞伽王即当证悟无生法忍。为哀愍故便现其身。令所化事还复如本。时十头王见所曾睹。无量山城悉宝庄严。一一城中皆有如来应正等觉。三十二相以严其身。自见其身遍诸佛前。悉有大慧夜叉围绕说自证智所行之法。亦见十方诸佛国土。如是等事悉无有别
    尔时世尊普观众会。以慧眼观非肉眼观。如师子王奋迅回盻欣然大笑。于其眉间髀胁腰颈及以肩臂德字之中。一一毛孔皆放无量妙色光明。如虹拖晖如日舒光。亦如劫火猛焰炽然。时虚空中梵释四天。遥见如来坐如须弥楞伽山顶欣然大笑。尔时诸菩萨及诸天众咸作是念。如来世尊于法自在。何因缘故欣然大笑。身放光明默然不动。住自证境入三昧乐。如师子王周回顾视。观罗婆那念如实法
    尔时大慧菩萨摩诃萨。先受罗婆那王请。复知菩萨众会之心。及观未来一切众生。皆悉乐着语言文字。随言取义而生迷惑。执取二乘外道之行。或作是念。世尊已离诸识境界。何因缘故欣然大笑。为断彼疑而问于佛。佛即告言。善哉大慧。善哉大慧。汝观世间愍诸众生。于三世中恶见所缠。欲令开悟而问于我。诸智慧人为利自他。能作是问。大慧。此楞伽王。曾问过去一切如来应正等觉二种之义。今亦欲问。未来亦尔。此二种义差别之相。一切二乘及诸外道皆不能测。尔时如来知楞伽王欲问此义。而告之曰。楞伽王。汝欲问我宜应速问。我当为汝分别解释满汝所愿令汝欢喜。能以智慧思惟观察。离诸分别善知诸地。修习对治证真实义。入三昧乐为诸如来之所摄受。住奢摩他乐远离二乘三昧过失。住于不动善慧法云菩萨之地。能如实知诸法无我。当于大宝莲花宫中。以三昧水而灌其顶。复现无量莲花围绕。无数菩萨于中止住。与诸众会递相瞻视。如是境界不可思议。楞伽王。汝起一方便行住修行地。复起无量诸方便行。汝定当得如上所说不思议事。处如来位随形应物。汝所当得。一切二乘及诸外道梵释天等所未曾见
    尔时楞伽王。蒙佛许已。即于清净光明如大莲华宝山顶上。从座而起。诸婇女众之所围绕。化作无量种种色花。种种色香末香涂香。幢幡幰盖冠佩璎珞。及余世间未曾见闻种种胜妙庄严之具。又复化作欲界所有种种无量诸音乐器。过诸天龙乾闼婆等一切世间之所有者。又复化作十方佛土昔所曾见诸音乐器。又复化作大宝罗网。遍覆一切佛菩萨上。复现种种上妙衣服。建立幢幡以为供养。作是事已即升虚空高七多罗树。于虚空中复雨种种诸供养云。作诸音乐。从空而下。即坐第二日电光明如大莲花宝山顶上。欢喜恭敬而作是言。我今欲问如来二义。如是二义。我已曾问过去如来应正等觉。彼佛世尊已为我说。我今亦欲问于是义。唯愿如来为我宣说。世尊。变化如来说此二义。非根本佛。根本佛说三昧乐境。不说虚妄分别所行。善哉世尊于法自在。唯愿哀愍说此二义。一切佛子心皆乐闻
    尔时世尊告彼王言。汝应问。我当为汝说。时夜叉王。更着种种宝冠璎珞。诸庄严具以严其身。而作是言。如来常说。法尚应舍何况非法。云何得舍此二种法。何者是法何者非法。法若应舍云何有二。有二即堕分别相中。有体无体是实非实。如是一切皆是分别。不能了知阿赖耶识无差别相。如毛轮住非净智境。法性如是云何可舍。尔时佛告楞伽王言。楞伽王。汝岂不见瓶等无常败坏之法。凡夫于中妄生分别。汝今何故不如是知法与非法差别之相。此是凡夫之所分别非证智见。凡夫堕在种种相中。非诸证者。楞伽王。如烧宫殿园林见种种焰火性是一。所出光焰由薪力故。长短大小各各差别。汝今云何不如是知法与非法差别之相。楞伽王。如一种子生牙茎枝叶及以花果无量差别。外法如是内法亦然。谓无明为缘生蕴界处一切诸法。于三界中受诸趣生。有苦乐好丑语默行止各各差别。又如诸识相虽是一随于境界有上中下染净善恶种种差别。楞伽王。非但如上法有差别。诸修行者修观行时。自智所行亦复见有差别之相。况法与非法。而无种种差别分别。楞伽王。法与非法差别相者。当知悉是相分别故。楞伽王。何者是法。所谓二乘及诸外道。虚妄分别说有实等为诸法因。如是等法应舍应离。不应于中分别取相。见自心法性则无执着。瓶等诸物凡愚所取本无有体。诸观行人以毗钵舍那如实观察。名舍诸法。楞伽王。何者是非法。所谓诸法无性无相永离分别。如实见者。若有若无如是境界彼皆不起。是名舍非法。复有非法。所谓兔角石女儿等。皆无性相不可分别。但随世俗说有名字。非如瓶等而可取着。以彼非是识之所取。如是分别亦应舍离。是名舍法及舍非法。楞伽王汝先所问我已说竟。楞伽王。汝言我于过去诸如来所已问是义。彼诸如来已为我说。楞伽王。汝言过去但是分别未来亦然。我亦同彼。楞伽王。彼诸佛法皆离分别。已出一切分别戏论。非如色相唯智能证。为令众生得安乐故而演说法。以无相智说名如来。是故如来以智为体。智为身故不可分别。不可以所分别。不可以我人众生相分别。何故不能分别。以意识因境界起取色形相。是故离能分别。亦离所分别。楞伽王。譬如壁上彩画众生无有觉知。世间众生悉亦如是无业无报。诸法亦然无闻无说。楞伽王。世间众生犹如变化。凡夫外道不能了达。楞伽王。能如是见名为正见。若他见者名分别见。由分别故取着于二。楞伽王。譬如有人于水镜中自见其像。于灯月中自见其影。于山谷中自闻其响。便生分别而起取着。此亦如是。法与非法唯是分别。由分别故不能舍离。但更增长一切虚妄不得寂灭。寂灭者所谓一缘。一缘者是最胜三昧。从此能生自证圣智。以如来藏而为境界

    大乘入楞伽经集一切法品第二之一
    尔时大慧菩萨摩诃萨与摩帝菩萨。俱游一切诸佛国土。承佛神力从座而起。偏袒右肩右膝着地。向佛合掌曲躬恭敬而说颂言
世间离生灭 譬如虚空花
智不得有无 而兴大悲心
一切法如幻 远离于心识
智不得有无 而兴大悲心
世间恒如梦 远离于断常
智不得有无 而兴大悲心
知人法无我 烦恼及尔焰
常清净无相 而兴大悲心
佛不住涅槃 涅槃不住佛
远离觉不觉 若有若非有
法身如幻梦 云何可称赞
知无性无生 乃名称赞佛
佛无根境相 不见名见佛
云何于牟尼 而能有赞毁
若见于牟尼 寂静远离生
是人今后世 离着无所见
    尔时大慧菩萨摩诃萨偈赞佛已。自说姓名
我名为大慧 通达于大乘
今以百八义 仰咨尊中上
    时世间解闻是语已。普观众会而说是言
汝等诸佛子 今皆恣所问
我当为汝说 自证之境界
    尔时大慧菩萨摩诃萨蒙佛许已。顶礼佛足以颂问曰
云何起计度 云何净计度
云何起迷惑 云何净迷惑
云何名佛子 及无影次第
云何刹土化 相及诸外道
解脱至何所 谁缚谁能解
云何禅境界 何故有三乘
彼以何缘生 何作何能作
谁说二俱异 云何诸有起
云何无色定 及与灭尽定
云何为想灭 云何从定觉
云何所作生 进去及持身
云何见诸物 云何入诸地
云何有佛子 谁能破三有
何处身云何 生复住何处
云何得神通 自在及三昧
三昧心何相 愿佛为我说
云何名藏识 云何名意识
云何起诸见 云何退诸见
云何姓非姓 云何唯是心
何因建立相 云何成无我
云何无众生 云何随俗说
云何得不起 常见及断见
云何佛外道 其相不相违
何故当来世 种种诸异部
云何为性空 云何刹那灭
胎藏云何起 云何世不动
云何诸世间 如幻亦如梦
干城及阳焰 乃至水中月
云何菩提分 觉分从何起
云何国土乱 何故见诸有
云何知世法 云何离文字
云何如空花 不生亦不灭
真如有几种 诸度心有几
云何如虚空 云何离分别
云何地次第 云何得无影
何者二无我 云何所知净
圣智有几种 戒众生亦然
摩尼等诸宝 斯并云何出
谁起于语言 众生及诸物
明处与伎术 谁之所显示
伽他有几种 长行句亦然
道理几不同 解释几差别
饮食是谁作 爱欲云何起
云何转轮王 及以诸小王
云何王守护 天众几种别
地日月星宿 斯等并是何
解脱有几种 修行师复几
云何阿阇梨 弟子几差别
如来有几种 本生事亦然
众魔及异学 如是各有几
自性几种异 心有几种别
云何唯假设 愿佛为开演
云何为风云 念智何因有
藤树等行列 此并谁能作
云何象马兽 何因而捕取
云何卑陋人 此并谁能作
云何六时摄 云何一阐提
女男及不男 此并云何生
云何修行进 云何修行退
瑜伽师有几 令人住其中
众生生诸趣 何形何色相
富饶大自在 此复何因得
云何释迦种 云何甘蔗种
仙人长苦行 是谁之教授
何因佛世尊 一切刹中现
异名诸色类 佛子众围绕
何因不食肉 何因令断肉
食肉诸众生 以何因故食
何故诸国土 犹如日月形
须弥及莲花 卍字师子像
何故诸国土 如因陀罗网
覆住或侧住 一切宝所成
何故诸国土 无垢日月光
或如花果形 箜篌细腰鼓
云何变化佛 云何为报佛
真如智慧佛 愿皆为我说
云何于欲界 不成等正觉
何故色究竟 离染得菩提
如来灭度后 谁当持正法
世尊住久如 正法几时住
悉檀有几种 诸见复有几
何故立毗尼 及以诸比丘
一切诸佛子 独觉及声闻
云何转所依 云何得无相
云何得世通 云何得出世
复以何因缘 心住七地中
僧伽有几种 云何成破僧
云何为众生 广说医方论
何故大牟尼 唱说如是言
迦叶拘留孙 拘那含是我
何故说断常 及与我无我
何不恒说实 一切唯是心
云何男女林 诃梨庵摩罗
鸡罗娑轮围 及以金刚山
如是处中间 无量宝庄严
仙人乾闼婆 一切皆充满
此皆何因缘 愿尊为我说
    尔时世尊。闻其所请大乘微妙诸佛之心最上法门。即告之言。善哉大慧。谛听谛听。如汝所问当次第说。即说颂言
若生若不生 涅槃及空相
流转无自性 波罗蜜佛子
声闻辟支佛 外道无色行
须弥巨海山 洲渚刹土地
星宿与日月 天众阿修罗
解脱自在通 力禅诸三昧
灭及如意足 菩提分及道
禅定与无量 诸蕴及往来
乃至灭尽定 心生起言说
心意识无我 五法及自性
分别所分别 能所二种见
诸乘种性处 金摩尼真珠
一阐提大种 荒乱及一佛
智所智教得 众生有无有
象马兽何因 云何而捕取
云何因譬喻 相应成悉檀
所作及能作 众林与迷惑
如是真实理 唯心无境界
诸地无次第 无相转所依
医方工巧论 伎术诸明处
须弥诸山地 巨海日月量
上中下众生 身各几微尘
一一刹几尘 一一弓几肘
几弓俱庐舍 半由旬由旬
兔毫与隙游 虮羊毛穬麦
半升与一升 是各几穬麦
一斛及十斛 十万暨千亿
乃至频婆罗 是等各几数
几尘成芥子 几芥成草子
复以几草子 而成于一豆
几豆成一铢 几铢成一两
几两成一斤 几斤成须弥
此等所应请 何因问余事
声闻辟支佛 诸佛及佛子
如是等身量 各有几微尘
火风各几尘 一一根有几
眉及诸毛孔 复各几尘成
如是等诸事 云何不问我
云何得财富 云何转轮王
云何王守护 云何得解脱
云何长行句 淫欲及饮食
云何男女林 金刚等诸山
幻梦渴爱譬 诸云从何起
时节云何有 何因种种味
女男及不男 佛菩萨严饰
云何诸妙山 仙闼婆庄严
解脱至何所 谁缚谁解脱
云何禅境界 变化及外道
云何无因作 云何有因作
云何转诸见 云何起计度
云何净计度 所作云何起
云何而转去 云何断诸想
云何起三昧 破三有者谁
何处身云何 云何无有我
云何随俗说 汝问相云何
及所问非我 云何为胎藏
及以余支分 云何断常见
云何心一境 云何言说智
戒种性佛子 云何称理释
云何师弟子 众生种性别
饮食及虚空 聪明魔施设
云何树行布 是汝之所问
何因一切刹 种种相不同
或有如箜篌 腰鼓及众花
或有离光明 仙人长苦行
或有好族姓 令众生尊重
或有体卑陋 为人所轻贱
云何欲界中 修行不成佛
而于色究竟 乃升等正觉
云何世间人 而能获神通
何因称比丘 何故名僧伽
云何化及报 真如智慧佛
云何使其心 得住七地中
此及于余义 汝今咸问我
如先佛所说 一百八种句
一一相相应 远离诸见过
亦离于世俗 言语所成法
我当为汝说 佛子应听受
    尔时大慧菩萨摩诃萨白佛言。世尊。何者是一百八句。佛言大慧。所谓生句非生句。常句非常句。相句非相句。住异句非住异句。刹那句非刹那句。自性句非自性句。空句非空句。断句非断句。心句非心句。中句非中句。缘句非缘句。因句非因句。烦恼句非烦恼句。爱句非爱句。方便句非方便句。善巧句非善巧句。清净句非清净句。相应句非相应句。譬喻句非譬喻句。弟子句非弟子句。师句非师句。种性句非种性句。三乘句非三乘句。无影像句非无影像句。愿句非愿句。三轮句非三轮句。摽相句非摽相句。有句非有句。无句非无句。俱句非俱句。自证圣智句非自证圣智句。现法乐句非现法乐句。刹句非刹句。尘句非尘句。水句非水句。弓句非弓句。大种句非大种句。算数句非算数句。神通句非神通句。虚空句非虚空句。云句非云句。巧明句非巧明句。伎术句非伎术句。风句非风句。地句非地句。心句非心句。假立句非假立句。体性句非体性句。蕴句非蕴句。众生句非众生句。觉句非觉句。涅槃句非涅槃句。所知句非所知句。外道句非外道句。荒乱句非荒乱句。幻句非幻句。梦句非梦句。阳焰句非阳焰句。影像句非影像句。火轮句非火轮句。乾闼婆句非乾闼婆句。天句非天句。饮食句非饮食句。淫欲句非淫欲句。见句非见句。波罗蜜句非波罗蜜句。戒句非戒句。日月星宿句非日月星宿句。谛句非谛句。果句非果句。灭句非灭句。灭起句非灭起句。医方句非医方句。相句非相句。支分句非支分句。禅句非禅句。迷句非迷句。现句非现句。护句非护句。种族句非种族句。仙句非仙句。王句非王句。摄受句非摄受句。宝句非宝句。记句非记句。一阐提句非一阐提句。女男不男句非女男不男句。味句非味句。作句非作句。身句非身句。计度句非计度句。动句非动句。根句非根句。有为句非有为句。因果句非因果句。色究竟句非色究竟句。时节句非时节句。树藤句非树藤句。种种句非种种句。演说句非演说句。决定句非决定句。毗尼句非毗尼句。比丘句非比丘句。住持句非住持句。文字句非文字句。大慧。此百八句。皆是过去诸佛所说(上正列中少二句应访寻)
    尔时大慧菩萨摩诃萨复白佛言。世尊。诸识有几种生住灭。佛言。大慧。诸识有二种生住灭。非臆度者之所能知。所谓相续生及相生。相续住及相住。相续灭及相灭。诸识有三相。谓转相业相真相。大慧。识广说有八。略则唯二。谓现识及分别事识。大慧。如明镜中现诸色像。现识亦尔。大慧。现识与分别事识。此二识无异相互为因。大慧。现识以不思议熏变为因。分别事识。以分别境界及无始戏论习气为因。大慧。阿赖耶识虚妄分别种种习气灭即一切根识灭。是名相灭。大慧。相续灭者。谓所依因灭及所缘灭即相续灭。所依因者。谓无始戏论虚妄习气。所缘者。谓自心所见分别境界。大慧。譬如泥团与微尘非异非不异。金与庄严具亦如是。大慧。若泥团与微尘异者。应非彼成而实彼成。是故不异。若不异者。泥团微尘应无分别。大慧。转识藏识若异者。藏识非彼因。若不异者。转识灭藏识亦应灭。然彼真相不灭。大慧。识真相不灭但业相灭若真相灭者藏识应灭。若藏识灭者。即不异外道断灭论。大慧。彼诸外道作如是说。取境界相续识灭。即无始相续识灭。大慧。彼诸外道说相续识从作者生。不说眼识依色光明和合而生。唯说作者为生因故。作者是何。彼计胜性丈夫自在时及微尘。为能作者。复次大慧。有七种自性。所谓集自性。性自性。相自性。大种自性。因自性。缘自性。成自性。复次大慧。有七种第一义。所谓心所行。智所行。二见所行。超二见所行。超子地所行。如来所行。如来自证圣智所行。大慧。此是过去未来现在一切如来应正等觉。法自性第一义心。以此心成就如来世间出世间最上法。以圣慧眼。入自共相种种安立。其所安立不与外道恶见共。大慧。云何为外道恶见。谓不知境界自分别现。于自性第一义。见有见无而起言说。大慧。我今当说。若了境如幻自心所现。则灭妄想三有苦及无知爱业缘。大慧。有诸沙门婆罗门。妄计非有及有于因果外显现诸物。依时而住。或计蕴界处依缘生住。有已即灭。大慧。彼于若相续若作用若生若灭若诸有若涅槃若道若业若果若谛。是破坏断灭论。何以故。不得现法故。不见根本故。大慧。譬如瓶破不作瓶事。又如燋种不能生牙。此亦如是。若蕴界处法已现当灭。应知此则无相续生。以无因故。但是自心虚妄所见。复次大慧。若本无有识三缘合生。龟应生毛沙应出油。汝宗则坏。违决定义。所作事业悉空无益。大慧。三合为缘是因果性可说为有。过现未来从无生有。此依住觉想地者。所有理教及自恶见熏习余气。作如是说。大慧。愚痴凡夫恶见所噬邪见迷醉。无智妄称一切智说。大慧。复有沙门婆罗门。观一切法。皆无自性。如空中云。如旋火轮。如乾闼婆城。如幻如焰。如水中月。如梦所见。不离自心。由无始来虚妄见故取以为外。作是观已断分别缘。亦离妄心所取名义。知身及物并所住处一切皆是藏识境界。无能所取及生住灭。如是思惟恒住不舍。大慧。此菩萨摩诃萨不久当得生死涅槃二种平等。大悲方便无功用行。观众生如幻如影从缘而起。知一切境界离心无得。行无相道渐升诸地住三昧境。了达三界皆唯自心。得如幻定绝众影像。成就智慧证无生法。入金刚喻三昧。当得佛身恒住如如。起诸变化力通自在。大慧。方便以为严饰游众佛国。离诸外道及心意识。转依次第成如来身。大慧。菩萨摩诃萨欲得佛身。应当远离蕴界处心因缘所作生住灭法戏论分别。但住心量观察三有无始时来妄习所起。思惟佛地无相无生自证圣法。得心自在无功用行。如如意宝随宜现身。令达唯心渐入诸地。是故大慧。菩萨摩诃萨于自悉檀应善修学

    大乘入楞伽经卷第一

    大乘入楞伽经卷第二
    大周于阗国三藏法师实叉难陀奉　敕译
    集一切法品第二之二
    尔时大慧菩萨摩诃萨复白佛言。世尊。唯愿为我说心意意识五法自性相众妙法门。此是一切诸佛菩萨。入自心境离所行相。称真实义诸佛教心。唯愿如来为此山中诸菩萨众。随顺过去诸佛。演说藏识海浪法身境界。尔时世尊告大慧菩萨摩诃萨言。有四种因缘眼识转。何等为四。所谓不觉自心现而执取故。无始时来取着于色虚妄习气故。识本性如是故。乐见种种诸色相故。大慧。以此四缘阿赖耶识如瀑流水。生转识浪。如眼识余亦如是。于一切诸根微尘毛孔眼等。转识或顿生。譬如明镜现众色像。或渐生。犹如猛风吹大海水。心海亦尔。境界风吹起诸识浪。相续不绝。大慧。因所作相非一非异。业与生相相系深缚。不能了知色等自性。五识身转。大慧。与五识俱。或因了别差别境相有意识生。然彼诸识不作是念。我等同时展转为因。而于自心所现境界。分别执着俱时而起。无差别相各了自境。大慧。诸修行者入于三昧。以习力微起而不觉知。但作是念。我灭诸识入于三昧。实不灭识而入三昧。以彼不灭习气种故。但不取诸境名为识灭。大慧。如是藏识行相微细。唯除诸佛及住地菩萨。其余一切二乘外道。定慧之力皆不能知。唯有修行如实行者。以智慧力了诸地相善达句义。无边佛所广集善根。不妄分别自心所见能知之耳。大慧。诸修行人宴处山林上中下修。能见自心分别流注。得诸三昧自在力通。诸佛灌顶菩萨围绕。知心意意识所行境界。超爱业无明生死大海。是故汝等应当亲近诸佛菩萨如。实修行大善知识。尔时世尊重说颂言
譬如巨海浪 斯由猛风起
洪波鼓溟壑 无有断绝时
藏识海常住 境界风所动
种种诸识浪 腾跃而转生
青赤等诸色 盐贝乳石蜜
花果日月光 非异非不异
意等七种识 应知亦如是
如海共波浪 心俱和合生
譬如海水动 种种波浪转
藏识亦如是 种种诸识生
心意及意识 为诸相故说
八识无别相 无能相所相
譬如海波浪 是则无差别
诸识心如是 异亦不可得
心能积集业 意能广积集
了别故名识 对现境说五
    尔时大慧菩萨摩诃萨以颂问曰
青赤诸色像 众生识显现
如浪种种法 云何愿佛说
    尔时世尊以颂答曰
青赤诸色像 浪中不可得
言心起众相 开悟诸凡夫
而彼本无起 自心所取离
能取及所取 与彼波浪同
身资财安住 众生识所现
是故见此起 与浪无差别
    尔时大慧复说颂言
大海波浪性 鼓跃可分别
藏识如是起 何故不觉知
    尔时世尊以颂答曰
阿赖耶如海 转识同波浪
为凡夫无智 譬喻广开演
    尔时大慧复说颂言
譬如日光出 上下等皆照
世间灯亦然 应为愚说实
已能开示法 何不显真实
    尔时世尊以颂答曰
若说真实者 彼心无真实
譬如海波浪 镜中像及梦
俱时而显现 心境界亦然
境界不具故 次第而转生
识以能了知 意复意谓然
五识了现境 无有定次第
譬如工画师 及画师弟子
布彩图众像 我说亦如是
彩色中无文 非笔亦非素
为悦众生故 绮焕成众像
言说则变异 真实离文字
我所住实法 为诸修行说
真实自证处 能所分别离
此为佛子说 愚夫别开演
种种皆如幻 所见不可得
如是种种说 随事而变异
所说非所应 于彼为非说
譬如众病人 良医随授药
如来为众生 随心应量说
世间依怙者 证智所行处
外道非境界 声闻亦复然
    复次大慧。菩萨摩诃萨若欲了知能取所取分别境界。皆是自心之所现者。当离愦闹昏滞睡眠初中后夜勤加修习。远离曾闻外道邪论及二乘法。通达自心分别之相
    复次大慧。菩萨摩诃萨住智慧心所住相已。于上圣智三相当勤修学。何者为三。所谓无影像相。一切诸佛愿持相。自证圣智所趣相。诸修行者获此相已。即舍跛驴智慧心相。入菩萨第八地。于此三相修行不舍。大慧。无影像相者。谓由惯习一切二乘外道相故而得生起。一切诸佛愿持相者。谓由诸佛自本愿力所加持故而得生起。自证圣智所趣相者。谓由不取一切法相成就如幻诸三昧身趣佛地智故而得生起。大慧。是名上圣智三种相。若得此相即到自证圣智所行之处。汝及诸菩萨摩诃萨应勤修学。尔时大慧菩萨摩诃萨知诸菩萨心之所念。承一切佛威神之力。白佛言。唯愿为说百八句差别所依圣智事自性法门。一切如来应正等觉。为诸菩萨摩诃萨堕自共相者。说此妄计性差别义门。知此义已。则能净治二无我观境照明诸地。超越一切二乘外道三昧之乐。见诸如来不可思议所行境界。毕竟舍离五法自性。以一切佛法身智慧。而自庄严入如幻境。住一切刹兜率陀宫色究竟天。成如来身。佛言。大慧。有一类外道。见一切法随因而尽。生分别解想兔无角。起于无见如兔角无。一切诸法悉亦如是。复有外道。见大种求那尘等诸物形量分位。各差别已执兔无角。于此而生牛有角想。大慧。彼堕二见不了唯心。但于自心增长分别。大慧。身及资生器世间等。一切皆唯分别所现。大慧。应知兔角离于有无。诸法悉然勿生分别。云何兔角离于有无。互因待故。分析牛角乃至微尘。求其体相终不可得。圣智所行远离彼见。是故于此不应分别
    尔时大慧菩萨摩诃萨复白佛言。世尊。彼岂不以妄见起相。比度观待妄计无耶。佛言。不以分别起相待以言无。何以故。彼以分别为生因故。以角分别为其所依。所依为因离异不异。非由相待显兔角无。大慧。若此分别异兔角者则非角因。若不异者因彼而起。大慧。分析牛角乃至极微求不可得。异于有角言无角者。如是分别决定非理。二俱非有谁待于谁若相待不成。待于有故言兔角无。不应分别。不正因故。有无论者执有执无二俱不成。大慧。复有外道。见色形状虚空分齐而生执着。言色异虚空起于分别。大慧。虚空是色随入色种。大慧。色是虚空。能持所持建立性故。色空分齐应如是知。大慧。大种生时自相各别。不住虚空中。非彼无虚空。大慧。兔角亦尔。观待牛角言彼角无。大慧。分柝牛角乃至微尘。又析彼尘其相不现。彼何所待而言无耶。若待余物彼亦如是。大慧。汝应远离兔角牛角虚空及色所有分别。汝及诸菩萨摩诃萨。应常观察自心所见分别之相。于一切国土为诸佛子说观察自心修行之法。尔时世尊即说颂言
心所见无有 唯依心故起
身资所住影 众生藏识现
心意及与识 自性五种法
二无我清净 诸导师演说
长短共观待 展转互相生
因有故成无 因无故成有
微尘分析事 不起色分别
唯心所安立 恶见者不信
外道非行处 声闻亦复然
救世之所说 自证之境界
    尔时大慧菩萨摩诃萨。为净心现流故而请佛言。世尊。云何净诸众生自心现流。为渐次净为顿净耶。佛言大慧。渐净非顿。如庵罗果渐熟非顿。诸佛如来净诸众生自心现流。亦复如是渐净非顿。如陶师造器渐成非顿。诸佛如来净诸众生自心现流。亦复如是渐而非顿。譬如大地生诸草木渐生非顿。诸佛如来净诸众生自心现流。亦复如是渐而非顿。大慧。譬如人学音乐书画种种伎术渐成非顿。诸佛如来净诸众生自心现流。亦复如是渐而非顿。譬如明镜顿现众像而无分别。诸佛如来净诸众生自心现流。亦复如是。顿现一切无相境界而无分别。如日月轮一时遍照一切色像。诸佛如来净诸众生自心过习。亦复如是。顿为示现不可思议诸佛如来智慧境界。譬如藏识顿现于身及资生国土一切境界。报佛亦尔。于色究竟天。顿能成熟一切众生令修诸行。譬如法佛顿现报佛及以化佛光明照曜。自证圣境亦复如是。顿现法相而为照曜。令离一切有无恶见。复次大慧。法性所流佛说一切法自相共相。自心现习气因相。妄计性所执因相。更相系属种种幻事皆无自性。而诸众生种种执着取以为实。悉不可得。复次大慧。妄计自性执着缘起自性起。大慧。譬如幻师以幻术力。依草木瓦石幻作众生若干色像。令其见者种种分别。皆无真实。大慧。此亦如是。由取着境界习气力故。于缘起性中。有妄计性种种相现。是名妄计性生。大慧。是名法性所流佛说法相。大慧。法性佛者。建立自证智所行。离心自性相。大慧。化佛说施戒忍进禅定智慧蕴界处法及诸解脱诸识行相。建立差别越外道见超无色行。复次大慧。法性佛非所攀缘。一切所缘一切所作相根量等相悉皆远离。非凡夫二乘及诸外道执着我相所取境界。是故大慧。于自证圣智胜境界相当勤修学。于自心所现分别见相当速舍离。复次大慧。声闻乘有二种差别相。所谓自证圣智殊胜相。分别执着自性相。云何自证圣智殊胜相。谓明见苦空无常无我诸谛境界。离欲寂灭故。于蕴界处若自若共外不坏相如实了知故心住一境。住一境已获禅解脱三昧道果而得出离。住自证圣智境界乐。未离习气及不思议变易死。是名声闻乘自证圣智境界相。菩萨摩诃萨虽亦得此圣智境界。以怜愍众生故。本愿所持故。不证寂灭门及三昧乐。诸菩萨摩诃萨于此自证圣智乐中不应修学。大慧。云何分别执着自性相。所谓知坚湿暖动青黄赤白如是等法非作者生。然依教理见自共相分别执着。是名声闻乘分别执着相。菩萨摩诃萨于此法中应知。应舍离人无我见入法无我相渐住诸地
    尔时大慧菩萨摩诃萨白佛言。世尊。如来所说常不思议自证圣智第一义境。将无同诸外道所说常不思议作者耶。佛言。大慧。非诸外道作者得常不思议。所以者何。诸外道常不思议因自相。不成。既因自相不成。以何显示常不思议。大慧。外道所说常不思议。若因自相成彼则有常。但以作者为因相故。常不思议不成。大慧。我第一义常不思议。第一义因相成。远离有无。自证圣智所行相故有相。第一义智为其因故有因。离有无故非作者。如虚空涅槃寂灭法故常不思议。是故我说常不思议。不同外道所有诤论。大慧。此常不思议。是诸如来自证圣智所行真理。是故菩萨当勤修学。复次大慧。外道常不思议。以无常异相因故常。非自相因力故常。大慧。外道常不思议。以见所作法有已还无无常已比知是常。我亦见所作法有已还无无常已不因此说为常。大慧。外道以如是因相成常不思议。此因相非有。同于兔角故。常不思议唯是分别但有言说。何故彼因同于兔角。无自因相故。大慧。我常不思议。以自证为因相。不以外法有已还无无常为因。外道反此。曾不能知常不思议自因之相。而恒在于自证圣智所行相外。此不应说
    复次大慧。诸声闻畏生死妄想苦而求涅槃。不知生死涅槃差别之相一切皆是妄分别有。无所有故。妄计未来诸根境灭以为涅槃。不知证自智境界转所依藏识为大涅槃。彼愚痴人说有三乘。不说唯心无有境界。大慧。彼人不知去来现在诸佛所说自心境界。取心外境常于生死轮转不绝。复次大慧。去来现在诸如来说一切法不生。何以故。自心所见非有性故。离有无生故。如兔马等角凡愚妄取。唯自证圣智所行之处。非诸愚夫二分别境。大慧。身及资生器世间等。一切皆是藏识影像。所取能取二种相现。彼诸愚夫。堕生住灭二见中故。于中妄起有无分别。大慧。汝于此义当勤修学
    复次大慧。有五种种性。何等为五。谓声闻乘种性。缘觉乘种性。如来乘种性。不定种性。无种性。大慧。云何知是声闻乘种性。谓若闻说于蕴界处自相共相。若知若证。举身毛竖心乐修习。于缘起相不乐观察。应知此是声闻乘种性。彼于自乘见所证已。于五六地断烦恼结。不断烦恼习。住不思议死。正师子吼言。我生已尽梵行已立。所作已办不受后有。修习人无我。乃至生于得涅槃觉。大慧。复有众生求证涅槃。言能觉知我人众生养者取者此是涅槃。复有说言。见一切法因作者有此是涅槃。大慧。彼无解脱。以未能见法无我故。此是声闻乘及外道种性。于未出中生出离想。应勤修习舍此恶见。大慧。云何知是缘觉乘种性。谓若闻说缘觉乘法。举身毛竖悲泣流泪。离愦闹缘无所染着。有时闻说现种种身或聚或散神通变化。其心信受无所违逆。当知此是缘觉乘种性。应为其说缘觉乘法。大慧。如来乘种性所证法有三种。所谓自性无自性法。内身自证圣智法。外诸佛刹广大法。大慧。若有闻说此一一法及自心所现身财建立阿赖耶识不思议境。不惊不怖不畏。当知此是如来乘性。大慧。不定种性者。谓闻说彼三种法时。随生信解而顺修学。大慧。为初治地人而说种性。欲令其入无影像地。作此建立。大慧。彼住三昧乐声闻。若能证知自所依识。见法无我净烦恼习。毕竟当得如来之身。尔时世尊即说颂言
预流一来果 不还阿罗汉
是等诸圣人 其心悉迷惑
我所立三乘 一乘及非乘
为愚夫少智 乐寂诸圣说
第一义法门 远离于二取
住于无境界 何建立三乘
诸禅及无量 无色三摩提
乃至灭受想 唯心不可得
    复次大慧。此中一阐提。何故于解脱中不生欲乐。大慧。以舍一切善根故。为无始众生起愿故。云何舍一切善根。谓谤菩萨藏言。此非随顺契经调伏解脱之说。作是语时。善根悉断不入涅槃。云何为无始众生起愿。谓诸菩萨以本愿方便。愿一切众生悉入涅槃。若一众生未涅槃者我终不入。此亦住一阐提趣。此是无涅槃种性相。大慧菩萨言。世尊。此中何者毕竟不入涅槃。佛言。大慧。彼菩萨一阐提。知一切法本来涅槃。毕竟不入非舍善根。何以故。舍善根。一阐提。以佛威力故。或时善根生。所以者何。佛于一切众生无舍时故。是故菩萨一阐提不入涅槃
    复次大慧。菩萨摩诃萨当善知三自性相。何者为三。所谓妄计自性。缘起自性。圆成自性。大慧。妄计自性从相生。云何从相生。谓彼依缘起事相种类显现。生计着故。大慧。彼计着事相。有二种妄计性生。是诸如来之所演说。谓名相计着相。事相计着相。大慧。事计着相者。谓计着内外法。相计着相者。谓即彼内外法中计着自共相。是名二种妄计自性相。大慧。从所依所缘起。是缘起性。何者圆成自性。谓离名相事相一切分别自证圣智所行真如。大慧。此是圆成自性如来藏心。尔时世尊即说颂言
名相分别 二自性相 正智真如
是圆成性
    大慧。是名观察五法自性相法门。自证圣智所行境界。汝及诸菩萨摩诃萨当勤修学。复次大慧。菩萨摩诃萨当善观察二无我相。何者为二。所谓人无我相。法无我相。大慧。何者是人无我相。谓蕴界处离我我所。无知爱业之所生起眼等识生。取于色等而生计着。又自心所见身器世间。皆是藏心之所显现。刹那相续变坏不停。如河流如种子如灯焰。如迅风如浮云。躁动不安如猨猴。乐不净处如飞蝇。不知厌足如猛火。无始虚伪习气为因。诸有趣中流转不息如汲水轮。种种色身威仪进止。譬如死尸咒力故行。亦如木人因机运动。若能于此善知其相。是名人无我智。大慧。云何为法无我智。谓知蕴界处是妄计性。如蕴界处离我我所。唯共积聚爱业绳缚。互为缘起无能作者。蕴等亦尔离自共相。虚妄分别种种相现。愚夫分别非诸圣者。如是观察一切诸法。离心意意识五法自性。是名菩萨摩诃萨法无我智。得此智已知无境界。了诸地相即入初地。心生欢喜次第渐进。乃至善慧及以法云。诸有所作皆悉已办。住是地已有大宝莲花王众宝庄严。于其花上有宝宫殿状如莲花。菩萨往修幻性法门之所成就。而坐其上。同行佛子前后围绕。一切佛刹所有如来皆舒其手。如转轮王子灌顶之法而灌其顶。超佛子地获自证法。成就如来自在法身。大慧。是名见法无我相。汝及诸菩萨摩诃萨应勤修学
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿说建立诽谤相。令我及诸菩萨摩诃萨离此恶见疾得阿耨多罗三藐三菩提。得菩提已破建立常诽谤断见。令于正法不生毁谤。佛受其请即说颂言
身资财所住 皆唯心影像
凡愚不能了 起建立诽谤
所起但是心 离心不可得
    尔时世尊欲重说此义。告大慧言。有四种无有有建立。何者为四。所谓无有相建立相。无有见建立见。无有因建立因。无有性建立性。是为四。大慧。诽谤者。谓于诸恶见所建立法求不可得。不善观察遂生诽谤。此是建立诽谤相。大慧。云何无有相建立相。谓于蕴界处自相共相本无所有。而生计着。此如是此不异。而此分别从无始种种恶习所生。是名无有相建立相。云何无有见建立见。谓于蕴界处。建立我人众生等见。是名无有见建立见。云何无有因建立因。谓初识前无因不生。其初识本无。后眼色明念等为因如幻生。生已有有还灭。是名无有因建立因。云何无有性建立性。谓于虚空涅槃非数灭无作性。执着建立。大慧。此离性非性。一切诸法离于有无。犹如毛轮兔马等角。是名无有性建立性。大慧。建立诽谤。皆是凡愚不了唯心而生分别。非诸圣者。是故汝等当勤观察远离此见。大慧。菩萨摩诃萨善知心意意识五法自性二无我相已。为众生故作种种身。如依缘起起妄计性。亦如摩尼随心现色。普入佛会听闻佛说。诸法如幻如梦如影。如镜中像如水中月。远离生灭及以断常。不住声闻辟支佛道。闻已成就无量百千亿那由他三昧。得此三昧已。遍游一切诸佛国土。供养诸佛生诸天上。显扬三宝示现佛身。为诸声闻菩萨大众。说外境界皆唯是心。悉令远离有无等执。尔时世尊即说颂言
佛子能观见 世间唯是心
示现种种身 所作无障碍
神通力自在 一切皆成就
    尔时大慧菩萨摩诃萨复请佛言。愿为我说一切法空无生无二无自性相。我及诸菩萨悟此相故离有无分别。疾得阿耨多罗三藐三菩提。佛言。谛听当为汝说。大慧。空者即是妄计性句义。大慧。为执着妄计自性故。说空无生无二无自性。大慧。略说空性有七种。谓相空自性空无行空行空一切法不可说空第一义圣智大空彼彼空。云何相空。谓一切法自相共相空。展转积聚互相待故。分析推求无所有故。自他及共皆不生故。自共相无生亦无住。是故名一切法自相空。云何自性空。谓一切法自性不生。是名自性空。云何无行空。所谓诸蕴本来涅槃无有诸行。是名无行空。云何行空。所谓诸蕴由业及因和合而起。离我我所。是名行空。云何一切法不可说空。谓一切法妄计自性无可言说。是名不可说空。云何第一义圣智大空。谓得自证圣智时。一切诸见过习悉离。是名第一义圣智大空。云何彼彼空。谓于此无彼。是名彼彼空。譬如鹿子母堂无象马牛羊等。我说彼堂空非无比丘众。大慧。非谓堂无堂自性。非谓比丘无比丘自性。非谓余处无象马牛羊。大慧。一切诸法自共相。彼彼求不可得。是故说名彼彼空。是名七种空。大慧。此彼彼空空中最粗。汝应远离
    复次大慧。无生者。自体不生而非不生。除住三昧。是名无生。大慧。无自性者。以无生故密意而说。大慧。一切法无自性。以刹那不住故。见后变异故。是名无自性。云何无二相。大慧。如光影如长短如黑白。皆相待立独则不成。大慧。非于生死外有涅槃。非于涅槃外有生死。生死涅槃无相违相。如生死涅槃。一切法亦如是。是名无二相。大慧。空无生无二无自性相。汝当勤学。尔时世尊重说颂言
我常说空法 远离于断常
生死如幻梦 而业亦不坏
虚空及涅槃 灭二亦如是
愚夫妄分别 诸圣离有无
    尔时世尊复告大慧菩萨摩诃萨言。大慧。此空无生无自性无二相。悉入一切诸佛所说修多罗中。佛所说经皆有是义。大慧。诸修多罗随顺一切众生心说。而非真实在于言中。譬如阳焰诳惑诸兽令生水想而实无水。众经所说亦复如是。随诸愚夫自所分别令生欢喜。非皆显示圣智证处真实之法。大慧。应随顺义莫着言说。尔时大慧菩萨摩诃萨白佛言。世尊。修多罗中说如来藏本性清净。常恒不断无有变易。具三十二相。在于一切众生身中。为蕴界处垢衣所缠。贪恚痴等妄分别垢之所污染。如无价宝在垢衣中。外道说我是常作者。离于求那自在无灭。世尊所说如来藏义。岂不同于外道我耶。佛言。大慧。我说如来藏。不同外道所说之我。大慧。如来应正等觉。以性空实际涅槃不生无相无愿等诸句义。说如来藏。为令愚夫离无我怖。说无分别无影像处如来藏门。未来现在诸菩萨摩诃萨。不应于此执着于我。大慧。譬如陶师于泥聚中以人功水杖轮绳方便作种种器。如来亦尔。于远离一切分别相无我法中。以种种智慧方便善巧。或说如来藏。或说为无我。种种名字各各差别。大慧。我说如来藏。为摄着我诸外道众。令离妄见入三解脱。速得证于阿耨多罗三藐三菩提。是故诸佛说如来藏。不同外道所说之我。若欲离于外道见者。应知无我如来藏义。尔时世尊即说颂曰
士夫相续蕴 众缘及微尘
胜自在作者 此但心分别
    尔时大慧菩萨普观未来一切众生。复请佛言。愿为我说具修行法。如诸菩萨摩诃萨成大修行。佛言。大慧。菩萨摩诃萨具四种法成大修行。何者为四。谓观察自心所现故。远离生住灭见故。善知外法无性故。专求自证圣智故。若诸菩萨成此四法。则得名为大修行者。大慧。云何观察自心所现。谓观三界唯是自心。离我我所无动作无来去。无始执着过习所熏。三界种种色行名言系缚身资所住分别随入之所显现。菩萨摩诃萨如是观察自心所现。大慧。云何得离生住灭见。所谓观一切法如幻梦生。自他及俱皆不生故。随自心量之所现故。见外物无有故。见诸识不起故。及众缘无积故。分别因缘起三界故。如是观时。若内若外一切诸法皆不可得。知无体实远离生见。证如幻性即时逮得无生法忍。住第八地。了心意意识五法自性二无我境。转所依止获意生身。大慧言。世尊。以何因缘名意生身。佛言。大慧。意生身者。譬如意去速疾无碍。名意生身。大慧。譬如心意于无量百千由旬之外。忆先所见种种诸物。念念相续疾诣于彼。非是其身及山河石壁所能为碍。意生身者亦复如是。如幻三昧力通自在诸相庄严。忆本成就众生愿故。犹如意去生于一切诸圣众中。是名菩萨摩诃萨得远离于生住灭见。大慧。云何观察外法无性。谓观察一切法。如阳焰如梦境如毛轮。无始戏论种种执着。虚妄恶习为其因故。如是观察一切法时。即是专求自证圣智。大慧。是名菩萨具四种法成大修行。汝应如是勤加修学
    尔时大慧菩萨摩诃萨复请佛言。愿说一切法因缘相。令我及诸菩萨摩诃萨了达其义离有无见。不妄执诸法渐生顿生。佛言。大慧。一切法因缘生有二种。谓内及外。外者谓以泥团水杖轮绳人功等缘和合成瓶。如泥瓶缕叠草席种牙酪苏。悉亦如是。名外缘前后转生。内者谓无明爱业等生蕴界处法。是为内缘起。此但愚夫之所分别。大慧。因有六种。谓当有因相属因相因能作因显了因观待因。大慧。当有因者。谓内外法作因生果。相属因者。谓内外法作缘生果。蕴种子等。相因者。作无间相生相续果。能作因者。谓作增上而生于果如转轮王。显了因者。谓分别生能显境相如灯照物。观待因者。谓灭时相续断。无妄想生。大慧。此是愚夫自所分别。非渐次生亦非顿生。何以故。大慧。若顿生者。则作与所作无有差别。求其因相不可得故。若渐生者。求其体相亦不可得。如未生子云何名父。诸计度人言以因缘所缘缘无间缘增上缘等。所生能生互相系属。次第生者理不得成。皆是妄情执着相故。大慧。渐次与顿皆悉不生。但有心现身资等故。外自共相皆无性故。惟除识起自分别见。大慧。是故应离因缘所作和合相中渐顿生见。尔时世尊重说颂言
一切法无生 亦复无有灭
于彼诸缘中 分别生灭相
非遮诸缘会 如是灭复生
但止于凡愚 妄情之所著
缘中法有无 是悉无有生
习气迷转心 从是三有现
本来无有生 亦复无有灭
观一切有为 譬如虚空花
离能取所取 一切迷惑见
无能生所生 亦复无因缘
但随世俗故 而说有生灭

    大乘入楞伽经卷第二

    大乘入楞伽经卷第三
    大周于阗国三藏法师实叉难陀奉　敕译
    集一切法品第二之三
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿为我说言说分别相心法门。我及诸菩萨摩诃萨善知此故。通达能说所说二义。疾得阿耨多罗三藐三菩提。令一切众生于二义中而得清净。佛言。大慧。有四种言说分别相。所谓相言说。梦言说计着过恶言说。无始妄想言说。大慧。相言说者。所谓执着自分别色相生。梦言说者。谓梦先所经境界觉已忆念。依不实境生。计着过恶言说者。谓忆念怨仇先所作业生。无始妄想言说者。以无始戏论妄执习气生。是为四。大慧复言。世尊。愿更为说言语分别所行之相。何处何因云何而起。佛言。大慧。依头胸喉鼻唇齶齿舌和合而起。大慧复言。世尊。言语分别为异不异。佛言。大慧非异非不异。何以故。分别为因起言语故。若异者分别不应为因。若不异者语言不应显义。是故非异亦非不异。大慧复言。世尊。为言语是第一义。为所说是第一义。佛告大慧。非言语是亦非所说。何以故。第一义者是圣乐处因言而入。非即是言。第一义者是圣智内自证境。非言语分别智境。言语分别不能显示。大慧。言语者起灭动摇展转因缘生。若展转缘生。于第一义不能显示。第一义者无自他相。言语有相不能显示。第一义者但唯自心。种种外想悉皆无有。言语分别不能显示。是故大慧。应当远离言语分别。尔时世尊重说颂言
诸法无自性 亦复无言说
不见空空义 愚夫故流转
一切法无性 离语言分别
诸有如梦化 非生死涅槃
如王及长者 为令诸子喜
先示相似物 后赐真实者
我今亦复然 先说相似法
后乃为其演 自证实际法
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿为我说离一异俱不俱有无非有无常无常等。一切外道所不能行。自证圣智所行境界。远离妄计自相共相。入于真实第一义境。渐净诸地入如来位。以无功用本愿力故。如如意宝普现一切无边境界。一切诸法皆是自心所见差别。令我及余诸菩萨等于如是等法。离妄计自性自共相见。速证阿耨多罗三藐三菩提。普令众生具足圆满一切功德。佛言。大慧。善哉善哉。汝哀愍世间请我此义。多所利益多所安乐。大慧。凡夫无智不知心量。妄习为因执着外物。分别一异俱不俱有。无非有无常无常等一切自性。大慧。譬如群兽为渴所逼。于热时焰而生水想。迷惑驰趣不知非水。愚痴凡夫亦复如是。无始戏论分别所熏。三毒烧心乐色境界。见生住灭取内外法。堕一异等执着之中。大慧。如乾闼婆城非城非非城。无智之人无始时来。执着城种妄习熏故。而作城想。外道亦尔。以无始来妄习熏故。不能了达自心所现。着一异等种种言说。大慧。譬如有人梦见男女象马车步城邑园林种种严饰。觉已忆念彼不实事。大慧。汝意云何。如是之人是黠慧不。答言不也。大慧。外道亦尔。恶见所噬不了唯心。执着一异有无等见。大慧。譬如画像无高无下。愚夫妄见作高下想。未来外道亦复如是。恶见熏习妄心增长。执一异等自坏坏他。于离有无无生之论。亦说为无。此谤因果拔善根本。应知此人分别有无起自他见。当堕地狱。欲求胜法宜速远离。大慧。譬如翳目见有毛轮。互相谓言此事希有。而此毛轮非有非无。见不见故。外道亦尔。恶见分别执着一异俱不俱等。诽谤正法自陷陷他。大慧。譬如火轮实非是轮。愚夫取着非诸智者。外道亦尔。恶见乐欲执着一异俱不俱等。一切法生。大慧。譬如水泡似玻[王*梨]珠。愚夫执实奔驰而取。然彼水泡非珠非非珠。取不取故。外道亦尔。恶见分别习气所熏。说非有为生坏于缘有。复次大慧。立三种量已。于圣智内证离二自性法。起有性分别。大慧。诸修行者。转心意识离能所取。住如来地自证圣法。于有及无。不起于想。大慧。诸修行者。若于境界起有无执。则着我人众生寿者。大慧。一切诸法自相共相。是化佛说非法佛说。大慧。化佛说法但顺愚夫所起之见。不为显示自证圣智三昧乐境。大慧。譬如水中有树影现。彼非影非非影。非树形非非树形。外道亦尔。诸见所熏不了自心。于一异等而生分别。大慧。譬如明镜无有分别。随顺众缘。现诸色像。彼非像非非像而见像非像。愚夫分别而作像想。外道亦尔。于自心所现种种形像。而执一异俱不俱相。大慧。譬如谷响依于风水人等音声和合而起。彼非有非无。以闻声非声故。外道亦尔。自心分别熏习力故。起于一异俱不俱见。大慧。譬如大地无草木处日光照触焰水波动。彼非有非无。以倒想非想故。愚痴凡夫亦复如是。无始戏论恶习所熏。于圣智自证法性门中。见生住灭一异有无俱不俱性。大慧。譬如木人及以起尸。以毗舍阇机关力故。动摇运转云为不绝。无智之人取以为实。愚痴凡夫亦复如是。随逐外道起诸恶见。着一异等虚妄言说。是故大慧。当于圣智所证法中离生住灭一异有无俱不俱等一切分别。尔时世尊重说颂言
诸识蕴有五 犹如水树影
所见如幻梦 不应妄分别
三有如阳焰 幻梦及毛轮
若能如是观 究竟得解脱
譬如热时焰 动转迷乱心
渴兽取为水 而实无水事
如是识种子 动转见境界
如翳者所见 愚夫生执着
无始生死中 执着所缘覆
退舍令出离 如因[打-丁+屑]出[打-丁+屑]
幻咒机所作 浮云梦电光
观世恒如是 永断三相续
此中无所有 如空中阳焰
如是知诸法 则为无所知
诸蕴如毛轮 于中妄分别
唯假施设名 求相不可得
如画垂发幻 梦乾闼婆城
火轮热时焰 实无而见有
如是常无常 一异俱不俱
无始系缚故 愚夫妄分别
明镜水净眼 摩尼妙宝珠
于中现色像 而实无所有
心识亦如是 普现众色相
如梦空中焰 亦如石女儿
    复次大慧。诸佛说法离于四句。谓离一异俱不俱及有无等建立诽谤。大慧。诸佛说法以谛缘起灭道解脱而为其首。非与胜性．自在．宿作．自然．时．微尘等而共相应。大慧。诸佛说法为净惑智二种障故。次第令住一百八句无相法中。而善分别诸乘地相。犹如商主善导众人。复次大慧。有四种禅。何等为四。谓愚夫所行禅。观察义禅。攀缘真如禅。诸如来禅。大慧。云何愚夫所行禅。谓声闻缘觉诸修行者。知人无我。见自他身骨锁相连皆是无常苦不净相。如是观察坚着不舍。渐次增胜至无想灭定。是名愚夫所行禅。云何观察义禅。谓知自共相人无我已。亦离外道自他俱作。于法无我诸地相义。随顺观察。是名观察义禅。云何攀缘真如禅。谓若分别无我有二是虚妄念。若如实知彼念不起。是名攀缘真如禅。云何诸如来禅。谓入佛地住自证圣智三种乐。为诸众生作不思议事。是名诸如来禅。尔时世尊重说颂言
愚夫所行禅 观察义相禅
攀缘真如禅 如来清净禅
修行者在定 观见日月形
波头摩深险 虚空火及画
如是种种相 堕于外道法
亦堕于声闻 辟支佛境界
舍离此一切 住于无所缘
是则能随入 如如真实相
十方诸国土 所有无量佛
悉引光明手 而摩是人顶
    尔时大慧菩萨摩诃萨复白佛言。世尊。诸佛如来所说涅槃说何等法名为涅槃。佛告大慧。一切识自性习气。及藏识意意识见习转已。我及诸佛说名涅槃。即是诸法性空境界。复次大慧。涅槃者。自证圣智所行境界。远离断常及以有无。云何非常。谓离自相共相诸分别故。云何非断。谓去来现在一切圣者自证智所行故。复次大慧。大般涅槃不坏不死。若死者应更受生。若坏者应是有为。是故涅槃不坏不死。诸修行者之所归趣。复次大慧。无舍无得故。非断非常故。不一不异故。说名涅槃。复次大慧。声闻缘觉知自共相舍离愦闹。不生颠倒不起分别。彼于其中生涅槃想。复次大慧。有二种自性相。何者为二。谓执着言说自性相。执着诸法自性相。执着言说自性相者。以无始戏论执着言说习气故起。执着诸法自性相着。以不觉自心所现故起。复次大慧。诸佛有二种加持。持诸菩萨。令顶礼佛足请问众义。云何为二。谓令入三昧。及身现其前手灌其顶。大慧。初地菩萨摩诃萨蒙诸佛持力故。入菩萨大乘光明定。入已十方诸佛普现其前身语加持。如金刚藏及余成就如是功德相菩萨摩诃萨者是。大慧。此菩萨摩诃萨蒙佛持力入三昧已。于百千劫集诸善根。渐入诸地善能通达治所治相。至法云地处大莲花微妙宫殿。坐于宝座。同类菩萨所共围绕。首戴宝冠身如黄金。瞻卜花色如盛满月。放大光明。十方诸佛舒莲花手。于其座上而灌其顶。如转轮王太子受灌顶已而得自在。此诸菩萨亦复如是。是名为二。诸菩萨摩诃萨为二种持之所持故。即能亲见一切诸佛。异则不能。复次大慧。诸菩萨摩诃萨。入于三昧现通说法。如是一切皆由诸佛二种持力。大慧。若诸菩萨离佛加持能说法者。则诸凡夫亦应能说大慧。山林草树城郭宫殿及诸乐器如来至处。以佛持力尚演法音。况有心者。聋盲喑痖离苦解脱。大慧。如来持力有如是等广大作用。大慧菩萨复白佛言。何故如来以其持力。令诸菩萨入于三昧及殊胜地中手灌其顶。佛言。大慧。为欲令其远离魔业诸烦恼故。为令不堕声闻地故。为令速入如来地故。令所得法倍增长故。是故诸佛以加持力持诸菩萨。大慧。若不如是。彼菩萨便堕外道及以声闻魔境之中。则不能得无上菩提。是故如来以加持力摄诸菩萨。尔时世尊重说颂言
世尊清净愿 有大加持力
初地十地中 三昧及灌顶
    尔时大慧菩萨摩诃萨。复白佛言。世尊。佛说缘起。是由作起非自体起。外道亦说胜性自在时我微尘生于诸法。今佛世尊。但以异名说作缘起。非义有别。世尊。外道亦说以作者故从无生有。世尊亦说以因缘故一切诸法本无而生生已归灭。如佛所说。无明缘行乃至老死。此说无因非说有因。世尊说言此有故彼有。若一时建立非次第相待者。其义不成。是故外道说胜。非如来也。何以故。外道说因不从缘生而有所生。世尊所说。果待于因因复待因。如是展转成无穷过。又此有故彼有者。则无有因。佛言。大慧。我了诸法唯心所现无能取所取。说此有故彼有。非是无因及因缘过失。大慧。若不了诸法唯心所现。计有能取及以所取。执着外境若有若无。彼有是过非我所说。大慧菩萨。复白佛言。世尊有言说故必有诸法。若无诸法言依何起。佛言。大慧虽无诸法亦有言说。岂不现见龟毛兔角石女儿等。世人于中皆起言说。大慧。彼非有非非有。而有言说耳。大慧。如汝所说。有言说故有诸法者。此论则坏。大慧。非一切佛土皆有言说言说者假安立耳。大慧。或有佛土瞪视显法。或现异相。或复扬眉。或动目睛。或示微笑嚬呻謦欬忆念动摇。以如是等而显于法。大慧。如不瞬世界妙香世界及普贤如来佛土之中。但瞪视不瞬。令诸菩萨获无生法忍及诸胜三昧。大慧。非由言说而有诸法。此世界中蝇蚁等虫。虽无言说成自事故。尔时世尊重说颂言
如虚空兔角 及与石女儿
无而有言说 妄计法如是
因缘和合中 愚夫妄谓生
不能如实解 流转于三有
    尔时大慧菩萨摩诃萨。复白佛言。世尊。所说常声依何处说。佛言。大慧。依妄法说。以诸妄法圣人亦现然不颠倒。大慧。譬如阳焰火轮垂发乾闼婆城梦幻镜像。世无智者生颠倒解。有智不然然非不现。大慧。妄法现时无量差别。然非无常。何以故。离有无故。云何离有无。一切愚夫种种解故。如恒河水有见不见。饿鬼不见不可言有。余所见故不可言无。圣于妄法离颠倒见。大慧。妄法是常。相不异故。非诸妄法有差别相。以分别故而有别异。是故妄法其体是常。大慧。云何而得妄法真实。谓诸圣者于妄法中不起颠倒。非颠倒觉。若于妄法有少分想。则非圣智有少想者。当知则是愚夫戏论非圣言说。大慧。若分别妄法是倒非倒。彼则成就二种种性。谓圣种性。凡夫种性。大慧。圣种性者。彼复三种。谓声闻缘觉佛乘别故。大慧。云何愚夫分别妄法生声闻乘种性。所谓计着自相共相。大慧。何谓复有愚夫分别妄法成缘觉乘种性。谓即执着自共相时离于愦闹。大慧。何谓智人分别妄法而得成就佛乘种性。所谓了达一切唯是自心分别所见无有外法。大慧。有诸愚夫分别妄法种种事物。决定如是决定不异。此则成就生死乘性。大慧。彼妄法中种种事物。非即是物亦非非物。大慧。即彼妄法。诸圣智者。心意意识诸恶习气自性法转依故。即说此妄名为真如。是故真如离于心识。我今明了显示此句。离分别者。悉离一切诸分别故。大慧菩萨白言。世尊。所说妄法为有为无。佛言如幻无执着相故。若执着相体是有者。应不可转。则诸缘起。应如外道说作者生。大慧又言。若诸妄法同于幻者。此则当与余妄作因。佛言大慧。非诸幻事为妄惑因。以幻不生诸过恶故。以诸幻事无分别故。大慧。夫幻事者。从他明咒而得生起。非自分别过习力起。是故幻事不生过恶。大慧。此妄惑法唯是愚夫心所执着。非诸圣者。尔时世尊重说颂言
圣不见妄法 中间亦非实
以妄即真故 中间亦真实
若离于妄法 而有相生者
此还即是妄 如翳未清净
    复次大慧。见诸法非幻无有相似。故说一切法如幻。大慧言。世尊。为依执着种种幻相。言一切法犹如幻耶。为异依此执着颠倒相耶。若依执着种种幻相。言一切法犹如幻者。世尊。非一切法悉皆如幻。何以故。见种种色相不无因故。世尊。都无有因令种种色相显现如幻。是故世尊。不可说言依于执着种种幻相。言一切法与幻相似。佛言。大慧。不依执着种种幻相言一切法如幻。大慧。以一切法不实速灭如电故说如幻。大慧。譬如电光见已即灭。世间凡愚悉皆现见一切诸法。依自分别自共相现亦复如是。以不能观察无所有故。而妄计着种种色相。尔时世尊重说颂言
非幻无相似 亦非有诸法
不实速如电 如幻应当知
    尔时大慧菩萨摩诃萨。复白佛言。世尊如佛先说。一切诸法皆悉无生。又言如幻。将非所说前后相违。佛言。大慧。无有相违。何以故。我了于生即是无生。唯是自心之所见故。若有若无一切外法。见其无性本不生故。大慧。为离外道因生义故。我说诸法皆悉不生。大慧。外道群聚共兴恶见。言从有无生一切法。非自执着分别为缘。大慧。我说诸法非有无生故名无生。大慧。说诸法者。为令弟子知依诸业摄受生死遮其无有断灭见故。大慧。说诸法相犹如幻者。令离诸法自性相故。为诸凡愚堕恶见欲不知诸法唯心所现。为令远离执着因缘生起之相。说一切法如幻如梦。彼诸愚夫执着恶见欺诳自他。不能明见一切诸法如实住处。大慧见一切法如实处者。谓能了达唯心所现。尔时世尊重说颂言
无作故无生 有法摄生死
了达如幻等 于相不分别
    复次大慧。我当说名句文身相。诸菩萨摩诃萨善观此相了达其义。疾得阿耨多罗三藐三菩提。复能开悟一切众生。大慧。名身者。谓依事立名。名即是身。是名名身。句身者。谓能显义决定究竟。是名句身。文身者。谓由于此能成名句。是名文身。复次大慧。句身者。谓句事究竟。名身者。谓诸字名各各差别。如从阿字乃至呵字。文身者。谓长短高下。复次句身者。如足迹。如衢巷中人畜等迹。名谓非色四蕴。以名说故。文谓名之自相。由文显故。是名名句文身。此名句文身相汝应修学。尔时世尊重说颂言
名身与句身 及字身差别
凡愚所计着 如象溺深泥
    复次大慧。未来世中有诸邪智恶思觉者。离如实法以见一异俱不俱相。问诸智者。彼即答言。此非正问。谓色与无常。为异为不异。如是涅槃诸行。相所相。依所依。造所造。见所见。地与微尘。智与智者。为异为不异。如是等不可记事次第而问。世尊。说此当止记答。愚夫无智非所能知。佛欲令其离惊怖处不为记说。大慧。不记说者。欲令外道永得出离作者见故。大慧。诸外道众计有作者。作如是说。命即是身命异身异。如是等说名无记论。大慧。外道痴惑说无记论。非我教中说离能所取不起分别。云何可止。大慧。若有执着能取所取。不了唯是自心所见。彼应可止。大慧。诸佛如来以四种记论为众生说法。大慧。止记论者我别时说。以根未熟且止说故
    复次大慧。何故一切法不生。以离能作所作无作者故。何以一切法无自性。以证智观自相共相不可得故。何故一切法无来去。以自共相来无所从去无所至故。何故一切法不灭。谓一切法无性相故。不可得故。何故一切法无常。谓诸相起无常性故。何故一切法常。谓诸相起即是不起。无所有故。无常性常。是故我说一切法常。尔时世尊重说颂言
一向及返问 分别与置答
如是四种说 摧伏诸外道
数论与胜论 言有非有生
如是等诸说 一切皆无记
以智观察时 体性不可得
以彼无可说 故说无自性
    尔时大慧菩萨摩诃萨。复白佛言。世尊。愿为我说诸须陀洹须陀洹果行差别相。我及诸菩萨摩诃萨闻是义故。于须陀洹斯陀含阿那含阿罗汉方便相。皆得善巧。如是而为众生演说。令其证得二无我法净除二障。于诸地相渐次通达。获于如来不可思议智慧境界。如众色摩尼。普令众生悉得饶益。佛言。谛听当为汝说。大慧言唯。佛言。大慧。诸须陀洹须陀洹果差别有三。谓下中上。大慧。下者于诸有中极七反生。中者三生五生。上者即于此生而入涅槃。大慧。此三种人断三种结。谓身见疑戒禁取。上上胜进得阿罗汉果。大慧。身见有二种。谓俱生及分别。如依缘起有妄计性。大慧。譬如依止缘起性故种种妄计执着性生。彼法但是妄分别相。非有非无。非亦有亦无。凡夫愚痴而横执着。犹如渴兽妄生水想。此分别身见无智慧故久远相应。见人无我即时舍离。大慧。俱生身见。以普观察自他之身。受等四蕴无色相故。色由大种而得生故。是诸大种互相因故。色不集故。如是观已。明见有无即时舍离。舍身见故贪则不生。是名身见相。大慧。疑相者。于所证法善见相故。及先二种身见分别断故。于诸法中疑不得生。亦不于余生大师想为净不净。是名疑相。大慧。何故须陀洹不取戒禁。谓以明见生处苦相。是故不取。夫其取者。谓诸凡愚于诸有中贪着世乐。苦行持戒愿生于彼。须陀洹人不取是相。惟求所证最胜无漏无分别法。修行戒品。是名戒禁取相。大慧。须陀洹人舍三结故离贪嗔痴。大慧白言。贪有多种舍何等贪。佛言。大慧。舍于女色缠绵贪欲。见此现乐生来苦故。又得三昧殊胜乐故。是故舍彼非涅槃贪。大慧。云何斯陀含果。谓不了色相起色分别。一往来已善修禅行。尽苦边际而般涅槃。是名斯陀含。大慧。云何阿那含果。谓于过未现在色相起有无见。分别过恶随眠不起。永舍诸结更不还来。是名阿那含。大慧。阿罗汉者。谓诸禅三昧解脱力通悉已成就。烦恼诸苦分别永尽。是名阿罗汉。大慧言。世尊。阿罗汉有三种。谓一向趣寂。退菩提愿。佛所变化。此说何者。佛言。大慧。此说趣寂非是其余。大慧。余二种人。谓已曾发巧方便愿。及为庄严诸佛众会于彼示生。大慧。于虚妄处说种种法。所谓证果禅者及禅皆性离故。自心所见得果相故。大慧。若须陀洹作如是念。我离诸结则有二过。谓堕我见及诸结不断。复次大慧。若欲超过诸禅无量无色界者。应离自心所见诸相。大慧。想受灭三昧。超自心所见境者不然。不离心故。尔时世尊重说颂言
诸禅与无量 无色四摩提
及以想受灭 惟心不可得
预流一来果 不还阿罗汉
如是诸圣人 悉依心妄有
禅者禅所缘 断惑见真谛
此皆是妄想 了知即解脱
    复次大慧。有二种觉智。谓观察智。及取相分别执着建立智。观察智者。谓观一切法。离四句不可得。四句者。谓一异俱不俱有非有常无常等。我以诸法离此四句。是故说言一切法离。大慧。如是观法汝应修学。云何取相分别执着建立智。谓于坚湿暖动诸大种性。取相执着虚妄分别。以宗因喻而妄建立。是名取相分别执着建立智。是名二种觉智相。菩萨摩诃萨知此智相。即能通达人法无我。以无相智于解行地善巧观察。入于初地得百三昧。以胜三昧力见百佛百菩萨。知前后际各百劫事。光明照曜百佛世界。善能了知上上地相。以胜愿力变现自在。至法云地而受灌顶。入于佛地十无尽愿成就众生。种种应现无有休息。而恒安住自觉境界三昧胜乐。复次大慧。菩萨摩诃萨当善了知大种造色。云何了知。大慧。菩萨摩诃萨应如是观。彼诸大种真实不生。以诸三界但是分别。惟心所现无有外物。如是观时大种所造悉皆性离超过四句无我我所。住如实处成无生相。大慧。彼诸大种云何造色。大慧。谓虚妄分别津润大种成内外水界。炎盛大种成内外火界。飘动大种成内外风界。色分段大种成内外地界。离于虚空。由执着邪谛。五蕴聚集大种造色生。大慧。识者以执着种种言说境界。为因起故。于余趣中相续受生。大慧。地等造色有大种因。非四大种为大种因。何以故。谓若有法有形相者。则是所作非无形者。大慧。此大种造色相外道分别。非是我说。复次大慧。我今当说五蕴体相。谓色受想行识。大慧。色谓四大及所造色。此各异相受等非色。大慧。非色诸蕴。犹如虚空无有四数。大慧。譬如虚空超过数相。然分别言此是虚空。非色诸蕴亦复如是。离诸数相。离有无等四种句故。数相者愚夫所说非诸圣者。诸圣但说如幻所作。唯假施设离异不异。如梦如像无别所有。不了圣智所行境故。见有诸蕴分别现前。是名诸蕴自性相。大慧。如是分别汝应舍离。舍离此已说寂静法。断一切刹诸外道见。净法无我入远行地。成就无量自在三昧。获意生身。如幻三昧力通自在皆悉具足。犹如大地普益群生
    复次大慧。涅槃有四种。何等为四。谓诸法自性无性涅槃。种种相性无性涅槃。觉自相性无性涅槃。断诸蕴自共相流注涅槃。大慧。此四涅槃是外道义。非我所说。大慧。我所说者。分别尔炎识灭名为涅槃。大慧言。世尊。岂不建立八种识耶。佛言建立。大慧言。若建立者。云何但说意识灭非七识灭。佛言。大慧。以彼为因及所缘故。七识得生。大慧。意识分别境界起执着时。生诸习气长养藏识。由是意俱我我所执思量随转无别体相。藏识为因为所缘故。执着自心所现境界。心聚生起展转为因。大慧。譬如海浪自心所现境界风吹而有起灭。是故意识灭时七识亦灭。尔时世尊重说颂曰
我不以自性 及以于作相
分别境识灭 如是说涅槃
意识为心因 心为意境界
因及所缘故 诸识依止生
如大瀑流尽 波浪则不起
如是意识灭 种种识不生
    复次大慧。我今当说妄计自性差别相。令汝及诸菩萨摩诃萨善知此义。超诸妄想证圣智境。知外道法。远离能取所取分别。于依他起种种相中。不更取着妄所计相。大慧。云何妄计自性差别相。所谓言说分别所说分别。相分别财分别。自性分别。因分别。见分别。理分别。生分别。不生分别。相属分别。缚解分别。大慧。此是妄计自性差别相。云何言说分别。谓执着种种美妙音词。是名言说分别。云何所说分别。谓执有所说事。是圣智所证境依此起说。是名所说分别。云何相分别。谓即于彼所说事中。如渴兽想。分别执着坚湿暖动等一切诸相。是名相分别云何财分别。谓取着种种金银等宝。而起言说。是名财分别。云何自性分别。谓以恶见如是分别此自性。决定非余。是名自性分别。云何因分别。谓于因缘分别有无。以此因相而能生故。是名因分别。云何见分别。谓诸外道恶见。执著有无一异俱不俱等。是名见分别。云何理分别。谓有执着我我所相。而起言说。是名理分别。云何生分别。谓计诸法若有若无从缘而生。是名生分别。云何不生分别。谓计一切法本来不生未有诸缘而先有体不从因起。是名不生分别。云何相属分别。谓此与彼递相系属。如针与线。是名相属分别。云何缚解分别。谓执因能缚而有所缚。如人以绳方便力故缚已复解。是名缚解分别。大慧。此是妄计性差别相。一切凡愚于中执着若有若无。大慧。于缘起中。执着种种妄计自性。如依于幻见种种物。凡愚分别见异于幻。大慧。幻与种种非异非不异。若异者。应幻非种种因。若一者。幻与种种应无差别。然见差别。是故非异非不异。大慧。汝及诸菩萨摩诃萨于幻有无不应生着。尔时世尊重说颂言
心为境所缚 觉想智随转
无相最胜处 平等智慧生
在妄计是有 于缘起则无
妄计迷惑取 缘起离分别
种种支分生 如幻不成就
虽现种种相 妄分别则无
彼相即是过 皆从心缚生
妄计者不了 分别缘起法
此诸妄计性 皆即是缘起
妄计有种种 缘起中分别
世俗第一义 第三无因生
妄计是世俗 断则圣境界
如修观行者 于一种种现
于彼无种种 妄计相如是
如目种种翳 妄想见众色
彼无色非色 不了缘起然
如金离尘垢 如水离泥浊
如虚空无云 妄想净如是
无有妄计性 而有于缘起
建立及诽谤 斯由分别坏
若无妄计性 而有缘起者
无法而有法 有法从无生
依因于妄计 而得有缘起
相名常相随 而生于妄计
以缘起依妄 究竟不成就
是时现清净 名为第一义
妄计有十二 缘起有六种
自证真如境 彼无有差别
五法为真实 三自性亦尔
修行者观此 不越于真如
依于缘起相 妄计种种名
彼诸妄计相 皆因缘起有
智慧善观察 无缘无妄计
真实中无物 云何起分别
圆成若是有 此则离有无
既已离有无 云何有二性
妄计有二性 二性是安立
分别见种种 清净圣所行
妄计种种相 缘起中分别
若异此分别 则堕外道论
以诸妄见故 妄计于妄计
离此二计者 则为真实法
    大慧菩萨摩诃萨。复白佛言。世尊。惟愿为说自证圣智行相及一乘行相。我及诸菩萨摩诃萨得此善巧。于佛法中不由他悟。佛言谛听当为汝说。大慧言唯。佛言。大慧。菩萨摩诃萨依诸圣教无有分别。独处闲静观察自觉。不由他悟离分别见。上上升进入如来地。如是修行。名自证圣智行相。云何名一乘行相。谓得证知一乘道故。云何名为知一乘道。谓离能取所取分别如实而住。大慧。此一乘道惟除如来。非外道二乘梵天王等之所能得。大慧白佛言。世尊。何故说有三乘不说一乘。佛言。大慧。声闻缘觉。无自般涅槃法故。我说一乘。以彼但依如来所说调伏远离。如是修行而得解脱。非自所得。又彼未能除灭智障及业习气。未觉法无我。未名不思议变易死。是故我说以为三乘。若彼能除一切过习觉法无我。是时乃离三昧所醉。于无漏界而得觉悟已。于出世上上无漏界中修诸功德。普使满足获不思议自在法身。尔时世尊重说颂言
天乘及梵乘 声闻缘觉乘
诸佛如来乘 诸乘我所说
乃至有心起 诸乘未究竟
彼心转灭已 无乘及乘者
无有乘建立 我说为一乘
为摄愚夫故 说诸乘差别
解脱有三种 谓离诸烦恼
及以法无我 平等智解脱
譬如海中木 常随波浪转
声闻心亦然 相风所漂激
虽灭起烦恼 犹被习气缚
三昧酒所醉 住于无漏界
彼非究竟趣 亦复不退转
以得三昧身 乃至劫不觉
譬如昏醉人 酒消然后悟
声闻亦如是 觉后当成佛

    大乘入楞伽经卷第三

    大乘入楞伽经卷第四
    大周于阗国三藏法师实叉难陀奉　敕译
    无常品第三之一
    尔时佛告大慧菩萨摩诃萨言。今当为汝说意成身差别相。谛听谛听善思念之。大慧言唯。佛言。大慧。意成身有三种。何者为三。谓入三昧乐意成身。觉法自性意成身。种类俱生。无作行意成身。诸修行者入初地已渐次证得。大慧。云何入三昧乐意成身。谓三四五地入于三昧。离种种心寂然不动。心海不起转识波浪。了境心现皆无所有。是名入三昧乐意成身。云何觉法自性意成身。谓八地中了法如幻皆无有相。心转所依。住如幻定及余三昧。能现无量自在神通。如花开敷速疾如意。如幻如梦如影如像。非四大造与造相似。一切色相具足庄严。普入佛刹了诸法性。是名觉法自性意成身。云何种类俱生无作行意成身。谓了达诸佛自证法相。是名种类俱生无作行意成身。大慧。三种身相当勤观察。尔时世尊重说颂言
我大乘非乘 非声亦非字
非谛非解脱 亦非无相竟
然乘摩诃衍 三摩提自在
种种意成身 自在花庄严
    尔时大慧菩萨摩诃萨。复白佛言。世尊。如世尊说五无间业。何者为五。若人作已堕阿鼻狱。佛言谛听当为汝说。大慧言唯。佛告大慧。五无间者。所谓杀母杀父。杀阿罗汉。破和合僧。怀恶逆心出佛身血。大慧。何者为众生母。谓引生爱与贪喜俱如母养育。何者为父。所谓无明令生六处聚落中故。断二根本名杀父母。云何杀阿罗汉。谓随眠为怨如鼠毒发。究竟断彼。是故说名杀阿罗汉。云何破和合僧。谓诸蕴异相和合积聚。究竟断彼名为破僧。云何恶心出佛身血。谓八识身妄生思觉。见自心外自相共相。以三解脱无漏恶心。究竟断彼八识身佛。名为恶心出佛身血。大慧。是为内五无间。若有作者。无间即得现证实法。复次大慧。今为汝说外五无间。令汝及余菩萨闻是义已于未来世不生疑惑。云何外五无间。谓余教中所说无间。若有作者。于三解脱不能现证。唯除如来诸大菩萨及大声闻。见其有造无间业者。为欲劝发令其改过。以神通力示同其事。寻即悔除证于解脱。此皆化现非是实造。若有实造无间业者。终无现身而得解脱。唯除觉了自心所现身资所住。离我我所分别执见。或于来世余处受生。遇善知识离分别过方证解脱。尔时世尊重说颂言
贪爱名为母 无明则是父
识了于境界 此则名为佛
随眠阿罗汉 蕴聚和合僧
断彼无余间 是名无间业
    尔时大慧菩萨摩诃萨。复白佛言。世尊。愿为我说诸佛体性。佛言。大慧。觉二无我。除二种障。离二种死。断二烦恼。是佛体性。大慧。声闻缘觉得此法已。亦名为佛。我以是义但说一乘。尔时世尊重说颂言
善知二无我 除二障二恼
及不思议死 是故名如来
    尔时大慧菩萨摩诃萨。复白佛言。世尊。如来以何密意。于大众中唱如是言。我是过去一切诸佛。及说百千本生之事。我于尔时。作顶生王．大象．鹦鹉．月光．妙眼如是等。佛言。大慧。如来应正等觉。依四平等秘密意故。于大众中作如是言。我于昔时作拘留孙佛．拘那含牟尼佛．迦叶佛。云何为四。所谓字平等语平等身平等法平等。云何字平等。谓我名佛。一切如来亦名为佛。佛名无别是谓字等。云何语平等。谓我作六十四种梵音声语。一切如来亦作此语。迦陵频伽梵音声性。不增不减无有差别。是名语等。云何身平等。谓我与诸佛。法身色相及随形好等无差别。除为调伏种种众生现随类身。是谓身等。云何法平等。谓我与诸佛皆同证得三十七种菩提分法。是谓法等。是故如来应正等觉。于大众中作如是说。尔时世尊重说颂言
迦叶拘留孙 拘那含是我
依四平等故 为诸佛子说
    尔时大慧菩萨摩诃萨。复白佛言。世尊。如世尊说。我于某夜成最正觉。乃至某夜当入涅槃。于其中间不说一字。亦不已说亦不当说。不说是佛说。世尊。依何密意作如是语。佛言。大慧。依二密法故作如是说。云何二法。谓自证法及本住法。云何自证法。谓诸佛所证我亦同证不增不减。证智所行离言说相。离分别相离名字相。云何本住法。谓法本性如金等在矿。若佛出世若不出世。法住法位。法界法性皆悉常住。大慧。譬如有人行旷野中见向古城平坦旧道即便随入止息游戏。大慧。于汝意云何。彼作是道及以城中种种物耶。白言不也。佛言。大慧。我及诸佛所证真如。常住法性亦复如是。是故说言始从成佛乃至涅槃。于其中间不说一字。亦不已说亦不当说。尔时世尊重说颂言
某夜成正觉 某夜般涅槃
于此二中间 我都无所说
自证本住法 故作是密语
我及诸如来 无有少差别
    尔时大慧菩萨摩诃萨。复白佛言。世尊。愿说一切法有无相。令我及诸菩萨摩诃萨离此相疾得阿耨多罗三藐三菩提。佛言。谛听当为汝说。大慧言唯。佛言。大慧。世间众生多堕二见。谓有见无见。堕二见故非出出想。云何有见。谓实有因缘而生诸法非不实有。实有诸法从因缘生非无法生。大慧。如是说者则说无因。云何无见。谓知受贪嗔痴已而妄计言无。大慧。及彼分别有相。而不受诸法有。复有知诸如来声闻缘觉无贪嗔痴性而计为非有。此中谁为坏者。大慧白言。谓有贪嗔痴性后取于无。名为坏者。佛言善哉。汝解我问。此人非止无贪嗔痴名为坏者。亦坏如来声闻缘觉。何以故。烦恼内外不可得故。体性非异非不异故。大慧。贪嗔痴性若内若外皆不可得。无体性故。无可取故。声闻缘觉及以如来本性解脱。无有能缚及缚因故。大慧。若有能缚及以缚因则有所缚。作如是说名为坏者。是为无有相。我依此义密意而说。宁起我见如须弥山。不起空见怀增上慢。若起此见名为坏者。堕自共见乐欲之中。不了诸法惟心所现。以不了故见有外法刹那无常展转差别蕴界处相。相续流转起已还灭。虚妄分别。离文字相。亦成坏者。尔时世尊重说颂言
有无是二边 乃至心所行
净除彼所行 平等心寂灭
不取于境界 非灭无所有
有真如妙物 如诸圣所行
本无而有生 生已而复灭
因缘有及无 彼非住我法
非外道非佛 非我非余众
能以缘成有 云何而得无
谁以缘成有 而复得言无
恶见说为生 妄想计有无
若知无所生 亦复无所灭
观世悉空寂 有无二俱离
    尔时大慧菩萨摩诃萨。复请佛言。世尊。惟愿为说宗趣之相。令我及诸菩萨摩诃萨善达此义不随一切众邪妄解疾得阿耨多罗三藐三菩提。佛言谛听当为汝说。大慧言唯。佛言。大慧。一切二乘及诸菩萨。有二种宗法相。何等为二。谓宗趣法相。言说法相。宗趣法相者。谓自所证殊胜之相。离于文字语言分别。入无漏界成自地行。超过一切不正思觉。伏魔外道生智慧光。是名宗趣法相。言说法相者。谓说九部种种教法。离于一异有无等相。以巧方便随众生心令入此法。是名言说法相。汝及诸菩萨当勤修学。尔时世尊重说颂言
宗趣与言说 自证及教法
若能善知见 不随他妄解
如愚所分别 非是真实相
彼岂不求度 无法而可得
观察诸有为 生灭等相续
增长于二见 颠倒无所知
涅槃离心意 唯此一法实
观世悉虚妄 如幻梦芭蕉
无有贪恚痴 亦复无有人
从爱生诸蕴 如梦之所见
    尔时大慧菩萨摩诃萨。复白佛言。世尊。愿为我说虚妄分别相。此虚妄分别云何而生。是何而生。因何而生。谁之所生。何故名为虚妄分别。佛言。大慧。善哉善哉。汝为哀愍世间天人而问此义。多所利益多所安乐。谛听谛听善思念之。当为汝说。大慧言唯。佛言。大慧。一切众生于种种境。不能了达自心所现。计能所取虚妄执着。起诸分别堕有无见。增长外道妄见习气。心心所法相应起时。执有外义种种可得。计着于我及以我所。是故名为虚妄分别。大慧白言。若如是者。外种种义性离有无起诸见相。世尊。第一义谛亦复如是。离诸根量宗因譬喻。世尊。何故于种种义言起分别。第一义中不言起耶。将无世尊所言乖理。一处言起一不言故。世尊。又说虚妄分别堕有无见。譬如幻事种种非实。分别亦尔有无相离。云何而说堕二见耶。此说岂不堕于世见。佛言。大慧。分别不生不灭。何以故。不起有无分别相故。所见外法皆无有故。了唯自心之所现故。但以愚夫分别自心种种诸法着种种相。而作是说。令知所见皆是自心。断我我所一切见着。离作所作诸恶因缘。觉唯心故转其意乐。善明诸地入佛境界。舍五法自性诸分别见。是故我说虚妄分别执着种种自心所现诸境界生。如实了知则得解脱。尔时世尊重说颂言
诸因及与缘 从此生世间
与四句相应 不知于我法
世非有无生 亦非俱不俱
云何诸愚夫 分别因缘起
非有亦非无 亦复非有无
如是观世间 心转证无我
一切法不生 以从缘生故
诸缘之所作 所作法非生
果不自生果 有二果失故
无有二果故 非有性可得
观诸有为法 离能缘所缘
决定唯是心 故我说心量
量之自性处 缘法二俱离
究竟妙净事 我说名心量
施设假名我 而实不可得
诸蕴蕴假名 亦皆无实事
有四种平等 相因及所生
无我为第四 修行者观察
离一切诸见 及能所分别
无得亦无生 我说是心量
非有亦非无 有无二俱离
如是心亦离 我说是心量
真如空实际 涅槃及法界
种种意成身 我说是心量
妄想习气缚 种种从心生
众生见为外 我说是心量
外所见非有 而心种种现
身资及所住 我说是心量
    尔时大慧菩萨摩诃萨。复白佛言。世尊。如来说言。如我所说。汝及诸菩萨。不应依语而取其义。世尊。何故不应依语取义。云何为语云何为义。佛言。谛听当为汝说。大慧言唯。佛言。大慧。语者所谓分别习气而为其因。依于喉舌唇齶齿辅。而出种种音声文字。相对谈说。是名为语。云何为义。菩萨摩诃萨住独一静处。以闻思修慧思惟观察向涅槃道自智境界。转诸习气。行于诸地种种行相。是名为义。复次大慧。菩萨摩诃萨善于语义。知语与义不一不异。义之与语亦复如是。若义异语。则不应因语而显于义。而因语见义如灯照色。大慧。譬如有人持灯照物知此物如是在如是处。菩萨摩诃萨亦复如是。因语言灯入离言说自证境界。复次大慧。若有于不生不灭自性涅槃三乘一乘五法诸心自性等中如言取义。则堕建立及诽谤见。以异于彼起分别故。如见幻事计以为实。是愚夫见非贤圣也。尔时世尊重说颂言
若随言取义 建立于诸法
以彼建立故 死堕地狱中
蕴中无有我 非蕴即是我
不如彼分别 亦复非无有
如愚所分别 一切皆有性
若如彼所见 皆应见真实
一切染净法 悉皆无体性
不如彼所见 亦非无所有
    复次大慧。我当为汝说智识相。汝及诸菩萨摩诃萨。若善了知智识之相。则能疾得阿耨多罗三藐三菩提。大慧。智有三种。谓世间智。出世间智。出世间上上智。云何世间智。谓一切外道凡愚计有无法。云何出世间智。谓一切二乘着自共相。云何出世间上上智。谓诸佛菩萨观一切法皆无有相。不生不灭非有非无。证法无我入如来地。大慧。复有三种智。谓知自相共相智。知生灭智。知不生不灭智。复次大慧。生灭是识。不生灭是智。堕相无相及以有无种种相因。是识。离相无相及有无因是智。有积集相是识。无积集相是智。着境界相是识。不着境界相是智。三和合相应生是识。无碍相应自性相是智。有得相是识。无得相是智。证自圣智所行境界。如水中月不入不出故。尔时世尊重说颂言
采集业为心 观察法为智
慧能证无相 逮自在威光
境界缚为心 觉想生为智
无相及增胜 智慧于中起
心意及与识 离诸分别想
得无分别法 佛子非声闻
寂灭殊胜忍 如来清净智
生于善胜义 远离诸所行
我有三种智 圣者能明照
分别于诸相 开示一切法
我智离诸相 超过于二乘
以诸声闻等 执着诸法有
如来智无垢 了达唯心故
    复次大慧。诸外道有九种转变见。所谓形转变。相转变。因转变。相应转变。见转变。生转变。物转变。缘明了转变。所作明了转变。是为九。一切外道因是见故。起有无转变论。此中形转变者。谓形别异见。譬如以金作庄严具。环钏璎珞种种不同。形状有殊金体无易。一切法变亦复如是。诸余外道种种计着。皆非如是亦非别异。但分别故一切转变。如是应知。譬如乳酪酒果等熟。外道言此皆有转变。而实无有若有若无。自心所见无外物故。如此皆是愚迷凡夫。从自分别习气而起。实无一法若生若灭。如因幻梦所见诸色。如石女儿说有生死。尔时世尊重说颂言
形处时转变 大种及诸根
中有渐次生 妄想非明智
诸佛不分别 缘起及世间
但诸缘世间 如乾闼婆城
    尔时大慧菩萨摩诃萨。复白佛言。世尊。惟愿如来。为我解说于一切法深密义及解义相。令我及诸菩萨摩诃萨善知此法。不堕如言取义深密执着。离文字语言虚妄分别。普入一切诸佛国土。力通自在总持所印。觉慧善住十无尽愿。以无功用种种变现。光明照曜如日月摩尼地水火风。住于诸地离分别见。知一切法如幻如梦。入如来位普化众生。令知诸法虚妄不实。离有无品断生灭执。不着言说令转所依。佛言谛听当为汝说。大慧。于一切法如言取义执着深密其数无量。所谓相执着。缘执着。有非有执着。生非生执着。灭非灭执着。乘非乘执着。为无为执着。地地自相执着。自分别现证执着外道宗有无品执着。三乘一乘执着。大慧。此等密执有无量种。皆是凡愚自分别执而密执着。此诸分别如蚕作茧。以妄想丝自缠缠他。执著有无欲乐坚密。大慧。此中实无密非密相。以菩萨摩诃萨见一切法住寂静故。无分别故。若了诸法唯心所见。无有外物皆同无相。随顺观察。于若有若无分别密执。悉见寂静。是故无有密非密相。大慧。此中无缚亦无有解。不了实者见缚解耳。何以故。一切诸法若有若无。求其体性不可得故。复次大慧。愚痴凡夫有三种密缚。谓贪恚痴及爱来生与贪喜俱。以此密缚令诸众生续生五趣。密缚若断。是则无有密非密相。复次大慧。若有执着三和合缘。诸识密缚次第而起。有执着故则有密缚。若见三解脱离三和合识。一切诸密皆悉不生。尔时世尊重说颂言
不实妄分别 是名为密相
若能如实知 诸密网皆断
凡愚不能了 随言而取义
譬如蚕处茧 妄想自缠缚
    尔时大慧菩萨摩诃萨。复白佛言。世尊。如世尊说。由种种心分别诸法。非诸法有自性。此但妄计耳。世尊。若但妄计无诸法者。染净诸法将无悉坏。佛言。大慧。如是如是如汝所说。一切凡愚分别诸法。而诸法性非如是有。此但妄执无有性相。然诸圣者以圣慧眼如实知见有诸法自性。大慧白言。若诸圣人以圣慧眼见有诸法性。非天眼肉眼。不同凡愚之所分别。云何凡愚得离分别。不能觉了诸圣法故。世尊。彼非颠倒非不颠倒。何以故。不见圣人所见法故。圣见远离有无相故。圣亦不如凡所分别如是得故。非自所行境界相故。彼亦见有诸法性相。如妄执性。而显现故。不说有因及无因故。堕于诸法性相见故。世尊。其余境界既不同此。如是则成无穷之失。孰能于法了知性相。世尊。诸法性相不因分别。云何而言以分别故而有诸法。世尊。分别相异诸法相异。因不相似。云何诸法而由分别。复以何故凡愚分别不如是有。而作是言。为令众生舍分别故。说如分别所见法相无如是法。世尊。何故令诸众生离有无见所执着法。而复执着圣智境界堕于有见。何以故。不说寂静空无之法。而说圣智自性事故。佛言。大慧。我非不说寂静空法堕于有见。何以故。已说圣智自性事故。我为众生无始时来计着于有。于寂静法以圣事说。今其闻已不生恐怖。能如实证寂静空法。离惑乱相入唯识理。知其所见无有外法。悟三脱门获如实印。见法自性了圣境界。远离有无一切诸着。复次大慧。菩萨摩诃萨不应成立一切诸法皆悉不生。何以故。一切法本无有故。及彼宗因生相故。复次大慧。一切法不生此言自坏。何以故。彼宗有待而生故。又彼宗即入一切法中。不生相亦不生故。又彼宗诸分而成故。又彼宗有无法皆不生。此宗即入一切法中。有无相亦不生故。是故一切法不生此宗自坏。不应如是立诸分多过故。展转因异相故。如不生一切法空无自性亦如是。大慧。菩萨摩诃萨应说一切法如幻如梦。见不见故。一切皆是惑乱相故。除为愚夫而生恐怖。大慧。凡夫愚痴堕有无见。莫令于彼而生惊恐远离大乘。尔时世尊重说颂言
无自性无说 无事无依处
凡愚妄分别 恶觉如死尸
一切法不生 外道所成立
以彼所有生 非缘所成故
一切法不生 智者不分别
彼宗因生故 此觉则便坏
譬如目有瞖 妄想见毛轮
诸法亦如是 凡愚妄分别
三有唯假名 无有实法体
由此假施设 分别妄计度
假名诸事相 动乱于心识
佛子悉超过 游行无分别
无水取水相 斯由渴爱起
凡愚见法尔 诸圣则不然
圣人见清净 生于三解脱
远离于生灭 常行无相境
修行无相境 亦复无有无
有无悉平等 是故生圣果
云何法有无 云何成平等
若心不了法 内外斯动乱
了已则平等 乱相尔时灭
    尔时大慧菩萨摩诃萨。复白佛言。世尊。如佛所说。若知境界但是假名都不可得。则无所取。无所取故亦无能取。能取所取二俱无故不起分别。说名为智。世尊。何故彼智不得于境。为不能了一切诸法自相共相一异义故言不得耶。为以诸法自相共相种种不同更相隐蔽而不得耶。为山岩石壁帘幔帷障之所覆隔而不得耶。为极远极近老小盲冥诸根不具而不得耶。若不了诸法自相共相一异义故言不得者。此不名智应是无智。以有境界而不知故。若以诸法自相共相种种不同更相隐蔽而不得者。此亦非智。以知于境说名为智非不知故。若山岩石壁帘幔帷障之所覆隔极远极近老小盲冥而不知者。彼亦非智。以有境界智不具足而不知故。佛言大慧。此实是智非如汝说。我之所说非隐覆说。我言境界唯是假名不可得者。以了但是自心所见外法有无。智慧于中毕竟无得。以无得故尔焰不起。入三脱门智体亦忘。非如一切觉想凡夫无始已来戏论熏习计着外法若有若无种种形相。如是而知名为不知不了诸法唯心所见。着我我所分别境智。不知外法是有是无。其心住于断见中故。为令舍离如是分别。说一切法唯心建立。尔时世尊重说颂言
若有于所缘 智慧不观见
彼无智非智 是名妄计者
无边相互隐 障碍及远近
智慧不能见 是名为邪智
老小诸根冥 而实有境界
不能生智慧 是名为邪智
    复次大慧。愚痴凡夫无始虚伪。恶邪分别之所幻惑。不了如实及言说法。计心外相着方便说。不能修习清净真实离四句法。大慧白言。如是如是诚如尊教。愿为我说如实之法及言说法。令我及诸菩萨摩诃萨于此二法而得善巧。非外道二乘之所能入。佛言谛听当为汝说。大慧。三世如来有二种法。谓言说法及如实法。言说法者。谓随众生心为说种种诸方便教。如实法者。谓修行者于心所现离诸分别。不堕一异俱不俱品。超度一切心意意识。于自觉圣智所行境界。离诸因缘相应见相。一切外道声闻缘觉堕二边者。所不能知。是名如实法。此二种法。汝及诸菩萨摩诃萨当善修学。尔时世尊复说颂言
我说二种法 言教及如实
教法示凡夫 实为修行者
    尔时大慧菩萨摩诃萨。复白佛言。世尊。如来一时说卢迦耶陀咒术词论。但能摄取世间财利。不得法利。不得法利不应亲近承事供养。世尊何故作如是说。佛言大慧。卢迦耶陀所有词论。但饰文句诳惑凡愚。随顺世间虚妄言说。不如于义不称于理。不能证入真实境界。不能觉了一切诸法。恒堕二边自失正道。亦令他失轮回诸趣永不出离。何以故。不了诸法唯心所见。执着外境增分别故。是故我说世论文句因喻庄严但诳愚夫。不能解脱生老病死忧悲等患。大慧。释提桓因广解众论自造诸论。彼世论者有一弟子。现作龙身诣释天宫。而立论宗作是要言。憍尸迦。我共汝论。汝若不如。我当破汝千辐之轮。我若不如。断一一头以谢所屈。说是语已。即以论法摧伏帝释。坏千辐轮还来人间。大慧。世间言论因喻庄严。乃至能现龙形。以妙文词迷惑诸天及阿修罗。令其执着生灭等见。而况于人。是故大慧。不应亲近承事供养。以彼能作生苦因故。大慧。世论唯说身觉境界。大慧。彼世论有百千字句。后末世中恶见乖离邪众崩散。分成多部各执自因。大慧。非余外道能立教法。唯卢迦耶以百千句。广说无量差别因相。非如实理。亦不自知是惑世法。尔时大慧白言。世尊。若卢迦耶所造之论。种种文字因喻庄严。执着自宗非如实法。名外道者。世尊。亦说世间之事。谓以种种文句言词广说十方一切国土天人等众而来集会。非是自智所证之法。世尊亦同外道说耶。佛言。大慧。我非世说亦无来去。我说诸法不来不去。大慧。来者集生。去者坏灭。不来不去。此则名为不生不灭。大慧。我之所说不同外道堕分别中。何以故。外法有无无所著故。了唯自心不见二取。不行相境不生分别。入空无相无愿之门而解脱故。大慧。我忆有时于一处住。有世论婆罗门来至我所。遽问我言。瞿昙。一切是所作耶。我时报言。婆罗门一切所作。是初世论。又问我言。一切非所作耶。我时报言。一切非所作是第二世论。彼复问言。一切常耶一切无常耶。一切生耶一切不生耶。我时报言。是第六世论。彼复问言。一切一耶一切异耶。一切俱耶一切不俱耶。一切皆由种种因缘而受生耶。我时报言。是第十一世论。彼复问言。一切有记耶一切无记耶。有我耶无我耶。有此世耶无此世耶。有他世耶无他世耶。有解脱耶无解脱耶。是刹那耶非刹那耶。虚空涅槃及非择灭。是所作耶非所作耶。有中有耶无中有耶。我时报言。婆罗门。如是皆是汝之世论非我所说。婆罗门。我说因于无始戏论诸恶习气而生三有。不了唯是自心所见。而取外法实无可得。如外道说。我及根境三合知生。我不如是。我不说因。不说无因。唯缘妄心似能所取。而说缘起。非汝及余取着我者之所能测。大慧。虚空涅槃及非择灭。但有三数本无体性。何况而说作与。非作。大慧。尔时世论婆罗门。复问我言。无明爱业为因缘故。有三有耶为无因耶。我言此二亦是世论。又问我言。一切诸法皆入自相及共相耶。我时报言。此亦世论。婆罗门。乃至少有心识流动分别外境皆是世论。大慧。尔时彼婆罗门复问我言。颇有非是世论者不。一切外道所有词论。种种文句因喻庄严。莫不皆从我法中出。我报言有。非汝所许非世不许。非不说种种文句义理相应非不相应。彼复问言。岂有世许非世论耶。我答言有。但非于汝及以一切外道能知。何以故。以于外法虚妄分别生执着故。若能了达有无等法一切皆是自心所见。不生分别不取外境。于自处住。自处住者是不起义。不起于何不起分别。此是我法非汝有也。婆罗门。略而言之。随何处中心识往来死生求恋。若受若见若触若住。取种种相和合相续。于爱于因而生计着。皆汝世论非是我法。大慧。世论婆罗门作如是问。我如是答。不问于我自宗实法。默然而去。作是念言。沙门瞿昙无可尊重。说一切法无生无相无因无缘。唯是自心分别所见。若能了此分别不生。大慧。汝今亦复问我是义。何故亲近诸世论者。唯得财利不得法利。大慧白言。所言财法是何等义。佛言。善哉。汝乃能为未来众生思惟是义。谛听谛听当为汝说。大慧。所言财者。可触可受可取可味。令着外境堕在二边。增长贪爱生老病死忧悲苦恼。我及诸佛说名财利。亲近世论之所获得。云何法利。谓了法是心见二无我。不取于相无有分别。善知诸地离心意识。一切诸佛所共灌顶。具足受行十无尽愿。于一切法悉得自在。是名法利。以是不堕一切诸见戏论分别常断二边。大慧外道世论令诸痴人堕在二边。谓常及断。受无因论则起常见。以因坏灭则生断见。我说不见生住灭者名得法利。是名财法二差别相。汝及诸菩萨摩诃萨应勤观察。尔时世尊重说颂言
调伏摄众生 以戒降诸恶
智慧灭诸见 解脱得增长
外道虚妄说 皆是世俗论
横计作所作 不能自成立
唯我一自宗 不着于能所
为诸弟子说 令离于世论
能取所取法 唯心无所有
二种皆心现 断常不可得
乃至心流动 是则为世论
分别不起者 是人见自心
来者见事生 去者事不现
明了知来去 不起于分别
有常及无常 所作无所作
此世他世等 皆是世论法
    尔时大慧菩萨摩诃萨。复白佛言。世尊。佛说涅槃。说何等法以为涅槃。而诸外道种种分别。佛言大慧。如诸外道分别涅槃。皆不随顺涅槃之相。谛听谛听当为汝说。大慧。或有外道言。见法无常不贪境界。蕴界处灭心心所法不现在前。不念过现未来境界。如灯尽如种败。如火灭。诸取不起分别不生。起涅槃想。大慧。非以见坏名为涅槃。或谓至方名得涅槃。境界想离犹如风止。或谓不见能觉所觉名为涅槃。或谓不起分别常无常见名得涅槃。或有说言。分别诸相发生于苦。而不能知自心所现。以不知故怖畏于相以求无相。深生爱乐执为涅槃。或谓觉知内外诸法自相共相去来现在有性不坏。作涅槃想。或计我人众生寿命及一切法无有坏灭。作涅槃想复有外道无有智慧。计有自性及以士夫求那转变作一切物以为涅槃。或有外道计福非福尽。或计不由智慧诸烦恼尽。或计自在是实作者以为涅槃。或谓众生展转相生。以此为因更无异因。彼无智故不能觉了。以不了故执为涅槃。或计证于谛道虚妄分别以为涅槃。或计求那与求那者而共和合一性异性俱及不俱。执为涅槃。或计诸物从自然生。孔雀文彩棘针铦利。生宝之处出种种宝。如此等事是谁能作。即执自然以为涅槃。或谓能解二十五谛即得涅槃。或有说言。能受六分守护众生斯得涅槃。或有说言。时生世间时即涅槃。或执有物以为涅槃。或计无物以为涅槃。或有计著有物无物为涅槃者。或计诸物与涅槃无别。作涅槃想。大慧。复有异彼外道所说。以一切智大师子吼说。能了达唯心所现不取外境。远离四句住如实见。不堕二边离能所取。不入诸量不着真实。住于圣智所现证法。悟二无我离二烦恼。净二种障转修诸地入于佛地。得如幻等诸大三昧。永超心意及以意识名得涅槃。大慧。彼诸外道虚妄计度不如于理智者所弃。皆堕二边作涅槃想。于此无有若住若出。彼诸外道皆依自宗而生妄觉。违背于理无所成就。唯令心意驰散往来。一切无有得涅槃者。汝及诸菩萨宜应远离。尔时世尊重说颂言
外道涅槃见 各各异分别
彼唯是妄想 无解脱方便
远离诸方便 不至无缚处
妄生解脱想 而实无解脱
外道所成立 众智各异取
彼悉无解脱 愚痴妄分别
一切痴外道 妄见作所作
悉著有无论 是故无解脱
凡愚乐分别 不生真实慧
言说三界本 真实灭苦因
譬如镜中像 虽现而非实
习气心镜中 凡愚见有二
不了唯心现 故起二分别
若知但是心 分别则不生
心即是种种 远离想所相
如愚所分别 虽见而无见
三有唯分别 外境悉无有
妄想种种现 凡愚不能觉
经经说分别 但是异名字
若离于语言 其义不可得

    大乘入楞伽经卷第四

    大乘入楞伽经卷第五
    大周于阗国三藏法师实叉难陀奉　敕译
    无常品第三之余
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿为我说如来应正等觉自觉性。令我及诸菩萨摩诃萨而得善巧自悟悟他。佛言。大慧。如汝所问当为汝说。大慧言唯。世尊。如来应供正等觉。为作非作。为果为因。为相所相。为说所说。为觉所觉。如是等为异不异。佛言。大慧。如来应正等觉。非作非非作。非果非因。非相非所相。非说非所说。非觉非所觉。何以故。俱有过故。大慧。若如来是作则是无常。若是无常一切作法应是如来。我及诸佛皆不忍可。若非作法则无体性。所修方便悉空无益。同于兔角石女之子。非作因成故。若非因非果则非有非无。若非有非无则超过四句。言四句者。但随世间而有言说。若超过四句。惟有言说则如石女儿。大慧。石女儿者惟有言说不堕四句。以不堕故不可度量。诸有智者。应如是知如来所有一切句义。大慧。如我所说诸法无我。以诸法中无有我性故说无我。非是无有诸法自性。如来句义应知亦然。大慧。譬如牛无马性马无牛性。非无自性。一切诸法亦复如是。无有自相。而非有即有。非诸凡愚之所能知。何故不知。以分别故。一切法空。一切法无生。一切法无自性。悉亦如是。大慧。如来与蕴非异非不异。若不异者应是无常。五蕴诸法是所作故。若异者。如牛二角有异不异。互相似故不异。长短别故有异。如牛右角异左左角异右。长短不同色相各别。然亦不异。如于蕴于界处等。一切法亦如是。大慧。如来者依解脱说。如来解脱非异非不异。若异者。如来便与色相相应。色相相应即是无常。若不异者。修行者见应无差别。然有差别故非不异。如是智与所知。非异非不异。若非异非不异。则非常非无常。非作非所作。非为非无为。非觉非所觉。非相非所相。非蕴非异蕴。非说非所说。非一非异。非俱非不俱。以是义故超一切量。超一切量故惟有言说。惟有言说故则无有生。无有生故则无有灭。无有灭故则如虚空。大慧。虚空非作非所作。非作非所作故远离攀缘。远离攀缘故出过一切诸戏论法。出过一切诸戏论法。即是如来。如来即是正等觉体。正等觉者永离一切诸根境界。尔时世尊重说颂曰
出过诸根量 非果亦非因
相及所相等 如是悉皆离
蕴缘与正觉 一异莫能见
既无有见者 云何起分别
非作非非作 非因非非因
非蕴非不蕴 亦不离余物
非有一法体 如彼分别见
亦复非是无 诸法性如是
待有故成无 待无故成有
无既不可取 有亦不应说
不了我无我 但着于语言
彼溺于二边 自坏坏世间
若能见此法 则离一切过
是名为正观 不毁大导师
    尔时大慧菩萨摩诃萨复白佛言。世尊。如佛经中分别摄取不生不灭。言此即是如来异名。世尊。愿为我说不生不灭此则无法。云何说是如来异名。如世尊说。一切诸法不生不灭。当知此则堕有无见。世尊。若法不生则不可取。无有少法谁是如来。惟愿世尊为我宣说。佛言。谛听当为汝说。大慧。我说如来非是无法。亦非摄取不生不灭。亦不待缘亦非无义。我说无生即是如来意生法身别异之名。一切外道声闻独觉七地菩萨不了其义。大慧。譬如帝释地及虚空乃至手足。随一一物各有多名。非以名多而有多体。亦非无体。大慧。我亦如是。于此娑婆世界。有三阿僧祇百千名号。诸凡愚人虽闻虽说。而不知是如来异名。其中或有知如来者。知无师者。知导师者。知胜导者。知普导者。知是佛者。知牛王者。知梵王者。知毗纽者。知自在者。知是胜者。知迦毗罗者。知真实边者。知无尽者。知瑞相者。知如风者。知如火者。知如俱毗罗者。知如月者。知如日者。知如王者。知如仙者。知戌迦者。知因陀罗者。知明星者。知大力者。知如水者。知无灭者。知无生者。知性空者。知真如者。知是谛者。知实性者。知实际者。知法界者。知涅槃者。知常住者。知平等者。知无二者。知无相者。知寂灭者。知具相者。知因缘者。知佛性者。知教导者。知解脱者。知道路者。知一切智者。知最胜者。知意成身者。如是等满足三阿僧祇百千名号。不增不减。于此及余诸世界中。有能知我如水中月不入不出。但诸凡愚心没二边不能解了。然亦尊重承事供义。而不善解名字句义。执着言教昧于真实。谓无生无灭是无体性。不知是佛差别名号如因陀罗释揭罗等。以信言教昧于真实。于一切法如言取义。彼诸凡愚作如是言。义如言说义说无异。何以故。义无体故。是人不了言音自性。谓言即义无别义体。大慧。彼人愚痴。不知言说是生是灭义不生灭。大慧。一切言说堕于文字。义则不堕。离有离无故。无生无体故。大慧。如来不说堕文字法。文字有无不可得故。惟除不堕于文字者。大慧。若人说法堕文字者是虚诳说。何以故。诸法自性离文字故。是故大慧。我经中说。我与诸佛及诸菩萨。不说一字不答一字。所以者何。一切诸法离文字故非不随义而分别说。大慧。若不说者教法则断。教法断者则无声闻缘觉菩萨诸佛。若总无者谁说为谁。是故大慧。菩萨摩诃萨应不著文字随宜说法。我及诸佛皆随众生烦恼解欲。种种不同而为开演。令知诸法自心所见无外境界。舍二分别转心意识。非为成立圣自证处。大慧。菩萨摩诃萨应随于义莫依文字。依文字者堕于恶见。执着自宗而起言说。不能善了一切法相文辞章句。既自损坏亦坏于他。不能令人心得悟解。若能善知一切法相文辞句义悉皆通达。则能令自身受无相乐。亦能令他安住大乘。若能令他安住大乘。则得一切诸佛声闻缘觉及诸菩萨之所摄受。若得诸佛声闻缘觉及诸菩萨之所摄受。则能摄受一切众生。若能摄受一切众生。则能摄受一切正法。若能摄受一切正法则不断佛种。若不断佛种则得胜妙处。大慧。菩萨摩诃萨生胜妙处。欲令众生安住大乘。以十自在力现众色像。随其所宜说真实法。真实法者。无异无别不来不去。一切戏论悉皆息灭。是故大慧。善男子善女人。不应如言执着于义。何以故。真实之法离文字故。大慧。譬如有人以指指物。小儿观指不观于物。愚痴凡夫亦复如是。随言说指而生执着。乃至尽命终不能舍文字之指取第一义。大慧。譬如婴儿应食熟食。有人不解成熟方便。而食生者则发狂乱。不生不灭亦复如是。不方便修则为不善。是故宜应善修方便。莫随言说如观指端。大慧。实义者微妙寂静是涅槃因。言说者与妄想合流转生死。大慧。实义者从多闻得。多闻者谓善于义非善言说。善义者不随一切外道恶见。身自不随亦令他不随。是则名曰于义多闻。欲求义者应当亲近。与此相违著文字者宜速舍离
    尔时大慧菩萨摩诃萨承佛威神。复白佛言。世尊。如来演说不生不灭非为奇特。何以故。一切外道亦说作者不生不灭。世尊亦说虚空涅槃及非数灭不生不灭。外道亦说作者因缘生于世间。世尊亦说无明爱业生诸世间。俱是因缘但名别耳。外物因缘亦复如是。是故佛说与外道说无有差别。外道说言。微尘胜妙自在生主等。如是九物不生不灭。世尊亦说一切诸法不生不灭。若有若无皆不可得。世尊。大种不坏。以其自相不生不灭。周流诸趣。不舍自性。世尊。分别虽稍变异。一切无非外道已说。是故佛法同于外道。若有不同愿佛为演。有何所以佛说为胜。若无别异外道即佛。以其亦说不生不灭故。世尊常说一世界中无有多佛。如向所说是则应有。佛言。大慧。我之所说不生不灭。不同外道不生不灭不生无常论。何以故。外道所说。有实性相不生不变。我不如是堕有无品。我所说法非有非无离生离灭。云何非无。如幻梦色种种见故。云何非有。色相自性非是有故。见不见故。取不取故。是故我说一切诸法非有非无。若觉惟是自心所见。住于自性分别不生。世间所作悉皆永息。分别者是凡愚事非贤圣耳。大慧。妄心分别不实境界。如乾闼婆城幻所作人。大慧。譬如小儿见乾闼婆城及以幻人商贾入出。迷心分别言有实事。凡愚所见生与不生有为无为悉亦如是。如幻人生如幻人灭。幻人其实不生不灭。诸法亦尔离于生灭。大慧凡夫虚妄起生灭见非诸圣人。言虚妄者。不如法性起颠倒见。颠倒见者。执法有性不见寂灭。不见寂灭故。不能远离虚妄分别。是故大慧。无相见胜。非是相见。相是生因。若无有相则无分别。不生不灭则是涅槃。大慧。言涅槃者。见如实处舍离分别心心所法。获于如来内证圣智。我说此是寂灭涅槃。尔时世尊重说颂言
为除有生执 成立无生义
我说无因论 非愚所能了
一切法无生 亦非是无法
如干城幻梦 虽有而无因
空无生无性 云何为我说
离诸和合缘 智慧不能见
以是故我说 空无生无性
一一缘和合 虽现而非有
分析无和合 非如外道见
如梦及垂发 野马与干城
无因而妄现 世事皆如是
折伏有因论 申述无生旨
无生义若存 法眼恒不灭
我说无因论 外道咸惊怖
云何何所因 复以何故生
于何处和合 而作无因论
观察有为法 非因非无因
彼生灭论者 所见从是灭
为无故不生 为待于众缘
为有名无义 愿为我宣说
非无法不生 亦非以待缘
非有物而名 亦非名无义
一切诸外道 声闻及缘觉
十住非所行 此是无生相
远离诸因缘 无有能作者
惟心所建立 我说是无生
诸法非因生 非无亦非有
能所分别离 我说是无生
惟心无所见 亦离于二性
如是转所依 我说是无生
外物有非有 其心无所取
一切见咸断 此是无生相
空无性等句 其义皆如是
非以空故空 无生故说空
因缘共集会 是故有生灭
分散于因缘 生灭则无有
若离诸因缘 则更无有法
一性及异性 凡愚所分别
有无不生法 俱非亦复然
惟除众缘会 于中见起灭
随俗假言说 因缘递钩琐
若离因缘琐 生义不可得
我说惟钩琐 生无故不生
离诸外道过 非凡愚所了
若离缘钩琐 别有生法者
是则无因论 破坏钩琐义
如灯能照物 钩琐现若然
此则离钩琐 别有于诸法
无生则无性 体相如虚空
离钩琐求法 愚夫所分别
复有余无生 众圣所得法
彼生无生者 是则无生忍
一切诸世间 无非是钩琐
若能如是解 此人心得定
无明与爱业 是则内钩琐
种子泥轮等 如为名为外
若言有他法 而从因缘生
离于钩琐义 此则非教理
生法若非有 彼为谁因缘
展转而相生 此是因缘义
坚湿暖动等 凡愚所分别
但缘无有法 故说无自性
如医疗众病 其论无差别
以病不同故 方药种种殊
我为诸众生 灭除烦恼病
知其根胜劣 演说诸法门
非烦恼根异 而有种种法
惟有一大乘 清凉八支道
    尔时大慧菩萨摩诃萨复白佛言。世尊。一切外道妄说无常。世尊亦言诸行无常是生灭法。未知此说是邪是正。所言无常复有几种。佛言。大慧。外道说有七种无常。非是我法。何等为七。谓有说始起即舍是名无常。生已不生无常性故。有说形处变坏是名无常。有说色即无常。有说色之变异是名无常。一切诸法相续不断。能令变异自然归灭。犹如乳酪前后变异。虽不可见然在法中坏一切法。有说物无常。有说物无物无常。有说不生无常。遍住一切诸法之中。其中物无物无常者。谓能造所造其相灭坏。大种自性本来无起。不生无常者。谓常与无常有无等法。如是一切皆无有起。乃至分析至于微尘亦无所见。以不起故说名无生。此是不生无常相。若不了此则堕外道生无常义。有物无常义有物无常者。谓于非常非无常处。自生分别。其义云何。彼立无常自不灭坏能坏诸法。若无无常坏一切法。法终不灭成于无有。如杖捶瓦石能坏于物而自不坏。此亦如是。大慧。现见无常与一切法。无有能作所作差别。云此是无常。此是所作无差别故。能作所作应俱是常。不见有因。能令诸法成于无故。大慧。诸法坏灭实亦有因。但非凡愚之所能了。大慧。异因不应生于异果。若能生者。一切异法应并相生。彼法此法能生所生应无有别。现见有别。云何异因生于异果。大慧。若无常性是有法者。应同所作自是无常。自无常故。所无常法皆应是常。大慧。若无常性住诸法中。应同诸法堕于三世。与过去色同时已灭。未来不生现在俱坏。一切外道计四大种体性不坏色者。即是大种差别大种造色。离异不异故。其自性亦不坏灭。大慧。三有之中能造所造。莫不皆是生住灭相。岂更别有无常之性。能生于物而不灭耶。始造即舍无常者。非大种互造大种。以各别故。非自相造。以无异故。非复共造。以乖离故。当知非是始造无常。形状坏无常者。此非能造及所造坏。但形状坏。其义云何。谓分柝色乃至微尘。但灭形状长短等见。不灭能造所造色体。此见堕在数论之中。色即是无常者。谓此即是形状无常非大种性。若大种性亦无常者则无世事。无世事者。当知则堕卢迦耶见以见一切法自相生惟有言说故。转变无常者。谓色体变非大种变。譬如以金作庄严具。严具有变而金无改。此亦如是。大慧。如是等种种外道。虚妄分别见无常性。彼作是说。火不能烧诸火自相。但各分散。若能烧者。能造所造则皆断灭。大慧。我说诸法非常无常。何以故。不取外法故。三界唯心故。不说诸相故。大种性处种种差别不生不灭故。非能造所造故。能取所取二种体性一切皆从分别起故。如实而知二取性故。了达惟是自心现故。离外有无二种见故。离有无见则不分别能所造故。大慧。世间出世间及出世间上上诸法。惟是自心非常非无常。不能了达堕于外道二边恶见。大慧。一切外道不能解了此三种法。依自分别而起言说着无常性。大慧。此三种法所有语言分别境界。非诸凡愚之所能知。尔时世尊重说颂言
始造即便舍 形状有转变
色物等无常 外道妄分别
诸法无坏灭 诸大自性住
外道种种见 如是说无常
彼诸外道众 皆说不生灭
诸大性自常 谁是无常法
能取及所取 一切惟是心
二种从心现 无有我我所
梵天等诸法 我说惟是心
若离于心者 一切不可得

    大乘入楞伽经现证品第四
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿为我说一切声闻缘觉入灭次第相续相。令我及诸菩萨摩诃萨。善知此已于灭尽三昧乐心无所惑。不堕二乘及诸外道错乱之中。佛言。谛听当为汝说
    大慧。菩萨摩诃萨至于六地。及声闻缘觉入于灭定。七地菩萨念念恒入。离一切法自性相故非诸二乘。二乘有作堕能所取。不得诸法无差别相。了善不善自相共相入于灭定。是故不能念念恒入。大慧。八地菩萨声闻缘觉。心意意识分别想灭。始从初地乃至六地。观察三界一切唯是心意意识自分别起。难我我所不见外法种种诸相。凡愚不知由无始来过恶薰习。于自心内变作能取所取之相而生执着。大慧。八地菩萨所得三昧。同诸声闻缘觉涅槃。以诸佛力所加持故。于三昧门不入涅槃。若不持者便不化度一切众生。不能满足如来之地。亦则断绝如来种性。是故诸佛为说如来不可思议诸大功德。令其究竟不入涅槃。声闻缘觉着三昧乐。是故于中生涅槃想。大慧。七地菩萨善能观察心意意识我我所执生法无我。若生若灭自相共相。四无碍辩善巧决定。于三昧门而得自在。渐入诸地具菩提分法。大慧。我恐诸菩萨不善了知自相共相。不知诸地相续次第。堕于外道诸恶见中故如是说。大慧。彼实无有若生若灭。诸地次第三界往来。一切皆是自心所见。而诸凡愚不能了知。以不知故我及诸佛为如是说。大慧。声闻缘觉至于菩萨第八地中。为三昧乐之所昏醉。未能善了惟心所见。自共相习缠覆其心。着二无我生涅槃觉。非寂灭慧。大慧。诸菩萨摩诃萨见于寂灭三昧乐门。即便忆念本愿大悲。具足修行十无尽句。是故不即入于涅槃。以入涅槃不生果故。离能所取故。了达惟心故。于一切法无分别故。不堕心意及以意识外法性相执着中故。然非不起佛法正因。随智慧行如是起故。得于如来自证地故。大慧。如人梦中方便度河未度便觉。觉已思惟向之所见。为是真实为是虚妄。复自念言非实非妄。如是但是见闻觉知。曾所更事分别习气。离有无念意识梦中之所现耳。大慧。菩萨摩诃萨亦复如是。始从初地。而至七地。乃至增进入于第八得无分别。见一切法如幻梦等离能所取。见心心所广大力用。勤修佛法未证令证。离心意意识妄分别想获无生忍。此是菩萨所得涅槃非灭坏也。大慧。第一义中无有次第亦无相续。远离一切境界分别。此则名为寂灭之法。尔时世尊重说颂言
诸住及佛地 惟心无影像
此是去来今 诸佛之所说
七地是有心 八地无影像
此二地名住 余则我所得
自证及清净 此则是我地
摩醯最胜处 色究竟庄严
譬如大火聚 光焰炽然发
化现于三有 悦意而清凉
或有现变化 或有先时化
于彼说诸乘 皆是如来地
十地则为初 初则为八地
第九则为七 第七复为八
第二为第三 第四为第五
第三为第六 无相有何次

    大乘入楞伽经如来常无常品第五
    尔时大慧菩萨摩诃萨复白佛言。世尊。如来应正等觉。为常为无常。佛言。大慧。如来应正等觉。非常非无常。何以故。俱有过故。云何有过。大慧。若如来常者。有能作过。一切外道说能作常若无常者。有所作过。同于诸蕴为相所相。毕竟断灭而成无有。然佛如来实非断灭。大慧。一切所作如瓶衣等。皆是无常。是则如来有无常过。所修福智悉空无益。又诸作法应是如来。无异因故。是故如来非常非无常。复次大慧如来非常。若是常者。应如虚空不待因成。大慧。譬如虚空非常非无常何以故。离常无常若一若异俱不俱等诸过失故复次大慧。如来非常。若是常者。则是不生。同于兔马鱼蛇等角
    复次大慧。以别义故亦得言常。何以故。谓以现智证常法故。证智是常如来亦常。大慧。诸佛如来所证法性法住法位。如来出世若不出世常住不易。在于一切二乘外道所得法中。非是空无。然非凡愚之所能知。大慧。夫如来者。以清净慧内证法性而得其名。非以心意意识蕴界处法妄习得名。一切三界皆从虚妄分别而生。如来不从妄分别生。大慧。若有于二有常无常。如来无二。证一切法无生相故。是故非常亦非无常。大慧。乃至少有言说分别生。即有常无常过。是故应除二分别觉勿令少在。尔时世尊重说颂言
远离常无常 而现常无常
如是恒观佛 不生于恶见
若常无常者 所集皆无益
为除分别觉 不说常无常
乃至有所立 一切皆错乱
若见惟自心 是则无违诤

    大乘入楞伽经刹那品第六
    尔时大慧菩萨摩诃萨复白佛言。世尊。惟愿为我说蕴界处生灭之相。若无有我谁生谁灭。而诸凡夫依于生灭。不求尽苦不证涅槃。佛言。大慧。谛听谛听当为汝说。大慧。如来藏是善不善因。能遍兴造一切趣生。譬如伎儿变现诸趣离我我所。以不觉故三缘和合而有果生。外道不知执为作者。无始虚伪恶习所熏。名为藏识。生于七识无明住地。譬如大海而有波浪。其体相续恒注不断。本性清净离无常过离于我论。其余七识意意识等念念生灭。妄想为因境相为缘和合而生。不了色等自心所现。计著名相起苦乐受。名相缠缚。既从贪生复生于贪。若因及所缘。诸取根灭不相续生。自慧分别苦乐受者。或得灭定。或得四禅。或复善入诸谛解脱。便妄生于得解脱想。而实未舍未转如来藏中藏识之名若无藏识七识则灭。何以故。因彼及所缘而得生故。然非一切外道二乘诸修行者所知境界。以彼惟了人无我性。于蕴界处取于自相及共相故。若见如来藏五法自性诸法无我。随地次第而渐转灭。不为外道恶见所动。住不动地得于十种三昧乐门。为三昧力诸佛所持观察不思议佛法及本愿力。不住实际及三昧乐获自证智。不与二乘诸外道共。得十圣种性道及意生智身离于诸行。是故大慧。菩萨摩诃萨欲得胜法。应净如来藏藏识之名。大慧。若无如来藏名藏识者则无生灭。然诸凡夫及以圣人悉有生灭。是故一切诸修行者虽见内境界住现法乐。而不舍于勇猛精进。大慧。此如来藏藏识本性清净。客尘所染而为不净。一切二乘及诸外道。臆度起见不能现证。如来于此分明现见。如观掌中庵摩勒果。大慧。我为胜鬘夫人及余深妙净智菩萨。说如来藏名藏识与七识俱起。令诸声闻见法无我。大慧。为胜鬘夫人说佛境界。非是外道二乘境界。大慧。此如来藏藏识是佛境界。与汝等比净智菩萨随顺义者所行之处。非是一切执著文字外道二乘之所行处。是故汝及诸菩萨摩诃萨。于如来藏藏识。当勤观察。莫但闻已便生足想。尔时世尊重说颂言
甚深如来藏 而与七识俱
执着二种生 了知则远离
无始习所熏 如像现于心
若能如实观 境相悉无有
如愚见指月 观指不观月
计著文字者 不见我真实
心如工伎儿 意如和伎者
五识为伴侣 妄想观伎众
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿为我说五法自性诸识无我差别之相。我及诸菩萨摩诃萨。善知此已渐修诸地具诸佛法。至于如来自证之位。佛言。谛听当为汝说。大慧。五法自性诸识无我。所谓名相分别正智如如。若修行者观察此法。入于如来自证境界。远离常断有无等见。得现法乐甚深三昧。大慧。凡愚不了五法自性诸识无我。于心所现见有外物而起分别。非诸圣人。大慧白言。云何不了而起分别。佛言。大慧。凡愚不知名是假立。心随流动见种种相。计我我所染着于色。覆障圣智起贪嗔痴。造作诸业如蚕作茧。妄想自缠堕于诸趣生死大海。如汲水轮循环不绝。不知诸法如幻如焰如水中月自心所见妄分别起离能所取及生住灭。谓从自在时节微尘胜性而生随名相流。大慧。此中相者。谓眼识所见名之为色。耳鼻舌身意识得者。名之为声香味触法。如是等我说为相。分别者。施设众名显示诸相。谓以象马车步男女等名而显其相。此事如是决定不异。是名分别。正智者。谓观其相互为其客。识心不起不断不常。不随外道二乘之地。是名正智。大慧。菩萨摩诃萨以其正智观察名相。非有非无远离损益二边恶见。名相及识本来不起。我说此法名为如如。大慧。菩萨摩诃萨住如如已得无照现境。升欢喜地离外道恶趣。入出世法法相淳熟。知一切法犹如幻等证自圣智所行之法。离臆度见。如是次第乃至法云。至法云已三昧诸力自在神通。开敷满足成于如来。成如来已为众生故。如水中月普现其身。随其欲乐。而为说法。其身清净离心意识。被弘誓甲。具足成满十无尽愿。是名菩萨摩诃萨入于如如之所获得
    尔时大慧菩萨摩诃萨复白佛言。世尊。为三性入五法中。为各有自相。佛言。大慧。三性八识及二无我悉入五法。其中名及相是妄计性。以依彼分别心心所法俱时而起。如日与光是缘起性。正智如如不可坏故。是圆成性。大慧。于自心所现生执着时。有八种分别起。此差别相皆是不实。惟妄计性。若能舍离二种我执。二无我智即得生长。大慧。声闻缘觉菩萨如来。自证圣智诸地位次。一切佛法悉皆摄入此五法中。复次大慧。五法者。所谓相名分别如如正智。此中相者。谓所见色等形状各别。是名为相。依彼诸相立瓶等名。此如是此不异。是名为名。施设众名显示诸相心心所法。是名分别。彼名彼相毕竟无有。但是妄心展转分别。如是观察乃至觉灭。是名如如大慧。真实决定究竟根本自性可得。是如如相。我及诸佛随顺证入。如其实相开示演说。若能于此随顺悟解。离断离常不生分别入自证处。出于外道二乘境界。是名正智。大慧。此五种法三性八识及二无我。一切佛法普皆摄尽大慧。于此法中汝应以自智善巧通达。亦劝他人令其通达。通达此已心则决定不随他转。尔时世尊重说颂言
五法三自性 及与八种识
二种无我法 普摄于大乘
名相及分别 二种自性摄
正智与如如 是则圆成相
    尔时大慧菩萨摩诃萨复白佛言。世尊。如经中说。过去未来现在诸佛如恒河沙。此当云何。为如言而受。为别有义
    佛告大慧。勿如言受大慧。三世诸佛非如恒沙。何以故。如来最胜超诸世间。无与等者非喻所及。唯以少分为其喻耳。我以凡愚诸外道等心恒执着常与无常。恶见增长生死轮回。令其厌离发胜悕望。言佛易成易可逢值。若言难遇如优昙华。彼便退怯不勤精进。是故我说如恒河沙。我复有时观受化者。说佛难值如优昙华。大慧。优昙钵华无有曾见现见当见。如来则有已见当见。大慧。如是譬喻非说自法。自法者内证圣智所行境界。世间无等过诸譬喻。一切凡愚不能信受。大慧。真实如来超心意意识所见之相。不可于中而立譬喻。然亦有时而为建立言。恒河沙等无有相违。大慧。譬如恒沙龟鱼象马之所贱踏。不生分别恒净无垢。如来圣智如彼恒河。力通自在以为其沙。外道龟鱼竞来扰乱。而佛不起一念分别。何以故。如来本愿以三昧乐普安众生。如恒河沙无有爱憎无分别故。大慧。譬如恒沙。是地自性劫尽烧时烧一切地。而彼地大不舍本性。恒与火大俱时生故诸凡愚人谓地被烧。而实不烧。火所因故。如来法身亦复如是。如恒河沙终不坏灭。大慧。譬如恒沙无有限量。如来光明亦复如是。为欲成就无量众生。普照一切诸佛大会。大慧。譬如恒沙住沙自性不更改变而作余物。如来亦尔。于世间中不生不灭。诸有生因悉已断故大慧。譬如恒沙取不知减投不见增。诸佛亦尔。以方便智成熟众生无减无增。何以故。如来法身无有身故。大慧。以有身故而有灭坏。法身无身故无灭坏。大慧。譬如恒沙虽苦压治欲求苏油终不可得。如来亦尔。虽为众生众苦所压。乃至蠢动未尽涅槃。欲令舍离于法界中。深心愿乐亦不可得。何以故。具足成就大悲心故。大慧。譬如恒沙随水而流非无水也。如来亦尔。所有说法莫不随顺涅槃之流。以是说言诸佛如来如恒河沙。大慧。如来说法不随于趣。趣是坏义。生死本际不可得知。既不可知云何说趣。大慧。趣义是断凡愚莫知。大慧菩萨复白佛言。若生死本际不可知者。云何众生在生死中而得解脱。佛言。大慧。无始虚伪过习因灭。了知外境自心所现。分别转依名为解脱。非灭坏也。是故不得言无边际。大慧。无边际者。但是分别异名。大慧。离分别心无别众生以智观察内外诸法。知与所知悉皆寂灭。大慧。一切诸法唯是自心分别所见。不了知故分别心起。了心则灭。尔时世尊重说颂言
观察诸导师 譬如恒河沙
非坏亦非趣 是人能见佛
譬如恒河沙 悉离一切过
而恒随顺流 佛体亦如是
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿为我说一切诸法刹那坏相。何等诸法名有刹那。佛言。谛听当为汝说。大慧。一切法者。所谓善法不善法。有为法无为法。世间法出世间法。有漏法无漏法。有受法无受法。大慧。举要言之。五取蕴法以心意意识习气为因而得增长。凡愚于此而生分别谓善不善。圣人现证三昧乐住。是则名为善无漏法。复次大慧。善不善者。所谓八识。何等为八。谓如来藏名藏识。意及意识并五识身。大慧。彼五识身与意识俱。善不善相展转差别相续不断。无异体生生已即灭。不了于境自心所现。次第灭时别识生起。意识与彼五识共俱。取于种种差别形相。刹那不住。我说此等名刹那法。大慧。如来藏名藏识。所与意等诸习气俱。是刹那法。无漏习气非刹那法。此非凡愚刹那论者之所能知。彼不能知一切诸法有是刹那非刹那故。彼计无为。同诸法坏堕于断见。大慧五识身非流转。不受苦乐非涅槃因。如来藏受苦乐与因俱有生灭。四种习气之所迷覆。而诸凡愚分别熏心。不能了知起刹那见。大慧。如金金刚佛之舍利。是奇特性终不损坏。若得证法有刹那者。圣应非圣。而彼圣人未曾非圣。如金金刚虽经劫住称量不减。云何凡愚不解于我秘密之说。于一切法作刹那想。大慧菩萨复白佛言。世尊。常说六波罗蜜若得满足便成正觉。何等为六。云何满足
    佛言。大慧。波罗蜜者。差别有三。所谓世间出世间出世间上上。大慧。世间波罗蜜者。谓诸凡愚着我我所执取二边。求诸有身贪色等境。如是修行檀波罗蜜持戒忍辱精进禅定。成就神通生于梵世。大慧。出世间波罗蜜者。谓声闻缘觉执着涅槃希求自乐。如是修习诸波罗蜜。大慧。出世间上上波罗蜜者。谓菩萨摩诃萨于自心二法。了知惟是分别所现。不起妄想不生执着。不取色相。为欲利乐一切众生。而恒修行檀波罗蜜。于诸境界不起分别。是则修行尸波罗蜜。即于不起分别之时。忍知能取所取自性。是则名为羼提波罗蜜。初中后夜勤修匪懈。随顺实解。不生分别。是则名为毗梨耶波罗蜜。不生分别。不起外道涅槃之见。是则名为禅波罗蜜。以智观察心无分别不堕二边。转净所依而不坏灭。获于圣智内证境界。是则名为般若波罗蜜。尔时世尊重说颂曰
愚分别有为 空无常刹那
分别刹那义 如河灯种子
一切法不生 寂静无所作
诸事性皆离 是我刹那义
生无间即灭 不为凡愚说
无间相续法 诸趣分别起
无明为其因 心则从彼生
未能了色来 中间何所住
无间相续灭 而有别心起
不住于色时 何所缘而生
若缘彼而起 其因则虚妄
因妄体不成 云何刹那灭
修行者正受 金刚佛舍利
及以光音宫 世间不坏事
如来圆满智 及比丘证得
诸法性常住 云何见刹那
干城幻等色 何故非刹那
大种无实性 云何说能造

    大乘入楞伽经卷第五

    大乘入楞伽经卷第六
    大周于阗国三藏法师实叉难陀奉　敕译
    变化品第七
    尔时大慧菩萨摩诃萨复白佛言。世尊。如来何故授阿罗汉阿耨多罗三藐三菩提记。何故复说无般涅槃法众生得成佛道。又何故说从初得佛至般涅槃于其中间不说一字。又言如来常在于定无觉无观。又言佛事皆是化作。又言诸识刹那变坏。又言金刚神常随卫护。又言前际不可知而说有般涅槃。又现有魔及以魔业。又有余报。谓旃遮婆罗门女。孙陀利外道女。及空钵而还等事。世尊既有如是业障。云何得成一切种智。既已成于一切种智。云何不离如是诸过。佛言。谛听当为汝说。大慧。我为无余涅槃界故。密劝令彼修菩萨行。此界他土有诸菩萨。心乐求于声闻涅槃。令舍是心进修大行。故作是说。又变化佛与化声闻而授记别。非法性佛。大慧。授声闻记是秘密说。大慧。佛与二乘无差别者。据断惑障解脱一味。非谓智障。智障要见法无我性乃清净故。烦恼障者。见人无我意识舍离。是时初断藏识习灭。法障解脱方得永净。大慧。我依本住法作是密语。非异前佛后更有说先具如是诸文字故。大慧。如来正知无有妄念。不待思虑然后说法。如来久已断四种习。离二种死除二种障。大慧。意及意识眼识等七。习气为因是刹那性。离无漏善非流转法。大慧。如来藏者。生死流转及是涅槃苦乐之因。凡愚不知妄着于空。大慧。变化如来。金刚力士常随卫护。非真实佛。真实如来离诸限量。二乘外道所不能知。住现法乐成就智忍。不假金刚力士所护。一切化佛不从业生。非即是佛亦非非佛。譬如陶师众事和合而有所作。化佛亦尔。众相具足而演说法。然不能说自证圣智所行之境
    复次大慧。诸凡愚人见六识灭起于断见。不了藏识起于常见。大慧。自心分别是其本际故不可得。离此分别即得解脱。四种习断离一切过。尔时世尊重说颂言
三乘及非乘 无有佛涅槃
悉授如来记 说离众过恶
成就究竟智 及无余涅槃
诱进怯劣人 依此密意说
诸佛所得智 演说如是道
惟此更非余 故彼无涅槃
欲色有诸见 如是四种习
意识所从生 藏意亦在中
见意识眼等 无常故说断
迷意藏起常 邪智谓涅槃

    大乘入楞伽经断食肉品第八
    尔时大慧菩萨摩诃萨复白佛言。世尊。愿为我说食不食肉功德过失。我及诸菩萨摩诃萨。知其义已为未来现在报习所熏食肉众生而演说之。令舍肉味求于法味。于一切众生起大慈心。更相亲爱如一子想。住菩萨地得阿耨多罗三藐三菩提。或二乘地暂时止息。究竟当成无上正觉。世尊。路迦耶等诸外道辈。起有无见执着断常。尚有遮禁不听食肉。何况如来应正等觉。大悲含育世所依怙。而许自他俱食肉耶。善哉世尊。具大慈悲哀愍世间。等观众生犹如一子。愿为解说食肉过恶不食功德。令我及与诸菩萨等。闻已奉行广为他说。尔时大慧菩萨重说颂言
菩萨摩诃萨 志求无上觉
酒肉及与葱 为食为不食
愚夫贪嗜肉 臭秽无名称
与彼恶兽同 云何而可食
食者有何过 不食有何德
惟愿最胜尊 为我具开演
    尔时佛告大慧菩萨摩诃萨言。大慧。谛听谛听善思念之。吾当为汝分别解说。大慧。一切诸肉有无量缘。菩萨于中当生悲愍不应啖食。我今为汝说其少分。大慧。一切众生从无始来。在生死中轮回不息。靡不曾作父母兄弟男女眷属乃至朋友亲爱侍使。易生而受鸟兽等身。云何于中取之而食。大慧。菩萨摩诃萨。观诸众生同于己身。念肉皆从有命中来。云何而食。大慧。诸罗刹等闻我此说尚应断肉。况乐法人。大慧。菩萨摩诃萨。在在生处观诸众生皆是亲属。乃至慈念如一子想。是故不应食一切肉。大慧。衢路市肆诸卖肉人。或将犬马人牛等肉。为求利故而贩鬻之。如是杂秽云何可食
    大慧。一切诸肉皆是精血污秽所成。求清净人云何取食。大慧。食肉之人众生见之悉皆惊怖。修慈心者云何食肉。大慧。譬如猎师及旃陀罗。捕鱼网鸟诸恶人等。狗见惊吠兽见奔走。空飞水住一切众生。若有见之咸作是念。此人气息犹如罗刹。今来至此必当杀我。为护命故悉皆走避。食肉之人亦复如是。是故菩萨为修慈行不应食肉。大慧。夫食肉者。身体臭秽恶名流布。贤圣善人不用亲狎。是故菩萨不应食肉。大慧。夫血肉者。众仙所弃群圣不食。是故菩萨不应食肉。大慧。菩萨为护众生信心。令于佛法不生讥谤。以慈愍故不应食肉。大慧。若我弟子食啖于肉。令诸世人悉怀讥谤。而作是言。云何沙门修净行人。弃舍天仙所食之味。犹如恶兽食肉满腹游行世间。令诸众生悉怀惊怖。坏清净行失沙门道。是故当知佛法之中无调伏行。菩萨慈愍为护众生。令不生于如是之心。不应食肉。大慧。如烧人肉其气臭秽。与烧余肉等无差别。云何于中有食不食。是故一切乐清净者不应食肉。大慧。诸善男女。冢间树下阿兰若处寂静修行。或住慈心或持咒术。或求解脱或趣大乘。以食肉故一切障碍不得成就。是故菩萨欲利自他不应食肉。大慧。夫食肉者。见其形色则已生于贪滋味心。菩萨慈念一切众生犹如己身。云何见之而作食想。是故菩萨不应食肉。大慧。夫食肉者诸天远离。口气常臭。睡梦不安觉已忧悚。夜叉恶鬼夺其精气。心多惊怖。食不知足。增长疾病易生疮癣。恒被诸虫之所唼食。不能于食深生厌离。大慧。我常说言。凡所食啖作子肉想。余食尚然。云何而听弟子食肉。大慧。肉非美好肉不清净。生诸罪恶败诸功德。诸仙圣人之所弃舍。云何而许弟子食耶。若言许食此人谤我。大慧。净美食者。应知则是粳米粟米大小麦豆苏油石蜜。如是等类此是过去。诸佛所许。我所称说。我种性中诸善男女。心怀净信久植善根。于身命财不生贪着。慈愍一切犹如己身。如是之人之所应食。非诸恶习虎狼性者。心所爱重
    大慧。过去有王名师子生。耽着肉味食种种肉。如是不已遂至食人。臣民不堪悉皆离叛。亡失国位受大苦恼。大慧。释提桓因处天王位。以于过去食肉余习。变身为鹰而逐于鸽。我时作王名曰尸毗。愍念其鸽自割身肉以代其命
    大慧。帝释余习尚恼众生。况余无惭常食肉者。当知食肉自恼恼他。是故菩萨不应食肉。大慧。昔有一王乘马游猎。马惊奔逸入于山险。既无归路又绝人居。有牝师子与同游处遂行丑行生诸子息。其最长者名曰班足。后得作王领七亿家。食肉余习非肉不食。初食禽兽后乃至人。所生男女悉是罗刹。转此身已。复生师子豺狼虎豹雕鹫等中。欲求人身终不可得。况出生死涅槃之道
    大慧。夫食肉者。有如是等无量过失。断而不食获大功德。凡愚不知如是损益。是故我今为汝开演。凡是肉者悉不应食。大慧。凡杀生者多为人食。人若不食亦无杀事。是故食肉与杀同罪。奇哉世间贪着肉味于人身肉尚取食之。况于鸟兽有不食者。以贪味故广设方便。罝罗网罟处处安施。水陆飞行皆被杀害。设自不食为贪价直而作是事
    大慧。世复有人心无慈愍专行惨暴犹如罗刹。若见众生其身充盛。便生肉想言此可食。大慧。世无有肉非是自杀亦非他杀。心不疑杀而可食者。以是义故我许声闻食如是肉。大慧。未来之世有愚痴人。于我法中而为出家。妄说毗尼坏乱正法。诽谤于我言听食肉亦自曾食。大慧。我若听许声闻食肉。我则非是住慈心者。修观行者。行头陀者。趣大乘者。云何而劝诸善男子及善女人。于诸众生生一子想断一切肉。大慧。我于诸处说遮十种许三种者。是渐禁断令其修学。今此经中自死他杀。凡是肉者一切悉断。大慧。我不曾许弟子食肉。亦不现许亦不当许。大慧。凡是肉食于出家人悉是不净
    大慧若有痴人。谤言如来听许食肉亦自食者。当知是人恶业所缠。必当永堕不饶益处。大慧。我之所有诸圣弟子尚不食于凡夫段食。况食血肉不净之食。大慧。声闻缘觉及诸菩萨尚惟法食。岂况如来。大慧。如来法身非杂食身。大慧。我已断除一切烦恼。我已浣涤一切习气。我已善择诸心智慧。大悲平等普观众生犹如一子。云何而许声闻弟子食于子肉。何况自食。作是说者无有是处。尔时世尊重说颂言
悉曾为亲属 众秽所成长
恐怖诸含生 是故不应食
一切肉与葱 [廿/韭]蒜及诸酒
如是不净物 修行者远离
亦常离麻油 及诸穿孔床
以彼诸细虫 于中大惊怖
饮食生放逸 放逸生邪觉
从觉生于贪 是故不应食
邪觉生贪故 心为贪所醉
心醉长爱欲 生死不解脱
为利杀众生 以财取诸肉
二俱是恶业 死堕叫唤狱
不想不教求 此三种名净
世无如是肉 食者我诃责
更互相食啖 死堕恶兽中
臭秽而癫狂 是故不应食
猎师旃茶罗 屠儿罗刹娑
此等种中生 斯皆食肉报
食已无惭愧 生生常癫狂
诸佛及菩萨 声闻所嫌恶
象胁与大云 涅槃央掘摩
及此楞伽经 我皆制断肉
先说见闻疑 已断一切肉
以其恶习故 愚者妄分别
如贪障解脱 肉等亦复然
若有食之者 不能入圣道
未来世众生 于肉愚痴说
言此净无罪 佛听我等食
净食尚如药 犹如子肉想
是故修行者 知量而行乞
食肉背解脱 及违圣表相
令众生生怖 是故不应食
安住慈心者 我说常厌离
师子及虎狼 应共同游止
若于酒肉等 一切皆不食
必生贤圣中 丰财具智慧

    大乘入楞伽经陀罗尼品第九
    尔时佛告大慧菩萨摩诃萨言。大慧。过去未来现在诸佛。为欲拥护持此经者。皆为演说楞伽经咒。我今亦说汝当受持。即说咒曰
    怛侄他(一)睹吒睹吒(都騃反下同二)杜吒杜吒(三)钵吒钵吒(四)葛吒葛吒(五)阿么隶阿么隶(六)毗么隶毗么隶(七)儞谜儞谜(八)呬谜呬谜(九)缚(扶可反)谜缚谜(十)葛隶葛隶(十一)揭啰葛隶(十二)阿吒末吒(十三)折吒咄吒(十四)耆若(攘舸反二合)吒萨普(二合)吒(十五)葛地(杂计反下同)剌地(十六)钵地(十七)呬谜呬谜(十八)第谜(十九)折隶折隶(二十)钵利钵利(二十一)畔第毗第(二十二)案制满制(二十三)[黑*主](胝户反下同)茶(去声下同)[口*(隶-木+士)](二十四)杜茶[口*(隶-木+士)](二十五)钵茶[口*(隶-木+士)](二十六)遏计遏计(二十七)末计末计(二十八)斫结斫结[口*(隶-木+士)](二合二十九)地(依字呼)谜地谜(三十)呬谜呬谜(三十一)[黑*主] [黑*主][黑*主][黑*主](三十二)楮(笞矩反)楮楮楮(三十三)杜杜杜(三十四)杜虎(二合)杜虎杜虎杜虎(三十五)莎婆诃(三十六)
    大慧。未来世中。若有善男子善女人。受持读诵为他解说此陀罗尼。当知此人。不为一切人与非人诸鬼神等之所得便。若复有人卒中于恶。为其诵念一百八遍。即时恶鬼疾走而去。大慧。我更为汝说陀罗尼。即说咒曰
    怛侄他(一)钵头摩第鞞(二)钵头迷(三)醯(去声下同)泥醯祢醯泥(四)隶主罗主隶(五)虎隶虎罗虎隶(六)庾隶庾隶(七)跛隶跛罗跛隶(八)嗔(上声呼)第膑第(九)畔逝末第(十)尼罗迦隶(十一)莎婆诃(十二)
    大慧。若有善男子善女人。受持读诵为他解说此陀罗尼。不为一切天龙夜叉人非人等诸恶鬼神之所得便。我为禁止诸罗刹故说此神咒。若持此咒则为受持入楞伽经一切文句悉已具足

    大乘入楞伽经偈颂品第十之初
    尔时世尊。欲重宣此修多罗中诸广义故。而说偈言
诸法不坚固 皆从分别生
以分别即空 所分别非有
由虚妄分别 是则有识生
八九识种种 如海众波浪
习气常增长 槃根坚固依
心随境界流 如铁于礠石
众生所依性 远离诸计度
及离智所知 转依得解脱
得如幻三昧 超过于十地
观见心王时 想识皆远离
尔时心转依 是则为常住
在于莲花宫 幻境之所起
既住彼宫已 自在无功用
利益诸众生 如众色摩尼
无有为无为 惟除妄分别
愚夫迷执取 如石女梦子
应知补伽罗 蕴界诸缘等
悉空无自性 无生有非有
我以方便说 而实无有相
愚夫妄执取 能相及所相
一切知非知 一切非一切
愚夫所分别 佛无觉自他
诸法如幻梦 无生无自性
以皆性空故 无有不可得
我惟说一性 离于妄计度
自性无有二 众圣之所行
如四大不调 变吐见萤光
所见皆非有 世间亦如是
犹如幻所现 草木瓦砾等
彼幻无所有 诸法亦如是
非取非所取 非缚非所缚
如幻如阳焰 如梦亦如翳
若欲见真实 离诸分别取
应修真实观 见佛必无疑
世间等于梦 色资具亦尔
若能如是见 身为世所尊
三界由心起 迷惑妄所见
离妄无世间 知已转染依
愚夫之所见 妄谓有生灭
智者如实观 不生亦不灭
常行无分别 远离心心法
住色究竟天 离诸过失处
于彼成正觉 具力通自在
及诸胜三昧 现化于此成
化身无量亿 遍游一切处
令愚夫得闻 如响难思法
远离初中后 亦离于有无
非多而现多 不动而普遍
说众生身中 所覆之性质
迷惑令幻有 非幻为迷惑
由心迷惑故 一切皆悉有
以此相系缚 藏识起世间
如是诸世间 惟有假施设
诸见如暴流 行于人法中
若能如是知 是则转所依
乃为我真子 成就随顺法
愚夫所分别 坚湿暖动法
假名无有实 亦无相所相
身形及诸根 皆以八物成
凡愚妄计色 迷惑身笼槛
凡愚妄分别 因缘和合生
不了真实相 流转于三有
识中诸种子 能现心境界
愚夫起分别 妄计于二取
无明爱及业 诸心依彼生
以是我了知 为依他起性
妄分别有物 迷惑心所行
此分别都无 迷妄计为有
心为诸缘缚 生起于众生
诸缘若远离 我说无所见
已离于众缘 自相所分别
身中不复起 我为无所行
众生心所起 能取及所取
所见皆无相 愚夫妄分别
显示阿赖耶 殊胜之藏识
离于能所取 我说为真如
蕴中无有人 无我无众生
生唯是识生 灭亦唯识灭
犹如画高下 虽见无所有
诸法亦如是 虽见而非有
如乾闼婆城 亦如热时炎
所见恒如是 智观不可得
因缘及譬喻 以此而立宗
干城梦火轮 阳焰日月光
火焰毛等喻 以此显无生
世分别皆空 迷惑如幻梦
见诸有不生 三界无所依
内外亦如是 成就无生忍
得如幻三昧 及以意生身
种种诸神通 诸力及自在
诸法本无生 空无有自性
迷惑诸因缘 而谓有生灭
愚夫妄分别 以心而现心
及现于外色 而实无所有
如定力观见 佛像与骨锁
及分析大种 假施设世间
身资及所住 此三为所取
意取及分别 此三为能取
迷惑妄计着 以能所分别
但随文字境 而不见真实
行者以慧观 诸法无自性
是时住无相 一切皆休息
如以墨涂鸡 无智者妄取
实无有三乘 愚夫不能见
若见诸声闻 及以辟支佛
皆大悲菩萨 变化之所现
三界唯是心 分别二自性
转依离人法 是则为真如
日月灯光焰 大种及摩尼
无分别作用 诸佛亦如是
诸法如毛轮 远离生住灭
亦离常无常 染净亦如是
如着陀都药 见地作金色
而实彼地中 本无有金相
愚夫亦如是 无始迷乱心
妄取诸有实 如幻如阳焰
应观一种子 与非种同印
一种一切种 是名心种种
种种子为一 转依为非种
平等同法印 悉皆无分别
种种诸种子 能感诸趣生
种种众杂苦 名一切种子
观诸法自性 迷惑不待遣
物性本无生 了知即解脱
定者观世间 众色由心起
无始心迷惑 实无色无心
如幻与干城 毛轮及阳焰
非有而现有 诸法亦如是
一切法不生 唯迷惑所见
以从迷妄生 愚妄计着二
由种种习气 生诸波浪心
若彼习断时 心浪不复起
心缘诸境起 如画依于壁
不尔虚空中 何不起于画
若缘少分相 令心得生者
心既从缘起 唯心义不成
心性本清净 犹若净虚空
令心还取心 由习非异因
执着自心现 令心而得起
所见实非外 是故说唯心
藏识说名心 思量以为意
能了诸境界 是则名为识
心常为无记 意具二种行
现在识通具 善与不善等
证乃无定时 超地及诸刹
亦越于心量 而住无相果
所见有与无 及以种种相
皆是诸愚夫 颠倒所执着
智若离分别 物有则相违
由心故无色 是故无分别
诸根犹如幻 境界悉如梦
能作及所作 一切皆非有
世谛一切有 第一义则无
诸法无性性 说为第一义
于无自性中 因诸言说故
而有物起者 是名为俗谛
若无有言说 所起物亦无
世谛中无有 有言无事者
颠倒虚妄法 而实不可得
若倒是有者 则无无自性
以有无性故 而彼颠倒法
一切诸所有 是皆不可得
恶习熏于心 所现种种相
迷惑谓心外 妄取诸色像
分别无分别 分别是可断
无分别能见 实性证真空
无明熏于心 所现诸众生
如幻象马等 及树叶为金
犹如翳目者 迷惑见毛轮
愚夫亦如是 妄取诸境界
分别所分别 及起分别者
转所转转因 因此六解脱
由于妄计故 无地无诸谛
亦无诸刹土 化佛及二乘
心起一切法 一切处及身
心性实无相 无智取种种
分别迷惑相 是名依他起
相中所有名 是则为妄计
诸缘法和合 分别于名相
此等皆不生 是则圆成实
十方诸刹土 众生菩萨中
所有法报佛 化身及变化
皆从无量寿 极乐界中出
于方广经中 应知密意说
所有佛子说 及诸导师说
悉是化身说 非是实报佛
诸法无有生 彼亦非非有
如幻亦如梦 如化如干城
种种由心起 种种由心脱
心起更非余 心灭亦如是
以众生分别 所现虚妄相
惟心实无境 离分别解脱
由无始积集 分别诸戏论
恶习之所熏 起此虚妄境
妄计自性故 诸法皆无生
依止于缘起 众生迷分别
分别不相应 依他即清净
所住离分别 转依即真如
勿妄计虚妄 妄计即无实
迷惑妄分别 取所取皆无
分别见外境 是妄计自性
由此虚妄计 缘起自性生
邪见诸外境 无境但是心
如理正观察 能所取皆灭
如愚所分别 外境实非有
习气扰浊心 似外境而转
已灭二分别 智契于真如
起于无影像 难思圣所行
依父母和合 如苏在于瓶
阿赖耶意俱 令赤白增长
闭尸及稠胞 秽业种种生
业风增四大 出生如果熟
五与五及五 疮窍有九种
爪甲齿毛具 满足即便生
初生犹粪虫 亦如人睡觉
眼开见于色 分别渐增长
分别决了已 唇齶等和合
始发于语言 犹如鹦鹉等
随众生意乐 安立于大乘
非恶见行处 外道不能受
自内所证乘 非计度所行
愿说佛灭后 谁能受持此
大慧汝应知 善逝涅槃后
未来世当有 持于我法者
南天竺国中 大名德比丘
厥号为龙树 能破有无宗
世间中显我 无上大乘法
得初欢喜地 往生安乐国
众缘所起义 有无俱不可
缘中妄计物 分别于有无
如是外道见 远离于我法
一切法名字 生处常随逐
已习及现习 展转共分别
若不说于名 世间皆迷惑
为除迷惑故 是故立名言
愚分别诸法 迷惑于名字
及以诸缘生 是三种分别
以不生不灭 本性如虚空
自性无所有 是名妄计相
如幻影阳焰 镜像梦火轮
如响及干城 是则依他起
真如空不二 实际及法性
皆无有分别 我说是圆成
语言心所行 虚妄堕二边
慧分别实谛 是慧无分别
于智者所现 于愚则不现
如是智所现 一切法无相
如假金璎珞 非金愚谓金
诸法亦如是 外道妄计度
诸法无始终 住于真实相
世间皆无作 妄计不能了
过去所有法 未来及现在
如是一切法 皆悉是无生
诸缘和合故 是故说有法
若离于和合 不生亦不灭
而诸缘起法 一异不可得
略说以为生 广说则为灭
一是不生空 一复是生空
不生空为胜 生空则灭坏
真如空实际 涅槃及法界
种种意生身 我说皆异名
于诸经律论 而起净分别
若不了无我 依教不依义
众生妄分别 所见如兔角
分别即迷惑 如渴兽逐焰
由于妄执着 而起于分别
若离妄执因 分别则不起
甚深大方广 知诸刹自在
我为佛子说 非为诸声闻
三有空无常 远离我我所
我为诸声闻 如是总相说
不着一切法 寂净独所行
思念辟支果 我为彼人说
身是依他起 迷惑不自见
分别外自性 而令心妄起
报得及加持 诸趣种类生
及梦中所得 是神通四性
梦中之所得 及以佛威力
诸趣种类等 皆非报得通
习气熏于心 似物而影起
凡愚未能悟 是故说为生
随于妄分别 外相几时有
尔所时增妄 不见自心迷
何以说有生 而不说所见
无所见而见 为谁云何说
心体自本净 意及诸识俱
习气常熏故 而作诸浊乱
藏识舍于身 意乃求诸趣
识述似境界 见已而贪取
所见唯自心 外境不可得
若修如是观 舍妄念真如
诸定者境界 业及佛威力
此三不思议 难思智所行
过未补伽罗 虚空及涅槃
我随世俗事 真谛离文字
二乘及外道 同依止诸见
迷惑于唯心 妄分别外境
罗汉辟支佛 及以佛菩提
种子坚成就 梦佛灌其顶
心幻趣寂静 何为说有无
何处及为谁 何故愿为说
迷惑于惟心 故说幻有无
生灭相相应 相所相平等
分别名意识 及与五识俱
如影像暴流 从心种子起
若心及与意 诸识不起者
即得意生身 亦得于佛地
诸缘及蕴界 人法之自相
皆心假施设 如梦及毛轮
观世如幻梦 依止于真实
真实离诸相 亦离因相应
圣者内所证 常住于无念
迷惑因相应 执世间为实
一切戏论灭 迷惑则不生
随有迷分别 痴心常现起
诸法空无性 而是常无常
生论者所见 非是无生论
一异俱不俱 自然及自在
时微尘胜性 缘分别世间
识为生死种 有种故有生
如画依于壁 了知即便灭
譬如见幻人 而有幻生死
凡愚亦如是 痴故起缚脱
内外二种法 及以彼因缘
修行者观察 皆住于无相
习气不离心 亦不与心俱
虽为习所缠 心相无差别
心如白色衣 意识习为垢
垢习之所污 令心不显现
我说如虚空 非有亦非无
藏识亦如是 有无皆远离
意识若转依 心则离浊乱
我说心为佛 觉了一切法
永断三相续 亦离于四句
有无皆舍离 诸有恒如幻
前七地心起 故有二自性
余地及佛地 悉是圆成实
欲色无色界 及以于涅槃
于彼一切身 皆是心境界
随其有所得 是则迷惑起
若觉自心已 迷惑则不生
我立二种法 诸相及以证
以四种理趣 方便说成就
见种种名相 是迷惑分别
若离于名相 性净圣所行
随能所分别 则有妄计相
若离彼分别 自性圣所行
心若解脱时 则常恒真实
种性及法性 真如离分别
以有清净心 而有杂染现
无净则无染 真净圣所行
世间从缘生 增长于分别
观彼如幻梦 是时即解脱
种种恶习气 与心和合故
众生见外境 不睹心法性
心性本清净 不生诸迷惑
迷从恶习起 是故不见心
唯迷惑即真 真实非余处
以诸行非行 非余处见故
若观诸有为 远离相所相
以离众相故 见世惟自心
安住于唯心 不分别外境
住真如所缘 超过于心量
若超过心量 亦超于无相
以住无相者 不见于大乘
行寂无功用 净修诸大愿
及我最胜智 无相故不见
应观心所行 亦观智所行
观见慧所行 于相无迷惑
心所行苦谛 智所行是集
余二及佛地 皆是慧所行
得果与涅槃 及以八圣道
觉了一切法 是佛清净智
眼根及色境 空明与作意
故令从藏识 众生眼识生
取者能所取 名事俱无有
无因妄分别 是为无智者
名义互不生 名义别亦尔
计因无因生 不离于分别
妄谓住实谛 随见施设说
一性五不成 舍离于谛义
戏论于有无 应超此等魔
以见无我故 不妄求诸有
计作者为常 咒术与诤论
实谛离言说 而见寂灭法
依于藏识故 而得有意转
心意为依故 而有诸识生
虚妄所立法 及心性真如
定者如是观 通达唯心性
观意与相事 不念常无常
及以生不生 不分别二义
从于阿赖耶 生起于诸识
终不于一义 而生二种心
由见自心故 非空非言说
若不见自心 为见网所缚
诸缘无有生 诸根无所有
无贪无蕴界 悉无诸有为
本无诸业报 无作无有为
执着本来无 无缚亦无脱
无有无记法 法非法皆无
非时非涅槃 法性不可得
非佛非真谛 非因亦非果
非倒非涅槃 非生亦非灭
亦无十二支 边无边非有
一切见皆断 我说是唯心
烦恼业与身 及业所得果
皆如焰如梦 如乾闼婆城
以住唯心故 诸相皆舍离
以住唯心故 能见于断常
涅槃无诸蕴 无我亦无相
以入于唯心 转依得解脱
恶习为因故 外现于大地
及以诸众生 唯心无所见
身资土影像 众生习所现
心非是有无 习气令不显
垢现于净中 非净现于垢
如云翳虚空 心不现亦尔
妄计性为有 于缘起则无
以妄计迷执 缘起无分别
非所造皆色 有色非所造
梦幻焰干城 此等非所造
若于缘生法 谓实及不实
此人决定依 一异等诸见
声闻有三种 愿生与变化
及离贪嗔等 从于法所生
菩萨亦三种 未有诸佛相
思念于众生 而现于佛像
众生心所现 皆从习气生
种种诸影像 如星云日月
若大种是有 可有所造生
大种无性故 无能相所相
大种是能造 地等是所造
大种本无生 故无所造色
假实等诸色 及幻所造色
梦色干城色 焰色为第五
一阐提五种 种性五亦然
五乘及非乘 涅槃有六种
诸蕴二十四 诸色有八种
佛有二十四 佛子有二种
法门有百八 声闻有三种
诸佛刹惟一 佛一亦复然
解脱有三种 心流注有四
无我有六种 所知亦有四
远离于作者 及离诸见过
内自证不动 是无上大乘
生及与不生 有八种九种
一念与渐次 证得宗唯一
无色界八种 禅差别有六
辟支诸佛子 出离有七种
三世悉无有 常无常亦无
作业及果报 皆如梦中事
诸佛本不生 为声闻佛子
心恒不能见 如幻等法故
故于一切刹 从兜率入胎
初生及出家 不从生处生
为流转众生 而说于涅槃
诸谛及诸刹 随机令觉悟
世间洲树林 无我外道行
禅乘阿赖耶 果境不思议
星宿月种类 诸王诸天种
乾闼夜叉种 皆因业爱生
不思变易死 犹与习气俱
若死永尽时 烦恼网已断
财谷与金银 田宅及僮仆
象马牛羊等 皆悉不应畜
不卧穿孔床 亦不泥涂地
金银铜钵等 皆悉不应畜
土石及与铁 [彖/虫]及颇梨器
满于摩竭量 随钵故听畜
常以青等色 牛粪泥果叶
染白钦婆等 令作袈裟色
四指量刀子 刀如半月形
为以割截衣 修行者听畜
勿学工巧明 亦不应卖买
若须使净人 此法我所说
常守护诸根 善解经律义
不狎诸俗人 是名修行者
树下及岩穴 野屋与冢间
草窟及露地 修行者应住
冢间及余处 三衣常随身
若阙衣服时 来施者应受
乞食出游行 前视一寻地
摄念而行乞 犹如蜂采花
闹众所集处 众杂比丘尼
活命与俗交 皆不应乞食
诸王及王子 大臣与长者
修行者乞食 皆不应亲近
生家及死家 亲友所爱家
僧尼和杂家 修行者不食
寺中烟不断 常作种种食
及故为所造 修行者不食
行者观世间 能相与所相
皆悉离生灭 亦离于有无

    大乘入楞伽经卷第六

    大乘入楞伽经卷第七
    大周于阗国三藏法师实叉难陀奉　敕译
    偈颂品第十之二
若诸修行者 不起于分别
不久得三昧 力通及自在
修行者不应 妄执从微尘
时胜性作者 缘生于世间
世从自分别 种种习气生
修行者应观 诸有如梦幻
恒常见远离 诽谤及建立
身资及所住 不分别三有
不思想饮食 正念端身住
数数恭敬礼 诸佛及菩萨
善解经律中 真实理趣法
五法二无我 亦思惟自心
内证净法性 诸地及佛地
行者修习此 处莲花灌顶
沈轮诸趣中 厌离于诸有
往冢间静处 修习诸观行
有物无因生 妄谓离断常
亦谓离有无 妄计为中道
妄计无因论 无因是断见
不了外物故 坏灭于中道
恐堕于断见 不舍所执法
以建立诽谤 妄说为中道
以觉了惟心 舍离于外法
亦离妄分别 此行契中道
惟心无有境 无境心不生
我及诸如来 说此为中道
若生若不生 自性无自性
有无等皆空 不应分别二
不能起分别 愚夫谓解脱
心无觉智生 岂能断二执
以觉自心故 能断二所执
了知故能断 非不能分别
了知心所现 分别即不起
分别不起故 真如心转依
若见所起法 离诸外道过
是智者所取 涅槃非灭坏
我及诸佛说 觉此即成佛
若更异分别 是则外道论
不生而现生 不灭而现灭
普于诸亿刹 顿现如水月
一身为多身 然火及注雨
随机心中现 是故说惟心
心亦是惟心 非心亦心起
种种诸色相 通达皆惟心
诸佛与声闻 缘觉等形像
及余种种色 皆说是惟心
从于无色界 乃至地狱中
普现为众生 皆是惟心作
如幻诸三昧 及以意生身
十地与自在 皆由转依得
愚夫为相缚 随见闻觉知
自分别颠倒 戏论之所动
一切空无生 我实不涅槃
化佛于诸刹 演三乘一乘
佛有三十六 复各有十种
随众生心器 而现诸刹土
法佛于世间 犹如妄计性
虽见有种种 而实无所有
法佛是真佛 余皆是化佛
随众生种子 见佛所现身
以迷惑诸相 而起于分别
分别不异真 相不即分别
自性及受用 化身复现化
佛德三十六 皆自性所成
由外熏习种 而生于分别
不取于真实 而取妄所执
迷惑依内心 及缘于外境
但由此二起 更无第三缘
迷惑依内外 而得生起已
六十二十八 故我说为心
知但有根境 则离于我执
悟心无境界 则离于法执
由依本识故 而有诸识生
由依内处故 有似外影现
无智恒分别 有为及无为
皆悉不可得 如梦星毛轮
如乾闼婆城 如幻如焰水
非有而见有 缘起法亦然
我依三种心 假说根境我
而彼心意识 自性无所有
心意及与识 无我有二种
五法与自性 是诸佛境界
习气因为一 而成于三相
如以一彩色 画壁见种种
五法二无我 自性心意识
于佛种性中 皆悉不可得
远离心意识 亦离于五法
复离于自性 是为佛种性
若身语意业 不修白净法
如来净种性 则离于现行
神通力自在 三昧净庄严
种种意生身 是佛净种性
内自证无垢 远离于因相
八地及佛地 如来性所成
远行与善慧 法云及佛地
皆是佛种性 余悉二乘摄
如来心自在 而为诸愚夫
心相差别故 说于七种地
第七地不起 身语意过失
第八地所依 如梦渡河等
八地及五地 解了工巧明
诸佛子能作 诸有中之王
智者不分别 若生若不生
空及与不空 自性无自性
但惟是心量 而实不可得
为诸二乘说 此实此虚妄
非为诸佛子 故不应分别
有非有悉非 亦无刹那相
假实法亦无 惟心不可得
有法是俗谛 无性第一义
迷惑于无性 是则为世俗
一切法皆空 我为诸凡愚
随俗假施设 而彼无真实
由言所起法 则有所行义
观见言所生 皆悉不可得
如离壁无画 离质亦无影
藏识若清净 诸识浪不生
依法身有报 从报起化身
此为根本佛 余皆化所现
不应妄分别 空及以不空
妄计于有无 言义不可得
凡愚妄分别 德实尘聚色
一一尘皆无 是故无境界
众生见外相 皆由自心现
所见既非有 故无诸外境
如象溺深泥 不能复移动
声闻住三昧 昏垫亦复然
若见诸世间 习气以为因
离有无俱非 法无我解脱
自性名妄计 缘起是依他
真如是圆成 我经中常说
心意及与识 分别与表示
本识作三有 皆心之异名
寿及于暖识 阿赖耶命根
意及与意识 皆分别异名
心能持于身 意恒审思虑
意识诸识俱 了自心境界
若实有我体 异蕴及蕴中
于彼求我体 毕竟不可得
一一观世间 皆是自心现
于烦恼随眠 离苦得解脱
声闻为尽智 缘觉寂静智
如来之智慧 生起无穷尽
外实无有色 惟自心所现
愚夫不觉知 妄分别有为
不知外境界 种种皆自心
愚夫以因喻 四句而成立
智者悉了知 境界自心现
不以宗因喻 诸句而成立
分别所分别 是为妄计相
依止于妄计 而复起分别
展转互相依 皆因一习气
此二俱为客 非众生心起
安住三界中 心心所分别
所起似境界 是妄计自性
影像与种子 合为十二处
所依所缘合 说有所作事
犹如镜中像 瞖眼见毛轮
习气覆亦然 凡夫起妄见
于自分别境 而起于分别
如外道分别 外境不可得
如愚不了绳 妄取以为蛇
不了自心现 妄分别外境
如是绳自体 一异性皆离
但自心倒惑 妄起绳分别
妄计分别时 而彼性非有
云何见非有 而起于分别
色性无所有 瓶衣等亦然
但由分别生 所见终无有
无始有为中 迷惑起分别
何法令迷惑 愿佛为我说
诸法无自性 但惟心所现
不了于自心 是故生分别
如愚所分别 妄计实非有
异此之所有 而彼不能知
诸圣者所有 非愚所分别
若圣同于凡 圣应有虚妄
以圣治心净 是故无迷惑
凡愚心不净 故有妄分别
如母语婴儿 汝勿须啼泣
空中有果来 种种任汝取
我为众生说 种种妄计果
令彼爱乐已 法实离有无
诸法先非有 诸缘不和合
本不生而生 自性无所有
未生法不生 离缘无生处
现生法亦尔 离缘不可得
观实缘起要 非有亦非无
非有无俱非 智者不分别
外道诸愚夫 妄说一异性
不了诸缘起 世间如幻梦
我无上大乘 超越于名言
其义甚明了 愚夫不觉知
声闻及外道 所说皆悭吝
令义悉改变 皆由妄计起
诸相及自体 形状及与名
攀缘此四种 而起诸分别
计梵自在作 一身与多身
及日月运行 彼非是我子
具足于圣见 通达如实法
善巧转诸想 到于识彼岸
以此解脱印 永离于有无
及离于去来 是我法中子
若色识转灭 诸业失坏者
是则无生死 亦无常无常
而彼转灭时 色处虽舍离
业住阿赖耶 离有无过失
色识虽转灭 而业不失坏
令于诸有中 色识复相续
若彼诸众生 所起业失坏
是则无生死 亦无有涅槃
若业与色识 俱时而灭坏
生死中若生 色业应无别
色心与分别 非异非不异
愚夫谓灭坏 而实离有无
缘起与妄计 展转无别相
如色与无常 展转生亦尔
既离异非异 妄计不可知
如色无常性 云何说有无
善达于妄计 缘起则不生
由见于缘起 妄计则真如
若灭妄计性 是则坏法眼
便于我法中 建立及诽谤
如是色类人 当毁谤正法
彼皆以非法 灭坏我法眼
智者勿共语 比丘事亦弃
以灭坏妄计 建立诽谤故
若随于分别 起于有无见
彼如幻毛轮 梦焰与干城
彼非学佛法 不应与同住
以自堕二边 亦坏他人故
若有修行者 观于妄计性
寂静离有无 摄取与同住
如世间有处 出金摩尼珠
彼虽无造作 而众生受用
业性亦如是 远离种种性
所见业非有 非不生诸趣
如圣所了知 法皆无所有
愚夫所分别 妄计法非无
若愚所分别 彼法非有者
既无一切法 众生无杂染
以有杂染法 无明爱所系
能起生死身 诸根悉具足
若谓愚分别 此法皆无者
则无诸根生 彼非正修行
若无有此法 而为生死因
愚夫不待修 自然而解脱
若无有彼法 凡圣云何别
亦则无圣人 修行三解脱
诸蕴及人法 自共相无相
诸缘及诸根 我为声闻说
惟心及非因 诸地与自在
内证净真如 我为佛子说
未来世当有 身着于袈裟
妄说于有无 毁坏我正法
缘起法无性 是诸圣所行
妄计性无物 计度者分别
未来有愚痴 揭那诸外道
说于无因论 恶见坏世间
妄说诸世间 从于微尘生
而彼尘无因 九种实物常
从实而成实 从德能生德
真法性异此 毁谤说言无
若本无而生 世间则有始
生死无前际 是我之所说
三界一切物 本无而生者
驼驴狗生角 亦应无有疑
眼色识本无 而今有生者
衣冠及席等 应从泥团生
如叠中无席 蒲中亦无席
何不诸缘中 一一皆生席
彼命者与身 若本无而生
我先已说彼 皆是外道论
我先所说宗 为遮于彼意
既遮于彼已 然后说自宗
恐诸弟子众 迷著有无宗
是故我为其 先说外道论
迦毗罗恶慧 为诸弟子说
胜性生世间 求那所转变
诸缘无有故 非已生现生
诸缘既非缘 非生非不生
我宗离有无 亦离诸因缘
生灭及所相 一切皆远离
世间如幻梦 因缘皆无性
常作如是观 分别永不起
若能观诸有 如焰及毛轮
亦如寻香城 常离于有无
因缘俱舍离 令心悉清净
若言无外境 而惟有心者
无境则无心 云何成唯识
以有所缘境 众生心得起
无因心不生 云何成惟识
真如及惟识 是众圣所行
此有言非有 彼非解我法
由能取所取 而心得生起
世间心如是 故非是唯心
身资土影像 如梦从心生
心虽成二分 而心无二相
如刀不自割 如指不自触
而心不自见 其事亦如是
无有影像处 则无依他起
妄计性亦无 五法二心尽
能生及所生 皆是自心相
密意说能生 而实无自生
种种境形状 若由妄计生
虚空与兔角 亦应成境相
以境从心起 此境非妄计
然彼妄计境 离心不可得
无始生死中 境界悉非有
心无有起处 云何成影像
若无物有生 兔角亦应生
不可无物生 而起于分别
如境现非有 彼则先亦无
云何无境中 而心缘境起
真如空实际 涅槃及法界
一切法不生 是第一义性
愚夫堕有无 分别诸因缘
不能知诸有 无生无作者
无始心所因 惟心无所见
既无无始境 心从何所生
无物而得生 如贫应是富
无境而生心 愿佛为我说
一切若无因 无心亦无境
心既无所生 离三有所作
因瓶衣角等 而说兔角无
是故不应言 无彼相因法
无因有故无 是无不成无
有待无亦尔 展转相因起
若依止少法 而有少法起
是则前所依 无因而自有
若彼别有依 彼依复有依
如是则无穷 亦无有少法
如依木叶等 现种种幻相
众生亦如是 依事种种现
依于幻师力 令愚见幻相
而于木叶等 实无幻可得
若依止于事 此法则便坏
所见既无二 何有少分别
分别无妄计 分别亦无有
以分别无故 无生死涅槃
由无所分别 分别则不起
云何心不起 而得有惟心
意差别无量 皆无真实法
无实无解脱 亦无诸世间
如愚所分别 外所见皆无
习气扰浊心 似影像而现
有无等诸法 一切皆不生
但惟自心现 远离于分别
说诸法从缘 为愚非智者
心自性解脱 净心圣所住
数胜及露形 梵志与自在
皆堕于无见 远离寂静义
无生无自性 离垢空如幻
诸佛及今佛 为谁如是说
净心修行者 离诸见计度
诸佛为彼说 我亦如是说
若一切皆心 世间何处住
何因见大地 众生有去来
如鸟游虚空 随分别而去
无依亦无住 如履地而行
众生亦如是 随于妄分别
游履于自心 如鸟在虚空
身资国土影 佛说惟心起
愿说影惟心 何因云何起
身资国土影 皆由习气转
亦因不如理 分别之所生
外境是妄计 心缘彼境生
了境是惟心 分别则不起
若见妄计性 名义不和合
远离觉所觉 解脱诸有为
名义皆舍离 此是诸佛法
若离此求悟 彼无觉自他
若能见世间 离能觉所觉
是时则不起 名所名分别
由见自心故 妄作名字灭
不见于自心 则起彼分别
四蕴无色相 彼数不可得
大种性各异 云何共生色
由离诸相故 能所造非有
异色别有相 诸蕴何不生
若见于无相 蕴处皆舍离
是时心亦离 见法无我故
由根境差别 生于八种识
于彼无相中 是三相皆离
意缘阿赖耶 起我我所执
及识二执取 了知皆远离
观见离一异 是则无所动
离于我我所 二种妄分别
无生无增长 亦不为识因
既离能所作 灭已不复生
世间无能作 及离能所相
妄计及惟心 云何愿为说
自心现种种 分别诸形相
不了心所现 妄取谓心外
由无智觉故 而起于无见
云何于有性 而心不生着
分别非有无 故于有不生
了所见惟心 分别则不起
分别不起故 转依无所著
则遮于四宗 谓法有因等
此但异名别 所立皆不成
应知能作因 亦复不成立
为遮于能作 说因缘和合
为遮于常过 说缘是无常
愚夫谓无常 而实不生灭
不见灭坏法 而能有所作
何有无常法 而能有所生
天人阿修罗 鬼畜阎罗等
众生在中生 我说为六道
由业上中下 于中而受生
守护诸善法 而得胜解脱
佛为诸比丘 说于所受生
念念皆生灭 请为我宣说
色色不暂停 心心亦生灭
我为弟子说 受生念迁谢
色色中分别 生灭亦复然
分别是众生 离分别非有
我为此缘故 说于念念生
若离取着色 不生亦不灭
缘生非缘生 无明真如等
二法故有起 无二即真如
若彼缘非缘 生法有差别
常等与诸缘 有能作所作
是则大牟尼 及诸佛所说
有能作所作 与外道无异
我为弟子说 身是苦世间
亦是世间集 灭道皆悉具
凡夫妄分别 取三自性故
见有能所取 世及出世法
我先观待故 说取于自性
今为遮诸见 不应妄分别
求过为非法 亦令心不定
皆由二取起 无二即真如
若无明爱业 而生于识等
邪念复有因 是则无穷过
无智说诸法 有四种灭坏
妄起二分别 法实离有无
远离于四句 亦离于二见
分别所起二 了已不复生
不生中知生 生中知不生
彼法同等故 不应起分别
愿佛为我说 遮二见之理
令我及余众 恒不堕有无
不杂诸外道 亦离于二乘
诸佛证所行 佛子不退处
解脱因非因 同一无生相
迷故执异名 智者应常离
法从分别生 如毛轮幻焰
外道妄分别 世从自性生
无生及真如 性空与真际
此等异名说 不应执为无
如手有多名 帝释名亦尔
诸法亦如是 不应执为无
色与空无异 无生亦复然
不应执为异 成诸见过失
以总别分别 及遍分别故
执着诸事相 长短方圆等
总分别是心 遍分别为意
别分别是识 皆离能所相
我法中起见 及外道无生
皆是妄分别 过失等无异
若有能解了 我所说无生
及无生所为 是人解我法
为破于诸见 无生无住处
令知此二义 故我说无生
佛说无生法 若是有是无
则同诸外道 无因不生论
我说惟心量 远离于有无
若生若不生 是见应皆离
无因论不生 生则著作者
作则杂诸见 无则自然生
佛说诸方便 正见大愿等
一切法若无 道场何所成
离能取所取 非生亦非灭
所见法非法 皆从自心起
牟尼之所说 前后自相违
云何说诸法 而复言不生
众生不能知 愿佛为我说
得离外道过 及彼颠倒因
惟愿胜说者 说生及与灭
皆离于有无 而不坏因果
世间堕二边 诸见所迷惑
惟愿青莲眼 说诸地次第
取生不生等 不了寂灭因
道场无所得 我亦无所说
刹那法皆空 无生无自性
诸佛已净二 有二即成过
恶见之所覆 分别非如来
妄计于生灭 愿为我等说
积集於戏论 和合之所生
随其类现前 色境皆具足
见于外色已 而起于分别
若能了知此 则见真实义
若离于大种 诸物皆不成
大种既惟心 当知无所生
此心亦不生 则顺圣种性
勿分别分别 无分别是智
分别于分别 是二非涅槃
若立无生宗 则坏于幻法
亦无因起幻 损减于自宗
犹如镜中像 虽离一异性
所见非是无 生相亦如是
如干城幻等 悉待因缘有
诸法亦如是 是生非不生
分别于人法 而起二种我
此但世俗说 愚夫不觉知
由愿与缘集 自力及最胜
声闻法第五 而有罗汉等
时隔及灭坏 胜义与递迁
是四种无常 愚分别非智
愚夫堕二边 德尘自性作
以取有无宗 不知解脱因
大种互相违 安能起于色
但是大种性 无大所造色
火乃烧于色 水复为烂坏
风能令散灭 云何色得生
色蕴及识蕴 惟此二非五
余但是异名 我说彼如怨
心心所差别 而起于现法
分析于诸色 惟心无所造
青白等相待 作所作亦然
所生及性空 冷热相所相
有无等一切 妄计不成立
心意及余六 诸识共相应
皆因藏识生 非一亦非异
数胜及露形 计自在能生
皆堕有无宗 远离寂静义
大种生形相 非生于大种
外道说大种 生大种及色
于无生法外 外道计作者
依止有无宗 愚夫不觉知
清净真实相 而与大智俱
但共心相应 非意等和合
若业皆生色 则违诸蕴因
众生应无取 无有住无色
说名为无者 众生亦应无
无色论是断 诸识不应生
识依四种住 无色云何成
内外既不成 识亦不应起
众生识若无 自然得解脱
必是外道论 妄计者不知
或有随乐执 中有中诸蕴
如生于无色 无色云何有
无色中之色 彼非是可见
无色则违宗 非乘及乘者
识从习气生 与诸根和合
八种于刹那 取皆不可得
若诸色不起 诸根则非根
是故世尊说 根色刹腻迦
云何不了色 而得有识生
云何识不生 而得受生死
诸根及根境 圣者了其义
愚痴无智者 妄执取其名
不应执第六 有取及无取
为离诸过失 圣者无定说
诸外道无智 怖畏于断常
计有为无为 与我无差别
或计与心一 或与意等异
一性有可取 异性有亦然
若取是决了 名为心心所
此取何不能 决了于一性
有取及作业 可得而受生
犹如火所成 理趣似非似
如火顿烧时 然可然皆具
妄取我亦然 云何无所取
若生若不生 心性常清净
外道所立我 何不以为喻
迷惑识稠林 妄计离真法
乐于我论故 驰求于彼此
内证智所行 清净真我相
此即如来藏 非外道所知
分别于诸蕴 能取及所取
若能了此相 则生真实智
是诸外道等 于赖耶藏处
计意与我俱 此非佛所说
若能辩了此 解脱见真谛
见修诸烦恼 断除悉清净
本性清净心 众生所迷取
无垢如来藏 远离边无边
本识在蕴中 如金银在矿
陶冶炼治已 金银皆显现
佛非人非蕴 但是无漏智
了知常寂静 是我之所归
本性清净心 随烦恼意等
及与我相应 愿佛为解说
自性清净心 意等以为他
彼所积集业 杂染故为二
意等我烦恼 染污于净心
犹如彼净衣 而有诸垢染
如衣得离垢 亦如金出矿
衣金俱不坏 心离过亦然
无智者推求 箜篌[彖/虫]鼓等
而觅妙音声 蕴中我亦尔
犹如伏藏宝 亦如地下水
虽有不可见 蕴真我亦然
心心所功能 聚集蕴相应
无智不能取 蕴中我亦尔
如女怀胎藏 虽有不可见
蕴中真实我 无智不能知
如药中胜力 亦如木中火
蕴中真实我 无智不能知
诸法中空性 及以无常性
蕴中真实我 无智不能知
诸地自在通 灌顶胜三昧
若无此真我 是等悉皆无
有人破坏言 若有应示我
智者应答言 汝分别示我
说无真我者 谤法著有无
比丘应羯磨 摈弃不共语
说真我炽然 犹如劫火起
烧无我稠林 离诸外道过
如苏酪石蜜 及以麻油等
彼皆悉有味 未尝者不知
于诸蕴身中 五种推求我
愚者不能了 智见即解脱
明智所立喻 犹未显于心
其中所集义 岂能使明了
诸法别异相 不了惟一心
计度者妄执 无因及无起
定者观于心 心不见于心
见从所见生 所见何因起
我姓迦旃延 净居天中出
为众生说法 令入涅槃城
缘于本住法 我及诸如来
于三千经中 广说涅槃法
欲界及无色 不于彼成佛
色界究竟天 离欲得菩提
境界非缚因 因缚于境界
修行利智剑 割断彼烦恼
无我云何有 幻等法有无
愚应显真如 云何无真我
已作未作法 皆非因所起
一切悉无生 愚夫不能了
能作者不生 所作及诸缘
此二皆无生 云何计能作
妄计者说有 先后一时因
显瓶弟子等 说诸物生起
佛非是有为 所具诸相好
是轮王功德 非此名如来
佛以智为相 远离于诸见
自内证所行 一切过皆断
聋盲喑痖等 老小及怀怨
是等尤重者 皆无梵行分
随好隐为天 相隐为轮王
此二着放逸 惟显者出家
我释迦灭后 当有毗耶娑
迦那梨沙婆 劫比罗等出
我灭百年后 毗耶娑所说
婆罗多等论 次有半择娑
憍拉婆啰摩 次有冒狸王
难陀及毱多 次篾利车王
于后刀兵起 次有极恶时
彼时诸世间 不修行正法
如是等过后 世间如轮转
日火共和合 焚烧于欲界
复立于诸天 世间还成就
诸王及四姓 诸仙垂法化
韦陀祠施等 当有此法兴
谈论戏笑法 长行与解释
我闻如是等 迷惑于世间
所受种种衣 若有正色者
青泥牛粪等 染之令坏色
所服一切衣 令离外道相
现于修行者 诸佛之憧相
亦系于腰绦 漉水而饮用
次第而乞食 不至于非处
生于胜妙天 及生于人中
宝相具足者 生天及人王
王有四天下 法教久临御
上升于天宫 由贪皆退失
纯善及三时 二时并极恶
余佛出善时 释迦出恶世
于我涅槃后 释种悉达多
毗纽大自生 外道等俱出
如是我闻等 释师子所说
谈古及笑语 毗夜娑仙说
于我涅槃后 毗纽大自在
彼说如是言 我能作世间
我名离尘佛 姓迦多衍那
父名世间主 母号为具财
我生瞻婆国 我之先祖父
从于月种生 故号为月藏
出家修苦行 演说千法门
与大慧授记 然后当灭度
大慧付达摩 次付弥佉梨
弥佉梨恶时 劫尽法当灭
迦叶拘留孙 拘那含牟尼
及我离尘垢 皆出纯善时
纯善渐减时 有导师名慧
成就大勇猛 觉悟于五法
非二时三时 亦非极恶时
于彼纯善时 现成等正觉
衣虽不割缕 杂碎而补成
如孔雀尾目 无有人侵夺
或二指三指 间错而补成
异此之所作 愚夫生贪着
惟畜于三衣 恒灭贪欲火
沐以智慧水 日夜三时修
如放箭势极 一坠还放一
亦如抨酪木 善不善亦然
若一能生多 则有别异相
施者应如田 受者应如风
若一能生多 一切无因有
所作因灭坏 是妄计所立
若妄计所立 加灯及种子
一能生多者 但相似非多
胡麻不生豆 稻非穬麦因
小豆非谷种 云何一生多
名手作声论 广主造王论
顺世论妄说 当生梵藏中
迦多延造经 树皮仙说祀
鸺鹠出天文 恶世时当有
世间诸众生 福力感于王
如法御一切 守护于国土
青蚁及赤豆 侧僻与马行
此等大福仙 未来世当出
释子悉达多 步多五髻者
口力及聪慧 亦于未来出
我在于林野 梵王来惠我
鹿皮三岐杖 膊绦及军持
此大修行者 当成离垢尊
说于真解脱 牟尼之幢相
梵王与梵众 诸天及天众
施我鹿皮衣 还归自在宫
我在林树间 帝释四天王
施我妙衣服 及以乞食钵
若立不生论 是因生复生
如是立无生 惟是虚言说
无始所积集 无明为心因
生灭而相续 妄计所分别
僧佉论有二 胜性及变异
胜中有所作 所作应自成
胜性与物俱 求那说差别
作所作种种 变异不可得
如水银清净 尘垢不能染
藏识净亦然 众生所依止
如兴渠葱气 盐味及胎藏
种子亦如是 云何而不生
一性及异性 俱不俱亦然
非所取之有 非无非有为
马中牛性离 蕴中我亦然
所说为无为 悉皆无自性
理教等求我 是妄垢恶见
不了故说有 惟妄取无余
诸蕴中之我 一异皆不成
彼过失显然 妄计者不觉
如水镜及眼 现于种种影
远离一异性 蕴中我亦然
行者修于定 见谛及以道
勤修此三种 解脱诸恶见
犹如孔隙中 见电光速灭
法迁变亦然 不应起分别
愚夫心迷惑 取涅槃有无
若得圣见者 如实而能了
应知变异法 远离于生灭
亦离于有无 及以能所相
应知变异法 远离外道论
亦离于名相 内我见亦灭
诸天乐触身 地狱苦逼体
若无彼中有 诸识不得生
应知诸趣中 众生种种身
胎卵湿生等 皆随中有生
离圣教正理 欲灭惑反增
是外道狂言 智者不应说
先应决了我 及分别诸取
以如石女儿 无决了分别
我离于肉眼 以天眼慧眼
见诸众生身 离诸行诸蕴
观见诸行中 有好色恶色
解脱非解脱 有住天中者
诸趣所受身 惟我能了达
超过世所知 非计度境界
无我而生心 此心云何生
岂不说心生 如河灯种子
若无无明等 心识则不生
离无明无识 云何生相续
妄计者所说 三世及非世
第五不可说 诸佛之所知
诸行取所住 彼亦为智因
不应说智慧 而名为诸行
有此因缘故 则有此法生
无别有作者 是我之所说
风不能生火 而令火炽然
亦由风故灭 云何喻于我
所说为无为 皆离于诸取
云何愚分别 以火成立我
诸缘展转力 是故能生火
若分别如火 是我从谁生
意等为因故 诸蕴处积集
无我之商主 常与心俱起
此二常如日 远离能所作
非火能成立 妄计者不知
众生心涅槃 本性常清净
无始过习染 无异如虚空
象卧等外道 诸见所杂染
意识之所覆 计火等为净
若得如实见 便能断烦恼
舍邪喻稠林 到圣所行处
智所知差别 各异而分别
无智者不知 说所不应说
如愚执异材 作栴檀沉水
妄计与真智 当知亦复然
食讫持钵归 洗濯令清净
澡漱口余味 应当如是修
若于此法门 如理正思惟
净信离分别 成就最胜定
离着处于义 成金光法灯
分别于有无 及诸恶见网
三毒等皆离 得佛手灌顶
外道执能作 迷方及无因
于缘起惊怖 断灭无圣性
变起诸果报 谓诸识及意
意从赖耶生 识依末那起
赖耶起诸心 如海起波浪
习气以为因 随缘而生起
刹那相钩锁 取自心境界
种种诸形相 意根等识生
由无始恶习 似外境而生
所见惟自心 非外道所了
因彼而缘彼 而生于余识
是故起诸见 流转于生死
诸法如幻梦 水月焰干城
当知一切法 惟是自分别
正智依真如 而起诸三昧
如幻首楞严 如是等差别
得入于诸地 自在及神通
成就如幻智 诸佛灌其顶
见世间虚妄 是时心转依
获得欢喜地 诸地及佛地
既得转依已 如众色摩尼
利益诸众生 应现如水月
舍离有无见 及以俱不俱
过于二乘行 亦超第七地
自内现证法 地地而修治
远离诸外道 应说是大乘
说解脱法门 如兔角摩尼
舍离于分别 离死及迁灭
教由理故成 理由教故显
当依此教理 勿更余分别

    大乘入楞伽经卷第七


The Lankavatara Sutra

大乘入楞伽经 (实叉难陀译) 入楞伽经 (菩提留支译) The Lankavatara Sutra


No

    No. 671

    入楞伽经卷第一
    元魏天竺三藏菩提留支译
    请佛品第一
    归命大智海毗卢遮那佛。如是我闻。一时婆伽婆住大海畔摩罗耶山顶上楞伽城中。彼山种种宝性所成。诸宝间错光明赫炎。如百千日照曜金山。复有无量花园香树皆宝香林。微风吹击摇枝动叶。百千妙香一时流布。百千妙音一时俱发。重岩屈曲处处皆有仙堂灵室龛窟。无数众宝所成。内外明彻日月光晖不能复现。皆是古昔诸仙贤圣。思如实法得道之处。与大比丘僧及大菩萨众。皆从种种他方佛土俱来集会。是诸菩萨具足无量自在三昧神通之力奋迅游化。五法自性二种无我究竟通达。大慧菩萨摩诃萨而为上首。一切诸佛手灌其顶而授佛位。自心为境善解其义。种种众生种种心色。随种种心种种异念。无量度门随所应度随所应见而为普现
    尔时婆伽婆。于大海龙王宫说法。满七日已度至南岸。时有无量那由他释梵天王诸龙王等。无边大众悉皆随从向海南岸。尔时婆伽婆。遥望观察摩罗耶山楞伽城。光颜舒悦如动金山。熙怡微笑而作是言。过去诸佛应正遍知。于彼摩罗耶山顶上楞伽城中。说自内身圣智证法。离于一切邪见觉观。非诸外道声闻辟支佛等修行境界。我亦应彼摩罗耶山楞伽城中为罗婆那夜叉王上首说于此法。尔时罗婆那夜叉王。以佛神力闻如来声。时婆伽婆离海龙王宫度大海已。与诸那由他无量释梵天王诸龙王等围绕恭敬。尔时如来观察众生阿梨耶识大海水波。为诸境界猛风吹动。转识波浪随缘而起。尔时罗婆那夜叉王而自叹言。我应请如来入楞伽城。令我长夜于天人中。与诸人天得大利益快得安乐。尔时楞伽城主罗婆那夜叉王。与诸眷属乘花宫殿至如来所。与诸眷属从宫殿下绕佛三匝。以种种伎乐乐于如来。所持乐器皆是大青因陀罗宝而用造作。大毗琉璃玛瑙诸宝以为间错。无价色衣以用缠裹。以梵声等无量种音。歌叹如来一切功德。而说偈言
心具于法藏 离无我见垢
世尊说诸行 内心所知法
白法得佛身 内身所证法
化身示化身 时到入楞伽
今此楞伽城 过去无量佛
及诸佛子等 无量身受用
世尊若说法 无量诸夜叉
能现无量身 欲闻说法声
    尔时罗婆那楞伽王。以都吒迦种种妙声。歌叹如来诸功德已。复更以伽他妙声歌叹如来。而说偈言
如来于七日 大海恶兽中
渡海至彼岸 出已即便住
罗婆那王共 妻子夜叉等
及无量眷属 大智诸大臣
叔迦婆罗那 如是等天众
各各悉皆现 无量诸神通
乘妙花宫殿 俱来到佛所
到已下花殿 礼拜供养佛
依佛住持力 即于如来前
自说己名字 我十头罗刹
愿垂哀愍我 及此城众生
受此楞伽城 摩罗耶宝山
过去无量佛 于此楞伽城
种种宝山上 说身所证法
如来亦应尔 于此宝山中
同诸过去佛 亦说如是法
愿共诸佛子 说此清净法
我及楞伽众 咸皆欲听闻
入楞伽经典 过去佛赞叹
内身智境界 离所说名字
我念过去世 无量诸如来
诸佛子围绕 说此修多罗
如来于今日 亦应为我等
及诸一切众 说此甚深法
未来诸世尊 及诸佛子等
于此宝山上 亦说此深法
今此楞伽城 微妙过天宫
墙壁非土石 诸宝罗网覆
此诸夜叉等 已于过去佛
修行离诸过 毕竟住大乘
内心善思惟 如实念相应
愿佛怜愍故 为诸夜叉说
愿佛天人师 入摩罗耶山
夜叉及妻子 欲得摩诃衍
瓮耳等罗刹 亦住此城中
曾供养过去 无量亿诸佛
今复愿供养 现在大法王
欲闻内心行 欲得摩诃衍
愿佛怜愍我 及诸夜叉众
共诸佛子等 入此楞伽城
我所有宫殿 妻子及眷属
宝冠诸璎珞 种种庄严具
阿舒迦园林 种种皆可乐
及所乘花殿 施佛及大众
我于如来所 无有不舍物
愿大牟尼尊 哀愍我受用
我及诸佛子 受佛所说法
愿佛垂哀愍 为我受用说
尔时三界尊 闻夜叉请已
即为夜叉说 过去未来佛
夜叉过去佛 此胜宝山中
怜愍夜叉故 说内身证法
未来佛亦尔 于此宝山中
为诸夜叉等 亦说此深法
夜叉此宝山 如实修行人
现见法行人 乃能住此处
夜叉今告汝 我及诸佛子
怜愍汝等故 受汝施请说
如来略答竟 寂静默然住
罗婆那罗刹 奉佛花宫殿
如来及佛子 受已即皆乘
罗婆那夜叉 亦自乘华殿
以诸婇女乐 乐佛到彼城
到彼妙城已 罗婆那夜叉
及其夜叉妻 夜叉男女等
更持胜供具 种种皆微妙
供养于如来 及诸佛子等
诸佛及菩萨 皆受彼供养
罗婆那等众 供养说法者
观察所说法 内身证境界
供养大慧士 数数而请言
大士能问佛 内身行境界
我与夜叉众 及诸佛子等
一切诸听者 咸请仁者问
大士说法胜 修行亦最胜
我尊重大士 请问佛胜行
离诸外道边 亦离二乘过
说内法清净 究竟如来地
尔时佛神力 复化作山城
崔嵬百千相 严饰对须弥
无量亿花园 皆是众宝林
香气广流布 芬馥未曾闻
一一宝山中 皆示现佛身
亦有罗婆那 夜叉众等住
十方佛国土 及于诸佛身
佛子夜叉王 皆来集彼山
而此楞伽城 所有诸众等
皆悉见自身 入化楞伽中
如来神力作 亦同彼楞伽
诸山及园林 宝庄严亦尔
一一山中佛 皆有大智问
如来悉为说 内身所证法
出百千妙声 说此经法已
佛及诸佛子 一切隐不现
罗婆那夜叉 忽然见自身
在己本宫殿 更不见余物
而作是思惟 向见者谁作
说法者为谁 是谁而听闻
我所见何法 而有此等事
彼诸佛国土 及诸如来身
如此诸妙事 今皆何处去
为是梦所忆 为是幻所作
为是实城邑 为乾闼婆城
为是翳妄见 为是阳炎起
为梦石女生 为我见火轮
为见火轮烟 我所见云何
复自深思惟 诸法体如是
唯自心境界 内心能证知
而诸凡夫等 无明所覆障
虚妄心分别 而不能觉知
能见及所见 一切不可得
说者及所说 如是等亦无
佛法真实体 非有亦非无
法相恒如是 唯自心分别
如见物为实 彼人不见佛
不住分别心 亦不能见佛
不见有诸行 如是名为佛
若能如是见 彼人见如来
智者如是观 一切诸境界
转身得妙身 是即佛菩提
    尔时罗婆那十头罗刹楞伽王。见分别心过。而不住于分别心中。以过去世善根力故。如实觉知一切诸论。如实能见诸法实相。不随他教善自思惟觉知诸法。能离一切邪见觉知。善能修行如实行法。于自身中能现一切种种色像。而得究竟大方便解。善知一切诸地上上自体相貌。乐观心意意识自体。见于三界相续身。断离诸外道常见。因智如实善知如来之藏。善住佛地内心实智。闻虚空中及自身中出于妙声。而作是言。善哉善哉楞伽王。诸修行者悉应如汝之所修学。复作是言。善哉楞伽王。诸佛如来法及非法如汝所见。若不如汝之所见者名为断见。楞伽王。汝应远离心意识。如实修行诸法实相。汝今应当修行内法。莫着外义邪见之相。楞伽王。汝莫修行声闻缘觉诸外道等修行境界。汝不应住一切外道诸余三昧。汝不应乐一切外道种种戏论。汝不应住一切外道围陀邪见。汝不应着王位放逸自在力中。汝不应着禅定神通自在力中。楞伽王。如此等事皆是如实修行者行。能降一切外道邪论。能破一切虚妄邪见。能转一切见我见过。能转一切微细识行修大乘行。楞伽王。汝应内身入如来地修如实行。如是修行者。得转上上清净之法。楞伽王。汝莫舍汝所证之道。善修三昧三摩跋提。莫着声闻缘觉外道三昧境界以为胜乐。如毛道凡夫外道修行者。汝莫分别。楞伽王。外道着我见。有我相故虚妄分别。外道见有四大之相。而着色声香味触法以为实有。声闻缘觉见无明缘行以为实有。起执着心离如实空。虚妄分别专著有法。而堕能见所见心中。楞伽王。此胜道法。能令众生内身觉观。能令众生得胜大乘能生三有。楞伽王。此入大乘行。能破众生种种翳瞙种种识波。不堕外道诸见行中。楞伽王。此是入大乘行。非入外道行。外道行者依于内身有我而行。见识色二法以为实。故见有生灭。善哉楞伽王。思惟此义。如汝思惟即是见佛
    尔时罗婆那楞伽王。复作是念。我应问佛。如实行法。转于一切诸外道行。内心修行所观境界。离于应佛所作应事更有胜法。所谓如实修行者证于法时。所得三昧究竟之乐。若得彼乐是则名为如实修行者。是故我应问大慈悲如来世尊。如来能烧烦恼薪尽。及诸佛子亦能烧尽。如来能知一切众生心使烦恼。如来遍至一切智处。如来如实善能知解是相非相。我今应以妙神通力见于如来。见如来已。未得者得已得者不退。得无分别三昧三摩跋提。得增长满足如来行处
    尔时世尊如实照知楞伽王应证无生法忍时至。怜愍十头罗刹王故。所隐宫殿还复如本。身于种种宝网庄严山城中现
    尔时十头罗刹楞伽王。见诸宫殿还复如本。一一山中处处皆见有佛世尊应正遍知三十二相妙庄严身而在山中。自见己身遍诸佛前。又见一切诸佛国土及诸国王念身无常由贪王位妻子眷属五欲相缚无解脱期。便舍国土宫殿妻妾象马珍宝施佛及僧入于山林出家学道。又见佛子在山林中勇猛精进投身饿虎师子罗刹以求佛道。又见佛子在林树下读诵经典为人演说以求佛道。又见菩萨念苦众生坐于道场菩提树下思惟佛道。又见一一佛前皆有圣者大慧菩萨说于内身修行境界。亦见一切夜叉眷属围绕而说名字章句
    尔时世尊智慧观察现在大众非肉眼观。如师子王奋迅视眄呵呵大笑。顶上肉髻放无量光。肩胁腰髀胸卍德处及诸毛孔。皆放一切无量光明。如空中虹如日千光。如劫尽时大火炽然猛炎之相。帝释梵王四天王等。于虚空中观察如来。见佛坐于须弥相对楞伽山顶上呵呵大笑。尔时菩萨众帝释梵天四天王等作是思惟。何因何缘如来应正遍知。于一切法中而得自在。未曾如是呵呵大笑。复于自身出无量光默然而住。专念内身智慧境界不以为胜。如师子视观楞伽王念如实行
    尔时圣者大慧菩萨摩诃萨。先受楞伽罗婆那王所启请已念楞伽王。知诸一切大菩萨众心行之法。观察未来一切众生。心皆乐于名字说法。心迷生疑如说而取着于一切声闻缘觉外道之行。诸佛世尊离诸一切心识之行能笑大笑。为彼大众断于疑心。而问佛言。如来何因何缘何事呵呵大笑。佛告圣者大慧菩萨。善哉善哉善哉大慧。复善哉大慧。汝能观察世间妄想分别之心邪见颠倒。汝实能知三世之事而问此事。如汝所问智者之问亦复如是。为自利利他故。大慧。此楞伽王。曾问过去一切诸佛应正遍知如是二法。今复现在亦欲问我如是二法。此二法者。一切声闻缘觉外道。未尝知此二法之相。大慧。此十头罗刹。亦问未来一切诸佛如此二法
    尔时如来知而故问罗婆那王而作是言。楞伽王。汝欲问我随汝疑心今悉可问。我悉能答断汝疑心令得欢喜。楞伽王。汝断虚妄分别之心。得地对治方便观察。如实智慧能入内身如实之相三昧乐行三昧佛即摄取汝身。善住奢摩他乐境界中。过诸声闻缘觉三昧不净之垢。能住不动善慧法云等地。善知如实无我之法。大宝莲花王座上而坐。得无量三昧而受佛职。楞伽王。汝当不久自见己身亦在如是莲花王座上而坐法尔住持。无量莲花王眷属无量菩萨眷属。各各皆坐莲花王座。而自围绕迭相瞻视。各各不久皆得住彼不可思议境界。所谓起一行方便行住诸地中。能见不可思议境界。见如来地无量无边种种法相。一切声闻缘觉四天王帝释梵王等所未曾见
    尔时楞伽王。闻佛世尊听已问已。彼于无垢无量光明大宝莲花众宝庄严山上。无量天女而自围绕。现于无量种种异花种种异香散香涂香。宝幢幡盖宝冠璎珞庄严身具。复现世间未曾闻见种种胜妙庄严之具。复现无量种种乐器。过诸天龙夜叉乾闼婆阿修罗迦楼罗紧陀罗摩睺罗伽人非人等所有乐具。复随三界欲界色界无色界。所有乐具皆悉化作。复随十方诸佛国土。所有种种胜妙乐具皆悉化作。化作无量大宝罗网。遍覆一切诸佛菩萨大众之上。复竖无量种种宝幢。罗婆那王作如是等变化事已。身升虚空高七多罗树。住虚空中。雨种种伎乐雨种种花。雨种种香雨种种衣。满虚空中如澍大雨。以用供养佛及佛子。雨供养已从上而下。于虚空中即坐第二电光明大宝莲花王种种宝山上
    尔时如来见其坐已发于微笑。听楞伽王问二种法。时楞伽王白佛言。世尊。此二种法我已曾问过去诸佛应正遍知。彼佛世尊已为我说。世尊。我今现在依名字章句亦问如来。如来毕竟应为我说。世尊。应化化佛说此二法非根本如来。世尊。根本如来修集三昧乐境界者。不说心识外诸境界。善哉世尊。如来自身于一切法而得自在。惟愿世尊应正遍知说此二法。一切佛子及我己身亦愿欲闻
    尔时世尊知而即告楞伽王言。楞伽王。汝问此二法。尔时夜叉王更着种种金冠璎珞金庄严具而作是言。如来常说。法尚应舍何况非法。世尊。云何言二法舍。世尊。何者是法何者非法。世尊。舍法云何有二。以堕分别相中。虚妄分别是有无法无大有大。世尊阿梨耶识知名识相。所有体相如虚空中有毛轮住。不净尽智所知境界。世尊。法若如是云何而舍。佛告楞伽王。楞伽王。汝不见瓶等无常败坏之法。毛道凡夫分别境界差别之相。楞伽王。何故不如是取。有法非法差别之相。依毛道凡夫分别心有。非圣证智以为可见。楞伽王。且置瓶等种种相事。毛道凡夫心谓为有。非谓圣人以为有法。楞伽王。譬如一火炎烧宫殿园林草木。见种种火光明色炎各各差别。依种种薪草木长短。分别见有胜负之相。此中何故不如是知有法非法差别之相。楞伽王。非但火炎依一相续身中见有种种诸相差别。楞伽王。如一种子一相续生牙茎枝叶华果树林种种异相。如是内外所生诸法。无明及行阴界入等一切诸法。三界所生皆有差别。现乐形相言语去来胜智异相。一相境界而取于相。见下中上胜相染净善不善相。楞伽王。非但种种法中见差别相。觉如实道者内证行中亦有见于种种异相。何况法非法无分别种种差别相。楞伽王。有法非法种种差别相
    楞伽王。何者为法。所谓一切外道声闻缘觉毛道凡夫分别之见。从因实物以为根本生种种法。如是等法应舍应离。莫取于相而生分别。见自心法计以为实。楞伽王。无瓶实法而毛道凡夫虚妄分别。法本无相。如实知观名舍诸法
    楞伽王何等为非法。所谓无有身相。唯自心灭妄想分别。而诸凡夫见实法非实法。菩萨如实见如是舍非法。复次楞伽王。何者复为非法。所谓兔马驴驼角石女儿等无身无相。而毛道凡夫取以为无。为世间义说于名字非取相。如彼瓶等法可舍。智者不取如是虚妄分别。兔角等名字法亦是可舍。是故舍法及非法。楞伽王。汝今问我法及非法云何舍。我已说竟
    楞伽王。汝言我于过去应正遍知已问此法。彼诸如来已为我说。楞伽王。汝言过去者即分别相。未来现在分别亦尔。楞伽王。我说真如法体是如实者亦是分别。如分别色为实际。为证实智乐修行无相智慧。是故莫分别如来为智身智体。心中莫分别。意中莫取我人命等。云何不分别。意识中取种种境界。如色形相如是莫取。莫分别可分别
    复次楞伽王。譬如壁上画种种相。一切众生亦复如是。楞伽王。一切众生犹如草木无业无行。楞伽王。一切法非法无闻无说。楞伽王。一切世间法皆如幻。而诸外道凡夫不知。楞伽王。若能如是见如实见者名为正见。若异见者名为邪见。若分别者名为取二。楞伽王。譬如镜中像自见像。譬如水中影自见影。如月灯光在屋室中影自见影。如空中响声自出声取以为声。若如是取法与非法。皆是虚妄妄想分别。是故不知法及非法。增长虚妄不得寂灭。寂灭者名为一心。一心者名为如来藏。入自内身智慧境界。得无生法忍三昧

    入楞伽经问答品第二
    尔时圣者大慧菩萨与诸一切大慧菩萨。俱游一切诸佛国土。承佛神力从坐而起更整衣服。合掌恭敬以偈赞佛
佛慧大悲观 世间离生灭
犹如虚空花 有无不可得
佛慧大悲观 一切法如幻
远离心意识 有无不可得
佛慧大悲观 世间犹如梦
远离于断常 有无不可得
佛慧大悲观 烦恼障智障
二无我清净 有无不可得
佛不入不灭 涅槃亦不住
离觉所觉法 有无二俱离
若如是观佛 寂静离生灭
彼人今后世 离垢无染取
    尔时大慧菩萨摩诃萨。如法偈赞佛已。自说姓名
我名为大慧 愿通达大乘
今以百八问 仰咨无上尊
最胜世间解 闻彼大慧问
观察诸众生 告诸佛子言
汝等诸佛子 及大慧咨问
我当为汝说 自觉之境界
    尔时圣者大慧菩萨摩诃萨。闻佛听问顶礼佛足。合掌恭敬以偈问曰
云何净诸觉 何因而有觉
何因见迷惑 何因有迷惑
何因有国土 化相诸外道
云何名佛子 寂静及次第
解脱何所至 谁缚何因脱
禅者观何法 何因有三乘
何因缘生法 何因作所作
何因俱异说 何因无而现
何因无色定 及与灭尽定
何因想灭定 何因从定觉
云何因果生 何因身去住
何因观所见 何因生诸地
破三有者谁 何身至何所
云何处而住 云何诸佛子
何因得神通 及自在三昧
何因得定心 最胜为我说
何因为藏识 何因意及识
何因见诸法 何因断所见
云何性非性 云何心无法
何因说法相 云何名无我
何因无众生 何因有世谛
何因不见常 何因不见断
云何佛外道 二相不相违
何因当来世 种种诸异部
云何名为空 何因念不住
何因有胎藏 何因世不动
云何如幻梦 说如揵闼婆
阳炎水中月 世尊为我说
云何说觉支 何因菩提分
何因国乱动 何因作有见
何因不生灭 何因如空花
何因觉世间 何因无字说
云何无分别 何因如虚空
真如有几种 何名心几岸
何因地次第 真如无次第
何因二无我 何因境界净
几种智几戒 何因众生生
谁作诸宝性 金摩尼珠等
谁生于语言 众生种种异
五明处伎术 谁能如是说
伽陀有几种 云何长短句
法复有几种 解义复有几
何因饮食种 何因生爱欲
云何名为王 转轮及小王
何因护国土 诸天有几种
何因而有地 何因星日月
解脱有几种 行者有几种
弟子有几种 阿阇梨几种
如来有几种 本生有几种
摩罗有几种 异学有几种
自性有几种 心复有几种
云何施假名 世尊为我说
何因有风云 何因有黠慧
何因有树林 世尊为我说
何因象马鹿 何因人捕取
何因为矬陋 世尊为我说
何因为六时 何因成阐提
男女及不男 为我说其生
何因修行退 何因修行进
教何等人修 令住何等法
诸众生去来 何因何像类
何因致财富 世尊为我说
云何为释种 何因有释种
何因甘蔗种 何因长寿仙
长寿仙何亲 云何彼教授
世尊如虚空 为我分别说
何因佛世尊 一切时刹现
种种名色类 佛子众围绕
何因不食肉 云何制断肉
食肉诸种类 何因故食肉
何因日月形 须弥及莲花
师子形胜相 国土为我说
乱侧覆世界 如因陀罗网
一切宝国土 何因为我说
如箜篌琵琶 鼓种种花形
离日月光土 何因为我说
何等为化佛 何等为报佛
何等如智佛 何因为我说
云何于欲界 不成等正觉
云何色究竟 离欲中得道
如来般涅槃 何人持正法
世尊住久如 正法几时住
如来立几法 各见有几种
比尼及比丘 世尊为我说
何因百变易 何因百寂静
声闻辟支佛 世尊为我说
何因世间通 何因出世通
何因七地心 世尊为我说
僧伽有几种 何因为破僧
云何医方论 世尊为我说
迦叶拘留孙 拘那含是我
常为诸佛子 何故如是说
何故说人我 何故说断常
何故不但说 唯有于一心
何因男女林 呵梨阿摩勒
鸡罗及铁围 金刚等诸山
次及无量山 种种宝庄严
仙乐人充满 世尊为我说
大天佛闻彼 所说诸偈句
大乘诸度门 诸佛心第一
善哉善哉问 大慧善谛听
我今当次第 如汝问而说
生及与不生 涅槃空刹那
趣至无自体 佛波罗蜜子
声闻辟支佛 外道无色者
须弥海及山 四天下土地
日月诸星宿 外道天修罗
解脱自在通 力思惟寂定
灭及如意足 觉支及道品
诸禅定无量 五阴及去来
四空定灭尽 发起心而说
心意及意识 无我法有五
自性相所想 所见能见二
云何种种乘 金摩尼珠性
一阐提四大 荒乱及一佛
智境界教得 众生有无有
象马诸禽兽 云何如捕取
譬如因相应 力说法云何
何因有因果 林迷惑如实
但心无境界 诸地无次第
百变及无相 医方工巧论
咒术诸明处 何故而问我
诸山须弥地 其形量大小
大海日月星 云何而问我
上中下众生 身各几微尘
肘步至十里 四十及二十
兔毫窓尘几 羊毛[麸-夫+黄]麦尘
一升几[麸-夫+黄]麦 半升几头数
一斛及十斛 百万及一亿
频婆罗几尘 芥子几微尘
几芥成草子 几草子成豆
几铢成一两 几两成一分
如是次第数 几分成须弥
佛子今何故 不如是问我
缘觉声闻等 诸佛及佛子
身几微尘成 何故不问此
火炎有几尘 风微尘有几
根根几尘数 毛孔眉几尘
何因则自在 转轮圣帝主
何因王守护 解脱广略说
种种众生欲 云何而问我
何因诸饮食 何因男女林
金刚坚固山 为我说云何
何因如幻梦 野鹿渴爱譬
何因而有云 何因有六时
何因种种味 男女非男女
何因诸庄严 佛子何因问
云何诸妙山 仙乐人庄严
解脱至何所 谁缚云何缚
云何禅境界 涅槃及外道
云何无因作 何因可见缚
何因净诸觉 何因有诸觉
何因转所作 幸愿为我说
何因断诸想 何因出三昧
破三有者谁 何因身何处
云何无人我 何因依世说
何因问我相 云何问无我
云何为胎藏 汝何因问我
何因断常见 何因心得定
何因言及智 界性诸佛子
勘解师弟子 种种诸众生
云何饮食魔 虚空聪明施
何因有树林 佛子何因问
云何种种刹 何因长寿仙
何因种种师 汝何因问我
何因有丑陋 修行不欲成
色究竟成道 云何而问我
何因世间通 何因为比丘
云何化报佛 何因而问我
云何如智佛 云何为众僧
箜篌鼓花刹 云何离光明
云何为心地 佛子而问我
此及余众生 佛子所应问
一一相相应 远离诸见过
离诸外道法 我说汝谛听
此上百八见 如诸佛所说
我今说少分 佛子善谛听
    生见不生见。常见无常见。相见无相见。住异见非住异见。刹那见非刹那见。离自性见非离自性见。空见不空见。断见非断见。心见非心见。边见非边见。中见非中见。变见非变见。缘见非缘见。因见非因见。烦恼见非烦恼见。爱见非爱见。方便见非方便见。巧见非巧见。净见非净见。相应见非相应见。譬喻见非譬喻见。弟子见非弟子见。师见非师见。性见非性见。乘见非乘见。寂静见非寂静见。愿见非愿见。三轮见非三轮见。相见非相见。有无立见非有无立见。有二见无二见。缘内身圣见非缘内身圣见。现法乐见非现法乐见。国土见非国土见。微尘见非微尘见。水见非水见。弓见非弓见。四大见非四大见。数见非数见。通见非通见。虚妄见非虚妄见。云见非云见。工巧见非工巧见。明处见非明处见。风见非风见。地见非地见。心见非心见。假名见非假名见。自性见非自性见。阴见非阴见。众生见非众生见。智见非智见。涅槃见非涅槃见。境界见非境界见。外道见非外道见。乱见非乱见。幻见非幻见。梦见非梦见。阳炎见非阳炎见。像见非像见。轮见非轮见。揵闼婆见非揵闼婆见。天见非天见。饮食见非饮食见。淫欲见非淫欲见。见非见见。波罗蜜见非波罗蜜见。戒见非戒见。日月星宿见非日月星宿见。谛见非谛见。果见非果见。灭见非灭见。起灭尽定见非起灭尽定见。治见非治见。相见非相见。支见非支见。巧明见非巧明见。禅见非禅见。迷见非迷见。现见非现见。护见非护见。族姓见非族姓见。仙人见非仙人见。王见非王见。捕取见非捕取见。实见非实见。记见非记见。一阐提见非一阐提见。男女见非男女见。味见非味见。作见非作见。身见非身见。觉见非觉见。动见非动见。根见非根见。有为见非有为见。因果见非因果见。色究竟见非色究竟见。时见非时见。树林见非树林见。种种见非种种见。说见非说见。比丘见非比丘见。比丘尼见非比丘尼见。住持见非住持见。字见非字见。大慧。此百八见过去诸佛所说。汝及诸菩萨当如是学

    入楞伽经卷第一

    入楞伽经卷第二
    元魏天竺三藏菩提留支译
    集一切佛法品第三之一
    尔时圣者大慧菩萨复白佛言。世尊。诸识有几种生住灭。佛告圣者大慧菩萨言。大慧。诸识生住灭。非思量者之所能知。大慧。诸识各有二种生住灭大慧。诸识二种灭者。一者相灭。二者相续灭。大慧。诸识又二种住。一者相住。二者相续住。大慧。诸识有二种生。一者相生。二者相续生。大慧。识有三种。何等三种。一者转相识。二者业相识。三者智相识。大慧。有八种识。略说有二种。何等为二。一者了别识。二者分别事识。大慧。如明镜中见诸色像。大慧。了别识亦如是见种种镜像。大慧。了别识分别事识。彼二种识无差别相迭共为因。大慧。了别识不可思议熏变因。大慧。分别事识分别取境界。因无始来戏论熏习。大慧。阿梨耶识虚妄分别种种熏灭诸根亦灭。大慧。是名相灭。大慧。相续灭者。相续因灭则相续灭。因灭缘灭则相续灭。大慧。所谓依法依缘。言依法者。谓无始戏论妄想熏习。言依缘者。谓自心识见境界分别。大慧。譬如泥团微尘非异非不异。金庄严具亦复如是。非异非不异。大慧。若泥团异者非彼所成。而实彼成。是故不异。若不异者。泥团微尘应无差别。大慧。如是转识阿梨耶识。若异相者。不从阿梨耶识生。若不异者。转识灭阿梨耶识亦应灭。而自相阿梨耶识不灭。是故大慧。诸识自相灭。自相灭者业相灭。若自相灭者阿梨耶识应灭。大慧。若阿梨耶识灭者。此不异外道断见戏论。大慧。彼诸外道作如是说。所谓离诸境界相续识灭。相续识灭已即灭诸识。大慧。若相续识灭者。无始世来诸识应灭大慧。诸外道说相续诸识从作者生。不说识依眼色空明和合而生。而说有作者。大慧。何者是外道作者。胜人自在时微尘等是能作者
    复次大慧。有七种自性。何等为七。一者集性自性。二者性自性。三者相性自性。四者大性自性。五者因性自性。六者缘性自性。七者成性自性
    复次大慧。有七种第一义。何等为七。一者心境界。二者智境界。三者慧境界。四者二见境界。五者过二见境界。六者过佛子地境界。七者入如来地内行境界
    大慧。此是过去未来现在诸佛如来应正遍知性自性第一义心。大慧。依此性自性第一义心。诸佛如来毕竟得于世间出世间。诸佛智慧眼同相别相诸法建立。如所建立不与外道邪见共同。大慧。云何不与外道邪见共同。所谓分别自心境界妄想见。而不觉知自心想见。大慧。诸愚痴凡夫。无有实体以为第一义。说二见论
    复次大慧。汝今谛听我为汝说。虚妄分别以为有物。为断三种苦。何等为三。谓无知爱业因缘灭。自心所见如幻境界。大慧。诸沙门婆罗门作如是说。本无始生依因果而现。复作是说。实有物住依诸缘故。有阴界入生住灭。以生者灭故。大慧。彼沙门婆罗门说。相续体本无始有若生若灭若涅槃若道若业若果若谛。破坏诸法是断灭论。非我所说。何以故。以现法不久当可得故。不见根本故。大慧。譬如瓶破不得瓶用。大慧。譬如燋种不生芽等。大慧。彼阴界入是灭。过去阴界入灭。现在未来亦灭。何以故。因自心虚妄分别见故。大慧。无彼阴界入相续体故。大慧。若本无始生依三法生种种识者。龟毛何故不生沙不出油。汝之所立决定之义是即自坏。汝说有无说生。所成因果亦坏。大慧。若如是依三法因缘。应生诸法因果自相。过去现在未来有无诸相譬喻。及阿含自觉观地依自见薰心。作如是说。大慧。愚痴凡夫亦复如是。恶见所害邪见迷意。无智妄称一切智说
    大慧。若复有沙门婆罗门。见诸法离自性故。如云火轮揵闼婆城不生不灭故。如幻阳炎水中月故。如梦内外心依无始世来虚妄分别戏论而现故。离自心虚妄分别可见因缘故。离灭尽妄想说所说法故。离身资生持用法故。离阿梨耶识取境界相应故。入寂静境界故。离生住灭法故。如是思惟观察自心以为生故。大慧。如是菩萨不久当得世间涅槃平等之心。大慧。汝巧方便开发方便。观察一切诸众生界。皆悉如幻如镜中像故。无因缘起远离内境故。自心见外境界故。次第随入无相处故。次第随入从地至地三昧境界故。信三界自心幻故。大慧。如是修行者当得如幻三昧故。入自心寂静境界故。到彼岸境界故。离作者生法故。得金刚三昧故。入如来身故。入如来化身故。入诸力通自在大慈大悲庄严身故。入一切佛国土故。入一切众生所乐故。离心意意识境界故。转身得妙身故。大慧。诸菩萨摩诃萨如是修行者。必得如来无上妙身。大慧。菩萨欲证如来身者。当远离阴界入心因缘和合法故。远离生住灭虚妄分别戏论故。诸法唯心。当如是知见三界因无始世来虚妄分别戏论而有故。观如来地寂静不生故。进趣内身圣行故。大慧。汝当不久得心自在无功用行究竟故。如众色随摩尼宝化身入诸众生微细心故。以入随心地故。令诸众生次第入地故。是故大慧。诸菩萨摩诃萨应当善知诸菩萨修行自内法故
    尔时圣者大慧菩萨摩诃萨。复白佛言。惟愿世尊。为诸菩萨摩诃萨。说心意意识五法自体相应法门诸佛菩萨修行之处。远离自心邪见境界和合故。能破一切言语譬喻体相故。一切诸佛所说法心。为楞伽城摩罗耶山大海中诸菩萨。说观察阿梨耶识大海波境界。说法身如来所说法故
    尔时佛告圣者大慧菩萨摩诃萨言。大慧。有四因缘眼识生。何等为四。一者不觉自内身取境界故。二者无始世来虚妄分别色境界薰习执着戏论故。三者识自性体如是故。四者乐见种种色相故。大慧。是名四种因缘。于阿梨耶识海起大勇波能生转识。大慧。如眼识起识。一切诸根毛孔一时转识生。如镜中像多少一时。复有随因缘次第生。大慧。犹如猛风吹境心海而识波生不断因事相故。迭共不相离故。业体相使缚故。不觉色体故。而五识身转故。大慧。不离彼五识因了别识相名为意识。共彼因常转故。大慧。五识及心识不作是念。我迭共为因。自心见虚妄分别取诸境界。而彼各各不异。相俱现分别境界。如是彼识微细生灭。以入修行三昧者不觉不知微细熏习。而修行者作是心。我灭诸识入三昧。而修行者不灭诸识入三昧。大慧。熏集种子心不灭。取外境界诸识灭。大慧。如是微细阿梨耶识行。除佛如来及入地诸菩萨摩诃萨。诸余声闻辟支佛外道修行者不能知故。入三昧智力亦不能觉。以其不知诸地相故。以不知智慧方便差别善决定故以不能觉诸佛如来集诸善根故。以不能知自现境界分别戏论故。以不能入种种稠林阿梨耶识窟故。大慧。惟下中上如实修行者。乃能分别见自心中虚妄见故。能于无量国土为诸如来授位故。得无量自在力神通三昧故。依善知识佛子眷属而能得见心意意识自心自体境界故。分别生死大海以业爱无智以为因有故。大慧。是故如实修行者。应推觅亲近善知识故。尔时世尊。而说偈言
譬如巨海浪 斯由猛风起
洪波鼓冥壑 无有断绝时
梨耶识亦尔 境界风吹动
种种诸识浪 腾跃而转生
青赤盐珂乳 味及于石蜜
众华与果实 如日月光明
非异非不异 海水起波浪
七识亦如是 心俱和合生
譬如海水动 种种波浪转
梨耶识亦尔 种种诸识生
心意及意识 为诸相故说
诸识无别相 非见所见相
譬如海水波 是则无差别
诸识心如是 异亦不可得
心能集诸业 意能观集境
识能了所识 五识现分别
    尔时圣者大慧菩萨摩诃萨。以偈问佛
青赤诸色像 自识如是见
水波相对法 何故如是说
    尔时世尊以偈答曰
青赤诸杂色 波中悉皆无
说转识心中 为凡夫相说
彼业悉皆无 自心离可取
可取及能取 与彼波浪同
身资生住持 众生惟识见
是故现转识 水波浪相似
大海波浪动 鼓跃可分别
阿梨耶识转 何故不觉知
凡夫无智慧 梨耶识如海
波浪转对法 是故譬喻说
    尔时圣者大慧菩萨摩诃萨。复说偈言
日出光等照 下中上众生
如来出世间 为凡夫说实
佛得究竟法 何故不说实
若说真实者 彼心无真实
譬如海波浪 镜中像及梦
俱时而得现 心境界亦然
境界不具故 是故次第现
识者识所识 意者然不然
吾则以现见 定中无如是
譬如巧画师 及画师弟子
布彩图众像 我说法亦尔
彩色本无文 非笔亦非器
为众生说故 绮错画众像
言说离真实 真实离名字
我得真实处 如实内身知
离觉所觉相 解如实为说
此为佛子说 愚者异分别
种种皆如幻 唯见非真实
如是种种说 随事实不实
为此人故说 于彼为非说
彼彼诸病人 良医随处药
如来为众生 唯心应器说
妄想非境界 声闻亦非分
诸如来世尊 自觉境界说
    复次大慧。若菩萨摩诃萨。欲知自心离虚妄分别能取可取境界相者。当离愦闹离睡眠盖初夜后夜常自觉悟修行方便。离诸外道一切戏论。离声闻缘觉乘相。当通达自心现见虚妄分别之相
    复次大慧。菩萨摩诃萨建立住持智慧心相者。于上圣智三相当勤修学。大慧。何等为上圣智三相。所谓无所有相。一切诸佛自愿住持相。内身圣智自觉知相。修行此已能舍跛驴智慧之相。得胜子第八地三相修行。大慧。何者无所有相。谓观声闻缘觉外道相。大慧。何者一切诸佛自愿住持相。谓诸佛本自作愿住持诸法。大慧。何者内身圣智自觉知相。一切法相无所执着。得如幻三昧身。诸佛地处进趣修行。大慧。是名上圣智三相。若成就此三相者。能到自觉圣智境界。是故大慧。诸菩萨摩诃萨求上圣智三相者当如是学
    尔时圣者大慧菩萨摩诃萨。知诸大菩萨众心之所念。承佛如来住持之力。问于如来名圣智行分别法门体。世尊。愿为我说名圣智行分别法门体。依百八见分别说。如来应正遍知。依此百八见为诸菩萨摩诃萨。分别说自相同相妄想分别体修行差别法。大慧。诸菩萨善得此妄想分别自体法行差别能清净人无我法无我。善解诸地过诸声闻辟支佛禅定三摩跋提之乐。得诸佛如来不可思议境界修行故。得离五法自体相行。入诸佛法身体真实行故。得如来法身善决定处。如幻境界所成故。一切国土从兜率天阿迦尼吒处得如来法身故
    佛告圣者大慧菩萨。有一种外道邪见执着空无。所有妄想分别智因有二。自体无体。分别兔角无。如兔角无诸法亦无。大慧。复有余外道。见四大功德实有物。见各各有差别相实无兔角。虚妄执着妄想分别实有牛角。大慧。彼诸外道堕于二见不知唯心。妄想分别增长自心界。大慧。如身资生器世间等。惟是心分别。不得分别兔角离于有无。大慧。不得分别一切诸法离于有无。大慧。若有人离于有无。作如是言。无有有兔角分别。不得分别无有有兔角。彼人见相待因。不得分别无兔角。何以故。大慧。乃至观察微细微尘不见实事。离圣人智境界。不得分别有牛角
    尔时圣者大慧菩萨摩诃萨白佛言。世尊。世尊愚痴凡夫不见分别相。而比智分别彼人见无。佛告圣者大慧菩萨言。大慧。非观分别心彼人无相。何以故。因虚妄分别心。依角有分别心。大慧。依止虚妄角有分别心。是故依依止因离相待法非见法彼无角。大慧。若离分别心更有分别。应离角有非因角有。大慧。若不离彼分别心。彼法乃至观察微尘不见有实物。大慧。不离于心彼法应无。以彼二法有无不可得。若尔见何等法有何等法无。大慧。若不如是见有无。不得分别有无。此义云何。见有牛角见无兔角。不得如是分别。大慧。以因不相似故。有无义不成。以诸外道凡夫声闻说有无义二俱不成故
    大慧。复有余外道。见色有因妄想执着形相长短。见虚空无形相分齐。见诸色相异于虚空有其分齐。大慧。虚空即是色。以色大入虚空故。大慧。色即是虚空。依此法有彼法依彼法有此法故。以依色分别虚空。依虚空分别色故。大慧。四大种生自相各别不住虚空。而四大中非无虚空。大慧。兔角亦如是。因牛角有言兔角无。大慧。又彼牛角折为微尘。分别微尘相不可得见。彼何等何等法有。何等何等法无。而言有耶无耶。若如是观余法亦然
    尔时佛告圣者大慧菩萨言。大慧。汝当应离兔角牛角虚空色异妄想见等。大慧。汝亦应为诸菩萨说离兔角等相。大慧。汝应当知自心所见虚妄分别之相。大慧。汝当于诸佛国土中为诸佛子。说汝自心现见一切虚妄境界。尔时世尊重说偈言
色于心中无 心依境见有
内识众生见 身资生住处
心意与意识 自性及五法
二种无我净 如来如是说
长短有无等 展转互相生
以无故成有 以有故成无
分别微尘体 不起色妄想
但心安住处 恶见不能净
非妄智境界 声闻亦不知
如来之所说 自觉之境界
    尔时圣者大慧菩萨摩诃萨。为净自心现流。复请如来而作是言。世尊。云何净除自心现流。为次第净为一时耶。佛告圣者大慧菩萨摩诃萨言。大慧。净自心现流。次第渐净非为一时。大慧。譬如庵摩罗果渐次成熟非为一时。大慧。众生清净自心现流亦复如是。渐次清净非为一时。譬如陶师造作诸器。渐次成就非为一时。大慧。诸佛如来净诸众生自心现流亦复如是。渐次而净非一时净。大慧。譬如大地生诸树林药草万物。渐次增长非一时成。大慧。诸佛如来净诸众生自心现流亦复如是。渐次而净非一时净。大慧。譬如有人学诸音乐歌舞书画种种伎术。渐次而解非一时知。大慧。诸佛如来净诸众生自心现流。亦复如是。渐次而净非一时净。大慧。譬如明镜无分别心一时俱现一切色像。如来世尊亦复如是。无有分别净诸众生自心现流。一时清净非渐次净。令住寂静无分别处。大慧。譬如日月轮相光明一时遍照一切色像非为前后。大慧。如来世尊亦复如是。为令众生离自心烦恼见薰习气过患。一时示现不思议智最胜境界。大慧。譬如阿梨耶识分别现境自身资生器世间等。一时而知非是前后。大慧。报佛如来亦复如是。一时成熟诸众生界。置究竟天净妙宫殿修行清净之处。大慧。譬如法佛报佛放诸光明。有应化佛照诸世间。大慧。内身圣行光明法体。照除世间有无邪见亦复如是
    复次大慧。法佛报佛说一切法自相同相故。因自心现见薰习相故。因虚妄分别戏论相缚故。如所说法无如是体故。大慧。譬如幻师幻作一切种种形像。诸愚痴人取以为实。而彼诸像实不可得。复次大慧。虚妄法体依因缘法。执著有实分别而生。大慧。如巧幻师依草木瓦石作种种事。依于咒术人工之力。成就一切众生形色身分之相名幻人像。众生见幻种种形色。执着为人而实无人。大慧。众生虽见以为是人。无实人体。大慧。因缘法体随心分别亦复如是。以见心相种种幻故。何以故。以执着虚妄相因分别心熏习故。大慧。是名分别虚妄体相。大慧。是名报佛说法之相。大慧。法佛说法者。离心相应体故。内证圣行境界故。大慧。是名法佛说法之相
    大慧。应化佛所作应佛说施戒忍精进禅定智慧故。阴界入解脱故。建立识想差别行故。说诸外道无色三摩跋提次第相。大慧。是名应佛所作应佛说法相。复次大慧。法佛说法者。离攀缘故。离能观所观故。离所作相量相故。大慧。非诸凡夫声闻缘觉外道境界故。以诸外道执着虚妄我相故。是故大慧。如是内身自觉修行胜相当如是学。大慧。汝当应离见自心相以为非实
    复次大慧。声闻乘有二种差别相。谓于内身证得圣相故。执着虚妄相分别有物故。大慧。何者声闻内身证得圣相。谓无常苦空无我境界故。真谛离欲寂灭故。阴界入故。自相同相故。内外不灭相故。见如实法故。得心三昧。得心三昧已。得禅定解脱三昧道果三摩跋提不退解脱故。离不可思议薰习变易死故。内身证得圣乐行法住声闻地故。大慧。是名声闻内身证得圣相。大慧菩萨摩诃萨入诸声闻内证圣行三昧乐法。而不取寂灭空门乐。不取三摩跋提乐。以怜愍众生故起本愿力行。是故虽知不取为究竟。大慧。是名声闻内身证圣修行乐相。大慧。菩萨摩诃萨应当修行内身证圣修行乐门而不取着大慧。何者是声闻分别有物执着虚妄相。谓于四大坚湿热动相。青黄赤白等相故。无作者而有生故。自相同相故。斟量相应阿含先胜见善说故。依彼法虚妄执着以为实有。大慧。是名声闻分别有物执着虚妄相。大慧。菩萨摩诃萨于彼声闻法应知而舍。舍已入法无我相。入法无我相已入人无我。观察无我相已次第入诸地。大慧。是名声闻分别有物执着虚妄相。大慧。所言声闻乘有二种相者我已说竟
    尔时圣者大慧菩萨摩诃萨复白佛言。世尊。世尊所说常不可思议法。内身证圣境界法第一前法。世尊。外道亦说常不可思议因果。此义云何。佛告圣者大慧菩萨言。大慧。诸外道说常不可思议因果不成。何以故。大慧。诸外道说常不可思议非因自相相应故。大慧。诸外道说常不可思议若因自相不相应者。此何等法。何等法了出。是故外道不得言常不可思议。复次大慧。诸外道说常不可思议者。若因自相相应者应成无常不可思议。以有因相故。是故不成常不可思议。大慧。我说常不可思议第一义。常不可思议。与第一义相因果相应。以离有无故。以内身证相故。以有彼相故。以第一义智因相相应。以离有无故。以非所作故。与虚空涅槃寂灭譬喻相应故。是故常不可思议。是故大慧。我说常不可思议。不同外道常不可思议论。大慧。此常不可思议。诸佛如来应正遍知实是常法。以诸佛圣智内身证得故。非心意意识境界故。大慧。是故菩萨摩诃萨应当修行常不可思议内身所证圣智行法。复次大慧。诸外道常不可思议。无常法相因相应故。是故无常。非因相而得名故。是故常法不可思议。大慧。若诸外道常不可思议。见有无法而言常。以彼法比智知言有常。大慧。我亦如是。即因此法作有无见。无常应常。何以故。以无因故。复次大慧。诸外道说若因相相应成常不可思议。以彼外道言因自相有无故者同于兔角。大慧。此常不可思议。诸外道等但虚妄分别。何以故。以无兔角但虚妄分别故。自因相无故。大慧。我常不可思议。惟内身证相因故。离作有无法故。是故常不可思议。以无外相故。常法相应故。大慧。诸外道等见无外相。比智知常不可思议以为常。彼外道等不知常不可思议。自因相彼因相故。以内身圣智证境界相故。大慧。彼外道于我法不应为说
    复次大慧。诸声闻辟支佛。畏生死妄想苦而求涅槃。不知世间涅槃无差别故。分别一切法与非法而灭诸根不取未来境界妄取以为涅槃。不知内身证修行法故。不知阿梨耶识转故。大慧。是故彼愚痴人。说有三乘法。而不能知唯心想寂灭得寂灭法。是故彼无智愚人。不知过去未来现在诸佛如来应正遍知。自心见境界故。执着外心境界故。是故大慧。彼愚痴人。于世间生死轮中常转不住
    复次大慧。过去未来现在一切诸佛。皆说诸法不生。何以故。谓自心见有无法故。若离有无诸法不生故。是故大慧。一切法不生。大慧。一切法如兔角驴驼等角。大慧。愚痴凡夫妄想分别分别诸法。是故一切诸法不生。大慧。一切诸法自体相不生。是内身证圣智境界故。非诸凡夫自体分别二境界故。大慧。是阿梨耶识。身资生器世间去来自体相故。见能取可取转故。诸凡夫堕于生住灭二相心故。分别诸法生有无故。大慧。汝应知如是法故
    复次大慧。我说五种乘性证法。何等为五。一者声闻乘性证法。二者辟支佛乘性证法。三者如来乘性证法。四者不定乘性证法。五者无性证法。大慧。何者声闻乘性证法。谓说阴界入法故。说自相同相证智法故。彼身毛孔熙怡欣悦。乐修相智不修因缘不相离相故。大慧。是名声闻乘性证法故。彼声闻人邪见证智。离起粗烦恼。不离无明熏习烦恼。见己身证相。谓初地中乃至五地六地离诸烦恼。同已所离故。熏习无明烦恼故堕不可思议变易死故。而作是言。我生已尽。梵行已立。所作已办。不受后有。如是等得入人无我乃至生心。以为得涅槃故。大慧。复有余外道求证涅槃。而作是言。觉知我人众生寿命作者受者丈夫。以为涅槃。大慧。复有余外道。见一切诸法依因。而有生涅槃心故。大慧。彼诸外道无涅槃解脱。以不见法无我故。大慧。是名声闻乘外道性。于非离处而生离想。大慧。汝应转此邪见修行如实行故
    大慧。何者辟支佛乘性证法。谓闻说缘觉证法。举身毛竖悲泣流泪。不乐愦闹故。观察诸因缘法故。不着诸因缘法故。闻说自身种种神通。若离若合种种变化。其心随入故。大慧。是名缘觉乘性证法。汝当应知随顺缘觉说
    大慧。何者如来乘性证法。大慧。如来乘性证法有四种。何等为四。一者证实法性。二者离实法证性。三者自身内证圣智性。四者外诸国土胜妙庄严证法性。大慧。若闻说此一一法时。但阿梨耶心。见外身所依资生器世间不可思议境界。不惊不怖不畏者。大慧当知。是证如来乘性人。大慧。是名如来乘性证法人相
    大慧。何者不定乘性证法。大慧。若人闻说此三种法。于一一中有所乐者随顺为说。大慧。说三乘者为发起修行地故。说诸性差别非究竟地。为欲建立毕竟能取寂静之地故。大慧。彼三种人离烦恼障熏习得清净故。见法无我得三昧乐行故。声闻缘觉毕竟证得如来法身故。尔时世尊重说偈言
逆流修无漏 往来及不还
应供阿罗汉 是等心乱惑
我说于三乘 一乘及非乘
诸圣如实解 凡夫不能知
第一义法门 远离于二教
建立于三乘 为住寂静处
诸禅及无量 无色三摩提
无想定灭尽 亦皆心中无
    大慧。何者无性乘。谓一阐提。大慧。一阐提者无涅槃性。何以故。于解脱中不生信心不入涅槃。大慧。一阐提者有二种。何等为二。一者焚烧一切善根。二者怜愍一切众生。作尽一切众生界愿。大慧。云何焚烧一切善根。谓谤菩萨藏作如是言。彼非随顺修多罗毗尼解脱说。舍诸善根。是故不得涅槃。大慧。怜愍众生作尽众生界愿者。是为菩萨。大慧。菩萨方便作愿。若诸众生不入涅槃者。我亦不入涅槃。是故菩萨摩诃萨不入涅槃。大慧。是名二种一阐提无涅槃性。以是义故。决定取一阐提行。大慧菩萨白佛言。世尊。此二种一阐提。何等一阐提常不入涅槃。佛告大慧菩萨摩诃萨。一阐提常不入涅槃。何以故。以能善知一切诸法本来涅槃。是故不入涅槃。非舍一切善根阐提。何以故。大慧。彼舍一切善根阐提。若值诸佛善知识等。发菩提心生诸善根便证涅槃。何以故。大慧。诸佛如来不舍一切诸众生故。是故大慧。菩萨一阐提常不入涅槃

    入楞伽经卷第二

    入楞伽经卷第三
    元魏天竺三藏菩提留支译
    集一切佛法品第三之二
    复次大慧。菩萨摩诃萨当善知三法自体相。大慧。何等三法自体相。一者虚妄分别名字相。二者因缘法体自相相。三者第一义谛法体相。大慧。何者虚妄分别名字相。谓从名字虚妄分别一切法相。是名虚妄分别名字之相。大慧。何者因缘法体自相相。大慧。因缘法体自相相者。从境界事生故。大慧。因缘法体境界事相。诸佛如来应正遍知。说虚妄分别差别有二种。何等二种。一者妄执名字戏论分别。二者妄执名字相分别境界相事相。大慧。何者妄执名字相境界相事相。谓即彼内外法自相同相。大慧。是名因缘法体二种自相相。以依彼法观彼法生故。大慧。是名因缘法体自相相。大慧。何者第一义谛法体相。谓诸佛如来。离名字相境界相事相相。圣智修行境界行处。大慧。是名第一义谛相诸佛如来藏心。尔时世尊重说偈言
名相分别事 及法有二相
真如正妙智 是第一义相
    大慧。是名观察五法自相法门。诸佛菩萨修行内证境界之相。汝及诸菩萨应如是学
    复次大慧。菩萨摩诃萨应当善观二无我相。大慧。何等二种。一者人无我智。二者法无我智。云何人无我智。谓离我我所阴界入聚故。无智业爱生故。依眼色等虚妄执着故。自心现见一切诸根器身屋宅故。自心分别分别故。分别分别识故。如河流种子灯焰风云。念念展转前后差别轻躁动转。如猨猴蝇等爱乐不净境界处故。无厌足如火故。因无始来戏论境界熏习故。犹如辘轳车轮机关。于三界中生种种色种种身。如幻起尸。大慧。如是观诸法相巧方便智。是名善知人无我智境界之相。大慧。何者法无我智。谓如实分别阴界入相。大慧。菩萨观察阴界入等无我我所。阴界入聚因业爱绳迭共相缚。因缘生故无我无作者。大慧。阴界入等离同相异相故。依不实相分别得名。愚痴凡夫妄相分别以为有故。非证实者见以为有。大慧。菩萨如是观察心意意识。五法体相一切离故诸因缘无。是名善知诸法无我智境界相。大慧。菩萨善知诸法无我已。观察真如修寂静行。不久当得初欢喜地。善能观察欢喜地已。如是诸地次第转明。乃至得证法云之地。菩萨住彼法云地已。无量诸宝间错庄严。大莲华王座大宝宫殿。如实业幻境界所生而坐其上。一切同行诸佛子等恭敬围绕。十方诸佛申手灌顶授于佛位。如转轮王灌太子顶。过佛子地。过佛子地已。观诸佛法如实修行。于诸法中而得自在。得自在已。名得如来无上法身。以见法无我故。大慧。是名如实法无我相。大慧。汝及诸菩萨应如是学
    尔时圣者大慧菩萨复白佛言。世尊。世尊有无谤相愿为我说。世尊。我及诸菩萨摩诃萨若闻得离有无邪见。速得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。远离断常邪见建立。便能建立诸佛正法。尔时世尊。复受圣者大慧菩萨摩诃萨请已。而说偈言
心中无断常 身资生住处
惟心愚无智 无物而见有
    尔时世尊于此偈义复重宣说。告圣者大慧菩萨言。大慧。有四种建立谤相。何等为四。一者建立非有相。二者建立非正见相。三者建立非有因相。四者建立非有体相。大慧。是名四种建立
    大慧。何者是谤相。大慧。观察邪见所建立法不见实相。即谤诸法言一切无。大慧。是名建立谤相
    复次大慧。何者建立非有相。谓分别阴界入非有法。无始来戏论非有实故。而执着同相异相。此法如是如是毕竟不异。大慧。依此无量世来烦恼薰习执着而起。大慧。是名建立非有相。大慧。何者建立非正见相。大慧。彼阴界入中。无我人众生寿者作者受者。而建立邪见。谓有我等故。大慧。是名建立非正见相。大慧。何者建立非有因相。谓初识不从因生。本不生后时生如幻。本无因物而有因眼色明念故识生。生已还灭。大慧。是名建立非有因相。大慧。何者建立非有体谤法相。谓虚空灭涅槃无作无物建立执着。大慧。彼三法离有无故。大慧。一切诸法如兔马驴驼角毛轮等故。离有无建立相故。大慧。建立谤相者诸凡夫虚妄分别故。不知但是心见。诸法是有非圣人所见故。大慧。是名建立非有体谤法相。大慧。汝当远离不正见建立谤法相故
    复次大慧。诸菩萨摩诃萨如实知心意意识五法体相二种无我。为安隐众生现种种类像。如彼虚妄无所分别。依因缘法。而有种种。大慧。菩萨摩诃萨亦复如是。依众生现种种色如如意宝。随诸一切众生心念。于诸佛土大众中现。如幻如梦如响如水中月镜中像故。远离诸法。不生不灭非常非断故。现佛如来。离诸声闻缘觉乘故。闻诸佛法。即得无量百千万亿诸深三昧。得三昧已依三昧力。从一佛土至一佛土供养诸佛。示现生于诸宫殿中赞叹三宝。现作佛身菩萨声闻大众围绕。令诸一切众生得入自心见境。为说外境无物有物。令得远离建立有无法故。尔时世尊重说偈言
佛子见世间 惟心无诸法
种类非身作 得力自在成
    尔时圣者大慧菩萨复请佛言。惟愿世尊为我等说一切法空无生无二离自体相。我及一切诸菩萨众。知诸法空无生无二离自体相已离有无妄想。速得阿耨多罗三藐三菩提。尔时佛告圣者大慧菩萨摩诃萨言。善哉善哉。善哉大慧。谛听谛听。我当为汝广分别说。大慧白佛言。善哉世尊。唯然受教。佛告大慧言。大慧。空者即是妄想法体句。大慧。依执着妄想法体。说空无生无体相不二。大慧。空有七种。何等为七。一者相空。二者一切法有物无物空。三者行空。四者不行空。五者一切法无言空。六者第一义圣智大空。七者彼彼空。大慧。何者是相空。谓一切法自相同相空。见迭共积聚。大慧。观察一一法自相同相。无一法可得。离自相他相二相。无相可住可见。是故名为自相空。大慧。何者一切法有物无物空。谓自体相实有法生大慧。诸法自体相有无俱空。是故名为自体相有物无物空。大慧。何者是行空。谓诸阴等离我我所。依因作业而得有生。大慧。是故名为行空。大慧。何者不行空。谓阴法中涅槃未曾行。大慧。是名不行空。大慧。何者一切法无言空。谓妄想分别一切诸法无言可说。大慧。是名一切法无言空。大慧。何者第一义圣智大空。谓自身内证圣智法空。离诸邪见熏习之过。大慧。是名第一义圣智大空。大慧。何者彼彼空。谓何等何等法处。彼法无此法有。彼法有此法无。是故言空。大慧。我昔曾为鹿母说殿堂空者。无象马牛羊等名为空。有诸比丘等名为不空。而殿堂殿堂体无。比丘比丘体亦不可得。而彼象马牛羊等非余处无。大慧。如是诸法自相同相。亦不可得离此彼处。是故我言彼彼空。大慧。是名七种空。大慧。此彼彼空最为粗浅。大慧。汝当应离彼彼空不须修习。大慧言。何者不生。大慧。自体不生而非不生。依世谛故说名为生。依本不生故言不生。大慧言。何者无体相。大慧。我说无体相者。一切诸法体本不生。是故我言诸法无体。而相续体刹那不住。大慧。以见异异相故。是故一切法无体相。大慧言。何者名为不二法相。大慧。二法相者。谓日光影长短黑白。彼如是等法各各别名。不得言不二。大慧。如世间涅槃一切诸法各各有二。大慧。何等涅槃。彼处无世间。何处世间。彼处无涅槃。以异因相故。是故我言一切诸法不二。一切诸法不二者。世间涅槃无二故。是故汝应修学诸法空不生无体不二故。尔时世尊重说偈言
我常说空法 远离于断常
生死如幻梦 而彼业不失
虚空及涅槃 灭二亦如是
凡夫分别生 圣人离有无
    尔时佛告圣者大慧菩萨摩诃萨言。大慧。一切法空不生无体不二相。入于诸佛如来所说修多罗中。凡诸法门皆说此义。大慧。一切修多罗。随诸一切众生心故分别显示。大慧。譬如阳焰迷惑禽兽。虚妄执着生于水想。而阳焰中实无有水。大慧。一切修多罗说法亦复如是。为诸凡夫自心分别令得欢喜。非如实圣智在于言说。大慧。汝应随顺于义。莫着所说名字章句
    尔时圣者大慧菩萨摩诃萨白佛言。世尊。世尊。如修多罗说。如来藏自性清净。具三十二相。在于一切众生身中。为贪嗔痴不实垢染阴界入衣之所缠裹。如无价宝垢衣所缠。如来世尊复说常恒清凉不变。世尊。若尔外道亦说我有神我常在不变。如来亦说如来藏常乃至不变。世尊。外道亦说有常作者。不依诸缘自然而有周遍不灭。若如是者。如来外道说无差别。佛告圣者大慧菩萨言。大慧。我说如来藏常。不同外道所有神我。大慧。我说如来藏空实际涅槃不生不灭无相无愿等文辞章句。说名如来藏。大慧。如来应正遍知。为诸一切愚痴凡夫。闻说无我生于惊怖。是故我说有如来藏。而如来藏无所分别寂静无相。说名如来藏。大慧。未来现在诸菩萨等。不应执著有我之相。大慧。譬如陶师依于泥聚微尘轮绳。人功手木方便力故作种种器。大慧。如来世尊亦复如是。彼法无我离诸一切分别之相。智慧巧便说名如来藏。或说无我。或说实际及涅槃等。种种名字章句示现。如彼陶师作种种器。是故大慧。我说如来藏不同外道说有我相。大慧。我说如来藏者。为诸外道执着于我。摄取彼故说如来藏。令彼外道离于神我妄想见心执着之处。入三解脱门。速得阿耨多罗三藐三菩提。大慧。以是义故。诸佛如来应正遍知说如来藏。是故我说有如来藏。不同外道执着神我。是故大慧。为离一切外道邪见。诸佛如来作如是说。汝当修学如来无我相法。尔时世尊重说偈言
人我及于阴 众缘与微尘
自性自在作 唯心妄分别
    尔时圣者大慧菩萨。观察未来一切众生。复请佛言。唯愿世尊。为诸菩萨说如实修行法。彼诸菩萨闻说如实修行之法。便得成就如实修行者。佛告圣者大慧菩萨摩诃萨言。大慧。有四种法得名为大如实修行者。何等为四。一者善知自心现见故。二者远离生住灭故。三者善解外法有无故。四者乐修内身证智故。大慧。菩萨成就如是四法。得成就大如实修行者。大慧。何者菩萨摩诃萨观察三界但是一心作故。离我我所故。无动无觉故。离取舍故。从无始来虚妄执着。三界薰习戏论心故。种种色行常系缚故。身及资生器世间中六道虚妄现故。大慧。是名诸菩萨摩诃萨善知自心现见相。大慧。云何一切菩萨摩诃萨见远离生住灭法。谓观诸法如幻如梦故一切诸法自他二种无故不生。以随自心现知见故。以无外法故。诸识不起观诸因缘无积聚故。见诸三界因缘有故。不见内外一切诸法无实体故。远离生诸法不正见故。入一切法如幻相故。菩萨尔时名得初地无生法忍。远离心意意识五法体相故。得二无我如意意身。乃至得第八不动地如意意身故。大慧菩萨白佛言。世尊。何故名为如意意身。佛告大慧。随意速去如念即至。无有障碍名如意身。大慧。言如意者。于石壁山障无量百千万亿由旬。念本所见种种境界自心中缚。不能障碍自在而去。大慧。如意身者亦复如是。得如幻三昧自在神力庄严其身。进趣一切圣智种类身无障碍随意而去。以念本愿力境界故。为化一切诸众生故。大慧。是名菩萨摩诃萨远离生住灭相。大慧。云何菩萨摩诃萨善解外法有无之相。所谓菩萨见一切法。如阳焰如梦如毛轮故。因无始来执着种种戏论分别妄想薰习故。见一切法无体相。求证圣智境界修行故。大慧。是名菩萨善解外法有无之相。即成就大如实修行者。大慧。汝应如是修学
    尔时圣者大慧菩萨复请佛言。世尊。唯愿世尊。说一切法因缘之相。我及一切诸菩萨等。善知诸法因缘之相。离于有无不正见等。妄想分别诸法次第一时生过。佛告大慧菩萨言。大慧。一切诸法有于二种因缘集相。所谓内外。大慧。外法因缘集相者。所谓泥团等柱轮绳人功方便缘故。则有瓶生。大慧。如泥团等因缘生瓶。如是缕叠草席种牙湩等人功生酪。生酪已生酥生酥已得醍醐。大慧。是名外法因缘集相。从下上上应知。大慧。何者内法因缘集相。大慧。所谓无明业爱。如是等法名内因缘集相。大慧。因无明等阴界入等。而得名为因缘集相。而诸凡夫虚妄分别各见别相。大慧。因有六种。何等为六。一者当因。二者相续因。三者相因。四者作因。五者了因。六者相待因。大慧。当因者。作因已能生内外法。大慧。相续因者。能攀缘内外法阴种子等。大慧。相因者。能生相续次第作事而不断绝。大慧。作因者。能作增上因如转轮王。大慧。了因者。妄想事生已能显示。如灯照色等。大慧。相待因者。于灭时不见虚妄生法。相续事断绝故。大慧。如是诸法。凡夫自心虚妄分别。大慧。是诸法非次第生。非一时生。何以故。大慧。若一切法一时生者。因果不可差别。以不见因果身相故。若次第生者。未得身相不得言次第生。如未有子不能言父。大慧。愚痴凡夫自心观察。次第相续不相应故。作如是言。因缘．次第缘．所缘缘．增上缘等能生诸法。大慧。如是次第诸法不生。大慧。虚妄分别取法体相。一时次第俱亦不生复次大慧。自心中见身及资生故。大慧。自相同相外法无法。是故次第一时不生。大慧。但虚妄识生自心见故。大慧。汝当应离不正见因缘生事次第一时生法。尔时世尊重说偈言
因缘无不生 不生故不灭
生灭因缘虚 非生亦非灭
为遮诸因缘 愚人虚妄取
有无缘不生 故诸法不起
以于三界中 熏习迷惑心
因缘本自无 不生亦不灭
见诸有为法 石女虚空花
转可取能取 不生惑妄见
现本皆不生 缘本亦不有
如是等诸法 自体是空无
亦无有住处 为世间说有
    尔时圣者大慧菩萨复白佛言。世尊。惟愿世尊。为我说名分别言语相心法门。我及一切诸菩萨等若得善知名分别言语相心法门。则能通达言说及义二种之法。速得阿耨多罗三藐三菩提。得菩提已。言说及义。能令一切诸众生等得清净解。佛告圣者大慧菩萨言。善哉大慧。谛听谛听。当为汝说。大慧菩萨言。善哉世尊。唯然受教。佛告大慧菩萨言。大慧。有四种妄相言语。何等为四。一者相言说。二者梦言说。三者妄执言说。四者无始言说。大慧。相言说者。所谓执着色等诸相而生。大慧。梦言说者。念本受用虚妄境界。依境界梦觉已。知依虚妄境界不实而生。大慧。执着言说者。念本所闻所作业生。大慧。无始言说者。从无始来执着戏论烦恼种子熏习而生。大慧。我言四种言说虚妄执著者。我已说竟
    尔时圣者大慧菩萨。复以此义劝请如来。而白佛言。世尊。惟愿为我重说四种虚妄执着言语之相。众生言语何处出。云何出何因出。佛告大慧菩萨言。大慧。从头胸喉鼻唇舌牙齿转故。和合出声。大慧菩萨白佛言。世尊。口中言语虚妄法相。为异为不异。佛告大慧言。大慧。言语虚妄者。非异非不异。何以故。大慧。因彼虚妄法相生言语故。大慧。若言语异者应无因生。大慧。若不异者。言说不能了前境界。大慧。说彼言语能了前境。是故非异非不异。大慧复白佛言。世尊。为言语即第一义。为言语所说为第一义。佛告大慧。非言语即第一义。何以故。大慧。为令第一义随顺言语入圣境界故。有言语说第一义。非言语即第一义。大慧。第一义者。圣智内证。非言语法是智境界。以言语能了彼境界。大慧。说第一义言语者。是生灭法念念不住。因缘和合有言语生。大慧。因缘和合者。彼不能了第一义。何以故。以无自相他相故。是故大慧。言语不能了第一义。复次大慧。随顺自心见外诸法无法分别。是故不能了知第一义。是故大慧汝当应离种种言语妄分别相。尔时世尊重说偈言
诸法本虚妄 无有自体实
是故诸言语 不能说有无
空及与不空 凡夫不能知
诸法无体相 说众生亦尔
分别有无法 犹如化梦等
观察一切法 不住于涅槃
亦不住世间 如王长者等
为令诸子喜 泥作诸禽兽
先与虚伪物 后乃授实事
我说种种法 自法镜像等
为诸佛子喜 后说明实际
    尔时圣者大慧菩萨复白佛言。世尊。唯愿世尊。为诸菩萨及我身。说离有无一异俱不俱有无非有非无常无常。一切外道所不能行。圣智自证觉所行故。离于自相同相法故。入第一义实法性故。诸地次第上上清净故。入如来地相故。依本愿力如如意宝无量境界修行之相自然行故。于一切法自心现见差别相故。我及一切诸菩萨等。离于如是妄想分别同相异相。速得阿耨多罗三藐三菩提。得菩提已与一切众生安隐乐具悉令满足故。佛告大慧。善哉善哉。善哉大慧。汝为哀愍一切天人。多所安乐多所饶益。乃能问我如是之义。善哉善哉。善哉大慧。谛听谛听。我当为汝分别解说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。愚痴凡夫不能觉知惟自心见。执着外诸种种法相以为实有。是故虚妄分别一异俱不俱有无非有非无常无常。因自心熏习依虚妄分别心故。大慧。譬如群兽为渴所逼依热阳焰自心迷乱而作水想。东西驰走不知非水。大慧。如是凡夫愚痴心见。生住灭法不善分别。因无始来虚妄执着戏论熏习。贪嗔痴热迷心逼恼。乐求种种诸色境界。是故凡夫堕于一异俱不俱有无非有非无常无常等。大慧。譬如凡夫见揵闼婆城生实城想。因无始来虚妄分别城想种子熏习而见。大慧。彼城非城非不城。大慧。一切外道亦复如是。因无始来戏论熏习。执着一异俱不俱有无非有非无常无常法故。大慧。以不觉知唯是自心虚妄见故。大慧。譬如有人于睡梦中见诸男女。象马车步。城邑聚落。牛与水牛。园林树木。种种山河。泉流浴池。宫殿楼阁。种种庄严广大严博。见身在中忽然即觉。觉已忆念彼广大城。大慧。于意云何。彼人名为是圣者不。大慧白佛言。不也世尊。佛告大慧。一切愚痴凡夫外道邪见诸见亦复如是。不能觉知诸法。梦睡自心见故。执着一异俱不俱有无非有非无常无常见故。大慧。譬如画像不高不下。大慧。愚痴凡夫妄见诸法有高有下。大慧。于未来世依诸外道邪见心熏习。增长虚妄分别一异俱不俱有无非有非无常无常等。大慧。而彼外道自坏坏他。说如是言。诸法不生不灭有无寂静。彼人名为不正见者。大慧。彼诸外道谤因果法。因邪见故拔诸一切善根白法清净之因。大慧。欲求胜法者当远离说如是法人。彼人心着自他二见。执虚妄法堕于诽谤。建立邪心入于恶道。大慧。譬如目瞖见虚空中有于毛轮。为他说言如是如是青黄赤白汝何不观。大慧。而彼毛轮本自无体。何以故。有见不见故。大慧。诸外道等依邪见心虚妄分别亦复如是。虚妄执着一异俱不俱有无非有非无常无常生诸法故。大慧。譬如天雨生于水泡似颇梨珠。愚痴凡夫妄见执着。生于珠想东西走逐。大慧。而彼水泡非宝珠非不宝珠。何以故。有取不取故。大慧。彼诸外道因虚妄心分别熏习亦复如是。说非有法依因缘生。复有说言实有法灭。复次大慧。彼诸外道建立三种量五分论。而作是言。实有圣者内证之法离二自体。虚妄分别故。大慧。离心意意识。转身便得圣种类身。修行诸行无如是心。离自心见能取可取虚妄境界故。入如来地自身进趣证圣智故。如实修行者。不生有无心故。大慧。如实修行必得如是境界故。大慧。若取有无法者。即为我相人相众生相寿者相故。大慧。说有无法自相同相。是名应化佛说。非法佛说。复次大慧。应化如来说如是法。随顺愚痴凡夫见心令其修行。非为建立如实修行。示现自身内证圣智三昧乐行故。大慧。譬如人见水中树影。大慧。彼非影非不影。何以故。有树则有无树则无故。大慧。彼诸外道依邪见心妄想熏习亦复如是。分别一异俱不俱有无非有非无常无常。妄想分别故。何以故。以不觉知唯自心见故。大慧。譬如明镜随缘得见一切色像无分别心。大慧。彼非像非不像。何以故。有缘得见无缘不见故。大慧。愚痴凡夫自心分别见像有无。大慧。一切外道自心妄想分别镜像亦复如是。见一异俱不俱故。大慧。譬如诸响因人山河水风空屋和合而闻。彼所闻响非有非无。何以故。因声闻声故。大慧。一切外道自心虚妄分别熏习。见一异俱不俱有无非有非无常无常故。大慧。譬如大地无诸草木园林之处因于日光尘土和合见水波动。而彼水波非有非无。何以故。令众生欢喜不欢喜故。大慧。一切外道愚痴凡夫亦复如是。因无始来烦恼心熏习戏论分别生住灭一异俱不俱有无非有非无常无常。圣人内身证智门中。示现阳焰渴爱事故。大慧。譬如有人依咒术力起于死尸。机关木人无众生体依毗舍阇力。依巧师力作去来事。而诸愚痴凡夫。执着以为实有。以去来故。大慧。愚痴凡夫诸外道等堕邪见心亦复如是。执着虚妄一异俱不俱有无非有非无常无常故。是故凡夫外道。虚妄建立如是法故。是故大慧。汝当远离生住灭一异俱不俱有无非有非无常无常故。自身内证圣智分别故。尔时世尊重说偈言
五阴及于识 如水中树影
如幻梦所见 莫依意识取
诸法如毛轮 如焰水迷惑
观察于三界 一切如幻梦
若能如是观 修行得解脱
如夏兽爱水 摇动迷惑心
彼处无水事 妄想见为水
如意识种子 境界动生见
愚痴取为实 彼法生如翳
无始世愚痴 取物如怀抱
如因榍出榍 诳凡夫入法
幻起尸机关 梦电云恒尔
观世间如是 断有得解脱
阳焰虚空中 无有诸识知
观诸法如是 不着一切法
诸识唯有名 以诸相空无
见阴如毛轮 何法中分别
画及诸毛轮 幻梦犍闼婆
火轮禽趣水 实无而见有
常无常及一 二俱及不俱
依无始因缚 凡夫迷惑心
镜宝水眼中 现诸种种像
妄见种种色 如梦石女儿
一切法无实 如兽爱空水
    复次大慧。诸佛如来说法离四种见。谓离一异俱不俱故。远离建立有无故。大慧。一切诸佛如来说法。依实际因缘寂灭解脱故。大慧。一切诸佛如来说法。依究竟境界。非因自性．自在天．无因．微尘时。不依如是说法
    复次大慧。诸佛说法离二种障烦恼障智障。如大商主将诸人众。次第置于至未曾见究竟安隐寂静之处。次第安置令善解知乘地差别相故
    复次大慧。有四种禅。何等为四。一者愚痴凡夫所行禅。二者观察义禅。三者念真如禅。四者诸佛如来禅。大慧。何者愚痴凡夫所行禅。谓声闻缘觉外道修行者。观人无我自相同相骨锁故。无常苦无我不净执着诸相。如是如是决定毕竟不异故。如是次第因前观次第上上乃至非想灭尽定解脱。是名愚痴凡夫外道声闻等禅
    大慧。何者观察义禅。谓观人无我自相同相故。见愚痴凡夫外道自相同相自他相无实故。观法无我诸地行相义次第故。大慧。是名观察义禅
    大慧。何者观真如禅。谓观察虚妄分别因缘。如实知二种无我。如实分别一切诸法无实体相。尔时不住分别心中得寂静境界。大慧。是名观真如禅。大慧。何者观察如来禅。谓如实入如来地故。入内身圣智相三空三种乐行故。能成办众生所作不可思议。大慧。是名观察如来禅。尔时世尊重说偈言
凡夫等行禅 观察义相禅
观念真如禅 究竟佛净禅
譬如日月形 钵头摩海相
虚空火尽相 行者如是观
如是种种相 堕于外道法
亦堕于声闻 辟支佛等行
舍离于一切 则是无所有
时十方刹土 诸佛真如手
摩彼行者顶 入真如无相
    尔时圣者大慧菩萨摩诃萨白佛言。世尊。言涅槃。涅槃者。说何等法名为涅槃。佛告圣者大慧菩萨言。大慧。言涅槃者。转灭诸识法体相故。转诸见熏习故。转心意阿梨耶识法相熏习。名为涅槃。大慧。我及诸佛说如是涅槃法体境界空事故。复次大慧。言涅槃者。谓内身圣智修行境界故。离虚妄分别有无法故。大慧。云何非常。谓离自相同相分别法故。是故非常。大慧。云何非断。谓过去未来现在一切圣人内身证得故。是故非断。大慧。般涅槃者非死非灭。大慧。若般涅槃是死法者。应有生缚故。大慧。若般涅槃是灭法者。应堕有为法故。是故大慧。般涅槃者非死非灭。如实修行者之所归依故。复次大慧。言涅槃者非可取非可舍。非此处非彼处。非断非常。非一义非种种义。是故名为涅槃。复次大慧。声闻涅槃者。观察自相同相觉诸法故。名声闻涅槃。大慧。辟支佛涅槃者不乐愦闹。见诸境界无常无乐无我无净。不生颠倒相。是故声闻辟支佛非究竟处生涅槃想故
    复次大慧。我为汝说二法体相。何等为二。一者执着言说体相。二者执着世事体相。大慧。何者执着言说体相。谓无始来执着言说戏论熏习生故。大慧。何者执着世事体相。谓不如实知唯是自心见外境界故
    复次大慧。诸菩萨摩诃萨依二种愿力住持故。顶礼诸佛如来应正遍知问所疑事。大慧。何等二种愿力住持。一者依三昧三摩跋提住持力。二者遍身得乐谓佛如来手摩其顶受位住持力。大慧。诸菩萨摩诃萨住初地中承诸如来住持力故。名入菩萨大乘光明三昧。大慧。诸菩萨摩诃萨入大乘光明三昧已。尔时十方诸佛如来应正遍知。与诸菩萨住持力故现身口意。大慧。如金刚藏菩萨摩诃萨。及余成就如是功德相菩萨摩诃萨。大慧。如是诸菩萨摩诃萨。住初地中三昧三摩跋提力住持故。以百千万亿劫修集善根力故。次第如实知地对治法相成就。菩萨摩诃萨至法云地。住大宝莲华王宫殿师子座上坐。同类菩萨摩诃萨眷属围绕。宝冠璎珞庄严其身。如阎浮檀金瞻卜日月光明胜莲花色
    尔时十方一切诸佛各申其手。遥摩莲花王座上菩萨摩诃萨顶。如得自在王帝释王转轮王灌太子顶授位故。大慧。彼授位菩萨。及眷属菩萨摩诃萨。依如来手摩顶故得遍身乐。是故言手摩菩萨顶住持力。大慧。是名诸菩萨摩诃萨二种住持力。大慧。诸菩萨摩诃萨。依此二种住持力故。能观察一切诸如来身。大慧。若无二种住持力者。则不得见诸佛如来。大慧。若诸菩萨摩诃萨。离二种住持力能说法者。愚痴凡夫亦应说法。何以故。谓不以得诸佛住持力故。大慧。依诸如来住持力故。山河石壁草木园林及种种伎乐。城邑聚落宫殿屋宅。皆能出于说法之声。自然皆出伎乐之音。大慧。何况有心者聋盲喑痖无量众生离诸苦恼。大慧。诸佛如来住持之力。无量利益安乐众生。大慧菩萨复白佛言。世尊。世尊何故诸菩萨摩诃萨入三昧三摩跋提及入诸地时。诸佛如来应正遍知作住持力。佛告大慧。为护魔业烦恼散乱心故。为不堕声闻禅定地故。为内身证如来地故。为增长内身证法故。大慧。是故诸佛如来应正遍知。为诸菩萨作住持力。大慧。若诸如来不为菩萨作住持力者。堕诸外道声闻辟支佛魔事故。不得阿耨多罗三藐三菩提。是故诸佛如来应正遍知。大慈摄取诸菩萨故。尔时世尊重说偈言
菩萨依自身 本愿力清净
入三昧授位 初地至十地
诸佛人中尊 神力作住持

    入楞伽经卷第三

    入楞伽经卷第四
    元魏天竺三藏菩提留支译
    集一切佛法品第三之三
    尔时圣者大慧菩萨摩诃萨复白佛言。世尊。如世尊说。十二因缘从因生果。不说自心妄想分别见力而生。世尊。若尔外道亦说从因生果。世尊。外道说言。从于自性自在天时微尘等因生一切法。如来亦说依于因缘而生诸法。而不说有自建立法。世尊。外道亦说从于有无而生诸法。世尊说言。诸法本无依因缘生生已还灭。世尊说从无明缘行乃至于有。依眼识等生一切法。如世尊说。亦有诸法无因而生。何以故。不从因生一时无前后生。以因此法生此法。世尊自说。因虚妄因法生。此法非次第生故。世尊。若尔外道说法胜而如来不如。何以故。世尊。外道说因无因缘能生果。如来说法因亦依果果亦依因。若尔因缘无因无果。世尊。若尔彼此因果展转无穷。世尊说言。从此法生彼法。若尔无因生法。佛告圣者大慧菩萨摩诃萨言。大慧。我今当说。因此法生彼法。不同外道所立因果。无因之法亦从因生。我不如是。我说诸法从因缘生。非无因缘亦不杂乱。亦无展转无穷之过。何以故。以无能取可取法故。大慧。外道不知自心见故。执着能取可取之法。不知不觉惟自心见内外法故。大慧。彼诸外道不知自心内境界故见有无物。是故外道有如是过。非我过也。我常说言。因缘和合而生诸法非无因生。大慧复言。世尊。有言语说应有诸法。世尊。若无诸法者应不说言语。世尊。是故依言说应有诸法。佛告大慧。亦有无法而说言语。谓兔角龟毛石女儿等。于世间中而有言说。大慧。彼兔角非有非无而说言语。大慧。汝言以有言说应有诸法者。此义已破。大慧。非一切佛国土言语说法。何以故。以诸言语惟是人心分别说故。是故大慧。有佛国土直视不瞬口无言语名为说法。有佛国土直尔示相名为说法。有佛国土但动眉相名为说法。有佛国土惟动眼相名为说法。有佛国土笑名说法。有佛国土欠呿名说法。有佛国土咳名说法。有佛国土念名说法。有佛国土身名说法。大慧。如无瞬世界及众香世界。于普贤如来应正遍知。彼菩萨摩诃萨。观察如来目不暂瞬。得无生法忍。亦得无量胜三昧法。是故大慧。汝不得言有言语说应有诸法。大慧。如来亦见诸世界中。一切微虫蚊虻蝇等众生之类。不说言语共作自事而得成办。尔时世尊重说偈言
如虚空兔角 及与石女儿
无而有言说 如是妄分别
因缘和合法 愚痴分别生
不知如实法 轮回三有中
    尔时圣者大慧菩萨摩诃萨复白佛言。世尊。世尊说常语法。依何等法作如是说。佛告圣者大慧菩萨言。大慧。依迷惑法我说为常。何以故。大慧。圣人亦见世间迷惑法非颠倒心。大慧。譬如阳焰火轮毛轮乾闼婆城幻梦水中月镜中像。世间非智慧者。见有诸像。颠倒见故。有智慧者不生分别。非不见彼迷惑之事。大慧。有智慧者见彼种种迷惑之事不生实心。何以故。离有无法故
    佛复告圣者大慧菩萨言。大慧。云何迷惑法离于有无。谓诸愚痴凡夫。见有种种境界。如诸饿鬼大海恒河见水不见。大慧。是迷惑法不得言有不得言无。大慧。余众生见彼是水故不得言无。大慧。迷惑之事亦复如是。以诸圣人离颠倒见故。大慧。言迷惑法常者。以想差别故。大慧。因迷惑法见种种相。而迷惑法不分别异差别。是故大慧。迷惑法常。大慧。云何迷惑法名之为实。以诸圣人迷惑法中不生颠倒心。亦不生实心。大慧。而诸圣人见彼迷惑法起少心想。不生圣智事相。大慧。起少想者是谓凡夫非谓圣人。大慧。分别彼迷惑法颠倒非颠倒者。能生二种性。何等二种。一者能生凡夫性。二者能生圣人性。大慧。彼圣人性者。能生三种差别之性。所谓声闻辟支佛佛国土差别性故。大慧。云何毛道凡夫分别迷惑法。而能生彼声闻乘性。大慧。所谓执着彼迷惑法自相同相。能成声闻乘性。大慧。是名迷惑法能生能成声闻乘性。大慧。云何愚痴凡夫分别迷惑法。而能生彼辟支佛乘性。大慧。所谓执着彼迷惑法。观察诸法自相同相不乐愦闹。能生辟支佛乘性。大慧。是名迷惑法能生能成辟支佛乘性。大慧。云何智者即分别彼迷惑之法。能生佛乘性。大慧。所谓见彼能见可见惟是自心。而不分别有无法故。大慧。如是观察迷惑之法。能生能成如来乘性。大慧。如是名为性义。大慧。何者一切毛道凡夫。即分别彼迷惑之法见种种事。能生世间所有乘性。以观察诸法如是如是决定不异。是故大慧。彼迷惑法愚痴凡夫。虚妄分别种种法体。大慧。彼迷惑法非是实事非不实事。何以故。大慧。圣人观察彼迷惑法不虚妄分别。是故圣人能转心意意识身相。离烦恼习故。是故圣人转彼迷惑法。名为真如。大慧。此名何等法。大慧。此名真如法。离分别法故。大慧。为此义故。我重宣说真如法体离分别法。彼真如中无彼虚妄分别法故。大慧菩萨复白佛言。世尊。彼迷惑法为有为无。佛告大慧。彼迷惑法执着种种相故名有。大慧。彼迷惑法于妄想中若是有者。一切圣人皆应不离。执著有无虚妄法故。大慧。如外道说十二因缘。有从因生不从因生。此义亦如是。大慧言。世尊。若迷惑法如幻见者。此迷惑法异于迷惑。以迷惑法能生法故。佛告大慧。大慧。非迷惑法生烦恼过。大慧。若不分别迷惑法者不生诸过。复次大慧。一切幻法依于人功咒术而生。非自心分别烦恼而生。是故大慧。彼迷惑法不生诸过。惟是愚痴人见迷惑法故。大慧。愚痴凡夫执着虚妄微细之事。而生诸过非谓圣人。尔时世尊重说偈言
圣不见迷惑 世间亦无实
迷惑即是实 实法次迷惑
舍离诸迷惑 若有相生者
即彼是迷惑 不净犹如翳
    复次大慧。汝不得言幻是无故一切诸法亦无如幻。大慧言。世尊。为执着诸法如幻相故。言诸法如幻。为执着诸法颠倒相故。言诸法如幻也。世尊。若执着诸法如幻相者。世尊不得言一切法皆如幻相。若执着诸法颠倒相故言如幻者。不得言一切法如幻。何以故。世尊。色有种种因相见故。世尊。无有异因色有诸相可见如幻。是故世尊。不得说言执着诸法一切如幻。佛告大慧。非谓执着种种法相。说言诸法一切如幻。大慧。诸法颠倒速灭如电故言如幻。大慧。一切诸法譬如电光即见即灭。凡夫不见。大慧。一切诸法亦复如是。以一切法自心分别同相异相。以不能观察故不如实见。以妄执着色等法故。尔时世尊重说偈言
非见色等法 说言无幻法
故不违上下 我说一切法
不见有本性 如幻无生体
    大慧菩萨复白佛言。世尊。如世尊说诸法不生。复言如幻。将无世尊前后所说自相违耶。以如来说一切诸法不如幻故。佛告大慧。我说一切法不生如幻者。不成前后有相违过。何以故。以诸一切愚痴凡夫不见生法及不生法。不能觉知自心有无外法有无。何以故。以不能见不生法故。大慧。我如是说诸法前后无有相违。大慧。我遮外道建立因果义不相当。是故我说诸法不生。大慧。一切外道愚痴群聚作如是说。从于有无生一切法。不说自心分别执着因缘而生。大慧。我说诸法有亦不生无亦不生。是故大慧。我说诸法不生不灭。大慧。我说一切诸法有者。护诸弟子令知二法。何等为二。一者摄取诸世间故。二者为护诸断见故。何以故。以依业故有种种身摄六道生。是故我说言有诸法摄取世间。大慧。我说一切法如幻者。为令一切愚痴凡夫毕竟能离自相同相故。以诸凡夫痴心执着堕于邪见。以不能知但是自心虚妄见故。令离执着因缘生法。是故我说一切诸法如幻如梦无有实体。何以故。若不如是说者。愚痴凡夫执邪见心。欺诳自身及于他身。离如实见一切法故。大慧。云何住如实见。谓入自心见诸法故。尔时世尊重说偈言
如汝言诸法 一切不生者
是则谤因果 不生如实见
我说有生法 摄受诸世间
见诸法同幻 不取诸见相
    复次佛告圣者大慧菩萨言。大慧。我今为诸菩萨摩诃萨。说名句字身相。以诸菩萨善知名句字身相故。依名句字身相。速得阿耨多罗三藐三菩提。得菩提已为众生说名句字相。大慧菩萨白佛言。善哉世尊。惟愿速说。大慧。何者名身。谓依何等。何等法作名名身事物名异义一。大慧。是名我说名身。大慧。何者是句身。谓义事决定究竟见义故。大慧。是名我说句身。大慧。何者是字身。谓文句毕竟故。大慧。复次名身者。依何等法了别名句。能了知自形相故。大慧。复次句身者。谓句事毕竟故。大慧。复次名身者。所谓诸字从名差别。从阿字乃至呵字。名为名身。大慧。复次字身者。谓声长短音韵高下。名为字身。大慧。复次句身者。谓巷路行迹。如人象马诸兽行迹等。得名为句。大慧。复次名字者。谓无色四阴依名而说。大慧。复次名字相者。谓能了别名字相故。大慧。是名名句字身相。大慧。如是名句字相。汝应当学为人演说。尔时世尊重说偈言
名身与句身 及字身差别
凡夫痴计着 如象溺深泥
    复次大慧。未来世中无智慧者。以邪见心不知如实法故。因世间论自言智者。有智者问如实之法。离邪见相一异俱不俱。而彼愚人作如是言。是问非是非正念问。谓色等法常无常为一为异。如是涅槃有为。诸行为一为异。相中所有能见所见为一为异。作者所作为一为异。四大中色香味触为一为异能见所见为一为异。泥团微尘为一为异。智者所知为一为异。如是等上上次第相。上上无记置答。佛如是说是为谤我。大慧。而我不说如是法者。为遮外道邪见说故。何以故。大慧。外道等说谓身即命身异命异。如是等法外道所说是无记法。大慧。外道迷于因果义故。是故无记。非我法中名无记也。大慧。我佛法中离能见可见虚妄之想无分别心。是故我法中无有置答。诸外道等执着可取能取。不知但是自心见法。为彼人故我说言有四种问法。无记置答非我法中。大慧。诸佛如来应正遍知。为诸众生有四种说言置答者。大慧。为待时故说如是法。为根未熟非为根熟。是故我说置答之义
    复次大慧。一切诸法若离作者及因不生。以无作者故。是故我说诸法不生。佛告大慧。一切诸法无有体相。大慧白佛言。世尊。何故一切诸法无实体相。佛告大慧。自智观察一切诸法自相同相不见诸法。是故我说一切诸法无实体相。佛告大慧。一切诸法亦无取相。大慧言。世尊。以何义故一切诸法亦无取相。佛告大慧。自相同相无法可取。是故我说无法可取。佛告大慧。一切诸法亦无舍相。大慧言。世尊。何故诸法亦无舍相。佛告大慧。观察自相同相法无法可舍。是故我说一切诸法亦无舍相。佛告大慧。诸法不灭。大慧言。世尊。何故一切诸法不灭。佛告大慧。观一切法自相同相无体相故。是故我说诸法不灭。佛告大慧。诸法无常。大慧言。世尊。何故一切诸法无常。佛告大慧。一切诸法常无常想常不生相。是故我说诸法无常。复次大慧。我说一切诸法无常。大慧言。世尊。何故一切诸法无常。佛告大慧。以相不生以不生体相。是故常无常。是故我说诸法无常。尔时世尊重说偈言
记论有四种 直答反质答
分别答置答 以制诸外道
有及非有生 僧佉毗世师
而说悉无记 彼作如是说
正智慧观察 自性不可得
是故不可说 及说无体相
    尔时圣者大慧菩萨摩诃萨白佛言。世尊。惟愿世尊。为我等说须陀洹等行差别相。我及一切菩萨摩诃萨等。善知须陀洹等修行相已。如实知须陀洹斯陀含阿那含阿罗汉等。如是如是为众生说。众生闻已入二无我相净二种障。次第进取地地胜相。得如来不可思议境界修行。得修行处已。如如意宝随众生念受用境界身口意行故。佛告大慧言。善哉善哉。善哉大慧。谛听谛听。今为汝说。大慧白佛言。善哉世尊。唯然听受。佛告大慧言。大慧。须陀洹有三种果差别。大慧言。何等三种。佛告大慧。谓下中上。大慧。何者须陀洹下。谓三有中七返受生。大慧。何者为中。谓三生五生入于涅槃。大慧。何者为上。谓即一生入于涅槃。大慧。是三种须陀洹有三种结。谓下中上。大慧。何者三结。谓身见疑戒取。大慧。彼三种结上上胜进得阿罗汉果大慧。身见有二种。何等为二。一者俱生。二者虚妄分别而生。如因缘分别法故。大慧。譬如依诸因缘法相虚妄分别而生实相。彼因缘法中非有非无。以分别有无非实相故。愚痴凡夫执着种种法相。如诸禽兽见于阳炎取以为水。大慧。是名须陀洹分别身见。何以故。以无智故。无始世来虚妄取相故。大慧。此身见垢见人无我乃能远离。大慧。何者须陀洹俱生身见。所谓自身他身俱见。彼二四阴。无色色阴生时。依于四大及四尘等。彼此因缘和合生色。而须陀洹知已能离有无邪见断于身见。断身见已不生贪心。大慧。是名须陀洹身见之相。大慧。何者须陀洹疑相。谓得证法善见相已。先断身见及于二见分别之心。是故于诸法中不生疑心。复不生心于余尊者以为尊相为净不净故。大慧。是名须陀洹疑相。大慧。何者须陀洹戒取相。谓善见受生处苦相故。是故不取戒相。大慧。戒取者。谓诸凡夫持戒精进种种善行。求乐境界生诸天中。彼须陀洹不取是相而取自身内证回向进趣胜处。离诸妄想修无漏戒分。大慧。是名须陀洹戒取相。大慧。须陀洹断三结烦恼离贪嗔痴。大慧白佛言。世尊。世尊说众多贪。须陀洹离何等贪。佛告大慧。须陀洹远离与诸女人和合。不为现在乐种未来苦因。远离打掴呜抱眄视。大慧。须陀洹不生如是贪心。何以故。以得三昧乐行故。大慧。须陀洹远离如是等贪。非离涅槃贪。大慧。何者斯陀含果相。谓一往见色相现前生心。非虚妄分别想见。以善见禅修行相故。一往来世间。便断苦尽入于涅槃。是名斯陀含。大慧。何者阿那含相。谓于过去现在未来色相中生有无心。以见使虚妄分别心。诸结不生。不来故名阿那含。大慧。何者阿罗汉相。谓不生分别思惟可思惟。三昧解脱力通烦恼苦等分别心故。名阿罗汉
    大慧菩萨白佛言。世尊。说三种阿罗汉。此说何等罗汉名阿罗汉。世尊为说得决定寂灭罗汉。为发菩提愿善根忘善根罗汉为化应化罗汉。佛告大慧。为说得决定寂灭声闻罗汉非余罗汉。大慧。余罗汉者。谓曾修行菩萨行者。复有应化佛所化罗汉。本愿善根方便力故。现诸佛土生大众中庄严诸佛大会众故。大慧。分别去来说种种事。远离证果能思惟所思惟可思惟故。以见自心为见所见说得果相。复次大慧。若须陀洹生如是心。此是三结。我离三结者。大慧。是名见三法堕于身见。彼若如是不离三结。大慧。是故须陀洹不生如是心。复次大慧。若欲远离禅无量无色界者。应当远离自心见相远离少相。寂灭定三摩跋提相故。大慧。若不如是。彼菩萨心见诸法以惟心故。尔时世尊重说偈言
诸禅四无量 无色三摩提
少相寂灭定 一切心中无
逆流修无漏 及于一往来
往来及不还 罗汉心迷没
思可思能思 远离见真谛
惟是虚妄心 能知得解脱
    复次大慧。有二种智。何等为二。一者观察智。二者虚妄分别取相住智。大慧。何者观察智。谓何等智观察一切诸法体相。离于四法无法可得。是名观察智。大慧。何者四法。谓一异俱不俱。是名四法。大慧。若离四法一切法不可得。大慧。若欲观察一切法者。当依四法而观诸法。大慧。妄想分别取相住智者。所谓执着坚热湿动。虚妄分别四大相故。执着建立．因．譬喻相故建立非实法以为实。大慧。是名虚妄分别执着取相住持智。大慧。是名二种智相。大慧。诸菩萨摩诃萨。毕竟知此二相进趣法无我相。善知真实智地行相。知已即得初地得百三昧。依三昧力见百佛见百菩萨。能知过去未来各百劫事。照百佛世界。照百佛世界已。善知诸地上上智相。以本愿力故。能奋迅示现种种神通。于法云地中依法雨授位。证如来内究竟法身智慧地。依十无量善根愿转。为教化众生种种应化。自身示现种种光明。以得自身修行证智三昧乐故
    复次大慧。菩萨摩诃萨应善知四大及四尘相。大慧。云何菩萨善知四大及四尘相。大慧菩萨摩诃萨。应如是修行。所言实者。谓无四大处。观察四大本来不生。如是观已复作是念。言观察者惟自心见虚妄觉知。以见外尘无有实物。惟是名字分别心见。所谓三界离于四大及四尘相。见如是已离四种见。见清净法离我我所。住于自相如实法中。大慧。住自相如实法中者。谓住建立诸法无生自相法中。大慧。于四大中云何有四尘。大慧。谓妄想分别柔软湿润。生内外水大。大慧。妄想分别暖增长力。生内外火大。大慧。妄想分别轻转动相。生内外风大。大慧。妄想分别所有坚相。生内外地大。大慧。妄想分别内外共虚空生内外想。以执着虚妄内外邪见。五阴聚落四大及四尘生故。佛告大慧。识能执着种种境界乐求异道。取彼境界故。大慧。四大有四。谓色香味触。大慧。四大无因。何以故。谓地自体形相长短不生四大相故。大慧。依形相大小上下容貌而生诸法。不离形相大小长短而有法故。是故大慧。外道虚妄分别四大及四尘。非我法中如此分别。复次大慧。我为汝说五阴体相。大慧。何者五阴相。谓色受想行识。大慧。四阴无色相。谓受想行识。大慧。色依四大生。四大彼此不同相。大慧。无色相法同如虚空。云何得成四种数相。大慧。譬如虚空离于数相。而虚妄分别此是虚空。大慧。阴之数相离于诸相。离有无相离于四相。愚痴凡夫说诸数相非谓圣人。大慧。我说。诸相如幻种种形相离一二相依假名说。如梦镜像不离所依。大慧。如圣人智修行分别见五阴虚妄。大慧。是名五阴无五阴体相。大慧。汝今应离如是虚妄分别之相。离如是已为诸菩萨说离诸法相寂静之法。为遮外道诸见之相。大慧。说寂静法得证清净无我之相入远行地。入远行地已得无量三昧自在如意生身故。以得诸法如幻三昧故。以得自在神通力修行进趣故。随一切众生自在用如大地故。大慧。譬如大地一切众生随意而用。大慧。菩萨摩诃萨随众生用亦复如是。复次大慧。外道说有四种涅槃。何等为四。一者自体相涅槃。二者种种相有无涅槃。三者自觉体有无涅槃。四者诸阴自相同相断相续体涅槃。大慧。是名外道四种涅槃。非我所说。大慧。我所说者。见虚妄境界分别识灭名为涅槃。大慧白佛言。世尊。世尊可不说八种识耶。佛告大慧。我说八种识。大慧言。若世尊说八种识者。何故但言意识转灭。不言七识转灭。佛告大慧。以依彼念观有故。转识灭七识亦灭。复次大慧。意识执着取境界生。生已种种熏习增长阿梨耶识。共意识故。离我我所相。着虚妄空而生分别。大慧。彼二种识无差别相。以依阿梨耶识因观自心见境。妄想执着生种种心。犹如束竹迭共为因。如大海波。以自心见境界风吹而有生灭。是故大慧。意识转灭七种识转灭。尔时世尊重说偈言
我不取涅槃 亦不舍作相
转灭虚妄心 故言得涅槃
依彼因及念 意趣诸境界
识与心作因 为识之所依
如水流枯竭 波浪则不起
如是意识灭 种种识不生
    复次大慧。我为汝说虚妄分别法体差别相。汝及诸菩萨摩诃萨。善分别知虚妄法体差别之相。离分别所分别法。善知自身内修行法。远离外道能取可取境界。远离种种虚妄分别因缘法体相。远离已不复分别虚妄之相。大慧。何者虚妄分别法体差别之相。大慧。虚妄分别自体差别相有十二种。何等为十二。一者言语分别。二者可知分别。三者相分别。四者义分别。五者实体分别。六者因分别。七者见分别。八者建立分别。九者生分别。十者不生分别。十一者和合分别。十二者缚不缚分别。大慧。是名分别自体相差别法相。大慧。言语分别者。谓乐着种种言语美妙音声。大慧。是名言语分别。大慧。可知分别者。谓作是思惟应有前法实事之相。圣人修行知。依彼法而生言语。如是分别。大慧。是名可知分别。大慧。相分别者。谓即彼可知境界中热湿动坚种种相执以为实。如空阳焰诸禽兽见生于水想。大慧。是名相分别。大慧义分别者。谓乐金银等种种实境界。大慧。是名义分别。大慧。自体分别者。谓专念有法自体形相。此法如是如是不异。非正见见分别。大慧。是名自体分别。大慧。因分别者。谓何等何等因。何等何等缘。有无了别因。相生了别相。大慧。是名因分别。大慧。见分别者。谓有无一异俱不俱。邪见外道执着分别。大慧。是名见分别。大慧。建立分别者。谓取我我所相说虚妄法。大慧。是名建立分别。大慧。生分别者。谓依众缘有无法中生执着心。大慧。是名生分别。大慧。不生分别者。谓一切法本来不生。以本无故依因缘有而无因果。大慧。是名无生分别大慧。和合分别者。谓何等何等法和合。如金缕共。何等何等法和合。如金缕和合。大慧。是名和合分别。大慧。缚不缚分别者。谓缚因执着如所缚。大慧。如人方便结绳作结。结已还解。大慧。是名缚不缚分别。大慧。是名虚妄分别法体差别之相。以此虚妄分别法体差别之相。一切凡夫执著有无故。执着法相种种因缘。是故大慧。分别法体差别之相。见种种法执着为实。如依于幻见种种事。凡夫分别知异于幻有如是法。大慧。我于种种法中不异幻说。亦非不异。何以故。若幻异于种种法者。不应因幻而生种种。若幻即是种种法者不应异见。此是幻此是种种而见差别。是故我说不异非不异。是故大慧。汝及诸菩萨摩诃萨。莫分别幻有实无实。尔时世尊重说偈言
心依境界缚 知觉随境生
于寂静胜处 生平等智慧
妄想分别有 于缘法则无
取虚妄迷乱 不知他力生
种种缘生法 即是幻不实
彼有种种想 妄分别不成
彼想则是过 皆从心缚生
愚痴人无智 分别因缘法
此诸妄想体 即是缘起法
妄想有种种 众缘中分别
世谛第一义 第三无因生
妄想说世谛 断则圣境界
譬如修行者 一事见种种
彼法无种种 分别相如是
如目种种瞖 妄想见众色
瞖无色非色 无智取法尔
如真金离垢 如水离泥浊
如虚空离云 真法净亦尔
无有妄想法 因缘法亦无
取有及谤无 分别观者见
妄想若无实 因缘法若实
离因应生法 实法生实法
因虚妄名法 见诸因缘生
想名不相离 如是生虚妄
虚妄本无实 则度诸妄想
然后知清净 是名第一义
妄想有十二 缘法有六种
内身证境界 彼无有差别
五法为真实 及三种亦尔
修行者行此 不离于真如
众生及因缘 名分别彼法
彼诸妄想相 从彼因缘生
真实智善观 无缘无妄想
第一义无物 云何智分别
若真实有法 远离于有无
若离于有无 云何有二法
分别二法体 二种法体有
虚妄见种种 清净圣境界
见妄想种种 因缘中分别
若异分别者 则堕于外道
妄想说妄想 因见和合生
离二种妄想 即是真实法
    尔时大慧菩萨摩诃萨复白佛言。世尊。惟愿为说自身内证圣智修行相及一乘法。不由于他游行一切诸佛国土通达佛法。佛告圣者大慧菩萨言。善哉善哉。善哉大慧。谛听谛听。当为汝说。大慧言。善哉世尊。唯然受教。佛告大慧。菩萨摩诃萨离阿含名字法诸论师所说分别法相在寂静处独坐思惟。自内智慧观察诸法不随他教。离种种见虚妄之相。当勤修行入如来地上上证智。大慧。是名自身内证圣智修行之相。大慧。更有三界中修一乘相。大慧。何者一乘相。大慧。如实觉知一乘道故。我说名一乘。大慧。何者如实觉知一乘道相。谓不分别可取能取境界。不生如是诸法相住。以不分别一切诸法故。大慧。是名如实觉知一乘道相。大慧。如是觉知一乘道相。一切外道声闻辟支佛梵天等未曾得知。惟除于我。大慧。故我说名一乘道相。大慧白佛言。世尊。世尊何因说于三乘不说一乘。佛告大慧。声闻缘觉不能自知证于涅槃。是故我说惟一乘道。大慧。以一切声闻辟支佛。随受佛教厌离世间。自不能得解脱。是故我说惟一乘道。复次大慧。一切声闻辟支佛。不离智障。不离业烦恼习气障故。是故我说惟一乘道。大慧。声闻辟支佛。未证法无我。未得离不可思议变易生。是故我为诸声闻故。说一乘道。大慧。声闻辟支佛。若离一切诸过熏习。得证法无我。尔时离于诸过。三昧无漏。醉法觉已修行出世间无漏界中一切功德。修行已得不可思议自在法身。尔时世尊重说偈言
天乘及梵乘 声闻缘觉乘
诸佛如来乘 我说此诸乘
以心有生灭 诸乘非究竟
若彼心灭尽 无乘及乘者
无有乘差别 我说为一乘
引导众生故 分别说诸乘
解脱有三种 及二法无我
不离二种障 远离真解脱
譬如海浮木 常随波浪转
诸声闻亦然 相风所漂荡
离诸随烦恼 熏习烦恼缚
味着三昧乐 安住无漏界
无有究竟趣 亦复不退还
得诸三昧身 无量劫不觉
譬如惛醉人 酒消然后悟
得佛无上体 是我真法身

    入楞伽经卷第四

    入楞伽经卷第五
    元魏天竺三藏菩提留支译
    佛心品第四
    尔时佛告圣者大慧菩萨言。大慧。我今为汝说意生身修行差别。大慧。谛听谛听。当为汝说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。有三种意生身。何等为三。一者得三昧乐三摩跋提意生身。二者如实觉知诸法相意生身。三者种类生无作行意生身。菩萨从于初地如实修行。得上上地证智之相。大慧。何者菩萨摩诃萨。得三昧乐三摩跋提意生身。谓第三第四第五地中。自心寂静行种种行。大海心波转识之相三摩跋提乐。名意识生。以见自心境界故。如实知有无相。大慧。是名意生身相。大慧。何者如实觉知诸法相意生身。谓菩萨摩诃萨。于八地中观察觉了。得诸法无相如幻等法悉无所有。身心转变得如幻三昧及余无量三摩跋提乐门。无量相力自在神通。妙华庄严迅疾如意。犹如幻梦水中月镜中像。非四大生似四大相具足身分。一切修行得如意自在。随入诸佛国土大众。大慧。是名如实觉知诸法相意生身。大慧。何者种类生无作行意生身。谓自身内证一切诸法。如实乐相法相乐故。大慧。是名种类生无作行意生身。大慧。汝当于彼三种身相观察了知。尔时世尊重说偈言
我乘非大乘 非说亦非字
非谛非解脱 非无有境界
然乘摩诃衍 三摩提自在
种种意生身 自在华庄严
    尔时圣者大慧菩萨。复白佛言。世尊。如世尊说。善男子善女人行五无间业。世尊。何等是五无间业。而善男子善女人。行五无间入于无间。佛告圣者大慧菩萨言。善哉善哉。善哉大慧。谛听谛听。当为汝说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。五无间者。一者杀母。二者杀父。三者杀阿罗汉。四者破和合僧。五者恶心出佛身血。大慧。何者众生母。谓更受后生贪喜俱生如缘母立。大慧。何者为父。谓无明为父生六入聚落。大慧。断彼二种能生根本。名杀父母。大慧。何者杀阿罗汉。谓诸使如鼠毒发。拔诸使怨根本不生。大慧。是名杀阿罗汉。大慧。何者破和合僧。谓五阴异相和合积聚。究竟断破。名为破僧。大慧。何者恶心出佛身血。谓自相同相见外自心相八种识身。依无漏三解脱门。究竟断八种识佛。名为恶心出佛身血。大慧。是名内身五种无间。若善男子善女人行此无间。得名无间者。无间者名证如实法故
    复次大慧。我为汝等说外五种无间之相。诸菩萨闻是义已。于未来世不生疑心。大慧。何者是外五种无间。谓杀父母罗汉。破和合僧。出佛身血。行此无间者。于彼三种解脱门中。不能得证一一解脱。除依如来力住持。应化声闻菩萨如来神力。为五种罪人忏悔疑心。断此疑心令生善根。为彼罪人作应化说。大慧。若犯五种无间罪者。毕竟不得证入道分。除见自心惟是虚妄。离身资生所依住处分别见我我所相。于无量无边劫中。遇善知识。于异道身离于自心虚妄见过。尔时世尊重说偈言
贪爱名为母 无明则为父
了境识为佛 诸使为罗汉
阴聚名为僧 无间断相续
更无有业间 得真如无间
    尔时圣者大慧菩萨。复白佛言。世尊。惟愿为我说诸如来知觉之相。佛告圣者大慧菩萨摩诃萨言。大慧。如实知人无我法无我。如实能知二种障故。远离二种烦恼。大慧。是名如来如实知觉。大慧。声闻辟支佛得此法者。亦名为佛。大慧。是因缘故我说一乘。尔时世尊重说偈言
善知二无我 二障二烦恼
得不思议变 是名佛知觉
    尔时圣者大慧菩萨。复白佛言。世尊。世尊何故于大众中说如是言。我是过去一切佛。及说种种本生经。我于尔时作顶生王。六牙大象。鹦鹉鸟。毗耶娑仙人。帝释王。善眼菩萨。如是等百千经皆说本生。佛告圣者大慧菩萨摩诃萨言。大慧。依四种平等。如来应正遍知。于大众中唱如是言。我于尔时作拘留孙佛。拘那含牟尼佛。迦叶佛。何等为四。一者字平等。二者语平等。三者法平等。四者身平等。大慧。依此四种平等法故。诸佛如来在于众中说如是言。大慧。何者字平等。谓何等字。过去佛名佛。我同彼字亦名为佛。不过彼字与彼字等无异无别。大慧。是名字平等。大慧。何者诸佛语平等。谓过去佛有六十四种美妙梵声言语说法。我亦六十四种微妙梵声言语说法。大慧。未来诸佛亦以六十四种微妙梵声言语说法。不增不减。不异无差别。迦陵频伽梵声美妙。大慧。是名诸佛语平等。大慧。何者诸佛身平等。大慧。我及诸佛法身色身相好庄严。无异无差别。除依可度众生。彼彼众生种种生处。诸佛如来现种种身。大慧。是名诸佛身平等。大慧。云何诸佛法平等。谓彼佛及我。得三十七菩提分法十力四无畏等。大慧。是名诸佛法平等。大慧。依此四种平等法故。如来于大众中作如是说。我是过去顶生王等。尔时世尊重说偈言
迦叶拘留孙 拘那含是我
说诸佛子等 依四平等故
    大慧菩萨复白佛言。世尊。如来说言。我何等夜证大菩提。何等夜入般涅槃。我于中间不说一字。佛言非言。世尊依何等义说如是语。佛语非语。佛告大慧言。大慧。如来依二种法说如是言。何者为二。我说如是。一者依自身内证法。二者依本住法。我依此二法作如是言。大慧。云何依自身内证法。谓彼过去诸佛如来所证得法。我亦如是证得不增不减。自身内证诸境界行。离言语分别相离二种字故。大慧。何者本住法。大慧。谓本行路平坦。譬如金银真珠等宝在于彼处。大慧。是名法性本住处。大慧。诸佛如来出世不出世。法性法界法住法相法证常住如城本道。大慧。譬如有人行旷野中。见向本城平坦正道即随入城。入彼城已受种种乐作种种业大慧。于意云何。彼人始作是道随入城耶。始作种种诸庄严耶。大慧白佛。不也世尊。大慧。我及过去一切诸佛。法性法界法住法相法证常住亦复如是。大慧。我依此义于大众中作如是说。我何等夜得大菩提。何等夜入般涅槃此二中间不说一字。亦不已说当说现说。尔时世尊重说偈言
我何夜成道 何等夜涅槃
于此二中间 我都无所说
内身证法性 我依如是说
十方佛及我 诸法无差别
    尔时圣者大慧菩萨。复请佛言。惟愿世尊。说一切法有无相。令我及余菩萨大众。得闻是已离有无相。疾得阿耨多罗三藐三菩提。佛告圣者大慧菩萨言。善哉善哉善哉大慧。谛听谛听。当为汝说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。世间人多堕于二见。何等二见。一者见有。二有见无。以见有诸法见无诸法故。非究竟法生究竟想。大慧。云何世间堕于有见谓实有因缘而生诸法非不实有。实有法生非无法生。大慧。世间人如是说者。是名为说无因无缘及谤世间。无因无缘而生诸法。大慧。世间人云何堕于无见。谓说言贪嗔痴。实有贪嗔痴。而复说言无贪嗔痴。分别有无。大慧。若复有人作如是言。无有诸法。以不见诸物相故。大慧。若复有人作如是言。声闻辟支佛。无贪无嗔无痴。复言先有。此二人者。何等人胜何等人不如。大慧菩萨言。若人言先有贪嗔痴后时无。此人不如。佛告大慧。善哉善哉。善哉大慧。汝解我问。大慧。非但言先实有贪嗔痴。后时言无同卫世师等。是故不如。大慧。非但不如灭一切声闻辟支佛法。何以故。大慧。以实无内外诸法故。以非一非异故。以诸烦恼非一非异故。大慧。贪嗔痴法内身不可得。外法中亦不可得。无实体故。故我不许。大慧。我不许者。不许有贪嗔痴。是故彼人灭声闻辟支佛法。何以故。诸佛如来知寂静法。声闻缘觉不见法故。以无能缚所缚因故。大慧。若有能缚必有所缚。若有所缚必有能缚因。大慧。如是说者名灭诸法。大慧。是名无法相。大慧我依此义余经中说。宁起我见如须弥山。而起憍慢。不言诸法是空无也。大慧。增上慢人言诸法无者。是灭诸法。堕自相同相见故。以见自心见法故。以见外物无常故。诸相展转彼彼差别故。以见阴界入相续体。彼彼因展转而生。以自心虚妄分别。是故大慧。如此人者灭诸佛法。尔时世尊重说偈言
有无是二边 以为心境界
离诸境界法 平等心寂静
无取境界法 灭非有非无
如真如本有 彼是圣境界
本无而有生 生已还复灭
非有非无生 彼不住我教
非外道非佛 非我亦非余
从因缘不成 云何得言有
若因缘不生 云何而言无
邪见论生法 妄想计有无
若知无所生 亦知无所灭
观世悉空寂 彼不堕有无
    尔时圣者大慧菩萨。复白佛言。世尊。惟愿如来应正遍知天人师。为我及诸一切菩萨。建立修行正法之相。我及一切菩萨摩诃萨。善知修行正法相已。速得成就阿耨多罗三藐三菩提。不随一切虚妄觉观魔事故。佛告大慧菩萨言。善哉善哉。善哉大慧。谛听谛听。我为汝说。大慧言。善哉世尊。唯然受教。佛告大慧言。大慧。有二种法。诸佛如来菩萨声闻辟支佛。建立修行正法之相。何等为二。一者建立正法相。二者说建立正法相。大慧。何者建立正法相。谓自身内证诸胜法相。离文字语言章句。能取无漏正戒诸证地修行相法。离诸外道虚妄觉观诸魔境界。降伏一切外道诸魔。显示自身内证之法如实修行。大慧。是名建立正法之相。大慧。何者建立说法之相。谓说九部种种教法。离于一异有无取相。先说善巧方便。为令众生入所乐处。谓随众生信彼彼法说彼彼法。大慧。是名建立说法相。大慧。汝及诸菩萨。应当修学如是正法。尔时世尊重说偈言
建立内证法 及说法相名
若能善分别 不随他教相
实无外诸法 如凡夫分别
若诸法虚妄 何故取解脱
观察诸有为 生灭等相续
增长于二见 不能知因缘
涅槃离于识 唯此一法实
观世间虚妄 如幻梦芭蕉
虽有贪嗔痴 而无有作者
从爱生诸阴 有皆如幻梦
    尔时圣者大慧菩萨。复请佛言。世尊。惟愿如来应正遍知。为诸菩萨说不实妄想。何等法中不实妄想。佛告大慧菩萨言。善哉善哉。善哉大慧。汝为安隐一切众生。饶益一切众生。安乐一切众生。哀愍一切世间天人。请我此事。大慧。谛听谛听。当为汝说。大慧言。善哉世尊。唯然受教。佛告大慧。一切众生执着不实虚妄想者。从见种种虚妄法生。以着虚妄能取可取诸境界故。入自心见生虚妄想故。堕于有无二见朋党非法聚中。增长成就外道虚妄异见熏习故。大慧。以取外诸戏论义故。起于虚妄心心数法犹如草束分别我我所法。大慧。以是义故生不实妄想。大慧白佛言。世尊。若诸众生执着不实虚妄想者。从见种种虚妄法生。执着虚妄能取可取一切境界。入自心见生虚妄想。堕于有无二见朋党分别聚中。增长成就外道虚妄异见熏习。以取外诸戏论之义不实妄想。起于虚妄心心数法。犹如草束取我我所者。世尊。如彼彼依外种种境界种种相。堕有堕无朋党相中。离有无见相。世尊。第一义谛亦应如是。远离阿含圣所说法。远离诸根。远离建立三种之法譬喻因相。世尊。云何一处种种分别执着。种种虚妄想生。何故不着第一义谛。虚妄分别而生分别。世尊。世尊如是说法。非平等说无因而说何以故。一处生一处不生故。若世尊如是说者堕二朋党。以见执着虚妄分别而生分别。以世尊说如世幻师。依种种因缘生种种色像。以世尊自心虚妄分别。以世尊言种种虚妄。若有若无不可言说为离分别。如是如来堕世间论。入邪见心朋党聚中。佛告大慧。我分别虚妄不生不灭。何以故。不生有无分别相故。不见一切外有无故。大慧。以见自心如实见故。虚妄分别不生不灭。大慧。我此所说。惟为愚痴凡夫而说自心分别。分别种种随先心生。分别种种有相执着。何以故。若不说者。愚痴凡夫不离自心虚妄觉知。不离执着我我所见。不离因果诸因缘过。如实觉知二种心故。善知一切诸地行相。善知诸佛自身所行内证境界。转五法体见分别相入如来地。大慧。因是事故。我说一切诸众生等。执着不实虚妄生心。自心分别种种诸义。以是义故。一切众生知如实义而得解脱。尔时世尊重说偈言
诸因及与缘 从此生世间
妄想着四句 彼不知我说
世有无不生 离有无不生
云何愚分别 依因缘生法
若能见世间 有无非有无
转于虚妄心 得真无我法
诸法本不生 故依因缘生
诸缘即是果 从果不生有
从果不生果 若尔有二果
若有二果者 果中果难得
离念及所念 观诸有为法
见诸唯心法 故我说唯心
量体及形相 离缘及诸法
究竟有真净 我说如是量
假名世谛我 彼则无实事
诸阴阴假名 假名非实法
有四种平等 相．因．生．无我
如是四平等 是修行者法
转一切诸见 离分别分别
不见及不生 故我说唯心
非有非无法 离有无诸法
如是离心法 故我说惟心
真如空实际 涅槃及法界
意身身心等 故我说唯心
分别依熏缚 心依诸境生
众生见外境 故我说唯心
可见外法无 心尽见如是
身资生住处 故我说唯心
    尔时圣者大慧菩萨。复白佛言。世尊。如来说言。如我所说。汝及诸菩萨。莫着音声言语之义。世尊。云何菩萨不着言语之义。世尊。何者为言语。何者为义。佛告圣者大慧菩萨言。善哉善哉。善哉大慧。当为汝说。大慧言。善哉世尊。唯然受教。佛告大慧。何者为声。谓依无始熏习言语名字和合分别。因于喉鼻齿颊唇舌和合动转。出彼言语分别诸法。是名为声。大慧。何者为义。菩萨摩诃萨依闻思修圣智慧力。于空闲处独坐思惟。云何涅槃趣涅槃道。观察内身修行境界。地地处处修行胜相。转彼无始熏习之因。大慧。是名菩萨善解义相。复次大慧。云何菩萨摩诃萨。善解言语义。大慧。菩萨见言语声义不一不异。见义言语声不一不异。大慧。若言言语离于义者。不应因彼言语声故而有于义。而义依彼言语了别。大慧。如依于灯了别众色。大慧。譬如有人然灯观察种种珍宝。此处如是如是。彼处如是如是。大慧。菩萨依言语声证离言语。入自内身修行义故。复次大慧。一切诸法不生不灭。自性本来入于涅槃。三乘一乘五法心诸法体等同。言语声义依众缘取相。堕有无见谛于诸法。见诸法体各住异相分别异相。如是分别已。见种种法相如幻。见种种分别。大慧。譬如幻种种异异分别。非谓圣人是凡夫见。尔时世尊重说偈言
分别言语声 建立于诸法
以彼建立故 故堕于恶道
五阴中无我 我中无五阴
不如彼妄相 亦复非是无
凡夫妄分别 见诸法实有
若如彼所见 一切应见真
一切法若无 染净亦应无
彼见无如是 亦非无所有
    复次大慧。我今为汝说智识相。汝及诸菩萨摩诃萨。应善知彼智识之相如实修行智识相故。疾得阿耨多罗三藐三菩提。大慧。有三种智。何等为三。一者世间智。二者出世间智。三者出世间上上智。大慧。识者生灭相。智者不生灭相。复次大慧。识者堕于有相无相。堕彼有无种种相因。大慧。智相者远离有相无相有无因相。名为智相。复次大慧。集诸法者名为识相。不集诸法名为智相。大慧。智有三种。何等为三。一者观察自相同相。二者观察生相灭相。三者观察不生不灭相。大慧。何者世间智。诸外道凡夫人等。执着一切诸法有无。是名世间智相。大慧。何者出世间智。谓诸一切声闻缘觉。虚妄分别自相同相。是名出世间智。大慧。何者出世间上上智。谓佛如来菩萨摩诃萨。观察一切诸法寂静不生不灭。得如来地无我证法。离彼有无朋党二见。复次大慧。所言智者无障碍相。识者识彼诸境界相。复次大慧。识者和合起作所作名为识相。无碍法相应名为智相。复次大慧。无所得相名之为智。以自内身证得圣智修行境界故。出入诸法如水中月。是名智相。尔时世尊重说偈言
识能集诸业 智能了分别
慧能得无相 及妙庄严境
识为境界缚 智能了诸境
无相及胜境 是慧所住处
心意及意识 远离于诸相
声闻分别法 非是诸弟子
寂静胜进忍 如来清净智
生于善胜智 远离诸所行
我有三种慧 依彼得圣名
于彼想分别 能闻于有无
离于二乘行 慧离于境界
取于有无想 从诸声闻生
能入唯是心 智慧无垢相
    复次大慧。诸外道有九种转变见。何等为九。一者形相转变。二者相转变。三者因转变。四者相应转变。五者见转变。六者物转变。七者缘了别转变。八者作法了别转变。九者生转变。大慧。是名九种转变见。依九种转变见故。一切外道说于转变从有无生。大慧。何者外道形相转变。大慧。譬如以金作庄严具。镮钏璎珞种种各异。形相虽殊金体不变。一切外道分别诸法形相转变亦复如是。大慧。复有外道分别诸法依因转变。大慧。而彼诸法亦非如是非不如是。以依分别故。大慧。如是一切转变亦尔。应知譬如乳酪酒果等熟一一转变。一切外道分别转变亦复如是。而无实法可以转变。以自心见有无可取。分别有无故。大慧。一切凡夫亦复如是。以依自心分别。而生一切诸法。大慧。无有法生无有法转。如幻梦中见诸色事。大慧。譬如梦中见一切事石女儿生死。尔时世尊重说偈言
转变时形相 四大种诸根
中阴及诸取 如是取非智
因缘生世间 佛不如是说
因缘即世间 如乾闼婆城
    尔时大慧菩萨摩诃萨。复白佛言。世尊。惟愿如来应正遍知。善说一切诸法相续不相续相。惟愿善逝说一切法相续不相续相。我及一切诸菩萨众。善解诸法相续不相续相。善巧方便知已。不堕执着诸法相续不相续相。离一切法相续不相续言说文字妄想已。得力自在神通游化十方一切诸佛国土大众之中。陀罗尼门善印所印。十尽句善转所转。种种变化光明照曜。譬如四大日月摩尼自然而行。众生受用远离诸地惟自心见分别之相。示一切法如幻如梦。示入依止诸佛之地。于众生界随其所应而为说法。摄取令住一切诸法如幻如梦。离于有无一切朋党。生灭妄想异言说义。转身自在往胜处生
    佛告圣者大慧菩萨言。善哉善哉。善哉大慧。谛听谛听。当为汝说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。一切诸法相续不相续相者。谓如声闻执着义相续。相执着相续缘执着相续。有无执着相续。分别生不生执着相续。分别灭不灭执着相续。分别乘非乘执着相续。分别有为无为执着相续。分别地地相执着相续。分别自分别执着相续。分别有无入外道朋党执着相续。大慧。如是愚痴凡夫。无量异心分别相续依此相续愚痴分别如蚕作茧。依自心见分别綖相续。乐于和合自缠缠他。执著有无和合相续。大慧然无相续无相续相。以见诸法寂静故大慧。以诸菩萨见一切法无分别相。是故名见一切菩萨寂静法门。复次大慧。如实能知外一切法离于有无。如实觉知自心见相。以入无相自心相故。大慧。以见分别有无法故。名为相续。以见诸法寂静故。名无相续。无相续相。无相续诸法相。大慧。无缚无脱。堕于二见。自心分别有缚有脱。何以故。以不能知诸法有无故。复次大慧。愚痴凡夫有三种相续。何等为三。谓贪嗔痴及爱乐生。以此相续故有后生。大慧。相续者众生相续生于五道。大慧。断相续者无相续无相续相。复次大慧。执着因缘相续故生于三有。以诸识展转相续不断。见三解脱门。转灭执着三有因识。名断相续。尔时世尊重说偈言
不实妄分别 名为相续相
能如实知彼 相续网则断
若取声为实 如蚕茧自缠
自心妄想缚 凡夫不能知
    大慧菩萨复白佛言。如世尊说。以何等何等分别心。分别何等何等法。而彼彼法无彼如是如是体相。惟自心分别。世尊。若惟自心分别非彼法相者。如世尊说。一切诸法应无染净。何以故。如来说言。一切诸法妄分别见无实体故。佛告大慧。如是如是如汝所说。大慧。而诸一切愚痴凡夫分别诸法。而彼诸法无如是相。虚妄分别以为实有。大慧。彼是凡夫虚妄分别诸法体相。虚妄觉知非如实见。大慧。如圣人知一切诸法自体性相。依圣人智。依圣人见。依圣慧眼。如如实知诸法自体。大慧菩萨言。世尊。世尊如诸圣人等。依圣智依圣见依圣慧眼。非肉眼天眼。觉知一切诸法体相无如是相。非如凡夫虚妄分别。世尊。云何愚痴凡夫转虚妄相。佛告大慧。能如实觉知圣人境界转虚妄识。世尊。彼痴凡夫非颠倒见。非不颠倒见。何以故。以不能见圣人境界如实法体故。以见转变有无相故。大慧白佛言。世尊。一切圣人亦有分别。一切种种诸事无如是相。以自心见境界相故。世尊。彼诸圣人见有法体分别法相。以世尊不说有因不说无因。何以故。以堕有法相故。余人见境不如是见。世尊。如是说者有无穷过。何以故。以不觉知所有法相无自体相故。世尊。非因分别有法体相而有诸法。世尊。彼云何分别。不如彼分别。应如彼分别。世尊。分别相异相。自体相异相。世尊。而彼二种因不相似。彼彼分别法体相异。云何凡夫如此分别。此因不成如彼所见。世尊说言。我为断诸一切众生虚妄分别心故。作如是说如彼凡夫虚妄分别无如是法。世尊。何故遮诸众生有无见事。而执着实法圣智境界。世尊。复令一切众生堕无见处。何以故。以言诸法寂静无相。圣智法体如是无相故。佛告大慧。我不说言一切诸法寂静无相。亦不说言诸法悉无。亦不令其堕于无见。亦令不着一切圣人境界如是。何以故。我为众生离惊怖处故。以诸众生无始世来。执着实有诸法体相。是故我说圣人知法体相实有。复说诸法寂静无相。大慧。我不说言法体有无。我说自身如实证法。以闻我法修行寂静诸法无相得见真如无相境界。入自心见法。远离见外诸法有无。得三解脱门。得已以如实印善印诸法。自身内证智慧观察离有无见。复次大慧。菩萨不应建立诸法不生。何以故。以建立法同诸法有。若不尔者同诸法无。复次大慧。因建立诸法有故说一切法。于建立法中同。何以故。以彼建立不同一切法不生。是故建立说一切法。是言自破。何以故。以建立中无彼建立。若不尔者。彼建立亦不生。以同诸法无差别相故。是故建立诸法不生。名为自破。以彼建立三法五法和合有故。离于建立有无不生。大慧。彼建立入诸法中。不见有无法故。大慧。若彼建立诸法不生。而作是言。一切法不生。大慧。如是说者建立则破。何以故离于建立。有无相不可得故。大慧。是故不应建立诸法不生。大慧。以彼建立同彼一切不生法体。是故不应建立诸法不生。以有多过故。大慧。复有不应建立诸法不生何以故。以三法五法彼彼因不同故。大慧。复有不应建立诸法不生。何以故。以彼三法五法。作有为无常故。是故不应建立一切诸法不生。大慧。如是不应建立一切法空。一切诸法无实体相。大慧。而诸菩萨为众生说一切诸法如幻如梦。以见不见相故。以诸法相迷惑见智故。是故应说如幻如梦。除遮一切愚痴。凡夫离惊怖处。大慧。以诸凡夫堕在有无邪见中故。以凡夫闻如幻如梦生惊怖故。诸凡夫闻生惊怖已远离大乘。尔时世尊重说偈言
无自体无识 无阿梨耶识
愚痴妄分别 邪见如死尸
一切法不生 余见说不成
诸法毕不生 因缘不能成
一切法不生 莫建如是法
同不同不成 是故建立坏
譬如目有瞖 虚妄见毛轮
分别于有无 凡夫虚妄见
三有惟假名 无有实法体
执假名为实 凡夫起分别
相事及假名 心意所受用
佛子能远离 住寂境界行
无水取水相 诸兽痴妄心
凡夫见法尔 圣人则不然
圣人见清净 三脱三昧生
远离于生灭 得无障寂静
修行无所有 亦复不见无
有无法平等 是故生圣果
有无法云何 云何成平等
以心不能见 内外法无常
若能灭彼法 见心成平等
    尔时圣者大慧菩萨白佛言。世尊。如世尊说。智慧观察不能见前境界诸法。尔时善知惟是内心。心意意识如实觉知。无法可取亦无能取。是故智亦不能分别而取。世尊。若言智慧不能取者。为见诸法自相同相。异异法相种种异法体不同故。智不能知。为见诸法种种体相不可异故。智不能知。为是山岩石壁墙幕树林草木。地水火风之所障故。智不能知。为是极远极近处故。智不能知。为是老小。为是盲冥诸根不具。智不能知。世尊。若一切法异异。法相异异。法体自相同相。种种不同故。智不能知者。世尊。若尔彼智非智。何以故。不能知前实境界故。世尊。若一切法种种体相。自相同相不见异故。智不能知者。若尔彼智不得言智。何以故。实有境界不能知故。世尊。有前境界如实能见。名之为智。若为山岩石壁墙幕树林草木。地水火风极远极近。老小盲冥诸根水具。不能知见者。彼智无智。有实境界而不知故。佛告大慧。如汝所说言无智者。是义不然。何以故。有实智故。大慧。我不依汝如是之说。境界是无惟自心见。我说不觉惟是自心。见诸外物以为有无。是故智慧不见境界。智不见者不行于心。是故我说。入三解脱门智亦不见。而诸凡夫无始世来虚妄分别。依戏论熏习熏彼心故。如是分别。见外境界形相有无。为离如是虚妄心故。说一切法惟自心见。执着我我所故不能觉知但是自心。虚妄分别是智是境界。分别是智是境界故。观察外法不见有无堕于断见。尔时世尊重说偈言
有诸境界事 智慧不能见
彼无智非智 虚妄见者说
言诸法无量 是智不能知
障碍及远近 是妄智非智
老小诸根冥 不能生智慧
而实有境界 彼智非实智
    复次大慧。愚痴凡夫。依无始身戏论烦恼分别烦恼。幻舞之身建立自法。执着自心见外境界。执著名字章句言说。而不能知建立正法。不修正行。离四种句清净之法。大慧菩萨言。如是如是。如是世尊。如世尊说。世尊为我说所说法建立法相。我及一切诸菩萨等。于未来世善知建立说法之相。不迷外道邪见声闻辟支佛不正见法。佛告大慧菩萨言。善哉善哉。善哉大慧。谛听谛听我为汝说。大慧言。善哉世尊。唯然受教。佛告大慧。有二种过去未来现在如来应正遍知所说法。何等为二。一者建立说法相。二者建立如实法相。大慧。何者建立说法相。谓种种功德。修多罗优波提舍。随众生信心而为说法。大慧。是名建立说法相。大慧。何者建立如实法相。谓依何等法而修正行。远离自心虚妄分别诸法相故。不堕一异俱不俱朋党聚中。离心意意识。内证圣智所行境界。离诸因缘相应见相。离一切外道邪见。离诸一切声闻辟支佛见。离于有无二朋党见。大慧。是名建立如实法相。大慧。汝及诸菩萨摩诃萨应当修学。尔时世尊重说偈言
我建立二法 说法如实法
依名字说法 为实修行者

    入楞伽经卷第五

    入楞伽经卷第六
    元魏天竺三藏菩提留支译
    卢迦耶陀品第五
    尔时圣者大慧菩萨复白佛言。世尊。如来应正遍知一时说言。卢迦耶陀种种辩说。若有亲近供养彼人。摄受欲食不摄法食。世尊。何故说言卢迦耶陀种种辩说。亲近供养摄受欲食不摄法食。佛告大慧。卢迦耶陀种种辩才。巧妙辞句迷惑世间。不依如法说不依如义说。但随世间愚痴凡夫情所乐故说世俗事。但有巧辞言章美妙失于正义。大慧。是名卢迦耶陀种种辩才乐说之过。大慧。卢迦耶陀如是辩才。但摄世间愚痴凡夫。非入如实法相说法。自不觉知一切法故。堕于二边邪见聚中。自失正道亦令他失。是故不能离于诸趣。以不能见唯是自心。分别执着外法有相。是故不离虚妄分别。大慧。是故我说卢迦耶陀。虽有种种巧妙辩才乐说诸法。失正理故不得出离生老病死忧悲苦恼一切苦聚。以依种种名字章句。譬喻巧说迷诳人故。大慧。释提桓因广解诸论自造声论。彼卢迦耶陀有一弟子证世间通。诣帝释天宫建立论法而作是言。憍尸迦。我共汝赌与汝论义。若不如者要受屈伏。令诸一切天人知见即共立要。我若胜汝要当打汝千辐轮碎。我若不如从头至足节节分解以谢于汝。作是要已。卢迦耶陀弟子现作龙身。共释提桓因论义。以其论法即能胜彼。释提桓因令其屈伏。即于天中打千辐轮车碎如微尘即下人间。大慧。卢迦耶陀婆罗门。如是种种譬喻相应。乃至现畜生身依种种名字。迷惑世间天人阿修罗。以诸世间一切众生执着生灭法故。何况于人。大慧。以是义故。应当远离卢迦耶陀婆罗门。以因彼说能生苦聚故。是故不应亲近供养恭敬咨请卢迦耶陀婆罗门。大慧。卢迦耶陀婆罗门所说之法。但见现前身智境界。依世名字说诸邪法。大慧。卢迦耶陀婆罗门所造之论有百千偈。后世末世分为多部各各异名。依自心见因所造故。大慧。卢迦耶陀婆罗门无有弟子能受其论。是故后世分为多部种种异名。大慧。诸外道等内心无有如实解故。依种种因种种异解。随自心造而为人说。执着自在因等故。大慧。一切外道所造论中无如是法。惟是一切卢迦耶陀。种种因门说百千万法。而彼不知是卢迦耶陀。大慧菩萨白佛言。世尊。若一切外道惟说卢迦耶陀。依于世间种种名字章句譬喻执着诸因者。世尊。十方一切国土众生天人阿修罗集如来所。如来亦以世间种种名字章句譬喻说法。不说自身内智证法。若尔亦同一切外道所说不异。佛告大慧。我不说于卢迦耶陀。亦不说言诸法不来不去。大慧。我说诸法不来不去。大慧。何者名来。大慧。所言来者名为生聚。以和合生故。大慧。何者名去。大慧。所言去者名之为灭。大慧。我说不去不来名为不生不灭。大慧。我说不同彼外道法。何以故。以不执着外物有无故。建立说于自心见故。不住二处不行分别诸相境界故。以如实知自心见故。不生自心分别见故。以不分别一切相者。而能入空无相无愿三解脱门名为解脱。大慧。我念过去于一处住。尔时有一卢迦耶陀大婆罗门。来诣我所而请我言。瞿昙。一切作耶。大慧。我时答言。婆罗门。一切作者此是第一卢迦耶陀。婆罗门言。瞿昙。一切不作耶。我时答言。婆罗门。一切不作者是第二卢迦耶陀。如是一切常一切无常。一切生一切不生。我时答言。婆罗门。是第六卢迦耶陀。大慧。卢迦耶陀复问我言。瞿昙。一切一耶一切异耶。一切俱耶一切不俱耶。一切诸法依于因生。见种种因生故。大慧。我时答言。婆罗门。是第十一卢迦耶陀。大慧。彼复问我。瞿昙。一切无记耶一切有记耶。有我耶无我耶。有此世耶无此世耶。有后世耶无后世耶。有解脱耶无解脱耶。一切空耶一切不空耶。一切虚空耶。非缘灭耶。涅槃耶。瞿昙。作耶非作耶。有中阴耶无中阴耶大慧。我时答言。婆罗门。如是说者。一切皆是卢迦耶陀。非我所说是汝说法。婆罗门。我说因无始戏论虚妄分别烦恼熏习故说彼三有。以不觉知唯是自心分别见有。非见外有如外道法。大慧。外道说言。我根意义三种和合能生于知。婆罗门。我不如是。我不说因亦不说无因。唯说自心分别见有可取能取境界之相。我说假名因缘集故而生诸法。非汝婆罗门及余境界。以堕我见故。大慧。涅槃虚空缘灭不成三数。何况言作有作不作。大慧。复有卢迦耶陀婆罗门来问我言。瞿昙。此诸世间无明爱业因故生三有耶无因耶。我时答言。婆罗门。此二法卢迦耶陀。非我法耶。婆罗门复问我言。瞿昙。一切法堕自相耶同相耶。我时答言。婆罗门。此是卢迦耶陀。非我法耶。婆罗门。但有心意意识执着外物。皆是卢迦耶陀。非我法耶。大慧。卢迦耶陀婆罗门。复问我言。瞿昙。颇有法非卢迦耶陀耶。瞿昙。一切外道建立种种名字章句因譬喻说者皆是我法。我时答言。婆罗门。有法非汝法。非不建立。亦非不说种种名字章句。亦非不依义依义说。而非卢迦耶陀建立法。婆罗门。有法非卢迦耶陀。以彼诸法一切外道乃至于汝不能了知。以妄执着外不实法分别戏论故。何者是谓远离分别。心观察有无自心见相如实觉知。是故不生一切分别。不取外诸境界法故。分别心息住自住处寂静境界。是名非卢迦耶陀。是我论法非汝论耶。婆罗门。住自住处者不生不灭故。不生不灭者不生分别心故。婆罗门。是名非卢迦耶陀。婆罗门。略说言之。以何等处识不行不取不退。不求不生不执着不乐。不见不睹不住不触。是名为住。名异义一。婆罗门。执着种种相。自我和合爱着诸因。是婆罗门卢迦耶陀法。非我法耶。大慧。卢迦耶陀婆罗门。来诣我所问如是法。我时答彼婆罗门。如向所说。时婆罗门默然而去。而不问我建立真法。时卢迦耶陀婆罗门心作是念。此沙门释子外于我法是可怜愍。说一切法无因无缘无有生相。惟说自心分别见法。若能觉知自心见相。则分别心灭。大慧。汝今问我。何故卢迦耶陀种种辩说。亲近供养恭敬彼人但摄欲味不摄法味。大慧白佛言。世尊。何者名食句义。何者名法句义。佛告大慧。善哉善哉。善哉大慧。汝能为于未来众生。咨问如来如是二义。善哉大慧。谛听谛听我为汝说。大慧白佛言。善哉世尊。唯然受故。佛告大慧。何者为食。谓食味触味。乐求方便巧谄着味执着外境。如是等法名异义一。以不能入无二境界法门义故。复次大慧。名为食者。依于邪见生阴有支。不离生老病死忧悲苦恼。爱生于有。如是等法名之为食。是故我及一切诸佛。说彼亲近供养卢迦耶陀婆罗门者。名得食味不得法味。大慧。何者为法味。谓如实能知二种无我。以见人无我法无我相。是故不生分别之相。如实能知诸地上上智故。尔时能离心意意识。入诸佛智受位之地。摄取一切诸句尽处。如实能知一切诸佛自在之处。名为法味。不堕一切邪见戏论分别二边。大慧。外道说法多令众生堕于二边。不令智者堕于二边。何以故。大慧。诸外道等多说断常。以无因故堕于常见。见因灭故堕于断见。大慧。我说如实见不着生灭。是故我说名为法味。大慧。是名我说食味法味。大慧。汝及诸菩萨摩诃萨当学此法。尔时世尊重说偈言
我摄取众生 依戒降诸恶
智慧灭邪见 三解脱增长
外道虚妄说 皆是世俗论
以邪见因果 无正见立论
我立建立法 离虚妄因见
为诸弟子说 离于世俗法
惟心无外法 以无二边心
能取可取法 离于断常见
但心所行处 皆是世俗论
若能观自心 不见诸虚妄
来者见因生 去者见果灭
如实知去来 不分别虚妄
常无常及作 不作彼此物
如是等诸法 皆是世俗论

    入楞伽经涅槃品第六
    尔时圣者大慧菩萨白佛言。世尊。如佛所言涅槃。涅槃者以何等法名为涅槃。而诸外道各各虚妄分别涅槃。佛告大慧菩萨言。善哉善哉。善哉大慧。谛听谛听当为汝说。诸外道等虚妄分别涅槃之相。如彼外道所分别者无是涅槃。大慧白佛言。善哉世尊。唯然受教。佛告大慧。有诸外道厌诸境界。见阴界入灭诸法无常心心数法不生。现前以不忆念过去未来现乐境界。诸阴尽处如灯火灭种种风止。不取诸相妄想分别。名为涅槃。大慧。而彼外道见如是法生涅槃心。非见灭故名为涅槃。大慧。或有外道从方至方名为涅槃。大慧。复有外道。分别诸境如风。是故分别名为涅槃。大慧。复有外道作如是说。不见能见所见境界不灭名为涅槃。复次大慧。复有外道作如是说。不见分别见常无常名为涅槃。复次大慧。复有外道作如是言。分别见诸种种异相能生诸苦。以自心见虚妄分别一切诸相怖畏诸相。见于无相深心爱乐生涅槃想。复次大慧。复有外道。见一切法自相同相不生灭想。分别过去未来现在诸法是有名为涅槃。复次大慧。复有外道。见我人众生寿命寿者诸法不灭。虚妄分别名为涅槃。复次大慧。有余外道。无智慧故分别所见自性。人命转变分别转变名为涅槃。复次大慧。有余外道说如是言。罪尽故福德亦尽名为涅槃。复次大慧。有余外道言。烦恼尽依智故名为涅槃。复次大慧。有余外道说如是言。见自在天造作众生。虚妄分别名为涅槃。复次大慧。有余外道言。诸众生迭共因生非余因作。如彼外道执着于因不知不觉。愚痴闇钝虚妄分别名为涅槃。复次大慧。有余外道说证谛道虚妄分别名为涅槃。复次大慧。有余外道作如是言。有作所作而共和合见一异俱不俱。虚妄分别名为涅槃。复次大慧。有余外道言。一切法自然而生。犹如幻师出种种形像。见种种宝棘刺等物自然而生。虚妄分别名为涅槃。复次大慧。有余外道言。诸万物皆是时作。觉知唯时。虚妄分别名为涅槃。复次大慧。有余外道言。见有物见无物见有无物。如是分别名为涅槃。复次大慧。余建立法智者说言。如实见者唯是自心。而不取着外诸境界离四种法。见一切法如彼彼法住。不见自心分别之相。不堕二边不见能取可取境界。见世间建立一切不实迷如实法。以不取诸法名之为实。以自内身证圣智法。如实而知二种无我。离于二种诸烦恼垢。清净二障如实能知上上地相。入如来地得如幻三昧。远离心意意识分别如是等见。名为涅槃。大慧。复有诸外道等。邪见觉观而说诸论。不与如实正法相应。而诸智者远离诃啧。大慧。如是等外道。皆堕二边虚妄分别。无实涅槃。大慧。一切外道如是虚妄分别涅槃。无人住世间无人入涅槃。何以故。一切外道依自心论虚妄分别无如实智。如彼外道自心分别无如是法。去来摇动无有如是外道涅槃。大慧。汝及一切诸菩萨等。应当远离一切外道虚妄涅槃。尔时世尊重说偈言
外道涅槃见 各各起分别
皆从心相生 无解脱方便
不离缚所缚 远离诸方便
自生解脱想 而实无解脱
外道建立法 众智各异取
彼悉无解脱 愚痴妄分别
一切痴外道 妄见作所作
是故无解脱 以说有无法
凡夫乐戏论 不闻真实慧
言语三界本 如实智灭苦
譬如镜中像 虽见而非有
熏习镜心见 凡夫言有二
不知唯心见 是故分别二
如实知但心 分别则不生
心名为种种 离能见可见
见相无可见 凡夫妄分别
三有惟妄想 外境界实无
妄想见种种 凡夫不能知
经经说分别 种种异名字
离于言语法 不说不可得

    入楞伽经法身品第七
    尔时圣者大慧菩萨白佛言。世尊。如来应正遍知。惟愿演说自身所证内觉知法。以何等法名为法身。我及一切诸菩萨等。善知如来法身之相。自身及他俱入无疑。佛告大慧菩萨言。善哉善哉。善哉大慧。汝有所疑随意所问为汝分别。大慧白佛言。善哉世尊。唯然受教。即白佛言。世尊。如来应正遍知。法身者为作法耶非作法耶。为是因耶为是果耶。为能见耶为所见耶。为是说耶为可说耶。为是智耶智所觉耶。如是等辞句。如来法身为异耶为不异耶。佛告大慧。如来应正遍知法身之相。如是辞句等。非作法非不作法非因非果。何以故。以二边有过故。大慧。若言如来是作法者是则无常。若无常者一切作法应是如来。而佛如来应正遍知不许此法。大慧。若如来法身非作法者则是无身。言有修行无量功德一切行者则是虚妄。大慧。若不作者应同兔角石女儿等。以无作因亦无身故。大慧。若法非因非果非有非无。而彼法体离四种相。大慧。彼四种法名世间言说。大慧。若法离于四种法者。彼法但有名字如石女儿。大慧。石女儿等惟是名字章句之法说同四法。若堕四法者则智者不取。如是一切问如来句。智者应知。佛复告大慧。我说一切诸法无我。汝当谛听无我之义。夫无我者。内身无我是故无我。大慧。一切诸法自身为有他身为无。如似牛马。大慧。譬如牛身非是马身。马亦非牛。是故不得言有言无。而彼自体非是无耶。大慧。一切诸法亦复如是。非无体相有自体相。愚痴凡夫不知诸法无我体相。以分别心非不分别心。大慧。如是一切法空一切法不生。一切法无体相亦尔。大慧。如来法身亦复如是。于五阴中非一非异。大慧。如来法身五阴一者。则是无常。以五阴是所作法故。大慧。如来法身五阴异者。则有二法。不同体相。如牛二角相似不异。见有别体长短似异。大慧。若如是一切诸法应无异相而有异相。如牛左角异右角右角异左角。如是长短相待各别。如色种种彼此差别。大慧。如是如来法身之相。于五阴中不可说一不可说异。于解脱中不可说一不可说异。于涅槃中不可说一不可说异。如是依解脱故。说名如来法身之相。大慧。若如来法身异解脱者。则同色相则是无常。若如来法身不异解脱者。则无能证所证差别。大慧。而修行者则见能证及于所证。是故非一。大慧。如是知于可知境界非一非异。大慧。若法非常非无常。非因非果。非有为非无为。非觉非不觉。非能见非可见。非离阴界入非即阴界入。非名非境界。非一非异。非俱非不俱。非相续非不相续。过一切诸法。若过诸法但有其名。若但有名彼法不生。以不生故彼法不灭。以不灭故彼法则如虚空平等。大慧。虚空非因非果。若法非因非果者。彼法则为不可观察。不可观察者。彼法过诸一切戏论。若过一切诸戏论者。名如来法身。大慧。是名如来应正遍知法身之相。以过一切诸根境界故。尔时世尊重说偈言
离诸法及根 非果亦非因
已离觉所觉 离能见可见
诸缘及五阴 佛无有见法
若无有见法 云何而分别
非作非不作 非因亦非果
非阴非离阴 亦不在余处
何等心分别 分别不能见
彼法非是无 诸法法自尔
先有故言无 先无故言有
是故不说无 亦不得说有
迷于我无我 但着于音声
彼堕于二边 妄说坏世间
离诸一切过 则能见我法
是名为正见 不谤于诸佛
    尔时圣者大慧菩萨复白佛言。世尊。惟愿世尊为我解说。惟愿善逝为我解说。如来处处说言诸法不生不灭。世尊。复言。不生不灭者。名如来法身。故言不生不灭。世尊。如来言。不生不灭者。为是无法故名不生不灭。为是如来异名不生不灭。而佛如来常说。诸法不生不灭。以离建立有无法故。世尊。若一切法不生者。此不得言一切法。以一切法不生故。若依余法有此名者。世尊应为我说
    佛告大慧菩萨言。善哉善哉。善哉大慧。谛听谛听当为汝说。大慧菩萨白佛言。善哉世尊。唯然受教。佛告大慧。如来法身非是无物。亦非一切法不生不灭。亦不得言依因缘有。亦非虚妄说不生不灭。大慧。我常说言不生不灭者名意生身。如来法身非诸外道声闻辟支佛境界故。住七地菩萨亦非境界。大慧。我言不生不灭者。即如来异名。大慧。譬如释提桓因．帝释．王．不兰陀罗。手爪．身体．地．浮弥．虚空．无碍。如是等种种名号名异义一。不依多名言有多体帝释等耶。大慧。我亦如是。于娑婆世界中。三阿僧祇百千名号。凡夫虽说而不知是如来异名。大慧。或有众生知如来者。有知自在者。有知一切智者。有知救世间者。有知为导者。有知为将者。有知为胜者。有知为妙者。有知世尊者。有知佛者。有知牛王者。有知师子者。有知仙人者。有知梵者。有知那罗延者。有知胜者。有知迦毗罗者。有知究竟者。有知阿利吒尼弥者。有知月者。有知日者。有知婆楼那者。有知毗耶娑者。有知帝释者。有知力者。有知海者。有知不生者。有知不灭者。有知空者。有知真如者。有知实际者。有知涅槃者。有知法界者。有知法性者。有知常者。有知平等者。有知不二者。有知无相者。有知缘者。有知佛体者。有知因者。有知解脱者。有知道者。有知实谛者。有知一切智者。有知意生身者。大慧。如是等种种名号如来应正遍知。于娑婆世界及余世界中。三阿僧祇百千名号不增不减众生皆知。如水中月不入不出。而诸凡夫不觉不知。以堕二边相续法中。然悉恭敬供养于我。而不善解名字句义。取差别相不能自知。执著名字故虚妄分别。不生不灭名为无法。而不知是如来名号差别之相。如因陀罗帝释王不兰陀罗等。以不能决定名与真实。随顺名字音声取法亦复如是。大慧。于未来世愚痴凡夫说如是言。如名义亦如是。而不能知异名有义。何以故。以义无体相故。复作是言不异名字音声有义。名字音声即是义。何以故。不知名字体相故。大慧。彼愚痴人不知音声即生即灭义不生灭故。大慧。音声之性堕于名字。而义不同堕于名字。以离有无故。无生无体故。大慧。如来说法依自声说。不见诸字是有无故不著名字。大慧。若人执著名字说者。彼人不名善说法者。何以故。法无名字故。大慧。是故我经中说。诸佛如来乃至不说一字不示一名。何以故。诸法无字依义无说。依分别说故。大慧。若不说法者。诸佛如来法轮断灭。法轮灭者。亦无声闻缘觉菩萨。无声闻缘觉菩萨者。为何等人何等法何事说。大慧。是故菩萨摩诃萨。不应着于言说名字。大慧。名字章句非定法故。依众生心说。诸佛如来随众生信而说诸法。为令远离心意意识故。不说自身内证圣智建立诸法。如实能知一切诸法寂静相故。但见自心觉所知法。离二种心分别之相。不如是说。大慧。菩萨摩诃萨。依义不依语。若善男子善女人。随文字说者堕在邪见。自身失坏第一义谛。亦坏他人令不觉知。大慧。诸外道等各依自论异见言说。大慧。汝应善知一切地相。善知乐说辩才文辞章句。善知一切诸地相已。进取名句乐说辩才。善知诸法义相应相。尔时自身于无相法乐而受乐受。住大乘中令众生知。大慧。取大乘者。即是摄受诸佛声闻缘觉菩萨。摄受诸佛声闻缘觉及菩萨者。即是摄受一切众生。摄受一切诸众生者。即是摄受胜妙法藏。摄受法藏者。即不断佛种。不断佛种者。不断一切胜妙生处。以彼胜处诸菩萨等愿生彼故。置诸众生大乘法中。十自在力。随诸众生形色诸使。而能随现说如实法。大慧。何者如实法。如实法者。不异不差。不取不舍。离诸戏论名如实法。大慧。善男子善女人。不得执著文字音声。以一切法无文字故。大慧。譬如有人为示人物以指指示。而彼愚人即执着指。不取因指所示之物。大慧。愚痴凡夫亦复如是。闻声执著名字指故。乃至没命终不能舍文字之指取第一义。大慧。譬如谷粟名凡夫食。不舂不吹不可得食。若其有人未作食者名为颠狂。要须次第乃至吹熟方得成食。大慧。不生不灭亦复如是。不修巧智方便行者。不得具足庄严法身。大慧。执著名字言得义者。如彼痴人不知舂吹。啖文字谷不得义食。以是义故当学于义。莫著文字。大慧。所言义者名为涅槃。言名字者分别相缚生世间解。大慧。义者从于多闻人得。大慧。言多闻者谓义巧方便。非声巧方便。大慧。义方便者离于一切外道邪说亦不和杂。如是说者。自身不堕外道邪法。亦不令他堕外道法。大慧。是名多闻有义方便。大慧。欲得义者应当亲近多闻智者供养恭敬。著名字者应当远离不应亲近。尔时大慧菩萨承诸佛力白佛言。世尊。如来世尊说一切法不生不灭非为奇特。何以故。一切外道亦说诸因不生不灭。如来亦说虚空．非数缘灭。及涅槃界不生不灭。世尊。诸外道亦说依诸因缘生诸众生。如来亦说无明爱业分别因缘生诸世间。若尔如来亦说因缘名字相异。依外因缘能生诸法。外道亦说依外因缘而生诸法。是故如来与外道说无有差别。世尊。外道因微尘．胜．自在天．梵天等。共外九种因缘。说言诸法不生不灭。如来亦说。一切诸法不生不灭。有无不可得。以诸四大不灭。自相不生不灭。随佛如来种种异说。而不离于外道所说。而诸外道亦说诸大不离大体。世尊。诸外道分别诸大。如来亦尔分别诸大。世尊。以是义故。如来所说不异外道。若不同者如来应说所有异相。若有异相当知不同外道所说。世尊。若佛如来于自法中不说胜相者。诸外道中亦应有佛。以说诸法不生不灭。如来常说一世界中而有多佛俱出世者。无有是处。如向所说一世界中应有多佛。何以故。所说有无因无差故。如佛所说言无虚谬。云何世尊于自法中不说胜相。佛告大慧言。大慧。我所说法不生不灭者。不同外道不生不灭。亦不同彼不生无常法。何以故。大慧。诸外道说有实有体性不生不变相。我不如是堕于有无朋党聚中。大慧。我说离有无法。离生住灭相。非有非无。见诸一切种种色像如幻如梦。是故不得言其有无。大慧。云何不得言其是无。谓色体相有见不见取不取故。大慧。是故我说一切诸法非有非无。大慧。以不觉知唯是自心分别生见。一切世间诸法本来不生不灭。而诸凡夫生于分别。非圣人耶。大慧。迷心分别不实义者。譬如凡夫见乾闼婆城。幻师所作种种幻人种种象马。见其入出虚妄分别。作如是言。此如是如是入。如是如是出。大慧。而彼实处无人出入。惟自心见迷惑分别。生不生法亦复如是。大慧。而彼实处无此有为无为诸法。如彼幻师所作幻事。而彼幻师不生不灭。大慧。诸法有无亦无所为。以离生灭故。惟诸凡夫堕颠倒心分别生灭。非谓圣人。大慧。颠倒者如心分别此法如是如是而彼法不如是如是。亦非颠倒分别颠倒者执着诸法是有是无。非见寂静故。不见寂静者不能远离虚妄分别。是故大慧。见寂静者名为胜相。非见诸相名为胜相。以不能断生因相故。大慧。言无相者远离一切诸分别心。无生无相者是我所说名为涅槃。大慧。言涅槃者谓见诸法如实住处。远离分别心心数法。依于次第如实修行。于自内身圣智所证。我说如是名为涅槃。尔时世尊重说偈言
为遮生诸法 建立无生法
我说法无因 凡夫不能知
我说法无因 而凡夫不知
一切法不生 亦不得言无
乾闼婆幻梦 诸法无因有
诸法空无相 云何为我说
离诸和合缘 智慧不能见
以空本不生 是故说无体
一一缘和合 见物不可得
非外道所见 和合不可得
梦幻及毛轮 乾闼婆阳焰
无因而妄见 世间事亦尔
降伏无因论 能成无生义
能成无生者 我法不灭坏
说无因诸论 外道生惊怖
云何何等人 何因于何处
生诸法无因 非因非无因
智者若能见 能离生灭见
无法生不生 为无因缘相
若为法名字 无义为我说
非法有无生 亦非待因缘
非前法有名 亦名不空说
声闻辟支佛 外道非境界
住在于七地 彼处无生相
离诸因缘法 为遮诸因缘
说建立惟心 我说名无生
诸法无因缘 离分别分别
离有无朋党 我说名无生
心离于见法 及离二法体
转身依正相 我说名无生
外非实无实 亦非心所取
幻梦及毛轮 乾闼婆阳焰
远离于诸见 是名无生相
如是空等法 诸文句应知
非生及空空 而无于生空
诸因缘和合 有生及有灭
离于诸因缘 不生亦不灭
离因缘无法 离和合无得
外道妄分别 而见有一异
有无不生法 有无不可得
惟和合诸法 而见有生灭
但有于名字 展转为钩锁
离彼因缘锁 生法不可得
生法不见生 离诸外道过
我说缘钩锁 诸凡夫不知
若离缘钩锁 更无有别法
是则无因缘 破坏缘锁义
如灯显众像 钩锁生亦然
是则离钩锁 别更有法生
生法本无体 自性如虚空
离钩锁求法 愚人无所知
复有余无生 圣人所得法
彼生无生者 是则无生忍
若见诸世间 则是见钩锁
一切皆钩锁 是则心得定
无明爱业等 是则内钩锁
攒轴泥团轮 种子大钩锁
若更有他法 而从因缘生
离于钩锁义 彼不住圣教
若生法是无 彼为谁钩锁
展转相生故 是名因缘义
坚湿热动法 凡夫生分别
离锁更无法 是故说无体
如医疗众病 依病出对治
而论无差别 病殊故方异
我念诸众生 为烦恼过染
知根力差别 随堪受为说
我法无差别 随根病异说
我唯一乘法 八圣道清净

    入楞伽经卷第六

    入楞伽经卷第七
    元魏天竺三藏菩提留支译
    无常品第八
    尔时圣者大慧菩萨复白佛言。世尊。世尊说无常。无常者。一切外道亦说无常。世尊。如来依于名字章句。说如是言。诸行无常是生灭法。世尊。此法为是真实为是虚妄。世尊。复有几种无常
    佛告圣者大慧菩萨言。善哉善哉善哉大慧。一切外道虚妄分别说八种无常。何等为八。一者发起所作而不作。是名无常。何者名为发起。谓生法不生法。常法无常法。名为发起无常。二者形相休息。名为无常。三者色等即是无常。四者色转变故异异无常。诸法相续自然而灭。如乳酪转变。于一切法不见其转亦不见灭。名为无常。五者复有余外道等。以无物故。名为无常。六者有法无法而悉无常。以一切法本不生故。名为无常。以无常法彼中和合。是故无常。七者复有余外道等。本无后有名为无常。谓依诸大所生相灭。不见其生离相续体。名为无常。八者不生无常。谓为非常是故无常。见诸法有无生不生。乃至微尘观察不见法生。故言不生。诸法非生。大慧。是名无生无常相。而诸外道不知彼法所以不生。是故分别诸法不生。故言无常。复次大慧。外道分别无常之法。言有于物。彼诸外道自心虚妄分别无常常非无常。以有物故。何以故。自体不灭故。自体不灭者。无常之体常不灭故。大慧。若无常法是有物者应生诸法。以彼无常能作因故。大慧。若一切法不离无常者。诸法有无一切应见。何以故。如杖木瓦石。能破可破之物悉皆破坏。见彼种种异异相故。是故无常因一切法无法。亦非因亦非果。大慧。复有诸过。以彼因果无差别故。而不得言此是无常而彼是果。以因果差别故。不得言一切法常。以一切法无因故。大慧。诸法有因。而诸凡夫不觉不知。异因不能生异果故。大慧。若异因能生异果者。因异应生一切诸法。若尔复更有过。应因果差别而见差别。大慧。若其无常是有物者。应同因体所作之事。复更有过。于一法中即应具足一切诸法。以同一切所作。因果业相无差故。复更有过。自有无常。无常有无常体故。复更有过。一切诸法无常应常故。复更有过。若其无常同诸法者堕三世法。大慧。过去色同无常故已灭。未来法未生。以同色无常故不生。现在有法不离于色。以色与彼诸大相。依五大依尘。是故不灭。以彼彼不相离故。大慧。一切外道不灭诸大。三界依大依微尘等。是故依彼法说生住灭。大慧。离于此法更无四大诸尘等法。以彼外道虚妄分别离一切法更有无常。是故外道说言诸大不生不灭。以自体相常不灭故。是故彼说发起作事中间不作名为无常。诸大更有发起诸大。无彼彼异相同相不生灭法。以见诸法不生灭故。而于彼处生无常智。大慧。何者名为形相休息无常。谓能造所造形相见形相异如长短。非诸大灭而见诸大形相转变。彼人堕在僧佉法中。大慧。复形相无常者。谓何等人即色名无常。彼人见于形相无常。而非诸大是无常法。若诸大无常。则诸世间一切不得论说世事。若论世事。堕卢迦耶陀邪见朋党。以说一切诸法唯名。复见诸法自体相生。大慧。转变无常者。谓见诸色种种异相。非诸大转变。譬如见金作庄严具形相转变金体不异。余法转变亦复如是。大慧。如是外道虚妄分别见法无常。火不烧诸大。自体不烧。以彼诸大自体差别故。大慧。诸外道说若火能烧诸大者。则诸大断灭是故不烧。大慧。我说大及诸尘非常非无常。何以故。我不说外境界有故。我说三界但是自心。不说种种诸相是有。是故说言不生不灭。唯是四大因缘和合。非大及尘是实有法。以虚妄心分别二种可取能取法。如实能知二种分别。是故离外有无见相。唯是自心分别作业。而名为生而业不生。以离有无分别心故。大慧。何故非常非不常。以有世间及出世间上上诸法。是故不得说言是常。何故非无常。以能觉知唯是自心分别见故。是故非无常。而诸外道堕在邪见执着二边。不知自心虚妄分别。非诸圣人分别无常。大慧。一切诸法总有三种。何等为三。一者世间法相。二者出世间法相。三者出世间上上胜法相。以依言语种种说法。而诸凡夫不觉不知。尔时世尊重说偈言
远离于始造 及与形相异
无常名有物 外道妄分别
诸法无有灭 诸大自性住
堕于种种见 外道说无常
彼诸外道说 诸法不生灭
诸大体自常 何等法无常
一切世唯心 而心见二境
可取能取法 我我所法无
三界上下法 我说皆是心
离于诸心法 更无有可得

    入楞伽经入道品第九
    尔时圣者大慧菩萨摩诃萨复白佛言。世尊。惟愿世尊。为我说诸一切菩萨声闻辟支佛入灭尽定次第相。我及一切诸菩萨等。若得善知入灭尽定次第之相巧方便者。不堕声闻辟支佛三昧三摩跋提灭尽定乐。不堕声闻辟支佛外道迷惑之法。佛告圣者大慧菩萨言。善哉善哉善哉大慧。谛听谛听当为汝说。大慧菩萨白佛言。善哉世尊。唯然受教。佛告大慧。菩萨从初地乃至六地入灭尽定。声闻辟支佛亦入灭尽定。大慧。诸菩萨摩诃萨。于七地中念念入灭尽定。以诸菩萨悉能远离一切诸法有无相故。大慧。声闻辟支佛不能念念入灭尽定。以声闻辟支佛缘有为行入灭尽定。堕在可取能取境界。是故声闻辟支佛。不能入七地中念念灭尽定。以声闻辟支佛生惊怖想。恐堕诸法无异相故。以觉诸法种种异相有法无法善不善法同相异相而入灭尽定。是故声闻辟支佛。不能入七地中念念灭尽定。以无善巧方便智故。大慧。七地菩萨摩诃萨。转灭声闻辟支佛心意意识。大慧。初地乃至六地菩萨摩诃萨。见于三界但是自心心意意识离我我所法。唯是自心分别。不堕外法种种诸相。唯是凡夫内心愚痴。堕于二边见于可取能取之法。以无知故。而不觉知无始世来身口及意妄想烦恼戏论熏习而生诸法。大慧。于八地中一切菩萨声闻辟支佛入涅槃想。大慧。诸菩萨摩诃萨。承己自心三昧佛力。不入三昧乐门。堕涅槃而住。以不满足如来地故。若彼菩萨住三昧分者。休息度脱一切众生。断如来种灭如来家。为示如来不可思议诸境界故。是故不入涅槃。大慧。声闻辟支佛堕三昧乐门法。是故声闻辟支佛生涅槃想。大慧。诸菩萨摩诃萨。从初地来乃至七地具巧方便。观察心意意识之想。远离我我所取相之法。观察我空法空。观察同相异相。善解四无碍巧方便义。自在次第入于诸地菩提分法。大慧。我若不说诸菩萨摩诃萨同相异相法者。一切菩萨不如实知诸地次第。恐堕外道邪见等法故。我次第说诸地相。大慧。若人次第入诸地者不堕余道。我说诸地次第相者。唯自心见诸地次第。及三界中种种行相。而诸凡夫不觉不知。以诸凡夫不觉知故。是故我及一切诸佛。说于诸地次第之相。及建立三界种种行相。复次大慧。声闻辟支佛。于第八菩萨地中。乐着寂灭三昧乐门醉故。不能善知唯自心见。堕自相同相熏习障碍故。堕人无我法无我见过故。以分别心名为涅槃。而不能知诸法寂静。大慧。诸菩萨摩诃萨。以见寂静三昧乐门。忆念本愿大慈悲心度诸众生。知十无尽如实行智。是故不即入于涅槃。大慧。诸菩萨摩诃萨。远离虚妄分别之心。远离能取可取境界。名入涅槃。以如实智知一切诸法唯是自心。是故不生分别之心。是故菩萨不取心意意识。不着外法实有之相。而非不为佛法修行。依根本智展转修行。为于自身求佛如来证地智故。大慧。如人睡梦度大海水。起大方便欲度自身。未度中间忽然便寤。作是思惟。此为是实为是虚妄。彼复思惟。如是之相非实非虚。唯是我本虚妄分别不实境界。熏习因故见种种色。形相颠倒不离有无。意识熏习于梦中见。大慧。菩萨摩诃萨亦复如是。于八地中见分别心。初地七地诸法同相。如梦如幻平等无差。离诸功用可取能取分别之心。见心心数法。为于未得上上佛法修行者令得故。菩萨摩诃萨修行胜法。名为涅槃。非灭诸法名为涅槃。菩萨摩诃萨。远离心意意识分别相故。得无生法忍。大慧。第一义中亦无次第。无次第行。诸法寂静亦如虚空。大慧菩萨白佛言。世尊。世尊说。声闻辟支佛。入第八菩萨地寂灭乐门。如来复说。声闻辟支佛不知但是自心分别。复说诸声闻得人无我。而不得法无我空。若如是说。声闻辟支佛尚未能证初地之法。何况八地寂灭乐门。佛告大慧。我今为汝分别宣说。大慧。声闻有三种。言入八地寂灭门者。此是先修菩萨行者堕声闻地。还依本心修菩萨行。同入八地寂灭乐门。非增上慢寂灭声闻。以彼不能入菩萨行。未曾觉知三界唯心。未曾修行菩萨诸法。未曾修行诸波罗蜜十地之行。是故决定寂灭声闻。不能证彼菩萨所行寂灭乐门。尔时世尊重说偈言
唯心无所有 诸行及佛地
去来现在佛 三世说如是
七地为心地 无所有八地
二地名为行 余地名我地
内身证及净 此名为我地
自在最胜处 阿迦尼吒天
昭曜如炎火 出妙诸光明
种种美可乐 化作于三界
化现三界色 或有在光化
彼处说诸乘 是我自在地
十地为初地 初地为八地
九地为七地 七地为八地
二地为三地 四地为五地
三地为六地 寂灭有何次
决定诸声闻 不行菩萨行
同入八地者 是本菩萨行

    入楞伽经问如来常无常品第十
    尔时圣者大慧菩萨摩诃萨白佛言。世尊。如来应正遍知。为是常耶为无常耶。佛告圣者大慧菩萨言。大慧。如来应正遍知。非常非无常。何以故。二边有过故。大慧。有无二边应有过失。大慧。若言如来是常法者则同常因。大慧。以诸外道说言微尘诸因常故。非是作法。大慧。是故不得言如来常。以非作法而言常故。大慧。亦不得言如来无常。言无常者即是同于有为作法。五阴可见能见法无。五阴灭故。五阴灭者诸佛如来亦应同灭。而佛如来非断绝法。大慧。凡作法者皆是无常。如瓶衣车屋及叠席等皆是作法。是故无常。大慧。若言一切皆无常者。一切智一切智人。一切功德亦应无常。以同一切作法相故。又复有过。若言一切皆无常者。诸佛如来应是作法。而佛如来非是作法。以无更说有胜因故。是故我言如来非常亦非无常。复次大慧。如来非常。何以故。虚空之性亦无修行诸功德故。大慧。譬如虚空非常非无常。何以故。以离常无常故。以不堕一异俱不俱。有无非有非无。常无常非常非无常。是故离于一切诸过不可得说。复次大慧。亦不得言如来是常。何以故。若言常者同于兔马驼驴龟蛇蝇鱼等角。是故不得言如来常。复次大慧。亦不得言如来是常。恐堕不生常故。是故不得言如来世尊常。复次大慧。更有余法。依彼法故。得言如来世尊是常。何以故。依内证智证常法故。是故得言如来是常。大慧。诸佛如来内证智法。常恒清凉不变。大慧。诸佛如来应正遍知。若出于世不出于世。法性常。如是法体常。如是法轨则常。如是以彼法性。一切声闻辟支佛等。亦不曾闻亦不曾见。如是法体。非虚空中。毛道凡夫不觉不知。大慧。诸佛如来内证智者依彼得名。大慧。以依如实智慧修行得名为佛。非心意意识无明五阴熏习得名。大慧。一切三界不实妄想分别戏论得名。大慧。不实分别二种法者。而得名为常与无常。而佛如来不堕二法。不堕能取可取二边。如来寂静。二法不生故。是故大慧。诸佛如来应正遍知。不得言是常与无常。大慧。凡所言语。而得说言常与无常。远离一切分别尽者。不得言取常无常法。是故我遮一切凡夫。不得分别常与无常。以得真实寂静法者得尽分别不生分别。尔时世尊重说偈言
离于常无常 非常非无常
若见如是佛 彼不堕恶道
若说常无常 诸功德虚妄
无智者分别 遮说常无常
所有立法者 皆有诸过失
若能见唯心 彼不堕诸过

    入楞伽经佛性品第十一
    尔时圣者大慧菩萨摩诃萨。复请佛言。世尊。惟愿如来应正遍知为我说。善逝为我说阴界入生灭之相。世尊。若无我者谁生谁灭。世尊。一切凡夫依生灭住不见苦尽。是故不知涅槃之相。佛告圣者大慧菩萨言。善哉善哉。善哉大慧。汝今谛听当为汝说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。如来之藏是善不善因故。能与六道作生死因缘。譬如伎儿出种种伎。众生依于如来藏故。五道生死。大慧。而如来藏离我我所。诸外道等不知不觉。是故三界生死因缘不断。大慧。诸外道等妄计我故。不能如实见如来藏。以诸外道无始世来虚妄执着种种戏论诸熏习故。大慧。阿梨耶识者。名如来藏。而与无明七识共俱。如大海波常不断绝身俱生故。离无常过离于我过自性清净。余七识者。心意意识等念念不住是生灭法。七识由彼虚妄因生。不能如实分别诸法。观于高下长短形相故。执著名相故。能令自心见色相故。能得苦乐故。能离解脱因故。因名相生随烦恼贪故。依彼念因诸根灭尽故。不次第生故。余自意分别不生苦乐受故。是故入少想定灭尽定。入三摩跋提四禅实谛解脱而修行者生解脱相。以不知转灭虚妄相故。大慧。如来藏识不在阿梨耶识中。是故七种识有生有灭。如来藏识不生不灭。何以故。彼七种识依诸境界念观而生。此七识境界一切声闻辟支佛外道修行者。不能觉知。不如实知人无我故。以取同相别相法故。以见阴界入法等故。大慧。如来藏如实见五法体相法无我故不生。如实知诸地次第展转和合故。余外道不正见不能观察。大慧。菩萨住不动地。尔时得十种三昧门等为上首。得无量无边三昧。依三昧佛住持。观察不可思议诸佛法及自本愿力故。遮护三昧门实际境界。遮已入自内身圣智证法真实境界。不同声闻辟支佛外道修行所观境界。尔时过彼十种圣道。入于如来意生身智身。离诸功用三昧心故。是故大慧。诸菩萨摩诃萨欲证胜法如来藏阿梨耶识者。应当修行令清净故。大慧。若如来藏阿梨耶识名为无者。离阿梨耶识无生无灭。一切凡夫及诸圣人。依彼阿梨耶识故有生有灭。以依阿梨耶识故。诸修行者入自内身圣行所证。现法乐行而不休息。大慧。此如来心阿梨耶识如来藏诸境界。一切声闻辟支佛诸外道等不能分别。何以故。以如来藏是清净相。客尘烦恼垢染不净。大慧。我依此义依胜鬘夫人。依余菩萨摩诃萨深智慧者。说如来藏阿梨耶识。共七种识生名转灭相。为诸声闻辟支佛等示法无我。对胜鬘说言。如来藏是如来境界。大慧。如来藏识阿梨耶识境界我今与汝及诸菩萨甚深智者。能了分别此二种法。诸余声闻辟支佛及外道等执著名字者。不能了知如此二法。大慧。是故汝及诸菩萨摩诃萨当学此法。尔时世尊重说偈言
甚深如来藏 与七识俱生
取二法则生 如实知不生
如镜像现心 无始习所熏
如实观察者 诸境悉空无
如痴见指月 观指不观月
计著名字者 不见我真实
心如巧伎儿 意如狡猾者
意识及五识 虚妄取境界
如伎儿和合 诳惑于凡夫

    入楞伽经五法门品第十二
    尔时圣者大慧菩萨摩诃萨。复请佛言。世尊。惟愿如来应正遍知为我说。善逝。为我说五法体相及二无我差别行相。我及一切诸菩萨等。若得善知五法体相二种无我差别相者。修行是法次第入于一切诸地。修行是法能入一切诸佛法中。入诸佛法者。乃至能入如来自身内证智地。佛告圣者大慧菩萨言。善哉善哉。善哉大慧。汝今谛听当为汝说。大慧菩萨言。善哉世尊。唯然受教。佛告大慧。我为汝说五法体相二种无我差别行相。大慧。何等五法。一者名二者相三者分别四者正智五者真如。内身修行证圣人智离断常见现如实修行者。入三昧乐三摩跋提行门故。大慧。一切凡夫不觉不知五法体相二种无我。惟以自心见于外物。是故生于分别之心非谓圣人。大慧白佛言。世尊。云何凡夫生分别心非圣人也。佛告大慧。一切凡夫执著名相随顺生法。随顺生法已见种种相。堕我我所邪见心中。执着具足。一切法相。执着已入于无明黑闇障处。入障处已起于贪心。起贪心已而能造作贪嗔痴业。造业行已不能自止。如蚕作茧以分别心而自缠身。堕在六道大海险难。如辘轳回转不自觉知。以无智故不知一切诸法如幻。不知无我我所诸法非实从于妄想分别而生。而不知离可见能见。而不知离生住灭相。不知自心虚妄而生。谓知随顺自在天．时．微尘．我生。大慧。何者为名。谓眼识见前色等法相如声相耳相鼻相舌相身相。大慧。如是等相。我说名为名相。大慧。何者分别以依何等法说名取相。了别此法如是如是毕竟不异。谓象马车步人民等分别种种相。是名分别。大慧。何者正智。以观察名相。观察已不见实法。以彼迭共因生故见。迭共生者诸识不复起。分别识相不断不常。是故不堕一切外道声闻辟支佛地。大慧。是名正智。复次大慧。菩萨摩诃萨依正智。不取名相法以为有。不取不见相以为无。何以故。以离有无邪见故。以不见名相是正智义。是故我说名为真如。大慧。菩萨住真如法者。得入无相寂静境界。入已得入菩萨摩诃萨初欢喜地。菩萨得初欢喜地时。证百金刚三昧明门。舍离二十五有一切果业。过诸声闻辟支佛地。住如来家真如境界。如实修行知五法相如幻如梦。如实观察一切诸法。起自内身证圣智修行。如是展转远离虚妄世间觉观所乐之地。次第乃至法云地。入法云地已次入三昧力自在神通诸华庄严如来之地。入如来地已为教化众生。现种种光明应庄严身如水中月。依无尽句善缚所缚。随众生信者而为说法。离心意意识身故。大慧。菩萨入真如已得佛地中如是如是无量无边法。大慧复白佛言。世尊。世尊为五法入三法。为三法入五法中。为自体相各各差别。佛告大慧。三法入五法中。大慧。非但三法入五法中。八种识二种无我亦入五法。大慧。云何三法入五法中。大慧。名相名为分别法相。大慧。依彼二法分别生心心数法。一时非前后。如日共光明一时。而有分别种种相。大慧。是名三相。依因缘力生故。大慧。正智真如名第一义谛相。依不灭法故。复次大慧。着于自心见分别法。差别有八种以分别诸相。以为实故离我我所生灭之法。尔时得证二无我法。大慧。五法法门入诸佛地。诸地法相亦入五法门中。一切声闻辟支佛法亦入五法门中。如来内身证圣智法亦入五法门中。复次大慧。五法相名分别真如正智。大慧。何者名为相。相者见色形相状貌胜不如。是名为相。大慧。依彼法相起分别相。此是瓶此是牛马羊等。此法如是如是不异。大慧。是名为名。大慧。依于彼法立名。了别示现彼相。是故立彼种种名字牛羊马等。是名分别心心数法。大慧。观察名相乃至微尘。常不见一法相诸法不实。以虚妄心生分别故。大慧。言真如者名为不虚。决定毕竟尽自性自体。正见真如相。我及诸菩萨及诸佛如来应正遍知。说名异义一。大慧。如是等随顺正智。不断不常。无分别分别不行处。随顺自身内证圣智。离诸一切外道声闻辟支佛等恶见朋党不正智中。大慧。于五法三法相八种识二种无我。一切佛法皆入五法中。大慧。汝及诸菩萨摩诃萨。为求胜智应当修学。大慧。汝知五法不随他教故。尔时世尊重说偈言
五法自体相 及与八种识
二种无我法 摄取诸大乘
名相及分别 三法自体相
正智及真如 是第一义相

    入楞伽经恒河沙品第十三
    尔时圣者大慧菩萨摩诃萨白佛言。世尊。如世尊依名字说过去未来现在诸佛如恒河河沙。世尊。佛说如是。为依如来口中所说。我随顺取。为更有义。愿为我说。佛告圣者大慧菩萨言。大慧。如我所说名字章句。莫如是取。大慧。三世诸佛非恒河河沙等。何以故。所说譬喻过世间者。非如譬喻。何以故。以有相似不相似故。大慧。诸佛如来应正遍知。不定说过世间相似不相似譬喻。何以故。大慧。我说譬喻但是少分故。大慧。我及诸佛如来应正遍知。所说譬喻但说少义。何以故。愚痴凡夫诸外道等。着诸法常增长邪见。随顺世间轮回生死。为彼生厌闻生惊怖又闻诸佛如恒河沙便于如来无上圣道生易得想求出世法。大慧。是故我说诸佛如来如恒河河沙。何以故。我余经中说佛出世如优昙华。众生闻已言佛道难得不修精进。是故我说诸佛如来如恒河河沙。大慧。我说诸佛出世如优昙华者。依可化众生义故。我说诸佛如优昙华。大慧。而优昙华于世间中无人曾见。当亦不见。大慧。诸佛如来世间曾见现见当见。大慧。我说如是。非依自身所得法说。是故说言如优昙华。诸佛如来亦复如是。大慧。我依内身证法说法。是故说过世间譬喻。以诸凡夫无信众生。不能信我所说譬喻。何以故。说自内身圣智境界。无譬喻可说。远离心意意识过诸见地。诸佛如来真如之法不可说故。是故我说种种譬喻。大慧。我说诸佛如恒河河沙者。是少分譬喻。大慧。诸佛如来平等非不平等。以非分别分别故。大慧。譬如恒河河中所有之沙。鱼鳖龟龙牛羊象马诸兽践蹈。而彼河沙不生分别不嗔不恚。亦不生心彼恼乱我。无分别故净离诸垢。大慧。诸佛如来应正遍知亦复如是。内身证得圣智。满足诸力神通自在功德如恒河沙。一切外道邪论诸师愚痴鱼鳖。以嗔恚心毁骂如来。如来不动不生分别。本愿力故为与众生三昧三摩跋提。一切诸乐令满足故。不分别分别。大慧。是故我说诸佛如来如恒河河沙等。等者平等无有异相。以离爱身故。大慧。譬如恒河河沙不离地相。大慧。大地火烧火不异地故。火不烧地地大有火相续体故。大慧。愚痴凡夫堕颠倒智。自心分别言地被烧。而地不烧以不离地。而得更有四大火身故。大慧。诸佛如来亦复如是。诸佛如来法身之体。如恒河河沙等。不灭不失故。大慧。譬如恒河河沙无量无边。大慧。诸佛如来亦复如是。出于世间放无量光。遍于一切诸佛大会。为化众生令觉知故。大慧。如恒河河沙更不生相。如彼微尘微尘体相如是而住。大慧。诸佛如来亦复如是。于世间中不生不灭。诸佛如来断有因故。大慧。如恒河河沙若出于河亦不可见入于河中亦不可见。亦不起心我出入河。大慧。诸佛如来智慧之力亦复如是。度诸众生亦不尽灭亦不增长。何以故。诸法无身故。大慧。一切有身皆是无常磨灭之法。非无身法。诸佛如来唯法身故。大慧。譬如有人欲得苏油。押恒河沙。终不可得无苏油故。大慧诸佛如来为诸众生苦恼。所押嗔不可得。不舍自法界相。不舍自法味相。不舍本愿与众生乐。以得具足大慈大悲。我若不令一切众生入涅槃者。我身亦不入于涅槃。大慧。如恒河河沙随水而流终不逆流。大慧。诸佛如来为诸众生说法亦尔。随顺涅槃而非逆流。大慧。是故我说诸佛如来如恒河河沙。大慧。言恒河河沙随顺流者非是去义。若佛如来有去义者。诸佛如来应无常灭。大慧。世间本际尚不可知。不可知者我云何依而说去义。是故如来非为去义。大慧。去义者名为断义。愚痴凡夫不觉不知。大慧白佛言。世尊。世尊若众生在于世间轮回。去来本际不可知者。云何如来而得解脱。复令众生得于解脱。佛告大慧言。大慧。言解脱者。离于一切戏论烦恼无始熏习分别心故。如实能知唯自心见外所分别心回转故。是故我说名为解脱。大慧。言解脱者非是灭法。是故汝今问。我若不知本际云何得解脱者。此问不成。大慧。言本际者。是分别心一体异名。大慧。离分别心更无众生。即此分别名为众生。大慧。真实智慧观内外法。无法可知能知故。大慧。以一切法本际来寂静。大慧。不如实知唯自心见虚妄分别。是故生于分别之心。如实知者不生分别。尔时世尊重说偈言
观察于诸佛 譬如恒河沙
不灭亦不生 彼人能见佛
远离诸尘垢 如恒河河沙
随顺流不变 法身亦如是

    入楞伽经卷第七

    入楞伽经卷第八
    元魏天竺三藏菩提留支译
    刹那品第十四
    尔时圣者大慧菩萨摩诃萨复白佛言。世尊。惟愿如来应正遍知为我说。善逝为我说一切法生灭之相。云何如来说一切法念念不住。佛告大慧菩萨言。善哉善哉。善哉大慧。汝今谛听当为汝说。大慧言。善哉世尊。唯然受教。佛告大慧。一切法。一切法者。所谓善法不善法。有为法无为法。世间法出世间法。有漏法无漏法。内法外法。大慧略说五阴法。因心意意识熏习增长。诸凡夫人依心意意识熏习故。分别善不善法。大慧。圣人现证三昧三摩跋提无漏善法乐行。大慧。是名善法。复次大慧。言善不善法者。所谓八识。何等为八。一者阿梨耶识。二者意。三者意识。四者眼识。五者耳识。六者鼻识。七者舌识。八者身识。大慧。五识身共意识身。善不善法展转差别相续。体无差别身。随顺生法生已还灭。不知自心见虚妄境界。即灭时。能取境界形相大小胜如之状。大慧。意识共五识身相应生。一念时不住。是故我说彼法念时不住。大慧。言刹尼迦者。名之为空。阿梨耶识名如来藏。无共意转识熏习故名为空。具足无漏熏习法故。名为不空。大慧。愚痴凡夫不觉不知。执着诸法刹那不住。堕在邪见而作是言。无漏之法亦刹那不住。破彼真如如来藏故。大慧。五识身者不生六道不受苦乐不作涅槃因。大慧。如来藏不受苦乐非生死因。余法者共生共灭。依于四种熏习醉故。而诸凡夫不觉不知邪见熏习。言一切法刹那不住。复次大慧。金刚如来藏。如来证法。非刹那不住。大慧。如来证法。若刹那不住者。一切圣者不成圣人。大慧。非非圣人。以圣人故。大慧。金刚住于一劫。称量等住不增不减。大慧。云何愚痴凡夫分别诸法。言刹那不住。而诸凡夫不得我意。不觉不知内外诸法念念不住。大慧复白佛言。世尊。如来常说满足六波罗蜜法。得阿耨多罗三藐三菩提。世尊。何等为六波罗蜜。云何满足。佛告大慧菩萨言。大慧。波罗蜜差别有三种。谓世间波罗蜜。出世间波罗蜜。出世间上上波罗蜜。大慧。言世间波罗蜜者。愚痴凡夫执着我我所法堕于二边。为于种种胜妙境界行波罗蜜。求于色等境界果报。大慧。愚痴凡夫行尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。乃至生于梵天。求五神通世间之法。大慧。是名世间诸波罗蜜。大慧。言出世间波罗蜜者。谓声闻辟支佛。取声闻辟支佛涅槃心。修行波罗蜜。大慧。如彼世间愚痴凡夫。为于自身求涅槃乐。而行世间波罗蜜行。声闻缘觉亦复如是。为自身故求涅槃乐。行出世间波罗蜜行。而乃求彼非究竟乐。大慧。出世间上上波罗蜜者。如实能知但是自心虚妄分别见外境界。尔时实知惟是自心见内外法。不分别虚妄分别。不取内外自心色相故。菩萨摩诃萨如实能知一切法故行檀波罗蜜。为令一切众生得无怖畏安隐乐故。是名檀波罗蜜。大慧。菩萨观彼一切诸法。不生分别随顺清凉。是名尸波罗蜜。大慧。菩萨离分别心忍。彼修行如实而知能取可取境界非实。是名菩萨羼提波罗蜜。大慧。菩萨云何修精进行。初中后夜常勤修行。随顺如实法断诸分别。是名毗梨耶波罗蜜。大慧。菩萨离于分别心。不随外道能取可取境界之相。是名禅波罗蜜。大慧。何者菩萨般若波罗蜜。菩萨如实观察自心分别之相。不见分别不堕二边。依如实修行转身。不见一法生不见一法灭。自身内证圣行修行。是名菩萨般若波罗蜜。大慧。波罗蜜义如是满足者。得阿耨多罗三藐三菩提。尔时世尊重说偈言
空无常刹那 愚分别有为
如河灯种子 空无常刹那
分别刹那义 刹那亦如是
刹尼迦不生 寂静离所作
一切法不生 我说刹那义
物生即有灭 不为凡夫说
分别相续法 妄想见六道
若无明为因 能生诸心者
乃至色未生 中间依何住
即生即有灭 余心随彼生
色不一念住 观于何法生
依何因生法 心无因而生
是故生不成 云何知念坏
修行者证定 金刚佛舍利
光音天宫殿 世间不坏事
其如证法实 如来智成就
比丘证平等 云何念不住
乾闼婆幻色 何故念不住
无四大见色 四大何所为

    入楞伽经化品第十五
    尔时圣者大慧菩萨摩诃萨复白佛言。世尊。如佛世尊与诸罗汉。授阿耨多罗三藐三菩提记。如来复说诸佛如来不入涅槃。复说如来应正遍知。何等夜证大菩提。何等夜入般涅槃于其中间不说一字。如来复说诸佛如来。常入无觉无观无分别定。复言作诸种种应化度诸众生。世尊复说诸识念念差别不住。金刚密迹常随侍卫。复说世间本际难知。复言众生入般涅槃。若入涅槃。应有本际。复说诸佛无有怨敌而见诸魔。复说如来断一切障。而见旃遮摩那毗孙陀梨等谤。佛入娑梨那村竟。不得食空钵而出。世尊。若如是者如来便有无量罪业。云何如来不离一切诸罪过恶。而得阿耨多罗三藐三菩提一切种智。佛告圣者大慧菩萨言。善哉善哉。善哉大慧。汝今谛听当为汝说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。我为曾行菩萨行诸声闻等依无余涅槃而与授记。大慧。我与声闻授记者。为怯弱众生生勇猛心。大慧。此世界中及余佛国。有诸众生行菩萨行。而复乐于声闻法行。为转彼取大菩提。应化佛为应化声闻授记。非报佛法身佛而授记莂。大慧。声闻辟支佛涅槃无差别。何以故。断烦恼无差异故。断烦恼障非断智障。复次大慧。见法无我断于智障。见人无我断烦恼障。大慧转意识故断法障业障。以转意阿梨耶识熏习故究竟清净。大慧。我常依本法体而住更不生法。依本名字章句。不觉不思而说诸法。大慧。如来常如意知常不失念。是故如来无觉无观。诸佛如来离四种地已。远离二种死二种障二种业故。大慧。七种识意意识。眼耳鼻舌身念念不住。因虚妄熏习离于无漏诸善法故。大慧。如来藏世间不生不死。不来不去。常恒清凉不变。复次大慧。依如来藏故有世间涅槃苦乐之因。而诸凡夫不觉不知。而堕于空虚妄颠倒。大慧。金刚密迹常随侍卫。应化如来前后围绕。非法佛报佛根本如来应正遍知。大慧。根本如来远离诸根大小诸量。远离一切凡夫声闻辟支佛等。大慧。如实修行。得彼真如乐行境界者。知根本佛。以得平等法忍故。是故金刚密迹随应化佛。大慧。应化佛者无业无谤。而应化佛不异法佛报佛如来而亦不一。如陶师盐等作所作事。应化佛作化众生事。异真实相说法。不说内所证法圣智境界。复次大慧。一切凡夫外道声闻辟支佛等。见六识灭堕于断见。不见阿梨耶识堕于常见。复次大慧。不见自心分别本际。是故世间名无本际。大慧。远离自心分别见者。名为解脱得涅槃证。大慧。诸佛如来远离四种熏习气故。是故无过。尔时世尊重说偈言
三乘及非乘 诸佛无量乘
一切记佛地 说诸烦恼断
内身证圣智 及无余涅槃
诱进怯众生 是故隐覆说
如来得证智 亦说于彼道
众生依入道 二乘无涅槃
见欲色及有 及四种熏地
意识亦所生 见意识共住
见意眼识等 常无常断灭
常见依意等 而起涅槃见

    入楞伽经遮食肉品第十六
    尔时圣者大慧菩萨摩诃萨白佛言。世尊。我观世间生死流转怨结相连堕诸恶道。皆由食肉更相杀害。增长贪嗔不得出离甚为大苦。世尊。食肉之人断大慈种。修圣道者不应得食。世尊。诸外道等说邪见法卢迦耶陀堕俗之论。堕于断常有无见中皆遮食肉。自己不食不听他食。云何如来清净法中修梵行者。自食他食一切不制。如来世尊于诸众生慈悲一等。云何而听以肉为食。善哉世尊。哀愍世间愿为我说食肉之过不食功德。我及一切诸菩萨等闻已得依如实修行广宣流布。令诸现在未来众生一切识知
    佛告圣者大慧菩萨言。善哉善哉善哉大慧。汝大慈悲愍众生故能问此义。汝今谛听当为汝说。大慧菩萨白佛言。善哉世尊。唯然受教。佛告大慧。夫食肉者有无量过。诸菩萨摩诃萨修大慈悲不得食肉。食与不食功德罪过我说少分。汝今谛听。大慧。我观众生从无始来食肉习故。贪着肉味更相杀害。远离贤圣受生死苦。舍肉味者闻正法味。于菩萨地如实修行速得阿耨多罗三藐三菩提。复令众生入于声闻辟支佛地止息之处。息已令入如来之地。大慧。如是等利慈心为本。食肉之人断大慈种。云何当得如是大利。是故大慧。我观众生轮回六道。同在生死共相生育。迭为父母兄弟姊妹。若男若女中表内外六亲眷属。或生余道善道恶道常为眷属。以是因缘我观众生更相啖肉无非亲者。由贪肉味迭互相啖。常生害心增长苦业流转生死不得出离。佛说是时。诸恶罗刹闻佛所说。悉舍恶心止不食肉。迭相劝发慈悲之心。护众生命过自护身。舍离一切诸肉不食。悲泣流泪而白佛言。世尊。我闻佛说谛观六道。我所啖肉皆是我亲。乃知食肉众生大怨断大慈种。长不善业是大苦本。世尊。我从今日断不食肉。及我眷属亦不听食。如来弟子有不食者。我当昼夜亲近拥护。若食肉者。我当与作大不饶益。佛言。大慧。罗刹恶鬼常食肉者。闻我所说尚发慈心舍肉不食。况我弟子行善法者当听食肉。若食肉者。当知即是众生大怨断我圣种。大慧。若我弟子闻我所说。不谛观察而食肉者。当知即是旃陀罗种。非我弟子我非其师。是故大慧。若欲与我作眷属者。一切诸肉悉不应食
    复次大慧。菩萨应观一切是肉皆依父母脓血不净赤白和合生不净身。是故菩萨观肉不净不应食肉
    复次大慧。食肉之人。众生闻气悉皆惊怖逃走远离。是故菩萨修如实行。为化众生不应食肉大慧。譬如旃陀罗猎师屠儿捕鱼鸟人一切行处。众生遥见作如是念。我今定死而此来者是大恶人。不识罪福断众生命。求现前利今来至此为觅我等。今我等身悉皆有肉。是故今来我等定死。大慧。由人食肉能令众生见者皆生如是惊怖。大慧。一切虚空地中众生。见食肉者皆生惊怖。而起疑念我于今者为死为活。如是恶人不修慈心。亦如豺狼游行世间常觅肉食。如牛啖草蜣螂逐粪不知饱足。我身是肉正是其食不应逢见。即舍逃走离之远去。如人畏惧罗刹无异。大慧。食肉之人。能令众生见者皆生如是惊怖。当知食肉众生大怨。是故菩萨修行慈悲。为摄众生不应食彼。非圣慧人所食之味。恶名流布圣人呵啧。是故大慧。菩萨为摄诸众生故不应食肉
    复次大慧。菩萨为护众生信心不应食肉。何以故。大慧。言菩萨者众生皆知。是佛如来慈心之种。能与众生作归依处。闻者自然不生疑怖。生亲友想善知识想不怖畏想。言得归依处得安隐处得善导师。大慧。由不食肉能生众生如是信心。若食肉者众生即失一切信心。便言世间无可信者断于信根。是故大慧。菩萨为护众生信心一切诸肉悉不应食
    复次大慧。我诸弟子。为护世间谤三宝故不应食肉。何以故。世间有人见食肉故。谤毁三宝作如是言。于佛法中。何处当有真实沙门婆罗门修梵行者。舍于圣人本所应食食众生肉。犹如罗刹食肉满腹醉眠不动。依世凡人豪贵势力觅肉食啖。如罗刹王惊怖众生。是故处处唱如是言。何处当有真实沙门婆罗门修净行者。无法无沙门无毗尼无净行者。生如是等无量无边恶不善心。断我法轮绝灭圣种。一切皆由食肉者过。是故大慧。我弟子者。为护恶人毁谤三宝。乃至不应生念肉想。何况食肉
    复次大慧。菩萨为求清净佛土教化众生不应食肉。应观诸肉如人死尸。眼不欲见不用闻气。何况可嗅而着口中。一切诸肉亦复如是。大慧。如烧死尸臭气不净。与烧余肉臭秽无异。云何于中有食不食。是故大慧。菩萨为求清净佛土教化众生不应食肉
    复次大慧。菩萨为求出离生死。应当专念慈悲之行。少欲知足厌世间苦速求解脱当舍愦闹就于空闲。住尸陀林阿兰若处。冢间树下独坐思惟。观诸世间无一可乐。妻子眷属如枷锁想。宫殿台观如牢狱想。观诸珍宝如粪聚想。见诸饮食如脓血想。受诸饮食如涂痈疮。趣得存命系念圣道不为贪味。酒肉葱[廿/韭]蒜薤臭味悉舍不食。大慧。若如是者是真修行。堪受一切人天供养。若于世间不生厌离。贪着滋味酒肉荤辛得便啖食。不应受于世间信施
    复次大慧。有诸众生过去曾修无量因缘。有微善根得闻我法。信心出家在我法中。过去曾作罗刹眷属。虎狼师子猫狸中生。虽在我法食肉余习见食肉者欢喜亲近。入诸城邑聚落塔寺饮酒啖肉以为欢乐。诸天下观犹如罗刹争啖死尸等无有异。而不自知已失我众成罗刹眷属。虽服袈裟剃除须发。有命者见心生恐怖如畏罗刹。是故大慧。若以我为师者。一切诸肉悉不应食
    复次大慧。世间邪见诸咒术师若其食肉咒术不成。为成邪术尚不食肉。况我弟子为求如来无上圣道出世解脱。修大慈悲精勤苦行犹恐不得。何处当有如是解脱为彼痴人食肉而得。是故大慧。我诸弟子为求出世解脱乐故不应食肉
    复次大慧。食肉能起色力。食味人多贪着。应当谛观。一切世间有身命者。各自宝重畏于死苦。护惜身命人畜无别。宁当乐存疥野干身。不能舍命受诸天乐。何以故。畏死苦故。大慧。以是观察死为大苦是可畏法。自身畏死云何当得而食他肉。是故大慧。欲食肉者先自念身。次观众生不应食肉
    复次大慧。夫食肉者。诸天远离。何况圣人。是故菩萨为见圣人。当修慈悲不应食肉。大慧。食肉之人睡眠亦苦起时亦苦。若于梦中见种种恶。惊怖毛竖心常不安。无慈心故乏诸善力。若其独在空闲之处。多为非人而伺其便。虎狼师子亦来伺求欲食其肉。心常惊怖不得安隐
    复次大慧。诸食肉者贪心难满。食不知量不能消化。增益四大口气腥臊。复中多有无量恶虫。身多疮癣白癞病疾种种不净。现在凡夫不憙闻见。何况未来无病香洁人身可得。复次大慧。我说凡夫为求净命啖于净食。尚应生心如子肉想。何况听食非圣人食。圣人离者以肉能生无量诸过。失于出世一切功德。云何言我听诸弟子食诸肉血不净等味。言我听者是则谤我。大慧。我听弟子食诸圣人所应食食。非谓圣人远离之食。圣食能生无量功德远离诸过。大慧。过去现在圣人食者。所谓粳米大小麦豆。种种油蜜。甘蔗甘蔗汁。骞陀末干提等。随时得者听食为净。大慧。于未来世有愚痴人。说种种毗尼言得食肉。因于过去食肉熏习爱着肉味。随自心见作如是说。非佛圣人说为美食。大慧。不食肉者。要因过去供养诸佛种诸善根。能信佛语坚住毗尼信诸因果。至于身口能自节量。不为世间贪着诸味。见食肉者能生慈心。大慧。我忆过去有王名师子奴。食种种肉爱着肉味。次第乃至食于人肉。因食人肉父母兄弟妻子眷属皆悉舍离。一切臣民国土聚落即便谋反共断其命。以食肉者有如是过。是故不应食一切肉。复次大慧。自在天王化身为鸽。释提桓因是诸天主。因于过去食肉习气。化身作鹰惊逐此鸽。鸽来投我。我于尔时。作尸毗王。怜愍众生更相食啖。称己身肉与鹰代鸽。割肉不足身上秤上受大苦恼。大慧。如是无量世来食肉熏习。自身他身有如是过。何况无愧常食肉者。大慧。复有余王不食肉者。乘马游戏为马惊波牵入深山。失于侍从不知归路。不食肉故师子虎狼见无害心。与雌师子共行欲事。乃至生子斑足王等。以过去世食肉熏习。及作人王亦常食肉。在七家村多乐食肉。食肉太过遂食人肉。生诸男女尽为罗刹。大慧。食肉众生依于过去食肉熏习。多生罗刹师子虎狼豺豹猫狸鵄枭雕鹫鹰鸡等中。有命之类各自护身不令得便。受饥饿苦常生恶心念食他肉。命终复堕恶道。受生人身难得。何况当有得涅槃道。大慧当知。食肉之人有如是等无量诸过。不食肉者即是无量功德之聚。大慧。而诸凡夫不知如是食肉之过不食功德。我今略说不听食肉。大慧。若一切人不食肉者。亦无有人杀害众生。由人食肉若无可食处处求买。为财利者杀以贩卖。为买者杀。是故买者与杀无异。是故食肉能障圣道。大慧。食肉之人爱着肉味。至无畜生乃食人肉。何况獐鹿雉兔鹅雁猪羊鸡狗驼驴象马龙蛇鱼鳖。水陆有命得而不食。由着肉味设诸方便杀害众生。造作种种罝罗机网。罗山罝地截河堰海。遍诸水陆安置罟网机拨坑陷弓刀毒箭间无空处。虚空地水种种众生皆被杀害。为食肉故。大慧。猎师屠儿食肉人等。恶心坚固能行不忍。见诸众生形体鲜肥肤肉充悦生食味心。更相指示言是可啖。不生一念不忍之心。是故我说食肉之人断大慈种
    大慧。我观世间无有是肉而非命者。自己不杀不教人杀他不为杀。不从命来而是肉者。无有是处。若有是肉不从命出而是美食。我以何故不听人食。遍求世间无如是肉。是故我说食肉是罪。断如来种故不听食
    大慧。我涅槃后于未来世法欲灭时。于我法中有出家者。剃除须发自称我是沙门释子。披我袈裟痴如小儿。自称律师堕在二边。种种虚妄觉观乱心贪着肉味。随自心见说毗尼中言得食肉。亦谤我言诸佛如来听人食肉。亦说因制而听食肉。亦谤我言如来世尊亦自食肉。大慧。我于象腋．央掘魔．涅槃．大云等一切修多罗中不听食肉。亦不说肉入于食味。大慧。我若听诸声闻弟子肉为食者。我终不得口常赞叹修大慈悲行如实行者。亦不赞叹尸陀林中头陀行者。亦不赞叹修行大乘住大乘者。亦不赞叹不食肉者。我不自食不听他食。是故我劝修菩萨行叹不食肉。劝观众生应如一子。云何唱言我听食肉。我为弟子修三乘行者速得果故。遮一切肉悉不听食。云何说言我毗尼中听人食肉。又复说言如来余修多罗中说三种肉听人食者。当知是人不解毗尼次第断故唱言得食。何以故。大慧。肉有二种。一者他杀。二者自死。以世人言有肉得食有不得者。象马龙蛇人鬼猕猴猪狗及牛。言不得食余者得食。屠儿不问得食不得。一切尽杀处处炫卖。众生无过横被杀害。是故我制他杀自死悉不得食。见闻疑者所谓他杀。不见闻疑者所谓自死。是故大慧。我毗尼中唱如是言。凡所有肉于一切沙门释子皆不净食。污清净命障圣道分无有方便而可得食。若有说言佛毗尼中说三种肉为不听食非为听食。当知是人坚住毗尼是不谤我。大慧。今此楞伽修多罗中。一切时一切肉。亦无方便而可得食。是故大慧。我遮食肉不为一人。现在未来一切不得。是故大慧。若彼痴人自言律师。言毗尼中听人食肉。亦谤我言如来自食。彼愚痴人成大罪障。长夜堕于无利益处无圣人处不闻法处。亦不得见现在未来贤圣弟子。况当得见诸佛如来。大慧。诸声闻人常所应食。米面油蜜种种麻豆能生净命。非法贮畜非法受取。我说不净尚不听食。何况听食血肉不净。大慧。我诸声闻辟支佛菩萨弟子食于法食。非食饮食何况如来。大慧。诸佛如来法食法住非饮食身。非诸一切饮食住身。离诸资生爱有求等。远离一切烦恼习过。善分别知心心智慧一切智一切见。见诸众生平等怜愍。是故大慧。我见一切诸众生等犹如一子。云何而听以肉为食。亦不随喜。何况自食。大慧。如是一切葱[廿/韭]蒜薤臭秽不净能障圣道。亦障世间人天净处。何况诸佛净土果报。酒亦如是能障圣道能损善业能生诸过。是故大慧。来圣道者酒肉葱[廿/韭]及蒜薤等能熏之味悉不应食。尔时世尊重说偈言
大慧菩萨问 酒肉葱[廿/韭]蒜
佛言是不净 一切不听食
罗刹等食啖 非圣所食味
食者圣呵啧 及恶名流布
愿佛分别说 食不食罪福
大慧汝谛听 我说食中过
酒肉葱[廿/韭]蒜 是障圣道分
我观三界中 及得圣道众
无始世界来 展转莫非亲
云何于其中 而有食不食
观肉所从来 出处最不净
脓血和杂生 尿屎脓涕合
修行净行者 当观不应食
种种肉及葱 酒亦不得饮
种种[廿/韭]及蒜 修行常远离
常远离麻油 穿孔床不眠
飞扬诸细虫 断害他命故
肉食长身力 由力生邪念
邪念生贪欲 故不听食肉
由食肉生贪 贪心致迷醉
迷醉长爱欲 不解脱生死
为利杀众生 为肉追钱财
彼二人恶业 死堕叫唤狱
三种名净肉 不见闻不疑
世无如是肉 生堕食肉中
臭秽可厌患 常生颠狂中
多生旃陀罗 猎师屠儿家
或生罗刹女 及诸食肉处
罗刹猫狸种 食肉生彼中
象腋与大云 涅槃．胜鬘经
及入楞伽经 我不听食肉
诸佛及菩萨 声闻亦呵啧
食肉无惭愧 生生常颠狂
先说见闻疑 已断一切肉
妄想不觉知 故生食肉想
如彼贪欲过 障碍圣解脱
酒肉葱[廿/韭]蒜 悉为圣道障
未来世众生 于肉愚痴说
言此净无罪 佛听我等食
净食如药想 犹如食子肉
知足生厌离 修行行乞食
安住慈心者 我说常厌离
师子豺虎狼 恒可同游止
食肉见者怖 云何而可食
是故修行者 慈心不食肉
食肉断慈心 离涅槃解脱
及违圣人教 故不听食肉
不食生梵种 及诸修行道
智慧及富贵 斯由不食肉

    入楞伽经陀罗尼品第十七
    尔时世尊。告圣者大慧菩萨摩诃萨言。大慧。汝应谛听受持我楞伽经咒。是咒过去未来现在诸佛。已说今说当说。大慧。我今亦说。为诸法师受持读诵楞伽经者。而说咒曰
    兜谛兜谛　祝谛祝谛　苏颇谛苏颇谛　迦谛迦谛　阿摩利　阿摩谛　毗摩梨毗摩梨　尼弥尼弥　奚弥奚弥　婆迷婆迷　歌梨歌梨　歌罗歌梨　阿[齿*齐]摩[齿*齐]　　遮[齿*齐]兜[齿*齐]　让[齿*齐]　苏弗[齿*齐]　葛弟葛弟　波弟波弟　奚咪奚咪地咪地咪　罗制罗制　波制波制　槃弟槃弟　　阿制弥制　竹荼梨兜荼弟　波罗弟　遏计遏计　斫计斫计梨利　尔[尸@羊]咪　屎咪　奚咪奚咪　昼昼昼昼　抽畜抽畜　紬紬紬紬　除除除除　苏婆呵
    大慧。是名楞伽大经中咒文句。善男子善女人。比丘比丘尼优婆塞优婆夷等。能受持读此文句为人演说。无有人能觅其罪过。若天天女。若龙龙女。若夜叉夜叉女。阿修罗阿修罗女。迦楼罗迦楼罗女。紧那罗紧那罗女。摩睺罗伽摩睺罗伽女。浮多浮多女。鸠槃荼鸠槃荼女。毗舍阇毗舍阇女。呜多罗呜多罗女。阿波罗阿波罗女。罗刹罗刹女。荼伽荼伽女。呜周何罗呜周何罗女。伽吒福多罗伽吒福多罗女。若人非人。若人女非人女。不能觅其过。若有恶鬼神损害人。欲速令彼恶鬼去者。一百遍转此陀罗尼咒。彼诸恶鬼惊怖号哭疾走而去。佛复告大慧。大慧。我为护此护法法师。更说陀罗尼。而说咒
    波头弥　波头弥提婢　奚尼奚尼奚祢诸梨　诸罗　诸丽　侯罗　侯丽　由丽　由罗　由丽　波丽　　波罗　波丽　闻制　嗔迭频迭槃逝末迭迟那　迦梨苏波呵
    大慧。是陀罗尼咒文句。若善男子善女人受持读诵为人演说。无人能得与作过失。若天。若天女。若龙若龙女。夜叉夜叉女。阿修罗阿修罗女。迦楼罗迦楼罗女。紧那罗紧那罗女。摩睺罗伽摩睺罗伽女。乾闼婆乾闼婆女。浮多浮多女。鸠槃荼鸠槃荼女。毗舍阇毗舍阇女。呜多罗呜多罗女。阿拔摩罗阿拔摩罗女。罗叉罗叉女。呜闼阿罗呜闼阿罗女。伽吒福单那伽吒福单那女。若人若非人。若人女非人女。彼一切不能得其过失。大慧。若有人能受持读诵此咒文句。彼人得名诵一切楞伽经。是故我说此陀罗尼句。为遮一切诸罗刹。护一切善男子善女人护持此经者

    入楞伽经卷第八

    入楞伽经卷第九
    元魏天竺三藏菩提留支译
    总品第十八之一
    尔时世尊。欲重宣此修多罗深义。而说偈言
如夏诸禽兽 迷惑心见波
诸禽兽爱水 彼水无实事
如是识种子 见诸境界动
诸愚痴众生 如眼[目*壹]见物
思惟可思惟 及离能思惟
见实谛分别 能知得解脱
是诸法非坚 虚妄分别生
虚妄分别空 依彼空分别
五阴识等法 如水中树影
如见幻梦等 识中莫分别
幻起尸机关 梦电云常尔
绝三相续法 众生得解脱
依诸邪念法 是故有识生
八九种种识 如水中诸波
依熏种子法 常坚固缚身
心流转境界 如铁依礠石
依止诸众生 真性离诸觉
远离诸作事 离知可知法
行如幻三昧 出诸十地行
汝观心王法 离心境识相
时知心常转 即住恒不变
住莲花宫殿 如幻境界相
住彼胜处已 得诸自在行
如摩尼现色 作度众生业
无有为无为 除诸分别心
愚痴无智取 如石女梦儿
寂静及无生 五阴人相续
因缘诸境界 空有及非有
我说诸方便 无如是实相
愚痴取实有 无能相可相
我觉一切法 而不觉一切
我有一切智 而无一切智
凡夫愚分别 自言世智者
我未曾觉知 亦不觉众生
一切法惟心 诸阴如毛轮
轮相毕竟无 何处有分别
本无始生物 诸缘中亦无
石女儿空华 若能见有为
尔时见可见 见迷法即住
我不入涅槃 不灭诸相业
灭诸分别识 此是我涅槃
非灭诸法相 愚痴妄分别
如瀑水竭尽 尔时波不生
如种种识灭 灭而不复生
空及无识相 如幻本不生
有无离有无 此诸法如梦
我说一实法 离于诸觉观
圣人妙境界 离二法体相
如见萤火相 种种而无实
世间见四大 种种亦如是
如依草木石 示现诸幻相
彼幻无是相 诸法体如是
无取着可取 无解脱无缚
如幻如阳焰 如梦眼中瞖
若如是实见 离诸分别垢
即住如实定 彼见我无疑
此中无心识 如虚空阳焰
如是知诸法 而不知一法
离有无诸缘 故诸法不生
三界心迷惑 是故种种见
梦及世间法 此二法平等
可见与资生 诸触及于量
身无常世间 种种色亦尔
世间尊者说 如是所作事
心三界种子 迷惑见现未
知世间分别 无如是实法
见世间如是 能离诸生死
生及与不生 愚痴迷惑见
不生及不灭 修智慧者见
阿迦尼妙境 离诸恶行处
常无分别行 离诸心数法
得力通自在 到诸三昧处
彼处成正觉 化佛此中成
诸法不生灭 诸法如是体
应化无量亿 彼体中出世
愚人闻佛法 如响不思议
远离初中后 及离有无法
遍不动清净 无诸相现相
识性覆法身 一切身中有
迷惑是幻有 幻非迷惑因
心无迷惑法 亦非不少有
心依二法缚 阿梨耶识起
但心如是见 我法如瀑水
观世间如是 尔时转诸心
乃是我真子 成就实法行
暖湿及坚动 愚分别诸法
非实专念有 无能相可相
八种物一身 形相及诸根
愚分别诸色 迷惑身罗网
诸因缘和合 愚痴分别生
不知如是法 流转三界中
诸法及言语 是众生分别
而诸法是无 如化如梦等
观诸法如是 不住世涅槃
心种种种子 现见心境界
可见分别生 愚痴乐二法
无智爱及业 是心心法因
依他力法生 故说他力法
依法分别事 心迷惑境界
故不成分别 迷惑邪分别
心依因缘缚 是故生诸身
若离诸因缘 我说不见法
离诸因缘法 离于诸法相
不住诸法中 我说不见境
如王长者等 以种种禽兽
会集宅野中 以示于诸子
我如是诸相 种种镜像法
内身智为子 说于实际法
如大海波浪 从风因缘生
能起舞现前 而无有断绝
阿梨耶识常 依风境界起
种种水波识 能舞生不绝
能取可取相 众生见如是
可见无诸相 毛道如是见
阿梨耶本识 意及于意识
离可取能取 我说如是相
五阴中无我 及无人众生
生即诸识生 灭即诸识灭
如画中高下 可见无如是
如是诸物体 见无如是相
如乾闼婆城 禽兽渴爱水
如是可见见 智观无如是
离可量及想 非因亦非果
离能觉所觉 离能见可见
依阴因缘觉 无人见可见
若不见可见 云何修彼法
因缘．因．譬喻 立意及因缘
梦．乾闼婆．轮 阳焰及日月
光焰幻等喻 我遮诸法生
如梦幻迷惑 空分别众生
不依于三界 内外亦皆无
见诸有不生 乃得无生忍
得如幻三昧 及于如意身
诸通及自在 力．心种种法
诸法本不生 空无法体相
彼人迷不觉 随因缘生灭
如愚痴分别 心见于自心
见外种种相 实无可见法
见骨相佛像 及诸大离散
善觉心能知 住持世间相
身住持资生 可取三种境
识取识境界 意．识．分别三
分别可分别 所有字境界
不能见实法 彼觉迷不见
诸法无自体 智慧者能觉
行者尔乃息 住于无相处
如墨图于鸡 愚取是我鸡
如痴凡夫取 三乘同是一
无诸声闻人 亦无辟支佛
所见声闻色 及见诸如来
诸菩萨大慈 示现是化身
三界唯是心 离二种体相
转变彼诸相 彼即是真如
法及人行相 日月光焰炽
大诸摩尼宝 无分别作事
诸佛法如是 如瞖取毛轮
如是分别法 愚痴虚妄取
离于生住灭 及离常无常
可见染净去 如空中毛轮
如中莨菪人 见诸像大地
一切如金色 彼不曾有金
如是愚痴人 无始心法染
幻阳焰生有 愚人取为实
一子及无子 大海是一子
亦是无量子 汝观心种子
一子如清净 转于无种子
平等无分别 起即是生死
能生种种子 是故说种子
因缘不生法 因缘不灭法
生法惟因缘 心如是分别
三界惟假名 实无事法体
妄觉者分别 取假名为实
观诸法实体 我不遮迷惑
实体不生法 观是得解脱
我不见幻无 说诸法是有
颠倒速如电 是故说如幻
非本生如生 诸因缘无体
无有处及体 惟有于言语
不遮缘生灭 不遮缘和合
遮诸愚痴见 分别因缘生
实无识体法 无事及本识
愚痴生分别 如死尸恶觉
三界但是心 诸佛子能见
即得种类身 离作有为法
得力通自在 及共相应法
现诸一切色 心法如是生
而无心及色 无始心迷惑
尔时修行者 得见于无相
智慧中观察 不见诸众生
相及事假名 意取诸动法
我诸子过是 无分别修行
乾闼婆城幻 毛轮及阳焰
无实而见实 诸法体如是
如心见诸法 无如是体相
一切法不生 但见迷惑法
毛道迷分别 以住于二法
初识生分别 种种熏种子
识如瀑水起 断彼则不生
种种念观法 若但心中生
如虚空壁中 何故而不生
若有少相观 心则从缘生
若从因缘生 不得言惟心
心取于自心 无法无因生
心法体清净 虚空中无熏
虚妄取自心 是故心现生
外法无可见 是故说惟心
本识但是心 意能念境界
能取诸境界 故我说惟心
心常无记法 意二边取相
取现法是识 彼是善不善
离二种识相 是第一义门
说三乘差别 寂静无是相
若心住寂静 及行于佛地
是过去佛说 现未亦如是
初七是心地 寂静第八地
二地是行处 余地是我法
自内身清净 是我自在地
自在究竟处 阿迦尼吒现
如诸火焰等 而出诸光明
种种心可乐 化作于三界
或有先有化 而化作三有
彼处说诸法 是我自在地
诸地无时节 国土转亦然
过诸心地法 是住寂静果
实无而谓实 而见于种种
愚人颠倒取 是种种颠倒
如无分别智 有事不相应
以心非诸色 是故无分别
诸禅及无量 及无色三昧
诸相毕竟灭 是故心中无
须陀洹果法 往来及不还
及诸罗汉果 一切心迷惑
空无常刹那 愚分别有为
河种子譬喻 分别刹那义
刹那无分别 离诸所作法
一切法不生 我说刹那义
有无说于生 僧佉等妄说
一切法无说 亦是彼人说
◎有四种记法 一往答反问
分别差别答 默答遮外道
世谛一切有 第一义谛无
而实体无相 是第一义谛
见于虚妄法 是故说世谛
因于言语生 无如是实体
无事有言语 世谛中实无
是即颠倒事 可见亦是无
若事颠倒有 寂静毕竟无
依于颠倒事 及见诸法生
毕竟定是无 即是无体相
所见诸种种 熏习烦恼生
心见外迷惑 现取于前境
分别无分别 是空实相法
如幻像诸相 如树叶金色
是可见人见 心无明熏习
圣人不见迷 中间不见实
迷惑即是实 以实即中间
远离诸迷惑 若能生诸相
即是其迷惑 如眼瞖不净
如瞖见毛轮 依迷取诸法
于诸境界中 愚痴取是法
诸法如毛轮 阳炎水迷惑
三界如梦幻 修行得解脱
分别可分别 能生于分别
缚可缚及因 六种解脱因
无地及诸谛 无国土及化
佛辟支声闻 惟是心分别
人体及五阴 诸缘及微尘
胜人自在作 惟是心分别
心遍一切处 一切处皆心
以心不善观 心性无诸相
五阴中无我 我中无五阴
分别无是法 而彼法非无
如愚痴分别 有诸一切法
如是见实有 一切应见实
一切法若无 无染亦无净
愚痴见如是 彼法不如是
迷惑分别相 是他力分别
彼相所有名 是名分别相
名相是分别 因缘事和合
若不生彼心 是第一义相
报相佛实体 及所化佛相
众生及菩萨 并十方国土
习气法化佛 及作于化佛
是皆一切从 阿弥陀国出
应化所说法 及报佛说法
修多罗广说 汝应知密意
所有佛子说 及于诸如来
是皆化佛说 非淳熟者说
是诸法不生 而彼法非无
乾闼婆城幻 如梦化相似
种种随心转 惟心非余法
心生种种生 心灭种种灭
众生妄分别 无物而见物
无义惟是心 无分别得脱
无始世戏论 依止于烦恼
诸分别熏修 是故邪见生
识无分别义 真如是智境
转彼是寂静 是诸圣境界
观察义思惟 诸凡夫思惟
念真如思惟 诸佛净思惟
分别诸法体 一切法不生
依他力因缘 众生迷分别
他力若清净 离分别相应
转彼即真如 离分别是行
莫分别分别 分别是无实
分别迷惑法 取可取不尽
见外分别境 分别是实体
心分别分别 彼法因缘生
邪见见外义 无义但是心
观斟量相应 能灭取可取
无诸外境界 愚痴妄分别
熏习增长心 似生于诸法
灭二种分别 真如智境界
生于无法相 不思议圣境
名相及分别 实体二种相
正智及真如 是成就实体
依父母和合 阿梨耶意合
如苏瓶等鼠 共赤白增长
辟尸厚泡疮 不净依节画
业风长四大 如诸果成熟
五及于五五 及有九种孔
诸毛甲遍覆 如是增长生
生如粪中虫 如人睡中寤
眼见色起念 增长生分别
分别及专念 断齿唇和合
口始说言语 如鹦鹉弄声
诸外道说定 大乘不决定
依众生心定 邪见不能近
我乘内证智 妄觉非境界
如来灭世后 谁持为我说
如来灭度后 未来当有人
大慧汝谛听 有人持我法
于南大国中 有大德比丘
名龙树菩萨 能破有无见
为人说我法 大乘无上法
证得欢喜地 往生安乐国
智慧观察法 不见实法体
是故不可说 及说亦无体
若因缘生法 不得言有无
因缘中有物 愚分别有无
邪见二邪法 我知离我法
一切法名字 无量劫常学
以学复更学 迭共相分别
若不说诸名 诸世间迷惑
是故作名字 为除迷惑业
依三种分别 愚痴分别法
依名迷分别 及因缘能生
法不灭不生 自性如虚空
法无体是体 分别相即体
影像及于幻 阳焰与梦响
火轮乾闼婆 诸法如是生
不二真如空 实际及法体
我说无分别 成就彼法相
口心境界虚 实乃立虚妄
心堕于二边 是故立分别
有无堕二边 以在心境界
远离诸境界 尔时正灭心
以离取境界 彼灭非有无
如圣人境界 愚人不能知
有灭住真如 智慧者能见
如彼诸法住 智慧者能见
法体不如是 以诸法无相
愚痴人见铁 分别以为金
非金而见金 外道取法尔
本无言始生 始生后还灭
从因缘有无 此说非我教
无始无终法 无始是相住
以世间住相 邪觉者不知
过去法是有 未来法非无
现在法亦有 不应言法生
转时及行相 诸大及诸根
虚妄取中阴 若取非觉者
一切佛世尊 不说因缘生
因缘即世间 如乾闼婆城
但法缘和合 依此法生法
离诸和合法 不灭亦不生
镜及于水中 眼及器摩尼
而见诸镜像 诸影像是无
如兽爱空水 见诸种种色
种种似如有 如梦石女儿
我乘非大乘 非声亦非字
非谛非解脱 非寂静境界
而我乘大乘 诸三昧自在
身如意种种 自在花庄严
一体及别体 因缘中无法
略说诸法生 广说诸法灭
不生空是一 而生空是二
不生空是胜 生灭即是空
真如空实际 涅槃与法界
身及意种种 我说异名法
经毗尼毗昙 分别我清净
依名不依义 彼不知无我
非外道非佛 非我亦非余
从缘成有法 云何无诸法
何人成就有 从因缘说无
说法生邪见 有无妄分别
若人见不生 亦见法不灭
彼人离有无 见世间寂静
众生分别见 可见如兔角
分别是迷惑 如禽爱阳焰
虚妄分别法 依彼分别见
无因缘分别 无因不应分
无水而取水 如兽妄生爱
愚痴如是见 圣者无如是
圣人见清净 以生三解脱
离诸生死法 修行寂静处
深快妙方便 知国土妙事
我为诸子说 不为诸小乘
三有是无常 空无我离我
同相及别相 我为声闻说
不着一切法 离世间独行
我说缘觉果 非思量境界
分别外实体 从他力故生
见自身迷惑 尔时转诸心
十地即初地 初地即八地
九地即七地 七地即八地
二地即三地 四地即五地
三地即六地 寂静无次第
诸法常寂静 修行者无法
有无法平等 尔时圣得果
诸法无体相 云何于无法
而能作平等 寂寂无分别
若不见诸心 内及外动法
尔时灭诸法 已见平等心
愚无始流转 取法如怀抱
诳凡夫而转 如因榍出榍
依彼因及观 共意取境界
依于识种子 能作于心因
修得及住持 随种类身得
及梦中所得 是通有四种
梦中所得通 及于诸佛恩
取种类身得 彼通非实通
熏种子熏心 似有法生转
愚人不觉知 为说生诸法
分别于外物 诸法相成就
尔时心闷没 不见自迷惑
何故说于生 何故说无见
不可见而见 愿必为我说
为于何等人 说何等法有
为于何等人 说何等法无
心体自清净 意起共诸浊
意及一切识 能作熏种子
阿梨耶出身 意出求诸法
意识取境界 迷惑见贪取
自心所见法 外法无外法
如是观迷惑 常忆念真如
修禅者境界 业诸佛大事
此三不思议 是智者境界
过现及未来 涅槃及虚空
我依世谛说 真谛无名字
二乘及外道 等着于邪见
迷没于心中 分别于外法
缘觉佛菩提 罗汉见诸佛
菩提坚种子 及梦中成就
何处为何等 云何为何因
所为为何义 惟愿为我说
幻心去寂静 有无朋党说
心中迷坚固 说有幻无幻
生灭相相应 相可相有无
分别惟是意 共于五种识
镜像水波等 从心种子生
若心及于意 而诸识不生
时得如意身 乃至于佛地
诸缘及阴界 是法自体相
假名及人心 如梦如毛轮
世间如幻梦 见依止得实
诸相实相应 离诸斟量因
诸圣人内境 常观诸妙行
迷覆斟量因 令世间实解
离一切戏论 智不住迷惑
诸法无体相 空及常无常
心住于愚痴 迷惑故分别
说是诸法者 非说于无生
一二及于二 忽然自在有
依时胜微尘 缘分别世间
世种子是识 依止彼因生
如依壁画像 知实即是灭
如人见于幻 见生死亦尔
愚痴人依闇 缚及解脱生
内外诸种种 诸法及因缘
如是观修行 住于寂静处
熏习中无心 心不共熏习
心无差别相 熏习缠于心
如垢见熏习 意从于识生
◎如帛心亦尔 依熏习不显
如物非无物 我说虚空然
阿梨耶身中 离于有无物
意识转灭已 心离于浊法
觉知一切法 故我说心佛
断绝于三世 离于有无法
世法四相应 诸有悉如幻
是二法体相 七地从心生
余地亦成就 二地及佛地
色界及无色 欲界及涅槃
一切心境界 不离于身中
若见诸法生 是生迷惑法
觉自心迷惑 是不生诸法
无生法体相 生即着世间
见诸相如幻 法体相如是
自心虚妄取 莫分别诸法
为痴无智说 三乘与一乘
及说于无乘 诸圣人寂静
我法有二种 相法及于证
四种斟量相 立量相应法
形及相胜种 见迷惑分别
名字及行处 圣行实清净
依分别分别 故有分别相
离分别分别 实体圣境界
常恒实不变 性事及实体
真如离心法 远离于分别
若无清净法 亦无有于染
以有清净心 而见有染法
清净圣境界 是故无实事
是诸法体相 圣人之境界
从因生世间 离于诸分别
如幻与梦等 见法得解脱
烦恼熏种种 共心相应生
众生见外境 非诸心法体
心法常清净 非是迷惑生
迷从烦恼起 是故心不见
迷惑即真实 余处不可得
非阴非余处 观阴行如实
离见能见相 若见有为法
见自心世间 彼人能离相
莫见惟心法 莫分别外义
住于真如观 过于心境界
过心境界已 远离诸寂静
修行住寂静 行者寂静住
不见摩诃衍 自然云寂静
依诸愿清净 智无我寂静
应观心境界 亦观智境界
智慧观境界 不迷于相中
心境界苦谛 智境界是集
二谛及佛地 是般若境界
得果及涅槃 及于八圣道
觉知一切法 得清净佛智
眼色及于明 虚空与心意
如是等和合 识从梨耶生
能取可取受 无名亦无事
无因分别者 若取于觉者
于义中无名 名中义亦尔
因无因而生 莫分别分别
一切法无实 言语亦复然
空不空义尔 愚痴见法是
妄取于实住 邪见说假名
一法成五种 如实能远离
五种是魔法 超越过有无
非修行境界 是外道之法
不求有邪法 亦无相见我
以作自常法 惟从言语生
实谛不可说 寂灭见诸法
依止阿梨耶 能转生意识
依止依心意 能生于转识
依虚虚妄成 真如是心法
如是修行者 能知心性体
分别常无常 意相及于事
生及与不生 行者不应取
莫分别二法 识从梨耶生
一义二心生 不知如是生
取一二之法 是凡夫境界
无说者及说 不空以见心
不见于自心 故生见罗网
诸因缘不生 诸根亦如是
界及五阴无 无贪无有为
本无有作业 不作非有为
无除亦无缚 无缚无解脱
无无记无物 无法无非法
无时无涅槃 法体亦是无
无佛无实谛 无因亦无果
无颠倒无灭 无灭亦无生
十二支亦无 边无边亦尔
离于诸邪见 是故说惟心
烦恼业及身 作者与果报
如阳焰及梦 乾闼婆城等
住于心法中 而生诸法相
住于心法中 而见于断常
涅槃中无阴 无我亦无相
能入惟是心 解脱不取相
见他何过失 诸众生见外
心非有非无 由熏习不显
垢中不见白 白中不见垢
如云盖虚空 是故心不见
心能作诸业 智于中分别
慧能观寂静 得大妙法体
心依境界缚 智依觉观生
寂静胜境界 慧能于中行
心意及意识 于相中分别
得无分别体 二乘非诸子
寂静胜人相 诸佛智慧净
能生于胜义 已离诸行相
分别法体有 他力法是无
迷惑取分别 不分别他力
非诸大有色 有色非诸大
梦幻乾闼婆 兽渴爱无水
我有三种慧 得止依圣名
心无法中生 是故心不见
身资生住持 众生依熏见
依彼分别相 而说于诸法
离二乘相应 慧离现法相
虚妄取法故 声闻见于法
能入惟是心 如来智无垢
若实及不实 从因缘生法
一二是取见 毕竟能取着
种种诸因缘 如幻无有实
如是相种种 不能成分别
依于烦恼相 诸缚从心生
不知分别法 他力是分别
所有分别体 即是他力法
种种分别见 于他力分别
世谛第一义 第三无因生
分别说相续 断即圣境界
修行者一事 惟心种种见
彼处无心体 如是分别相
如人眼中瞖 分别种种色
瞖非色非色 愚见他力尔
如金离尘垢 如水离泥浊
如虚空离云 如是净分别
声闻有三种 应化及愿生
离诸贪痴垢 声闻从法生
菩萨亦三种 诸如来无相
众生心心中 见佛如来像
分别无如是 他力法体有
见有无二边 见故见分别
若无分别法 他力云何有
远离有法体 实有法体生
依止于分别 而见于他力
依名相和合 而生于分别
常无所成就 他力分别生
尔时知清净 第一义实体
分别有十种 他力有六种
真如是内身 是故无异相
五法是实法 及三种实相
如是修行者 不坏真如法
星宿云形像 似于日月体
诸众生见心 可见熏集生
诸大无自体 非能见可见
若色从大生 诸大生诸大
如是不生大 大中无四大
若果是四大 因是地水等
实及假名色 幻生作亦尔
梦及乾闼婆 兽爱水第五
一阐提五种 诸性亦如是
五乘及非乘 涅槃有六种
阴有二十四 色复有八种
佛有二十四 佛子有二种
度门有百种 声闻有三种
诸佛国土一 而佛亦有一
解脱有三种 心虑有四种
我无我六种 可知境四种
离于诸因缘 亦离邪见过
知内身离垢 大乘无上法
生及于不生 有八种九种
一时证次第 立法惟是一
无色有八种 禅差别六种
缘觉及佛子 能取有七种
无有三世法 常无常亦尔
作及于业果 如梦中作事
佛从来不生 声闻佛子尔
心离于可见 亦常如幻法
胎生转法轮 出家及兜率
住诸国土中 可见而不生
去行及众生 说法及涅槃
实谛国土觉 从因缘生法
世间诸树林 无我外道行
禅乘阿梨耶 证果不思议
月及星宿性 诸王阿修罗
夜叉乾闼婆 因业而发生
不可思议变 退依熏习缘
断绝诸变易 时烦恼罪灭
一切诸菩萨 如实修行者
不畜诸财宝 金银及象马
牛羊奴婢等 米谷与田宅
不卧穿孔床 不得泥涂地
金银赤白铜 钵盂及诸器
修行净行者 一切不得畜
憍奢耶衣服 一切不得着
钦婆罗袈裟 牛粪草果叶
青赤泥土汁 染坏于白色
石泥及与铁 珂及于琉璃
如是钵听畜 满足摩陀量
为割截衣故 听畜四寸刀
刃如半月曲 不得学伎术
如实修行人 不得市贩卖
所须倩白衣 及诸优婆塞
常护于诸根 知于如实义
读诵修多罗 及学诸毗尼
不与白衣杂 修行人如是
空处与冢间 窟中林树下
尸陀林草中 乃至于露地
如实修行人 应住如是处
三衣常随身 不畜余钱财
为身须衣服 他自与听受
为乞食出行 亦不左右视
视前六尺地 安庠而直进
如蜂采诸花 乞食亦如是
比丘比丘尼 众中众所杂
我为佛子说 此是恶命活
如实修行者 不听此处食
王小王王子 大臣及长者
为求于饮食 一切不得往
死家及生家 亲家及爱家
比丘杂等众 修行者不食
寺舍烟不断 常作种种食
故为人所作 行者不应食
离有无朋党 能见可见缚
行者观世间 离于生灭法
三昧力相应 及诸通自在
若不生分别 不久得如法
从微尘胜人 缘中莫分别
诸因缘和合 行者不分别
分别诸世间 种种从熏生
行者如实观 三有如幻梦
莫分别三有 身资生住持
离于有无谤 亦离有无见
饮食如服药 身心常正直
一心专恭敬 佛及诸菩萨
如实修行者 应知诸律相
及诸修多罗 简择诸法相
五法体及心 修行无我相
清净内法身 诸地及佛地
如是修行者 住于大莲花
诸佛大慈悲 如意手摩顶
去来于六道 诸有生厌心
发起如实行 至尸陀林中
日月形体相 及于花海相
虚空火种种 修行者见法
见如是诸相 取于外道法
亦随声闻道 及缘觉境界
远离如是等 住于寂静处
时佛妙光明 往于诸国土
摩彼菩萨顶 此摩顶妙相
随顺真如法 尔时得妙身
有无因法体 离于断常法
谤于有无法 是分别中道
分别无诸因 无因是断见
见种种外法 是人灭中道
不舍诸法相 恐有断绝相
有无是谤法 如是说中道
觉但是内心 不灭于外法
转虚妄分别 即是中道法
惟心无可见 离于心不生
即是中道法 我及诸佛说
生及于不生 有物无物空
诸法无自体 莫分别二法
分别是有法 愚分别解脱
不觉心分别 离于二取相
觉知自心见 时离于二见
如实知远离 不灭分别相
实知可见心 时知分别生
不生诸分别 是真如离心
离诸外道过 若见生诸法
彼智者应取 涅槃而不灭
知此法是佛 我说及余佛
若异见诸法 是说外道事
不生现于生 不退常现退
同时如水月 万亿国土见
一身及无量 然火及注雨
心心体不异 故说但是心
心中但是心 心无心而生
种种色形相 所见惟是心
佛及声闻身 辟支佛身等
复种种色身 但说是内心
无色界无色 色界及地狱
色现为众生 但是心因缘
如幻三昧法 而身如意生
十地心自在 菩萨转得彼
自心分别名 戏论而摇动
依见闻生知 愚痴依相知
相是他力体 彼依名分别
分别是诸相 依他力法生
智慧观诸法 无他力无相
毕竟无成就 智依何分别
若有成就法 离于有无法
离于有无体 二体云何有
分别二种体 二种体应有
分别见种种 清净圣境界
分别是种种 分别是他力
若异分别者 是堕外道说
分别是分别 见是因体相
分别说分别 见是因相生
离于二分别 即是成就法
国土佛化身 一乘及三乘
无涅槃一切 空离一切生
佛三十差别 别复有十种
一切国土器 依诸众生心
如分别法相 现见种种法
彼法无种种 法佛世间尔
法佛是真佛 余者依彼化
众生自种子 见一切佛相
依迷惑转心 能生于分别
真不离分别 及不离于相
实体及受乐 化复作诸化
佛众三十六 是诸佛实体
如青赤及盐 珂乳及石蜜
新果诸花等 如月诸光明
非一亦非异 如水中洪波
如是七识种 共于心和合
如大海转变 是故波种种
阿梨耶亦尔 名识亦如是
心意及意识 分别外相义
八无差别相 非能见可见
如大海水波 无有差别相
诸识于心中 转变不可得
心能造诸业 意是能分别
意识能知法 五识虚妄见
青赤白种种 众生识现见
水波相对法 牟尼为我说
青赤白种种 水波中无是
愚痴见诸相 说于心中转
心中无是体 离心无外见
若有于可取 应有于能取
身资生住持 说水波相似
众生识现见 水波共相似
大海水波起 如舞转现见
本识如是转 何故知不取
愚痴无智慧 本识如海波
水波转相对 是故说譬喻
如日出世间 平等照众生
如是世尊灯 不为愚说法
住于真如法 何故不说实
若说于实法 心中无实法
如海中水波 如镜及于梦
如自心境界 等见无前后
无一时境界 是故次第生
识能知诸法 意复能分别
五识现见法 寂静无次第
如世间画师 及画师弟子
我住于妙法 为实修行说
离分别分别 是内身实智
我诸佛子说 不为于愚人
亦如幻种种 可见无如是
说种种亦尔 说亦尔不尔
为一人说法 不为余人说
如人病不同 医师处药别
诸佛为众生 随心说诸法
依外法种子 分别说现法
心取他力法 可取是分别
依止心种子 观取外境界
二种转迷惑 更无第三因
以迷惑不生 依何法不生
六十十八法 是故惟说心
自心见外法 见彼离于我
若入心分别 能离诸法相
依于阿梨耶 能生于诸识
愚痴内身入 心见于外入
取星宿毛轮 如梦中见色
有为无为常 分别无如是
乾闼婆城幻 如禽兽爱水
无如是见有 他力法亦尔
我诸根形相 我说三种心
心意及意识 离于自体相
心意及意识 离于他体相
心意及意识 无我无二体
五法自体相 是诸佛境界
就相有三种 依于一熏因
如彩色一种 壁上见种种
二种无我心 意及诸识相
五种法体相 我性无如是
远离诸心相 识离于意相
诸法体如是 是我之境界
离于诸法体 是诸如来性
身口及意业 彼不作白法
如来性清净 离于诸修行
自在净诸通 三昧力庄严
种种意生身 是净如来性
内身智离垢 离于诸因相
八地及佛地 是诸如来性
远行善慧地 法云与佛地
是诸佛之性 余地三乘杂
依众生身别 及为愚痴相
为说七种地 故佛说心地
口身心诸障 七地中无是
八地中妙身 如梦瀑水相
八地及五地 学种种伎术
一切诸佛子 三有中作王
生及与不生 不分空不空
实及于不实 心中无如是
此实此非实 莫分别此实
缘觉及声闻 非为佛子说
有无有非实 亦无有空相
假名及实法 心中一切无
依世谛有法 第一义悉无
无实法迷惑 是诸世谛法
一切法无法 我说于假名
言语及受用 愚痴见是实
从于言语法 是实有境界
从言语生法 见法无如是
如离壁无画 亦如影离像
本净识亦尔 为水波不现
如幻心亦尔 意如狡猾者
识共于五种 分别见如采
说是真法习 所有集作化
是诸佛根本 余者应化佛
心迷可见中 可见心中无
身资生住持 即阿梨耶现
心意及意识 实体五种法
二种无我净 诸佛如来说
虚妄觉非境 及声闻亦尔
是内身境界 诸佛如来说
长短等相待 彼此相依生
有能成于无 无能成于有
及分别微尘 色体不分别
说但是于心 邪见不能净
是中分别空 不空亦如是
有无但分别 可说无如是
功德微尘合 愚痴分别色
一一微尘无 是故无是义
自心见形相 众生见外有
外无可见法 是故无是义
心如毛轮幻 梦乾闼婆城
火轮禽兽爱 实无而人见
常无常及一 二及于不二
无始过所缚 愚痴迷分别
我不说三乘 但说于一乘
为摄取众生 是故说一乘
解脱有三种 亦说法无我
平等智烦恼 依解脱分别
亦如水中木 为波之所漂
如是痴声闻 为诸相漂荡
彼无究竟处 亦复不还生
得寂灭三昧 无量劫不觉
是声闻之定 非我诸菩萨
离诸随烦恼 依习烦恼缚
三昧乐境醉 住彼无漏界
如世间醉人 酒消然后寤
彼人然后得 我佛法身体
如众没深泥 身东西动摇
如是三昧醉 声闻没亦尔

    入楞伽经卷第九

    入楞伽经卷第十
    元魏天竺三藏菩提留支译
    总品第十八之二
依诸佛住持 诸愿力清净
受职及三昧 功德及十地
虚空及兔角 及与石女儿
分别法如是 无而说名字
因熏种世间 非有非无处
能见得解脱 解于法无我
实体分别名 他体从因生
我说是成就 诸经常说是
字句名身等 于名身胜法
愚痴人分别 如象没深泥
天乘及梵乘 及于声闻乘
如来及缘觉 我说如是乘
诸乘不可尽 有心如是生
心转灭亦无 无乘及乘者
心分别及识 意及于意识
阿梨耶三有 思惟心异名
命及于暖识 阿梨耶命根
意及于意识 是分别异名
心住持于身 意常觉诸法
识自心境界 共于识分别
我说爱是母 无明以为父
识觉诸境界 是故说名佛
诸使是怨家 众和合是阴
无于相续体 断彼名无间
二无我烦恼 及二种无我
不可思议变 无生死名佛
意相应法体 我法是内身
若能如是见 彼不随妄觉
实无于诸法 如愚痴分别
依虚妄无法 云何得解脱
生灭和合缚 见于有为法
增长于二见 不失因缘法
芭蕉梦幻等 是世间如是
惟是一法实 涅槃离意识
有贪及与嗔 及有痴无人
从爱生诸阴 阴有亦如梦
何等夜证法 何等夜入灭
于此二中间 我不说一字
内身证于法 我依如是说
彼佛及我身 无有说胜法
实有神我物 五阴离彼相
阴体是实有 彼阴中无我
各各见分别 随烦恼及使
得世间自心 离苦得解脱
诸因及因缘 世间如是生
是四法相应 彼不住我教
非有无生法 离有无不生
愚云何分别 从因及诸缘
有无四句离 若能见世间
尔时转心识 即得无我法
诸法本不生 是故因缘生
诸缘即是果 果中生于有
果中生二种 果中应有二
而二中无果 果中不见物
离于观可观 若见有为法
离心惟是心 故我说惟心
量实体形相 离于缘实体
究竟第一净 我说如是量
如假名为我 无实法可见
如是阴阴体 是假名非实
平等有四种 相因及于生
无我亦平等 四修行者法
转诸一切见 分别可分别
不见及不生 故我说惟心
无法亦非无 离于有无体
真如离于心 故我说惟心
真如空实际 涅槃及法界
意生身及心 故我说惟心
分别依熏习 种种生种种
众生心见外 故我说惟心
可见无外物 见心种种见
身资生住持 故我说惟心
诸声闻尽智 诸佛如来生
一切辟支佛 无和合而生
无外诸色相 自心见外法
觉知于自心 愚分别有为
愚人不知外 自心种种见
譬喻遮愚人 着于四种法
无因无分别 譬喻五种论
自心体形相 能知是黠慧
依分别可别 此是分别相
依止于分别 分别于现生
一一别和合 是一种子因
客二法是二 故人心不生
分别心心法 住于二界中
现生于诸法 彼体是虚妄
因依现和合 故有十二入
依因观和合 我不说是法
如镜中见僧 眼[目*壹]见毛轮
如是依熏心 愚痴人心见
共分别可别 而生于分别
如外道分别 无如是外相
如人不识绳 而取以为蛇
不识自心义 分别于外法
而乘于乘体 离于一二中
以分别于乘 是自心过失
依何法何体 分别不能见
不得言彼无 诸法体如是
依有故言无 依无故言有
故不得言无 亦不得言有
即分别分别 此非彼法体
云何见无体 而生于分别
色体无色身 如瓶及叠等
可见是无法 云何有分别
若分别是迷 有为法无始
何法迷众生 牟尼为我说
诸法无法体 而说惟是心
不见于自心 而起于分别
若分别是无 如愚痴分别
彼法无异体 而智不能觉
若圣有彼法 非凡妄分别
若圣妄有彼 圣愚痴无别
圣人无迷惑 以得心清净
愚人无信心 故分别分别
如母为诸子 虚空将果来
汝取果莫啼 儿取种种果
我于诸众生 分别种种果
令贪种种说 离有无朋党
若本无法体 非因非从因
本不生始生 亦无其身体
无身亦非生 离因缘无处
生灭诸法体 离因缘处无
略观察如是 有无非余处
从因缘生法 智者莫分别
说一体二体 外道愚痴说
世间如幻梦 不从因缘生
依言语境界 大乘无上法
我依了义说 而愚痴不觉
声闻及外道 依嫉妒说法
于义不相应 以依妄觉说
相体及形相 名是四种法
观于如是法 故生于分别
分别一二多 彼随梵天缚
日月及诸天 是见非我子
圣人见正法 以如实修行
能转虚妄相 亦离于去来
此是解脱印 我教诸佛子
离于有无法 亦离去来相
转种种色识 若灭一切业
不应常无常 无世间生法
于转时若灭 色离于彼处
离于无过失 业住阿梨耶
色是灭体相 识中有亦尔
色识共和合 而不失诸业
若共彼和合 众生失诸业
若灭和合业 无缚无涅槃
若共于彼灭 生于世间中
色亦共和合 无差别应有
有别亦无别 但是心分别
诸法无灭体 离有无朋党
假名因缘法 迭共无差别
如色中无常 迭共生诸法
离于彼此相 分别不可知
无有有何成 如色中无常
若善见分别 即不起他力
是于他力法 亦不起分别
若灭于分别 是灭于我法
于我法中作 亦谤于有无
是诸谤法人 于何时中有
是灭我法轮 不得共彼语
智者不共语 不共比丘法
已灭于分别 妄见离有无
见如毛轮幻 如梦乾闼婆
亦见如阳焰 时见于有无
彼人不觉佛 若有人摄彼
彼人堕二边 亦坏于余人
若知寂静法 是实修行者
离于有无法 应摄取彼人
如有处可出 金银诸珍宝
无业作种种 而众生受用
众生真如性 不由于业有
不见故无业 亦非作业生
诸法无法体 如圣人分别
而有于诸法 如愚痴分别
若法无如是 如愚痴分别
无有一切法 众生亦无染
诸法依心有 烦恼亦如是
生死诸世间 随于诸根转
无明爱和合 而生于诸身
余人恒无法 如愚痴分别
若人法不生 行者不见根
若诸法是无 能作世间因
愚人离于作 自然应解脱
愚圣无差别 有无云何成
圣人无法体 以修三解脱
五阴及人法 有同有异相
诸因缘及根 我为声闻说
无因惟于心 妙事及诸地
内身真如净 为诸佛子说
于未来世有 谤于我法轮
身披于袈裟 说有无诸法
无法因缘有 是圣人境界
分别无法体 妄觉者分别
未来世有人 啖糠愚痴种
无因而邪见 破坏世间人
从微尘生世 而微尘无因
九种物是常 邪见如是说
从物生于物 功德生功德
此法异于法 分别是体是
若本无始生 世间应有本
我说于世间 无有于本际
三界诸众生 是本无始生
狗驼驴无角 必应生无疑
眼本无始有 色及识亦尔
席冠白叠等 泥团中应生
于叠中无瓶 蒲中亦无叠
一于一中实 何故因不生
即命即是身 是本无始生
此是他说法 我说诸法异
我领因缘法 然后遮他法
遮彼邪见者 后说于自法
故领外道法 然后说正法
恐诸弟子迷 立于有无法
从胜人生世 迦毗罗恶意
为诸弟子说 诸功德转变
非实非不实 非从缘即缘
以无诸因缘 无实法不生
离于有无法 离因亦离缘
离于生灭法 自法离可见
世间如幻梦 离诸因缘法
立因缘者见 是故生分别
如禽兽爱水 乾闼婆毛轮
离于有无法 离因及于缘
见三有无因 如是见净心
何等人无事 但有于内心
远离于心事 不得说惟心
若观于外事 众生起于心
云何心无因 不得说惟心
真如惟心有 何人无圣法
有及于非有 彼不解我法
能取可取法 若心如是生
此是世间心 不应说惟心
身资生住持 若如梦中生
应有二种心 而心无二相
如刀不自割 指亦不自指
如心不自见 其事亦如是
非他非因缘 分别分别事
五法及二心 寂静无如是
能生及于生 及二种法相
我意无能生 说法无自相
种种形相体 若生于分别
虚空兔角等 彼体无应生
若有诸法相 应有于外事
以无外分别 离心更无法
于无始世间 无有外诸法
以心无生因 而见于外义
若无因生长 兔角亦应生
以无因增长 云何生分别
如现在无法 如是本亦无
无体体和合 云何心能生
真如空实际 涅槃及法界
一切诸法生 是第一义法
凡夫堕有无 分别因及缘
无因本不生 不知于三有
心见于可见 无始因异见
无始亦无法 云何见异生
若无物能生 贫人应多财
云何生无物 牟尼为我说
此一切无心 而不无诸法
乾闼婆梦幻 诸法无因有
无生无体相 空法为我说
离于和合法 是不见诸法
尔时空无生 我说无法相
梦及毛轮幻 乾闼婆爱水
无因而有见 世间法亦尔
如是和合一 离于可见无
非诸外道见 和合无如是
降伏依无因 成就于无生
若能成无生 我法轮不灭
说于无因相 外道生怖畏
云何为何人 何处来诸法
何处生于法 无因而生法
生于无因中 而无于二因
若能智者见 尔时转邪见
说生一切法 无生为无物
为观诸因缘 尔时转邪见
为有法有名 为无法无名
而无法不生 亦非待因缘
名非依于法 而名非无体
声闻辟支佛 外道非境界
住七地菩萨 彼则无生相
转于因缘法 是故遮因义
惟说依于心 故我说无生
无因生诸法 离分别分别
离立于有无 故我说无生
心离于可见 亦离于二体
转于依止法 故我说无生
不失外法体 亦不取内心
离一切邪见 此是无生相
如是空无相 一切应观察
非生空空法 本不生是空
诸因缘和合 生及与于灭
离于和合法 不生亦不灭
若离和合法 更无实法体
一体及异体 如外道分别
有无不生法 非实生不生
离于诸因缘 生及与不生
惟是于名字 彼此迭共锁
可生体毕无 差别因缘锁
离可生无生 是离诸外道
我说惟是锁 而凡夫不知
而可生法体 离锁更无别
彼人无说因 破灭坏诸锁
如灯了诸物 锁亦应能了
若更有别法 离于钩锁体
无体亦不生 自性如虚空
离于钩锁法 愚痴异分别
此是异不生 圣人所得法
彼法生不生 不生是无生
若见诸世间 即是缘钩锁
世谁是钩锁 尔时心得定
无明爱业等 是内钩锁法
幢泥团轮等 子四大外法
依于他法体 是从因缘生
非惟钩锁体 不住量阿含
若可生法无 智何法为因
彼法迭共生 非是诸因缘
暖湿动及坚 愚痴分别法
此钩锁无法 是故无体相
如医师依病 说治病差别
而论无差别 依病故差别
我依众生身 为说烦恼浊
知诸根及力 我为愚法说
烦恼根差别 我教无差别
我惟有一乘 清凉八圣道
瓶叠冠及角 兔角无是因
无因依彼生 而无彼因法
而彼是无法 汝不得取无
依有因故无 依无不相应
有法对于无 是共相待法
若依少有法 见于少有法
无因见少法 少法是无因
若彼依余法 彼此迭共见
如是无穷过 少亦无少体
依于色木等 如幻可见法
如是依止事 人见有种种
幻师非色等 非木亦非石
愚痴见如幻 依止于幻身
依止于实事 若见于少事
见时无二法 云何见少事
分别无分别 而非无分别
若分别无法 无缚无解脱
以分别无法 故不生分别
若不生分别 不得说惟心
种种心差别 法中无实法
以无实法故 无解脱世间
无外物可见 愚痴妄分别
如镜像现心 因熏心迷没
一切法不生 非有似有生
此一切惟心 离于诸分别
愚人说诸法 从因非智者
实体离于心 圣人心是净
僧佉毗世师 裸形婆罗门
及于自在天 无实堕邪见
无体亦无生 如空幻无垢
诸佛为何说 佛为何人说
修行清净人 离邪见觉观
诸佛如法说 我说亦如是
若一切惟心 世间何处住
去来依何法 云何见地中
如鸟虚空中 依止风而去
不住不观察 于地上而去
如是诸众生 依分别风动
自心中去来 如空中飞鸟
见身资生器 佛说心如是
云何因现见 惟心为我说
身资生住持 现见依熏生
无修行者生 现见生分别
分别境界体 心依境界生
知于可见心 不复生分别
若能见分别 离于觉所觉
名名不相合 是说有为法
此惟是可觉 名名不相离
离于知可知 是说有为法
此惟是可觉 名名中不离
若人异觉知 不自觉他觉
五法实法本 及于八种识
二种无我法 摄取于大乘
若见知可知 寂静见世间
名名中分别 尔时不复生
作名字分别 见彼不复生
不见于自心 是故生分别
四阴无诸相 彼则无数法
云何色多种 四大异异相
舍于诸相法 无诸大及大
若有异色相 何故阴不生
若见如是相 不见诸阴入
依境根及识 故生八种识
依相有三种 寂灭无如是
阿梨耶意我 我所及于智
因取于二法 知彼法即灭
离于彼此法 若见不相离
世间惟心分 世尊为我说
不复分别二 我及于我所
不增长分别 亦无意识因
离于因及缘 非物亦非生
分别但是心 世尊为我说
离于诸因缘 离能见可见
见自心种种 可见妄分别
不知自心见 不觉异心义
无见邪见成 若于智不见
彼何故不有 彼人心取有
分别非有无 故不生有心
不知惟心见 是故生分别
无分别分别 是灭已无因
遮四种朋党 若诸法有因
此异名字相 彼人作不成
彼应异自生 不尔应因生
因缘应和合 以遮因生法
我遮于常过 若诸缘无常
是不生不灭 愚痴无常见
灭相法无法 不见作于因
故无常生有 云何人不见
我摄取众生 依持戒降伏
智慧灭邪见 依解脱增长
一切诸世俗 外道妄语说
依因果邪见 自法不能立
但成自立法 离于因缘果
说诸弟子众 离于世俗法
惟心可见无 心见于二种
离可取能取 亦离于断常
但有心动转 皆是世俗法
不复起转生 见世是自心
来者是事生 去者是事灭
如实知去来 不复生分别
常无常及作 亦不作彼此
如是等一切 是皆世俗法
天人阿修罗 畜生鬼夜摩
众生去彼处 我说于六道
上中下业因 能生于彼处
善护诸善法 得胜处解脱
佛说念念生 生死及于退
为比丘众说 何意为我说
心不至第二 已灭坏不续
我为弟子说 念展转生灭
色色分别有 生及灭即已
分别即是人 离分别无人
我说于念法 依彼我说竟
离于取色相 不生亦不灭
因缘从缘生 无明真如等
依于二法生 真如无是体
因缘从缘生 若尔无异法
从常生于果 果即是因缘
无异于外道 因果共相杂
佛及诸佛说 大牟尼无异
此一寻身中 苦谛及集谛
灭及于道谛 我为诸弟子
取三为实者 取可取邪见
世间出世法 凡夫人分别
我领于他法 是故说三法
为遮彼邪见 莫分别实体
说过无定法 亦复无心生
实亦不二取 真如无二种
无明及爱业 识等从邪生
无穷过不作 作中不生有
诸法四种灭 无智者所说
分别二种生 有物无有物
离于四种法 亦离四种见
二种生分别 见者更不生
诸法本不生 起于智差别
现生于诸法 平等莫分别
愿大牟尼尊 为我及一切
如法相应说 离二种二见
我离于邪见 及诸余菩萨
常不见有无 以不见彼法
离外道和杂 离声闻缘觉
佛证法诸圣 为我说不失
颠倒因缘因 无生及一切
异名诸迷惑 智者所远离
譬如云雨楼 宫阁及于虹
阳焰毛轮幻 有无从心生
诸外道分别 世间自因生
不生真如法 及与实际空
是诸异法名 莫分别无物
于色上种种 莫分别无法
如世间．手．瓜． 自在．能．破物
如是一切法 莫分别无法
离色空不异 亦无生法体
莫分别无异 分别着邪见
分别可分别 摄取于诸事
长短方圆等 是摄分别相
分别是心法 可分别是意
若能如法知 离能相可相
外道说不生 及取于我法
分别如是相 此二见无差
何意如是说 若能如是知
彼人入于量 能解我说法
因见是沉没 无生是不依
知是二种义 故我说无生
诸法无有生 牟尼为我说
无因不相当 无有有法杂
无因亦无生 异因见外道
离有无无法 是故说惟心
生及于不生 离法是邪见
说无因无生 说有是着因
自然无作者 作者是邪见
方便诸愿等 是见为我说
若诸法是无 云何生三世
离可取能取 不生亦不灭
从物见异物 依彼法生心
诸法不生化 云何为我说
实有而不知 是故我说法
牟尼诸法中 前后自相违
离诸外道过 离于颠倒因
生及与不生 大师为我说
离有及于无 不失于因果
地及于次第 为说一无相
世间堕二边 为诸见迷惑
无生无生等 不知寂灭因
我无三世法 我亦不说法
有二毕有过 诸佛二清净
诸法空刹那 无体亦不生
说邪法覆心 分别非如来
生及与不生 惟愿为我说
云何何等法 离于境界生
色具足和合 从於戏论集
聚于外色相 从分别而生
知于彼法者 是如实解义
随顺圣人性 而心不复生
离于一切大 生法不相应
心虚妄观大 观如是无生
莫分别可别 智者不分别
分别于分别 是二无涅槃
立于无生法 如幻不见法
从幻等因生 所立诸法破
见心如镜像 无始熏习因
似义而无义 观诸法亦尔
如镜中色像 离于一二相
可见无非无 诸相亦如是
乾闼婆幻等 依于因缘观
如是诸法体 生非不生法
分别似如人 二种相而现
说我及于法 而愚人不知
相违及无因 声闻诸罗汉
自成及佛力 是五种声闻
时摄及于灭 第一离第一
是四种无常 愚无智分别
愚痴堕二边 功德及微尘
不知解脱因 以著有无法
譬如愚痴人 取指即是月
如是乐名字 不知我实法
诸大各异相 无色体相生
而诸大和合 无大无依大
火能烧诸色 水能烂诸物
风能动诸色 云何大相生
色阴及于识 是法二无五
是诸阴异名 我说如帝释
心心数差别 现转诸法生
四大彼此别 色心非从依
依青等有白 依白有青等
依因果可生 空有及于无
能作可作作 寒热见等见
如是等一切 妄觉不能成
心意及余六 诸识共和合
离于一异体 生死虚妄生
僧佉毗世师 裸形自在天
堕有无朋党 离于寂静义
形相貌胜生 四大生非尘
是外道说生 四大及四尘
余者无处生 外道分别因
愚痴而不觉 以依有无党
生共心相应 死不共相应
清净实相法 共智相应住
业及于色相 五阴境界因
众生无因体 无色界不住
佛说法无我 无色同外道
说无我是断 识亦不应生
心有四种住 无色云何住
内外诸法相 而识不能行
妄觉者计有 中阴有五阴
如是无色生 有而是无色
自然应解脱 无众生及识
是外道无疑 妄觉不能知
若彼处无色 是故见无色
彼无非立法 非乘无乘者
识从种子生 共诸根和合
八种色一分 于念时不取
色不住于时 根不共根住
是故如来说 诸根念不住
若不见色体 识云何分别
若智不生者 云何生世间
即生时即灭 佛不如是说
一时亦不念 虚妄分别取
诸根及境界 愚痴非智者
愚痴闻名取 圣人如实知
第六无依止 以无因可取
不善知于我 离于有法过
愚于有无法 觉者离实智
有为无为我 愚痴不能知
一中有施法 异中亦如是
共心中一体 意识能觉知
若施是心者 心数是名字
云何离能取 分别于一异
共因依止见 业．生．作业等
如火如是说 相似相似法
如火一时间 可烧能烧异
如是我依因 妄觉何不尔
生及与不生 而心常清净
妄觉者立我 何故不说喻
迷于识稠林 离于真实法
妄觉东西走 觅神我亦尔
内身修实行 我是清净相
如来藏佛境 妄觉非境界
可取及能取 差别五阴我
若能知于相 尔时生真智
外道说意识 阿梨耶藏体
共于我相应 我法说不尔
若如实知法 实谛得解脱
修行于见道 断烦恼清净
心自性清净 如来净法身
是法依众生 离于边无边
如金及与色 石性与真金
陶冶人能见 众生于阴尔
非人亦非阴 佛是无漏智
无漏常世尊 是故我归依
心自性清净 烦恼及意作
共五阴相应 说中胜者说
心自性清净 意等是因缘
彼能作诸业 故彼二种染
意等客尘法 烦恼我清净
彼依烦恼染 如垢依清净
如依离于垢 亦如金离垢
有而不可见 我离过亦尔
如琴及[骨*可]鼓 种种美妙声
阴中我亦尔 愚痴觅一异
地中诸宝藏 及与清净水
阴中我亦尔 实有不可见
心及心数法 功德阴和合
阴中我亦尔 无智不能见
如女人胎藏 虽有而不见
我于五阴中 无智故不见
如香药重担 火及于诸薪
阴中我亦尔 无智不能见
一切诸法中 无常及与空
阴中我亦尔 无智有不见
诸地及自在 通及于受位
无上妙诸法 及余诸三昧
及诸胜境界 若阴中无我
而此诸法等 一切亦应无
有人破坏言 若有应示我
智者应答言 汝心应示我
说无真如我 惟是虚妄说
作比丘业者 不应共和合
是人立有无 堕于二朋党
破坏诸佛法 彼不住我法
离诸外道过 焚烧无我见
令我见炽然 如劫尽火炎
如石蜜蒱桃 乳酪苏油等
彼处所有味 不尝者不知
取于五种中 五阴我亦尔
愚痴人不见 智见得解脱
明等诸譬喻 心法不可见
何处何因缘 和合不可见
诸法异体相 一心不能取
无因亦无生 虚妄觉者过
实行者见心 心中不见心
可见从见生 能见何因生
我姓迦旃延 首陀会天出
为众生说法 趣于涅槃城
是过去行路 我及彼诸佛
三千修多罗 说于涅槃法
欲界及无色 佛不彼成佛
色界中上天 离欲成菩提
境界非缚因 因境界是缚
依智断烦恼 修行者利剑
有我有幻等 法有无云何
愚不见如是 云何有无我
以有作不作 无因而转生
一切法不生 愚痴不觉知
诸因不能生 诸缘亦不作
彼二不能生 云何分别缘
先后及一时 妄觉者说因
虚空瓶弟子 一切诸物生
佛非有为作 诸相相庄严
是转轮功德 非诸佛得名
诸佛是智相 离诸邪见过
内身是智见 离诸一切过
聋瞎盲及哑 老少怀恶人
是等一切人 名无梵行者
广大胜妙体 是转轮王相
出家或一二 余者是放逸
毗耶娑迦那 及于梨沙婆
迦毗罗释迦 我入涅槃后
未来世当有 如是等出世
我灭后百年 毗耶娑围陀
及于般荼婆 鸠罗婆失罗
然后复更有 及于毛厘等
次毛厘掘多 次有无道王
次有刀剑乱 次刀剑末世
次于末世世 无法无修行
如是等过未 如轮转世间
日火共和合 焚烧于欲界
复成妙世界 彼器世间生
四姓及国王 诸仙人及法
供养大会施 时法还如本
话笑本如是 长行及子注
子注复重作 种种说无量
如是我闻等 迷没诸世间
不知真实法 何者为是非
衣裳如法染 捣治令洁净
清泥牛粪等 坏色而受用
诸香涂身衣 离于外道相
流通我法轮 是诸如来相
不漉水不饮 腰绳及内衣
依时行乞食 离于下贱家
生于妙天境 及人中胜处
诸宝相成就 天人中自在
依法修行者 生天四天下
多时而受用 依多贪还灭
正时及三灾 及于二恶世
我及余正时 释迦末世时
释种悉达他 八臂及自在
如是等外道 我灭出于世
如是我闻等 释迦师子说
曾有如是事 毗耶娑说是
八臂那罗延 及摩醯首罗
说如是等言 我化作世间
我母名善才 父名梵天王
我姓迦旃延 离于诸烦恼
生于瞻波城 我父及祖父
父名为月护 从于月种生
出家修实行 说于千种句
授记入涅槃 付慧转法轮
大慧与法胜 胜与弥佉梨
弥佉无弟子 于后时法灭
迦叶拘留孙 拘那含及我
离于诸烦恼 一切名正时
过彼正法后 有佛名如意
于彼成正觉 为人说五法
无二三灾中 过未世亦尔
诸佛不出世 正时出于世
无人夺有相 衣裳不割裁
纳衣碎破杂 如孔雀画色
二寸或三寸 间错而补纳
若不如是者 愚人所贪夺
常灭贪欲火 智水常洗浴
日夜六时中 如实修行法
如放箭石木 势极则还下
放一还下一 善不善亦尔
一中无多种 以相无如是
如风取一切 如田地被烧
若一能作多 一切无作有
不尔一切失 是妄觉者法
如灯及种子 云何多相似
一能生于多 是妄觉者法
如麻不生豆 稻不生[麸-夫+黄]麦
小麦等种子 云何一生多
波尼出声论 阿叉波太白
末世有梵藏 说于世俗论
迦旃延作经 夜婆伽亦尔
浮稠迦天文 是后末世论
婆梨说世福 世人依福德
能护于诸法 王婆离施地
弥迦摩修罗 阿舒罗等说
迷惑及王论 末世诸仙现
悉达他释种 浮单陀五角
口力及黠慧 我灭后出世
阿示那三掘 弥佉罗澡罐
我住阿兰若 梵天施与我
汝当未来世 名大离尘垢
能说真解脱 是诸牟尼尊
梵天共梵众 及余诸天众
鹿皮等施我 还没自在天
诸杂间错衣 及为乞食钵
帝释四天王 闲处施与我
说无生及因 生及与不生
欲成于不生 是但说言语
若无明等因 能生于诸心
未生于色时 中间云何住
即时灭于心 而更生余心
色不一念住 观何法能生
依于何因缘 心是颠倒因
彼不能成法 云何知生灭
修行者合定 金安阇那性
光音天宫殿 世间法不坏
住于所证法 是诸一切佛
如来等智慧 比丘证于法
及余所证法 彼法常不坏
云何虚妄见 诸法念不住
乾闼婆幻色 何故念不住
诸色无四大 诸大何所为
因无明有心 无始世界习
依生灭和合 妄觉者分别
僧佉有二种 从胜及转变
胜中有于果 果复成就果
胜是大体相 说功德差别
因果二种法 于转变中无
如水镜清净 诸尘土不染
真如如是净 依止于众生
如兴求及葱 女人怀胎藏
盐及盐中味 种子云何有
异体不异体 二体离二法
有法无因缘 非无于有为
如马中无牛 阴中我亦尔
说有为无为 是法无可说
恶见量阿含 依邪觉垢染
不觉说有我 非因不离因
五阴中无我 取我是过失
一中及异中 妄觉者不觉
水镜及眼中 如见镜中像
远离于一异 阴中我亦尔
可观及能观 禅道见众生
观察是三法 离于邪见法
即灭于知见 如孔中见空
诸法转变相 愚人妄分别
涅槃离有无 住如实见处
远离生灭法 亦离有无体
离能见可见 观察转变法
离诸外道说 离名相形体
依内身邪见 观察转变法
诸天及地狱 触及于逼恼
无有中阴法 云何依识生
胎卵湿化等 生于中阴中
众生身种种 应观于去来
离量及阿含 能生烦恼种
诸外道浪言 智慧者莫取
先观察于我 后观于因缘
不知有说有 故石女儿胜
般若离肉眼 妙眼见众生
离于有为阴 妙身体众生
住好恶色中 出离缚解脱
妙体住有为 能见妙法身
在于六趣中 妄觉非境界
我过于人道 非余妄觉者
而无生我心 何因如是生
如河灯种子 何不如是说
而识未生时 未有无明等
离于闇无识 云何相续生
三世及无世 第五不可说
是诸佛境界 妄觉者观行
行中不可说 以离智行中
取于诸行中 智离于行法
依此法生此 现见是无因
诸缘不可见 离于无作者
依风火能烧 因风动能生
风能吹动火 风还能灭火
愚者不分别 云何生众生
说有为无为 离于依所依
云何成彼法 风火愚分别
彼此增长力 彼此法不及
云何而生火 惟言语无义
众生是谁作 而分别如火
能作阴入躯 意等因能生
如常无我义 共心常转生
二法常清净 离于诸因果
火不能成彼 妄觉者不知
心众生涅槃 自性体清净
无始等过染 如虚空无差
外道邪见垢 如白象床城
依意意识覆 大等能清净
彼人见如实 见已破烦恼
舍譬喻稠林 彼人取圣境
知能知差别 彼分别异体
朦钝人不觉 复言不可说
譬如栴檀鼓 愚人作异说
如栴檀沉水 诸佛智亦尔
愚人不觉知 以依虚妄见
中后不受食 以钵依量取
离口等诸过 啖于清净食
此是如法行 不能知相应
依于法能信 莫分别邪行
不着世间物 能取于正义
彼人取真金 能然于法灯
痴有无因缘 邪见网分别
一切烦恼垢 离于贪嗔恚
尔时不复生 以无一切染
诸如来身手 而授于佛位
外道迷因果 余者迷因缘
及无因有物 断见无圣人
受于果转变 识及于意识
意从本识生 识从于意生
一切识从本 能生如海波
一切从熏因 随因缘而生
念差别钩锁 缚自心取境
似于形体相 意眼等识生
无始来过缚 依熏生取境
外见心诸法 遮诸外道见
依彼更生余 及依彼观生
是故生邪见 及世间生死
诸法如梦幻 如乾闼婆城
阳焰水中月 观察是自心
行差非真如 正智幻三昧
依首楞严定 及余诸三昧
入于初地得 诸通及三昧
智及如意身 受位入佛地
尔时心不生 以见世虚妄
得观地余地 及得于佛地
转于依止身 如诸色摩尼
亦如水中月 作诸众生业
离有无朋党 离二及不二
出于二乘地 及出第七地
内身见诸法 地地中清净
离外道外物 尔时说大乘
转于分别识 离于变易灭
如兔角摩尼 得解脱者说
如依结相应 依法亦如是
依相应相应 莫分别于异
眼识业及受 无明及正见
眼色及于意 意识染如是
佛说此妙经 圣者大慧士
菩萨摩诃萨 罗婆那大王
叔迦婆罗那 瓮耳等罗叉
天龙夜叉等 乾闼婆修罗
诸天比丘僧 大欢喜奉行

    入楞伽经卷第十