Mahaparinirvana Sutra: Chapter 12 On the Buddha Nature

animated candle 16th century Reclining Buddha from Thailand animated candle

Tao-Sheng (ca. 360-434)
And the Doctrine of the Buddha Nature

In 405 or 406, after staying at Lu-shan for about seven years, Tai-sheng made a long-cherished and easerly awaited move to Ch'ang-an to study with Kumarajiva, who had been there since 401, attracting about 3000 aspiring pupils to Mahayana doctrines. However, Tao-sheng's sojourn in Ch'ang-an was relatively brief, only about two years.... This brief period, however, was sufficient to demonstrate Tao-sheng's ability and warrent him a position in contempory "honours lists," ranging from one of the four "(great) philosophers" to one of the fifteen great disciples, moe often than not being listed first.

Despite his fame, the specific role Tao-sheng played and how much he contributed, particularly in Kumarajiva's major task, translation, are not certain. Although Tao-sheng is reported by Seng-chao to have been on hand when Kumarajiva translated the Lotus, Tao-sheng does not figure prominently in any record as a close assistant to Kumarajiva. When Tao-sheng arrived in Ch'ang-an, the capital of the Eastern Chin (317-420), the massive 100-volume work of the Great Wisdom Treastise (Mahaprajnaparamita-sastra, Ta Chih-tu lun) was almost (or just) completed. In the course of the brief period between 405 and 408, however, an assortment of important texts was translated. These included the Vimalakirti-nirdesa, Lotus, and Astasahasrika-prajnaparamita (Hsiao-p'in) Sutras It may not be coincidental that in the ensuing years, Tao-sheng wrote commentaries on these three, the last of which is not extant today in any form. In 408 Tao-sheng returned to Lu-shan for some unidentified reason.

Soon afterwards, in 409, Tao-sheng moved to Chien-k'ang for the second time. He remained in the area more than twenty years, taking up residence in a monastery called Ch'ing-yuan ssu (later Lung-kuang ssu) from 419 on. This period also marks his maturity as a thinker, was his most productive in terms of writings, most of which are presumed to have been drafted during this period. A contraversial theory Tao-sheng advocated at this time concerned the question of whether the icchantikas, regarded traditionally as outcasts from the path of enlightenment, were also Buddha-natured. Tao-sheng decided they were while reading an incomplete version of the Mahaparinirvana Sutra, a complete version of which was still to come. The absolute universality of the Buddha-nature was the logical conclusion he reached by inference from the first part of the sutra, even though it contained an explicit statement excepting the icchantikas. This bold new interpretation, amounting to a challenge of an accepted channel of the Buddha's doctrines, brought about his expulsion from the Buddhist community sometime between 428 and 429.

Lamenting that people had not been able to transcend the symbols of the translated sutras to grasp the true meaning behind the words and predicitng that he would be proven right and eventually exonerated, Tao-sheng retreated to Lu-shan in 430, via Hu-ch'iu-shan in 429. It was not long, after the complete text of the Nirvana Sutra, translated by Dharmakshema, had made its way there, that Tao-sheng turned out to be correct. He was vindicated and praised for his penetrating insight. Instead of returning to Chien-k'ang, however, he remained at Lu-shan until his death in 434. In 432, Tao-sheng composed a commentary on the Lotus Sutra on the basis of information and lecture notes he had collected throughout his years.

The study and exegesis of the Nirvana Sutra continued during the fourth century and into the beginning of the fifth, largely due to Tao-sheng's study of the text and the contraversy over the related theory of Buddha-nature he initiated. This textual study did not evolve into a full-fledged system or "school" in the full sense of the term, and it was to be overshadowed by the development of other schools in the sixth century. Yet, such continued interest in a specific text and its doctrine, without any missionary or Indian founder involved in the lineage, was almost unprecedented in China. In this respect, Tao-sheng stood very much in the forefront of the formation of the schools that would emerge in the centuries to come.

Tao-sheng was placed at the top of the list of exegetes of the Nirvana Sutra and expounders of the theory of the Buddha-nature; he was first not just chronologically but also as the initiator of the tradition. In 509, upon the order of the Emporer Wu (reigner 502-550) of the Liang dynasty (502-557), Pao-liang (444-509) or Seng-liang or both collected various commentaries on the sutra and compiled ten works, ranging from Tao-sheng's commentary to Pao-liang's own commentary, into an anthology of seventy-one volumes. This line of study in the South waned afterwards, giving way to and being absorbed into other sectarian movements. Yet the tradition continued in the North from the sixth century to the seventh, enlisting many eminent monks ranging from T'an-yen (516-588) to Fa-ch'ang (567-645).

Tao-sheng's theory of Buddha-nature also gave rise to diverse interpretations; at first three "houses," later to be further divided into ten or eleven interpretations. Tao-sheng's position constitutes the first listed in both classifications. The scriptural source given is the Nirvana Sutra (chapter 12): "'Self' means none other than Tathagata-garbha (Womb of the Thus Come One). All sentient beings possess Buddha-nature and that is what 'Self' precisely means."

The basic issue for the three "houses" was whether sentient beings possess the Buddha-nature originally, at present, or in the future. The essence or substance (t'i) of Buddha-nature in other practical terms was also discussed. Tao-sheng defined it as "what sentient beings are going to have (or realize as the fruit of cultivation and enlightenment.)" Dharmakshema, master of the second "house" or interpretation and translator of the large version of the Nirvana Sutra (in forty rolls, T.12, near 374) identifies the substance of Buddha-nature with what beings originally have, the Middle Path (Madhyama-pratipad) and Suchness (Bhutatathata). The third view, held by Ta-yao (ca. 400-475), is a middle position between the two. Buddha-nature as the "right cause" cheng-yin) consists of the li for attaining Buddhahood already in a being's possession. In the case of the ten viewpoints, the descriptive terms identified with Buddha-nature include the li of the Buddha, true spirit, pleasure principle, sentient beings, storehouse (alaya consciousness, or pure consciousness (amala-vijnana). The last two were associated with the masters of the Ti-lun (Dashabhumi) School (6th century); the predecessor of the Hua-yen (Avatamsaka) School (7th century); and She-lun (Mahayana-samparigraha) (6th century), the predecessor of the Fa-hsiang (Vijnaptimatrata) School (7th century). All these facts indicate that Tao-sheng's shadow extended beyond both his own century and the Nirvana School. As a matter of fact, the Nirvana School is considered a forerunner of the T'ien-t'ai School, as it became absorbed into the latter. Likewise, the universality of the Buddha-nature came to be absorbed into Hua-yen Buddhism and also permeated the Ch'an literature; the concept is central to the Platform Sutra.

Tao-Sheng's Commentary on the Lotus Sutra: A Study and Translation by Young-Ho Kim. State University of NY Press: Albany, NY. 1990. pp. 16-18, 65-66.

The Mahaparinirvana Sutra

Chapter 12 On the Nature of Tathagata

Kasyapa said to the Buddha: "O World-honoured One! Is there any self in the twenty-five existences or not?" The Buddha said: "O good man! 'Self' means 'tathagatagarbha.' Every being has the Buddha Nature. This is self. Such a self is, since the very beginning, under cover of innumerable illusions. That is why man cannot see it. O good man! There is here a poor woman. Sha has in her house the true gold hidden. But none of the people of the house, big or small, know it. But there is a stranger, who, by expediency, speaks to the poor woman: 'I shall employ you. You now weed the land!' The woman answers: 'I cannot do it now. If you let my son see where the gold is hidden, I will soon work for you.' The man says, 'I know the way. I will show it to your son.' The woman says again: 'No people of my house, big or small, know. How can you?' The man says: 'I will now make it clear.' The woman says again: 'I desire to see. Pray let me.' The man digs out the gold that lay hidden. The woman sees it, is glad, and begins to respect the person. O good man! The same is the case with the Buddha Nature that man has. Nobody can see it. This is as in the case of the gold the poor woman possessed and yet could not see. O good man! I now let persons see the Buddha Nature that they possess, which is overspread by illusions. This is as in the case of the poor woman who cannot see the gold, even possessing it. The Tathagata now shows all beings the storehouse of enlightenment, which is the so-called Buddha Nature. If all beings see this, they are glad and will take refuge in the Tathagata. The good expediency is the Tathagata and the poor woman is all the innumerable beings, and the cask of true gold is the Buddha Nature.

"Also, next, O good man! For example, a woman has a child, who, yet very young, is taken by illness. Worried by this, the woman seeks a good doctor. A good doctor comes and mixes up three medicines, which are the butter, milk and rock candy. This he gives her, to have it taken by the child. Then, he says to the woman: 'When the child has taken the medicine, do not give milk to the child for some time. When the medicine has worked out its way, you, then, may give milk.' Then, the woman applies a bitter thing to the nipple and says to the child: 'Do not touch it. The nipple is poisoned.' The child is dying for the milk and wants to have it. Hearing of poison, it runs away. When the medicine has done the work, the mother washes the nipple, calls the child in, and gives it. The hungry child, having heard of poison, does not come to it. The mother says again: 'Just to give you the medicine, I put on it poison. As you have already taken the medicine, I have washed it off. Come! Have the nipple. It is no more bitter.' Hearing this, the child slowly comes back and takes it. O good man! The same is the case with the Tathagata. To save beings, he gives them the law of no-self. Having thus practiced the Way, the beings make away with the mind that clings to self and gain nirvana. All this is to make away with the wrong concept of the people, to show them the way and make them stand above, to show them that they stick to self, that what goes in the world is all false and not true, and make then practice no-self and purify their own self. This is as in the case of the woman who puts bitter things to the nipple for love of the child. The same is the case of the Tathagata. For practicing the void, I say that all do not have the self. This is as in case of the woman who washed the nipple, calling for the child to partake of the milk. The same is the case with me too. I speak of the tathagatagarbha. Because of the, the bhishus do not entertain fear. The same goes with the child which hears its mother, slowly comes back, and take the milk. The same is the case with the bhiksus. They should well know that the Tathagata hides nothing."

Bodhisattva Kasyapa said to the Buddha: "O World-honoured One! Indeed, there can be no case in which there is a self. Why? At the time when the child gains birth, there is nothing it knows. If there is a self, the child must know when it gains birth in the world. Because of this, we know that there is no self. If a self definitely exists, there can be no losing of knowing. If it is that all beings possess eternally the Buddha Nature, there can be no breaking away. If there is no destruction, how can there be the difference of ksatriya, brahman, vaisya, sudra, candala, and beast? Now, the work of karma is various, and differences esist in life. If there is definitely a self, there can be no victory or defeat with the beings. By this we may definitely know that the Buddha Nature is the eternal law. If the Buddha Nature is definitely eternal, why do we say such things as killing, stealing, lust, double-tongued, ill-speaking, lying, flattering, greed, hatred, and wrong views? If it is that there is eternally the nature of self, why is it that one becomes intoxicated and mad? If the nature of self is eternal, the blind must see, the deaf must hear, the dumb talk, and the limp walk. If the self is eternal, the hole of fire, the great flood of water, poison, sword, evil persons, and beasts cannot be evaded. If the self is eternal, what has basically been changed cannot be forgottn or lost. If forgotten, how can one say: 'I have somewhere seen this person.' If the self is eternal, there can be no old or young, no ups or downs, no remembering what has passed away. If the self is eternal, where does it stay or live? Is it that tears, spits, blue, yellow, red, and white are to remain in all things? If the self is eternal, it will fill the body as in the case of the sesame seed in which there is no space left in between? When the body is bashed, the self too must well be cut off."

The Buddha said to Kasyapa: "O good man! For example, there is in the household of a king a great wrestler. He has on the brow an adamantine bead. This man wrestles with other wrestlers. As the head of the other person has touched the brow, the bead gets into the flesh, and there is no knowling of where it is. There is a boil there. A good doctor is called to have it cured. At the time, there is a good doctor with a bright head. He knows well how to see and prescribe the medicine. Now, he sees that this boil is come out because of the fact that the bead has got into the body. He has come to know that this bead has got into the flesh and there remains. Then, the good doctor asks the wrestler: 'Where is the bead which was on your brow?' The wrestler gets surprised and answers: 'O great teacher and doctor! Has not the bead on my brow been lost? Where could this bead be now? Is it not a miracle?' He is worried and weeps. The the doctor appeases the wrestler: 'Do not too much be worried. As you fought, the gem got into your body. It is now under the skin and is now loomingly to be seen. As you fought, the poison of anger had so burnt that it got into your body and you do not feel it.' But the wrestler does not believe in the word of the doctor. 'If under the skin, how could it be that it does not come out because of the impure pus and blood? If in the sinew, we cannot possibly see it. What do yuo mean to cheat me?' Then, the doctor takes up a mirror and applies it to the face. The gem clearly comes out in the mirror. The wrestler sees, gets surprised, and is all wonder. The case is like this. O good man! The same is the case with all beings. They do not come near the good teacher of the Way. So, they cannot see the Buddha Nature that is within, even when having it. And they are reigned over by greed, lust, anger, and ignorance. So, they fall into the realms of hell, beast, hungry preta, asura, candala, and they get born in such various houses as of ksatriya, brahman, vaisya, and sudra. The karma worked out by mind leads one, though born man, to live such lives as cripple, limp, deaf, blind, dumb, and to twenty-five existences, when such as greed, lust, anger, and ignorance reign over the mind, and one cannot know the presence of the Buddha Nature. The wrestler says that the gem has gone away, in spite of the fact that it is in the body. The same is the case with the beings too. Not having come near the good teacher of the Way, one knows not the Tathagata's undisclosed treasure, and does not study the selflessness. For example, even when one is told of the unholy self, one cannot know the true quality of self. The same is the case with my disciples. As they do not befriend the good teacher of the Way, they practice no-self and do not know where it is. One does not know the true nature of selflessness. How could they well know the true nature of self itself? Thus, O good man! The tathagata says that all beings possess the Buddha Nature. For example, this is like the case of the good doctor who makes the wrestler see where the adamantine gem rests. All these beings are reigned over by innumerable illusions and, thus, do not know the whereable of the Buddha Nature. When illusion is made away with, there come about knowledge and brightness. This is as in the case of the wrestler who sees in the mirror the gem. O good man! It is thus that what rests undisclosed in the Tathagata is innumerable and is difficult for beings to think about.

"Also, O good man! For example, there is in the Himalaya a medicine called 'pleasing taste.' It tastes very sweet. It grows hidden under a deep growth of plants and we cannot easily see it. By the scent, one comes to know the whereabouts of the medicine. In the days gone by, there was a cakravartin, who, placing here and there in the Himalayas wooden tubes, took this medicine. When ripe, it flows out and enters the tube. It tastes truly right. When the king died, this medicine became sour, saltish, sweet, bitter, or hot, or light. Thus, what is one tastes differently as places differ. The true taste of the medicine remains in the mountain; it goes like the full moon. Any common mortal, sterile in virtue, may work hard, dig, and try, but cannot get it. Only a chakravartin high in virtue comes out in the world, and he arrives at the true worth of the medicine because of the happy circumstantial relations. The same is the case. O good man! The taste of the undisclosed store of the Tathagata, too, goes like this. Overspread by all the growths of illusion, the beings clad in ignorance cannot hope to see. We say 'one taste'. This goes, for instance, as in that of the Buddha Nature. By the presence of illusion, several tastes come about, such as the realms of hell, beast, hungry preta, deva, human being, man, woman, non-man, non-woman, ksatriya, brahman, vaisya, and sudra.

"e;The Buddha Nature is strong and vigorous; it is hard to destroy. Therefore, there is none that can well kill it. If there is one that well kills it, the Buddha Nature will die out. Nothing can ever destroy such a Buddha Nature. Anything as nature can never be cut. The nature of self is none but the undisclosed storehouse of the Tathagata. Such a storehouse can never be broken, put to fire, or made away with. Though not possible to destroy or see, one can know of it when one attains the unsurpassed bodhi. Because of this, there is none that well kills it, no karma result will raise the head from evil actions." The Buddha said to Kasyapa" "There truly goes killing. Why? O good man! The Buddha Nature of the beings rests in the five groups. If the five groups are destroyed, this is the killing. If one harms a living thing, one gains the evil realm. By the working of karma, one transmigrates through such realms as ksatriya, brahman, vaisya, sudra, candala, or man, woman, non-man, non-woman, and the twenty-five variegated existences. One who has not attained the hold stage of a sage is waywardly bound up by the attachment to self. All such phases of existence, big or small, are like the barnyard grass, like the rice or bean, or like the thumb. They thus loosely imagine these things. There can be no true shape in wild fancies. The shape of self that seeks to flee from the world is the Buddha Nature. It is the best way of conceiving self.

"And, next, O good man! For example, there is here a man who well knows what is hidden under. He takes up a sharp hoe, dig the ground, and hits at such as stone and gravel. All go through and nothing hinders. Only when the diamond comes in the way. It cannot go through. Now, all sword and hatchet cannot destroy the diamond. O good man! The Buddha Nature of the beings is like this. It is one which all those people who discuss things, marapapiyas, all men and devas cannot destroy. The characteristic of the five groups is what happens and what is done. Whatever happens and is done can well be destroyed as in the case of stone and sand. The true self of the Buddha Nature is like the diamond which cannot be crushed out. Because of this we call the destroying of the five groups the killing of life. O good man! Know well definitely that the Buddha teaching is not within the boundary of conceiving.

"O good man! The vaipulya sutra is like amrta and poison." Bodhisattva Kasyapa said to the Buddha: "Why is it, O Tathagata! that you must say that the vaipulya sutra is like amrta and poison?" The Buddha said: "O good man! Do you desire to be informed of the undisclosed storehouse of the Tathagata?" Kasyapa said to the Buddha: "I now really desire to know of the signification of the undisclosed store of the Tathagata."
Then, the Tathagata said in a gatha:

"There is one who takes amrta, harms life, and dies early,
Or one who takes amrita and gains long life,
Or one who takes poison and gains life,
Or one who takes poison and dies.
The unhindered wisdom, which is the amrta, in none
But the Mahayana sutras. And such Mahayana sutras too
Are what contain poison. It is
Like the butter, sarpirmanda or rock candy,
Which, when taken and digested, is medicine.
If not digested, then it is none but poison.
The same if the case with the vaipulya sutras.
The wise make it amrta, and the ignorant, not knowing
The worth of the Buddha Nature, make it a poison.
Sravakas and pratyekabuddhas make Mahayana amrta.
This is like the milk which is the first of what taste.
Those who thus work and make progress
Ride on Mahayana, gain the shore of nirvana, and become
The elephant king of man. Beings know of the Buddha Nature
As with Kasyapa. The superb amrta is
The birthlessness and deathlessness. O Kasyapa!
Know well of the three refuges. The nature
Of the three refuges is that of self. If one knows
Clearly that the nature of self has the Buddha Nature,
Such a one well enters the undisclosed house.
One who knows of self and what belongs to self
Cames already out of the world.
The nature of the Three Treasures of the Buddhist teaching
Is the upperless and the most to be honored.
Its nature is as I say thus in my gatha"

Then, Kasyapa said in a gatha:

"I do not know how to take refuge
In the Three Treasures, how
To take refuge in the unsurpassed fearlessness.
Knowing no place of the Three Treasures, how can one
Gain fearlessness? How can one who takes refuge
In the Buddha gain peace, how can one take refuge in the Law?
Condescend and tell me of these! How does one gain
Unmolestedness, and how non-unmolestedness,
How does one take refuge in the sangha, and, thereby,
Attain the unsurpassed benefit?
How does one gain the true sermon, how
Buddhahood in the days to come?
If one does not attain it in the days to come,
How can one take refuge in the Three Treasures?
I have nothing to forsee; I shall, by steps, work up.
Not conceiving, can one think of having a child? If
It is definitely in the embryo, we may well say
That we have a child. If the child is in the womb,
It will not be long before it comes out.
This is what means of a child. The same is the case
With what pertains to the karma of man.
The ignorant cannot know what the Buddha says.
By ignorance, the wheel of birth and death turns.
One who is an upasaka by name only cannot know
The true significance. Condescend and explain to me
And cut off the web of doubt.
Oh, the great wisdom of the Tathagata! Have pity
And explain! I pray, open the closed door
Of the treasure house of the Tathagata.quot;

"O Kasyapa! I will now for your sake
Open the closed door of the storehouse and uproot your doubt.
Give ears to what I say with all your heart!
You, all bodhisattvas, and the seventh Buddha, have the same name.
One who takes refuge in the Buddha is the true upasaka.
One no more takes refuge in all other heavens.
One who takes refuge in the Law cuts oneself away
From harming others. One who takes refuge
In the holy sangha does not take refuge in tirthakas.
Thus taking refuge in the Three Treasures,
One attains fearlessness."

Kasyapa said to the Buddha:

"I take refuge in the Three Treasures.
This is the right path, and this the world of all Buddhas.
That the two treasures are equal
Possesses always the nature of great wisdom.
The nature of self and the Buddha Nature
Do not differ. This is the path the Buddha praises;
This is where man rightly steps forward
And when one abides in peace,
This is the right enlightenment.
This is the Buddhahood. I, too, am a Well-gone, and am
On way to the unsurpassed bodhi praised by all.
This is the best amrta.
This is where there is no existence to name."
Then, the Buddha said to Kasyapa: "O good man! Do not, like all sravakas and common mortals, see the Three Treasures. In this Mahayana, there is no discrimination in the Three Treasures. Why? The Buddha Nature has in it the Law and the sangha. To teach sravakas and common mortals, discrimination is resorted to and the three different phases spoken of the Three Treasures. O good man! The bodhisattva will think: 'This I now take refuge in the Buddha. If this I attain bodhi and Buddhahood, I shall not pay respect, worship, or do offerings to all Buddhas. Why? For all Buddhas are all-equal. They are all taken refuge in by all beings. If one desires to pay respect to the law body and the sarira, one should also pay respect to the stupas of all Buddhas. Why? Because of guiding in all beings. It also makes beings conceive in me a thought of stupa, to make them worship and do offerings. Such beings make my law body the place where they take refuge in. All beings stand on what is not true and what is false. I shall now, by steps, show the true law. If there are people who take refuge in priests that are not of true stuff, I shall become the true refuge for them. If there are those who see differently the three refuges, I shall become the single place where to take refuge in. So, there can be no difference of the three to take refuge in. To those born blind, I shall be the eye, and to sravakas and pratyekabuddhas I shall become the true refuge. O good man! Such bodhisattvas do the Buddha works for the sake of innumerable evil beings and all wise people. O good man! There is, for example, a person here who goes to the battle field and thinks: 'I am the first of all the first of these. All soldiers depend on me.' Also, it is as in the case of the prince who thinks: 'I shall subdue all other princes, succeed to the works of a great emperor, gain the unmolested power, and make all other princes pay homage to me. So, let me not entertain a whit of a self-surrendering mind.' Like as the prince of the king also go things with the minister. O good man! The same is the case with the bodhisattva-mahasattva, and he thinks: 'How does the three become one with me?' O good man! I make it that the three things are the nirvana. The Tathagata is the unsurpassed one. For example, the head is the highest part of man's body, and not the other limbs and the hands and legs. The same is the case with the Buddha. He is the most respected, and not the Law and the sangha. In order to teach the world, he manifests himself severally. It is as in the case of going up the ladder. This being the case, do not regard the refuges as different as do the common mortals and the ignorant take things to be. Abide in the Mahayana as bravely and decisively as a shard sword."

Q&A Six (out of Nine) New [added 8/19]

Bodhisattva Kasyapa said to the Buddha: "I ask as I know, not that I do not know. I ask for the sake of the greatly courageous bodhisattvas about the untainted pure actions, so that the Tathagata, will, for the sake of bodhisattvas, proclaim what is wonderful and expound and thus desire to praise the Mahayana vaipulya sutras. The Tathagata, will, for the sake of bodhisattvas, proclaim what is wonderful and expound and thus desire to praise the Mahayana vaipulya sutras. The Tathagata, the great compassionate one, now speaks. I, too, shall peacefully abide in it. The pure actions of the bodhisattva is well proclaimed in the great nirvana sutra. O World-honoured One! I shall now, for the sake of all beings, disseminate the undisclosed store of the Tathagata. Also, I shall now well attest and know the three refuges. If any beings well believes

Mahaparinirvana-Sutra. Translated from the Chinese of Kumarajiva by Kosho Yamamoto. The Karin Buddhological Series No. 5, Published by the Karinbunko: Yamaguchi-ken, Japan. 1973. pp. 181-190. [The nine Q&A's between Kasyapa and the Buddha on the universal Buddha Nature will be transcribed here in the future.... Please check back!]

Nirvana Sutra: PDF (Ch.1-6) | Ch.12 on Buddha-Nature | Ch.18 on Illness

Dharmakshema's The Great Parinirvana Sutra extensive excerpts

Tao-sheng's On the Title of the Lotus Sutra

Search | Buddhas | Discuss | Gohonzon | Gosho | HBS | Independent | Kempon | Kwan-yin | Lotus Sutra | Nichiren | Nipponzan | NShoshu | NShu | Pilgrimage | Prayer | Pure Land | Queers | RKK | Reiyukai | Ryuei | SGI | Stupas | Sutra Library | Tales | Tantric | Tendai | Theravada | WebRings | Women | Zen | Misc. | What'sNew?

LE FastCounter