New Page 1

此网页使用了框架，但您的浏览器不支持框架。


New Page 2

A Guide To the Bodhisattva Way Of Life
By Shantideva

[In copying this ancient manuscript we discovered various translations from different traditions. The reader can be comforted to know that they all agreed with one another in substance, however, some were easier to understand in places then others. In making this text available we worked hard to ensure that it would be comprehensible. In every case we selected the verse that we felt was easiest to understand. BIONA ED.]

Chapter One
The Benefit of the Spirit of Awakening

1. Reverently bowing to the Sugatas, who are endowed with the Dharmakaya, together with their children and all who are worthy of veneration, I shall concisely present a guide to the discipline of the children of the Sugatas in accordance with the scriptures.

2. There is nothing here that has not been said before, nor do I have any skill in composition. Thus, I have no concern for the welfare of others, and I have composed this solely to season my own mind.

3. Owing to this, the power of my faith increases to cultivate virtue. Moreover, if someone else with a disposition like my own examines this, it may be meaningful.

4. This leisure and endowment, which are so difficult to obtain have been acquired, and they bring about the welfare of the world. If one fails to take this favorable opportunity into consideration, how could this occasion occur again?

5. Just as lightning illuminates the darkness of a cloudy night for an instant, in the same way, by the power of the Buddha, occasionally people's minds are momentarily inclined toward merit.

6. Thus, virtue is perpetually ever so feeble, while the power of vice is great and extremely dreadful. If there were no spirit of perfect awakening, what other virtue would overcome it?

7. The Lords of Sages, who have been contemplating for many eons, have seen this alone as a blessing by which joy is easily increased and immeasurable multitudes of beings are rescued.

8. Those who long to overcome the abundant miseries of mundane existence, whose who wish to dispel the adversities of sentient beings, and those who yearn to experience a myriad of joys should never forsake the spirit of awakening.

9. When the spirit of awakening has arisen, in an instant a wretch who is bound in the prison of the cycle of existence is called a child of the Sugatas and becomes worthy of reverence in the worlds of gods and humans.

10. Upon taking this impure form, it transmutes it into the priceless image of the gem of the Jina. So, firmly hold to the quicksilver elixir, called the spirit of awakening, which must be utterly transmuted.

11. The world's sole leaders, whose minds are fathomless, have well examined its great value. You, who are inclined to escape from the states of mundane existence, hold fast to the jewel of the spirit of awakening.

12. Just as a plantain tree decays upon losing its fruit, so does every other virtue wane. But the tree of the spirit of awakening perpetually bears fruit, does not decay, and only flourishes.

13. Owing to its protection, as due to the protection of a powerful man, even after committing horrendous vices, one immediately overcomes great fears. Why do ignorant beings not seek refuge in it?

14. Like the conflagration at the time of the destruction of the universe, it consumes great ices in an instant. The wise lord Maitreya taught its incalculable benefits to Sudhana.

15. In brief, this spirit of awakening is known to be of two kinds: the spirit of awakening, and the spirit of aspiring for awakening, and the spirit of venturing towards awakening.

16. Just as one perceives the difference between a person who yearns to travel and a traveler, so do the learned recognize the corresponding difference between those two.

17. Although the result of the spirit of aspiring for awakening is great within the cycle of existence, it is still not like the continual state of merit of the spirit of venturing.

18. From the time that one adopts that spirit with an irreversible attitude for the sake of liberating limitless sentient beings,

19. From that moment on, an uninterrupted stream of merit, equal to the sky, constantly arises even when one is asleep or distracted.

20. The Tathágata himself cogently asserted this in the Subahuprccha for the sake of beings who are inclined toward the lesser vehicle.

21. A well-intentioned person who thinks, "I shall eliminate the headaches of sentient beings," bears immeasurable merit.

22. When then of a person who desires to remove the incomparable pain of every single being and endow them with immeasurable good qualities?

23. Who has even a mother or father with such altruism? Would the gods, sages, or Brahmas have it?

24. If those beings have never before had that wish for their own sake even in their dreams, how could they possibly have it for the sake of others?

25. How does this unprecedented and distinguished jewel, whose desire for the benefit of others does not arise in others even for their own self-interest, come into existence?

26. How can one measure the merit of the jewel of the mind, which is the seed of the worlds joy and is the remedy for the worlds suffering?

27. If reverence for the Buddhas is exceeded merely by an altruistic intention, how much more so by striving for the complete happiness of all sentient beings?

28. Those desiring to escape from suffering hasten right toward suffering. With the very desire for happiness, out of delusion they destroy their own happiness as if it were an enemy.

29. He satisfies with all joys those who are starving for happiness and eliminates all the sorrows of those who are afflicted in many ways.

30. He dispels delusion. Where else is there such a saint? Where else is there such a friend? Where else is there such merit?

31. Even one who repays a kind deed is praised somewhat, so what should be said of a bodhisattva whose good deed is unsolicited?

32. The world honors as virtuous one who makes a gift to a few people, even if it is merely a momentary and contemptuous donation of plain food and support for half a day.

33. What then of one who forever bestows to countless sentient beings the fulfillment of all yearnings, which is inexhaustible until the end of beings as limitless as space?

34. The Lord declared, "One who brings forth an impure thought in his heart against a benefactor, a child, of the Jina, will dwell in hells for as many eons as there were impure thoughts.

35. But if ones mind is kindly inclined, one will bring forth an even greater fruit. Even when a greatly violent crime is committed against the children of the Jinas, their virtue spontaneously arises.

36. I pay homage to the bodies of those whom this precious jewel of the mind has arisen. I go for refuge to those who are mines of joy, toward whom even an offence results in happiness.

Chapter Two
The Confession of Sin

1. In order to adopt that jewel of the mind, I make offerings to the Tathágatas, to the stainless jewel of the sublime Dharma, and to the children of the Buddhas, who are oceans of excellent qualities.

2. As many flowers, fruits, and medicinal herbs as there are, and as many jewels as there are in the world, and clear and pleasant waters,

3. Jeweled mountains, forested regions, and other delightful and solitary places, vines shining with the ornaments of lovely flowers, and trees with branches bowed with delicious fruit,

4. Fragrances and incenses, wish fulfilling trees, jeweled trees, lakes adorned with lotuses, enchanting calls of wild geese in the worlds of gods and other celestials,

5. Uncultivated crops, planted crops, and other things that ornament the venerable ones, all these that are un-owned and that extend throughout space,

6. I bring to mind and offer to the foremost of sages, together with their children. May those worthy of precious gifts, the greatly merciful ones, compassionate towards me, accept these from me.

7. Devoid of merit and destitute, I have nothing else to offer. Therefore, may the Protectors, whose concerns are for the welfare of others, accept this by their own power, for my sake.

8. I completely offer my entire self to the Jinas and their children. O supreme beings, accept me! I reverently devote myself to your service.

9. Being free from fear of mundane existence due to your protection, I shall serve sentient beings; I shall completely transcend my earlier vices, and henceforth I shall sin no more.

10. In sweetly fragrant bathing chambers, whose beautiful pillars are radiant with jewels, glowing canopies made with pearls, and crystal floors transparent and sparkling,

11. I bathe the Tathágatas and their children with many vases studded with superb jewels and filled with pleasing, fragrant flowers, and water, to the accompaniment of songs and instrumental music.

12. I dry their bodies with scented, immaculate, exquisite clothes; then I offer them beautifully colored and sweetly fragrant garments.

13. I adorn Samantabhadra, Ajita, Manjughosa, Lokesvara, and others with those divine, soft, delicate, and colorful raiment's and with the most precious of jewels.

14. With perfumes permeating a thousand million worlds, I anoint the bodies of the lords of sages that are blazing with the luster well refined, well rubbed, and polished gold.

15. I worship the most glorious lords of sages with all wonderfully fragrant and pleasing blossoms-mandarava flowers, blue lotus's, and others-and with splendidly arranged garlands.

16. I perfume them with enchanting clouds of incenses having a pungent and pervasive aroma. I offer them feasts consisting of various foods and drinks.

17. I offer them jeweled lamps, mounted in row of golden lotuses; and I scatter lovely drifts of blossoms on the floor, anointed with perfume.

18. To those filled with love I also offer brilliant multitudes of palaces, delightful with songs of praise, radiant with garlands of pearls and jewels, and ornamented at the entrances in four directions.

19. I bring to mind the great sages exquisitely beautiful, jeweled parasols perfectly raised with golden handles, lovely shapes, and inlaid pearls.

20. Thereafter, may delightful clouds of offerings rise high, and clouds of instrumental music that enrapture all sentient beings.

21. May showers of flowers, jewels and the like continually fall on the images, reliquaries, and all the jewels of the sublime Dharma.

22. Just as Manjughosa and others worship the Jinas, so do I worship the Tathágatas, the protectors, together with their children.

23. With hymns that are seas of melodies, I praise the oceans of virtues. May the clouds of harmonies of praise ascend to them in the same way.

24. With prostrations as numerous as the atoms within all the Buddha-fields, I bow to the Buddha's present in all the three times, to the Dharma, and to the sublime assembly,

25. Likewise, I pay homage to all the shrines and resting places of the Bodhisattva. I prostrate to the preceptors and to the praiseworthy adepts as well.

26. I go for refuge to the Buddha as far as the quintessence of enlightenment; I go for refuge to the Dharma and the community of Bodhisattvas.

27. With folded hands I beseech the Fully Awaked Ones present in all directions and the greatly compassionate bodhisattvas.

28. Whatever sin, I, a brute, have committed or caused others to commit in this life and others throughout the beginning less cycle of existence,

29. And anything in which I have improperly rejoiced, thereby harming myself, that transgression I confess, overcome by remorse

30. Whatever offence I have committed, out of disrespect, with my body, speech, and mind against the Three Jewels, against mother and fathers, and against spiritual mentors and others,

31. And whatever terrible vices, I, a sinner, defiled with many faults, have done, O Guides, I confess them all.

32. How shall I escape it? Rescue me quickly! May death not soon creep up on me before my vices have vanished!

33. Death does not differentiate between tasks done and undone. This traitor is not to be trusted by the healthy or the ill, for it is like an unexpected, great thunderbolt.

34. I have committed various vices for the sake of friends and enemies. This I have not recognized: "Leaving everyone behind, I must pass away."

35. My enemies will not remain, nor will my friends remain. I shall not remain. Nothing will remain.
36. Whatever is experienced will fade to a memory. Like an experience in a dream, everything that has passed will not be seen again.

37. Even in this life, as I have stood by, many friends and enemies have passed away, but terrible sin induced by them remains ahead of me.

38. Thus, I have not considered that I am ephemeral. Due to delusion, attachment, and hatred, I have sinned in many ways.

39. Day and night, a life span unceasingly diminishes, and there is no adding to it. Shall I not die then?

40. Although lying here on a bed, and relying on relatives, I alone have to bear the feeling of being cut off from my vitality.

41. For a person seized by the messengers of death, what good is a relative, and what good is a friend? At that time merit alone is a protection, and I have not applied myself to it.

42. O Protectors, I, negligent, and unaware of this danger, have acquired many vices out of attachment to this transient life.

43. One completely languishes while being led today to have the limbs of ones body amputated. Parched with thirst, and with pitiable eyes, one sees the world differently.

44. How much more is one overpowered by the horrifying appearances of the Messengers of Death as one is consumed by the fevers of terror, and smeared with a mass of excrement?

45. With distressed glances, I seek protection in the four directions. Which good person will be my protection from this great fear?

46. Seeing the four directions devoid of protection, I return to confusion. What shall I do in that state of great fear?

47. Right now I go for refuge to the Protectors of the world whose power is great, to the Jinas, who strive to protect the world and who eliminate every fear.
48. Likewise, I earnestly go for refuge to the Dharma that is mastered by them and that annihilates the fear of the cycle of existence, and to the assembly of Bodhisattvas as well.

49. Trembling with fear, I offer myself to Samantabhadra, and of my own will I offer myself to Manjughosa.

50. Terrified, I utter a mournful cry to the Protector, Avalokita, whose conduct overflows with compassion, that he may protect me, a sinner.

51. Seeking protection, I earnestly invoke noble Akasagarbha, Ksitigarbha, and all the compassionate ones.

52. I bow to Vajri, upon the sight of whom, the Messengers of Death and other malevolent beings flee in terror to the four directions.

53. After neglecting your council, in terror I go to you for refuge now as I face this fear. Swiftly remove my fear!

54. Even one frightened by a fleeting illness would not disregard the physicians advice; how much more so one afflicted by the four hundred and four diseases,

55. Of which just one can annihilate all people living Jambudvipa, and for which a medicine is not found in any region.
56. If I disregard the council of the Omniscient Physician who removes every pain, shame on me, extremely deluded one that I am!

57. If I stand very attentive, even on a smaller cliff, how much more so on an enduring chasm of a thousand leagues?

58. It is inappropriate for me to be as ease, thinking, "Just today death will not arrive." The time when I will not exist in inevitable.

59. Who can give me fearlessness? How can I escape? I shall certainly not exist. Why is my mind at ease?

60. What of value has remained with me from earlier experiences, which have disappeared, and engrossed in which, I have neglected the council of spiritual mentors?

61. Upon forsaking my relatives and friends, and this world of the living, alone I shall go elsewhere. What is the use of all my friends and enemies?

62. In that case, only this concern is appropriate for me day and night: how shall I surely escape suffering on account of that non-virtue?

63. Whatever vice, whatever natural misdeed, and whatever misdeed by prohibition I, an ignorant fool, have accumulated,

64. Terrified of suffering, all this I confess, standing with folded hands in the presence of the Protectors and bowing repeatedly.

65. May the guides be aware of my transgressions, together with my inequity. O Protectors, may I not commit this evil again!

Chapter Three
Adopting the Spirit of Awakening

1. I happily rejoice in the virtue of all sentient beings, which relieves the suffering of the miserable states of existence. May those who suffer dwell in happiness!

2. I rejoice in sentient beings' liberation from the suffering of the cycle of existence, and I rejoice in the Protectors' Bodhisattva Hood and Buddhahood.

3. I rejoice in the teachers' oceanic expressions of the spirit of awakening, which delight and benefit all sentient beings.

4. With the folded hands I beseech the Fully Awakened Ones in all directions that they may kindle the light of Dharma for those who fall into suffering owing to confusion.

5. With folded hands I supplicate the Jinas who wish to leave for Nirvana that they may stay for countless eons, and that this world may not remain in darkness.

6. May the virtue that I have acquired by doing all this relieve every suffering of sentient beings!

7. May I be the medicine and the physician for the sick. May I be their nurse until their illness never recurs!

8. With showers of food and drink may I overcome the afflictions of hunger and thirst! May I become food and drink during times of famine.

9. May I be an inexhaustible treasury for the destitute! With various forms of assistance may I remain in their presence.

10. For the sake of accomplishing the welfare of all sentient beings, I freely give up my body, enjoyments, and all my virtues of the three times.

11. Surrendering everything is Nirvana, and my mind seeks Nirvana. If I must surrender everything, it is better that I give it to sentient beings.

12. For the sake of all beings I have made this body pleasure less. Let them continually beat it, revile it, and cover it with filth.

13. Let them play with my body. Let them laugh at it and ridicule it. What does it matter to me? I have given my body to them.

14. Let them have me perform deeds that are conductive to their happiness. Whoever resorts to me, may it never be in vain.

15. For those who have resorted to me and have an angry or unkind thought, may even that always become the cause for their accomplishing every goal.

16. May those who falsely accuse me, who harm me, and who ridicule me all partake of awakening!

17. May I be a protector for those who are without protectors, a guide for travelers, and a boat, a bridge, and a ship for those who wish to cross over!

18. May I be a lamp for those who seek light, a bed for those who seek rest, and may I be a servant for all beings who desire a servant.

19. To all sentient beings may I be a wish-fulfilling gem, a vase of good fortune, an efficacious mantra, a great medication, a wish-fulfilling tree, and a wish-granting cow.

20. Just as earth and other elements are useful in various ways to innumerable sentient beings dwelling throughout infinite space,

21. So may I be in various ways a source of life for the sentient beings present throughout space until they are liberated.

22. Just as the Sugatas of old adopted the spirit of awakening, and just as they properly conformed to the practice of the Bodhisattvas,

23. So I myself shall generate the spirit of awakening for the sake of the world; and so I myself shall properly engage in those practices.

24. Upon gladly adopting the spirit of awakening in this way, an intelligent person should thus nurture the spirit in order to fulfill his wish.

25. Now my life is fruitful. Human existence is well obtained. Today I have been born into the family of the Buddhas. Now I am a child of the Buddha.

26. Thus, whatever I do now should accord with the Bodhisattvas' family, and it should not be a stain on this pure family.

27. Just as a blind man might find a jewel amongst heaps of rubbish, so this spirit of Awakening has somehow arisen in me.

28. It is the elixir of life produced to vanquish death in the world. It is an inexhaustible treasure eliminating the poverty of the world.

29. It is the supreme medicine that alleviates the illness of the world. It is the tree of rest for beings exhausted from wondering on the pathways of mundane existence.

30. It is the universal bridge for all travelers on their crossing over miserable states of existence. It is the rising moon of the mind that soothes the mental afflictions of the world.

31. It is the great sun dispelling the darkness of the world's ignorance. It is the fresh butter formed from churning the milk of Dharma.

32. For the caravan of beings traveling on the path to mundane existence and starving for the meal of happiness, it is the feast of happiness that satisfies all sentient beings who have come as guests.

33. Today I invite the world to Sugata-hood and temporal happiness. May the gods, asuras, and other rejoice in the presence of all the Protectors!

Chapter Four
Attending to the Spirit of Awakening

1. Thus, upon firmly adopting the spirit of awakening, a child of the Jinas should always vigilantly strive not to neglect his training.

2. Although one has made a commitment, it is appropriate to reconsider whether or not to do that which has been rashly undertaken and has not been well considered.

3. But shall I discard that which has been examined by the sagacious Buddhas and their children, as well as by myself according to the best of my abilities?

4. If, upon making such a promise, I do not put it into action, then having deceived those sentient beings, what destiny shall I have?

5. It has been said that a person who intended to give away even a tiny thing but does not do so, becomes a preta.

6. Then all the more so, having deceived the entire world after loudly and sincerely inviting it to unsurpassable happiness, what state of existence shall I have?

7. Only the Omniscient One knows the inconceivable course of action of those people whom he liberates even when they forsake the spirit of awakening.

8. Therefore, for a Bodhisattva it is the heaviest downfall of all; for if he commits such a downfall, he impairs the welfare of all sentient beings.

9. If someone else hinders his virtue, even for a moment, there will be no end to his miserable states of existence, because he diminishes the welfare of sentient beings.

10. One would be destroyed, obliterating the well being of even one sentient being, how much more so of beings dwelling throughout all space?

11. Thus, due to the power of the downfalls and due to the power of the Spirit of Awakening, one revolving in the cycle of existence is slow in the attaining of bodhisattva grounds.

12. Therefore, I should respectfully act in accordance with my commitment. If I do not make an effort now, I shall go from lower to lower states.

13. Innumerable Buddhas have gone by, seeking out every sentient being, but through my own fault, I have not come into the domain of their cure.

14. If I remain like this, as I am now, I will repeatedly come to the miserable states of existence, illness, death, amputation, destruction and the like.

15. When shall I encounter the extremely rare appearance of the Tathágata, faith, human existence, and the ability to practice virtue,

16. Health, daily sustenance, and lack of adversity? Life is momentary and deceptive; and the body is as if on loan.

17. With such behavior on my part, a human state is certainly not obtained again. When a human state is not achieved there is only vice, and how could there be blessing?

18. If I do not perform virtue even when I am capable of it, what then shall I do when fully dazed by the sufferings of miserable states of existence?

19. For one does not perform virtue but accumulates sin, even the expression, "favorable state of existence" will be lost for a thousand million eons.

20. Therefore, the blessed one stated that human existence is extremely difficult to obtain, like a turtles head emerging into the ring of a yoke in a vast ocean.

21. One dwells in the Avichi Hell for an eon as a consequence of a vice committed in a single moment. What then can be said of a favorable state of existence, since sin has accumulated since beginning-less time?

22. Having experienced that alone, one is still not liberated. Therefore, while experiencing it, one begets more vices.

23. Upon obtaining such leisure, if I do not practice virtue, then there is no duplicity greater than this, and there is no delusion greater than this.

24. If I recognize this and, still deluded, fall into sloth, then when I am commanded by the messengers of Yama, I shall long remain in great anguish.

25. The unendurable fire of hell will scorch my body for ages, and afterward the fire of remorse will torment my undisciplined mind for a long time.

26. I have somehow obtained the advantageous state that is very difficult to achieve, and though aware of that, I am led back to those same hells.

27. I have no will in this matter, as if bewitched by spells. I do not know by whom I am bewitched or who dwells inside me.

28. Enemies such as craving and hatred are without arms, legs, and so on. They are neither courageous nor wise. How is it that they have enslaved me?

29. Stationed in my mind, they ruin me, while remaining well established themselves; and yet I do not get angry at my forbearance with this shameful and improper situation.

30. If all gods and humans were my enemies, even they would be unable to bring me to the fire of the Avichi Hell.

31. When encountered, it consumes even the ashes of Mount Meru. Mental afflictions, the mighty enemies, instantly throw me there.

32. For the longevity of all other enemies is not so enduring, beginning-less, and endless as that of my enemies, the mental afflictions.

33. Everyone becomes favorably disposed when tended with kindness, but when these mental afflictions are honored, they bring about suffering all the more.

34. How can I take delight in the cycle of existence when constant, long lasting enemies, who are the sole cause of the currents and floods of adversities, fearlessly dwell in my heart?

35. How can I be happy if the guardians of the prison of the cycle of existence, these murderers and slaughterers in hells and the like, remain in the cage of greed within the dwelling of my heart?

36. Therefore, as long as these enemies are not destroyed before my eyes, I shall not forsake my task. Those lofty with pride, who are enraged at someone who gives them even a minor insult, will not sleep until they kill him.

37. At the height of a battle, ready to slaughter those who are in darkness and who are naturally subject to suffering through death, those afflicted with injuries from countless spears and arrows do not turn back without accomplishing their goal.

38. What then when I am eager to destroy my natural enemies, which are the perpetual causes of all miseries? Today, even if I am beset with a hundred adversities, why am I weary and despondent?

39. If they wear scars from their enemies for no reason as if they were ornaments, then why do sufferings trouble me when I am set to accomplish a great goal?

40. If fishermen, outcasts, farmers, and others, whose minds are fixed merely on their own livelihoods, withstand the adversities of cold and heat, then why do I not endure for the sake the well being of the world?

41. While I have promised to liberate beings throughout space in the ten directions from their mental afflictions, I have not liberated even myself from the mental afflictions.

42. Without knowing my own limitations, I spoke at that time as if I were a bit insane. Therefore, I shall never turn back from vanquishing mental afflictions.

43. I shall be tenacious in this matter; and fixed on revenge, I shall wage war, except against those mental afflictions that are related to the elimination of mental afflictions.

44. Let my entrails ooze out and my head fall off, but by no means shall I bow down to my enemies, the mental afflictions.

45. Even if exiled, an enemy may acquire a residence and followers in another country whence he returns with his full strength. But there is no such course for my enemy, the mental afflictions.

46. Once the afflictions that dwell in my mind have been expelled, where could it go, and where would it go, and where would it rest and attempt to return and destroy me? Feeble in spirit, I am lacking in perseverance. Mental afflictions are frail and conquerable with the eye of wisdom.

47. Mental afflictions do not exist in sense objects, or in sense faculties, or in the space between, and not anywhere else. Then where do they exist and agitate the whole world? This is an illusion only. Liberate your fearing heart and cultivate perseverance for the sake of wisdom. Why would you torture yourself in hells for no reason?

48. After pondering in this way, I shall make an effort to apply the teachings as they have been explained. How can someone who could be cured by medicine be restored to health if he strays from the physician's advice?

Chapter Five
Guarding Introspection

1. Those who wish to protect their practice should zealously guard the mind. The practice cannot be protected without guarding the unsteady mind.

2. Untamed, mad elephants do not inflict as much harm in this world as does the unleashed elephant of the mind in the Avichi Hell and the like.

3. But if the elephant of the mind is completely restrained by the rope of mindfulness, then all perils vanish and complete well-being is obtained.

4. Tigers, lions, elephants, bears, snakes, all enemies, all guardians of hells,

5. Dakinis (evil spirits) and demons become controlled by controlling the mind alone. By subduing the mind alone, they all become subdued.

6. For the Propounder of the Truth (The Buddha) said that all fears and immeasurable sufferings arise from the mind only.

7. Who diligently constructed the weapons in hell? Who devised the floor of heated iron? And from where have those women come?

8. The sage declared that all of that has arisen from the evil mind, so there is nothing else on the three worlds more formidable than the mind.

9. If the perfections of generosity makes the world free from poverty, how is it possible that the Protectors of the past acquired it, when the world is still impoverished today?

10. The perfection of generosity is interpreted simply as a state of mind due to the intention of giving away everything, together with the fruits of that, to all people.

11. Where can fish and the like be taken where I could not kill them? When the mind of renunciation is obtained, that is considered the perfection of ethical discipline.

12. How many malicious people, as unending as space, can I kill? When the mind state of anger is slain, all enemies are slain.

13. Where would there be leather enough to cover the entire world? There earth is covered over merely with the leather of my sanders.

14. Likewise, I am unable to restrain external phenomena, but I shall restrain my own mind, what need is there to restrain anything else?

15. Even when accompanied by body and speech, feeble mental activity does not have results such as Brahma hood and alike, which the mind alone has when clear.

16. The omniscient One stated that all recitations and austerities, even through performed for a long time, are actually useless if the mind is on something else or dull.

17. Those who have not cultivated the mind, which is the mystery and the very essence of Dharma, uselessly wander in space in order to eliminate suffering and find happiness.

18. Therefore, I should well control and well guard my mind. Once I have forsaken the vow of guarding the mind, of what use are many vows to me?

19. Just as those standing in the midst of boisterous people carefully guard their wounds, so those standing in the midst of evil people should always guard their minds.

20. Fearing slight pain from a wound, I guard it with great care. Why don't I, fearing the crushing of the mountains of the Samghata hell, guard the wound of my mind?

21. Living with this attitude even among evil people and among maidens, with steadfast effort, a persevering sage will not be defeated.

22. Let my possessions freely vanish; let my honor, my body, livelihood, and everything else pass away. But may my virtuous mind never be lost.

23. I appeal to those desiring to guard their minds: always diligently guard your mindfulness and introspection.

24. Just as a person smitten by disease is unfit for any work, so the mind lacking those two is not fit for any work.

25. What has been heard, pondered, and cultivated, like water in a cracked jar, does not remain in the memory of the mind that lacks introspection.

26. Even many people who have faith and extraordinary perseverance become defiled by vices on account of the fault of lacking introspection.

27. Even upon accumulating virtues, those who have been robbed by the thief of non-introspection, who come after the loss of mindfulness, enter miserable states of existence.

28. This band of thieves, the mental afflictions, looks for an entrance. Upon finding an entrance, it plunders and destroys life in fortunate realms of existence.

29. Therefore, mindfulness should never be displaced from the gate of the mind. If it is gone, it should be reinstated while recalling the anguish of hell.

30. Mindfulness easily arises for those of good fortune because of their association with a spiritual mentor, and for those who are reverent on account of the instruction of a preceptor and because of their fear.

31. The Buddhas and Bodhisattvas have unobstructed vision in all directions. Everything is in their presence; and I stand in front of them.

32. Meditating thus, one should remain filled with a sense of propriety, respect, and fear; and one should repeatedly think of the Buddhas in this way.
33. When mindfulness stands guard at the gate of the mind, introspection arrives, and once it has come, it does not depart again.

34. First, I should establish this mind in such a manner, and I should always remain still as if without sense faculties like a piece of wood.

35. One should never cast one's gaze around without purpose. One should always direct one's gaze downwards as if in meditation.

36. However, one should occasionally look around in order to relax the gaze; and if someone should appear in the field of ones vision, one should look up and give a greeting.

37. In order to detect danger on the road and so forth, one should look to the four directions for a moment. Pausing, one should look in the distance, looking behind only after turning around.

38. Upon looking forward or behind, one should go ahead or turn back. Likewise, in all situations one should proceed after realizing what needs to be done.

39. Thinking, "The body should remain like this," and resorting to action again, one should periodically look afresh to see how the body is positioned.

40. In this way the mad elephant of the mind should be watched diligently so that it is not loosed while tied to the great pillar of the thought of Dharma.

41. One should examine the mind in this way-where is mine engaged-so that it does not even for a moment leave the pole of concentration.

42. If one is unable to do so in the case of danger or a festive occasion, then one should be at ease. It is said that at the time of giving, ethical discipline may be held in abeyance.

43. Upon recognizing what needs to be undertaken, with a mind focused on that, one should attend to nothing else until one accomplishes it.

44. For in this way everything is well done. Otherwise neither will occur, and the mental affliction of non-introspection will increase as well.

45. One should eliminate yearning that arises for various idle conversations, which often take place, and for all kinds of entertainment.

46. If useless crushing of the earth, ripping of grass, or drawing in the dirt takes place, then fearfully recalling the teaching of the Tathágata, one should instantly stop it.

47. When one intends to move or when one intends to speak, one should first examine one's own mind and then act appropriately with composure.

48. When one sees one's own mind to be attached or repulsed, then one should neither act nor speak, but remain still like a piece of wood.

49. When my mind is haughty, sarcastic, full of conceit and arrogance, ridiculing, evasive, and deceitful,

50. When it is inclined to boast, or when it is contemptuous of others, abusive, and irritable, then I should remain still like a piece of wood.

51. When my mind seeks material gain, honor, and fame, or when it seeks attendance and service, then I will remain still like a piece of wood.

52. When my mind is averse to the interests of others and seeks my own self interest, or when it wishes to speak out of a desire for an audience, then I will remain still like a piece of wood.

53. When it is impatient, indolent, timid, impudent, garrulous, or biased in my own favor, then I will remain still like a piece of wood.

54. Perceiving in this way that the mind is afflicted or engaged in fruitless activities, the hero should always firmly control it by means of an antidote to that.

55. Resolute, confidant, steadfast, respectful and courteous, modest, meek, calm, devoted to pleasing others,

56. Un-distressed by the mutually incompatible desires of foolish people, endowed with compassion, knowing that they are like this as a consequence of the arising of their mental afflictions,

57. Always resorting to irreproachable things for the sake of myself and others, I will maintain my mind free of pride, like an apparition.

58. Remembering over and over again that after a long time the best of moments of leisure has been attained; I will keep this mind unshakable, like Sumeru.

59. One does not object when the body is dragged here and there by vultures coveting its flesh. Then why do so now?

60. Mind, why do you protect this body, appropriating it as your own? It is really separate from you, what good is it to you?

61. Oh fool, if you do not consider as your own a pure wooden statue, why are you guarding this foul machine composed of impurities?

62. First, with your own intellect, peel off this sheath of skin, and with the knife of wisdom loosen the flesh from the skeleton.

63. Breaking the bones, look inside at the marrow and examine for yourself, "where is the essence here?"

64. If searching carefully in this way, you do not see an essence here, then say why you are still protecting the body today.

65. If you would not eat it, as impure as it is, and if you would not drink the blood not suck out the entrails, then what will you do with the body?

66. However, it is proper to guard it for the sake of feeding the vultures and the jackets. This wretched body of humans is an instrument for action.

67. Even though you protect it so, merciless death will snatch the body away and give it to the vultures. What will you do then?

68. You do not give clothing and such to a servant if you think he will not stay. The body will eat and pass away. Then why do you waste yourself?

69. Therefore, mind, upon giving the body its wages, now serve your own needs, because not everything earned by a laborer should be given to him.

70. Consider the body as a ship because it is the basis of coming and going. Set the body in motion at your will in order to accomplish the welfare of sentient beings.

71. One who has become self-controlled in that way should always have a smiling face. One should give up frowning and grimacing, be the first to greet, and be a friend to the world.

72. One should not inconsiderately and noisily throw around chairs and the like. One should not pound on the door, and one should always delight in silence.

73. The crane, the cat, or the thief, moving silently and covertly, achieves its desired goal. A sage should always move in such a way.

74. One must respectfully accept the advice of those skilled in directing others and providing unsolicited aide. One should always be a pupil of everyone.

75. One should express one's appreciation for all good words. Having seen someone engaging in virtue, one should cheer him on with praises.

76. One should speak of other's good qualities in their absence and relate them again with satisfaction; and when one's own virtue is discussed, one should consider it as appreciation for good qualities.

77. All endeavors are for the sake of satisfaction, which is difficult to obtain, even by means of wealth. So I will enjoy the pleasure of satisfaction in good qualities diligently accomplished by others.

78. There will be no loss for me in this life, and there will be great happiness in the hereafter. But due to animosities, there is the suffering of aversion and great misery in the hereafter.

79. In a soft and gentle voice one should speak sincere, coherent words that have clear meaning and are agreeable, pleasant to the ear, and rooted in compassion.

80. One should always look straight at sentient beings as if drinking them in with the eyes, thinking, "relying on them alone, I shall attain Buddhahood."

81. Great blessing arises from continuous yearning for the fields of virtues and kindness, and from an antidote with regard to those who are suffering.

82. Skillful and vigorous one should always do the work oneself. With respect to all works, one should not leave the opportunity to someone else.

83. The perfections of generosity and so forth are progressively more and more lofty. One should not forsake a better one for the sake of a lesser, unless it is with accordance with the bridge of the Bodhisattva way of life.

84. Realizing this, one should always strive for the benefit of others. Even that which is prohibited has been permitted for the compassionate one who foresees benefit.

85. Sharing with those who have fallen into miserable states of existence, with those who have no protector, and with mendicants, one should eat moderately small proportions. Except for the three robes, one should give away everything.

86. For the sake of an insignificant benefit one should not harm the body that practices the sublime Dharma, for only in this way can one quickly fulfill the hopes of sentient beings.

87. Therefore, when the thought of compassion is impure, one should not sacrifice one's life, but it should be sacrificed when one's thought is unbiased. Thus, life must not be wasted.

88. One should not teach the profound and vast Dharma to the disrespectful, to a healthy person wearing a headdress, to a person with an umbrella, a stick, or a weapon, to one whose head is veiled,

89. To those who are inadequate (whose minds are unprepared), nor to women in the absence of a man. One should pay equal respect to inferior and superior Dharmas.

90. One should not expose a vessel of the vast Dharma to an inferior Dharma. Putting aside the Bodhisattva way of life one should not seduce them with Sutras and Mantras.

91. Flagrantly discarding a tooth-stick or spitting is undesirable and urinating or so forth in water or on land that is useable is contemptible.

92. One should not eat with a full mouth, noisily, or with the mouth wide open. One should not sit with ones legs outstretched, and one should not rub one's hands together.

93. One should not travel, lie, or sit alone with some one else's spouse. After observing and inquiring, one should forsake everything that does not please people.

94. One should not point out anything with one's finger but should respectfully show the way with one's whole right hand.

95. One should not call out to someone and wave one's arms when there is little urgency, instead should snap one's fingers or the like. Otherwise, one could lose composure.

96. One should lie down in the preferred direction in the lion's posture of the lords Nirvana. One should get up quickly with vigilance and a prior determination.
97. The conduct of Bodhisattvas is described as immeasurable. One should first surely engage in practices that purify the mind.

98. Three times by day and three times by night one should recite the Triskandha. By that means one alleviates the remaining downfalls because of ones reliance on the Jinas and the Spirit of Awakening.

99. One should diligently apply oneself to the trainings that pertain to those situations in which one finds oneself, either of one's own accord or under the influences of others.'

100. For there is nothing that the Children of the Jina should not learn. For the good person who behaves in this way, there is nothing that is non-virtuous.

101. One should do nothing other than benefit sentient beings either directly or indirectly; and for the sake of sentient beings alone, one should subordinate everything to Awakening.

102. Never, even at the cost of ones life, should one forsake the spiritual friend who observes the vows of the Bodhisattva and who is well versed in the matters of the Mahayana.

103. One should learn from the Srisambhavavimoksa respectful behavior towards mentors. This and other advice of the Buddha should be known through reciting the sutras.

104. The practices are found in the sutras; therefore one should recite them, and then one should study the primary downfalls in the akasagarbhasutra.

105. One should definitely study the Sikasamuccaya again and again, because good conduct is explained there in detail.

106. Alternatively, one should first look at it briefly, and then carefully read the Sutramuccaya composed by Arya Nargarjuna.

107. Seeing what is forbidden and what is prescribed, one should implement those teachings for the sake of protecting people's minds.
108. In brief, this alone is the definition of introspection: the repeated examination of the state of one's body and mind.

109. I shall practice it with my body. What is the use of merely reading the words? Will a sick person have any benefit merely by reading about medical treatments?

Chapter Six
The Perfection of Patience

1. Anger destroys all the good conduct, such as generosity and worshipping the Sugatas, which has been acquired over thousands of eons.

2. There is no vice like hatred, and there is no austerity like patience. Therefore, one should earnestly cultivate patience in various ways.

3. The mind does not find peace, nor does it enjoy pleasure and joy, nor does it find sleep or fortitude when the thorn of hatred dwells in the heart.

4. Even dependents whom one rewards with wealth and honors wish to harm the master who is repugnant due to his anger.

5. Even friends fear him. He saddens his friends. He attracts with generosity but is not served. In brief, there is nothing that can make an angry person happy.

6. One who recognized hatred as the enemy, knowing that it creates sufferings such as these, and persistently overcomes it, becomes happy in this world and in the other.

7. Finding its fuel in discontent originating from an undesired event and from an impediment to desired events, anger becomes inflamed and destroys me.

8. Therefore, I shall remove the fuel of that enemy, for that foe has no function other than to harm me.

9. Even if I fall into extreme adversity, I should not disrupt my happiness. When there is frustration, nothing is agreeable, and virtue is forsaken.

10. If there is a remedy, then what is the use of frustration? If there is no remedy, then what is the use of frustration?

11. For loved ones and for oneself, one does not desire suffering, contempt, verbal abuse, or disgrace; but for an enemy, it is the opposite.

12. Happiness is obtained with great difficulty, whereas suffering occurs easily. Only through suffering is there release from the cycle of existence. Therefore, O mind, be strong!

13. The devotees of Durga and the people of Karnata needlessly endure the pain of burns, cuts, and the like. Why then am I timid when my aim is liberation?

14. There is nothing whatsoever that remains difficult as one gets used to it. Thus, through habituation with slight pain, even great pain becomes bearable.

15. Do you not consider the pain of bugs, gadflies, and mosquitoes, of thirst and hunger, and the irritation of a serious rash and the like as insignificant?

16. Cold, heat, rain, wind, traveling, illness, captivity, and beatings should not induce a sense of fragility. Otherwise, the distress becomes greater.

17. Some, seeing their own blood, show extraordinary valor, while some faint even at the sight of others blood.

18. That comes from mental fortitude or from timidity. Therefore, one should become invincible to suffering, and surmount pain.

19. Not even in suffering should a wise person disrupt his mental serenity, for the battle is with the mental afflictions; in battle pain is easily obtained and there is much agony.

20. Courageous victors are dismissive of all suffering, and they conquer such enemies as hatred. The rest just kill corpses.

21. Suffering has another quality since arrogance diminishes because of despair, and ones feels compassion for beings in the cycle of existence, fear, and sin, and a yearning for the Jina.

22. I am not angered at bile and the like even though they cause great suffering. Why be angry at those who have minds? They too are impelled by conditions.

23. Just as sharp pain arises although one does not desire it, so anger forcibly arises although one does not desire it.

24. A person does not intentionally become angry, thinking, "I shall get angry," nor does anger originate, thinking, "I shall arise."

25. All offences and vices of various kinds arise under the influence of conditions, and they do not arise independently.

26. An assemblage of conditions does not have the intention, "I shall produce," nor does that which is produced have the intention, "I shall be produced."

27. That which is regarded as the Primal Substance and that which is construed as the Self do not originate, thinking, "I shall come into being."

28. Since it has not arisen, how could it wish to come into existence? Since it engages with objects, it cannot strive to cease either.

29. If the permanent self is not sentient, it is obviously inactive like space. Even in conjunction with conditions, what activity does the immutable have?

30. What is the use of action to the self, which at the time of action is the same as it was before? If the relationship is that it has action, then which of the two is the cause of the other?

31. Thus, everything is dependent on something else, and even that on which something is dependent is not autonomous. Hence, why would one get angry at things that are inactive, like apparitions?

32. Qualm: Averting anger is inappropriate, for who averts what? Response: That is appropriate, because it is a state of dependent origination and is considered to be the cessation of suffering.

33. Therefore, upon seeing a friend or an enemy committing a wrong deed, one should reflect, "Such are his conditions," and be at ease.

34. If all beings would find fulfillment according to their own wishes, then no one would suffer, for no one wishes to suffer.

35. People hurt themselves with thorns and the like out of negligence, with fasting and so on out of anger, and by desiring to obtain inaccessible women and so forth.

36. Some kill themselves by hanging, by jumping from cliffs, by eating poison or unwholesome substances, and by non-virtuous conduct.

37. When under the influence of mental afflictions, they kill even their own dear selves in this way; then how could they have restraint toward the bodies of others?

38. If you do not even have compassion toward those who, intoxicated by mental afflictions, commit suicide, then why does anger arise?

39. If inflicting harm on others is the nature of the foolish, then my anger toward them is as inappropriate as it would be toward fire, which has the nature of burning.

40. If this fault is advantageous and if sentient beings are good by nature, then anger toward them is as inappropriate as it would be toward pungent smoke in the sky.

41. Disregarding the principle of cause, such as a stick and the like, if I become angry with the one who impels it, then it is better if I hate hatred, because that person is also impelled by hatred.

42. In the past, I too have inflicted such pain on sentient beings; therefore, I, who have caused harm to sentient beings, deserve that in return.

43. Both his weapon and my body are causes of suffering. He has obtained a weapon, and I have obtained a body. With what should I be angry?

44. Blinded by craving, I have obtained this boil that appears as a human body, which cannot bear to be touched. When there is pain, with whom should one be angry?

45. I do not desire suffering; yet, fool that I am, I desire the cause of suffering. When suffering emerges due to my own fault, why should I be angry with anyone else?

46. Just as the forest of razor leaves and the birds of hell are brought into existence by my actions, so is this. With whom should I be angry?

47. Those who hurt me are impelled by my actions, as a result of which they will go to the infernal realms. Surely, it is I alone who have ruined them.

48. On account of them, many vices of mine diminish through forbearance. On account of me, they enter infernal realms with long lasting agonies.

49. It is I alone who harm them, and they are my benefactors. O Wicked mind, why do you misconstrue this and become angry?

50. If there is virtue in my intention, I will not enter the infernal realms. If I protect myself, what will happen to them here?

51. If I were to retaliate, they would not be protected and my conduct would be impaired. Because of that, those in anguish would be lost.

52. Because of its immateriality, the mind can never be harmed by anyone. However, due to its attachment to the body, the mind is tormented by suffering.

53. Neither contempt, abusive speech, nor disgrace harms the body. Why then, mind, O mind, do you become angry?

54. Will the unkindness of others toward me devour me in this life or another, that I am so adverse to it?

55. If I am adverse to it because it hinders my material gain, my acquisitions will vanish in this life, but my sin will surely remain.

56. It is better that I die today, than have a long, corrupt life. For even after living a long time, I shall have the suffering of death.

57. One person wakes up after enjoying a hundred years of pleasure in sleep, and another person wakes up after being happy for a moment.

58. Does happiness return to either once they have awakened? It is the same at the moment of death for one who lives a long time and for one who lives a short time.

59. Even though I have acquired many possessions and have enjoyed pleasures for a long time, I shall depart empty handed and naked as if I had been robbed.

60. What if I destroy vice and perform virtue while living off my acquisitions? Do vice and the destruction of virtue not occur for one who gets angry on account of material gains?

61. If the meaning of my life vanishes, then what is the point of a life that creates only non-virtue?

62. If you think that your hatred toward one who disparages you is because he dries away sentient beings, why does your anger not arise also when others are defamed in the same way?

63. You have patience toward those who are unkind because their ungracious behavior is directed toward someone else, but you do not have patience toward one who disparages you when he is subject to the arising of mental afflictions.

64. My hatred toward those who revile and violate images, stupas, and the sublime Dharma is wrong, because the Buddhas and the like are free of distress.

65. As in the preceding case, one should ward off anger toward those who injure spiritual mentors, relatives, and friends, by seeing this as arising from conditions.

66. Harm is certainly inflicted on beings either by sentient beings or non-sentient things. This distress is felt in a sentient being, so endure that pain.

67. Some do wrong out of delusion, while others, being deluded, become angry. Among them, whom do we call innocent, and whom do we call guilty?

68. Why did I previously act in such a way that now I am harmed by others? All are subject to their actions. Who am I to alter this?

69. Realizing this, I shall strive for virtues in such a way that all will have loving thoughts toward each other.

70. When fire spreads from one burning house to another, one should bundle up the straw and the like, take it out, and discard it.

71. Likewise, when the mind burns with the fire of hatred due to attachment, one should immediately cast it aside because of the fear of burning the body of merit.

72. If one who is to be executed has his hand amputated and is released, is this unfortunate? If a person is freed from hell by human suffering, is this unfortunate?

73. If one who is unable to endure even this slight suffering of the present, then why does one not ward off anger, which is the cause of pain in hell?

74. Thus, solely due to anger I have brought myself into hells thousands of times, and I have not brought about benefit for myself or others.

75. But this suffering is not of that kind, and it will bring about great benefit. Only delight in suffering that eliminates the suffering of the world is appropriate here.

76. If others find pleasure and joy in praising the abundance of someone's good qualities, why, O mind, do you not praise it and delight in this way, too?

77. This joy from your rejoicing is a blameless source of happiness. It is not prohibited by the victorious ones, and it is the most excellent way to attract others.

78. If you do not like it, thinking that it is a pleasure for that person only, then if you were to stop giving wages and the like, your seen and unseen reward would be destroyed.

79. When your own good qualities are being praised, you want others to rejoice as well. When good qualities of someone else are being praised, you do not want happiness even for your self.

80. Upon generating the Spirit of Awakening out of the desire for the happiness of all sentient beings, why are you angry at sentient beings now that they have found happiness themselves?

81. If you desire sentient beings' Buddhahood, which is worshipped in the three worlds, then why are you burned up when you see them slightly honored.

82. One who nurtures a person who you should nurture is making you a gift. Upon finding a person who supports your family, are you not delighted, but angry?

83. What does one who wishes Awakening for sentient beings not wish for them? How can one who becomes angry at others' prosperity have the Spirit of Awakening?

84. If someone does not receive that gift and if it remains in the house of the benefactor, then you do not have it anyway. So what use is it to you, whether it is given away or not?

85. Why would you have him ward off merits, kind people, and his own good qualities? Let him not accept when he is being given something? Say, at what are you angry?

86. Not only do you not repent for sins you have committed, but you also wish to compete with others who have performed virtues.

87. If something unpleasant happens to your enemy, would your satisfaction make it happen again? It would not happen merely due to your desire, without a cause.

88. Even if that suffering were brought about by your desire, why would you take delight in that? If you say it brings you satisfaction, what is worse than that?

89. Once I am snagged by this horrible fishhook cast by the fishermen, the mental afflictions, I will certainly be stewed in infernal cauldrons by the guardians of hell.

90. Praise, fame, and honor are not conducive to my merit, long life, strength, health, or physical well-being.

91. If I recognize my own self-interest, what good is there in that for me? If I want only mental pleasure, I should devote myself to gambling, drinking, and so on.

92. For the sake of fame, some sacrifice their wealth, and even kill themselves. Yet what good are words? When one dies, who has that pleasure?

93. At the loss of praise and fame, my own mind appears to me just like a child who wails in distress when its sandcastle is destroyed.

94. Since a word is not sentient, it cannot praise me. But knowing that someone likes me is a cause of my delight.

95. Whether it is for someone else or for me, what good to me is the affection of another? That joy of affection belongs only to that person. Not even a tiny fraction of that belongs to me.

96. If I take pleasure in that person's pleasure, then I should take it in every single case. Why am I am unhappy when others are made happy through their favor for some one else?

97. Therefore, it is because I am being praised that pleasure arises in me. But due to such absurdity, this is nothing more than the behavior of a child.

98. Praise and so on distract me and remove my disillusionment with the cycle of existence. They stir up jealousy toward gifted people, and anger at their success.

99. Therefore, are those conspiring to destroy my reputation and so forth not protecting me from falling into hell?

100. The bondage of acquisition and honor is unfitting for me who seeks liberation. How can I hate those who are freeing me from bondage?

101. How can I hate those who, as if due to the Buddha's blessing, block the gate as I seek to enter suffering?

102. It is wrong to feel anger toward someone, thinking that person impedes my merit. As there is no austerity equal to patience, shall I not abide in that?

103. If on account of my own fault I do not practice patience here, then I myself have created an obstacle when grounds for merit have been presented.

104. If one thing does not exist without another, and does exist when the other is present, then that other thing is its cause. How can that be called a hindrance?

105. For a supplicant is not a hindrance to generosity at the time of alms giving; and when a person who bestows an ordination arrives, he is not called a hindrance to the ordination.

106. Beggars are easy to meet in the world, but malefactors are difficult to find, for no one will wrong me when I do no wrong.

107. Therefore, since my adversary assists me in my Bodhisattva way of life, I should long for him like a treasure discovered in the house and acquired without effort.

108. Thus, he and I have obtained the fruit of patience. It should be given to him first, for patience is caused by him.

109. If an adversary does not deserve respect because his intention was not that I accomplish patience, then why is the sublime Dharma honored? It too has no intention to be a cause of that achievement.

110. If an adversary is not respected because his intention is to cause harm, then for what other reason would I have patience toward him, if he is like a physician who is intent on my well-being!

111. Thus patience arises only in dependence on that evil intention, so he alone is the cause of my patience. I should respect him just like the sublime Dharma.

112. The sage has declared that the field of sentient beings is the field of the Jinas, because many have reached the highest fulfillment by honoring them.

113. As the attainment of the Buddhas qualities is equally due to sentient beings and the Jinas, how is it that I do not respect sentient beings as I do the Jinas?

114. Their greatness is not in terms of their intention but in terms of the result itself. The greatness of sentient beings is comparable to that, so they are equal.

115. A friendly disposition, which is honorable, is the very greatness of sentient beings. The merit due to faith in the Buddhas is the very greatness of the Buddhas.

116. Therefore, sentient beings are equal to the Jinas in their share in the acquisition of the qualities of the Buddha; but none of them are equal to the Buddhas, who are oceans of good qualities with endless portions.

117. If even a minute good quality of those who are a unique collection of the essence of good qualities is found in someone, not even the three worlds would be enough to honor that one.

118. Because sentient beings have some portion of the superb qualities of the Buddha, it is right to honor sentient beings for just that similarity.

119. Apart from respecting sentient beings, what other repayment to true friends, the immeasurable benefactors, is possible?

120. The kindness of the Bodhisattvas, who sacrifice their lives and enter Avichi, is repaid by service to sentient beings, so even if sentient beings harm one, they are to be treated with kindness.

121. Why do I generate pride and not act like a servant toward those masters for whose sake my Lords have no regard for their own selves?

122. The sages are delighted with their joy, and they are not pleased if they are harmed; by pleasing them, all the sages are overjoyed, and to injure them is to injure the sages.

123. Just as there is no mental pleasure in all sensual gratification whatsoever when ones body is on fire, likewise there is no way for the compassionate ones to be happy when sentient beings are in pain.

124. Therefore, whatever displeasure I have brought to all the great compassionate ones by harming sentient beings, I confess that sin today. Thus, may I be forgiven by the sages whom I have displeased!

125. In order to please the Tathágatas, today with my entire being, I place myself in the service of the world. Let streams of people step on my head and strike me down. May the Protector of the World be pleased!

126. There is no doubt whatsoever that those Compassionate Beings regard all beings as themselves. Are they not seen as the Protectors in the form of sentient beings? Why then is there disrespect for them?

127. This alone is pleasing to the Tathágatas. This alone is the accomplishment of one's goal. This alone removes the suffering of the world. Therefore, let this alone be my resolve.

128. When some king's man tyrannized the populace, the farsighted among them cannot retaliate.

129. Because that man is not alone, and his power is the kings power. So one should not disparage any weak person who has done wrong,

130. Since his power is the guardians of hell and the Compassionate Ones. Therefore, one should please sentient beings, just as a servant would a hot-tempered king.

131. What could an angry king do that would equal the anguish of hell, experienced as a result of inflicting mental pain on sentient beings?

132. What could a gratified king give that would equal Buddhahood, experienced as a result of delighting sentient beings?

133. Let alone future Buddhahood, do you not see that in this life, fortune, fame, and happiness ensue from pleasing sentient beings?

134. While transmigrating, a patient person, with beauty, health, charisma, and so forth, achieves longevity and the abundant joy of a Cakravati.

Chapter Seven
The Perfection of Zeal

1. Thus, one who has patience should cultivate zeal, because Awakening is established with zeal, and there is no merit without zeal, just as there is no movement without wind.

2. What is zeal? It is enthusiasm for virtue. What is said to be its antithesis? It is spiritual sloth, clinging to the reprehensible, apathy, and self-contempt.

3. Spiritual sloth arises from indolence, indulging in pleasures, sleep, and craving for lounging around due to ones apathy toward the miseries of the cycle of existence.

4. Scented out by the hunters, the mental afflictions, you have entered the snare of rebirth. Why do you not recognize even now that you are in the mouth of death?

5. You do not see that those of your own kind are gradually being killed. You even fall asleep like a buffalo among butchers.

6. When Yama watches you and your path is blocked on all sides, how can you enjoy eating, and how can you sleep and have sexual intercourse?

7. Since death will come swiftly, until it does, one should accumulate the collections of merit and knowledge. Even if one rejects spiritual sloth at the time of death, what will you do at this wrong time?

8. Thinking: "I have not achieved this. I have just started this, but it remains half done. Death has suddenly arrived, O I am wretched,"

9. Seeing despondent relatives with their eyes swollen and red, with tears on their faces from the impact of their grief, and the faces of the messengers of Yama,

10. Tormented by the recollection of your own vices, hearing the sounds of hell, and befouling your body with excrement out of fear, what will you do when you are so terrified?

11. Realizing, "I am like a live fish," (pulled from the water) your fear is appropriate now. How much more when you have committed vices and face the intense suffering of hell.

12. So, delicate one, you burn even when touched by hot water. Upon performing deeds leading to hell, how will you remain at ease?

13. You expect results with no effort. So delicate you are, and in so much pain! While in the clutches of death, you act like an immortal. Hey, miserable one, you are destroying yourself!

14. Upon finding the boat of human birth now, cross the great river of suffering. O fool, there is no time for sleep, for this boat is hard to catch again.

15. Forsaking the supreme joy of Dharma, which is an endless stream of joy, how can you delight in frivolity and jokes, which are two causes of suffering?

16. The absence of apathy, the array of abilities such as prudence, self-control, equality between oneself and others, and exchange of oneself for others

17. Should be practiced without the discouragement of thinking, "how can I possibly attain awakening?" For the truth speaking Tathágata proclaimed this truth:

18. "Even those who were gadflies, mosquitoes, bees, and worms attain supreme Awakening, which is difficult to attain, through the power of their effort."

19. Human by birth and capable of knowing what is beneficial and what is not, why could I not attain Awakening as long as I do not forsake the guidance of the Omniscient One?

20. If I fear, thinking, "I shall have to sacrifice my arms, legs, and the like," I may confuse the important with the insignificant due to my lack of discrimination.

21. For countless millions of eons I shall be cut, pierced, burned, and split open many times, but awakening will not occur.

22. However, this limited suffering of mine, which yields perfect Awakening, is like the suffering of extraction when removing the pain of an imbedded splinter.

23. All physicians cure with unpleasant treatments. Therefore, to destroy a multitude of pains, a slight one must be endured.

24. Although such treatment is customary, the Supreme Physician does not give it. He cures chronic diseases with gentle treatment.

25. At the beginning, the Guide prescribes giving vegetables and the like. One does it gradually so that later one can give away even one's own flesh.

26. When insight arises that ones own flesh is like the vegetable, then what difficulty is there in giving away one's own flesh and bone?

27. On account of abandoning vices, one does not suffer, and on account of being wise, one does not become troubled in mind; for mental pain is due to false conceptions, and bodily pain is due to sinful actions.

28. The body is well on account of merit; and the mind is joyful on account of wisdom. What can afflict a compassionate one who stays in the cycle of existence for the sake of others?

29. Extinguishing previous vices and accumulating oceans of merit, owing to the power of the Spirit of Awakening alone, one moves ahead of the Sravakas.

30. Upon mounting the chariot of the Spirit of Awakening, which carries away all despondency and weariness, what sensible person would despair at progressing in this way from joy to joy?
31. The powers of aspiration, steadfastness, delight, and letting go, are for the sake of accomplishing the benefit of sentient beings. Out of fear of suffering, one should generate that aspiration as one contemplates its blessings.
32. Uprooting its opposite in this way, one should strive to increase one's zeal with the powers of aspiration, self-confidence, delight, letting go, dedication, and determination.
33. I must eliminate immeasurable faults for myself and for others. While the eradication of every single fault may take myriads of eons,

34. I shall eliminate my own and others'
immeasurable faults. While it takes oceans of eons to eliminate each of those faults, if I do not see even a fraction of a beginning of the elimination of faults, why does my heart not burst, as I am a locus of immeasurable suffering?

35. I must acquire many good qualities for myself and for others; otherwise, the cultivation of every single good quality may not take place in myriads of eons.

36. I have never trained in even a small fraction of good qualities. It is astonishing that this life, which I have somehow obtained, has been spent in vain.

37. I have not found joy in great festivals and offerings to the Blessed One. I have not paid my respect to the teaching, nor have I fulfilled the hopes of the poor.

38. I have not granted fearlessness to the frightened, nor have I comforted the distressed. I became a spear in the womb just for my mother to suffer.

39. Due to my former lack of aspiration for Dharma, such a disaster has befallen me now. Who would forsake the aspiration for Dharma?

40. The sage declared that aspiration is a root of all virtues, and the root of that is constantly meditating on the results of the maturation of karma.

41. Miseries, depressions, various fears, and impediments to their desires befall those who do evil.

42. By performing an intended virtue, wherever one goes, one will be honored with the resultant benefits of one's merit.

43. But wherever the desire for happiness of the evildoers goes, their vices destroy it with weapons of sufferings.

44. On account of their virtues, the Children of the Sugata, who dwell in the hearts of spacious, fragrant, and cool lotuses, whose splendor is enhanced with the nourishment of the sweet voice of the Jina, and whose handsome bodies emerge from the Lotuses Blossomed by the rays of the Sage, are born in the presence of the Sugata.

45. On account of non virtues, one cries out in distress, one's entire skin is ripped away by the agents of Yama, one's body is immersed into copper melted by the heat of fire, pieces of one's flesh are cut off by hundreds of strokes of blazing spears and swords, and one repeatedly falls on intensely heated iron grounds.

46. Therefore, one should nurture an aspiration for virtue, cultivating it with reverence. Once one has begun, one should cultivate self confidence according to the method discussed in the Vajradhvaja Sutra.

47. After first examining one's means, one should either begin or not begin. Surely, it is better not to begin than to turn back once one has begun.

48. This habit continues even in another life; and due to that sin, suffering increases. Another opportunity for action is lost, and the task is not accomplished.

49. One should apply self-confidence to these three: actions, secondary mental afflictions, and ability. "I alone should do it" expresses self-confidence with regard to action.

50. This world overwhelmed by mental afflictions is incapable of accomplishing its own self-interest. Therefore, I must do it for them. I am not as incapable as the world is.

51. Why should someone else do inferior work while I stand by? If I do not do it out of pride, then it is better to let my pride be destroyed.

52. Even a crow behaves like a garuda when attacking a dead water snake. If my mind is weak, even a small adversity is troubling.

53. When one is made powerless by despondency, adversities are easily caused, but one who is uplifted and zealous is invincible even in the face of great adversities.

54. Therefore, with an unswerving mind, I shall bring disaster to adversity. For as long as I am conquered by adversities, my desire for victory over the three worlds is ludicrous.

55. I should overcome everything and not be overcome by anything. I should acquire this self-confidence, for I am a Child of Lions, the Jinas.

56. Beings who are overcome with pride are wretched and not self-confident; they are under the power of the enemy, pride. A self-confident person does not succumb to the power of the enemy.

57. Led by pride to miserable states of existence, they are devoid of joy even in human life. They are slaves who eat others' morsels, stupid, ugly, and feeble.

58. They are despised everywhere, puffed up with pride, and miserable. If they are included among the self confident, they are pitiable. Say, of what kind are they?

59. They are self confident and victorious heroes who bear their self-confidence in order to conquer the enemy, pride. Upon killing that growing enemy, pride, they demonstrate the fruit of their victory to the world as they please.

60. Abiding amidst a multitude of mental afflictions, one should be vigorous in a thousand and unconquerable by the hosts of mental afflictions, like a lion by a herd of deer.

61. Even in great troubles, the eye does not perceive flavor. Likewise, upon encountering difficulty, one should not be overcome by mental afflictions.

62. One should diligently apply oneself to the action in which one engages. Intoxicated by that action, one should be of an insatiable mind, like one striving for the satisfaction of the result of a game.

63. An action is performed for the sake of happiness, and yet happiness may or may not occur. But how can one who delights in action itself be happy when inactive?

64. In the cycle of existence, there is no satisfaction in sensual desires, which are like honey on a razors edge. How can there be satiation with the nectar of merits, which are sweet in their maturation and beneficial?

65. Therefore, even upon the completion of an action, one should immerse oneself in it again, just as an elephant, scorched by the midday sun, immediately approaches a lake.

66. And when one's strength begins to decline, one should quit so that one can re-engage later. When a task has been well completed, one should leave it with the desire for more and more.

67. One should ward off the blows of mental afflictions and severely attack them, as if engaged in a sword-combat with a trained enemy.

68. Just like one would quickly, fearfully pick up a dropped sword, so one should pick up the dropped sword of mindfulness, while bearing the hells in mind.

69. Just as a poison spreads throughout the body once it has reached the blood, so does a fault spread throughout the mind once it has reached a vulnerable spot!

70. A practitioner should be like someone carrying a jar of oil while under the scrutiny of swordsmen, careful of stumbling out of fear of death.

71. Therefore, just as one quickly jumps up when a snake creeps into one's lap, so should one swiftly counteract the advent of drowsiness and sloth!

72. At every single disgrace, one should burn with remorse and ponder: "How shall I act so that this does not happen to me again?

73. One should seek for companionship or for an appointed task with this motive: "how may I practice mindfulness in these circumstances?"

74. Bringing to mind the teaching on conscientiousness, one should arouse oneself so that one is always prepared before encountering a task.

75. Just as cotton is swayed in the direction of the winds coming and going, so should one surrender oneself to one's enthusiasm, and in this way one's supernormal powers will thrive.

Chapter Eight
The Perfection of Meditation

1. Upon developing zeal in that way, one should stabilize the mind in meditative concentration, since a person whose mind is distracted lives between the fangs of mental afflictions.

2. With bodily and mental seclusion, distraction does not arise. Therefore, upon renouncing the world, one should renounce discursive thoughts.

3. On account of attachment and craving for gain and the like, one does not renounce the world. Thus, upon forsaking them, the wise should contemplate in this way.

4. Realizing that one who is well endowed with insight through quiescence eradicates mental afflictions one should first seek quiescence. Quiescence is due to detachment toward the world and due to joy.

5. For what impermanent person, who will not see his loved ones again in thousands of births, is it appropriate to be attached to impermanent things?

6. Failing to see them, one does not find joy nor does one abide in meditative concentration. Even upon seeing them, one does not become satisfied but is tormented by strong desire, just as before.

7. One does not perceive reality and loses disillusionment with the cycle of existence. One is consumed by that grief-desire for the company of the beloved.

8. Because of thinking of that person, life ever so swiftly passes in vain. Due to a transient entity, the eternal Dharma is lost.

9. One who acts in the same manner as foolish people definitely goes to a miserable state of existence. They do like someone who is different. What is gained from association with fools?

10. One moment they are friends, and the next moment they are enemies. On an occasion for being pleased, they become angry. Ordinary people are difficult to gratify.

11. When given good advice, they become angry; and they turn me away from good advice. If they are not listened to, they become angry and go to a miserable state of existence.

12. They feel envy toward a superior, competitiveness with a peer, arrogance toward one who is inferior, conceit due to praise, and anger due to reproach. When could there be any benefit from a fool?

13. Between one fool and another, something non-virtuous is inevitable, such as glorification of one's own self, speaking ill of others, and conversation about the pleasures of the cycle of existence.

14. Thus, on account of one's association with someone else, one encounters adversity. I shall happily live alone with a non-afflicted mind.

15. One should flee far from a fool. One should gratify the encountered person with pleasantries, not with the intention of intimacy but in the manner of a kind and impartial person.

16. Taking only what benefits Dharma, like a bee taking nectar from a flower, I shall live everywhere without acquaintance, as if I had not existed before.

17. A mortal who thinks, "I am rich and respected, and many like me," experiences fear of approaching death.

18. Wherever the mind, infatuated by pleasures, finds enjoyment, there a thousand-fold suffering arises and falls to one's share.

19. Hence, the wise should not desire it. Fear arises from desire, yet it passes away by itself. Generate fortitude and look at it with indifference.

20. Many have become wealthy and many have become famous, but no one knows where they have gone with their wealth and fame.

21. If others despise me, why should I rejoice when praised? If others praise me, why should I be despondent when reviled?

22. If sentient beings of different dispositions have not been satisfied by the Jinas themselves, then how could they be like an ignorant person like myself? So, what is the point of attending to the world?

23. They revile a person without acquisitions, and despise a person with acquisitions. How can those whose company is by nature suffering bring forth joy?

24. The Tathágatas have said that a fool is no ones friend, because the affection of a fool does not arise without self-interest.

25. Love due to self-interest is love for one's own sake, just as distress at the loss of possessions is occasioned by the loss of pleasures.

26. Trees do not revile nor can they be pleased with effort. When might I dwell with those whose company is a delight?

27. When shall I dwell in a cave, an empty temple, or at the foot of a tree, without looking back, and without attachment?

28. When shall I dwell, living freely and without attachment, in unclaimed and naturally spacious regions?

29. When shall I dwell with a paltry alms bowl and so on in clothing wanted by no one, living fearlessly, even without concealing my body?

30. When shall I go to the local charnel grounds and compare my own body, which has the nature of decay, with other corpses?

31. For this body of mine will also become so putrid that even the jackals will not come near it because of the stench.

32. If the flesh and bone that have arisen together with this body will deteriorate and disperse, how much more is this the case for other friends?

33. A person is born alone and also dies alone. No one else has a share in one's agony. What is the use of loved ones who create hindrances?

34. Just as one who has undertaken a journey takes lodging, so does one who travels in the cycle of existence take lodging in a rebirth.

35. Until one his hoisted by four men and mourned by the world, one should retire to the forest.

36. Without intimacy and without conflict, one dwells in physical solitude, and when one is counted as if already dead no one grieves when one actually dies.

37. There is on one to inflict grief and harm, nor is there any one to distract one from the recollection of the Buddha and so forth.

38. Thus, I shall always dwell alone in the delightful forest, which creates few problems, good cheer, and the pacification of all distraction.

39. Free from all other concerns and having a single-pointed mind, I shall apply myself to meditative concentration and to the subjugation of the mind.

40. Casting off all other concerns, and with a single pointed mind, I shall strive to balance and subdue my mind. In this world and the next, sensuous desires create troubles, such as murder, imprisonment, and dismemberment in this life, and hell and so forth in the next.

41. She for whom you have supplicated male and female messengers many times and for whose sake you have not considered the cost of either vice nor disgrace,

42. Throwing yourself into danger and wasting your health, embracing her with the greatest pleasure-

43. She is nothing but bones, indifferent and impersonal. Why do you not resort to emancipation, fully embracing it to your hearts content?

44. Either you have seen that bashfully lowered face before as being lifted up with effort, or you have not seen it as it was covered by a veil.

45. Just as that face that torments you is perceived now, so you will see it unveiled by vultures. Why does it make you flee now?

46. Since you guarded her face from the gaze of others, why do you, O avaricious one, not guard it as it is being eaten?

47. Seeing this mass of flesh being eaten by vultures and others, should you worship others food with wreaths of flowers, sandalwood paste, and ornaments?

48. You fear a skeleton that has been seen like this, even though it does not move. Why do you fear it when it moves, as if set in motion like some ghost?

49. Their saliva and excrement arise from the same food. Why then do you dislike excrement, and like sucking saliva?

50. Taking no delight in cotton pillows that are soft to the touch, the lustful, who are deluded with respect to filth, say the body does not emit a foul odor?

51. The lustful, degraded, and deluded have distain for soft cotton, saying, "It can't engage in intercourse."

52. If you say 'I do not lust after filth,' why do you embrace on your lap something else that is a skeleton tied together with sinews, and plastered over with a mire of flesh?

53. You have plenty of filth yourself, and you always have the use of it, yet out of craving, you desire the filth in another sack of muck.

54. Casting aside a fresh lotus opening, under the rays of the cloudless sun, why do you, with your filth-craving mind, take delight in a container of muck?

55. The mind that you desire cannot be seen or touched; and that which can be is not conscious. Why do you embrace in vain?

56. It is not surprising that you do not look at another persons body as composed of filth, but it is astonishing that you do not perceive your own body as composed of filth.

57. Thinking, "I like its flesh," you wish to touch it and look at it. Why do you not desire the flesh of a dead body, which, by nature, is not sentient?

58. If you do not desire to touch soil and the like because it is smeared with excrement, how can you wish to touch the body out of which it is excreted?

59. If you do not have passion for what is impure, why do you embrace someone else, who is a seed or arisen from a field of filth and nourished by it?

60. You do not desire a dirty worm originating from filth because it is small, but you desire a body that consists of much filth and also born from filth.

61. Not only do you not abhor your own filth, out of craving, you desire other filthy sacks of excrement.

62. Even the ground is considered impure when savory foods, such as camphor or boiled rice and condiments, are spat out or vomited from the mouth.

63. If you do not trust that this is filth even though it is obvious, look at other bodies too, repugnant and discarded in the charnel ground.

64. Knowing that great fear arises when the skin is torn off, how can you have attraction to that same thing again?

65. Although applied to the body, this fragrance is from sandalwood and not from anything else. Why are you attracted to someone by the fragrance that belongs to something else?

66. If attraction does not arise due to a naturally foul smell, is that not good? Why do people take pleasure in what is worthless and anoint it with fragrance?

67. If it is sandalwood that is sweet smelling, did it come from the body? Why is someone attracted to someone because of a fragrance that belongs to something else?

68. If the naked body, containing the slime of filth, is frightening in its natural condition, with its long hair and nails and stained yellowish teeth,

69. Why do you meticulously polish it like a weapon for suicide? This earth is crowded with the insane, so diligent in deluding themselves!

70. If you are repelled upon seeing just skeletons in a charnel ground, are you attracted to a village, which is a charnel ground crowded with animated skeletons?

71. Thus, that filth is not gained without a price. Due to accomplishing that end, one is afflicted with fatigue and tormented in hells.

72. A child cannot increase its wealth, so with what is one happy when one is a youth? When ones life is spent accumulating wealth, what good is sensual gratification once one is old?

73. Some debased sensualists exhaust themselves with work throughout the day; then upon coming home, their depleted bodies fall asleep like the dead.

74. Others are afflicted by traveling abroad and suffer as they are far from home; and though they long for their wives and children, they do not see them for years on end.

75. Deluded by sensual desires, they sell themselves for that which they never acquire. Instead, their life is uselessly spent in labor for others.

76. The wives of those who have sold themselves and who always carry out commissions give birth at the feet of trees in the jungles and other inappropriate places.

77. In order to make a livelihood they enter war that endangers their lives, and they become servants for the sake of their self-respect. They are fools ridiculed for their sensual desires.

78. Some other sensualists are mutilated, fixed on a stake. They are seen being burned, and slain with daggers.

79. Consider wealth as an unending misfortune because of the troubles of acquiring, protecting, and losing it. Those who are distracted by attachment to wealth have no opportunity for liberation from the suffering of mundane existence.

80. Thus, sensualists have much distress and little enjoyment, like a beast that has hold of a bit of grass while pulling a wagon.

81. For the sake of that bit of enjoyment, which is easily obtainable even for an animal, an ill-fated one has destroyed this leisure and endowment, which is very difficult to find.

82. Sensual gratification is definitely transient and it casts one down to hell and so forth, and for no great end, one is constantly weary.

83. With even a billionth part of that diligence, there can be Buddhahood. Sensualists have suffering greater than the suffering of the Path, but they have no Awakening.

84. If one considers the suffering of the hells and so on, weapons, poison, fire, precipices, and enemies do not compare to sensual desires.

85. Becoming disillusioned with sensual desires in that way, generate delight in solitude in the peaceful forest, devoid of strive and annoyances.
86. The fortunate, pondering on how to benefit others, roam about, caressed by silent, gentle forest breezes, and cooled by the sandalwood rays of the moon on the lovely mansions of vast boulders.
87. In an empty hut, at the foot of a tree, or in a cave, one remains as long as one desires, and casting off the suffering of guarding ones possessions, one lives light heartedly, without a care.
88. Living freely, without attachment, and not tied by anyone, one savors the joy of contentment that is difficult even for a king to find.
89. After meditating on the advantages of solitude in this and other ways, having one's discursive thoughts calmed, one should cultivate the spirit of awakening.

90. One should first earnestly meditate on the equality of oneself and others in this way: "All equally experience suffering and happiness, and I must protect them as I do myself."

91. Although it has many divisions, such as arms and so one, the body is protected as a whole. Likewise, different beings, with their joys and sorrows, are all equal, like my self, in their yearning for happiness.

92. Even though my agony does not hurt anyone else's body, that suffering of mine is unbearable because I cling to it as mine.

93. Likewise, although others' suffering does not descend upon me, that suffering of theirs is difficult to bear because they cling to it as 'theirs.'

94. I should eliminate the suffering of others because it is suffering, just like my own suffering. I should take care of others, just as I am a sentient being.

95. When happiness is equally dear to others and myself, then what is so special about me that I strive after happiness for myself alone?

96. When fear and suffering are equally abhorrent to others and myself, then what is so special about me that I protect myself but not others

97. If I do not protect them because I am not afflicted by their suffering, why do I protect my body from the suffering of a future body, which is not my pain?

98. The notion that I will experience that is mistaken, for the one who has died is born elsewhere and is someone else.

99. If one thinks a person's suffering should be warded off by himself, since pain of the foot is not of the hand, why should the one take care of the other?

100. If one argues that even though it is inappropriate, it happens because of a grasping onto a self, our response is: with all ones might, one should avoid that which is inappropriate, whether it belongs to oneself, or to another.

101. The continuum of consciousness, like a series, and the aggregation of constituents, like an army and such, are unreal. Since one who experiences suffering does not exist, to whom will that suffering belong?

102. All sufferings are without an owner, because they are not different, they should be warded off, simply because they are suffering. Why is any restriction made in this case?

103. Why should suffering be prevented? Because everyone agrees. If it must be warded off, then all of it must be warded off; and if not, then this goes for oneself as it does for everyone else.

104. Qualm: much suffering arises from compassion, so why should one force it to arise? Response: After seeing the suffering of the world, how can this suffering from compassion be considered great?

105. If the suffering of many disappears because of the suffering of one, then a compassionate person should induce that suffering for his own sake and for the sake of others.

106. Therefore, Supuspacandra, although knowing the king's animosity, did not avoid his own suffering as a sacrifice for many people in misery.

107. Thus, one whose mind stream is accustomed to meditation and who delights in calming the suffering of others enters into Avichi Hell like a swan into a pool of Lotuses.

108. When sentient beings are liberated, they have oceans of joy. Is that not enough? What is the point of desiring ones own liberation?

109. Thus, although working for the benefit of others, there is neither conceit nor dismay; and on account of the thirst for the single goal of benefiting others, there is no desire for the result of the maturation of ones Karma.

110. Therefore, to the extent that I protect myself from disparagement, so shall I generate a spirit of protection and a spirit of compassion toward others!

111. Due to habituation, there is a sense that "I" exists in the drops of blood and semen that belongs to others, even though the being in question does not exist.

112. Why do I not also consider another's body as myself in the same way, the otherness if my own body is not difficult to determine?

113. Acknowledging oneself as fault-ridden and others as oceans of virtues, one should contemplate renouncing one's self-identity and accepting others.

114. Just as the hands and the like are cherished because they are members of the body, why are the embodied beings not cherished in the same way, for they are the members of the world?

115. Just as the notion of a self with regard to one's own body, which has no personal existence, is due to habitation, will the identity of one's self with others not arise in the same way?

116. Although working for the benefit of others in this way, there is neither conceit nor dismay. Even upon feeding oneself, expectation of a reward does not arise.

117. Therefore, just as you protect yourself from even minor disparagement, cultivate a spirit of protection and a spirit of compassion toward the world.

118. Hence, out of great compassion Lord Avalokita (Bodhisattva Avalokitesvara) blessed his own name to dispel even the anxiety of being in a crowd.

119. One should not turn away from difficulty, since owing to the power of habituation, one may have no pleasure in the absence of something that one previously feared to hear mentioned.

120. One who wishes to protect oneself and others quickly should practice exchanging oneself for others, which is a great mystery.

121. If even at a small danger fear arises on account of great attachment to oneself, why should one not abhor that self like a terrifying enemy?

122. One who kills birds, fish, and deer, and sets up an ambush with the desire to quell illness, thirst, and hunger,

123. One, who kills one's parents and steals the property of The Three Jewels for the sake of profit and respect, will become fuel in the Avichi Hell.

124. What wise person would desire, protect, and venerate such a self? Who would not see it as an enemy, and who would respect it?

125. If, out of concern for oneself, one thinks: "if I give it away, what shall I enjoy?" This is a fiendish state. If out of concern for others one thinks: "if I enjoy it, what shall I give away?" This is a divine state.

126. Upon harming another for one's own sake, one is burnt in hells and the like; but upon afflicting oneself for the sake of others, one has success in everything.

127. The desire for self-aggrandizement leads to a miserable state of existence, low status, and stupidity. By transferring that same desire to someone else, one obtains a fortunate state of existence, respect, and wisdom.

128. By ordering another around for ones own sake, one experiences the position of a servant and the like; but by ordering oneself around for the sake of others, one experiences the position of a master and the like.

129. All those who are unhappy in the world are so as a result of their desire for their own happiness. All those who are happy in the world are so as a result of their desire for the happiness of others.

130. Enough of such talk! Note the difference between the fool who seeks his own benefit, and the sage who works for the benefit of others.

131. One, who does not exchange his own happiness for the suffering of others, surely does not achieve Buddhahood. How could one find happiness even in the cycle of existence?

132. Not to mention the next life, even in this life, a desired goal of a servant who does not do his work, and of a master who does not pay out the wages, cannot be accomplished.

133. Forsaking the generation of mutual happiness and the felicity of present and future happiness, deluded people take on tremendous suffering because of harming one another.

134. If all the harm, fear, and suffering in the world occur due to grasping onto the self, what use is that great demon to me?

135. Without forsaking one's own self, one cannot avoid suffering, just as without avoiding the fire one cannot avoid being burned.

136. Therefore, in order to alleviate my own suffering and to alleviate the suffering of others, I give myself up to others, and I accept others as my own self.

137. O mind, make this resolve: "I am bound to others." From now on you must not be concerned with anything but the welfare of all sentient beings.

138. It is inappropriate to seek one's own welfare with the eyes and so on that are dedicated to others. It is inappropriate to pour one's own benefit with hands that are dedicated to others.

139. Therefore, becoming subservient to sentient beings, and snatching away whatever you see on this body, use it for the well being of others.

140. Placing your own identity in inferior ones and placing the identity of others in your own self, cultivate envy and pride with the mind free of discursive thoughts.

141. He is respected, not I. I am not wealthy, as he is. He is praised, while I am despised. I am unhappy, while he is happy.

142. I do chores while he lives at ease. It seems he is great in the world, while I am debased, lacking in good qualities.

143. What can one do without good qualities? Every person is endowed with good qualities. There are those with regard to whom I am inferior, and there are those with regard to whom I am superior.

144. The degeneration of my ethical discipline, views, and so on is due to the power of mental afflictions and not my own free will. You must heal me as well as you can, and I shall accept the pain.

145. If he cannot cure me, why does he disdain me? What use are his good qualities to me when he is the one who has good qualities?

146. He has no compassion for beings who dwell in the jaws of the beast of prey of miserable states of existence. Moreover, out of pride in his qualities, he desires to surpass the wise.

147. Seeing himself as being equal to others in order to enhance his own superiority, he will obtain wealth and respect for himself even by means of discord.

148. Were my good qualities to become apparent to everyone in the world, then no one would ever even hear of his good qualities.

149. Were not my faults to be concealed, there would be honor for me and not for him. Today, I have easily acquired possessions. I am honored while he is not.

150. Delighted, we shall watch him, as he is finally being ill treated, ridiculed and reviled from all sides.

151. Also, it seems this wretched one is competing with me does he have this much learning, wisdom, beauty, noble ancestry, and wealth?

152. Hearing my own good qualities being praised everywhere in this way, thrilled, with my hair standing on end, I shall enjoy the delight of happiness.

153. Even though this one has possessions, they are to be taken over with my strength; and if he works for me, I will give him just enough to survive.

154. We should deprive him of happiness and always yoke him to our anguish. We all have been afflicted in the cycle of existence hundreds of times by him.

155. O mind, countless eons have passed as you have yearned to accomplish your own self-interest, but with such great toil you have gained only suffering.

156. Thus, definitely apply yourself in this way right now without hesitation. Later you will see the advantages of this, for the words of the Sage are true.

157. If you had carried out this task earlier, this state deprived of the perfection and bliss of the Buddha would not have occurred.

158. Therefore, just as you formed a sense of self-identity, with regard to the drops of blood and semen of others, contemplate others in the same way.

159. Living as one who belongs to others and snatching away whatever you see on this body, practice what is beneficial to others.

160. Arouse envy towards your own self in this way: I am well while the other is miserable; the other is lowly while I am exalted; the other works while I do not.

161. Deprive yourself of happiness and expose yourself to the suffering of others. Examine your own faults with the consideration, "what have I done, at what time?"

162. Take the mistake made by another on your head, and disclose even a trivial mistake of yours to the Great Sage.

163. Let your own reputation be outshone by exalting the reputation of others, and like the least of servants, commit yourself to everyone's welfare.

164. This one of defective nature should not be praised for adventitious good qualities. Act so that no one may know of this one's good qualities.
165. In brief, whatever offense you have committed toward others for your own benefit, let it descend on yourself for the benefit of sentient beings.

166. This one should not be encouraged to be abusive, but should be established in the behavior of a young bride, modest, meek, and restrained.

167. Act in this way! Remain in this way! You should not do this! You should be subjugated and subdued in this way if you disobey.

168. O mind, if you do not do this even when you are being told, then I shall subjugate you alone, for all faults dwell in you.

169. Where will you go? I can see you, and I shall annihilate all your vanities. That was another, earlier time when I was ruined by you.

170. Now give up this hope: "Still, I have my own self interest!" Unconcerned as you are with much distress, I have sold you to others.

171. If I do not joyfully offer you to sentient beings, you will undoubtedly deliver me to the guardians of hell.

172. Handing me over in that way many times, you have tormented me for a long time. Remembering those grudges, I shall destroy you, the servant of your own self interest.

173. If you are pleased with yourself, you should take no pleasure in yourself. If you need protection, it is inappropriate to protect yourself.

174. The more this body is pampered, the more fragile it becomes, and the more it degenerates.

175. When it has degenerated in this way, not even this earth can completely fulfill its desire. Who then will satisfy its desire?

176. For one who desires the impossible, mental affliction and disappointment arise; but for one who is free of expectations there is unblemished prosperity.

177. Therefore, free rein should not be given to the growth of bodily desires. It is truly good when one does not take something that ones wants.

178. This awful, impure form has its end in ashes and stillness, moved only by another. Why do I grasp onto it as mine?

179. Of what use is this contrivance to me, whether it is dead or alive? What difference is there between this and a clump of soil and the like? Alas, you are not eliminating the grasping onto the "I."

180. By favoring the body, one uselessly accumulates suffering. Of what use is anger or love to something equal to a piece of wood?

181. Whether it is nurtured by me, or eaten by vultures, it feels neither affection nor aversion, so why am I so fond of it?

182. If the body, which has no anger due to abuse, or satisfaction due to praise, is unconscious, then for whom am I exerting myself?

183. Those who like this body are said to be my friends. They all like their own bodies too, so why do I not like them?

184. Therefore, with indifference I have given up my body for the benefit of the world. Hence, although it has many faults, I keep it as an instrument for that task.

185. So enough of worldly conduct! Recalling the teaching on consciousness and warding off drowsiness and lethargy, I shall follow the wise.

186. Therefore, withdrawing the mind from evil ways, I shall always concentrate it on its own meditative object to eliminate obscurations.

Chapter Nine
Affection of Wisdom

1. The Sage taught this entire system for the sake of wisdom. Therefore, with the desire to ward off suffering, one should develop this wisdom.

2. This truth is recognized as being of two kinds: conventional and ultimate. Ultimate reality is beyond the scope of the intellect. The intellect is called conventional reality.

3. In the light of this, people are seen to be of two types: the contemplative and the ordinary person; the ordinary folks are superseded by the contemplatives. [The contemplative perceives the ordinary, worldly persons viewpoint to be incorrect. (Ed.)]

4. Due to the difference in their intelligence, even contemplatives are refuted by successfully higher ones by means of analogies accepted by both parties, regardless of what they aim to prove.

5. Ordinary people see and imagine things as real and not illusory. It is in this respect that there is disagreement between the contemplatives and the ordinary people.

6. Even the objects of direct perception, such as form and the like, are established by consensus and not by verifying cognition. That consensus is false, as is the general agreement that pure things are impure, for example.

7. The Protector taught things in order to bring people to understanding. Qualm: If these things are not ultimately, but only conventionally, momentary, this is inconsistent.

8. Madhyamika: There is no fault in the conventional truth of the contemplatives. In contrast to ordinary people, they see reality. Otherwise, ordinary people would invalidate the perception of women as impure.

9. Qualm: How can there possibly be merit due to the Jina who is like an illusion, as is the case if he is truly existent? If a sentient being is like an illusion, why is he reborn again after he dies?

10. Madhyamika: Even an illusion lasts for as long as the collection of its conditions. Why should a sentient being truly exist merely because its continuum lasts a long time?

11. Yogacarin: If consciousness does not exist, then there is no sin in killing an illusionary person. Madhyamika: On the contrary, when one is endowed with the illusion of consciousness, vice and merit do arise.

12. Yogacarin: an illusionary mind is not possible, since mantras and the like are unable to produce it. Madhyamika: Diverse illusions originate on account of diverse conditions. Nowhere does a single condition have the ability to produce everything.

13. Yogacarin: If one could be ultimately emancipated, and yet transmigrate conventionally, then even the Buddha would transmigrate. So what would be the point of the Bodhisattva way of life?

14. Madhyamika: When its conditions are not destroyed, an illusion does not cease either. Due to a discontinuity of its conditions, it does not originate even conventionally.

15. Yogacarin: When even a mistaken cognition does not exist, by what is an illusion ascertained?

16. Madhyamika: If, for you an illusion itself does not exist, what is apprehended? Even if it is an aspect of the mind itself, in reality it exists as something different.

17. Yogacarin: If the mind itself is an illusion, then what is perceived by what? Madhyamika: The Protector of the World stated that the mind does not perceive the mind. Just as a sword cannot cut itself, so it is with the mind.

18. Yogacarin: It illuminates itself, as does a lamp. Madhyamika: A lamp does not illuminate itself, for it is not concealed by darkness.

19. Yogacarin: A blue object does not require something else for its blueness, as does a crystal. So something may or may not occur in dependence on something else.

20. Madhyamika: As is the case of non-blueness, blue is not regarded as its own cause. What blue by itself could make itself blue?

21. Yogacarin: It is said; that a lamp illuminates once this is cognized with awareness. The mind is said to illuminate once this is cognized with what?

22. Madhyamika: If no one perceives whether the mind is luminous or not, then there is no point in discussing it, like the beauty of a barren woman's daughter.

23. Yogacarin: If self-cognizing awareness does not exist, how is consciousness recalled? Madhyamika: Recollection comes from its relation to something else that was experienced, like a rats poison.

24. Yogacarin: It illuminates itself, because the mind, endowed with other conditions, perceives. Madhyamika: A Jar seen due to the application of a magical ointment is not the ointment itself.

25. The Manner in which something is seen, heard, or cognized is not what is refuted here, but the conceptualization of its true appearance, which is the cause of suffering, is rejected here.

26. If you fancy that an illusion is neither different from the mind, nor non different, then if it is a really existing thing, how can it not be different? If it is not different, then it does not really exist.

27. Just as an illusion can be seen even though it does truly exist, so it is with the observer, the mind. Yogacarin: The cycle of existence has its basis in reality or else it would be like space.

28. Madhyamika: How can something that does not exist have any efficacy by being based on something real? You have approached the mind as being an isolated unity.

29. If the mind were free from any apprehended object, then all beings would be Tathágatas. Thus, what good is gained by speculating that only the mind exists?

30. Yogacarin: Even when the similarity to illusion is recognized, how does a mental affliction cease, since lust for an illusory woman arises even in the mind of the one who created her?

31. Madhyamika: Because her creator's imprints of mental afflictions toward objects of knowledge have not been eliminated, when seeing her, his imprint of emptiness is weak.

32. By building up the imprints of emptiness, the imprint of existence is diminished; and after accustoming oneself to the fact that nothing truly exists, even that diminishes.

33. Yogacarin: If it is conceived that a phenomenon that does not really exist cannot be perceived, then how can a non-entity, which is without basis, stand before the mind?

34. Madhyamika: When neither an entity nor a non-entity remains before the mind, then since there is no other possibility, having no objects, it becomes calm.

35. Just as a wish fulfilling gem, or a wish granting tree satisfies desires, so the image of the Jina is seen, because of his vow and his disciples.

36. When a charmer against poison dies, after completing a pillar, that pillar neutralizes poisons and the like, even for a long time after his death.

37. Likewise, the pillar of the Jina, completed with accordance with the Bodhisattva way of life, accomplishes all tasks, even when the bodhisattva has passed into Nirvana.

38. Hinayananist: How could worship offered to something that has no consciousness be fruitful? Madhyamika: Because it is taught that it is the same whether he is present or has passed into Nirvana.

39. According to the scriptures, effects of worship do exist, whether conventionally or ultimately, in the same way that worship offered to the true Buddha is said to be fruitful.

40. Hinayananist: Liberation comes from understanding the four noble truths, so what is the point of perceiving emptiness? Madhyamika: Because the scripture states that there is no awakening without this path.

41. Hinayananist: The Mahayana is certainly not authenticated. Madhyamika: How is your scripture authenticated? Hinayananist: Because it is authenticated by both of us. Madhyamika: Then it is not authenticated by you from the beginning.

42. Apply the same faith and respect to the Mahayana as you do to it. If something is true because it is accepted by two different parties, then the Vedas and the like would also be true.

43. If you object that the Mahayana is controversial, then reject your own scripture because it is contested by heterodox groups and because parts of your scriptures are contested by your own people and others.

44. The teaching has its root in the monk-hood and the monk-hood is not on a firm footing. For those whose minds are subject to grasping, Nirvana is not on a firm footing either.

45. If your objection is that liberation is due to the elimination of mental afflictions, then it should occur immediately afterward. Yet one can see the power of Karma over those people, even though they had no mental afflictions.

46. If you think that as long as there is no craving there is no grasping onto rebirth, why could their craving, even though free of mental afflictions, not exist as delusion?

47. Craving has its cause in feeling, and they have feeling. The mind that has mental objects has to dwell on one thing or another.

48. Without emptiness the mind is constrained and arises again, as in non-cognitive meditative equipoise. Therefore, one should meditate on emptiness.

49. If you acknowledge the utterances that correspond to the sutras as the words of the Buddha, why do you not respect the Mahayana, which for the most part is similar to your sutras?

50. If the whole is faulty because one part is not acceptable, why not consider the whole as taught by the Jina because one part is similar to the Sutras?

51. Who will not accept the teachings not fathomed by leaders such as Maha- Kassapa just because you failed to understand them?

52. Remaining in the cycle of existence for the sake of those suffering due to delusion is achieved through freedom from attachment and fear. That is a fruit of emptiness.

53. Thus, no refutation is possible with regard to emptiness, so one should meditate on emptiness without hesitation.

54. Since emptiness is the antidote to the darkness of afflictive and cognitive obstructions, how is it that one desiring omniscience does not promptly meditate on it?

55. Let fear arise towards something that produces suffering. Emptiness pacifies suffering. So why does fear of it arise?

56. If there were something called "I," fear could come from anywhere. If there is no "I," whose fear would there be?

57. Teeth, hair, and nails are not "I," nor am I bone, blood, mucus, phlegm, puss, or lymph.

58. Bodily oil is not I, nor are sweat, fat, or entrails, the cavity of the entrails is not "I," nor is excrement or urine.

59. Flesh is not "I," nor are sinews, heat, or wind. Bodily apertures are not "I," nor, in any way, are the six consciousnesses.

60. If the awareness of sound were "I," then sound would always be apprehended. But without an object of awareness, what does it cognize on account of which is called awareness?

61. If that which is not cognizant were awareness, a piece of wood would be awareness. Therefore, it is certain there is no awareness in the absence of its object.

62. Why does that which cognizes form not hear it as well? Samkhya: Because of the absence of sound, there is no awareness of it.

63. Madhyamika: How can something that is of the nature of the apprehension of sound be the apprehension of form? One person may be considered as a father and a son, but not in terms of ultimate reality,

64. Since Sattva, Rajas, and Tamas are neither a father nor a son. Moreover its nature is not seen as related to the apprehension of sound.

65. If it is the same thing taking another guise, like an actor, he too is not permanent. If he has different natures, then this unity of his is unprecedented.

66. If another guise is not the true one, then describe its natural appearance. If it were the nature of awareness, then it would follow that all people would be identical.

67. That which has volition and that which has no volition would be identical because their existence would be the same. If difference were false, then what would be the basis for similarity?

68. That which is not conscious is not "I", because it lacks consciousness, like a cloth and the like. If it were consciousness because it has consciousness, than it would follow that when it stops being conscious of anything, it would vanish.

69. If the self is not subject to change, what is the use of its consciousness? Thus, this implies that space, which lacks consciousness and activity, has a self.

70. Objection: Without the self, the relationship between an action and its result is not possible, for if the agent of an action has perished, who will have the result?

71. Madhyamika: When both of us have agreed that an action and its result have different bases and that the self has no influence in this matter, then there is no point in arguing about this.

72. One who has the cause cannot possibly be seen as being endowed with the result. It is pointed out that the existence of the agent and the experiencer (sic) of the consequences depends upon the unity of their continuum of consciousness.

73. The past or future mind is not "I", since it does not exist. If the mind were "I", then when it had vanished, the "I" would not exist anymore.

74. Just as the trunk of a plantain tree is nothing when cut into pieces, in the same way, the "I" is non-existence when sought analytically.

75. Qualm: If no sentient being exists, for whom is there compassion? Madhyamika: For one who is imagined through delusion, which is accepted for the sake of the task.

76. Qualm: If there is no sentient being, whose is the task? Madhyamika: True. The effort, too, is due to delusion. Nevertheless, in order to alleviate suffering, delusion with regard to one's task is not averted.

77. However, grasping onto the "I", which is a cause of suffering, increases because of the delusion with regard to the self. If this is the unavoidable result of that, meditation on identity-less-ness is the best.

78. The body is not the feet, the calves, nor the thighs. Nor is the body the hips, the abdomen. The back, the chest, or the arms.

79. It is not the hands, the sides of the torso, or the armpits, nor is it characterized by the shoulders. Nor is the body the neck or the head. Then what here is the body?

80. If this body partially exists in all of these, and its parts exist in their parts, where does it stand by itself?

81. If the body were located in its entirety in the hands and other limbs, there would be just as many bodies as there are hands and so forth.

82. The body is neither inside nor outside. How can the body be in the hands and other limbs? It is not separate from the hands and the like. How, then, can it be found at all?

83. Thus, the body does not exist. However, on account of delusion, there is the impression of the body with regard to the hands and the like, because of their specific configuration, just as there is the impression of a person with regard to a pillar.

84. As long as a collection of conditions lasts, the body appears like a person. Likewise, as long as it lasts with regard to the hands and the like, the body continues to be seen in them.

85. In the same way, since it is an assemblage of toes, which one would be a foot? The same applies to a toe, since it is an assemblage of joints, and to a joint as well, because of its division into its own parts.

86. Even the parts can be divided into atoms, and an atom itself can be divided according to its cardinal directions. The section of a cardinal direction is space, because it is without parts. Therefore, an atom does not exist.

87. What discerning person would be attached to form, which is just like a dream? Since the body does not exist, then who is a woman and who is a man?

88. If suffering truly exists, why does it not oppress the joyful? If delicacies and the like are a pleasure, why do they not please someone struck by grief and so forth?

89. If it is not experienced because it is overpowered by something more intense, how can that which is not of the nature of experience be a feeling?

90. Objection: Surely there is suffering in its subtle state while its gross state is removed. Madhyamika: If it is simply another pleasure, then that subtle state is a subtle state of pleasure.

91. If suffering does not arise when the conditions for its opposite have arisen, does it not follow that a "feeling" is a false notion created by conceptual fabrication?

92. Therefore, this analysis is created as an antidote to that false notion. For the meditative stabilizations that arise from the field of investigations are the food of contemplatives.

93. If there is an interval between a sense faculty and its object, where is the contact between the two? If there is no interval, they would be identical. In that case, what would be in contact with what?

94. One Atom cannot penetrate another, because it is without empty space and is of the same size as the other. When there is no penetration, there is no mingling there is no contact.

95. How, indeed, can there be contact with something that has no parts? If part-less-ness can be observed when there is contact, demonstrate this.

96. It is impossible for consciousness, which has no form, to have contact; nor is it possible for a composite, because it is not a truly existent thing, as investigated earlier.

97. Thus, when there is no contact, how can feeling arise? What is the reason for this exertion? Who can be harmed by what?

98. If there is no one to experience feeling and if feeling does not exist, then after understanding this situation, why, oh craving, are you not shattered?

99. The mind that has a dream-like and illusion-like nature sees and touches. Since feeling arises together with the mind, it is not perceived by the mind.

100. What happen earlier is remembered but not experienced by what arises later. It does not experience itself, nor is it experienced by something else.

101. There is no one who experiences feeling. Hence, in reality, there is no feeling. Thus, in this identity-less bundle, who can be hurt by it?

102. The mind is not located in the sense facilities, or in form and other sense-objects, or in between them. The mind is also not found inside, or outside, or anywhere else.

103. That which is not in the body nor anywhere else, neither intermingled nor somewhere separate, is nothing. Therefore, sentient beings are by nature liberated.

104. If cognition is prior to the object of cognition, in dependence on what does it arise? If cognition is simultaneous with the object of cognition, in dependence on what does it arise?

105. If it arises after the object of cognition, from what would cognition arise? In this way it is ascertained that no phenomenon comes into existence.

106. Objection: If conventional truth does not exist, how can there be the two truths? If it does exist due to another conventional truth, how can there be a liberated sentient being?

107. Madhyamika: One is an ideation of someone else's mind, and one does not exist by one's own conventional truth. After something has been ascertained, it exists; if not, it does not exist as a conventional reality either.

108. The two, conception and the conceived, are mutually dependent; just as every analysis is expressed by referring to what is commonly known.

109. Objection: But if one analyzes by means of analysis which itself is analyzed, then there is an infinite regress, because that analysis can also be analyzed.

110. Madhyamika: When the object of analysis is analyzed, no basis for analysis is left. Since there is no basis, it does not arise, and that is called "nirvana."

111. A person for whom these two are truly existent is in an extremely shaky position. If an object exists because of the power of cognition, how does one arrive at the true existence of cognition?

112. If cognition exists because of the power of the object of cognition, how does one arrive at the true existence of cognition? If their existence is due to their mutual power, neither can exist.

113. Objection: If there is no father without a son, how can there be a son? Madhyamika: Just as in the absence of a son there is no father, in the same way these two do not exist.

114. Objection: A sprout arises from a seed. The seed is indicated by that sprout. Why does cognition that arises from the object of cognition not ascertain the true existence of that object of cognition?

115. Madhyamika: It is ascertained that a seed exists owing to a cognition that is not the same as a sprout. How is the existence of a cognition cognized, since the object of cognition is ascertained by that cognition?

116. People observe every cause through direct perception, since the components of a lotus, such as the stalk and so forth, are produced by a variety of causes.

117. Qualm: What makes the variety of causes? Madhyamika: a preceding variety of causes. Qualm: How can a cause give an effect? Madhyamika: Because of the power of the preceding causes.

118. Nyaya-Vaisesika: Isvara is the cause of the world. Madhyamika: Then explain who Isvara is. If he is the elements, so be it; but then why tussle over a mere name?

119. Moreover, the earth and other elements are not one; they are impermanent, inactive, and not divine. They can be stepped on and are impure. That is not Isvara.

120. Space is not the Lord because it is inactive. Nor is it the Self, because that has been refuted. How can the inconceivable creatorship of the Inconceivable One be describes?

121. What does he desire to create? If he desires to create a self, are not that self, the nature of the earth and other elements, and Isvara eternal? Cognition is due to the object of cognition and is without beginning.

122. Happiness and suffering are the result of action. Say then, what did he create? If the cause has no beginning, how can its effect have a beginning?

123. If he does not depend on anything else, why does he not always create? There is nothing whatsoever that is not created by him. So on what would he depend?

124. If Isvara depends on a collection of conditions, then again, he is not the cause. He cannot refrain from creating when there is a collection of conditions, nor can he create in their absence.

125. If Isvara creates without desiring to do so, it would follow that he is dependent on something other than himself. Even if he desires to create, he is dependent on that desire. Whence is the supremacy of the creator?

126. Those who claim the atoms are permanent have been refuted earlier. The Samkhyas consider a primal substance as the permanent cause of the world.

127. The universal constituents-sattva, rajas, and tamas-remaining in equilibrium, are called the primal substance. The universe is explained by their dis-equilibrium.

128. It is implausible that a single thing has three natures, so it does not exist. Likewise, he universal constituents do not exist, since they would each be comprised of three constituents.

129. In the absence of the three universal constituents, the existence of sound and other sense objects is far fetched. There is also no possibility of pleasure and the like in unconscious things such as cloth and so on.

130. If you argue that things have the nature of causes, have things not been analyzed away? For you, pleasure and the like are the cause, but cloth and the like are not the result of that cause.

131. Happiness and other feelings may be due to things such as a cloth, but in their absence, there would be no happiness and so on. The permanence of happiness and other feelings is never ascertained.

132. If the manifestation of happiness truly exists, why is the feeling not apprehended? If you see that it becomes subtle, how can it be gross and subtle?

133. Objection: It is subtle upon leaving its gross state. Its grossness and subtlety are impermanent. Madhyamika: Why do you not consider everything impermanent in that way?

134. If its gross state is not different from happiness, then the impermanence of happiness is obvious. If you think that something non-existent does not arise, because it has no existence whatsoever, then you have accepted, even against your will, the origination of something manifest that was non-existent.

135. If you accept that the effect is present in the cause, then one who eats food would be eating excrements, and a cotton tree seed would be bought at the price of a cloth and worn as a garment.

136. If you argue that ordinary people do not see this because of delusion, this is the case even for one who knows reality.

137. Even ordinary people know that. Why do they not see it? If you argue that ordinary people have no verifying cognition, then even their perception of something manifest is false.

138. Samkhya: If verifying cognition is not verifying cognition, then what is not verified falsely? In reality, the emptiness of phenomena is not ascertained through that verifying cognition.

139. Madhyamika: Without detecting an imagined thing, its non-existence is not apprehended. Therefore, if a thing is false, its non-existence is clearly false.

140. Thus, when in a dream a son has died, the thought 'he does not exist' prevents the arising of the thought of his existence; and that too is false.

141. Therefore, with this analysis, nothing exists without a cause, nor is it contained in its individual, or combined causal conditions.

142. Nothing comes from something else, nothing remains, and nothing departs. What is the difference between an illusion and that which is considered by fools as real?

143. Examine this: As for that which is created by illusion and that which is created by causes, where do they come from and where do they go?

144. How can there be true existence in something artificial, like a reflection, which is perceived only in conjunction with something else, and not in its absence?

145. For something that already exists, what need is there for a cause? If something does not exist, what is the need for a cause?

146. Something that does not exist will not be subject to change, even with millions of causes. How can something in that state be existent. What else can come into existence?

147. If there is no existent thing at the time of non-existent, when will an existent thing come into existence? For that non-existent thing will not disappear as long as the existent thing is not produced.

148. When a non-existent thing has not disappeared, there is no opportunity for the existent thing. An existent thing does not does not become non-existent; since it would follow that it would be of two natures.

149. Thus, there is neither cessation nor coming into existence at any time. Therefore, this entire world does not arise or cease.

150. States of existence are like dreams; upon analysis, they are similar to plantain trees. In reality, there is no difference between those who have attained Nirvana and those who have not.

151. When all phenomena are empty in this way, what can be gained and what can be lost? Who will be honored or despised by whom?

152. Whence comes happiness or suffering? What is pleasant and what is unpleasant? When investigated in its own nature, what is craving and for what is craving?

153. Upon investigation what is the world of living beings, and who will really die here? Who will come into existence, and who has come into existence, who is a relative, and who is a friend of whom?

154. May those who are like me apprehend everything as being like space. They rage and rejoice by means of dispute and jubilation.

155. Seeking their own happiness with evil deeds they live miserably with grief, troubles, despair, and cutting and stabbing each other.

156. After repeatedly entering the fortunate states of existence and becoming accustomed to pleasure again and again, they die and fall into the miserable states of existence in which there is long and intense anguish.

157. There are many pitfalls in mundane existence, but there is not this truth here. There is mutual incompatibility. Reality could not be like this.

158. There are incomparable, violent, boundless oceans of suffering. Strength is scanty there; and the life span is short there as well.

159. There, too, in practices for long life and health, in hunger, fatigue, and weariness, in sleep and calamities, and in unprofitable associations with fools,

160. Life passes by swiftly and in vain. Discrimination is difficult to obtain there. How could there be a way to prevent habitual distractions?

161. There, too, Mara tries to throw them into very wretched states. There, because of the abundance of wrong paths, doubt is difficult to overcome.

162. And leisure is hard to obtain again. The appearance of a Buddha is extremely rare. The flood of mental afflictions is difficult to impede. Alas, what a succession of suffering!

163. Ah, there should be a great pity for those adrift in the flood of suffering, who, although miserable in this way, do not recognize their wretched situation.

164. Just like one who repeatedly immerses himself in water but must enter fire again and again, so they consider themselves fortunate, although they are extremely miserable.

165. As they live like this, pretending that they are not subject to aging and death, terrible calamities come, with death the foremost of them.

166. Thus, when might I bring relief to those tormented by the fire of suffering, with the requisites of happiness springing forth from the clouds of my merit?

167. When shall I respectfully teach emptiness and the accumulation of merit-in terms of conventional truth and without reification-to those whose views are reified?

Chapter Ten
Dedication

1. May all sentient beings be graced with the bodhisattva way of life by the virtue I have obtained while reflecting on the "A Guide To The Bodhisattva Way of Life."

2. Through my merit, may all those in all directions who are afflicted by bodily and mental sufferings, obtain oceans of joy and contentment.

3. As long as the cycle of existence lasts, may their happiness never decline. May the world attain the constant joy of the Bodhisattvas.

4. As many hells as there are in the world, may beings in them delight in the joys of contentment in Sukhavati.

5. May those afflicted with cold, find warmth. May those oppressed by heat be cooled by oceans of water springing from the great clouds of the Bodhisattvas.

6. May the forest of sword leaves become for them the splendor of a pleasure grove; and may the sword-like Salmali trees grow as wish-fulfilling trees.

7. May the regions of hell become vast ponds of delight, fragrant with lotuses, beautiful and pleasing with the cries of white geese, wild ducks, ruddy geese, and swans.

8. May the heap of burning coal become a mound of jewels. May the burning ground become a crystal marble floor; and may the mountains of "The Crushing Hell" become temples of worship filled with Sugatas.

9. May the rain of burning coal, lava, and daggers from now on become a rain of flowers; and may mutual battling with weapons now become a playful flower fight.

10. By the power of my virtue, may those whose flesh has completely fallen off, whose skeletons are of the color of a white jasmine flower, and who are immersed in the river Vaitarani whose water is like fire, attain celestial bodies and dwell with goddesses by the river Manakini.

11. May the horrifying agents of Yama, crows, and vultures suddenly watch here in fear. Those looking upward behold blazing Vajrapani in the sky wonder: "Whose is this brilliant light that dispels darkness all around and generates the joy of contentment?" May they depart together with him, freed of vice through the power of their joy.

12. A rain of Lotuses falls mixed with fragrant waters. It is seen to extinguish the unceasing fires of the hells. May the beings of the hells, suddenly refreshed with joy, wonder, "What is this?" and may they see Padmapani.

13. Friends, come quickly! Cast away fear! We are alive! A radiant vanquisher of fear, a certain prince in a monastic robe, has come to us. By his power every adversity is removed, streams of delight flow, the Spirit of Awakening is born, as is compassion, the mother of protection of all beings.

14. Behold him whose Lotus-Feet are worshipped with tiaras of hundreds of gods, whose eyes are moist with compassion, on whose head a stream of diverse flowers rains down, with his delightful summer palaces celebrated by thousands of goddesses singing hymns of praise. Upon seeing Manjughosa before them, may the beings of the hells immediately cheer.

15. Through my virtues, may the beings of the hells rejoice upon seeing the un-obscured clouds of Bodhisattvas, headed by Samantabhadra and bearing pleasant, cool, and fragrant rains and breezes.

16. May the intense pains and fears of the beings of the hells be pacified. May the inhabitants of all miserable states of existence be liberated from their woeful states.

17. May the animal's risk of being eaten by each other disappear! May the Pretas be as happy as the people in Uttarakura!

18. May the Pretas always be satiated, bathed, and refreshed by streams of milk pouring from the hand of noble Avalokiteshvara.

19. May the blind always see forms, and may the deaf hear. May pregnant women give birth without pains, as did Mayadevi.

20. May they acquire everything that is beneficial and desired by the mind: clothing, food, drink, flower garlands, sandalwood-paste, and ornaments.

21. May the fearful become fearless and those struck with grief find joy. May the despondent become resolute and free of trepidation.

22. May the ill have good health. May they be freed from every bondage. May the weak become strong and have affectionate hearts for one another.

23. May all regions be advantageous to all those who travel on roads. May the purpose for which they set out be expediently accomplished.

24. May those who journey by boat succeed, as they desire. May they safely reach the shore and rejoice with their relatives.

25. May those who find themselves on wrong paths in dreary forests come upon the company of fellow travelers; and without fatigue, may they journey without fear of bandits, tigers, and the like.

26. May deities protect the dull, the insane, the deranged, the helpless, the young, and the elderly, and those in danger from sickness, the wilderness, and so on.

27. May they be free from all lack of leisure; may they be endowed with faith, wisdom, and compassion; may they be possessed of stature and good conduct; and may they always remember their former lives.

28. May they be inexhaustible treasuries just like Sky Treasure. Free of conflict or irritation, may they have an independent way of life.

29. May beings who have little splendor be endowed with great magnificence. May unattractive wretched be endowed with great beauty.

30. May the women in the world become men. May the lowly obtain grandeur and yet be free of arrogance.

31. Through this merit of mine, may all beings without exception abstain from every vice and always engage in virtue.

32. Not lacking the Spirit of Awakening, devoted to the Bodhisattva way of life, embraced by the Buddhas, and free of the deeds of Maras,

33. May all beings have immeasurable life spans. May they always live happily, and may even the word death disappear.

34. May all quarters of the world be delightful with gardens of wish fulfilling trees, filled with the Buddhas and the Children of the Buddhas, and be enchanting with the sound of Dharma.

35. May the ground everywhere be free from stones and rocks, smooth like the palm of the hand, soft, and made of Lapis Lazuli.

36. May the great assemblages of Bodhisattvas sit on all sides. May they beautify the earth with their own resplendence.

37. May all beings unceasingly hear the sound of Dharma from the birds, from every tree, from the rays of light, and from the sky.

38. May they always encounter the Buddhas and the Children of the Buddhas. May they worship the Spiritual Mentor of the world with endless clouds of offerings.

39. May a god send rain in time, and may there be an abundance of crops. May the populace be prosperous, and may the king be righteous.

40. May medicines be effective, and may the mantras of those who recite them be successful. May Dakinis, Rakasas, and other ghouls be filled with compassion.

41. May no sentient being be unhappy, sinful, ill, neglected, or despised; and may no one be despondent.

42. May monasteries be well established, full of chanting and study. May there always be harmony among the Sangha, and may the purpose of the Sangha be accomplished.

43. May monks who wish to practice find solitude. May they meditate with their minds agile and free of all distractions.

44. May nuns receive provisions and be free of quarrels and troubles. May all renunciations be of untarnished ethical discipline.

45. May those who are of poor ethical discipline be disgusted and become constantly intent on the extinction of their vices. May they reach a fortunate state of existence, and may their vows remain unbroken there.

46. May they be learned and cultured, receive alms, and have provisions. May their mind streams be pure and their fame be proclaimed in every direction.

47. Without experiencing the suffering of the miserable states of existence and without arduous practice, may the world attain Buddhahood in a single divine body.

48. May all sentient beings worship all the Buddhas in many ways. May they be exceedingly joyful with the inconceivable bliss of the Buddhas.

49. May the Bodhisattvas' wishes for the welfare of the world be fulfilled; and whatever the protectors intend for sentient beings, may that be accomplished.

50. May the Pratyekabuddhas and Sravakas be happy, always worshipped by the lofty gods, asuras, and humans.

51. Through the grace of Manjughosa, may I always achieve ordination and the recollection of the past lives until I reach the Joyous Ground.

52. May I live endowed with strength in whatever posture I am. In all my lives may I find plentiful places of solitude.

53. When I wish to see or ask something, may I see the Protector Manjunatha himself, without any impediment.

54. May my way of life be life be like that of Manjusri, who lives to accomplish the benefit of all sentient beings throughout the ten directions.

55. For as long as space endures and for as long as the world lasts, may I live dispelling the miseries of the world.

56. Whatever suffering there is for the world, may it all ripen upon me. May the world find happiness through all the virtues of the Bodhisattvas.

57. May teaching that is the sole medicine for the suffering of the world and the source of all prosperity and joy remain for a long time, accompanied by riches and honor!

58. I bow to Manjughosa, through whose grace my mind turns to virtue. I salute my spiritual friend through whose kindness it becomes stronger.

[End Text]


New Page 3

          入菩萨行论

        寂天菩萨 造颂

    〖第一品 菩提心利益〗

法身善逝佛子伴 及诸应敬我悉礼
今当依教略宣说 入善逝子律仪方
此论未宣昔所无 诗韵吾亦不善巧
是故未敢言利他 为修自心撰此论
循此修习善法故 吾信亦得暂增长
善缘同我诸余人 得见此已亦获益
暇满人身极难得 即得能办人生利
倘若今生利未办 后世怎得此圆满
犹于乌云暗夜中 刹那闪电极明亮
如是因佛威德力 世人暂萌修福意
以是善行恒微弱 罪恶力大极难当
舍此圆满菩提心 何有余善能胜彼
佛於多劫深思维 见此觉心最饶益
无量众生依于此 顺利能获最胜乐
欲灭三有百般苦 及除有情众不安
欲享百种快乐者 恒常莫舍菩提心
系于轮回苦有情 若生刹那菩提心
得名诸佛善逝子 世间人天应礼敬
犹如最胜冶金料 垢身得此将转成
无价之宝佛陀身 故应坚持菩提心
众生导师以慧观 彻见彼心极珍贵
诸欲出离三界者 宜善坚持菩提心
其余善行如芭蕉 果实生已终枯槁
菩提心树恒生果 非仅不尽反增茂
如人虽犯极重罪 然依勇士得除畏
依靠何者速解脱 彼者善人何不依
菩提心如劫末火 刹那能毁诸重罪
智者弥勒谕善财 彼心利益无限量
    略摄菩提心 当知有二种
    愿求菩提心 趣行菩提心
    如人皆了知 欲行正行别
    如是智者知 二心次第别
    愿心轮回中 虽能生大果
    然不如行心 相续生福德
    何时为度尽 无边有情众
    立志不退转 受持此行心
    即自彼时起 纵眠或放逸
    福德相续生 量多等虚空
    为信小乘者 妙臂问经中
    如来自宣说 其益极应理
    若仅思疗愈 有情诸头疾
    具此饶益心 即得无量福
    况欲除有情 无量不安乐
    乃至欲成就 有情无量德
    是父抑或母 谁具此心耶
    欲天或诸仙 梵天宁有此
    彼等为自利 尚且未梦及
    况为他有情 生此饶益心
    他人为自利 尚且未能发
    珍贵此益心 能生诚希有
    珍贵菩提心 众生安乐因
    除苦妙甘霖 其福何能量
    仅思利众生 福即胜供佛
    何况勤精进 利乐诸有情
    众生欲除苦 反行痛苦因
    愚人虽求乐 自毁如灭仇
    于诸乏乐者 多苦诸众生
    足彼众安乐 断彼一切苦
    更复尽其痴 何有等此善
    何得似此友 岂有似此福
    若人酬恩施 尚且应称赞
    何况未受托 菩萨行善乐
    偶尔微劣食 一时施少众
    轻蔑半日饱 人敬为善士
    何况恒施与 无边有情众
    善逝无上乐 满彼一切愿
如是博施诸佛子 若人于彼生恶心
佛言彼当住地狱 长如所生心数劫
若人于彼生净信 得果较前还增胜
佛子虽逢大艰难 然罪不生善自增
何人生此珍贵心 我即敬礼彼人身
于谁作还接乐缘 皈依敬彼安乐源

    〖第二品 忏悔罪业〗

为能持彼珍宝心 我今善供诸如来
无诸垢染妙法宝 及诸佛子功德海
所有鲜花与珍果 以及种种诸良药
一切世间珍宝物 所有悦意澄净水
如是巍巍珍宝山 静谧舒适宜人林
奇花严饰妙宝树 珍果累累垂支树
天等世间妙芳香 燃香如意妙宝树
不耕自生诸庄稼 及余堪供诸珍饰
莲花饰海诸湖泊 吟鸣悦耳野天鹅
浩瀚虚空界所及 一切无主所持物
以意缘取敬奉献 人中尊及诸佛子
祈请大悲胜福田 慰念吾心纳吾供
我无福德极贫穷 丝毫无余所供财
祈求利他慈怙主 为吾利故受此供
诸佛以及佛子前 吾亦恒献吾之身
祈诸胜士哀纳受 我愿敬当汝尊仆
即已全为尊摄受 无惧世间利有情
生前罪业离清净 今后亦定不为恶
水晶铺地亮莹莹 宝柱耀眼生悦意
高悬闪烁珍珠盖 于此馥郁妙澡堂
陈设诸多珍宝瓶 盛满悦意妙香水
洋溢种种美歌乐 请佛佛子至此浴
妙香所熏极洁净 无比浴巾拭其身
拭已于彼复献上 香极最胜妙色衣
亦以种种细柔服 百种最胜庄严物
庄严普贤与文殊 世间自在等圣众
香气遍满三千界 以此妙香涂敷彼
犹如拭净纯炼金 闪闪发光诸佛身
于诸牟尼胜供处 以诸悦意香莲花
曼陀罗花青莲等 及妙花蔓为供养
于彼亦献最胜香 迷人香溢结香云
于彼亦献诸神馐 并同种种妙饮食
亦将献上金莲花 齐整罗列珍宝灯
于彼香馥地面上 点点散布悦意花
赞歌悠扬越量宫 珠宝悬垂耀亮丽
彼等无量空中饰 亦献性具大悲主
金柄撑展珍宝伞 周边缀以悦意饰
眼观形妙极华丽 亦常撑此献诸佛
    余亦为供具 奏乐极悠雅
    能息有情苦 诸云祈驻留
    愿珍宝花等 如雨续降临
    一切妙法宝 灵塔佛身前
    犹如妙吉祥 昔日供诸佛
    如是吾亦供 如来诸佛子
    我以海潮音 赞佛功德海
    愿妙赞歌云 飘临彼等前
    化身微尘数 匍伏我顶礼
    三世一切佛 正法最胜僧
    敬礼佛灵塔 菩提心根本
    亦礼戒胜者 堪布阿遮黎
    乃至菩提果 皈依诸如来
    正法菩萨众 如是亦皈依
    我于十方佛 及具菩提心
    大悲诸圣众 合掌如是白
    无始轮回起 此世或他生
    无知犯诸罪 或劝他作恶
    或因痴所牵 随喜他做为
    见此罪过已 对佛诚忏悔
    我以身语意 三宝及父母
    上师或余人 惑催作伤害
    因昔犯众过 今成有罪人
    一切难恕罪 佛前悉忏悔
    罪业未净前 吾身或先亡
    云何脱此罪 故祈速救护
    死神不足信 不待罪净否
    无论病未病 寿暂不可恃
    因吾不了知 死时舍一切
    故为亲与友 造种种罪业
    人生如梦幻 无论何事物
    受已成念境 往事不复见
    仇敌化虚无 诸亲亦烟灭
    吾身必死亡 一切终归无
    复次于此生 亲仇半已逝
    为彼所造罪 历历在目前
    因吾不甚解 命终如是骤
    基于贪嗔痴 造作诸罪业
    昼夜不停留 此生恒衰灭
    额外不复增 似吾岂不亡
    临终弥留际 众亲虽围绕
    命绝诸苦痛 唯吾一人受
    魔使来执时 亲朋有何益
    唯福能救护 然我未曾修
    放逸吾未知 死亡如是怖
    故为无常生 亲造诸多罪
    若今赴刑场 罪犯犹惊怖
    口干眼凸出 形貌异故昔
    何况形恐怖 阎使所执持
    大怖忧苦缠 苦极不待言
    谁能善护我 离此大怖畏
    睁大凸怖眼 四方寻救护
    四方遍寻觅 无依心懊丧
    彼处若无依 惶惶何所从
    佛为众怙主 慈悲勤护生
    力能除众惧 故我今皈依
    如是亦皈依 能除轮回怖
    我佛所悟法 及菩萨圣众
    因怖惊颤栗 将身奉普贤
    亦复将此身 敬献文殊前
    哀号力呼求 不昧大悲行
    慈尊观世音 救赎罪人我
    复于虚空藏 及地藏王等
    一切大悲尊 由衷祈救护
    皈依金刚持 怀瞋阎魔使
    见彼心畏惧 四方速逃逸
    昔违尊圣教 今生大忧惧
    愿以皈命尊 求速除怖畏
    若具寻常疾 尚需遵医嘱
    何况贪等患 宿疾恒缠身
    一瞋若能毁 瞻部一切人
    疗惑诸药方 若遍寻不得
    药王一切智 拔苦诸圣教
    知已若不行 极痴应诃责
    若遇寻常险 犹须慎防护
    况堕千由旬 长劫险难处
    或思今不死 安逸此非理
    吾身终归尽 死期必降临
    谁赐我无惧 云何定脱此
    倘若必死亡 为何今安逸
    除忆昔经历 今吾复何余
    然因执著彼 屡违上师教
    此生若须舍 亲友亦如是
    独行无定所 何须结亲仇
    不善生诸苦 云何自脱彼
    故吾当日夜 恒常思惟此
    吾因无明痴 犯诸自性罪
    及佛所制罪 及余众戒罪
    合掌怙主前 以畏罪苦心
    再三礼诸佛 忏除一切罪
    诸佛祈宽恕 往昔所造罪
    此即非善行 尔后誓不为

    〖第三品 持守菩提心〗

    欣乐而随喜 一切诸有情
    息苦诸善行 得乐诸福报
    随喜积善行 彼为菩提因
    随喜众有情 实脱轮回苦
    随喜佛菩提 及诸佛子地
    亦欣乐随喜 令有情安乐
    发心福善海 及诸饶益行
    我于十方佛 合掌诚祈请
    为苦惑有情 燃亮正法灯
    知佛欲涅槃 合掌速祈请
    住世无量劫 莫令世间迷
    如是诸行事 所积一切善
    以彼愿消除 有情一切苦
    乃至众生疾 尚未疗愈前
    愿为医与药 并作看护士
    盼天降食雨 解除饥渴难
    于彼灾荒劫 愿成充饥食
    为彼贫困者 愿成无量藏
    愿诸资生物 悉现彼面前
    为利有情故 不吝尽施舍
    身及诸财富 三世一切善
    舍尽则脱苦 吾心则涅槃
    死亦舍一切 不如布施胜
    吾即将此生 随顺施有情
    一任彼欢喜 恒常打骂杀
    纵戏弄吾身 或轻侮讥讽
    吾身即施舍 云何复珍惜
    一切无害业 令身遍造作
    愿彼见我者 悉获众利益
    若人因见我 生起信瞋心
    愿彼恒成为 成办众利因
    愿彼损我者 及余害我者
    如是辱我者 皆具菩提缘
    路人无依怙 愿为彼引导
    并作渡者舟 船筏与桥梁
    求岛即成岛 欲灯化为灯
    欲床变作床 凡须仆从者
          我愿成彼仆
    愿成如意牛 如意宝妙瓶
    明咒及灵药 诸如意宝树
    地水火风空 愿我恒成为
    无量众有情 资生大根本
    乃至尽空际 有情界种种
    殊途悉涅槃 愿成资生因
    如昔诸善逝 发愿菩提心
    后次第安住 诸菩萨学处
    如是为利生 我发菩提心
    复于诸学处 次第勤修学
    智者如是持 净菩提心已
    复为增长故 如是赞彼心
    今生吾获福 善得此人身
    复生佛家族 成彼如来子
    尔后我当为 宜乎家族业
    慎莫染污此 无垢尊贵种
    犹如目盲人 垃圾中获宝
    生此菩提心 如是我何幸
    灭死胜甘露 即此菩提心
    除贫无尽藏 即此菩提心
    疗疾最胜药 亦此菩提心
    彼为泊世途 众生休憩树
    复是能渡桥 渡众出恶趣
    彼是除恼热 东升心中月
    复是璀璨日 能除无知霾
    是摇正法乳 所出妙醍醐
于诸飘泊众生客 及欲安享福乐者
此心能令住胜乐 因满有情贵客意
今于一切怙主前 恳请众生为贵客
宴飨成佛及余乐 愿天非天皆欢喜

    〖第四品 不放逸〗

    佛子即如是 坚持菩提心
    应恒勤勿怠 莫违诸学处
    行若不慎思 或任意妄为
    彼虽受誓言 后乃思取舍
    诸佛及佛子 大慧所观察
    吾亦屡思择 云何舍彼戒
    若誓利众生 而不勤践履
    则为欺有情 来生何所似
    意虽思布施 微少凡常物
    然未施与人 经说堕饿鬼
    恳请众生赴 无上安乐宴
    后反欺众生 云何生善趣
    有人舍觉心 却办解脱果
    彼业则难思 唯一切智知
    菩萨戒堕中 此罪最严重
    因彼心若生 将损众生利
    虽仅一刹那 障碍他人德
    亏损有情利 恶趣报无边
    毁一有情乐 自身且遭损
    况毁尽空际 众有情安乐
    是故具罪堕 及菩提心者
    间杂轮回故 登地久蹉跎
    故如所立誓 我当恭敬行
    今后若不勉 定当趣下流
    饶益众有情 无量佛已逝
    然我因昔过 不得佛化育
    若今依旧犯 如是将反覆
    恶趣中领受 病缚剖割苦
    或值佛出世 为人信佛法
    宜修善稀有 何日复得此
    纵以今无病 足食无损伤
    然寿刹那逝 身犹须臾质
    凭吾此身素 尚不得人生
    若不得人身 徒恶无善行
    若具行善缘 而我未为善
    恶趣众苦逼 彼时复何为
    即未行诸善 复亲集众恶
    纵历一亿劫 不闻善趣名
    是故世尊说 人身极难得
    如海中盲龟 颈入轭木孔
    刹那造重罪 历劫住无间
    况无始轮回 积罪失善趣
    然仅受彼报 犹不得解脱
    因受彼报时 复生余多罪
    即得此闲暇 若我不修善
    自欺莫胜此 亦无过此愚
    若我已解此 因痴而怠惰
    则于临终时 将起大忧苦
    难忍地狱火 长久烧身时
    悔火灸燃故 吾心必痛苦
    难得饶益处 今既侥幸得
    亦复具智慧 若仍赴地狱
    则如咒所惑 我成无心者
    不知受何惑 何蛊藏吾心
    瞋贪等诸敌 无有手足等
    非明非勇精 怎役我如奴
    惑住我心中 任意伤害我
    犹忍不瞋彼 非当应诃责
    纵使天非天 齐来敌对我
    然彼也不能 引我入无间
    烦恼敌力大 掷我入狱火
    须弥若遇之 灰尽亦无余
    吾心烦恼敌 长住无始终
    其余世间敌 则不如是久
    若我顺待敌 彼或利乐我
    若随诸烦恼 徒招伤害苦
    此久相续敌 孽祸唯一因
    若真住我心 生死怎无惧
    生死牢狱卒 地狱刽子手
    若皆住我心 安乐何能有
    乃至吾未能 亲灭此惑敌
    则我于今生 不应舍精进
    于他微小害 尚且起瞋心
    是故未灭彼 壮士不成眠
    列阵激战场 奋力欲灭彼
    终必自死亡 生诸苦恼敌
    尚且不顾虑 箭矛著身苦
    未达目的已 不向后逃跑
况吾精进定欲灭 恒未苦因自然敌
今虽遭受百般苦 不应丧志生懈怠
昔因微利遭敌伤 于身犹如配庄严
今为大利勤精进 痛苦云何能困我
渔夫屠户农人等 唯念己身维生计
犹忍冷热诸艰辛 为众乐故何不忍
    虽曾立此誓 欲度十方际
    众生除烦恼 然我未离惑
    出言不量力 云何非颠狂
    故于灭烦恼 应恒不退怯
    我应爱著此 怀恨于彼战
    此似烦恼心 唯能灭烦恼
    吾宁被烧杀 或遭断头苦
    然我决不可 屈就烦恼贼
驱凡常敌出此境 则便盘据住他乡
养足能力旋复返 烦恼贼则不如是
烦恼若为慧眼断 驱出吾意何所之
居子何处返害我 然我懦弱乏精进
烦恼非住于外境 非住根身非中间
此外亦非其它处 居于何处害众生
此惑如幻心莫惧 应为智慧勤精进
云何我于地狱中 毫无意义受伤害
如上思已当尽力 修成所说诸学处
倘若不听医师嘱 需药病人何能愈

     〖第五品 正知〗

    欲护学处者 当策励护心
    若不护此心 不能护学处
    若纵心狂象 受难无间狱
    未驯大狂象 为患不若此
    若遍以念索 紧拴心狂象
    怖畏则全消 并获一切善
    虎狮大象熊 蛇及一切敌
    有情地狱卒 及恶神罗刹
    唯由系此心 能系彼一切
    调伏此一心 一切皆驯服
    实语者佛言 一切诸畏惧
    及无量痛苦 皆从心所生
    有情狱兵器 何人故意造
    谁造烧铁地 女众从何出
    佛说彼一切 皆由恶心造
    是故三界中 恐怖莫甚心
    若除众生贫 始成施度者
    今犹见饥者 昔佛云何成
    心乐与众生 一切物及果
    依此施度圆 故施唯依心
    鱼逐等何方 使得不遭伤
    断尽恶心时 说为戒度圆
    顽者如虚空 岂能尽制彼
    若息此瞋心 则同灭众敌
    怎得足量革 尽覆此大地
    片革垫靴底 即同覆大地
    如是吾不克 尽制诸外敌
    吾应制此心 何劳制其余
    生一明定心 亦得梵天果
    身口业纵善 行弱难成就
    虽久习念诵 及它众苦行
    然心散它处 佛说彼无益
    若不知此心 奥秘法中尊
    虽欲乐避苦 无义终漂泊
    故吾当善持 善护此道心
    护心禁行处 何劳多禁行
    如处乱众中 人皆慎护疮
    置身恶人群 常护此心伤
    若惧小疮痛 犹须护疮伤
    畏山夹毁者 何不护心伤
    行持若如斯 则住恶人群
    或处女人中 勤律终不退
    吾宁失利养 资身众活计
    亦宁失余善 终不损此心
    合掌诚劝请 诸欲护心者
    致力护一切 正念与正知
    受病所困者 无力为诸业
    如是惑扰心 无力成事业
    心无正知者 闻思修所得
    如漏瓶中水 不复住正念
    纵信复多闻 数数勤精进
    然因无正知 终染犯堕垢
    彼无正知贼 尾随念失后
    盗昔所聚福 令人趋恶趣
    此群烦恼贼 寻隙欲打劫
    得便夺善财 复毁善趣命
    故终不应纵 正念离意门
    离则思诸患 复住于正念
    伴随上师尊 堪布赐开示
    畏敬有缘者 恒易生正念
    佛及菩萨众 无碍见一切
    故吾诸言行 必现彼等前
    如是思惟已 则生惭敬畏
    循此复极生 殷殷随念佛
    为护心意门 安住正念已
    正知即随临 去者亦复返
    此恶初生际 知其有过已
    即时护正念 坚持住如树
    吾终不应当 无义散漫望
    决志当恒常 垂眼向下望
    苏息吾眼故 偶宜顾四方
    若见某人至 正视道善来
    为察道途险 四处频观望
    憩时宜回顾 背面细检索
    察视前后已 续行或回返
    故于一切时 应视所需行
    欲身如是住 安妥动作已
    时时应观察 此身云何住
    尽力遍观察 此心大狂象
    系念法大柱 已拴未走失
    精进习定者 刹那勿驰散
    如是当观察 吾意何所行
    危难喜庆时 心散亦应安
    经说行施时 可舍微细戒
    思已欲为时 莫更思他事
    心志应专注 且先成办彼
    如是事皆成 否则俱不成
    不正知随眠 由是不增盛
    无义众闲谈 诸多稀奇剧
    临彼众彼时 当断彼贪著
    无义掘挖割 于地绘图时
    当忆如来教 惧罪舍彼行
    若身欲移动 或口欲出言
    应先观彼心 安稳如理行
    吾意正生贪 或欲瞋恨时
    言行应暂止 如树安稳住
    掉举与藐视 傲慢与骄矜
    或欲评论他 若思伪与诈
    或思勤自赞 或欲诋毁他
    粗言并离间 如树应安住
    或思名利敬 或欲役仆役
    若欲人侍奉 如树应安住
    削减弃他利 或欲谋己利
    因是欲语时 如树当安住
    不耐懒与惧 无耻言无义
    若生偏袒心 如树当安住
    应观此污染 已行无义心
    勇士当对治 坚持守此心
    深信极肯定 坚稳恭有理
    知惭畏因果 寂静勤他乐
    愚稚意不合 心且莫生厌
    彼乃惑所生 思已应怀慈
    为自及有情 利行不犯罪
    更以如幻观 恒常守此意
    吾当再三思 历劫得暇满
    故应持此心 不动如须弥
    秃鹰贪食肉 争相扯尸体
    若汝不经意 云何今看顾
    意汝于此身 何故执且护
    汝彼既各别 于汝何所需
    痴意汝云何 不护净树身
    何苦守护此 败坏垢聚器
    首当以意观 分出表皮层
    次以智慧剑 析肉离身骨
    复解诸骨骼 审查至于髓
    当自如是究 何处见精妙
    如是勤寻觅 若未见精要
    何故犹贪著 爱护汝此身
    若垢不堪食 身血不宜饮
    肠胃不适吮 身复何所需
    贪身唯一因 为狐鹫护食
    故此诸人生 唯应为善遣
    纵汝护若此 死神不留情
    夺已施鹫狗 彼时汝当何
    若仆不堪使 主不与衣食
    养身而它去 如何劳养护
    于此施薪资 当今办吾利
    无益则于彼 一切不应与
    当念身如舟 唯充去来使
    为办有情利 转成如意身
    如是有自在 恒常露笑颜
    平息怒纹眉 众友正实语
    开门勿粗暴 常喜柔和语
    水鸥猫盗贼 无声形隐蔽
    故成所欲事 能仁如是行
    应善勉励人 不请饶益语
    恭敬且顶戴 恒为众人徒
    一切妙隽语 皆赞为善说
    见人行福善 赞叹生欢喜
    暗赞他人功 随说他人德
    闻人说己德 应知自有无
    一切行为喜 彼难以价估
    故当依他德 安享随喜乐
    如是今无损 来世乐亦多
    反之因嫉苦 后世苦更大
    出言当称意 义明语相关
    悦意离贪瞋 柔和调适中
    眼见有情时 诚慈而视之
    念我依于彼 乃能成佛道
    热衷恒行善 或依对治兴
    施福恩苦田 成就大福善
    善巧具信已 我当常行善
    众善己应为 谁亦不依仗
    施等波罗密 应令渐增胜
    勿应小失大 大处思利他
    前理既已明 当勤饶益他
    见远佛具悲 于彼开诸遮
    食当与堕者 无怙住戒者
    唯敢适量食 三衣余尽施
    修行正法身 莫为小故伤
    行此众生愿 迅速得圆满
    悲愿未清净 不应施此身
    今他生皆然 利大乃可舍
    不敬勿说法 无病缠绕头
    持伞杖兵器 遮头等亦然
    莫于无伴女 智劣说深广
    于诸胜劣法 等敬遍修习
    于诸大法器 不应与劣法
    不应舍律行 经咒诳惑人
    牙木与唾液 弃时应掩埋
    于用水及地 不当弃屎尿
    食时莫满口 出声与咧嘴
    坐时莫伸足 双手莫揉搓
    于车床诸处 莫会他人妇
    世间所不信 观询而舍弃
    单指莫示意 心当怀恭敬
    平伸右手掌 示路亦如是
    手臂莫挥摆 示意以微动
    出声及弹指 否则易失态
    犹如佛涅槃 应朝欲方卧
    正知并决志 觉已速起身
    菩萨诸行仪 经说有无量
    然当尽力为 修持净心行
    昼夜当各三 诵读三聚经
    依佛菩提心 忏除余堕罪
    为自或为他 何时修何行
    皆当勤修习 佛所说学处
    佛子不需学 毕竟皆无有
    善巧如是住 决无薄福者
    直接或间接 所行唯利他
    但为有情利 回向大菩提
    为命亦不舍 善巧大乘义
    安住菩萨戒 珍贵善知识
    应如吉祥生 修学待师规
    此及余学处 读经即能知
    经中有学处 故应阅经藏
    首先当阅读 圣虚空藏经
    何故恒修行 学集广宣说
    故当再三览 众学处集要
    偶亦阅精简 一切经集要
    亦当勤阅览 龙树二论典
    经论所未遮 皆当勤修学
    为护世间心 见已即当行
    再三当观察 身心诸状态
    仅此间言之 即护正知义
    应当躬谨行 徒说岂能成
    唯阅疗病方 于患有何益

     〖第六品 安忍〗

    一瞋能摧毁 千劫所集施
    供养善逝等 一切诸善行
    罪恶莫过瞋 难行莫胜忍
    故应以众理 努力修安忍
    若心执灼瞋 意即不寂静
    喜乐亦不生 不稳不成眠
    有人以利敬 恩施来依者
    施主若易瞋 反遭彼杀害
    瞋令亲友厌 虽施亦不依
    总之有瞋恚 安乐不久住
    瞋敌能招至 如上诸痛苦
    精勤灭瞋者 享乐今后世
    强行我不欲 或扰吾所欲
    得此不乐食 瞋盛毁自他
    故应尽断除 瞋敌诸粮食
    此敌唯害我 更无他余事
    遭遇任何事 莫扰欢喜心
    忧恼不济事 反失诸善行
    若事尚可救 云何不欢喜
    若已不济事 不乐有何益
    不欲吾与友 历苦受轻蔑
    粗言不雅语 于敌则反是
    乐因何其微 苦因极繁多
    无苦无出离 故心应坚忍
    苦行伽那巴 无端忍烧割
    吾今求解脱 何故反畏怯
    习久不成易 此事定非有
    渐习小害故 大害亦能忍
    蛇及虻蚊噬 饥渴等苦受
    乃至疥疮等 岂无此苦受
    于寒暑风雨 病缠捶打等
    不宜太娇弱 若娇反增苦
    有人见己血 反增其坚勇
    有人见他血 惊慌复闷绝
    此二分别由 坚毅怯弱致
    故应轻害苦 莫为诸苦毁
    智者纵历苦 不乱心澄明
    奋战诸烦恼 虽生多害苦
    然应轻彼苦 力克贪瞋敌
    胜彼乃勇士 其余唯杀尸
    苦害有诸德 厌离除骄慢
    悲愍生死众 羞恶乐善行
    不瞋胆病等 痛苦大渊薮
    云何瞋有情 彼皆缘所成
    如人不欲病 然病乃涌现
    如是不欲恼 烦恼强生起
    心虽不思瞋 而人自然瞋
    如是未思生 彼瞋犹自生
    所有一切过 种种诸罪恶
    彼皆缘所生 全然非自力
    彼等众缘聚 不思将生瞋
    所生瞋恼等 亦无已生想
    纵许有主物 施设所谓我
    主我不思故 将生而生起
    不生故无果 常我欲生果
    则于境恒散 彼执永不止
    彼我若是常 无作如虚空
    纵遇它缘时 不动无变异
    作时亦如前 则作有何用
    谓彼作即此 我作何相关
    是故一切法 依他非自主
    知已不应瞋 如幻如此事
    由谁除何瞋 除瞋不应理
    依彼断诸苦 故非不应理
    故见怨或亲 非理加害我
    思此乃缘生 如是应乐住
    若苦由自取 世皆不欲苦
    是则诸有情 应皆无苦楚
    或因己不慎 以刺自戮伤
    或为得妇心 忧伤复绝食
    自缢或纵崖 服毒不宜食
    以非福德行 于己作损伤
    自惜性命者 因惑尚自尽
    尔时于他身 云何能不损
    于彼生烦恼 而行杀我者
    慈悲纵不起 生瞋亦非当
    设若害他人 乃愚自本性
    瞋彼则非理 如瞋烧性火
    若过是偶发 有情性乃贤
    则瞋亦非理 如瞋烟蔽空
    杖等亲为害 若瞋使杖者
    彼复瞋使敌 定应瞋其瞋
    我昔于有情 曾作如是害
    故害有情者 我应受此损
    彼器于我身 二者皆苦因
    双出器与身 于谁该当瞋
    身似人形疮 轻触苦不堪
    盲目我爱执 遭损当瞋谁
    愚夫不欲苦 偏爱诸苦因
    既由己过害 岂能瞋于人
    譬如诸狱卒 乃诸剑叶林
    既由己业生 于谁该当瞋
    宿业所发动 令他损恼我
    因此若堕狱 岂非我害他
    依彼修忍辱 消我诸多罪
    彼等依我者 堕狱久受罪
    若吾伤害彼 彼反饶益我
    则汝粗暴心 何故反瞋彼
    若我有功德 则不趋地狱
    若吾自守护 则彼何所得
    若以害回报 则彼不护罪
    吾行亦退失 难行将损毁
    心意无形体 谁亦不能坏
    若心著此身 则遭诸苦损
    轻蔑及粗语 并诸恶名称
    于身若无害 心汝何故瞋
    谓他不喜我 然彼于现后
    不能毁损我 何故厌弃彼
    谓碍利养故 纵我厌受损
    吾利终将舍 诸罪则久留
    宁今速死殁 不愿邪命活
    似此纵久住 终必遭死苦
    梦受百年乐 彼人复苏醒
    或受须臾乐 顷刻此人醒
    醒已此二人 梦乐皆不还
    寿虽有长短 临终唯如是
    设得多利养 长时受安乐
    死时遭盗劫 裸体空手还
    谓利能活命 避恶并修福
    若为利养瞋 福尽恶当生
    若以某物活 复因彼退堕
    唯行罪恶事 苟活有何益
    谓谤令他疑 故瞋谤我者
    如是何不瞋 诽谤他人者
    谓此唯关他 是故汝堪忍
    如是何不忍 烦恼所生谤
    佛像塔正法 诽谤摧毁者
    我为不应瞋 佛等无害故
    诸害上师者 及害亲友者
    思彼皆缘生 知已应止瞋
    情与无情二 俱害诸有情
    云何唯瞋人 故我应忍害
    或由愚行害 或由愚而瞋
    此中孰无过 孰为有过者
    因何昔造业 于今受他害
    一切既依业 凭何瞋于彼
    如是知见已 以慈互善待
    故吾当一心 勤行诸福善
    譬如屋著火 燃及他屋时
    助火蔓延草 理当速弃彼
    如是心所贪 能助瞋火蔓
    虑火烧德屋 应疾厌弃彼
    如彼待杀者 断手获解脱
    若以人间苦 离狱岂非善
    于今些微苦 若我不能忍
    何不除瞋恚 地狱众苦因
    为欲曾迁返 堕狱受火烧
    然于自他利 吾犹未成办
    此苦不如是 且能成大利
    为除众生害 欣然受此苦
    人赞敌有德 若获欢喜乐
    意汝何不赞 令汝自欢喜
    如是所生乐 唯乐无性罪
    诸佛皆称许 亦是摄他法
    谓他获乐故 然不欲彼乐
    则应不支薪 此坏现后乐
    他赞吾德时 吾亦欲他乐
    赞敌功德时 何故我不乐
    初欲有情乐 而发菩提心
    有情今获乐 何故反瞋彼
    初欲令有情 三界供佛果
    今见劣利敬 何故起忧恼
    所应自抚养 是应汝施给
    若令他人养 不喜岂反瞋
    不愿彼获利 岂愿彼证觉
    瞋彼富贵者 岂有菩提心
    若彼从他得 或利在施家
    既俱非汝有 施不施何干
    何故弃福德 信心与己德
    不守己得财 汝何不瞋己
    非但汝不忧 昔日所为恶
    岂欲竟胜彼 昔培福者乎
    纵令敌不喜 汝有何可乐
    唯盼敌受苦 不成损他因
    汝愿纵得偿 他苦汝何喜
    若谓满我愿 更无余能毁
    若为惑渔夫 利钩所钩执
    陷我于狱瓶 定受狱卒煎
    受赞享荣耀 非福非长寿
    非力非无病 非令身安乐
    若吾识自利 赞誉有何益
    若唯图暂乐 应依饰等酒
    若但为名声 失财复丧命
    语词有何用 死时谁得乐
    沙屋倾颓时 愚童哀极泣
    如是伤失誉 吾心似愚童
    声暂无心故 受赞何足乐
    若谓他喜我 彼赞是喜因
    赞吾或他喜 于我有何益
    喜乐属于彼 少分吾不得
    若因彼而乐 一切应如是
    何故于敌赞 他乐我不乐
    故谓已赞我 心若生欢喜
    此喜亦非当 唯是愚童行
    赞誉令心散 破坏厌离心
    令妒有德者 复毁圆满事
    现前若有人 欲损我声誉
    彼岂非救我 免堕诸恶趣
    吾唯求解脱 勿需利敬缚
    解我束缚者 何故反瞋彼
    如吾欲趣苦 然蒙佛加被
    闭门不放行 云何反瞋彼
    若谓能障福 瞋彼亦非当
    难行莫过忍 云何不忍耶
    若吾因己过 不堪忍彼敌
    是则徒自障 习忍福德因
    无害忍不生 怨敌生忍福
    既为修福因 云何谓障福
    应时来乞者 非行布施障
    授戒诸堪布 亦非障出家
    世间乞者众 忍缘敌害稀
    若不谁施害 必无来害者
    故敌如家宝 毋须费力得
    能助菩提行 故当喜自敌
    敌我共成忍 故此安忍果
    首当奉献彼 因敌是忍缘
    谓无助忍想 故敌非应供
    是则不应供 正法修善因
    谓彼思为害 故敌非应供
    倘如医利我 云何修安忍
    既依极瞋心 方能修坚忍
    唯敌是忍因 应供如正法
    是故牟尼说 生佛胜福田
    常敬彼二者 圆满到彼岸
    修法所依托 有情等诸佛
    敬佛不敬众 岂有此言教
    非说智德等 由果故云等
    有情助成佛 故彼二相等
    怀慈供有情 因彼尊贵故
    敬佛福德广 亦因佛尊贵
    助成修佛份 故许二相等
    然彼非等佛 无边功德海
    唯佛聚德齐 于具少分者
    虽供三界物 犹嫌不得足
    能生胜佛法 有情有此分
    唯因此德符 即应供有情
    无伪众生亲 诸佛利无边
    除令有情喜 何能报佛恩
    利生方足报 舍身入狱佛
    故我虽受害 亦当行众善
    诸佛为有情 尚且不惜身
    愚痴较慢我 云何不侍众
众生乐故佛欢喜 众生遭害诸佛愠
有情欣喜佛悦乐 冒犯有情亦伤佛
犹如身上遍著火 虽与诸欲意不乐
如是若伤诸有情 则无取悦诸佛方
因我昔是害众生 令大悲佛心不悦
众罪我今一一悔 祈佛慈悲尽宽恕
为令如来欢喜故 从今止害利世间
众生鞋虽践吾顶 宁死亦悦世间主
彼大悲佛已无疑 视诸众生犹如己
故见有情即佛体 如是何不敬众生
悦众能令如来喜 成办自利不离此
除世间苦亦即此 故我应常行此事
    譬如大王臣 虽伤众多人
    然有远见者 力堪不报复
    因彼力非单 王势即彼援
    害者力非弱 不应轻忽彼
    悲佛与狱卒 吾敌救援者
    如民侍暴君 普令有情喜
    暴君纵生瞋 不能令遭致
    犯有情所生 地狱诸过害
    如是王虽喜 然彼不能与
    悦有情所得 成满正觉果
    取悦有情果 未来成正觉
    今世享荣耀 吾今何不见
    轮回因忍得 美貌无病苦
    享誉与长寿 乐等转轮王
    忍已需精进 精进菩提住
    如无风不动 无勤福不生
    进即喜为善 下说其违品
    同恶散劣事 自轻凌懒惰
    贪著懒乐味 爱习近睡眠
    不厌轮回苦 频生强解怠
    惑网者捉已 次进投生罗
    正入死神口 云何犹不知
    渐次杀吾类 汝岂不见乎
    然乐睡眠者 如牛见屠夫
    遍封通道已 死神正观望
    此时汝何能 贪食复贪眠
    死亡速临故 及时应积资
    届时方断懒 迟矣有何用
    未济或始做 或唯半成时
    死神突然至 呜呼吾命休
    因忧眼红肿 面颊泪双垂
    亲友已绝望 吾见阎魔使
    忆罪怀忧苦 闻声惧堕狱
    狂以秽履身 届时当如何
    死时所怀惧 尚如待宰鱼
    何况罪所引 难忍地狱苦
    如触灼沸水 婴肉极刺痛
    已造狱业者 何能安乐住
    不劳而欲得 脆弱有多害
    死至似天呼 呜呼苦摧人
    依此人身筏 能渡大苦海
    此筏难复得 愚者勿贪眠
    弃胜正法喜 无边欢乐因
    何故汝反喜 散掉等苦因
    勿怯积资粮 习定令自主
    自他平等观 勤修自他换
    不应自退怯 谓我不得觉
    如来实语者 说此真实言
    所有蚊虻蜂 如是诸虫蛆
    次发精进力 咸证无上觉
    况我生为人 能办利与害
    若不废行持 何故不证觉
    若谓吾怖畏 须舍手足等
    是未察轻重 愚者徒自畏
    无量俱祗劫 千番受割截
    刺烧及分解 今犹未证觉
    吾今修菩提 此苦有限量
    如为除腹疾 暂受割伤苦
    医皆以小苦 疗疾令病除
    为灭众苦故 当忍微小苦
    凡常此疗法 良医尚不用
    巧施缓药方 医治诸病痛
    佛陀先令行 惠施蔬菜等
    习此微施已 渐能施己肉
    一但觉自身 微如诸菜叶
    尔时舍身肉 于彼有何难
    恶断故无苦 智巧故无忧
    是因邪分别 与罪坏身心
    福德令身适 智巧令心安
    为众处生死 菩萨岂生厌
    以此菩提心 能尽宿恶业
    能集福德海 也胜诸声闻
    故应除彼厌 驭驾觉心驹
    彼乐趣胜乐 智者岂退怯
    勤利生助缘 希求坚喜舍
    畏苦思利益 能生希求力
    故断彼违品 以欲坚喜舍
    进取自在力 勤以增精进
    发愿吾灭除 自他诸过失
    然尽一一过 须修一海劫
    若我尚没有 尽过精进分
    定堕无量苦 吾心岂无惧
    发愿吾促成 自他众功德
    成此一一德 须修一海劫
    然我终未生 应修功德分
    无义耗此生 莫名太希奇
    吾昔未供佛 未献喜宴乐
    未曾依教行 未满贫者愿
    未除怖者惧 未与苦者乐
    吾令母胎苦 唯起痛苦已
    从昔至于今 于法未希求
    故遭此困苦 谁复舍求法
    佛说一切善 根本为希求
    希求本则为 恒修果报应
    痛苦不悦意 种种诸畏惧
    所求不顺遂 皆从昔罪生
    由行所思善 无论至何处
    福报皆现前 供以善果德
    恶徒虽求乐 然至何处所
    罪报皆现前 剧苦猛摧残
    因昔净善业 生居大莲藏
    芬芳极清凉 闻食妙佛语
    心润光泽生 光照白莲启
    生出最胜身 喜成佛前子
    因昔众不善 阎魔诸狱卒
    剥皮令受苦 热火熔钢液
    淋灌无肤体 灸燃剑矛刺
    身肉尽碎裂 纷堕烧铁地
    故应希求法 复当恭敬修
    以金刚幢轨 行善修傲慢
    首当量己为 应为不应为
    不宜切莫为 为已不应退
    退则于来生 串习增罪苦
    他事及彼果 卑劣复不成
    于业惑能力 应生自傲慢
    吾应独自为 此是事业慢
    世人随惑转 不能办自利
    众生不如我 故我当尽力
    他尚勤劣业 我怎悠闲住
    亦莫因慢修 无慢最为宜
    乌鸦遇死蛇 勇行如大鹏
    信心若怯懦 反遭小过损
    怯懦舍勤行 岂能除贫乏
    傲慢复力行 大障亦无碍
    故心应坚定 摧灭诸罪堕
    罪堕若胜我 岂能超三界
    吾当胜一切 不使惑胜我
    诸佛狮子儿 应持此信心
    以慢摧何众 乃惑非慢者
    不屈于慢敌 彼慢制慢敌
    因慢生傲者 将赴恶趣道
    人间欢宴失 为仆食人残
    蠢丑体虚弱 轻蔑处处逢
    傲慢苦行者 倘入自慢数
    卑者何所似
    为胜我慢敌 坚持自慢心
    彼为胜利者 英豪自信士
    若复真实灭 慢敌暗蔓延
    定能成佛果 圆满众生愿
    若处烦恼众 千般须忍耐
    如狮处狐群 不遭烦恼害
    人逢大危难 先护其眼目
    如是虽临危 护慧不随惑
    吾宁被烧杀 甚或断吾头
    然则终不应 屈就烦恼敌
    一切时与处 不行非理事
    如童逐戏乐 所做众善业
    心应极耽著 乐彼无厌足
    世人勤求乐 成否犹未定
    二利能成乐 不行乐何有
    如蜂嗜刃蜜 贪欲无厌足
    感乐寂灭果 于彼何需足
    为成所求善 应乐趣彼业
    犹如日中象 遇池疾驰入
    身心疲乏时 暂舍为久继
    事成即应舍 为趣余善故
    沙场老兵将 遇敌避锋向
    如是回惑刃 巧缚烦恼敌
    战阵失利剑 惧故疾拾取
    如是若失念 畏狱速提起
    顺血急流动 毒素遍全身
    如是惑得便 罪恶尽缠身
    如持满油钵 剑尖逼近身
    惧溢虑遭杀 护戒当专注
    复如蛇入怀 疾起速抖落
    如是懈眠至 应疾消退彼
    每逢误犯过 皆当深自责
    屡思吾今后 终不犯此过
    故于一切时 皆应修正念
    依此求明师 圆成正道业
    为令堪众善 应于行事前
    忆不放逸教 振奋欢喜行
    如絮极轻盈 随风任来去
    身心若振奋 众善皆易成

        〖第八品 静虑〗

    发起精进已 意当住禅定
    心意涣散者 住惑獠牙间
    身心若寂静 散乱即不生
    故应舍世间 尽弃诸俗虑
    贪亲爱利等 则难舍世间
    智者尽弃彼 如是修观行
    知有止胜观 能灭诸惑已
    首当勤求止 止由离贪成
    自身本无常 犹贪无常人
    彼纵历千生 不见所爱人
    未见则不乐 不能入等至
    纵见不知足 如昔因爱苦
    若贪诸有请 则障真实性
    亦毁厌离心 终遭愁叹苦
    若心专念彼 此生将虚度
    无常众亲友 亦坏恒常法
    行为同凡愚 必堕三恶趣
    心欲赴圣境 何需近凡愚
    刹那成密友 须臾复结仇
    喜处复生瞋 凡夫难取悦
    忠告则生瞋 反劝离善行
    若不从彼语 生瞋堕恶趣
    妒高竞相等 傲卑赞复骄
    逆耳则生瞋 伴愚怎得益
    伴愚则定生 自赞毁他过
    好谈轮回乐 及诸不善行
    是故近亲友 徒然自招损
    彼无益于吾 吾亦未利彼
    故应离凡愚 会时喜相迎
    亦莫太亲密 平常而善住
    犹如蜂采蜜 为法化缘已
    如昔未谋面 淡然而应住
    吾富受恭敬 众人皆爱我
    若持此骄慢 殁后定生惧
    故吾愚痴意 无论贪何物
    定当招千倍 今生所受苦
    故智者不贪 贪生三途怖
    应当坚信解 彼性本应舍
    纵吾财物丰 令誉遍称扬
    所集诸名利 非随心所欲
    若有人毁我 赞誉何足喜
    若有人赞我 讥毁何足忧
    有情种种心 世尊难取悦
    何况劣如我 故应舍此虑
    僻倪贫穷户 诋毁富裕家
    性本难为侣 伴彼怎得乐
    如来曾宣示 凡愚若无利
    郁郁终寡欢 故莫友凡愚
    林中鸟兽树 不出刺耳声
    伴彼心常乐 何时共安居
    何时住树下 岩洞无人寺
    愿心不眷顾 断舍尘世贪
    何时吾方栖 天然辽阔地
    不执为我所 无贪恣意行
    何时吾能居 唯持钵等器
    匪盗不需衣 不蔽体无惧
    赴于尸寒林 他骨及吾体
    皆为灭性法 何时能平齐
    吾身速腐朽 彼臭令狐狼
    不敢趣前尝 其变终至此
    孑然此一身 生时骨肉连
    灭后各分散 何况是他亲
    生即孤独生 殁复独自亡
    苦痛无人分 亲眷有何用
    如诸行路人 不执暂留处
    如是行有道 他应恋生家
    及至众亲友 伤痛且哀泣
    四人掮吾体 未到应赴林
    无亲亦无怨 只身隐山林
    先已视同死 殁后无人忧
    近者也无有 哀伤或为害
    故佛等随念 无人能令散
    故当独自栖 事少易安乐
    灵秀宜人林 止息众散乱
    尽弃俗虑已 吾心当专一
    为令入等至 制惑而精进
    此世及来生 诸欲引灾祸
    今生砍杀缚 他世入地狱
    月老媒婆前 何故屡恳求
    为何全不忌 诸罪或恶名
    纵险吾亦投 资财亦耗尽
    只为女人怀 望得胜安乐
    除骨更无余 与其贪执彼
    无自非自主 何不趣涅槃
    始则奋抬头 揭已羞垂视
    昔见或未见 悉以纱覆面
    汝昔隐惑容 今现明眼前
    鹫已去其纱 即见何故逃
    昔是他眼窥 汝即忙守护
    今鹫食彼肉 吝汝何不护
    见此聚尸已 鹫兽竞分食
    何苦以花饰 殷献鸟兽食
    若汝见白骨 静卧犹惊骇
    何不惧少女 灵动如活尸
    昔衣汝亦贪 今裸何不欲
    若谓不喜彼 何故拥著衣
    粪便与口涎 悉从饮食生
    何故贪口涎 不乐臭粪便
    嗜欲者不乐 柔软木棉枕
    谓无女人味 彼诚迷垢秽
    迷劣欲者言 棉枕虽滑柔
    难成鸳鸯眠 于彼反生瞋
    若谓厌不净 肌腱系骨架
    肉泥粉饰女 何故拥入怀
    汝自多不净 日用恒经历
    岂贪不得足 犹图他垢囊
    若谓喜彼肉 欲观并摸触
    则汝何不欲 无心尸肉躯
    汝所欲彼心 无从观与触
    可触非心识 空拥何所为
    不明他不净 犹非顶稀奇
    不知自不净 此则太稀奇
    汝执不净心 何故舍弃彼
    晨曦启嫩莲 反著垢秽囊
    若汝不欲触 垢秽所涂地
    云何反欲抚 泄垢源之体
    若不贪不净 不净种所生
    垢秽处所出 何以搂入怀
    粪便所生蛆 虽小尚不欲
    云何欲垢生 诸多不净体
    汝于不净身 非仅不轻弃
    反因贪不净 图彼垢秽囊
    宜人冰片等 米饭或菜蔬
    食已复泄出 大地亦染污
    身垢秽似此 亲见若复疑
    应观寒林尸 及余不净物
    表皮分裂时 见者生大畏
    知此复何能 于彼生欢喜
    彼涂身妙香 是旃檀非他
    何以因异香 贪著他身躯
    若身味本臭 不贪岂非善
    贪欲无聊辈 为何身涂香
    若香属旃檀 则身出何味
    何需因异香 贪爱女身躯
    若长发修爪 黄牙臭泥味
    是令人怖畏 裸体自本性
    何故贪著彼
    欲如伤己器 何故令锋利
    自迷痴狂徒 呜呼满天下
    寒林唯见骨 意若生厌离
    岂乐活白骨 充满寒林城
    又彼不净身 无酬不可得
    今生逐尘劳 后遭地狱难
    少无生财力 及长怎享乐
    财积寿渐近 老来欲何为
    多欲卑下人 白日劳力竭
    夜归精气散 身如死尸眠
    或需赴他乡 长涉历辛劳
    虽欲会骄妻 终年不相见
    成人为自利 因愚卖身讫
    彼利尚未得 空随业风去
    或有自售身 任凭他指使
    妻妾纵临产 荒郊树下生
    欲欺凡夫谓 求活谋生故
    虑丧赴疆场 为利成佣奴
    为欲或杀生 或竖利戈尖
    或遇短矛刺 乃至火焚烧
    积护耗尽苦 应知财多祸
    贪金涣散人 脱苦遥无期
    贪欲生众苦 害多福利少
    彼如拖车牲 唯食数口草
    彼利极微薄 虽畜亦易得
    为彼勤苦众 竟毁暇闲身
    诸欲终坏灭 后堕地狱等
    为此瞬息乐 恒久历艰困
    彼艰千万分 便足成佛道
    欲者较菩萨 苦多无菩提
    思惟地狱苦 始知诸欲患
    非毒火兵器 险敌所能拟
    故当厌诸欲 欣乐阿兰若
    离诤无烦恼 寂静山林中
    皎洁明月光 清凉似檀香
    倾泻平台上 如官意生欢
    林风无声息 徐徐默吹送
    有福瑜伽士 踱步思利他
    空舍岩洞树 随时任意住
    尽舍护持苦 无忌恣肆行
    离贪自在行 谁亦不相干
    王候亦难享 知足闲居欢
    远离重尘缘 思彼具功德
    当尽息分别 观修菩提心
    首当勤观修 自他本平等
    避苦求乐同 护他如护己
    手足肢虽众 护如身则同
    众生苦乐殊 求乐与我同
    虽吾所受苦 不伤他人身
    然彼乃吾苦 执己难忍故
    如是他诸苦 亦不临吾身
    然彼乃吾苦 执己难忍故
    吾应除他苦 苦故如自苦
    吾当饶益他 有情如吾身
    自与他双方 求乐既相等
    与自有何殊 何故求自乐
    自与他双方 恶苦既相等
    自他何差殊 何故唯自护
    谓彼不伤吾 故不护他苦
    后苦不害今 何故汝防护
    若谓当受苦 此诚邪思惟
    亡者他体故 生者亦复然
    若谓需慎防 自身受所苦
    足苦非手苦 何故手护足
    若谓此非理 执我故如此
    执自他非理 唯当极力断
    相续与蕴聚 假名如蔓军
    本无受苦者 谁复感彼苦
    既无受苦者 一切无差别
    苦故悉应除 何故强分别
    不应有此诤 何需除他苦
    除则一切除 否则吾如众
    悲心引多苦 何故强摧生
    若念众生苦 自苦云何多
    一苦若能除 众多他痛苦
    为利自他故 慈者引彼苦
    妙花月虽知 国王有害意
    然为尽众苦 不惜殉生命
    如是修自心 则乐灭他苦
    无间亦乐住 如鹅趣莲池
    有情若解脱 心喜如大海
    此喜宁不足 何求唯自度
    故虽谋利他 然无骄矜气
    一心乐利他 不望得善报
    微如言不逊 吾亦慎防护
    如是于他苦 常习悲护心
    如于他精血 本非吾身物
    串习故执取 精血聚为我
    如是于他身 何不执为我
    自身换他身 是故亦无难
    自身过患多 他身功德广
    知已当修习 爱他弃我执
    众人皆认许 手等是身肢
    如是何不许 有情众生分
    于此无我躯 串习成我所
    如是于他人 何不生我心
    故虽谋利他 然无骄矜气
    如人自喂食 未曾盼回报
    微如言不逊 吾亦慎防护
    如是于众生 当习悲护心
    故观音怙主 为除临众怖
    涌现大悲心 加持自圣号
    闻名昔丧胆 因久亲近故
    失彼竟寡欢 知难应莫退
    若人欲速疾 救护自与他
    当修自他换 胜妙秘密诀
    贪著自身故 小怖亦生畏
    于此生慎身 谁不瞋若敌
    千般欲疗除 饥渴身饥者
    捕杀鱼鸟兽 伺机劫道途
    或为求利敬 乃至杀父母
    盗取三宝物 因是焚无间
    有谁聪智者 欲护供此身
    谁不视如仇 谁不轻蔑彼
    若施何能享 自利饿鬼道
    自享何所施 利他升天法
    为自而害他 将受地狱苦
    损己以利他 一切圆满成
    欲求自高者 卑愚堕恶趣
    若彼转他人 受敬上善趣
    为己役他者 将受仆役苦
    劳自以利他 当封王侯爵
    所有世间乐 悉从利他生
    所有世间苦 咸从自利出
    此何需繁叙 凡愚求自利
    牟尼唯利他 且观此二别
    不能以自乐 真实换他苦
    非但不成佛 生死中无乐
    暂置他世间 然今仆不为
    顾主不给酬 难成现世利
    利他能成乐 舍此则失乐
    害他令受苦 愚者定遭殃
    世间诸灾害 怖畏及从苦
    悉由我执生 此魔何所需
    我执未尽舍 苦必不能除
    犹如火未弃 不免受灼伤
    故为止自害 及灭他痛苦
    舍自尽施他 爱他犹如己
    意汝定当知 吾已全属他
    除利有情想 汝今莫思余
    不应以他眼 诸物办自利
    复莫以眼等 邪恶待众生
    故当尊有情 吾身所有物
    见已咸取出 广利他众生
    易位卑高者 移自换利他
    以无疑虑心 修妒竟胜慢
    彼蒙敬非我 吾财不如彼
    彼受赞非我 彼乐吾受苦
    吾勤苦工作 彼安逸度日
    彼世间盛赞 吾身败名裂
    无才学何为 吾悉有才学
    彼较某人劣 吾亦胜某人
    戒见衰退等 因惑而非我
    彼应力济我 困则力取受
    然吾未蒙济 何以反遭轻
    彼虽具功德 于我有何益
    不愍愚众生 危陷恶趣口
    向外夸己德 欲胜诸智者
    为令自优胜 利能等我者
    虽诤亦冀得 财利与恭敬
    极力称吾德 名扬诸世间
    克抑彼功德 不令世间闻
    且当藏吾过 吾受供非他
    吾今受大利 吾受敬非他
    吾喜观望彼 沦落久遭难
    令受众嘲讽 竞相共诃责
    据云此狂徒 欲与吾相争
    彼才貌慧识 种性宁等我
    故闻众异口 齐颂吾胜德
    毛竖心欢喜 浑然乐陶陶
    彼富吾夺取 若彼为吾佣
    唯予资生酬 其余悉霸取
    当令彼失乐 恒常遇祸害
    一切生死中 彼百损害我
    意汝欲自利 然经无量劫
    遍历大劬劳 以此唯增苦
    是故当尽心 力行众生利
    牟尼无欺言 奉行必获利
    若汝自往昔 素行如此事
    除佛圆满乐 必不逢今苦
    故汝于父母 一滴精血聚
    即可执为我 于他亦当习
    汝作他巡探 见己任何物
    悉数尽盗取 以彼利众生
    自乐他不乐 自高他卑下
    己利不顾他 何不嫉妒己
    吾当离安乐 甘受他人苦
    时观谓何行 细察己过失
    他虽犯大过 欣然吾顶替
    自过纵微小 众前诚忏悔
    显扬他令誉 以此匿自名
    役己如下仆 勤谋众人利
    此身本多过 德暂不足赞
    故当隐己德 莫令他人知
    总之为自利 汝尽害众生
    如今为利他 愿害悉归我
    莫令汝此身 猛现顽强相
    令如初嫁媳 羞畏极谨慎
    坚持利他行 切莫伤众生
    欲行当制止 逾距当治罚
    纵已如是海 若汝犹不为
    众过终临汝 唯当首治罚
    昔是受制汝 今日吾已明
    无论行何处 悉摧汝骄慢
    今当弃此念 吾享自权益
    汝已售他人 莫哀应尽心
    若吾稍放逸 未施汝于众
    则汝定将吾 贩与诸狱卒
    如是汝多番 弃我令久苦
    今忆诸宿怨 摧汝自利心
    若汝欲自惜 不应自爱执
    若汝欲护己 则当常护他
    汝愈献殷勤 护此不净身
    彼愈如是堕 哀朽极脆弱
    身弱欲爱增 此地一切物
    尚且不厌足 谁复惬彼欲
    逐欲未得足 生恼复失意
    若人无所求 彼福无穷尽
    增长身贪故 莫令有机趁
    不执悦意物 此实真妙财
    火化终成灰 不动待他牵
    可怖不净身 何故执为我
    无论生与死 此身何所为
    此何异煤等 怎不除我慢
    奉承此身故 无义集诸苦
    于此似树身 何劳贪与瞋
    或细心爱护 或弃鹫等食
    彼既无贪瞋 何故贪彼身
    何毁令身瞋 何赞令身喜
    彼既无所知 勤苦何所为
    若人喜此身 则彼为吾友
    众皆爱己身 何故不喜彼
    是故应离贪 利众舍自身
    此身虽多患 当视如利器
    愚行吾已足 今当随智行
    忆不放逸教 奋退昏与眠
    如大悲佛子 安忍所当行
    若不恒勤修 何日得出苦
    为除诸障故 回心避邪途
    并于正所缘 恒常修三昧

        〖第九品 智慧〗

    此等一切支 佛为智慧说
    故欲息苦者 当生空性慧
    世俗与胜义 许此为二谛
    胜义非意境 许意是世俗
    世间见二种 瑜伽及平凡
    瑜伽世间破 平凡世间者
    瑜伽慧差别 为上上所胜
    以二所许喻 为果不观察
    世人见世俗 分别为真实
    非如幻化故 与瑜伽师诤
    色等现量境 共称非智量
    彼等诚虚伪 如不净谓净
    为导世间人 佛说无常法
    真实非刹那 岂不违世俗
    瑜伽量无过 待世谓见真
    否则观不净 将违世间见
    幻佛出幻德 如实佛实德
    有情若如幻 死亦云何生
    众缘聚合已 虽幻亦当生
    云何因久住 有情成实有
    幻人杀施等 无心无罪福
    于有幻心者 则生幻罪福
    咒等无功能 不生如幻心
    种种因缘生 种种如幻物
    一缘生一切 毕竟非有此
    若胜义涅槃 世俗皆轮回
    则佛亦轮回 菩提行何用
    诸缘若未断 纵幻亦不灭
    诸缘若断绝 俗中亦不生
    乱识若亦无 以何缘幻境
    若许无幻境 心识当缘何
    真性外别有 境相即心体
    幻境若即心 何者见何者
    世间主亦言 心不自见心
    意如刀剑锋 不能自割自
    若谓如灯火 如实明自身
    灯火非所明 其无暗蔽故
    如晶青依他 物青不依他
    如是亦得见 依与不依他
    非青转青者 非以自为自
    虽说灯能明 识知而说之
    则自心唯明 由何知故说
    若谁亦不见 则明或不明
    如石女娇媚 说彼亦无义
    若无自证分 心识怎忆念
    从受境相连 能知如鼠毒
    具他心通者 见故自明自
    然涂炼就药 见瓶不见药
    於见闻觉知 此处非所遮
    此处所应遮 苦因执地实
    幻境非心外 亦非全无异
    若实怎非异 非异则无实
    如幻境非实 能见心亦然
    轮回依实法 否则如虚空
    若无实依实 云何有作用
    汝心无助伴 当成独一体
    若心离所取 众皆成如来
    施设唯识义 究竟有何德
    虽知法如幻 何能除烦恼
    如彼幻变师 亦贪所变女
    幻师于所知 未断烦恼习
    空性习气弱 见彼犹生贪
    若久修空性 将断实有习
    由修无所有 后亦断空执
    抉择诸法时 不得所察法
    无实离所依 彼岂住心前
    若实无实法 皆不住心前
    彼时无他相 无缘最寂灭
    摩尼如意树 无心满众头
    是由誓愿力 诸佛亦现身
    如人修鹏塔 塔成彼人逝
    虽逝经久远 尚能灭毒等
    随修菩提行 圆成佛宝塔
    菩萨虽入灭 然成一切利
    供养无心者 云何能得果
    住世或涅槃 经说相等故
    于世俗胜义 经说皆得果
    如供真实佛 能得果报然
    由见谛解脱 何用见空性
    经说无此道 不能证菩提
    大乘若不成 汝教云何成
    二皆许此故 汝初亦不成
    何缘信彼典 于大乘亦同
    二许若即真 吠陀亦为真
    大乘有诤故 外道于总教
    自他于他教 诤故皆应舍
    比丘为教本 彼亦难安住
    心有所缘者 亦难住涅槃
    若语入经藏 即许为佛说
    多藏大乘教 云何汝不许
    若因一不摄 一切皆有过
    则当以一同 一切成佛说
    诸圣大迦叶 佛语未尽测
    彼者汝未解 谁舍大乘教
    为救愚苦者 解脱贪惧边
    能成住轮回 此即悟空果
    不应随意破 如上空性理
    心应不生疑 如理修空性
    空性能治彼 烦恼所知障
    欲速成佛者 云何不修彼
    何法若生苦 于彼应生惧
    空性能息苦 云何畏修彼
    若稍存实我 则于彼有惧
    然无任何我 谁是畏惧者
    齿发甲非我 我非骨及血
    非涎非鼻涕 非胆汁非脓
    我非脂非汗 肺肝亦非我
    余内脏非我 亦非粪与尿
    肉与皮非我 热与气非我
    孔穴亦复然 六识皆非我
    声识若是常 一切时应闻
    若无所知声 何理谓识声
    若无识能知 则树亦应知
    是故定应知 无境则无知
    若谓彼知色 彼时何不闻
    若谓声不近 故知识亦无
    持声自性者 何成持色识
    一人成父子 假名非真实
    忧喜暗三德 非子亦非父
    彼无持声性 不见彼性故
    如使异状见 则识即非常
    若异样一体 彼一未曾有
    异样若非真 则自性为何
    若谓即是识 众生将成一
    心无心亦一 同为有者故
    差殊成妄时 何为共同依
    无心亦非我 无心则如瓶
    若谓具心故 知则灭无知
    若我无变异 心于彼何用
    无知离作用 虚空亦成我
    若我非实有 业果系非理
    业造已即灭 应谁受业报
    造业受果异 报时作者亡
    汝我即共许 诤此有何义
    因时见有果 见此不可能
    佛说作者受 依同一相续
    过去未来心 俱无故非我
    生心若是我 彼灭我则亡
    犹如芭蕉树 剥析无所有
    如是以慧观 觅我见非实
    有情若非有 于谁起悲愍
    为果立誓者 因痴虚设有
    无众谁得果 许为痴心得
    为众生息若 不应除果痴
    我慢痛苦因 迷我得增长
    若谓不能除 修无我最胜
    身非足小腿 腿臀亦非身
    腹背及胸肩 彼等复非身
    侧肋手非身 腋窝肩非身
    内脏头与颈 彼等皆非身
    此中何为身
    若身于一切 诸方皆遍住
    诸分住自分 身应住何处
    倘若吾全身 住于手等分
    则尽手等数 应成彼数身
    若内外无身 云何手有身
    手等外无它 云何有彼身
    无身因愚迷 于手生身觉
    如因石状殊 觉彼为真人
    众缘聚合时 则见身似人
    如是于手等 则亦见有身
    如是指聚故 手复应成何
    彼亦节聚故 节者尚可分
    分复析为尘 尘析为方分
    方分离部份 如空微尘无
    是故有智者 谁贪如梦身
    如是若无身 何男何为女
    若苦性中有 云何不灭乐
    乐实则甘等 为何不生喜
    若谓苦强故 不觉彼乐受
    既非领受性 云何可谓受
    若谓有微苦 岂非许除粗
    谓彼即余乐 微苦岂非乐
    尚有逆缘故 苦受不得生
    此岂非成立 受分别是执
    是故应修习 对治空观慧
    观察田中生 禅定瑜伽食
    根境若有隔 彼二如何遇
    无隔二成一 何复触于何
    尘尘不相入 无间相等故
    不入则无合 不合则无遇
    无分而能遇 云何此应理
    若见无分遇 请汝当指彼
    意识无身故 有触不应理
    聚亦无实故 如前应观察
    若触非真有 则受从何生
    何故逐尘劳 何苦伤何人
    若见无受者 领受亦无实
    彼时见此已 云何爱不灭
    所见或所触 皆为梦幻性
    与心俱生故 受非心能见
    后念唯能忆 非能受前心
    不能自受自 亦非它能受
    毕竟无受者 故受非真有
    云何以此受 害此无我聚
    意不住诸根 非住色与中
    既不住内外 余处亦不得
    非身非异身 非合亦非离
    彼无少实故 有情性涅槃
    若境前有识 缘何而生识
    识境若同时 则彼缘何生
    若识境后起 识当缘何生
    故应不能知 法生为实有
    倘若无世俗 云何有二谛
    世俗若因它 有情岂涅槃
    此由他分别 彼非自世俗
    后决定则有 非故无世俗
    分别所分别 二者相依存
    故一切观察 皆依世共称
    以析空性智 究彼空性时
    析智尚需智 则应成无穷
    悟明所究已 理智无所依
    无依故不生 说此即涅槃
    心境实有宗 彼极难安立
    若境由识成 依何立识有
    若识由境成 凭何立所知
    心境相待有 二俱应非实
    无子则无父 无父子何生
    无子亦无父 如是无心境
    如芽从种生 因芽知有种
    由境所生识 何不知有境
    由彼异芽识 虽知有芽种
    然心知境时 凭何知真识
    世人亦现见 一切能生因
    莲花根茎等 差别因所生
    谁作因差别 由昔诸异因
    何故因生果 从昔因力故
    自在天是因 何为自在天
    若谓许大种 何必唯取名
    然而大种众 非常动非天
    不净践踏物 定非自在天
    非空无动故 非我前已破
    若非可思议 说彼有何用
    云何此彼生
    我与自在天 大种岂非常
    识从所知生 苦乐无始业
    何为彼所生
    若谓因无始 彼果何有始
    彼不依他故 何故不常作
    若皆彼所造 则彼尚依何
    若依缘聚生 则因生非彼
    若聚则定生 无聚无生力
    若非自在欲 则生依他力
    若欲依欲作 若作何自在
    微尘常恒因 於前已破讫
    主常众生因 数论师所许
    乐忧及与暗 三德平衡状
    即说为主体 不平变众生
    一体有三性 非理故彼无
    如是德非有 彼复得三故
    若无此三德 亦离有声等
    无心之衣等 亦非有乐等
    谓法即因性 岂非已究讫
    汝因为三德 从彼不生布
    若布生乐等 无布则无乐
    故乐等常性 毕竟不可得
    乐等恒存者 时终无所缘
    若有乐等明 为何不领受
    若谓彼变细 云何有粗细
    舍粗而变细 粗细应无常
    如是何不许 一切法非常
    粗既不亦乐 显然乐非常
    若许因位无 无则终不生
    则纵汝不许 无显生亦在
    因时若有果 食成食不净
    汝应以布值 购穿棉花种
    谓愚不见此 然知真所立
    世间亦应知 何故不见果
    世见若非量 所见亦非真
    若量皆非量 量果岂非假
    故汝修空性 亦应成错谬
    不依所察实 不取彼无实
    所破实既假 无实亦然假
    如于梦子死 知无梦中子
    能遮有之想 彼遮亦是假
    如是究诸法 则知非无因
    亦非住各别 或合集诸缘
    亦非从他来 非住非趋行
    因愚所执谛 何异于幻物
    幻物及众因 所变诸事物
    应详观察彼 何来去何处
    缘合见诸物 无因则不见
    虚伪如影像 其中岂有真
    若法已有成 其因何所需
    若法本无者 彼因复何需
    纵以亿万因 无不能成有
    无时怎成有 成有者为何
    无时若无有 何时方成有
    于有杀生时 是则未离无
    倘若未离无 是则无有时
    有亦不成无 应成二性故
    自性不成灭 有法性亦无
    此等诸众生 毕竟不生灭
    众生如梦幻 究时同芭蕉
    涅槃不涅槃 其性皆无别
    故于诸空性 何有得与失
    谁人恭敬我 谁人轻蔑我
    苦乐由何生 何有喜与忧
    若于性中觅 孰为爱所爱
    细究此世人 谁将逝于此
    孰生孰当生 何为亲与友
    如我当受持 一切如虚空
    诸欲求乐者 由争爱诸因
    引生烦乱喜 勤求忧苦诤
    互砍相杀刺 因罪艰困活
    虽数至善趣 频享众欢乐
    死已堕恶趣 久历难忍苦
    三有多险地 迷真即同缚
    迷悟复相违 世无等此真
    难忍无法喻 苦海无边际
    如是善力微 寿命亦短促
    为活及无病 强忍饥疲苦
    睡眠受他害 愚伴行无义
    无义命速逝 观慧极难得
    此生有何法 除灭散乱因
    此时魔亦勤 诱堕于恶趣
    彼复邪道多 难逾正法疑
    暇满难再得 难遇佛出世
    不易断惑流 呜呼苦相续
    如是虽极苦 因痴不觉苦
    众生往苦流 呜呼应悲愍
    如人数沐浴 或数入火中
    如是虽极苦 然自以为乐
    如是诸众生 度日若无死
    先遭拭杀已 后堕恶趣苦
    何时吾能降 自集福德云
    所出安乐雨 为众息苦火
    何时方无缘 诚敬集福德
    于执有众生 开示空性理

      〖第十品 回向〗

    造此入行论 所生诸福善
    回此愿众生 悉入菩萨行
    周遍诸方所 身心病苦者
    愿彼因吾福 得乐如大海
    愿彼尽轮回 终不失安乐
    愿彼悉皆得 相续菩萨乐
    于诸世间界 所有诸地狱
    彼中众有情 愿获极乐喜
    愿寒者得暖 亦愿菩萨云
    飘降无边水 清凉灸热苦
    愿彼剑叶林 悉成美乐园
    铁刺树枝干 咸长如意枝
    愿狱成乐园 饰以鸥鹅雁
    悦音美飞禽 芬芳大莲池
    愿煨成宝聚 烧铁成晶地
    怖畏众合山 成佛无量宫
    岩浆石兵器 悉成散花雨
    刀兵相砍杀 化为互投花
    地狱众有情 咸溺铁浆河
    皮肉溶蚀尽 骨露水仙白
    愿彼因吾善 得获天身福
    缓降天池中 天女共嬉游
云何此中恐怖隼 炎魔卒鹫顿生惧
何人有此微妙力 尽除黑暗生喜乐
思已仰望虚空际 见金刚手璀灿立
愿彼以此欣喜力 常随菩萨远宿罪
愿狱苦难有情见 花雨掺拌妙香水
纷纷自天迅飘降 熄灭熊熊地狱火
顿觉安乐意喜足 心念此系何因缘
思时仰望虚空际 喜见持莲圣观音
愿地狱中众有情 喜见文殊而欢呼
吾友莫惧速来此 吾等上方有文殊
五髻童子光灿灿 已生慈悲菩提心
力能灭苦引喜乐 彻底救护诸众生
能令畏惧尽消除 谁复舍此而他去
汝观彼居悦意宫 成千天女齐歌颂
莲花足上呈供奉 百天所成五佛冠
天花妙雨临其顶 大悲泪水润慈目
    复愿狱有情 以吾善根力
    悉见普贤等 无碍菩萨云
    飘降芬芳雨 清凉复安乐
    见已彼等众 真实生欢喜
    愿彼旁生离 遭残食怖畏
    并愿饿鬼获 北俱卢人乐
    愿圣观世音 手出相续乳
    饱足饿鬼众 永浴恒清凉
    愿盲者见色 聋者常闻声
    佛母摩耶女 孕妇产无碍
    愿裸者得衣 饥者得足食
    渴者得净水 妙味诸甘饮
    愿贫者得财 苦者得安乐
    愿彼绝望者 振奋意永固
    愿诸病有情 速脱疾病苦
    并愿众生疾 毕竟永不生
    愿畏者无惧 缚者得解脱
    弱者力强壮 心思互饶益
    愿十方商贾 处处皆安乐
    所求一切利 无劳悉成办
    愿诸航行者 成办意所愿
    安然抵边岸 亲友共欢聚
    愿迷荒郊者 幸遇诸行旅
    无有盗虎惧 无倦顺利行
    愿诸天守护 无路险难处
    老弱无怙者 愚痴颠狂徒
    愿脱无暇难 具信慈爱慧
    食用悉富饶 时时忆宿命
    愿受用无尽 犹如虚空藏
    愿无诤无害 自在享天年
    愿卑微寒士 容光悉焕发
    苦行憔悴者 健朗形庄严
    愿世娇弱女 悉成男子汉
    寒门得显贵 慢者转谦逊
    愿一切有情 因吾诸福德
    悉断一切恶 常乐福善行
    愿不舍觉心 委身菩提行
    诸佛恒提携 断尽诸魔业
    愿诸有情众 万寿永无疆
    安乐度时日 不闻死殁名
    愿一切诸方 遍长如意林
    充满佛佛子 所宣妙法音
    愿十方大地 无砾无荆棘
    平坦如舒掌 柔软似琉璃
    愿诸菩萨众 安住闻法眷
    各以妙功德 庄严诸道场
    愿一切有情 相续恒听闻
    鸟树及光明 虚空所出音
    彼等常值佛 以及诸佛子
    并以无边云 献供众生师
    愿天降时雨 五谷悉丰收
    仁王如法行 世事皆兴荣
    愿药具速效 咒语咸灵验
    空行罗刹等 悉具慈悲心
    愿有情无痛 不病未造罪
    无惧不遭轻 毕竟无不乐
    愿诸伽蓝寺 读诵以兴盛
    僧伽常和合 僧事悉成办
    愿欲学比丘 悉住阿兰若
    断诸散乱已 轻安堪修善
    愿尼得利养 断诤离诸害
    如是众僧尼 戒圆无缺憾
    犯者愿生悔 时时忏罪业
    愿彼得善趣 不复失禁戒
    愿智受尊崇 化缘皆得足
    心续悉清净 令誉遍诸方
    愿离恶趣苦 以及诸艰困
    复以胜天身 迅速成正觉
    愿一切有情 殷勤供诸佛
    依佛无边福 恒常得安乐
    愿菩萨如愿 成办众生利
    愿有情悉得 怙主慈护念
    愿独觉声闻 如是亦得乐
    未登极喜前 愿蒙文殊恩
    常忆己宿命 出家恒为僧
    愿吾菲饮食 维生充体能
    愿世世恒得 圆满寂静处
    何世欲阅藏 或欲问法义
    愿我无障碍 面见文殊尊
    为于十方际 成办有情利
    愿吾行酷似 文殊圆满行
    乃至有虚空 以及众生住
    愿吾住世间 尽除众生苦
    愿众生诸苦 悉报于吾身
    愿因菩萨德 众生享安乐
    愿除苦良药 一切安乐源
    教法伴利敬 长久住世间
    礼敬文殊尊 恩生吾善心
    亦礼善知识 恩长吾三学

**********************************************************************
【录自：佛文化】