The Diamond Perfection of Wisdom Sutra

[ Updates
& News ] [ Poetry & Stories ]
[ Theravada Writings ]
[ Zen / Ch'an Writings ]
[ Other Mahayana Writings ]
[ Buddhist Webrings ]
[ Buddhist Links ]
[ About this Page ]
[ Home ]

The Diamond Perfection of Wisdom Sutra

The Vajracchedika-prajna-paramita Sutra

Thus have I heard. Once upon a time, the Buddha sojourned in the Jetavana park near Sravasti with an assembly of twelve hundred and fifty bhiksus.

One day, at mealtime, the World Honoured One put on His robe, took His bowl, and entered the great town of Sravasti to beg for His food. After He had begged from door to door, He returned to His place. When He had taken His meal, He put away His robe and bowl, washed His feet, arranged His seat and sat down.

At the time, the elder Subhuti who was in the assembly, rose from his seat, uncovered his right shoulder, knelt upon his right knee, respectfully joined the palms of his hands and said to the Buddha: 'It is very rare, O World Honoured One! how well the Tathagata protects and thinks of all Bodhisattvas; how well He instructs all the Bodhisattvas.

"O World Honoured One, when virtuous men or women develop the supreme-enlightenment mind, how should their minds abide and how should they be subdued?' The Buddha said: 'Excellent, excellent, Subhuti! As you say, the Tathagata protects, cherishes and instructs Bodhisattvas so well. Now listen attentively and I will tell you how the minds of virtuous men and women, who develop the supreme enlightenment mind, should thus abide and be subdued. (Subhuti replied: ) 'Oh yes, World Honoured One, I shall be glad to hear (your instruction).'

The Buddha said: 'Subhuti, all Bodhisattvas and Mahasattvas should subdue their minds as follows: All living beings born from eggs, wombs, humidity or by transformation, with or without form, either thoughtful or thoughtless, and neither thoughtful nor thoughtless are all led by me to the final nirvana for the extinction of reincarnation. Although immeasurable, uncountable and unlimitable numbers of living beings are thus led to (the final nirvana for) the extinction of reincarnation, it is true that not a living being is led there. Why so, Subhuti? (Because) if a Bodhisattva (still) clings to the false notion (laksana) of an ego, a personality, a being and a life, he is not ( a true) Bodhisattva. 'Furthermore, Subhuti, a Bodhisattva's mind should not abide anywhere when giving alms; that is to say, he should give without a mind abiding in form, or he should give without a mind abiding in sound, or in smell, or in taste, or in touch or in things . Subhuti thus a Bodhisattva should give alms without a mind abiding in false notions of form (laksana).

'Why? (Because) if a Bodhisattva's mind does not abide in forms .(laksanas) when practising charity (dana), his merit will be inconceivable and immeasurable. Subhuti, what do you think? Can you think of and measure the extent of space in the East?'

'I cannot, World Honoured One!'

'Subhuti, can you think of and measure (all) the extent of space in the South, West and North, as well as in the intermediate directions, including the zenith and nadir?'

'I cannot, World Honoured One!'

'Subhuti, (when) a Bodhisattva practises charity without a mind abiding in forms, his merit is equally inconceivable and immeasurable.' 'Subhuti, a Bodhisattva's mind should thus abide as taught.

'Subhuti, what do you think? Can the Tathagata be seen by means of His bodily form?'

'No, World Honoured One, the Tathagata cannot be seen by means of His bodily form. Why? Because when the Tathagata speaks of bodily form, it is not (real) form.'

The Buddha said to Subhuti: 'Everything with form is unreal; if all forms are seen as unreal, the Tathagata will be perceived.'

Subhuti said to the Buddha: 'World Honoured One, will there be living beings who can develop a true belief in these words, sentences and chapters when they are expounded to them?'

The Buddha said: 'Subhuti, do not speak like that. In the last 500 years, before the final passing of the Tathagata, there will be those who will observe the rules of morality and perform good actions which will result in blessing. These people will be able to develop a faith in these sentences (which they will consider as embodying the Truth. You should know that they will not have planted good roots in just one, two, three, four, or five Buddha lands. They will have planted them in countless thousands and tens of thousands of Buddha lands. Upon hearing these sentences, there will arise in them a single thought of pure faith. Subhuti, the Tathagata knows and sees all; these living beings will thus acquire immeasurable merits. Why? (Because) they will have wiped out false notions of an ego, a personality, a being and a life, of Dharma and Not-Dharma. Why? (Because) if their minds grasp form (laksana), they will (still) cling to the notion of an ego, a personality, a being and a life. If their minds grasp the Dharma, they will (still) cling to the notion of an ego, a personality, a being and a life. Why? (Because) if their minds grasp the Not-Dharma, they will (still) cling to the notion of an ego, a personality, a being and a life. Therefore, one should not grasp and hold on to the notion of Dharma as well as that of NotDhama. This is why, the Tathagata always said: "Ye Bhiksus, should know that the Dharma I expound is likened to a raft." Even the Dharma should be cast aside; how much more so the Not-Dharma?

'Subhuti, what do you think? Has the Tathagata (in fact) obtained Supreme Enlightenment (Anubodhi)? Does the Tathagata (in fact) expound the Dharma?'

Subhuti replied: 'As I understand the meaning of the Buddha's teaching, there is no fixed Dharma called Supreme Enlightenment and there is also no fixed Dharma the Tathagata can expound. Why? (Because) the Dharma the Tathagata expounds cannot be clung to and cannot be expressed (in words); it is neither Dharma nor Not-Dharma. Why is this? All Bhadras and Aryas differ on account of the Eternal Asamskrta Dharma.'

'Subhuti' what do you think? If someone filled the Universe with the seven treasures and gave them all as alms, would his merit be great?'

Subhuti replied: 'Very great, World Honoured One. Why? Because this merit is not the nature of merit, the Tathagata says it is great.'

'Subhuti, if on the other hand, someone received and kept even a four line stanza of this sutra and expounded it to others, his merit would surpass that (of the giver of treasures). Why? (Because), Subhuti, all Buddhas and their Supreme-Enlightenment-Dharma originate from this sutra. Subhuti, the so-called Buddhas and Dharmas are not real Buddhas and Dharmas.

'Subhuti, what do you think? Can one who has entered the stream (srota-apanna) have this thought (in his mind): I have obtained the fruit of entering the stream?'

Subhuti replied: 'No, World Honoured One. Why? Because srota-apanna means 'entering the stream', but actually there is no entry into either form, sound, smell, taste, touch or dharma. Therefore, he is called srota-apanna.'

'Subhuti, what do you think? Can a Sakrdagamin have this thought (in his mind): I have obtained the fruit of a Sakrdagamin?'

Subhuti replied: 'No, World Honoured One. Why? Because Sakrdagamin means „once more to come", but actually there is neither coming nor going. Therefore, he is called a Sakrdagamin.'

'Subhuti, what do you think? Can an Anagamin have this thought (in his mind): I have obtained the fruit of an Anagamin?'

Subhuti replied: 'No, World Honoured One. Why? Because Anagamin means "no-coming" but actually there is no such a thing as no-coming. Therefore, he is called an Anagamin.'

'Subhuti, what do you think? Can an Arhat have this thought (in his mind): I have obtained the enlightenment of an Arhat?'

Subhuti replied: 'No, World Honoured One. Why? Because there is no Dharma which is called Arhatship. World Honoured One, if an Arhat thinks "I have obtained the enlightenment of an Arhat", he will still grasp and hold on to the notion of an ego, a personality, a being and a life. World Honoured One, the Buddha has declared that I have obtained the Passionless Samadhi and that I surpass all men. I am, therefore, the highest passionless Arhat. World Honoured One, I do not think "I am a passionless Arhat" for, World Honoured One, if I had thought "I have attained Arhatship", the World Honoured One would not have said: "Subhuti takes delight in- the calm and quiet, free from temptation and distress." The fact that Subhuti does not act (mentally) is called the calm and quiet in which Subhuti takes delight.'

The Buddha said to Subhuti: 'What do you think.? Did the Tathagata obtain anything from the Dharma, when in the past He was with Dipamkara Buddha?'

'No, World Honoured One. When the Tathagata was with Dipamkara, He did not obtain anything from the Dharma.'

'Subhuti, what do you think? Do Bodhisattvas adorn Buddha lands (by their moral actions)?'

'No. World Honoured One. Why? Because this is not real adornment; it is (merely) called the adornment of Buddha lands.'

'Subhuti, this is why all Bodhisattvas and Mahasattvas should thus develop a pure and clean mind which should not abide in form, sound, smell, taste, touch and dharma. They should develop a mind which does not abide in anything. 'Subhuti, supposing a man has a body as great as mount Sumeru, what do you think? Would such a body be great?'

Subhuti replied: 'Very great, World Honoured One. Why? Because the Buddha says it is not the real body but is (merely) called a great body.'

'Subhuti, if there were as many rivers like the Ganges as there are grains of sand in the Ganges, would the total of grains of sand in all these rivers be very great?'

Subhuti replied: 'Very great, World Honoured One! These rivers would be innumerable; how much more so would be their sand-grains.'

'Subhuti, I now tell you truly. If a virtuous man or woman filled a number of universes, as great as the number of sand-grains in all these rivers, with the seven treasures, and gave them all away in alms (dana), would his or her merit be great?'

Subhuti replied: 'Very great, World Honoured One!'

The Buddha said to Subhuti: 'If a virtuous man or woman receives and holds (in mind) even a four-line stanza of this sutra and expounds it to others, his or her merit will surpass that of the almsgiver. Furthermore, Subhuti, wheresoever this sutra or even one of its four-line stanzas is expounded, you should know that all devas, men and asuras should make their offerings there as if the place was a Buddha stupa or a Buddha temple. How much more so if someone is able to receive, hold (in mind), read and recite the whole sutra! Subhuti, you should know that such a person will achieve the highest and rarest Dhama. Wheresoever this sutra may be found the Buddha and His respected disciples will be there also.'

Subhuti then asked the Buddha: 'World Honoured One, what name should be given to this sutra and how should we receive and hold it (in mind)?'

The Buddha said: 'This sutra should be called The Diamond prajna-paramita" under which name you should receive and hold it. Why? Because, Subhuti, the Prajna- paramita as expounded by the Buddha, is not Prajna- paramita but is (merely) so called.'

'Subhuti, what do you think Does the Tathagata expound the Dharma?'

Subhuti said: 'World Honoured One, the Tathagata does not expound anything.'

'Subhuti, what do you think? Are there many particles of dust in the universe?'

Subhuti replied: 'Many, World Honoured One!'

'Subhuti, the Tathagata says these particles of dust are not (real), (but) are (merely) called particles of dust. The Tathagata says the universe is not (real), but it is (merely) called the universe.'

'Subhuti, what do you think? Can the Tathagata be perceived by means of His thirty-two physical characteristics (laksanas)?'

'No, World Honoured One. The Tathagata cannot be perceived by them. Why? Because the Tathagata says they are not real but are (merely) called the thirty-two physical characteristics.'

'Subhuti, if on the one hand, a virtuous man or woman, in giving alms (dana), sacrifices as many lives as there are sand-grains in the Ganges, and on the other hand, someone receives and holds (in mind) even a four-line stanza of this sutra, and expounds it to other, the merit resulting from the latter will be greater.'

At that time, after listening to this sutra, Subhuti had understood its profound meaning and was moved to tears. He said to the Buddha: 'How rare, O World Honoured One! The Buddha has expounded such a very profound sutra. Since I have acquired the wisdom eye, I have not heard of such a sutra. World Honoured One, if someone after listening to this sutra believes that his mind is clean and pure, he will realise reality. We should know that such a person will achieve the highest and rarest merit. World Honoured One, this Reality is not Reality but the Tathagata calls it Reality. World Honoured One, as I now listen to this sutra I have no difficulty in believing, understanding, receiving and holding it, but in the last epoch, the last five hundred year period if there be a man who (happens to) listen to this sutra, believes, understands receives and holds it, he will be most rare. Why? Because he will no longer (think in terms of) an ego, a personality, a being and a life. Why? Because the forms of an ego, a personality, a being and a life are not forms. Why? Because when he has rejected all forms he is called a Buddha.'

The Buddha said: 'Just so! Subhuti, just so! If on the one hand, there be a man who listens to this sutra and is not filled with alarm, fear, or dread, you should know that such a person is most rare. Why? Because, Subhuti, as the Tathagata says, the first perfection ( paramita) is not so (but) is (merely) called the first perfection (paramita).

'Subhuti, the Tathagata speaks of the Perfection of Patience (ksanti paramita) which is not but is called the Perfection of Patience. Why? Because, Subhuti, in (a) past (life) when my body was mutilated by Kaliraja, I had at that time no notion of an ego, a personality, a being and a life. Why? Because, in the past, when my body was dismembered, if I (still) held the conception of an ego, a personality, a being and a life, I would have been stirred by feelings of anger and hatred. Subhuti, I also remember that in the past, during my former five hundred lives, I was a Ksantyrsi and held no conception of an ego, a personality, a being and a life. Therefore, Subhuti, Bodhisattvas should forsake all conceptions of form and resolve to develop the Supreme Enlightenment Mind (Anuttara-samyaksam-bodhi). Their minds should not abide in form, sound, smell, taste, touch and dharma. Their minds should abide nowhere. If minds abide somewhere, it will be in falsehood. This is why the Buddha says that Bodhisattvas' minds should not abide in form when practising charity (dana). Subhuti, all Bodhisattvas should thus make offerings for the welfare of all living beings. The Tathagata speaks of forms which are not forms and of living beings who are not living beings. 'Subhuti, the Tathagatas' words are true and correspond to reality. They are ultimate words, neither deceitful nor heterodox. Subhuti, the Dharma the Tathagata has obtained is neither real nor unreal. 'Subhuti, if a Bodhisattva practises charity ( dana ) with a mind abiding in things (dharma), he is like a man entering the darkness where he cannot see anything; (but) if a Bodhisattva practises dana with a mind not abiding in dharma, he is like a man with open eyes, who can see everything in the sunshine.

'Subhuti, in future ages, if a virtuous man or woman is able to receive, hold (in mind), read and recite this sutra, the Tathagata, by means of His Buddha Wisdom, will know and see clearly that such a person will achieve immeasurable and unlimitable merits. Subhuti, if (on the one hand) a virtuous man or woman sacrifices in the practice of charity (dana), as many lives as the sand-grains of the Ganges in the morning, at midday and again in the evening, and continues so doing throughout numberless aeons; and if (on the other hand) a person after listening to this sutra believes in his own mind without (further) contradiction, the latter's merit will surpass that of the former. How much more so if this sutra is written, received, held, read, recited and expounded to others!

'Subhuti, to sum up, the merits resulting from this sutra are inconceivable, inestimable and without limit. The Tathagata expounds it to those initiated into the Mahayana and the Supreme Yana. If they are able to receive, hold (in mind), read and recite it and expound it widely to others, the Tathagata will know and will see that they will achieve inexpressible and inconceivable merits that are without measure or limit. They will bear (responsibility for) the Tathagata's Supreme Enlightenment (Anuttara-samyak-sambodhi.) Why? Because, Subhuti, those who take delight in the Hinayana and hold the view of an ego, a personality, a being and a life, cannot listen to, receive, hold (in mind), read and recite this sutra and explain it to others.

'Subhuti, wheresoever this sutra may be found, all worlds of devas, men and asuras should make offerings, for you should know that such a place is just a stupa which should be revered, worshipped and circumambulated, with offerings of flowers and incense. 'Furthermore, Subhuti, if a virtuous man or woman receives, holds (in mind), reads and recites this sutra and is despised by others, this person who is bound to suffer from evil destinies in retribution for his past sins, and whose karmic Sins are now eradicated by the others' contempt, will attain Supreme Enlightenment (Anuttarasamyak-sambodhi).

'Subhuti, I remember that in the past countless aeons before the advent of Dipamkara Buddha, I met 84,000 milliards of Buddhas to whom I made offerings and whom I served faultlessly. Now if in the last period (of 500 years) in the Buddha kalpa someone is able to receive, hold (in mind), read and recite this sutra, his merits will far exceed mine which resulted from my offerings made to Buddhas, for mine cannot be reckoned as one hundredth, one thousandth, one ten thousandth or one hundred thousandth part thereof; in fact no computation or comparison is possible. Subhuti, in the last period of the Buddha kalpa, if a virtuous man or woman is able to receive, hold (in mind), read and recite this sutra, my full statement of this person's merits will create derangement, doubt and disbelief in the minds of all listeners. Subhuti, you should know that as the meaning of this sutra is inconceivable, so is the fruit of its reward.'

At the time, Subhuti asked the Buddha: 'World Honoured One, if a virtuous man or woman is determined to develop the Supreme Enlightened Mind, how should his or her mind abide and how should it be subdued?'

The Buddha said to Subhuti: 'A virtuous man or woman who is determined to develop the Supreme Enlightened Mind, should thus develop it: I have to lead all living beings to put a stop to (reincarnation) and escape (suffering), and when they have been so led, not one of them in fact stops (reincarnating) or escapes suffering. Why? Because, Subhuti, if a Bodhisattva clings to the notion of an ego, a personality, a being and a life, he is not a (true) Bodhisattva. Why? Because, Subhuti, there is not really a Dharma which can develop the Supreme-Enlightenment-Mind.

'Subhuti, what do you think? When the Tathagata was with Dipamkara Buddha, did He have any Dharma by means of which He attained Supreme Enlightenment (Anuttara-samyak-sambodhi)?'

'No, World Honoured One. As I understand the meaning of the Buddha's teaching, when He was with Dipamkara Buddha, He had no Dharma by means of which He attained "Supreme Enlightenment".'

The Buddha said: 'Just so! Subhuti, just so! There was really no Dharma by means of which the Tathagata attained Supreme Enlightenment. Subhuti, if there had been, Dipamkara Buddha would not have predicted: "In your next life, you will be a Buddha named Sakyamuni". 'Why is it? Because "Tathagata" means the suchness of all Dharmas. If someone still says: "The Tathagata obtained Supreme Enlightenment," I tell you, Subhuti, there is no Dharma by means of which the Buddha did so, (because), Subhuti, that Enlightenment was by itself neither real nor unreal. This is why the Tathagata says that all Dharmas are Buddha's Dharmas. Subhuti, these so-called Dharmas are not, but are (expediently), called all Dharmas. Subhuti, supposing there is a man whose body is great.'

Subhuti said: 'World Honoured One, the great body of which the Tathagata speaks is not great, but is (expediently) called a great body.'

'Subhuti, in like manner, if a Bodhisattva says: "I should lead uncountable living beings to put a stop to (reincarnation) and escape (from suffering)", he cannot be called a Bodhisattva. Why? Because there is really no dharma called the Bodhisattva (stage). Therefore, the Buddha says: "Of all dharmas, there is not a single one which possesses an ego, a personality, a being and a life." Subhuti, if a Bodhisattva says: "I should adorn Buddha lands", he cannot be called a Bodhisattva. Why? Because when the Tathagata speaks of such adornment it is not, but is (expediently), called adornment. Subhuti, if a Bodhisattva is thoroughly versed in (the doctrine of) the unreality of ego and of things (dharma), the Tathagata will call him a true Bodhisattva. 'Subhuti, what do you think.? Does the Tathagata possess human eyes?

'Yes, World Honoured One, the Tathagata possesses human eyes.'

'Subhuti, what do you think? Does the Tathagata possess deva eye?'

'Yes, World Honoured One, the Tathagata possesses deva eyes.'

'Subhuti, what do you think? Does the Tathagata possess wisdom eyes?'

'Yes, World Honoured One, the Tathagata possesses wisdom eyes.

'Subhuti, what do you think? Does the Tathagata possess Dharma eyes?

'Yes, World Honoured One. The Tathagata possess Dharma eyes'

'Subhuti, What do you think? Does the Tathagata possess Buddha eyes?'

'Yes, World Honoured One, the Tathagata possesses Buddha eyes.'

'Subhuti, what do you think? Does the Tathagata say that the sand-grains in the Ganges are sand-grains?

'Yes, World Honoured One, the Tathagata says they are sand-grains'

'Subhuti, what do you think? If there were as many Ganges rivers as sand-grains in the Ganges, and if there were as many Buddha realms as sandgrains of all these Ganges rivers, would there be many world systems.?'

'Many, World Honoured One!'

The Buddha said the living beings in all these world systems have many different minds which are all known to the Tathagata. Why? Because the minds the Tathagata speaks of are not minds, but are (expediently) called minds. And why? Because, Subhuti, neither the past, the present nor the future mind can be found.

'Subhuti, what do you think.? If someone filled the universe with the seven treasures and gave all away in his practice of dana, would this (good) cause enable the giver to gain a great merit?' 'Yes, World Honoured One, because of this (good) cause the giver would gain a great merit.' 'Subhuti, if the merit was real, the Tathagata would not say it was great. He says so because there is no merit. 'Subhuti, what do you think? Can the Buddha be perceived by His completely perfect physical body (rupa-kaya)?' 'No, World Honoured One, the Tathagata should not be so perceived. Why? Because the Buddha says the completely perfect rupa-kaya is not, but is called the completely perfect rupakaya.'

'Subhuti' what do you think? Can the Tathagata be perceived by His completely perfect forms?

'No, World Honoured One, the Tathagata should not be so perceived, because the Tathagata says the completely perfect forms are not, but are called completely perfect forms.'

'Subhuti, do not say that the Tathagata thinks: "I must expound the Dharma". Do not have such a thought. Why? Because if someone says so, he will really slander the Buddha and be unable to understand my teaching. Subhuti, when (the 'Tathagata) expounds the Dharma, there is really no Dharma to teach: but this is (expediently) called teaching the Dharma.'

Then the wise Subhuti said to the Buddha: 'World Honoured One, will there be in future ages living beings who will believe this Dharma when they hear it?'

The Buddha said: 'Subhuti, the living beings (you just mentioned) are neither living nor not living beings. Why? Because, Subhuti, the Tathagata says these living beings are not (really), but they are (expediently), called living beings.'

Subhuti said to the Buddha: 'World Honoured One, does your (own) attainment of Supreme Enlightenment (Anuttara-samyak-sambodhi) mean that you have not gained anything whatsoever?'

The Buddha replied: 'Just so, Subhuti, just so, I have not gained even the least Dharma from Supreme enlightenment, and this is called Supreme Enlightenment. Furthermore, Subhuti, this Dharma is universal and impartial; wherefore it is called Supreme Enlightenment. The practice of all good virtues (Dharmas), free from attachment to an ego, a personality, a being and a life, will result in the attainment of Supreme Enlightenment. Subhuti. the so-called good virtues (Dharmas), the Tathagata says, are not good, but are (expediently) called good virtues. 'Subhuti, if (on the one hand) a man, in his practice of charity (dana) gives away the seven treasures piled up in a heap as great as all the Mounts Sumeru in the Universe put together, and (on the other hand) another man receives, holds (in mind) reads and recites even a four-line stanza of this Prajna-paramita Sutra, and expounds it to others, the merit resulting from the former's dana will not be worth one-hundredth, one-thousandth, one-ten-thousandth and one-hundred thousandth part of that obtained by the latter, as no conceivable comparison can be made between the two. 'Subhuti, what do you think? You should not say the Tathagata has this thought (in His mind): "I should liberate living beings." Subhuti, you should not think so. Why? Because there are really no living beings whom the Tathagata can liberate. If there were, the Tathagata would hold (the concept of) an ego, a personality, a being and a life. Subhuti, (when) the Tathagata speaks of an ego, there is in reality no ego, although common men think so. Subhuti, the Tathagata says common men are not, but are (expediently) called, common men.

'Subhuti, what do you think? Can the Tathagata be recognised by His thirty-two physical characteristics?'

Subhuti replied: 'Yes, yes, He can.'

The Buddha said: 'Subhuti, if the Tathagata can be recognised by His thirty-two physical characteristics, a world ruler (cakravarti) would be the Tathagata.'

Subhuti said to the Buddha: 'World Honoured One, as I understand your teaching, the Tathagata cannot be recognised by His thirty-two physical characteristics.

Thereupon, the World Honoured One recited the following gatha:

'He who sees me by outward appearance

(And) seeks me in sound,

Treads the heterodox path

(And) cannot perceive the Tathagata.

'Subhuti, if you have ( in your mind) this thought: "The Tathagata does not rely on His possession of characteristics to obtain supreme Enlightenment," Subhuti, banish that thought. Subhuti, if you think it while developing the Perfect Enlightenment Mind, you will advocate the annihilation of all Dharmas. Do not have such a thought. Why? Because one who develops the Supreme Enlightenment Mind, does not advocate the annihilation (of things). 'Subhuti, if (on the one hand) a Bodhisattva gave in his practice of dana, all the seven treasures in quantities sufficient to fill worlds as many as sand-grains in the Ganges, and (on the other hand) another man comprehended that all dharmas were egoless and thereby achieved perfection of patience (ksanti), the latter's merit would surpass that of the former. Why? Because, Subhuti, all Bodhisattvas do not receive reward for their merits.'

Subhuti asked the Buddha: 'World Honoured One, why do Bodhisattvas not receive reward for their merits?'

'Subhuti, Bodhisattvas should have no longing and no attachment when they practise meritorious virtues; therefore, they do not receive a reward. 'Subhuti, if someone says the Tathagata comes or goes, sits or lies, he does not understand what I mean. Why? Because the Tathagata has neither whence (to come) nor whither (to go); therefore, He is called the Tathagata.

'Subhuti. what do you think? If a virtuous man or woman reduced to dust all the worlds in the Universe, would those particles of dust many?'

Subhuti replied: 'Many, World Honoured One. Why? Because if they really existed, the Buddha would not say they were particles of dust. And why? Because when the Buddha speaks of particles of dust, they are not, but are (expediently) called, particles of dust. World Honoured One, when the Tathagata speaks of worlds, they are not, but are (expediently) called, worlds. Why? Because if they really exist, they are just agglomerations. The Tathagata speaks of agglomerations which are not, but are (expediently) called, agglomerations.'

'Subhuti, that which is called an agglomeration cannot be spoken of, but the vulgar man has longing for and attachment to this thing. 'Subhuti, what do you think? If someone says: "The Buddha speaks of the view of an ego, a personality, a being and a life", Subhuti, does that person understand what I mean?"

'No, World Honoured one, that person does not understand. Why? Because (when) the Tathagata speaks of the view of an ego, a Personality, a being and a life, it is not really, (but) is (expediently) called the view of an ego, a personality a being and a life.' 'Subhuti, he who develops the Supreme Enlightenment Mind, should thus know, see, believe and comprehend (all things); he should not set up the perception of things (dharma-laksana) in his mind. Subhuti, the so-called form of things (dharma-laksana), the Tathagata says is not, but is, (expediently) called the form of things. 'Subhuti, if on the one hand, someone gave away in alms (dana) the seven treasures inquantities sufficient to fill all the worlds in uncount-able aeons, and if on the other hand, a virtuous man or woman developed the Bodhi-mind, and received, held (in mind), read and recited even a four-line stanza of this sutra and expounded it to others, the latter's merit would surpass that of the former. In what manner should it be taught to others? By teaching it without attachment to form with the immutability of the absolute.

Why is it? Because: -

All phenomena are like a dream, an illusion, a bubble and a shadow,

Like dew and lightning.

Thus should you contemplate them'.

When the Buddha had finished expounding this sutra, the elder Subhuti, together with bhiksus, bhiksunis, upasakas, upasikas, and all the worlds of devas, men and asuras who had listened to His teaching, were filled with joy and believed received and observed it.