New Page 2

此网页使用了框架，但您的浏览器不支持框架。


New Page 4

佛说十善业道经

唐于阗三藏实叉难陀奉制译

  如是我闻：一时，佛在娑竭罗龙宫，与八千大比丘众、三万二千菩萨摩诃萨俱。

  尔时，世尊告龙王言：“一切众生心想异故，造业亦异，由是故有诸趣轮转。

  龙王！汝见此会及大海中，形色种类各别不耶﹖如是一切，靡不由心造善不善身业、语业、意业所致。而心无色，不可见取，但是虚妄诸法集起，毕竟无主、无我我所。虽各随业，所现不同，而实于中无有作者。故一切法皆不思议，自性如幻。智者知已，应修善业，以是所生蕴、处、界等，皆悉端正，见者无厌。

  龙王！汝观佛身，从百千亿福德所生，诸相庄严，光明显曜，蔽诸大众。设无量亿自在梵王，悉不复现；其有瞻仰如来身者，莫不目眩！汝又观此诸大菩萨，妙色严净，一切皆由修集善业福德而生。又诸天、龙八部众等大威势者，亦因善业福德所生。今大海中所有众生，形色粗鄙，或大或小，皆由自心种种想念，作身、语、意诸不善业，是故随业各自受报。汝今当（常）应如是修学，亦令众生了达因果，修习善业。汝当于此正见不动，勿复堕在断、常见中！于诸福田，欢喜、敬养，是故汝等亦得人天尊敬、供养。

  龙王！当知菩萨有一法，能断一切诸恶道苦。何等为一﹖谓于昼夜，常念、思惟、观察善法，令诸善法念念增长，不容亳分不善间杂。是即能令诸恶永断，善法圆满，常得亲近诸佛菩萨及余圣众。言善法者：谓人天身、声闻菩提、独觉菩提、无上菩提，皆依此法以为根本而得成就，故名善法。此法即是十善业道。

  何等为十﹖谓能永离杀生、偷盗、邪行、妄语、两舌、恶口、绮语、贪欲、瞋恚、邪见。

  龙王！若离杀生，即得成就十离恼法。何等为十﹖

    一、于诸众生普施无畏；二、常于众生起大慈心；三、永断一切瞋恚习气；四、身常无病；五、寿命长远；六、恒为非人之所守护；七、常无恶梦，寝觉快乐；八、灭除怨结，众怨自解；九、无恶道布；十、命终生天；是为十。若能回向阿耨多罗三藐三菩提者，后成佛时，得佛随心自在寿命。

  复次，龙王！若离偷盗，即得十种可保信法。何等为十﹖

    一、（者？、）资财盈积，王、贼、水、火，及非爱子，不能散灭；二、多人爱念；三、人不欺负；四、十方赞美；五、不忧损害；
六、善名流布；七、处众无畏；八、财、命、色、力安乐，辩才具足无缺；九、常怀施意；
十、命终生天；是为十。若能回向阿耨多罗三藐三菩提者，后成佛时，得证清净大菩提智。

  复次，龙王！若离邪行，即得四种智所赞法。何等为四﹖

    一、诸根调顺；二、永离諠掉；三、世所称叹；四、妻莫能侵；是为四。若能回向阿耨多罗三藐三菩提者，后成佛时，得佛丈夫隐密藏相。

   复次，龙王！若离妄语，即得八种天所赞法。何等为八﹖

    一、口常清净、优钵华香；二、为诸世间之所信伏；三、发言成证，人天敬爱；四、常以爱语安慰众生；五、得胜意乐，三业清净；六、言无误失，心常欢喜；七、发言尊重，人天奉行；
八、智慧殊胜，无能制伏；是为八。若能回向阿耨多罗三藐三菩提者，后成佛时，即得如来真实语。

  复次，龙王！若离两舌，即得五种不可坏法。何等为五﹖

    一、得不坏身，无能害故；二、得不坏眷属，无能破故；三、得不坏信，顺本业故；四、得不坏法行，所修坚固故；五、得不坏善知识，不诳惑故；是为五。若能回向阿耨多罗三藐三菩提者，后成佛时，得正眷属，诸魔外道不能沮坏。

  复次，龙王！若离恶口，即得成就八种净业。何等为八﹖

    一、言不乖度；二、言皆利益；三、言必契理；四、言词美妙；五、言可承领；六、言则信用；七、言无可讥；八、言尽爱乐；是为八。若能回向阿耨多罗三藐三菩提者，后成佛时，具足如来梵音声相。

   复次，龙王！若离绮语，即得成就三种决定。何等为三﹖

    一、定为智人所爱；二、定能以智，如实答问；三、定于人天，威德最胜，无有虚妄；是为三。若能回向阿耨多罗三藐三菩提者，后成佛时，即得如来诸所授记，皆不唐捐。

  复次，龙王！若离贪欲，即得成就五种自在。何等为五﹖

    一、三业自在，诸根具足故；二、财物自在，一切怨贼不能夺故；三、福德自在，随心所欲，物皆备故；四、王位自在，珍奇妙物皆奉献故；五、所获之物，过本所求百倍殊胜，由于昔时不悭嫉故；是为五。若能回向阿耨多罗三藐三菩提者，后成佛时，三界特尊，皆共敬养。

  复次，龙王！若离瞋恚，即得八种喜悦心法。何等为八﹖

    一、无损恼心；二、无瞋恚心；三、无诤讼心；四、柔和质直心；五、得圣者慈心；六、常作利益安众生心；七、身相端严，众共尊敬；
八、以和忍故，速生梵世；是为八。若能回向阿耨多罗三藐三菩提者，后成佛时，得无碍心，观者无厌。

   复次，龙王！若离邪见，即得成就十功德法。何等为十﹖

    一、得真善意乐、真善等侣；二、深信因果，宁殒身命，终不作恶；三、唯（惟）归依佛，非余天等；四、直心正见，永离一切吉凶疑网；五、常生人天，不更恶道；六、无量福慧，转转增胜；七、永离邪道，行于圣道；八、不起身见，舍诸恶业；九、住无碍见；十、不堕诸难；是为十。若能回向阿耨多罗三藐三菩提者，后成佛时，速证一切佛法，成就自在神通。

   尔时，世尊复告龙王：“言若有菩萨依此善业，于修道时，
能离杀害而行施故，常富财宝，无能侵夺；长寿无夭，不为一切怨贼损害。
离不与取而行施故，常富财宝，无能侵夺；最胜无比，悉能备集诸佛法藏。
离非梵行而行施故，常富财宝，无能侵夺；其家直（贞）顺；母及妻子，无有能以欲心视者。
离虚诳语而行施故，常富财宝，无能侵夺；离众毁谤，摄持正法；如其誓愿，所作必果。
离离间语而行施故，常富财宝，无能侵夺；眷属和睦，同一志乐，恒无乖诤。
离粗恶语而行施故，常富财宝，无能侵夺；一切众会，欢喜归依；言皆信受，无违拒者。
离无义语而行施故，常富财宝，无能侵夺；言不虚设，人皆敬受；能善方便，断诸疑惑。
离贪求心而行施故，常富财宝，无能侵夺；一切所有，悉以慧（惠）舍；信解坚固，具大威力。
离忿怒心而行施故，常富财宝，无能侵夺；速自成就无碍心智；诸根严好，见皆敬爱。
离邪倒心而行施故，常富财宝，无能侵夺；恒生正见敬信之家；见佛、闻法、供养众僧；
常不忘失大菩提心。是为大士修菩萨道时，行十善业，以施庄严，所获大利如是。

   龙王！举要言之：行十善道，以戒庄严故，能生一切佛法义利，满足大愿；忍辱庄严故，得佛圆音，具众相好；精进庄严故，能破魔怨，入佛法藏；定庄严故，能生念、慧、惭、愧、轻安；慧庄严故，能断一切分别妄见；慈庄严故，于诸众生不起恼害；悲庄严故，愍诸众生，常不厌舍；喜庄严故，见修善者，心无嫌嫉；舍庄严故，于顺违境，无爱恚心；四摄庄严故，常劝摄化一切众生；念处庄严故，善能修习四念处观；正劝庄严故，悉能断除一切不善法，成一切善法；神足庄严故，恒令身心轻安、快乐；五根庄严故，深信坚固，精劝匪懈，常无迷妄，寂然调顺，断诸烦恼；力庄严故，众怨尽灭，无能坏者；觉支庄严故，常善觉悟一切诸法；正道庄严故，得正智慧常现在前，止庄严故，悉能涤除一切结使；观庄严故，能如实知诸法自性；方便庄严故，速得成满为、无为乐。

龙王！当知此十善业，乃至能令十力、无畏、十八不共、一切佛法、皆得圆满。是故汝等应勤修学！

  龙王！譬如一切城邑、聚落，皆依大地而得安住；一切药草、卉木、丛林，亦皆依地而得生长。此十善道亦复如是：一切人、天依之而立，一切声闻、独觉菩提，诸菩萨行，一切佛法，咸共依此十善大地而得成就。若离十善业，欲修行证果，譬如空中建楼阁，或种稻子，欲成就生长，无有是处。(注：此段经句，为莆田广化寺发行的经书中有录。)

  佛说此经已，娑竭龙王及诸大众：一切世间天、人、阿修罗等，皆大欢喜，信受奉行。

佛说十善业道经

注？：宋译本此文之后，复有一段经文如是：

“龙王！复次，观于十不善法微细之行，多堕地狱、饿鬼、畜生之趣。龙王！观彼众生，
若复杀生，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、短命；二者、苦恼。
若复偷盗，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、自居贫贱；二者、不得他人财宝。
若复邪染，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、愚痴；二者、妻不贞正。
若复妄语，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、言不诚实；二者、人不信奉。
若复绮语，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、言不真正；二者、所言无定。
若复恶口，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、言多斗诤；二者、人闻不重。
若复二舌，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、得下劣眷属；二者、感亲属分离。
若复多贪，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、不能利益他人；二者、常被他人侵害。
若复多瞋，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、心常不喜；二者、多不称意。
若复邪见，当堕地狱、畜生、焰魔界。后生人间，以余业故，得二种报：一者、邪见；二者、懈怠。

龙王！若有行于如是十不善法，决定获得如是果报！复更别得无边诸大苦蕴。”

（全一卷﹒唐代实叉难陀译）
*全一卷﹒唐代实叉难陀译﹒收于大正藏第十五册﹒本经为“海龙王经”中十德六度品之抄译﹐
北宋施护所译之“佛为娑伽罗龙王所说大乘经”为其同本异译﹒
注？：宋、元、明三本及宫本，“直”字俱作“贞”字。
注？：宋、元、明三本及宫本，“慧”字俱作“惠”字。
注？：本经以《大正藏》为底本，兼参考《佛教大藏经》其异译本为：“佛为娑伽罗龙王所说大乘法经”　宋　施护译。
（《大正藏》第15册一五九页、《佛教大藏经》第29册一五五页）
注？：宋、元、明三本及宫本，作“常”字。
注？：宋、元、明三本及宫本，俱无“者”字。
注？：宫本“唯”字作“惟”字。


The Ten Wholesome Ways Of Actions Sutra

THE DISCOURSE ON THE TEN WHOLESOME WAYS OF ACTION

Translated to Chinese by the Tripitakacarya Sikshananda from Khotan
during the Tang Dynasty
Translated to English by Saddhaloka Bhikkhu
Key'ed in from hardcopy by TY with permission from publisher
(Yan Boon Remembrance Commitee in Hong Kong)

Thus have I heard. At one time, the Buddha stayed in
the palace of the Dragon King of the Ocean together with
an assembly of eight thousand great Bhikshus and thirty-
two thousand Bodhisattvas and Mahasattvas altogether. At
that time the World Honored One told the Dragon King
saying:

Because all beings have different consciousness and
thoughts, they perform too different actions and as a
consequence there is the turning around in all the different
courses of existence. Oh Dragon King, do you see the
variety of shapes and appearances in this meeting and in
the great ocean, are they not different from one another.

Thus among all of them there is none which is not
made by the mind, whether it is brought about by whole-
some or unwholesome bodily, verbal, and mental actions,
and yet the mind is formless it cannot be grasped or
perceived, but it is the unreal accumulation and arising of
all dharmas which are ultimately without owner, without
I and mine. Although that which is manifested by each
(being) according to its actions is not the same, there is
nevertheless really no creator in these (actions). Therefore
all dharmas are inconceivable and inexpressible, their own
nature is phantom like. The wise ones knowing this ought
to cultivate wholesome actions. Through this the aggregates
sense-bases and elements that will be given rise
to, will all be upright and those who will see them will not
grow tired of them.

Oh Dragon King, when you behold the body of the
Buddha born from a hundred thousand of Kotis of
merit, with all the marks adorned, the splendor of its
radiance covering the whole of the great assembly, even if
there were immeasurable Kotis of Ishvara and Brahma
devas they all would not come again into appearance.
Those who look with reverence at the Tathagata's body how
can they but not be dazzled. You again behold all these
great Bodhisattvas of marvelous appearance, dignified and
pure. All this comes into being entirely through the merit
of cultivating wholesome actions. Again all the powerful
ones like the eight classes of devas and dragons, and
suchlike they also come into being because of the
merits of wholesome actions.

Now all beings in the great ocean are of course and
mean shapes and appearances, they all whether small or
large performed unwholesome bodily, verbal, and mental
actions out of all kinds of thoughts from their own minds.
Thus is that each being receives its own result according
to its action.

You ought to practice and to study constantly in this
way, and also to bring beings to a thorough understanding
of cause and effect and to the practice of wholesome actions.
In this you must have unshakable right view and you must
not fall again into the views of annihilation and eternity.
As to the fields of merit you rejoice in them,
respect them and support them because of this you will
also be respected and supported by men and devas.

Oh Dragon King you must know that Bodhisattva has
one method which enables him to cut off all sufferings
of evil destinies. What kind of methods is this? It
is constantly, day and night, to recollect, to reflect
on and to contemplate on the wholesome dharmas so as to
cause the wholesome dharmas to increase from thought-
moment to thought-moment, without allowing the least
unwholesome thought to mingle in. This will then enable
you to cut off all evil forever, to bring the wholesome
dharmas to completion and to be constantly near all the
Buddhas, Bodhisattvas, and other holy communities. Speaking
about wholesome dharmas, the bodies of men and
devas, the Illumination of the Shravakas, the Illumination
of the Pratyekas, and the Highest Illumination,
they are all accomplished depending on these dharmas
which are to be considered as fundamental. Therefore they
are called wholesome dharmas. These dharmas are the ten
wholesome ways of actions. What are these ten? They are
the ability to give up forever killing, stealing, wrong
conduct, lying, slandering, harsh language, frivolous
speech, lust, hate, and wrong views.

Oh Dragon King, if one gives up taking life hen one
will accomplish ten ways of being free from vexations.
What are the ten?
i. One give universally to all beings without fear
ii. One always has a heart of great compassion towards all beings
iii. All habitual tendencies of hate in oneself will be cut off
forever
iv. One's body is always free from illness
v. One's life is long
vi. One is constantly protected by non-human beings
vii. One is always without bad dreams, one sleeps and wakes happily
viii. The entanglement of enmity is eradicated and one is free from
all hatred
ix. One is free from the dread of evil destinies
x. When one's life comes to an end one will be born as a deva
These are the ten. If one is one who is able to
turn-towards the Highest Perfect Illumination, one will later
at the time one becomes Buddha attain to the ability
peculiar to the Buddha, to live as long as one wishes.

Again, oh Dragon King, if one gives up stealing then
one will attain to ten kinds of dharmas which can protect
one's confidence. what are the ten?
i. One's wealth will increase and accumulate and
cannot be scattered or destroyed by Kings,
robbers, floods, fires, and careless sons.
ii. One is thought of with fondness by many people.
iii. People do not take advantage of one.
iv. Everywhere one is praised
v. One is above the worry, that one oneself could be injured.
vi. One's good name spreads
vii. One is without fear in public.
viii. One is endowed with wealth, long life,
strength, peace, happiness, and skill in speech,
without deficiencies
ix. One always thinks of giving
x. At the end of one's life, one will be born as a deva
These are the ten. If one is one who is able to turn towards
the Highest Perfect Illumination, one will later at
the time one becomes Buddha, attain to the realization of
the purified great illumination wisdom.

Again the Dragon King, if one gives up wrong conduct
one will attain to four kinds of dharmas which are praised
by the wise. What are the four?
i. All one's faculties are tuned and adjusted.
ii. One is free from turmoil and excitement.
iii. One is praised and extolled by the world
iv. One's wife cannot be encroached upon by anybody
These are the four. If one is one who is able to turn
towards the Highest Perfect Illumination one will later at the
time one becomes Buddha, attain the mastersign of the
Buddha, of a concealed organ.

Again, oh Dragon King, if one gives up lying then one
will attain to the eight dharmas which are praised by the
devas. What are the eight?
i. One's mouth is always pure and has the
fragrance of a blue lotus flower.
ii. One is trusted and obeyed by all the world.
iii. What one says is true and one is loved by men and devas.
iv. One always comforts beings with loving words.
v. One attains to excellent bliss of mind and one's
actions, speech, and thoughts are pure.
vi. One's speech is faultless and one's mind is always joyful.
vii. One's words are respected and are followed by men and
devas.
viii. One's wisdom is extraordinary and cannot be subdued
These are the eight. If one is one who is able to turn
towards the Highest Perfect Illumination, one will later at the
time one becomes Buddha, attain to the true speech of the
Tathagata.

Again, oh Dragon King, if one gives up slandering one
will then attain to five kinds of incorruptible dharmas.
What are the five?
i. One attains to an incorruptible body because no
harm can be done to one.
ii. One gets an incorruptible family because no
one can destroy it.
iii. One attains to incorruptible confidence because
this is in line with one's own actions.
iv. One attains to an incorruptible spiritual life
because what one cultivates is firmly grounded.
vi. One gets incorruptible spiritual friends because
one does not mislead or delude anybody.
These are the five. If one is one who is able to
turn-towards the Highest Perfect Illumination, one will later
at the time one becomes Buddha, gets a holy retinue which
cannot be corrupted by any Mara or heretic.

Again, oh Dragon King, if one gives up harsh language
then one will attain to the accomplishment of eight kinds
of pure actions. What are the eight?
i. One's speech is meaningful and reasonable
ii. All that one says is profitable.
iii. One's words are bound to be truthful.
iv. One's language is beautiful and marvelous.
v. One's words are accepts (by others).
vi. One's words are trusted.
vii. One's words cannot be ridiculed.
viii. All one's words are being loved and enjoyed (by others)
These are the eight. If one is one who is able to turn towards
the Highest Perfect Illumination, be endowed with the
perfect characteristic of the Brahma voice of the Tathagata.

Again, oh Dragon King, if one gives up frivolous
speech then one will attain to the accomplishment of the
three certainties. What are the three?
i. One is certain to be loved by the wise
ii. One is certain to be able to answer questions
with wisdom and according to reality
iii. One is certain to have the most excellent dignity
and virtue among men and devas and one is without falsehood.
These are the three. If one is one who is able to turn
towards the Highest Perfect Illumination, one will later at
the time one becomes Buddha, attain to the Tathagata's
(ability) to predict everything, none (of the predictions) are
ever in vain.

Again, oh Dragon King, if one gives up lust, then one
will attain to the accomplishment of the five kinds of
freedom. What are the five?
i. Freedom of bodily, verbal, and mental actions
because one's six faculties are perfect
ii. Freedom as regards property because all
enemies and robbers cannot rob one.
iii. Freedom with regard to merit because whatever
one wishes one will be provided with.
iv. Freedom of being in the position of a King,
because precious, rare and marvelous things
will be reverently offered to one.
v. The things one will get will surpass in excellency
by a hundred times that what one is
looking for, because in times by-gone one was
neither stingy nor envious
These are the five. If one is one who is able to turn
towards the Highest Perfect Illumination, one will later at
the time becomes Buddha, be especially revered in all
three realms all (the beings of the three realms) will
all respectfully make offering to one.

Again, oh Dragon King, if one gives up hatred then
one will attain to eight kinds of dharmas of joy of mind.
What the eight?
i. One's mind is free from (the want) to injure and to
annoy (others)
ii. One's mind is free from hatred
iii. One's mind is free from (the desire) to dispute and to argue
iv. One's mind is gentle and upright
v. One has attained to the mind of loving kindness of a saint
vi. One is of a mind that always acts beneficially giving peace
to beings
vii. One's bodily appearance is dignified and one is respectfully
by all
viii. Because one is kind and forbearing, one will be born soon
in the Brahma World.
These are the eight. If one is one who is able to turn
towards to the Highest Perfect Illumination, one will later at
the times one becomes Buddha, attain to the mind of the
Buddha that is free from obstacles. People will not become
tired of looking at him.

Again, Oh Dragon King, if one gives up wrong views, one
will attain to the accomplishment of ten meritorious
dharmas. What are the ten?
i. One attains to genuinely good bliss of mind and
one gets genuinely good companions
ii. One has deep confidence in (the law of) cause and
effect and one would rather lose one's life than do evil.
iii. One takes refuge in the Buddha only and not in
devas or others.
iv. One is of a straight mind and right views, and
leaves behind the net of doubts about good and evil
fortune.
v. One will not be born again in an evil course of
existence but will always be born as a man or deva
vi. Immeasurable blessings and wisdom will increase
sublimely from turn to turn
vii. One will forever leave the wrong path and tread
the holy path.
viii. The view of a personality will not arise (in
one) and one gives up all evil actions.
ix. One will abide in unobstructed understanding.
x. One will not fall into any difficult conditions.
These are the ten. If one is one who is able to turn
towards the Highest Perfect Illumination, one will later at
the time one becomes Buddha, realize quickly all Buddha-
dharmas and accomplish the mastery of the higher
spiritual powers."

At that time the World Honored One further told the
Dragon King saying:
"If there is a Bodhisattva who is able to give up killing
and harming, and practice giving, follow these wholesome
actions at the time he treads the path, he will therefore
always be rich in wealth, without anybody being able
to rob him. he will have a long life and not die
untimely, and he will not be injured by any robbers or
enemies.

Because he gives up taking what is not given and practice
giving, he will always be rich in wealth without there
being anybody who can rob him. He will be most excelling
beyond comparison (in this respect), and will be able
to collect completely all the store of Buddha-dharmas.

Because he gives up the impure way of living and
practices giving, he will always be rich in wealth without
anybody being able to rob him. His family will be virtuous
and obedient. There will be nobody who can look at his
mother, wife, and daughter with a lustful mind.

Because he gives up false speech and practices giving,
he will always be rich in wealth without anybody being
able to rob him. Giving up all slandering he takes up the
true Dharma. That which he does according to his vows
will certainly bear fruit.

Because he gives up speech hat causes dissension and
practices giving, he will always be rich in wealth without
anybody being able to rob him. His family will be
harmonious and they (all the members of the family) have the
same aspirations and joys in common and will never
unreasonably dispute (with one another).

Because he gives up coarse evil speech and practices
giving, he will always be rich in wealth without anybody
being able to rob him. At all gatherings people joyfully
accept him as their teacher. His words will be received with
trust without opposition.

Because he gives up meaningless speech and practices
giving, he will always be rich in wealth without anybody
being able to rob him. His words are not spoken in vain,
but are received with respect by all people. He is able and
skilled in solving doubts and uncertainties.

Because he gives up the greedy mind and practices
giving, he is always rich in wealth without anybody being
able to rob him. All he has he gives (to others) with
kindness. His confidence is firm and his understanding well
grounded. He is endowed with great authority and strength.

Because he gives up the angry mind and practices
giving he is always rich in wealth without anybody being
able to rob him. He quickly accomplishes by himself the
wisdom of the mind that is free from obstruction. All his
faculties are well dignified and all those who see him
respect and love him.

Because he gives up the perverted mind and practices
giving, he is always rich in wealth without anybody being
able to rob him. He is always born in family which is
possessed of right views, reverence and confidence. He sees
the Buddha, hears the dharma and supports the Community
of Monks. He never forgets or loses the great Illumination
Mind.

These are the great benefits obtained by a Great Being
(Mahasattva), who at the time he cultivates the
Bodhisattva path, practices the ten wholesome actions and
adorns them without giving.

Thus, oh Dragon King, I am summarising. Because one
adorns the practice of the ten wholesome ways of action
with morality, the meaning and benefit of all the
Buddha-dharma can arise and the great vows are brought
to completion.

Because one adorns (the practice of the ten wholesome
ways of actions) which patience, one attains to the
perfect voice of the Buddha and all the marks will be
lovely.

Because one adorns (this practice) with effort, one is
able to destroy the Mara enemy and enter into the store
of Buddha-dharmas.

Because one adorns (this practice) with meditation,
therefore mindfulness, wisdom, shame, conscientiousness
and calm will arise.

Because one adorns (this practice) with wisdom one is
able to cut off wrong views arising from discrimination.

Because one adorns (this practice) with loving kindness
no (thought of) anger or harming will arise in oneself
towards any being.

Because one adorns (this practice) with compassion,
one will have sympathy towards all beings and will never
get weary of and indifferent to them.

Because one adorns (this practice) with sympathetic joy,
one's mind when seeing somebody cultivating the good
will be free from envy and jealousy.

Because one adorns (this practice) with serenity, one will
not have a mind that is neither attached to favorable
circumstances or that resents adverse circumstances.

Because one adorns (this practice) with the four ways of
helping (others), one will always be diligent in helping
and teaching all beings.

Because one adorns (this practice) with the foundations of
mindfulness, one will be able to be skillful in the
practice of the contemplation of the four foundations of
mindfulness.

Because one adorns (this practice) with the (four) right
efforts, one will be able to cut off and remove entirely
all unwholesome dharmas.

Because one adorns (this practice) with the (four) roads
to power, one's body and mind will always be calm and at
ease.

Because one adorns (this practice) with the five faculties,
deep confidence will be firmly established, there will be
unremitting effort, one is always free from confusion and
from delusion, one is at peace and well balanced, and all
the defilement will be cut off.

Because one adorns (this practice) with the (five)
powers, all enmity will be entirely destroyed and one
cannot be harmed.

Because one adorns (this practice) with the (seven)
factors of illumination, one will always well awake to all
dharmas.

Because one adorns (this practice) with the Noble
(eightfold) Path, one will attain to perfect
wisdom which will always be present before oneself.

Because one adorns (this practice) with calm meditation,
one is able to wash away all the bonds and (latent)
tendencies.

Because one adorns (this practice) with insight meditation,
one is able to know the self nature of all dharmas
according to reality.

Because one adorns (this practice) with the means, one
will quickly attain to the fulfillment of the conditioned and
unconditioned happiness.

Oh Dragon King, you should know that these ten wholesome
actions can lead up to the completion of the Ten Powers
(of the Tathagata), of the (Four Kinds of) Fearlessness,
of the Eighteen Dharmas that distinguish (the Buddha) and
of all Buddha-dharmas. You should therefore practice and
and train with diligence.

Oh Dragon King, it is like the towns and villages, they
all depend on the great ground where they stand. All the
herbs, grasses, flowers, trees, and woods also depend on
the ground for their growth. With these ten wholesome
ways of actions it is the same. All men and devas are
established (in their human and deva nature) depending on
them. The illumination of all the Shravakas, of all the
Pratyekas, the way of the Bodhisattva, all Buddha-dharmas
they all are attained and come to fruition due to these
ten wholesome great grounds. After the Buddha had spoken
this discourse, the Dragon King of the Ocean, together
with the great assembly, all the devas, asuras, and so on,
all rejoiced greatly, received it with confidence
and put it reverently into practice.