New Page 1

此网页使用了框架，但您的浏览器不支持框架。


New Page 2

药师琉璃光如来本愿功德经
大唐三藏法师玄奘奉　诏译

如是我闻。
一时薄伽梵游化诸国至广严城住乐音树下。与大苾刍众八千人俱。菩萨摩诃萨三万六千。及国王大臣婆罗门居士。天龙药叉人非人等。无量大众恭敬围绕而为说法。

尔时曼殊室利法王子。承佛威神从座而起偏袒一肩右膝着地。向薄伽梵曲躬合掌白言。世尊。惟愿演说如是相类诸佛名号及本大愿殊胜功德。令诸闻者业障销除。为欲利乐像法转时诸有情故。

尔时世尊赞曼殊室利童子言。善哉善哉曼殊室利。汝以大悲劝请我说诸佛名号本愿功德。为拔业障所缠有情。利益安乐像法转时诸有情故。汝今谛听极善思惟。当为汝说。曼殊室利言。唯然愿说。我等乐闻佛告曼殊室利。东方去此过十殑伽沙等佛土。有世界名净琉璃。佛号药师琉璃光如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。曼殊室利。彼佛世尊药师琉璃光如来。本行菩萨道时发十二大愿。令诸有情所求皆得。

第一大愿。愿我来世得阿耨多罗三藐三菩提时。自身光明炽然。照曜无量无数无边世界。以三十二大丈夫相八十随好庄严其身。令一切有情如我无异。

第二大愿。愿我来世得菩提时。身如琉璃内外明彻净无瑕秽。光明广大功德巍巍。身善安住焰网庄严过于日月。幽冥众生悉蒙开晓。随意所趣作诸事业。

第三大愿。愿我来世得菩提时。以无量无边智慧方便。令诸有情皆得无尽。所受用物。莫令众生有所乏少。

第四大愿。愿我来世得菩提时。若诸有情行邪道者。悉令安住菩提道中。若行声闻独觉乘者。皆以大乘而安立之。

第五大愿。愿我来世得菩提时。若有无量无边有情。于我法中修行梵行。一切皆令得不缺戒具三聚戒。设有毁犯闻我名已。还得清净不堕恶趣。

第六大愿。愿我来世得菩提时。若诸有情。其身下劣诸根不具。丑陋顽愚盲聋喑哑挛躄背偻白癞癫狂种种病苦。闻我名已一切皆得端正黠慧。诸根完具无诸疾苦。

第七大愿。愿我来世得菩提时。若诸有情。众病逼切无救无归无医无药无亲无家贫穷多苦。我之名号一经其耳。众病悉得除身心安乐。家属资具悉皆丰足。乃至证得无上菩提。

第八大愿。愿我来世得菩提时。若有女人。为女百恶之所逼恼。极生厌离愿舍女身。闻我名已一切皆得转女成男具丈夫相。乃至证得无上菩提。

第九大愿。愿我来世得菩提时。令诸有情。出魔罥网。解脱一切外道缠缚。若堕种种恶见稠林。皆当引摄置于正见。渐令修习诸菩萨行速证无上正等菩提。

第十大愿。愿我来世得菩提时。若诸有情。王法所录。缧缚鞭挞系闭牢狱或当刑戮。及余无量灾难凌辱悲愁煎迫。身心受苦。若闻我名。以我福德威神力故。皆得解脱一切忧苦。

第十一大愿。愿我来世得菩提时。若诸有情。饥渴所恼。为求食故造诸恶业。得闻我名专念受持。我当先以上妙饮食饱足其身。后以法味。毕竟安乐而建立之。

第十二大愿。愿我来世得菩提时。若诸有情。贫无衣服。蚊虻寒热昼夜逼恼。若闻我名专念受持。如其所好即得种种上妙衣服。亦得一切宝庄严具华鬘涂香鼓乐众伎。随心所玩皆令满足。

曼殊室利。是为彼世尊药师琉璃光如来应正等觉行菩萨道时所发十二微妙上愿复次曼殊室利。彼世尊药师琉璃光如来行菩萨道时。所发大愿及彼佛土功德庄严。我若一劫若一劫余说不能尽。然彼佛土一向清净无有女人。亦无恶趣及苦音声。琉璃为地。金绳界道。城阙宫阁轩窗罗网皆七宝成。亦如西方极乐世界。功德庄严等无差别。于其国中有二菩萨摩诃萨。一名日光遍照。二名月光遍照。是彼无量无数菩萨众之上首。悉能持彼世尊药师琉璃光如来正法宝藏。是故曼殊室利诸有信心善男子善女人等。应当愿生彼佛世界。

尔时世尊复告曼殊师利童子言。曼殊室利。有诸众生。不识善恶唯怀贪吝。不知布施及施果报。愚痴无智阙于信根。多聚财宝勤加守护。见乞者来其心不喜。设不获已而行施时。如割身肉深生痛惜。复有无量悭贪有情。积集资财。于其自身尚不受用。何况能与父母妻子奴婢作使及来乞者。彼诸有情从此命终。生饿鬼界或傍生趣。由昔人间曾得暂闻药师琉璃光如来名故。念在恶趣。暂得忆念彼如来名。即于念时从彼处没还生人中。得宿命念畏恶趣苦不乐欲乐。好行惠施赞叹施者。一切所有悉无贪惜。渐次尚能以头目手足血肉身分施来求者。况余财物。

复次曼殊室利。若诸有情。虽于如来受诸学处。而破尸罗。有虽不破尸罗而破轨则。有于尸罗轨则虽得不坏然毁正见。有虽不毁正见而弃多闻于佛所说契经深义不能解了。有虽多闻而增上慢。由增上慢覆蔽心故。自是非他嫌谤正法为魔伴党。如是愚人自行邪见。复令无量俱胝有情堕大险坑。此诸有情。应于地狱傍生鬼趣流转无穷。若得闻此药师琉璃光如来名号。便舍恶行修诸善法。不堕恶趣。设有不能舍诸恶行修行善法。堕恶趣者。以彼如来本愿威力。令其现前暂闻名号。从彼命终还生人趣。得正见精进善调意乐。便能舍家趣于非家如来法中。受持学处无有毁犯。正见多闻解甚深义。离增上慢不谤正法。不为魔伴。渐次修行诸菩萨行速得圆满。

复次曼殊室利。若诸有情悭贪嫉妒自赞毁他。当堕三恶趣中。无量千岁受诸剧苦。受剧苦已。从彼命终来生人间。作牛马驼驴。恒被鞭挞。饥渴逼恼。又常负重随路而行。或得为人生居下贱。作人奴婢受他驱役。恒不自在。若昔人中。曾闻世尊药师琉璃光如来名号。由此善因今复忆念至心归依以佛神力众苦解脱。诸根聪利智慧多闻。恒求胜法常遇善友。永断魔罥破无明谷禾卵。竭烦恼河解脱一切生老病死忧愁苦恼。

复次曼殊室利。若诸有情好喜乖离更相斗讼恼乱自他。以身语意造作增长种种恶业。展转常为不饶益事。互相谋害。告召山林树冢等神。杀诸众生取其血肉祭祀药叉罗刹娑等。书怨人名作其形像以恶咒术而咒咀之。厌媚蛊道咒起尸鬼。令断彼命及坏其身。是诸有情若得闻此药师琉璃光如来名号彼诸恶事悉不能害。一切展转皆起慈心。利益安乐无损恼意及嫌恨心。各各欢悦于自所受生于喜足。不相侵凌互为饶益。

复次曼殊室利。若有四众苾刍苾刍尼邬波索迦邬波斯迦。及余净信善男子善女人等。有能受持八分斋戒。或经一年或复三月受持学处。以此善根愿生西方极乐世界无量寿佛所。听闻正法而未定者。若闻世尊药师琉璃光如来名号。临命终时有八菩萨。乘神通来示其道路。即于彼界种种杂色众宝华中自然化生。或有因此生于天上。虽生天中而本善根亦未穷尽。不复更生诸余恶趣。天上寿尽还生人间。或为轮王统摄四洲。威德自在安立无量百千有情于十善道。或生刹帝利婆罗门居士大家。多饶财宝仓库盈溢。形相端严眷属具足。聪明智慧。勇健威猛如大力士。若是女人得闻世尊药师如来名号至心受持。于后不复更受女身。

尔时曼殊室利童子白佛言。世尊我当誓于像法转时。以种种方便。令诸净信善男子善女人等得闻世尊药师琉璃光如来名号。乃至睡中亦以佛名觉悟其耳。世尊若于此经受持读诵。或复为他演说开示。若自书若教人书。恭敬尊重以种种花香涂香末香烧香花鬘璎珞幡盖伎乐而为供养。以五色彩作囊盛之。扫洒净处敷设高座而用安处。尔时四大天王与其眷属及余无量百千天众。皆诣其所供养守护。世尊若此经宝流行之处。有能受持。以彼世尊药师琉璃光如来本愿功德及闻名号。当知是处无复横死。亦复不为诸恶鬼神夺其精气。设已夺者还得如故。身心安乐。

佛告曼殊室利。如是如是如汝所说。曼殊室利。若有净信善男子善女人等。欲供养彼世尊药师琉璃光如来者。应先造立彼佛形像敷清净座而安处之。散种种花烧种种香。以种种幢幡庄严其处。七日七夜受持八分斋戒。食清净食澡浴香洁着新净衣。应生无垢浊心无怒害心。于一切有情起利益安乐慈悲喜舍平等之心。鼓乐歌赞右绕佛像。复应念彼如来本愿功德读诵此经思惟其义演说开示。随所乐求一切皆遂。求长寿得长寿。求富饶得富饶。求官位得官位。求男女得男女。若复有人忽得恶梦。见诸恶相或怪鸟来集。或于住处百怪出现。此人若以众妙资具。恭敬供养彼世尊药师琉璃光如来者。恶梦恶相诸不吉祥皆悉隐没不能为患。或有水火刀毒悬崄恶象师子虎狼熊罴毒蛇恶蝎蜈蚣蚰蜓蚊虻等怖。若能至心忆念彼佛恭敬供养。一切怖畏皆得解脱。若他国侵扰盗贼反乱。忆念恭敬彼如来者亦皆解脱复次曼殊室利。若有净信善男子善女人等。乃至尽形不事余天。惟当一心归佛法僧受持禁戒。若五戒十戒菩萨四百戒苾刍二百五十戒苾刍尼五百戒。于所受中或有毁犯怖堕恶趣。若能专念彼佛名号恭敬供养者。必定不受三恶趣生。或有女人临当产时受于极苦。若能至心称名礼赞恭敬供养彼如来者。众苦皆除。所生之子身分具足。形色端正见者欢喜。利根聪明安隐少病无有非人夺其精气。

尔时世尊告阿难言。如我称扬彼佛世尊药师琉璃光如来所有功德。此是诸佛甚深行处难可解了。汝为信不。阿难白言。大德世尊。我于如来所说契经不生疑惑。所以者何。一切如来身语意业无不清净。世尊。此日月轮可令堕落妙高山王可使倾动。诸佛所言无有异也。世尊。有诸众生信根不具。闻说诸佛甚深行处。作是思惟。云何但念药师琉璃光如来一佛名号便获尔所功德胜利。由此不信反生诽谤。彼于长夜失大利乐堕诸恶趣流转无穷。佛告阿难。是诸有情。若闻世尊药师琉璃光如来名号。至心受持不生疑惑。堕恶趣者无有是处。阿难。此是诸佛甚深所行难可信解。汝今能受。当知皆是如来威力。阿难。一切声闻独觉及未登地诸菩萨等。皆悉不能如实信解。惟除一生所系菩萨。阿难。人身难得。于三宝中信敬尊重亦难可得。得闻世尊药师琉璃光如来名号复难于是。阿难。彼药师琉璃光如来无量菩萨行。无量善巧方便。无量广大愿。我若一劫若一劫余而广说者。劫可速尽。彼佛行愿善巧方便无有尽也尔时众中有一菩萨摩诃萨。名曰救脱。即从座起偏袒右肩。右膝着地曲躬合掌。而白佛言。大德世尊。像法转时。有诸众生。为种种患之所困厄。长病羸瘦不能饮食。喉唇干燥见诸方暗。死相现前。父母亲属朋友知识啼泣围绕。然彼自身卧在本处。见琰魔使引其神识至于琰魔法王之前。然诸有情有俱生神。随其所作若罪若福皆具书之。尽持授与琰魔法王。尔时彼王推问其人。算计所作随其罪福而处断之。时彼病人亲属知识。若能为彼归依世尊药师琉璃光如来。请诸众僧转读此经。然七层之灯悬五色续命神幡。或有是处彼识得还。如在梦中明了自见。或经七日或二十一日或三十五日或四十九日。彼识还时。如从梦觉皆自忆知善不善业所得果报。由自证见业果报故。乃至命难亦不造作诸恶之业。是故净信善男子善女人等。皆应受持药师琉璃光如来名号。随力所能恭敬供养。

尔时阿难问救脱菩萨曰。善男子。应云何恭敬供养彼世尊药师琉璃光如来。续命幡灯复云何造。救脱菩萨言。大德。若有病人欲脱病苦。当为其人。七日七夜受持八分斋戒。应以饮食及余资具。随力所办供养苾刍僧。昼夜六时礼拜供养彼世尊药师琉璃光如来。读诵此经四十九遍。然四十九灯。造彼如来形像七躯。一一像前各置七灯。一一灯量大如车轮。乃至四十九日光明不绝。造五色彩幡长四十九打丁桀手。应放杂类众生至四十九。可得过度危厄之难。不为诸横恶鬼所持。

复次阿难。若刹帝利灌顶王等。灾难起时。所谓人众疾疫难。他国侵逼难。自界叛逆难。星宿变怪难。日月薄蚀难。非时风雨难。过时不雨难。彼刹帝利灌顶王等。尔时应于一切有情起慈悲心赦诸系闭依前所说供养之法供养彼世尊药师琉璃光如来。由此善根及彼如来本愿力故。令其国界即得安隐。风雨顺时谷稼成熟。一切有情无病欢乐。于其国中。无有暴虐药叉等神恼有情者。一切恶相皆即隐没。而刹帝利灌顶王等。寿命色力无病自在皆得增益。阿难若帝后妃主储君王子大臣辅相中宫釆女百官黎庶。为病所苦及余厄难。亦应造立五色神旛然灯续明。放诸生命。散杂色华烧众名香。病得除愈众难解脱。

尔时阿难问救脱菩萨言。善男子。云何已尽之命而可增益。救脱菩萨言。大德。汝岂不闻如来说有九横死耶。是故劝造续命幡灯修诸福德。以修福故尽其寿命不经苦患。阿难问言。九横云何。救脱菩萨言。有诸有情。得病虽轻然无医药及看病者。设复遇医授以非药。实不应死而便横死。又信世间邪魔外道妖萨女之师。妄说祸福便生恐动。心不自正卜问觅祸。杀种种众生解奏神明呼诸魍魉请乞福佑欲冀延年。终不能得。愚痴迷惑信邪倒见。遂令横死入于地狱无有出期。是名初横。二者横被王法之所诛戮。三者畋猎嬉戏。耽淫嗜酒放逸无度。横为非人夺其精气。四者横为火焚。五者横为水溺。六者横为种种恶兽所啖。七者横堕山崖。八者横为毒药厌祷咒咀起尸鬼等之所中害。九者饥渴所困不得饮食而便横死。是为如来略说横死有此九种。其余复有无量诸横难可具说。

复次阿难。彼琰魔王主领世间名籍之记。若诸有情不孝五逆破辱三宝坏君臣法毁于信戒。琰魔法王随罪轻重考而罚之。是故我今劝诸有情然灯造幡放生修福。令度苦厄不遭众难。

尔时众中有十二药叉大将俱在会坐。所谓：宫毗罗大将、伐折罗大将、迷企罗大将、安底罗大将、頞仁二尔罗大将、珊底罗大将、因达罗大将、波夷罗大将、摩虎罗大将、真达罗大将、招杜罗大将、毗羯罗大将此十二药叉大将。一一各有七千药叉以为眷属。同时举声白佛言。世尊。我等今者蒙佛威力。得闻世尊药师琉璃光如来名号。不复更有恶趣之怖。我等相率皆同一心。乃至尽形归佛法僧。誓当荷负一切有情为作义利饶益安乐。随于何等村城国邑空闲林中。若有流布此经或复受持药师琉璃光如来名号恭敬供养者。我等眷属卫护是人。皆使解脱一切苦难。诸有愿求悉令满足。或有疾厄求度脱者。亦应读诵此经以五色缕结我名字得如愿已然后解结。

尔时世尊赞诸药叉大将言。善哉善哉大药叉将。汝等念报世尊药师琉璃光如来恩德者。常应如是利益安乐一切有情尔时阿难白佛言。世尊。当何名此法门我等云何奉持。佛告阿难。此法门名说药师琉璃光如来本愿功德。亦名说十二神将饶益有情结愿神咒。亦名拔除一切业障。应如是持。时薄伽梵说是语已。诸菩萨摩诃萨及大声闻。国王大臣婆罗门居士。天龙药叉揵达缚阿素洛揭路荼紧捺洛莫呼洛伽人非人等。一切大众闻佛所说。皆大欢喜信受奉行。

────全文结束────


Library

Sutra of the Merit and Virtue of

the Past Vows of Medicine Master Vaidurya Light Tathagata

Translation into Chinese by Tripitaka Master Hsuan Tsang (Text) Tripitaka Master Yi Jing (Mantra) of Tang Dynasty (ca. A.D. 700)

Translation into English by The Buddhist Text Translation Society, Dharma Realm Buddhist University, City Of Ten Thousand Buddhas (1997)

Thus I have heard. At one time the Bhagavan was travelling through various lands to teach living beings. He arrived at Vaishali ["City of Extensive Adornments"] and stayed beneath a tree from which music resounded. With him were eight thousand great Bhikshus and thirty-six thousand Bodhisattvas, Mahasattvas; also kings, ministers, Brahmans, lay disciples; gods, dragons, and the rest of the eightfold division; beings both human and non-human. The immeasurable great multitude respectfully surrounded him, and he spoke Dharma for them.

At that time, the Dharma Prince Manjushri, receiving the awesome inspiration of the Buddha, rose from his seat, bared one of his shoulders, knelt on his right knee, and, inclining his head and placing his palms together, said to the Bhagavan,

"World Honored One! We wish you would speak about such Dharmas as the Buddhas' names, the great vows they made in the past, and their supreme merit and virtue, so that those who hear them will be rid of their karmic hindrances. This request is also for the sake of bringing benefit and joy to sentient beings in the Dharma-Image Age."

The Buddha then praised the Pure Youth Manjushri:

"Good indeed! Good indeed, Manjushri. With great compassion you now request that I speak about the Buddhas' names and the merit and virtue of their past vows, for the sake of rescuing sentient beings who are bound up by karmic obstacles, and for the purpose of bringing benefit, peace, and joy to beings who live in the Dharma-Image Age. Listen attentively to my words and reflect on them extremely well, for I will now answer you."

Manjushri said, "Please do speak. We are glad to listen."

The Buddha told Manjushri, "Passing from here to the east, beyond Buddhalands numerous as the sand grains in ten Ganges rivers, is a world called 'Pure Vaidurya.' The Buddha there is named Medicine Master Vaidurya Light Tathagata, Of Proper and Equal Enlightenment, Perfect in Understanding and Practice, Well Gone One, One Who Understands the World, Supreme Lord, Regulating Hero, Teacher of Gods and Humans, Buddha, Bhagavan. Manjushri, when that World Honored One, Medicine Master Vaidurya Light Tathagata, was practicing the Bodhisattva path in the past, he made twelve great vows that enable all sentient beings to obtain what they seek.

The First Great Vow:

'I vow that in a future life, when I attain anuttarasamyaksambodhi, my body will shine with dazzling light that will illumine measureless, countless, boundless worlds. My body will be adorned with the thirty-two heroic features and the eighty subsidiary characteristics, and I will enable all beings to become as I am.'

The Second Great Vow:

'I vow that in a future life when I attain Bodhi, my body will be as bright and clear as vaidurya, flawlessly pure, vastly radiant, majestic with merit and virtue, abiding at ease, adorned with blazing nets brighter than the sun and the moon. Beings dwelling in darkness will be illuminated and will succeed in all their endeavors.'

The Third Great Vow:

'I vow that in a future life when I attain Bodhi, I will, by means of limitless, unbounded wisdom and skill-in-means, enable all sentient beings to obtain an inexhaustible supply of material necessities so they are without the slightest want.'

The Fourth Great Vow:

'I vow that in a future life when I attain Bodhi, I shall lead those sentient beings who practice deviant paths to reside in the Way of Bodhi, and those who travel on the vehicles of the Hearer or Pratyekabuddha to abide in the Great Vehicle.'

The Fifth Great Vow:

'I vow that in a future life when I attain Bodhi, I shall enable limitless and boundless numbers of sentient beings who cultivate Brahma conduct within my Dharma to perfectly uphold the three clusters of precepts without exception. Should there be any violation, upon hearing my name, they will regain their purity and not fall into the evil destinies.'

The Sixth Great Vow:

'I vow that in a future life when I attain Bodhi, if there are sentient beings whose bodies are inferior and whose faculties are imperfect, who are ugly, dull, blind, deaf, mute, deformed, paralyzed, hunch-backed, or afflicted with skin disease, insanity, or
various other sicknesses and sufferings, upon hearing my name they shall all become endowed with upright features, keen intelligence, and perfect faculties, and they shall be free of sickness and suffering.'

The Seventh Great Vow:

'I vow that in a future life when I attain Bodhi, I shall cause sentient beings who are oppressed by many illnesses and who are without aid, without a place to turn, without a doctor,without medicine, without relatives, and without a family, who are poverty-stricken and filled with suffering to be cured of their sicknesses upon having my name pass by their ear, so they are peaceful and happy in body and mind. They will have a family and relatives, and acquire an abundance of property and wealth, and even realize unsurpassed Bodhi.'

The Eighth Great Vow:

'I vow that in a future life when I attain Bodhi, if there are women who give rise to a deep loathing for their female body and wish to renounce it because they are oppressed and disturbed by the myriad sufferings of being female, upon hearing my name, they will be able to turn from women into men who are replete with male features and ultimately realize unsurpassed Bodhi.'

The Ninth Great Vow:

'I vow that in a future life when I attain Bodhi, I shall liberate sentient beings from the nets of demons and the bonds of external sects. If they have fallen into the dense forests of evil views, I shall lead them to have proper views and to gradually cultivate the practices of Bodhisattvas so they will quickly realize unsurpassed, proper and equal Bodhi.'

The Tenth Great Vow:

'I vow that in a future life when I attain Bodhi, I shall cause sentient beings who fall into the hands of the law and are bound, interrogated, whipped, fettered, imprisoned, sentenced to execution, or subjected to endless disasters, hardships, abuse, and humiliation so that they are torn by grief and distress and suffering in body and mind, to obtain, upon hearing my name, liberation from all worry and suffering by means of my blessings, virtue, and awesome spiritual power.'

The Eleventh Great Vow:

'I vow that in a future life when I attain Bodhi, I shall cause all sentient beings who are so plagued by hunger and thirst that they create all kinds of bad karma in their quest for food, upon hearing my name and single-mindedly accepting and maintaining it, to be filled with delicious food and drink and afterward, by means of the flavor of Dharma, to settle in ultimate peace and happiness.'

The Twelfth Great Vow:

'I vow that in a future life when I attain Bodhi, if there are sentient beings who are poor and without clothes so that day and night they are troubled by mosquitoes and flies, and by cold and heat, upon hearing my name and single-mindedly accepting and maintaining it, they shall obtain all kinds of fine and wonderful garments that accord with their tastes, as well as a variety of precious adornments, flower garlands, fragrant balms, and the enjoyments of music, and various kinds of talents, so that
all their hearts' delights will be fulfilled.'

"Manjushri, these are the twelve sublime and wonderful vows that the World Honored One, Medicine Master Vaidurya Light Tathagata, One of Proper and Equal Enlightenment, made while cultivating the
Bodhisattva Way."

"Moreover, Manjushri, if I were to speak for an eon or more about the great vows made by the World Honored One, Medicine Master Vaidurya Light Tathagata, when he practiced the Bodhisattva Way and about the merit, virtue, and adornments of his Buddhaland, I could not finish."

"That Buddhaland has always been completely pure; there are no women, no evil destinies, and no sounds of suffering. The ground is made of vaidurya, with golden cords lining the roads. The city walls , towers, palace pavilions, studios, windows, and latticework, are all made of the seven treasures.

The merit, virtue, and adornments of this land are identical to those of the Western Land of Ultimate Bliss."

"Residing in that land are two Bodhisattvas, Mahasattvas; the first is called Universally Radiant Sunlight, and the second, Universally Radiant Moonlight. They are the leaders among the immeasurable, uncountable hosts of Bodhisattvas in that land and will be the successors to that Buddha.

They are able to maintain the precious treasury of the Proper Dharma of the World Honored One, Medicine Master Vaidurya Light Tathagata.

Therefore, Manjushri, all good men and women who have faith should vow to be born in that Buddha's land."

At that time, the World Honored One again spoke to the Pure Youth Manjushri saying,

"Manjushri, there are living beings who don't distinguish good from evil, who indulge in greed and stinginess, and who know nothing of giving or its rewards. They are stupid, ignorant, and lack the foundation of faith. They accumulate much wealth and many treasures and ardently guard
them. When they see a beggar coming, they feel displeased. When they have to practice an act of charity that does not benefit themselves, they feel as though they were cutting a piece of flesh from
their body, and they suffer deep and painful regret."

"There are other innumerable avaricious and miserly living beings who hoard money and necessities that they don't use even for themselves, how much less for their parents, wives, or servants, or for beggars! At the end of their lives, such beings will be reborn among the hungry ghosts or animals. If they heard the name of that Buddha, Medicine Master Vaidurya Light Tathagata, in their former human existence, and they recall that Tathagata's name for the briefest moment while they are in the evil destinies, they will immediately be reborn in the human realm. Moreover, they will remember their past lives and will dread the sufferings of the evil destinies. They will not delight in worldly pleasures, but will rejoice in giving and praise others who give. They will not begrudge giving whatever they have.
Gradually, to those who come to beg, they will be able to give away their own head, eyes, hands, feet, and even their entire body, to say nothing of their money and property!"

"Moreover, Manjushri, there are beings who, although they study under the Tathagata, nonetheless violate the shila.

Others, although they do not violate the shila, nonetheless transgress the rules and regulations.

Others, although they do not violate the shila or rules and regulations, nonetheless destroy their own proper views.

Others, although they do not destroy their own proper views, nonetheless neglect learning, so they are unable to understand the profound meaning of the Sutras that the Buddha speaks.

Others, although they are learned, nonetheless give rise to overweening pride. Shadowed by overweening pride, they justify themselves and disparage others, slander the Proper Dharma, and join the retinue of demons.Such fools act on their misguided views and further, cause immeasurable millions of beings to fall into pits of great danger.

These beings will drift endlessly in the realms of the hells, the animals, and the ghosts. But if they hear the name of Medicine Master Vaidurya Light Tathagata, they will be able to renounce their evil practicesand cultivate wholesome Dharmas, and thereby avoid falling into the evil destinies.

If those who have fallen into the evil destinies because they could not renounce their evil practices and cultivate wholesome Dharmas, by the awesome power of the past vows of that Tathagata, get to hear his name for only a moment, then after they pass out of that existence, they will be reborn again as human beings. They will hold proper views and will be ever vigorous. Their minds will be well-regulated and joyful, enabling them to renounce their families and leave the householder's life.
They will take up and maintain study of the Tathagata's Dharma without any violation, they will have proper views and erudition; they will understand profound meanings and yet be free from
overweening pride.

They will not slander the Proper Dharma and will never join the ranks of demons.

They will progressively cultivate the practices of Bodhisattvas and will soon bring them to perfection."

"Moreover, Manjushri, if there are sentient beings who harbor stinginess, greed, and jealousy, who praise themselves and disparage others, they will fall into the three evil destinies for countless thousands of years where they will undergo intense suffering.

After undergoing intense suffering, at the end of their lives they will be born in the world as oxen, horses, camels, and donkeys that are constantly beaten, afflicted by thirst and hunger, and made to carry heavy burdens along the roads.

Or they may be reborn among lowly people, as slaves or servants who are always ordered around by others and who never for a moment feel at ease.

If such beings, in their former lives as humans, heard the name of the World Honored One, Medicine Master Vaidurya Light Tathagata, and by this good cause are able to remember it and sincerely take refuge with that Buddha, then, by means of the Buddha's spiritual power, they will be liberated
from all sufferings. They will be endowed with keen faculties, and they will be wise and erudite.
They will always seek the supreme Dharmas and encounter good friends. They will eternally sever the nets of demons and smash the shell of ignorance. They will dry up the river of afflictions and be liberated from birth, old age, sickness, death, anxiety, grief, suffering, and vexation."

"Moreover, Manjushri, there may be beings who delight in perversity and engage in legal disputes, bringing trouble to others as well as themselves.

In their actions, speech, and thoughts, they create ever-increasing amounts of evil karma.

Never willing to benefit and forgive others, they scheme to harm one another instead.

They pray to the spirits of the mountain forests,trees, and graves.

They kill living beings in order to make sacrifices of blood and flesh to the yaksha and rakshasa ghosts.

They write down the names of their enemies and make images of them, and then they hex those names and images with evil mantras.

They summon paralysis ghosts, cast hexes, or command corpse-raising ghosts to kill or injure their enemies.

However, if the victims hear the name of Medicine Master Vaidurya Light Tathagata, then all those evil things will lose their power to do harm.

The evildoers will become kind to one another.They will attain benefit, peace, and happiness and no longer cherish thoughts of malice, affliction, or enmity.

Everyone will rejoice and feel content with what they have. Instead of encroaching upon each other,
they will seek to benefit one another."

"Moreover, Manjushri, there may be those among the fourfold assembly of Bhikshus, Bhikshunis, Upasakas and Upasikas, as well as other good men and women of pure faith, who accept and uphold the eight precepts, either for one year or for three months, practicing and studying them.

With these good roots, they may vow to be born in the Western Land of Ultimate Bliss where the Buddha of Limitless Life dwells, to hear the Proper Dharma, but their resolve may not be firm.

However, if they hear the name of the World Honored One, Medicine Master Vaidurya Light Tathagata, then as the end of their lives draws near, before them will appear eight great Bodhisattvas, whose names are:

Manjushri Bodhisattva,
The Bodhisattva Who Observes the Sounds of the World,
Great Strength Bodhisattva,
Inexhaustible Intention Bodhisattva,
Jeweled Udumbara Flower Bodhisattva, Medicine King Bodhisattva,
Medicine Superior Bodhisattva, and
Maitreya Bodhisattva.

Those eight great Bodhisattvas will appear in space to show them the way, and they will naturally be born by transformation in that land, amid precious flowers of a myriad colors.

Or they may be born in the heavens due to this cause.

Although reborn in the heavens, their original good roots will not be exhausted and so they will not fall into the evil destinies again.

When their life in the heavens ends, they will be born among people again.

They may be wheel-turning kings, reigning over the four continents with awesome virtue and ease,
bringing uncountable hundreds of thousands of living beings to abide in the practice of the ten good deeds.

Or they may be born as kshatriyas, Brahmans, laymen, or sons of honorable families.
They will be wealthy, with storehouses filled to overflowing.
Handsome in appearance. they will be surrounded by a great retinue of
relatives.
They will be intelligent and wise, courageous and valiant, like great and awesome knights.
If a woman hears the name of the World Honored One, Medicine Master Vaidurya Light Tathagata,
and sincerely cherishes it, in the future she will never again be born as a female."

"Moreover, Manjushri, when Medicine Master Vaidurya Light Tathagata attained Bodhi, by the power of his past vows he contemplated all the sentient beings who were undergoing various kinds of sickness and sufferings.

Some suffered from diseases such as emaciation,atrophy, severe thirst, or yellow fever; others were harmed by paralysis ghosts or by poisonous hexes; some died naturally when young, while others experienced untimely deaths.

He wished to dispel all their sicknesses and sufferings, and to fulfill their wishes."

At that time, the World Honored One entered a samadhi called "extinguishing the suffering and distress of all beings."

After he entered this samadhi, a great light came forth from his flesh-cowl.

From amid that light he proclaimed this magnificent dharani:

Na mo bo qie fa di
Bi sha she
Ju lu bi liu li
Bo la po
He la she ye
Da tuo jie duo ye
E la he di
San miao san pu tuo ye
Da zhi tuo nan
Bi sha shi
Bi sha shi
Bi sha she
San mo jie di
Suo he.

After he had spoken that mantra from amid the light, the earth trembled and emitted great light. All beings' sicknesses and sufferings were cast off, and they felt peaceful and happy.

"Manjushri, if you see a man (or a woman) who is ill, you should single-mindedly and frequently clean and bathe him and rinse his mouth. Provide him with food, medicine, or water that is free of insects, over any of which the dharanihas been recited 108 times. After the sick person has taken it, all his sicknesses and sufferings will be gone.

If this person has a wish, he should recite this mantra with utmost sincerity. Then he will obtain whatever he wished for, and his life will be prolonged and free from illness. At the end of his life, he will be reborn in that Buddha's land. He will become irreversible and will ultimately attain Bodhi.

Therefore, Manjushri, if there are men and women who, with utmost sincerity, diligently worship and make offerings to Medicine Master Vaidurya Light Tathagata they should always recite this mantra and
never forget it."

"Moreover, Manjushri, men or women of pure faith, who have heard all the names of Medicine Master Vaidurya Light Tathagata, One of Proper and Equal Enlightenment, should recite and uphold them. In the early morning, after brushing their teeth and bathing, they should make offerings of fragrant flowers,incense, perfumed balms, and various kinds of music before an image of that Buddha.

They should personally write out this Sutra or ask others to do so, and they should single-mindedly and constantly recite it. If they listen to explanations of its meaning from a Dharma Master, they should make offerings to him of all necessities, so that he is without the slightest want.

In this way, they will receive the mindful protection of the Buddhas. All of their wishes will be fulfilled, and they will ultimately attain Bodhi."

At that time, the Pure Youth Manjushri said to the Buddha,

"World Honored One, I vow that in the Dharma-Image Age, using various expedient means, I shall enable good men and women of pure faith to hear the name of the World Honored One, Medicine Master Vaidurya Light Tathagata. Even during their sleep, I will awaken them with this Buddha's name."

"World Honored One, there may be those who accept and uphold this Sutra, read and recite it,explain its meanings for others, write it out themselves, or tell others to write it out.

They may revere it by making offerings of various flowers, paste incense, powdered incense, stick incense, flower garlands, necklaces, banners, canopies, and music.

They may make bags of five-colored thread in which to keep the Sutra.
They may sweep clean a place and arrange a high altar on which to place this Sutra.

At that time, the Four Heavenly Kings with their retinues and other innumerable hundreds of thousands of gods will come to that place to worship and protect it.

World Honored One, it should be known that if, in the places where this precious Sutra circulates, people can accept and uphold it, then due to the merit and virtue of the past vows of that World Honored One, Medicine Master Vaidurya Light Tathagata, because they have heard his name,
none of those people will meet with untimely death.

In addition, none of them will be robbed of his vital energy by evil ghosts and spirits.

Those people whose vital energies have already been robbed will have their health restored, and they will be happy and at peace in body and mind."

The Buddha told Manjushri, "So it is, so it is! It is exactly as you say, Manjushri, if there are good men and women of pure faith who wish to make offerings to that World Honored One, Medicine Master Vaidurya Light Tathagata, they should first make an image of that Buddha and arrange a pure and clean dais on which to place the image. Then they should strew all kinds of flowers, burn various incenses, and adorn the place with a variety of banners and streamers. For seven days and seven nights they should hold the eight precepts and eat pure food. Having bathed until clean and fragrant, they should put on clean clothes. Their minds should be undefiled, without thoughts of anger and malice. Toward all sentient beings, they should cherish thoughts of benevolence, peace, kindness, compassion, joy, giving, and equanimity.

Playing musical instruments and singing praises,they should circumambulate to the right of the Buddha's image.

Moreover, they should recall the merit and virtue of that Tathagata's past vows.

They should read and recite this Sutra, ponder its meaning, and lecture on and explain it.

Then, they will obtain whatever they seek: Those who seek long life will attain longevity; those who seek wealth will gain wealth; those who seek an official position will obtain it; and those who seek a son or a daughter will have one.

"Moreover, if a person who suddenly has nightmares, sees ill omens, notices strange birds flocking together, or perceives many uncanny events in his dwelling can worship and make offerings of many fine things to that World Honored One, Medicine Master Vaidurya Light Tathagata, then the nightmares, ill omens, and inauspicious things will disappear and will no longer trouble him.

When a person is endangered by water, fire, knives, or poison; or finds himself on a steep cliff or in a dangerous place; or faces fierce elephants, lions, tigers, wolves, bears, poisonous snakes, scorpions, centipedes, millipedes, mosquitoes, gnats, or other frightful things, if he can single-mindedly recollect, worship, and make offerings to that Buddha, he will be liberated from all those frightful things.

When other countries invade or when there arethieves or riots, if a person can recollect and worship that Tathagata, then he will be free of all of these as well.

Moreover, Manjushri, there may be good men and women of pure faith who, all their lives, do not worship other gods, but single-mindedly take refuge with the Buddha, the Dharma, and the Sangha. They accept and uphold precepts, such as the five precepts, the ten precepts, the four hundred precepts of a Bodhisattva, the two hundred and fifty precepts of a Bhikshu, or the five hundred precepts of a Bhikshuni.

Perhaps they have violated some of the precepts they received and are afraid of falling into the evil destinies.

If they concentrate on reciting that Buddha's name and worship and make offerings to him, they definitely will not be reborn in the three evil destinies."

"If there is a woman about to give birth who suffers great pain, if she sincerely recites his name and worships, praises, venerates, and makes offerings to that Tathagata, all her sufferings will be dispelled.
The newborn child will be sound and healthy, and will have upright features. Seeing him will make people happy.

He will be keen and intelligent, peaceful and secure, and with few ailments, and no evil spirit will come to rob him of his vitality."

At that time the World Honored One said to Ananda:

"The merit and virtue of the World Honored One, Medicine Master Vaidurya Light Tathagata, which I have just extolled, is the extremely profound practice of all Buddhas. It is difficult to fathom and to comprehend. Do you believe it or not?"

Ananda said, "Greatly virtuous World Honored One, I have absolutely no doubts regarding the Sutras spoken by the Tathagata. Why? Because all Buddhas' karmas of body, speech and mind are pure.
World Honored One, the sun and moon could fall, Wonderfully High, the king of mountains,
could be toppled or shaken, but the words of the Buddhas never change."

"World Honored One, there are sentient beings deficient in faith who hear about the extremely profound practices of all Buddhas and think to themselves, 'How could one obtain such supreme merit and benefit merely by reciting the name of a single Buddha, Medicine Master Vaidurya Light
Tathagata?'

Due to this lack of faith, they give rise to slander. During the long night, they lose great benefit and joy and fall into the evil destinies, where they wander ceaselessly"

The Buddha told Ananda, "If these sentient beings hear the name of the World Honored One, Medicine Master Vaidurya Light Tathagata and sincerely accept and uphold it without any doubts, they cannot possibly fall into the evil destinies.

Ananda, this is the extremely profound practice of all Buddhas which is difficult to believe and to understand! You should know that your ability to accept this comes from the awesome power of the Tathagata.

Ananda, all Hearers, Solitarily Enlightened Ones, and the Bodhisattvas who have not yet ascended to the Grounds are incapable of believing and understanding this Dharma as it really is. Only the Bodhisattvas who are destined in one life to attain Buddhahood are capable of understanding.

Ananda, it is difficult to obtain a human body. It is also difficult to have faith in and to revere the Triple Jewel. It is even more difficult to be able to hear the name of the World Honored One, Medicine Master Vaidurya Light Tathagata.

Ananda, Medicine Master Vaidurya Light Tathagata possesses boundless Bodhisattva practices,
limitless skillful expedients, and immeasurably, vast, great vows.

If I were to speak extensively of those for an eon or more, the eon would soon end, but that Buddha's practices, vows, and skillfulexpedients have no end!"

At that time within the assembly, a Bodhisattva Mahasattva named One Who Rescues and Liberates
arose from his seat, bared his right shoulder, knelt with his right knee on the ground, leaned forward with his palms joined together, and said to the Buddha,

"Greatly virtuous World Honored One! During the Dharma-Image Age, there will be living beings afflicted with various diseases, emaciated from chronic illnesses, unable to eat or drink, their throats parched and their lips dry. Such a being sees darkness gathering all around him as the signs of
death appear. While lying in bed, surrounded by his weeping parents, relatives, and friends, he sees the messengers of Yama leading his spirit before that king of justice.

Every sentient being has spirits that stay with him throughout his life. They record his every deed, both good and evil, to present to Yama, the king of justice.

At that time, King Yama interrogates this person in order to tally his karma and mete out judgement according to his good and evil deeds.

At that time, if the sick person's relatives and friends, on his behalf, can take refuge with the World Honored One, Medicine Master Vaidurya Light Tathagata, and request members of the Sangha to recite this Sutra, to light seven layers of lamps, and to hang up the five-colored banners for prolonging life, then it is possible for his spirit to return.

As if in a dream, the person will see everything very clearly himself.

If his spirit returns after seven, twenty-one, thirty-five, or forty-nine days, he will feel as if awakened from a dream and will remember the retributions that he underwent for his good and bad karma.

Having personally witnessed the retributions of his own karma, he will never again do any evil, even if his very life is endangered.

Therefore, good men and women of pure faith should accept and uphold the name of Medicine Master Vaidurya Light Tathagata and, according to their capability, worship and make offerings to him."

At that time, Ananda asked the Bodhisattva Who Rescues and Liberates,

"Good man, how should we worship and make offerings to the World Honored One, Medicine Master Vaidurya Light Tathagata? And how should we make the banners and lamps that prolong life?"

The Bodhisattva Who Rescues and Liberates said, "Greatly Virtuous One, if there is a sick person who wishes to be freed from sickness and suffering, for his sake one should accept and uphold the eight precepts for seven days and seven nights, and make offerings to the Bhikshu Sangha of as many items of food, drink and other necessities as are in his power to give.

During the six periods of the day and night one should worship, practice the Way, and make offerings to the World Honored One, Medicine Master Vaidurya Light Tathagata.

Read and recite this Sutra forty-nine times, light forty-nine lamps, and make seven images of that Tathagata. In front of each image place seven lamps, each as large as a cartwheel.

These lamps must be kept burning continuouslyfor forty-nine days.

Hang up five-colored banners that are forty-nine spans long.

Liberate a variety of living creatures, as many as forty-nine species.

Then the sick one will be able to surmount the danger and will not suffer an untimely death or be held by evil ghosts.

Furthermore, Ananda, in the case of kshatriya princes who are due to be anointed on the crowns of their heads, at a time when calamity arises, such as pestilence among the population, invasion by foreign countries, rebellion within their territories, unusual changes in the stars, a solar or lunar eclipse,
unseasonal winds and rains, or prolonged drought, those kshatriya princes should bring forth an attitude of kindness and compassion toward all sentient beings and grant amnesty to all prisoners.

They should follow the above-mentioned methods to make offerings to that World Honored One, Medicine Master Vaidurya Light Tathagata.

Due to these good roots and the power of thatTathagata's past vows, the country will be safe and peaceful, the winds and rains will be timely, the crops will ripen, and all sentient beings will be blissful and free of disease.

Within this country there will be no violence, nor any yakshas or other spirits that harm sentient beings, and all evil omens will vanish.

The kshatriya princes who are due to be anointed on the crowns of their heads will enjoy longer lives and good health, and they will be at ease and free from illness."

"Ananda, if the queens, the princes, the ministers or court counselors, the ladies of the palace, the provincial officials or the common people suffer from diseases or other difficulties, they should also hang up five-colored spiritual banners, light lamps and keep them burning, liberate living creatures,
strew flowers of various colors, and burn precious incense.

Then those people will be cured of their diseases and relieved of their difficulties."

Then Ananda asked the Bodhisattva Who Rescues and Liberates,

"Good man, how can a life that has come to an end be prolonged?"

The Bodhisattva Who Rescues and Liberates answered, "Greatly Virtuous One, did you not hear the Tathagata say that there are nine kinds of untimely death?

That is why people are exhorted to make life-prolonging banners and lamps and to cultivate all kinds of blessings.

Through such cultivation of blessings, they will be freed from suffering and adversity for the rest of their lives."

Ananda asked, "What are the nine kinds of untimely death?"

The Bodhisattva Who Rescues and Liberates said, "There may be living beings who, although not seriously ill, have neither medicine nor a doctor to treat them, or else they meet a doctor who gives them the wrong medicine; consequently, they meet with an untimely death.

Some of them believe in worldly cults, whose deviant teachers frighten them with false prophecies .

Unable to set their minds at ease, they consult oracles to find out what calamities are in store for them.

In order to propitiate the spirits, they kill various creatures.

They pray to wang liang ghosts for aid and protection. Although they wish to prolong their lives, their efforts are to no avail.

They deludedly hold to wrong beliefs and perverse views. Thus they meet with an untimely death and fall into the hells, never to come out.

This is the first kind of untimely death.

The second kind of untimely death is to be executed at the hands of the law.

The third kind is to hunt for sport, to indulge in drinking and lust, or to become excessively dissipated, and then to be waylaid by non-human beings that rob one's essence and energy.

The fourth is to be burned to death; the fifth is to drown; the sixth is to be devoured by wild beasts;
the seventh is to fall from a steep cliff; the eighth is to be harmed by poison, voodoo, evil mantras, or the corpse-raising ghosts; the ninth is to die from hunger and thirst.

These are the nine kinds of untimely deaths generally spoken of by the Tathagata.

There are also innumerable other kinds which cannot all be spoken of here."

"Moreover, Ananda, King Yama keeps track ofthe karmic records of all the inhabitants of the world.

If there are beings who are not filial to their parents, who commit the Five Rebellious Acts, who revile the Triple Jewel, who destroy the laws of the country, or who violate the precept of truthfulness, then Yama, the king of justice, examines and punishes them according to the severity of their offenses.

Therefore, I encourage people to light lamps and make banners, to liberate beings and cultivate blessings so that they can overcome suffering and peril and forestall all disasters."

At that time, twelve great yaksha generals were present in the assembly.

They were:

General Kumbhira, General Vajra,

General Mihira, General Andira,

General Anila, General Sandira,

General Indra, General Pajra,

General Makura, General Kinnara,

General Catura, and General Vikarala.

These twelve great yaksha generals, each with a retinue of seven thousand yakshas, simultaneously raised their voices and addressed the Buddha, "World Honored One! Today, by relying on the Buddha's awesome power, we are able to hear the name of the World Honored One, Medicine Master Vaidurya Light Tathagata!

As a result, we are no longer afraid of the evil destinies.

All of us are of one mind to take refuge with the Buddha, the Dharma, and the Sangha to the end of our lives.

We vow to support all living beings and to benefit them, so that they may live in peace and happiness.

In whatever cities, villages, countries, or secluded forests this Sutra circulates, or wherever people accept and uphold the name of Medicine Master Vaidurya Light Tathagata and venerate and make offerings to him, we, together with our retinues, will guard and protect them, deliver them from all distress and fulfill all their wishes.

If a person wishes to dispel illnesses and difficulties, he should read or recite this Sutra and tie a five-colored thread into knots, forming the letters of our names. He should untie the knots when his wishes have been fulfilled."

At that time, the World Honored One praised the great yaksha generals, saying,

"Good indeed, good indeed, mighty yaksha generals! All of you who want to repay the kindness of the World Honored One, Medicine Master Vaidurya Light Tathagata, should always benefit beings and bring peace and happiness to them in this way."

Then Ananda said to the Buddha,

"World Honored One, what should we call this teaching? How should we uphold it?"

The Buddha told Ananda,
"This teaching is called, 'The Merit and Virtue of the Past Vows of Medicine Master Vaidurya
Light Tathagata.' It is also called, 'Twelve Spiritual Generals' Vows to Use Spiritual Mantras to Benefit
Living Beings.' It is also called, 'Eradicating All Karmic Obstacles.' You should uphold it in this way."

When the Bhagavan had finished speaking, all the Bodhisattvas, Mahasattvas, great Hearers, kings, ministers, Brahmans, laypeople, gods,dragons, yakshas, gandharvas, asuras, garudas, kinnaras, mahoragas, humans and non-human beings, and all the great assembly, on hearing what the Buddha had said, were greatly delighted.

They received it with faith and respectfully practiced it.

End of the Sutra of the

Merit and Virtue of the Past Vows of Medicine Master Vaidurya Light Tathagata.

Mantra for Patching the Flaws in Recitation

Na Mo He La Da Na.

Duo La Ye Ye.

Qie La Qie La.

Ju Zhu Ju Zhu.

Mo La Mo La.

Hu La. Hong.

He He.

Su Da Na.

Hong.

Po Mo Nu.

Suo Po He.