封面

《辨法法性论》讲记

印顺法师 讲

中华佛典宝库制作 2005.4.30


目录

序
序论
正论
    1 辨法法性通明三乘义
      1.2 广释
        1.22 辨涅槃
    2. 特详转依别彰大乘义
        2.126 悟入所依住
          2.12626 悟入无分别智遍知
        2.127 悟入作意
      2.2 喻说


辨法法性论讲记

序

    ‘辨法法性论’，系印顺导师在慧日讲堂，讲说录音，由宏观依录音带笔记其讲说，距今已十余年矣。在此十余年中，历经不少人事离散，意兴阑珊，夜半梦回，思潮起伏。想年已八十矣，应急速完成未了之事；“今世事得今世毕”，庶得安心而去。辗转几时，蒙印顺导师取去笔记，修正鉴定，所谓佛法重时节因缘，时到缘熟，自然而成，诚不得不信！此论名‘辨法法性论’，以辨明法与法性为主，而得以透彻了解佛法中之法性也。兹不多述，详情请阅本书，印顺导师所讲，如何乃可依法而修得！本书得以付印，实系印顺吾师之功德，及各位大德资力协助，圆满功德。愿同沾法喜，同登彼岸！略述始末因缘如是。
    民国七十一年宏观敬序


序论 由知何永断，有余所应证；欲辨彼等相，故我造此论。

    辨法法性论讲记
    ──民国五十三年春，讲于慧日讲堂──

    这部‘辨法法性论’，是法尊法师依据藏文翻译为汉文的。
    法尊，河北人，少年出家。民国十一年秋，到武昌佛学院求学，从太虚大师修学佛法。十四年夏天，从（太虚大师弟子）大勇法师领导的留藏学法团西行；起初到西康，后来到西藏，在拉萨修学。太虚大师在四川北碚缙云山，成立汉藏佛学苑，一再敦促他回来，法尊才于二十三年夏回来，主持汉藏佛学苑。法尊依据藏文，译出论典及宗喀巴等名著很多，在民国的佛教翻译界，是一位最值得推重的！这部‘辨法法性论’，是他在民国二十五年所译的，汉藏教理苑刻版流通。
    ‘辨法法性论’，传说是弥勒菩萨造的。弥勒菩萨是佛教界公认的未来佛，现住兜率陀天的内院，是大乘唯识学者所推崇的大祖。依唐玄奘所传，无著菩萨在阿瑜陀国时，夜晚上升兜率天，从弥勒菩萨听受‘瑜伽师地论’；白天，在瑜遮那讲堂，为大众说法。西藏传说，无著精进苦行十二年，才见到弥勒菩萨现身；然后上升兜率天，在六个月中，从弥勒菩萨学‘瑜伽行地论’（即‘瑜伽师地论’）。弥勒学，是依无著的弘传而大大流行的；传说的弥勒论，事实是无著所集出的。弥勒所造的论，西藏所传有五论：一、‘现观庄严论’，二、‘大乘经庄严论’，三、‘辨中边论’，四、‘辨法法性论’，五、‘大乘最上要义论’。这五部论，都是偈颂，而长行的‘瑜伽师地论’，却被作为无著造的。西藏的传说，是比较迟一些的传说。早一些，唐玄奘所传，‘瑜伽师地论’，还有‘显扬圣教论’（西藏缺），都是弥勒菩萨造的。西藏所传的‘现观庄严论’（颂），是解说大品‘般若经’的；世亲的弟子解脱军，开始为这部论作释，成为西藏般若学的要典；但在汉译中，从来不知道这部论。在汉译中，解说‘般若经’的，有‘金刚般若经论’（颂），魏菩提流支，唐义净译；所译出的本论颂，是无著造，或说弥勒造，可是这部早期的‘般若经论’，西藏译中是没有的。藏传的‘大乘最上要义论’，就是汉译的‘究竟一乘宝性论’（本颂），但汉译所传，是坚慧所造的。在西藏所传的五论中，玄奘仅译出了‘辨中边论’，没有提到‘辨法法性论’，反而提到了弥勒造的‘分别（“辨”）瑜伽论’，并引用了论颂。从论名来说，分别法法性，分别中边，分别瑜伽，倒是富有共同性的。
    辨，是分别、辨别的意思。本论所要分别的，是法与法性，所以名‘辨法法性论’。佛法虽深广无边，但概括起来，不外乎现实的生死流转，理想的涅槃寂灭；学佛，只是怎样的从了解到实行，超越生死而证入涅槃。本论说：其中法所显，即是说生死；其法性所显，即三乘涅槃。所以本论的分别法与法性，就是生死与涅槃的分别。法，梵文的含义很多，如转法轮的法，归依佛法僧的法，不是生死，反而是近于法性、涅槃的。但现在依一般习用的，一切法（蕴、处、界所摄）的法，是虚妄生死法。法性，是法的本性、实性，法性是真如、法界等异名，是如实的涅槃。本论所说的法相与法性相，是：虚妄分别所现，也就是唯识现的，似有实无，是法；虚妄分别所现的，能取所取不可得，是真如性、法性。这一体系，与‘辨中边论’相近。‘辨中边论’以九相显虚妄分别，五相明空性（真如的异名）；本论以六相显法相，六相明法性：这都是立生死与涅槃，虚妄分别与真如二大纲，然后分别说明怎样转虚妄而显真实的。本论又以客尘诸垢及真如性──二性，广明转依，在思想上，这是更近于心性本净说，如来藏说，但本论立‘契经法界’，就是‘摄大乘论’的法界等流闻熏习，与‘究竟一乘宝性论’说，不完全一致。后代的唯识宗，如‘成唯识论’，著重唯识变现义，详于境相，可说是重于虚妄的；如来藏说，依如来藏说生死、说涅槃，是重于真实的。然从弥勒本论及‘辨中边论’来看，立虚妄分别与真如而说转依，是重于行果的。传说的弥勒偈颂论，与‘瑜伽师地论’，有其重点的不同，所以本论为唯识学系，而立论有其独到处，这是讲说、研究本论所不可不知的！
    以下，顺著论颂而次第解说。

    序论
    由知何永断，有余所应证；欲辨彼等相，故我造此论。
    印度造论，或用长行，或偈颂，此论用偈颂。
    论有论的体裁，经有经的体裁。经典一般分三分。序分；正宗分；流通分。论典也有一般体裁，当然也有例外的，大概来说，一般论典以‘归依三宝’及‘造论所为’为序起的。为什么归依三宝？以佛说法，而法为僧宝所修所传的。造论先归依三宝，使人看后，知此是佛法的论。另一方面，有请三宝加被的意思，恐此论有一字之错，贻误后学。造论所为，是说明造论的目的，是为了什么？造论之主要目的，先要说明。本论简略，所以归依三宝也略去了。
    依太虚大师的科题，此论分成二部分：一、序论，二、正论。序论好像经典中的序文一样，序说为何造此论，即上面二句：由知何永断，有余所应证。
    “由知何永断”的意思是：由于知道什么，是应该要永久断除的，永断是不会再生起来了。“有余所应证”，是除了永断以外，还有其他，是我们学佛者所应该证悟的。“欲辨彼等相”，就是要分别彼等相，彼等相即指‘永断’与‘应证’的种种义相。由于为了辨明应证与永断的义相，“故我造此论”。我，是弥勒菩萨自称；换言之，弥勒菩萨造此论的主要目的是：为了说明什么是应该永断的，什么是应该证得的。此即是本论的主要意义，也就是造论的二大目的。
    永断，断是什么意义？断是前后不相续，前面的过去了，以后不再生起来，此即是断了。在佛法，从烦恼的断，到生死的永断，都是断。如我们所有的贪心、嗔恨心、骄慢、贡高心，种种烦恼，断了而不再起来，就称之为断。‘断’和‘不起’，有些是不完全一致的，因为有的断了，却还要起来；有的虽然不起来，可是还没有断。以比喻来说：如杨柳树等，若把树根锯断了，放在地上，它还会发青，发芽生叶子，它还在生，实在已连根都锯断了。我们的烦恼，有的也是如此。另有一种，虽不再生起，可是还没有断。如地面上的草类，把它除得干干净净，可是一下雨又生起来了。因为它的根种，深深的埋在土里，没有拔去。所以，佛法说断，有的断了而还再起来，有的不起来而还没有断。断了而还起来，当然是暂时的，在修行过程中的。烦恼与生死，彻底断了，决定不再生起，才名为永断。佛法中，断烦恼，了生死，都是要求永断。否则，暂时没有烦恼，过了若干时又来了，还是没有解决。佛法所说的永断，是彻底究竟的断了。
    应证：证是证明、证实。如古代文物的考证，或诉讼的物证、人证，世间的证明、证实，都是外证，即从外面去求得证明。现在所说的证，是内证──‘内自所证’，是我们经修持以后，内心亲切的证实。佛法所说的内证、自证，正如佛法中说：‘如人饮水，冷暖自知’。经自己的亲切证验，才证知真如、法性──绝对真理。所以，经修行而到达，亲亲切切，直接体验到的，名为证。
    以这二种结合起来说，佛法依我们现实人生而开示，启发了我们一种正确认识：我们的现实人生，是不理想的，是苦难很多，不自在（即不自由），变动大，没有永久性，不可靠，不彻底的。在世间所有现实人生中去观察，从自己身心事，一直到国家事、国际事，再说到太空星球，一切一切都可以证实了这一论题。中国人大都以为：我们做了人，就是做人，做好人就是了；世间，只好让他永久的苦恼下去。如此说来，似乎太悲观了。佛法以为不理想，不自在，不彻底，不清净，不永久的，可从因果的理解中，找出不理想、不彻底的原因，而给以彻底的解决。消除不正确的心理（烦恼），不正当的行为，就能亲切体验到真理，达成圆满的理想。佛法对人生，充满光明的理想，所以不是悲观的。以国家大事来作比喻，‘分久必合，合久必分’，如果永久如此下去，那实在太恼人了，所以有‘大同’思想而求其实现。我们也如此，如人人生死无边的流转下去，不能永断，那如何是好？佛法的修学，就是不让它永久无限止的延续下去，而求其永断。如生死永断，即开展出无边光明，永远自在，永久清净，彻底究竟，证得真理圆满实现的涅槃。生死永断而实现的究竟涅槃，佛法中或称之谓‘常、乐、我、净’，也就是永远安乐，永久自由，永久清净的境地。
    佛说法，不外乎开示我们这样的一回事。这可以说是，从声闻乘法到大乘法都是一样的。所以佛在初转法轮时说四谛法门，说‘知、断、证、修’，就是知道是苦；应断其原因；断了能证入涅槃；这要从修行的方法去实践。
    现在综合起来说，学佛人都说要了生死，即是‘永断’的意思。可是如何断法？都不知道，所以说‘由知何永断’。先要知道什么是要永远断的，找到应断的根本，给予彻底的断除。断以外，还有其余是所应证的。永断与应证，包含了种种义相，应加以分辨，所以弥勒菩萨说：故我造此论──‘辨法法性论’。


正论

    1 辨法法性通明三乘义
    1.1 略标 总摄二事 当知此一切，略摄为二种：由法与法性，尽摄一切故。其中法所显，即是说生死；其法性所显，即三乘涅槃。
     从此以下是正论，即对所永断的、所应证的，作详细的分别。依太虚大师，分为两大科：第一、‘辨法法性通明三乘义’；第二、‘特详转依别彰大乘义’。就是先以法与法性的分别，通明三乘的法义。然后专论转依──转生死为涅槃，特别发挥大乘的胜义。
    ‘辨法法性’中，分略标与广释；略标中又分为二目：一是总摄二事；二为别说三门。
    1.11 总摄二事：就是将现在所要讨论的一切，用法与法性──二事来统摄，一切依法与法性而显示出来。
     “当知此一切”：应当知道，所永断的事，所应证的事。好像只是二事，其实永断里面包括了很多问题；应证里面也包括了种种的修行，种种的过程，证得的境界。这二者，包括了一切的一切。可以说永断是世间法，应证是出世法；永断是生死法，应证是涅槃法。永断和应证，实包括了一切。
    “略摄为二种”：现在，把一切法统摄在二种中，“由法与法性、尽摄一切故”。一是‘法’，一是‘法性’。弥勒菩萨以法与法性来统摄一切，因为法与法性，可以将所应断、所应证的一切问题全部统摄在里面。
    法与法性，是佛法中的名词。名词的含义，是随时代，随区域，而有多少不同的。如中国古代的‘仁’，孔子和孟子以及后代的学者，对仁的意义，解说上多少就有些不同。佛法也是这样，不但法义深奥，名词的定义，也是不完全一致的。不要以为某名词，从辞典上找到了意义，就以为一切都可应用。因为有一派即有一派的定义，佛法中，小乘与大乘，宗派与宗派间，同一名词，定义每多少有些不同。正如现在世界上的哲学家，使用的术语，也是各有各的意义，不会完全一致的。法与法性，此二词的意义，不一定要照本论的意思讲；不过弥勒菩萨本论所说的法与法性，有著独到的解说。
    法，凡是有一种特性，能使我们了解是什么的，叫做法。如成唯识论说：‘能持自性，轨生他解’。就是有他的特性，使我们依之而有特殊的认识，不会与其他混乱。世间现象界的一切都如此，所以一般生死界中所有的一切，都名为法。法性是法的本性、真性、实性。弥勒菩萨就把此法与法性二者，总摄一切，该括一切。
    摄，古代有自性摄与他性摄的解说不同。现在本论所说的摄，如领袖那样，是领导中心，统摄一切，这是约他性摄说的。如说‘布施’不只是布施的行为，也可包括了布施的动机与结果。进一步说，布施同时相关连的持戒、忍辱等......也可统摄在布施中。现在约这种意义，说一切的一切，都总摄在法与法性二词内。
    法与法性，究竟讲的什么事？“其中法所显，即是说生死”。法所表显的，就是说生死方面的事。“其法性所显，即三乘涅槃”。佛法中，因修行人的发心不同，修行不同，智慧不同，向来分为三乘：声闻乘、缘觉乘、佛菩萨乘。三乘都可以证得涅槃，三乘的涅槃，都是依法性而显示的。这可见，‘辨法法性论’，就是‘辨生死涅槃论’。法显示生死，法性显示三乘涅槃，以法与法性，统摄了生死涅槃中的一切。
    现在再把生死与涅槃二词略说一下：什么叫生死？中国人以自母胎出生时为生。断了气为死。依佛法说，在父母交合，男精女血结成一个新生命的开始，此是佛法所说的生。母生儿女的生，只是通俗的生育。人如此，动物也如此，升天，落地狱，都取新生命开始为生。死，说断气还不够，有人断了气，还能活过来，可见实在还没有死。佛法以为，以人来说，呼吸断了，身上全冷了，一切精神活动都停止了，这才是死。
    学佛的人，常常说‘了生死’，好像是只说生与死，其实并非此义。生死是一个新生命开始到这个生命的结束。一个生命，从新生到结束，中间一切都包括在生死之内。佛法详细说到生、老、病、死；在这生死过程中所有的一切事，都包括在内，所以经中每说：‘生、老、病、死、忧、悲、苦、恼，甚大苦聚集’。在从生到死中，各式各样不如意，不自在事，一切境界，一切遭遇等等，都包括在里面。
    这样说，不过说这一生中，从生到死的一切事情。佛法说生死，还要进一步说：由生而死，又由死而生，生生死死，生生不已，‘生死’包括了一切生死轮回；生死太广大了，所以比喻为生死大海。如果不这样说，我们活在世间，死了就完了，一切解决了，那就用不著佛法。只因为死了还要生，生了还要死，生生死死，永久不断，所以需要佛法，佛法才能彻底解脱。无限生死的一切，都用这法来统摄，说明生死。
    什么是涅槃？涅槃，是印度话。涅槃的字义，有二种意义：一、含有消散的意思，一切苦难、障碍取消了；二、由消散而表显出来的，自由、清净、安宁的，这就是涅槃。
    佛法常说生死是无常的，苦的，无我的。生死是生灭变化的，没有常住的；变化而不安定的无常，当然是苦的；苦迫而不得自在的，所以是无我。无常、苦都消散而不存在了，所以说涅槃是常（不生不灭），乐，清净的，这就是学佛的究竟归宿，究竟的理想。假使我们要设想涅槃是什么样的，那一定不对的，因为我们现实经验到的，尽是些不理想，不自由的；凭我们有漏的思惟分别，是不能正确理解的。所以只有从一切苦痛消散中，以烘云托月的方式，反显出涅槃。但这不是不可体验的，所以与不可知论不同。
    在本论，涅槃依法性而显出，法性是一切法的本性。佛在阿含经中，说涅槃为‘最上法’，也就是最究竟的法。或称‘无为法’，无为是不生不灭，永恒不变的，不从烦恼业所造作（为）的。三乘学人修学，有一共同的目的，如‘金刚经’说：‘皆以无余涅槃而灭度之’。无余涅槃是最究竟的，最圆满的涅槃。‘楞伽经’也说：涅槃是一切圣者的归趣。平常说‘归依佛，归依法，归依僧’，归依法就是归向于离欲清净的涅槃。
    以众生的根性不同，所以有三乘：声闻；缘觉；大乘即佛、菩萨乘。声闻乘，听了佛的教法，依照佛说的去修行，到达究竟而证得涅槃。根据佛所说之法，才能依法修行，不能自发自觉的。举比喻说，佛如发明家，发明了电灯，教以如何的方法装置开关，一按可亮；声闻如一般人依此而行，电灯也能放亮一样。缘觉的特性是独觉，不适宜于团体生活，近于中国隐逸独居之士。缘觉人喜独住茅室，什么事都厌烦，吵吵闹闹的事，当然更讨厌。从经、律看起来，缘觉人对说法也没有兴趣，乞食也会嫌麻烦。但这种人的根性，比声闻为利，能由自己的智慧而觉悟。佛也是无师自悟，用自己的智慧，慢慢地磨练成。到自己大彻大悟，发明了这究竟的真理，实现究竟的涅槃。佛与独觉之不同，在于佛的福报大，智慧大。佛成就大悲大愿，可以广度众生，独觉无悲愿，所以只能自度，什么都怕麻烦。智慧不及佛，自然其他一切都不及佛了。佛法分三乘，要成佛的，应学菩萨，发菩提心，修菩萨行，这就是大乘行。虽然学佛的有根性的不同，所证的涅槃，原则的说，是不能说不同的。如说：‘三兽渡河，渡分深浅’。象、马、兔，共渡一条河，象的力量大，它是直流而过，而且踏到河底的。换言之，他是彻底的。马、兔也渡河，但是浮在水面中过去的；也在水中过去，可是他是浮在浅水面的。一是，彻底的，一是浮面的，但在渡水来说，都在水里，也都渡过去了。所以三乘所同证的涅槃，在涅槃来说，很难说不同的。但修行者的智慧，悲愿的有大小，所以能力有种种不同，表现出大小乘涅槃的深浅。其实涅槃无二无别，不能说有差别的。
    本论以法性来表显涅槃，或以无为法来表显，如金刚经说：‘皆以无为法而有差别’。三乘同证得无为法，都证得涅槃，但是声闻是声闻，缘觉是缘觉，佛菩萨是佛菩萨，显出各各的不同。
    1.12 别说三门
     1.121 相门 别说三门：由三方面来解说法与法性，先作一简明扼要的了解，到下面广释中，再详细的来讲。三门的第一是相门，相是什么意思？相的意义很多：或是体相，体相就是体性的相；或是义相，法法的意义如何，是义理的相；或是相貌的相，就是形态相有种种不同。现在所说的相门的相，是义相，就是说明法的义相，及法性的义相。
    此中法相者，谓虚妄分别，现二及名言。实无而现故，以是为虚妄；彼一切无义，惟计故分别。
    先说“法相”，以唯识的意义来说明，唯识变现的主要意义，都包括在这七句中。现在简要的来说，法的义相就是“虚妄分别”。什么是虚妄分别？不实在的是虚；不真的是妄，分别就是心识的作用。在中国佛教界，有一个很熟悉的名词──‘妄识’，虚妄分别就是妄识，虚妄即妄，分别即是识；也名为‘妄心’。
    “现二及名言”，就是虚妄分别的定义。什么叫现二？二是能取与所取，‘现二’是现起能取、所取──两方面。如以手拿东西，叫取。佛法中，眼见、耳听也名取；但这里所说的取，专指我们的心识取境界相叫取。取，一定有二方面，一能取，一所取。我们的心识，能认识境相，有能取作用，叫能取。取得什么？如我见到一朵花，那是眼识的所取，就是所认识的对象。有认识，就有能取与所取。在常识中，我们感觉到、认识到的，不外乎色、声、香、味、触、法；种种复合体而为我们所认识的，如房屋、山、河、大地、草、木、丛林。无论是常识的认识，或研究所得的；不管是哲学、生理学、物理学、原子、电子，都好像是在外的，我们的心去分别它、了解它、研究它。我们的心识呢？是在内的。心内的，和心识以外的存在，好似两种不同的对立物。心与物，能取与所取的各别对立，是我们一般人的感觉。妄识的境界，就是如此。
    大乘唯识学的见解，与常识的意见不同，认为我们的心识生起时，就现起两方面。不认识就算了，什么都不知道。一起认识作用，就一定现起两方面。即使你不认识，不知道什么，但心上终有一认识的意象，也就有所取与能取。能取与所取，或名心与境，或名能分别与所分别。这是说，所认识的对象，不是外在的，而是从内心所现起的。
    只是这个识，但此识不起则已，一起就自然而然的显现为两方面，有主观和客观对立的倾向，这所以被称为虚妄。
    ‘名言’：什么是名言？我们的心识活动，不过是名言而已。如我们说话，或一个名词，或是一句话，是名言；而我们内心的认识什么，也好像讲话一样。所以有人说：我们的思想，是没有声音的语言，语言是有声音的思想。所以，佛法称世俗心识为名言识。
    现在我们认识到的，圆的，红的，虽没有说出来，却与我们口说的一样。我们不要以为我的心，心能认识到了红的、圆的......，红的、圆的......是真实认识到了那个客观的东西，真实认到了外面的那个东西。其实，我们所认识的什么，只是我们心识的名言作用。
    我们心识的认识活动，纯粹是一种名言作用。但在人们的感觉中，并不是这样，以为红的实在是红的，物质实在是物质，声音也以为实有声音，样样都以为是实在的。其实，呈现在认识中的对象，一切都不外乎名言作用。以‘现二’及‘名言’──二义，说明了我们的心识，实在是虚妄分别。佛法所说生死法，中心即是虚妄分别──妄识。为什么是虚妄分别？因为一方面显现二取──能取、所取，一方面不外乎名言。
    名言有二类，明确的与不明确的。以众生来分别，狗、猫与人就差多了。人有认识，猫、狗有认识么？当然有，如认识到主人回家了。又如猫嗅到了鱼味即走近来，要吃。不过他们的认识，名言的活动非常暗昧，简单而不大清楚，所以他们虽有这认识的名言作用，却不能清楚的表达出来。我们人就不同了，我们的认识非常清楚，名言作用很强，也能用语言表显出来。人类的语言多复杂，什么都能讲给别人听，使人听了可以理解。不但是口说，也能以手势，或面部的表情代语言。试看哑吧，不是用手势来表显吗？这也是名言。名言是能表诠的，表示一种意义。凡能表示一种意义的，都是名言，不管口中所说，或是心中所想的，或是身体的一种表示。人类在进步中，中国有方块字，外国人用拼音字。直写横写，各式各样不同，文字都与语言一样，能表示内心认识的内容。我们的方块字，一横一竖的，拆开来，什么意义都没有，可是结合起来，能表示出具体或抽象的一切。名言──内心的、声音的、形色的，就是这么个东西。人类的名言作用强，所以思想、语言、文字，也特别发达；而名言的根源，是心识所有的作用。猫、狗等动物，不能说完全没有，如在吃饭时，猫会走到身旁叫著要吃，这也是一种表示。狗见主人回家，摇尾表示欢迎。叫的声音也有分别，有经验的动物学家，听得出喜欢叫声，及忿怒的叫声，不过没有人类那样的微细、复杂、清楚而已。动物中，高高低低的名言活动不同，人类也是这样。刚生下来的小孩，什么不懂，不会做，也知哭，吃母亲喂的奶；渐渐的认识母亲，及其他的人；以后会讲话了，先叫爸爸、妈妈，渐渐什么都会讲了，他的心上的名言，就一天一天发达复杂起来。所以，心识的名言作用，是一切众生所都有的，不过程度的不同而已。
    要了解，我们的心识活动，是有表示作用的，称为名言，使我们知道是什么，其实是个符号。我们用方块字，拼音字，各式各样都可用以表示一切。或用声音表示，虽随地区、随时代而不同，语音不同，而表示什么，却是一样的。我们凭心识、语言、文字，以为这是什么？那是什么？以为确实是这样，不知这是符号的世界，名言的世界。不是真实是那样，而只是我们心识表现的法相。现二与名言，说明了虚妄分别的意义。
    进一步说：“实无而现故，以是为虚妄；彼一切无义，惟计故分别”。为什么是虚妄？‘实无而现故’。实在没有这样的实在性，而却有能取与所取的现起。我们的心不起则已，一起即表现为主观与客观，也就是内心与外境的对立。直觉到有客观外在的东西，为内心所认识，但此能取与所取，推究起来，实际是没有这二种对立的真实性。好像有主观、客观，心、境，内、外的对立，其实并不如此。如现起此二种是真实的，那就不是虚妄了。因为没有能取、所取，对立的真实性，只是心识的表现，所以称之为是虚妄的。
    一般人的想法：客观实在的境界，是存在于心外的，是实在。依唯识说，没有心外独存的实在物，只是心识的似现。那末，能取的心识总是实在的了！不是的，如有实在的境界，也许可说实有内心，而实际并不如此，心与境是不相离的，离所取是没有能取的。我们觉得心与境实在各别不同，所以认识到的客观境界不离错误，觉得那个主观实在的心，也不离错误。境不离我们的心，心也不离境，所以呈现在我们心识中的什么客观主观，心境对立的，都是虚妄、颠倒、错乱的。因为实无别体的能取、所取的对立可得，所以说：‘彼一切无义’。‘无义’，是说没有这能取与所取的实在的体性，或者没有实在的外境。
    然而，我们不是觉得有实在的体性吗？这不过是我们心识的名言活动，种种的推度而已，所以说‘惟计故分别’。佛法说‘遍计所执性’，遍计，即以我们的分别心去作各式各样的推度执著，觉得这是这样，那是那样。也就是我们不知道是虚妄现的，取著能取所取而作种种的计执，以为是实在的。如除去了我们内心的计度以外，就没有我们所想像的一切实性了。所以一切都是无义的，惟是计度而已，所以只是‘分别’。总结的说，如果这个现象界的种种，确是实在有能取、所取相对立，有客观那个东西实在的话，就不能说一切都是虚妄分别了。现在推究起来，没有实义，惟是我们自心，因心识表现为能取与所取，不知道这是虚妄的，所以起种种认识推度作用，以我们分别推度显现出一切，以为是如此如此的。所以除了分别，一切不可得。换句话说，这是一意言、名言的活动，就称之谓分别。
    众生所以有生死，由于无明，这是佛法所公认的。什么是无明？无明是蒙昧错误的认识。我们对宇宙人生没有体悟得到真理，所了解到的，都是虚妄错误，不实在的。由于这样，我们常在错乱，颠倒中，起烦恼，造业，受生死，一生一生的生死不了。所说虚妄、颠倒、错误的根本，究竟是什么？唯识宗给我们指示出来：我们的无明──最根本的错误，就是觉到心物对立，好像心外有客观实在的世界，离外界而有内心。错误由于虚妄分别，成了生死的根本。我们每个人都觉得心在内，境在外，山水在外；外物是与心无关，自己就是这样的。大家都为无明所蔽，都有根本错误，所以谁也解决不了生死，谁也不得究竟解脱。
    所以唯识宗要说：一切都是唯识所（表）现，惟是虚妄分别，从虚妄分别所显现的一切。依著这样的理解，去观察一切唯识所现，便能断除无明，证悟真理，解脱生死。就是大乘空宗，也还不是这样：我们在生死轮回中，颠倒错乱，生死不得解脱，由于无明。什么是无明根本？不知一切是空，而遍计执著实性的有。如能观一切法无自性，无自性故空，就能解脱生死，启悟真理而得涅槃。这就是说，真正的佛法，不管讲空，讲唯识，都是为了这个问题，都是为了要了解这生死，袪除无明而得到涅槃，成佛。佛法，有深广的理论，但为理论而理论，真正佛法中是没有的。现在弥勒菩萨所开示的论，是唯识大乘，所以首先说：法──生死，主要的就是虚妄分别，一般叫做妄识。妄心不起则已，起即能取所取相现，所以说：心生，种种法生；心灭，种种法灭。知道惟是自心所显，惟计故分别，所以破除遍计执，体悟法性得解脱，是唯识学的根本意趣。
    复此法性相，无能取所取，能诠所诠别，即是真如性。
    上来已略说法的相，以下明法性的相。法性是要依法而说明的，所以对所说法相，再简单叙述一下：法就是生死法；生死法是轮回不已。生死一切法，以虚妄分别为性，所以一切唯识。本论以现二及名言──二义，说明生死以虚妄分别为性，这是法相。现在依法相而遮显法性相，所以说：“复此法性相，无能取所取，能诠所诠别，即是真如性”。一般说，法性无相，法性有什么相可说！这话是对的，因为说到的相，不外乎名言分别。法性那里可以分别？心思所不及，语言所不到，所以说法性无相。可是，没有相就不可说，不说如何能使人趣向法性？所以佛菩萨从不可说中作方便说，用不、非、无这些话来表示。或如维摩诘经中，维摩诘以默然不说来表示。这种方式，在我们佛法中，有人觉得是消极的，因为这也不是，那也不是，不是也不是；这是空，那也是空；这不可得，那也不可得，却不说是这样，是那样。因为肯定的说，就著相了，就与法性不相应，所以用一种遮遣的方法，用否定的字句来表示，这叫烘云托月法。画师要画一月亮，如敊一圆圈，人家见了都说这月亮画得不太像。如在旁画了许多乌云，中间留有一圆圆的地方，在这乌云中显出了月亮。其实他没有画月亮，不过是用衬托的方法表达出来，却非常神似。佛法说真如，法性，涅槃，都是用此法的。现在所说的‘此法性相’，是没有能取、所取，没有能诠、所诠的差别，这就是没有‘现二’──能取、所取，也没有‘名言’──能诠、所诠。上面说，生死法是虚妄分别所现起的能取、所取，似乎心境对立，这是世间法。现在法性是能取、所取不可得。上面所说虚妄分别是名言，口中说的是名言，心中思想的也是名言。名言是能表示某种意义的，所以名言必有能诠表与所诠表，但法性是超脱能诠所诠的。法性是能取、所取不可得；能诠、所诠不可得；所以说：‘无能取所取，能诠所诠别’。‘别’字连到上面解，没有能取、所取的差别；‘无’字又连著下面解，没有能诠、所诠的差别。能取、所取，能诠、所诠都不可得，这是法性相。
    这许多名词，大家听了似乎很生疏，如改用我们向来惯用的话就熟悉了。如说不可思议，没有能取、所取，所以不可思；没有能诠、所诠，所以不可议。法性超过了能取、所取，能诠、所诠，即是真如性。
    什么是真如？真是表示它不是虚妄的，有现二就是虚妄，有能取、所取，能诠、所诠，就是虚妄。现在无能取、所取，能诠、所诠，这就是不虚妄，名为真。什么是如！如乃如如不二，一模一样，平等平等，没有变异，没有差别，名为如。如有心，有境的差别，是不如；有能诠、所诠的差别，是不如；有此、有彼，有多、有少，有这、有那，就是不如。总之，有二（落入相对界），就是不如。如真正的平等，超越相对的差别界，就是真真的如。法性没有能取、所取，能诠、所诠的差别，所以就是真如性。真如性是法性的别名。
    1.122 成立门
     如上面所说的，为什么非如此不可？非如此不能成立生死的杂染，涅槃的清净，也可说佛法全部的重要意义，都要依这样的意义而成立。
    无而现故乱，即是杂染因，如现幻象等，非有而现故。若无及现中，任随一非有，则乱与不乱，染净皆非理。
    此二颂，先成立生死是杂染，是错乱的；次成立有染有净，有错乱与不错乱。我想提起一个问题：我们所了解的一切，是否正确？我们知道的一切，连高深的哲学、科学知识在内，真能恰恰如此，与真理相契合吗？我们自以为这样、那样，其实连自己也不知道自己。如真能通达真理，那所作所为，都应合于真理的活动，合于真理的生活。如世间文明，真能渐进而接近真理，那世间也就不会如此：混乱，战争的规模越来越大，越来越厉害，什么比原子弹更凶的还要出来，使大家过著苦恼、紧张、不得平安的生活。佛法以为，世间是苦恼不理想的，充满矛盾斗争的，没有真自由的。为什么这样？因为我们的认识上有错误，所以发而为思想，见之于行动，世间会愈搞愈糟，不能实现永久的和平。我们个人，在生死中，不得永久安乐，不自在、不得解脱；家庭、国家、国际，一切都在这样的不理想之中。人，一切众生，都在迷惑与错乱之中，这就是苦迫不自在的根源。
    西方有一位大哲学家说：他好像在大海边上拾到了一小小蚌壳，他所知道的不过一点点。这位大哲学家，比别人强一些，因为他知道自己无知，知道自己懂不了多少。
    人生问题的不得解决，问题在无知，在佛法名为无明。无明就是不明，没有智慧，不能正见宇宙人生的真理。到底错误在什么地方？本论说：“无而现故乱，即是杂染因”。根本没有心物的各别实性，而在我们的心识中，有二取现起，这是错乱，就是生死杂染的因缘。杂染与恶不同，杂染是有漏的，不清净法。善的，恶的，非善非恶的，如没有离去颠倒错乱，没有断除烦恼，不是无漏的，就是杂染。
    杂染有三：1.惑杂染，2.业杂染，3.生杂染。惑杂染──惑是烦恼：是杂染、不干净，如布在染缸中染上了各种颜色，不再清净洁白了。业杂染──由烦恼而起的造作──行为名为业，善业、恶业，一切有漏的业，都叫业杂染，业是要感生死果报的。生杂染──由业感到生死果报，或是人，或入地狱，或升天，种种业报，是生杂染。此烦恼，业，果报，种种不清净的杂染法，从何根源而来？‘无而现故乱’，是生起这种种杂染的原因。我们常说了生死，生死是什么事？就是烦恼，业，果报。从那里了起？先得知道这杂染的根源在那里。把此错乱的根本消除了，烦恼、业、生杂染才可以解决。
    我们起贪、嗔、憍慢、贡高、嫉妒、斗争、障碍、残酷心，都是杂染的；我们即是做好事，存好心，如爱心，悲悯心，或无贪心，这些善心也还是不清净的杂染因。一般的恶心与善心，都还是杂染的。依善恶心所造出来的善业、恶业，也还是杂染。由善业、恶业所感到的果报，即使升天，也还是不清净的有漏之法。根本原因是无而现为杂染因。行为依于思想，思想依于一般的知识。当一念心起时，现起能取与所取，有对立的倾向。这一错乱的呈现，影响我们的认识与思想，也影响了我们的行为与成果。此乃无明，根本无明，就是我们的不明。现起的二取相，不是真实的，好像是心外有境，境外有心，心境对立，其实是不真实的错乱。不要以为我不执著就可以，如不经正确的观察，勘破这迷乱所在，心随境转，不执著也不成的。因为心起时，好像有一对立性的真实存在，有一种力量，会使你迷而更迷。非经过修持，引发真智慧，是没有办法改变的。
    能取、所取是无而现起的，无而似乎是有，所以叫‘乱’，论文举一比喻“如现幻象等，非有而现故”来说明。佛法常说如幻如化，现在举如幻的比喻。幻，就是魔术。魔术师变现起一只象，根本没有这只象（印度时常见象，故以象做比喻），但幻现出来的，却是一只活生生的象。并没有此象，可是现起的象，叫你看了活像是真象。此比喻本无能取、所取，但心识现起的二取，在我们觉得的确有能取、所取对立存在。幻象，大家也许没有见过。但我们常见的魔术，拿一条毛巾扎成一小鼠，一跳一叫的，看的人就好像见到了真的老鼠。幻术的‘非有而现’似实有，虽没有这会事，却有强大迷惑、欺诳的力量。虚妄分别的现起二取，实无其事，而严重的影响到思想上、行动上，使众生永久流转于杂染、苦恼中。
    以下，说明非如此不可。“若无及现中，任随一非有，则乱与不乱，染净皆非理”。现，是明白的呈现摆在我们的面前；无，是不是实有这会事。此二──现与无，平常是合不起来的；一般以为，没有就是没有此事，明明白白现起，那便是有此事。假使如一般的想法，现有就是有，无就什么都没有，那是不对的，不能成立真妄、染净的。虚妄分别性，说他无，不是什么都没有；说他现有，只是现象如此，并不说他就是真实。所以说无而是现有，现有而又是无；从现这方面讲是有，从无这方面讲是空。佛法中每用如幻、如化，如镜中影，如空花等比喻，只是说明好像这样，其实并不这样；虽并不这样，却又好像是这样。
    佛法用幻、梦、化等比喻，说明无而现，现而无，无与现的统一。法──生死世间法，非如此不可。‘若无及现中，任随一非有’，就不能成立真妄与染净。现与无，在这二义中，随便那一方面没有的话，那末乱与不乱，杂染及清净，一切都不能成立。假使说是无，无就是没有，而不是似现，那与方广道人一样，也无所谓杂染了；确实是没有，也就说不上是乱了。如果说现，现起就是这样的实在，不是没有的，那怎么能说是乱？不错乱，即符合真理，那就也不是杂染了。所以，乱与杂染，是以无而现，现而无，才能成立的。
    没有乱，就没有不乱；没有杂染，也就没有清净。依一般人的想法，似乎这是杂染，另外还有一清净的；这是错乱，另外有个不错乱的，这又不对了。在现实的人生世界中，佛依现实的观察，这是杂染与错乱的。清净与不乱，在虚妄分别中，是不可得的。要知道清净依杂染而能成立，有了这不清净的杂染，如遣除杂染法，才能有清净法。所以如没有杂染，清净也不能成立。错乱与不错乱，也是一样，勘破这虚妄错乱，不再错乱了，才是不乱，才是真如、涅槃。所以先要成立杂染法，转去杂染而有清净；先要成立乱，离去惑乱而显出不乱。所以，唯识宗以虚妄分别为所依。现而无，所以是惑乱的；是惑乱，所以成为杂染的。知道是惑乱的，就能离乱而达不乱。是杂染不清净的，才能离杂染而得清净的。如不是无而似现，现而实无，那末杂染与错乱不成立，清净与不错乱也不能成立了。所以说：‘则乱与不乱，染净皆非理’。如杂染、清净、错乱、不错乱都不成立，那一切世出世法都被破坏了。但我们是人，知道是杂染的，因而寻求清净；知道惑乱，所以趣向不乱；知道虚妄，所以追求真理。这样，非承认有错乱，有杂染不可了。错乱、杂染从何而来？就是无而现，现而无。释迦牟尼佛开示佛法的方法论是这样的，后代佛法的方法论，不一定这样。有的说：众生本有清净的，不惑乱的，然后倒转来说，为什么成为杂染与惑乱，修行是返本还源，复归于净的。释迦牟尼佛说法，从生死说到涅槃；从杂染说到清净。杂染与生死惑乱，是世间现实的，这是现实人生所接触到的。肯定了惑乱与杂染，然后从杂染到清净，从生死到涅槃，从错乱到不错乱。不乱依错乱而成立，清净依杂染而成立；杂染与错乱，依无而现，现而无，才能成立。所以在我们心起时，现起能取、所取，虽无而现有，似乎各立存在，是错误的根源，而是非如此不可的。
    1.123 不一不异门 此二非即一，亦复非别异；以彼有无事，有别无别故。
     虚妄分别是现而无，无而现的。无与现──二者，是一还是异呢？一般人的想法，不是一，就是二；不是二，就是一，怎么虚妄分别是现而又无，无而又现呢！现在说，这是不一不异的。现起能取、所取，是这个样子，这是现有；但能取、所取，不是真实有，这就是实无。这两者是非一非异的，所以说：“此二非即一，亦复非别异”。无与现这二义，并不等于一，不能说完全同一的；但也不能说是各别的。一就一，二就二为什么要说不一不异？“以彼有无事，有别无别故”。因为有是现，无即不可得，有与无二义中，有有别与无别的缘故。有与无所有不同的含义在那里？有事──现起，有能取、所取的差别相；能诠所诠的差别，宇宙人生一切差别相，都从有显出来的。无事是不可得，是无性，无性是平等一如的，无二无别的。有事有差别，无事无差别，别与无别不同，就不能说是一了。然而，凡是现有的，就是无自性的；无，并非离有以外，别有一无性。这样，有与无，是有差别而又无差别的。无差别，所以不能说是异。说一也不可，说异也不可，所以成立这现有与无性，是非一非异的。一般所说的性相，不一不异，也就是这样的。不过，有的人著重于不异，有的人也著重于不一。如专重不一，那就事相与理性对立了！如专重不异──无二，那以理性说事相，又不免事理儱侗了。总之，事与理，现相与无性（无性即实性），是不一不异的。以上是法与法性的略标。
    弥勒菩萨另外有一部论，名‘辨中边论’，或译作‘中边分别论’。中道与二边，‘辨中边论’也是从虚妄分别说起，如说：‘虚妄分别有，于此二都无，此中惟有空，于彼亦有此，故知一切法，非空非不空，有无及有故，此即为中道’。辨中边论的颂文与本论的意思相合。依中边论说：虚妄分别是有的，就是现二及名言的识。在这虚妄分别性中，现起的二──能取、所取，实在是都无自性，不可得的。在虚妄分别中，都无能取所取，所以虚妄分别性中惟有空性（无性）。空无是不碍现有的，所以彼空性中也可有虚妄分别。此虚妄分别是能现的，空性是无。现起的有，与无性的空，不一不异，所以说‘故此一切法，非空非不空’，这就是中道了。


1.2 广释

    1.2 广释
    1.21 辨生死
     1.211标列
     从此以下，对法与生死，法性与涅槃──两方面，作详细的解说。先辨生死，也就是法的分别。标列，是把要说的内容，总括的标列出来。
    由六相悟入，诸法为无上：谓相与成立，及非一非异，所依共不共，悟入能所取，现似而非有。
    有六种相，或可说从六方面，对于一切生死法，为悟入的无上方便。说到悟入，中国学佛的人，开口是开悟，闭口也是开悟，悟是悟入真如的意义。这里也说悟入，意义稍有不同。从理解法开始；理解以后，深深的思惟法；进一步从修持中通达究竟。所以“悟入”不单是开悟，是经闻、思、修而到达证见的。
    本论以“六”种“相”说明此法，是通达法的“无上”方便。六种相：1.“相”；2.“成立”；3.“非一非异”；4.“所依共”；5.所依“不共”；6.“悟入能所取，现似而非有”。简略的说：1.相，是法相，如上颂说：‘此中法相者，谓虚妄分别，现二及名言，实无而现故。以是为虚妄，彼一切无义，惟计故分别’。2.成立，如上颂说：‘无而现故乱，即是杂染因；如现幻象等，非有而现故。若无及现中，任随一非有，则乱与不乱，染净皆非理’。3.非一非异，如上颂说：‘此二非即一，亦复非别异，以彼有无事，有别无别故’。4.所依共；5.所依不共。所依，指生死流转，虚妄分别法所依。所依法中有共的，是众生彼此间所共同的，如所住的世界（地球），是人与人，人与畜生等所共同的。不共，如一个人，一个蚂蚁，都有个体，维持各自的生存。所依，有此共与不共二种。6.悟入相──‘悟入能所取，现似而非有’。对识现起的能取、所取，不执著为实有，不执为心、物别体，悟入是现似而其实非有的。悟入一切法唯识所现，是修观悟入的必要胜解，这是六相中最重要的部分。
    1.212 别释
     1.2121 略指前三 其中相成立，及非一非异，如略标中说。
     分别的解释六相中，第一相；第二成立；第三非一非异，这三相都已在略标中说过了。
    1.2122 所依共与不共 诸于何流转，说彼为所依？谓情界器界。器界即为共，如共同所了。
     现在从所依说起。什么是所依？“诸于何流转，说彼为所依？谓情界器界”。这是所依的解说。诸，与‘凡’字差不多。凡是于什么流转的，在什么处流转的，依什么法而流转的，就说他是所依。流转，或译作轮回。我们可以水的流动为比喻，如水流入了漩涡中，转来转去，转不出去，一直在这圈子里面转动，这就是流转。众生在生死中，也是这样，升到天上，由天上又入人间，人间再入地狱，地狱出来到畜生，畜生又到地狱，地狱又到人间，尽管转来转去，却一直在生死中，因此称生死轮回为流转。众生无始以来，死了又生，生了又死，生死不已的是流转，到底依什么而流转？流转的所依法，是‘情界、器界’，情界与器界，是流转的所依。
    什么是情界、器界？界是界别，有界限的，彼此差别的。佛法总说二种界：一、有情界，二、器界。有情是有情爱的，有情识的，如人、畜生、天、地狱、饿鬼这五类都是有情界，都是有生命的，有心识作用的。古译众生；新译为有情，是有心识作用，情爱活动的生命体。有情分五类，名为五趣，或分六趣（六道），在天、人、地狱、畜生、饿鬼外，更立阿修罗为一趣。
    什么是器界，器是器皿，是能容受物品的。现在所说的器界，如地球、星球等，是人类等所住的，所以地球等属于器界。佛法中所说的器界，有无量的大千世界，中千世界，小千世界。一小千世界，有四大部洲，八中洲；我们所住的，是南阎浮洲，属于器界。简单说，人类是有情界，动物等也是有情界。山、河、大地、草、木、丛林，这都是器界。器界中，例如我们所住的世界，在地上名五趣杂居地──地狱、畜生、饿鬼、人、天，都是的。向上还有空居的天；人天都有淫欲，所以名为欲界。欲界以上有色界，无色界，都是天趣。欲界、色界、无色界，总名为三界。
    论有情，不出于五趣；论器界，不出于三界（九地）。生死流转的所依，以人类来说，身心是所依；我们住在这地球、山上、海里，也是我们的所依。
    现在先说器界所依：“器界即为共”，器世界是共的所依。这地球是谁的？不能说是个人的，是全人类（及畜生等）所共的。或者说，如空气，如大水，这都是共的。共是共同的，佛法说共业所感，就是大家的业共同所感到的。以唯识来讲，是唯心所现的。在我们心识中，现起来的时候，就现有内而身心，外有器界的相，各自各的显现出来，所以说唯识所现。以人类来说，每人都从自心识中现起这器界相，所现的器界相，在我、你、他间，都有一个共同性：我现起这样的相，人人都现起这样的相，器界相现似共同性，不以个人的心识而有所改变，所以被想像为有一客观实在的物质世界。成唯识论举灯光的比喻：在这房子里点一盏灯，光由此灯放出，一灯放一光；如房内又有一盏灯，就又有一光；或有几十盏灯，几百盏灯，就放射几十几百光明。这几十、几百盏的灯光，综合融和，现出一片光明，这一光明，谁能分出此光彼光呢！而事实上，各各灯放各各灯的光明，虽综合如一大光明，而仍是属于各各灯的。如这盏灯熄了，这盏灯的光明就不见了，但大家所见的，还是一片光明，并不因一灯光明的熄灭而不见。这比喻说明了，我们所依住的器世界，器界的存在也是这样的。心识所现起的器界相，是各人心识所各别显现的。由于心识所现的器界相，彼此间有共同性，大家都见到同一的器界。见到的是同样的，好像与我们的心识是没有关系，其实是我们各各所变现的。是各人各各变现的，那末这个人死了，他所现起的器世界，应该就不见了，可是大家还觉得是同样的世界。一人死了，多人死了（又有人生了），这地球还是地球，这正如一灯息了，几盏灯息了，还是见到一大光明一样。器世界的共，是“如共同所了”。大家所了解的器界，一模一样，因此这一种所依，称之谓共。
    如以五趣生死来说，五趣有情所见的器世界，不是一致的。你、我、他，都是人，人类所见的世界，是一样的。假使有人所见不同的话，那是病态，器官有病，神经失常，心理变态了。但人以外，还有畜生、饿鬼、天。人类所见的人世界，虽然都是一模一样，但这个器世界，在饿鬼、天、畜生来看，就与我们有点不一样了。如我们常见红花、黄花，多采多姿的花，有些动物，如牛，所见只是灰色的。如牛与牛能互相交换意见，那末，一定以为这世界是灰色一片了。又如人世界所见到的水，水是人类器界所共的，可是饿鬼所见的，是火焰，脓血。饿鬼不见清水，在人来说是错了，但饿鬼与饿鬼间，有他们的共同了解，都说是脓血、火焰，怎能说他是颠倒？
    鱼类所见又不同，鱼游在水里，正像人在空气中一样，若无其事。如人在空气中，鱼游在水中，也是这样。鱼类住在水中，有对水的不同感觉，这是鱼的器界。如果是天的话，所见的是七宝庄严，这就大不同了。所以器界被称为共，是共业所感，共同所了。但约众生的类别不同来说，是随类而所见不同的。
    有情界有共，复有诸不共：
    现在来说有情界所依。“有情界”，“有”是“共”的，也“有”种种“不共”的；共有种种，不共也有种种。例如每个人，都保持个体生命的延续，各各的不同活动，各各的不同思想，都独立的存在与发展，这是不共的。可是有情与有情，彼此间也有种种关系。如人与人，人与畜生，畜生与畜生，彼此间都有相互关系。这种共同关系，就是共。所以器界──山、河、大地、草、木、丛林，都是共的。以有情界来说，就有共与不共的。成唯识论也说到共与不共，但所说的意义，有些不同。总之，有情所有的个体活动，是不共的；而有情与有情，彼此间结成共同关系，就是共。‘有情界有共，复有诸不共’，这二句是总标，下面分别的说明。先说所依有情界的八种共。
    托胎生、名言，摄受与治罚，饶益及违害，功德并过失：由更互增上，互为因故共。
    颂中先举八事，次说共的意义，就是末二句：‘由更互增上，互为因故共’。这是通于八事的，所以先解说后二句。共的意义，是更互增上，及互为因。什么是更互增上？增上，是有力的。这个对于那个，能给与一种影响，给与一种力量，这就叫增上。更互是展转的意义，如你对我，我对你，彼此间能互相给与一种力量，这就是更互增上。什么是互为因？增上也可说是因，但约疏远的说，因是比较亲近的。佛法说因果，如甲给予乙以一种力量，能使乙生起，甲就是乙的因；因力，也有相互的关系。由于增上及因的展转相关，所以形成有情界的共同关系。例如我骂你一句，这句话就是一种力量，刺激了你，使你听了，立刻脸色变青，有的两脚乱跳；再不忍，拳一伸，就打起来了。你打我，也许我也打你，结成了彼此间的严重关系，可能一直影响下去。不但是人，人与畜生，畜生与畜生，众生与众生间，都有一种相互的影响力，所以互相为因，也互相为果，这就是共的意义。
    八种共中，一、“托胎生”：新生命的开始，叫生。以人来说，是父母和合，父精母血，结合而开始一新生命的活动，名为生。佛法说众生有四种生：胎生、卵生、湿生、化生。化生，新生命的开始，全依业力而生起，没有与其他有情的共同关系。但人及猴、牛等高等动物，都是胎生的；鸡鸭等鸟类，是卵生的；其他先生一卵子，经一次、二次的变化，才成为成虫，这一类，称为湿生。胎、卵、湿生，就依赖其他的有情而生起。
    佛法虽说四生，主要为人类说法，所以以人的胎生来说。一个人要出生，要具备三方面的事情：要有父亲；要有母亲；在父母和合，父精母血结合时，另有有情自己的业力引发，识来入胎。这是说，在父精母血正结合的时候，一念识依托而起，成为一新的生命开始。这样，胎生要有父、母，要依赖父母间的增上力。所以这样的生命开始──‘托胎生’是有情所依的共事。
    二、“名言”，这里的名言，指我们的语言、文字而说。不管造的文字，怎样合理，写的怎样好看，如只是自己了解，别人都不识，这失去了名言的作用，不能有所表示。如语言的音声流变，彼此间完全不能了解，也不能成为语言。要知道，语言也好，文字也好，都成立于人与人间，由于彼此互相了解，渐成为共同承认，共同应用的名言。如语言，一地区有一地区的语言，一时代有一时代的语言，在这同一地区，同一时间中，人与人间所说的，大家习俗相传，共同承认、了解这句话；你说我也懂，我说你也懂，成为一种表示意义的语言。语言──名言，是表达我心里所了解的，觉到什么，就说出来使你了解。这句话表示的意义，彼此间有共同感，所以能互相沟通感情，传达种种知识，可见语言──名言是共的。文字也是如此，不是圣人造好一批字，让大家去使用。文字是渐渐传出，孳生而日渐增多起来。文字的意义，大家公认了，在人类界应用起来。文字是不断演变的，字形与意义都在演变中。有时误写或误解了，习俗以讹传讹，被大家误认了，还是一样用。错就错了，只要大家公认就得。所以文字──名言，是有情界所共依的。古代文字，都出于人的偶然应用，渐被大众所接受。近代文明，或新发现一种元素，成立一种事实，都给以一个名词，后人照著使用，这名词就为大家所通用了。总之，名言要彼此间共同了解，承认，这不管中国、外国、古代、现在，都是一样。名言是成立于有情间的，所以是共的。
    三、“摄受”：这是组织，也是领导。如老师教学，许多学生来跟他学，老师摄受学生，形成师生关系，这就是摄受。在佛法中，老师摄受弟子，是摄受的一种。如家庭，有家长领导，成为一个家庭。不论人少人多，在社会中，每一社团，都有领导者在摄受。国家，佛教的僧团，都是一样。这是多数人能集合起来，中间有一种向心力──摄受的力量，使大家能联结于同一范围之内。彻底的说起来，畜生间也有摄受的。我在四川看到，老猴子在前来了，母猴、小猴子就跟著来。凡是群居的有情，都有摄受力，建立起彼此间的集体关系。这当然是有情界的共。
    四、“治罚”：是摄受，那就不是个人，而是彼此间的组合了。不管这组合是宽松的，或严密的，既是组织，为了维持此团体的健全，发展，不论大小，都会有成规。所以有句话说：家有家法，校有校规，国有国法。如组织内的成员，所作所为而可能障碍破坏此组织，那就要受到组织的制裁──治罚。以国家说，即是法律，以法律来处罚。在佛教内，出家以后，加入僧团，成为僧团的一员。在僧团内，受到佛制戒律──学处的约束。如违犯了，就要受到僧团的治罚。有了摄受，就有治罚。家有家法，学校中有校规，宗教有教规，国家有法律；现在成立的世界性组织，国与国之间的联合组织，也就有国际的制裁。这是有情界的共同。
    五、“饶益”、六、“违害”：这二事，是相反的。什么是饶益？能给他一种利益，使他得到好处，是饶益。什么是违害？能够给他一种损害，使他感到苦恼，是违害。举例说：别人经济有困难的时候，能够帮助他，或救济他，就是饶益。如赖了他的钱，或想尽不正当办法以取得别人的财物，这就是违害。饶益与违害，都建立在有情的共同关系上。凡是对他有利的，或是物质上的，或是精神上的，或是知识上的，或使他的身心健康，人格进步，只要是能使他得到利益的，这一切都是饶益。相反的，凡是使他困难的，引他堕落的，或杀他，打他，骗他，谤他，只要是使他受到损害的，一切都是违害。
    七、“功德”、八、“过失”：这又是相反的。过失，不好的事情，错了就有罪过。反之，有了好的事情，有功可得，就名为功德。功德与过失，都是依有情与有情间的共同关系而成立的。什么是功德？如布施，或供养三宝，或救济贫穷，或办理社会文化事业，这都是功德。或说在家里孝养父母，受持净戒，这些好事，都是功德。相反的就是过失，如不孝父母，刻薄剥削贫人等。
    那末，这饶益与违害，功德与过失，有什么不同？饶益与违害，是约对他的意义上说的。使他得到好处，使他得到损害，是饶益与违害。如约自己说：做了好的事情，自己可得到功德；做了不好的，自己就有了过失。功德与过失，能使自己得到幸福与苦难的结果。饶益与违害，功德与过失，虽有约对他说，约自己说的不同，总之都是建立在有情与有情的共同关系上的。如果离开了其他有情，专讲个人的话，这功德与过失很难讲。一个人关起门来做，没有共同关系，没有共的意义，这功德与过失亦建立不起来。所以在佛法之中，说的好事，如不杀、不盗、不淫、不妄语等，那都是与有情有关系的。说不好的：如杀、盗、淫、妄语，种种都是与有情有关系的。
    上说八事，在有情彼此之间，都有“互”相“增上”，“互”相“为因”的力量，造成有情与有情的“共”同关系。如托胎生，在人类，构成了宗族生命的延续。名言，促成人类的感情与知识，相互交流。以此而摄受成为群体，有家庭、社会、国家等。为了维持团体，所以有法制治罚。彼此间有利有害；也就有功德与过失。这一切，成立于有情与有情的共同关系上，所以说是所依共。
    依及诸了别，苦、乐、业、死、生，系缚与解脱，彼九不共故，名不共所依。
    有情界的不共所依，有九种，多数是佛教的术语。
    一、“依”，依是依止。有情自体的依止，是业力所感的果报识，也是持有一切种子的种子识，形成有情的生命主体。依唯识学说，阿赖耶识就是依。摄大乘论中，第八阿赖耶识，名为所知依，是一切法的所依止性。本论没有明白说到七识、八识，但也提到一切种。关于心识，现在简单的说一下。大乘唯识学说，就我们的心识作用分别起来，是前六识及第七、第八识。前六识是：眼识、耳识、鼻识、舌识、身识、意识，是大家所容易了解的。如我的眼看到了什么色──形色、显色，引起的认识作用，就是眼识。耳根听到声音，引起的了别作用，能了解这声音的，就是耳识。鼻识了别香臭；舌识了别滋味。身识是身体接触到物体，感觉到硬、软、热、冷等，能够了别到这是什么，这就是身识。意识是忆念过去，想像未来，或了别现在；不只了别具体事相，还能推究法与法间的关系，法则义理等，都是意识的作用。这六种识，从小乘到大乘，是佛法所共说的。
    大乘唯识学，更说到二类很微细的识，依现在的知识来说，是属于下意识，或潜意识的。在自己能感觉得到的心理活动──六识以外，还有微细潜在而不易觉察的。二种细识中，第七识名末那识，是深细的自我执著，直觉得有自己存在。最深细的自我觉了，就是第七识。第八识名阿赖耶识，一切种子依阿赖耶识而存在，依阿赖耶识而显现。从阿赖耶识所有种子而显现的，是器界及一切识，所以成为一切法的依住。阿赖耶的意义是藏，如库藏一样，有东西就放进去，要用就向里面拿。所有一切的认识，都留下潜能，藏在里面，有缘再显发出来。藏入又发现出来，成为一切意识一切法的根源，所以名为阿赖耶识。
    依唯识学说，依是阿赖耶识，是业力所感的果报识，现起一切的种子识，所知一切法的依住处，所以名所知依。不过照中国一般所了解的，唯识学一定说七识、八识；其实不一定如此。在印度，唯识有二大派：一派名随教行派，就是依经文怎么说，就怎么说；这依经说的一派，都是立第七识与第八识的。另一派名随理行派：以为经文所说，每有随机方便，不了义说。随理行派以理为宗，如世亲菩萨门下的陈那菩萨，是‘因明’──佛教论理学的权威；陈那的弟子名法称。这一派说唯识，不立七识、八识，也还是一样的唯识学。不过在中国，这一派没有传来。如立第七识、第八识，依一切种、果报阿赖耶识为“依”；如不立第七识、第八识，那就依异熟──果报意识为依。在部派中，如说一切有部，立“命根”为有情依。
    二、“诸了别”：了是明了，别是区别，了别是我们有认识作用的那个识的作用。为何名诸了别？了别识不止一种，如眼识、耳识、鼻识、舌识、身识、意识，这六识就是六种了别。立八识，七识与八识也是有了别作用的，不过阿赖耶识重在“依”，前六识的了别作用强，所以了别属前六识。心识的了别作用，都是不共的。我的意识不是你的意识，你的意识不是我的意识，眼识等也如此，彼此间各各不同，所以六识了别，是有情界各各不共的。
    三、“苦”，四、“乐”：苦与乐，是情绪上的一种感受，受蕴所摄，是内心的情绪作用。我感觉到苦痛，别人不一定感到苦痛；我感到快乐，别人也不一定在快乐。如到了八月中秋，明月圆满的时候，大家去赏月，有人看到月亮，欢喜极了，又亮、又圆，心里说不出的欢喜。但有的却对著月亮，在淌眼泪，心里难过得很。触对境界，各人的感受不同，情绪不同。看到月亮时，内心引生的苦乐，是有情彼此所不共的。又如上山，自己不想上山去，父母或师长的命令，“去！非去不可”！不去不成，只好上山去，一面走，一面心里不欢喜，满心不快活。如自己要去上山，越走越有兴趣，即使腿酸，心里还是欢喜的。同样的环境，同样的了解，但所得的苦与乐，彼此间是不相同的。从业感得苦果，或得福乐的果报，在有情间也是不共的。
    五、“业”：业是什么意思？业就是事业，作事。不过佛法里所说的作业，范围比较大：身体所作的是身业，口说的是语业（写出文章来，也是业），内心的动作是意业。总之，身心的一切动作，都是业。通泛的说，业与其他有情相关，但这里所说的是：自己怎么做了，引起一种力量，能影响自己──现在或未来，受苦或受乐；这种造作的力量，就是业。如布施、持戒、忍辱等，凡作善事，当下留下善的力量，潜藏在自己身心内，这就是善业。杀生等不善业，也是这样。身语意三业，是各人自己造作的；留下的业力，也是你是你的，我是我的，各各不同。有情所造的业，是彼此不共的。
    六、“死”，七、“生”：各人生，各人死，生死是各人自己的事情。向来说，真正无常到了，到了要死的时候，什么人都代替不了你。自生自死，是各人自己的事，与别人无关，所以是不共的。
    八、“系缚”，九、“解脱”：什么是系缚？系缚如被绳索捆缚住了；系缚是解脱的反面，解脱如把绳结解开脱下一样。
    如人生不自在，受束缚而不得自由，有一种力量把我束缚住了。在种种束缚之中，要生出来，就不能不生；生了以后，就受制约，受支配，终于又不得不死。如生在人中，就是一个人；当然人的能力有大小，知识有强弱，境遇有顺逆，可是总有个限度，怎么也超不过这人的限度。人生出来以后，就有一期的延续，经过老、病阶段，最后还是不能不死。死了以后还要生，永久是个生了又死，死了又生的局面，这就是系缚。被什么束缚住了？还是自己束缚自己，自己的迷妄，自己的烦恼，自己的错误行为，自己系缚自己而不得解脱。
    解脱也是自己的事，谁也不能使你得到解脱。所以楞严经中说：佛的堂弟阿难说：我是佛的堂弟，佛很喜欢我，总想佛能帮助我解脱，可是事实上却不可能。所以学佛的人，向来有两句话：‘各人吃饭各人饱，各人生死各人了’。系缚生死是自己的事，解脱涅槃也是自己的事，都属于有情的不共。
    依与了别，是有情自己的心识问题。苦、乐，是情感的。造了业，所以有死，有生，或系缚而生死不了，或解脱而证得涅槃。这“九”事是“不共”的，所以“名不共所依”。
    悟入二取似现非有 共现外所取，实即能取识。以离其内识，外境义非有，是共同性故。
    六相中第六，悟入二取似现非有，为说明生死法为唯识所现的重要部分，共有六颂，次第的加以解说。先明所依共的不离内识：‘共现外所取，实即能取识’等，是约共所依说。共是山、河、大地，草、木、丛林，星球，一般人所认定的客观物质世界；还有有情不共中的共，如胎生等八类，那主要是人类社会文明的事情。
    以唯识学来说：‘共现外所取，实即能取识’。山、河、大地，草、木、丛林，种种星球，宇宙间的无边世界，这一切所依共的器世界，是有情内识共同所现起的。依小乘说，是共业所起的；依唯识说，是心识中业力所现起的。有情与有情间，“现”起“共”同相，“外”在相，成为心识“所取”的外境，觉得有一心外存在的世界。一般人都觉得这是在我们心以外的，所以说唯识不容易理解；如说这是在外的物质世界，大家都觉得是对的，因为每个人都是感觉到这样的。可是，依唯识说，这是“实即能取识”。一般所感觉到的外在境界，实在是我能取心识上所现的境界。换言之，所取的外境，实际是我们能取心识所表现的，就是我们的心识。
    明明有所取的外境，为什么说就是内识呢？因为“以离其内识，外境义非有”。我们所见到的，听到的，我们所了解的所谓器世界，好像是在心外的，其实如离开了我们的内识，没有内识的活动作用，那外面所取的境界，就不可能成立。换言之，我们所以知道有这客观存在的器界，因为有心识作用而发现出来，如没有心识，根本不知道有什么外界的存在，所以说，离去了内识，外在境义是没有的。
    弥勒的唯识学，是建立在‘认识论’上的。譬如说：我们所认识的什么，不是直接得到那东西，是心识上现起的所取影像，这影像并没有离开了自己的心识。例如颜色，红的是红的，黄的是黄的，以为确有红、黄等色彩在外面。其实红的、黄的，都是我们的眼根，引起眼识所现的。由于人类眼根的共同性，引起眼识所现，也有共同性；我们就以为事物的本身，就是这样红的、黄的。关于外境不离内识的唯识论，弥勒、无著、世亲等菩萨，都有严密的论证。本论下文也有很好的说明。但不要误会，现起所有的外境，唯识学并没有否定他，只是说这是不离心识而存在的。
    器界等外境，是不离内识而存在的，这是唯识的定义。一般人总觉得：既如此，为什么你看到红的，我也看到红的？不能由个人主观、片面的来决定，所以是客观存在的。即使你不知道，没有见到，大家也还见到是红的。为了解释这一疑问，所以说：“是共同性故”。共同，是我的心识现起来的印象如此，你的心识所现起来的印象也如此，大家现起来的印象都是这样，有一致的共同性，所以觉到不因个人的心识而改变，这才误解为客观实在的外界。
    因为你是个人，我也是个人，中国与外国人都差不多，看起来样子不同一点，其实是差不多的。我们的眼睛有共同性，也不是一切有情共同的。人与人之间有共同性，畜生中一类一类都有其共同性，鬼与鬼，天与天，都有其同一类的共同性。所以同类共见的，似乎确实如此的器界，在不同类的有情中，因不同的识类而器界相有所变化了。共同性的随类而不同，也可以说明外所取非实的意义。
    于余不共识，为所取等义，谓他心等法。
    上文说：所依共的，是山、河、大地，草、木、丛林，星球等器界；所依不共的，是有情界。有情界中，有共义的，是托胎生等八类；不共的是依，诸了别，系缚，解脱等九类。器界及有情界的共义，能为其他的有情所了别，是唯识所现，已如上说。“余”如有情“不共”的心“识”，也能“为”其他有情所取，成为他有情的“所取”“义”──境。他人的心，被别人知道如何如何，他心就成为所取的境界──义就是境界义。不共而成为所取的，不只是“他心”，如他有情的生与死，烦恼的系缚，烦恼的解脱，苦与乐等，都可以为他有情所取。为所取的内容不少，所以说‘为所取等义，谓他心等法’。谓他心，是别人的心。有情的心，是各各不共的。我知道你的心，或你知道我的心，难道我的心，成为你心识上的境界吗？又如意识能知道眼识，耳识，鼻识，六识是不同的心识作用，也不能说眼识，耳识，鼻识等，就是意识所取的内容。以心知心──甲有情知乙有情心，或意识知眼识，这能说唯是内识所现吗？这一问题，依大乘唯识学说：每一有情，都有他的心识活动。说唯是有情各各有识，而在各人内心有所了别时，都是自识所见的，所以是唯识的。进一步说，他有情心，不是直知他心，而是在自己心中，现起他心的活动情形。所以知他心，是在自己的心识上，现起他人的心象，自心所能取的，就是自心所现的，所以知他心等是唯识的。
    诸能取识前，更互非境故；于非等引时，自分别现故；于诸等引前，三摩地行境，现彼影像故。
    上面说明了所依共与所依不共的，不离内识，都是识所现的，所以生死一切法唯识。但所说唯识，不是唯一识所现，而是种种心识的种种现起，所以又说此二颂。现在先说明二个名词：‘等引’，‘非等引’。一、等引，印度梵语是三摩呬多，译义为等引。等是平等，引是前后的引续，引发功德，等引是殊胜的定。说到定，梵语名三摩地，简译为三昧，意义是等持。什么叫平等？原来，一般的心是不平等的，不平衡的。心是散乱的，妄想纷飞，修定是精神集中，系念一境以息除妄念。但心是不平等的，平常是散乱，要他不散而归于一，又易于昏沉，什么都不解了，进一步就是睡眠。如将心提起，心又向上飞扬──掉举。不是掉举，就是昏沉；不是偏于这边，就是偏于那边。不能保持心的平等安和，就不能得定。学佛而要修定的，要修习到内心平等，不散乱，也不昏沉；不起种种分别，却又明明白白，这就是平等持心的等持。由于心的定──等持，引起平等的前后延续，引发定中的种种功德，所以名为等引。静虑（四禅），等至（八定），等持（三三摩地），解脱（八解脱），这些胜定，都名为三摩呬多──等引。二、非等引，即一般的心，或是昏昧睡眠，或是散乱、掉举，凡没有达到等引境地的，都名非等引。唯识，不是一识所现的，不但自心与他心不同，眼识等与意识不同；在意识中，定心也与散心不同，不同心识上各现所取，所以一切是唯识。
    现在来销释颂文。‘诸能取识前，更互非境故’。能取心如上说，自心与他心，眼识等与意识，等引心与非等引心，是各各不同的。如等引的能取识现起的境界，在定心中，定心所取的境界，与非等引能取的境界──散心分别所取的境界，是彼此不同的。在定心不取散心的境界，散心也不取定心的境界。所以说等引境，非等引境，在不同的能取识前，彼此间是互不为境的。换言之，散境是散心的境，定境是定心的境，彼此不同的。例如我们的臂上，用针刺一下，一般人会觉得很痛，那是散心分别所取的境。如这人受了催眠，或是入了定，那针刺下去就不觉得痛，那是催眠状态的心境，这可见各各取境不同了。
    再分别来说，等引的境，与非等引的境，是怎样的唯心所现？“于非等引时”，也就是散心分别的时候，所取境是“自分别现”的。自己分别心所现起的，是分别心所知道的境界。分别心所取的，离了分别心所现的境界，那就没有了。换言之，一切分别心所取的，不离分别心所现，这是说非等引境是唯识所现的。
    上面说到，四禅是等引，八等至、三三摩地、八解脱也是等引。等引有种种，所以说“诸等引”。通俗的说，种种等引，就是种种定。定境与散心境是不同的，在诸等引心前，所取的是“三摩地行境”。三摩地──等持所行境，就是定心所行的境界。定心所行的境界，与散心境不同，是从定心所现的，现起彼定心的影像。定心所现起的影像，如明镜当前，现起种种影像；影像，专指定心所现境说。现在举一个例子来说：有大乘经，名‘般舟三昧经’，这是一心专念阿弥陀佛的法门。念，是心系一境；念佛，这里是专念阿弥陀佛，不是称名。专心系念阿弥陀佛相，念到般舟三昧成就时，十方一切佛现在前（所以名般舟三昧，般舟是在前立的意义），明白的见到，如夜晚见天空中的繁星一样。这不是开眼所见，而是定心所现的境界。依经中说，不但见佛，也与佛问答，他说：应发愿往生西方极乐世界。后来，得般舟三昧的，就于定中观察自己并没有到西方去，阿弥陀佛也并没有来，自己所见所闻的，只是唯心所现。我举这个例子，最容易明白。修定的，或修般舟三昧，念阿弥陀佛的，初修习时，系念的相现起，起初相是不分明的，动摇的，那是因为心不定；等到你心定了，眼睛也不再动的时候，相也明显、不动了。如阿弥陀佛，‘相好光明无等伦，白毫宛转五须弥，绀目澄清四大海......’。这境界太广大了，初学不易成就，可观阿弥陀佛像。如佛像──紫金色，白毫相等，一一分明，能放光，会说话，那是已到达定境。
    佛法中有不净观，静观死尸的相，慢慢变色，青瘀，腐化，流脓血，末后仅存白骨。像这种不净相，如修习到不净相现前，清清楚楚的见到相，甚至于见到处处是不净相。这就是依不净观而得定。
    凡定心成就，都会现起定境（随定的差别而不同），名为影像。佛在解深密经中，给弥勒菩萨说的极清楚：‘由彼影像唯是识故。善男子！我说识所缘，唯识所现故。......此中无有少法，能见少法，然即此心如是生时，即有如是影像显现。......如是此心生时，相似有异三摩地所行影像显现’。所以诸等引前所现的，都是三摩地行境，“现彼影像故”。
    定心所现境，是确实有作用的，如修得火光三昧，望去会有一片火光。修水三昧成就的，别人到他住处，会见到一房子的水。这种境界，都是三摩地行境，是从定心所现的影像。
    散心分别的人，要使他知道唯心所现，好像很难，要用种种推理去了解。如修禅定而有成就的，观什么能在观心上现前。如修青一切处，见一切都是青的；黄一切处，见一切都是黄的。成就禅定的，容易悟入一切境界唯心所现，以一切是随心而转的。如禅定力深，心力强，更容易悟解此义。唯识学成立唯心所现的理证中，就有以瑜伽师修行境界随心而转，来证明唯心所现的。唯识学，不是为了学理，而是佛弟子的修习定、慧，从经验中发现来说明的。一切所取境，唯是心识所现，为了说明此理，所以特别以等引、非等引境界，来说明都是唯识所现。上来所说生死依止的共与不共，说明所取的境，唯识所现，所以所取境义，是非有，不可得的。现在要进一步说，能取也不可得，如颂所说：以所取若无，亦无似能取。由此亦成立，无似能所取。
    一切境界都是唯心所现的，一切境界离心不可得；一切境界不可得，那就唯是心识了，这个心总是实有的了！然依唯识说，‘以所取若无，亦无似能取’。“所取”的境如不可得，“能取”识也就不可得了。一切境界，唯识所现，为什么没有所取境，能取心也不可得呢？其实，心与境，从来是不能分离而有的。要知道心识起来时，心里决定现起那境像，心识是不可能没有认识对象的。所以平常说我们什么都不想，这话是不通的。因为有心必有境像，觉得什么都不想，这什么都没有，就是心的境像了。否则，就是昏睡，分别心也不起了。换言之，有能取，一定有所取；如没有所取，那一定没有能取。所以说，心境从来是不能分离而有的。佛法中，小乘也是这样说的。当境界生起，一定有心缘于境界的；心生起时，境界是心的缘──所缘缘。所以，心与境，要起就一起起，不起就都不起。若依中观家说：心境是因缘所生的，也是‘离心无境，离境无心’的。唯识学在方法上，有他的不同处。先说以虚妄分别有，有能取识，所取依能取而现，所以所取境不可得。进一步说，如没有所取的境，能取心也不可得。所以说：“由此亦成立，无似能所取”。如没有似所取，也就没有似能取，能取、所取，都只是虚妄显现。
    空宗与唯识宗，有一根本不同处。唯识学一定要这么说：所取的境界不可得，因为一切都是内识所现的；有识无境（尘），正是唯识学的特色。然进一步说，如境界非实有，能取也不可得，这就进入能取、所取都不可得，显示无二、无别的真如法性。这一层次，真谛三藏解说为方便唯识与真实唯识。空宗依因缘所生法显平等空性：心是因缘所生，境也是因缘所生；如说空，心也空，境也空；如说有，心也有，境也有，保持心境同等的立场。可以说，这是菩萨们说法的方式不同，虽在胜义中，心境并冥，都不可得，而在世俗安立中，或出发于境依心立，或出发于心境更互缘起而有，引出宗派的各别。唯识学出发于依识有境的立场，所以说境空心有。到了能取所取都不可得时，也是说识寂、识不起、识不现，却不说心是空的。如说境空故心也空，就觉得这是恶取空，因为不能成立一切法了。
    唯识宗成立唯识的层次，也就是修唯识观的次第，达到无二无别的，平等真如法性。弥勒菩萨在辨中边论中，说得还要清楚，如说：‘以识有所得，境无所得生’。那是说，由于虚妄分别识有，所以知道境是不可得的。‘依境无所得，识无所得生’：那是说，由于境不可得，所以识也不可得了。‘由识有得性，亦成无所得，故知二有得，无得性平等’：心不可得，境不可得，似有能取所取──心境二者，在无得平等性中，是无二无别的。上面所说的，就是悟入虚妄分别无相的方便。楞伽经立四种禅，也是这一意义。四种禅中，第一名愚夫所行禅；这是外道、小乘的禅观。第二名观察义禅，就是观一切境相（义）不可得。如观境不可得，心也不可得，现起平等空性相，是第三缘真如禅。因缘真如空无性相，有空相在，还不是真知真如，等到空相也不起了，超越能所一切相，才是真实悟入真如，就是第四如来禅。凡是说唯心（识）的，从初修到悟入，都有这样层次的。
    然由无始来，等起而成立，二取悉非有，亦善成立故。
    这里引起一问题，既然所取不可得，故能取也不可得，心境都非实有，为什么众生生出来就有心识作用，而且有心同时就有境，永久是心境相对而起呢？依佛法说：“然由无始来，等起而成立”。先后引起，名为等起。先如此，后如此，如生死不得解脱，以后还是如此，这名为等起。我们前念起时，有心也有境，后念起时，还是有心、有境；死了以后再生时，还是有心、有境。永久是有心、有境。所以说，从无始以来，一向如此。心生时，自然而然的，似现能所二取，是由无始以来就这样的。佛说无始以来，始是开始，佛不是说最初如此。生活在虚妄分别之中，生活在一个时间观念中。我现在这样，前生还是这样，前前生还是这样。起初为什么会这样？佛不说最初是怎样的，因为在时间观念中，求开始是不可得的。所以论到最初，释迦牟尼佛是‘无记’，不加答覆的。无始以来，一向如此。现在应把握现实，去解决生死问题。如说最初如何如何，那是神教而不是佛法了。为什么我们现起能取所取？简单说：无始以来一向如此，一向是不起则已，起则有心、有境，前后等起相续，所以现在也是如此。
    我们心起时，有能取、所取，有心、有境，一向如此，怎么知道“二取悉非有”呢？心起时，就有所取相现，由于不知境依心生，不知唯识所现，在能取所取关涉时，认为是心外有境的，起种种执著──遍计所执性。分别执著时，留下一种力量，就是能取、所取的潜能──遍计所执种子。这是从执著心外有境而来的，所以能取、所取种子，依缘而现起时，能取心中就有所取相现。这样的依现起而执著，依执著而薰习，引起后后的现行，从无始来一直到现在，生死轮回，永久如此如此。既是如此，解悟二取的非实有的道理，也能“善（巧）成立”了。因为我们心起时觉得这能取、所取是各别的实有性，所以会薰习为种子。虽然虚妄现起，却好像心、境都实在是有；如知道非实有的，就不起执著，不会薰成遍计所执种子。薰习的力量，愈来愈微薄，终于到达二取都不现的实证。举例说，如知道自己在走路、坐下，或说话的态度不太好，能知道就会注意改正，过了一个时候，更正了，不再会有不好的态度了。所以，不知道，会一切一切的一直下去；如知道了所取、能取非实有的话，就可以达到解脱。能达到能取、所取不可得，就因为能取、所取是虚妄分别，实义是没有的。依唯识现，成立生死流转，也就依唯识现，所取非有，能取也非有，观二取都非有，而通达法性。
    上来依生死法，明六相，了达虚妄分别，悟入法性。法性的意义，如下所说。


1.22 辨涅槃

    1.22 辨涅槃
    1.221 标列 由六相悟入，法性为无上：谓相、与依处，抉择、及触证，随念、并悟入，到达彼自性。
     已说生死、法事，以下说涅槃、法性。通达悟解法性，是依于正方便的，本论也以“六”种“相”，为“悟入法性”的“无上”方便。六相为：一、相，二、依处，三、抉择，四、触证，五、随念，六、悟入到达彼自性。
    一、“相”──是义相，法性的义相。
    二、“依处”──依什么而能够渐渐的悟入法性？如生死的流转不息，要有所依止，所依共，所依不共，就是这有情界、器世界，是生死流转的依处；悟入法性、得涅槃，也同样的要有依处。
    三、“抉择”──抉择是智慧的作用；般若悟入法性，般若──慧以抉择为性。择是选择、简择，如选择物品，这是好的、要的，那是不好的、不要的，这就是择。抉是抉发，将正确的事理，抉发出来，显示出来，这是抉。抉择是般若──慧的观察作用。如七菩提分中有‘择法’，也就是抉择法。
    四、“触证”──触是直接的接触到，证是证实。法性不是名言，不是听到，理解，而是般若的直接的触证。例如一杯蜜，要真的尝到了杯中的蜜味，才是触证了。这里说触证法性，触证的触，与色、声、香、味、触、法的触不同，这触是法性──真理的亲切体验，中国学者每称之为开悟，或证悟。
    五、“随念”──随念，依过去所得到的，随顺系念不忘。随念，是修行的方法。
    六、“到达彼自性”──经修行而达到究竟。自性，就是法性，也就是涅槃。法性是胜义的自性，就是体验到这自性，究竟圆满的实性，唯识学名之为圆成实自性。
    1.222 别释
     （1）相相如略标说。
    以下别说六相。法性的“相”，在“略标”中已“说”过了。法性相是：没有能取、所取，没有能诠、所诠；不是语言可说明，不是思想可分别理解的。超越一切相对的名言，相对的能取所取，是绝对的，无二无别的真如性。
    （2）依处 处谓一切法，及一切经等。
    “处”，是依处。依于什么，才能悟入法性？论说有二：一、依“一切法”；二、依“一切经等”。什么是依一切法？法是形形色色的一切事。如山、河、大地，草、木、丛林，国家，社会，家庭，个人等，只是复合的假有。如分析一切法，凡有一一特性的，如色法有青、黄、赤、白等色，心有眼等识，贪、嗔等心所，这都名一切法。现在而外，过去、未来的也是法。阿含经曾说：如于一法不通达，就不会证悟的。这是说，要证悟，须证知一切法性。但一切法如此多，怎能一一都通达呢？一切法虽多，但法性是通相，是遍通一切的，能通达一法性，就通达一切法性。一法如此，法法如此，凡是证悟的，没有悟此法而不悟彼法的。悟一法，即悟一切法，约悟入法的实性说，并不如某些人所误解的，以为悟了什么都知道。现象界无限差别，怎能一切都知道呢？一切法的法性，平等法性，是无二、无别的，是依一切法而触证的。
    小乘──声闻学者，急于解脱三界生死，如说：‘三界如火宅，生死如怨家’。佛给以简单扼要的方法。身心以外事不问，专从自己身心去观察自己。观自己身心为无常、苦、空、无我（这是生死法的通相），体验而得解脱。所以小乘学容易，简单而扼要，但身心也是一切法（身外法也不外于此），还是依一切法的。大乘广观一切法空，不生不灭。如大般若经说：色、受、想、行、识──五蕴，十二处，十八界，凡夫事，二乘事，菩萨事，成佛的事，一切一切都为般若慧所依。大乘唯识学，所以说悟入法性，平等法性，要依于一切法。
    第二是依一切经等。无论是身心以内的，以外的，一切法一直呈现在我们的心识之前，我们不知道法的真相，所以不能得到解脱。唯有依佛的开示，菩萨等圣者的开示，才能得到应遵循的正道。所以说依一切经等，不但是经，还有菩萨的论，经与论都是悟入法性所依止的。经是非常多的，如持一部经，能解脱生死，成佛，还简要容易，依一切经，那问题可大了！小乘法虽可以简持而入，大乘却不能如此。菩萨发心，无量法门誓愿学，一切法门都是菩萨所要学的。因为佛所说的法，是适应众生根机的：或是人、天世间法；或是为声闻、缘觉说的；或是为大乘菩萨说的。所说的法，或是通途大道，或是说迂曲的路，或是便道小径。佛说无量，有方便，有真实；有权教，有实教；有了义，有不了义。适应众生无边根性，说无边法门，菩萨要利益一切众生，众生根性不一，怎能专学一经，一佛，一咒？如卖帽子的，如拿一顶帽子，要人人都适合戴上，那是不成的；如为大众著想，大小都得备有。学大乘法要依一切经典，理由就是这样。所以西藏黄教──达赖、班禅一派，依一切经论从五乘共法到三乘共法，再到大乘不共法。统贯一切教法，次第深入，正是依一切经等的好榜样！
    依一切教典，一切法门，愿学无量法门，就是菩萨通达法性所依的方便。部分中国佛教的观念，有些不同。以为证悟，证悟可说么？不可说。可思惟么？不可思惟。修学经论，是要分别的，那不是愈分别愈不对吗！所以讥为‘以水洗水’。如不可说，所以非文字相；非能取、所取，所以非心缘相，于是有直下不作分别去参证的方便，这是中国禅者的见解。唯识是印度佛学，不是这样说的。要悟入法性，须依一切法、一切经去闻思修学。这不是分别么？不是分别更多吗？依印度所传佛法，小乘、大乘，唯识与中观，都重视闻、思，依分别入无分别，依名言入离名言，依世俗入胜义。如一切不加分别，无知无见，怎能方便证悟法性呢？例如要去总统府，先要分别：向东或是向南，向中正路呢，还是南京东路？左转或是右转。要知道路线，才能到达总统府。到了总统府，总统府自身，没有东南西北可说，可是如没有东南西北的指示，怎么也不能到达的。总统府自身无所谓东南西北，却要依东南西北的指示才能到达，这就是方便。佛能化度众生，就有赖方便。法性是无能取、所取，无能诠、所诠，却说种种法门，从了解分别中，引导趣入，这就是佛的伟大，不可思议的方便！
    （3）抉择 其中抉择者，谓依大乘经，如理作意摄，一切加行道。
    有人说：我会读经，我藏经看过一遍，看过几遍的也有，但不一定有用。要知道经是佛说的，是应机说法的，经义有著多样的应机性。如自己去阅读，或从师长那里去听，这都是闻。无论是读是听，经上这么说就以为这么说，这问题可大了！佛经中，佛说这部经是经中之王；那部经也说是经中之王，到底有多少王呢！有的经上说：这样理解，这样观察，才是正观，不作此观，就是邪观；可是其他经中，所说的邪观、正观，又不相同，那又怎么理解呢？有的经说：一切圣人都从此来，非依此法门，不能解脱生死、不能成佛；同样的话，又在别的经中说。所以经上这么说，我就这么了解，那是不够的。学佛的，初学一部经，非常欢喜，肯定佛法就是这样。学了二部、三部......更多部以后，却反而弄不清楚了。所以佛说：修学一切经法，要进一步去思惟；思惟了还要修。思惟与修习，就是抉择。
    说到“抉择”，就是“依大乘经，如理作意摄，一切加行道”。悟入法性的抉择方便，含有‘如理作意’与‘加行’二义，这都是依大乘经的。经论所说作意，略有三类意义：一是注意，如作意心所。二、作意是修定时，内心的观想系念。三、这里的作意，是思惟，思考抉择的意思。平常说，学佛法有四条件：一、亲近善友（善知识）；二、多闻正法（多多的听法）；三、如理思惟（如理作意）；四、法随法行，就是依法修行大乘经法，经如理思惟，然后依著作止观的修行，就是一切加行道。
    如理作意是什么？经典有深、有浅；有究竟说，不究竟说；有尽理说，不尽理说；了义说，不了义说。究竟说是彻底的，不究竟说是不彻底的。尽理是说得很彻底圆满的，不尽理是这么说，其实是不完全如此的。例如说，吃饭能滋养身体，这是对的，但是不彻底、不尽理的。如吃饭过饱，可能反而吃坏了。可见这句话，是有相对的意义，却不是彻底的。又如有人头上生有一块黑疤，就名之为黑人，其实别处都是雪白的。世俗语言，大抵是不尽理的，经典随俗说法，有些也是如此。所以，对佛法要如理作意，要依彻底的义理来思惟，如依不彻底的义理来思惟，那就错了。不要以为经文如此说，就可以以此为标准！
    佛的经典分二类：一是了义经，一是不了义经。了义经是究竟彻底的。如所说的，还要再解说，再补充，这就是不了义的。所以如理作意，是依了义，不依不了义，以了义经义去如理作意，才能得到大乘法的究竟意义，也能解说不了义经。如理作意是思慧的作用，分别，观察，以获得佛法如理的正见。经法虽多，如依了义经为准绳，可得佛法深义与方便。摄持一切佛法，化繁为简，渐渐的脱略文句，而系念法义，然后可以实行，可以从观察中显现法义。抉择的如理作意，能成就思所成慧。思惟还是散心分别的，如能在定心中思惟，依定心分别观察，这就是修所成慧；依修所成慧，能得般若的现证法性。佛法从阿含、中观、瑜伽以来，都说止观，都说分别、抉择，从闻到思，到修，然后到证入。不过，不是什么分别都可引入证悟的。世俗的分别，止与观，即使有助于佛法的修持，也不能证悟法性。佛法有特殊的观察──胜义观，能遮遣我们的虚妄分别，这才能依分别而契入无分别。依唯识学说，这就是要观察所取无性，能取非有，所取、能取都不可得。如理作意，要从虚妄分别，现有能所取而实不可得去理解，了解决定，坚信不疑，成就深刻的信解，才依之而起修。
    加行是什么意思？广义的说，加行就是一种功用，努力去做。依这一意义来说修行，修福、修慧都是加行。但加行有一特别意义，就是从凡入圣，所用思惟，观察；修止，修（胜义）观，在没有悟入以前的一切，就是加行道。从凡夫到成佛，唯识宗分成五道：一、资粮道：广集无边福德、智慧资粮，菩萨要自利利他，备一切功德，所以凡是福德、智慧，应尽量去修集。依唯识说，这要修行一大阿僧祇劫。二、加行道：分四位，暖、顶、忍、世第一法。四位时间不太长，就在一大阿僧祇劫的后期。三、见道：经加行道的修习，现证法性，如实的体见了真理，名为见道位。四、见道以后，随顺所悟而修习，名修道位，要经二大阿僧祇劫。修到究竟圆满了，究竟成佛，就是第五、究竟道。这里说的，是加行道，要依大乘经如理作意，再经暖、顶、忍、世第一法，渐观二取都无所得，所修的加行，就是唯识观。一般说，先观所取性空；再观能取也不可得；达到了能取、所取都无所得，但还有无所得的空相现前；等到空相也泯寂不现，那就证悟了。
    依处与抉择，包括了闻、思、修；抉择是思、修二位。闻、思、修三阶段，古人譬喻为：如人学习游泳，起初要抱木棒习游，如闻慧要依文句。渐渐游了一时期，木棒可以有时放下，有时抱著，如思慧的依于文句，或可不依文句。最后不要木棒，也会游泳了，如修慧的依义而不依文句。这三阶段，第一阶段是闻，一定要依佛所说的教典，或是菩萨所说的。第二阶段是思惟，依照经文，却慢慢地把经义原则化，简要化，把经文的要义，渐渐提纲挈领，了然明白，当然还不能完全不依经论。到最后，依义而不依经论的文句，如法修习。加行道，到了从思入修的阶段。
    法性现证，是要从闻、思、修而入的。说到这里，想到如理作意的不容易。因佛要适应众生根性，说种种法门，有时似乎有点矛盾。这里这样说，那里那样说，可是我们很少能依自己的能力，深入经藏，而得实义的。把经藏多读几遍，不一定就能深入，那么我们要用什么方法呢？可依古代大菩萨所开创的宗派。如走入深林，到处没有路的，要自己去摸索出一条路出来，不是不可以，不过不容易，也太危险了。如过去有人，已走出了一条路，如依著这条路渐渐走去，即使迂曲些，到底是事半功倍。所以印度大乘的唯识宗、中观宗，都有这种见解：我们自己去读大乘经，不容易把握佛法的真实意义，可依古代圣者所开辟的大路，或依龙树所创开的中观；或依弥勒的唯识。印度大菩萨的论义，直接继承于印度，对印度的文字，也较少望文生义，比中国学者依据译典，更为亲切！印度论师所传也是有异义的，不过依此思惟观察，总是容易得多。这一观念，在印度，在西藏，都是这样的，所以在印度与西藏，对于论部，特别的重视。以论通经，容易了解，容易把握经里的深义。还有论师们互相论辨，总是把握对方的要义而论辩的，每可以从不同的宗派中，了解自宗的要义。所以依唯识宗的，最好读读空宗，查查龙树菩萨的论典；学空宗的，也要了解唯识家的不同。从前唯识学者欧阳竟无说：他读了清辨菩萨的大乘掌珍论，对唯识宗的主要思想，才正确的把握了。印度菩萨造论，辩论是不随便的，知道对方是这样说的，才扼要的加以批评。所以依某宗论为如理作意的准绳，对不同宗派的大乘论，也是可以参考的。
    （4）触证 触为得正见，故以真见道，现前得真如，所以亲领受。
    触证相的触是接触，证是证实。亲切的经验到法性，名为触证。中国的禅者，欢喜说开悟，或说大彻大悟了，然证有一定的标准，悟的意义，可浅可深。亲亲切切经验到了，真正的体验到了真如法性，才可叫证。而悟，无论以听闻所得来的智慧，以思惟所得的智慧，从修习所得的智慧，虽不是真正的般若现前，但也有一番领会。例如天台宗所说名字即佛，称为大开圆解，于佛法中豁然贯通，有一番体会。这不是证，不过是闻所成慧。悟是浅浅深深的，或在读经时，或在静坐时，内心都可能现起一种体验。闻慧、思慧、修慧，都有内心体验的，但都不是证。修行者在证得法性以前，必有一层一层的经过，假使不了解，就以为证了，成为增上慢人。所以证是实证，特别名为“触证”，触是触到，而不是想到了。经上譬喻说：好像井中有水，望见了，可是没有触到；若把水拿起尝到了，才真的知道了水，触证就是那样。论文说：“触”是“得”到了“正见”。正见即是般若，在八正道中称为正见。正见，不是一般所说的正确了解，而是正确的智见。那八正道的正见，是现证法性的般若。为何名为见？如以眼睛见物，看得很清楚。我们的智慧，直对真理，体验得明明白白，这样的智慧，所以又名为见──叫正见。
    在修行的五位中，经资粮位到加行位，修到世第一法，下一刹那，真正的智慧现前了，正见现前，名为见道。见道有二：一为真见道；二为相见道。正见是真见道，如般若经说：‘慧眼于一切法都无所见’。真正的般若现前，一切的法都不现前。这就是毕竟空性，或名真如，或名法性。无能取、所取，无能诠、所诠，平等平等。禅宗有一句话：‘说似一物即不中’，说他是什么，就不是的，因为所认识的一切，所说的一切，都是名言，与法性不合的。真见道体验到法性是怎样的？那实在是不能说的。中国人说哑子吃黄莲，有苦说不出；佛法的譬喻是，般若真见道，如哑子食蜜，甜得很，就是说不出。这不但常人不能说，菩萨不能说，佛也不能说。菩萨在定中真见道，一切法都不可得，从真见道出定后，从般若起方便，或名后得智。如在总统府，不能说总统府在南在北，等到离开总统府，那又可以说了。通达空性是什么样的，在后得智中，以世间语言、思想表达出来。法性是这样那样，其实这已不是真实的，因为有相可得，所以名相见道，真见道时，般若是无相的，没有一切相，空相也没有。当时是一切相不可得，唯识家如此说，中观家也如此说。真见道证得真如，真如就是法性。没有虚妄的，名真；这虚妄的有能取、所取的对立，能诠、所诠的差别，触证得无二无别的，所以名为如。
    “现前得真如”，现前的意义是：就是觌面相呈，当前的，直接的经验，不是间接的，雾里看花那样。智慧现前，或名为现观。现是直下的，当前的，不加思惟，不加分别，离能取所取而明明白白的现前，这就是触证的正见。此正见能体验到真如，“所以”是“亲领受”的。亲领受是亲切的体验到，这是一切文字、语言所不能安立的。心识起时，一定有能取、所取，而这是超越能所的。所以真见道是一切法相不现前的。般若经说：‘一切法不生，则般若生’，就是这个意义。
    （5）随念 随念谓修道，为除诸垢故，于前所见义，菩提分所摄。
    进一步，是‘随念’的修道位。有的说：证到了，一了百了，什么都没有事了。然依楞伽经，或中观与唯识论，都不是如此。证是顿证，通达无二法性，是没有次第可说的，但证了以后，还要进修。菩萨在定中，通达真如，亲切体验到法性，但从定出来，能取、所取，能诠、所诠，一切又都起来了。虽现起一切，但与没有体证的人是不同的。证悟了的，是真能知道这一切相是虚妄如幻的。证悟，断了见道所断的烦恼，但还有修道所断的烦恼；有的烦恼虽断，还留有习气，所以证悟以后，正好修行。证悟以后的，名为真修，这就是随念。什么叫随念？随是随顺，念是系念，随念是随顺那体验过的，见到证到的境界，系念观察，以此观察当前的身心世界，不断的随念观察。禅宗说悟了以后，随时照顾这一悟境，不时的提起来，不断的进步，意义有点相近。所以“随念”是证后起修，是“修道”位，是初地真见道以后，从初地、二地，到十地菩萨后心，共经二大阿僧祇劫。
    随念是修道，所以证后要起修，“为除诸垢故”。生死众生是杂染的，无论是烦恼杂染，业杂染，或报得身心的生杂染，都是不清净的垢染。其中主要的是烦恼，除去烦恼，要在认识的心境上，除去执著为实有性的计执相，才能渐除烦恼而到达清净。
    “于前所见义”：前是真见道，前所见到的义，是见道的证境，不断的随顺见道的证境去修。众生的烦恼，有二大类：一为见解的，思想的错误，如我我所见等，名见所断烦恼。这些烦恼，是见解的、思想的错误，所以一旦见道──体证真如，这些烦恼就解决了。另一类是在生活行为中，属于情意的，如爱、慢等。众生无始来这种种的烦恼，不是一悟所可解决的，不过有了正见，属于情意的，有关生活行为的烦恼，可以正见去观察而渐渐消除的。见道以后，应时时将体见的境地，在一切事上去体验。一方面，深修定慧，定中证到真见道的境界，一切相又不现了。等到从定起来，一切相又现了，把那个体验到的境界，了解一切如幻如化，随时在平常日用中去体会，一切修道所断的烦恼，渐渐的消除。
    这里举一譬喻：如天上月，有时见月跑得很快，这是错乱、虚妄、颠倒的。经慢慢的观察，集中眼光去看，久而久之了解了，原来是乌云在动而月没动，这是见解的正确。虽知道了云动而月不动的真相，但如果不经意的以眼望去，月亮还是在动的。要经过不断的训练，久而久之，才能一望而知，月并没有动。这可以譬说，能取、所取，能诠、所诠，虚妄分别相现，真见道时一切不现前了。虽体证了，但一出真见道，一切相又现，虽能知一切如幻如化，与从前的认识不完全相同，但到底还要现起妄相。这如心里明知月没有动，可是眼见月在动一样。这必须把那证悟到的，毕竟空的境地，在平常日用中去，见到的，听到的，想到的种种境界上去历练，到了念念常证真理，幻空不二，断尽一切烦恼，那就成佛了。从前达摩所开示的，‘一、理入；二、行入’，理入是证入法性；证悟后，要在一切行为中去修，就是行入。西藏所传的大手印，我见到的，也是先发悟，悟入了法性后，说明遇到苦怎么样？遇到乐，又怎样？病时怎么样？甚至死时怎么样？得意和失意时怎么样？总之，在人生一切经验中，处处以此悟入的境地去历练。所以见道以后的修行是随念前所行境，就是修道。修道位的修，要数数修，不断的修习，以到达究竟。
    修道位所修的，“菩提分所摄”。菩提分，是三十七菩提分。菩提译义为觉，分是条件，就是因素。要成就大觉，就要具备这些支分。菩提分是：四念处，四正勤，四如意足，五根，五力，七菩提，八正道分，这都是完成大觉所要修的事。三十七菩提分是通于小乘的，大乘法也有三十七菩提分，主要是六或十波罗蜜多，种种三摩地，陀罗尼，一切修行法门；为了圆满究竟的大菩提，所以这所修的，都是菩提分所摄的。十地经等说‘十地菩萨修十波罗蜜多’，就是此义。在还没证悟以前，也是修菩提分的。依大乘经说：证悟以后，才是真正的波罗蜜多；证悟以前，叫远波罗蜜多，相似波罗蜜多，因为都是有漏的，还不能与法性相应的。证悟以后，无漏的，与法性相应的行，才是真正的菩提分所摄。依上来所说，可说依处是资粮位，抉择是加行位，触证是见道位，随念是修道位。
    （6）到达自性 悟达彼自性，谓真如无垢，一切唯真如；显现彼即是，转依圆成实。
    这五句，最后“悟”入到“达彼自性”，就是成佛的究竟位。悟是或浅或深的，这里所说的悟，是成佛时的彻悟通达。自性，与平常所说无自性不同，这是胜义自性，是智慧所体悟的究竟真实。自性，或译本性，是本来如是的体性。众生、凡夫所见到的一切法，直觉到是这样的，以为这是一切法的真相，不知这是虚妄分别所现，如执为真实如此，那是颠倒的，错误的自性。这种妄执自性，是毕竟不可得的；遍计所执自性，非彻底破除不可的。一切虚妄执著所显的一切法本性，禅宗称之为本来面目的，是一切法的如实相，也名为自性，就是胜义自性。
    证悟通达一切法的自性，就是“真如无垢”，就是离染的真如。世俗学者，有些学佛者，对于真如自性，每想像为万有以外的，或万有之内的本体，意解为一实体。佛法所说的自性，是从一一法的自性，推究到、体悟到一一法的本体，这就是胜义自性。所以胜义自性，不是在一切法以外的，也不是在一切法内部或底里，另有一微妙不可思议的自性，而是一一法的真相。如眼识有眼识自性，耳识有耳识自性，......，依世俗所见的不同特性而立。现象界的一一自性，都是唯心所现的，观一切法虚妄，通达一一法无所得，体悟一切法（胜义）；从一一法上推究到究竟处，超越了能取、所取，能诠、所诠，到达的胜义，是一一法的本性，胜义法性的体悟，名为‘自内所证’，就是内证的一切法性，而不是在一一法外的什么。观一一法不可得，一切法相都不见了，称此自内所证的为‘真如’（法性），因为虚妄相没有了，一切法无二无别，平等平等，所以名为真如。这不能想为万法以外或万法以内有个实体，再从这个生起一切；佛法是不说从自性生起一切的。无论唯识或中观，但说一切法真如、法性，无二无别，却不能想像为一，因多与一，都是相对的，没有差别的多，一也不可说。佛法中常说不二、无二，怕众生听了会误解，所以很少是一的。
    真如是一一法本性，众生为什么不得悟入？众生在生死中，虚妄分别，烦恼、业、苦，流转不息。真如没有离一切法，因无始以来为无明所蒙蔽，如明镜面有灰尘在；或如虚空本来明净，而现有乌云一样，所见的虽还是虚空，但不见明净的，而是那么阴沉沉地晦暗，所以经说‘客尘所染’，这就是有垢。其实，真如不会有垢的，可是众生有垢，为客尘所障，妄相现而真相不现罢了！为无明所障，名世俗谛。在梵文里，世俗有覆蔽的意义，所以说：‘无明覆真故世俗’。
    当真见道时，一切虚妄相不现前，体证到一切法清净真如，但杂染没有消尽，出观时种种虚妄相又现。经修道位修习，虚妄渐渐消融，渐渐转化，到二障永尽，杂染彻底消失，名为最清净法界，也就是真如显现了最极清净，这才是真如无垢，唯识学或称为‘出障圆明’，离杂染障碍，显出真如的究竟清净，也就是圆显一切法的本性──胜义自性。究竟到达佛位，也就是悟达彼自性。在佛的境界中，一切法都是真如现前，所以说“一切唯真如”，再没有虚妄分别相了。虚妄分别尽净了，圆满“显现彼”真如，这就是“转依圆成实”。
    转依与圆成实，在唯识学中，是重要的术语。一、转依，向来说有二种依：一、持种依：阿赖耶识为杂染清净种子依，为染净法所依。无始以来有虚妄杂染种子，显现虚妄生死，生死不已，又由清净种子，引起圣道，舍染得净。转无始来的虚妄杂染为真实清净，都以阿赖耶识为依，这是约持种依说。二、迷悟依，迷是迷了这个，悟是悟了这个，这就是真如、法性，真如有垢而成为迷妄，真如无垢而成为清净，真如为迷悟依。约本论说，转依圆成实，是约迷悟依说的。
    转依所显的，是圆成实性。圆成实的意义是：圆是圆满，圆满是无欠无余，不增不减。成是成就，与一般造作所成的成不同，与中国所说‘成者自成也’的意义一样。实是真实，离虚妄名实。在唯识学的三性中，第三名圆成实性。圆成实性在唯识学中，略有二种解说：一、圆成实是毕竟空性，法性，真如，约理性说，而佛果所有的无边功德等，不属圆成实性，它名为清净依他起性。唐玄奘所译唯识，多取此义。二、如阿毗达摩大乘经、摄大乘论等，圆成实有四种，即四种清净。依四清净说，佛果的一切清净功德，属于圆成实性。也就是佛的果德，一切是真如，圆成实所显。
    以上法与法性，都以六相来分别解说，以下特说转依圆成实义。


2. 特详转依别彰大乘义

    2. 特详转依别彰大乘义
     2.1 法说
     将转依特别提出来详细说明。这是著重于大乘的，从证悟真如，初地菩萨以上，到成佛的转依。法性的意义，虽是重于大乘的，如但约证悟法性来说，也通于二乘的果证。
    2.11 总标 由十相悟入，转依为无上：入性、物、数取，别、所为、依住，作意及加行，过患并功德。
     先总标，转依的悟入，有十种相，为悟入转依无上方便。十相中，第一相“入性”，入是悟入，入自性就是悟入自性。第二相入“物”，悟入的对象。第三相入“数取”，梵语补特伽罗，译义为数取趣，是众生的别名。众生为什么又叫数取趣呢？因为每一众生，都是无始生死以来，在人、天等五趣中，不断的生了又生。数是数数，是一次又一次的意思；不断的受取五趣，所以名数取趣。通俗的说，不但是五趣凡夫，声闻、缘觉、菩萨、佛圣者，也名数取趣。所以入数取，说明这转依是属于谁的。第四相入“别”，别是差别，殊胜的意义。第五相入“所为”，明为什么要悟入转依。第六相入“依住”，明转依依住，这一科最重要，是说般若无分别智。第七相入“作意”，是悟入的作意修习。第八相入“加行”，悟入的加行。第九相入“过患”，如不立转依，有什么过失。第十相入“功德”，安立转依，有什么利益。总标十相，以下再一相一相的详说。
    2.12 别释
     2.121 悟入自性 其悟入自性：谓客尘诸垢，及与真如性；不现及现义，即无垢真如。
     悟入，如上说‘悟达彼自性’，悟入的自性究竟是怎么样的？上文说过，自性是真如、法性，但是要说明法性、真如的转依，先从二方面来说，“谓客尘诸垢，及与真如性”，一方面为客尘，一方面是真如性。不虚妄为真，如如无别为如。法性是法的本性，是本来如此的。本来如此，所以真如、法性，是超越了时间观念的，但一般说起来，总是从时间观念去想，本性被看作从过去以来，一向如此，于是问题丛生了！真如，法性，是超脱一切名言、时空，没有杂染与非杂染的，对生死杂染说，名为清净。
    另一方面是诸垢，种种杂染不净的诸垢，也名客尘。尘是染污的，无始以来所有的染污。约心说，是虚妄分别心，是妄识相应的种种烦恼。如约心所现所取来说，是似现的错乱相，执著种种实有性。为什么叫客？真如法性是清净的，一向清净的；杂染、诸垢、无明，也是无始以来就有的。一向有真如，一向有无明，简直不能说谁前谁后，谁主谁客。可是虚妄杂染，可以因修行而灭去，消融而不再存在，所以染污的，如烦恼、戏论相等，称之为客。如客人在此住几天就走了，他终于要离开的，主人却一直住在此地。所以客尘，不过形容可以取消的；对真如本净，而名诸垢为客尘。
    可是，如从时间上去说，还是先有真如？先有无明？还是同时而有？如同时而有，为什么有主客之分？假使说先有无明，后有真如，那真如不成其为真如，起初没有而后来才有，这是不符真如定义的。如先有真如，后有无明，这过失就大了，这是不能成立的！既然先有真如本净，为什么后来又起无明呢？有的说，真如本净，由于一念不觉，一动念而有无明。试问：有了无明才一念不觉呢？一念不觉才有无明呢？没有无明，为什么会一念不觉呢？假使真如本来清净，后来会忽然而有无明，那大家不用修行，因为修行是没有用的。你就是修到了成佛，完全清净了，说不定忽然一念，垢染又起来了。所以说先有真如，后有无明，这都是从时间观念去说本性，说客尘，这才陷入理窟，无法自拔。佛是从现实身心出发的，只说无明是无始以来如此的；由于无明等垢染可以除灭，不是永久如此的，所以称之为客。诸垢名为客尘，依唯识说，客尘是虚妄分别心，妄心所现能取、所取自性，种种执著所起种种烦恼。
    “不现及现义”：在凡夫的众生位上，客尘显现，真如不显现；没有证悟以前，真如是从来不显现的。真如性不现，所以客尘现虚妄分别，能取、所取，修行就是要使客尘不现，真如性现前，把它倒转过来，向来显现的不现，向来不现的现在显现。不过，在修道的过程中，是进进退退的，最后才到达究竟的清净的。真见道时，一切相不现，真如法性现前了，但客尘没有尽，执障与习气都还在，所以一出见道，虚妄分别，能取、所取杂染，又起来了。这样的不断修习，真如法性时时现前；到八地菩萨，自利方面，无相无功用，纯清净心，但还没有纯净，究竟清净真如显现，要到佛位，一切客尘永不现了，这才是“无垢真如”──离垢真如。真如是如是如是，没有变异，本来清净的，在众生位上也不受垢染，如真如受垢，也不成其为真如了。真如本净，但因众生虚妄显现，没有显出清净法性，不显并没有失却；到成佛，一切杂染销融，法性究竟现前，名离垢真如。古代禅师这样说：‘修证即不无，污染即不得’。真如性是不会污染的，但要经修证而显出，所以要有修有证（约真如本如是说，也可说无修无证）。悟入自性是无垢真如，是转依的胜义自性；或约唯识说，名为无垢识。
    2.122 悟入物体 谓共器界识，真如性转依；及契经法界，真如性转依；并诸非所共，有情界内识，真如性转依。
     转依，依什么而转化？如上文说，生死法为所依，是共所依，不共所依。涅槃法性为依处，是一切法、一切经等。转依，是依这种种的物体，转显真如清净。
    平常说：唯识宗‘转八识成四智’。众生有八识：眼、耳、鼻、舌、身、意──六识；第七末那识；第八阿赖耶识，都是有漏的。等到究竟成佛，八识都转成四种智：转阿赖耶识成大圆镜智，转末那识成平等性智，转意识成妙观察智，转前五识成成所作智。转有漏识，成无漏智，就是转依。然唯识宗所说转依，不一定依八识说，如庄严大乘经论，从种种方面说转依：众生有种种方面的虚妄杂染，都可依之而说转依，如我们有贪欲，转依了成什么；有烦恼，有五根，有器界，转依了成什么。总之众生所有一切，都转化为究竟清净。
    本论所说转依，是依上文所说而立的。上面说：‘诸于何流转，说彼为所依’，所依是器世界与有情界。器界是共的，就是山、河、大地等。有情界有共与不共：托胎生、名言、摄受、治罚、饶益、违害、功德、过失──八事，众生与众生间是有彼此展转相互关系的是共。有情界的依、了别、苦、乐、业、死、生、系缚、解脱──九事，是不共。器世界与有情界，是生死流转所依，现在就依此来说转依。
    “谓共器界识，真如性转依”：器世界是共的，虚妄杂染共相识所现。依此说转依，就是转杂染世界为清净世界，就是净土。世亲菩萨的净土论，是无量寿佛的优波提舍，说到佛的清净土，是第一义境界，胜义的境界，也就是这里所说的真如性。众生器世界，是虚妄分别所现，到转依时，就是真如性显现。清净佛土的无边清净庄严，一一以真如性为体；虚妄不现而真如性显现，名真如性转依。
    本论所说转依，分为三类：一是共器世界识；有情界有共，有不共，总为三类。有情界的共，是托胎生等八事，其中名言是极重要的。因为人与人间，以名言──语言文字来表达思想、感情，彼此间心意相通，主要是以语言为媒介的。如来救度众生，主要依于说法。佛与众生发生关系，虽也有现神通的，但主要是说法。佛所说的法，把他结集下来，就是经（律的根本，也是名为经的），所以说：“及契经法界，真如性转依”。梵语修多罗，译义为契经，因为佛所说法，一方面契合真理，一方面契合众生的根性，契机、契理，所以译为契经。现在要问：契经是妄还是真呢？众生听闻、了解、忆持、思考，只是名言，名言是虚妄所现，那末佛怎么能以虚妄分别所现的语言文字，化我们趣向真如呢？众生的名言，是虚妄分别所现的，能取、所取，能诠、所诠，听闻佛所说的，虽还是能诠、所诠，但有一不同，佛所说的契经，是属于法界等流的。法界的意义很多，这里是圣法之因。一切圣法、圣道，因此，依此而生起，所以名为法界，界就是因义。法界是真如异名，与真如相应，才有无漏圣法，所以又名为法界。佛说的一切经法，是法界等流。这是说，佛证悟了清净真如──法界，悲愿薰心，起方便善巧，将自己所修，所证得的说出来。佛为众生方便开示，演说，是从证悟法界而来的，称法界性，平等流出，所以叫法界等流。我们从佛闻法，所以能够发心，修行，解脱生死，成佛，转虚妄而显真如，都因为佛说是法界等流而有可能的。佛的言教，在我们听起来，不外乎语言文字，能诠、所诠，也不外乎虚妄分别，但从佛说的内容说，有众生生死虚妄所没有的成分，这是证悟了真如，以善巧方便宣说，有著导迷启悟，转妄成真的作用。
    譬如说：日月潭怎样好，我们不知道，所以我们也不想去观赏。有人去了日月潭，照了好多风景片，拿来给我们看，这当然不是真实的日月潭。可是从所摄的照片，使我们了解日月潭是如何的，而引起去日月潭旅行的动机，我们依那人告诉我们的路线，就可以发心前往，到达日月潭。这样，佛证悟了平等法界，真如法界是离言不可说的，但佛有慈悲方便，从自证法界流出言教。在佛来说，这是真如性显现，不过到众生心中，成为一般的语言文字。佛经与世界所有的各种学术，有什么不同？佛是从证悟真理而宣扬出来，有引导众生，转迷向悟的功能。听到了法界等流的契经，就在众生虚妄识中，薰习成一种出世的种子，名为闻薰习，成为出世心的种子。闻而思，思而修，出世种子力愈来愈强，终于引发现行的无漏智慧现前。契经是语言文字，不离虚妄分别，却可以破名言，使这虚妄分别转化。依法界等流的契经而闻思修习，等到究竟成佛，这是‘契经法界，真如性转依’。佛的言教，在圆成实性四种清净中，名生此境清净。经典的法义，能生起无二智慧等，为智慧的境，虽是名言，而属于清净法──圆成实性。
    “并诸非所共，有情界内识，真如性转依”。有情界的不共，是依、了别、苦、乐、业、死、生，等等九事。不共的有情界，以有情的内识为主，如依、了别等。依或是五根，或是阿赖耶识；了别是眼识、耳识、鼻识、舌识、身识、意识等。末那识、阿赖耶识，与眼、耳等六识，这种种能取的识转，转显真如性，都是圆成实性。
    2.123 悟入数取趣 初二谓诸佛，及诸菩萨众，真如性转依；后亦通声闻，及诸独觉者。
     第三相悟入数取趣，是说转依的是些什么人。通俗的说，约修行得转依的有情来分别：初二是上面三类转依中，共器界识，及契经法界的转依；这是“诸佛”与诸大“菩萨众”的真如性转依。上面说过，证得涅槃的，有三乘差别。声闻与缘觉圣者，是没有净土的；净土是佛菩萨乘的特法。二乘人的修行，著重在断烦恼，得解脱，专于自己身心的义利，不大注意外界，也没有要使外界清净的动机，所以不发愿，功德少，到了证得声闻、缘觉的圣果，是没有净土的。释迦佛在世的时候，诸大阿罗汉所见的世界，是杂染的秽土，如维摩诘经里，舍利弗尊者说：他所见到的，释迦牟尼佛的国土，秽恶充满，种种荆棘土石，是不清净的；与凡夫所见到的一样，所以二乘是没有净土的。但诸佛与菩萨，有器世界转依，就有净土。佛有究竟净土，这是不用说的。菩萨到了初地以上，也有一分净土，因为到了初地菩萨，是已经证悟真如法性了，无分别智现前；断除一分不净，能见到佛的他受用净土。在佛方面，是他受用净土；在菩萨方面，是菩萨自身的庄严清净土。所以共器界识，转杂染世界为净土的，是佛与菩萨（那样的数取趣）。‘契经法界’的真如性转依，也是佛菩萨的。佛与菩萨，都证悟了法界，方便流布的语言文字，在佛菩萨的觉悟境界，是法界等流，圆成实为性，所以也是真如性转依。在声闻、独觉乘，这些语言文字，终究是虚妄世俗法；所以契经的真如性转依，也是属于佛与菩萨的。
    “后亦通声闻，及诸独觉者”。在三类转依的后一种，就是‘有情界内识，真如性转依’。这是说，可通于声闻、独觉，当然佛菩萨也在其内。声闻、独觉，可以说内识得到了转依的。声闻与独觉，能解脱生死，有这真正的般若现前，依唯识宗说：声闻与独觉，有生空智，通达我空真如，生空无漏智现前，有漏识不起，悟入法性。我们的心识，圆满转依，真如性显现，声闻、缘觉，是达不到的，但声闻与缘觉，未入涅槃以前，有清净无漏智慧现前，悟入法性，有转依的意义。等到入般涅槃，有漏身心永灭，所以生死究竟解脱，证涅槃是（生空）真如性显现，所以有情界内识的真如性转依，声闻、独觉，也是能得到的。如声闻与独觉，不能得到内识界的真如转依，那怎么能了生死？解脱成涅槃？声闻、独觉，是通于这一分涅槃的，所以华严经十地品说：八地菩萨时，依无分别智，证得无分别法性，也是声闻、独觉所能契入的。
    2.124 悟入差别 悟入差别者：谓诸佛菩萨，严净土差别，及得智法身，报身并化身，能普见、教授，自在成差别。
     “悟入差别”，是转依的差别。声闻有转依，独觉也有转依，佛菩萨也有转依；菩萨是分证，佛是圆证，佛菩萨所证的转依，比二乘有什么差别？差别，是佛菩萨与二乘不同；差别可译为殊胜，有特殊超胜的意思。悟入差别，是说佛菩萨的转依，与二乘不同，比二乘的转依殊胜得多。佛菩萨转依，有那些不共二乘呢？一、“谓诸佛菩萨，严净土差别”：佛菩萨净土的庄严，胜过了小乘，这已在上面说过了。二、“及得智法身，报身并化身”：究竟转依的佛果，有法身、报身、化身三身（菩萨分得），这是与二乘完全不同的。依此三身而起妙用：能普见，教授，自在，显出大乘转依胜过了二乘。
    平常说佛具三身，法身、报身、化身。唯识宗更严密的分别，分报身为自受用身，他受用身，所以成四身，不过三身是一般大乘经的通义。本论称法身为智法身，经说法身的意义不一，如但约法性为法身，那是一切众生本来如此的，也可说人人成就法身的。法身是无彼无此，无差别性，不但佛与佛可共证，一切众生都可说有这法身。佛（菩萨）圆证的法身，是以无分别智证悟显现了法性。清净法性圆满显现，是智慧圆证所能得的，就是无垢真如，所以称为智法身。经说：‘如如，如如智，名为法身’，就是这样的法身。约法身无差别，与一切众生不二，这是如如义；但佛法身是以智而圆满体现的，非众生所有，所以佛法身名为智法身。
    报身，约佛来说：菩萨初发菩提心，修菩萨行，积集广大资粮，六波罗蜜多，四摄，三昧门，陀罗尼门，修习到究竟圆满，名为佛。佛是无边清净功德所庄严的，是菩萨发心修行所成就的。约这一意义说，名为报身，报是修所成的，是修得的果报。报身约功德圆满成就说，所以名圆满报身。佛的圆满报身，约佛说，是修行圆满，佛自受用甚深法乐，名自受用身。但在初地到十地菩萨所见到的佛身，教授甚深法，菩萨从佛而受用法乐，所以又名他受用身。
    化身，是适应众生而起的种种变化身。出现于娑婆秽土的释迦牟尼佛，在大乘法中，属于化身。不过化身不一定这样，名为随类化身。应以什么身化度，佛就化现什么身。所以所化的身相，不一定是比丘相，不一定是佛相；救度你，化导你，现起各样的身相出来，受化者也不一定知道是佛。如人在种种危险急难时，在黑暗中因遇到光明而脱险，这光明可能也是佛所化的。有佛化丈六身，如释迦佛那样，是凡夫，或小乘根性成熟所见的化身。如十住，十行，十回向菩萨，虽还没有证悟，不见佛报身，但功德广大，所见的化身，现天人相，身体高大，或如须弥山。所以化身中，是种种不同的。
    佛的三身，与心识的转依有关。阿赖耶识转依，就是法身。意识转依，妙观察智成身，是报身。化身起种种利他事业，是转前五识，名成所作事智所现。古代唯识学，也多少有不同的分别。以内识界转依成智，名智法身、报身、化身。三身的差别殊胜，是二乘所没有的。
    依三身而起妙用来说：
    一、“能普见”，是智法身的作用。普见的意义是：遍一切处，遍一切事，遍一切法，刹那刹那间，无所不知，无所不见。普见也可说普现，念念顿现一切，这是智法身的妙用。约转识成智说，这就是大圆镜智，如大圆镜内，一切一切都影现出来。
    二、“教授”，是报身的妙用。佛成报身，在清净净土中，教化十地菩萨，所以八识规矩颂说：‘十地菩萨所被机’。十地菩萨能见报身佛，报身佛为十地菩萨说法，教授十地菩萨。佛教授菩萨甚深法，所以菩萨能领受甚深法乐。
    三、“得自在”，化身妙用。现种种身，说种种法，应现什么身就现什么身，应说什么法就说什么法，一切自在，作种种利济事业，是化身的妙用。
    这样，得智法身，能普见一切；得报身，能教授十地大菩萨；得化身，能起种种自在事业。佛（菩萨得一分）与二乘的转依，是完全不同，显出佛菩萨转依的殊胜。
    2.125 悟入所为 悟入所为者：谓宿愿差别；宣说大乘法，即所缘差别；十地加行别。
     “所为”，是菩萨修行，到能得究竟转依，在进修过程中的所作所为。这是与二乘所为不同的，主要有三种差别：一、宿愿差别；二、所缘差别；三、地加行差别。
    “宿愿差别”：菩萨最初发心时所立的菩提大愿，与二乘不同。宿愿，经中或称本愿。初发心所发的大愿，简单的说，是上求佛道，下化众生。具体的说，菩萨发愿，要求得究竟圆满的佛道，要度尽一切众生。或说：要庄严一切国土，见一切佛，听一切佛说法，修学一切法门，利益一切众生，圆满佛所有的一切功德：一切都是遍法界的一切一切。这样的宿愿，与二乘完全不同。二乘专为己利，急求解脱生死，不为众生著想，从没有成就一切功德的希望。二乘的发心，但求己利，与菩萨初愿不同，是宿愿差别。
    “所缘差别”：二乘听佛说法，少闻为足，不求佛说的无量法门。闻法少，思惟、修习也少，闻、思、修慧的所缘法义，都是狭少的。菩萨遍学一切法，遍观一切法，所谓无量法门誓愿学。听闻，思惟，修习，依一切法为所缘境，这是菩萨的所缘差别。
    “加行差别”：上面说到的加行道，是真见道以前的，暖、顶、忍、世第一法，名为四加行，这是狭义的加行；约广义说，从菩萨发心起，所有一切修行，都可名为加行。不过，这里所说加行，专约十地菩萨所修的加行。声闻、独觉所修的是戒、定、慧──三无漏学，这戒、定、慧学，也不是圆满的。菩萨的加行广大，自初地到十地菩萨，修十波罗蜜多：初地修布施波罗蜜多圆满，二地修持戒波罗蜜多圆满，布施，持戒，忍辱，精进，禅定，智慧；从方便智别出的，是方便、愿、力、智波罗蜜多。菩萨在十地所修的加行，一切都究竟圆满，显出大乘加行的特胜。悟入所为的三差别，也可说是愿大、境大、加行大。


2.126 悟入所依住

    2.126 悟入所依住
    2.1261 标列 悟入所依住，谓由六种相，入无分别智：即悟入所缘，离相、正加行，性相、与胜利，及悟入遍知。
     第六相，“悟入所依住”，正说无漏般若，也名无分别智，是能得转依的枢纽所在。平常学佛者说，不要分别，一念不起，无分别，但无分别是什么意义？怎么样才可得到无分别？修得无分别智所包含的一切意义，这里来广为说明。真如法性的圆满开显，是依无分别智而成就的。依无分别智而真如法性转依，所以无分别智为所依住。本论以“六种”义“相”，明悟“入无分别智”：甲、“悟入所缘”，无分别智以什么为所缘？乙、悟入“离相”，无分别智离什么相？丙、悟入“正加行”，无分别智以什么加行而得？丁、悟入“性相”，无分别智的性相。戊、“胜利”，得到无分别智的殊胜义利；胜利与功德的意义差不多。己、“悟入遍知”，无分别智的遍通达一切。遍知，在佛法中，是一特殊术语，遍知不只是一一法的了解，而是由于真理的通达，能断除烦恼。证真与离惑，是相关的，遍知谛理就能够断烦恼。这六相，是标列悟入所依住的，下面再分别来解说。
    2.1262 别释
     2.12621 悟入无分别智所缘 当知有四相，初悟入所缘：谓于大乘法，说、胜解、决定，及圆满资粮。
     初相是悟入所缘。“悟入”无分别智的“所缘”，有“四”种“相”，无分别智以此四相为所缘而成就。四种是：听闻所说，胜解，决定，圆满资粮，这四种都是依大乘法而起的。在上面‘悟入所为’中，曾说过：‘宣说大乘法，即所缘差别’，大乘法为所缘，是菩萨智慧的特性。依大乘法为所缘，依次第深入说，就有此四相。
    “说”，是佛菩萨所说的大乘法。佛世多用言教，多用耳闻，所以名为说。菩萨无分别，不是什么都不去分别，先要听闻大乘法教。如从人听说大乘法，或阅读文字记录的大乘经，都称为闻法，所闻的就是说。如不听闻大乘教说，不阅读大乘经典，想得菩萨无分别智，那是根本不可能的。有人说：我什么都不分别，以为这样修学就能得无分别，那是误解了！所以要得无分别智，先要听法。本来，趣入佛法的初步，就是要亲近善友，从善知识那里，多多去听闻大乘教说。说，起闻慧，依听闻教说为所缘，能成闻所成慧。
    “胜解”：从听闻大乘法，经如理思惟，渐渐地得到了殊胜的见解。这是很坚定，很明确的见解，名为胜解。得了胜解，不再是人怎么说，自己也怎么说，毫无定见了。如理思惟大乘法义，所得坚强不变的见解，是胜解，这是坚固不动摇的。如达到胜解的阶段，不管旁人怎么说，都不能改变；即使他能现神通，也不会变动自己的见解。胜解不是从听闻而来的，要经过如理思惟，确定为非此不可，所以胜解是思所成慧。
    “决定”：胜解也是决定的，但这里的决定有抉择的意思。依思惟所得，进而起观察慧，观慧以简择为相。这不是散心分别，而是定中观察，大乘法义，能于定心中安住不动，这是决定，所以决定是修所成慧。要得到无分别智，必定以大乘法义为所缘，从闻而思，从思而修，才有引起无分别智的可能。
    “圆满资粮”：在佛法中，无分别智当然是智慧，但菩萨无分别智的引发，不是二乘智慧那样，专修智慧就可以了。菩萨的无分别智，一定要有福德庄严，福德助成智慧。福德要从大慈大悲，利益众生中来，所以菩萨无分别智，一定与慈悲相应。有慈悲心，能利益众生，悲行福业的修集，是福德资粮；闻、思、修慧的修集，是智慧资粮。二种资粮圆满，名为圆满资粮，资粮是成佛所应具备的条件。如要去什么地方，要预备路费，及途中应用的东西，名为资粮；要得无分别智，也有应该具备的条件，具备了就是资粮圆满。所以，经中说无分别智，一定与慈悲相应，而且要定慧均等，这才能生起菩萨无分别智。有的学佛者，以为什么都不需要，只要修得无分别智就可以了，那是误解的。龙树菩萨说：般若，不是凡夫的智慧，不是外道的智慧，不是二乘的智慧。与二乘智慧的差别，就因为菩萨的般若，与慈悲相应。所以圆满（福德）资粮，才能得无分别智。
    四相的前三种，约修智慧说：听闻佛说，于大乘法义得胜解，得决定；这都是属于智慧资粮的。第四圆满资粮，要与慈悲相应，定慧均等，是福德资粮。般若无分别智，要这样的修学，才能现起。
    2.12622 悟入无分别智离相 第二能悟入，离相亦四种：谓由离所治，能治、及真如，并能证智相。此四如次第，即所永远离，粗、中、与微细，及常随逐相。
     凡所有相，皆是虚妄，一切相都是要离的，能离一切相，才能得无分别智；因为有了相，即有分别，所以要离一切相。泛说离一切相，而在修行的过程中，次第“离相”，也以“四种”相来说：第一、所治相；二、能治相；三、真如相；四、能证智相。
    一、“所治”相：智慧所对治的，是烦恼，烦恼是所对治相。然以唯识观来说，虚妄分别现能取、所取二相，是错乱杂染的因，这是要离去的。修唯识观时，观唯识所现的所取境，是离识无所得的；所取相为智慧所对治，修习到所取了不可得，是为第一离所治相。
    二、“能治”相：有所治，就有能对治的。通泛的说，修三十七菩提分，六波罗蜜多等，都是能对治烦恼，都可说是能治的。然约唯识观行说，上观所取相不可得，离心以外的所取相是所治相。这是观为唯心所现，能除心外所有的执著。观唯心所现，不离能取，就是以有识为能治。然所治的所取相不可得，能治的能取相也就不能成立，所以要进一步离去能治的能取相。
    三、“真如”相：真如是无相可得的，然从唯识观行的过程来说，修到所取相不可得，能取相也不可得时，有二取都不可得相现前。无二无差别，是真如相；一切法不可得是空性相。有此空相、真如相，还不能证入真如，这种似现的真如相，也是要远离的，这是离真如相。
    四、“能证智相”：修观时，总有一能观相；到观心现起二取不可得──真如相时，就有一能证真如智相，也就是自觉得能证真如。这也是相，是无分别智所远离的。
    将四相综合起来：所治，能治，真如，能证智，是修唯识观行，到达无分别智现前所应远离的。先要离所治相，观唯识所现，识外所有一切相不可得，对治所取相──心外所有一切相。一切不离能取心识，是能对治所取相的；如离去了所取相，这能治的能取心相也不可得，名为离能治相。所取相、能取相都不现前时，有真如相现前，空相现前，这真如相也是要离去的，因为真如是没有一切相的。所证的真如相既不可得，那能证的智慧相也不可得，所以说：‘无智亦无得’。修唯识观，对于这四种相，要一层一层的次第远离，四相都远离了，那才是真正的无分别智。
    颂文承上说：“此四如次第”这四相──所治，能治，真如，能证智，如四相的次第，就是“所永远离”的“粗、中、与微细，及常随逐相”。这四种相，是修行者所应该永远远离的。其中，所治相是粗的，识外的一切所取相，是最先远离的。能治相，是能取相，比较上要细一点，也就是次一层远离的，所以是中。能取、所取相不可得，真如相是最微细的，也是最后远离的。所治相是粗，能治相是中，真如相是微细，而能证智相是常随逐相，因为只要修唯识观，无论是离所治相，离能治相，离真如相，总有一离相观智的自觉。离相观智的自觉，是与观行不相离的，所以说是常随逐；这也还是相，直到有证有得的证智相也离了，才是无分别智现前。四相彻底永离，是无分别智离相的全部意义。
    2.12623 悟入无分别智加行 悟入正加行，亦有四种相：谓有得加行，及无得加行，有得无得行，无得有得行。
     “正加行”，不是广泛的加行，而是资粮圆满，正修唯识观行，在真正证悟以前，所修的四加行位。暖、顶、忍、世第一法，名四加行位，是正修唯识观的。要得到无分别智，真正的般若现前，证悟法性，非要经过正加行的修习不可，如不修加行，无分别智是决不会现起的。佛法中一向说：‘没有天生的弥勒，也没有自然的释迦’。弥勒佛，释迦佛，无论那一位佛，都是经修持得来的。唯识大乘所说的正加行有四：一、有得加行；二、无得加行；三、有得无得加行；四、无得有得加行。四加行的意义，是这样的：
    “有得加行”：究极的目的是无所得，但修行方便，第一要先修有得加行。什么有得？虚妄分别性可得，依虚妄分别性是有，作唯识观。如说：能取、所取，能诠、所诠一切都不可得，种种执著都不可得，一切一切既都不可得，那又从何起修？所以尽管说能取、所取种种妄执，可以是没有的，而虚妄分别，却不能说没有的，这就是唯识宗与空宗差别的地方。先要确信虚妄分别心是有的，这才灭除这虚妄分别，能得解脱。如辨中边论说：‘非实有全无，许灭解脱故’。依他起性的虚妄分别，当然不是实有的，可不能说是无，因为不是完全没有，所以要以修行来灭除他。许，是许可，承认，灭除虚妄分别而得解脱，是佛法所公认的；如虚妄分别什么也没有，等于无，那也不用修行了！一般人不太理解，有宗、空宗所论诤的重点所在，所论诤的，重在虚妄分别──依他起性。空宗以为，这是毕竟空的；唯识宗说：这不能说是空的，虚妄分别是有的。
    为什么一定要观虚妄分别为有，修有得加行？因为依虚妄分别有得，才能观察起“无得加行”。依唯识说：虚妄分别是有的，但从虚妄分别心（心所法）生起时，我们不能了解虚妄分别性是唯识的，现有能取、所取相，而能取、所取似乎心境对立，主观与客观对立，这是错误的，根本没有的。能取、所取──二取相，是不可得，是空的；这样的观察，名无得加行。把初二加行综合起来，就是有心无境：虚妄分别心是有的，心识现起的心境各别对立的──二取是无的。如辨中边论说：‘虚妄分别有，于此二都无’。修唯识观，是依虚妄心识，而显二取是无的，这也如辨中边论说：‘依识有所得，境无所得生’，唯识学是特重虚妄分别有的。一切法中，心为一切法的主导，为一切法的中心，无始以来有这虚妄分别心，所以在生死轮回之中，不得解脱。在生死流转中，起烦恼，造业，受果，都是依妄识──虚妄分别心而有的。虚妄分别心是不能没有的，没有就无所谓解脱；但也不是实有，实有是不可灭、不可破的，这是唯识宗所说的幻有。唯识学立虚妄分别心是有，依虚妄分别识，明能取、所取二相现前，心境对立是没有的。依虚妄分别有，观能取、所取相无，就是有得加行、无得加行的意义。
    “有得无得行”的意义是：虚妄分别是有得，所以心外所取不可得，所取境不可得时，能取心也不可得了。这样，虚妄分别有得，也就成为无得了。
    “无得有得行”：无得，就是上面的二取都无所得。二取都不可得，不是什么也没有了，因二取不可得，显出的二取空性是有的，这是有得。在唯识观行过程中，以二取不可得，而有空性在。这是加行，还没有证悟，但要肯定空性是有的。唯识学立虚妄分别是有（得），这才能安立生死与解脱，才能依妄识有而明二取无。唯识学又立空性是有（得），这才能明有所证得。所以，以唯识宗来看，一切空者是不对的！这也没有，那也没有，什么都是空的，那怎么安立生死与解脱，何必起修求证！生死与涅槃都不能安立，那就落在断见。在正修观行时，观空性是有的；无所得空是有的，所以名无得有得加行。
    唯识说虚妄分别是有，能取、所取的空性是有，所以或称有宗。这如弥勒菩萨辨中边论颂说：‘虚妄分别有’，先肯定虚妄分别是有的；‘于此二都无’，于虚妄分别所现的二取，是不可得的；‘此中唯有空’，此虚妄分别心中，唯有空性；‘于彼亦有此’，于彼空性中，众生位上，是有虚妄分别的。虚妄分别及空性是有，是唯识宗的根本见解。说空性是有，就是说真如是有，法性是有，涅槃是可证得的。说虚妄分别心是有，所以生死是有，灭除以后，可以得到解脱。这样，‘故知一切法，非空非不空’。一切法不只是空的，也不只是不空的，这就是中道。‘有无及有故，是则契中道’。虚妄分别是有；能取、所取是无；及有故是：虚妄分别心中有空性，空性中有虚妄分别。这样，才契合于佛说的中道。
    上来所说的，是悟入无分别智的加行，要得到般若无分别智，要依此修行：有得加行；无得加行；进而有得无得加行；再进而无得有得加行。依这样的现观次第，可以证悟真理，无分别智现前。中国的唯识学者，成立五重唯识观，在唯识经论中，可说从来没有此说。一切唯识经论，从弥勒，到无著，世亲，说到唯识观，都如本论所说的。
    2.12624 悟入无分别智性相 悟入于性相，当知由三种：谓由住法性，依住无二取，离言法性故。第二由无现，二取及言说，根、境、识、器世，悉皆不见故。以是此即明：无所观、无对，无住、无所现，无了、无依处。无分别智相。如经所宣说：由现一切法，见如虚空故；及一切诸行，见如幻等故。
     性是自体，相是相状或义相。任何存在的，不能有言无实，一定要以相知性，有这样的相，可知有这样的法，如说‘了别为性相’，‘思量为性相’，就从了别与思量的相，知有了别性、思量性的存在。那末，怎样理解无分别智的性相呢？约三种说，因为无分别智，根本虽是现证的无分别智，但从加行到现证，现证以后，都有无分别的意义，所以无分别智有三种：加行无分别智，根本无分别智，后得无分别智。
    第一种，“由住法性”：无分别智所证悟的，是法性，真如。在说明上，智慧与法性，好像是相对的，智慧是能证的，法性、真如是所证的。这是方便说，为众生是不能不这么说的。众生界是相对界，语言，思惟，没有不是相对的；为众生说法，也不能不说相对的智与法性。在说明中，好像智慧是智慧，法性是法性，智慧能证真如，然与证悟的意义，这是不亲切的。要知道，无分别智不是一般的智慧，一般的智慧是虚妄分别的，是有能见、所见，能知、所知的。无分别智是无分别的，是没有能所的，换言之，没有主观、客观，能知、所知的对立意义。本论说是‘由住法性’，无分别智安住在法性中。住，是安住，有深深契合法性，融然如一的意义。法性是无相的，无能取、所取，无能诠、所诠，真如法性是这样的；真正的无分别智现前，就安住法性中，也就是这样的。“依住无二取，离言法性故”，这两句，应读为依住无二取法性，依住离言法性。依住，是依住于法性；无二取是离能取、所取的法性；离言是离能诠、所诠的法性。所以真正无分别智现前，安住在法性中，法性是无二取，离名言，无分别智也是无二取，离名言；法性是这样，无分别智也是这样，无二无别。依安住法性，显示无分别智的性相，这是第一种。
    第二、“由无现”：无分别智相，由六种相不现来说明。真正的无分别智现前，有六种相不现，总括了一切法不现，无现就是不现的意思。“二取，及言说，根、境、识、器世，悉皆不见”。这六相不现了，即一切法相不现。二取不现，言说不现，如上依住法性所说，法性离能取、所取──二取，离能诠、所诠，所以无分别智现前，这二种相是不现起的。下面四种是：无根、无境、无识、无器世界相。一般的心识活动，一定有三方面：有根、有境、有识。例如以眼见来说，一定有眼根，眼根不坏。依佛法说，在眼睛瞳人内，有一种很微细，很精妙的物质，名为净色根，近于现代所说的视神经；依此而能见的，名为眼根。眼根见色，一定有青、黄、赤、白、长的、短的、圆的、方的色境，为眼根所取（境相影现在眼瞳人中）。如没有境界，眼根无所取，也就不会见了。眼根是生理作用，色境似乎是在外面的对象，依眼见色而引起眼识的了别，是心理的作用。根、境、识这三种互相交涉，才能成为认识，所以说：（根、境）二和生识，（根、境、识）三和合触，这是一般人的认识。无分别智是不是心？上说：说他是心，与一般的心理活动不同；说不是，又好像是心，从修习观行所引起的，有点近于心。一般的心，是不离根、境、识的作用；但无分别智现前时，根、境、识，都不起作用，不现起根、境、识相。所以，真正的般若现前，决不是见到什么，听到什么，想像到什么，一切相、一切法不现，唯是安住法性的自证。器世，是我们的依住处，也就是所处的自然环境。我们住在地球上；缩小说，我们住在台湾；再缩小些，现在住在讲堂内。无论如何，总有个依住的器界。但无分别智现前，器界相也不现前，所以说：虚空粉碎，大陆平沈。无分别智现前，真正的证悟，是一切不现，一切法不可得的。
    本论所说的无现，六种相不现，是依大乘经所说的，所以颂说：“以是此即明，无所观、无对，无住、无所现，无了、无依处”。依上面所说的六种无现，即解明了经里所说的无所观......无依处。无所观等六种无，般若经、宝积经等，都有说到。但经说不一定是六无，这可能是经说的详略不同，或是翻译者的简略。本论所说的六种无，配合经说的六种无，这是说：无所观是二取不现前。没有所取相，没有能取相，没有能观、所观，叫无所观。无对是无言说，一切语言文字，都是相对而立的，如离相对，一切语言文字是不可得的，所以无对是无言说。无住是无根，根不现的意思。心识是依根而起的，似乎依根而住，依根而发生一样；所以根不现起，经内称为无住。无所现是无境，没有所现的境相。无了是无识，识的定义是了别。无依处是无器世界，器世界是众生所依住的，所以器世界不现，经中名为无依处。本论约六种不现：二取、言说、根、境、识、器世不现，解说经中的：无所观、无对，无住、无所现，无了、无依处。以六种无现，说明无分别智性相。
    无分别智的第三相，是引经说的，如以说：“无分别智相，如经所宣说”。无分别智，主要是证悟法性的证智，但依经立论，有三种无分别智：一、加行无分别智；二、根本无分别智；三、后得无分别智。什么是加行无分别智？这是在没有证悟，得根本无分别智以前，修唯识观行。如有得加行，无得加行，有得无得加行，无得有得加行，其中所取相不可得，能取相不可得，真如相不可得，那种观察慧，是无分别的观察，名无分别观。没有得到证悟的无分别智，但依无分别的观慧为加行，能引起这真正的无分别智，所以这种智慧，名为加行无分别智。众生一向是虚妄分别，处处分别，所以流转生死。要离分别，却不可能一下无分别，佛法的方便善巧，就是用分别来破除分别。无分别观察，观察能取、所取，能诠、所诠不可得，这种观察慧，也是一种分别，但不是随顺世俗的分别，虽还是分别，而是随顺胜义，向于胜义的分别，有破坏分别，破坏种种妄识的功能。所以修唯识无分别观，无分别观也是分别抉择；依无分别的分别，渐次深入，达到虚妄分别的彻底除遣，证入无分别法性，以分别观智，遣除虚妄分别，譬喻很多，例如以小橛出大橛。如竹管里本来是空的，但有木橛塞在里面，有什么办法恢复竹管的中空呢？可以另取一根小木橛，对准大的木橛，用力推击他，等到大木橛出来了，小木橛也跟著出来了，恢复了竹管中空的本相。分别抉择的无分别观慧，是分别而遣除分别，所以名为加行无分别智。本论没有谈到，因为已在正加行中说过了。
    根本无分别智，是证悟法性的无分别智，于一切法都无所见。以中国佛学来说，这是但空（偏空），或是但中了。其实，菩萨现证法性是超越了一切相对界，体证真如，是超越的绝对，而不是拟议的圆融。菩萨在定中证悟了，出定以后，起二种心：一是一般的有漏世俗心，一是无漏的分别心。无漏的分别心，依无分别智证悟而起的，所以名为后得无分别智。后得无分别智也有二类：一，离二取相，离名言相的真如，但不是亲证真如的。后得无分别智的体悟真如空性，如从梦中醒来时，觉到方才梦境是这样的，其实那时的心境，知道梦境而与梦里的境界不一样。根本无分别智是离相的，后得无分别智是有相的，所以是带相观空的。二，后得无分别智，能了解一切法如幻如化。我们口说如幻如化，认识到的一切法，都是计执为实有的，那里能知道如幻如化？证悟真如以后，起后得无分别智，才能了解世间一切法都是如幻如化。
    现在说第三无分别智性相，是依经所说的。经上这样说：一、“由现一切法，见如虚空故”。这，可以解说根本无分别智，而主要是后得无分别智。现前的一切法，见一切法犹如虚空。云气不是虚空，光明不是虚空，日、月和星都不是虚空，蔚蓝色也不是虚空；只可说虚空是毕竟清净无著无碍，无二无别。唯识学以虚空譬喻圆成实性，所以这可能是根本无分别智，但这是依现起的一切法，见如虚空，不是一切不现，所以是后得智的带相观空。二、“及一切诸行，见如幻等故”，这是后得无分别智的达有。诸行的行，是迁流造作的意义。迁流所以是有生有灭的，变化不息的世间一切法，那一样不是行？后得智见一切诸行都是如幻的；如幻法虽非实有，却确有如幻相现起，所以后得无分别智，见一切法如幻，虽见一切法，与凡夫、二乘所见到的不同。
    中国天台宗，华严宗，称为圆教。在最初证悟时，以为就能证悟事理无碍，事事无碍，即空即假即中。如说菩萨先以根本智通达空性，次以后得智通达一切有如幻，就认为不圆满，不究竟。可是印度的大乘，无论是龙树菩萨的中观，弥勒、无著、世亲菩萨的唯识，都与中国的圆教不同。当然，究竟成佛时，是空有一如，理事无碍，法法更互涉入，但菩萨修行悟入，是有次第的。先要证悟一切法不现前，通达空性。然后起如幻智，通达一切有。起初是彼此出没，有前后的，久久才能二谛圆融无碍。唯识宗对于无分别智，分别为根本智，后得智，就表示先后的意义。密严经说：‘非不见真如，而能了诸行，皆如幻事等，虽有而非真’。这可见没有通过真如的证悟，是不能通达诸行如幻的。龙树菩萨也说：‘般若将入毕竟空，绝诸戏论；方便将出毕竟空，严土化生’。般若就是根本无分别智，使我们证入毕竟空，那时是没有一切戏论相的。从般若起方便，就是后得无分别智。起方便智，才能达有──庄严净土，利益众生，起种种如幻如化的事业。所以印度大乘经论，对于修行证悟的历程，都是先证得一切法性；再起后得无分别智，了一切法如幻如化。
    无分别智的性相有三种：一、是住法性，二、是无现，是依根本无分别智说的，三、依经说，明后得无分别智，观一切相如虚空，了一切是幻有。从这样的智相，显出无分别智的自性。
    2.12625 悟入无分别智胜利 悟入胜利四：得圆满法身，得无上安乐，得知见自在，得说法自在。
     无分别智，有什么“胜利”、功德？有“四”种功德胜利，都是依无分别智的证悟而得到的。初地菩萨最初得无分别智，证得真如空性；起后得智，通达诸行如幻。初地菩萨的智慧甚深，有广大神通。可是初地的智慧是有出入的：证空的根本无分别智时，不能了达一切如幻如化；等到后得智了达一切法如幻，又不能亲证法性，所以二种智慧是有出没的，不同时的。修行到第五地，才能二智并观，一念中通达一切法空，同时能了达一切法如幻。一是无相的，一是有相的，要从同一无相中并观理事，这是极不容易到达的，所以第五地名难胜地。五地菩萨的二智一念并观，不能常常如此。有时又起根本智，不起后得智；或后得智，又不起根本智，一直要到八地菩萨，才能任运并观，这二种智慧，会自然而然的并观，打成一片似的。八地菩萨的任运并观，还只是自利方面如此，如起利他事业，还不能自然而然的，不能完全没有功用。证悟空性与了达诸行，直到成佛，才能究竟，所以或说见中道成佛。菩萨初证时，得无分别智，又起后得无分别智，到成佛才是究竟圆满的无分别智。无分别智这一名词，浅一些，四加行位修唯识观，名加行无分别智；切实的说，初地菩萨才是无分别智；以后一直到成佛，究竟圆满。这一切智慧，所以名无分别智，因为无分别法性相契应。现在说无分别智慧的胜利，约一分说，可通于初地菩萨以上；约究竟圆满说，就是佛地，佛果位的智慧，佛的菩提所有的功德。
    一、“得圆满法身”：法身，如约法性本来清净说，一切众生都是如此。但要经累劫修行，从无分别智现前，到究竟最清净法界，无边白法所成，一切功德所成身，才是圆满法身。功德圆满的法身，依无分别智而成就，所以是无分别智所得的胜利，法身也名为智法身。菩萨修行成佛，是依无分别智为根本，为主导的，所以大般若经说：五度等一切功德，如瞎子一样，只有般若才是有眼目的；般若摄导六度等一切功德，趣向萨婆若（一切智），直到佛位。
    二、“得无上安乐”：无上安乐是究竟的涅槃。涅槃的意义，一方面是种种障碍苦恼的消散，一方面是离苦所得的安乐。不过，安乐是各式各样的，世间也有世间的安乐，但这是有系缚的安乐，安乐会引起以后的苦痛；有时候，快乐和苦痛，简直分辨不出，到底是快乐，还是苦痛。出世的安乐，是离妄执的安乐，在佛法中名为离系乐。没有执著的，没有系缚的乐，是无漏的安乐，与世间的安乐不同。二乘也能得离系乐，如证得阿罗汉的，究竟涅槃，乐是消极的，只是从没有苦痛来说。但大乘菩萨，修行到成佛，具足了永恒的安乐，究竟的安乐。所以在涅槃中，安立常、乐、我、净，乐是四德之一。这是常乐，永恒的乐，也就是无上的安乐。
    三、“得知见自在”：无分别智修行到成佛，一切功德圆满而得法身，法身是不离开知见的。知与见，都是智慧，智慧的功用。本来眼也是见，不是知，知乃心识的作用。知不一定是见，如或是听来的，或是推论出来的，假想得来的，这样的知，都不是见，因为不是直接的，明确的。现在综合知见为一词，这是知得非常深刻，明了，如见到一样。所以佛法中，都以眼来代表智慧，如五眼中，除肉眼、天眼外，慧眼、法眼、佛眼，都是智慧的别名。佛果所有的一切智慧，都是最亲切的，直接的现量智，如眼见一样。佛的一切知见，无论是证空、达有，自利、利他，都是无障碍的自在，念念遍知一切，任运自然，所以说一切知见自在。
    四、“得说法自在”：一般说法师，那是不要说了，就是大菩萨说法，也不能自在。经说九地菩萨，得四无碍辩，说法无碍，但这话是有限的。九地菩萨为九地菩萨说，能一切自在吗？如对方是十地菩萨，能无碍吗？当然不会的。所以真能说法自在无碍的，唯有佛。说法，与说话，作文一样，一般都是要思考的。如出席会议，请你说几句话，得心里想一想，今天讲些什么。即使没有定腹稿的，到了那地方，也得看看情形，或听别人讲些什么。如什么都不想，一下子跑上去，怕说不上来，说也说得不合理想。作文也是这样，总是要考虑一下的。但是佛的究竟无分别智，是不加功用的，不用思虑，自然能任运自在，应什么机说什么，说得恰到好处，名为说法自在。


2.12626 悟入无分别智遍知

    2.12626 悟入无分别智遍知
     2.126261 标列 悟入遍知者，当知有四相：谓对治遍知，及自相遍知，诸差别遍知，五作业遍知。
     对于转依，本论以十种相来说明。第六相──悟入所依住，也以六相悟入，现在是第六相，悟入无分别智“遍知”。遍知是于一切法而莫不通达的，无分别智是遍知。证悟真理的智，断种种的障，去种种妄执，起种种妙用，这都是遍知相。遍知的含义很广，所以又标列“四相”，然后分别解释。标列四相是：一、“对治遍知”，约对治妄执以显示遍知；二、“自相遍知”，显无分别智的自相；三、“诸差别遍知”，对小乘以显无分别的殊胜──差别；四、“五作业遍知”，无分别智所起妙用，能作种种自利、利他的一切事业。
    2.126262 别释
     2.1262621 对治遍知 其对治遍知，谓无分别智，对治五妄执：即妄执有法、数取趣、变坏，异、及损减性。
     “对治遍知”，明对治种种妄执的遍知相。“无分别”智遍破一切妄执，不是暂时的“对治”，而是彻底的克服，消解一切妄执。换言之，只有真正的般若，才能断一切妄执。所以譬喻说：‘般若如大火聚，四边不可触’。这是说般若──无分别智，如大火聚，各式各样的执著，一触到般若，都不能存在。般若能够遍破一切妄执，断息一切戏论，本论扼要的举出“五”种“妄执”，为无分别遍智所对治。
    一、对治“妄执有法”，这是法执。法字的意义，如‘辨法法性论’，法是生死的一切。但这里，法与数取趣相对。数取趣──补特伽罗我执，是于自己或其他有情身心上，看作一独立自体，有一实在的生命主体，就是实有补特伽罗，名补特伽罗（我）执。如眼所见的青、黄、赤、白等，耳所听到种种声音等，六根、六境、六识，都是法。有情界的血、肉、筋、脉等，器世界的山、河、大地，草、木、丛林等，以及年、月、星宿等，六识所得到的一切，都名为法。众生是没有不执取法为实有的，如唯心所现的能取、所取，能取是心，所取是境，我们终觉得心和境都是实有的。地球、太阳，无边星宿，是想为实有的；如说极微，即是小到不是眼耳所能经验的，如原子、电子等，听到了也觉得他是实有的。这六识的境界，了别到什么，都好像实有性的；就是能了别的识，也觉得是实有的。这种妄执有法，是无分别智所能对治遣除的，所以第一种就是叫妄执有法。
    二、对治妄执“数取趣”：上面已说过，梵语补特伽罗，是不断的受生死（趣）者，一生又一生的不断受生。于生死轮回中，执有生命自体，从今生到来生，从人间到天上，来来去去，就是这补特伽罗的来去。佛教徒信轮回──流转吗？确信作善业的死了生于人间、天上了；作了恶，要堕落到地狱去。但一般人，听说生来死去，总好像有个生命自体，生到天上，堕入地狱。于是说恶人下生到畜生趣去，就说变畜生，好像人变了猪、羊一样，这都是由于妄执实有补特伽罗我执所引起的妄执。自我的妄执，是普遍的，凡夫是没有人能远离的。依唯识宗说：我执，小乘学者，以无常、苦、空、无我的正观，观身心中我不可得，得无我正见，就能断我见得解脱了。通达我空的智慧，名为我空（或作生空）智。大乘菩萨修行断执，与小乘不一样。菩萨要正观一切唯心所现，离能取、所取，一切法不现，体悟清净法性。那时，能断我执，也能断法执；从初地菩萨，到成佛才究竟断尽。所以平常说：小乘断我执，大乘断我法二执。虽然中观宗不一定这样说，但唯识宗确是这样说的。上面所断二种妄执，小乘智慧能破实有数取趣我执，能破我见；大乘菩萨以无分别智，通达我法二空，断我法实有性的妄执。法执与数取趣我执，实包括了一切的妄执，我执、法执外，还有什么执呢！
    下面约另一意义，又别出三种妄执。
    三、对治“变坏”妄执：平常说，一切是无常的，无常所以都是要坏的。这种通俗的话，佛弟子也是在这样说的。但进一步推求，变坏是怎样的变坏？如执著有实法，慢慢地变化，到最后坏尽，那是妄执。佛法说变坏，推论到刹那刹那，即生即灭，不承认有暂住而渐渐变坏的。进一步说，我们所见到的一切，似乎生灭变化，其实一切法本性不生不灭。所以如执有实在法，渐渐的变坏，那是一种妄执。如幻如化，即生即灭的坏相，看作实在了，而想像为渐渐的变坏，是与真实事理不相应的。以变坏为妄执，无论中观宗，唯识宗，都是一样的。一切法性本不生灭，无分别智现证法性，能对治对于生灭变坏的妄执。楞伽经上说，有好多外道，说种种意义的变坏，依大乘唯识，都属于妄执。就是小乘部派中，如执实有生灭，也是妄执。当然，佛说无常，也说变坏，但佛说的意义，是与世俗的变坏见不同的。
    四、对治“异”妄执：异即差别。在这生死世界里，相对界是无限的差别，可说都是差别相。这种差别观念，习以成性，觉得一切都是差别的。即使听到说法与法性，生死与涅槃，烦恼与菩提，有为与无为，也觉得是各各差别的。无往而不差别的妄执，无分别智现前，就能对治，因为无分别智也名无差别智，现证法性、真如，是无二无别、平等平等的。所以一切差别相，都是虚妄所现，而众生随而妄执，唯有现证这无分别智，能对治这别异相。
    五、对治“损减性”妄执：什么是损减性妄执？这在唯识学中，是有重要意义的。没有的东西，我们以为他是有的；不是这样的，而我们觉得它是这样的，这叫增益妄执。它本不是这样，我们给他附加了什么上去，如执有法，执有我，执有差别，执有变异，都是增益的妄执。另有损减妄执，那是应该有的，的确有的，而我们以为没有，是有而执为没有，就是损减性妄执。例如不承认有轮回，以为死了什么都没有了，这是损减性妄执。唯识宗所说的损减性妄执，最要紧的是：如以为一切法都是空的，就是损减性的妄执。因为，虚妄分别有，虽不是真实有的，却不能说没有，如说没有，那一切能取、所取等，一切从那里来呢？所以唯识宗与中观宗──空宗的重要诤论，就是说一切皆空（经所说）是不了义，应该依三性来解说，依他起性──虚妄分别是有的，不能说是空的；圆成实空性是空所显性，也不是空的。无分别智，能对治损减性的妄执。至于空宗怎样的答覆，这里且不加讨论。中观以如幻如梦等喻，说一切法空。唯识宗说：梦境是没有的，但梦境也可发生作用。有人梦醒时，觉得好辛苦；有人在梦中，身体上会起一种变化。所以如幻如化，也不能说是空的，什么都没有的。所以世间法，唯识宗分为二类：一、虽妄执为有，其实是没有的；二、虽在法性中不可得，但在世俗谛中不可说没有的。应该有而以为没有，就是损减性妄执。
    无分别智能对治，除遣这五种妄执，就是对治遍知。
    2.1262622 自相遍知 自相遍知者：远离不作意，超寻伺、寂静，自性、执息念，五种为自相。
     “遍知”──无分别智的“自相”，不容易正面说明，所以从远离世俗的五种无分别，来表示这证悟法性的无分别智自性。因为，多少人听到无分别，都误会以为这就是无分别，佛法所说的无分别智，其实可能错了。楞伽经说：‘分别是识，无分别是智’，禅宗也常说这二句话。弥勒菩萨所开示的，真能证悟法性的无分别智，与一般所说，这样那样的无分别，是不同的。不相干的、错误的无分别，应把他清理出去，所以说到这遍知自相，就是说五种的无分别都不是的。佛弟子应该多想一想，怕自以为然的无分别，正是五种中的一种！
    一、“远离不作意”的无分别：远离二字，是通贯下文的，远离不作意的无分别；远离超寻伺的无分别；远离寂静的无分别；远离自性的无分别；远离执息念的无分别。远离这五种无分别，才是真正的无分别智。所以，无分别智是离这五种不正确的无分别。不作意，与不注意的意义相近。在根、境相关涉而起识时，一定有作意，作意有引发识趣境的作用，如没有作意，那就视而不见，听而不闻，食而不知其味。眼前的境界过去，却不知道是什么；耳中似有声音，但也没有听进去，这就是不作意。如不起作意，就视而不见，嗅而不闻，似乎触对境界而心无分别。如禅宗的神会，劝人不作意修，以为是无分别（炖煌本坛经，六祖慧能是彻底否定不作意修的）。菩萨的无分别智，在修加行无分别智时，到任运现前，也是不作意的，但与直下就不作意，不作意而觉得什么都无分别，是大大不同的。不要以为是修行时，什么都不观察，什么都不分别，以为就是无分别。静坐中一切不作意，也能引发一些类似的定境，不知道这不是无分别智，而是心识萎缩，精神呆住，引起恍恍惚惚的幻境。
    二、远离“超寻伺”的无分别，比上一类要深一些。什么是超寻伺？寻与伺，是两种心所作用。以寻伺二字的世间解释：寻是东找西找的寻求，伺是伺察。伺也是在寻找，但方法不同。如猫找老鼠，跑东跑西的找，是寻；如发现鼠洞，猫就等在洞口，静静的等著老鼠出来，这就是伺。现在寻与伺的心所作用，都有推求分别的意义，但有粗有细：粗的分别名为寻，细的分别就是伺。人的说话，是依于寻伺的，如没有寻伺，就不会引发语言。在众生来讲，我们所处的是欲界，欲界众生一定是有寻、有伺的。修定而得初禅定的，定心中还是有寻有伺，所以初禅名有寻有伺三摩地。向上进修，在初禅与二禅间，名中间禅，中间禅名无寻有伺三摩地；那时，粗的分别没有了，细的分别还是有的。等到修得二禅，名无寻无伺三摩地，那时寻与伺都没有了，所以二禅以上，是超过寻伺的。如没有寻伺，就是无分别智，那末得二禅定，生二禅天的，都是得无分别智了！然二禅是定而不是慧，二禅天人还是凡夫，所以超寻伺的无分别，不是无分别智。在禅定心境中，到了二禅以上，像镜子照东西一样，来个什么，就现个什么，分别明了，可是没有寻伺的分别。在安静的定心中，了了分明，而没有寻伺的分别，也是很好的定了！但这样的无分别，不是无分别智。
    三、远离“寂静”的无分别：二禅已经是无寻无伺了，经三禅到四禅，或四禅以上，那时的定心，最寂静，最安静，没有些微激动，所以四禅以上名为不动。人都是会激动的，为什么会激动？喜、乐、忧、苦，这是会引起激动的。到了四禅，忧与苦，早已没有了；喜与乐也不再现起，唯是舍受。忧、苦、喜、乐──情绪的激动都没有了，所以四禅以上，是最寂静的。上面所说二禅的无寻伺，虽好像无分别，还有冲动的心情，到此时，一些激动的心情也没有了，佛法中名为寂静，如中夜无声一样。大家不要误会！这不是佛法所说的涅槃寂静，只是定境的寂静。表示证悟境界的术语，有些也应用于定境，如不动，寂静，无分别等。如误以定境的寂静为无分别智，那末四禅以上，都是大菩萨了！其实，四禅以上，还是共世间的禅定，所以这样的寂静，也不是无分别智。
    四、远离“自性”的无分别：什么是自性无分别？自体本来就是没有分别的。如桌子、板凳，从来就是没有分别的。这样，土、石、树木、花草等物，都是自性无分别，不是经修行而达到的无分别。这种自性无分别，不是无分别智，否则，石头、泥土等，都成了圣智了。所以成佛，是凡夫修行所得的；无分别智，是分别心经修行而得无分别的。中国佛学所说‘无情有性’，‘无情成佛’，实是违反佛法的戏论！
    五、远离“执息念”的无分别：这是外道定。生死轮回不已，病根在什么地方？因有分别心，刹那刹那的念念不息。那有什么办法呢？如生灭心不起，意念不起，就可以得涅槃了。外道不知妄念的因缘，不知离妄念分别的正道，以为只要没有念就好了。所以执著息念，以息念法门而修行。不知这样的修行，即使修到了无念，还是外道禅。外道中有二：一为无想天，是属于四禅天的。外道以为，我们的妄念，依想而起，所以用灭想为方便。想是心所法，与一切心识相应，有心识就一定有想。外道修无想为方便，得定时，想没有了，六识也不起了，是无心定之一。依唯识学，得无想定的，没有六识，第七、第八识还是有的。外道如修成无想定，死后上升无想天，受五百劫无心的果报。修得了定，有些是会失掉的，可是得了无想定的，因为没有（六识）心，所以不会退失，一定要受长期无心的果报。二、是非想非非想定，是属于世间最高的禅定。有的外道以为：心念的生起时，一定有受与想相应。想，所以多起分别；受，所以有苦乐等情绪的不稳定，所以以止息受想为方便，将受与想止息下去，使它不起；受与想不起时，一切心心所都不起了。佛法名之为非想非非想定，是心识微细到似有似无的境地。无想定与非想非非想定，外道修得了，就以为是涅槃，无有分别。佛法认为这只是息念为先的定境，不是涅槃，当然也不是无分别智。我们知道，无分别智是要以分别力，修观行而成就的，不是不分别就是了，更不是把念压下而无心就是了。不作意，离寻伺，寂静不动，一切心识不起的定境，不离虚妄分别所摄，离不了唯心所现。所以说到无分别智，不要误会了，以为没有分别就是了。
    学佛的道友们，每为佛法的名词所误解。听说空，以为空是什么都没有了。听说无分别的，以为不作意，不寻伺，兀兀腾腾的什么都不问，以为能达到最高的无分别；也有以为少分别，少烦恼，如以为离想受可以得涅槃。佛法所说现证法性的无分别智，是要修加行的。要亲近善知识，听闻大乘法，如理作意，勤修止观。依唯识学，要理解唯心所现，修有得加行，无得加行，有得无得加行，无得有得加行，才能实现无分别智，体悟法性，真如。印度的大乘佛法，唯识与中观，都是闻、思、修；要修习止观，依止观得定慧。佛法是以慧为先导，以戒为基础，以定为方便，才能悟入。从前释迦牟尼佛，出家修行，起初跟二人修学，所修的就是定──无所有定，非想非非想定。释迦不满意，才到菩提树下，深观缘起法，通达法性而成佛的。这就是佛法与外道的不同处。佛法的证悟，从观慧而来，不是但依深定的。有的以观慧为分别，而专从禅定去达无分别，可说是根本颠倒了！
    2.1262623 差别遍知 差别遍知者，谓不分别性，及非少分性，无住与毕竟，并其无上相，是五种差别。
     “差别”，是不同的意思。菩萨“遍知”──无分别智，与二乘不同，胜于二乘的，也有五种。
    一、“不分别性”：菩萨根本无分别智现前，是不分别性的，也就是不是分别性的。众生的心识有能分别，有所分别，没有不分别的。二乘圣者的无漏智，由于执法有实性，所以是有分别性的。不分别性，显出了菩萨遍知的差别。
    二、“非少分性”：二乘能通达少分法性，于有情身心，通达无我空性；菩萨遍于一切法无分别证悟法性。菩萨智尽虚空、遍法界，于一切法无分别，不是二乘那样的少分性，所以说：二乘空如毛孔空，菩萨空如太虚空。
    三、“无住”：菩萨的无分别智，是无住的，无所住著。住是安住，有定住而不动的意思。众生是有所住的，住于生死，住在生死中，安定的，牢靠的，住在生死中，不能出离生死。凡夫住生死，二乘住涅槃。住涅槃，就落在涅槃中。凡夫住生死，声闻、缘觉住涅槃，住是住著，住著就局限定了。住涅槃有什么不好？如住涅槃，就远离生死，不能化度众生。如自己的生活好了，沉醉在舒服享受中，就忽略了别人的苦难一样。声闻、缘觉住在涅槃，依大乘法说，想发愿回心向大，也是很不容易的。但菩萨不住生死，不住涅槃，生死与涅槃，无二无分别，所以都无所住（或称为无住涅槃）。菩萨无分别智，离生死而证涅槃；虽契入涅槃，而悲愿熏心，不离生死，历劫化度众生。小乘与大乘无分别智，是这样的不同。
    四、“毕竟”：众生，二乘圣者，什么都是有局限性的。大乘无分别智，体悟一切法空性，这是超越时空性，超越数量的。所以，时间，空间，功德，化度众生等，一切是一切的一切，无穷无尽的。菩萨一直到成佛，成佛以后，是尽未来际度众生，这是无分别智的毕竟相，非凡夫、二乘所有。
    五、“无上相”：最究竟、最圆满的无分别智，是佛智。佛的无分别智，唯佛与佛，乃得究竟。佛佛平等，无上无等，再没有比这再高再上的，是无分别智的无上相。
    大乘的无分别智，从不分别性，非少分性，无住，毕竟，无上相──“五”相中，显出了无分别智的超越于二乘的“差别”相。
    2.1262624 作业遍知 最后业遍知：谓离诸分别；给无上安乐；令远离烦恼，无所知二障。其后所得智，而能正悟入，一切所知相，严净诸佛土，成熟诸有情；并能令生起，一切相智性。五种业差别。
     菩萨遍知中，“最后”是“遍知”“业”，是无分别智的业用。作业是（事）业用，也就是无分别智所起的大用。事业有五种，根本无分别智有三；后得无分别智有二，以下分别的解说。
    先以根本无分别智来说，
    一、“离诸分别”：离诸分别，一切分别不起，是无分别智的妙用，是无分别智中最主要的。
    二、“给无上安乐”：离一切分别，证得涅槃，涅槃是无上安乐。不是灰身泯智的二乘涅槃，是备有常、乐、我、净四德的大般涅槃。无上安乐，依无分别智离一切分别系缚而得。
    三、能离障：“远离烦恼”、“所知二障”。离烦恼障，没有所知障，是无分别智的作用。无分别智，上面已说能对治种种的妄执。能对治一切妄执，所以能离二障。障是障碍，烦恼障能碍涅槃，所知障能障大菩提，非离障是不能证涅槃，得大菩提佛果的。
    什么叫烦恼？烦恼本是种种不良心所法的通称。生起来的时候，使心识烦动恼乱，情绪不安定了，是非不明白了。烦恼很多，或是属于情感方面的，或是属于知识方面的，或是属于意志方面的。凡一切不如理的，不正常的不良的心理因素，都是烦恼。唯识宗分烦恼为二大类：
    一、烦恼障：根本烦恼有十种；随烦恼，又有大随、中随、小随等烦恼。一切烦恼，是以萨迦耶见──我见为主的。萨迦耶见是自我见，使我们以自我为中心而营为一切，起善、作恶，将来能得人天等乐报，地狱等苦报，在生死中流转。烦恼障能使我们感生死果，不能得涅槃，障碍涅槃。这种烦恼障，是二乘所共断的，断了烦恼障，才能了生死，得涅槃。烦恼障中，有见道所断的烦恼，修道所断的烦恼，古译或称为见、思烦恼。
    二、所知障：也还是种种烦恼，以萨迦耶见为中心的，但比烦恼障更微细。其重心是什么？所知障于一切所知法中，由于不悟法空性，对一切事理有所著，有所碍。如一切实有性等法执，就是所知障。我们不能了解如幻如化，就是有所知障在那里。所知是我们所知的一切法，我们不能恰恰好的去如实悟解，执著一切，而起错误的认识。那末，所知障是由于内心有微细烦恼，所以不能如实了解一切。有了这样的所知障，就不能成佛了，所以说所知障障大菩提。唯识宗有一句话说：‘所知本非障，被障障所知’。所知的境界自身，不能说是障，由于自己心理的执障，才障蔽了所知的真相。如戴了红色的眼镜，看来什么都是红色的；戴了凹凸眼镜，看出来都是弯弯曲曲，歪歪斜斜的。其实，所见的并没有变了样，只要除去红色或凹凸的眼镜，就见到真相了。如一切是唯心所现的，现起能取、所取，由于不知唯心所现，以为心是心，境是境，心境各有自性，这就是所知障所起。远离这所知障、烦恼障，是根本无分别智的妙用。能彻底的离障，才能得大菩提、大涅槃，圆满佛果。
    以下，是后得智的业用。根本智证真以后所生起来的智慧，是后得无分别智。后得，就是证真以后所得的。后得智的业用，有二：一、“能正悟入，一切所知相”：通达一切所知相，是通达一切法的如幻如化，种种无尽的，一切一切的所知法相。所以说：根本无分别智是平等智，后得智是差别智。佛菩萨不但通达平等真性，也依后得智，善巧一切，于一切无所不知。
    有了这悟入一切所知相，所以能完成二大工作：“严净诸佛土，成熟诸有情”。龙树菩萨也说：菩萨得了无生法忍（般若证悟法性）以后，就没有别的事了，专于方便利他，严净佛土，成熟众生。严净佛土，是菩萨遍到十方佛土，种种供养庄严，见佛，闻法；广修种种功德，庄严佛土。等到修行圆满成佛，就实现了最清净最圆满的佛土，不但庄严法身佛净土，还能引摄菩萨，于诸佛法会中，受用法乐：这就是严净诸佛土。成熟有情，只是应一切根机，现身、说法。有人天善根的，以人天法而成熟之；有声闻、缘觉善根的，以声闻、缘觉法门而成熟之；有大乘善根的，以大乘法门成熟他──使他发菩提心，修菩萨行，广度众生，究竟成佛。成熟，或译成就，就是使他成法器，善根成熟而能解脱。菩萨后得无分别智的利他，不外乎救度众生与庄严佛土；在利他中，完成佛果。小乘与大乘，这就是根本不同处：小乘以‘自利’为主，以解脱自身的生死，为唯一大事。对于众生，只是随缘摄化。有时往来出入，见到了人，多少说几句佛法，要他归依三宝，或劝他布施，持戒；有智慧善根的人，为说四谛法门，不能说不救度众生。但声闻的化度众生，是随缘的，缺少主动的大愿，所以不能为人作‘不请之友’。菩萨就不同了，菩萨以悲愿方便，利他为先，从根本无分别智起后得智，起无方妙用的时候，能与众生以不同程度的救度，尽未来际为众生。而且，声闻但重视有情的净化，菩萨更重视环境，也要净化国土。如阿弥陀佛完成了庄严清净的极乐世界，能摄受无数人到那边去，净土中容易修学，容易成就，容易不退转。大乘法一定会说到净土的，这就是菩萨后得智所起业用的特胜。
    后得智的第二业用，是“能令生起一切相智性”。佛智的名称很多，如一切智，一切智智，一切种智，一切相智。一切种智是一切法门通达一切法的佛智；一切相智，是通达一切法的一切相。所以一切相智与一切种智，意义相近，都是通达无尽一切法的佛智。这是菩萨的后得智，到了究极圆满，就成为佛的一切相智，所以是后得智所起的。
    菩萨遍知──无分别智的“业”用“差别”，共有“五种”：前三种属于根本无分别智的业用，后二种属后得无分别智的业用。无分别智的遍知，以对治、自相、诸差别、五作业，来说明，已说完了。以六相悟入所依住，广明无分别智，也到此为止。


2.127 悟入作意 悟入作意者，谓若诸菩萨，发心欲悟入，无分别智者，当作如是意：由不知真

2.127 悟入作意

    2.127 悟入作意 悟入作意者，谓若诸菩萨，发心欲悟入，无分别智者，当作如是意：由不知真如，起虚妄分别，名曰一切种，为现二取因，依此起异识；故彼因及果，虽现而实无，彼现法性隐，彼没法性现。若如是作意，菩萨即能入，无分别正智。
     “悟入作意”，是说要悟入转依，得无上大般涅槃，应该如何作意。这里，作意是意解，是观想。可以分为二段：一、作唯识理解；二、修唯识观行。假使菩萨“发心”，想“悟入无分别智”而得转依，那就应该起这样的意解，也就是这样的理解、思惟。这就是要知道：众生无始以来，“由不知真如，起虚妄分别，名曰一切种，为现二取因”。众生从来不曾知道真如、法性，因没有能通达法性，所以就起虚妄分别心。虚妄分别，是一切妄识的别名。虚妄分别的心心所法中，根本识名为一切种，一切种子识就是阿赖耶识的异名。阿赖耶识摄藏一切种子，从种子起现行，所以虚妄分别种子识，能变现而起能取、所取，为现起二取的因缘。到底为什么有虚妄分别呢？虚妄分别的所以生起，就因为不通达平等法性、真如，不通达真如，就起虚妄分别。这样说，有人要解说为迷真起妄了，好像真如本来清净，由于不了，以后才生起虚妄分别。其实，这是论理的前后，并不是时间的先后。什么是论理的前后？在理论上，平等法性是本来如此的，因为不通达法性，所以就有虚妄分别，所以说虚妄分别因不知真如而起，虚妄分别可灭而真如常住，可说虚妄分别是后起的。但这不是时间上的先后，决不能想像先有个真如，后来因为不悟真如，才生起虚妄分别。真如常住，是超越时间性，所以想像有时间的先后，是颠倒见。应该说，从无始以来，就是这样的，不悟真如而起虚妄分别。一切种，在唯识学上，是阿赖耶识，一切种子为生起一切的根源。一切种是虚妄分别的生死根源，一切种起虚妄分别，虚妄分别能摄持一切种，虚妄分别与一切种，是不一不异的。无始以来为恶习所熏成的虚妄分别，就是一切种阿赖耶识，为现起二取的因。“依”于能取、所取的变现，“起”种种别“异识”。什么是别异识？能取、所取──二取，就是别异。在能取中，眼识、耳识、鼻识、舌识、身识、意识、末那识，一一都是别异，在所取中，色、声、香、味、触等，山河、大地、草木、丛林，一切是唯识所现的差别相，一切唯识为性，可以称为识的。
    这样，一切种是因，虚妄分别是果；虚妄分别是因，能取所取是果。“故彼因及果，虽现而实无”。依因有果，因果的种种差别，其实都是不可得的，只是虚妄分别所现──唯识现而已。虚妄分别如乌云一样，真如如虚空一样。“彼现法性隐，彼没法性现”，这就是虚妄分别种子现起时，就不知法性、真如，如乌云聚集，明净的虚空就隐而不见了。如虚妄分别的一切种子没有的话，法性就显现清净，如乌云消散而显出明净的虚空一样。迷悟、染净的转依，应这样的理解！
    “若如是作意，菩萨即能入，无分别正智”。这是结说。菩萨发心要悟入无分别智，证入法性而得转依，要有上面所说那样的作意。众生无始以来，不悟真如，起虚妄分别，有一切种子阿赖耶识。有了一切种子识，自然的现起能取所取，因果展转，起种种异识，在生死流转中，不能解脱。这唯有了解虚妄分别所现，虽现而无实去求解决。这样的作意，菩萨就要入唯识法门，读大乘经论，理解唯心所现的道理，起唯识的决定胜解。有了这样的唯识正理的闻、思，进一步可以修观了。
    从缘知唯识，观识不得境；由境无得故，亦不得唯识。由此无得故，入二取无别，二别无所得，即无分别智。无境无所得，以是一切相，无得所显故。
    上来理解到，生死到涅槃──转依的正理，就是依唯识所现，而明迷悟、染净的正理。有了这样的理解，就要进一步修唯识观，观也就是作意。被称为方便唯识观的，是“从缘知唯识，观识不得境”。缘是所缘，了解到心识所缘的，一切唯识。根本是虚妄分别──妄识。依虚妄分别而显起一切，这一切当然以妄识为自性。在虚妄分别心所缘境界，似乎是存在于心外的，知道了一切都是唯识所现，所以观一切唯识而不得外境的实性。离了识以外，所取的境不可得，就是所取空。唯是识所现前，离心的所取境不可得，是唯识无境的正观。
    “由境无得故，亦不得唯识”，被称为真实唯识观。识与境是相对的，有境就有识，有识就有境，有漏的心识活动，确是如此的。现在，既观所取的境不可得，与境相对的识，也不可得，所以说亦不得唯识。依空宗说，这妄识也是空的；但唯识宗说，因外境空无，能取的内识也不能现起了，所以说不得唯识。
    “由此无得故，入二取无别”，由于观所取无所得，能取也无所得；境不可得，唯识也不可得，所以能悟入二取无别。能取不可得，所取不可得，同样的无得，无二无别。“二别”──能取所取的差别都“无所得”，能从观而悟入无得，“即无分别智”现前。妄识与分别智，有这样的根本不同：妄识一定有所取、所缘境相，如没有境，妄识是不能生起的。有心一定有境，所以密严经说：‘众生心二性，内外一切分’，众生心有二性，就是现有内外，内是能取，外是所取。有能取、所取，相互关涉，所以种种贪爱，种种执著，种种分别，都起来了。无分别智，决不是我不分别，不想就是了。一定要破除所取，因所取空而能取也不起，无分别智才能现前。无分别智与妄识不同，是没有所缘相的。无分别智证悟真如，真如无相，所以无分别智不是妄识那样，有真如相可得。一般心识的缘了境界，心内一定有所缘的影像；没有影像相，就不可能知道。无分别智是没有影像相的，所以叫无所取，无能取，能所双忘，也就是无分别智，是超越主观客观的自证。
    总结的说：“无境无所得”，境是没有的，由无境而能取、所取都无所得。这样，“以是一切相，无得所显故”。在无分别智证中，一切相都是以无所得而显出真如。如般若波罗蜜多心经说：‘以无所得故’。一切法都无所得，就是般若，也就是无分别智。在无分别智证悟中，一切相不可得。所以，如以为证悟是这样那样的，是不可信的。从前，香港有一位禅师：劝人参禅，他的方法特别快，几天就可以开悟。他对他的弟子说：你看，你看，你找啊！有弟子问他：‘师父！你到底找到了什么东西’？他说：‘我好不容易才找到了，头颈后面亮亮的’。那是笑话！真正的证悟，那里是这样的相？证悟无分别智现前，一切法都无所得，佛也不能说是什么的。
    依悟入作意说，要这样的理解唯识所现，除二取而灭虚妄分别，才是唯识法门的主题。
    2.128 悟入无分别智遍知 悟入地加行 悟入地，于四相当知：由胜解加行，于胜解行地，是顺抉择位。各别证加行，即于初地中，是触真实位。由修习加行，于未净六地，及三清净地，是为随念位。由究竟加行，任运佛事业，相续不断故，此即是达到，彼智体性位。
     ‘加行’一词，上面说过，含义是有宽有狭的。现在所说加行位，是广义的。在修行历程中，一切的功用，努力，都叫加行。进一步说，佛的无方妙用，从十地菩萨进修到成佛，成佛的利生大用，也还是加行。所以这里所说的“加行”，是广义的。修行到成佛，一步步的前进，用“四相”来说，也就是四种不同的阶段。唯识宗立五位：资粮位，加行位，见道位，修道位，究竟位。从菩萨发心到成佛，分成五个阶段。现在所说加行的四位，没有说第一资粮位。资粮位虽修福德、智慧资粮，还没有修唯识正观，对于悟证转依，差得太远，所以不说。从加行位说起，就只有四位了。
    一、“胜解加行”：胜解是深刻的理解，达到坚定不拔的阶段。胜解不是真实的体验，不过也不是一般平常的了解。依唯识说，这是深解一切唯识，而修唯识观的。“胜解行地”，就是暖、顶、忍、世第一法──四加行位；地是经历的地位，修胜解行的地位，名胜解行地。这是初地菩萨以前的，修唯识而到初地证悟的阶段，那一不长的时期，名胜解行地。胜解行地，“是顺抉择位”；那时候的智慧，又名顺抉择分善根。什么叫顺抉择？真正能抉择真理，那是证悟了。修暖、顶、忍、世第一法──四加行，观所取空，观能取不可得，观所取、能取──二取都无所得，这种观察慧，是顺于抉择的。换言之，是倾向抉择，引到真正的抉择、证悟的，所以叫顺抉择位。暖、顶、忍、世第一法，修顺于抉择、证悟的观慧，就是上面所说的：有得加行，无得加行，有得无得加行，无得有得加行；修这四种加行的阶段，是胜解行地。胜解行地，一般说，可通于初地以前的十住，十行，十回向，不过本论专指十回向末了，起四加行时，名胜解行地。
    二、“各别证加行”：菩萨初证真如──见道位，初地菩萨所起加行，名各别证加行。证悟真如、法性的加行，为什么名为各别证加行？各别证是各别自证，证得一一法的本性──自性。真如法性是一切法的通相，但不是抽象的普遍的理性，而是一一法的法性；一一法的法性，无二无别，所以或说为通相──共相。是一一法的本性，所以说各别证，但又不是一法一法去体认，而是一证一切证的。前面曾说到自内证，正就是这各别证。中国人欢喜说一，如说一真法界，其实真如、法性无二无别，无二而又是不著一的。各别证加行在“初地”菩萨见道位，就“是触真实位”。触是直接体验到的，真如的亲切证悟，名触真实位。各别证加行，与胜解行的加行不同，胜解行是加行无分别智，各别证是根本无分别智。
    三、“修习加行”：由修习加行，“于未净六地，及三清净地，是为随念位”。随念，是随顺根本无分别智，依证悟的法性清净，于一一法不断的体验、修习，趣向圆满。随念位是修道位，名‘修习加行’。依菩萨十地说：初地归入触真实位；二地、三地、四地、五地、六地、七地，名为未清净六地；八地、九地、十地，是三清净地。也可以说：从初地到六地，是未净六地；七地、八地、九地，是清净三地。未净与清净的差别在那里？菩萨地中，从初地到六地，名有相有功用地；七地名无相有功用地；八地到十地，名无相无功用地。前有相，所以初地到六地菩萨，无分别智悟入真如，一切相都不现。当然清净了；但后得无分别智起，相又现起，有相与无相间杂，一下子有相，一下子无相，所以名未净六地。八地菩萨以上，无相无功用，二谛并观，真俗无碍。七地菩萨以上，才是纯无相观，八地、九地、十地，名三清净地。第七地无相而有功用，在清净与未净之间，如在两国中间一样。可说清净；约有功用，也可说未净。修道位菩萨的地地加行，是修习加行。
    四、“究竟加行”：从十地菩萨后心到成佛，所起的名究竟加行。十地菩萨的时间很长，到了十地菩萨的最后心，一念圆证中道，也可说真俗无碍，事事无碍，到了最究竟，最彻底的阶位。虚妄分别习气一些也没有了，所以说烦恼、所知二障的粗重习气，全部断除之时。十地圆满的最后一念，进入佛位的加行，名究竟加行。由究竟加行，圆成佛道，能“任运”──自然而然的施为一切“佛事业”。佛的身业、语业、意业，都有自利、利他的一切妙用，都是自然而然的，名为任运。任运的佛事业，“相续不断”的尽未来际，所以名为常。以究竟加行，到达成佛，才是真正到达了，“彼智体性位”。佛以无分别智证真如，真如最清净，无分别智最究竟为体性。如如、如如智无二无别，名为法身；法身是智法身，是以无分别智圆满显发清净法性为体。经中或名为法界体性智，法界体性智就是佛的体性智。上来所说四加行，各各不同，一步一步的深入，也一步一步的圆满。究竟圆满成佛，是究竟转依，大菩提与大般涅槃，圆满成就。
    下面说转依有二种相：一为过患相，一为功德相，这是一正一反的。什么是过患相，功德相？意思说，如没有转依，有一切的过失，佛法的一切功德，都不能成立；反之，有了转依，一切功德能成立，一切都没有过失，这说明了，为什么要说转依，转依是后期大乘──唯识与如来藏学所说的。转依的自性，是无垢真如。迷真如法性，有虚妄分别，现二取相；悟真如法性，能断惑，修道，得涅槃，菩提，成就智法身。转迷启悟的佛法，都不离真如法性而成立。
    2.129 悟入无分别智遍知 悟入过患 悟入过患者，谓若无转依，有四种过患：无断惑依过；无修道依过；无诸涅槃者，施设依处过；三菩提差别，施设无依过。
     如没有转依，“有四种过患”：一、“无断惑依过”，就是断惑没有著落，断烦恼就没有依止。二、“无修道依过”，修道──以悟入真如，没有依处，没有著落。三、“无诸涅槃者，施设依处过”。什么是涅槃？涅槃依什么而说？如没有转依，也没有施设涅槃的依处了。四、“三菩提差别，施设无依过”。三菩提是声闻、缘觉、佛的菩提，这三种菩提，如没有转依，那三种菩提也亦无从施设了。所以，修行断烦恼，要转依；修道证真，也要转依；涅槃要转依；菩提，阿耨多罗三藐三菩提，也都要转依。如没有转依，断惑，证真，涅槃，菩提，都无从安立，这就是后期大乘，特明转依的理由所在。
    一、无断惑依过：断惑（烦恼障、所知障）与证真是相应的，证悟的一念无分别智现前，就断除了见道所断的惑障；证真如光明的显现，断惑如黑暗的消散。本论上文说到转依的自性，是：‘谓客尘诸垢，及与真如性，不现及现义，即无垢真如’。真如是转依自性，无始以来为客尘诸垢──惑障所蒙蔽，不得显现无垢清净；转依就是转灭客尘诸垢，转显真如清净。客尘诸垢等虚妄法，是依附真如的，但真如不受惑染，而终究可以转去的。在断惑中，如断惑证真时，眼、耳、鼻、舌、身、意等识没有了，烦恼也没有了，一切相都不现前。但惑障并没有断尽，见道证真以后，从真出俗，二取相又现前了，还有烦恼障习气，所知障现行、习气，所以并没有成佛。真见道时，一切相不现，毕竟清净，怎么还有未断的惑障，惑障保留在什么处呢？当然不在无分别智中。因为无始以来，法性本来清净，而为这虚妄习气所熏染。虚妄分别习气与真如，虽真妄不一，而虚妄却依于真如。所以无分别智现证，虽一切不可得，而虚妄分别的二取习气还在──依于真如。所以要经长期修行，二取习气彻底断了，虚妄分别彻底不起才是纯无相行，圆成佛道。中国佛教有一句话：‘一念清净一念佛’，那是不知道惑障次第尽的实际情形了！虚妄分别的习气依于真如法性，如乌云依于虚空。乌云依于虚空，但不能说是从虚空生的，虚空不生乌云，乌云却依虚空而有。所以说断惑而得转依，是以真如法性为依而说转的。经中说到：如来藏为依、为住，为建立故，有生死，有涅槃。虚妄杂染法，依附如来藏，而不是如来藏，是离、是异，真如法性在虚妄隐覆中，名为如来藏。惑障依于真如，真如离惑障，无垢真如是转依自性，所以说，假使没有转依，就没有断惑的依止，断惑障就不能成立了。
    二、无修道依过：修道也是以清净真如为依。修道，从听闻佛法，知有佛法开始。修布施、供养、持戒，修定，修观察慧。这样的修行，都是虚妄分别，都是有漏，这有什么用？以真如法性为依，所以修道是有用的。听闻佛法，所听闻的是法界等流，是从佛证悟法性所流出的圣教。从佛或佛弟子听法，能熏习成出世心种子。这是虚妄分别的，是世间有漏的，却发生向于真如法性的作用。能破坏虚妄分别，达到证悟真如，成为无漏圣道。那时，戒、定、慧一切功德，都与法性相应，与真如不离、不异。这样，修道才有了意义。无漏圣道，一得永得，菩萨的展转进修，功德也愈修愈大，修到究竟圆满而成佛。所以说修道，必有转依，自性──真如为依止，否则，没有清净真如为依止，修道也不能成立了。
    三、无诸涅槃者，施设依处过：涅槃，为三乘圣者所归趣，究竟依什么施设──安立？没有苦恼，没有忧愁，种种虚妄颠倒都没有，什么都没有，就是涅槃吗？不是的！不能说什么都没有就是涅槃。涅槃是依转依而施设的；一切虚妄杂染都没有了，清净法性就显现，也就依清净法性而安立为涅槃。如不说转依，无有无垢真如的转依自性，那涅槃是施设无依了。
    四、三菩提差别施设无依过：声闻菩提，独觉菩提，成佛的阿耨多罗三藐三菩提；菩提的意义是觉，觉是以清净法性转依而建立的。如以生空智慧，通达生空无分别性；通达生空真如的，是声闻菩提、独觉菩提。如以圆满的无分别智，通达我、法空性、真如，修到圆显最清净法界；圆满无分别智性，就是阿耨多罗三藐三菩提──无上正等正觉。这样，声闻、独觉、佛的菩提，都是依真如、法性而建立的，所以金刚经说：‘一切贤圣，皆以无为法而有差别’。如没有转依自性──无垢真如，那三乘菩提，都有无依的过失，三乘菩提也成为不可能了。没有转依，断惑、修道，涅槃、菩提，都不能成立，也就没有佛法，过患可太大了！
    2.1210 悟入无分别智遍知 悟入功德 当知彼相违，四相入功德。
     知道了没有转依的四种过患，就知道与上面“相违”反的，也有“四相”悟“入”有转依的“功德”。有了转依，断惑到究竟清净，一切都能成立了。有转依自性，从有漏修行，到无漏修行，经十地菩萨圣道而达究竟圆满，也可以成立了。三乘的涅槃，三乘的菩提，有转依自性而可以施设了。佛法修证成圣的事，一切都依之成立，这就是功德。这就是唯识学特别重视转依的理由。


2.2 喻说 广说转依，有法说，有喻说，上以十种相，法说转依。以下以譬喻来说明。

2.2 喻说

    2.2 喻说 广说转依，有法说，有喻说，上以十种相，法说转依。以下以譬喻来说明。
     于无而现有，喻如梦、幻等。转依则喻如：虚空、金、水等。
    在本论的最后，举二种譬喻，来总结本论的论义。
    2.21 虚妄分别喻：从虚妄分别现起能取、所取，各各差别境界，是“于无而现有”的。实在是没有自体的，但现起而在我们的认识中，好像是真实有的。于无而现有所举的譬喻，是“如梦、幻”。梦境，好像是有的，见到这样，那样，或喜笑，或啼哭；有时梦境非常明白，但梦不是真实的。幻，上面已说过，如以手巾结成兔子，会跳，会叫，可是只是手巾，那里有兔子！于无而现有的譬喻，譬虚妄分别，一切有为法。经中所举的很多，或说如梦、幻、泡、影等六喻，或说九喻，或说十喻，本论略举梦、幻二喻，以等其他的譬喻，譬说于无而现有的有为诸行。
     2.22 转依喻：转依自性，无垢真如，从虚妄分别所染，转化到显现究竟清净“转依”的譬“喻”，本论举“虚空、金、水”三喻。可以譬喻转依的，是不止此三喻的，所以末有等字。经中，论中，说到这三种譬喻的，极为普遍。虚空本来明清，或为乌云所遮，或是大雾，或是风沙大作，天昏地黑，虚空清净相就不显现了。如乌云散了，雾散了，风沙停止了，虚空明净就显出来了。这转依自性，有二种清净：一、本性清净，二、离垢清净。本性清净，如乌云遮著虚空时，看起来不清净，其实虚空还是那样的，本来是清净的。等到没有乌云时，那时的虚空清净，譬如真如的离垢清净。转依自性是真如，转依是从客尘诸垢所染，转为离垢的毕竟清净。
     金喻，如开采金矿，金与矿内的沙、石、土等，混在一起，当然是不清净了，也没有见到黄金。将金矿加以冶炼，成为纯金，那时最清净的金子显出来了，可用金来作成庄严具。当虚妄分别现前时，如矿中的金砂一样，见它不清净，有的还不知道是金呢！经过冶炼，炼成十足真金，可以做种种器具，种种庄严具。正如我们经修行，消融虚空分别，无垢真如就转依而成佛了。大用无方，法身、报身、化身，起自利、利他一切功德业。
    水喻，如下大雨时，流水，污浊得很。水为什么不清净？因为尘土和水混在一起，所以成为浑水。如水澄静一下，尘土下沉，把尘土抽去，就成清水了。如加热使水成为水蒸气，冷后成为蒸馏水，那是最清净了。其实，水质本来是清的。真如法性转依，也是这样。虚妄分别时，不见真如清净，一切是烦恼、业、生死杂染。经修行而显现真如清净，就像浑水的转为清水一样。水的功用极大，一切生物都依水而滋长；如佛德广大，一切众生都蒙佛的恩德。
    学大乘人，应观虚妄分别，似有无实，是如梦如幻的。应观转依自性──清净真如，如虚空、金、水那样。似有而实无的，可以消解灭去，所以能出生死。真如本性清净，依之而可以断惑，可以修道；涅槃与菩提果德，也依之而成立。本论辨法法性：法──生死法，可以从前面二譬喻来了解；法性──涅槃，可以从后三譬喻去了解。这二类譬喻，作为全部论义的总结。
    （宏观记）