了凡四训大意

了凡四训

1 | 了凡四训
2 | 了凡四训大意－改造命运的秘诀(净空法师)

佛学指归http://ofo.coc.cc制作收录


了凡四训

                                    袁了凡

    《第一篇立命之学》

    《第二篇改过之法》

    《第三篇积善之方》

    《第四篇谦德之效》

    【袁了凡居士传】

    《第一篇立命之学》

    余童年丧父，老母命弃举业学医，谓可以养生，可以济人，且习一艺以成名，尔父夙心
也。后余在慈云寺，遇一老者，修髯伟貌，飘飘若仙，余敬礼之。

    语余曰：「子仕路中人也，明年即进学，何不读书？」余告以故，并叩老者姓氏里居。

    曰：「吾姓孔，云南人也。得邵子皇极数正传，数该传汝。」余引归，告母。

    母曰：「善待之。」试其数，纤悉皆验。余遂启读书之念，谋之表兄沈称，

    言：「郁海谷先生，在沈友夫家开馆，我送汝寄学甚便。」余遂礼郁为师。孔为余起
数：县考童生，当十四名；府考七十一名，提学考第九名。明年赴考，三处名数皆合。复为
卜终身休咎，言：某年考第几名，某年当补廪，某年当贡，贡后某年，当选四川一大尹，在
任三年半，即宜告归。五十三岁八月十四日丑时，当终於正寝，惜无子。余备录而谨记之。

    自此以后，凡遇考校，其名数先后，皆不出孔公所悬定者。独算余食廪米九十一石五斗
当出贡；及食米七十一石，屠宗师即批准补贡，余窃疑之。后果为署印杨公所驳，直至丁卯
年(西元1567年)，殷秋溟宗师见余场中备卷，叹曰：「五策，即五篇奏议也，岂可使博洽
淹贯之儒，老於窗下乎！」遂依县申文准贡，连前食米计之，实九十一石五斗也。余因此益
信进退有命，迟速有时，澹然无求矣。

    贡入燕都，留京一年，终日静坐，不阅文字。己巳(西元1569年)归，游南雍，未入
监，先访云谷会禅师於栖霞山中，对坐一室，凡三昼夜不瞑目。

    云谷问曰：「凡人所以不得作圣者，只为妄念相缠耳。汝坐三日，不见起一妄念，何
也？」

    余曰：「吾为孔先生算定，荣辱生死，皆有定数，即要妄想，亦无可妄想。」

    云谷笑曰：「我待汝是豪杰，原来只是凡夫。」问其故？

    曰：「人未能无心，终为阴阳所缚，安得无数？但惟凡人有数；极善之人，数固拘他不
定；极恶之人，数亦拘他不定。汝二十年来，被他算定，不曾转动一毫，岂非是凡夫？」

    余问曰：「然则数可逃乎？」

    曰：「命由我作，福自己求。诗书所称，的为明训。我教典中说：『求富贵得富贵，求
男女得男女，求长寿得长寿。』夫妄语乃释迦大戒，诸佛菩萨，岂诳语欺人？」

    余进曰：「孟子言：『求则得之』，是求在我者也。道德仁义可以力求；功名富贵，如
何求得？」

    云谷曰：「孟子之言不错，汝自错解耳。汝不见六祖说：『一切福田，不离方寸；从心
而觅，感无不通。』求在我，不独得道德仁义，亦得功名富贵；内外双得，是求有益於得
也。若不反躬内省，而徒向外驰求，则求之有道，而得之有命矣，内外双失，故无益。」

    因问：「孔公算汝终身若何？」余以实告。

    云谷曰：「汝自揣应得科第否？应生子否？」余追省良久，

    曰：「不应也。科第中人，有福相，余福薄，又不能积功累行，以基厚福；兼不耐烦
剧，不能容人；时或以才智盖人，直心直行，轻言妄谈。凡此皆薄福之相也，岂宜科第哉。

    地之秽者多生物，水之清者常无鱼；余好洁，宜无子者一；和气能育万物，余善怒，宜
无子者二；爱为生生之本，忍为不育之根；余矜惜名节，常不能舍己救人，宜无子者三；多
言耗气，宜无子者四；喜饮铄精，宜无子者五；好彻夜长坐，而不知葆元毓神，宜无子者
六。其馀过恶尚多，不能悉数。」

    云谷曰：「岂惟科第哉。世间享千金之者，定是千金人物；享百金之产者，定是百金人
物；应饿死者，定是饿死人物；天不过因材而笃，几曾加纤毫意思。

    即如生子，有百世之德者，定有百世子孙保之；有十世之德者，定有十世子孙保之；有
三世二世之德者，定有三世二世子孙保之；其斩焉无后者，德至薄也。

    汝今既知非。将向来不发科第，及不生子之相，尽情改刷；务要积德，务要包荒，务要
和爱，务要惜精神。从前种种，譬如昨日死；从后种种，譬如今日生；此义理再生之身。

    夫血肉之身，尚然有数；义理之身，岂不能格天。太甲曰：『天作孽，犹可违；自作
孽，不可活。』诗云：『永言配命，自求多福。』孔先生算汝不登科第，不生子者，此天作
之孽，犹可得而违；汝今扩充德性，力行善事，多积阴德，此自己所作之福也，安得而不受
享乎？

    易为君子谋，趋吉避凶；若言天命有常，吉何可趋，凶何可避？开章第一义，便说：
『积善之家，必有馀庆。』汝信得及否？」

    余信其言，拜而受教。因将往日之罪，佛前尽情发露，为疏一通，先求登科；誓行善事
三千条，以报天地祖宗之德。

    云谷出功过格示余，令所行之事，逐日登记；善则记数，恶则退除，且教持准提咒，以
期必验。

    语余曰：「符录家有云：『不会书符，被鬼神笑。』此有秘传，只是不动念也。执笔书
符，先把万缘放下，一尘不起。从此念头不动处，下一点，谓之混沌开基。由此而一笔挥
成，更无思虑，此符便灵。凡祈天立命，都要从无思无虑处感格。

    孟子论立命之学，而曰：『夭寿不贰。』夫夭寿，至贰者也。当其不动念时，孰为夭，
孰为寿？细分之，丰歉不贰，然后可立贫富之命；穷通不贰，然后可立贵贱之命；夭寿不
贰，然后可立生死之命。人生世间，惟死生为重，曰夭寿，则一切顺逆皆该之矣。

    至修身以俟之，乃积德祈天之事。曰修，则身有过恶，皆当治而去之；曰俟，则一毫觊
觎，一毫将迎，皆当斩绝之矣。到此地位，直造先天之境，即此便是实学。

    汝未能无心，但能持准提咒，无记无数，不令间断，持得纯熟，於持中不持，於不持中
持。到得念头不动，则灵验矣。」

    余初号学海，是日改号了凡；盖悟立命之说，而不欲落凡夫窠臼也。从此而后，终日兢
兢，便觉与前不同。前日只是悠悠放任，到此自有战兢惕厉景象，在暗室屋漏中，常恐得罪
天地鬼神；遇人憎我毁我，自能恬然容受。

    到明年(西元1570年)礼部考科举，孔先生算该第三，忽考第一；其言不验，而秋闱中
式矣。然行义未纯，检身多误；或见善而行之不勇，或救人而心常自疑；或身勉为善，而口
有过言；或醒时操持，而醉后放逸；以过折功，日常虚度。自己巳岁(西元1569年)发愿，
直至己卯岁(西元1579年)，历十馀年，而三千善行始完。

    时方从李渐庵入关，未及回向。庚辰(西元1580年)南还。始请性空，慧空诸上人，就
东塔禅堂回向。遂起求子愿，亦许行三千善事。辛巳(西元1581年)，生男天启。

    余行一事，随以笔记；汝母不能书，每行一事，辄用鹅毛管，印一朱圈於历日之上。或
施食贫人，或放生命，一日有多至十馀者。至癸未(西元1583年)八月，三千之数已满。复
请性空辈，就家庭回向。九月十三日，复起求中进士愿，许行善事一万条，丙戌(西元1586
年)登第，授宝坻知县。

    余置空格一册，名曰治心篇。晨起坐堂，家人携付门役，置案上，所行善恶，纤悉必
记。夜则设桌於庭，效赵阅道焚香告帝。

    汝母见所行不多，辄颦蹙曰：「我前在家，相助为善，故三千之数得完；今许一万，衙
中无事可行，何时得圆满乎？」

    夜间偶梦见一神人，余言善事难完之故。神曰：「只减粮一节，万行俱完矣。」盖宝坻
之田，每亩二分三厘七毫。余为区处，减至一分四厘六毫，委有此事，心颇惊疑。适幻余禅
师自五台来，余以梦告之，且问此事宜信否？

    师曰：「善心真切，即一行可当万善，况合县减粮，万民受福乎？」吾即捐俸银，请其
就五台山斋僧一万而回向之。

    孔公算予五十三岁有厄，余未尝祈寿，是岁竟无恙，今六十九矣。书曰：「天难谌，命
靡常。」又云：「惟命不於常」，皆非诳语。吾於是而知，凡称祸福自己求之者，乃圣贤之
言。若谓祸福惟天所命，则世俗之论矣。

    汝之命，未知若何？即命当荣显，常作落寞想；即时当顺利，常作拂逆想；即眼前足
食，常作贫窭想；即人相爱敬，常作恐惧想；即家世望重，常作卑下想；即学问颇优，常作
浅陋想。

    远思扬德，近思盖父母之愆；上思报国之恩，下思造家之福；外思济人之急，内思闲己
之邪。

    务要日日知非，日日改过；一日不知非，即一日安於自是；一日无过可改，即一日无步
可进；天下聪明俊秀不少，所以德不加修，业不加广者，只为因循二字，耽阁一生。

    云谷禅师所授立命之说，乃至精至邃，至真至正之理，其熟玩而勉行之，毋自旷也。

    《第二篇改过之法》

    春秋诸大夫，见人言动，亿而谈其祸福，靡不验者，左国诸记可观也。大都吉凶之兆，
萌乎心而动乎四体，其过於厚者常获福，过於薄者常近祸，俗眼多翳，谓有未定而不可测
者。至诚合天，福之将至，观而必先知之矣。祸之将至，观其不善而必先知之矣。今欲获福
而远祸，未论行善，先须改过。

    但改过者，第一，要发耻心。思古之圣贤，与我同为丈夫，彼何以百世可师？我何以一
身瓦裂？耽染尘情，私行不义，谓人不知，傲然无愧，将日沦於禽兽而不自知矣；世之可羞
可耻者，莫大乎此。孟子曰：耻之於人大矣。以其得之则圣贤，失之则禽兽耳。此改过之要
机也。

    第二，要发畏心。天地在上，鬼神难欺，吾虽过在隐微，而天地鬼神，实鉴临之，重则
降之百殃，轻则损其现福，吾何可以不惧？不惟此也。闲居之地，指视昭然；吾虽掩之甚
密，文之甚巧，而肺肝早露，终难自欺；被人觑破，不值一文矣，乌得不懔懔？不惟是也。
一息尚存，弥天之恶，犹可悔改；古人有一生作恶，临死悔悟，发一善念，遂得善终者。谓
一念猛厉，足以涤百年之恶也。譬如千年幽谷，一灯才照，则千年之暗俱除；故过不论久
近，惟以改为贵。但尘世无常，肉身易殒，一息不属，欲改无由矣。明则千百年担负恶名，
虽孝子慈孙，不能洗涤；幽则千百劫沈沦狱报，虽圣贤佛菩萨，不能援引。乌得不畏？

    第三，须发勇心。人不改过，多是因循退缩；吾须奋然振作，不用迟疑，不烦等待。小
者如芒刺在肉，速与抉剔；大者如毒蛇啮指，速与斩除，无丝毫凝滞，此风雷之所以为益
也。

    具是三心，则有过斯改，如春冰遇日，何患不消乎？然人之过，有从事上改者，有从理
上改者，有从心上改者；工夫不同，效验亦异。

    如前日杀生，今戒不杀；前日怒詈，今戒不怒；此就其事而改之者也。强制於外，其难
百倍，且病根终在，东灭西生，非究竟廓然之道也。

    善改过者，未禁其事，先明其理；如过在杀生，即思曰：上帝好生，物皆恋命，杀彼养
己，岂能自安？且彼之杀也，既受屠割，复入鼎镬，种种痛苦，彻入骨髓；己之养也，珍膏
罗列，食过即空，疏食菜羹，尽可充腹，何必戕彼之生，损己之福哉？又思血气之属，皆含
灵知，既有灵知，皆我一体；纵不能躬修至德，使之尊我亲我，岂可日戕物命，使之仇我憾
我於无穷也？一思及此，将有对食痛心，不能下咽者矣。

    如前日好怒，必思曰：人有不及，情所宜矜；悖理相干，於我何与？本无可怒者。又思
天下无自是之豪杰，亦无尤人之学问；有不得，皆己之德未修，感未至也。吾悉以自反，则
谤毁之来，皆磨炼玉成之地；我将欢然受赐，何怒之有？又闻而不怒，虽谗焰薰天，如举火
焚空，终将自息；闻谤而怒，虽巧心力辩，如春蚕作茧，自取缠绵；怒不惟无益，且有害
也。其馀种种过恶，皆当据理思之。此理既明，过将自止。

    何谓从心而改？过有千端，惟心所造；吾心不动，过安从生？学者於好色，好名，好
货，好怒，种种诸过，不必逐类寻求；但当一心为善，正念现前，邪念自然污染不上。如太
阳当空，魍魉潜消，此精一之真传也。过由心造，亦由心改，如斩毒树，直断其根，奚必枝
枝而伐，叶叶而摘哉？

    大抵最上治心，当下清净；才动即觉，觉之即无；苟未能然，须明理以遣之；又未能
然，须随事以禁之；以上事而兼行下功，未为失策。执下而昧上，则拙矣。

    顾发愿改过，明须良朋提醒，幽须鬼神证明；一心忏悔，昼夜不懈，经一七，二七，以
至一月，二月，三月，必有效验。

    或觉心神恬旷；或觉智慧顿开；或处冗沓而触念皆通；或遇怨仇而回镇作喜；或梦吐黑
物；或梦往圣先贤，提携接引；或梦飞步太虚；或梦幢幡宝盖，种种胜事，皆过消灭之象
也。然不得执此自高，画而不进。

    昔蘧伯玉当二十岁时，已觉前日之非而尽改之矣。至二十一岁，乃知前之所改，未尽
也；及二十二岁，回视二十一岁，犹在梦中，岁复一岁，递递改之，行年五十，而犹知四十
九年之非，古人改过之学如此。

    吾辈身为凡流，过恶猬集，而回思往事，常若不见其有过者，心粗而眼翳也。然人之过
恶深重者，亦有效验：或心神昏塞，转头即忘；或无事而常烦恼；或见君子而赧然相沮；或
闻正论而不乐；或施惠而人反怨；或夜梦颠倒，甚则妄言失志；皆作孽之相也，苟一类此，
即须奋发，舍旧图新，幸勿自误。

    《第三篇积善之方》

    易曰：「积善之家，必有馀庆。」昔颜氏将以女妻叔梁纥，而历叙其祖宗积德之长，逆
知其子孙必有兴者。孔子称舜之大孝，曰：「宗庙飨之，子孙保之」，皆至论也。试以往事
徵之。

    杨少师荣，建宁人。世以济渡为生，久雨溪涨，横流冲毁民居，溺死者顺流而下，他舟
皆捞取货物，独少师曾祖及祖，惟救人，而货物一无所取，乡人嗤其愚。逮少师父生，家渐
裕，有神人化为道者，语之曰：「汝祖父有阴功，子孙当贵显，宜葬某地。」遂依其所指而
窆之，即今白兔坟也。后生少师，弱冠登第，位至三公，加曾祖，祖，父，如其官。子孙贵
盛，至今尚多贤者。

    鄞人杨自惩，初为县吏，存心仁厚，守法公平。时县宰严肃，偶挞一囚，血流满前，而
怒犹未息，杨跪而宽解之。宰曰：「怎奈此人越法悖理，不由人不怒。」自惩叩首曰：「上
失其道，民散久矣，如得其情，哀矜勿喜；喜且不可，而况怒乎？」宰为之霁颜。

    家甚贫，馈遗一无所取，遇囚人乏粮，常多方以济之。一日，有新囚数人待哺，家又缺
米；给囚则家人无食；自顾则囚人堪悯；与其妇商之。

    妇曰：「囚从何来？」

    曰：「自杭而来。沿路忍饥，菜色可掬。」因撤己之米，煮粥以食囚。后生二子，长曰
守陈，次曰守址，为南北吏部侍郎；长孙为刑部侍郎；次孙为四川廉宪，又俱为名臣；今楚
亭，德政，亦其裔也。

    昔正统间，邓茂七倡乱於福建，士民从贼者甚众；朝廷起鄞县张都宪楷南征，以计擒
贼，后委布政司谢都事，搜杀东路贼党；谢求贼中党附册籍，凡不附贼者，密授以白布小
旗，约兵至日，插旗门首，戒军兵无妄杀，全活万人；后谢之子迁，中状元，为宰辅；孙
丕，复中探花。

    莆田林氏，先世有老母好善，常作粉团施人，求取即与之，无倦色；一仙化为道人，每
旦索食六七团。母日日与之，终三年如一日，乃知其诚也。因谓之曰：「吾食汝三年粉团，
何以报汝？府后有一地，葬之，子孙官爵，有一升麻子之数。」其子依所点葬之，初世即有
九人登第，累代簪缨甚盛，福建有无林不开榜之谣。

    冯琢庵太史之父，为邑庠生。隆冬早起赴学，路遇一人，倒卧雪中，扪之，半僵矣。遂
解己绵裘衣之，且扶归救苏。梦神告之曰：「汝救人一命，出至诚心，吾遣韩琦为汝子。」
及生琢庵，遂名琦。

    台州应尚书，壮年习业於山中。夜鬼啸集，往往惊人，公不惧也；一夕闻鬼云：「某妇
以夫久客不归，翁姑逼其嫁人。明夜当缢死於此，吾得代矣。」公潜卖田，得银四两。即伪
作其夫之书，寄银还家；其父母见书，以手迹不类，疑之。既而曰：「书可假，银不可假，
想儿无恙。」妇遂不嫁。其子后归，夫妇相保如初。

    公又闻鬼语曰：「我当得代，奈此秀才坏吾事。」

    旁一鬼曰：「尔何不祸之？」

    曰：「上帝以此人心好，命作阴德尚书矣，吾何得而祸之？」应公因此益自努励，善日
加修，德日加厚；遇岁饥，辄捐谷以赈之；遇亲戚有急，辄委曲维持；遇有横逆，辄反躬自
责，怡然顺受；子孙登科第者，今累累也。

    常熟徐凤竹〔木式〕，其父素富，偶遇年荒，先捐租以为同邑之倡，又分谷以赈贫乏，
夜闻鬼唱於门曰：「千不诓，万不诓；徐家秀才，做到了举人郎。」相续而呼，连夜不断。
是岁，凤竹果举於乡，其父因而益积德，孳孳不怠，修桥修路，斋僧接众，凡有利益，无不
尽心。后又闻鬼唱於门曰：「千不诓，万不诓；徐家举人，直做到都堂。」凤竹官终两浙巡
抚。

    喜兴屠康僖公，初为刑部主事，宿狱中，细询诸囚情状，得无辜者若干人，公不自以为
功，密疏其事，以白堂官。后朝审，堂官摘其语，以讯诸囚，无不服者，释冤抑十馀人。一
时辇下咸颂尚书之明。

    公复禀曰：「辇毂之下，尚多冤民，四海之广，兆民之众，岂无枉者？宜五年差一减刑
官，核实而平反之。」尚书为奏，允其议。时公亦差减刑之列，梦一神告之曰：「汝命无
子，今减刑之议，深合天心，上帝赐汝三子，皆衣紫腰金。」是夕夫人有娠，后生应埙，应
坤，应【俊】，皆显官。

    嘉兴包凭，字信之，其父为池阳太守，生七子，凭最少，赘平湖袁氏，与吾父往来甚
厚，博学高才，累举不第，留心二氏之学。一日东游泖湖，偶至一村寺中，见观音像，淋漓
露立，即解橐中十金，授主僧，令修屋宇，僧告以功大银少，不能竣事；复取松布四疋，检
箧中衣七件与之，内〔纟宁〕褶，系新置，其仆请已之。

    凭曰：「但得圣像无恙，吾虽裸裎何伤？」

    僧垂泪曰：「舍银及衣布，犹非难事。只此一点心，如何易得。」后功完，拉老父同
游，宿寺中。公梦伽蓝来曰：「汝子当享世禄矣。」后子汴，孙柽芳，皆登第，作显官。

    嘉善支立之父，为刑房吏，有囚无辜陷重辟，意哀之，欲求其生。囚语其妻曰：「支公
嘉意，愧无以报，明日延之下乡，汝以身事之，彼或肯用意，则我可生也。」其妻泣而听
命。及至，妻自出劝酒，具告以夫意。支不听，卒为尽力平反之。囚出狱，夫妻登门叩谢
曰：「公如此厚德，晚世所稀，今无子，吾有弱女，送为箕帚妾，此则礼之可通者。」支为
备礼而纳之，生立，弱冠中魁，官至翰林孔目，立生高，高生禄，皆贡为学博。禄生大纶，
登第。

    凡此十条，所行不同，同归於善而已。若复精而言之,则善有真，有假；有端，有曲；
有阴，有阳；有是，有非；有偏，有正；有半，有满；有大，有小；有难，有易；皆当深
辨。为善而不穷理，则自谓行持，岂知造孽，枉费苦心，无
益也。

    何谓真假？昔有儒生数辈，谒中峰和尚，

    问曰：「佛氏论善恶报应，如影随形。今某人善，而子孙不兴；某人恶，而家门隆盛；
佛说无稽矣。」

    中峰云：「凡情未涤，正眼未开，认善为恶，指恶为善，往往有之。不憾己之是非颠
倒，而反怨天之报应有差乎？」

    众曰：「善恶何致相反？」中峰令试言。

    一人谓「詈人殴人是恶；敬人礼人是善。」

    中峰云：「未必然也。」

    一人谓「贪财妄取是恶，廉洁有守是善。」

    中峰云：「未必然也。」众人历言其状，中峰皆谓不然。因请问。

    中峰告之曰：「有益於人，是善；有益於己，是恶。有益於人，则殴人，詈人皆善也；
有益於己，则敬人，礼人皆恶也。是故人之行善，利人者公，公则为真；利己者私，私则为
假。又根心者真，袭迹者假；又无为而为者真，有为而为者假；皆当自考。」

    何谓端曲？今人见谨愿之士，类称为善而取之；圣人则宁取狂狷。至於谨愿之士，虽一
乡皆好，而必以为德之贼；是世人之善恶，分明与圣人相反。推此一端，种种取舍，无有不
谬；天地鬼神之福善祸淫，皆与圣人同是非，而不与世俗同取舍。凡欲积善，决不可徇耳
目，惟从心源隐微处，默默洗涤，纯是济世之心，则为端；苟有一毫媚世之心，即为曲；纯
是爱人之心，则为端；有一毫愤世之心，即为曲；纯是敬人之心，则为端；有一毫玩世之
心，即为曲；皆当细辨。何谓阴阳？凡为善而人知之，则为阳善；为善而人不知，则为阴
德。阴德，天报之；阳善，享世名。名，亦福也。名者，造物所忌；世之享盛名而实不副
者，多有奇祸；人之无过咎而横被恶名者，子孙往往骤发，阴阳之际微矣哉。

    何谓是非？鲁国之法，鲁人有赎人臣妾於诸侯，皆受金於府，子贡赎人而不受金。孔子
闻而恶之曰：「赐失之矣。夫圣人举事，可以移风易俗，而教道可施於百姓，非独适己之行
也。今鲁国富者寡而贫者众，受金则为不廉，何以相赎乎？自今以后，不复赎人於诸侯
矣。」

    子路拯人於溺，其人谢之以牛，子路受之。孔子喜曰：「自今鲁国多拯人於溺矣。」自
俗眼观之，子贡不受金为优，子路之受牛为劣；孔子则取由而黜赐焉。乃知人之为善，不论
现行而论流弊；不论一时而论久远；不论一身而论天下。现行虽善，其流足以害人；则似善
而实非也；现行虽不善，而其流足以济人，则非善而实是也。然此就一节论之耳。他如非义
之义，非礼之礼，非信之信，非慈之慈，皆当抉择。

    何谓偏正？昔吕文懿公，初辞相位，归故里，海内仰之，如泰山北斗。有一乡人，醉而
詈之，吕公不动，谓其仆曰：「醉者勿与较也。」闭门谢之。逾年，其人犯死刑入狱。吕公
始悔之曰：「使当时稍与计较，送公家责治，可以小惩而大戒；吾当时只欲存心於厚，不谓
养成其恶，以至於此。」此以善心而行恶事者也。

    又有以恶心而行善事者。如某家大富，值岁荒，穷民白昼抢粟於市；告之县，县不理，
穷民愈肆，遂私执而困辱之，众始定；不然，几乱矣。故善者为正，恶者为偏，人皆知之；
其以善心行恶事者，正中偏也；以恶心而行善事者，偏中正也；不可不知也。

    何谓半满？易曰：「善不积，不足以成名；恶不积，不足以灭身。」书曰：「商罪贯
盈，如贮物於器。」勤而积之，则满；懈而不积，则不满。此一说也。

    昔有某氏女入寺，欲施而无财，止有钱二文，捐而与之，主席者亲为忏悔；及后入宫富
贵，携数千金入寺舍之，主僧惟令其徒回向而已。

    因问曰：「吾前施钱二文，师亲为忏悔，今施数千金，而师不回向，何也？」

    曰：「前者物虽薄，而施心甚真，非老僧亲忏，不足报德；今物虽厚，而施心不若前日
之切，令人代忏足矣。」此千金为半，而二文为满也。

    锺离授丹於吕祖，点铁为金，可以济世。

    吕问曰：「终变否？」

    曰：「五百年后，当复本质。」

    吕曰：「如此则害五百年后人矣，吾不愿为也。」

    曰：「修仙要积三千功行，汝此一言，三千功行已满矣。」此又一说也。

    又为善而心不著善，则随所成就，皆得圆满。心著於善，虽终身勤励，止於半善而已。
譬如以财济人，内不见己，外不见人，中不见所施之物，是谓三轮体空，是谓一心清净，则
斗粟可以种无涯之福，一文可以消千劫之罪，倘此心未忘，虽黄金万镒，福不满也。此又一
说也。何谓大小？昔卫仲达为馆职，被摄至冥司，主者命吏呈善恶二录，比至，则恶录盈
庭，其善录一轴，仅如筋而已。索秤称之，则盈庭者反轻，而如筋者反重。

    仲达曰：「某年未四十，安得过恶如是多乎？」

    曰：「一念不正即是，不待犯也。」因问轴中所书何事？

    曰：「朝廷尝兴大工，修三山石桥，君上疏谏之，此疏稿也。」

    仲达曰：「某虽言，朝廷不从，於事无补，而能有如是之力。」

    曰：「朝廷虽不从，君之一念，已在万民；向使听从，善力更大矣。」故志在天下国
家，则善虽少而大；苟在一身，虽多亦小。

    何谓难易？先儒谓克己须从难克处克将去。夫子论为仁，亦曰先难。必如江西舒翁，舍
二年仅得之束修，代偿官银，而全人夫妇；与邯郸张翁，舍十年所积之钱，代完赎银，而活
人妻子，皆所谓难舍处能舍也。如镇江靳翁，虽年老无子，不忍以幼女为妾，而还之邻，此
难忍处能忍也；故天降之福亦厚。凡有财有势者，其立德皆易，易而不为，是为自暴。贫贱
作福皆难，难而能为，斯可贵耳。

    随缘济众，其类至繁，约言其纲，大约有十：第一，与人为善；第二，爱敬存心；第
三，成人之美；第四，劝人为善；第五，救人危急；第六，兴建大利；第七，舍财作福；第
八，护持正法；第九，敬重尊长；第十，爱惜物命。

    何谓与人为善？昔舜在雷泽，见渔者皆取深潭厚泽，而老弱则渔於急流浅滩之中，恻然
哀之，往而渔焉；见争者皆匿其过而不谈，见有让者，则揄扬而取法之。期年，皆以深潭厚
泽相让矣。夫以舜之明哲，岂不能出一言教众人哉？乃不以言教而以身转之，此良工苦心
也。

    吾辈处未世，勿以己之长而盖人；勿以己之善而形人；勿以己之多能而困人。收敛才
智，若无若虚；见人过失，且涵容而掩覆之。一则令其可改，一则令其有所顾忌而不敢纵，
见人有微长可取，小善可录，翻然舍己而从之；且为艳称而广述之。凡日用间，发一言，行
一事，全不为自己起念，全是为物立则；此大人天下为公之度也。

    何谓爱敬存心？君子与小人，就形迹观，常易相混，惟一点存心处，则善恶悬绝，判然
如黑白之相反。故曰：君子所以异於人者，以其存心也。君子所存之心，只是爱人敬人之
心。盖人有亲疏贵贱，有智愚贤不肖；万品不齐，皆吾同胞，皆吾一体，孰非当敬爱者？爱
敬众人，即是爱敬圣贤；能通众人之志，即是通圣贤之志。何者？圣贤志，本欲斯世斯人，
各得其所。吾合爱合敬，而安一世之人，即是为圣贤而安之也。

    何谓成人之美？玉之在石，抵掷则瓦砾，追琢则圭璋；故凡见人行一善事，或其人志可
取而资可进，皆须诱掖而成就之。或为之奖借，或为之维持；或为白其诬而分其谤；务使成
立而后已。

    大抵人各恶其非类，乡人之善者少，不善者多。善人在俗，亦难自立。且豪杰铮铮，不
甚修形迹，多易指摘；故善事常易败，而善人常得谤；惟仁人长者，匡直而辅翼之，其功德
最宏。

    何谓劝人为善？生为人类，孰无良心？世路役役，最易没溺。凡与人相处，当方便提
撕，开其迷惑。譬犹长夜大梦，而令之一觉；譬犹久陷烦恼，而拔之清凉，为惠最溥。韩愈
云：「一时劝人以口，百世劝人以书。」较之与人为善，虽有形迹，然对证发药，时有奇
效，不可废也；失言失人，当反吾智。

    何谓救人危急？患难颠沛，人所时有。偶一遇之，当如恫【环】在身，速为解救。或以
一言伸其屈抑；或以多方济其颠连。崔子曰：「惠不在大，赴人之急可也。」盖仁人之言
哉。

    何谓兴建大利？小而一乡之内，大而一邑之中，凡有利益，最宜兴建；或开渠导水，或
筑堤防患；或修桥梁，以便行旅；或施茶饭，以济饥渴；随缘劝导，协力兴修，勿避嫌疑，
勿辞劳怨。

    何谓舍财作福？释门万行，以布施为先。所谓布施者，只是舍之一字耳。达者内舍六
根，外舍六尘，一切所有，无不舍者。苟非能然，先从财上布施。世人以衣食为命，故财为
最重。吾从而舍之，内以破吾之悭，外以济人之急；始而勉强，终则泰然，最可以荡涤私
情，〔衤去〕除执吝。

    何谓护持正法？法者，万世生灵之眼目也。不有正法，何以参赞天地？何以裁成万物？
何以脱尘离缚？何以经世出世？故凡见圣贤庙貌，经书典籍，皆当敬重而修饬之。至於举扬
正法，上报佛恩，尤当勉励。

    何谓敬重尊长？家之父兄，国之君长，与凡年高，德高，位高，识高者，皆当加意奉
事。在家而奉侍父母，使深爱婉容，柔声下气，习以成性，便是和气格天之本。出而事君，
行一事，毋谓君不知而自恣也。刑一人，毋谓君不知而作威也。事君如天，古人格论，此等
处最关阴德。试看忠孝之家，子孙未有不绵远而昌盛者，切须慎之。

    何谓爱惜物命？凡人之所以为人者，惟此恻隐之心而已；求仁者求此，积德者积此。周
礼，「孟春之月，牺牲毋用牝。」孟子谓君子远庖厨，所以全吾恻隐之心也。故前辈有四不
食之戒，谓闻杀不食，见杀不食，自养者不食，专为我杀者不食。学者未能断肉，且当从此
戒之。

    渐渐增进，慈心愈长，不特杀生当戒，蠢动含灵，皆为物命。求丝煮茧，锄地杀虫，念
衣食之由来，皆杀彼以自活。故暴殄之孽，当与杀生等。至於手所误伤，足所误践者，不知
其几，皆当委曲防之。古诗云：「爱鼠常留饭，怜蛾不点灯。」何其仁也！

    善行无穷，不能殚述；由此十事而推广之，则万德可备矣。

    《第四篇谦德之效》

    易曰：「天道亏盈而益谦；地道变盈而流谦；鬼神害盈而福谦；人道恶盈而好谦。」是
故谦之一卦，六爻皆吉。书曰：「满招损，谦受益。」予屡同诸公应试，每见寒士将达，必
有一段谦光可掬。

    辛未(西元1571年)计偕，我嘉善同袍凡十人，惟丁敬宇宾，年最少，极其谦虚。

    予告费锦坡曰：「此兄今年必第。」

    费曰：「何以见之？」

    予曰：「惟谦受福。兄看十人中，有恂恂款款，不敢先人，如敬宇者乎？有恭敬顺承，
小心谦畏，如敬宇者乎？有受侮不答，闻谤不辩，如敬宇者乎？人能如此，即天地鬼神，犹
将佑之，岂有不发者？」及开榜，丁果中式。

    丁丑(西元1577年)在京，与冯开之同处，见其虚己敛容，大变其幼年之习。李霁岩直
谅益友，时面攻其非，但见其平怀顺受，未尝有一言相报。予告之曰：「福有福始，祸有祸
先，此心果谦，天必相之，兄今年决第矣。」已而果然。

    赵裕峰，光远，山东冠县人，童年举於乡，久不第。其父为嘉善三尹，随之任。慕钱明
吾，而执文见之，明吾悉抹其文，赵不惟不怒，且心服而速改焉。明年，遂登第。

    壬辰岁(西元1592年)，予入觐，晤夏建所，见其人气虚意下，谦光逼人，归而告友人
曰：「凡天将发斯人也，未发其福，先发其慧；此慧一发，则浮者自实，肆者自敛；建所温
良若此，天启之矣。」及开榜，果中式。

    江阴张畏岩，积学工文，有声艺林。甲午(西元1594年)，南京乡试，寓一寺中，揭晓
无名，大骂试官，以为眯目。时有一道者，在傍微笑，张遽移怒道者。

    道者曰：「相公文必不佳。」

    张怒曰：「汝不见我文，乌知不佳？」

    道者曰：「闻作文，贵心气和平，今听公骂詈，不平甚矣，文安得工？」张不觉屈服，
因就而请教焉。

    道者曰：「中全要命；命不该中，文虽工，无益也。须自己做个转变。」

    张曰：「既是命，如何转变？」

    道者曰：「造命者天，立命者我；力行善事，广积阴德，何福不可求哉？」

    张曰：「我贫士，何能为？」

    道者曰：「善事阴功，皆由心造，常存此心，功德无量，且如谦虚一节，并不费钱，你
如何不自反而骂试官乎？」

    张由此折节自持，善日加修，德日加厚。丁酉(西元1597年)，梦至一高房，得试录一
册，中多缺行。问旁人，

    曰：「此今科试录。」

    问：「何多缺名？」

    曰：「科第阴间三年一考较，须积德无咎者，方有名。如前所缺，皆系旧该中式，因新
有薄行而去之者也。」

    后指一行云：「汝三年来，持身颇慎，或当补此，幸自爱。」是科果中一百五名。

    由此观之，举头三尺，决有神明；趋吉避凶，断然由我。须使我存心制行，毫不得罪於
天地鬼神，而虚心屈己，使天地鬼神，时时怜我，方有受福之基。彼气盈者，必非远器，纵
发亦无受用。稍有识见之士，必不忍自狭其量，而自拒其福也，况谦则受教有地，而取善无
穷，尤修业者所必不可少者也。

    古语云：「有志於功名者，必得功名；有志於富贵者，必得富贵。」人之有志，如树之
有根，立定此志，须念念谦虚，尘尘方便，自然感动天地，而造福由我。今之求登科第者，
初未尝有真志，不过一时意兴耳；兴到则求，兴阑则止。孟子曰：「王之好乐甚，齐其庶几
乎？」予於科名亦然。

    【袁了凡居士传】

    (原文系文言文，为清朝彭绍升撰)

    袁了凡先生，本名袁黄，字坤仪；江苏省吴江县人。年轻时入赘到浙江省嘉善县姓殳的
人家；因此，在嘉善县得了公费做县里的公读生。他於明穆宗隆庆四年(西元一五七○年)，
在乡里中了举人；明神宗万历十四年(西元一五八六年)考上进士，奉命到河北省宝坻县做县
长。过了七年升拔为兵部「职方司」的主管人，任中刚好碰到日寇侵犯朝鲜，朝鲜向中国求
救兵。当时的「经略」(驻朝鲜军事长官)宋应昌奏准请了凡为「军前赞画」(参谋长)的职
务，并兼督导支援朝鲜的军队。提督李如松掌握兵权，假装赐给高官俸禄与日寇谈和，日寇
信以为真，没有设防；李如松发动突击，攻破形势险要的平壤，因而打败了日寇。

    了凡先生因为这件事当面指责李如松，不应用诡诈的手段对付日寇，这样有损大明朝的
国威；而且李如松手下的士兵随便杀害百姓，并以头来记功。了凡向李如松据理力争，李如
松发怒；不但不接受劝诫，反而独自带著军队东走，使得了凡所率领的军队孤立无援。日寇
因而乘机攻击了凡的军队，幸赖了凡机智应对，将日寇击退。而李如松的军队，最后终於被
日寇击败了；他想要脱却自己的罪状，反而以十项罪名弹劾袁了凡；了凡很快地被提出审
判，终於在「拾遗」(谏官)的仕内，被迫停职返乡。在家里，了凡非常恳切，认真地行善直
到去世，过逝时享年七十四岁。

    明熹宗天启年间，了凡的冤案终於真相大白，朝廷追叙了凡征讨日寇的功绩，赠封他为
「尚宝司少卿」的官衔。了凡先生从当学生时，就非常喜欢研究学问，书不论古今，事不分
轻重，他都认真研究，并且非常通达。例如：星象，法律，水利，理数，兵备，政治，堪舆
等。

    了凡先生在宝坻县当县长时，非常注重人民的福利，常常想做些有利地方的事情；宝坻
县当时常有水灾泛滥，了凡先生於是积极兴办水利，将三汊河疏通，筑堤防以抵挡水患侵
袭；并且教导百姓沿著海岸种植柳树，每当海水泛滥，挟带沙土冲上岸时，遇到柳树就积挡
下来，久而久之变成一道堤防。於是了凡先生又督导百姓在堤防上建造沟渠，并鼓励百姓耕
种；因此，荒废的土地渐渐地开垦，了凡先生又免除百姓种种杂役以便民，使得百姓安居乐
业。

    了凡先生家里并不富有，可是却非常喜欢布施，家居生活俭朴，每天诵经持咒，参禅打
坐，修习止观。不管公私事务再忙，早晚定课从不间断。在这当中，了凡先生写下四篇短
文，当时命名为「戒子文」，用来训诫他儿子，就是后来广行於世的「了凡四训」这本书。

    了凡先生的夫人非常贤慧，经常帮助他行善布施，并且依照功过格记下所做的功德，因
为她没有读过书，不会写字；因此用鹅毛管沾红墨水，每天在历书上做记号。有时了凡先生
较忙，当天所做功德较少，她就皱眉头，希望先生能多做些善事。有一次，她为儿子裁制冬
天的大袍子，想买棉絮做内里。

    了凡先生问：「家里有丝绵又轻又暖和，为什麽还买棉絮呢？」

    了凡夫人答：「丝绵较贵，棉絮便宜，我想将家里的丝绵拿去换棉絮，这样可以多裁几
件棉袄，赠送给贫寒的人家过冬！」

    了凡先生听了非常高兴说：「你这样虔诚的布施，不怕我们孩子没有福报了！」

    他们的儿子袁俨，后来中了进士，最后以广东省高要县的县长退休。

    【袁了凡居士传】

    【注】

    (1)代用字：

    【俊】：如「俊」字形，「人」旁换成「土」旁

    【环】：取「环」字右侧，填入「病」中「丙」字的位置

    (2)本文输入和初校所据如下：

    了凡四训白话解释【精简本】

    著作：明朝，袁了凡

    演述：民初，黄智海

    整理：民国，王丽民(3)大阪魏世杰於1996年母亲节谨志

佛学指归（ofo.8u8.com)网站制作收录


了凡四训大意－改造命运的秘诀(净空法师)

     了凡四训大意－改造命运的秘诀(净空法师讲述,弟子邱淑真笔记)

    净空法师于一九九九年五月十七日在澳洲净宗学会讲《了凡四训》大意，为时五日。淑真亲聆音带，摘要记录，顺文整理，草成此篇，供养读者。

    ◎ 演讲缘起
    此次到澳洲，参加多元文化活动中心破土典礼。藉此机会，大家要我将《了凡四训》的大意讲一遍，我想这也很好。
    【印祖启示∶尽形寿竭力提倡印送数百万册。悟知三书乃世出世学必具因基。】

    现前时代动乱至极，正是《弥陀经》所说的「五浊恶世」。由于人心不善，造作十恶业，感得大灾难。佛弟子应以何种态度，看待此事？印光大师在《了凡四训》的序文中，讲得非常之好。印祖生于清末民初，是净宗一代祖师，一生中弘法利生，令人敬佩。他是陕西人，家乡口音很重，说的话大家听不懂，所以在弘法上有语言的障碍；因此，他是以文字来弘法，即现在的《印光大师全集》。他一生当中，讲经说法只有一次，在「上海护国息灾法会」上，讲了七天的开示，最后传授三皈五戒。这是他一生唯一的讲演，但是以印送经书、善书来弘法利生，可说是尽了一生的努力。

    印祖在世时，倍受中国佛教界的推崇，至今提起印光法师，无人不尊敬。其一生所印之经书中，以《了凡四训》、《感应篇汇编》及《安士全书》，分量最多，超过三百万册。大量印行流通这三种书，这是为了挽救现前劫难。要想挽救现今灾难，佛法虽然好，但是来不及了。佛法太深，懂得的人愈来愈少，依照佛法修学的人也愈来愈少。而这三种书籍比较通俗，确实可以挽救目前的灾难。

    西方有许多预言家，就像《了凡四训》里的孔先生一样，博学多闻，精通天文地理，所以对于许多事情的推论相当正确。但是他们只知道这些现象的发生，不知道如何去化解，所以都说是世间人造作罪业，违背上帝的意思，上帝发脾气要惩罚众生，这是他们的理念。这是只知其一，不知其二。我从这些地方体会到，印祖大量宣扬此三本书的用心。我请翻译组的同学，赶紧将《了凡四训》译成英文，向全世界流通，让大家知道∶劫难是我们自己造的，我们有能力去化解。真正了解其所以然之理，才有办法救自己，帮助别人。

    ◎ 四训宗旨
    《了凡四训》是袁了凡先生对儿子的教诲，教他如何做人处事、如何消除灾难、如何修善积福。在中国，用这些话勉励下一代的人非常之多，不只了凡先生一人。因为了凡先生是虔诚的佛教徒，所以佛门一些高僧大德替他宣扬，特别是印光大师，所以才有这么大的流通量，对社会造成影响。但是我们要知道，自古至今，像了凡先生这种修学成就的，不胜枚举。总而言之，此书是说明因果的道理，要我们深信因果。
    此段分成「总示」与「别明」，先做整体介绍。
    【人定数、事定数】
    人有定数，事也有定数。定数就是一般人讲的命运，命运确实是能够推算出来的。不论中国人、外国人，对算命、看相、看风水都很有兴趣。

    【（迷）有，（悟）无】
    云谷禅师讲得好，「定数是迷了就有，觉悟了就没有」。六道凡夫迷，四圣法界也迷，还没有觉悟，超越十法界才是真正的大圣。迷悟的标准就是见性，明心见性才称为「悟」，没有明心见性都是「迷」。迷就落在数量里，高明的人就晓得你生生世世的命运；佛菩萨、大圣有这个能力，小圣这个能力就有限。经上讲，阿罗汉能知道一个人过去五百世，及未来五百世，这比孔先生高明多了；孔先生只能算一世，来世就算不到了。
    命运怎么来的？从自己的妄想分别执着来的。佛为我们说明宇宙人生的真相，六道轮回的起源，就是妄想分别执着。六道轮回本来没有，是自己造的，自作自受，不是别人给你安排的。妄想分别执着，总称为烦恼。执着是见思烦恼，分别是尘沙烦恼，妄想是无明烦恼，这三种烦恼，每一种都是无量无边。我们具足了这些烦恼，所以才变成这个身。身是烦恼的果报，环境也是烦恼的果报。烦恼有头数，所以命运就能够推算得出来，像孔先生为了凡先生算命，就算得非常准确。《了凡四训》我曾经详细讲解过，也印成书，我将此书换了一个题目，叫「改造命运，心想事成」，全书的内容就是这八个字。所以觉悟非常重要。

    【迷∶未能无心，阴阳所缚；盛衰兴废，皆有定数。】
    「无心」就是无妄想分别执着。执着这个身是自己，用自己这个身，与外面所有一切人事物对立，这是迷惑，这是不觉，所以就被阴阳所缠缚。中国人讲阴阳、气数，外国人讲磁场、环境的干扰。人事环境、物质环境干扰，你就不自在，心里常常会产生变化。
    「盛衰」是对人而言，人在一生当中，命运五年一转，有最好的五年，也有最坏的五年；命运是有周期性的，所以有盛有衰。「兴废」是对事而言，事业有兴旺的时候，也有失败、衰退的时候。盛衰兴废，「皆有定数」。世间看相算命的，推算得非常正确，但是无法改造命运。所以，

    【听天由命，随业流转。】
    了凡先生在少年时，遇到孔先生替他算命，算他一生的寿命到五十三岁，作官可做到县长。五十三岁寿命到了，应当辞职回到家乡，落叶归根。他每年拿国家多少待遇，考试第几名，都算得很准，了凡先生一对照，一点都没错，所以就深信不疑。既然一生的命都已定，所以心就定了，没有妄想。世间人追求功名、财富，而了凡先生没有这个念头，因为他晓得命里没有的，求也求不到，所以干脆就不想了。后来，他和云谷禅师在禅堂里，坐了三天三夜，没有打一个妄想。禅师很佩服他，「你的功夫了不起，一般人做不到」。他说∶「我的命被人算定了，打妄想也没有用。」云谷禅师听了哈哈大笑说∶「我以为你是圣人，原来你还是个凡夫。」了凡先生是个标准凡夫，因为他不造恶也不造善。他就照着孔先生批的命去过日子，随业流转。实在讲，这也是很可悲，一点都不自在。遇到云谷禅师的教导，他才明白、觉悟。
    有妄想分别执着，这是迷；没有妄想分别执着，那是悟。六道凡夫，妄想分别执着统统有；四圣法界的众生（声闻、缘觉、菩萨、佛），有妄想、分别，没有执着；若连分别也没有了，就超越十法界，住一真法界。
    《华严经》上，毗卢遮那佛的华藏世界是一真法界，阿弥陀佛的极乐世界也是一真法界。十方诸佛所住的报土都是一真法界，必须要断尽执着、分别，妄想断一部分；妄想是最难断的，并没断尽，所以一真法界里还是有阶级。《华严经》讲的四十一位法身大士，就是有四十一个阶级。阶级从哪里来的？妄想愈少的阶级愈高，妄想多的阶级就低。但是妄想最低限度要破一品，「破一品无明，证一分法身」，就是圆教初住菩萨，跟诸佛如来思想见解都相同。由此可知，十法界是自己造的，六道是自己造的，三恶道也是自己造的。造善因得善果，造恶因得恶报，业因果报丝毫不爽。所以要度自己，决定要破分别、执着。破分别、执着说起来容易，做起来困难，这是无量劫来的习气烦恼，岂能容易断得了！

    十方诸佛刹土中，为何偏赞西方极乐世界？西方极乐世界阿弥陀佛的弘愿，确实与诸佛如来不一样。诸佛如来的刹土，要是不断分别、执着，决定去不了；但是西方极乐世界，不断也能往生，方便在此地。西方极乐世界有四土三辈九品，能够断执着，就生方便有余土；若连分别也断了，决定生实报庄严土；统统没有断，分别、执着都还有，则生凡圣同居土。但是都能往生，这是十方一切诸佛世界所没有的。虽说分别执着不断也能往生，倘若我们现在天天造罪业，还是不能往生。西方极乐世界往生的标准，虽讲烦恼不用断，但是要有能力控制。控制比断容易太多了，我们能做得到；若要断，实在讲做不到。

    用什么方法控制？这个方法既简单又容易，就是分别、执着念头才起，一句「阿弥陀佛」将之压下去，这是真用功。不能让分别、执着继续发展，发展下去就造业了。所以念头才起，佛号就要提起来，古人讲「不怕念起，只怕觉迟」，要觉悟得快；觉就是念佛。这像石头压草，压久了，功夫就得力，这是我们可以做到的。在日常生活当中，执着逐渐淡薄了；执着就是为自己，为自己的念头淡薄了。功夫好的，为自己的念头没有了，起心动念都为社会、为众生，不再为自己。能达到这种境界，即是「功夫成片」，也就是功夫得力，往生西方极乐世界有把握。

    诸位要知道，世间是一场梦，世间全是假的，没有一样是真的，何必造作罪业！真正觉悟、真正明白，不会再造罪业，不再做傻事。对人、对事、对物，从心地上改变过来。过去迷的时候，总想控制别人，管别人的事情，占有一切人事物。而控制、占有的念头，就是造业的第一因素。觉悟的人把这些放弃了，不再有控制、占有一切人事物的行为。能够把这些放下，就得大自在，真正身心安乐、福慧增长，这是真正的福报，真实的智慧。我们的智慧福报，就是被「控制、占有」障碍了，所以自己本有的智慧不能现前，本来性德具足的无量福报也不能现前。这个道理，若不是佛说明，我们决定不会知道。

    【悟∶祸福转移，操之在人；积善断恶，灾消福来。】
    祸福操纵在自己手上。命运是自己造的，所以自己可以改变命运。能把自己舍弃，一切为社会、为众生，就能与诸佛菩萨感应道交。因为诸佛菩萨就是这个心愿，你的心愿与诸佛菩萨完全相同，立刻得到诸佛菩萨的加持。我二十六岁学佛，亲近章嘉大师，大师教导我，「佛氏门中，有求必应」。倘若有求没有应，决定有障碍，障碍是自己有业障。忏除业障，所求的就现前了。佛家讲修行，有无量法门，其实任何法门都是忏悔法，只是忏悔的方式不同，效果是相同的。我们一定要忏悔，忏悔什么？为自己是错误的，我们想求名、求利，求别人恭敬，都是错误的。

    很多人来澳洲，是为了找一个福地，这是不是福地？不见得。什么地方最安全？修福积德最安全。灾难来了，共业我们不能抵御，但我们有好地方去，移民到极乐世界。何况真正觉悟之人，没有生死的观念，没有时间的观念，生命决定是永恒的。我们将来的生活，会愈转变愈殊胜，愈转变愈好，境随心转。所以，归根结柢，修心重要。

    中国古老的祖先，充满了真实的智慧；以现代眼光来看，许多诸佛菩萨示现在中国。中国的文字是智慧的符号，此地讲的「祸福」二字很相似，教我们祸福要认清楚。世间许多人把祸当作福，把福当作祸，远离福而去亲近祸害。这些文字符号，能令你开智慧。

    「积善断恶，灾消福来。」我们今天移民要找好地方，到哪里找？在心地上找。外面境界是找不到的，若在外面境界上真的找到了，就可以消灾免难，那因果定律也推翻了，命运的说法也推翻了，哪有这个道理？因果道理连诸佛如来都不能推翻，都无法改变，这是永恒不变的真理。转变完全要靠自己觉悟，觉悟的人才积善、断恶。灾从何处来？从恶的念头、思想见解、行为，招来灾祸。

    战争是人为的最大灾祸，这是与一切众生结恶缘而产生的。我们在佛典中，常读到一句话，「假设要世间没有战争，除非不食众生肉」。倘若世间人吃众生肉，战争就决定不能避免。《楞严经》云∶「人死为羊，羊死为人」，人吃羊肉，羊死了来生变人，人死了来生变羊，吃来吃去，冤冤相报没完没了。报复不会报得恰好，每次报复都过头，就会造成大的毁灭。

    澳洲政府推动多元文化，这是智慧的作法。其目的是希求社会安定、世界和平，大家都能够消除种族宗教的歧视，消除一切误会、隔阂，使不同的种族、不同的文化，共同生活，互助合作、共存共荣。实际上，最初推动多元文化的是释迦牟尼佛，释迦牟尼佛讲的第一部经典是《大方广佛华严经》，这部经记载有一百七十多种不同的族群，比我们现在社会还多。不同的种族，不同的生活方式，不同的思想，不同的信仰，种种不相同，他们都能够和睦相处，都能够踏进华藏世界。佛为我们展示一个榜样，不同的族群能够和睦相处。我们应当向他们学习，应当和睦相处。所以《大方广佛华严经》，就是和合各种不同文化族群的教材，正是解决现代世界上无法解决的问题。

    今天我参加破土典礼，听到每个宗教领袖为破土祝福，祝词都很好，但是若不能落实，还是于事无补。最后轮到我讲话，我提醒大家，我今天的祝福，是希望所有宗教领导人的祝福都能落实。要怎样才能落实？心量要大。佛家讲∶「心包太虚，量周沙界」，要有大心量，要放弃对一切人事物的控制与占有，这些祝福就落实了。若还有不平之心，我比别人高一等，人家都不如我，永远不会落实。所以，《华严经》给我们最大的启示，就是万法平等，我们要深深体会这个道理。

    佛在经中说，虚空法界一切众生，与自己是一个生命共同体。此生命共同体即是法身。一切诸佛如来有法身，我们也有法身，我们的法身与佛的法身是一个身，不是两个身。证得法身，就成佛了。譬如一个人身，身体是多元文化，眼睛是一个族群，耳朵也是一个族群，每个器官都是一个族群，所有族群共同一个生命。每个族群都第一，眼见第一，耳听第一，鼻嗅第一，舌尝第一，没有第二，有第二就打架了。这些族群一打架，人就生病了。佛了解整个虚空法界是一个法身，所以个个第一，没有第二。《华严经》中，一百七十多个族群，个个第一。《楞严经二十五圆通章》，二十五位菩萨，个个第一。个个都第一就平等了，这才能和睦。有高下、有第一第二，就不能平等，就有争执、斗争，问题就产生了。

    学佛就是学清净平等，知道一切人事物统统是平等的，我们与诸佛菩萨也是平等的，生佛平等。「平等真法界」，平等就是一真法界。换句话说，所有一切差错都是从不平之心产生的，不平就是迷惑颠倒，不了解事实真相。所以一定要懂得，一切众生都是平等的。在世法里，一个学生犯过失，可以把他开除；在佛法里，不能开除。我们不能说眼有问题，就把眼睛挖掉不要了，这是病态，不是健康。什么是健康的？要帮助它，使它恢复正常。所以佛法里没有开除人的，佛法的教学，是要把恶人变成善人，教化他，教导他、改变他。化即变化，恶变成善，坏变成好，迷变成悟，凡变成圣，这是佛法教学的成就。

    经上说得很好，「佛氏门中，不舍一人」，一个人都不放弃。把人开除，那是迷，是不负责任。教不好，要回过头来反省自己，是自己不好，没有办法感化他。自己觉悟才会有进步，决定不能把过失推给别人。真正佛菩萨，将众生的过失担在自己肩上，好事推给别人，这是别人的功德，过失都在自己，这是一个好老师，是一个负责任的老师。决定不能把过失、罪业推给别人，此罪业极重，比自己造作任何罪业都重。
    佛法的教育，是一种深度感化的教育。将道理讲清楚、讲明白，让他知道善恶是有报应的，若他还要造恶，将来受报他不会怪你。不但要讲清楚、讲明白，更要发大慈悲心，做榜样给学生看。佛为我们做了最好的榜样，佛的弟子们、菩萨、罗汉，历代的祖师大德，也都为我们做出好榜样，这些都是我们的典型、模范。我们要能够观察、体会得到，才明了应如何去学习。

    我过去亲近李炳南老居士，李老居士非常谦虚，不以老师的身分来教我，而是以同学的身分自居。他是印光法师的学生，所以他教我学印光法师，其实他的行持与印光法师没有两样。他的生活降到最低的水平，一天吃一餐，生活非常节俭。他的衣服都是穿了三、四十年，内衣、袜子都是有补钉的。他能不能过好一点的生活？能，他也有钱，他是奉祀官府的主任秘书，阶级很高，待遇也很丰厚。还兼了两个学校的教授，都有收入。但他把所有的收入，除了生活费用之外，全都做慈善公益事业。他的一生，念念为利益众生，念念想帮助社会。他教学非常认真，在台中讲经三十八年，从未休息过，不辞辛劳。要上班、教学，还要看病，他的医术非常高明。生活过得那么艰苦，一丝毫不敢浪费。

    这些大善知识做出榜样给我们看，我们要效法、学习，一切为大众。建立道场也是为了这个地方，不为自己。我对于道场没有一丝毫留恋之心，台湾道场舍弃了，美国的道场也舍弃了，一点念头都没有。我过得很自在，这是积善修福。为大众做是积善修福，为自己做是造罪业。这些众生供养的钱都是因果钱，「施主一粒米，大如须弥山，今生不了道，披毛戴角还」，这是说还债之前还要堕地狱、变饿鬼来受罪，罪受满了，再变畜生来还债。这些钱现在用得很自在，将来还起来就不自在了。印光法师对于信徒供养的钱，全部都印经书布施，这是法布施。我一生学印光法师，所有信徒对我的供养，我全部都拿去印书。

    新加坡的李木源居士，我教他怎么做，他很认真、努力，所以感应不可思议。道场非常兴旺，天天在进步。怎么进步？改过。李木源居士心胸广大，任何人对他的批评，无论是善意、恶意，统统接受。只要提出来，他会认真思考，是过失就马上改进，天天在改过，所以这个道场日新又新。对一切人常存感恩之心，不论是善意、恶意，都以感恩之心来对待，这是佛菩萨，这是学佛。所以这个道场从上到下一千多人，满面笑容，没有意见、没有冲突，真正做到见和同解、戒和同修、利和同均。那个地方就是福地，人肯修福、肯造福。我们今天要消灾免难，不修福、不断恶，灾就消不了。一定要把心转变过来，要改心。

    【命自我造，数不能拘。】
    这是结论，命运决定是自己造的，自己也决定可以改造命运。懂得道理、方法，就可以改造。我在没有学佛之前，很多人给我算命，都说我活不过四十五岁。我非常相信，但不是迷信，因为我家里好几代长辈，都没有超过四十六岁的。还算出我没有福报。幸亏我还有一点小智慧，遇到佛法还能够理解，还能好学，这就转变了我的命运。
    有一年，台北举办「仁王法会」，我讲《仁王经》共二十天。法会期间，遇到甘珠活佛，他跟我是老友。甘珠活佛看到我很欢喜，他说∶「从前我们都讲你人很聪明，可惜没有福报又短命。但是这么多年来，你讲经说法，弘法利生，命运转变了，不但长寿，福报还很大。」所以一定要真修，才能改造命运，这是「佛氏门中，有求必应」。没有寿命可以求长寿，没有福报可以求福报，没有求不到的。尤其不为自己，是为众生求的，决定有求必应。

    【改造命运∶】
    【经训－必具善根、福德、因缘】
    必须具足这三个条件。善根、福德都是宿世修成的。何谓善根？明理是善根，信解是善根，接触善知识，亲近善知识，对善知识的教诲能信、能解，这是善根。能行是福德，相信了肯做，这是福德。人有善根、福德，佛菩萨会为你促成因缘，这就是感应。善根、福德是能感，因缘就有应，佛菩萨会为我们做增上缘。
    【开示－须知道理、方法、境界】
    真正能懂、能透彻，改造命运就不难了。人在世间，最难得的是寿命，寿命能够延长，身体能够健康，不容易！这件事都能做到，其他的都是小事。尤其遇到念佛法门，此因缘是无比殊胜。超越六道、超越十法界，往生不退成佛，这是最难的，这件事都能做到，其他的事情，岂有不能成就的！所以一定要晓得，不能成就，就如章嘉大师所讲的，自己有业障，一定要反省，要改过自新。真正改过自新，与诸佛菩萨立刻感应道交。念念为社会，念念为众生，不为自己。为社会、为众生，就是真正为自己。为自己决定保不住自己，因为无量劫来烦恼习气罪业太重了，这一生纵使为自己而努力修学，功德都非常有限，敌不过业力。念头一转，为众生、为佛法，就能转变自己的业力，这个道理我们要懂。

    ◎ 立命之学
    这是《了凡四训》的第一篇。全文分两段∶第一段讲「休咎有数」；第二段是主题，「立命之学」。
    【休咎有数∶慈云寺遇孔公，试数皆验。信生死荣辱、治乱兴衰，数皆前定。澹然无求。】
    了凡先生在慈云寺遇到孔先生，孔先生为他算命，断定他一生的吉凶祸福。「休咎」就是吉凶祸福。「试数皆验」，“验”是灵验、准确，屡次的试验都非常准确。所以算命、看相、占卜，不是没有道理的。真正有学问、有德行之人，就会算得很准确。一般江湖术士靠不住，他虽能说对几分，实际上那是全凭经验。因为他每天接触的人多，看的人多，就能揣摩一般众生的心理。看你的言行举止，就晓得你有什么困难，说些应付之辞，那个不准确。孔先生不属于江湖术士这类，他确实有学问、有修养、有道德。

    由于试数皆验，于是了凡先生深信不疑，知道一个人「生死」有命，「荣辱」也有命。“荣”是一生发达，功名富贵；“辱”是所希求的得不到，物质生活、精神生活非常困苦，这都是命里注定的。「生死荣辱」是讲自己的一生。「治乱兴衰」是讲家庭、社会，即佛家讲的依报环境，就是自己居住的环境。“治”是社会安定，“乱”是社会动乱。社会安定、动乱也有数，国家的兴衰、家庭的兴衰，乃至于自己事业的兴衰也都有数。这是根据术数来推算的，就是现在讲的数学，数学为科学之母。中国最古老的术数，就是《易经》。一个人的一生休咎，一个国家的国运，乃至于整个世界的种种演变，都可以从《易经》卦象中推算出来。「数皆前定」，人的一生，乃至于生生世世，都按照定数过日子，很少人能够逃出定数。

    了凡先生经过孔先生算定之后，知道自己一生吉凶祸福都是前世注定的，所以「澹然无求」。他的心定了，真正做到「与人无争，于世无求」。他毕竟是个聪明的读书人，知道求也没用，争也没用，正所谓「命里有时终须有，命里无时莫强求。」了凡先生确实是个标准凡夫，完全顺着命运过日子，但这也比一般人聪明。一般人不晓得这个道理，不了解事实真相，天天虚妄祈求，这是妄念。不但求不到，还造作许多罪业，不懂修福、培福，反而把自己命中原有的福报都折损了，这是最愚痴之人。

    【立命之学∶】
    分为两段∶「云谷开示」与「实行功德」。
    【山中对坐三日无念。师奇相问，知为凡夫。】
    了凡先生闲暇之时，喜欢到寺庙访问高僧大德，遇到了云谷禅师。与禅师在禅堂对坐三日，心无妄念，这是相当好的功夫。在日常生活中，六根接触六尘境界，不起心、不动念，不分别、不执着，他做到了。云谷禅师非常赞叹，问他平常用什么功夫？了凡先生是个老实人，他说∶「我没有什么功夫，我的命被孔先生算定，打妄想也没用，干脆就不打了。」云谷禅师一听哈哈大笑，「我以为你是圣人，原来你还是个凡夫，还是被命运所转。」被命运所转就是凡夫，能转命运才是圣人。云谷禅师就教导他，应当要转命运，不能随着命运转。了凡先生就怀疑了，命既然是定的，难道还能转吗？下面是云谷禅师对他开示的重点。

    【诗书∶命由我作，福自己求。】
    禅师先「引证」。诗书是《四书五经》。命运是自己造的，不是别人给你定的。一生吉凶祸福，是自己过去造作的因，这一生所受的是果报。佛家则讲，我们的身是业报身。诸佛菩萨应化世间是愿力身，是乘愿再来，不是业力，所以他的应化永远是自在的。我们被烦恼所缚，毫无自由，所以是业报身。业有两种∶「引业」和「满业」。引业就是引导你到哪一道去投胎。过去生中，五戒十善修得很好，这个力量就引导你到人道来投生。得人身，这一生当中的吉凶祸福，就是满业，这是另一个因。
    你前生处事待人接物，所修的善业多，这一生就得福报。哪些是属于善业？布施供养。财富是命里有的，前生财布施是因，布施得愈多，这一生所得的财富也愈多。命里有财，不管从事于哪个行业都会发财，工作的勤惰只是缘，过去生布施是因。聪明智慧是果报，这是前生修法布施，喜欢教导别人，这一生就得聪明智慧。如果修无畏布施，就得健康长寿。世间人希求的果报，总不外乎财富、聪明智慧、健康长寿这三类。这一生有财富、有聪明智慧、有健康长寿，是前生修得好。这一生生活很困苦，要觉悟、明白，现在亡羊补牢还不晚，只要懂得道理，认真努力去修因，修得非常殊胜，不需等到来世，这一生果报就现前。

    绝不是说赚了钱储蓄起来，就会有钱，这靠不住！佛经上讲「财为五家共有」，世间财物为王、贼、火、水、恶子等五家所共有。这两年，在新加坡的经济风暴中，有很多财产上亿、上千万的人，股票跌了，一文不值，最后走投无路，跳楼自杀。有一个同修告诉我∶他的一个朋友，有上亿的财产，在这次经济风暴中，全部赔光了，只剩下三百多万，结果跳楼自杀。其实三百万也不少，也能过日子，何必要死！所以，财靠不住。倘若他在有钱时，拿这些钱来救济贫困，做社会福利工作，就不会受经济风暴的影响。在经济风暴的浪潮中，还是有人做生意会赚钱，我们同修当中就有一位。命里有财，肯布施，欢喜布施，经济风暴对他就毫无影响。所以财富是果，布施是因。

    聪明智慧是果，法布施是因。法布施包括的范围很广泛，印善书劝人为善是法布施，以自己的智慧与技术能力教导别人也是法布施。现在科技发达，制做讲经的录影带、录音带、CD，与人结缘，劝人修学佛法，都是法布施。只要认真努力帮助一切众生，自然就会有福报、有智慧。

    健康长寿是果，无畏布施是因。所谓无畏布施，就是别人有恐惧，身心不安时，给予安慰、保护，让他离开一切恐怖。中国佛教徒选择素食，不吃众生肉，不伤害一切众生，这是属于无畏布施。

    修什么因，得什么果报，这种果报称为「满业」。得人身是属于引业，修三种布施是属于满业。若过去生中没有修这三种布施，虽得人身，生活就非常艰难、困苦。世间有些人有富贵而没有智慧，有些人有智慧而没有富贵，既有福报又有智慧之人不多。既健康长寿，又有智慧，又有大福报，这才是真正圆满。

    办老人院，这是属于无畏布施。很多人的晚年生活很痛苦，尤其在现前社会，儿女不孝，父母老了就住进老人院。老人院固然在物质生活上照顾周到，可是精神生活上非常贫乏。我参观过世界各地许多老人院，澳洲黄金海岸有几个退休村，我也访问、参观过。老人福利事业，以澳洲办得最好，但仍缺乏精神生活的照顾。所以住在老人院，吃饱了没事做，一个人晒太阳，连说话的人都没有，生活非常苦闷，等于坐吃等死。今天看到这个去世，明天又有一个，天天看这种情形，难免有恐惧感。所以，办老人院不仅是物质生活的照顾，要特别着重精神生活的照顾，宗教修学上的照顾。对于病苦的老人，年岁大的老人，要特别照顾。每天要有人去跟他谈话，一天两、三次，一次的时间不超过十分钟。劝导他们念佛，并将三世因果的道理，讲给他听，让他明了，让他不要对死亡产生恐怖，这是无畏布施。

    生死只是一个转变，这个身坏了，再转一个身，再换一个生活环境。他果真明白，就不会贪生怕死。年岁大了，想到来生的生活环境，比这一生还要殊胜，自然就不会恐惧。用我们的精神、体力，照顾、帮助老人，这是内财布施，比外财还要殊胜；外财是身外之物。为他讲解因果道理，佛法的道理，劝导他念佛，这是法布施。他接受之后，心里很安慰，没有恐惧，这是无畏布施。老人院里，三种布施具足，纵使不能往生西方极乐世界，来生的果报必定非常殊胜，得财富、聪明智慧、健康长寿。所以老人院是真正的道场，天天劝别人往生，自己哪有不往生的道理！决定得生净土。

    这几年，经济不景气，而居士林的收入却月月增加，原因无他，居士林依照佛的教诲修布施，愈施愈多。新加坡居士林的餐厅，一年三百六十五天，天天免费供应饭菜，无论什么人，不学佛的，甚至毁谤佛法，都来者不拒。自助餐有十几道菜任你选择，还免费供应水果、咖啡、牛奶。每天来居士林吃饭的有一千多人，星期六、日约有四千人，非常兴旺。居士林从未买过米、菜、油盐，因为大家晓得此地是无条件供斋，所以自然有人送米、送菜、送油。送的东西吃不完，放久了会坏，所以每天用卡车转送给老人院、孤儿院。所以，真正发心做好事，必得三宝加持、龙天护法。

    【佛曰∶有求必应，内外双得。】
    云谷禅师引用佛家所说的话。佛家讲「有求必应」，凡是有求而不得，都是有业障，能忏除业障，就能称心满愿。何谓业障？自私自利的念头就是业障，所求就没有感应。没有一点私心，完全为众生、为佛法，感应不可思议。「内外双得」，“内”是智慧、健康、长寿，“外”是财富、功名富贵，你统统得到。理论明白了，你就建立信心。从何处做起？

    【指归实学∶】
    “实”是真实，实实在在，不是玄学、空谈。
    【断恶修善，广积阴功。】
    要想改造命运，就从这两句做起。一切不善的念头，不善的思想，不善的言行，要将之改正。修是修正，修正过来就是善。凡是为自己的都是不善。我们所想的、所说的、所做的，总是为了自己的利益，这就不善。念念为众生、为社会，这是善。世出世间圣贤的教诲，都是以此为标准。起心动念一切所为，帮助社会，帮助苦难的众生，奉献自己的身心；奉献就是「广积阴功」，为一切众生服务，这是功德。何谓阴功？做好事不让人知道。因为别人晓得了，一称赞表扬，功德就报掉了。做好事不宣扬，这是阴德，此善德愈积愈厚，果报就不可思议。恶事希望大家都知道，这个人骂你，那个人指责你，恶就报掉了。所以恶不要隐瞒，要宣扬出去；善要藏起来，才积得厚。现在人没福，做一点好事唯恐人不晓得，大肆宣扬，立刻报光了；造的恶隐瞒，不让人知道，所以恶愈积愈厚，善没有积到，将来的果报都是恶报。这两句真正能做到，就不失人身。

    【改过指入不二法门】
    不二就是平等。我们所有的过失，根源何在？就在不平等。我总比别人高一点，时时处处有高下的念头，这是烦恼，是严重的分别执着。所以佛家讲要断烦恼，儒家是世间法，虽然没有讲断，但是也教人要控制。《礼记·曲礼》一开始就说∶「傲不可长，欲不可纵，志不可满」。贪嗔痴慢是一切众生与生俱来的烦恼，无量劫来，生生世世薰习成种，不需要学习，贪嗔痴慢就现前，傲慢的习气随时就表现出来。
    有傲慢，只能生欲界，色界没有分。傲慢、嗔恚断掉了，禅定修成功，才能生色界天。所以这是大烦恼，严重的烦恼，能够断掉，心就平等，这才能与大乘佛法的不二法门相应。不二法就是平等法。真正明了，法法第一，法法平等，有什么好傲慢的？怎么能在别人之上。《华严经》讲，法法第一，没有第二。第一就是不二，智慧才能显露出来。有定才能生智慧，有智慧才能改变命运。

    【义理再生之身－乘愿再来】
    没有断恶修善、广积阴功、认真改过，就决定被命运所转，一生脱离不了业报；要认真努力修学，命运才会转变。义理再造之身超过数量，看相算命就不准了。这就说明命确实能改，有改的道理，有改的方法，有改的效果。真正改过来了，就与诸佛菩萨应化一样，是「乘愿再来」。以上是云谷禅师开示的大意。

    要晓得，十法界里的菩萨、佛都还有过失，我们怎么会没有过失？必须是一真法界里的佛才没有过失。我们天天造作无量无边的过失，自己完全不知道，麻木不仁，这还有救吗？现在众生确实是如此，唯一的办法就是听经、读经、研教，希望用这种方法提醒自己。所以释迦牟尼佛在世，讲经说法四十九年，从未中断。除此之外，没有第二个方法，天天讲、天天劝，所谓是「一门深入，长时薰修」，才能产生效果。三天不听经，面目全非，这都是事实。由此可知，我们的烦恼、业障、习气是多么深重，还自以为是，有什么值得傲慢？所以，佛菩萨、祖师大德真正是大慈大悲，天天劝勉、教导我们。

    自己若能反省，就能发现自己的过失。有些同修告诉我，我们看到别人的过失，看不到自己的过失，怎么办？我说，你回过头来就看到了。如何回头？别人是一面镜子，看到别人的过失，想想自己有没有，就能发现了。六祖大师说∶「若真修道人，不见世间过」。真修道人是指转凡成圣之人，凡夫决定见到世间过失。过失从哪里来的？过失在于自己，世间并没有过失，是自己的烦恼习气起现行，才看到过失，所以见到别人的过失，正是自己的过失。但是世间人不知道照看自己，不晓得是自己的过失，总以为是别人错。真正觉悟之人，会修行之人，见到世间过，立刻反省自己。能发现自己过失，这是觉悟；改正自己的过失，才能转凡成圣。
    过失无量无边，其根本就是自私自利。好事归自己，恶事推给别人，这是过失的根本。大、小乘佛法都讲究从根本修，效果非常显著、快速。妄想分别执着也是根本，六根对六尘起分别、执着，执着就是烦恼障，分别就是所知障。执着里最严重的是身见、我见，以为这个身是我，于是就产生自私自利，产生我痴、我爱、我慢，这是唯识讲的「四大烦恼常相随」。真正觉悟了，所谓是「义理再生之身」，这是明白身不是我。谁是我？虚空法界一切众生是我。

    晓得为一切众生是真正为自己，那是正知正见。念念为自己，造无量无边的罪业，纵然行善也不是真善。何以故？不能脱离六道。行善在三善道受果报，出不了轮回，那就是恶业。所以一定要做一个大转变，没有学佛之前，念念为自己；明白之后，念念为众生，活在世间是为众生服务的，为佛法服务的。佛法是觉悟一切众生的方法；换句话说，帮助一切众生觉悟，帮助一切众生了解宇宙人生的真相，就是佛法。我们到世间来，就是为一切众生服务的，不是为自己。一切众生里，当然也包括自己，自己不在一切众生之外，心量就扩大了。时时刻刻想一切众生，帮助一切众生，念头就转过来了。

    【疑为罪根，信为福母。】
    对于道理，不能相信，不能接受，不能照做，每天的生活还是造业，此罪根就是怀疑。能够断疑生信，依教奉行，就是自求多福。「母」是比喻能生之义，是讲「信能生福」。有好老师也要有好学生，好学生是对老师的教诲不怀疑，决定相信，并能懂得教诲的意义，又肯依教奉行。这样的学生是老师心目当中的传人，决定有成就。

    【实行功德∶】
    「功」是功夫，功夫是断恶修善、改过自新。下面列了五条∶
    【一、体悟凡圣实学，改号了凡。】
    了凡先生接受云谷禅师的教诲，觉悟了。圣贤人所教导的是真实的学问，不是空谈，确实能够改变人生，改造命运，这种学问才是真实的。他改号为「了凡」；了是明了，明了过去凡夫的这些习气。名是表法，别人见到他称「了凡」，是提醒自己，我是否真的明了，是否真的觉悟。名是时时刻刻提醒自己，是否名实相符。古人起名号意思很深，父母给子女起的名号，一生不能改变，时时刻刻要提醒自己，父母对自己的愿望有没有做到，名实相符才是大孝。

    【二、解行相资，誓行善事三千，定数不验。】
    他接受云谷禅师的教诲，断恶修善、广积阴功。解是解其理，解帮助行持；行持又帮助深入理解，这称作「解行相资」。他虽然发愿要行三千件善事，但是不够积极，时间拖得很长，十年才做圆满，所以感应就没有那么快速。可是命运改变了，孔先生算的渐渐不准了。他作官升级，俸禄也增多，与命运不相符，有此效果，他信心更具足。

    【三、二次誓行善事三千，求子生天启。】
    因为他命里没有儿子，所以此次行善事为「求儿子」。他后来得到两个儿子，是命里没有的，是求来的。这三千件善事不到三年就圆满，可见得他做得有信心，也非常积极，而且是全家人都做，果然求子得子。
    【四、三次誓行万善事，求进士丙戍登第。】
    进士是功名，这是他命里没有的。从前的学位是考试得来的，县考秀才，省考举人，进士是皇帝考的，也称殿试，是国家颁发的最高学位。那时他做宝坻知县，看到农民生活困苦，所以实行减税。此政策全县几万人都得好处，所以做一桩善事，一万件善事就圆满了。梦中有境界告诉他，他的善行已圆满，他半信半疑，请教高僧大德，确实无误。所以公门好修善，有机会、有权力做这种好事，减轻农民的负担，让全县人都能得到利益。一个好政策是万善，一个错误的政策是万恶，道理一定要懂。
    他求功名果然得功名。他命里无子，求子得子；他没有求寿命，但是寿命延长了，命里是五十三岁，最后活了七十多岁，因为他积功累德，寿命不求自然就延长。因缘果报的道理，我们要懂得。他以一生的经验，一生的实学，教导儿子。

    【五、训子闲邪存诚，知非改过，齐家报国。】
    《了凡四训》这四篇文章是教训他的儿子，内容是「闲邪存诚」。“闲”是防止，“邪”是错误的思想、行为，要知道预防。“存诚”，不欺骗自己，不欺骗别人，真诚心处事待人接物，福报就大了。要晓得，心地虚伪是造作一切罪业的根本。处事待人没有一点诚意，这种人决定堕地狱。我们用真诚心待人，别人欺骗我们无所谓，不必介意。人生短暂，以真诚心待人，来生有好去处，至少生天享天福。他用欺罔心对待我，他造罪业，堕三恶道。各人有各人的去处，各人有各人的因果。「知非改过，齐家报国」，心量逐渐扩大，不为自己，能够为社会、为众生，福报就大了。

    【云师教诲，精邃真理，熟玩勉行。】
    这是结论。云谷禅师的教诲是非常精深的真理，要细心研读、玩味，勉励自己努力奉行，决定改造命运。自己命运能改，家运、国运也能改。今天世界上有这么多灾难，只要我们真正觉悟，真正回头，一切为众生、为社会，求佛菩萨加持，就能消灾免难。为自己是自私自利，为众生是功德无有穷尽，念头一转，这是真修，真正的实学。

    ◎ 改过之法
    这是《了凡四训》的第二篇。分成四小段∶第一、「改过之因」；第二、「改过之基」；第三、「改过之法」；第四、「改过效验」，就是成绩、绩效。
    【一、改过之因】
    【吉凶之兆∶过于厚者常获福，过于薄者常近祸。】
    “兆”是预兆，无论是吉利或是凶灾，未来临之前都有预兆。古代读书人对于这些征兆，都能看得很清楚；现代人即使是非常明显的预兆，都不能觉察。这跟读书有很大的关系，古人读的是圣贤书，目的是志在圣贤。「圣贤」就是对于宇宙人生的事理通达明了；完全通达明了称作圣人，不能圆满的通达明了，也认真努力的学习，就称作贤人。在佛法里，圣就是佛，贤就是菩萨。而今天读书的目的，都是为了赚钱，为了名闻利养，人没有智慧，所以吉凶预兆在面前也看不出来。志在圣贤，心是清净的，心是定的，清净心、定心能生智慧，即使是很不明显的预兆，都能够觉察。此书举的例子很多，要细心去体会、观察，我们在这一生当中，才有能力趋吉避凶。

    此地讲了一个大原则∶「过于厚者常获福，过于薄者常近祸」。一个人心地厚道，不欺骗人，就常得福报；心地非常刻薄之人，容易得到灾祸。可是现代人的观念，反而认为厚道被人欺负，刻薄厉害能显示自己有能力，这是颠倒是非，不知因果报应之理。心地厚道之人眼光远大，心地刻薄之人目光短浅，只顾眼前的利益，这两种人有截然不同的结果，古代如是，现在依然。刻薄之人即使能兴家，聚集亿万财产，但死了之后，儿子不争气，三年五载就挥霍殆尽，随之而来的就是殃祸。这是前生修的福报大，这一生衰相尚未现前；若过去生中福薄，今生就会衰败。仔细观察我们周围的人事，不难发现，有人发财，三年五载就破产衰败了；有人能够支持十年、二十年，依旧是昙花一现，晚年生活贫穷潦倒。

    有人告诉我，香港半山区都是很好的别墅，过去住的都是电影明星，现在都换了主人。那些人享受富贵的日子，没有超过十年。在有钱、有地位、有势力之时，不知道修福，还尽情的挥霍、享受，福报就享尽了。处事待人刻薄，自欺欺人，都没有善终的。这样的例子，古今中外有很多，而且都很明显。心地厚道，肯吃亏、肯忍让之人，眼前似乎吃亏，别人轻视、瞧不起，但是有后福。常言说，年轻时运不好，中壮年勉勉强强，年老福报就来了。我们要晓得，晚年享福是真正的福报；若年轻享福，晚年没有福报，没有人照顾，生活非常贫穷困苦，这是无福之人。许多作大官、发大财的，在得志时，有很多佣人伺候；到年老之时，无人照顾，病死了都没人晓得，这是我亲眼所见。原因都是得志时不知道修福、惜福。

    释迦牟尼佛是大圣，孔夫子也是中国历史上的大圣。我们读佛经、读《论语》，释迦牟尼佛和孔夫子当年在世的生活，不但勤奋、节俭、惜福，而且心地厚道仁慈，尽心尽力帮助社会，帮助一切苦难众生。孔夫子的后代迄今七十多代，无论在中国、在海外，都受到社会尊敬，此福报很大，历代的帝王都比不上。汉、唐是中国历史上最负盛名，汉高祖的后代没人知道，唐太宗的后代也没人晓得。释迦牟尼佛虽然出家没有后代，但至今全世界有很多人供奉释迦牟尼佛，此福报更大！福从何来？心地厚道超过常人，所以福报几千年都不衰。
    而心地刻薄，无论眼前如何辉煌、发达，终有衰败之一日。心地厚道仁慈，眼前虽然穷困，将来一定有大福报。看人从此地看，看一个家庭亦如是。谚语常讲∶「家和万事兴」。一家人父慈子孝，兄友弟恭，纵然是很平常的家庭，甚至于相当贫困，将来一定会兴旺。一个事业再大、财富再多的家庭，彼此面和心不和，此富贵不长久，一定会衰败。再扩大到社会、国家，若此地的人民普遍都很刻薄，此地就不是福地；多数人民都很厚道，就是福地。夫子所谓「危邦不居，乱邦不入」。

    在日常生活当中，心地厚道之人一定节俭，懂得惜福；心地刻薄之人恰恰相反，享受奢侈，这不是福的预兆。再看社会、国家的吉凶祸福，古人所谓「明若观火」，清清楚楚、明明白白。

    【至诚合天∶福将至，观其善必先知之。祸将至，观其恶必先知之。获福远祸，先须改过。】
    「至诚合天」，“天”，现在的说法是指自然的道理，这是从性理上说的；原文是指上帝、天地鬼神，这是从事相上说的；性理跟事相是一不是二。
    「福将至，观其善必先知之。」一个人的福报快要现前时，观察他的善行就能明了，一定是心地善良，行事善良，这是预兆。这些年我提倡四好∶「存好心、说好话、行好事、做好人」，能够符合四好，就是福报快要现前之人。

    「祸将至，观其恶必先知之。」一个人有灾难来临，观察他的行为就晓得，一定是心不善、言不善、行不善，这是预兆。看看别人，回头反省自己，若是善的就要增长，要继续保持；若发现自己的恶，要立刻改过，后不再造，就能「获福远祸」。远离一切祸害，最重要的是「先须改过」。
    改过一定要知道自己的过失，过失就是自私自利，自私自利的心是恶心，自私自利的行为是恶行，自私自利的言语是恶言，心不善，言就不善；心恶、言恶、行恶，灾祸就来临。反之，心善、行善、言善就远离祸害，而得福报。这是古今中外永远不变的因果定律，也就是现代人所讲的「真理」。所以，首先要发现自己的过失，绝对不能大意、疏忽。念念为众生，念念为社会整体的安全着想，所作所为都不离开此原则。要想存心、言语、行为都善，就一定要改过。

    【二、改过之基－三心圆发】
    改过的基础、根本，是「三心圆发」。“三心”不是佛法讲的三心，是了凡居士在此篇文中讲的三种心。
    【第一要发耻心－知耻能生大勇；第二要发畏心－知畏则生诚敬；第三要发勇心－知勇则能振奋】
    第一∶「要发耻心－知耻能生大勇」，即古人所谓「知耻近乎勇」。“勇”是勇于改过，不知耻的人永远不肯改过。“耻”就是过失，心不善、言不善、行不善都是耻。学佛之人善恶的标准，是以释迦牟尼佛为标准；中国古代读书人善恶的标准，是以孔夫子为标准。《论语》说夫子有五德∶「温、良、恭、俭、让」。第一温和厚道；第二善良，心地善良；第三恭慎，对人恭敬，没有傲慢的习气，做事小心谨慎。第四节俭，节俭是惜福，人力、物力绝不浪费；不浪费人力是爱人，不浪费物力是爱物，所谓「仁民爱物」。第五是能忍让。释迦牟尼佛的大德就是十善，身是不杀生、不偷盗、不淫欲；口是不妄语、不两舌、不恶口、不绮语；意是不贪、不嗔、不痴。这是世出世间大圣人善恶的标准。我们存心、言语、行事违背十善，这是耻辱。
    不知耻在佛法里称「一阐提」，一阐提是印度话，翻成中国意思，是没有善根之人，就是不知耻、不改过。佛的教学分五个时期∶华严、阿含、方等、般若、法华涅盘。前四时，佛对于一阐提者不教，是无法教导，他不肯回头，所以说一阐提没有佛性，不能作佛。可是在法华会上「开权显实」，佛说一阐提也有佛性，也能作佛。但不是指这一生，是来生、或再来生，佛度化众生生生世世，也许过无量劫又无量劫，他才肯回头。但是佛很有耐心，还是不舍弃，显示了佛的大慈大悲。佛法以十善做为善恶的标准，很容易明了。我们的思想、言行与十善相应是善；与十善相违背就是恶。

    前年，我在休士顿讲经，遇到蔡念生老居士的儿子，他是个大学教授。他说现代人的病根是「不知耻」，此话说得很正确。另外还有两位教授，谈论如何唤醒社会大众的觉悟，就是「要知耻」。我当时提议，他们可以组织一个团体，名称为「知耻学社」，来推动此运动，他们很赞同。人人都知道羞辱，都知耻，就能挽救世界灾难；人人都不知耻，这是大灾难来临的预兆。我们能否自救，能否帮助社会、帮助众生，关键就在「知耻」。
    第二∶「要发畏心－知畏则生诚敬」，“畏”是畏惧，畏惧果报。现代人不相信因果报应，不相信六道轮回，所以不怕果报；学佛的人知道有六道轮回。《地藏菩萨本愿经》里，说明地狱的状况，读了信不信？过去古老的中国，每个县城都有一个城隍庙。实在讲，古代的政治是人与鬼神共同治理；一个县，阳间有个县长，阴间有个城隍，阴阳共治。城隍庙里有十殿阎王、地狱变相图。地狱变相图像现在展览会一样，展示善恶果报的形相。很多人到城隍庙看过，就知道改过，不敢再作恶，作恶将来就要受果报。「畏」就是怕将来受果报。所以「知畏则生诚敬」，明了因缘果报的道理与事实真相，诚敬之心油然而生，对一切人、一切事、一切物至诚恭敬。知耻、诚敬，这是善。

    第三∶「要发勇心－知勇则能振奋」，能发勇猛心，就能提起精神，真正断恶修善；反之，不能发勇猛心，虽然知耻、诚敬，还是懈怠、懒散，因循苟且，最后还是堕落，还要受三途果报。
    了凡先生的改过之方，就是基于此三个条件。以佛法来讲，这三条都是属于菩提心的「深心」。「菩提心」，即《起信论》的「直心、深心、大悲心」，《观无量寿佛经》的「至诚心、深心、回向发愿心」。深心就是好德好善之心，所以这三条都是属于好德好善，这是自利、自受用，这是世间法。若要在佛法上有成就，必需具足三心，而此三心是以真诚心做基础，真诚到极处。

    我以二十个字，概括佛法教学的精髓，即「真诚、清净、平等、正觉、慈悲；看破、放下、自在、随缘、念佛」，要时时刻刻提醒自己。倘若我们的心不真诚，就是虚伪；不清净，就有烦恼、习气；不平等，就有是非人我、有高下；迷惑颠倒，就不觉悟；自私自利，就没有慈悲。与这二十个字相反，就是耻辱。他们已经作佛、作大菩萨，我还在六道轮回，奇耻大辱莫过于此。所以能知耻才能发愤，勇猛精进，在这一生当中要迎头赶上，我也要作佛、作菩萨。能否做到，在一念之间，一念觉悟，一生就做到了。所以发勇心是关键。
    大乘经讲，菩萨唯一善根是「精进」。世间法的善根，是「无贪、无嗔、无痴」，对于世出世间一切法，没有贪嗔痴，这是世间善法的善根，这都是属于菩提心的深心。深心是自利，回向发愿心是利他。将自己所修积的一切功德、福报，供养给一切众生，自己不享受，让大家来享福。所以佛家讲的三心，比这三条的范围还广，此三条只是菩提心之一。
    有这些基础，改过才有效果；反之，纵然想改过也很难。许多同修说，知道自己有过失，但是改不掉，就是没有这个基础。所以了凡先生改过，有其一番道理和程序。这是他以自身经验来教诲儿子，循着这些理论与程序，才能收到改过的效果。

    【三、改过之法】
    【第一、就事而改之－强制于外，病根终在】
    这是第一种，从事相上断恶修善。但心里没有改变，其效果不大。若从事上修，其目的是希求名利，希求别人的恭敬、赞叹，是为自己的知名度而行善，这是不善之心。行善、事善，心不善，所积的善立刻就报掉了。
    【第二、明理而改之－事理既明，过将自止】
    这是第二种。「明理」是对于吉凶祸福的大道理、事实真相，清楚明白。种善因得善果，造恶因必定得恶报，这些道理与事实真相已清楚明白，就有畏心，害怕恶的果报，不敢再做恶事，「过将自止」。不但做恶事有恶报，连动一个恶念都有恶报，千万不要认为，起心动念微不足道，无人晓得。其实自己还没觉察到，佛菩萨、天龙鬼神早已觉察到了，因为起心动念是波动的现象。

    在五十年前，科学家承认有物质的存在。物质分析成分子、原子、电子，现在讲的基本粒子，似乎有物质存在。近代科学更进一步，发现根本没有物质存在，物质是波动的现象。此说法与大乘佛法讲的非常接近，佛法讲无明，无明就是波动的现象。「无明不觉生三细，境界为缘长六粗」，这是宇宙人生的真相。所以，确实是波动的现象。什么波？思想波，起心动念就有微弱的波动。一念善、一念恶，念头太微弱，自己尚未觉察，佛菩萨早已觉察到。因为佛菩萨心净，以现在的说法，就是接收的能力很强，极其微弱的电波都能接收到。我们收不到佛菩萨的波动现象，是因为我们粗心大意，我们的念头，像大海的波浪一样，大波大浪。而我们的波动，无论是大波浪，还是极其微细的波动，念头一动，刹那之间遍虚空法界，速度之快不可思议。所以与天地鬼神、佛菩萨感应道交，非常快速。

    物质的波动速度缓慢，虽缓慢也达到虚空法界，只是时间长。心念的波动，速度非常快，刹那之间遍虚空法界。如果用比喻来说，物质的波动，就像水的波动一样，在池塘里丢一块石头，水就起了波浪，慢慢的会遍满整个池塘。思想的波动，就像无线电波，没有障碍，所以速度快。

    《无量寿经》上说，西方极乐世界即使是下下品往生，能力都恢复了，天眼洞视、天耳彻听。十方世界一切众生起心动念，波动的现象，他都能接收到。而我们是自欺欺人，自欺欺人是耻辱。过去无量劫来，我们天天做这些错事、傻事，是没有听闻到佛法，不知道事实真相。而这一生有幸得人身、闻佛法，了解事实真相，还不回头吗？只要回头，决定不再做错事。

    起心动念、言语造作，不离十善业道，这就是从事上修。不违背「真诚、清净、平等、正觉、慈悲；看破、放下、自在、随缘、念佛」，这是明理而改之。起心动念、处事待人接物，与这十句相应，就是真觉悟，真正回头；与这十句相违背，就是迷而不觉，这一生当中，无论修学哪个法门，成就都有限，不可能脱离六道轮回。不能脱离六道轮回，决定在三途。与十善业道相应，才能得人身，所以自己好好反省，起心动念、所作所为，若与十善业道不相应，决定堕三恶道。

    【第三、从心而改之－不取于相，如如不动】
    这是第三种，「从心而改」是最高级的，从心改决定出十法界。真正觉悟之人，就是从心而改之，与「真诚、清净、平等、正觉、慈悲；看破、放下、自在、随缘、念佛」相应。对于世出世间法，不再执着、分别。「不取于相」就是不着相；「如如不动」是自己的心地清净平等，「外不着相，内不动心」。再说明白一点，「外不着相」就是决定不会被外面境界诱惑。眼见色，耳闻声，起心动念被境界所转，这是凡夫，是迷不是觉。无论顺境、逆境，心境相遇，心地坦然，乾乾净净，一念不生，如如不动，就是《楞严经》所说的，「若能转境，则同如来」，这是圣人；有能力转境界，不被境界所转。

    前天有位同修谈到中国的风水，是左青龙、右白虎。他说，我们道场的停车场，是在白虎的位置上，而青龙的位置是寮房，这个位置不太好。依我看很好，青龙上面住的是出家人、念佛人，怎么会不好？真正有修养、有道德，自然转境界，不必理会这些。凡是算命、看相、看风水，都是心被境转。风水好不好没有一定的，要与人的心、情绪相配合。自己居住的环境，觉得很舒服、很快乐，这个风水对你就好。住在此地，心里总觉得不舒服、很别扭，烦恼很多，风水就不好。不要去问人，自己有非常明显的感触。凡夫会受环境的影响，因此应当要选择好的居住环境。

    中国人居住的房舍是正方的，人住在里面很舒畅；若房子是五角形、六角形的，住了就很别扭。我们道场隔壁有一个房子要卖，我去看了之后，它的风水不好。它有四个房间，主卧室是夫妇住的，是长方形；另外三个房间是他的三个女儿住的，都是五角形。我就问他∶「你的女儿住在里面，思想是不是很奇怪？」他说∶「我的三个女儿都胡思乱想，无法管教。」依风水来讲∶住五角形的房子，住满一百天就会胡思乱想。这就是凡夫没有定功，没有智慧，会受环境的影响。外国人造房子，都是奇奇怪怪的，不像中国人是正正方方的。所以，外国人的居处，往往住不长久，常常搬家。中国人建的房子，一住就是几百年，传很多代，算是老家。
    所以，最高级的改过，是从心地上改，心地真正改了，就能不受环境影响。五角、六角、八角形的房子，真正修道人在那里入定，丝毫不受影响。有道德之人从心上改，这是菩萨的修学。菩萨勇猛精进，天天改过，菩萨尚且如此，何况凡夫！菩萨有五十一个位次∶十信、十住、十行、十回向、十地、等觉，改过才能往上提升。等觉菩萨都还有过失，什么过失？最后一品生相无明没破，所以还要改过自新，将最后一品无明破除，才能达到究竟圆满的佛果，称作「妙觉位」。现在人强调「改进」，就是改过进步。过失不改掉，怎么会有进步？

    【一心为善，正念现前】
    这是结论。「正念」就是一心为善。「一心」的意思很深，就是没有第二个念头。所以，真正学佛的人，每天修福、修慧，这是菩萨行。修福从断恶修善上修；修慧从「不取于相，如如不动」上修，这是福慧双修。
    无论什么人指责我们的过失，都要诚恳的接受，不要去辩白，仔细去反省，「有则改之，无则嘉勉」，这是圣贤人真实的功夫。若别人说错了就要辩白，这是拒绝别人说你的过失，自绝于善道，近祸就不远了。《贞观政要》上，记载唐太宗接受别人的劝告，欢迎别人说他的过失。他说要是我不肯接纳，以后就没有人敢说我的过失了。有此度量，所以他成为历史上的明君，有其一番道理。

    ◎ 积善之方
    这是《了凡四训》的第三篇。分「总示」和「别明」两段。
    【易曰∶「积善之家，必有余庆」。世出世间圣哲，无有不深达因果之理者。】
    「积善之家，必有余庆」，出自《易经》，这与前文所说吉凶之兆完全相应。“积善之家”，凡是在社会上有声望、地位，受到大众尊敬的大家族，都是很多代的行善，在中国历史上，记载得非常之多。一个人积善，能消灾免难，佛法讲消除业障；不能行善、积善，业障就无法消除。一个人行善必然影响一家，带动家族，人人知道行善、积善，此家族纵然这一代不能兴旺，第二代、第三代或第四代必定兴旺。所以眼光要往深处看、远处看，不能看自己这一世。

    禅宗是由达摩祖师传入中国，他初来之时，没有人理会，他在少林寺面壁九年，才等到一个慧可。慧可传僧璨，僧璨传道信，道信传弘忍，五代单传，到第六代惠能，禅宗才发扬光大。而惠能的承传，是前面五代修善积功累德，到他这一代才发达，影响了中国佛教一千多年。禅宗过去的这些祖师，很少人知道，到了六祖发达，大家才认识这些祖师。一个人、一个家庭、一个团体，乃至于国家，若不懂得修善、积善，如何会发达？《易经》的这两句话，是圣人所说，言词非常肯定，一丝毫疑惑都没有，必定有余庆。

    【一部二十五史即是因果报应记录】
    中国世间圣人，从黄帝、尧、舜、禹、汤，至孔子集大成。出世间圣人诸佛菩萨，对于这些因果道理与事实真相，无一不通达。而我们迷惑颠倒，不了解这些事实，读了古圣先贤的书籍，还以为他们是用这些方式劝人行善而已，未必真实。我们有怀疑不相信，所以不肯去做。不能行善，必定造恶，到果报现前，后悔就来不及。

    【居士举往事十人以征信】
    了凡居士举了十个人，证明积善之家必有余庆，是真实不虚。

    【必深明因果之理，方能尽事修之功。】
    这是总结。我们修行功夫不得力，就是对于业因果报的理论与事实，未能透彻明了，信心不足。果真明了事实真相，自然就会改过，不需人督促。经上说，阿罗汉有智慧、有能力，知道自己过去五百世的状况。想到自己曾经堕入阿鼻地狱的情形，还心有余悸，流血汗！而我们过去也曾堕过地狱，但是忘记了，若我们也有阿罗汉的功夫，能知道过去生生世世堕落受苦的情形，一定会发愤图强，毛病习气怎么会改不了！其实不是改不了，是自己不肯改。圣人与凡夫之别在此，圣人肯改，凡夫不肯改。凡夫何时才肯改？罪受到了极处，才肯回头，但这个罪就有得受了。所以，倘若不是深明因果之理，回头确实很难。

    我劝导初学之人，先将《了凡四训》念三百遍，就是让他深明因果。念一遍、十遍都不管用，薰习的力量太薄弱。三百遍要限定时间完成，不间断的薰习，就会相信因果。起心动念、言语造作，会有高度警觉，动这个念头、做这件事情，与因果道理是否相符。要是没有三百遍的功力，面对人事还是随顺烦恼习气。我自己修学的基础，也是得力于此书。我刚接触佛法时，朱镜宙老居士送我《了凡四训》，我读了深受感动。
    下面是「别明」，详细解释。

    【善有真假、端曲、阴阳、是非、正偏、满半、大小、难易】
    行善、积善，首先要懂得什么是「善」。有许多人对于善恶没有辨别的能力，把善当作恶，恶当作善，这种颠倒的成见，不但学佛难，连做人都难。在古代，小孩从小有人教导，在家父母教，上学老师教，从小薰习，纵然做坏事，还会受良心责备，也就是他还知耻。现在人做坏事，不但不会受良心责备，还认为做坏事是应该的，说起来还谈笑风生，不以为耻。这是修道最大的障碍，不但道业不能成功，做人到后来都失败，那就是「积不善之家，必有余殃」。

    何谓「真善」、「假善」，了凡先生也有一个标准，此标准与佛相同∶有益于人的是善，有益于自己的是恶。现在人的观念，则是相反，都把自私自利看作是天经地义，是正当的道理，这观念是见解上的错误。自私自利，决定损人利己。好事自己独揽，恶事推给别人，在现前社会里，这种现象太多了。处处存有侥幸的心理，占别人的便宜。

    为何说自利是恶？佛告诉我们，六道轮回就是自私自利变现出来的。自利的心淡薄，超越轮回就容易；没有自利的心，就超越轮回。换句话说，超越六道轮回是善，不能超越六道轮回是恶。这件事，相信的人更少了，许多人根本不承认有六道轮回，认为六道轮回是神话，不是真的，这是世间人自作聪明。我们之所以相信，因为有相信的道理，就是大乘经上所讲的「唯识所变」。十法界依正庄严从何处来的？从心想生。贪心是饿鬼，愚痴是畜生，嗔恚是地狱。你心里有嫉妒、嗔恚，就会变现地狱。我们有贪嗔痴的心，贪嗔痴是业因，就会变现三恶道。所以能将贪嗔痴的心断除，三恶道就没有了。这是一种说法。

    第二种说法，利益别人的，称之为公，公就是真；利益自己的是私，私就是假。第三种说法，从真心里去帮助别人，利益社会，这是真的；看到别人做，我们不得不跟着去做，那是假的。第一个发心的人，是从真心里发的，这是真的。第二个发心的人，可能是为名、为利，心就不真了。虽然发心利益别人，其实终极目的是自利，希望获得别人赞叹、恭敬，这还是私，是假的。第四种说法，「无为而为」是真的，「有为而为」是假的。了凡先生说了四个标准，是教导我们如何去辨别。行善积善要知道善有真假，积善要积真善。

    「端曲」，第一种说法，纯粹是济世之心，这是端；有丝毫媚世之心，就是曲。“媚”是谄媚巴结，心不正，也就是现在人讲的讨好。为了讨好社会、讨好别人，去做善事，就是曲；没有条件，真心帮助别人，这是端。第二种说法，纯是爱人之心，这是端；不是真正爱人，而是假藉这种行持，得到自己的目的，这是曲。第三种说法，真正敬人之心，这是端，“端”是端正、端庄；有丝毫玩世之心，就是曲。就是把行善当作一种消遣，此善是曲。

    「阴阳」，行善不欲人知，这是阴；阳是显露，别人都晓得你行善。了凡先生说∶「阴德天报之」，天地鬼神都报答你；「阳善享世名，名亦福也。」做一点好事，享受别人的恭敬、赞叹，恭敬、赞叹也是福，那种福立刻就享尽了。尤其是现在，积善非常不容易，做一点好事，报纸一刊登，电视一宣扬，就报光了。而现在人造恶，用种种方法隐瞒，不让人知道；恶积厚了，天罚之，老天爷惩罚。行善，善积不住；造恶，恶全累积，这多可怕！这些道理与事实真相，我们都要懂得。可是今天作善确实会有记者来采访，会有新闻媒体来报导，但我们的心确实无此念头，善还能保存一点；若为了提高自己的知名度、声望，福报就享尽了。
    「名者，造物所忌。」盛名不但人嫉妒，天地鬼神都嫉妒。「世之享盛名而实不副者，多有奇祸。」世间知名度高的人，若没有真实的德行，往往有灾祸。「人之无过咎而横被恶名者，子孙往往骤发。」真正心善行善，而遭社会人嫉妒、毁谤，这些人往往自己这一生不发达，但他的儿孙一定发达。他的善是真正累积下来，他的罪业现世已经报尽了。所以古人常教人积阴功、积阴德，为善不宣扬，这是很深的道理。

    「是非」，了凡先生也举了古代的例证，归结到最后，他讲∶做一桩善事，特别要重视其流弊。所以善不在一时而在久远，不在一生而在其影响。若他现在做的是一桩好事，但是这桩好事并非有好的影响，此影响反而会害人，那就不是真善，这种善似是而非。譬如在二次世界大战时，以原子弹轰炸日本，使日本人投降。原子弹是爱因斯坦发明的，当时对我们来讲，这是好事。但现在想想，爱因斯坦的发明是不善，原子弹发展的流弊，将来会毁灭整个世界。事实上，日本人投降是迟早的事，因为当时日本的国力已经消耗尽了，无法再拖下去。所以，凡是似是而非的善，都不是真善。

    反之，眼前他做的事情似乎是不善，可是影响久远，确实有许多众生得到利益，这是真善。譬如中国佛教提倡素食，初学素食之人，面黄肌瘦，营养不良，这看起来不善。但慢慢习惯之后，对于身体健康有很大的帮助。这是因为以前肉食吃惯了，现在要调整需要一段适应期，这是生理上的转变，约一年至三年，依个人体质而定。要能忍耐过去，饮食就适应了，晚年的身体健康，是一般肉食者不能相比的，这是真正得好处。
    所以古人常讲，聪明人有前后眼。往前看，记取历史的教训；往后看，自己怎样能够获得福报，这就叫有前后眼，一般讲的有眼光。年轻人谁不喜欢欢乐场所、谁不爱玩，年轻真是大好时光，若是浪费在游乐之中，不知进取，晚年就困难了。年轻人过着幸福欢乐的生活，往往都是家境不错；家庭生计非常困难的，哪有机会去玩，天天要做工，一天不做工，一天就没饭吃。所以家庭生活艰难，子孙往往好学能发达，这当中都有因果关系。
    我是生在一个非常贫困的家庭，家中一无所有。父亲若一天不工作，家里一天就不能生活。知道此困境，年轻时不敢去玩，懂得要读书、要好学。同事、同学、朋友都说我是书呆子，他们问我为何不去玩，我说我也很想玩，但是时间换一换，你们年轻玩，我在年轻时多攒一点资本，到晚年再玩。现在我的那些老同学、老朋友，看到我都说∶「你对了。」这就是我比他们聪明之处。老年享福是真正的福报，年轻的福报不算福报。年轻受苦无所谓，有体力、有精神；老年没有福报，就很可怜，没有人照顾，生活很凄惨。所以年轻要修福，要积德行善；老年时，无论在何处，都会有人照顾。所以，「是非」我们要有能力辨别。

    「偏正」，善心、善行是正；恶念、恶行是偏。但我们看到有以善心造恶事的，此即所谓「正中偏」；也有以恶心却造了善事，这是「偏中正」。这些事实真相不可不知。善人造了恶事，这当中的善恶因果、事相非常复杂。譬如，早年我在台北参加大专佛学讲座，主持者是道安法师，他请我去教学，所以我有机会亲近他。道安法师非常慈悲，所以有信徒常常去骗钱，但老和尚都给他。有一天我去看老和尚，进去时，正好有一个人出来，那个人我也认识。老和尚说∶「刚才那个人今天又来骗我。」我说∶「你给他了吗？」他说∶「给了。」那个人不知道老和尚已知道了，以为今天又骗到手。道安法师往生时，负债八百多万，都是被人骗去的。但他并不是不知道，他知道还让你骗。老和尚没有钱，跟信徒借钱来给他，这是「正中偏」。也有以恶心做了好事，他实在是想害你、想整你，没想到这个因缘，让你得了大利，这些事情往往有之，那是「偏中正」。所以善恶很难辨别，要很细心去观察，守住佛讲的大原则－「凡所有相，皆是虚妄」，你就能看清楚、看明白。

    「半满」，满是圆满，半是不圆满。行善而不着善，这是圆满。行善之后，还念念不忘我做了多少好事，对哪些人有恩惠，此善是半，不是圆满的。譬如以财物帮助人，内不要常想到自己做了一桩好事；外也不要去记挂哪些人受你的恩惠，也不要想到你的那些财物，心地清净，这是「三轮体空」。这个福报是圆满的，无论布施多少都是圆满的。

    若着相布施，不忘记能布施的我，也不忘记那个人受我恩惠，你布施得再多，都是半。半就是所得的福报是很有限的；满才是无限的。所以经上讲，以恭敬心布施供养辟支佛一钵饭，能得九十亿劫不受贫穷的果报，一钵饭就能种无量的福报。为何福报那么大？以真诚心、清净心、平等心、慈悲心去修福，福报就是圆满的。所以一分钱的供养，能消无量无边的罪业，就是以真诚、清净心修布施。若是着相布施，捐黄金万两，福报还是非常有限。

    所以修福真的是很公平的，不是说有钱、有地位，才能修福；贫穷下贱，没有地位的人，就不能修福，没有这种道理，那是世间人的俗见，不是佛菩萨的智慧。我们在经上看到，乞丐遇到佛菩萨，遇到阿罗汉，想到自己这一生贫穷下贱，是过去生中没修福，今天遇到圣贤人，想修一点福。但实在没有什么能供养的，自己在外面讨了一点饭，可能已经吃了一半，还剩下一点。阿罗汉不嫌弃，接受你的供养，你来生享天福。所以一钵半碗饭的福报，能换得来生享天福，这是真诚、恭敬心修福。大富大贵之人布施百万、千万，未必能生天。只要明白这些道理，就知道自己应如何修学。修福是人人都有机会，是人人平等的，问题就是你懂不懂这个道理，明不明白这些事实真相，如理如法的修学，每个人都能够得圆满的福报。

    「难易」，行善、积善有难有易。凡是有机会去做就容易；有机会而不肯做，这就难了。尤其是贫穷之人，生活在极度困难当中之人，要是能发心修布施供养，真正难能可贵。所以难易不在事，在心。真正觉悟明白，会抓住机会就容易了。但是世间确实有很多有财富、有地位之人，不晓得修善、积善，抓不到机会，这对他就难了。
    有一位同修告诉我，澳大利亚有一个很有钱的人死了，财产不给儿子，也不给女儿，给他养的狗，这苹狗变成了富狗。他这么喜欢狗，来生一定到畜生道去投狗身，这是愚痴到了极处！他有这些财富，不知道做社会福利事业，不知道帮助世间困难之人，许多机会在他面前错过了。当然这苹狗跟他也是有缘分，过去生中没有缘就不可能。这是他愚痴，不懂得修福。

    【为善必穷理，否则行无益。】
    这是结论，这是真话，要深明当中之理。我们要做真正的好事、善事。首先要明白什么是第一等好事，就是「帮助众生破迷开悟」。所以释迦牟尼佛、诸佛菩萨应化在世间，就为了这桩事情，也就是现在所讲的「多元文化的教学」。帮助一切众生破迷开悟，果报就是离苦得乐。众生的苦难从哪里来？迷惑颠倒造成种种苦难。觉悟之后，就能消灾免难。所以觉悟之后，自然有能力辨别真妄、邪正、是非、利害；自然就断恶修善，积功累德，福报无有穷尽。
    了凡先生在此地，又讲了积善的十个纲领，教我们要认真去做。

    【与人为善、爱敬存心、成人之美、劝人为善、救人危急、兴建大利、舍财作福、护持正法、敬重尊长、爱惜物命】
    一、「与人为善」，这是讲存心，要存一个善心，以善心看待一切众生。
    二、「爱敬存心」，以真诚心爱一切众生，爱一切人事物；“敬”是恭敬、谨慎、细心，对人、对事、对物，爱敬存心。
    三、「成人之美」，人家有好事，我们要帮助他、成全他，不能破坏。此人是恶人，但是他做的事是好事，即「偏中正」，我们也要帮助他。不能对人要对事，此事对社会有好处，对大众有好处，就应当帮助。人虽然不善，我们要常常辅导他，尽心尽力去帮助他，使他的善行能成就。
    四、「劝人为善」，特别劝导有能力、有机会的人，他们有能力、有机会行善，错过非常可惜。没有机会去创造机会，比较困难；创造机会也必须有创造机会的条件，否则也是做不到。所以认识机会，掌握机会，这是真正的智慧。
    五、「救人危急」，人在有急难、危险之时，不论他是好人、恶人，是恩人、冤家，不能见死不救，一定要救援。
    六、「兴建大利」，所谓大利，利益社会、利益众生的就是大利。自己有能力，自己一个人做；没有能力，就集合大众的能力来做。利益社会大众的事情太多，什么是真正的大利，真实的大利无过于教育，教育是根本。今天社会动乱，人心不安，灾难频繁，其原因就是教育的失败。现前最大的利益，就是宗教教育的落实。现在的学校教育，要回到中国古老的教学宗旨很难；换句话说，纵然他明了，也无法改正过来。所以，今天唯一的办法，就是宗教教育。

    宗教教育要看我们自己怎样去推动。说到佛教教育，今天无法推动佛教教育的原因何在？没有师资，没有讲经说法的人。出家人虽然不少，但出家人没有忘记自己，没有放弃自私自利，想推动佛陀教育根本不可能。要想推动佛陀教育，最低限度要将自私自利的念头舍弃，这就难了。所以当前最大的利益是办学，培养师资，然后才有一批人来推动，来教化众生，帮助众生断恶修善、积功累德。
    这个世间孤儿很多，这些小孩从小就失去母爱，失去家庭，他们需要真正有爱心的人来照顾、教导。要如何教导，这都是社会大利之一。现今的社会，年老之人退休后，儿女不孝养，老人的晚年非常孤单、寂寞。我们要如何照顾、教导他们，让他们回头，让他们忏悔，认真学习，使来生比这一生过得更殊胜，这是教育。当然最殊胜的，是帮助他作佛、作菩萨。此目标若达不到，也应当帮助他生天，帮助他来生得到人间富贵，这都是属于大利。

    七、「舍财作福」，世间人不知道财是罪业，你能够舍财，你就修福了。积财就是罪业，很多人缺乏财用，你把财留在身边，让一些人受苦受难，这就是造业。何况财积在身边，增长贪嗔痴；换句话说，增长你将来堕三恶道的机会。所以财一定要舍，要舍得乾乾净净。世间人不肯舍财，就是有顾虑，担心舍了之后生活没着落，这是他不懂因果的道理。命里有的决定有，舍都舍不掉；命里没有的，求也求不来。可是财来的时候，还要赶快舍。

    中国从前供的财神是范蠡，很有道理。范蠡非常懂得处理财务，他帮助越王勾践打败吴国之后，就退隐去做生意，没多久就发财了。发财之后就布施，布施完了，再从小生意做起；没多久又发财了，发了之后又散，三聚三散。所以他懂得散财，懂得布施，愈施愈多，愈多愈要散，决定不积财，这是修大福报。不但他这一生当中，财用决定不会匮乏，来生的福报无比殊胜。

    八、「护持正法」，世间正法、出世间正法都要维护。今天护持正法以新加坡的李木源居士为榜样，值得我们学习。他毫无私心，真正是念念为佛法、念念为众生。但是护法首先要有智慧、有能力，认识正法。特别在现前时代，《楞严经》云∶「邪师说法，如恒河沙」，也就是说仿冒的佛法太多了。所以首先要有能力认识正法，然后才发心去护持正法。我们一生全心全力做这桩事情，但是每个人缘分不同，有人很想学佛，很想亲近善知识，但是遇不到。真正遇到善知识是大幸，遇到善知识要真正肯学，发心学习弘扬、护持，这是无比的福报。

    九、「敬重尊长」，佛教导我们要孝亲尊师，要做到。现在世间人不重视孝道、师道，我们要为社会大众做好榜样，念念不忘父母师长的恩德，这是存心厚道。不但不忘，还要有行为表现，对父母、师长要尽到孝养的责任。生命得之于父母，慧命得之于老师，对父母、老师之恩怎么能忘记？我小学的老师已经找不到了，中学时代的老师，现在还有一位。每当逢年过节，我都会送一份供养给老师，礼虽然很微薄，但老师感到很温暖，学生没有把老师忘记。

    老师对我们有厚恩，如何报答？表扬老师的德行。我跟李老师学佛十年，李老师往生之后，我向台中莲社建议，在老师的故乡山东济南，建立一个纪念堂。韩馆长对我有护法之恩，念念不忘。我在她的故乡买了一栋七层的大楼，做为韩瑛馆长的纪念堂，这是不忘本。我还有一个中学校长－周邦道先生，抗战期间我在贵州念书，他是我的校长。到台湾，我们有缘分跟李炳南老居士学佛。他往生了，我在贵州建立一个中学纪念校长。校长的别号庆光，所以学校名称为庆光中学。我母亲往生了，我用华藏奖学金来纪念她。在大陆有五十个学校，设立这个奖学金。孝亲尊师，我们要有行动去表现，要真正做到。这是提倡孝道、师道，提倡知恩报恩，人不能忘本，这是教育的作用。
    十、「爱惜物命」，佛家提倡素食，素食是不杀生。戒律里，将「不杀生」列为第一条戒。杀生是大恶，我们要学习爱护一切众生的生命。

    【善行无穷，由此推广，万德可备。】
    善行真的无量无边，了凡居士在此地，为我们列出这十条，我们能做到，然后将这十条推广，才真正是积善、行善。我们这一生有幸遇到佛法，遇到好老师，我们才明白这个道理，才知道这一生应该如何做人，真正依教奉行，这一生过得很充实、很美满。尤其现在是大动乱的时代，积善积德一定要抓紧机会，赶快努力去做，失去机会就很难再遇到。

    ◎ 谦德之效
    这是《了凡四训》的第四篇。主要是告诉我们∶为人处事要懂得谦虚。
    【满招损，谦受益】
    很多世间人做好事不能成就，其原因多半是姿势太高，傲慢引起别人嫉妒，所以产生了阻力；到招架不住时，事情就毁于一旦。古人做善事为何能成就，为何那么顺利，又得到许多人的帮助，就是谦虚。自己不居功，功德都是大家的。今天我们在新加坡做这么多好事，李木源居士从未说这是他做的，都说是大家做的，每个人都尽心尽力，所以才有今天殊胜的成就。功德归大家，过失归自己，事情就能成功；功德归自己，过失归大家，没有不失败的。
    第一小段「举易总明」，这是举《易经》来总说。

    【天道亏盈而益谦，地道变盈而流谦，鬼神害盈而福谦，人道恶盈而好谦。】
    「天道亏盈而益谦」，“盈”就是满足。所谓「满招损，谦受益」，人最忌讳的就是「满」。人觉得自己很满足的时候，往往不知不觉，骄慢的态度就出现了，这是最不好的预兆。打仗亦是如此，骄兵必败。“谦”是谦虚，谦虚就受益。《易经》上举个比喻，譬如这个杯子是满的，若要再加水，就加不进去了，会漏出来。若这个杯子只有一半的水，就能接受别人的供养。所以，满就招损，谦就受益。「天道亏盈而益谦」，“亏”是亏损，“益”是增加。你自满，就会让你亏损一点；你谦虚，就会给你增加一点，这是天道。
    「地道变盈而流谦」，“变”是变迁，满的时候，必定有变化；“流”是润泽，地洼之地就有水润泽，地高之地就得不到润泽。「鬼神害盈而福谦」，鬼神看到自满之人，往往会害之；谦虚之人，鬼神会保佑之。「人道恶盈而好谦」，踌躇满志者，人厌恶，嫉妒障碍就产生；谦虚者，大家都喜欢、都尊重，都愿意帮助。所以我们处事待人接物，要懂得谦虚。
    第二小段「举事别明」∶

    【丁宾恭敬顺承受侮不答，闻谤不辩，必登第。冯开之虚己敛容，友面攻其非，平怀顺受，及第。夏建所气虚意下，谦光逼人，温良若此，中式。】
    了凡先生在这一段里，举了几位他熟知之人。凡是谦虚的读书人，考功名都能考中。丁宾是他同时代的一位年轻读书人，为人孝亲尊师。同学毁谤、侮辱他，他没有一句辩白，完全能够忍受。而且以恭敬心、清净心、平等心待人，不会嫌弃毁谤、侮辱他的人，所以此人考中功名。有没有功名，有没有富贵，是命里有的，不在乎学识。运气好的，考试的题目正好都知道；有人非常用功，非常勤奋，天天读书，考的题目刚好没有读到，往往没考取。

    我小学考中学时，天天玩，根本没有读书，结果考中第十名。我有个同学叫曹同文，非常用功，是全班第一名，结果他没有考取。为何没有考取？这是命。所以古人讲到考试，首先是阴功，你的祖宗有没有积阴德，自己有没有积阴德。了凡居士看人也是这么看，这是吉凶祸福的预兆。

    第二，冯开之也是当时应考者之一。此人谦虚，在大众之中，懂得收敛，对人恭敬，别人当面说他的过失，都能虚心接受，这是一般人做不到的。了凡先生认为此人考试一定考中，果然不出所料。第三，夏建所的待人处事虚心下意，处处不敢为人先。了凡先生说他是「谦光逼人，温良若此」，温厚善良，谦虚卑下，这是个读书人，肯定考取。这是讲谦德的效果。

    【虚心曲己，受福之基；谦则受教，取善无穷。】
    最后，以此勉励儿子要学谦虚。「虚心曲己，受福之基」，虚心委屈自己，这是受福的基础；贡高我慢，不可一世，瞧不起人，那是祸害的根源。你现在得志，可以傲慢，有一天你失志时，人家远离你，不再理会你，你就有苦头受了。所以人在得志时，愈要谦虚恭敬，愈要诚心诚意，利用这个机会去帮助别人，修福积德。到自己年老体衰，报恩的人，照顾你的人就多。所以我们现在修福，到晚年才享福。中国的教学，年轻时代是培养福德的基础、根基。这些教育都是小学时教的，父母、老师教导，一个人的成就都是得力于当时的栽培，所以父母、老师之恩德昊大。中年时期踏进社会，是修福、造福、积福的时候。《礼记》云∶「七十而致仕」，七十岁是退休的年龄，退休之后享福。

    现在的社会颠倒了，儿童享福，父母宠爱；中年战场拼命；晚年坟墓，这多可悲！这是中国与外国教育理念之不同。我过去住在美国，中国人还有祖孙三代同堂的，日本人也有很多，当地美国老人看到很感动。他们的儿女走了之后，就不回来，逢年过节寄一张贺卡，就高兴极了。现在人受西方文化影响太大，也学外国人不养父母，忘恩负义。种下这个因，到晚年退休时，也会尝到这个果报。我们要想恢复传统善良的教学，一定要从自己做起，一定要懂得谦虚。

    「谦则受教，取善无穷」，谦虚才能受教，善福无有穷尽。人只要傲慢不谦虚，再好的老师都无法教导。我跟李老师十年，看到老师对学生的教学，凡是学生傲慢毫无谦下之心的，老师对他就很客气、很恭敬。他有过失，老师也不责备，因为讲了没用处，反而得罪结冤仇。能接受的，肯听话的，老师又打又骂，没有一点好脸色，这是真正在教导。不肯接受的，将你当作客人；肯接受的，才当作学生。老师不是偏心，完全看学生肯不肯接受。所以，有一分诚敬，肯接受一分，就教你一分；有十分诚敬，肯接受十分，就教你十分；不能接受就不教了，教了没用。这是因人施教，看学生的真诚心、谦虚心来教导。

    所以，佛法的修学，旨在说明宇宙人生的真相；人生就是自己本人，宇宙就是生活环境。了解宇宙人生真相者，称作佛、菩萨；迷惑颠倒，不清楚、不明了，就称作凡夫，所以圣凡只在迷悟之间。觉悟了，就得大自在；迷了，不但不自在，还要受很多苦难。不了解事实真相，随着自己的烦恼、知见，错误的想法、作法，变现出这些不吉祥的果报，招致许多的灾难。自古以来，世出世间的圣人，中国人称作圣人，印度人称作佛，其意思完全相同。因此，「圣」的定义，就是明白宇宙人生真相之人。

    佛法分世间圣人与出世间圣人，其实这都是方便说。真正觉悟、圆满觉悟之人，心地清净，决定没有世间、出世间的这些概念；有就是妄想、分别、执着没断，纵然觉悟，悟得很有限。佛是希望每个人都能彻底觉悟，也就是希望人人都成佛，成佛就是成就彻底圆满觉悟。所以，佛不是神，神还是没有觉悟，只是福报比我们大一点，智慧比我们高一点，其实也高不了多少，也还没超越三界六道。这些事理我们都要清楚，才知道应该如何学佛，学佛的目的何在，学佛应当具备的态度与方法，希望有什么样的成就。成就是果报，每个人都希望过幸福、快乐、美满的生活，佛法确实能让我们达到此目的。无论在这一生、在来生，生生世世永远得到幸福、美满、快乐。

    如何才能得到？觉悟才能得到。如何才能觉悟？要教学，要亲近善知识，佛在经上这样教导我们，中国圣人也是这样教导我们。我们亲近善知识，是否真的能觉悟？固然有觉悟的，还是少数，不觉悟的占多数。关键还是「好学」，好学的人亲近善知识就有成就，不好学的遇到善知识也是空过。好学是否真的能有殊胜的成就，也不见得，只能说会有一点小成就，至于大成就、圆满的成就，还要加上一个条件，就是大心量。谚语所谓「量大福大，福大慧大」，大智慧、大福德就是从大心量来的。心量小纵然好学，遇到善知识，成就还是小。
    佛家的教学亦如是，小乘亲近善知识，大乘加上一个好学，普贤行再加上大心量。「心包太虚，量周沙界」，又好学，又喜欢亲近善知识，具足这三个条件，一生才能够圆满成佛。这三个条件，若缺少善友，纵然好学、有大心量，也不能成就，因为没有基础，可见得亲近善知识是极为重要。《阿难问事佛吉凶经》一开始就说，要亲近明师；「明」就是通达明了。纵然不好学，没有大心量，能亲近明师，也可以达到修学佛法的第一目标－断恶修善。也就是说，真善知识绝对不会帮助人增长贪嗔痴。帮助人增长贪嗔痴，帮助人造十恶业，就是恶知识。善知识不但教人断恶修善，自己一定也会做个好榜样。

    释迦牟尼佛是一位最好的老师，最好的善知识，他自己所说的，他全都做到。他一生对于自己所需，可说是降到最低的水平，过着三衣一钵的生活。就是告诉我们，物质生活过最低的水平，所谓是吃得饱，穿得暖，有个小房子可以遮避风雨，就足够了。身心毫无牵挂、忧虑，没有丝毫压力，正是圣贤人所讲的「心安理得」。道理明白，心就安了，心安就知足常乐。世间何人最苦？不知足的人最苦，他永远没有满足之时。
    所以，佛法教学目标，首先是教导众生「断恶修善」，这是修因，果报是人天福报。断恶就是断三恶道，修善就是修人天福报。这是指亲近明师，亲近善友，就得到这样殊胜的果报。若加上好学，果报就更殊胜。学能开悟，学能明理，对于宇宙人生的真相通达明了，果报更殊胜，能超越六道轮回。

    世间真正的乐，是读书乐。读什么书？圣贤书。佛是大圣大贤，天天读佛经，能体会到经中的义理，其乐无穷，此乐非世间名闻利养、五欲六尘之乐所能相比。所以，释迦牟尼佛一生，乐此不疲。佛的学生，诸大菩萨、大阿罗汉，和中国历代祖师大德，各个都乐此不疲。我们应当细心体会、观察，真正亲近圣贤，有大乐在其中。
    更进一步，心量拓开了，真的是「心包太虚、量周沙界」，念念为一切众生着想，为虚空法界着想，这种心量在佛法里称「普贤行」。无论修学什么法门，都是普贤法门，以心量将修学的功德，拓展到最圆满、最究竟，就圆成佛道。
    这三个阶段，第一是「断恶修善」，脱离三恶道，得人天福报。第二是「破迷开悟」，脱离六道轮回，往生到四圣法界（声闻、缘觉、菩萨、佛）。最高的层次，就是拓开心量，无一不能包容，心地真诚、清净、平等、正觉、慈悲，就与诸佛如来相同，这就「超凡入圣」；「凡」是十法界，「圣」是一真法界，超越十法界，入一真法界。《华严经》讲的华藏世界，净土宗讲的极乐世界，都是超凡入圣。所以，佛法是属于觉悟的教育，觉悟的教学。

    佛菩萨、善知识愿意教，有没有人来学？「佛氏门中，不舍一人」，只要有一个人肯学，佛菩萨就来教。我们在经典里看到的当机众，当机众是来当学生的，除他之外都是旁听的。真正来学的人得利益，旁听的只是结一点法缘；换句话说，得到一点佛学常识，真正的利益得不到。而真正做学生的就会真干，真的断恶修善，那是正科生，佛法称当机众。所以佛的教学非常慈悲，只要有一个人肯学，佛就会住世。教学的成果，是要将恶人教化变成善人，将坏人教化变成好人，将迷人教化变成觉悟之人，这是教学。不能说这是坏人，就开除他，那是失败的教育；成功的教育是变化气质。众生可不可能有变化？决定可能。但是众生的业障、烦恼、习气很重，善知识要有耐心，这不是一天、两天就能成功。我学佛四十七年才转过来、才回头，我不是一个很用功的人，也不是上根利智，可是天天学，锲而不舍，不知不觉就转过来了。真转过来，起心动念决定不会再为自己想，为自己想是没转过来。为一切众生幸福着想，为一切众生消灾免难着想，就是真正回头。所以，我们的学习要跟老师相应，老师是佛菩萨，佛菩萨的教诲就是经典，读诵经典就是亲近诸佛菩萨。

    所以，此次将《了凡四训》的大意，为大家略略介绍，很有必要。《了凡四训》的内容，是「深信因果，改造命运」。尤其现在世间有许多灾难，能否化解？能，只要懂得道理、方法就能化解。若不懂道理、方法，就没有办法了。这几天有这点时间，与大家在一起研究，也是一件好事情。

返回栏目