封面

中华佛典宝库制作　2005.2.8
http://www.fodian.net


目录

《普贤行愿品》观修原理
济群法师 讲述


导　论

    《普贤行愿品》观修原理
    济群法师
    2004年讲于苏州定慧讲堂

    导　论

    在盛行大乘的汉传佛教地区，《普贤行愿品》的流传极为广泛。许多佛弟子都将本品作为日常念诵功课，而寺院晚课的“八十八佛大忏悔文”中，也有一半内容出自本品，以此忏悔业障，扫除修行道路中的违缘。在藏传佛教的修行中，源于《行愿品》的七支供亦倍受重视，被视为一切法门的前行。所谓前行，即修法前的准备工作，包括集资和净障两方面。集资，是积累成佛所需的福德、智慧资粮；净障，则是忏悔业障。我们之所以流转生死，正是业力所致。《行愿品》告诉我们，“众生罪业若有形相，尽虚空遍法界不能容纳”。这些无尽生命中造作的罪业，是促使有情流转生死的动力，也是障碍成佛修行的阻力。所以，在广泛积集资粮的同时，必须彻底忏悔业障。
    那么，我们如何在短时间内圆满积集资粮，并清除无量罪障呢？汉、藏两地的祖师大德们都提倡依《普贤行愿品》修行。《行愿品》的核心内容，为礼敬诸佛、称赞如来、广修供养、忏悔业障、随喜功德、请转法轮、请佛住世、常随佛学、恒顺众生、普皆回向十大愿王。发愿，想必大家都不陌生。在人生的各个阶段，我们曾有过这样或那样的愿望，但这些愿力往往现实而渺小。而“普贤行愿”所以被称为愿王，是因为每一愿皆以广大无限的发心为基础。“礼敬诸佛”，是以尽虚空、遍法界、十方三世微尘数诸佛为礼敬对象；“恒顺众生”，同样是以尽虚空、遍法界一切众生为恒顺对象。
    《普贤行愿品》为《华严经》最后一品。《华严》教法至圆至顿，素被誉为“经中之王”，此无上甚深法门最终也是导归普贤行愿。由此可以看出，十大愿王对于修行的意义极为深远。根据我个人的修学心得，认为本品可总结为两句话，那就是“菩提心的无上观修，佛陀品质的临摹方法”。所谓“菩提心的无上观修”，是因为本品乃修习菩提心的殊胜法门；所谓“佛陀品质的临摹方法”，是因为按本品所揭示的法门修行，能指引我们直接通过临摹而成就佛道。若按《行愿品》着手修学，会发现成佛距离我们并不遥远，且是切实可行的。从这个意义上说，本品是一部教我们如何成佛的宝典。
    在正式进入《行愿品》的学习前，我们首先要对佛法有一些基本认知。

    一、暇满人身的重大意义

    人生最重要的是什么？或许会有很多答案。却很少有人会想到，和我们在世间所能得到的一切相比，人身才是最可珍贵的无上至宝。
    人们往往意识不到这一身份的价值，似乎生而为人是理所当然的事，根本不值得庆幸。我们赚点小钱也会开心，对得到这个“人身宝”却毫不在意，因为它是免费的，不是我们花钱买来的。其实，我们身上的任何一个器官远比财富更重要。当我们拥有健全的色身时，或许体会不到，明亮的眼睛有多么重要，完整的四肢又有多么重要。我们习惯于拥有，习惯得几乎感觉不到它们的存在，自然也忽略了其价值。一旦失去之后，才会追悔莫及，甚至愿以全部财产来换取它们。如果没有眼睛，我们就看不到整个世界；如果没有双手，连基本生活都难以自理。报刊上，时常可以看到病人为移植器官而历尽艰辛、倾家荡产的事例。得到一个器官尚且如此艰难，何况完整的人身呢？若是失去这一身份，也就失去了在世间拥有的一切。
    我们的一生，不断处于各种追逐中，追求金钱、事业，追求家庭、感情，以为这就是人生的全部。为什么会产生这些欲求？是因为凡夫这颗无法自主的心需要它们来填补。若仔细评估一下，其价值究竟何在？我们期待的这一切，只代表暂时的需要，也只有暂时的意义。因为它们都无法永远保有，我们不过是暂时的经营者或保管者。死亡来临，我们什么也带不走，甚至这个身体，最终也要化为灰烬，回归大地。伴随生命继续流转的，唯有无始以来积累的业力，这才是和我们须臾不离的。而在随业风漂流的漫长岁月中，得到人身的机会微乎其微。
    现代人感觉不到人身难得，可能因为我们看到的人太多了，尤其是城市，到处人满为患。另一方面，生个孩子也很容易，似乎人身不见得那么难得。但从宏观角度来看，得到人身的概率在一切生命中却是微不足道的。虽说世界人口已达几十亿，仍无法和其它众生相比。仅仅在我们可以看到的畜生道，一个蚁窝就生存着成千上万的生命，而在广袤的海洋和森林中，更蕴藏着难以计数的众生。
    佛经记载，某日，佛陀从地上抓起一把树叶询问弟子：我手中的树叶多，还是大地的树叶多？弟子回答：当然是大地的树叶多，手中所有无法比拟。佛陀以此告诫大众：得到人身的有情，如我手中的树叶；未得人身的有情，则如大地的树叶。
    在无尽轮回中，我们曾堕落地狱，曾沦为傍生。如今虽然得到人身，但百年之后，能保证自己再得到人身吗？人身的意义，不仅在于其难得，更在于它的价值重大。我们能用这个身份做什么？或许不少人会觉得，这个身份可以用来赚钱，用来养家糊口。在这个世上，多数人都不曾对现有人身善加利用，反而沦为这一身份的奴隶，不仅要为生存奔波操劳，更为了满足不断增长的物欲忙碌一生。尤其是现代人，极度缺乏因果观念，在几十年的人生中，因贪图享受而不断造业。一旦离开这个世界时，带不走分毫财富，却背负了沉重的恶业，实在得不偿失。
    当然，也有些人能利用今生造福社会民众，或通过修行改善自身生命。但总体而言，都未发挥人身的最高价值。那么，这一最高价值究竟是什么？那就是成佛！在生命的某个层面，每个人都具有和佛菩萨同样的品质，经中将此喻为“贫女宝藏”、“力士额珠”。一旦将蕴涵如来智慧德相的牟尼宝珠打开，我们也可以象佛菩萨那样自在解脱，广泛利益众生。
    或许有人会感到疑惑，为什么我们现有的境界和佛菩萨毫无相似之处呢？这是因为，我们固然具有佛菩萨那样的潜质，目前却滞留于凡夫心的层面，还未将此宝藏打开。事实上，很多人根本不知自家有如此宝藏尚待开发。即使听说，也往往当作神话一笑了之，既不能直下承担，亦无心挖掘开显。因为我们现有的心行是如此狭隘，甚至容不下这种可能性。
    作为学佛者，必须认识到生命是无尽的，而不仅是今生这几十年。众生虽然平等，但因业力所致，起点各不相同。有些人天生聪慧，福报深厚；也有些人资质驽钝，福薄命苦。有鉴于此，我们不能仅仅考虑现世，更要着眼于未来。人天善法的修习，正是立足于瑕满人身的获得。得到人身，既出离了三恶道苦，更对生命发展具有重大意义。六道中，唯有人的身份可以修行。地狱、饿鬼太痛苦、畜生太愚痴，而天人则太快乐，都无法精勤道业。唯有人类处在苦乐参半的环境中，兼具抽象思维能力，能为离苦得乐而追寻真理。
    佛陀是以人的身份修行成佛的，诸佛世尊同样是以人的身份成就菩提的。可见，人的身份是踏上成佛之路不可或缺的护照。得到人身，有如得到一次超凡入圣的大好机会。若不加善加珍惜，蹉跎一生，不知何时才能再有这样的幸运。所以说，认识暇满人身的重大意义，直接关系到我们能否利用今生学好佛法。

    二、念死和观苦
    认识到人身的意义，不是为了对此身份产生贪著，而是利用它成就道业。故应发起勇猛精进之心，这就需要通过念死和观苦来策励道心，激发求道的迫切感。
    人身难得而易失。死亡，几乎是人生唯一可以确定的事实，无人可以例外。千百年来，无论是帝王将相还是贤圣名士，乃至历代高僧大德，皆已先后离去，差别只在于辞世方式的不同。百年后，在座的各位也要到不同去处报到。所以，死亡好比恢恢法网，疏而不漏。
    然而死期却是不定的。尤其在当今社会，天灾人祸频繁，我们随时都在面临死亡的威胁。但未死之前，我们总觉得死亡似乎很遥远。特别是年轻健康时，更觉得死亡与己无关。虽然也知道世上每天都有人离去，但总是心存侥幸，以为属于自己的日子还长得很。惟有亲人离世，才会使我们体味到死亡的阴影。而到自己必须直面死亡的时刻，方有切肤之痛，可往往为时晚矣。
    生命极其危弱，一口气不来，转息便是来生。若我们时常观想死亡，便能减少对世间的贪著。因为所有执著都是建立于对“恒常”的向往，可在死亡面前，这一切又是多么微不足道呵。曾经拥有的金钱、地位，对于亡者又有什么意义？念死无常，不仅能使我们以超然的心态生活，更为我们揭示了修行的关键，那便是“舍弃今生”。不论是以什么方式贪著今生，势必无法将烦恼连根拔除。所以，想要究竟解脱生死，必须以舍弃今生幸福为代价。
    人生短暂，一期生命结束后，我们又将走向何方？唯一可以肯定的是，未解脱生死前，我们必然在轮回中。如果曾经造作恶业，就可能堕落于三恶道。其中，最苦为地狱道，世间所有的刑罚和刑具都无法与之比拟。地狱又分八寒地狱和八热地狱，不是极冷便是极热，日夜在其中千生千死、万生万死。稍次为饿鬼道，则始终处于极度饥渴状态，即使得到食物也无法下咽。最轻为畜生道，但也时刻面临弱肉强食和任人宰杀的恐惧。其中，仅仅是畜生所受的苦痛已足以令我们胆寒，遑论饿鬼及地狱之惨烈痛苦。
    现代人对恶道苦或许比较隔膜，因为我们更信服“眼见为实”的事例。那我们就来观察一下人道，其实，人间苦难也是三恶道的显现。有些人整天被烦恼和病痛折磨，那种求生不能、求死不得的痛楚，就仿佛身处地狱；也有些人对财富的需求永无餍足，始终被病态的渴求折磨，又仿佛饿鬼一般；还有些人终年为生计拼命劳作，干着比牛马更累的粗活，所得却仅能裹腹，除求得温饱外再无任何目标，这样生存方式和动物又有什么区别？时常观察恶道苦，能帮助我们生起出离心，否则就会贪著现世，造业亦在所难免。如果不加以警惕，那些恶道苦也许就是我们的未来。
    不仅恶道是苦，轮回的本质就是苦。在我们的感觉中，世间似乎有苦有乐。尤其是有钱有势者，或许还感觉挺风光。但任何一种快乐都蕴涵着痛苦，即佛教所说的有漏皆苦。所谓有漏，就是不完整、有缺陷。无钱时固然痛苦，有钱了还是烦恼；未成家时觉得孤独，成家后才知问题更多。饥饿时面对大餐备感幸福，食之过量便立即转为痛苦；疲倦时睡上一觉浑身舒畅，但若没完没了地躺下去就让人烦恼了。可见，由欲望满足得来的快乐是多么短暂而善变，稍纵即逝。
    真正认识到轮回是苦，认识到三界有如火宅，必定引发强烈的出离心。当我们迫不及待地想离开一个地方时，自然不再有心思贪著什么。反之，若对世间尚有爱执，势必无法与修行相应，因为用心的起点就错了。

    三、放弃我执

    一切执著的根本是我执，即执著有个自我。因为我执，就和众生有了自、他的对立。生活中我们可以发现，那些特别在乎自己的人，烦恼往往也特别多；反之，无私的人却更容易快乐、自在。
    “我”是什么？其实只是一种感觉。比如一本书，本身并不存在你、我的差别。但我们将这本书买来之后，就会在其上附加“我”的标签。一旦确立这种感觉，这本书的损坏或丢失就会影响到我们。而在此之前，无论它发生什么变故，都不会对我们构成伤害。再如我们去购房，未买下之前，房子出现什么问题都无足轻重，因为它还未和我们发生关系。可买下之后，它的任何变化都会牵动我们的心。这种难过，正是由于那些附加的、“我”的感觉所致。
    为什么我们会为这些琐事烦恼，而非其它更重要的事情呢？世间每天有很多灾难，有很多人遭遇挫折或离开人世，但我们只是感叹一下，不会有多少切身感受，更不会因此寝食难安。这是因为其中还未沾上“我”的标签，一旦发生的事情中介入“我”，感觉立刻就不同了。如果那个遭遇挫折的是“我”，那个离开人世的是“我”的亲人，一场普通的人间悲剧便顿时上升为头等大事。是呵，在我们的世界中，还是什么比“我”受到伤害更严重的事件呢？当一个不相干的人去世了，我们会觉得人皆有一死，未足为奇；可当亲人或我们自己面临死亡时，就不会如此坦然面对了，不是抱怨上天不公，便是哀叹自己薄命。
    可见，一切烦恼皆围绕“我”而展开。我们将缘起的念头和想法当作是“我”，将种种不是我的当作是“我”。若不受这种错觉的影响，那些来来去去的念头，又如何能在心中生根并进而伤害我们呢？如果没有“我”的干扰，世间的无常变化就是我们能够接受的客观规律，就如我们能够接受四季更替和草木枯荣那样。
    那么，色身总该属于“我”的吧？其实不然，色身亦是因缘的产物，由物质和精神两方面构成，前者是父母的遗传基因，后者是蕴藏无量种子的阿赖耶识，其中并无“我”的属性。当阿赖耶识最初投胎时，将父母的基因执以为我，赋予“我”的感觉，从此难弃难舍。因为执著时间长久，故对我们的影响也特别大。其实，色身从成长到衰老始终处于新陈代谢的过程中。现如今，医学更发达到可以替换人体器官，可以更换“我”的组装零件。其中，又有哪一部分是固定不变的“我”呢？至于我们的想法，一生中也在不断变化，青年不同于中年，中年不同于老年。而感情就更是无常，亲人可能反目为仇，仇人也许握手言欢。在人间这个大舞台上，这样的情节时时都在上演。
    身内之物尚且如此，更何况汽车、房子等身外之物呢？所有这些，我们只有暂时的使用权，都不能代表我们自己。一件无主的物品，只因为附加了“我”的感觉，却成了能够伤害我们的武器，越是在乎，杀伤力就越大。那些爱钱如命的人，一旦失去财产，就如遭受灭顶之灾，甚至丧失活着的勇气。造成痛苦的根源，并不是金钱本身，而是人们对金钱的执著。我们每做一件事，也会介入我执，成功了，觉得“我很成功，很有面子”；失败了，觉得“我很失败，屡受挫折”。事实上，事业并不能代表我们自己。如果两者是一体，事业失去时，“我”　是否也会随之失去呢？感情、家庭也是同样，各人在乎的对象不同，烦恼的重心也不尽相同。因为感觉的力量也是缘起的，取决于我们的培养。
    由此可见，“自我”只是虚张声势的皮包公司，并无实际内容。凡夫因无明所致，将拥有的一切赋予“我”的错觉，进而执著它。其实，被执以为“我”的一切，只是出自我们的设定而非事实本身。我执是流转生死的根源，唯有从根本上舍弃它，我们才能超越三界和轮回。否则，学佛只是隔靴挠痒，或充实一下业余生活，对于改善生命并无真实力用。
    我们的心，本象虚空那么空明浩瀚，那才是心灵的真相。情绪只是虚空漂浮的云彩，是生命延续过程中积累的渣滓。而凡夫因看不清事实真相，始终纠缠在云彩中，将之作为虚空，作为心的本质。我们的心有多大，世界就有多大。虽然我们生活在同样的天空下，但各人心中的世界却如天地悬隔。如能突破我执，放弃对这片云彩的执著，凡夫心就失去了立足点，就能驱散遮蔽虚空的浮云，使生命回复清净无染的本来面目。

    四、发心

    做每件事，都离不开心的参与。对于大多数人来说，所思所想无非围绕个人利益。那么，学佛者又应具备什么样的心行基础呢？那就是出离心和菩提心。所谓出离，是出离五欲六尘及对五欲六尘的贪著。而菩提心，则是佛菩萨那样的“无缘大慈，同体大悲”。无缘，即没有任何条件，不求丝毫回报，对方需要就尽力给予。所谓同体，是将众生和自己视为一体，彻底打破自他分别，没有任何亲疏界限。若能以天下众生为利益对象，无一例外，慈悲也就圆满了。
    那么，菩提心又是如何发起的呢？所有心行皆来自积累，我们以贪心做事，就是在增长贪心；以悲心、利他心做事，则能长养悲心和利他心。其实，每个人都有或多或少的悲心，正如孟子所云，“乍见孺子将入于井，皆有怵惕恻隐之心”。但问题在于，一般人的悲心往往狭隘而薄弱。我们能否关心他人胜过自己？当个人利益受到影响时，是否还愿意帮助他人？“自他相换”，是藏传佛教关于发心的重要修法。凡夫的特点是处处想着自己而舍弃他人，一是出于对自我的爱执，一是源于对众生的冷漠。而“自他相换”则要求我们将眷顾自己的那份心转向关爱众生，将舍弃他人的行为转为舍弃自我。《道次第》云：“我执是一切衰损之门，利他为一切功德之本”，一语道破修行关键。诸佛菩萨为何能成就无量功德？正是因为舍我而利他。多关爱众生一分，自然少考虑自己一分；念念以众生为重，就不再有时间照顾“我执”。所以说，心发得有多大，思想境界就有多高。
    发心，难的不是行为本身。我们在世间取得的一切成就都来自发心，如我要考上大学、我要开办公司、我要成家立业等等。这种“我要达到什么目标”的愿望，就是发心。发菩提心与此不同的，只是目标的转换，也就是将利己之心转为成就佛道、利益众生的大愿。所以，修行所要做的就是调整方向，将为自己谋福利的那份精神用之于服务众生，象四弘誓愿所说的那样：“众生无边誓愿度，烦恼无尽誓愿断，法门无量誓愿学，佛道无上誓愿成。”
    除了观念的转换，菩提心还需通过利他行来巩固。我们可以规定自己每天做一件或三件利他善行，日积月累，使利他成为我们的习惯。行善的根本目的，在于长养善的品质。许多学佛者之所以会退心，正是因为发心后不再着意培养。发心好比播种，其后还应不断提供成长所需的养料，才能使它深深扎根于心田，枝繁叶茂，硕果累累。因此，我们要将生活中的一切境界作为修习利他心的增上缘。遇到顺境时，希望和一切众生共享；遇到逆境时，希望能以此承担世间所有的不幸。
    大乘佛教所有法门的修行都离不开菩提心，任何一位佛菩萨，也都是在因地发菩提心而成就。阿弥陀佛在因地发四十八大愿；药师琉璃光如来在因地发十二大愿；地藏菩萨在因地发“众生度尽，方证菩提”之宏愿。这些愿力皆由菩提心转化而来，既是下化众生的承诺，也是上求佛道的决心。其共同特点则是利益一切众生，佛菩萨是这样想的，更是这样做的。
    菩提心代表着生命中健康向上的根本力量，具有无限威力，散发无量光明，可以帮助我们成就最高尚的品质。按人本心理学所言，即完成“自我实现”。唯有发起真切、猛利的菩提心，才能成为真正的佛子，乃至成就佛菩萨那样的大慈大悲。否则的话，即使整天诵经、拜佛，也只能得到人天小果或种些善根而已。

    五、关于《行愿品》

    这次所讲的《行愿品》，主要立足于菩提心的基础上。
    除《行愿品》外，《华严经·初发心功德品》也围绕发菩提心的相关内容作了专门论述，以华严见地阐扬菩萨初发心功德。在我们的观念中，发心只是成佛之路的起点。而依《华严》见地来看，“初发心即成正觉”，圆满发心与最终结果无二无别。若菩提心发到位，和成佛所成就的，便是同一种心。但这一发心要求极高，不同于普通的发心，更非泛泛一说，必须准确而圆满。关于菩萨初发心功德，经中运用大量比喻作为说明。如一人度化世间所有人信佛、学佛、修行乃至证得阿罗汉果，其功德比之菩萨初发心功德，却百分不及一、千分不及一、亿万分不及一。原因何在？因为度化世间所有人证阿罗汉果，所度之人及所证果位都是有限的，故功德亦有限。而菩提心是以利益一切众生为对象，发心无限，故所获功德也就无限。
    此外，《华严经·净行品》也是教界广为流传的一品经文，对我们修行及生活中的用心方式作了详尽指导，甚至包括洗脸、吃饭、如厕等生活细节。我们可能会觉得：吃饭、如厕谁不会呢？那我们看看《华严经》是怎样说的：“大小便时，当愿众生，弃贪嗔痴，蠲除罪法……。若饭食时，当愿众生，禅悦为食，法喜充满”。同样的行为，因以不同发心为基础，性质就有了根本改变。
    我们以什么心做事，最终就会成就什么。做事有外在和内在两种结果：外在结果是暂时的，一如过眼云烟；而内在结果却对生命有着长久的影响。回顾人生，会发现以往经历的种种，曾经那么“真实”的生活，曾经那么让我们耿耿于怀的人和事，都被时间过滤成了一堆前尘影事。但我们要知道，这一切并未完全成为过去，由此积累的心力和造就的人格，还将继续影响未来生命。所以，学佛的关键正在于善于其心。
    《行愿品》是对菩提心教法的无上观修，它的高明之处，正是在于直接对佛果功德进行临摹。密宗将修行分为因乘和果乘，以大乘为因乘，通过发菩提心、修六度四摄而积累成佛资粮；而以密宗为果乘，直接从佛果的功德和品质着手修习。所以，首先要认识到佛菩萨的品质是什么，成佛究竟要成什么，然后按此特征调整心行。《行愿品》的修行，正是采取这种临摹、拷贝的方式，像临字帖那样，对照佛菩萨的品质，将我们的心行逐步调整到相似的层面，乃至完全吻合。
    《行愿品》由十大愿王组成，其中又包含座上观修和座下实修。如礼敬诸佛，是礼敬尽虚空、遍法界、微尘刹土诸佛世尊，观想法界每一微尘皆为佛身和佛德的显现，所谓“一花一世界，一叶一如来”。“称赞如来”等也是如此，主要是通过观想进行心行调整。以座上观修为基础，通过不断观修获得稳定有力的心行力量后，才有能力在座下真履实践。同时，座上和座下的修行也是相互融摄的，如“广修供养”，以实物供养为基础，再赋予观想的力量，将有限之物转化为无限。在无限的所缘境中，回归无限的心行，成就无限的功德。
    弘扬《普贤行愿品》，是希望大家将本品提供的修行法门付诸实践。如果我们能将普贤行愿的境界和心量纳入修行，念一声佛号等于念了无量佛号，拜一尊佛菩萨等于拜了无数佛菩萨。如此，每件善行都转化为无量，福智资粮必以最快速度递增，使我们早日成就佛道，广泛度化众生。这也是学习《行愿品》的意义所在。

    下面按《行愿品》的经文进行说明。
    “尔时普贤菩萨摩诃萨，称叹如来胜功德已，告诸菩萨及善财言：善男子，如来功德，假使十方一切诸佛，经不可说不可说佛刹极微尘数劫，相续演说，不可穷尽。若欲成就此功德门，应修十种广大行愿。何等为十？一者礼敬诸佛，二者称赞如来，三者广修供养，四者忏悔业障，五者随喜功德，六者请转法轮，七者请佛住世，八者常随佛学，九者恒顺众生，十者普皆回向。”
    佛经通常由序分、正宗分、流通分三部分够成。序分乃法会发起因缘，多为“如是我闻……”，但《行愿品》却没有这部分内容。因为本品并非独立经典，而是《华严经》中的一品。
    《华严经》为《大方广佛华严经》之简称，是佛成道后在菩提场等处，藉普贤、文殊诸大菩萨显示佛陀的因行果德广大圆满、无尽无碍妙旨的要典。本经在中国先后有三种译本，分别是东晋佛陀跋陀罗所译的六十卷《华严》、唐实叉难陀所译的八十卷《华严》和唐般若所译的四十卷《华严》。其中，四十卷本相当于前两译之《入法界品》，但文字上大为增广，尤其是“普贤十大行愿”等内容，为前两译所未有。
    本品经文出自《华严经·入法界品》，以善财童子为当机者，“善财童子五十三参”的著名典故即出于此。善财童子发起菩提心后，欲广修菩萨行，成就无上佛道。于是四处参学问道，共参访了五十三位善知识，分别是德云比丘、海云比丘、善住比丘、弥伽大士、解脱长者、海幢比丘、休舍优婆夷、毗目瞿沙仙人、胜热婆罗门、慈行童女、善见比丘、自在主童子、具足优婆夷、明智居士、法宝髻长者、普眼长者、无厌足王、大光王、不动优婆夷、遍行外道、鬻香长者、婆施罗船师、无上胜长者、师子频申比丘尼、婆须蜜多女、鞞瑟胝罗居士、观自在菩萨、正趣菩萨、大天神、安住地神、婆珊婆演底主夜神、普德净光主夜神、喜目观察众生主夜神、普救众生妙德夜神、寂静音海主夜神、守护一切众生主夜神、开敷一切树花主夜神、大愿精进力救护众生夜神、妙德圆满神、释迦瞿波女、摩耶夫人、王女天主光、遍友童子师、善知众艺童子、贤胜优婆夷、坚固解脱长者、妙月长者、无胜军长者、最寂静婆罗门、德生童子及有德童女、弥勒菩萨、文殊师利。最后于文殊师利所得三昧已，普摄诸根，一心求见普贤菩萨。
    普贤菩萨为善财童子宣说了他本人修学菩萨道所采取的途径，那就是我们接着要学习的十大行愿。这是一种极为高超的修行法门，倘若一时修不起来也无妨，可先以闻思种下善根，再通过努力修行和积累，终有善根成熟的那天。
    “尔时普贤菩萨摩诃萨，称叹如来胜功德已。”“尔时”，即那时。本品中，是指普贤菩萨赞叹如来殊胜功德之后。我们通常读诵的《行愿品》并不完整，只是《行愿品》核心内容的节选。之前还有很长一段经文，是普贤菩萨对如来功德的称扬赞叹。普贤行愿的修行原理，正是基于对如来功德的认识和模拟，故首先介绍如来究竟有哪些功德。
    “告诸菩萨及善财言，善男子，如来功德，假使十方一切诸佛，经不可说、不可说佛刹极微尘数劫，相续演说，不可穷尽。”普贤菩萨称赞如来功德后，进一步向诸大菩萨及善财童子总结如来功德之无量无边。“十方”，是从空间而言，即东、西、南、北、东南、西南、东北、西北、上、下，共十方世界。“一切诸佛”，指处于十方虚空中的诸佛菩萨。“不可说”是形容指时间漫长得难以记述、无法形容。“劫”，又译大时，本身已是年、月、日不能计算的漫长时间，更何况“微尘数劫”。所谓“微尘数劫”，是将地球碎成微尘，每粒微尘又代表一劫之久。即使集十方诸佛之力，以如此长劫岁月赞叹如来功德，仍无法穷尽。原因何在？因为如来功德是无限的，如因地上的舍身饲虎、割肉喂鹰，所行无量善行皆由其大悲心发出。由无限慈悲化现的无限善行，以有限的语言自然无法表述。
    如来功德广大无边，但主要可归纳为断德、智德、恩德三种。所谓断德，亦名解脱，因佛陀已将生命中一切烦恼和无明净除无余。所谓智德，是因佛陀乃了达一切的觉者，以平等智慧照了诸法，对自身生命和整个世界不再有丝毫困惑。所谓恩德，是因如来乘大愿力，对一切众生，不论亲疏，皆充满无限慈悲。其中，又以慈悲和智慧为一切功德之源。佛陀之所以为佛陀，正是因为圆满了无限的慈悲和智慧，而不是在于他所拥有的这个名号。我们学习《普贤行愿品》，也应以佛陀功德为所缘及观修对象。
    所缘，即我们认识的对象。如眼睛能看见色彩，耳朵能听见声音，鼻子能闻到味道，这些色、声、味就是所缘对象。本品的观修，是以佛陀功德为所缘，故名之为“成佛的模拟方法”。练过书法的人都知道，我们临一本字贴时，须对所临字体的结构、运笔了然于胸，越是熟悉，才能临得越象。同样，我们模拟佛陀的品质，也应对其功德有清晰认识，如佛陀的慈悲、智慧具有哪些特征。熟悉所缘境之后，才能有的放矢地进行模仿，以我们的心去接近佛菩萨的心。佛菩萨的心是无限的，平等眷顾着所有众生。我们从现在开始，做每件事也应发大悲心，以利他为己任，将佛菩萨的品质落实于生命中。事实上，众生本具这种品质，只是蒙尘已久，故须对照佛菩萨的品质不断去除凡夫心，使人人皆有的如来智慧德相得以开发。
    学佛，是基于对佛陀功德的仰慕。很多人都有自己仰慕的对象，或是圣贤伟人、或是科学、艺术家，乃至歌星、球星。崇拜对象不同，出发点也不同。有些是因为感佩对方的人格魅力，有些是因为赞叹对方的智慧和创造力，有些是因为羡慕对方的相貌和力量。作为佛教徒，我们仰慕的是佛陀，是佛法僧三宝。但若没有深刻认识到佛陀的功德所在，即使皈投礼拜，多少带有盲目甚至投机的成分。学佛的最终目的，是闻思佛法、行佛所行，而非停留于顶礼膜拜、燃香祈福。所以，我们不仅要以佛陀作为人生依怙，更应以其品质作为人生榜样，以其功德作为修行目标。
    大乘经典中，记载了很多菩萨在因地发宏誓伟愿而成就菩提的修行事迹。《无量寿经》记载，阿弥陀佛发四十八愿成就西方极乐世界；又《药师经》记载，药师如来发十二大愿成就东方琉璃世界等等。作为学佛者，选择一位佛菩萨作为模范，以他的愿力为自己的愿力，以他的行持为自己的行动指南，实为稳妥便捷的修行之道。我们学习《普贤行愿品》，也应象普贤菩萨那样发愿并行持。若切实遵循本品阐述的修行法门，必能快速成就佛陀品质。
    那么，十大行愿的内容分别是什么呢？
    “若欲成就此功德门，应修十种广大行愿。何等为十？一者礼敬诸佛，二者称赞如来，三者广修供养，四者忏悔业障，五者随喜功德，六者请转法轮，七者请佛住世，八者常随佛学，九者恒顺众生，十者普皆回向。”
    此十大行愿又称“愿王”，标帜其殊胜、高超为一切愿力之最。但仅仅看这些条目，我们可能会觉得很简单。从礼敬诸佛到普皆回向，都是极其寻常的修行功课，即使没有学习本品的人，也一样在拜佛、供养、忏悔，如此平淡无奇的法门，与人们心目中的成佛捷径实在相距甚远。那么，它究竟为什么被尊为愿王呢？我们解读经文内容，尤其是长行部分之后，才能了知个中原因。
    “善财白言：大圣，云何礼敬，乃至回向？”
    《行愿品》是普贤菩萨为前来参访的善财童子所作的开示。“大圣”，乃善财童子对普贤菩萨的尊称。“云何礼敬，乃至回向？”普贤菩萨阐明十大行愿后，善财童子进一步请益：那么，究竟怎样礼敬诸佛乃至普皆回向？


第一大愿：礼敬诸佛

    “普贤菩萨告善财言：善男子，言礼敬诸佛者，所有尽法界虚空界，十方三世一切佛刹极微尘数诸佛世尊，我以普贤行愿力故，深心信解，如对目前，悉以清净身语意业，常修礼敬。一一佛所，皆现不可说不可说佛刹极微尘数身。一一身，遍礼不可说不可说佛刹极微尘数佛。虚空界尽，我礼乃尽。以虚空界不可尽故，我此礼敬无有穷尽。如是乃至众生界尽，众生业尽，众生烦恼尽，我礼乃尽。而众生界乃至烦恼无有尽故，我此礼敬无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”

    礼拜对于修行的意义极为重大，能以此强化三宝在我们心目中的地位。我们虽身为佛子，但佛菩萨是否在我们心中有着至高无上的地位？是否比我们在世间拥有的一切更为重要？许多人声称信佛，但总是在工作甚至娱乐之余才想起修学佛法，实为本末倒置。当然，对于在家居士来说，生存和工作毕竟是不可回避的现实问题。但我们要知道，这些对生命只有暂时的意义，即使赚再多的钱，至多享用几十年。而通过学佛修行来改造生命，则关系到我们尽未来际的幸福。如果我们以佛法作为生命的唯一归宿，必能发勇猛心、精勤道业。反之，将学佛视为生活的点缀，也就只能种种善根而已。
    礼敬，是由景仰佛陀功德而通过身口意三业体现的行为。包括平日见到的所有佛像、法宝，都应发自内心地生起尊重之心，外在体现为顶礼或合掌问讯。时常有人会问：如果我们表现得不够恭敬，佛菩萨是否会因此不快乃至迁怒于人？其实，唯有凡夫才会作如是想，那正是我相、人相、众生相、寿者相在作怪。世人会因得不到大众尊敬而哀伤失落，但佛陀已彻底断除我执，我们恭敬与否，对他老人家不构成丝毫影响。无论是诽谤还是赞叹，佛陀都不会因之动心，所谓“毁誉不动如须弥”。
    既然对佛陀没有任何意义，我们为何还要礼敬诸佛呢？原因在于，这种礼敬对我们个人修学极为必要。有一分恭敬，就能得到一分佛法的受益。在日常环境中，我们已习惯于放逸，内心也因之躁动不安，时时随着凡夫心追逐名利声色，制造人我是非。而当我们踏入寺院或面对佛菩萨像时，往往感到安详和清凉。因为我们是带着恭敬心来到寺院，带着清净心面对佛菩萨。若在家中营造一个气氛庄严的佛堂，也能帮助我们将忙碌的心安定下来。当然，前提是必须有恭敬心，否则环境能起到的作用也极为有限。如果我们时刻想着佛菩萨的功德和智慧，妄想就难有可乘之机。由此可见，恭敬本身就具有净化内心的作用。心中有佛，生命就会拥有依怙和目标，而礼敬诸佛，则能使我们从内在身心到外在行为变得调柔而谦恭。
    《普贤行愿品》中，又是如何进行礼敬的呢？
    “所有尽法界虚空界”，指范围之广大。“法界”，为法所在之处。佛教中，任何事物皆涵盖于“法”的范畴，包括有的、空的，精神的、物质的，清净的、染污的……皆统称为“法”。其中，色法为有形，心法为无形。“界”则是边际之义，穷极诸法边际，故称法界。又因法无所不在，故法界亦无边际。“法界”如是，“虚空界”亦如是，浩渺无边，不可穷尽。普贤菩萨的修行，是以无尽法界和虚空界为对象，气势恢弘，不可限量。在我们的认识中，可曾以法界为对象？我们所思所想，皆是具体、狭隘的人和事。我们拜佛，往往只是拜眼前的这尊佛，人们甚至还常常担心：拜了这尊佛之后，是否冷落了其他佛菩萨？这完全是以凡夫心在揣度佛菩萨。如何才能突破这狭隘的心？便应象普贤菩萨那样，以法界、虚空界为所缘对象。
    “十方三世一切佛刹极微尘数诸佛世尊”，在无垠法界和虚空界中，我们所礼敬的不是一佛、二佛，而是十方三世一切诸佛。“十方”指的是空间，即东、西、南、北、东南、东北、西南、西北、上、下十方；“三世”指的是时间，即过去、现在、未来三世；“佛刹”指的是诸佛菩萨的国土。在无尽时空的无量国土中，已有无数众生成佛，多如微尘，这就是“极微尘数诸佛世尊”。色法之极少为极微，极微之七倍曰微尘，故“极微尘数”用于比喻数量之多，数不胜数。如果说十方三世充满着微尘那么多的佛菩萨，那也可以反过来说，每一微尘皆是佛菩萨的化现。若能以如此见地看待世界，目光所及，在在处处无一不是佛菩萨。当然，这是一种极高的见地，可能大家一时还理解不了，不妨先以信心来接受。在佛法中，对于我们能够理解的，可以用理性来接受；对于我们无法理解的，则应以信心来接受。当我们观一切都是佛菩萨的显现，内心自然会随之清净。
    “我以普贤行愿力故，深心信解，如对目前。”以普贤愿力的加持，以普贤行愿的观修方法，发至诚恳切之心，观想一切诸佛就在我们面前，历历在目。可能大家会说：我们眼前并没有佛菩萨呵，所见所闻无非是世间的人和事。但我们要知道，佛以法身为身，而法身本体周遍如太虚空，无有障碍、无所不在，故世间一切皆为佛身、佛德的显现。事实上，不仅诸佛的心是如此，我们的心也具有同样功用，所谓“心包太虚，量周沙界”。只因妄想所缚，才变得狭隘而渺小。我们执著身体，就以身体健康为头等大事；执著家庭，就以家庭幸福为重中之重。久而久之，使心完全系缚于色身或家庭，再也容不下其他。唯有放弃我法二执，心才能与法界融为一体，没有终了，也没有边际。这是通过观想来转换境界。
    “悉以清净身语意业，常修礼敬。”所谓清净，是远离颠倒妄想之心，断除贪嗔烦恼之心。凡夫心有种种执著和痛苦，分别此是好人、彼是坏人等等，由此引发好恶之心及种种烦恼。若将一切视为佛身和佛德的显现，便能油然而生平等无别的恭敬心。如此，时时都能以清净无染的行为、语言和思想礼敬诸佛。
    “一一佛所，皆现不可说不可说佛刹极微尘数身。一一身，遍礼不可说不可说佛刹极微尘数佛。”我们不仅要观想宇宙中有微尘数诸佛，更要观想自身是无所不在的。我们执著现有的色身为“我”，便会局限于这个身体。通过观想的力量，可将山河大地及一切有情观想为自己的化身，观想他们与自己一同礼敬诸佛。在每一处佛土，在每个佛陀之前，都有无数的我在礼拜；而每一个我，又在礼拜无量佛土中的无量诸佛。佛身遍满宇宙，每一微尘既是佛，也是我们自己。佛菩萨是无限的存在，我们也同样是无限的存在。作如是观想时，自身便融入诸佛之中，不再有我相和贪嗔痴。当心量打开之后，小我就失去了藏身之地，我执也将随之瓦解。
    “虚空界尽，我礼乃尽。以虚空界不可尽故，我此礼敬无有穷尽。如是乃至众生界尽，众生业尽，众生烦恼尽，我礼乃尽。而众生界乃至烦恼无有尽故，我此礼敬无有穷尽。”这种礼敬不是暂时的，而是尽未来际永不间断，如虚空般永无尽头。在漫长的修行之路上，我们要将此清净心行长久保持下去，一直持续到众生、众生的业力和烦恼都消失之后。但众生是无边无际的，虽然我们发愿“众生无边誓愿度”，但终究是度不完的。所以，我们对诸佛菩萨的礼敬也是没有穷尽的。由此我们也可以看到，普贤菩萨愿力之宏大，远非世间的海誓山盟可比拟。
    “念念相续，无有间断。身语意业，无有疲厌。”这种礼敬将一念接一念地延续下去，永无中断之时。虽然我们时时都在礼敬诸佛，但身、口、意三业却乐此不疲，没有丝毫厌倦。因为我们是发自内心地景仰佛陀功德。
    我们现有凡夫心，是经过长时间培养起来的。成就佛菩萨的品质，同样需要通过持续观修来巩固。尤其是开始之初，更应刻意强化心力，一旦观修纯熟并形成稳定的心行之后，不必费力即可进入特定境界和心行轨道，并保持这一状态。达到这样的程度，我们就能时时都在礼敬诸佛。


第二大愿：称赞如来

    “复次善男子，言称赞如来者，所有尽法界虚空界，十方三世一切刹土，所有极微一一尘中，皆有一切世间极微尘数佛。一一佛所，皆有菩萨海会围绕。我当悉以甚深胜解，现前知见，各以出过辩才天女微妙舌根，一一舌根，出无尽音声海，一一音声，出一切言辞海，称扬赞叹一切如来诸功德海。穷未来际，相续不断。尽于法界，无不周遍。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我赞乃尽。而虚空界乃至烦恼无有尽故，我此赞叹无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”

    我们赞叹一个人，可能因为他能力卓著，可能因为他道德高尚，可能因为他为人善良……总之，有过人之处才值得赞叹。我们称赞如来，则是因为认识到如来的功德。前面讲过，如来具有圆满的智慧和慈悲。我们通过赞叹如来而忆念其功德，从而生起见贤思齐、高山仰止之心，当心完全融入这些功德时，凡夫心也将随之消融。时时赞叹并忆念佛陀的智慧和慈悲，并将此作为观修所缘境，还能帮助我们强化修行目标。所以，称赞如来是非常重要的修行内容，连诸佛之间也时常互相赞叹。
    称赞有两种，一是即恰如其分地赞叹他人长处，一是以有所得之心谄曲奉承。前者是清净的，能令众生欢喜；后者是污染的，且会妨碍修行。以善心赞叹他人，不仅能带来融洽和谐的人际关系，更能使我们充分认识他人长处，从善如流。若能时时发现他人优点，会觉得世界充满阳光，因为我们看到、想到的都是好人。
    赞叹他人，还能帮助我们有效克服我慢、我执和嫉妒。一个我慢或嫉妒心特别重的人，是不会称赞别人长处的。自古文人相轻，原因就在于自视甚高，故将所有好话留给自己而不愿赠予他人。更有甚者，总是拿着放大镜检查他人缺点，似乎所有人都不如自己，全世界都对不起自己，结果使内心充满嗔恨，终是害人害己。其实，即使再恶的人也总有其长处。按佛教的观点来说，以好人或坏人来定义是不合适的，区别只在于健康或不健康。以这个标准来看，佛陀就是绝对健康的人，因为他已彻底去除生命中的不健康因素。
    我们来看一看，《普贤行愿品》是如何称赞如来功德的：
    “所有尽法界虚空界，十方三世一切刹土，所有极微一一尘中，皆有一切世间极微尘数佛。一一佛所，皆有菩萨海会围绕。我当悉以甚深胜解，现前知见。”称赞如来，是以如来功德为所缘境，且不是称赞一佛、二佛，而是尽法界、虚空界、十方三世一切刹土的如来。首先，要观想在宇宙中，在无量无边的佛国中，有微尘数那么多的佛菩萨聚会一处，其德之深与数之多，犹如大海。如《华严玄疏》云：“言海会者，以深广故，谓普贤等众，德深齐佛，数广刹尘，故称为海。”不仅要如是观想，更要于所缘之境决定印可而不移转，深信所见一切皆为佛身和功德的显现。
    “各以出过辩才天女微妙舌根，一一舌根，出无尽音声海，一一音声，出一切言辞海，称扬赞叹一切如来诸功德海。各以出过辩才天女微妙舌根，一一舌根，出无尽音声海，一一音声，出一切言辞海，称扬赞叹一切如来诸功德海。”面对海会云集的佛菩萨，我们怎样才能一一称扬赞叹呢？同样要借助观想的力量，将自己观想为辩才天女。辩才天女出现于《华严经·如来出现功德品》，拥有五百条舌头，每一舌皆能说多种语言。我们可以观想自己象辩才天女那样，以无量舌头发出各种音声，每一音声皆在赞叹如来功德。我们还能将自己观想为播音员，在说话时，整个世界有百万、亿万的声音同时响起。我们还可以将听到的、山河大地的所有声音，包括风声、雨声、琴声、歌声、鸟鸣声、流水声、读书声都观想为称叹如来的美妙赞歌。当我们至心称赞如来大悲周遍、智慧无边时，心就会消融在如来无所不在的慈悲和智慧中。因为我们所感受到的一切，皆是如来功德和赞叹如来功德的音声，无我亦无我所。
    “穷未来际，相续不断。尽于法界，无不周遍。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我赞乃尽。而虚空界乃至烦恼无有尽故，我此赞叹无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”从今往后，我们要时时刻刻、持续不断地赞叹如来功德，并使这种赞叹充满法界，遍及一切。如果虚空会有尽头，众生及众生的业力、烦恼会有尽头，那么我们发出的赞叹才会停止。而虚空乃至众生烦恼是永无止境的，所以我们对如来的赞叹也是永无止境的，更不会对此感到疲倦。
    我们赞叹佛陀的大慈大悲，赞叹佛陀的的智慧无量，因为赞叹而心向往之，以身口意三业模拟佛陀的心行。这种忆念的过程，本身就是修行。事实上，凡夫心也是通过忆念而成长的。贪心，是因为我们不断贪著而形成；嗔心，也是因为我们不断嗔恨而造成。这些正是心行训练的成功典范，遗憾的是，它们都是本该断除而非巩固加强的。如果我们能以培养贪心和嗔心的那份努力来忆念佛菩萨功德，就是在念念增长佛菩萨那样的慈悲和智慧，何愁不能成就。


第三大愿：广修供养

    “复次善男子，言广修供养者，所有尽法界虚空界，十方三世一切佛刹极微尘中，一一各有一切世界极微尘数佛。一一佛所，种种菩萨海会围绕。我以普贤行愿力故，起深信解，现前知见，悉以上妙诸供养具而为供养。所谓华云、鬘云、天音乐云、天伞盖云、天衣服云、天种种香、涂香、烧香、末香，如是等云，一一量如须弥山王。燃种种灯，酥灯、油灯、诸香油灯，一一灯炷如须弥山，一一灯油如大海水。以如是等诸供养具，常为供养。善男子，诸供养中，法供养最。所谓如说修行供养、利益众生供养、摄受众生供养、代众生苦供养、勤修善根供养、不舍菩萨业供养、不离菩提心供养。善男子，如前供养无量功德，比法供养一念功德，百分不及一，千分不及一，百千俱胝那由他分、迦罗分、算分、数分、喻分、优波尼沙陀分，亦不及一。何以故？以诸如来尊重法故，以如说行出生诸佛故。若诸菩萨行法供养，则得成就供养如来。如是修行，是真供养故。此广大最胜供养，虚空界尽，众生界尽，众生业尽，众生烦恼尽，我供乃尽。而虚空界乃至烦恼不可尽故，我此供养亦无有尽。念念相续，无有间断。身语意业，无有疲厌。”
    每个学佛者多少会有过供养的行为，如以香、花、灯或其它财物供养三宝。在佛教中，与供养内涵接近的是布施，都是供给对方所需。但供养更强调了亲近、奉事、尊重的成分，而布施则含有对弱者的同情、怜措、爱护之义。故对佛菩萨及父母、师长，是以恭敬心供养，若同样能以供养心修布施则更有利于平等心的修习，将迅速成就清净、圆满的功德。
    “人天路上，修福为先”，福报从何而来？正是通过供养、布施而来，就象收获是通过播种而来。供养的对象，又称为福田。福田有三，一是悲田，如穷困者及弱势群体；一是恩田，为父母等有恩于我们的人；一是敬田，为三宝或师长等我们恭敬的善知识，这些都是培植福德的土壤。有了福报，人生和修行道路才能畅通无阻。或许有些人不解，生存自然是需要福报，难道修行也要福报吗？确实如此。如果没有福报，修行会遇到很多障碍，所谓“修慧不修福，罗汉托空钵”。我们的色身需要物质滋养，若是资粮不具，甚至整天要为生计奔忙操劳，又如何安心办道？
    另一方面，供养还能帮助我们克服悭贪和吝啬的心理。凡夫最大的特点就是贪著，将属于自己的物品也视为自身的一部分。烦恼便因这种对“我所”的执著而产生，物品损坏后会为之伤感，失去后会为之心痛，赠予他人更是万般不舍。贪著和我执，是对我们伤害极大的两种烦恼，而供养正是破除它们的重要法门。菩萨之所以能为众生舍弃一切，是因为在他们的心目中，众生和自己是平等无二的。在世间，母亲对儿女的付出是最无私的，但离菩萨的境界还相距甚远。因为菩萨行还具有无相、无住、无所得的特点，毫无执著和期待。
    说到供养，可能有些人会担心：如果缺乏供养的财力，又该怎么办呢？其实，供养的重点并不在于实际财物，而是在于心行的调整。同样是供养，发心不同，采取的方式不同，所获效果和福报也大不相同。《行愿品》中，普贤菩萨为我们揭示了将有限供养转为无限的观修法门，以此获福无量。
    “言广修供养者，所有尽法界虚空界，十方三世一切佛刹极微尘中，一一各有一切世界极微尘数佛。一一佛所，种种菩萨海会围绕。我以普贤行愿力故，起深信解，现前知见。”供养，首先要有供养的对象。《行愿品》所言，为“广修供养”，即广泛供养一切。本品的修行所缘境有二：一是以佛菩萨的品质为观修所缘境，一是以所有众生作为发菩提心的所缘对象。在此，重点是以佛菩萨功德为所缘境。我们每天供佛时，不仅仅要供养眼前这尊佛，也应象“礼敬诸佛”和“称叹如来”那样，礼拜并供养十方三世一切诸佛。如果只供一尊佛，成就的也仅是一份功德；如果供养十方三世一切诸佛，则能成就无量无边的功德。面对海会围绕的佛菩萨，我们又以什么作为供养呢？
    “悉以上妙诸供养具而为供养。”应以最上等、微妙、圣洁的供品来供养诸佛菩萨，以此表达我们对佛菩萨的无比敬意。
    “所谓华云、鬘云、天音乐云、天伞盖云、天衣服云、天种种香、涂香、烧香、末香。”“华云”，比喻花之多、之盛如云一般；“鬘云”，是将花串成一串串的花鬘；“天音乐云”，是最为美妙的天籁之音，所谓“此曲只应天上有”；“天伞盖云”，是帝王出巡或举办法会时使用的伞盖；“天衣服云”，是天人享用的霓裳羽衣；“天种种香”，是指最馥郁、芬芳的香；“涂香”，是涂抹于身体的香膏；“烧香”，是通过燃烧散发香味的香；“末香”，是研磨成粉状的香末。每一种供品皆多如云涌，数不胜数。
    “如是等云，一一量如须弥山王。”须弥山，又译妙高山，佛教多认为是最高大的山，高广无边，此处形容供品之多，堆积如山。
    “燃种种灯，酥灯、油灯、诸香油灯。”此外，还要点燃种种明灯，包括酥油灯、油灯及各种香油制作的灯。在佛经中，灯明为六供具之一，比喻佛的智波罗蜜。
    “一一灯炷如须弥山，一一灯油如大海水。”这些供佛的灯明，并非我们平时所用的供灯，而是灯炷高如须弥，灯油多如大海的巨型供灯。
    或许大家会担心：如何有条件准备这些香、花、灯、油？不必担心，因为《行愿品》是通过观修来完成如此广大殊胜的供养。我们看到一切卉木，皆可通过观想转化为供养所需珍妙物品；看到万家灯火，则可观想为供佛的“酥灯、油灯、诸香油灯”。包括我们的每个心念乃至色身，皆可转化为供养于诸佛菩萨前的一盏明灯、一朵莲花。若能作如是观想，我执、我所执就无处藏身了。因为一切都是献给诸佛的供品，何处有“我”的存在？所以，“广修供养”也是对治凡夫心的有效法门。
    “以如是等诸供养具，常为供养。”时刻作如是观修，我们的心自然能从我执、我所执中超越出来。若能将一切供养诸佛菩萨，心便是无量的。以无量之心观想无量供具并供养无量诸佛菩萨，当下即可成就无量福德。以这样的方法积累功德，则能迅速成满佛道资粮。当我们供养一杯水时，可将之观想为四大海的净水；当我们供养一盏灯时，可观想为尽虚空遍法界的灯明。无论供养什么，皆观想为广大无限的供养，使我们的心胸象虚空那样无限广阔，毫不住相。如果能这样的话，即使供养一杯水，也能成就虚空般的无尽功德。反之，若心有所住著，所获福德将极为有限，就象《金刚经》所说的“如人入暗，则无所见”。
    “善男子，诸供养中，法供养最。”在一切供养中，财供养虽然功德很大，却远不如法供养殊胜。当然，如能象本品所说的那样观想，供灯、供花的本身已经升华为法供养。通过依法修行，我们可以开智慧、断烦恼并获得究竟解脱。故佛陀在很多经典中都为我们宣说了法供养的意义，如《金刚经》数数以校量功德引导人们行法供养。为什么财布施不及法布施，财供养不及法供养呢？因为财供养只能满足暂时的需要，而法供养却能改变生命品质。一个品格低劣、烦恼重重的人，即使拥有许多财富，依然不会获得快乐。反之，对于断除烦恼的圣者而言，哪怕一无所有、生活清贫，却能处处自在、时时安乐。那么，什么是法供养呢？
    “所谓如说修行供养”，即闻思佛法、如理作意、法随法行。佛陀出现于世，目的正是为了帮助众生解脱烦恼和生死。所以说，按照佛法指引的道路修行，象佛菩萨那样广泛利益一切众生，才是至高无上的供养。若仅仅是对佛教有兴趣、对佛陀有感情，于了生脱死并无实际帮助，也不是令诸佛欢喜赞叹的真正佛子。就象在家庭中，依父母意愿行事的孝顺孩子才能令长辈欢喜，若不听父母教诲而胡作非为，虽能给父母带来钱财，却无法令其安心。同样的道理，依法修行才是佛弟子们应有的作为。
    “利益众生供养”，时刻心系众生，并尽自己所能利益他人，也是供养如来的方式之一。《行愿品》第九大愿谈到：若令众生欢喜，即令如来欢喜，随顺众生，即是随顺如来。诸佛如来从发心开始，为救度众生而精进修行。很多人以为，学佛的目的是为了成佛。这固然不错，但我们要知道，成佛的目的却是为了更好地度化众生，所谓“为利有情愿成佛”。所以，对于利益众生的行为，十方诸佛都会欢喜、赞叹，因为我们正是在行佛所行。
    “摄受众生供养”，是按布施、利行、爱语、同事四摄法门摄受众生皈依三宝、修学佛法，并以此作为对诸佛如来的供养。
    “代众生苦供养”，愿担当天下苍生的痛苦，愿以己身代替一切众生承受苦难，是慈悲心的极致。慈悲是佛菩萨悲智二德之一，以这种广大悲心与众生同甘共苦，正是对诸佛如来的真实供养。
    “勤修善根供养”，勤，是精进、勤奋。佛法所说的善行有着不同的内涵，如以五戒、十善为主的人天善行，以戒、定、慧、解脱、解脱知见五分法身为主的解脱道善行，以布施、持戒、忍辱、精进、禅定、般若六度为主菩萨道善行。勤修善根，能使出离心、菩提心的力量得到增强，最终证佛所证，是为究竟供养。
    “不舍菩萨业供养，不离菩提心供养。”生生世世永不舍离菩萨道的事业，永不舍离菩提心的实践，尽未来际走在菩提大道上，自利利他，自觉觉他，才是究竟圆满的法供养。
    “善男子，如前供养无量功德，比法供养一念功德，百分不及一，千分不及一，百千俱胝那由他分、迦罗分、算分、数分、喻分、优波尼沙陀分，亦不及一。”　此处以一系列比喻，衬托法供养的功德之大。《金刚经》中，也是通过反复校量来突显法供养与财供养的功德差别。如以恒河沙生命或三千大千世界七宝布施，所获福德虽巨，却比不上受持《金刚经》四句偈的功德。因为单纯的财供养不能在根本上解决生命问题，故无法与依法修行所获功德比拟。
    “何以故？以诸如来尊重法故，以如说行出生诸佛故。”三世诸佛皆依法修行而成就，故法以其至高无上的地位而倍受尊重，即使是诸佛如来，同样要礼敬于法。如果没有法存在于世间，那么诸佛也无法证道并成就。
    “若诸菩萨行法供养，则得成就供养如来。如是修行，是真供养故。此广大最胜供养，虚空界尽，众生界尽，众生业尽，众生烦恼尽，我供乃尽。而虚空界乃至烦恼不可尽故，我此供养亦无有尽。念念相续，无有间断。身语意业，无有疲厌。”如果菩萨能行法供养，才是最究竟、最真实的供养。《行愿品》所阐述的广大供养乃无上妙法，发心极为广阔，在空间上周遍十方，在时间上尽未来际。如果虚空会有尽头，众生及众生的烦恼会有尽头，这种广大供养才会结束。事实上，虚空是无尽的，众生及众生的烦恼是无尽的，所以对诸佛如来的供养也是永无止境的。并且，这种供养时时刻刻都在进行，从来不曾间断，始终不会厌倦。
    由此我们可以看到，普贤菩萨所发大愿之深广、境界之高超，实在是令人叹为观止。这也正是它被尊为愿王的关键所在，因为每一愿皆以无限的时间和空间为对象。


第四大愿：忏悔业障

    “复次善男子，言忏除业障者，菩萨自念，我于过去无始劫中，由贪瞋痴，发身口意，作诸恶业，无量无边。若此恶业有体相者，尽虚空界不能容受。我今悉以清净三业，遍于法界极微尘刹，一切诸佛菩萨众前，诚心忏悔，后不复造，恒住净戒一切功德。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我忏乃尽。而虚空界乃至众生烦恼不可尽故，我此忏悔无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”

    修行过程中，不仅要积累资粮，更应忏悔业障。无始以来，正是业力推动并左右有情生命的延续，这也是佛教和其他宗教的重要区别。其他宗教认为世间一切皆由神造，而佛教不承认世上有造物主，并指出命运正是由自己造作的业力决定。
    业是由行为构成，包括身业、语业和意业。所以说，身体、语言、思想是业力产生的三大渠道。其中，最难把握的是思想行为，即每日的起心动念。现代人妄想特别多，因为世界太复杂、生活太丰富了，故整日思绪纷飞，不绝如屡。我们往往以为，妄想过去就不留痕迹了，所以很少有意识地在这方面约束自己。事实上，每个心念都会在识田留下影像，并形成正面或负面的的心行力量。当善的心所活动时，我们自己也觉得开心自在。真诚关爱他人，能令我们的内心柔和谦恭；慷慨救济贫困，能令我们的心胸慈悲宽广。反之，当不善的心所产生作用时，则被嗔恨和痛苦折磨，不仅伤害他人，更会伤害自己。
    在无尽的生死长河中，我们曾经想过、做过很多。这些生命延续中积累的经验，将在识田中形成不同业力，包括善、恶、无记三种。这些业力就像编写的各种程序，在未来生命中继续活动并运作，给生命带来不同结果。其中，善业代表正面力量，有利生命的和谐发展；恶业则代表负面的力量，阻碍生命的健康发展。凡是我们造作的业力，必定会感得苦乐果报，又名“业决定之理”。也就是说，一切快乐都是善业招感，所有痛苦则是恶业决定。即使是点滴的苦乐果报，亦是往昔善恶业力决定，无一例外。故学佛须深信业果真实不虚，惟有这样，才能策励我们“诸恶莫作，众善奉行”。外在的事业很快会成为过去，但在内心产生的影像却有着长久作用。业是决定的，不作不得，作已不失，唯一可行的办法是通过真诚忏悔来弥补。
    事实上，每个众生都具备和佛菩萨一样清净无染的心，但因无明烦恼所覆，使内心变得污浊不堪。所以，佛陀在很多经典中为我们阐述了忏悔法门，以此清除业障并净化人格，使重业转轻、轻业消除。同时，忏悔也是克服并战胜凡夫心的重要手段，所谓“忏悔则清净，忏悔则安乐”。在修学过程中，任何法门的修行都必须以忏悔为前行。汉传佛教中，天台宗祖师便曾制订了许多忏法，以此扫除修法道路上的障碍。而藏传佛教的前行中，大礼拜及诵百字明咒都属于忏悔的内容。如果不具备这些前提，修行路上往往违缘众多、障碍重重。
    关于忏悔之道，《菩提道次第论》将之归纳为四种：
    一是依止力，我们皈依之后，通过念佛、拜佛、忆念三宝功德等方式不断祈求三宝加持。同时，发起殊胜的菩提心，一旦发起这种心灵世界中最强大的力量，罪业也就迎刃而解了。
    二是能破力，以追悔来摧毁罪业。造业之后，若以至诚恳切之心忏悔，后不复造，就能使重业转轻，轻业消除。就如我们和某人结怨之后，真诚地向对方表示歉意，便能及时化解双方矛盾。
    三是对治现行力，以念佛、诵经、持咒等力量与之对抗，如读诵大乘经典或持大悲咒、百字明咒、八十八大忏悔文等。其中，观一切性空对治效果最佳，当然难度也是最大的。
    四是遮止力，业有增长广大的能力，就象播下的树种会长成参天大树。同样，我们所造恶业虽小，却能继续增长。尤其是造作之后不断重复这一行为，其力量将迅速强大。遮止力，便是停止造作，不再对这一业行创造成长的因缘。
    那么，《行愿品》又是以什么方式忏悔的呢？
    “复次善男子，言忏除业障者，菩萨自念，我于过去无始劫中，由贪瞋痴，发身口意，作诸恶业，无量无边。”此处所言之菩萨，不仅指普贤菩萨，也包括每个学习《行愿品》、发起菩提心的佛弟子。生命并非始于今生，而是有着无穷的过去。故应省察自往昔以来，因受贪嗔痴烦恼影响，身口意三业造作了无量恶业。烦恼就像电脑病毒一样，一旦运行起来，会影响乃至破坏整个系统的运转。更可怕的是，烦恼还能不断复制并全面感染其它文件。同样，贪嗔痴三毒也不仅限于自身的单独活动，还具有自动复制的能力，干扰其它心理活动。当我们被负面情绪主宰时，所有想法和行为都会涂抹上这一色彩。如对某种境界或对象生起强烈的贪心时，这种心念会在行住坐卧间时时现起，徘徊不去。
    贪嗔痴为生命中三种主要毒素，其根本又在于痴，即无明，也就是对生命真相缺乏认识和智慧观照。若能照了一切事物皆由因缘和合、虚幻不实，尽管念头来来去去，却能始终保持内心警觉，历历分明而不被其所转。问题在于，我们总是将这些念头执以为“我”，不自觉地被其主宰并染污。即使想安静一下时，念头还是无法控制。无明，还使我们产生很多错误的人生观念，如以事业成败衡量自我价值的实现等等。其实，做事只是缘起的过程，但被赋予自我的感觉后，却带来诸多执著和烦恼。贪嗔痴的力量，还使世界充满种种恶业。因为贪，会导致谋财害命（杀）、偷盗抢劫（盗）、好色邪淫（淫）、诈骗钱财（妄）等行为。同样，嗔和痴也会引发杀、盗、淫、妄。由此可见，一切犯罪行为皆源于贪嗔痴。要杜绝社会犯罪现象，必须从改善人心下手，否则只是治标而不治本。
    “若此恶业有体相者，尽虚空界不能容受。”恶业，即不善业，包括身三、口四、意三的十种。其中，身体行为有杀、盗、淫三种，语言行为有两舌（挑拨离间）、恶口（以粗恶语伤害他人）、绮语（诲淫诲盗、爱恨情仇）、妄语（假话）四种，思想行为是贪婪、嗔恨、邪见三种。反之，则是十种善行，即不杀、不盗、不邪淫，不两舌、不恶口、不绮语、不妄语、不贪、不嗔、不邪见。无始以来，由于贪嗔痴三不善根，使我们造下无边恶业。如果这些恶业有形有相的话，那么虚空都无法容纳。正如《地藏经》所云：“阎浮提众生举心动念无非是罪，无非是业。”或许有人会说，我们并没有时时在造作杀盗淫妄之事。但我们要看到，即使我们没有造作行为上的杀盗淫妄时，起心动念仍被贪嗔痴所染污。哪怕是做件好事，也往往不是纯正的善行。那么，我们又该如何对待这些罪业呢？
    “我今悉以清净三业，遍于法界极微尘刹，一切诸佛菩萨众前，诚心忏悔，后不复造，恒住净戒一切功德。”　首先，要观想宇宙间有微尘刹土那么多的佛菩萨，而我们是向尽虚空、遍法界的佛菩萨忏悔。在观想过程中，以虔诚、清净的身口意三业，将自己融入佛菩萨的功德中，正是消除罪业的最佳方法。若我们心中充满佛菩萨的功德，不随贪嗔痴所转，三业即可保持清净，人格也将随之净化。所以，清净三业的本身就是最好的忏悔。更重要的，还须发誓将来不再造作罪业。否则的话，这种忏悔必定不是发自内心的，也就缺乏相应的力量。
    虽然我们在无量劫中造作了诸多罪业，但不要使其成为心灵负担，更不要被它们压垮。佛陀要我们认识到自身的罪业，并非让我们沉溺其中自哀自怨，而是让我们警惕种种不良习惯气的诱导，并指引我们以积极、正确的态度去对待。事实上，罪业并无固定不变的实质。它也是因缘所生，是无自性的，故能通过相应的手段对治。业力由心而生，同样可以用心忏悔，所谓“罪从心起将心忏，心若灭时罪亦亡，心亡罪灭两俱空，是则名为真忏悔”。通过真诚、猛利的忏悔，或体认罪业的本质，便可从根本上清除它。
    “如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我忏乃尽。而虚空界乃至众生烦恼不可尽故，我此忏悔无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”忏悔，绝非一次、两次即可万事大吉。许多人或许都有这样的经验，犯错之后虽然也知懊悔，也想痛改前非，但不久又会明知故犯。因为众生的烦恼习气根深蒂固，所以，忏悔也必须长期、持久地进行，尽未来际永不间断，才能形成稳定的心行力量，从而与无始以来形成的习气抗衡。
    当我们的心转化为清净心、慈悲心和智慧心时，当下就能和佛菩萨相应。到那时，烦恼就再也奈何不了我们了。


第五大愿：随喜功德

    “复次善男子，言随喜功德者，所有尽法界虚空界，十方三世一切佛刹极微尘数诸佛如来，从初发心，为一切智，勤修福聚，不惜身命，经不可说不可说佛刹极微尘数劫。一一劫中，舍不可说不可说佛刹极微尘数头目手足。如是一切难行苦行，圆满种种波罗蜜门，证入种种菩萨智地，成就诸佛无上菩提，及般涅槃，分布舍利。所有善根，我皆随喜。及彼十方一切世界，六趣四生一切种类，所有功德，乃至一尘，我皆随喜。十方三世一切声闻及辟支佛、有学、无学，所有功德，我皆随喜。一切菩萨所修无量难行苦行，志求无上正等菩提，广大功德，我皆随喜。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此随喜无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”

    随喜，即随顺、赞叹他人所作善行、功德和成就。任何人作利益众生之事，我们都应由衷地欢喜赞叹。以清净心随喜他人善行，也是在成就自身的善心。不仅如此，随喜还能获得与行善者相同的功德，在某些情况下，甚至会超过对方。原因何在？因为所获功德的多寡是取决于发心，而非我们以为的，与出了多少钱或多大力成正比。我们的心，就像装载功德的容器，若它本身极其狭隘且放有其它杂物，自然也就盛不下更多了。所以，若以凡夫心、以充满我执的名利心行善，即使所做事情很大，但因为发心狭隘而不纯净，所获功德往往极其有限。反之，若能以无限广大的清净心去随喜，所获功德却是尽虚空、遍法界的。
    无论我们做什么，都离不开心灵的参与。事实上，发什么心做事，最后就成就什么。发凡夫心行善，只能积累人天福报；发菩提心利他，才能成就佛菩萨的品质。所以，要以广大无限的心去随喜。这件事看似容易，实际操作时却并不容易。当自己的家人乐施净资利益大众时，我们可能会埋怨他们乱花钱；当不相干的人发心行善时，我们又会对别人的成就感到嫉妒，同样随喜不起来。这两种情况都很普遍，因为凡夫皆局限于我执的天地中，只希望自己成就或得益。唯有去除我执，才能无私随喜他人，无我地赞叹他人。就象佛菩萨那样，将众生和自己视为一体，为他们的快乐而快乐，为他们的痛苦而痛苦。唯有具足这样的心，才能发自内心地随喜一切善行，而这正是迅速积累佛道资粮的捷径。因为我们的能力和精力有限，不可能事事身体力行，但只要以清净、广大的心随喜，功德就将念念增长。也许有人会觉得，既然随喜能获如此功德，再遇到需要出钱出力的事，口头表示一下即可，钱和力都可省下了。如果是这样，所谓的随喜必定是不真诚的，只是为自己的吝啬而找的借口。要知道，随喜不仅包括内心的认同，语言的赞叹，还包括相应的行为。根据自己的实际情况积极参与，才是身口如一的随喜，才是由衷的、清净的随喜。
    《行愿品》中，又是如何修习随喜法门的呢？
    “所有尽法界虚空界，十方三世一切佛刹极微尘数诸佛如来，从初发心，为一切智，勤修福聚，不惜身命。”首先，我们要随喜诸佛菩萨的功德，因为学佛修行的终极目标正是成佛。我们随顺的不仅是一佛、二佛，而是十方三世一切诸佛。诸佛菩萨从最初发心开始，为成就一切智慧、为追求真理和解脱，精进不懈地修福、修慧，甚至不惜以生命为代价。这种为法忘躯的精神，正是一代又一代佛弟子的楷模。对于他们的所有善行，我们应当由衷地欢喜并赞叹。
    “经不可说不可说佛刹极微尘数劫。一一劫中，舍不可说不可说佛刹极微尘数头目手足。”在因地三大阿僧祗劫的漫长修行中，佛陀不知多少次为法舍身，行种种难行苦行。只要众生需要就慨然给予，乃至舍身饲虎、割肉喂鹰，血肉之躯尚不足惜，更何况身外财物。为听闻无上正法，更是难舍能舍。佛陀在因地时，曾生于无佛之世，为向一罗刹求半偈佛法而毅然舍身。仅仅就这一点来说，佛菩萨的境界也是我们难以想像的。对现代人来说，不必说为半偈舍身，若是听法条件差一点，很多人可能就不来了；在经济条件允许的范围内修一点布施，也往往十分吝啬，百般不舍。身为佛弟子，怎样才能克服凡夫心并不断向佛菩萨靠拢呢？首先应随喜佛菩萨的功德，以此作为修学的入手处。
    “如是一切难行苦行，圆满种种波罗蜜门。”种种波罗蜜门，即布施、持戒、忍辱、禅定、精进、般若六度，这是菩萨修行的六个主要项目。佛陀在行菩萨道的过程中，不断修习六度直至圆满。那么，怎样才能圆满六度呢？仅以布施为例，天下需要帮助的人那么多，我们的能力又如此有限，如何才有圆满的那一天？其实我们不必担心，布施的圆满并不在于给所有众生提供实际帮助。如果那样的话，面对无量无边的众生，不仅我们永无机会圆满布施，诸佛菩萨也难以成就了。我们知道，诸佛菩萨都发愿度尽一切有情，为什么他们成佛了，世间却仍有那么多苦难众生呢？由此可见，圆满布施的关键也是在于心行。只要对每个众生都能生起布施心，无一人例外；对任何利益众生的财物都愿意布施，无一物不舍，布施就圆满了。慈悲也是同样，能对所有众生生起无限悲心，就已具备佛菩萨的大慈大悲。
    “证入种种菩萨智地”，菩萨道的修行过程共有十地，分别是初地欢喜地、二地离垢地、三地发光地、四地焰慧地、五地难胜地、六地现前地、七地远行地、八地不动地、九地善慧地、十地法云地。十地代表了菩萨在修行中断除烦恼的程度，也标志着菩萨成就功德的程度。这一修行步骤，正如我们驱车从苏州前往北京，必得经过很多站点才能达到目的地。同样，成佛也不是虚无缥渺的，在每个前进阶段都有明确的考量标准，使修学者可以对照自身修行进行调整。
    “成就诸佛无上菩提，及般涅槃，分布舍利。”最终，成就至高无上的菩提果位，即福德、智慧的究竟圆满。同时，还成就法、报、化三身和大圆镜智、平等性智、妙观察智、成所作智。涅槃，代表着佛陀在这个世界身相的结束。虽然佛陀的法身是不生不灭的，但因与此间众生因缘已尽，故其应化身会在娑婆世界消失。这并不意味着佛陀死了，因为佛陀是不生不灭、不来不去的。舍利，乃佛陀荼毗后留下的骨子，如五色珠，光莹坚固。佛陀涅槃之后，将其舍利分布世界各地，造塔供奉，给未能值遇佛世的众生种下善根。扶风法门寺收藏的佛指舍利和北京灵光寺收藏的佛牙舍利，都是闻名世界的佛陀舍利。2002年，法门寺的佛骨舍利应邀前往台湾巡展，朝拜者超过四百多万。佛陀已灭度两千五百余年，其遗骨尚能引起如此轰动，充分体现了佛陀功德的感召力之强。
    “所有善根，我皆随喜。”当我们对佛陀的发心和功德表示衷心赞叹时，就能将心逐步融入佛陀的境界中，进而将佛陀的发心变成自己的发心，将佛陀所修善行变成自己的行为。所以说，随喜的修行不仅是称扬赞叹，重点还在于观所缘境，并将心融入所缘境中。若只停留于口头赞美，还算不上真正的随喜。
    “及彼十方一切世界，六趣四生一切种类，所有功德，乃至一尘，我皆随喜。”我们不但要随顺佛菩萨的功德，还要随顺十方一切众生的功德。六趣，指天、人、阿修罗、傍生、饿鬼、地狱六道，四生则指有情受生的四种形式，即胎、卵、湿、化。我们应对所有众生的善行表示赞叹，随时发现、鼓励、赞叹他人的长处，既能可使对方的长处发扬光大，还可使自身的优良品质得到发展。反之，若我们总带着凡夫心去挑剔他人，对方固然不易接受，也会增长自身的慢心等不良习气，于己于人皆无益处。
    “十方三世一切声闻及辟支佛、有学、无学，所有功德，我皆随喜。”声闻，是修习解脱道而证果的圣者。辟支佛，则指那些乐独善寂、慧根极利的圣贤，虽值遇无佛之世，但能通过花开花落等自然现象深知诸法因缘，体悟空性而修行成就。有学、无学也代表着修行的不同阶段，所谓有学，即修行尚未圆满，为声闻的前三果，分别是须陀洹果、斯陀含果和阿那含果。所谓无学，即所作已办，不受后有的阿罗汉，彻底断除烦恼并了达诸法空性。对这些圣人的修行和功德，我们皆应广泛随喜。当我们以清净心赞叹时，就能与他们成就的功德相应，并将自己的心融入这些功德中。
    “一切菩萨所修无量难行苦行，志求无上正等菩提，广大功德，我皆随喜。”除声闻圣者外，一切菩萨在行菩萨道的过程中所修无量难行苦行，为寻求真理而舍弃生命，为救度众生而奉献自身，这些高尚行为我们都要发自内心地赞叹。
    “如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此随喜无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”这种随喜是永无止境的。因为一念随喜的力量微不足道，无法形成稳定的心行。如果更多时间还在想着吃喝玩乐的话，那么随喜之心很快就会淹没不见。只有时时刻刻地忆念佛菩萨功德，才能形成巩固、稳定的心行，长久地保持正念并念念安住。


第六大愿：请转法轮

    “复次善男子，言请转法轮者，所有尽法界虚空界，十方三世一切佛刹极微尘中，一一各有不可说不可说佛刹极微尘数广大佛刹。一一刹中，念念有不可说不可说佛刹极微尘数一切诸佛成等正觉，一切菩萨海会围绕。而我悉以身口意业种种方便，殷勤劝请转妙法轮。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我常劝请一切诸佛转正法轮，无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”

    转法轮，是比喻佛陀说法。根据印度的传说，转轮圣王出世时以轮宝号令天下，所向披靡、无坚不摧。以法轮之喻，标识佛法能摧毁众生的一切烦恼。佛陀在鹿野苑初转法轮时，宣说苦、集、灭、道四谛法门。佛法虽有三藏十二部典籍，博大精深，其纲领却无出其右。四谛法门又包含两重因果，一是以“苦谛”和“集谛”说明的凡夫因果，如众生为何有种种烦恼，命运为何有种种差别等。众生长劫处于轮回之苦，有生、老、病、死之苦，有爱别离、怨憎会、求不得、五蕴炽盛之苦，这些痛苦的根源，正是“集”所阐述的内容。此外，佛陀还以“灭谛”和“道谛”说明成就圣贤的因果。灭，为灭除烦恼和痛苦，也就是佛法所说的涅槃境界。至于如何灭除，则是道谛的内容。四谛法门又相当于治病的程序，首先指出病状，其次寻找病源，然后决定治疗方案。在了脱生死之前，我们都是生死之病的患者，而佛陀则是帮助我们治病的大医王，引导我们究竟解决烦恼病苦，成为真正健康的解脱者。
    说到解决痛苦，世人日日忙碌操劳，无非也是为了这一目的，并将离苦之道寄托于事业成功、出人头地之上。但名利双收之后，痛苦却依然存在，甚至越来越多。究其原因，正是因为不曾找到痛苦之源，故采取的方法也如扬汤止沸，虽奔忙一生，却不能从根本上解决问题。或许有人会说，在今天这个物质世界中，很多人都活得踌躇满志，难道他们的生活也痛苦吗？其实，那只是在物质享乐和声色刺激中，对苦的感受变得迟钝了。要知道，烦恼和痛苦决不会因为被忽略、被掩盖而消失，一旦爆发之后，还会因酝酿已久而更具杀伤力。
    轮回的本质是痛苦的。只要内心制造烦恼的根源不曾消除，不论我们如何努力，即使贵为帝王、身家亿万，一样走不出烦恼的怪圈。佛法指出，造成生命痛苦的根源正是我们内在的无明和烦恼。四谛法门不仅告诉我们人生的真相，也为我们提供了究竟解决痛苦的正确方法。
    佛陀最初在菩提树下悟道时，发现他所领悟的真理和世人以为的事实天地悬隔，担心即使说出也无人领悟，决定即刻入灭。此时，大梵天王降临人间祈请佛陀宣说法要。佛陀因其一再祈请，方开始说法度众生，此为请转法轮。请法，也是表示对法的尊重。凡是太易得到的，人们往往不会加以珍惜。反之，经过反复请求和艰难困苦得到的，人们反而更能认识到它的价值。如果没有请法的诚意，很可能对得到的无上法宝不以为然，这将成为修学道路上的重大障碍。求和请，并非说法者的需要，而是我们自己要培养对法的尊重之心。孔子“朝闻道，夕死可矣”的心声，二祖“断臂求法”的壮举，无不体现了对法的恭敬和尊重。有了这一前提，我们才有可能自觉地依教奉行。否则的话，即使学了很多佛法义理，也难以在心行上真正产生作用。
    另一方面，因为请转法轮，佛法才能流传世间并利益更多的人。不然，我们也无缘听闻如此甚深微妙的佛法。此外，不断求法、请法的过程中，我们会不断地忆念法。因为凡夫心是和五欲尘劳相应的，若非特别提起正念，通常就是纠缠在于财色名食睡中。所以，要通过不断请法使心融入佛法中，融入空性中。我们念佛，就和佛相应；念法，就和法相应；念僧，就和僧相应；念戒，就和戒相应。心中忆念什么，最终就会就能成就什么。这也是念法、求法的深意所在。
    “所有尽法界虚空界，十方三世一切佛刹极微尘中，一一各有不可说不可说佛刹极微尘数广大佛刹。一一刹中，念念有不可说不可说佛刹极微尘数一切诸佛成等正觉，一切菩萨海会围绕。”《行愿品》的特点在于，修习每一愿，首先将之拓展为最宏伟的愿望，这就必须将心量扩大至无限。根据佛教的时空观，宇宙中有着无量无边的世界。如《阿弥陀经》云，“从是西方过十万亿佛土，有世界名曰极乐”。一个佛土，就是一个三千大千世界，是一位佛陀教化的区域。太阳系相当于一小世界，一千小世界为中千世界，一千中千世界为大千世界。三千大千世界，即因其中有三个千的倍数而得名。不说其他佛土，仅仅是极乐世界便有十万亿佛土之遥，而整个宇宙之无穷无尽更是难以言表。
    我们应观想无量佛土中，正有无量诸佛菩萨在成就佛道：有的刚出生，有的在成长，有的才出家，有的于菩提树下证道，有的已觉悟成佛。每位佛陀悟道后，我们也象大梵天王那样祈请他们不要入灭，常转法轮、广度众生。不仅对诸佛菩萨如此祈请，对人间的一切善知识也应当作佛一般，祈请他们长久住世，弘法利生。藏传佛教特别强调“视师如佛”，这本身就是非常善巧的修行方式。事实上，上师是否与佛功德同等并不重要。重要的是，当我们真正视师如佛时，当下会升起极度的神圣感，内心也能因此得到净化。就象我们带着神圣感来到寺院时，纷扰的心很容易安定下来，感到沉静、祥和。反之，如果我们觉得师长和自己不相上下，除增长慢心之外，于个人修学没有丝毫帮助。看不到他人长处的人，必定会走向固步自封的绝路。当然，依止善知识也不能过于盲目轻率。选择师长之前还需经过审慎考察，确定其符合善知识各项标准再如法依止。
    “而我悉以身口意业种种方便，殷勤劝请转妙法轮。”我们应以清净的身语意三业祈请佛陀说法。观想要领在于，佛陀是无所不在的，请法的我也是无所不在的。在尽虚空、遍法界的诸佛菩萨前，有无数的我在祈请；每一个我，又在祈请无量的诸佛菩萨。在这一观想过程中，我们的身心应毫无保留地融入佛陀宣说的法义中，融入空性中。
    “如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我常劝请一切诸佛转正法轮，无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”我们对佛菩萨的祈请不是一天、两天，而是尽未来际，永不停息。


第七大愿：请佛住世

    “复次善男子，言请佛住世者，所有尽法界虚空界，十方三世一切佛刹极微尘数诸佛如来，将欲示现般涅槃者，及诸菩萨、声闻、缘觉、有学、无学，乃至一切诸善知识，我悉劝请莫入涅槃，经于一切佛刹极微尘数劫，为欲利乐一切众生。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此劝请无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”

    佛法之所以能在世间流传，是因为有佛出现于世。虽然佛陀亲证的真理并非自创，而是本然如是。但若没有佛陀说法，我们也就无从了解佛法，更不能依法得解脱。就像每个人都具备与佛无别的智慧德相，却因不识本来面目，佛性虽有若无，只能流转生死。正因为佛陀出世说法，我们才有机缘认识生命真相，找到究竟解脱之道。在这个世间，还有很多邪教流行，给世界制造了种种不安定因素。即使有心向道的学佛者，因为没有善知识的引导，没有分辨是非的能力，也会正邪不辨，乃至走上歧途。即使学习简单的世间技术，也要拜师学艺，更何况学佛是断烦恼、开智慧的头等大事。唯有如法依止善知识，我们的法身慧命才能有可靠的依托。所以说，请佛住世这一大愿，不论是对我们个人修行，还是对这个世界的众生都具有重大意义。
    从另外的角度来说，每个人都具备佛一样的品质。佛性，即觉悟之义。众生和佛的区别何在？《六祖坛经》曰：“前念迷即众生，后念觉悟即佛。前念著境即烦恼，后念离境即菩提。”佛和众生的差别，只在于迷悟之间。若能当下念念不迷，也同样是在请佛住世。反之，若迷失于五欲六尘和贪、嗔、痴中，便是诸佛入灭。所以，请佛住世也可从我们个人修行中得到体现。
    同时，我们还可以通过弘扬佛法来启发人们的本觉智慧。每个众生都具有佛菩萨一般的品质，只因不了解自身本具的佛性，背觉合尘，心逐尘境，故应以佛法智慧去引导他们，让他们认识到自身的宝藏，点亮心灯，返照自性。若我们以这样的发心和认知来弘扬佛法，同样属于请佛住世的方式。
    那么，普贤菩萨在《行愿品》中又是如何开示的呢？
    “复次善男子，言请佛住世者，所有尽法界虚空界，十方三世一切佛刹极微尘数诸佛如来，将欲示现般涅槃者。及诸菩萨、声闻、缘觉、有学、无学，乃至一切诸善知识，我悉劝请莫入涅槃。”娑婆世界的教主释迦牟尼佛已经入灭，但我们要观想宇宙中还有无量无边的世界，其中又有无量佛陀正在出世、修行、证道，或与其所化佛土因缘将尽而示现涅槃。当他们将入涅槃时，我们应以至诚恳切的心祈请诸佛慈悲住世，莫入灭度。除此而外，我们还要殷勤劝请各位菩萨、声闻、缘觉、有学、无学乃至一切善知识们长久住世。如果他们入灭离世，众生便将失去依怙。这一大愿既可作为观修，也可作为实际的修持方法。当现实中的大善知识们尘缘将尽时，我们不仅要恳切劝请他们为怜悯、利益众生而住世，还应不断诵经、放生，以种种功德回向，使他们久住世间。
    “经于一切佛刹极微尘数劫，为欲利乐一切众生。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此劝请无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”请佛住世是没有时间期限的，应当作为我们尽未来际的事业。这一修行既可通过观修来完成，也可通过自身念念觉而不迷来进行，还可以通过弘法来启发众生的本觉智慧。我们不是为了成佛而行菩萨道，而是为了更圆满地行持菩萨道而成佛。所以说，修习菩萨道就是我们永无止境的事业。


第八大愿：常随佛学

    “复次善男子，言常随佛学者，如此娑婆世界毗卢遮那如来，从初发心，精进不退，以不可说不可说身命而为布施。剥皮为纸，析骨为笔，刺血为墨，书写经典，积如须弥。为重法故，不惜身命，何况王位、城邑聚落、宫殿园林，一切所有，及余种种难行苦行。乃至树下成大菩提，示种种神通，起种种变化，现种种佛身，处种种众会。或处一切诸大菩萨众会道场，或处声闻及辟支佛众会道场，或处转轮圣王、小王眷属众会道场，或处刹利及婆罗门、长者、居士众会道场，乃至或处天龙八部、人非人等众会道场。处于如是种种众会，以圆满音，如大雷震，随其乐欲，成熟众生，乃至示现入于涅槃。如是一切，我皆随学。如今世尊毗卢遮那，如是尽法界虚空界，十方三世一切佛刹所有尘中一切如来，皆亦如是。于念念中，我皆随学。如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此随学无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”
    常，是恒常；随，是追随。现代学者往往将“佛学”当作学术研究，而此处所讲的“常随佛学”，则是向佛陀学习，以佛菩萨因地的修行为榜样，不断向这一目标靠拢直至最终成就。学佛有两种方式，一是依法学习，佛陀说法四十九年，开示八万四千法门，我们可在其中选择适合自己的法门，并以佛陀开示的正见作为修行指南。一是直接向佛菩萨学习，以阿弥陀佛、观音菩萨乃至十方三世一切佛菩萨因地的愿力和法门作为修学榜样。《楞严经》二十五圆通，就论述了二十五位菩萨及大罗汉的修行过程，于六尘、六根、六识、七大各各不同之悟入处。如观音菩萨耳根圆通章，就叙述了观音菩萨从耳根开始修行，并圆照三昧、成就菩提的经验。我们也可按照这些法门着手修行，沿着佛菩萨走过的修行之路勇往直前。所以说，学佛决不仅仅是求佛菩萨保佑，更要落实在修学实践中。“广修供养”中讲过，“诸供养中，法供养最”。之所以将法供养列于首位，是因为依法修行才能证得法性，最终成就佛果。
    “如此娑婆世界毗卢遮那如来，从初发心，精进不退。以不可说不可说身命而为布施。剥皮为纸，析骨为笔，刺血为墨，书写经典，积如须弥。为重法故，不惜身命，何况王位、城邑聚落、宫殿园林，一切所有。及余种种难行苦行。”这段是介绍佛陀在因地的修行经历。娑婆，为堪忍之义。在我们这个五浊恶世，烦恼众多，痛苦重重，生于此间需有极大忍耐力，否则便会痛苦不堪。娑婆世界为释迦牟尼佛教化的区域，而毗卢遮那如来则是释迦佛的法身。佛陀有三身，分别是清净法身毗卢遮那如来、圆满报身卢舍那佛、千百亿化身释迦牟尼佛。佛陀从最初发心开始，为追求真理和智慧，始终精进不退。在无尽生命中，不仅数数为法舍身，还曾将自己的皮肤铺为纸，将骨胳折作笔，将鲜血作为墨，以此书写经典流传世间。佛陀在因地所写的血经堆积如山，高如须弥。为表示对法的尊重，生命尚不足惜，何况权势、财物等身外之物。类似的事迹在中国佛教史上也屡见不鲜。在以往的年代，得到一本佛经极为不易，通常都需要一字一句地抄写。更有许多高僧大德刺血写经，体现了舍身求道的大无畏精神。除此而外，历代高僧大德还为学法和弘法谱写了许多感人篇章。如玄奘为到西域求法而历尽艰辛，鉴真为向日本传法而六次东渡，慧可为向达摩问道而断臂求法等等，他们都不愧是真正的佛法实践者。
    “乃至树下成大菩提。示种种神通，起种种变化，现种种佛身，处种种众会。”正因为修习众多难行苦行，佛陀才能在菩提树下夜睹明星，见性成佛。佛陀的神通主要是六种，分别是天眼通、天耳通、他心通、宿命通、神足通、漏尽通。至于身相的变化，则根据众生的不同身份而示现。如观音菩萨的三十二应，便是世人最为熟悉的佛教典故之一。佛陀成道以后，为更好地度化众生，以神通变化各种身相：应于何身得度者，即现何身而为说法。同时，还在人间、天上乃至海中等不同场所宣说法要。
    “或处一切诸大菩萨众会道场，或处声闻及辟支佛众会道场，或处转轮圣王、小王眷属众会道场，或处刹利及婆罗门、长者、居士众会道场，乃至或处天龙八部、人非人等众会道场。”佛陀因机设教，应众生的不同根基而作开示。有时到大菩萨们活动的场所说法；有时在声闻、辟支佛所在的场所说法；有时在国王聚会的场所说法；有时到执政者、婆罗门、商人聚会的场所说法；甚至到天、龙、夜叉、乾闼婆、阿修罗、迦楼罗、紧那罗、摩睺罗伽、非人等聚集的场所说法。
    “处于如是种种众会，以圆满音，如大雷震，随其乐欲，成熟众生，乃至示现入于涅槃。如是一切，我皆随学。”在不同场所，佛陀又会根据众生的需求和喜好，以最为圆满的音声宣说种种教法，以无量的智慧和方便善巧传播佛法，如隆隆雷声唤醒众生的无明迷梦。直到在世间的化缘已尽，才入于涅槃。无论是佛陀在因地求法的精神，还是佛陀为众生慈悲说法的精神，都是我们要尽未来际努力学习的。
    “如今世尊毗卢遮那，如是尽法界虚空界，十方三世一切佛刹所有尘中一切如来，皆亦如是。于念念中，我皆随学。”本品主要介绍了释迦牟尼佛求法和弘法的经历，为求法不畏艰难，为弘法不知疲倦。释迦牟尼是这样做的，十方三世一切诸佛也是这样做的。我们既要向释迦牟尼佛学习，也要向十方三世一切诸佛学习。或是学习阿弥陀佛的四十八大愿；或是学习药师琉璃光如来的十二大愿；或是学习地藏王菩萨“地狱不空，誓不成佛，众生度尽，方证菩提”的宏伟愿望；或是学习观世音菩萨“大慈大悲、寻声救苦”的精神；或是学习本品所介绍的普贤菩萨的广大无边的十大行愿。
    在学佛过程中，我们可以寻找一位和自己最有缘的菩萨来学习。如文殊菩萨代表智慧，观音菩萨代表大悲，地藏王菩萨代表大愿，普贤菩萨代表大行……每个人都可选择其中一位作为修行榜样，将他们的愿力转化为自己的愿力，以他们的品行调整自己的品行。若以观世音菩萨为学习榜样，就应充分了解观世音菩萨的品质和功德，以此作为纠正凡夫习气的参照系数。修习达到一定程度后，就可将自己观想为观音菩萨。藏传佛教关于本尊的修法，正是基于这一原理。观世音菩萨曾是普通的凡夫，阿弥陀佛曾是平凡的众生，释迦牟尼佛在因地也曾和我们一样的，只因为他们发广大心，修殊胜行，才能成就无上佛道。所以说，只要我们也象诸佛菩萨那样发心并勇于直下承担，将来也能和十方诸佛一样修行成就。
    “如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此随学无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”常随佛学，是尽未来际向诸佛学习，无论斗转星移、沧海桑田，始终精进不退。学佛，关键在于行佛所行，而不仅是祈求佛菩萨的加持和保佑。唯有将佛法落实到自身的心行改造中，才是名符其实的学佛。


第九大愿：恒顺众生

    “复次善男子，言恒顺众生者，谓尽法界虚空界，十方刹海所有众生，种种差别。所谓卵生、胎生、湿生、化生，或有依于地水火风而生住者，或有依空及诸卉木而生住者。种种生类、种种色身、种种形状、种种相貌、种种寿量、种种族类、种种名号、种种心性、种种知见、种种欲乐、种种意行、种种威仪、种种衣服、种种饮食，处于种种村营聚落、城邑宫殿。乃至一切天龙八部、人非人等。无足、二足、四足、多足，有色、无色、有想、无想、非有想非无想，如是等类。我皆于彼随顺而转，种种承事，种种供养，如敬父母，如奉师长，及阿罗汉，乃至如来，等无有异。于诸病苦，为作良医。于失道者，示其正路。于闇夜中，为作光明。于贫穷者，令得伏藏。菩萨如是平等饶益一切众生。何以故？菩萨若能随顺众生，则为随顺供养诸佛。若于众生尊重承事，则为尊重承事如来。若令众生生欢喜者，则令一切如来欢喜。何以故？诸佛如来，以大悲心而为体故。因于众生而起大悲，因于大悲生菩提心，因菩提心成等正觉。譬如旷野沙碛之中，有大树王，若根得水，枝叶华果，悉皆繁茂。生死旷野，菩提树王，亦复如是。一切众生而为树根，诸佛菩萨而为华果。以大悲水饶益众生，则能成就诸佛菩萨智慧华果。何以故？若诸菩萨以大悲水饶益众生，则能成就阿耨多罗三藐三菩提故。是故菩提属于众生，若无众生，一切菩萨终不能成无上正觉。善男子，汝于此义，应如是解。以于众生心平等故，则能成就圆满大悲。以大悲心随众生故，则能成就供养如来。菩萨如是随顺众生，虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此随顺无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”
    《行愿品》的核心为上求佛道，下化众生，这也是本品的两大内容。前者是以佛果功德为所缘境，包括礼敬诸佛、称赞如来、广修供养、忏悔业障、随喜功德、请转法轮、请佛住世八大愿王，引导我们将心念念融入大觉海中。后者是以利益一切众生为所缘境，菩提心乃利益众生之心，“恒顺众生”之愿便切实体现了这一内涵。但我们要明确的是，这种顺从是有原则的，并非一味迁就。我们发心利益众生，便应做对众生真正有利的事。众生为无明所惑，其需要往往伴随着贪嗔痴烦恼。如果没有智慧加以分辨，所谓的随顺很可能只是在满足众生的贪嗔痴，对他们非但没有真实利益，甚至会埋下隐患。所以，恒顺众生应以智慧为前提，确定我们的行为能否真正利益众生。
    《行愿品》的修行是模拟成佛的修行，通过对佛菩萨品质的观修，将心行调整到这一层面。而佛菩萨品质是由无限的智慧和慈悲组成，其中，慈悲必须通过众生才能成就。没有众生，我们去慈悲谁呢？所以说，离开众生的话，我们永远无法成佛。当然，不是要将所有众生都救度完之后，功德才能圆满。因为度众生也是要有因缘的，对于无缘众生，佛陀亦无能为力。因此，只要能对一切众生具有平等而无限的悲心，就是圆满的大慈大悲。在佛菩萨的心目中，一切众生都是平等无别的。若存有好恶之分，只能说明其心行仍滞留于凡夫境界。哪怕还有一个众生是他讨厌或不愿救度的，就不是圆满的慈悲。从这个意义上说，考察修行境界如何，唯有通过对内心的审视才能判断：我们有什么心态，就代表修行达到什么程度。
    菩萨道的修行特点在于，起心动念间都想着利益众生。《行愿品》第九大愿，便是对如何利益众生的具体指导。
    “言恒顺众生者”，恒，是恒常；顺，是随顺。其原则在于，随顺众生的善心和善行，而不是无条件地随顺。否则，随顺众生的种种恶习和非法要求，岂不是和他们一同堕落吗？所以，唯有能为众生带来长久利益而无负面影响的事情才能随顺，而对众生没有利益、或只有暂时利益而于未来有负面影响的行为则不能随顺。那么，佛菩萨究竟要随顺哪些众生呢？
    “谓尽法界虚空界，十方刹海所有众生，种种差别。”佛菩萨的随顺，是以一切众生为对象，也就是本品再再提到的，尽法界、虚空界的所有众生。因为佛菩萨的发心是无限的，故能圆满无量功德。相反，凡夫的发心是有限的，成就的功德也极为有限。如何将有限的功德转化为无限？关键在于心的拓展，所以做每件事都要发心为利益众生而做。我们来此听经，也要发心为利益一切众生成就佛道而听闻佛法。当我们遇到顺境时，希望以此因缘更好地利益一切众生；当我们遭遇逆境时，希望藉由自身磨难承担其他众生的苦难。如果我们时时都能这样发心，就是在不断接近佛菩萨的心行。
    “所谓卵生、胎生、湿生、化生”，这是众生的不同受生形式。卵生，如鸡、鸭等通过孵卵而出生；胎生，如人类、牛羊等通过胎藏而出；湿生，如水中受生的众生，假润而生；化生，如地狱众生。
    “或有依于地水火风而生住者，或有依空及诸卉木而生住者。”这是指众生生存的不同处所。有些众生在地上生存，有些众生在水中生存，有些众生在火中生存，有些众生在风中生存，有些众生在虚空生存，有些众生依附于草木而生存……因为业力不同，其生存处所也是千差万别。
    “种种生类，种种色身，种种形状，种种相貌，种种寿量。”这是指有情的种种差别。芸芸众生，无奇不有。出生的方式不同，色身的状态不同，显现的形状不同，具有的相貌不同，存活的寿命也不同，如《庄子》云，“朝菌不知晦朔，惠蛄不知春秋。此小年也。楚之南有冥灵者，以五百岁为春，五百岁为秋；上古有大椿者，以八千岁为春，八千岁为秋。”其间相差何止千万倍，足见业力之不可思议。
    “种种族类，种种名号，种种心性，种种知见，种种欲乐，种种意行。”众生有不同种足族，如白种人、黑种人、黄种人等，其中又分为汉族、藏族、满族等不同民族。此外，还有张三、李四等各种姓名，更有不同的心理状态及认识、观念、欲望、喜好、人生愿望等等。
    “种种威仪，种种衣服，种种饮食，处于种种村营聚落、城邑宫殿。”众生的行动方式、举止威仪不同，所穿服饰不同（即使动物也有不同的皮毛），所吃食物不同，居住环境不同。
    总之，虽然众生形形色色，但都是佛菩萨慈悲和利益的对象，其中没有佛教徒和异教徒之别，甚至没有人和动物之分。在佛菩萨的心目中，一切有情都是平等无二的。行菩萨道，应对所有众生具有平等之心。为什么我们不能以平等心看待众生？因为我们还是凡夫，而凡夫心的特点正是充满人我是非。佛菩萨所具有的平等，是建立在无限的慈悲心行上。只有将内在的慈悲品质完全启动并激发起来，我们才能像佛菩萨那样对一切众生常怀悲悯，平等视之，有如独子。正因为我们现在还做不到，所以更需要每天训练。从知母、念恩开始，观想一切众生在无尽轮回中都做过我们的生身母亲，由此生起报恩心，然后将这份报恩心不断强化并普及，进而引发慈心、悲心、增上心和菩提心。
    “乃至一切天龙八部、人非人等。无足、二足、四足、多足，有色、无色、有想、无想、非有想非无想，如是等类。”所谓天龙八部，即天、龙、夜叉、乾闼婆、阿修罗、迦楼罗、紧那罗、摩睺迦。所谓人非人等，人即人类，非人即人类之外的其它众生，如恶鬼等冥众。有些众生是无足的，如蛇、蚯蚓等爬行动物；有些是二足的，如人等；有些是多足的，如蜈蚣。有想，即有思想的众生；无想，即想心昏迷，无所觉了的众生；非有想非无想，粗想已去除，但仍有非常微细之想，如色界天众生。生命的种类无量无边，对于所有这些众生，我们都要生起慈悲和平等之心。
    “我皆于彼随顺而转，种种承事，种种供养，如敬父母，如奉师长，及阿罗汉，乃至如来，等无有异。”我们要随顺众生做种种于他们有益的事，以各种方法去侍奉、供养他们，将他们当作自己的父母师长般恭敬，甚至将当作阿罗汉和诸佛菩萨般敬重。若我们对众生生起这样的关爱，内心就能得到净化。反之，对众生的不平等和虚妄分别，则是因为我们有不清净的心。分别此人好，那人不好，分别此人和我有关，那人和我无关，平添许多烦恼。尤其是中国社会，人际关系非常复杂，要耗费许多心力在妄想中纠缠。能够放下这些妄想分别，将一切众生视为佛菩萨，所有问题也就迎刃而解了。
    “于诸病苦，为作良医。于失道者，示其正路。”我们又该为众生做些什么呢？众生有身病和心病，当众生身患病苦时，我们要象医生那样为他们治病；当他们偏离正道或堕落邪教时，我们要以佛法开导他们，指明正确的前进方向。
    “于闇夜中，为作光明。”此处的暗夜非指昼夜之夜，而是指众生因无明所惑，处于生命暗夜中，不知生从何而来，死往何去。人人最关心的就是自己，却不知何者为“我”；人人都想一生幸福快乐，却不知人生意义为何，多数都是茫茫然来世间走一遭。作为菩萨道行者，应发心以佛法启迪他们的智慧，点亮他们的心灯，使他们早日脱离轮回，走向光明的解脱之道。
    “于贫穷者，令得伏藏。”贫穷包括物质和精神两方面。对于物质贫穷的人，我们应给予经济帮助；而对于精神贫穷的人，我们要使其听闻佛法，帮助他们止恶行善，积累功德法财。
    “菩萨如是平等饶益一切众生。何以故？菩萨若能随顺众生，则为随顺供养诸佛。若于众生尊重承事，则为尊重承事如来。若令众生生欢喜者，则令一切如来欢喜。”菩萨对于一切众生都要生起无限慈悲，并通过各种方式给予帮助。这样做的意义是什么？一般人以为，供佛、念佛、令诸佛欢喜就是修行的全部。事实上，诸佛菩萨出现于世，正是为了度化众生。如果我们利益众生，就是在做诸佛菩萨所做的事，才能真正令诸佛欢喜。随顺众生利益，是对诸佛最好的供养；对众生尊重承事，就是尊重承事如来；令众生欢喜，就是令一切如来欢喜。对于佛法修行而言，众生甚至比佛菩萨更重要，因为他们更需要我们的帮助。而佛菩萨只是佛弟子的修学典范，对于他们来说，完全不需要我们为他们做些什么。我们对诸佛菩萨的恭敬、供养，最终都是在成就自身修行，而非佛菩萨所需。
    “何以故？诸佛如来，以大悲心而为体故。”这也是告诉我们众生对于修行的重要性。诸佛的品质是大慈大悲，但这一品质并非与生俱来，而是在对众生的无尽慈悲中形成。离开众生，悲心也无法成就。事实上，每个人都有慈悲的心行基础，即悲悯心。但一般人的悲悯心很小，尤其是现代人，大多自私冷漠且缺乏同情心，相关事例不仅媒体报道时常可见，生活中也比比皆是。这一点，正是学佛道路上的重大障碍修行。我们学佛修行，必须彻底克服自私的小我，通过各种方便法门及外在因缘，不断培育、张扬生命内在的优良品质。
    “因于大悲生菩提心，因菩提心成等正觉。”以悲悯心为基础，才能引发菩提心的生起，最终圆满佛陀的大慈大悲。因为菩提心正是大乘的不共教法，是成佛的不共因。
    “譬如旷野沙碛之中，有大树王，若根得水，枝叶华果，悉皆繁茂。”这一比喻充分说明，在修学菩萨道的过程中，众生和我们的关系多么重要。就像沙漠中有棵参天巨树，如果它的根系得到灌溉，才会枝繁叶茂，果实累累。
    “生死旷野，菩提树王，亦复如是。一切众生而为树根，诸佛菩萨而为华果。以大悲水饶益众生，则能成就诸佛菩萨智慧华果。何以故？若诸菩萨以大悲水饶益众生，则能成就阿耨多罗三藐三菩提故。”在无尽的生死旷野之中，我们想要成就无上菩提，也应像这棵巨树那样，确保根部得到浇灌。对于佛道修行来说，一切众生好比树根，诸佛菩萨好比果实。不断以大悲水滋养众生，才能结出无上菩提的累累花果。如果菩萨能对一切众生充满无限慈悲，时时心系众生，才能成就无上佛道。
    “是故菩提属于众生，若无众生，一切菩萨终不能成无上正觉。”这是极为重要的总结，希望大家能够引起高度重视。菩提从何而来？正是由众生而成就。如果没有众生作为修行所缘境，一切菩萨都无法圆满佛道，成就无上正觉。
    “善男子，汝于此义，应如是解。以于众生心平等故，则能成就圆满大悲。以大悲心随众生故，则能成就供养如来。”对于修学菩萨道的大乘行者来说，必须了解利益众生在修行中的重要性。只有对众生平等看待，等无有异，才能圆满佛菩萨的大慈大悲。如果缺乏平等心，必定还是凡夫有限、有所得的小慈小悲，而非佛菩萨的“无缘大慈，同体大悲”。以大悲心和广大行随顺众生事业，正是对如来的无上供养。这一点也充分说明，大乘佛教的修行是非常积极而非消极遁世的。
    “菩萨如是随顺众生，虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此随顺无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”菩萨对众生的随顺，不是短时间的。一个人做一件好事并不难，难的是一辈子做好事。而对于发心修学菩萨道的人来说，不仅要一辈子做好事，还要尽未来际、永不间断地行善积德。即使虚空会有尽头，利益众生的事业和愿望却不会穷尽，所谓“虚空有尽，我愿无穷”。从这个意义而言，修行的根本目标是利益众生而非成佛，因为成佛也是为了更好、更彻底地度化众生。如果我们是为了“我要成佛”而利他，说明还有我执在，那么佛果一定无法圆满。


第十大愿：普皆回向

    “复次善男子，言普皆回向者，从初礼拜，乃至随顺，所有功德，皆悉回向尽法界虚空界一切众生。愿令众生常得安乐，无诸病苦。欲行恶法，皆悉不成。所修善业，皆速成就。关闭一切诸恶趣门，开示人天涅槃正路。若诸众生，因其积集诸恶业故，所感一切极重苦果，我皆代受。令彼众生，悉得解脱，究竟成就无上菩提。菩萨如是所修回向，虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此回向无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”

    每做一件事或修行之后，都要进行回向，并有不同的具体内容。如放生、受戒的回向偈分别是“放生功德殊胜行，无边胜福皆回向，普愿沉溺诸众生，速往无量光佛刹”，及“受戒功德殊胜行，无边胜福皆回向，普愿沉溺诸众生，速往无量光佛刹”。而修习净土法门的人，多以“愿生西方极乐中，九品莲花为父母，花开供佛悟无生，不退菩萨为伴侣”作为回向。
    所谓回向，是将我们所做的功德指向一个目标。比如我们为达到某个目标而赚钱，回向，就是将每笔钱存储到指定的帐号。如果赚钱很多却随手花掉，想用时就会囊中羞涩了，最终一事无成。同样，修行所得功德也需有一明确目标。或回向人天善果，或回向往生西方等等。而最高的回向，是将功德回向一切众生。或许有人会说，我花了这么多钱和精力做好事，若回向给一切众生岂不很亏？更何况其中还有些众生是我们所讨厌的，如何甘愿让他们也分得一杯羹呢？但我们要知道，我们也是众生之一，当我们发愿将功德回向一切众生时，并不因回向众生而一无所获。正相反，由于我们的发心无限，所获功德将百千倍、亿万倍地增长，绝非狭隘的发心所能比拟。
    我们每天讲经最后所念的回向偈是：“愿以此功德，普及于一切，我等与众生，皆共成佛道。”也就是说，希望我们讲经和闻法的功德，使一切众生获得法益；希望我们与一切众生能于菩提道上早日成就，究竟解脱轮回之苦。这种回向，就属于最高、最广大的回向。那么，《行愿品》又是如何回向的呢？
    “言普皆回向者，从初礼拜，乃至随顺，所有功德，皆悉回向尽法界虚空界一切众生。”行愿品的回向，乃普皆回向，将修行功德如甘霖般遍洒人间。从本品最初的“礼敬诸佛”到第九愿的“随顺众生”，每修完一种之后，都应将修行功德回向尽虚空、遍法界的所有众生。其核心在于，将一切功德回向一切有情。回向的心有多大，最后成就的功德就有多大。若我们只希望将功德回向于自己或亲人身上，如此狭隘的心又能装得下多少功德呢？一个茶杯，只能装一杯水。同样的道理，如果我们心狭隘，成就也必定狭隘。所以，必须彻底打破我执设定的界限。心本如虚空般浩瀚辽阔，无形无相。只因我执及我所执的系缚，才被局限于有限的家庭或事业中。修行，正是要去除一切人为设定的界限，使心回到清净无染的本然状态。
    “愿令众生常得安乐，无诸病苦。欲行恶法，皆悉不成。所修善业，皆速成就。”我们发愿将一切功德回向众生，又该如何祝福他们呢？我们要祝愿众生永远安祥、快乐，远离色身病苦和心灵痛苦。此外，我们还祝愿所有准备作恶的众生都无法如愿；愿所有准备行善的众生都能心想事成。
    “关闭一切诸恶趣门，开示人天涅槃正路。”恶趣，即地狱、饿鬼、畜生三恶道。希望恶道之门早日关闭，所有众生都能生于人、天善道，并通过修行证得涅槃、断除烦恼、成就佛果。
    “若诸众生，因其积集诸恶业故，所感一切极重苦果，我皆代受。令彼众生，悉得解脱，究竟成就无上菩提。”如果众生因造作恶业将遭受极大痛苦，我们发愿代其承担这份苦果。更进一步，愿为天下众生承担所有痛苦。祝愿他们早日离苦得乐，解脱生死，成就无上菩提。
    “菩萨如是所修回向，虚空界尽，众生界尽，众生业尽，众生烦恼尽，我此回向无有穷尽。念念相续，无有间断。身语意业，无有疲厌。”菩萨每做一件好事，哪怕是微小善行，都应如此回向，而这种回向是永不间断的。当我们作如此回向时，等于将一滴水投入大海中，和大海融为一体，并因此获得恒久的力量。
    因此，发心无限，所得无限；发心有限，所得亦有限。


结说：修学利益

    下面总结修行普贤十大行愿的利益。

    “善男子，是为菩萨摩诃萨十种大愿，具足圆满。若诸菩萨，于此大愿，随顺趣入，则能成熟一切众生，则能随顺阿耨多罗三藐三菩提，则能成满普贤菩萨诸行愿海。是故善男子，汝于此义，应如是知。若有善男子、善女人，以满十方无量无边不可说不可说佛刹极微尘数一切世界上妙七宝，及诸人天最胜安乐，布施尔所一切世界所有众生，供养尔所一切世界诸佛菩萨，经尔所佛刹极微尘数劫，相续不断，所得功德。若复有人，闻此愿王，一经于耳，所有功德，比前功德，百分不及一，千分不及一，乃至优波尼沙陀分亦不及一。或复有人，以深信心，于此大愿受持读诵，乃至书写一四句偈，速能除灭五无间业。所有世间身心等病，种种苦恼，乃至佛刹极微尘数一切恶业，皆得消除。一切魔军、夜叉、罗刹，若鸠槃茶、若毗舍阇、若部多等，饮血啗肉，诸恶鬼神，皆悉远离。或时发心亲近守护。是故若人诵此愿者，行于世间，无有障碍。如空中月，出于云翳。诸佛菩萨之所称赞，一切人天皆应礼敬，一切众生悉应供养。此善男子，善得人身，圆满普贤所有功德。不久当如普贤菩萨，速得成就微妙色身，具三十二大丈夫相。若生人天，所在之处，常居胜族。悉能破坏一切恶趣，悉能远离一切恶友，悉能制伏一切外道，悉能解脱一切烦恼。如狮子王，摧伏群兽。堪受一切众生供养。
    又复是人临命终时，最后刹那，一切诸根悉皆散坏，一切亲属悉皆舍离，一切威势悉皆退失。辅相大臣、宫城内外、象马车乘、珍宝伏藏，如是一切无复相随。唯此愿王，不相舍离，于一切时，引导其前。一刹那中，即得往生极乐世界。到已即见阿弥陀佛、文殊师利菩萨、普贤菩萨、观自在菩萨、弥勒菩萨等。此诸菩萨，色相端严，功德具足，所共围绕。其人自见生莲华中，蒙佛授记。得授记已，经于无数百千万亿那由他劫，普于十方不可说不可说世界，以智慧力，随众生心而为利益。不久当坐菩提道场，降服魔军，成等正觉，转妙法轮。能令佛刹极微尘数世界众生，发菩提心。随其根性，教化成熟，乃至尽于未来劫海，广能利益一切众生。
    善男子，彼诸众生，若闻若信此大愿王，受持读诵，广为人说。所有功德，除佛世尊，余无知者。是故汝等闻此愿王，莫生疑念，应当谛受。受已能读，读已能诵，诵已能持，乃至书写，广为人说。是诸人等，于一念中，所有行愿，皆得成就。所获福聚，无量无边。能于烦恼大苦海中，拔济众生，令其出离，皆得往生阿弥陀佛极乐世界。”
    这段经文是介绍修学《行愿品》的功德，主要包括八个部分。

    一、总说
    “善男子，是为菩萨摩诃萨十种大愿，具足圆满。若诸菩萨，于此大愿，随顺趣入，则能成熟一切众生，则能随顺阿耨多罗三藐三菩提，则能成满普贤菩萨诸行愿海。是故善男子，汝于此义，应如是知。”《行愿品》对普贤菩萨的十大愿王作了详尽阐述，其境界广阔无边。那么，此十种愿力能使我们得到什么利益呢？本段是总说《行愿品》的功德：若菩萨能按《普贤行愿品》阐述的观修方法修行，即能成就并利益一切众生，因其发心所缘境为一切众生，是和无上佛果相应的。如果我们也能象普贤菩萨那样，发广大愿，行殊胜行，我们就是普贤菩萨的化身了，因为他的愿力已在我们内心乃至行动中得到实现。

    二、校量功德
    “是故善男子，汝于此义，应如是知。若有善男子、善女人，以满十方无量无边不可说不可说佛刹极微尘数一切世界上妙七宝，及诸人天最胜安乐，布施尔所一切世界所有众生，供养尔所一切世界诸佛菩萨，经尔所佛刹极微尘数劫，相续不断，所得功德。若复有人，闻此愿王，一经于耳，所有功德，比前功德，百分不及一，千分不及一，乃至优波尼沙陀分亦不及一。”这是通过校量比较的方式说明本品利益。普贤菩萨告诉我们，如果有人以十方世界那么多的、数不胜数的极品珍宝布施众生，并以此供养十方世界所有的诸佛菩萨，而且尽未来际永不间断地供养。所获功德虽然极大，却无法和修学普贤法门的功德相比，甚至不到百分之一、千分之一、千万分之一。因为以再多的珍宝布施再多的人，只能使人得到物质利益，却不能令众生断烦恼、了生死。而听闻《行愿品》并按照这一法门精进修学，却能帮助我们成就佛道，获得究竟解脱。在学佛者都很熟悉的《金刚经》中，也数数以校量功德的方式说明，法布施远胜于财布施，法供养远胜于财供养。

    三、消除恶业
    “或复有人，以深信心，于此大愿受持读诵，乃至书写一四句偈，速能除灭五无间业。所有世间身心等病，种种苦恼，乃至佛刹极微尘数一切恶业，皆得消除。”修学《行愿品》，还能帮助我们灭除罪障。佛教中最重罪业为五无间业，分别是杀父、杀母、杀阿罗汉、出佛身血、破和合僧五项。即使如此深重的罪业，也能通过读诵、书写《行愿品》进行忏悔，并因此灭除一切罪业及身心的痛苦烦恼。

    四、远离邪魔
    “一切魔军、夜叉、罗刹，若鸠槃茶、若毗舍阇、若部多等，饮血啗肉，诸恶鬼神，皆悉远离。或时发心亲近守护。”世间灾难多与魔军、夜叉等妖魔鬼怪有关，但只要我们一心读诵《行愿品》，所有诸恶鬼神看到我们都会远远避开，甚至变作护法来帮助并守卫我们。因为我们修学的是成佛的无上法门。

    五、诸佛护念，人天礼敬
    “是故若人诵此愿者，行于世间，无有障碍。如空中月，出于云翳。诸佛菩萨之所称赞，一切人天皆应礼敬，一切众生悉应供养。”我们修学《行愿品》，在世间就不再会遇到任何障碍。就象月亮跳出云彩遮蔽之后，朗照四方而无任何阻挡。修学普贤菩萨的十大愿王，不仅会得到世人恭敬，还会得到天人尊重，甚至诸佛菩萨也会时常赞叹我们。

    六、获得圆满身份
    “此善男子，善得人身，圆满普贤所有功德。不久当如普贤菩萨，速得成就微妙色身，具三十二大丈夫相。若生人天，所在之处，常居胜族。悉能破坏一切恶趣，悉能远离一切恶友，悉能制伏一切外道，悉能解脱一切烦恼。如狮子王，摧伏群兽。堪受一切众生供养。”修学《行愿品》，将在未来生得到最美满的身份。象普贤菩萨那样，圆满他所具有的一切功德。我们学习佛菩萨，最后就能圆满他们所具备的功德，并具备三十二种大丈夫相，这是佛教最圆满的相貌。若生在人天善处，还能出身于高贵的家族。从今往后，不仅不必担心堕落恶道，连恶友也能自动远离我们，除非是我们发心去救度他们。此外，一切外道会被我们的威德摄受，一切烦恼也将得到解脱。因为本品阐述的修行法门，代表着菩提心转化的、威力无比的心行力量。就象百兽之王狮子那样，能使群兽俯首称臣。按照《行愿品》修学，就是如来家业的真正继承者，能够得到众生的供养。

    七、往生佛刹速成佛道
    “又复是人临命终时，最后刹那，一切诸根悉皆散坏，一切亲属悉皆舍离，一切威势悉皆退失。辅相大臣、宫城内外、象马车乘、珍宝伏藏，如是一切无复相随。唯此愿王，不相舍离，于一切时，引导其前。一刹那中，即得往生极乐世界。到已即见阿弥陀佛、文殊师利菩萨、普贤菩萨、观自在菩萨、弥勒菩萨等。此诸菩萨，色相端严，功德具足，所共围绕。其人自见生莲华中，蒙佛授记。得授记已，经于无数百千万亿那由他劫，普于十方不可说不可说世界，以智慧力，随众生心而为利益。不久当坐菩提道场，降服魔军，成等正觉，转妙法轮。能令佛刹极微尘数世界众生，发菩提心。随其根性，教化成熟，乃至尽于未来劫海，广能利益一切众生。”
    学佛的人，最关心临终去哪里。当色身即将败坏时，身边再亲密的人也无法陪伴我们；生前地位再高，此时一无用处；生前财富再多，仍然只能两手空空地离去。此刻，唯有宿世积累的业力会陪伴我们。所以，人们都关心临终时是否会因一念之差而堕落恶道，关心阿弥陀佛是否前来接引。但如果我们修学普贤法门，就不必担心这些问题了。因为修学十大愿王所发起的菩提心的力量，将在临终时引导我们，将我们直接推动到极乐世界。到达之后，不仅诸佛菩萨都会前来接见，还将生于莲花中，得到佛陀的授记。然后，立刻前往十方世界大行菩萨道。最后，象佛陀那样成就无上佛道，降服魔军，广转法轮。使得无量无边的众生因听闻普贤菩萨的殊胜教法而发起菩提心，并根据各自的根性得到度化，最终都能修行成就。

    八、结说
    “善男子，彼诸众生，若闻若信此大愿王，受持读诵，广为人说。所有功德，除佛世尊，余无知者。是故汝等闻此愿王，莫生疑念，应当谛受。受已能读，读已能诵，诵已能持，乃至书写，广为人说。是诸人等，于一念中，所有行愿，皆得成就。所获福聚，无量无边。能于烦恼大苦海中，拔济众生，令其出离，皆得往生阿弥陀佛极乐世界。”
    普贤菩萨告诉我们，一切有缘听闻并深信普贤十大愿王的众生，只要能够认真地受持、读诵并向他人宣说，必将获得无比殊胜的功德。其功德之大，除了十方诸佛，无人能够真正了解。同时，普贤菩萨还告诫我们，切莫对此法门产生怀疑。虽然我们一时还无法真正理解普贤菩萨的甚深境界，但至少可以通过信仰来接受这一法门。只要真实修行，能够读诵、书写、演说，终将成就普贤菩萨那样的功德。不仅自己能于一念中成就无量的福德智慧，也能使众生远离生死轮回，最后往生极乐世界。

    《普贤菩萨行愿品》，是一部教导我们圆满成就菩提心的修行宝典。菩提心代表着生命中最强大、最健康的力量。成就菩提心，不仅可以解决我们自身的问题，也可帮助无量众生解除痛苦和烦恼。若我们生活在凡夫心中，即使想要帮助别人，也是泥菩萨过河、自身难保。自己的心行都不健康，如何有力量帮助他人？中国历史上，不少起义军开始也是为天下百姓揭竿而起，但有了一定地位之后，就无一例外地变质了。原因何在？正是因为缺乏菩提心。他们所有的发心，哪怕也一定的阶段和程度也包含慈悲济世的成分，却仍是建立在凡夫心的基础上。而凡夫心的特点是我执，是自私自利，所谓“人不为己，天诛地灭”。凡夫心来自无始以来的积累，其力量根深蒂固、难以动摇。而摆脱凡夫心的唯一道路，就是成就菩提心。菩提心是无限、无我、无所得之心，唯有它的力量，才能战胜凡夫心，进而广泛利益一切众生，使我们实践生命的终极价值。