祖堂集
海东新开印版记

已上序文并《祖堂集》一卷，先行此土。尔后一卷齐到。谨依具本，爰欲新开印版，广施流传，分为二十卷。以此先写七佛，次□天竺二十七祖并诸震旦六代，代有傍正。祖位次第，并以录上；随其血脉初无联绵。佋穆之仪，有孙有嫡也。其纂成，所以群英散说周览于眼前，诸圣异言获瞻于卷内。今以沙门释匡俊所异中华集者，永祛惜法之痕。此界微曹，愿学和禅之美。深惭洞彻，乞恕僭疣。一一上名次第如后。

第一毗婆尸佛，第二尸弃佛，第三毗舍浮佛，第四拘留孙佛，第五拘那含佛，第六迦叶佛，第七释迦佛。第一大迦叶祖，〔释尊传金蝠袈裟，见在鸡足山。令迦叶持此衣，传言为信也〕第二阿难祖，第三商那和修，第四伏婆菊多，第五提多迦，第六弥遮迦，第七婆须密，第八佛陀难提，第九伏陀密多，第十胁祖师，第十一富那夜奢，第十二马鸣尊者，第十三迦毗罗祖师，第十四龙树祖师，第十五提婆祖师，第十六罗侯罗。〔已上七佛并西天二十三祖。第一卷已毕〕。第十七僧伽难提，第十八伽耶舍多，第十九鸠摩罗，第二十阇夜多，第二十一婆修盘头，第二十二摩喀罗，第二十三鹤勒祖师，第二十四师子比丘，第二十五婆舍斯多，第二十六不如密多，第二十七般若多罗，第二十八初祖达摩，第二十九祖惠可，第三十祖僧璨，第三十一祖道信，第三十二祖弘忍，第三十三祖慧能。〔已上夭竺并震旦六代衣钵相传事迹毕。〕初祖傍出道育、总持。〔第二卷己毕。〕四祖下傍出：慧融第一，智严第二，慧方第三，法持第四，智威第五，慧忠第六。前智威下出马素和尚，马素下出道钦和尚，道钦下出鸟窠和向。〔已上九人，则空宗也。〕五祖下傍出神秀和尚、安国师、道明和尚。前神秀出普寂和尚，普寂下出懒瓚和尚。老安下出腾腾和尚、坦然和尚、破灶堕。〔已上八人，则比宗也。〕六祖下出思和尚、荷泽和尚、忠国师、崛多三藏、智策和尚、本净和尚、宿觉和尚、让和尚。〔已上八人第四十一代。第三卷已毕。〕思和尚下出石头和尚，忠国师下出耽源和尚。〔已上二人四十二代。〕石头下出天皇和尚、尸利和尚、丹霞和尚、招提和尚、药山和尚。〔第四卷已毕。〕大颠和尚、长髭和尚。〔已上七人四十三代。〕天皇下出龙潭和尚，丹霞下出翠微和尚，药山下出云岩和尚、华亭和尚、肾树和尚、道吾和尚。大颠下出三平和尚，长髭下出石室和尚。〔已上八人四十四代。〕龙潭下出德山和尚。〔第五卷已毕。〕翠微下出投子和尚，圆禅师下出宗密禅师，云岩下出神山和尚、洞山和尚，道吾下出渐源和尚、石霜和尚。〔第六卷已毕。〕花亭下出夹山和尚。〔已上八人四十五代。〕德山下出岩头和尚、雪峰和尚。〔第七卷已毕。〕洞山下出云居和尚、钦山和尚、中山和尚、曹山和尚、华岩和尚、本仁和尚、青林和尚、疏山和尚、龙牙和尚、幽栖和尚。夹山下出上蓝和尚、〔第八卷已毕。〕落浦和尚、盘龙和尚、逍遥和尚、洞安和尚、黄山和尚、韶山和尚。石霜下出栖贤和尚、大光和尚、肥田和尚、涌泉和尚、南际和尚、云盖和尚、九峰和尚、南岳泰、宝盖和尚。〔已上二十八人四十六代。〕岩头下出玄泉和尚、乌岩和尚、灵岩和尚、罗山和尚。〔第九卷已毕。〕雪峰下出玄沙和尚、长生和尚、鹅湖和尚、大普和尚、镜清和尚、翠岩和尚、报恩和尚、化度和尚、鼓山和尚、隆寿和尚、安国和尚、长庆和尚。〔第十卷已毕。〕保福和尚、云门和尚、齐云和尚、永福和尚、福清和尚、潮山和尚、惟劲和尚、越山和尚、睡龙和尚。云居下出佛日和尚、水西和尚。曹山下出仲曹山和尚、金峰和尚、鹿门和尚、〔第十一卷已毕。〕荷玉和尚、育王和尚。华严下出紫陵和尚、长兴和尚。龙牙下出报慈和尚。疏山下出后疏山和尚。九峰下出禾山和尚、宝峰和尚、光睦和尚、同安和尚、泐潭和尚。云盖下出后云盖。玄泉下出黄龙和尚。罗山下出龙光和尚、龙回和尚、清平和尚。玄沙下出中塔和尚。〔已上四十七人四十七代。〕长庆下出仙宗和尚、〔第十二卷已毕。〕后招庆、报慈和尚。保福下出龙潭和尚、福先招庆、山谷和尚。〔已上五人四十八代。第十三卷已毕。已上九十六人石头下法孙，次辩江西下。〕

六祖能大师下出让和尚。〔四十一代。〕让和尚下出马祖。〔四十二代。〕马祖下出大珠和尚、百丈政、杉和尚、茗溪和尚、石巩和尚、紫玉和尚、南源和尚、百丈和尚、鲁祖和尚、高城和尚、章敬和尚、〔第十四卷已毕。〕西堂和尚、鹅湖和尚、伏牛和尚、盘山和尚、麻谷和尚、盐官和尚、五泄和尚、大梅和尚、永泰和尚、东寺和尚、邓隐和尚、归宗和尚，汾州和尚、大同和尚、金牛和尚、龟洋和尚、陈禅师、黑涧和尚、魔岩和尚、庞居士、〔已上三十一人四十三代。第十五卷已毕。〕南泉和尚。百丈下出沩山和尚、黄檗和尚、西林和尚、古灵和尚、性空和尚、〔第十六卷已毕。〕大慈和尚、西院和尚。西堂下出处微和尚、海东陈田、海东桐里、海车实相。章敬下出海东慧目山、公畿和尚。盐官下出关南和尚、海东崛山。盘山下出普化和尚。麻浴下出海东圣住。大梅下出天龙和尚。五泄下出正原和尚。归宗下出芙蓉和尚。南泉下出岑和尚、白马和尚、下堂和尚、海东双峰、〔第十七卷已毕。〕赵州和尚、紫湖和肖、陆亘大夫。〔已上二十七人四十四代。〕沩山下出仰和尚、〔第十八卷已毕。〕香岩和尚、鸿徠和尚、灵云和尚、王敬初敬。黄檗下出临济和尚、观和尚、陈和尚。西院下出大随和尚、灵树和尚、倩山和尚。关南下出道吾和尚。天龙下出俱胝和尚。紫湖下出胜光和尚。〔已上十四人四十五代也。〕仰山下出资福和尚、〔第十九卷己毕。〕海东顺之。王常侍下出米和尚。临济下出宝寿和尚、灌溪和尚。〔已上五人四十六代。〕灌溪下出后鲁祖、隐山和尚、兴平和尚、半岭和尚。〔第四十七代也。第二十卷已毕。〕

海东新开印版，《祖堂集》现其本迹者，二百五十三员，并载于二十卷内。莫知迹者，不能具录矣。

下一页


祖堂集卷一

祖堂卷一·毗婆尸佛

第一毗婆尸佛，姓拘楼，刹利王种。父字般裱，母字般头末陀。所治国名刹末提。偈曰：

身从无相中受生，喻如幻出诸形像。

幻人心识本来空，罪福皆空无所住。

祖堂卷一·尸弃佛

第二尸弃佛，姓拘楼，刹利王种。父字阿轮孥，母字婆罗诃越提。所治国名阿楼那和提。偈曰：

起诸善法本是幻，造诸恶业亦是幻。

身如聚沫心如风，幻出无根无实性。

祖堂卷一·毗舍浮佛

第三毗舍浮佛，姓拘楼，刹利王种。父字须波罗提和。母字耶舍越提。所治国名阿耨忧摩。偈曰：

假借四大以为身，心本无生因境有。

前境若无心亦然，罪福如幻起亦灭。

祖堂卷一·拘留孙佛

第四拘留孙佛，姓迦叶，婆罗门种。父宇阿枝达兜，母字随舍迦。所治国名轮诃利提。偈曰：

见身无实是见佛，了心如幻是了佛。

了得身心本性空，斯人与佛何殊别？

祖堂卷一·拘那含牟尼佛

第五拘那含牟尼佛，姓迦叶，婆罗门种。父字耶[目*夹]钵多，母字郁多罗。所治国名差摩越提。偈曰：

佛不见身知是佛，若实有知别无佛。

智者能知罪性空，坦然不惧于生死。

祖堂卷一·迦叶佛

第六迦叶佛，姓迦叶，婆罗阿种。父字阿枝达耶婆，母字檀明越提耶。所治国名婆罗私。偈曰：

一切众生性清净，从本无生无可灭。

即此身心是幻生，幻化之中无罪福

祖堂卷一·释迦牟尼佛

第七释迦牟尼佛，姓释迦，刹利王种。父字阅头檀。母字摩诃摩耶。所治国名迦维罗卫。偈曰：

幻化无因亦无生，皆则自然见如是。

诸法无非自化生，幻化无生无所畏。

是释迦佛者，即贤劫中第四佛也。三劫之中，初千佛、花光佛为首，下至毗舍浮佛，于过去庄严劫中而得成佛也。中千佛者，拘楼孙佛为首，下至楼至如来，于现在劫中次第成佛也。后千佛者，日光如来为首，下至须弥相佛，于未来星宿劫中当得成佛也。贤劫初时，香水弥满，中有千茎大莲华，王其第四禅。观见此瑞，递相谓曰：“今此世界若成，当有一千贤人出现于世。”是故，此时名为贤劫。准《因果经》云“释迦如来未成佛时，为大菩萨，名曰善慧，亦名忍辱。功行已满，位登补处，生兜率天，名曰圣善，亦曰护明。为诸天王说补处行，亦于十方现身说法，期运将至，当下作佛。觐诸国土何者处中，则知迦毗罗国最是地之中矣。”故《本起经》云：“佛之威神，至尊至重，不生边地之倾斜也。此迦毗罗城，三千日月，乾坤之中央也。往古诸佛，皆兴于此。”《俱舍论》云：“剡浮洲之中矣。”《山海经》云：“身毒之国，轩辕氏居之。”郭璞注曰：“则中天竺也。彼土自分五天竺国，中天竺国是天地之中。名既非边，中义现矣。”《因果经》云：“中天大夏种姓有四，谓杀利帝种、婆罗门种、毗舍罗种、首陀种。刹利王种最为高贵，劫初以来，相承不绝。余之三姓，非此所论，但明佛性，自分五别。”又《长阿含经》云：“劫初成时，未有日月光明。诸天福尽下生，皆化为人。欢喜为食，身光远照，飞行自在，无有男女、尊卑、亲属。自然地味，味如苏蜜。有试当者，遂生搏食，光威通亡，呼嗟在地。食多貌悴，食小形泽，便兴胜负。地味则没。又生地皮，因食地皮故，诸恶凑集。又生林藤粳米等，众味甘美。因兹食者具男女根，如是展转，便为姻媾，遂始胎生。”《楼炭经》云：“自然粳米，朝刈暮熟。”《中阿经》云：“米长四寸，人竞预取。”如是相煞，预取之处，后更不生。”《长阿含经》云：“尔时众生既见不重生，故各怀忧恼，互封田宅，以为疆畔。其有自藏以来，盗他田谷，由是诤起，无能决者。议立一人，号平等主，赏善罚恶，仍共供给。时有一人，容质瑰伟，威严鞠物，众所信伏。则往请之，彼既受已，遂有民主名焉。”《楼炭经》云：“众人言议，为作长号，谥之曰王，以法取祖，故名刹利，此译田地主也。”时阎浮提，天下富乐安隐。地生青草，如孔雀毛。八方郡国，聚落相闻。无有寒热及病恼者。王以正法治世，奉行十法，互相崇敬，犹如父子。人寿极久，不可量计。后有余王，不行正法，其寿遂减至十千岁。如是渐减，至今百年。先于劫初，创始为王，展转相承。至菩萨身，罗候罗正嫡便绝余族，枝派今犹嗣位，故下广列传轮粟散，绍续之相也。

初民主王号曰大人，第二珍宝玉，乃至第三十三善思王。如上三十三王子子相承也，亦是粟散而已。次下并是转轮圣位，嫡嫡相承，至于菩萨。《楼炭经》云：“真阇王有一太子，名波迮迦，译云大鱼王也。”《佛本行经》云：“中天有城，名曰褒多那。人民繁炽，其中有帝，名大鱼王。”从此王乃至大名称王，有子孙相承苗裔计有八万四千二百七十二王，尽是金轮王。最后有二王，为阎浮提主，名茅草王。草王有太子，名大茅草王。大茅草王无子为王，作是念言：“我上祖代代相承，皆是金轮王之苗裔。我今无嗣，种姓将恐断绝。我若出家，恐断王种；若不出家，则断圣种。”思惟是已，则持国事付诸大臣，王乃入山修道，成五通仙，名曰王仙。此王仙先有夫人，名善袭，在宫有娠，后生一子，是大茅草王之苗裔也。后诸大臣知是王仙太子，遂则重册灌顶，绍承王位，号为遮王，又云郁魔王，亦曰懿摩王也。王有二妃。一名善贤，二名妙端正。妙端正者，生四太子，一名炬面，二名金色，三名象众，四名别成。善贤夫人唯生一子，名曰长寿，端严可喜，世间小双。唯无骨相，不堪绍位。善贤思维：“妙端正四子，炬面等辈，兄弟群族。我今唯此一子，虽然端正，不堪为王。作何方便，今我此子得绍王位？”

尔时，遮王驾车宫苑，安慰诸妃。善贤出来。启王言：“我种种安隐，唯有一愿，拟从王乞，愿王赐我。”王曰：“从心所欲，朕当与之。”善贤曰：“王不得变悔！请王设誓！”王言：“若变悔者，朕当破作七分。”善贤白太王曰：“炬面等四子，宜可摈出。”王言：“此四子无过，云何摈出？”

王良久思惟，为自设誓已不违愿故，遂判四子摈于他方。

时四王子白父王言：“我等四人不造余过，忽然摈我出国，何也？”王言：“知汝四子实无过失，不辜横遭如上所说。此非我心，善贤之意。”

时四童子所生庶母并眷属等闻此事已，疾至王所，白大王言：“我等四子奉王摈出，我愿随去。”王言；“宜依。”遮王有敕，续告四子：“若欲姻娉，莫婚他族，宜亲内姓，无令种姓断绝。”

此四童子敬王教敕，则领眷属面北而去。至含夷林，其中水土宽平，无诸坑阜。将诸眷属住此林中。福德盛故，遂成巨国。

后遮王思问群臣：“朕昔摈出四子，今在何方？”大臣奏曰：“今在香山之北，雪山之南。二山中间有林，名日含夷。地沃丰饶，人民炽盛，百姓归之，犹如廛市。郁成大国，册立为王，名尼拘罗城。古仙迦毗罗得道之处，因兹立城名也。”时遮王闻已，再三叹言：“我子释迦！我子释迦！”释迦者，译言能仁也。

大遮王三子已殁，唯有别成，号曰尼拘罗王，是佛祖祖。此王有太子，名曰拘卢王，是佛高祖。此王有太子，名曰瞿拘卢王，是佛曾祖。此王有太子，名曰师子颊王，是佛祖。此王有四太子，一名输头檀那，则净饭王。二名输拘卢檀那，则白饭王。三名途卢那，则斛饭王。四名阿弥都檀那。则甘露饭王。净饭王有二太子，一名悉达多，则是佛，四月八日生，身长丈六。二名难陀，则是逆风扫地者也，四月九日生，身长丈尺四寸。白饭王有二太子，一名调达，是佛当兄，四月七日生，身长丈五尺四寸。二名阿难，是佛侍者，四月十日生，身长丈五尺三寸。斛饭王有二太子，一名释摩男，捉土成金者，四月十二日生，身长丈四寸。甘露饭王有二太子，一名波投，出家竟，四月十三日生，身长丈四寸。二名跋提子，八道，四月十四日生，身长丈四寸。

《佛本行经》曰：“尔时，护明菩萨在兜率天上，心念欲化一切众生。遂敕金团天子：‘汝善观察诸王种族，则当为吾拣一生处。’金团天子奉菩萨敕为其观察。观察已竟，白菩萨言：‘有刹利种，姓瞿昙氏，刹利帝后。依瞿昙大仙学道，从师姓瞿昙氏。元本以来，世世为金轮王之种族，乃至遮王苗裔以来，子孙相承，住彼迳毗罗城，释种之所都也。其中有王，名师子颊王。此王有太子，名输头檀那王。今此王者，于一切世间天人之中有大名称，堪为菩萨托生之处。’菩萨叹曰：‘善哉！善哉！汝善观察诸王种姓，如汝所说，我定生彼。’”又《经》云：“护明菩萨欲降下时，摩耶夫人告净饭王言：‘大王当知，我今欲受八禁清净斋戒。’当斋戒已，遂则眠。于梦中见有一六牙白象，其首硃色，七支柱地，以金装牙。天人乘之，从空而下，赴净饭王宫。”

据《阿含经》曰：“推佛降神母胎，则当此土姬周第五帝昭王即位二十三年癸丑之岁七月十五日托阴摩耶。至二十四年甲寅之岁，摩耶夫人于毗罗苑中游戏快乐，见婆罗树花可爱，举右手攀枝，菩萨从右胁而诞生。身真金色，相好具足。”

又《普曜经》云：“佛初生时放大光明，照十方界。地涌金莲，自然捧足。东南西北，各行七步。观察四方，一手指天，一手指地，作师子吼：‘天上天下唯我独尊。’又偈曰：‘我生胎分尽，是最后末身。我已得解脱，当复度众生。’说此偈已，感九龙吐水，沐浴太子。大子浴已，默然不语，还同世间婴兒。”

又案《周异记》云：“昭王即位二十四年甲寅之岁，四月八日，江河泉池忽然泛涨，宫殿人舍、山川大地咸悉震动。其光有五色，贯入大微，遍于四方。昭王问大史苏由曰：‘是何祥也？’苏由奏曰：‘有大圣人生于西方。’又问：‘于天下如何？’由曰：‘则时无也。他一千年外声教被于此土。’”即是佛初生西天竺国迦毗罗城净饭王宫瑞应此土。

案《十二因缘经》云：“太子年登十九，厌皇后宫’。父王恐畏出家，遂敕箫韵，娱乐太子。太子不乐。坐至三更，五百宫人，悉皆得睡。净居太子时在虚空中，说偈告于太子：

世间不净众惑迷，无过妇人身体性。

世问衣服庄严故。愚痴是边生贪欲，

是人能做如是观，如梦如幻非真实。

速舍无明勿放逸，心得解脱功德身。

又天人于窗牖中叉手白太子言：“时可去矣。”太子闻此偈已，心生欢喜。潜命车匿鞁健陟来。四神捧足逾城，西北而去。太子念言：“夫出家者具大慈悲，不留马迹，王必罪于门人。”则于城西北角留一马迹，令知腾空西北而去。时当此土周昭王四十二年壬申之岁二月八日夜半也。

案《律》云：“太子去已，至摩竭陀国斑荼山中，于其石上结跏趺坐。作是念言：以何物剃除鬓发？”才起此念，净居天子便捧刀。太子自把，剃鬓发已，净居天子更捧缦僧伽梨衣，便脱旧日所著衣服，并脱头冠白马等付与车匿，将还王宫，并说偈言辞父王曰：

假便恩爱久共处，时至命尽会别离。

见此无常须臾间，是故我今求解脱。

尔时太子在于山中勇猛精进，修无上道。又诣阿蓝迦蓝处。三年学不用处定，知非便舍。复至郁头蓝弗处，一年学非想非非想定，知非亦舍。又至象头山，同诸外道日食麻麦，经于六年。苦行将满，则于尼连阿浴。苦行日久，就岸稍难，追成仙人挽低树枝，接于太子。

又《因果经》云：“浴已。‘我若以羸劣之身而取道者，外道言自饿则是涅盘，故当受食。’太子才起此念时，有难陀波罗奈姊妹二人捧上乳糜，太子又自念言：‘当将何器而为受食？’才起此念时，四天王各捧石钵。其时，菩萨为平等故，并总受之。息贪欲故，按成一钵以受乳糜。食充色力，欲诣正觉山。

准《本行经》云：“太子思念：‘当用何物而坐？应须净草。’才起此念，路上遇刈草人，名日吉安。太子语曰：‘此草可能惠施小许？不为爱惜？’吉安则授与。逦迤而去，至正觉山。为太子德重故，其山震动，山神出现，语太子曰：‘此非成道处。’太子问曰：‘何方堪耶？’山神曰：‘从此去，摩竭提国东一十六里有金刚座，贤劫千佛皆升此座，成等正觉。宜当往彼。’”

尔时太子遂则下山，遇一盲龙。盲龙语太子曰：“菩萨欲求成道处也。”太子问：“汝何知我菩萨？”盲龙曰：“我昔于毗婆尸佛时，为恶性比丘，毁骂王宝，遂垄龙中，兼盲其目。过去三佛出世，我眼则开，灭后还闭。今见汝身，令我眼开，故知汝是菩萨。”则引太子诣金刚座，以草敷上，遂升此座。太子发弘愿言：“我若不成无上菩提，誓不起于此座！”而成正觉，号之为佛。故《普曜经》云：“菩萨于二月八日明星出时大悟，便造偈曰：

因星得悟，悟后非星。

不随于物，不是无情。

时当此土周第六帝穆王三年癸末之岁二月八日成道，因此三十成道也。”

尔时释迦如来成道竟，示众曰：“夫出家沙门者，断欲去爱，识自心源；达佛本理，悟无为法；内无所得；外无所求；心不系道，亦不业结；无念无作；非修非证；不历诸位，而自崇敬，名之为道。”有一比丘问：“如何是清净本性？”佛言：“毕竟净故”。“如何是本性无知？”佛言：“诸法钝故。”外道问佛：“不问有言，不问无言。”佛乃良久。外道作礼赞曰：“善哉！善哉！世尊有如是大慈大悲，开我迷云，令我得入。”外道去后，阿难问佛：“外道以何所证而言得入？”佛言：“如世间良马，见鞭影而行。”如是说法，住世四十九年。后于拘尸那城熙连河侧娑罗双树间入于涅盘，寿龄当七十九矣。时周穆王五十二年壬申之岁二月十五日，暴风忽起，飘损人含，伤折树木。山河大地，悉皆震动。西方有白虹十二道，通过此土，连夜不灭，当此之时，则佛入涅盘之祥应。

又《涅盘经》云：“尔时世尊欲涅盘时，迦叶不在众会。佛告诸大弟子：‘迦叶来时，可令宣扬正法。’又云：‘吾有清净法眼。涅盘妙心、实相无相、微妙正法付嘱于汝，汝善护持。’并敕阿难嗣二传化，无令断绝，而说偈曰：

法本法无法，无法法亦法。

今付无法时，法法何曾法？

尔时，迦叶与五百弟子在耆阇崛山，身心寂然，入于三昧。于正受中倏然心惊，举身战栗。从定中出，见诸山地皆大振动，则知如来已入涅盘。告诸弟子：“我佛大师入于涅盘，经于七日，已入棺中。苦哉！苦哉！应当疾往至如来所。”恐荼毗不得见佛，以敬佛故，不敢飞空往如来所，则将弟子寻路疾行，悲哀速往。正满七日，至拘尸城荼毗所。问大众言：“如何得开大圣金棺？”大众答曰：“佛入涅盘，已经二七。恐有损坏，如何得开？”迦叶言：“如来之身，金刚坚固，不可俎坏。德香芬馥，若啃檀山。”作是语已，涕泪交流，至佛棺所。尔时，如来大悲平等，为迦叶故，棺自然开，皆则解散，现出三十二相八十种好真金紫磨坚固之身。尔时，迦叶复重悲衷，与诸弟子绕佛七匝，长跪合掌，说偈哀难曰：

苦哉苦哉大圣尊，我今荼毒苦切心。

世尊灭度一何速，大悲不能留待我。

我于崛山禅定中，遍观如来悉不见。

又观见佛已涅盘，倏然心战大振惊。

忽见暗云遍世界，复睹山地大振动。

则知如来已涅盘，故我疾来已不见。

世尊大悲不普我，令我不见佛涅盘。

不蒙一言相教告，令我孤露何所依？

世尊我今大苦痛，情乱迷闷昏浊心。

我今为礼世尊顶，为复哀礼如来胸？

为复敬礼大圣手，为复悲礼如来腰？

为复敬礼如来脐？为复深心礼佛足？

何故不见佛涅盘？唯愿示我敬礼处。

如来在世众安乐，今入涅盘皆大苦。

哀哉衷哉深大苦，大悲示教所礼处。

尔时迦叶说是偈已，世尊大悲，则现二足；千辐轮相出于棺外，回示迦叶。从千辐轮放干光明，远照十方一切世界。尔时迦叶与诸弟子见佛足已，一时礼拜。千辐轮相大觉世尊金刚双足还自入棺，封闭如故。尔时如来以大悲力从心胸中火涌棺外，渐渐荼毗，经于七日，焚妙香薪，尔乃方尽。佛力威神，内外白执\衣而无损也。此有二表：外一重白执\衣不损者，表俗谛存焉，内一重白执\衣不损者，表真谛不坏也。

自如来入涅盘壬申之岁，至今唐保大十年壬子岁，得一千九百一十二年。教流汉土，迄今壬子岁，凡经八百八十六年矣。

祖堂卷一·迦叶

第一祖大迦叶尊者，摩竭国人也。姓婆罗门，父名饮泽，母字香志。与瓶沙王竞富，唯让一犁；共摩竭以争饶，更逾千倍。积长者之贝玉，祈请树神；获贪女之金珠，庄严塔像。载诞金光之子，结成金色之妻。果合前缘，深扶宿愿。虽为贵偶，乃无欲情。欲求出家，泽志听许。便投世尊，发弘誓愿。上法受戒，清贞守素。无爱无欲；常行头陀。世尊在日，命坐付衣，常于众中称叹第一。

尔时大迦叶告诸比丘曰：“佛已荼毗，金刚舍利，非我等事。何以故？自有国王大臣长者居士求最胜福田者，自当供养。我等宜当结集法宝，无令断绝，为未来世作大照明，绍隆正法。”

尔时迦叶作大神通，往须弥顶而说偈曰：

如来诸弟子，且莫般涅盘。

若得神通者，当赴于结集。

说是偈已，则击挝铜。挝铜之中而传此偈，声遍三千大世界。得神通者，悉皆赴集。圣众既惊，遂拣内闲三藏、外达五明、足满六通、智圆四辨者。其数四百九十有九，悉集王舍城耆阇崛山宾钵罗窟，此云七叶岩。

尔时阿难为漏未尽，当被跋阇比丘有他心智，则便观察知：“阿难兄有欲漏故，未及众圣，不得入会。”时阿难比丘当自念言：“我事如来亦无缺犯，为自有漏，不及众数。”思惟是事，晓夜经行。明相出时，身体疲极。兼卧之次，头未至枕，得证果位。心生欢喜，则往宾钵罗窟，击其石门。

尔时迦叶在于窟中问：“是何人敲我此户？”答言：“是佛侍者比丘阿难。”迦叶语曰：“汝漏未尽，不得入来。”阿难答言：“我已证无漏。”迦叶报言：“汝既证无漏，可现神变以遣众疑。”尔时阿难则骋神通，从钥孔入，得在众会，添数五百。

案《育王经》云：“迦叶告阿庠世王：‘我今欲集如来三藏。愿大王为我檀越。”王言：“愿大圣集如来三藏，无有遗余，不舍慈悲，受我供养。”

阿庠世王为结集主时，诸比丘则从座起，谘问长老大迦叶：“于三藏中先集何藏？”迦叶语云：“当集修多罗藏。”迦叶白圣众言：“此阿难比丘多闻总持，有大智慧。常随如来，梵行清净。所闻佛法如水传器，无有遗余。佛所赞叹，聪敏第一。宜可请彼集修多罗藏。”大众默然允之。

迦叶告阿难曰：“汝于今者宜宣法宝。”阿难躬受敬诺，观察圣心而说偈曰：

比丘诸眷属，离佛不庄严。

犹如虚空中，众星之无月。

说是偈已，礼众圣足，则升法座。

案《七事记》云：“尔时阿难当升座已，尊诸相好，现身如佛。众见此瑞，则生三疑。一谓大师慈悲故，从涅盘起，为我等辈宣甚深法。二谓他方诸佛知我释迦奄化故，而来此中宣扬妙法。三谓阿难转身成佛，为众说法耶？尔时阿难而说是言：‘如是我闻，一时佛住某城某处，说某经教，乃至人天等作礼奉行。’阿难则下法座，却复本身。诸菩萨等知是世尊加被，众疑悉遣。时迦叶问诸比丘：‘阿难所言不错谬乎？’诸比丘皆云：‘不异世尊所说。’于是迦叶请优波离集毗尼藏，次命迦旃延集阿毗昙藏，迦叶则入愿智三味。观所集法藏，皆无欠少。因兹流布而不断绝。”

阿庠世王忏悔经有三种阿难。一阿难陀，此云庆喜，持声闻法藏，于上二乘随力随分。二阿难陀跋罗，此云庆喜贤，持中乘法藏，于上大乘随力随分；于下小乘客与兼持。三名阿难陀婆伽罗，此云庆喜海，持菩萨大乘法藏，于下二乘容与兼持。

又台教中有四阿难。何等为四？一者庆喜阿难，结集藏教。二者贤阿难，结集通教。三者典藏阿难，结集别教。四者海阿难，结集圆教。论其本也，唯一金龙尊佛；语其边也，分四阿难弟子。

梵语阿难，此翻无染。阿者无也，难者染也。论此无染，亦分为二。一者断除烦恼，名为无染。二者出离修证，名为无染。断除烦恼无染是名传教阿难，出说修证无染是名传禅阿难矣。

阿难问师：“传佛金蝠外，别传个什摩？”师唤阿难，阿难应喏。师曰：“倒却门前刹竿著！”

阿庠世王请师说法，师受请升座，良久乃下。王问师：“何故不为弟子说？”师云：“大王位崇名重。”

迦叶尊者阐一乘而利物，弘二教以度人。实得他心，终无我想。说法住世四十五年，度无量众。乃告阿难言：“如来正法眼付嘱于我，我今年迈，持佛僧伽犁衣入鸡足山，待慈氏一生。汝受佛嘱，弘扬正法，勿令断绝。听吾偈曰：

法法本来法，无法无非法。

何于一法中，有法有非法。

尔时迦叶说是偈已，遂入王舍城，等阿庠世王。王寝不遇，留言付于门者，令奏王知云：“吾当往鸡足山矣。”准《西域记》云：“此山三峰，如仰鸡足”，故因此立号也。

迦叶尊者于此山上以草敷坐，结跏而已，作是念言：“今我此身著佛所与粪扫之衣及持僧伽梨等，经于五十七俱低，六十百千岁，慈氏佛出世，不令其朽坏。”作是念已，遂语山曰：“若阿庠世王与阿难来，山当为开，令其得入。若归去后，复当还合。”言讫，便入灭尽定，应时大地六种震动。

尔时阿庠世王于睡梦中见殿梁折，遂则惊觉。时执扃之使奏王知云：“大迦叶辞王，往鸡足山，欲入涅盘。过王殿寝，未敢奏闻。”王闻此语，遂生悲泣。云：“朕何薄佑！诸圣涅盘，不得睹见。”则诣竹园精会，礼阿难足，借问迦叶所在。遂命阿难同往鸡足。王到山已，山自开辟，迦叶在中，全身不散。王乃敕诸力士积诸香薪，欲庠维之。阿难白大王曰：“摩诃迦叶以定持身。待于弥勒下生，捧付僧伽梨竟，方入涅盘。如今切不可焚也！”王闻是语，以种种供养，心生悲恋，然后礼辞定身。却命阿难入于王舍城。阿庠世王与阿难才出此山，山合如故。

师入灭时，当此土周第八主孝王五年丙辰岁矣。净修禅师赞曰：

伟哉迦叶，密传佛心。

身衣一纳，口海千寻。

威仪庠序，化导幽深。

未逢慈氏，且定鸡岑。

祖堂卷一·阿难

第二祖阿难尊者，王舍城人也。姓刹利帝，白饭王子，是佛之当弟也。本是金龙尊佛，今为如来所化。建立法幢，度六万众；高悬佛日，大照迷徒。博达总持，多闻第一。师巡游往至一竹林之间，闻一比丘错念佛偈曰：

若人生百岁，不见水潦涸。

不如生一日，而得睹见之。

阿难闻已，嗟叹曰：

世间一凡有，不解诸佛意。

徒载四围陀，不如空身睡。

阿难叹已，语比丘曰：“此非佛语。如今当听我演佛偈。”曰：

若人生百岁，不会诸佛机。

未若生一日，而得决了之。〔具如《宝林传》所说也〕

尔时阿难告商那和修言：“如来正法眼付嘱于我，我今付汝。当弘吾教，无令断绝。”复谓末田底曰：“佛预记汝：吾灭度后，罽宾国中一百二十年有一比丘，名末田底，流布佛法。”

尔时商那和修与禾田底同师阿难。末田底无弟子，商那和修有一弟子，名优婆纺多，西国罗汉宗首。

尔时阿难付法偈曰：

本来付有法，付了言无法。

各各既自悟，悟了无无法。

师付法已，踊身处空，作十八变，入风轮奋迅三昧。分身四分，一分奉叨利天，一分奉沙竭罗龙王，一分奉毗舍离王，一分奉阿庠世王。各起宝塔供养。

阿难入灭时，当此土周第十主厉王十二年癸巳岁矣。净修禅师赞曰：

多闻庆喜，高建法幢。

传佛金偈，继祖银钅工。

慈悲第一，智慧无双。

饮光后嘱，月印秋江。

祖堂卷一·商那和修

第三祖商那和修尊者，亦名商诺迦，是西天自然九枝秀草名也，摩突罗国人也。姓毗舍多，父名林胜，母字娇奢耶。在母胎中六年始生。寻后出家，身衣自然化成九条。得庆喜之法，广度群生，大作明灯。乃云：“佛记：‘吾灭度后二百年中，圣者继我，则入三昧观见。’吒利国中有长者子，名日善意而姓首陀。后生三子，少者出家，当续于我，大兴吾教。吾当以小神通至于彼国，不将徒众而自往之。”长者作礼问：“尊者远至，有何所须？”答曰：“我无伴侣，孑然一身。欲命徒侣而归佛道。”长者曰：“我乐世俗，不能出家。若复生子，当给于汝。”师云：“善哉！善哉！”言已，则归本座。

时长者寻后果生三子。前二子不愿出家，第三子名优婆纺多，年十七。尔时和修告父而曰：“佛记此子云：‘吾灭度后二百年中，当第四师而度筹众。’”父闻佛记，则奉尊者，任其出家。师乃问纺多曰：“汝年几岁耶？”子曰：“年十七岁也。”师曰：“汝十七岁，姓十七岁耶？”子曰：“性非十七岁。”子曰：“姓非十七岁。”子白师曰：“为心白耶，为头白耶？”师曰：“此白是发，非心头也。”子曰：“身自十七岁，非姓尔也。”在师左右三四年间，出家具戒，便证圣果。

尔时商那和修告纺多言：“如来以大法眼付嘱迦叶，如是展转，乃至于我。我今付嘱于汝。听吾偈曰：

非法亦非心，无心亦无法。

说是心法时，是法非心法。〔具如《宝林传》所说也。〕

自商那和修灭度时，当姬周第十一主宣二十三年乙未岁矣。净修禅师偈曰：

胎衣尊者，暗室明灯。

人天耳目，佛法股肱。

非心非色，不灭不增。

良哉至圣，觉海大鹏。

祖堂卷一·优婆纺多

第四祖扰婆纺多尊者，吒利国人。其姓首陀。佛记：“于禅祖中当其第四。化度群品，如我今日。贤劫之中当得成佛，名无相好如来。”十七出家，二十成道。随方行化，至摩突罗国，大众云集。半月说法，天花时降，地神腰现。而听法故，尽获解脱。〔具如《宝林传》所说也〕

尔时纺多尊者，凡度一人，抛下一筹。筹长四寸，满一石室。室高丈六，纵广亦然。其后度者名曰提多迦，志求出家。师问曰：“为心出家耶，为身出家耶？”子曰：“我来出家，非为身心而求利益。”师云：“不为身心，复谁出家？”子曰：“夫出家者无我之故，无我之故心不生灭，心不生灭则是常故，既是常故诸佛亦常。心无形相，其体亦尔。”师云：“汝当大悟。心自明朗，依佛法中度恆沙众。”

尔时纺多尊者曰：“我今将此法眼付嘱于汝，汝可流布，无令断绝。汝今当听吾说偈曰：

心自本来心，本心非有法。

有法有本心，非心非本法。

纺多尊者付嘱法已，即入涅盘。尔时提多迦取石室筹，积之焚烧。拾取舍利，竖塔供养。时当此土姬周第十三主平王三十一年庚子之岁矣。净修禅师赞曰：

优波纺多，辩泻悬河。

法山峥崪，道树婆娑。

筹盈石室，尸系天魔。

性非十七，悟在刹那。

祖堂卷一·提多迦

第五祖提多迦尊者，摩迦陀国人也。在舍，父梦金日从屋而出，放大光明，照一宝山，山顶有泉。初名香众，因父梦故，号提多迦，译云通真量。

纺多云：“如来记汝，吾灭度后一百年中，必有一子而证道果。”又为师解：其父梦宝山者，吾身是也；出光明者，汝智慧也；从屋而出者，入道也；山顶泉者，无上法味也。提多迦闻纺多解梦，心目忻庆而说偈曰：

巍巍七宝山，常出智慧泉。

回为真法味，能度诸有缘。

纺多尊者以偈答曰：

我法传于汝，当现大智慧。

金日从屋出，照曜于天地。

尔时提多迦闻纺多偈已，合掌瞻颜。既得付法，游历诸土而度群品。〔俱如《宝林传》所说也。〕

尔时弥遮迦，八千仙中主，欲求出家。尔时提多伽告曰：“汝欲出家，各应自念，非假刀剃。随所念故，鬓发自净；深敬佛故，衣生袈裟而变檀相。”时诸仙人各自念佛，心生敬慕，鬓发自净，袈裟生体。心不退转，尽获圣果。

尔时提多迦告弥遮迦曰：“如来以正法眼付嘱迦叶，如是展转，乃至于我。我今将此法眼付嘱于汝。听吾偈曰：

通达本法心，无法无非法。

悟了同未悟，无心得无法。

师说偈已，化火三昧而烬其体。弟子弥遮迦收得舍利，斑荼山中起塔供善，时当此土姬周第十五主庄王七年已丑岁矣。净修禅师赞曰：

多迦大师，无我出家。

了根达境，免却空花。

体非形相，理出齿牙。

随方利物，岂有匏瓜。

祖堂卷一·弥遮迦

第六祖尔远迦尊者，中印土人，得提多迦法。〔俱如传中〕

尔时弥遮迦得法已，游历行化。众中有一人，名波须密，欲求出家。尔时提多迦尊者曰：“佛在世时，至北天竺而请阿难曰：‘此国土中，吾灭度后三百年末，有一圣者当出于世。姓波罗随，名婆须密。于诸祖中当其第七。’佛之记汝，非我所知。汝可出家舍除触器，合证圣果。”时婆须密弃其酒器，合掌作礼，深自觉知：“我昔曾于无量劫中而施宝座于第七佛。与我授记，于贤劫中当得作佛，于禅祖中当得第七。如尊所说，深达昔缘，如寤所睹。尊者大慈，愿接引我。”

时弥遮迦则为出家，而受佛戒。所作已办，深自知之。乃命付法而说偈言：

无心无可得，说得无名法。

若了心非心，始解心心法。

师入灭度时，当此土姬周第十八主襄王十七年丙申岁矣。净修禅师偈曰：

弥遮迦祖，习五通仙。

遇师法正，省我心偏。

悟如来悟，玄之又玄。

神通示灭，八部潸然。

祖堂卷一·婆须密

第七祖婆须密尊者，北天竺国人也。得弥遮迦法已，而自行化，度诸有情。至迦摩罗国，大作佛事。于此座前，有大智者而称佛陀难提，问师曰：“解论义不？”师曰：“论则不义，义则不论。若拟论义，终非论义。”佛施难提闻师论义，心则敬伏，而求出家。师则纳受，具戒证果。乃命付法而说偈曰：

心同虚空界，示等虚空法。

证得虚空时，无是无非法。〔具如本传。〕

自波须密入定时，当此土姬周第二十一王定王十九年辛未岁矣。净修禅师赞曰：

祖婆须密，入弥遮室。

迷悟本如，物我冥一。

手携酒器，顶擎佛日。

异是奚非？谁得谁失？

祖堂卷一·佛陀难提

第八祖佛陀难提尊者，迦摩罗国人，姓瞿昙波。当生之时，顶上有珠，珠光照曜。年至四十，遇婆须密而得出家，使证圣果，游行化导。至提迦国，而有一人名伏驮密多，而问师曰：“父母非我亲，谁为最亲者？诸佛非我道，谁为最道者？”师曰：

汝言与心亲，父母非可比。

汝行与道合，诸佛心即是。

外求有相佛，与法不相似。

若识汝本心，非合亦非离。

尔时伏驮密多得闻尊者说是妙法，则五体投地，深作敬礼。尔时尊者则与出家，而命贤圣受具足戒。

尔时佛陀难提告伏驮密多曰：“如来以大法眼付嘱迦叶，如是展转，吾当第八。汝受法宝，勿令断绝。听吾偈言：

虚空无内外，心法亦如是。

若了虚空故，是达真如理。〔具如本传。〕

师入灭时，当此土姬周第二十四主景王十二年丙寅岁矣。净修禅师赞曰：

佛陀难提，大化群迷。

心无内外，法离高低。

五天论将，三界云梯。

卓然真气，南北东西。

祖堂卷一·伏陀密多

第九祖伏驮密多尊者，提迦国人，姓毗舍罗。〔具如本传〕。得佛陀难提法已，至中印国，大作佛事，导化群品，百千人俱。有一长者名曰香盖，家有一子，号难生，依师出家。尔时师既受已，勤苦修行，胁不至席，因兹立号，名胁尊者。

尔时伏驮密多告比丘难生曰：“如来以大法眼付嘱迦叶，展转相传，至今于我。我将此法付嘱于汝，汝善护持，无令断绝。汝受吾教而听偈曰：

真理本无名，因名现真理。

领得真实法，非真亦非伪。

师说偈已，默然入定。诸天散花，而供养之。时胁尊者则以香薪用阇维之，收得舍利，建塔供养。时当此土姬周第二十六主敬王三十五年甲寅岁矣。净修禅师赞曰：

伏驮密多，大器晚成。

五十不语，五十不行。

俄逢大士，倏契无生。

崖松有操，锾鹗无程。

祖堂卷一·胁尊者

第十祖胁尊者，中印国人也。得伏驮密多法，广化群迷。至花氏国，有一长者名曰宝身，而有七子。第七子名富那耶奢，礼师白言：“我今欲出家，尊者当济度。”尔时尊者则为出家，具戒证果。乃命付法而说偈曰：

真体自然真，因真说有理。

获得真真法，无行亦无止。

师付法已，火化三昧而自焚身。耶奢尊者收拾舍利，竖塔供养，时当此土姬周第二十八主贞王二十二年癸亥岁矣。净修禅师赞曰：

胁大尊者，爱憎网矽。

量等虚空，道唯萧洒。

真体自然，因真舒写。

约世苍茫，奔腾意马。

祖堂卷一·富那耶奢

第十一祖富那耶奢尊者，花氏国人也。姓瞿昙，兄弟七人，而处最幼。心明博达，无诸所求。得付法已，广宣流布，次第游化。又至一城，名波罗奈。遇一长者名马鸣，问师曰：“我欲识佛，何者即是？”师曰：“汝欲识佛，不识者是。”马鸣曰：“佛既不识，争知是乎？”师曰：“汝既不识，争知不是？”马鸣曰：“此是锯义。”师曰：“彼是木义。”师和问：“锯义者何？”马鸣曰：“共师并出。”马鸣却问：“云何木义？”师曰：“汝被我解。”

尔时马鸣闻师胜义，心即欢喜，而求出家。〔俱如传中。〕

尔时富那耶奢告马鸣曰：“我今将此正法眼藏付嘱于汝。汝可流布，勿令断绝。”而说偈曰：

迷悟如隐显，明暗不相离。

今付隐显法，非一亦非二。

时马鸣闻师说偈，心大庆悦。师付法已，则现神通，飞行自在。却至本座，而入寂定。时当此土姬周第三十三主安王十四年戊戍岁矣。净修禅师赞曰：

富那夜师，智若须弥。

心捐去住，身外荣衰。

明暗隐显，视听希夷。

现前提取，更莫参差。

祖堂卷一·马鸣

第十二祖马鸣尊者，波罗奈国人。〔具如本传〕尔时马鸣告毗罗曰：我今将此法眼藏付嘱于汝，汝可流布，无令断绝，而听偈曰：

隐显即本法，明暗元无贰。

今付悟了法，非取亦非弃。

师入大寂时，当此土姬周三十五帝显王二十七年甲午岁矣。净修禅师赞曰：

尊者马鸣，化花氏城。

魔宫雾卷，释苑风清。

我欲识佛，不识者明。

莫非玄解，动足尘生。

祖堂卷一·毗罗

第十三组毗罗尊者，花氏国人。〔俱如本传〕尔时毗罗告龙树曰：我今将此正法眼藏用付于汝，汝当护持，勿令断绝。而听偈言：

非隐非显法，说是真实际。

悟此隐显法，非愚亦非智。

毗罗入灭时，当此土姬周三十七帝赧王四十一年壬辰岁。净修禅师赞曰：

毗罗大圣，因地魔王。

凭师指教，豁证真常。

胡为愚智，讵是讵长。

德馨兰慧，性净冰霜。

祖堂卷一·龙树

第十四祖龙树尊者，西天竺人。具如本传。

尔时龙树告提婆曰：“我今将此正法眼藏用付于汝，汝当受教。听吾偈曰：

为明隐显法，方说解脱理。

于法心不证，无嗔亦无喜。

龙树尊者寂然入定时，当此土秦第二帝始皇三十五年巳五岁矣。净修禅师赞曰：

菩萨龙树，化龙是务。

心晓佛心，住而非住。

身显圆月，法流膏雨。

提婆投机，就谙旨趣。

祖堂卷一·迦那提婆

第十五祖迦那提婆尊者，南印土人，姓毗舍罗。〔具如传中。〕尔时提婆尊者告罗侯罗多曰：“我今将此正法眼藏用付于汝，汝宜传受，无令断绝。而听偈言：

本对传法人，为谈解脱理。

于法实无证，无终复无始。

此师灭度时，当此土前汉第四主文帝十九年庚辰岁矣。净修禅师赞曰：

迦那提婆，德岸弥高。

回旋香象，吹却金毛。

机迅岩电，辩泻秋涛。

始终绝证，勿误王刀。

祖堂卷一·罗侯罗

第十六格罗侯罗尊者，毗罗国人。姓梵摩，父名净德。〔俱如传中。〕

尔时僧伽难提而问师曰：“法有证不？有取舍不？有有无不？有内外不？愿尊者慈造而为解说。”尔时罗侯罗多以偈答曰：

于法实无证，不取亦不离。

法非有无相，内外云何起？

此师全身入定时，当此土前汉第六武帝十年戊辰岁矣。净修禅师赞曰：

罗侯道德，在口宁论？

因师说耳，寻得入门。

高提日月，大照乾坤。

不取不舍，传乎子孙。


祖堂集卷二

祖堂卷二·僧伽难提

第十七祖僧伽难提尊者，罗伐城人也。刹利姓，父名宝庄严，母名芬陀利。才生解语，分明晓了，为母说法。既得罗侯罗法，行化至摩竭国。见一童子，年当十二，手执铜镜，而来师所。师问曰：“子年几耶？”于曰：“我当百岁。”师曰：“汝当无智，看汝幼少。”答曰：“我年百岁，非其理也。”子曰：“我不会理，正当百岁。”师曰：“子善机也。”子曰：“佛偈云：‘若人生百岁，不会诸佛机，未若生一日，而得决了之。”时尊者敬之，深知是圣。

问曰：“汝执此镜，其意云何？”子曰：“诸佛大圆镜，内好无瑕翳。两人同得见，心眼皆相似。”

其舍父母，见子言异，则令出家。师为度脱，领诣古寺而为受戒，名曰伽耶舍多。于彼殿角，有一铜铃被风摇响。师曰：“彼风鸣耶，铜铃鸣耶？’子曰：“我心鸣耶，非风铜铃。”师曰：“非风铜铃，我心谁耶也？”子曰：“俱寂静故，岂非三昧？”师曰：“善哉，真比丘！善会诸佛理，善说真法要，善识诸佛义。”乃命付法，以偈告曰：

心地本无生，因种从缘起。

缘种不相妨，花果亦复然。

伽耶舍多闻师说揭，及受法藏，心生敬重，顶戴受持。师付法已，即离本座。至树下立。而举左手攀其树枝，寻则灭度。焚其舍利，则在树侧，不可移动。则就本处竖塔供养，诸天散花而雨宝衣，用散塔处。时当此土前汉第七主昭帝十年辛酉岁矣。净修禅师赞曰：

僧伽难提，庄严王子。

逾城九重，入山千里。

定俞井金，义班始终。

理屈于师，忽案自己。

祖堂卷二·伽耶舍多

第十八祖伽耶合多尊者，摩竭国人。姓郁头蓝，父名天盖，母名方圣。年至十二，得僧伽难提法。行化至月氏国，大作佛事。有一波罗门，名曰鸠摩罗多，心信外道，不爱佛法。师至波罗门家，为说大因缘，又为说父病因缘。于时波罗门闻师所说而生欢喜，欲求出家。师与出家，受具足戒，令证道果。乃命付法而说偈曰：

有种有心地，因缘能发萌。

于缘不相碍，当生生不生。

时鸠摩罗多闻师说偈，心生欢喜，当自安乐。师付法已，即从座起，踊身虚空作十八变，化火三昧，自焚其身。众拾舍利，起塔供养。时当此土前汉第十五主成帝十四年戊申岁矣。净修禅师赞曰：

伽耶舍多，幼会佛机。

手执宝镜，面难提师。

内外绝翳，眉目无亏。

风飘铎韵，非我是谁？

祖堂卷二·鸠摩罗多

第十九祖鸠摩罗多尊者，月氏国人也。初遇伽耶舍多，得法行化，时至北天。有一大士名阇夜多，而用油涂足。巡游诸国，遥见伽耶含多，作礼问：“我家父母心常供养，亦求佛道，未省是何因缘，长萦疾苦。又观邻舍常行凶杀，不乐修行，而无所患。此二事实未晓之，唯愿慈悲，为我解说！”尊者云：“业通三世，如影随形。积善余庆，积恶余殃。”闻说欢喜，志愿出家，乞师纳受。既摄受已，便获道果。师乃命付法，而说偈曰：

性上本无生，为对求人说。

于法既无得，何怀决不决？

师付法已，于座上以爪蛱面，各分两向。当此处分，有大光明。照大众已，寂然灭度。时当此土王莽则位十八年壬午岁矣。净修禅师赞曰：

鸠摩罗多，大常止檐。

蒙师为诀，委父无厌。

本非锻练，肯藉槌钳。

一榻孤坐，人天礼瞻。

祖堂卷二·庠夜多

第二十祖庠夜多尊者，北天竺国人也。得鸠摩罗多法已，行化至罗阅城，遇一头陀，名婆修盘头。六时礼佛，少欲知足；长坐不卧，一食而已。

尔时尊者问大众曰：“此头陀者，汝见如何？”众曰：“不可思议。常修梵行。长坐不卧，一食而已。”师曰：“此是道耶？”众曰：“诚如尊说。”师曰：“今此头陀不久当堕，与道悬远；心有所求，不名为道。”众曰：“师如何？”师曰：“我不求道，亦不颠倒；我不六礼，亦不轻慢；我不长坐，亦不懈怠；我不一食，亦不杂食；我不知足，亦不贪欲。”

尔时头陀闻师所说，心生欢喜。说偈赞曰：

稽首三昧尊，不求于佛道。

不礼亦不慢，心不生颠倒。

不坐不懈怠，但食无所好。

虽慢而不迟，虽急而不燥。

我今遇宝尊，和南依师教。

师见说偈已，师告曰：“如来以正法眼付嘱迦叶，如是展转，乃至于我。我今嘱汝，汝善护持，勿令断绝。听吾偈曰：

言下合无生，同于法界性。

若能如是解，通达事理竟。

师入灭时，当此土后汉第二主明帝十六年甲申岁矣。净修禅师赞曰：

阇夜多祖，格高貌古。

锡有六环，田无半亩。

言下不生，何处不普。

垂手入廛，他方此土。

祖堂卷二·婆修盘头

第二十一祖婆修盘头尊者，罗阅城人。姓毗舍导，父名光盖，母名严一。师得庠夜多法，行化至那提国。而共常自在王言论次，有一使者乃奏王曰：“百万象兵至于南面。”王曰：“此事非少，如何抵敌？”师曰：“大王莫愁，令第二太子摩喀罗轻喝一声。”大王则命太子喝。太子奉王教诏，即至城南。便举左手拍其腹上而喝一声，象兵倒地，不复更起。王见此事，深自叹许。愿师摄受，度脱出家，命圣受戒。尔时太子偈赞曰：

为摧百万象，鼓腹作神通。

一切诸宫殿，无不震动者。

遇师方便力，而得度脱我。

稽首父母辞，而出于爱火。

尔时尊者则须太子游行化导，建胜法幢。乃命付法，而说偈曰：

泡幻同无碍，如何不了悟。

达法在其中，非今亦非古。

师入定时，当此土后汉第五主炀帝九年丁已岁矣。净修禅师赞曰：

婆修盘头，修行不卧。

虽历辛勤，翻成懒惰。

因指见月，逢歌指和。

泡幻无真，虑情无过。

祖堂卷二·摩喀罗

第二十二祖摩喀罗尊者，那提国人。姓刹利帝，名大力尊。父名多满，亦名常自在。〔具如宝林传也。〕

尔时摩喀罗告鹤勒曰：“我令将此正法眼藏用付于汝，汝当守护，无令断绝，汝受吾教。”而说偈言：

心随万境转，转处实能幽。

随流认得性，无喜复无忧。

此师入灭时，当此土后汉第九主桓帝十八年乙已岁矣。净修禅师赞曰：

辩塔降象，自在王子。

雷震蛰门，邪师失齿。

神运六通，道风千里。

声色恆真，何须馈耳。

祖堂卷二·鹤勒

第二十祖鹤勒尊者，月氏国人。姓婆罗门，父名千胜，母号金光。〔具如《宝林传》也。〕

尔时鹤勒告师子曰：“我今将此正法眼藏用付于汝，汝善护持，外方行化。当国有难，刑在汝身。汝受吾教而听偈曰：

认得心性时，可说不思议。

了了无可得，得时不说知。

此师灭度时，当后汉第十一主献帝十九年巳五岁矣。净修禅师赞曰：

尊者鹤勒，上德不德。

任性纵横，发言奇特。

功高三仪，名喧万国。

稽首归依，祖林搴卜。

祖堂卷二·师子

第二十四祖师子尊者，中印土人。姓婆罗门。〔具如《宝林传》也。〕

尔时师子告婆余斯多曰：“如来以正法眼付嘱迦叶，如是展转，乃至于我。我持此法并僧伽梨衣嘱付于汝，汝当护持，无令断绝。而听偈言：

正说知见时，知见俱是心。

当心即知见，知见即于今。

此师还债时，当此土前魏第三主少帝已丑岁矣。净修禅师赞曰：

师子尊者，人天仰誉。

雪里松青，云间鹤翥。

论鼓才击，法轮高驭。

挫拉邪徒，悟真来去。

祖堂卷二·婆舍斯多

第二十五祖婆舍斯多尊者，潲宾国人。姓婆罗门，父名寂行，母号常安乐。夜梦神人手执宝剑付常安乐，因此有孕。满月产下，其子左手常拳似执物。从此出家，证果得法。行化至中天竺国，度化群迷。次第游行至南印土。有一国王，名曰得胜，常崇咒师，不信佛法。咒师奏王：“婆舍斯多不会佛法，请王试之。此人云圣，问其异事。若答不得，则非师子继承弟子。”大王有一太子，名不如密多，则向王曰：“今此尊者，先王供养，有大威德，不用试之。”王切齿呵责，则囚太子。王乃命师，师则赴命。王不令坐，当殿试语。问曰：“我国之中，无诸邪法。师所学者，当是何宗？”师曰：“此国之内，无诸邪法。我所学者，当是佛宗。”王曰：“佛灭度已千二百年，师今七十，当何得之？”师曰：“自释迦传教，历于二十四人。我今所学，当继师子尊者法。亦有信衣，名僧伽梨衣，现在囊中，取呈大王。”王虽见传法袈裟，心不敬信。则命左右以火验之，其火炽然，光明贯天，祥云覆地，而雨四花，异香气馥，火烬衣存。王睹斯瑞，方乃发心，求哀忏悔。〔此衣在于王宫起塔供养。〕

时太子被囚深宫，并不得食。乃云：“我为法故，今此饥渴，如何存济？”其时天降白乳入口，味如甘露，食了轻健。乃作是言：“我若出宫，则便出家。”王诏出宫，投师出家。师云：“汝欲出家，当为何事？”太子曰：“我所出家，不为其事。”师曰：“汝言不为，不为何事？”太子曰：“我所不为，不为俗事。”师云：“不为俗事，当为何事？”太子曰：“不为俗事，当为佛事。”师自念言：“如来以大悲力令此太子助作佛事。”在师左右出家具戒，便证道果。乃命付法，而说偈曰：

圣人说知见，当境无非是。

我今悟真性，无道亦非理。

此师入灭时，当此土东晋第一主元帝八年乙酉岁矣。净修禅师赞曰：

婆舍斯多，久离攀缘。

未逢作者，终不开拳。

传师衣钵，度物桥船。

当心妙见，岂假言宣。

祖堂卷二·不如密多

第二十六祖不如密多尊者，南印土国王太子，正名得胜。〔具如《宝林传》也〕

尔时不如密多告般若多罗曰：“我持此法用付于汝，汝善护持，勿令断绝，而听吾偈言：

真性心地藏，无头亦无尾。

应缘而化物，方便呼为智。

此师入灭时，当此土东晋第九主孝武帝戊子岁矣。净修禅师赞曰：

不如密多，胜王诞庆。

高远宫嫔，迥惇道行。

佛法栋梁，王臣瞻敬。

洞鉴媸妍，祖堂金镜。

祖堂卷二·般若多罗

第二十七祖般若多罗尊者，东印土人。姓婆罗门。父母俱丧，示化菩萨而作佛事。得不如密多法，行化至南天竺国。国王刹帝利，名香至。师因赴王斋次，诸圣尽转经，唯有师不转经。大王问师：“为什摩不转经？”师曰：“贫道出息不随众缘，入息不居蕴界，常转如是经，百千万亿卷，非但一卷。”尔时大王赐师一珠，光明耀然。〔具如《宝林传》也。〕是化般苦多罗告达摩曰：“我今将此正法眼藏用付于汝，而听吾偈曰：

心地生诸种，因事复因理。

果满菩提圆，花开世界起。

般若多罗化火焚身，时当此土宋第五王武帝孝建四年丁酉岁矣。净修禅师偈曰：

般若多罗，幼名璎珞。

父母沦亡，东西盘泊。

一晓龟毛，恆嗟水涸。

果满菩提，道源辽廓。

祖堂卷二·达摩

第二十八祖菩提达摩和尚，南天竺国香至大王第三太子也。得般若多罗法，般若多罗乃告曰：“汝今得法，亦莫远化，待吾灭后六十七年，当往震旦大施法药。汝勿速去，当有难起，衰于日下。”达摩问曰：‘我去彼国行化，有菩萨不？”师云：“彼国获道者如稻麻竹苇，不可称计。吾灭度后六十七年，各别著人，此国留难，水中文布，自善降之。汝至彼国，南方勿住，彼国天人不见佛理，好作有缘而爱功德。汝至彼国，则出不住。听吾谶曰：

路行跨水复逢羊，〔路行者，来也。跨水者，过海也。复逢羊者，洛阳也。达摩大师从南天竺国过海而来。初到广州，次普通八年丁末岁入梁国。

独自换换暗渡江。〔独自者，无伴侣也。换换者，若换也。暗渡江者，梁武帝不悟大理，变容不言，师知机不契，则潜过江，向北魏也。〕

日下可怜双象马，〔日下者，京都也。可怜者，好。双象马者，志公傅大士也。〕

两株嫩桂久昌昌。〔两株者，二木也。二木是林字也。嫩桂老，少也，则是少林寺也。久昌昌者，几年面壁而出大行佛法也。〕

达摩又问师：“此后更有难不？”师云：“吾灭度后一百五年而有小难，听吾谶曰：

心中虽吉外头凶，〔心中者，周字也。外头凶者，周王无道灭佛法也。〕

川下僧房名不中。〔川下僧房者，俗号僧房为邑，川下邑为邕字也。后周文帝姓宇文，名秦邕。不中者，后周沙汰灭佛法。〕

为遇毒龙生武子，〔毒龙者，武帝父王也，生武子者，生武帝也。〕

忽逢小鼠寂无穷。〔小鼠者，庚子也，周武帝庚子崩寂。无穷者，尽灭无也。〕

又问：“此后更有难不？”师云：“吾灭度后一百六年有小难，父子相连，亦当不久，作一二三五岁。当此事过，以有人见其意，吾不能明。略与谶曰：

路上忽逢深处水，〔路上者，李字也。深水者，渊字也。唐高祖神尧皇帝，姓李名渊也。〕

等闲见虎又逢猪。〔等闲见虎者，寅也。唐高祖戊寅年登位也。又逢猪者，亥也。高祖丁亥年崩。〕

小小牛兒虽有角，〔小小牛兒者，高祖武德四年九月日，有前道士太史今博奕，先是黄巾党，其所习遂上表底佛法，事十有一条，大略而云：“释经是损国破家，未开益世。请胡佛邪教退还天竺。凡是沙门放归桑梓，则国家昌泰，李孔教行矣。”高祖纳奕奏书，乃下诏问诸沙门曰：“弃父母鬓发。去君臣花服，利在何间？益在何情？损益二宜，请动妙释。”时有琳法师上表得延五年。高祖崩，太宗即位，再兴佛法矣。具如别传。言半角者，正当挃触而无害即是。〕

清溪龙出总须输。〔清溪者，山名也。龙者，琳法师护法之龙，能令博奕竽邪见之徒总须伏也。〕

又问师：“于此后有圣人出不？”师云：“林下见有一人，当得于道，亦契菩提。听吾谶曰：

震旦虽阔无别路，〔震旦者，唐国也。无别路者，唯有一心之法，让大师化等如此也。〕

要假侄孙脚下行。〔侄孙者，今时传法弟子也。〕

金鸡解衔一颗米，〔金鸡者，金州也。让师是金州人也。一颗米者，意取道一，江西马祖名道一。〕

供养十方罗汉僧。〔让和尚付法与道一，故言供养。十方者，马和尚是汉州十方县罗汉寺出家也。〕

达摩大师同学兄名佛大先，此佛大先是佛驮跋陀罗三藏之弟子。佛驮跋陀罗复有弟子名那连耶舍，于南天大化，后来此土东魏高欢鄴都，与五戒优婆塞万天懿译出《梵本尊胜经》一部。万天懿问：“彼天有菩萨传教不？”那连耶舍答曰：“西天诸祖二十七师悉说此法，名般若多罗。亦有弟子，名菩提达摩。至此土后魏第八帝讳詡大和十年，至于洛阳少林寺化导，至九年示灭，经于一十五年矣。”又问：“此师后有人能继不？”三藏谶曰：

尊胜今藏古，〔尊胜者，妙智也。古者，可大师。本有妙高之性，性被恼覆云，未现了，故言藏也。〕

无肱亦有肱。〔肱者，手也。可大师求法断臂也。〕

龙来方受宝，〔龙来者。初祖西来也。方受实者，二祖传法。〕

捧物复嫌名。〔棒者，惠也。本名神光，复居达摩，嫌之改名，言为写〕

又问：“此后谁当继此耶？”三藏谶曰：

初首不称名，〔后周第三主已卯之岁，有一居士不说年岁，不称姓名，故言不称名。〕

风狂又有声。〔风狂者，三相有风病。有声者，远近皆知有病，故言有声也。〕

人来不喜见，〔人来不喜见患风之形状。〕

白宝初平平。〔白宝者，玉也。玉边作祭，璨也。三祖名璨大师。〕

又问：“此师后更有人断不？”又谶曰：

起自求无碍，〔有一沙弥年十四，名道信。来礼拜问：“唯愿和尚教某甲解脱法门。”故言求无碍。〕

师传我没绳。〔师者，三祖也。我没绳者，既无人缚汝，即是解脱。〕

路上逢僧礼，〔路上者，道也。礼者，信也。四祖大师名道信。〕

脚下六枝分。〔脚下者，门下也。四祖下横出一宗。六枝者，牛头、融禅师等六祖。〕

又问：“此师后更有人继不？”三藏又谶曰：

三四全无我，〔三四者，七也。五祖七岁遇道信大师。无人我出家也。〕

隔水受心灯。〔隔水者，五祖于新州蕲水郡得传四祖心印，故言受心灯。〕

尊号过诸量，〔过量者，弘字也。〕

逢嗔不起憎。〔不起者，忍字也。〕

又问：‘此师后谁能继之？”三藏又谶曰：

捧物何曾捧，〔捧者，惠字。〕

言阖又不阖。〔阖者，能也。六祖名能。〕

唯书四句偈。〔唯书四句偈者，神秀和尚呈四句偈，惠能和尚亦呈四句个，故言四句偈。〕

将对瑞田人。〔瑞田人者，神秀和尚东阳嘉禾县瑞田人。〕

又问：“此师后明其法者能继之不？”三藏又谶曰：

心里能藏事，〔能藏者，怀；则怀让也。〕

说向汉江滨。〔说向者，说法也。汉江滨者，马大师汉州人也。马大师求佛心印，让和尚说向道一也。〕

湖波探水月，〔湖波者，曹溪也。探水月者，得也。让大师于六祖身边得传心印。〕

将照二三人。〔二三者，六。让大师传法弟子六人。言六人者，一道一得心，二智达得眼，三常浩得眉，四神照得鼻，五坦然得耳，六严峻得舌。是为六人也。〕

三藏又谶曰：

领得殷勤语，〔领得者，马大师于让大师处领悟也。〕

离乡日日敷。〔离乡者，南方也。日日者，昌字也。敷者，演也。马大师归至洪州南昌寺敷演大教是也。〕

移梁来近路，〔移梁者，梁都也。近路者，洪州观察使姓路，送请大师自虔州南庚县移入洪州开元寺，故言来近路。〕

余算脚天徒。〔余者，我字也。从马大师二十年外，有契道者千万，遍行天下。故言脚天徒。〕

三藏又谶曰：

艮地生玄旨，〔艮地者，车北也。神秀和尚从五祖下，傅一枝法在北，自为立宗旨也。〕

通尊媚亦尊。〔通尊者，谥号大通禅师也。媚者，秀也。亦尊者，三帝所尊敬，故亦尊也。〕

比肩三九族，〔比后者，同学也。三九族者，十二人也。秀大师同学十二人。〕

足下一有分。〔从秀和尚足下各分宗旨，南北有异。〕

三藏又谶曰：

灵集愧天恩，〔灵者，神；集者，会也；愧者，荷也；天恩者，泽也。神会大师住洛京荷泽寺。〕

生互二六人。〔生互者，师资也。二六者，会大师弟子十二人也。〕

法中无气味。〔法中者，佛法也。会大师传佛知见甚深法也。无气味者，缘北宗秀大师弟子普寂于京盛行，通其经教；当此之时，曹溪宗旨于彼未盛行，故言无气味也。〕

石上有功勋。〔石上者，秀大节弟子磨却南宗碑，神秀欲为六代，何其天之不从，乃得会大师再立实录，故有功勋。〕

三藏又谶曰：

本是大虫男，〔印宗法师本是小乘，喻如大虫不是师子。〕

回成师子谈。〔回者传也，回小作大。印宗法师礼六祖便悟上乘，是成师子吼。〕

官家封马岭，〔封者印也，马岭者宗也。印宗曾为讲经法师也。〕

同详三十三。〔同详者同学也。六祖弟子祥岑等三十三人，祥禅师位于峡山。〕

三藏又谶曰：

八女出人伦，〔八女者，安字也，出人伦者，为国师也。〕

八个绝婚姻。〔八个者，安字。绝婚姻者，安徒难为绍继之。〕

朽床添六脚，〔朽床者，老字也。六脚者，则天中宗，腾腾坦然圆寂百五十五年住世。破灶堕和尚六住嵩山，是为六脚也。〕

心祖众中尊。〔心祖者，姓也。安和尚颖悟为国师，故众中尊也。〕

三藏又谶曰：

走戊与朝邻，〔走戊者，越字。忠国师是越州人也。与朝邻者，为国师。〕

鹅鸟子出身。〔鹅者鹉州也。今越州是。鸟者鸣鹤县也，今诸暨县是。国师生此县也。〕

二天虽有感，〔二天者，肃宗、代宗二帝也。有感者，帝礼为师也。〕

三化寂无尘。〔三化寂无尘者，二帝与国师俱寂也。〕

三藏又谶曰：

说小何曾小，〔希字是也。〕

言流又不流。〔迁字是也。〕

草若除其首，〔石头无草。〕

三四继门修。〔传法弟子人数。准其传法人数，应云：“十七继门修”也。〕

尔时那连耶舍说此谶已，告万天懿云：“今此国吾灭后二百八十年中，有大国王善敬三宝，此前诸贤悉出于世，化道群品约有千百亿，后所得法，只因一师，兴大饶益，开甘露门，能为首者当菩提达摩焉。”

尔时达摩和尚泛海东来，经于三载。梁普通八年丁末之岁九月二十一日至于广州上舶。刺史萧昂出迎，奏闻梁帝。十月一日而至上元，武帝亲驾车辇，迎请大师升殿供善。是时志公和尚监修高座寺，彼请寺主灵观曰：“汝名灵观，实灵观不？”灵观曰：“唯愿和尚指示。”志公曰：“从西天有大乘菩萨而入此国。汝若不信，听吾谶曰：

仰观两扇，〔仰视者，霄也。两扇者，梁也。萧梁帝是。〕

低腰捻钩。〔低腰捻者，十字也；钩者，月字也。十月到也。〕

九鸟射尽，〔九鸟者，日也；射尽者，二十九；卜月尽。〕

唯有一头。〔一头者，十月初一日。总言初祖十月一日到也。〕

至则不久，〔在梁国十九日，便过江北。故言不久。〕

要假须刀。〔断仁义也。〕

逢龙不住，〔初祖见武帝，故言逢龙。祖师所答不称帝意，便过江，故言不住。〕

过水则逃。〔过江入魏。〕

尔时灵观则以纸笔录于记之。

尔时武帝问：“如何是圣谛第一义？”师曰：“廓然无圣。”帝曰：“对朕者谁？”师曰：“不识。”又问：“朕自登九五已来，度人造寺，写经造像，有何功德？”师曰：“无功德。”帝曰：“何以无功德？”师曰：“此是人天小果。有漏之因，如影随形。虽有善因，非是实相。”武帝问：“如何是实功德？”师曰：“净智妙圆，体自空寂，如是功德，不以世求。”武帝不了达摩所言，变容不言。达摩其年十月十九日，自知机不契，则潜过江北，入于魏邦。志公特至帝所问曰：“我闻西天僧至，今在何方？”梁武帝曰：“昨日逃过江向魏。”志公云：“陛下见之不见，逢之不逢。”梁武帝问曰：“此是何人？”志公对曰：“此是传佛心印观音大士。”武帝乃恨之曰：“见之不见，逢之不逢。”即发中使赵光文往彼取之。志公曰：“非但赵光文一人，阖国取亦不回。”

大师自到东京。有一僧名神光，昔在洛中久传庄老。年逾四十，得遇大师，礼事为师。从至少林寺。每问于师，师并不言说。又自难曰：“古人求法，敲骨取髓，剌血图像，布发掩泥，投崖饲虎。古尚如此，我何惜焉？”时大和十年十二月九日，为求法故，立经干［子］夜，雪乃齐腰。天明师见问曰：“汝在雪中立，有如何所求耶？”神光悲啼泣泪而言：“唯愿和尚开甘露门，广度群品。”师云：“诸佛无上菩提，远劫修行。汝以小意而求大法，终不能得。”神光闻是语已，则取利刀自断左臂，置于师前。师语神光云：“诸佛菩萨求法，不以身为身，不以命为命。汝虽断臂求法，亦可在。”遂改神光名为惠可。又问：“请和尚安心？”师曰：“将心来，与汝安心。”进日：“觅心了不可得。”师曰：“觅得岂是汝心？与汝安心竟。”达摩语惠可曰：“为汝安心竟，汝今见不？”惠可言下大悟。惠可白和尚：“今日乃知一切诸法本来空寂；今日乃知菩提不远。是故菩萨不动念而至萨般若海；不动念而登涅盘岸。”师曰“如是，如是。”惠可进曰：“和尚此法有文字记录不？”达摩曰：“我法以心传心，不立文字。”

大师语诸人言：“有三人得我法。一人得我髓，一人得我骨，一人得我肉。得我髓者惠可，得我骨者道育，得我肉者尼总持。我法至六代，陵迟传法之人。”惠可进曰：“何故第六代陵迟传法之人？”达摩云：“为邪法竞兴，乱于正法。我有一领袈裟，传授与汝。”惠可白和尚：“法既以心传心，复无文字，用此袈裟何为？”大师云：“内授法印，以契证心；外传袈裟，以定宗旨。虽则袈裟不在法上，法亦不在袈裟，于中三世请佛递相授记。我今以袈裟亦表其信，令后代传法者有禀承，学道者得知宗旨。断众生疑故。”

惠可便顶礼，亲事九年，昼夜不离左右。达摩大师乃而告曰：如来以净法眼并袈裟付嘱大迦叶，如是展转乃至于我。我今付嘱汝，女听吾偈曰：

吾本来此土，传教救迷情。

一花开五叶，结果自然成。

师付法已，又告惠可曰：“吾自到此土，六度被人下药，我皆拈出。今此一度，更不拈出，吾已得人付法。”

尔时达摩领众云往禹阿千圣寺，止得三日。时有期城太守杨衍问师曰：“西国五天，师承为祖，未晓此意，其义云何？”师曰：“明佛心宗，寸无差误，行解相应，名之曰祖。”又问：“唯此一等，更有别耶？”师答曰：“须明他心，知其古今；不厌有无，亦非取故；不贤不愚，无迷无悟，若能是解，亦名为祖。”杨衍又问曰：“弟子久在恶业。不近知识，勤生恭敬，被小智慧而生缠缚，却成愚惑，不得悟道而致于此。伏愿师指示大道，通达佛心，修行用心。何名法祖？”师以偈答曰：

亦不睹恶而生嫌，

亦不观善而勤措，

亦不舍愚而近贤，

亦不抛迷而就悟。

达大道兮过量，

通佛心兮出度。

不与几圣同躔，

超然名之曰祖。

杨衍作礼：‘唯愿和尚久住世间，化导群品！”师曰：“吾则去矣，不宜久停。人多致患，常疾于我。”杨衍而问：“是何人也？愿师指示，当为知之。”师曰：“吾宁往矣，终不明焉，恐损此人。汝若要委，听吾谶曰：

江槎分玉浪，〔江者流也，槎者支也。玉浪者三藏。总言流支三藏也〕

管炬开金锁。〔管炬者光也。开者统也，金锁者者毒药。〕

五口相共行，〔五口者吾字也，相共行者与吾争行佛法，生嫉法心。〕

九十无彼我。〔九十者九/十字也，无彼我者无彼此之我也。〕

杨衍而作礼曰：“旦辞尊长，愿善保庆！”

时后魏第八主孝明帝大和十九年入涅盘，寿龄一百五十，葬在熊耳吴坂也，武帝敕昭明太子而述祭文。

灭度后三年，魏使时有宋云西岭为使，却回逢见达摩手携只履，语宋云曰：“汝国天子已崩。”宋云到魏，果王已崩。遂闻奏后魏第九主孝庄帝，及开塔唯见一只履，却取归少林寺供养。因武帝自制师碑文。代宗皇帝谥呈圆觉大师，敕空观之塔。自魏丙辰之岁迁化，迄今壬子岁，得四百一十三年矣。净修禅师赞曰：

菩提达摩，化道无为。

九年少室，六叶宗师。

示灭熊耳，只履西归。

梁天不荐，惠可传衣。

慧可

第二十九祖师慧可禅师者，是武牢人也，姬氏。父寂，初无其子，共室念言：“我今至善家而无慧子，深自叹羡，何圣加卫！”时后魏第六主孝文帝永宜十五年正月一日，夜现光明，遍于一宅。因兹有孕，产子，名曰光光。年十五，九经通诵。至年三十，往龙门香山寺，事宝静禅师，常修定慧。既出家已，至东京永和寺具戒。年三十二，却步香山，侍省尊长。又经八载，忽于夜静见一神人而谓光曰：“当欲受果，何于此住，不南往乎而近于道？”本名曰光光，因见神现故，号为神光。至于第二夜，忽然头痛如裂。其师欲与灸之，空中有声报云：“且莫，且莫！此是换骨，非常痛焉。”师即便止；遂说前事见神之由，以白宝静。宝静曰：“必是吉祥也。汝顶变矣，非昔首焉。五峰垂坠玉轸，其相异矣。”遂辞师南行，得遇达摩，豁悟上乘。师乃云：“一真之法，尽可有矣，汝善守护，勿令断绝。汝传信衣，各有所表。”慧可曰：“有何所表？”达摩曰：“内传心印，以契证心；外受袈裟，而定宗旨，不错谬故。吾灭度后二百年中，此袈裟不传。法周沙界，明道者多，行道者少；说理者多，通理者少。于后得道，还近千万。汝所行道，勿轻末学。此人回志，便获菩提，初心菩萨，与佛功等。”

尔时可大师得付法已，广宣流布，度诸有情。于天平年中，后周第二主孝闵已卯之岁，有一居士，不说年几，候有十四［四十］，及至礼师，不称姓名，云：“弟子身患风疾，请和尚为弟子忏悔。”师云：“汝将罪来，为汝忏侮。”居士曰：“觅罪不可见。”师云：“我今为汝忏悔竟，汝今宜依佛法僧宝。”居士问：“但见和尚则知是僧，未审世间何者是佛？云何为法？”师云：“是心是佛，是心是法，法佛无二，汝知之乎？”居士曰：“今日始知，罪性不在内外中间，如其心然，法佛无二也。”师知是法器而与剃发，云：“汝是僧宝，宜名僧璨。”亦受具戒，师告曰：“如来以大法眼付嘱迦叶，如是展转乃至于我。我今将此法眼付嘱于汝，并赐袈裟以为法信。汝听吾偈曰：

本来缘有地，因地种花生。

本来无有种，花亦不能生。

说此偈已，告璨曰：“吾往鄴都还债。”便去彼所，化导群生，得三十四年。或在城市，随处任缘；或为人所使，事毕却还。彼所有智者，每劝之曰：“和尚是高人，莫与他所使。”师云：“我自调心，非关他事。”时有辩和法师，于鄴都管城安县匡救寺讲《涅盘经》。是时大师至彼寺门说法，集众颇多。法师讲下人少。辩和怪于师，送往县令瞿仲偘说之：“彼邪见道人，打破讲席。”瞿令不委事由，非理损害而终。葬在磁州涂阳东北七十余里。寿龄一百七岁，示于时灭，当隋第一主文帝开皇十三年癸丑之岁。唐内供奉沙门法琳撰碑文，德宗皇帝镇号大弘禅师大和之塔。自隋癸丑岁迁化，迄今唐保大十年壬子岁，得三百五十九年矣。净修禅师赞曰：

二祖硕学，操为坚礭。

心贯三乘，顶奇五岳。

天上麒麟，人间鸑鷟。

断臂立雪，混而不独。

祖堂卷二·僧璨

第三十祖僧璨者，即是大隋三祖。不知何许人，不得姓字。遇可大师，得付心法。大集群品，普雨正法，会中有一沙弥，年始十四，名道信，来礼师而问师曰：“如何是佛心？”师答曰：“汝今是什摩心？”对曰：“我今无心。”师曰：“汝既无心，佛岂有心耶？”又问：“唯愿和尚教某甲解脱法门。”师云：“谁人缚汝？”对曰：“无人缚。”师云：“既无人缚汝，即是解脱，何须更求解脱？”道信言下大悟，在师左右八九年间。后于吉州具戒，却归省觐于师。师命付法而说偈曰：

花种虽因地，从地种花生。

若无人下种，花种尽无生。

师自隋第二主炀帝大业二年丙寅岁迁化，迄今唐保大十年壬子岁，得三百四十年矣。大明孝皇帝谥号智镜禅师觉寂之塔矣。净修禅师赞曰：

三祖大师，法王真子。

语出幽微，心无彼此。

或处山林，或居廛市。

因地花生，啃檀旖旎。

祖堂卷二·道信

第三十一祖道信和尚者，即唐土四祖。姓司马氏，本居河内，迈止蕲州，广济之所育也。得璨大师心印之后，忽于黄梅路上见一小兒，年七岁，所出言异。师乃问子何姓，子答曰：“姓非常姓。”师曰：“是何姓？”子答：“是佛性。”师曰：“汝勿姓也。”子答曰：“其姓空故。”师顾左右曰：“此子非凡，吾灭度二十年中，大作佛事。”子问曰：“诸圣从何而证？”师云：“廓然，廓然。”子曰：“与摩则无圣去也。”师曰：“犹有这个纹彩在。”师乃付法偈曰：

花种有生性，因地花性生。

大缘与性合，当生不生生。

师付法已，时当高宗永徽二年庚戍之岁，闰九月四日，掩然而灭。寿年七十二，葬后二年四月八日，塔门无故自开。容貌端然，无异常日。自兹已后，门人更不取［敢］闭。至大历年中，代宗谥号大医禅师慈云之塔。中书令太子宾客襄阳公杜正伦撰碑文。净修禅师赞曰：

四祖十四，因师解脱。

处世道流，兴慈量阔。

永绝雕荣，迥祛始末。

果少花多，忍传衣钵。

祖堂卷二·弘忍

第三十二祖弘忍和尚，即唐土五祖也。姓周氏，本居汝南，迁止蕲州。黄梅诞生，七岁出家，事信大师。幼而聪敏，事不再问。母怀之时，发光通宵，每闻异香，身体安泰，后乃生育。形貌端严，哲者观之，云：“此子阙七种大人之相，不及佛也。”时有卢行者，年三十二，从岭南来，礼觐大师。大师问：“汝从何方而来。有何所求？”行者对曰：“从新州来，来求作佛。”师云：“汝岭南人，无佛性也。”行者云：“人则有南北，佛性无南北。”师云：“汝作何功德？”行者对曰：“愿竭力抱石，舂米供养师僧。”师便许之。于一日一夜舂得一十二石米，首末亲事。经八个余月，行者又问曰：“如何是大道之源？”师曰：“汝是俗人，问我此事作什摩？”对曰：“世谛即有僧俗，道岂碍人耶？”师曰：“汝若如此，莫从人觅。”进曰：“与摩即不从外得。师曰：“内亦非。”

大师临迁化时，告众云：“正法难闻，盛会希逢。是你请人如许多时在我身边，若有见处各呈所见，莫记吾语，我与你证明。”时众中有神秀，闻师频训告，遂挥毫于壁。书偈曰：

身是菩提树，心如明镜台。

时时勤拂拭，莫使有尘埃。

师见此偈，乃告众曰：“是你诸人，若依此偈修行而得解脱。”众僧总念此偈。

有一童子碓坊里念此偈，行者曰：“念什摩？”童子曰：“行者未知，第一座造偈呈师，大师曰：‘若依此偈修行而得解脱。’”行者曰：“某甲不识文字，请兄与吾念看，我闻愿生佛会。”有一江州别驾张日用，为行者高声诵偈。行者却请张日用：“与我书偈，某甲有一个拙见。”其张日用与他书偈曰：

身非菩提树，心镜亦非台。

本来无一物，何处有尘埃？

时大师复往亲观之，挥却了，举头微笑，亦不赞赏，心自诠胜。

师又去碓坊，便问行者：“不易行者，米还熟也未？”对曰：“米熟久矣，只是未有人簸。”师云：“三更则至。”行者便唱喏。

至三更，行者来大师处。大师与他改名，号为慧能。当时便传袈裟以为法信，如释迦牟尼授弥勒记矣。

大师便偈曰：

有情来下种，因地果还生。

无情既无种，无性亦无生。

行者闻偈欢喜，受教奉行。师又告云：“吾三年方入灭度，汝且莫行化，当损于汝。”行者云：“当往何处而堪避难？”师云：“逢怀则止，遇会且藏。”〔怀则州，会则县。〕又问：“此衣传不？”师云：“后代之人，得道者恆河沙。今此信衣，至汝则住。何以故？达摩大师付嘱此衣，恐人不信而表闻。法岂在衣乎？若传此衣，恐损于物。受此衣者，命若悬丝。况达摩云：‘一花开五叶，结果自然成。’是印此土与汝五人。般若多罗云：‘果满善提圆，花开世界起。’此两句亦印今时法衣至汝不合付与人。”行者奉教，便辞大师。大师遂到江边，升小船子。师自把橹，行者曰：“某甲把橹。”师云：“你莫闹！我若称断，是你嘱我；你若称断，我则嘱你。”过江了，向行者云：“你好去。”其行者迤逦取向南方矣。

师经于三日都不说法。至第四日，众人问曰：“师法嗣何人？”师云：“吾法已往岭南。”神秀便问：“何人得之？”师云：“能者则得。”众人良久思惟，不见行者数日，恐是将法去也。当时七百余人，一齐趁卢行者。众中有一僧，号为慧明，趁得大庾岭上，见衣钵不见行者。其上座便近前，以手提之，衣钵不动，便委得自力薄。则入山觅行者，高处望见行者在石上坐。行者遥见明上座，便知来夺我衣钵，则云：“和尚分付衣钵，某甲苦辞不受。再三请传持，不可不受。虽则将来，现在岭头。上座若要，便请将去。”明上座云：“不为衣钵，特为佛法来。不知行者辞五祖时有何密语密意，愿为我说！”行者见上座心意苦切，便向他说：“静思静虑，不思善不思恶，正与摩思不生时，还我本来明上座面目来。”上座又问：“上来密语密意，只有这个，为当更有意旨？”行者云：“我今明明与汝说，则是不密。汝若自得自己面目，密却在汝。”上座问：“行者在黄梅和尚处意旨如何？”行者曰：“和尚看我对秀上座偈，则知我入门意，则印惠能：‘秀在门外，汝得入门，得坐被衣。向后自看，此衣钵从上来分付，切须得人。我今分付汝，汝须努力将去。十有余年勿弘吾教，当有难起。过此已后，善诱迷人。’又问：‘当往何处而堪避难？’师云：‘逢怀则止，遇会且藏。’”慧明云：“某甲虽在黄梅剃发，实不得宗乘面目。今蒙行者指授，也有入处，如人饮水冷暖自知。从今向后，行者即是慧明师，今便改名，号为道明。”行者便云：“汝若如是，我亦如是，与汝同在黄梅不异，自当护持。”道明云：“行者好与速向岭南，在后大有僧来趁行者。”道明又问：“宜往何处？”行者云：“遇蒙则住，逢袁即止。”

道明敬仰之心辞行者，便回向北去。至于虔州，果然见五十余僧来寻卢行者。道明向众云：“大庾岭头怀化镇五六日寻候，兼问诸门津并向北寻觅行者，言不见此色。”诸人却回。道明独往庐山布水台。经三年后，归蒙山修行。凡徒弟尽教过岭南六祖处，只今蒙山灵塔现在。

大师付法后，高宗在位二十四年壬申之岁，二月十六日灭度，春秋七十四。代宗谥号大满禅师法雨之塔。自上元壬申岁迁化，迄今唐保大十年壬子岁，得二百八十年矣。净修禅师赞曰：

五祖七岁，洞达言前。

石牛吐雾，木马含烟。

身心恆寂，理事俱玄。

无情无种，千年万年。

祖堂卷二·惠能

第三十三祖惠能和尚，即唐土六祖。俗姓卢，新州人也。父名行瑫，本贯范阳，移居新州。父早亡，母亲在孤。艰辛贫乏，能市卖柴供给。

偶一日卖柴次，有客姓安名道诚，欲买能柴，其价相当。送将至店，道诚与他柴价钱。惠能得钱，却出门前，忽闻道诚念《金刚经》。惠能亦闻，心开便悟。惠能遂问：“郎官此是何经？”道诚云：“此是《金刚经》。”惠能云：“从何而来，读此经典？”道诚云：“我于蕲州黄梅县东冯母山礼拜弟五祖弘忍大师，今现在彼山说法，门人一千余众，我于此处听受。大师劝道俗，受持此经，即得见性，直了成佛。”惠能闻说，宿业有缘。其时道诚劝惠能往黄梅山礼拜五祖，惠能报云：“缘有老母家乏欠阙，如何抛母无人供给？”其道诚遂与惠能银一百两，以充老母衣粮，便令惠能往去礼拜五祖大师。惠能领得其银分付安排老母讫，便辞母亲。

不经一月余日，则到黄梅县东冯母山。礼拜五祖，五祖问：“汝从何方而来？有何所求？”惠能云：“从新州来，来求作佛。”师云：“汝岭南人，无佛性也。”对云：“人即有南北，佛性即无南北。”师曰：“新州乃猎獠，宁有佛性耶？”对曰：“如来藏性遍于蝼蚁，岂独于獦獠而无哉？”师云：“汝既有佛性，何求我意旨？”深奇其言，不复更问。自此得之心印。既承在法，遂辞慈容。后隐四会怀集之间，首尾四年。至仪夙元年正月八日，南海县制旨寺遇印宗。印宗出寺迎接归寺里安下。

印宗是讲经论僧也。有一日正讲经，风雨猛动。见其幡动，法师问众：“风动也，幡动也？”一个云风动。一个云幡动。各自相争，就讲主证明。讲主断不得，却请行者断，行者云：“不是风动，不是幡动。”讲主云：“是什摩物动？”行者云：“仁者自心动。”从此印宗回席座位。正月十五日剃头，二月八日于法性寺请智光律师受戒。戒坛是宋朝求那跋摩三藏之所置也。尝云：“后有肉身菩萨于此受戒。”梁末有真谛三藏于坛边种菩提树，云：“一百二十年，有肉身菩萨于此树下说法。”师果然于此树下演无上乘。

至明年二月三日便辞，去曹溪宝林寺说法化道，度无量众。师以一味法雨普润学徒，信衣不传，心珠洞付。得道之者若恆河沙，遍满诸方，落落星布。

时神龙元年正月十五日，则王孝和皇帝诏大师云：“朕虔诚慕道，渴仰禅门。诏诸山禅师集内道场，安秀二德最为僧首。朕每谘求法，再三辞推，云：‘南方有能和尚，受弘忍大师记，传达摩衣为信，顿悟上乘，明见佛性。今居韶州曹溪山，示悟众生即心是佛。’朕闻：如来以心之法付嘱摩诃迦叶，如是相传，至如达摩。教被东土，代代相承，至今不绝。师既禀受，并有信衣，可赴京师设化。缁俗归衣，天人瞻仰。故发遣中使薛简迎师，愿早降至。”大师表曰：“沙门惠能生自边方，长而慕道。叨承忍大师付如来心印，传西国衣钵，受东山佛心。伏奉天恩，发中使薛简诏惠能入内。惠能久处山林，年迈风疾。陛下德包物外，道贯百邦，育养苍生，仁慈黎庶，恩旨弥天，钦仰释门。恕惠能居山养疾，修持道业。上答皇恩及诸王太子。谨奉表陈谢以闻。释沙门惠能顿首顿首谨言。”时中使薛简启师云：“京师禅师大德教人要假坐禅，然方得道。”师云：“由心悟道，岂在坐也？故经云：‘若有人言如来若来若去，若坐若卧，是人行邪道，不解我所说义。’如来者，无所从来，亦无所去，故名如来。诸法空故即是如来，毕竟无得无证，岂况坐耶？”薛简曰：“弟子至天庭，圣人必问。伏愿和尚指授心要，传奏圣人及京城学道者。譬如一灯照百千灯，冥者皆明，明明无尽。”师云：“道无明暗，明暗是代谢之义。明明无尽，亦是有尽，相待立名故。经云：‘法无有比，无相待故’。”薛简曰：“明譬智慧，暗喻烦恼。学道之人若不用智慧照生死烦恼，何得出离？”师云：“烦恼即是菩提，无二无别故。以智慧照烦恼者，是二乘人见解；有智之人终不如此。”薛个曰：“何者是大乘人见解？”师云：“《涅般经》云：‘明与无明，凡夫见二。’智者了达其性无别。无别之性即是实性。处凡不减，在圣不增。住烦恼而不乱，居禅定而不寂。不断不常，不来不去，不在中间及其内外。不生不灭，性相常住，恆而不变，名之曰道。”简曰：“师也说不生不灭，何异外道说不生不灭？”师云：“外道说不生不灭，将生止灭，灭犹不灭。我说不生不灭，本自无生，今亦无灭，所以不同外道。中使欲得心要，一切善恶都莫思量，自然得入心体，湛然常寂，妙用恆沙。”

时薛简闻师所说，豁然便悟。礼师数拜曰：“弟子今日始知佛性本自有之。昔日将谓太远，今日始知至道不遥，行之即是。今日始知涅盘不远，触目菩提。今日始知佛性不念善恶，无思无虑，无造无作，无住无为。今日始知佛性常而不变易，不被诸境所迁。”

中使礼辞大师，进持表至京，时当神龙元年五月八日。

后至九月三日，回诏曰：“师辞老病。为朕修道，国之福田。师若净名托疾，金粟阐弘大教，传诸佛心，谈不二之法，杜口毗耶，声闻被呵，菩萨辞退，师若如此。薛简传师指教，受如来知见，一切善恶都莫思惟，自然得入心体，湛然常寂，妙用恆沙。朕积善余庆，宿种福因。值师之出世，顿悟上乘佛心第一。朕感荷师恩，顶戴修行。永永不朽。奉磨纳袈裟一领，金钵一口，供养大师。”其后敕下赐寺额重兴寺及新州古宅造国恩寺。

师每告诸善知识曰：“汝等诸人自心是佛，更莫孤［狐］疑。外无一物而能建立，皆是本心生万种法。故经云：“心生即种种法生，心灭即种种法灭。’汝等须达一相三昧，一行三昧。一相三昧者，于一切处而不住相，于彼相中不生僧爱，不取不舍，不念利益，不念散坏，自然安乐，故因此名为一相三味。一行三昧者，于一切处行住坐卧，皆一直心，即是道场，即是净土。此之名为一行三昧。如地有种能含藏故，心相三昧亦复如是。我说法时犹如普雨，汝有佛性如地中种，若遇法雨，各得滋长。取吾语者，决证菩提；依吾行者，定证圣果。吾今不传此衣者，以为众信心不疑惑，普付心要，各随所化。昔吾师有言，从吾后若受此衣，命如悬丝。吾以道化，不可损汝。汝受吾法，听吾偈曰：

心地含诸种，普雨悉皆生。

顿悟花情已，菩提果自成。

师说此偈已，乃告众曰：“其性无二，其心亦然。其道清净，亦无诸相。汝莫观净及空其心，此心本净，亦无可取。汝各努力，随缘好去。”

有人问曰：“黄梅意旨何人得？”师云：“会佛法者得。”僧曰：“和尚还得也无？”师云：“我不得。”僧曰：“和尚为什摩不得？”师云：“我不会佛法。”云大师拈问龙花：“佛法有何过，祖师不肯会？”花云：“向上人分上合作摩生？”进曰：“向上人事如何？”花云：“天反地覆。”龙花却问云大师，大师云：“一翳不除，出身无路。”进曰：“除得一翳底人还称得向上人也无？”云大师云：“横眠直卧有何妨？”

六祖见僧，竖起拂子云：“还见摩？”对云：“见。”祖师抛向背后云：“见摩？”对云：“见。”师云：“身前见，身后见？”对云：“见时不说前后。”师云：“如是，如是。此是妙空三昧。”有人拈问招庆：“曹溪竖起拂子意旨如何？”庆云：“忽有人回把柄到汝作摩生？”学人掩耳云：“和尚。”庆便打之。

尔时大师住世说法四十年。先天元年七月六日，忽然命弟子于新州故宅建塔一所。二年七月一日，别诸门人：“吾当进途归新州矣。”大众缁俗啼泣留连大师，大师不纳曰：“诸佛出世现般涅盘，尚不能还其宿命，况吾未能变易，分段之报必然之至，当有所在耳。”门人问师：“师归新州，早晚却回？”师云：“叶落归根，来时无口。”问：“其法付谁？”师云：“有道者得，无心者得。”又曰：“吾灭度后七十年末，有二菩萨从东而来，一在家菩萨，同出兴化，重修我伽蓝，再建我宗旨。”师言讫，便往新州国恩寺。饭食讫，敷坐披衣，俄然异香满室，白虹属地，奄而迁化，八月三日矣。春秋七十六。

当先天二年，达摩大师传袈裟一领，是七条屈眴布，青黑色碧绢为里，并钵一口。

中宗敕谥大鉴禅师元和灵照之塔。癸丑岁迁化，迄今唐保大十年壬子岁，得二百三十九年矣。净修禅师赞曰：

师造黄梅，得旨南来。

奚因幡义，大震法雷。

道明遭遇，神秀迟回。

衣虽不付，天下花开。


祖堂集卷三

祖堂卷三·牛头

牛头和尚嗣四祖，师讳法融，润州延陵人也，姓文。四祖在双峰山告众曰：“吾来至此山时，于武德七年秋，于庐山顶上东北而望见此蕲州双峰山顶上有紫云如盖，下有白气横分六道。四祖问五祖曰：“汝识此瑞不？”五祖曰：“莫是师脚下横出一枝佛法不？”四祖曰：“汝会我义。汝善住矣。吾过江东。”便去至牛头山幽栖寺。见数百僧并无道气，乃顾问僧曰：“寺中有多少住持？其中有道人不？”僧曰：“禅和大相轻。夫出家者阿那个不是道人？”四祖曰：“何者是道人？”僧无对。乃云：“山上有懒融，身著一布裘，见僧不解合掌。此是异人也，禅师自往看。”四祖乃往庵前，过来过去，谓曰：“善男子莫入甚深三昧。”融乃开眼。四祖曰：“汝学为有求为无求耶？”融曰：“我依《法华经》开示悟入，某甲为修道。”四祖曰：“开者开何人？悟者悟何物？”融无对。四祖曰：“西天二十八祖传佛心印。达摩大师至此土，相承有四祖。汝还知不？”融瞥闻此语，乃曰：“融每常望双峰山顶礼，恨未得亲往面谒。”四祖曰：“欲识四祖，即吾身是。”融便起接足礼曰：“师因何降此？”祖曰：“特来相访。”又曰：“别更有住处不？”融以手指于庵后曰：“更有庵在。”遂引四祖到庵所。师遂见虎狼绕庵，麋鹿纵横四畔。师乃两手作怕势云：“□。”（入山见虫的合字）融曰：“师犹有这个在。”师曰：“适来见什摩？”融于言下，虽承玄旨，而无有对。师于是为说法要曰：“夫百千妙门，同归方寸。恆沙妙德，尽在心源。一切定门，一切慧门，悉自具足。神通妙用，并在汝心。烦恼业障，本来空寂。一切果报，本来自有。无三界可出，无菩提可求。人与非人，性相平等。大道虚旷，绝思绝虑。如是之法汝今已得，更无阙少，与佛无殊，更无别法可得成佛。汝但任心自在，莫作观行，亦莫停心，莫起贪瞋痴，莫怀愁虑，荡荡无碍，任意纵横。不作诸善，不作诸恶。行住坐卧，触目遇缘，总是佛之妙用。快乐无忧，故名为佛。”融问：“心既具足，何者是心？何者是佛？”师曰：“非心不问心，问心非不心。”又问：“既不许观行，于境起时如何对治？”师曰：“境缘无好丑，好丑起于心。心若不强名，妄情从何起？妄心既不起，真心任遍知。随心身在，复无始终。则名常住法身，无有变易。吾从先师璨和尚处传得顿悟法门，今付于汝。汝今谛受以酬吾道，但住此山。从汝向后更有五人，相继不绝也。善自保持，吾当去矣。”

师于言下顿荡微瑕，永亡朕兆。自是灵怪鬼神供须无地。以此详鉴，足见如来密旨，岂修证以能齐？祖胤玄门，安寂静之可趣？言亡理契，顾玄要以云泥；静虑还源，望禅枢而楚越矣。

问师：“夫言圣人者，当断何法，当得何法，而言圣人？”答：“一法不断，一法不得，此谓圣人。”进曰：“不断不得与凡夫有何异？”师曰：“有异。何以故？一切凡夫皆有所断妄计，所得真心，圣人则本无所断，亦无所得。故曰有异。”进曰：“云何凡夫有所得，圣人无所得？得与不得复有何异？“师曰：“有异。何以故？凡夫有所得，则有虚妄；圣人无所得，则无虚妄。有虚妄者则有异，无虚妄者则无异。”进曰：“若无异，圣人名因何立？”师曰：“凡之与圣，二俱是假名。假名之中无二，则无有异。如说龟毛兔角也。”进曰：“圣人若同龟毛兔角，则应是无。令人学何物？”师曰：“我说龟毛，不说无龟。汝何意作此难！”进曰：“龟喻何物？毛喻何物？”师曰：“龟喻于道，毛喻于我。故圣人无我而有道，凡夫无道而有我。执我者犹如龟毛兔角也。”次乃法付智严已。

自显庆元年，司空萧无善请出建初寺，师辞不免，乃谓众曰：“从今一去，再不践也。”既出寺门，禽兽哀号，逾月不止；山间泉地，激石涌砂，一时填满；房前大桐四株，五月繁茂，一朝竭尽。

师至显庆二年丁巳岁闰正月二十三日，于建初寺终，春秋六十四，僧夏四十一。至二十七日葬，塔在金陵后湖溪笼山，即耆阇山也。因此牛头宗六枝，第一是融禅师，第二智岩，第三慧方，第四法持，第五智威，第六惠忠也。

祖堂卷三·鹤林

鹤林和尚嗣牛头威禅师。师讳马素，未规行状，不决化缘始终。敕谥大律禅师大和宝航之塔。问：“如何是西来意？”师曰：“会即不会，疑即不疑。”师却云：“不会不疑底，不疑不会底。”有僧敲门，师问：“是什摩人？”对曰：“僧。”师曰：“非但僧，佛来亦不著。”进曰：“佛来为什摩不著？”师曰：“此间无公止泊处。”

祖堂卷三·先径山

先径山和尚嗣鹤林，师讳道钦。大历年代宗请赴京师，号国一禅师。肃宗皇帝来礼师，师见帝来遂起立。帝曰：“大师见朕来因何起？”师曰：“檀越因什摩向四威仪中见贫道？”问：“如何是祖师西来意？”师曰：“汝问不当。”曰：“如何得当：“师曰：“待我死即向汝道。”

江西马大师令西堂问师：“十二时中以何为境？”师曰：“待汝回去有信上大师。”西堂曰：“如今便回去。”师曰：“传语大师：‘却须问取曹溪始得。’”

祖堂卷三·鸟窠

鸟窠和尚嗣径山国一禅师，在杭州。未睹行录，不决化缘始终。因侍者辞，师问：“汝去何处？”对曰：“向诸方学佛法去。”师曰：“若是佛法，我这里亦有小许。”侍者便问：“如何是这里佛法？”师抽一茎布毛示，侍者便悟。

白舍人亲受心戒，又时对坐，并无言说。舍人第三弟见此造诗曰：

白头居士对禅师，正是楞严三昧时。

一物也无百味足，恆沙能有几人知？

白舍人问：“一日十二时中如何修行，便得与道相应？”师云：“诸恶莫作，诸善奉行。”舍人曰：“三岁孩兒也解道得。”师曰：“三岁孩兒也解道得，百岁老人略行不得。”舍人因此礼拜为师，赞曰：

形羸骨瘦久修行，一纳麻衣称道情。

曾结草庵倚碧树，天涯知有鸟窠名。

师问白舍人：“汝是白家兒不？”舍人称名“白家易”，师曰：“汝阿爷姓什摩？”舍人无对。舍人归京，入寺游戏，见僧念经，便问：“甲子多少？”对曰：“八十五。”进曰：“念经得几年？”对曰：“六十年。”舍人云：“大奇，大奇！虽然如此，出家自有本分事。作摩生是和尚本分事？”僧无对。舍人因此诗曰：

空门有路不知处，头白齿黄犹念经。

何年饮著声闻酒，迄至如今醉未醒。

祖堂卷三·懒瓚

五后忍大师下傍出一枝：神秀和尚、老安国师、道明和尚。神秀下普寂，普寂下懒瓚和尚。在南岳。师有乐道歌曰：

兀然无事无改换，无事何须论一段。

真心无散乱，他事不须断。

过去已过去，未来更莫算。

兀然无事坐，何曾有人唤？

向外觅功夫，总是痴顽汉。

粮不畜一粒，逢饭但知执/食。

世间多事人，相趁浑不及。

我不乐生天，亦不爱福田。

饥来即吃饭，睡来即卧瞑。

愚人笑我，智乃知贤。

不是痴钝，本体如然。

要去即去，要住即住。

身被一破纳，脚著娘生裤。

多言复多请，由来久相误。

若欲度众生，无过且自度。

莫漫求真佛，真佛不可见。

妙性及灵台，何曾受勋［薰］练？

心是无事心，面是娘生面。

劫石可移动，个中难改变。

无事本无事，何须读文字？

削除人我本，实合个中意。

种种劳筋骨，不如林间睡兀兀。

举头见日高，乞饭从头喂。

将功用功，展转冥朦。

取则不得，不取自通。

吾有一言，绝虑忘缘。

巧说不得，只用心传。

更有一语，无过直与。

细如毫末，本无方所。

本自圆成，不劳机杼。

世事悠悠，不如山丘。

青松弊日，碧涧长流。

卧藤萝下，塊石枕头。

山云当幕，夜月为钩。

不朝天子，岂羡王侯？

生死无虑，更须何忧？

水月无形，我常只宁。

万法皆尔，本自无生。

兀然无事坐，春来草自青。

祖堂卷三·老安

老安国师嗣五祖忍大师，在嵩山。坦然禅师问：“如何是祖师西来意旨？”师曰：“何不问自家意旨，问他意旨作什摩？”进曰：“如何是坦然意旨？”师曰：“汝须密作用。”进曰：“如何是密作用？”师闭目又开目，坦然禅师便悟。

祖堂卷三·腾腾

腾腾和尚嗣安国师。师有乐道歌。曰：

问道道无可修，问法法无可问。

迷人不了性空，智者本无违顺。

八方四千法门，至理不离方寸。

不要广学多闻，不在辩才聪隽。

识取自家城廓，莫漫游他州郡。

言语不离性空，和光不同尘坌。

烦恼即是菩提，净花生于泥粪。

若有人求问答，谁能共他讲论？

亦不知月之大小，亦不知岁之余闰。

晨时以粥充饥，仲时更餐一顿。

今日任运腾腾，明日腾腾任运。

心中了了总知，只没佯痴缚钝。

祖堂卷三·破灶堕

破灶堕和尚嗣安国师。师在北地，有一禅师唯善塞灶，频频感得灶神现身，彼地敬重剧于佛像。是时和尚至彼，为灶神说法。灶神闻法，便获生天。故现本身，礼辞和尚：“蒙师说法，重得生天，故来谢师，便还天府。”言犹未讫，瞥然不见。其灶瓦解，悉自落破。此师本不称名，因此缘故破灶堕和尚也。〔已上北宗。〕

祖堂卷三·靖居

靖居和尚嗣六祖，在吉州。师讳行思，俗姓刘，庐陵人也。自传曹溪密旨，便复庐陵，化度群生。僧问：“如何是佛法大意？”师曰：“庐陵米作摩价？”师问神会：“汝从何方而来？”对曰：“从曹溪来。”师曰：“将得何物来？”会遂震身而示。师曰：“犹持瓦砾在。”会曰：“和尚此间莫有真金与人不？”师曰：“设使有，与汝向什摩处著？”

师以开元二十八年十二月十三日迁化。敕谥弘济大师归真之塔。净修禅师赞曰：

曹溪门人，出世庐陵。

唯提一脉，迥出三乘。

泽中孤烛，火里片冰。

许君妙会，说底相应。

祖堂卷三·荷泽

荷泽和尚嗣六祖，在西京荷泽寺。师讳神会，姓高，襄阳人也。师初到六祖处，六祖问：“是你远来大艰辛，还将本来不？若有本即合识主，是你试说看！”师对曰：“神会以无主为本，见即是主。”祖曰：“者沙弥争取次语！”便以杖乱打，师杖下思惟：“大善知识历劫难逢。今既得遇，岂惜身命！”六祖察其语深情至，故试之也。因此自传心印，演化东都，定其宗旨。南能北秀，自神会现杨［扬］。曹溪一枝，始芳宇宙。

天宝中御史卢液是北宗普寂门徒，奏会聚徒洛阳。玄宗徵赴，驾幸诏应。得对天颜，言理允符，圣情郑重。有司量移均州。

至德二年，肃宗敕徙荆州，住开元寺。师乡信到，报父母俱丧。师乃入僧堂白槌曰：“父母俱丧，请大众念摩诃般若！”大众才坐，师日：“劳烦大众珍重。”师上元元年五月十三日终。敕谥真宗大师般若之塔。

祖堂卷三·慧忠

慧忠国师嗣六祖，姓冉，越州诸暨县人也。其兒子在家时，并不曾语，又不曾过门前桥。直到十六，有一个禅师来，才望见走出过门前桥，迎接礼拜，通寒喧。父、阿娘、眷属、远近邻舍总来惊讶曰：“不可思议。这个兒子，养来到十六，并不曾见他语话，又不曾见他过门前桥。今日才见和尚，有如是次第。恐是此兒子异於常人也。”兒子便问禅师：“乞师慈悲摄受，度得一个众生。某甲切要投禅出家。”禅师曰：“是我宗门中银轮王嫡子、金轮王孙子，方始得继续不坠此门风。是你三家村里男女、牛背上将养底兒子，作摩生投这个宗门？不是你分上事。”兒子曰：“启禅师：‘是法平等，无有高下。’那得有这个言词障於某甲善心？再乞禅师垂慈容纳。”禅师见兒子有如是次第，便向兒子说：“你若如此，投某出家则不得。”子曰：“投什摩人出家？禅师与某甲指示宗师。”禅师曰：“汝还闻曹溪摩？”子曰：“不知漕溪是什摩州界。”禅师曰：“广南漕溪山，有一善知识，唤作六祖，广六百众，你去那里出家。某甲未曾游天台，你自但去。”

其兒子便入草隐遁，回避爷娘便行。三日程二日行，两日程一日行。到曹溪，恰遇祖师正当说法时，便礼拜祖师。祖师问：“从什摩处来？”对曰：“只近。”祖曰：“生缘在阿那里？”子曰：“自得五阴后忘却也。”祖师招手云：“近前来！”子便近前。祖师曰：“实说你是什摩处人。”子曰：“浙中人。”祖曰：“远来到这里为什摩事？”于曰：“一则明师难遇，正法难闻，特来礼觐祖师。二则投师出家，乞师垂慈摄受。”祖曰：“我向你道莫出家。”于曰：“因什摩有此言？”祖曰：“你是圣明不动干戈六十年天子，是你但造天子佛法为主。”于曰：“启师：非但六十年，百年天子也不要。乞师慈悲，容许某甲出家。”师便摩顶授记曰：“你若出家，天下独立佛。”便摄受。

师曾在南阳白崖山修行四十徐年，上元二年正月十六日奉敕，肃宗皇帝徵诏赴上都，千福寺西禅院安置，后归光宅寺。肃宗、代宗前后两朝，并亲受菩萨戒，礼号国师焉。

僧问：“如何是佛法大意？”师曰：“文殊堂里一万菩萨。”僧曰：“学人不会。”师曰：“大悲千手千眼。”师定坐次，肃宗问：“师得何法？”师曰：“陛下见空中一片云不？”皇帝曰：“见。”师曰：“钉钉著，悬挂著？”帝又问：“如何是十身调御？”师乃起立云：“还会摩？”帝曰：“不会。”师曰：”与老僧过净瓶水来。”耽源问：“师百年后，忽有人问极则事，如何向他道？”师曰：“幸自可怜生，要须得个护身符子作什摩？”肃宗因从侍肩舁师上殿。师乃仰面视曰：“还会摩？”帝曰：“不会。”师曰：“老僧今日困。”帝问：“如何是无诤三味？”师曰：“檀越踏毗卢头上行。”帝曰：“如何是踏毗卢头上行？”师曰：“莫认自己清净法身。”

师于一日见耽源入法堂，师便垂一足。耽源便出去，良久回来。师曰：“适来意作摩生？”对曰：“向阿谁说即得？”师曰：“我问你。”对曰：“什摩处见某甲？”肃宗帝问讯次，师不视帝。帝曰：“朕身一国天子，师何得殊无些子视朕？”师云：“皇帝见目前虚空摩？”帝曰：“见。”师曰：“还曾眨眼向陛下摩？”鱼军容问：“师住白崖山时如何修行？”师唤家童子，童子来。师乃以手摩童子头曰：“惺惺直言惺惺，历历直言历历，以后莫受人谩。”

南阳张诹问：“某甲闻有无情说法，未谛其事，乞师指示。”师曰：“无情说法，汝若闻时，方闻无情说法。缘他无情，始得闻我说法，汝但问取无情说法去。”张诹曰：“只如今约有情方便之中，如何是无情因缘？”师曰：“但如今于一切动用之中施为。但凡圣两流都无小分起灭，便是出识，不属有情。炽然见觉只是无其系执。所以六根对色分别非识。”师在党子谷时，麻谷来绕师三匝，震锡一下。师曰：“既然任摩，何用更见贫道？”又震锡一下。师呵曰：“这野狐精！”长庆代曰：“大人是什摩心行？”又代曰：“若不与摩，争识得和尚？”师与紫岔法师共论义次，各登坐了，法师曰：“请师立义，某甲则破。”师曰：“岂有与摩事？”法师曰：“便请立义。”师曰：“立义了也。”法师曰：“立是什摩义？”师曰：“果然不见，非公境界。”长庆代曰：“师义堕也。”

有座主来参次，师问：“作什摩事业？”对：“讲《金刚经》业。”师曰：“最初两字是什摩字？”对曰：“如是。”师曰：“是什摩？”师问岔供奉：“佛是什摩义？”对曰：“佛是觉义。”师曰：“佛还曾迷也无？”对曰：“不曾迷。”师曰：“既不曾迷，用觉作什摩？”无对。供奉又问：“如何是实相义？”师曰：“将虚底来。”对曰：“虚底不可得。”师曰：“虚底尚不可得，问实相作什摩？”师又时见僧来。以手作圆相，圆相中书曰：“字。”僧无对。

有时王咏问“如何得解脱？”师曰：“诸法不相到，当处得解脱。”咏曰：“若然者，即是断，岂是解脱？”师便喝曰：“这汉，我向你道不相到，谁向汝道断？”王咏更无言。和尚亦识此人是三教供奉。王咏门徒志心问：“如何得成佛去？”师曰：“佛与众生，一时放却，当处解脱。”进曰：“如何得相应去？”师曰：“善恶都莫思量，自然得见佛性。”又问：“若为得证法身耶？”云：“超毗卢遮那境界。”进曰：“清净法身如何超得？”师曰：“不著佛求。”又问：“阿那个是佛？”师曰：“即心即佛。”进曰：“心有烦恼，如何是佛？”师曰：“烦恼性自离。”进曰：“岂不断烦恼耶？”师曰：“断烦恼是声闻缘觉，若见烦恼不生，名大涅般。”

代宗又引一大白山人来见和尚，曰：“此山人甚有见知。”师问：“解何艺业？”代宗曰：“识山，识地，识字，解算。”和尚借问：“山人所住是雌山，是雄山？”山人久而不答。又问：“识地不？”山人曰：“识。”师则指殿上地曰：“此是何地？”山人曰：“容弟子算，方得乃知。”又问：“识字不？”对曰：“识。”师向地上划作“一”字，问：“此是何字？”对曰：“此是‘一’字。”师曰：“‘土’上著‘一’字，是‘王’字，是什摩‘一’字！”又问：“解算不？”对曰：“解。”师曰：“三七是多小？”对曰：“和尚弄弟子，三七二十一。”师曰：“却是山人弄贫道。三七是十，唤作二一，岂非弄贫道？”又问：“山人更会何业？”山人曰：“更有，实不敢对。”师曰：“纵汝总解，亦不足贵。”师却请代宗曰：“问山不识山，问地不识地，问字不识字，问算不解算，何处引得这个朦汉来？”代宗向山人曰：“朕虽有国位，未为宝；和尚是真宝。”山人曰：“陛下真识宝人也。”

时十月中旬，有诸座主来礼拜和尚。师问：“城外草作何色？”曰：“作黄色。”师遂唤少童子问：“城外草作何色？”对曰：“作黄色。”师曰：“座主解经解论，与此厮兒见解何殊？”座主却问和尚：“城外草作何色？”师曰：“见天上鸟不？”座主曰：“和尚转更勿交涉也。愿和尚教某等作摩生即是。”师却唤座主向前来。座主一时向前来。师见诸座主不会，遂笑曰：“诸座主且归寺，别日却来。”

诸大德嘿然而往。明日又来：“愿和尚为某等说看。”师曰：“见即见，若不见，纵说得出亦不得见。”诸供奉曰：“从上国师，未有得似和尚如是机辩。”师曰：“他家即师国，贫道即国师。”诸供奉曰：“我等诸人，谩作供奉，自道解经、解论。据他禅宗都勿交涉。”

有南方禅客问：“如何是古佛心？”师曰：“墙壁瓦砾，无情之物，并是古佛心。”禅客曰：“与经太相违。故《涅盘经》曰：‘离墙壁瓦砾，无情之物，故名佛性。’今云一切无情皆是佛心。未审心与性为别不别？”师曰：“迷人即别，悟人即不别。”禅客曰：“又与经相违，故经曰：‘善男子心非佛性。佛性是常，心是无常。’今日不别，未审此义如何？”师曰：“汝依语而不依义。譬如寒月，结水为冰，及至暖时释冰为水。众生迷时，结性成心，众生悟时，释心成性。汝若定执无情无佛性者，经不应言‘三界唯心，万法为识’。故《华严经》曰：‘三界所有法，一切唯心造。’今且问汝：无情之物，为在三界内，为在三界外？为复是心，为复不是心？若非心者，经不应言‘三界唯心’；若是心者，不应言‘无情无佛性’。汝自违经，吾不违也。”禅客曰：“无情既有心，还解说法也无？”师曰：“他炽然说，恆说常说，无有间歇。”禅客曰：“某甲为什摩不闻？”师曰：“汝自不闻，不可妨他有闻者。”进曰：“谁人得闻？”师曰：“诸圣得闻。”禅客曰：“与摩即众生应无分也。”师曰：“我为众生说，不可为他诸圣说。”禅客曰：“某甲愚昧声瞽，不闻无情说法；和尚是为人天师，说《般若波罗蜜多经》，得闻无情说法不？”师曰：“我亦不闻。”进曰：“和尚为什摩不闻？”师曰：“赖我不闻无情说法。我若闻无情说法，我则同于诸圣。汝若为得见我，及闻我说法乎？”禅客曰：“一切众生，毕竟还得闻无情说法不？”师曰：“众生若闻，即非众生。”禅客曰：“无情说法，还有典据也无？”师曰：“言不关典，非君子之所谈。汝岂不见《弥陀经》云：‘水、鸟、树林，皆是念佛、念法、念僧。’鸟是有情，水及树岂是有情乎？又《华严经偈》云：刹说众生说，三世一切说。众生是有情，刹岂是有情乎？”客曰：“既是无情有佛性，未审有情又如何？”师曰：“无情尚尔，岂况有情乎？”禅客曰：“若有情无情俱有佛性，杀有情而食仵其身分，即结于罪怨相报。损害无情，食仵五谷、菜蔬、果栗等物，不闻有罪互相仇报也。”师曰：“有情是正报，从无始劫来，虚妄颠倒，计我我所，而怀结恨，即有怨报。无情是依报，无颠倒结恨心，所以不言有报。”客曰：“经教中但见有情授三菩提记，于未来世，而得作佛。号曰某等，不见无情授菩提记，作佛之处，只如贤劫千佛中，阿那个是无情成佛，请为示之。”师曰：“我今问汝：譬如皇太子受王位时，为太子一身受于王位，为复国界一一受也？”对曰：“但令太子受得王位，国土一切自属于王，宁当别受乎？”师曰：“今此亦尔。但令有情授记作佛之时，三千大千世界，一切国土，尽属毗卢遮那佛身。佛身之外，那得更有无情而得授记耶？”客曰：“一切大地既是佛身，一切众生居佛身上，便利秽污佛身，穿凿践踏佛身，岂无罪乎？”师曰：“一切众生全是佛身，谁为罪乎？”客曰：“佛身无为，无所挂碍。今以有为质碍之物而作佛身，岂不乖于圣旨乎？”师曰：“汝今不见《大品经》曰：‘不可离有为而说无为，又不可离无为而说有为。’汝信色是空不？”对曰：“佛之诚言，那敢不信？”师曰：“色既是空，宁有挂碍？”又问：“众生与佛既同者，只用一佛修行，一切众生应一时解脱。今见不尔，‘同’义何在？”师曰：“汝不见《华严经》中‘六相’义，同中有异，异中有同；成中有壤，坏中有成；总中有别，别中有总？众生与佛虽同一性，不妨各各自修自得。看他人食，终自不饱。”又问：“古德曰：‘青青翠竹，尽是真如；郁郁黄花，无非般若。’有人不许，是邪说；亦有人信，言‘不可思议。’不知若为？”师曰：“此盖是普贤、文殊大人之境界，非诸凡小而能信受。皆与大乘了义经意合。故《华严经》云：‘佛身充满于法界，普现一切群生前，随缘赴感靡不周，而恆处此菩提座。’翠竹既不出于法界，岂非法身乎？又《摩诃般若经》曰：‘色无边，故般若无边。’黄花既不越于色，岂非般若乎？此深远之言，不省者难为措意。”又问：“有善知识言，学道人但识得本心了，无常来时，抛却壳漏子一边著。灵台觉性，迥然而去，名为解脱，此复若为？”师曰：“此犹未离二乘外道之量。二乘之人，皆厌离有为生死，忻乐无余涅盘。《老子》亦曰：‘吾有大患，为吾有身。’忻乐冥谛，而为至道，乃趣冥谛，须陀洹人八万劫，斯陀含人六万劫，阿那含人四万劫，阿罗汉人二万劫，辟支佛十千劫。住于定中，外道亦八万大劫。住非想非非想天，二乘劫满，犹回心向大，外道劫满，不免轮回生死。”又问：“一切人佛性，为复一种，为复有别？”师曰：“不得一种。”进曰：“云何有别。”师曰：“有人佛性，全不生灭，有人佛性，半生灭半不生灭。”进曰：“谁人佛性，全不生灭？谁人佛性，半生灭半不生灭耶？”师曰：“我此间佛性，全不生灭，彼南方佛性，半生灭半不生灭。”进曰：“和尚佛性，若为全不生灭？南方佛性，若为半生灭半不生灭？”师曰：“我之佛性，身心一如，身外无余，所以全不生灭。南方佛性，身是无常，心性是常，所以半生灭半不生灭也。”进曰：“和尚身是色身，岂得便同法身不生灭耶？”师曰：“汝今那得入邪道乎？”禅客曰：“某甲早晚入于邪道也？”师曰：“《金刚经》曰：‘若以色见我，以音声求我，是人行邪道，不能见如来。’汝既作色见我，岂非入邪道乎？”于是禅客作礼而叹曰：“和尚此说，事无不尽，理无不周。某甲若不遇和尚，空过一生矣。”

肃宗皇帝问：“一切众生，忙忙业性，无本可据，日用而不知，此意如何？”师拈起金花叠子向帝曰：“唤作什摩？”帝曰：“金花叠子。”师曰：“灼然是一切众生，日用而不知。”

伏牛和尚与马大师送书到师处。师问：“马师说何法示人？”对曰：“即心即佛。”师曰：“是什摩语话！”又问：“更有什摩言说？”对曰：“非心非佛，亦曰：不是心，不是佛，不是物。”师笑曰：“犹较些子。”伏牛却问：“未审此间如何？”师曰：“三点如流水，曲似刈禾镰。”后有人举似仰山，仰山云：“水中半月现。”又曰：“三点长流水，身似鱼龙衣。”

肃宗皇帝问：“一切众生，忙忙业性，无本可据，日用而不知，无由得出离于三界。乞师方便，弟子与众生，离于生死。”师便索三个钅沙罗，盛水著讨蚁子，便抛放水里。蚁子在水中，绕转两三匝，困了浮在中心，死活不定。帝礼拜曰：“乞师慈悲。”师又索一草，抛放水里，其蚁子惊讶，依草便上钅沙罗外。皇帝豁然便悟。

代宗皇帝问：“师百年后要个什摩？”师曰：“与老僧造个无缝塔。”帝乃胡跪曰：“请师塔样。”师良久，帝罔措。师曰：“吾有付法弟子在，耽源却谙此事，问取他去。”

国师顿世后，帝乃诏耽源，举此因缘，问：“此意如何？”耽源乃作偈曰：

湘之南，潭之北，中有黄金充一国。

无影树下合同船，琉璃殿上无知识。

师大历十年十二月九日终，代宗谥号大证禅师。净修禅师赞曰：

唐朝国师，大播洪猷。

曹溪探日，渭水乘舟。

二天请偈，四众抛筹。

法才极赡，大耳惭著。

祖堂卷三·崛多三藏

崛多三藏嗣六祖。师天竺人也。行至太原定襄县历村，见秀大师弟子结草为庵，独坐观心。师问：“作什摩？”对曰：“看静。”师曰：“看者何人？静者何物？”僧遂起礼拜，问：“此理如何，乞师指示！”师曰：“何不自看？何不自静？”僧无对。师见根性迟回，乃曰：“汝师是谁？”对曰：“秀和尚。”师曰：“汝师只教此法，为当别有意旨？”对曰：“只教某甲看静。”师曰：“西天下劣外道所习之法，此土以为禅宗。也大误人！”其僧问：“三藏师是谁？”师曰：“六祖。”又曰：“正法难闻，汝何不往彼中？”其僧闻师提训，便去曹溪，礼见六祖，具陈上事。六祖曰：“诚如崛多所言，女何不自看？何不自静？教谁静汝？”其僧言下大悟也。

祖堂卷三·智策

智策和尚嗣六根，在务州。师自契曹溪密旨，逍遥物外，不拘小节，未决化缘始终。

师游北地，遇见五祖下智皇禅师一十年修定，师遂问：“在此间作什摩？”对曰：“入定。”师曰：“入定者为有心大定耶，为无心入定耶？若有心入定者，即一切有情悉皆有心，亦合得定；若无心入者，一切无情亦合得定。”智皇曰：“吾正入定之时，不见有无之心。”师曰：“若不见有无之心，即是常定，不应更有出入也。”智皇无对。却问：“汝师是谁？”师曰：“六祖。”“汝师以何法为禅定？”师曰：“妙湛圆寂，体用如如。五阴本空，六尘非有。不出不人，不定不乱。禅性无住，离住禅寂；禅性无生，离生禅相。心如虚空，亦无虚空之量。”皇闻此说，未息疑情，遂震锡南行，直往曹溪礼见六祖。六祖乃亦如上说，智皇禅师言下大悟。龙神其夜报旧住庵处檀越曰：“智皇禅师今夜得道。”

祖堂卷三·司空本净

司空山本净和尚嗣六祖。师姓张，绛州人也。僧问：“奇特事如何？”师曰：“无一念心喜。”僧曰：“岂得无喜耶？”师曰：“喜是阿谁分上事？”

天宝三年，敕令中使杨光庭往司空山采恆春藤。到于寺中，去禅师院语话次，问禅师曰：“弟子生死事大，一心慕道。愿和尚慈悲救度！”师曰：“大夫自京城来。帝王之地禅伯甚多，彼处问之。某甲老病，一无知解。”中使设礼再请，师曰：“为当求佛，为复问道？若求作佛，即心是佛；若欲问道，无心是道。”中使不会，再请说之。师又曰：“若欲求佛，即心是佛，佛因心得。若悟无心，佛亦无佛。若欲会道，无心是道。”中使曰：“京城大德皆令布施、持戒、忍辱、苦行寻求佛。今和尚曰：‘无漏智性，本自具足；本来清净，不假修行。’故知前虚用功耳。”

中使到京城进恆春藤讫，遂口奏禅师，具陈上事。帝乃闻之，敕令中使却往传诏取禅师。

天宝三年十二月十七日，到京参讫，帝敕于白莲花亭子安置。正月十五日，敕令京城内大师大德与禅师论道。禅师奏曰：“山僧久病，无暇谈论，不假繁辞。以要言之，安问敢对。”有泰平寺远禅师问曰：“对圣人不敢繁词，何者为道？”师曰：“道本无名，因心名道。心名若有，道不穷虚，然名心若无，道凭何有？二俱虚妄，总是假名。”问：“见有身心是道已不？”师曰：“小僧身心，本来是道。”问：“适来曰无心是道，今言身心本来是道，岂非相违？”师曰：“无心是道，心泯道无。心道一如，故曰无心是道。身心本来是道者，道亦本是身心。身心本既是空，道亦穷源不有。”远公曰：“渺小山僧还会道理？”师曰：“大德只见山僧相，不见无相。见相者是大德所见，故云凡所有相皆是虚妄。若见诸相非相，即悟其道；若以相为实者，穷劫不可得也。”问：“今见山僧相，不见山僧无相，请为于相中说无相理看。”师曰：“净名曰：‘四大无主，身亦无我。’今即无我所见与道相应。大德若以四大有主，主即是我。若有我见，恆沙劫中不可会得。是曰：‘圣人大悦，朝士忻然。’”师乃四大无主偈曰：

四大无心复如水，遇曲逢直无彼此。

净秽两处不生心，壅决何曾有二意？

境触但似水无心，在世纵横有何事？

又香山僧慧明问：“无心是道，瓦砾无心，亦应是道？”又曰：“身心是道，四生六类皆有身心，悉是道不？若有见闻，请对圣说！”师曰：“大德若作见闻觉知之者，非是求道之人，与道殊不相应。经曰：‘无眼耳鼻舌身意’，眼耳尚无，见闻觉知凭何说有？穷本不有，何处存心？若会无心，不同草木。”惠明无对。师遂见闻觉知偈曰：

见闻觉知无障碍，声香味触常三昧。

如鸟空中只没飞，无取无舍无憎爱。

若会应处本无心，方得名为观自在。

又白马寺惠真问：“禅师说无心是道？”师曰：“然。”问曰：“道既无心，佛有心耶？佛之与道，是一是二？”师曰：“不一不二。”问：“佛度众生为有心故，道不度人为无心故。一度一不度，是二是不二？”师曰：“此是大德妄生二见，山僧不然。何者？佛是虚名，道亦妄立。二俱不实，都是假名。一假之中立何二？”又问：“佛之与道纵是假名，当立名时，是谁为立？若有立者，何得言无？”师曰：“佛之与道，因心而立。推穷心本，心亦是无。二俱虚妄，犹如花翳。即悟本空，强立佛道。”于是惠真赞曰：“事无不尽，理无不备。此是顿见真门，即心是佛，可与后世众生轨则。”师无修偈曰：

见道方修道，不见复何修？

道性如虚空，虚空何处修？

遍观修道者，拨火见浮沤。

但看弄傀儡，线断一时休。

法空禅师问曰：“佛之与道尽是假名妄立，十二部经亦应不实。从前尊宿代代相承，皆言修道，总是妄不？”师曰：“然。十二部教皆合于道。禅师错会，背道逐教。道本无修，禅师强修；道本无作，禅师强作；道本无事，强生多事；道本无为，于中强为；道本无知，于中强知。如此见解，自是不会，须自思之。”师《背道逐教偈》曰：

道体本无修，不修自合道。

若起修道心，此人未会道。

弃却一真性，却入闹浩浩。

忽逢修道人，第一莫向道。

又福先寺安禅师问：“道是假名，佛亦妄立。十二部教接人方便，一切总妄，以何为真？”师曰：“为有妄故，将真对妄。推穷妄性，本来空寂。真亦何曾更有实体？故知真妄总是假名。”座下众人悉皆顿悟。又问：“一切是妄，妄亦同真。真妄无殊，复是何物？”师曰：“若言何物，此亦是妄。道无相似，道无比并，道无譬喻，道无对治。言道者以言诠理，得理忘言，知悟性空，此人悟道。经曰：‘言语道断，心行处灭。’”师《真妄偈》曰：

穷真真无相，穷妄妄无形。

返观推穷心，知心亦假名。

会道既如此，到头也只宁。

有所成寺达性禅师赞叹问：“其理甚妙。真妄双泯，佛道两亡。修行性空，名相不实。如是解时，不可断他众生善恶二根，可是菩提耶？”师曰：“善恶二根，因心而有。穷心若有，根亦不无。推心既空，根因何立？经曰：‘善不善从心化生。’善恶业缘，本无有实，虽则不实，不共心俱。”师《善恶二根不实偈》曰：

善既从心生，恶岂离心有？

善恶是外缘，于心实不有。

舍恶送何处？取善令谁守？

伤嗟二见人，攀缘两头走。

忽悟无生本，始会从前咎。

又士孙体虚问：“此身从何而来？百年后复归何处？”师曰：“如人睡时，忽然作梦，梦从何来？睡觉之时，梦从何去？”进曰：“梦时不可言无，忽觉不可言有。虽有往来，往来无所。”师曰：“贫道之身亦如其梦。”体虚顿悟此身实同于梦。师来往如梦偈曰：

亦知如在梦，睡里实是闹。

忽觉万事休，还同睡时觉。

智者会悟梦，迷人信梦闹。

会梦无两般，一悟无别悟。

富贵与贫贱，更亦无别道。

师上元三年五月五日迁化，春秋九十五。敕谥大晓禅师。

祖堂卷三·一宿觉

一宿觉和尚嗣六祖，在温州。师讳玄觉，字道明，俗姓戴氏，温州永嘉县人也。内外博通，食不耕锄，衣不蚕口，平生功业，非人所测。曾在温州开元寺，孝顺亲母，兼有姊，侍奉二人。合寺合廓，人谤其僧。有一日，亲母下世，著麻，未抛姊，又更被人谤，其僧不能观得。有一日，廊下见一禅师，号曰神策，年近六十有余，弟姊两人隔帘见其老宿，姊却向弟曰：“屈老宿归房里吃茶，还得也无？”弟便出来屈其老宿。老宿不欲得入，见其僧苦切，老宿许之。老宿去房里，女出来相看曰：“小弟容易，乞老宿莫怪。”便对老宿坐，又教弟坐。三人说话次，老宿见其僧气色异于常人，又女人亦有丈夫之气。老宿劝其僧曰：“孝顺之事，自是一路，虽明佛理，未得师印。过去诸佛，圣圣相传，佛佛印可。释迦如来，燃灯授记，若不然者，即堕自然矣。南方有大圣，号曰慧能禅师，可往礼足为师。”僧对曰：“昨者母亲下世，只有姊，独自无人看侍，争抛得？”姊却向弟说：“弟莫疑我，某甲独自身，取次寄住得，但自去。”弟僧从此装裹，却去寺主处具说前事。寺主曰：“师兄若这个善心，某甲身已不能去得，某相共造善因。师兄但去，莫愁其姊。某甲孝顺，但唤来他房里。”其僧一一依他寺主处分，唤姊去守主房里安排了，便发去。

其弟僧年当三十一，迤逦往到始兴县曹溪山，恰遇大师上堂，持锡而上，绕禅床三匝而立。六祖问：“夫沙门者，具三千威仪，八万细行，行行无亏，名曰沙门。大德从何方而来，生大我慢？”对曰：“生死事大，无常迅速。”六祖曰：“何不体取无生，达本无速乎？”对曰：“体本无生，达即无速。”祖曰：“子甚得无生之意。”对曰：“无生岂有意耶？”祖曰：“无意谁能分别？”对曰：“分别亦非意。”祖曰：“如是如是。”于时大众千有余人，皆大愕然。师却去东廊下挂锡，具威仪，便上礼谢，默然击目而出，便去僧堂参众，却上来辞。祖曰：“大德从何方来？返太速乎？”对曰：“本自非动，岂有速也？”祖曰：“谁知非动？”对曰：“仁者自生分别。”祖师一跳下来，抚背曰：“善哉，善哉！有手执干戈。”小留一宿，来朝辞祖师。禅师领众送其僧。其僧行十步来，振锡三下曰：“自从一见曹溪后，了知生死不相干。”

其僧归来，名号先播于众人耳，直道不可思议人也。收过者无数，供养者不一。从此所有歌行偈颂皆是其姊集也。师先天二年十月十七日迁化，春秋三十九，敕谥无相大师净光之塔。

祖堂卷三·怀让

怀让和尚嗣六祖，在南岳，姓杜氏，金州人也。初生之时，有六道白气应于上像。仪凤二年四月八日生，感此瑞气，刺使瞻见，奏闻高宗。帝曰：“此气何瑞？”太史曰：“国之法宝，非染俗贵，在于安康、金州分野。”时金州太守韩偕具录奏上，帝曰：“僧瑞宜加善庆。”敕韩偕亲往存毓。厚赐安慰。是时杜氏名曰光奇，家内有三子。于三子中其应瑞生者，年近五岁，炳然殊异，心怀恩让，不与竞。父母号之名为让。子至于十载，唯爱佛经。有三藏玄静过舍说法，告光奇曰：“此子出家之后当获上乘，至幽至微，会于佛理。”垂拱四年，年始十五，拜辞父母，往荆州玉泉寺事弘景律师。经于八年便怀让，至通天元年四月十二日于当寺受戒，至久视元年七月十八日自叹曰：“我受戒今经五夏，广学威仪而严有表，欲思真理而难契焉。”又曰：“夫出家者为无为法，天上人间无有胜者。”时有坦然禅师，睹让嗟叹，乃命云游，博问先知。至嵩山安和尚处，坦然问西来意话，坦然便悟，事安和尚。师乃往曹溪而依六祖。六祖问：“子近离何方？”对曰：“离嵩山，特来礼拜和尚。”祖曰：“什摩物与摩来？”对曰：“说似一物即不中。”在于左右一十二载，至景云二年礼辞祖师。祖师曰：“说似一物即不中，还假修证不？”对曰：“修证即不无，不敢污染。”祖曰：“即这个不污染底，是诸佛之所护念，汝亦如是，吾亦如是。西天二十七祖般若多罗记汝：佛法从汝边去，向后马驹踏杀天下人。汝勿速说此法，病在汝身也。”

马和尚在一处坐，让和尚将砖去面前石上磨。马师问：“作什摩？”师曰：“磨砖作镜。”马师曰：“磨砖岂得成镜？”师曰：“磨砖尚不成镜，坐禅岂得成佛也？”马师曰：“如何即是？”师曰：“如人驾车，车若不行，打车即是，打牛即是？”师又曰：“汝为学坐禅，为学坐佛？若学坐禅，禅非坐卧。若学坐佛，佛非定相。于法无住，不可取舍，何为之乎？汝若坐佛，却是杀佛。若执坐相，非解脱理也。”马师闻师所说，从座而起，礼拜问曰：“如何用心即合禅定无相三昧？”师曰：“汝学心地法门，犹如下种。我说法要，譬彼天泽。汝缘合故，当见于道。”又问：“和尚见道，当见何道？道非色故，云何能观？”师曰：“心地法眼能见于道，无相三昧亦复然乎？”马师曰：“可有成坏不？”师曰：“若契于道，无始无终，不成不怀，不聚不散，不长不短，不静不乱，不急不缓。若如是解，当名为道。汝受吾教，听吾偈曰：

心地含诸种，遇泽悉皆萌。

三昧花无相，何坏复何成？”

有大德间：“如镜铸像，像成后镜明向什摩处去？”师曰：“如大德未出家时相状向什摩处去？”进曰：“成像后为什摩不鉴照？”师曰：“虽然不鉴照，谩他一点不得。”

师天资三年八月十二日终，敕谥大慧禅师最胜轮之塔。


祖堂集卷四

祖堂卷四·石头

石头和尚嗣吉州思和尚，在南岳。师讳希迁，姓陈，端州高要人也。在孕之时，母绝膻秽。及诞之夕，满室光明。父母怪异，询乎巫祝。巫祝曰：“斯吉祥之徵也。”风骨端秀，方颐大耳，专静不杂，异乎凡童。及年甫龆龀，将诣佛寺，见尊像。母氏令礼，礼已曰：“斯佛也。”师礼讫，瞻望久之，曰：“此盖人也，形仪手足与人奚异？苟此是佛，余当作焉。”时道俗咸异斯言。亲党之内多尚淫祀，率皆宰犊以祈福佑。童子辄往林社毁其祀具，夺牛而还，岁盈数十，悉巡之于寺。自是亲族益修净业。时六祖正扬真教，师世业邻接新州，遂往礼觐。六祖一见忻然，再三抚顶而谓之曰：“子当绍吾真法矣！”与之置馔，劝令出家。于是落发离俗。开元十六年具戒于罗浮山。略探律部，见得失纷然，乃曰：“自性清静，谓之戒体。诸佛无作，何有生也？”自尔不拘小节，不尚文字，因读肇公《涅盘无名论》云：“览万像以成己者，其唯圣人乎？”乃叹曰：“圣人无己，靡所不己；法身无量，谁云自他？圆镜虚鉴于其间，万家体玄而自现。境智真一，孰为去来？至哉斯语也！”尚于山舍假寐如梦，见吾身与六祖同乘一龟，游泳深池之内，觉而详曰：“龟是灵智也；池，性海也。吾与师同乘灵智，游于性海久矣。”

六祖迁化时，师问：“百年后某甲依什摩人？”六祖曰：“寻思去。”六祖迁化后，便去清凉山靖居行思处。礼拜侍立，和尚便问：“从什摩处来？”对曰：“从曹溪来。”和尚拈起和痒子曰：“彼中还有这个也无？”对曰：“非但彼中，西天亦无。”和尚曰：“你应到西天也无？”对曰：“若到即有也。”和尚曰：“未在，更道。”对曰：“和尚也须道取一半，为什摩独考专甲？”和尚曰：“不辞向你道，恐已后无人承当。”和尚又问：“你到曹溪得个什摩物来？”对曰：“未到曹溪，亦不曾失。”师却问和尚：“在曹溪时还识和尚不？”思曰：“你只今识吾不？”对曰：“识又争能识得？”又问：“和尚自从岭南出后，在此间多少时？”思曰：“我亦不知汝早晚离曹溪。”对曰：“某甲不从曹溪来。”思曰：“我也知你来处。”对曰：“和尚幸是大人，莫造次。”思和尚见师异于常人，便安排于西侠，日夕只在和尚身边。其师形貌端正，足人是非，直得到和尚耳里。和尚得消息，向师曰：“汝正时是。”师便应喏。第二日，粥鼓鸣了，在西侠里坐，伸手取粥。厨下僧见其钵盂，寻来。元来其师取和尚粥，众人知是其人安排。凡夫不识圣人，谤和尚，又毁师。阖院一齐上来，于和尚前收过。思和尚向师曰：“从今已后，第一不得行此事。你若行此事，是你正眼埋却也不难。”师受戒后，思和尚问：“你已是受戒了也，还听律也无？”对曰：“不用听律。”思曰：“还念戒也无？”对曰：“亦不用念戒。”思曰：“你去让和尚处达书得否？”对曰：“得。”思曰：“速去速来。你若迟晚些子，不见吾。你若不见吾，不得床下大斧。”师便去到南岳让和尚处。书犹未达，先礼拜问：“不慕诸圣不重己灵时如何？”让和向曰：“子问太高生，向后人成阐提去。”师对曰：“宁可永劫沉沦，终不求诸圣出离。”师机既不投，书亦不达，便归师处。思和尚问：“彼中有信不？”师对曰：“彼中无信。”思曰：“有回报也无？”对曰：“信既不通，书亦不达。”师却问：“专甲去时，和尚有言，教速来床下收取大斧。峰已来也，便请大斧。”思和尚良久，师作礼而退。斯之要旨，岂劣器之能持？乃佛佛径烛心灯，祖祖玄传法印。大师既投针而久亲于丈室，临歧而回。承方外之机，则能事将备，道可行矣。思和尚曰：“吾之法门，先圣展转递相嘱授，莫令断绝。祖师预记于汝，汝当保持，善自好去。”非久之间，思和尚迁化。师著麻一切了，于天宝初方届衡岳。遍探岑壑，遂歇息于南台。

寺东有石如台，乃庵其上，时人号石头和尚焉。此台则梁海禅师得道之台也。师初至南台，师僧去看，转来向让和尚说：“昨来到和尚处问佛法、轻忽底后生来东石头上坐。”让曰：“实也无？”对曰：“实也。”让便唤侍者曰：“你去东边子细看，石头上坐底僧，若是昨来底后生，便唤他。若有应，你便道：‘石上憉忄享子，堪移此处栽。”侍者持此偈举似师。师答曰：“任你哭声哀，终不过山来。”侍者却来举似让和尚。和尚云：“这阿师！他后子孙噤却天下人口去。”又教侍者问法。侍者去彼问：“如何是解脱？”师曰：“阿谁缚汝？”“如何是净土？”师曰：“阿谁垢汝？”“如何是涅般？”师曰：“谁将生死与汝？”侍者却来举似和尚。和尚便合掌顶戴。此时有坚固禅师、兰、让三人为世宗匠，佥曰：“彼石头有真师子吼。”师唤主事具陈前事。主事曰：“乞师有事处分。”和尚领众去东边见石头。石头又强为不得，起来迎接，相看一切了，让和尚与石头起院成持也。僧问：“如何是祖师西来意？”师曰：“问取露柱去。”僧曰：“不会。”师曰：“我更不会。”大颠问：“古人道：‘道有道，无二谤。’请师除。”师曰：“正无一物，除个什摩？”师索大颠曰：“并却咽喉脣吻，速道将来。”对曰：“无这个。”师曰：“若与摩则你得入门也。”僧问：“如何是本来事？”师曰：“汝因何从我见？”进曰：“不从师觅，如何即得？”师曰：“何曾失却那作摩？”

药山在一处坐。师问：“你在这里作什摩？”对曰：“一物也不为。”师曰：“与摩则闲坐也。”对曰：“若闲坐则为也。”师曰：“你道不为，不为个什摩？”对曰：“千圣亦不识。”师以偈赞曰：

从来共住不知名，任运相将作摩行。

自古上贤犹不识，造次常流岂可明？

僧拈问：“漳南既是千圣，为什摩不识？”答曰：“千圣是什摩碗鸣声！”师问僧：“从什摩处来？”对曰：“从江西来。”师曰：“江西还见马祖不？”对曰：“见。”师乃指一柴橛曰：“马师何似这个？”僧无对，却回举似师，请师为决。马师曰：“汝见柴橛大小？”对曰：“勿量大。”马师曰：“汝甚有壮大之力。”僧曰：“何故此说？”马师曰：“汝从南岳负一柴橛来，岂不是有壮大之力？”师述《参同契》曰：

竺土大仙心，东西密相付。

人根有利钝，道无南北祖。

灵源明皎洁，枝派暗流注。

执事元是迷，契理亦非悟。

门门一切境，回互不回互。

回而更相涉，不尔依位住。

色本殊质像，声源异乐苦。

暗合上中言，明暗清浊句。

四大性自复，如子得其母。

火热风动摇，水湿地坚固。

眼色耳声音，鼻香舌咸醋。

然于一一法，依根叶分布。

本末须归宗，尊卑用其语。

当明中有暗，勿以明相遇。

当暗中有明，勿以暗相睹。

明暗各相对，譬如前后步。

万物自有功，当言用及处。

事存函盖合，理应箭锋住。

承言须会宗，勿自立规矩。

触目不见道，运足焉知路。

进步非远近，迷隔山河耳。

谨白参玄人，光阴勿虚度。

师与邓隐峰铲草次，见蛇。师过锹子与隐峰。隐峰接锹子了，怕，不敢下手。师却拈锹子截作两段，谓隐峰曰：“生死尚未过得，学什摩佛法。”师将锹子铲草次，隐峰问：“只铲得这个，还铲得那个摩？”师便过锹子与隐峰。隐峰接得锹子，向师铲一下。师曰：“你只铲得这个。”洞山代曰：“还有堆阜摩？”

师唐贞元六年庚午岁十二月六日终，春秋九十一，僧夏六十三。僖宗皇帝谥号无际大师见相之塔。

祖堂卷四·耽源

耽源和尚嗣忠国师，先是马大师门人也。师入京为国师侍者。后再见马大师，于大师前旋行一匝作圆相，然后于中心礼拜。大师曰：“你欲作佛也？”对曰：“某甲不解捏目。”大师曰：“吾不如汝。”百丈在泐潭推车次，师问：“车在这里，牛在什摩处？”百丈以手斫额，师以手拭目。

祖堂卷四·天皇

天皇和尚嗣石头，在荆南。师讳道悟，未睹行状，不决终始之要。师初问石头：“离却智慧，何法示人？”石头曰：“老僧无奴婢，离什摩？”进曰：“如何得玄旨？”石头曰：“你解撮风不？”师曰：“若与摩则不从今日去也。”石头曰：“未审汝早晚从那边来？”师曰：“某甲不是那边人。”石头曰：“我早个知汝来处。”师曰：“和尚亦不得赃贿于人。”石头曰：“汝身现在。”师曰：“虽然如此，毕竟如何示于后人？”石头云：“你道阿谁是后人？”师礼谢，深领玄要。问：“如何玄妙之说？”师云：“莫道我解佛法！”僧云：“争那学人疑滞何？”师曰：“何不问老僧？”僧曰：“问则问了也。”师曰：“去！不是你存泊处。”

师乃一日忽然唤典座，典座来。师示曰：“会摩？”曰：“不会。”师便把枕子当面抛之，乃告寂。

祖堂卷四·尸梨

尸梨和尚嗣石头。顺宗皇帝问师：“大地普众生，见性成佛道？”师曰：“佛性犹如水中月，可见不可取。”大义禅师曰：“佛性非见，必见水中月，何不攫取？”帝默然之。又问大义：“何者是佛性？”大义云：“不离陛下所问。”皇帝默契玄关，一言遂合。

祖堂卷四·丹霞

丹霞和尚嗣石头。师讳天然，少亲儒墨，业洞九经。初与庞居士同侣入京求选，因在汉南道寄宿次，忽夜梦日光满室。有鉴者云：“此是解空之祥也。”又逢行脚僧，与吃茶次，僧云：“秀才去何处？”对曰：“求选官去。”僧云：“可借许功夫，何不选佛去？”秀才曰：“佛当何处选？”其僧提起茶碗曰：“会摩？”秀才曰：“未测高旨。”僧曰：“若然者，江西马祖今现住世说法，悟道者不可胜记，彼是真选佛之处。”二人宿根猛利，遂返秦游而造大寂，礼拜已，马大师曰：“这汉来作什摩？”秀才汰上幞头，马祖便察机，笑而曰：“汝师石头摩？”秀才曰：“若与摩则与某甲指示石头。”马祖曰：“从这里去南岳七百里，迁长老在石头，你去那里出家。”秀才当日便发去，到石头参和尚。和尚问：“从什摩处来？”对曰：“某处来。”石头曰：“来作什摩？”秀才如前对，石头便点头曰：“著槽厂去。”乃执爨役。经一二载余，石头大师明晨欲与落发，今夜童行参时，大师曰：“佛殿前一搭草，明晨粥后铲却。”来晨诸童行竞持锹酴，唯有师独持刀水，于大师前跪拜揩洗。大师笑而剃发。师有顶峰突然而起，大师按之曰：“天然矣。”落发既毕，师礼谢度兼谢名，大师曰：“吾赐汝何名？”师曰：“和尚岂不曰‘天然’耶？”石头甚奇之，乃为略说法要，师便掩耳云：“太多也。”和尚云：“汝试作用看。”师遂骑圣僧头，大师云：“这阿师！他后打破泥龛塑像去。”

师受戒已，而大寂耀摩尼于江西，师乃下岳，再诣彼，礼谒大寂。大寂问：“从什摩处来？”对曰：“从石头来。”大寂曰：“石头路滑，还弛倒也无？”对曰：“若弛倒即不来此也。”大寂甚奇之。师放旷情杯，涛违顺境，乐乎云水，去住逍遥。至洛京，参忠国师。初见侍者便问：“和尚还在也无？”对曰：“在，只是不看客。”师曰：“大深远生！”侍者曰：“佛眼觑不见。”师曰：“龙生龙子，凤生凤子。”侍者举似国师，国师便打侍者。师寻上邓州丹霞山，格调孤峻，少有攀者。爰有禅德远来问津，山下遇见师，遂辄申问：“丹霞山在什摩处？”师指山曰：“青青黯黯底是。”禅德曰：“莫只这个便是不？”师曰：“真师子兒，一拨便转。”次于天台，居花顶峰三载。又礼国一禅师。以元和初上龙门香山，与伏牛禅师为莫逆侣。后于惠林寺，遇天寒，焚木佛以御次，主人或讥，师曰：“吾荼毗，觅舍利。”主人曰：“木头有何也？”师曰：“若然者何责我乎？”主人亦向前，眉毛一时坠落。有人问真觉大师：“丹霞烧木佛，上座有何过？”大师云：“上座只见佛。”进曰：“丹霞又如何？”大师云：“丹霞烧木头。”

师有时到山院寄宿，见老宿共行者同床坐。师放下衣钵便问讯二人，二人都不顾视。直至来朝，遂见行者将一铛饭向堂中心著，共老宿吃，又不唤师。师亦自向前共吃。行者见师向前，便顾视老宿云：“莫言侵早起。”师向老宿曰：“这个行者，何不教伊？大无礼生！”老宿云：“好个人家男女，有什摩罪过？点污他作什摩！”师云：“适来洎错放过。”

师作《孤寂吟》曰：

时人见余守孤寂，为言一生无所益。

余则闲吟孤寂章，始知光阴不虚掷。

不弃光阴须努力，此言虽说人不识。

识者同为一路行，岂可颠坠缘榛棘。

榛棘茫茫何是边，只为终朝尽众喧。

众喧不觉无涯际，哀哉真实不虚传。

传之响之只不闻，犹如灯烛合盂盆。

共知总有光明在，看时未免暗昏昏。

昏昏不觉一生了，斯类尘沙比不少。

直似潭中吞钩鱼，何异空中荡罗鸟。

此患由来实是长，四维上下远茫茫。

倏忽之间迷病死，尘劳难脱哭怆怆。

怆怆哀怨终无益，只为将身居痛室。

到此之时侮何及，云泥未可访孤寂。

孤寂宇宙穷为良，长吟高卧一闲堂。

不虑寒风吹落叶，岂愁桑草遍遭霜。

但看松竹岁寒心，四时不变流清音。

春夏暂为群木映，秋冬方见郁高林。

故知世相有刚柔，何必将心清浊流。

二时组糖随缘过，一身遮莫布毛裘。

随风逐浪往东西，岂愁地迮与天低。

时人未解将为错，余则了然自不迷。

不迷须有不迷心，看时浅浅用时深。

此中真珠若采得，岂同樵夫负黄金。

黄金亨练转为真，明珠含光未示人。

了即毛端滴巨海，始知大地一微尘。

尘滴存乎未免僭，莫弃这边留那边。

直似长空搜鸟迹，始得玄中又更玄。

举一例诸足可知，何用喃喃说引词。

只见饿夫来取饱，未闻浆逐渴人死。

多人说道道不行，他家未悟诈头明。

三寸刺刀开旷路，万株榛棘拥身生。

尘滓茫茫都不知，空将辩口泻玄微。

此物那堪为大用，千生万劫作贫兒。

聊书孤寂事还深，锺期能听伯牙琴。

道者知音指其掌，方贵名为孤寂吟。

师又有《玩珠吟》：

识得衣中宝，无明醉自惺。

百骸俱溃散，一物镇长灵。

知境浑非体，寻珠不见形。

悟即三身佛，迷疑万卷经。

在心心岂测，居耳耳难听。

罔像先天地，渊玄出杳冥。

本刚非锻炼，元净莫澄停。

盘泊逾朝日，玲珑映晓星。

瑞光流不灭，真澄浊还清。

鉴照崆峒寂，劳笼法界明。

悍凡功不灭，超圣果非盈。

龙女心亲献，蛇王口自倾。

护鹅人却活，黄雀义犹轻。

解语非关舌，能言不是声。

绝边弥瀚漫，三际等空平。

演教非为教，闻名不认名。

二边俱不立，中道不须行。

见月休看措，归家罢问程。

诚心岂测佛，何佛更堪成？

又颂曰：

丹霞有一宝，藏之岁月久。

从来人不识，余自独防守。

山河无隔碍，光明处处透。

体寂常湛然，莹彻无尘垢。

世间采取人，颠狂逐路走。

余则为渠说，抚掌笑破口。

忽遇解空人，放旷在林薮。

相逢不擎出，举意便知有。

师又有《骊龙珠吟》：

骊龙珠，骊龙珠，光明灿烂与人殊，

十方世界无求处，纵然求得亦非珠。

珠本有，不升沉，时人不识外追寻，

行尽天涯自疲极，不如体取自家心。

莫求觅，损功夫，转求转见转元无。

恰如渴鹿趁阳焰，又似狂人在道途。

须自体，了分明，了得不用更磨莹，

深知不是人间得，非论六类及生灵。

虚用意，损精神，不如闲处绝纤尘，

停心息意珠常在，莫向途中别问人。

自迷失，珠元在，此个骊龙终不改。

虽然埋在五阴山，自是时人生懈怠。

不识珠，每抛掷，却向骊龙前作客，

不知身是主人公，弃却骊龙别处觅。

认取宝，自家珍，此珠元是本来人，

拈得玩弄无穷尽，始觉骊龙本不贫，

若能晓了骊珠后，只这骊珠在我身。

师有《弄珠吟》：

般若神珠妙难测，法性海中亲认得。

隐现时游五蕴山，内外光明大神力。

比珠无状非大小，昼夜圆明悉能照。

用时无处复无踪，行住相随常了了。

先圣相传相指授，信此珠人世希有。

智者号明不离珠，迷人将珠不识走。

吾师权指喻摩尼，采人无数入春池。

争拈瓦砾将为宝，智者安然而得之。

言下非近亦非远，体用如如转无转。

万机珠对寸心中，一切时中巧方便。

皇帝曾游于赤水，视听争求都不遂。

罔像无心却得珠，能见能闻是虚伪。

非自心，非因缘，妙中之妙玄中玄。

森罗万像光中现，寻之不见有根源。

烧六贼，烁四魔，能摧我山竭爱河。

龙女灵山亲献佛，贫兒衣里枉蹉跎。

亦非性，亦非心，非性非心超古今。

体绝名言名不得，权时题作弄珠吟。

师与麻谷游山，到涧边语话次，麻谷问：“如何是大涅盘？”师回头云：“急。”谷曰：“急个什摩？”师云：“涧水。”

师初开堂时，有人问：“作摩生语话即得不坠门风？”师曰：“一任语话即不堕门风。”僧云：“便请和尚语话。”师曰：“青山绿水不相似。”师勘僧曰：“什摩处来？”对曰：“山下来。”师曰：“吃饭也未？”对曰：“吃饭了也。”师曰：“将饭与阇梨吃底人还有眼也无？”僧无对。有人举似沩山，沩山云：“有。”进曰：“眼在什摩处？”沩山曰：“眼在顶上。”有人持此话举似洞山，洞山云：“若不是沩山，争解与摩道？”僧便问：“作摩生是在顶上底眼？”洞山云：“不昧向上。”招庆拈问保福：“将饭与人吃，感恩则有分，为什摩却成不具眼去？”保福云：“施者受者，二俱瞎汉。”庆云：“忽有人尽其机来，还成瞎汉不？”保福曰：“和尚还为人摩？”庆云：“教某甲共阿谁商量？”保福寻后曰：“道某甲瞎汉得摩？”师又有《如意颂》曰：

真如如意宝，如意宝真如。

森罗及万象，一法更无余。

海澄孤月照，天地洞然虚。

寂寂空形影，明明一道如。

师以长庆三年癸卯岁六月二十三日告门人，令备汤，沐讫云：“吾将行矣。”乃戴笠子，策杖入屦，垂一足未至地而逝。春秋八十六。敕谥智通大师妙觉之塔。刘轲撰碑文。

祖堂卷四·招提

招提和尚嗣石头。师讳惠明，姓欧阳，韶州曲江人也。年十三，于邓林寺摸禅师处出家。十七游衡岳，二十受戒，乃往虔州龚公山谒大寂。大寂云，“你来何求？”对曰：“求佛知见。”大寂曰：“佛无知见，知见乃魔界耳。你从南岳来，似未见石头曹溪心要耳。汝应却归石头。”师遂依言而返，造石头，果应大寂之言，契缘悟达。不出招提三十余年，因号招提朗矣。至元和十五年庚子岁正月二十二日迁化，春秋八十三，僧夏六十四矣。

祖堂卷四·药山

药山和尚嗣石头，在朗州。师讳惟俨，姓韩，绛州人也，后徙南康。年十七，事潮州西山慧照禅师。大历八年，受戒于衡岳寺希澡律师。师一朝言曰：“大丈夫当离法自净，焉能屑屑事细行于布巾耶？”即谒石头大师，密领玄旨。师于贞元初居澧阳芍药山，因号药山和尚焉。

师初住时，就村公乞牛栏为僧堂。住未得多时，近有二十来人。忽然有一僧来请他为院主，渐渐近有四五十人。所在迫侠［狭］，就后山上起小屋，请和尚去上头安下。和尚上头又转转师僧王。其院主僧再三请和尚为人说法。和尚一二度不许，第三度方始得许，院主便欢喜，先报大众。大众喜不自胜，打锺上来。僧众才集，和尚关却门便归丈室。院主在外责曰：“和尚适来许某甲为人，如今因什摩却不为人？赚某甲。”师曰：“经师自有经师在，论师自有论师在，律师自有律师在。院主怪贫道什摩处？”从此后从容得数日，后升座，便有人问：“未审和尚承嗣什摩人？”师曰：“古佛殿里拾得一行字。”进曰：“一行字道什摩？”师曰：“渠不似我，我不似渠，所以肯这个字。”李翱相公来见和尚，和尚看经次，殊不采顾。相公不肯礼拜，乃发轻言：“见面不如千里闻名。”师召相公，相公应诺。师曰：“何得贵耳而贱目乎？”相公便礼拜。起来，申问：“如何是道？”师指天又指地曰：“云在青天水在瓶。”相公礼拜。后以偈□曰：

练得身形□鹤形，千株松下两函经。

我闻□□□□□，□□青天水在瓶。

师因一□□□上□□□□夜而大笑一声，澧阳东来去□□九十□□□□□夜同闻笑声，尽曰：“是东家声来□□□□□□□东推。”直至药山。徒众曰：“夜间和尚□顶□□。”李相公赞曰：

选得幽居惬野情，终年□□□□□。

有时直上孤峰顶，月下披云笑一声。

相公□问：“如何是戒定慧？”师曰：“贫道这里无这个闲家具。”问：“己事未明，乞和尚指旨［示］。”师沉吟良久曰：“吾今为汝道一句亦不难，只宜汝于言下□□去。”师因唤沙弥。道吾曰：“用沙弥童行作什摩？”师曰：“为有这个。”吾曰：“何不弃却？”师曰：“有来多少时？”师因石头垂语曰：“言语动用亦勿交涉。”师曰：“无言语动用，亦勿交涉。”石头曰：“这里针扎不入。”师曰：“这里如石上栽花。”有人拈问漳南：“古人石上栽花意作摩生？”漳南曰：“伏汝大胆。”却曰：“还会摩？”对曰：“不会。”云：“癞人吃猪肉。”师问僧：“近离什摩处？”对曰：“近离百丈。”师曰：“海师兄一日十二时中，为师僧说什摩法？”对曰：“或曰三句外省去，或曰六旬外会取，或曰未得玄鉴者。且依了义教，犹有相亲分。”师曰：“三千里外且喜得勿交涉。”

师带刀行次，道吾问：“背后底是什摩？”师拔刀便蓦口斫。师夜不点火，僧立次，师乃曰：“我有一句子，待特牛生兒，即为汝说。”僧曰：“特牛生兒了也，只是和尚不说。”师便索火。火来，僧便抽身入众。后云岩举似洞山，洞山曰：“此僧却见道理，只是不肯礼拜。”僧拈问长庆：“既是见，为什摩不肯礼拜？”庆曰：“只为无礼。”白莲拈问：“僧既见道理，为什摩不肯礼？”无对。白莲代曰：“更不欲得出头。”师又时唤沙弥。云岩曰：“唤他作什摩？”师曰：“我有折脚铛子，要伊提上提下。”岩曰：“若与摩，则某甲与和尚一人出一手。”师又时问僧：“汝诸方行脚来觅取难得底物来不？”僧对不中。师曰：“堪作什摩用？”师代曰：“不缘闺閤（里外）所滞，觅来久矣。”师问云岩：“作什摩？”对曰：“担水。”师曰：“那个尼？”对曰：“在。”师曰：“你来去为阿谁？”对曰：“替渠东西。”师曰：“何不教伊并头行？”对曰：“和尚莫谤他。”师曰：“不合与摩道。”师代曰：“还曾担担摩？”

师有时曰：“我有一句字，未曾向人说。”道吾曰：“相随来也。”师问僧：“汝从什摩处来？”对曰：“南泉来。”师曰：“在彼中多少时？”对曰：“经冬过夏。”师曰：“与摩则作一头水牯牛去也。”对曰：“虽在彼中，不曾上他食堂。”师曰：“不可口吃东西风也。”对曰：“莫错和尚，自有人把匙箸在。”云岩问：“一句子如何言说？”师曰：“非言说。”道吾曰：“早说了也。”云岩因乞百丈斋，师问：“阴界不吃，乞与阿谁？”对曰：“有一人要。”因于迪相公问紫玉：“佛法至理如何？”玉召相公名，相公应喏。玉曰：“更莫别求。”师闻举曰：“搏杀这个汉。”僧便问师：“如何？”师代曰：“是什摩？”院主报和尚：“打锺也，请和尚上堂。”师曰：“汝与我擎钵盂来。”院主不会。云岩曰：“和尚无手脚来多少时？”师曰：“汝只是狂［枉］被袈裟。”岩曰：“某甲只与摩，和尚如何？”师曰：“我无这个眷属。”

师问园头：“作什摩来？”对曰：“栽菜来。”师曰：“栽则不障，你莫教根生。”园头曰：“既不教根生，大众吃个什摩？”师曰：“你还有口摩？”师书一“佛”字，问道吾：“是什摩字？”吾曰：“是‘佛’字。”师曰：“咄！这多口阿师。”千佛代叉手退后立，又代药山第二机曰：“错。”

有僧在药山三年作饭头，师问：“汝在此间多少时？”对曰：“三年。”师曰：“我总不识汝。”其僧不会，恨而发去。问：“学人有疑，请师决。”师曰：“且待上堂时来。”师晚际上堂曰：“今日有僧决疑，在什摩处？出来！”其僧才出来，师便托出，却入房丈。师行次，云岩避边侧立，待师到，云：“后底，后底。”师便蓦口掴。问：“如何得不被诸境惑？”师曰：“听他，何碍你？’僧曰：“学人不会此意如何？”师曰：“何境惑你？”问：“如何是道中指宝？”师曰：“莫谄曲。”进曰：“不谄曲时如何？”师曰：“倾国不换。”

道吾和尚四十六方始出家，俗姓王，锺陵建昌县人也。云岩和尚是道吾亲弟也。云岩先出家，在百丈造侍者。道吾在屋里报探官。一日行得五百里，恰到百丈庄头，讨吃饭。当时侍者亦下庄头。庄主唤侍者对客。侍者来相看一切后，便问：“将军是什摩处人？”曰：“锺陵建昌人也。”“贵姓什摩？”对曰：“姓王。”侍者便认得家兄，便把手啼哭云：“娘在无？”对曰：“忆师兄，哭太煞，失却一只眼，下世去。”侍者得消息，当日便上百丈。侍者须兄参一切后，侍者便谘白和尚：“这个是某甲兄，欲投师出家，还得也无？”百丈曰：“投某出家则不得。”侍者曰：“作摩生即是？”百丈曰：“投师伯处出家。”侍者领去师伯处，具陈前事，师伯便许，兄便投出家。

后侍者领师弟入京受戒了，却转来近百丈。两人坐地歇息次，道吾起来礼拜曰：“某甲有一段事，欲问多时，未得其便。今日有幸，启问师兄，还得也无？”岩曰：“有什摩事？”吾便问：“离却这个壳漏子后，与师兄什摩处得相见？”岩曰：“不生不灭处相见。”吾曰：“莫道草里无人，自有鉴人。”岩曰：“作摩是你幞头痕子尚犹在，有这个身心？”吾曰：“启师兄，莫下这个言词。佛法不在僧俗。”岩便问：“与摩理长则就，师弟作摩生？”吾曰：“非不生不灭处，亦不求相见。”云岩后曰：“灼然是你眼目得与摩细，若也到山中，递相度脱。”便归百丈。过得一年后，道吾辞百丈，便到药山。药山问：“一句子如何言说？”吾曰：“有一人总不曾言说。”师曰：“大藏小藏从何来？”吾曰：“傍出。”师甚奇之。因此学禅得滋味，后只观望师兄来。有一日造书，书上说：“石头是真金铺。江西是杂货铺。师兄在彼中堕根作什摩？千万千万，速来速来。”云岩得这个信后，只管忧愁。有一日在和尚身边侍立，直到三更。和尚曰：“且歇。”岩不去。和尚曰：“你有什摩事？颜容瘦恶，恰似肚里有事。有事但说。”云岩云：“无事。”和尚曰：“莫是得智阇梨信不？”岩云：“不敢。”百丈索道吾信，岩便取，呈似和尚。和尚见了云：“灼然是‘生我老父母，成我者朋友’。你不用在我这里，便速去。”岩曰：“不敢去。”百丈曰：“我有书兼有信物，欲得送药山尊者，你持书速去。”

云岩奉师处分，持书到药山。道吾相接，引去和尚处。达书一切了后，药山问：“海师兄寻常说什摩法？”对曰：“三句外省去，亦曰六句外会取。”师曰：“三千里外且喜得勿交涉。”又问：“更有什摩言句？”对曰：“有时说法了，大众下堂次，师召大众，大众回首，师曰：‘是什摩？’药山曰：“何不早道？海兄犹在，因汝识得百丈矣。”师问云岩：“目前生死如何？”对曰：“目前无生死。”师曰：“二十年在百丈，俗气也未除。”岩却问：“某甲则如此，和尚如何？”师曰：“挛挛拳拳，羸羸垂垂，百丑千拙，且与摩过时。”从此共师弟递相成持。云岩后有一日辞药山。药山问：“去什摩处？”对曰：“欲去沩山师兄处。”师曰：“为什摩事？”对曰：“某甲与沩山在百丈时有一愿。”师曰：“愿道什摩？”对曰：“某等两人曾在百丈时，沩山和尚造典座，某甲造侍者，不离左右，佐副和尚。在后达于本愿，欲得说破这个事。”师便许，岳便下山。道吾担衣钵送到桥亭后却转来，不审和尚。和尚云：“送师兄去来？”对曰：“送了也。”道吾却问：“师兄离师左右，还得也无？”师曰：“智阇梨何必有此问？多少年压膝道伴，何事不造作，何事不商量？不用更问。”道吾云：“无和尚一言，堪为后来是标榜，乞和尚一言。”师曰：“若也如此，我则与汝道：‘眼则有也，只欠涛汰。’”道吾闻此语，当夜便发，明朝到山下村院，得见师兄，说药山语了，相共转来药山，直到终，不离左右。

真觉大师举问玄晤大师：“眼门放光，照破山河。山河大地，不碍眼光。此人过在什摩处，只欠涛汰。”玄晤大师曰：“除却两人，降此已下，任你大悟去，也须涛汰。”进曰：“此是什摩人？”对曰：“西天是一人，唐土是一人。”进曰：“西天一人是什摩人？”对曰：“维摩居士。”“唐土是什摩人？”云：“双林傅大士。”进曰：“此两人被什摩时节因缘，即不涛汰？”对曰：“札竹/到则过於老兄。”（此是龙花举也，若依祖堂举者）云岩不安时，道吾问：“离却这个壳漏子，向什摩处再得相见？”岩曰：“不生不灭处相见。”吾曰：“何不道‘非不生不灭处，亦不求相见’？”

师问云岩：“马有角，你还见也无？”对曰：“有，要见作什摩？”师曰：“与摩则好马也。”对曰：“若是好马，则将出去。”

师有一日看经次，白颜问和尚：“休得看经，不用摊人得也。”师卷却经，问白颜曰：“势何似？”对曰：“正当午时。”师曰：“犹有纹彩在。”对曰：“无亦无。”师曰：“你大煞聪明。”却问道：“某甲如此，和尚如何？”师曰：“挛挛拳拳，羸羸垂垂，百丑千拙，且与摩过时。”

茗溪和尚对师说话去後，师向云岩曰：“茗溪向上曾为节察来。”岩却问和尚：“向上曾为什摩？”师日：“挛挛拳拳，羸羸垂垂，百丑千拙，且与摩过时。”

岩礼拜出去，向道吾拈起因缘。吾曰：“好话只欠一问。”岩云：“作摩生问？”道吾曰：“何故如此？”岩才得个问头，便去和尚处，续前问：“何故如此？”师曰：“书卷不曾展。”後有人举似石霜。石霜曰：“不曾展他书卷。”

又时，侍者请和尚吃药食。师曰：“不吃。”进曰：“为什摩不吃？”师曰：“消他不得。”进曰：“什摩人消得？”师曰：“不犯优婆事者。”进曰：“和尚为什摩消他不得？”师拈起绵卷子日：“争奈这个何？”

云岩请师浴，师曰：“我不浴。”进曰：“为什摩不浴？”师曰：“无垢。”进曰：“无垢却须浴。”师曰：“这苍生，无垢浴什摩？”进曰：“争那如许多孔窍何？”

师勘东国僧，问：“汝年多少？”对曰：“七十八。”师曰：“可年七十八摩？”对曰：“是也。”师便打之。後有人拈问曹山：“作摩生只对，免得药山打之？”曹山曰：“正衔天子敕，诸侯避路傍。”进曰：“只如上座。过在什摩处即被打之？”曹山曰：“前锵托犹浅，后箭射人深。”

问：“学人拟欲归乡去时如何？”师曰：“有人遍身烘烂，卧荆棘之中，阇梨作摩生归？”对曰：“与摩则某甲却不归去也。”师曰：“无。却须归乡去。你若归乡去，我与你休粮方。”进曰：“请和尚休粮方。”师曰：“二时把钵盂上堂，莫咬破一粒米。”曜日颁：

遍身烘烂更何人，卧棘森森一智真。

为报你来须体妙，时中不拟宛然新。

石室高沙弥往京城受戒，恰到朗州，经过次，近药山下，路上忽见一个老人。沙弥问老人万福，老人曰：“法公万福。”沙弥问：“前程如何？”老人曰：“法公何用忙，这里有肉身菩萨出世，兼是罗汉僧造院主，何妨上山礼拜？”沙弥才得个消息，便到药山，换衣服直上法堂，礼拜和尚。师曰：“从什摩处来？”对曰：“从南岳来。”师曰：“什摩处去？”对曰：“江陵受戒去。”师曰：“受戒图什摩？”对曰：“图免生死。”大师曰：“有一人不受戒而远生死，阿你还知也无？”对曰：“既若如此，佛在世制二百五十条戒又奚为？”师曰：“咄！这饶舌沙弥，犹挂著脣齿在。”师便教伊参众去。其沙弥去库头相看主事次，道吾来，不审和尚。和尚向道吾曰：“你见适来跛脚沙弥摩？”对曰：“见。”师曰：“此沙弥有些子气息。”吾曰：“村里男女有什摩气息？未得草草，更须勘过始得。”师教侍者唤其沙弥，沙弥便上来。师曰：“闻说长安甚大闹，汝还知也无？”对曰：“不知。我国甚安清。”师曰：“汝从看经得，从人请益得？”对曰：“不从看经得，亦不从人请益得。”师曰：“大有人不看经亦不从人请益。为什摩不得？”对曰：“不道他无，自是不肯承当。”师向道吾曰：“不信道老僧不虚发言。”便下床抚背云：“真师子兒。”沙弥又辞。师问：“汝向什摩处去？”对曰：“住庵去。”师曰：“生死事大，汝何不受戒？”对曰：“彼此知是一般事，唤什摩作受戒？”师曰：“若与摩在我身边，时复要见。”因此在药山去半里地卓庵过一生，呼为石室高沙弥也。

僧问：“身命切急处如何？”师曰：“莫种杂粮。”进曰：“将何供养？”师曰：“无口者。”师垂语曰：“是你请人欲知保任，向高高山顶立，向深深海底行。此处行不异，方有小许些子相应之分。”有人拈问顺德：“古人有言：‘向高高山顶立，向深深海底行。’如何是‘高高山顶立’？”德云：“只处峭峭。”“如何是‘深深海底行’？”德云：“深湛履践。”

师看经次，僧问：“和尚寻常不许人看经，为什摩却自看经？”师曰：“我要遮眼。”进曰：“学人学和尚看经得不？”师曰：“汝若学我看经，牛皮也须穿过。”长庆拈问僧：“古人遮眼，眼有何过？”对者非一，不称师旨。自代曰：“一翳又作摩生？”

师大和八年甲寅岁十一月六日告众曰：“法堂倒也，法堂倒也。”众人不测，遂把物撑之。师拍手大笑曰：“汝不会我意。”师遂告寂，春秋八十四，僧夏六十五，敕谥弘道大师化城之塔。


祖堂集卷五

祖堂卷五·大颠

大颠和尚嗣石头，在潮州。元和十三年戊戌岁迎真身，元和皇帝于安远门躬自焚香，迎候顶礼。皇帝及百寮俱见五色光现，皆云是佛光，百寮拜贺圣感。唯有侍郎韩愈一人独言不是佛光，不肯拜贺圣德。帝问：“既不是佛光，当此何光？”侍郎当时失对，被贬潮州。侍郎便到潮州，问左右：“此间有何道德高行禅流？”左右对曰：“有大颠和尚。”侍郎令使往彼三请，皆不赴。后和尚方闻佛光故乃自来，侍郎不许相见，令人问：“三请不赴，如今为什摩不屈自来？”师云：“三请不赴，不为侍郎；不屈自来，只为佛光。”侍郎闻已喜悦，则申前旨，“弟子其时云不是佛光，当道理不？”师答曰：“然。”侍郎云：“既不是佛光，当时何光？”师曰：“当是天龙八部释梵助化之光。”侍郎云：“其时京城若有一人似于师者，弟子今时日不来此。”侍郎又问曰：“未审佛还有光也无？”师曰：“有。”进曰：“如何是佛光？”师唤云：“侍郎。”侍师应喏。师曰：“看还见摩？”侍郎曰：“弟子到这里知不会。”师云：“这里若会得，是真佛光。故佛道一道，非青黄赤白色，透过须弥卢围，遍照山河大地，非眼见，非耳闻，故五日不睹其客，二听不闻其响。若识得这个佛光，一切圣凡虚幻无能惑也。”师欲归山，留一偈曰：

辞君莫怪归山早，为忆松萝对月宫。

台殿不将金锁闭，来时自有白云封。

自后侍郎特到山，复礼乃问：“弟子军州事多，佛法中省要处，乞师指示。”师良久，侍郎罔措，登时三平造侍者在背后敲禅床，师乃回视云：“作摩？”对曰：“先以定动，然后智拔。”侍郎向三平云：“和尚格调高峻，弟子罔措。今于侍者边却有入处。”礼谢三平，却归州。

后一日上山礼师，师睡次，见来不起。便问：“游山来，为老僧礼拜来？”对曰：“礼拜和尚来。”师曰：“不礼更待何时！”侍郎便礼拜。

后一日又上山，师问：“游山来，为老僧礼拜来？”侍郎曰：“游山来。”师曰：“还将得游山杖来不？”对曰：“不将得来。”师曰：“若不将来，空来何益？”

又一日师曰：“老僧往年见石头，石头问：‘阿那个是汝心？’对曰：‘即只对和尚言语者是。’石头便喝之。经旬日却问：‘和尚前日岂不是？除此之外何者是心？’石头云：‘除却扬眉动目一切之事外直将心来。’对曰：‘无心可将来。’石头曰：‘先来有心，何得言无心？有心无心，尽同谩我。’于此时言下大悟此境。却问：‘既今某甲除却扬眉动目一切之事外，和尚亦须除之。’石头云：‘我除竟。’对曰：‘将示和尚了也。’石头云：‘汝既将示我心如何？’对曰：‘不异和尚。’石头曰：‘不关汝事”。’对曰：‘本无物。’石头曰：‘汝亦无物。’对曰：‘无物则真物。’石头云：‘真物不可得。汝心见量意旨如此，也须护持。’”僧问：“其中人相见时如何？”师曰：“早不其中。”进曰：“其中者如何？”师曰：“渠不作这个问。”

祖堂卷五·长髭

长髭和尚嗣石头，在潭州攸县。未睹行录，不决化缘终始。师初礼石头，密领玄旨。次往曹溪礼塔，却回石头。石头问：“从何处来？”对曰：“从岭南来。”石头云：“大庾岭头一铺功德，还成就也无？”对曰：“诸事已备，只欠点眼在。”石头曰：“莫要点眼不？”对曰：“便请点眼。”石头蹻起脚示之，师便连礼十数拜不止。石头云：“这汉见什摩道理？但知礼拜。”师又不止，石头进前把住云：“你见何道理了但知礼拜。”师曰：“如红炉上一点雪。”石头云：“如是，如是。”

师得十岁兒子，养得八年。有一日，兒子启和尚曰：“某甲欲得受戒去，还得也无？”师云：“受戒图什摩？”兒子曰：“某甲祖公在南岳，欲得去那里礼觐，只是未受戒，不敢去。”师曰：“受戒须是二十始得，且住。”师忽然觉察，唤来许伊受戒。小师明朝辞和尚，和尚云：“子归来，须到石头处来。”小师应喏，便去南岳般若寺受戒，后却去石头参。石头云：“从什摩处？”对云：“从长髭来。”石头曰：“今夜在此宿，还得摩？”对云：“一切取和尚处分。”小师第二日早朝来不审，师便领新戒入山。路边有一个树子，石头云：“汝与我斫却，这个树碍我路。”对曰：“某甲不将刀子来。”石头曰：“我这里有刀子。”曰：“便请。”石头便抽刀，把柄过与刀子。曰：“何不过那头来？”师曰：“用那头作什摩？”新戒便大悟。石头教新戒归受业处，新戒便辞石头，却归师处。师问：“教你到石头，你还到也无？”对曰：“到则到，不通耗。”师问曰：“依什摩人受戒？”对曰：“不依他。”师曰：“你在彼中即如此，我这里作摩生？”对曰：“要且不违背。”师曰：“大与摩多知生！”对曰：“舌头不曾染著在！”师便咄：“这多口新戒，出去！”此是石室和尚也。

祖堂卷五·龙潭

龙潭和尚嗣天皇，在澧朗州。师讳崇信，未详姓氏。在俗之时，世业作饼师，住在天皇巷阳。其天皇和尚住寺内，独居小院，多闭禅房，静坐而已。四海禅流，无由凑泊。唯有饼师每至食时，躬持胡饼十枚，以饷斋餐，如是不替数年。天皇每食已，常留一饼与之，云：“吾惠汝，以廕子孙。”日日如斯，以为常准。师因于一日忽自讶之，乃问：“此饼是某甲持来，何乃返惠某甲？”天皇云：“是你持来，复汝何咎？”师闻此语，似少惊觉，乃问曰：“弟子浮生扰扰，毕竟如何？”天皇云：“在家牢狱逼迮，出家逍遥宽广。”师便投天皇出家。天皇云：“汝昔崇福善，今信吾语，宜名崇信。”受具戒已，执爨数年。忽于一日问天皇曰：“某甲身厕僧伦，已果宿志，未蒙和尚指示个心要，伏乞指示。”天皇曰：“你自到吾身边来，未尝不指汝心要。”师问：“何处是和尚指某甲心要处？”天皇曰：“汝擎茶，吾为汝吃；汝持食，吾为汝受。汝和南，吾为汝低首。何处不是示汝心要？”师低头沉吟顷刻，天皇云：“见即直下便见，拟思则便差。”师问已，顿悟指要，便问：“毕竟如何保任则得始终无患？”皇曰：“任性逍遥，随缘放旷。不要安禅习定，性本无拘。不要塞耳藏睛，灵光迥耀。如愚若讷，行不惊时。但尽凡心，别无圣解。汝能尔者，当何患乎？”师既领宗要，触目朗然，犹如远客还家，顿息他游之意；亦如贫收宝藏，故无不足求。自荆渚至澧阳龙潭栖止，行不惊俗，世莫能疑。未尝辄衔机锋，玄流无由扣击。所居兰若临小溪潭，时属元阳，郡民多于是处祈求雨泽，故号龙潭和尚焉。

有僧问：“髻中珠谁人得？”师曰：“不赏玩者得。”僧曰：“安著何处？”师曰：“待有所在，即说似汝。”尼僧问：“如何得为僧去？”师曰：“汝作尼来多少时。”尼曰：“还有为僧时也无？”师曰：“你即今是什摩？”尼曰：“现是女身，何得不识？”师曰：“谁识汝？”

祖堂卷五·翠微

翠微和尚嗣丹霞，在西京。师讳无学。僖宗皇帝诏入内，大敷玄教，帝情大悦，赐紫法号广照大师。自余未睹行录，不决化缘终始。师因供养罗汉次，僧问：“今日设罗汉，罗汉还来也无？”师云：“是你每日噇什摩？”

祖堂卷五·云岩

云岩和尚嗣药山，在潭州澧陵县。师讳昙晟，姓王，钟陵建昌县人也。其生自然胎裳，右袒仿若缁服。出家于石门，初参百丈，入室十数年间，次参药山。药山问：“汝师百丈，于徒奚示？”师对曰：“师今示何物？”药山云：“因汝识得百丈矣。”师禀承药山，后止攸县，大弘法化。

师有时谓众曰：“有个人家兒子，问著无有道不得底。”洞山问：“他屋里有多小典籍？”师曰：“一字也无。”进曰：“争得与摩多知生？”师曰：“日夜不曾睡。”洞山云：“问著则无有道不得底，问一段事还道得不？”师曰：“道得却不道得！”师问僧：“从什摩处来？”对曰：“石头上语话来。”师曰：“石头还点头也无？”对曰：“师未问时却点头。”师因看经次，洞山云：“就师乞眼精。”师曰：“汝底与阿谁去也？”洞山云：“某甲无。”师曰：“有，汝向什摩处著？”洞山无对。师曰：“乞眼精底是眼不？”洞山云：“非眼。”师曰：“咄，出去！”道吾问：“初祖未到此土时，还有祖师意不？”师曰：“有。”吾云：“既有，更用来作什摩？”师曰：“只为有，所以来。”

师因行粽子，洞山受了又展手云：“更有一人在。”师云：“那个人还吃不？”洞山云：“行即吃。”洞山辞时，师问：“何处去？”洞山云：“虽辞和尚，未卜所止。”师曰：“莫是湖南去不？”对曰：“无。”师曰：“莫是归乡去不？”对曰：“也无。”师举高声云：“早晚却来？”对曰：“待和尚有住处即来。”师曰：“自此一别后，应难得相见。”对曰：“难得不相见。”洞山到沩山，沩山即大圆，当时郢匠，集徒千众，振化三湘，乃见洞山来，顾而异焉。他日沩山密离宴室，独步林泉。洞山乃疾追，蹑迹其后，至于佛地之西，有作务之所。洞山遂进前礼拜而言曰：“某甲窃闻国师有无情说法之示，曾闻其语，常究其微，每欲励心，愿尽于此。”沩山忻然顾曰：“子于何获此语耶？”洞山具述始终而举，举了，沩山乃曰：“此间亦有小许，但缘罕遇其人，非我所吝也。”洞山云：“便请。”沩山云：“父母缘生口，终不敢道。”洞山不礼拜便问：“还有与师同时慕道者不？”沩山云：“此去澧陵县侧，石室相邻，有云岩道人，若能拨草瞻风，必为子之所重也。”洞山便问：“无情说法什摩人得闻？”师曰：“无情说法无情得闻。”进曰：“和尚还闻得不？”师云：“我若闻，汝则不得见我。”进曰：“与摩则某甲不得闻和尚说法去也。”师云：“吾说法尚自不闻，岂况于无情说法乎？”因此洞山息疑情，乃作偈曰：

可笑奇，可笑奇，无情解说不思议。

若将耳听声不现，眼处闻声方得知。

师问尼众曰：“汝阿爷还在也无？”对曰：“在。”师曰：“年多少？”对曰：“年八十。”师云：“有少爷年非八十，汝还知也无？”对曰：“莫是与摩来底是不？”师曰：“这个犹是兒子。”洞山云：“直饶不来也是兒子。”问：“一念瞥起便落魔界时如何？”师曰：“汝因什摩从佛界来？”却云：“还会摩？”对曰：“不会。”师曰：“莫道不会，设使会得，也只是左之右之。”

师与道吾、船子三人受山下人请斋。一人云：“斋去日晚。”一人云：“近那！动步便到。”师云：“有一人不动步便到作摩生？”寻后洞山闻，举云：“此语最著力，如人入镬汤炉炭，不被烧煮始得。这里得永劫不失，余处得暂时间。切嘱第一莫向舌头上取办，记他了事言语有什摩用处？这个功课从无人边得，不由聪明强纪。莫向闲处置功，一步不回，冥然累劫。所以云岩云‘向这个相貌中失却人身最苦，无苦于此苦’。”师问僧：“何处去来？”对云：“添香去来。”师曰：“还见佛不？”对曰：“见。”师曰：“什摩处见？”对曰：“下界见。”师曰：“古佛，古佛。”师煎茶次，道吾问：“作什摩？”师曰：“煎茶。”吾曰：“与阿谁吃？”师曰：“有一人要。”道吾云：“何不教伊自煎？”师云：“幸有某甲在。”药山问：“承汝解弄师子，弄得几出？”师曰：“弄得六出。”药山云：“我亦弄得。”师问：“和尚弄得几出？”药山云：”我弄得一出。”师曰：“一即六，六即一。”沩山问师：“承闻长老在药山，解弄师子是不？”师曰：“是也。”沩山云：“为复常弄，还有置时也无？”师曰：“要弄即弄，要置即置。”沩山曰：“置时师子在什摩处？”师云：“置也，置也。”师窥一老宿房，老宿云：“只这个是，窥作什摩？”师云：“大有人不肯与摩道。”师问道吾：“老兄家风作摩生？”吾曰：“教汝指点著，堪作什摩！”师云：“无这个来多少时？”吾云：‘牙根犹带生涩在。”问：“如何是正修行路？”师云：“修是墙堑，不修是里头人。”师问众：“世间什摩物最苦？”云：“地狱是最苦。”师云：“地狱未是苦，今时作这个相貌中，失却人身最苦，无苦过于此苦。”

师与洞山锄姜次，师说先德事。洞山云：“这个人如今在什摩处？”师良久云：“作摩？作摩？”洞山云：“太迟也。”有僧出来，两三则语举似师，师复审之云：“我适来只闻汝声，不见汝身。出来，我要见汝。”其僧竖起五指，师云：“苦杀人，洎错放过者个汉。”洞山问：“此僧竖起五指意如何？”师曰：“现五分法身，如今在阿那个分？”师临迁化时，洞山问：“和尚百年后，有人问还邈得师真也无，向他作摩生道？”师云：“但向他道，只这个汉是。”洞山沉吟底，师云：“此著一子，莽卤吞不过，千生万劫休。阇梨瞥起，草深一丈，况乃有言。”师见洞山沉吟底，欲得说破衷情。洞山云：“启师：不用说破。但不失人身，为此事相著。”师迁化后，过太相斋，共师伯欲往沩山。直到潭州，过大溪次，师伯先过，洞山离这岸，未到彼岸时，临水睹影，大省前事，颜色变异，呵呵底笑。师伯问：“师弟有什摩事？”洞山曰：“启师伯：得个先师从容之力。”师伯云：“若与摩，须得有语。”洞山便造偈曰：

切忌随他觅，迢迢与我疏。

我今独自往，处处得逢渠。

渠今正是我，我今不是渠。

应须与摩会，方得契如如。

后有人问洞山：“云岩道‘只这个汉是’意旨如何？”洞山云：“某甲当初洎错承当。”报慈拈问：“累害在什摩处？”又续前问：“如今作摩生？”又问洞山：“云岩道‘只这个汉是’，还知有事也无？”洞山云：“先师若不知有，又争解与摩道？”良久又曰：“若知有事，争肯与摩道？”保福拈问长庆：“既知有事，为什摩不肯与摩道？”庆曰：“此问甚当。”保福曰：“昔日云岩又奚为？”庆云：“养子方知父慈。”

师比色碗里贮甘橘，洞山来不审立地。师曰：“那边还有这个摩？”洞山曰：“有也，过于这个无用处。”师曰：“有也未曾与阇梨，说什摩有用无用！”洞山当时无对，隔三日道：“恐怕和尚与专甲。”师肯之。师问黄檗侍者：“汝和尚还说法不？”对曰：“也说。”师云：“汝还听也无？”对曰：“也听。”师云：“说时即听，不说时还听也无？”对曰：“听。”师曰：“说时即从汝听，不说时听什摩？”对曰：“不可无这个人也。”师曰：“默底是？说底是？”对曰：“默底是。”师曰：“洎错放过这个汉。”师示众云：“从门入者非宝，直饶说得石点头，亦不干自己事。”又云：“拟心则差，况乃有言，恐有所示转远。”僧问石头：“如何是祖师意？’石头曰：“老僧面前一踏草，三十年来不曾锄。”有人举似师，师云：“牛不吃栏边草。”南泉云：“智不到处，不得说著，说著则头角生也。”有人举问师：“主人与摩道，意作摩生？”师曰：“兄弟也莫说，说若这个事，损著说底人。”有人举问洞山：“云岩与摩道作摩生？”洞山云：“在途也。”有人举问云居：“洞山与摩道，意作摩生？”居云：“说似也。”有人举问疏山：“云居与摩道，意作摩生。”疏山云：“一棒打杀龙蛇。”师扫地次，叫寺主，问：“师何得自驱驱？”师曰：“有一人不驱驱。”寺主曰：“何处有第二月？”师竖起扫帚云：“这个是第几月？”寺主无对。玄沙代云：“此犹是第二月。”洞山问：“无量劫来，余业未尽时如何？”师云：“汝只今还作不？”对曰：“更有胜妙亦不作。”师云：“汝还欢喜不？”对云：“欢喜即不敢，如粪扫堆上拾得一颗明珠。”师问僧：“承汝解卜是不？”对曰：“是。”师云：“试卜老僧看。”无对。洞山代云：“请和尚生月。”师自会昌辛酉年忽示疾，至十月二十七日迁化，敕谥无住大师净胜之塔。

祖堂卷五·华亭

华亭和尚嗣药山，在苏州。师讳德诚，未详姓，莫测始终。师昔与云岩、道吾三人并契药山秘旨。药山去世后，三人同议，持少多种粮、家具，拟隐于澧源深邃绝人烟处，避世养道过生。三人议毕，即俟晨去。三人之中，花亭处长，道吾居末。至中夜，道吾具三衣，白二师兄曰：“向来所议，于我三人，甚适本志，然莫埋没石头宗枝也无？”花亭曰：“因什摩得埋没？”道吾云：“两个师兄与某甲三人，隐于深邃绝人烟处，避世养道过生，岂不是埋没？”师云：“师弟元来有这个身心。若然者，不用入山，各自分去。然虽如此，有事嘱于师弟。专甲从分襟之后，去苏州花亭县，讨小船子水面上游戏。于中若有灵利者，教他来专甲处。”道吾云：“依师兄尊旨。”从此三人各自分去。

道吾出世数年，并不见灵利者。有一日新到参，道吾问：“从什摩处来？”对曰：“天门山来。”吾云：“什摩人住持？”对曰：“某与摩和尚。”道吾云：“有什摩佛法因缘？”其僧举两三则因缘，道吾便欢喜，处分安排。夜问唤院主云：“某甲欲得去天门山，辄不得出这个消息。”

当夜便发，行便到天门山。才三门前，和尚望见道吾，便走下来，引接道吾上法堂。一切了后，便问：“和尚有什摩事到这里？”道吾曰：“特为长老来。见说来日开堂，还是摩？”对云：“开什摩堂？无与摩事。”道吾曰：“莫与摩道。不用待来日，今夜速开堂。”主人推不得，便升座，破题两三则言语。有人问：“如何是真佛？”师曰：“真佛无相。”问：“如何是法眼？”师曰：“法眼无瑕。”道吾闻此对答掩耳。京口下堂，遂屈道吾。吾来房，京口问：“某甲对答，过在什摩处，掩耳出去？”道吾曰：“观师精彩，甚是其器，奈缘不遇其人。某甲师兄，在苏州花亭县，乘小船子江里游戏。长老才去那里便有来由。这里若有灵利者，领二人，著座主衣服去。”

主人当夜便发，直到江边立。师才望见二个座主，便问：“座主从那个寺里住？”对曰：“寺即不住，住即不寺。”师云：“为什摩么故不住？”对曰：“目前无寺。”师曰：“什摩处学得来？”对曰：“非耳目之所到。”师曰：“一句合头意，万劫系驴橛。”便打数下。师虽打他。见根性灵利，又云：“适来只对底阿师莫怪，下船。”天门便下船，便问：“每日直钩钓鱼，此意如何？”云：“垂丝千丈，意在深潭。浮定有无，离钩三寸。子何不问？”天门拟欲问谘和尚，师以船篙蓦便撞，天门却出，云：“语带玄而无路，舌头谈而不谈。”师云：“每日直钩钓鱼，今日钓得一个。”师曰：“有语云：‘竿头丝线从君弄，不犯清波意自殊。’”师问天门：“座主还去得也无？”对曰：“去。”师曰：“去即一任去，还见其事也无？”对曰：“见。”师曰：“作摩生见？”对曰：“见草。”师再嘱曰：“子以后藏身处没迹，没迹处藏身。不住两处，实是吾教。”有人拈问花严：“如何是藏身处没迹？”花严曰：“夹山亲受花亭嘱。”“如何是没迹处藏身？”严云：“今朝忽睹个呆郎。”因此颂曰：

藏身没迹师亲嘱，没迹藏身自可知。

昔日时时逢剑客，今朝往往遇痴兒。

择禅师因道吾指夹山寻师，颂曰：

京口谈玄已有名，吾山特地涉途程。

虽云法眼无瑕翳，争奈其人掩耳听。

参学须参真心匠，合头虚诈不劳聆。

此来更欲寻师去，决至应当暂改形。

道友当年深契会，老僧今日苦叮咛。

特报水云知识道，半秋孤月落花亭。

又夹山顿遇以华亭，颂曰：

一泛轻舟数十年，随风逐浪任因缘。

只道子期能辩律，谁知座主将参禅。

目前无寺成桩橛，句下相投事不然。

遥指碧潭垂钓叟，被师呵退顿忘筌。

祖堂卷五·肾树

稗树和尚嗣药山。不睹实录，不决化缘终始。因道吾卧次，师问：“作什摩？”吾云：“盖覆。”师云：“卧底是，不卧底是？”吾云：“不在两处。”师云：“争那盖覆何？”道吾乃拂袖而出。福先拈问僧：“盖覆意作摩生？”僧无对。自代良久。师问道吾：“作什摩来？”吾曰：“亲近来。”师曰：“你道亲近来，更用动两片皮作什摩？”吾云：“岂无借？”师曰：“不曾为人借什摩。”石霜云：“此是他人口。”师扫地次，赵州问：“般若以何为体？”师曰：“只与摩去。”

赵州第二日见师扫地，依前与摩问。师曰：“借这个阇梨还得也无？”赵州曰：“便请。”师便问，赵州拍掌而去。

祖堂卷五·道吾

道吾和尚嗣药山，在刘阳县。师讳圆智，姓王，锺陵建昌人也。依涅盘和尚指示而参药山。药山示众云：“法身具四大，阿谁道得？若有人道得，与汝一腰裈。”师曰：“性地非风，风非性地，是名风大。地、水、火大，亦复如是。”药山肯之，不违前言，赠一腰裈。石霜问：“百年后忽有人问极则事，作摩生向他道？”师唤沙弥，沙弥应喏，师云：“添净瓶水著。”师却问石霜：“适来问什摩？”石霜再举，师便起去。

师下山到五峰，五峰问：“识彼中老宿不？”师云：“不识。”峰云：“何故不识？”师曰：“不识，不识。”僧问：“如何是和尚家风？”师便下禅床，作拜相云：“谢子远来，都无只对。”问：“万里无云犹是傍来日，如何是本来日？”师曰：“今日好晒麦。”因沩山问云岩：“菩提以何为座？”岩曰：“无座为座。”云岩却问沩山，沩山云：“以诸法空为座。”沩山却问师，师曰：“坐也听伊坐，卧也听伊卧。有一人不坐不卧，速道将来。”师将出笠子，云岩问：“用这个作什摩？”师云：“有用处。”岩云：“黑风猛雨来时作摩生？”师云：“盖覆著。”岩云：“他还受盖覆也无？”师云：“虽然如此，要且无漏。”问：“如何是今时著力处？”师曰：“千人唤，不回头，方有少分相应。”僧云：“忽然火起时作摩生？”师曰：“能烧大地。”因肾树向火次，师问：“作什摩？”肾树曰：“和合。”师曰：“与摩则当头脱去也。”树云：“隔阙来多少时也。”师便拂袖而出。师问云岩：“千手千眼如何？”岩云：“如无灯夜把著枕子。”云：“汝还知不？”师云：“我会也，我会也。”岩却问：“作摩生会？”师云：“通身是眼。”神山云：“浑身是眼。”师有时示众云：“出世不出世，尽是出世边说。”僧曰：“有一人不肯。”师云：“直饶不肯，亦是傍出。”

师辞沩山，沩山唤云：“智头陀。”师云：“其中事作摩生？”沩山云：“智头陀，智头陀。”师云：“也大丑拙。”师见新到参，便打鼓归房丈。其僧又打鼓归僧堂。主事来和尚处啧云：“和尚打鼓本分，新到因什摩无端打鼓？”师曰：“如法批排茶饭，明日我与你勘。”到明日，批排茶饭屈吃次，师指教童子指僧，童子便来其僧身边立。其僧便摩童子头云：“和尚唤。”师便归丈室。主事又向和尚曰：“比来昨日无端打鼓，要伊勘责，为什摩却打他童子头！”师曰：“我与你勘责了也。”因高僧冲雨上堂，药山笑曰：“汝来也。”高僧曰：“尸@杲里。”药山云：“可杀湿。”高僧云：“不打与摩鼓笛。”云岩云：“皮也无，打什摩鼓笛？”师云：“骨也无，打什摩皮？”药山曰：“大好曲调。”

师大和九年乙亥之岁九月十一日，有人问：“伏审和尚四体违和，可杀疒@登，还减损也无？”师曰：“若与摩地不疒@登痛作什摩？所以古人道：‘愿得今身偿，不入恶道受’。”师又曰：“还知道不偿不受者摩？”对曰：“与摩则波不离水，水不离波去也。”师便蓦面唾。良久之间，问大众：“如今是什摩时？”对云：“未时。”师曰：“与摩则打锺。”打锺三下便告寂。春秋六十七。临行时谓众云：“吾虽西逝，理无东移。”后焚得灵骨，一节特异清莹，其色如金，其声如铜。乃塔于石霜，敕谥修一大师实相之塔。净修禅师赞曰：

长沙道吾，多不聚徒。

出世不出，树倒藤枯。

寒岩古桧，碧汉金乌。

垂机险峭，石霜是乎。

祖堂卷五·三平

三平和尚嗣大颠，在漳州。师讳义忠，福州福唐县人也。姓杨。自入大颠之室，而获深契。值武宗澄汰，隐避三平山。后虽值宣宗再扬佛日，而彼海辱竟绝玄侣。后至西院大沩兴世，众中好事者十数人，往彼请而方转玄关。因有一僧时称黄大口，师问曰：“久响大口是公不？”对曰：“不敢。”师曰：“口大小？”曰：“通身是口。”师曰：“向什摩处屙？”当时生对。白是法道声扬寰海，古往不避瘴疠之奔而远凑。

师示众曰：“今时出来尽学个驰求走作，将当自己眼目，有什摩相应时？阿你欲学，不要诸余，各自有本分事在，何不体取？作什摩心愤愤、口俳俳？有什摩利益分明说，若要修行路及诸圣建立化门，自有大藏教在；若是宗门中事，宜你不得错用心！”有人问：“还有学路也无？”师云：“有一路滑如苔。”僧云：“还许人蹑不？”师云：“不拟心，你自看。”问：“三乘十二分教，学人不疑，乞和尚直指西来意！”师云：“大德龟毛拂子、兔角柱杖藏著何处？”僧对曰：“龟毛兔角岂是有耶？”师云：“肉重千斤，智无铢两。”荷玉颂曰：

龟毛拂，兔角杖，拈将来，随处放。

古人事，言不当，非但有，无亦丧。

王侍郎问：“黑豆未生芽时作摩生？”师云：“诸佛亦不知。”师颂曰：

菩提慧日朝朝照，般若凉风夜夜吹。

此处不生聚杂树，满山明月是禅枝。

师云：“诸人若未曾见知识，则不可。若曾见作者来，便合体取些子意度。向幽岩雅塙独宿孤峰，木食草衣。任摩去，方有少分相应。若也驰求知解义句，则万里望乡关。珍重！”

师有偈三首：

即此见闻非见闻，无余声色可呈君。

个中若了全无事，体用无妨分不分。

又曰：

见闻觉知本非尘，识海波生自味身。

状似碧潭冰沫覆，灵王翻作客中宾。

又曰：

见闻觉知本非因，当处虚玄绝妄真。

见性不生痴爱业，洞然明白自家珍。

师咸通十三年壬辰岁十一月六日迁化，春秋九十二。吏部侍师王讽制塔铭矣。

祖堂卷五·石室

石室和尚嗣长髭，在潭州攸县，师讳善导。因沙汰年中改形为行者，沙汰后师僧聚集，更不造僧。每日踏碓供养师僧。木口和尚到，见行者每日踏碓供养僧，问：“行者不易甚难消？”师曰：“开心碗子里盛将来，合盘里合取，说什摩难消易消！’木口失对。有僧举似云居，云居云：“得底人改形换服。”又问曰：“行者还曾到五台山也无？”师曰：“到。”木口曰：“还见文殊也无？”师曰：“见。”进曰：“向行者道什摩？”师曰：“道阇梨父母在村草里。”木口又失对。长庆代云：“行者还出得摩？”后曹山拈问强上座：“是赏是罚？”对曰：“是罚。”曹山曰：“罚他什摩处？”对曰：“罚他知有处。”曹山曰：“什摩处是他知有处？”对曰：“为不如山中事，便认著文殊。”曹山曰：“作摩生是山中事？”对曰：“不认文殊。”曹山曰：“如是，如是。”

在后木口出世，数年后迁化。主事差两人往洞山达哀书。僧持书到洞山达一切了，洞山问两人：“和尚迁化后作摩生？”对曰：“荼毗。”洞山曰：“荼毗了作摩生？”对曰：“拾得二万八千粒舍利。一万粒则纳官家，一万八千粒则三处起塔。”洞山曰：“还得希异也无？”对曰：“世间罕有。”洞山曰：“作摩生说罕有？”对云：“有眼不曾见，有耳不曾闻，岂不是罕有？”洞山曰：“任摩你和尚遍天下尽是舍利去，总不如当时识取石室行者两句语。”

沩山教仰山探石室，仰山去到石室。过一日后便问：“如何是佛？”室拳手。“如何是道？”又展手。“毕竟阿那个即是？”石室便摆手云：“勿任摩事。”仰山却归，具陈前话。沩山便下床，向石室合掌。

师与仰山同玩月次，仰山问：“这个月尖时，圆相在什摩处？”师曰：“尖时圆相隐，圆时尖相在。”云须云：“尖时圆相在，圆时尖相无。”道吾云：“尖时亦不尖，圆时亦不圆。”自余未睹实录焉。

祖堂卷五·德山

德山和尚嗣龙潭，在朗州。师讳宣鉴，姓周，剑南西川人也。生不薰食，幼而敏焉。□岁从师，依年受具。毗尼胜藏，靡不精研；解脱相宗，独探其妙。每曰一毛吞巨海，海性无亏；纤芥投针锋，锋利不动。然学与非学，唯我知焉。遂云游海内，访谒宗师，凡至击扬，皆非郢哲。后闻龙潭则石头之二叶，乃摄衣而往焉。初见而独室小驻门徒，师乃看侍数日。因一夜参次，龙潭云：“何不归去？”师对曰：“黑。”龙潭便点烛与师，师拟接，龙潭便息却。师便礼拜。潭云：“见什摩道理？”师云：“从今向去终不疑天下老师舌头。”师便问：“久向龙潭。及至到来，潭又不见。龙又不见时如何？”潭云：“子亲到龙潭也。”师闻不糅之言，喜而叹曰：“穷诸玄辩，如一毫置之太虚；竭世枢机，似一滴投于巨壑。”遂乃摄金牙之勇敌，藏敬德之雄征，继立雪之言徒，俟传衣之秘旨。给侍瓶屦，日扣精微。更不他游，盘泊澧源三十余载乎。澄汰后，咸通初年，武陵太守薛延望迎请，始居德山。自是四海玄徒冬夏常盈五百矣。

师有时谓众曰：“汝等诸方更谁敢铭邈？有摩？出来，吾要识汝。”闻此语者惕栗钳结，无敢当对。师又曰：“汝但无事于心，无心于事，乃虚而妙矣。若毫厘系念，皆为自欺。瞥尔生情，万劫羁锁去。”师问曰：“维那今日几个新到？”对曰：“有八个。”师曰：“一时令来，生案过却。”僧问禾山：“‘一时令来，生案过却’，此意如何？”禾山云：“才出门便知委下客。”僧曰：“如何免得此过？”禾山曰：“万里元来却肯伊。”钦山问：“天皇也与摩，未审德山作摩生道。”师曰：“试举天皇、龙潭看。”钦山礼拜，师乃打之。云大师代曰：“与摩则自置。虚言已决。”

师又时云：“问则有过，不问则又乖。”僧便礼拜，师乃打之。僧云：“某甲始礼，为什摩却打？”师云：“侍你开口，堪作什摩？”师见僧来，便闭却门。僧便敲门，师问：“阿谁？”僧云：“师子兒。”师便开门，其僧便礼拜。师骑却头云：“者畜生什摩处去来？”

师因病次，问：“和尚病，还有不病者无？”云：“有。”进曰：“如何是不病者，”师云：“阿耶阿耶。”龙牙问：“学人仗镆耶之剑，拟取师头时如何？”云：“你作摩生下手？”龙牙曰：“与摩则师头落也。”师不答。龙牙后到洞山，具陈上事。洞山云：“把将德山落底头来！”龙牙无对。问：“如何是菩提？”师便咄云：“出去！莫向这里屙！”岩头问：“凡圣相去多少？”师喝一声。因南泉第一座养猫兒，邻床损脚，因此相诤。有人报和尚，和尚便下来，拈起猫兒云：“有人道得摩？有人道得摩？若有人道得，救这小猫兒命。”无对。南泉便以刀斩作两橛。雪峰问师：“古人斩猫兒意作摩生？”师便打趁雪峰，雪峰便走，师却唤来云：“会摩？”对云：“不会。”师云：“我与摩老婆，你不会。”师问岩头：“还会摩？”对曰：“不会。”云：“成持取不会好。”进曰：“不会，成持个什摩？”师云：“你似铁橛。”

雪峰在德山时，上法堂见和尚便转。师曰：“此子难偕。”长庆拈问：“什摩处是雪峰与德山相见处？”僧无对。庆代云：“还得当摩？更有枢要，备陈广诲。”

咸通六年乙酉岁十二月三日，忽告诸徒：“扪空追响，劳你神耶？梦觉觉非，觉有何事？”言讫，宴坐安详，奄然顺化。春秋八十四，僧夏六十五。敕谥见性大师，沙门元会撰碑文。净修禅师赞曰：

德山朗州，刚骨无俦。

尚祛祖佛，岂立证修？

释天杲日，苦海慈舟。

谁攀真躅？雪峰崖头。


祖堂集卷六

祖堂卷六·投子

投子和尚嗣翠微，在舒州桐城县。师讳大同，舒州怀宁县人也，姓刘。受业于东都保唐满禅师下。初习小乘定，知非而舍。次广穷海藏，博悟幽深。便造翠微而问师：“未审二祖初见达摩当何所得？”翠微答曰：“汝今见吾，复何所得？”师乃伏膺玄墀，息心他往。又因一日翠微在法堂行道次，师而近前接礼。问曰：“西来密旨，和尚如何指示于人？”翠微驻步须臾，师又近曰：“请和尚指示！”翠微答曰：“不可，事须要第二杓恶水浆泼作摩？”师于言下承旨，礼谢而退。翠微云：“莫躲却！”师曰：“时至根苗自生。”师又问：“曾闻丹霞烧木佛，和尚何以供养罗汉？”翠微云：“烧亦烧不着，供养亦一任供养。”师既承言领旨，任性逍遥，放旷人间，周游胜概。旋经故里，卜投子山而有终焉之志。乃创立庵茨，栖心遁迹。

及乾符中和之际，鼎沸鲸吞荆越楚吴，戈鋋竞耀，狂戎交扇，榤蹠纵横。岂唯隳殄国邦，抑亦摧残佛寺。时有暴党魁帅，执刃庵前厉声曰：“和尚在此间作什摩？”师曰：“吾在此间传心。”魁帅云：“传个什摩心？”师曰：”佛心。”魁帅低首良久，解颜曰：“和尚家大不思议，非我辈之所图。”则内剑于匣膜，各脱服玩，用施而去。

自尔日有禅流相访。有人问曰：“凡圣相去几何？”师下绳床立。问：“一物不将来，为什摩却言放下著？”师云：“辛苦与摩来。”问：“最亲处乞师一言！”师以杖敲之。僧曰：“为什摩不道？”师云：“汝争得与摩不识好恶！”问：“主人道‘百年后山下作一头水牯牛’，意作摩生？”师云：“为鞔常住。”僧曰：“不鞔常住时作摩生？”师云：“又鞔俗人。”问：“大庾岭头趁得及，为什摩提不起？”师提起纳衣。僧云：“不问这个。”师云：“看你提不起。”问：“佛佛授授，祖祖相传。未审传个什摩。”师曰：“年老也争受谩语。”问：“并却咽喉脣吻，请师道！”师曰：“汝只要我道不得。”问：“达摩未来时如何？”师曰：“遍天遍地。”僧曰：“来后如何？”师曰：“盖覆不得。”问：“诸圣从何而证？”师曰：“有病不假服药。”僧曰：“与摩则不假修证去也。”师曰：“不可长嗔长喜。”问：“省要处还通信不？”师曰：“是你与摩问我。”僧曰：“如何识得？”师曰：“不可识。”僧曰：“毕竟作摩生？”师曰：“真是省要。”问：“如何得不犯目前机？”师曰：“犯也。”僧曰：“什摩处是犯？”师曰：“适来道什摩？”问：“古人道‘要急相应，唯言不二。’未审和尚作摩生？”师曰：“汝问我，我更道。”僧曰：“作摩生道？”师曰：“唯言不二。”

师有时云：“诸方一切句道尽一句。老师则不然，一句道尽一切句。”僧进问：“如何是和尚一句道尽一切句底句？”师曰：“今日上堂吃些子饭。”问：“古人有言：‘解语非关舌，能言不是声。’如何是解语？”师曰：“一切总道得。”“如何是非关舌？”师曰：“无耳听音声。”问：“主人有言：‘目前无法，意在目前。’作摩生是在目前意？”师曰：“不狂妄。”僧曰：“作摩生？”师曰：“他不是目前法，非耳目之所到。”赵州到投子，山下有铺。向人问：“投子那里？”俗人对曰：“问作什摩？”赵州云：“久响和尚，欲得礼谒。”俗曰：“近则近，不用上山。明日早朝来乞钱，待他相见。”赵州云：“若与摩和尚来时，莫向他说纳僧在里。”俗人唱喏。师果然是下来乞钱，赵州便出来把驻云：“久响投子。莫只这个便是也无？”师才闻此语，便侧身退。师又拈起笊篱云：“乞取盐钱些子。”赵州走入里头，师便归山。赵州落后到投子，便问：“死中得活时如何？”师云：“不许夜行，投明须到。”赵州便下来一直走，师教沙弥：“你去问他我意作摩生。”沙弥便去唤赵州，赵州回头，沙弥便问：“和尚与摩道意作摩生？”赵州云。“遇著个太伯。”沙弥归举似，师便大笑。有僧举似雪峰，便问：“只如古人与摩道意作摩生？”雪峰曰：“将为我胡伯，更有胡伯在。”僧问黄龙：“古人道：‘不许夜行，投明须到’，意作摩生？”黄龙曰：“嚼饭喂鲁伯。”又问：“未见四祖时如何？”师曰：“在。”“见后如何？”师曰：“在。”师问僧：“从什摩处来？”对曰：“雪居来。”师曰：“何似此间地？”僧无对。却归举似云居，云居云：“南有雪峰，北有赵州。”

师又才开门了，便东觑西觑。大众一时走上，师便关却门。有囗问石门：“投子关门意作摩生？”门云：“关门尚不囗，不关门你向什摩处会？”

师有时云：“你诸人囗囗闲处，脱不可得相应，亦无量劫来，向一切处囗心著急自己事，却是闲事，所以难得相称。莫因修各自办事，莫待临脱衣时方始慌忙不及也。老僧此间无巧言囗囗，囗囗人咬嚼。只是随汝问处只对。汝若不问囗，囗囗向什摩处道则得？若更向汝道向上向下，囗囗囗事尽是走作。你无了时，你但莫逐名囗囗囗囗囗走作，则了事边亦收管你不著。却囗囗囗囗囗及诸过患，虽然如此，包罗天地，含囗囗囗囗囗囗囗，不同于量万，囗囗不差殊，直囗囗囗囗囗囗囗囗取囗囗囗囗囗囗示简要囗囗囗囗囗囗囗囗囗囗囗囗囗囗曰锄地囗囗囗囗囗囗囗囗囗囗囗囗囗囗囗囗囗囗囗不依一法。问：“便请和尚直指！”师嘎。价曰：“即这个，别更有也无？”师曰：“莫闲言语！”

师于甲戊岁四月六日跏趺端坐，俄然顺化。春秋九十六，僧夏七十六矣。

祖堂卷六·草堂

磁州如禅师嗣荷泽，益州惟忠和尚嗣慈州如，达州圆禅师嗣惟忠，草堂和尚嗣圆禅师。师讳宗密，未睹行录，不叙终始。师内外谚瞻，朝野钦敬。制数本《大乘经论疏钞》，《禅诠》百卷、《礼忏》等见传域内。臣相裴休深加礼重，为制碑文，询奂射人，颇彰时誉。敕谥定慧禅师青莲之塔。

有时史山人十问草堂和尚。第一问曰：“云何是道？何以修之？为复必须修成，为复不假用功？”禅师答曰：“无碍是道，觉妄是修。道虽本圆，妄起为累。妄念都尽，即是修成。”

第二问曰：“道若因修而成，即是造作，便同世间法，虚伪不实。成而复坏，何名出世？”师答曰：“造作虽是结业，名虚伪世间；无作是修行，即真实出世。”

第三问曰：“其所修者，为顿为渐？渐则忘前失后，何以集合而成？顿即万行多方，岂得一时圆满？”师答曰：“真理即悟而顿圆，妄情息之而渐尽。顿圆如初生孩子，一日而肢体已全；渐修如长养成人，多年而志气方立。”

第四问曰：“凡修心地之法，为当悟心即了，为当别有行门？若别有行门，何名南宗顿旨？若悟即同诸佛，何不发神通光明？”师答曰：“识冰池而全水，藉阳气而熔融，悟凡夫而即真，资法力而修习。冰消则水流润，方呈溉涤之功；妄尽即心灵通，始发通光之应。修心之外，无别行门。”

第五问曰：“若但修心而得佛者，何故诸经复说必须庄严佛土、教化众生方名成道？”师答曰：“镜明而影像千差，心静而神通万应。影像类庄严佛国，神通即教化众生。庄严而即非庄严，影像亦色而非色。”

第六问曰：“诸经皆说度脱众生，且众生即非众生。何故更劳度脱？”师答曰：“众生若是实，度之即为劳。既自云即非众生，何不例度而无度？”

第七问曰：“诸经说佛常住，或说佛灭度，常即不灭，灭即非常，岂不相违？”师答曰：“离一切相即名诸佛，何有出世入灭之实乎？见出没者在乎机缘，机缘应即菩提树下而出现。机缘尽即娑罗林间而涅盘。其犹净水无心，无像不现，像非我有，盖外质之去来相非佛身，岂如来之出没？”

第八问曰：“云何佛比所生？吾如彼生，佛既无生，生是何义？若言心生法生，心灭法灭，何以得无生法忍耶？”师答曰：“既云如化，化即是空，空即是无生，何诘生义？生灭灭已，寂灭为真，忍可此法无生，名曰无生法忍。”

第九问曰：“诸佛成道说法，只为度脱众生。众生既有六道，佛何但住在人中现化？又佛灭后付法于迦叶，以心传心，乃至此方七祖。每代只传一人。既云于一切众生皆得一子之地，何以传授不普？”师答：“日月丽天，六合俱照，而盲者不见，盆下不知。非日月不普，是障隔之咎也。度与不度，义类如斯，非局人天，拣于鬼畜，但人道能结集。传授不绝。故只知佛现人中也。灭度后委付迦叶，展转相承一人者，此亦盖论当代为宗教主，如土无二王，非得度者唯尔数也。”

第十问曰：“和尚因何发心？慕何法而出家？今如何修行？得何法味？所行得至何处地位？今住心耶，修心耶？若住心妨修心，若修心即动念不安，云何名为学道？若安心一定，即何异定性之徒？伏愿大德运大慈悲，如理如如，次第为说。长庆四年五月日，制诚谨问。”师答曰：“觉四大如坏幻，达六尘如空花，悟自心为佛心，见本性为法性，是发心也。知心无住，即是修行；无住而知，即为法味。住著于法，斯为动念。故如人入娼，即无所见。今无所住，不染不著，故如人有目及日光，明见种种法，岂为定性之徒？既无所住著，何论处所阶位？同年同月二日，沙门宗密谨对。”〔史山人自后领讨论心地，乃至出家为道。〕

祖堂卷六·神山

神山和尚嗣云岩，师讳僧密。未睹行录，不决始终。

师与洞山锄茶次，洞山抛却酴头云：“我今日困，一点气力也无。”师曰：“若无气力，争解与摩道得？”洞山云：“将谓有气力底是。”因裴大夫问僧：“下供养佛还吃也无？”僧曰：“如大夫祭祀家先。”有人举似云岩，云岩云：“这个人未出家在。”师进曰：“却请和尚道！”岩曰：“汝几般饭食，但一时下来。”岩却问师；“他忽然下来时作摩生？”师曰：“却须合取钵盂。”岩深肯之。有行者问：“生死事大，请师一言！”师曰：“行者何时曾死来？”行者云：“不会，请师说！”师云：“若与摩须死一场去。”师与洞山行脚时，到寺里，洞山坐禅，师一向睡。洞山心闷唤师，师应喏。洞山云：“上座还会摩？”师曰：“不会。”洞山云：“既不会，作摩生睡？”师云：“会底人还睡也无？”洞山不语。师曰：“一条绳子自系。”

师把针次，洞山问：“作什个摩？”师曰：“把针。”洞山云：“作摩生把针？”师云：“个个与他相似。”洞山云：“若有个个，则不相似。”师却问洞山，洞山云：“大地一齐火发。”曹山云：“为什摩寸丝不留？”曹山问僧：“作摩生是大地一齐火发？”对曰：“近不得。”曹云：“近不得是火也，与摩时还存得寸丝也无？”对曰：“若有寸丝则不成大火。”曹山不肯，邈上座云：“与摩时却存得寸丝。”曹山云：“邈阇梨是间生。”师与洞山到村院向火次，洞山问师：“水从何出？”师云：“无处来。”洞山云：“三十年同行，作任摩语话！”师云：“理长则就，老兄作摩生？”洞山云：“只见淈淈，不知从何出。”

祖堂卷六·洞山

洞山和尚嗣云岩，在洪州高安县。师讳良价，姓俞，越州诸暨县人也。初投村院院主处出家，其院主不任持，师并无欺嫌之心。过得两年，院主见他孝顺，教伊念《心经》。未过得一两日念得彻，和尚又教上别经。师启师曰：“念底《心经》尚乃末会，不用上别经。”院主云：“适来可怜念得，因什摩道未会？”师曰：“经中有一句语不会。”院主云：“不会那里？”师曰：“不会无眼耳鼻舌身意。请和尚为某甲说。”院主杜口无言。从此法公不是寻常人也。院主便领上五泄和尚处，具陈前事：“此法公不是某甲分上人，乞和尚摄收。”五泄容许，师蒙摄受。过得三年后，受戒一切了，谘白和尚：“启师：某甲欲得行脚，乞和尚处分。”五泄云：“寻取排择下，问取南泉去。”师曰：“一去攀缘尽，孤鹤不来巢。”师便辞五泄到南泉，南泉因归宗斋垂语云：“今日为归宗设斋，归宗还来也无？”众无对。师出来礼拜云：“请师徵起。”南泉便问，师对曰：“待有伴则来。”南泉[走*弗]跳下来，抚背云：“虽是后生，敢有雕啄之分。”师曰：“莫压良为贱。”因此名播天下，呼为作家也。后参云岳，尽领玄旨。

止大中末间，住于新丰山，大弘禅要。时有人问：“学人欲见和尚本来师时如何？”师曰：“年涯相似则无阻碍。”学人再举所疑，师曰：“不蹑前踪，更请一问。”云居代云：“与摩则某甲不得见和尚本来师也。”后教上座拈问长庆：“如何是年涯相似？”长庆云：“古人与摩道，教阇梨来这里觅什摩？”问：“师见南泉因什摩为云岩设斋？”师曰：“我不重他云岩道德，亦不为佛法，只重他不为我说破。”问：“如何是毗卢师法身主？”师曰：“禾茎粟柄。”师到百颜，颜问：“近离什摩处？”师曰：“近离湖南。”颜云：“官察使姓什摩？”师曰：“不得他姓。”颜云：“名什摩？”师曰：“不得他名。”颜曰：“还曾出不？”师曰：“不曾出也。”颜曰：“合句当事不？”师曰：“自有郎幕在。”颜曰：“虽不出，合处分事。”师乃拂袖而出。百颜经宿，自知不得，入堂问：“昨日二头陀何在？”师曰：“某甲是。”颜曰：“昨夜虽对阇梨，一夜不安，将知佛法大难大难。头陀若在此间过夏，某甲则陪随二头陀，便请代语。”师代云：“也太尊贵。”

因云岩问院主游石室云：“汝去入石室里许，莫只与摩便回来。”院主无对。师云：“彼中已有人占了也。”岩云：“汝更去作什摩？”师云：“不可人情断绝去也。”问：“如何是西来意？’师云：“大似解鸡犀。”有人问个山：“时时勤拂拭，大杀好，因什摩不得衣钵？”洞山答曰：“直道本来无一物，也未得衣钵在。”进曰：“什摩人合得衣钵？”师曰：“不入门者得。”进曰：“此人还受也无？”师曰：“虽然不受，不得不与他。”问：“蛇吞虾蟆，救则是，不救则是？”师云：“救则双目不睹，不救则形影不彰。”因云岩斋，有人问：“和尚于先师处得何指示？”师曰：“我虽在彼中，不蒙他指示。”僧曰：“既不蒙他指示，又用设斋作什摩？”师曰：“虽不蒙他指示，亦不敢辜负他。”又设斋次，问：“和尚设先师斋，还肯先师也无？”师曰：“半肯半不肯。”僧曰：“为什摩不全肯？”师曰：“若全肯，则辜负先师。”僧拈问安国：“全肯为什摩却成辜负？”安国曰：“金屑虽贵。”白莲云：“不可认兒作爷。”有人拈问凤池：“如何是半肯？”凤池云：“从今日去向入，且留亲见。”“如何是半不肯？”凤池云：“还是汝肯底事摩？”僧曰：“全肯为什摩辜负先师？”凤池云：“守著合头则出身无路。”问：“三身中阿那个身不堕众数？”师曰：“吾常于此切。”僧问曹山：“先师道：‘吾常于此切’，意作摩生？”曹山云：“要头则斫将去。”问雪峰，雪峰以杖拦口擉云：“我亦曾到洞山来。”

因夜不点灯，有僧出来问话。师唤侍者点灯来。侍者点灯来，师曰：“适来问话上座出来，出来。”其僧便出，师曰：“将取三两粉与这个上座。”僧拂袖而出。后因此得入路，将衣钵一时设斋。得三五年后辞和尚，和尚云：“善为，善为。”雪峰在身边侍立，问：“者个上座适来辞去，几时再来？”师曰：“只知一去，不知再来。”此僧归堂衣钵下座而迁化。雪峰见上座迁化，便报师，师曰：“虽然如此，犹教老僧三生在。”又一家举则别：因两个僧造同行，一人不安，在涅盘堂里将息，一人看他。有一日，不安底上座唤同行云：“某甲欲得去，一时相共去。”对曰：“某甲未有病，作摩生相共去？”病僧云：“不得，比来同行去，也须同行去始得。”对曰：好，与摩则某甲去辞和尚。”其僧到和尚处，具说前事。师云：“一切事在你，善为，善为。”其僧去涅盘堂里，两人对坐，说话一切后，当胸合掌，峭底便去。雪峰在法席造饭头见其次第，便去和尚处说：“适来辞和尚僧去涅盘堂里，两人对座迁化，极是异也。”师云：“此两人只解与摩去，不解传来。若也与老僧隔三生在。”

师有时示众曰：“吾有闲名在世，谁能与吾除得？”有沙弥出来云：“请师法号。”师自槌曰：“吾闲名已谢。”石霜代云：“无人得他肯。”进曰：“争那闲名在世何？”霜曰：“张三李四他人事。”云居代云：“若有闲名，非吾先师。”曹山代曰：“从古至今，无人弁得。”疏山代云：“龙有出水之机，人无弁得之能。”问：“如何是正问正答？”师曰：“不从口里道。”当曰：“有如是人问，和尚还道不？”师曰：“汝问也未曾问。”问：“如何是病？”师曰：“瞥起是病。”进曰：“如何是药？”师曰：“不续是药。”洞山问僧曰：“什摩处来？”对曰：“三祖塔头来。”师曰：“既从祖师处来，要见老僧作什摩？”对曰：“祖师则别，学人与和尚不别。”师云：“老僧欲见庠梨本来师，得不？”对曰：“亦须师自出头来始得。”师云：“老僧适来暂时不在。”问：“承教中有言：‘誓度一切众生，我则成佛。’此意如何？”师曰：“譬如十人同选，一人不及第，九人总不得。一人若及第，九人总得。”僧曰：“和向还及第不？”师曰：“我不读书。”师问僧：“名什摩？”对曰：“某甲。”师曰：“阿那个是阇梨主人公？”对曰：“现只对和尚即是。”师曰：“苦哉，苦哉！今时学者，例皆如此。只认得驴前马后，将当自己眼目。佛法平沉，即此便是。客中主尚不弁得，作摩生弁得主中主？’僧问：“如何是主中主？”师曰：“阇梨自道取。”僧云：“某甲若道得，则是客中主。”师曰：“与摩道则易，相续则大难大难。”云居代云：“某甲若道得，不是客中主。”

师问雪峰：“汝去何处？”对曰：“入岭去。”师云：“汝从飞猿岭过不？”对曰：“过。”师曰：“来时作摩生？”对曰：“亦彼处来。”师曰：“有一人不从飞猿岭便到者里作摩生？”对曰：“此人无来去。”师曰：“汝还识此人不？”对曰：“不识。”师曰：“既不识，争知无来去？”雪峰无对。师代云：“只为不识，所以无来去。”

师有时曰：“体得佛向上事，方有些子语话分。”僧便问：“如何是语话分？师曰：“语话时阇梨不闻。”僧曰：“和尚还闻不？”师曰：“待我不语话时刖闻。”师有时云：“直须向万里无寸草处立。”有人举似石霜，石霜云：“出门便是草。”师闻举云：“大唐国内能有几人？”师举盐官法会有一僧知有佛法，身为主事，未得修行，大限将至，见鬼使来取僧，僧云：“某甲身为主事，未得修行，且乞七日，得不？”鬼使云：“待某甲去白王。王若许，得七日后方始来。若不许，须臾便到。”鬼使七日后方来，觅僧不得。有人问：“他若来时，如何只对他？”师曰：“被他觅得也。”

有僧从曹溪来，师问：“见说六祖在黄梅八个月踏碓，虚实？”对曰：“非但八个月踏碓，黄梅亦不曾到。”师曰：“不到且从，从上如许多佛法，什摩处得来？”对曰：“和尚还曾佛法与人不？”师曰：“得则得，即是太抵突人。”师代曰：“什摩劫中曾失却来？”中招庆代云：“和尚禀受什摩处？”

问：“如何是古人百答而无一问？”师曰：“清天朗月。”“如何是今时百问而无一答？”师云：“黑云[唝*爱]叇。”问：“师见什摩道理更住此山？”师曰：“见两个泥牛斗入海，直至如今无消息。”问：“饭百千诸佛，不如饭一无修无证之者。未审百千诸佛有何过？”师曰：“无过，只是功勋边事。”僧曰：“非功勋者如何？”师曰：“不知有保任即是。”问：“承和尚有言，教人行鸟道，未审如何是鸟道？”师曰：“不逢一人。”僧曰：“如何是行？”师曰：“足下无丝去。”僧曰：“莫是本来人也无？”师曰：“阇梨因什摩颠倒？”僧云：“学人有何颠倒？”师曰：“若不颠倒，你因什摩认奴作郎？”僧曰：“如何是本来人？”师曰：“不行鸟道。”问：“六国不宁时如何？”师曰：“臣无功。”僧曰：“臣有功时如何？”师云：“国界安清。”僧曰：“安清后如何？”师曰：“君臣道合。”僧云：“臣传身后如何？”师曰：“不知有君。”问：“知识出世，学人有依，迁化去后如何得不被诸境惑？”师曰：“如空中轮。”僧曰：“争奈今时妄起何？”师曰：“正好烧却。”问：“和尚出世，几人肯重佛法？”师曰：“实无一人肯重。”僧曰：“为什摩不肯重？”师曰：“他各各气宇如王相似。”问云居：“你爱色不？”对曰：“不爱。”师曰：“你未在好与。”云居却问：“和尚还爱色不？”师曰：“爱。”居曰：“正与摩见色时作摩生？”师曰：“如似一团铁。”师问僧：“名什摩？”对曰：“请和尚安名。”师自称良价。僧无对。云居代云：“与摩则学人无出头处也。”又云：“与摩则总被和尚占却也。”师问：“太长老有一物，上柱天，下柱地，常在动用中黑如漆，过在什摩？”对曰：“过在动用。”师便咄：“出去！”石门代云：“觅不得。”有人进曰：“为什摩觅不得？”石门云：“黑如漆。”

因雪峰般柴次，师问：“重多少？”对曰：“尽大地人提不起。”师云：“争得到这里？”雪峰无对。云居代云：“到这里方知提不起。”疏山代云：“只到这里岂是提得起摩？”

有一僧到参，师见异，起来受礼了，问：“从何方而来？”对曰：“从西天来。”师曰：“什摩时离西天？”曰：“斋后离。”师曰：“太迟生。”对曰：“迤逦游山玩水来。”师曰：“即今作摩生？”其僧进前，叉手而立，师乃祗揖云：“吃茶去。”师问僧：“什摩处来？”僧云：“游山来。”师曰：“还到顶上不？”曰：“到。”师曰：“顶上还有人不？”对曰：“无人。”师曰：“与摩则阇梨不到顶上也。”对曰：“若不到，争知无人？”师曰：“阇梨何不且住？”对曰：“某甲不辞住，西天有人不肯。”师问云居；“什摩处去来？”对曰：“踏山去来。”师曰：“阿那个山敢住？”对曰：“阿那个山不敢住？”师曰：“与摩则大唐国内山总被阇梨占却了也。”对曰：“不然。”师曰：“与摩则子得入门也。”对曰：“无路。”师曰：“若无路，争得与老僧相见？”对曰：“若有路，则与和尚隔生。”师云：“此子已后千万人把不住。”

师到泐潭，见政上座谓众说话云：“也太奇，也大奇！道界不可思议，佛界不可思议。”师便问：“道界佛界则不问，且说道界佛界是什摩人？只请一言。”上座良久无言，师催云：“何不急道！”上座云：“争则不得。”师云：“道也未曾道，说什摩争即不得！”上座无对。师曰：“佛之与道，只是名字，何不引教？”上座曰：“教道什摩？”师曰：“得意忘言。”上座云：“犹将教意向心头作病在。”师曰：“说道界佛界者病多少？”上座因兹而终。

师问雪峰：“什摩处去来？”对曰：“斫槽去来。”师曰：“几斧得成？”对曰：“一斧便成。”师云：“那边事作摩生？”对曰：“无下手处。”师曰：“此犹是这边事，那边事作摩生？”雪峰无对。疏山代云：“不堕无釿斧。”问：“单刀直入拟取师头时如何？”师曰：“堂堂无边表。”僧曰：“争奈今时羸劣何？”师曰：“四邻五舍，谁人无之？暂寄旅店，足什摩可怪？”

大师又劝学徒曰：“天地之内，宇宙之间，中有一宝，秘在形山。识物灵照，内外空然。寂寞难见，其位玄玄。但向己求，莫从他借。借亦不得，合亦不堪。总是他心，不如自性。性如清净，即是法身。草木之生，见解如此。住止必须择伴，时时闻于未闻。远行要假良朋，数数清于耳目。故云：‘生我者父母，成我者朋友’。亲于善者，如雾里行。虽不湿衣，时时有润。蓬生麻竹，不扶自直。白砂在泥，与之俱黑。一日为师，终世为天。一日为主，终身为父。玉不琢不成器，人不学不知道。”

师问病僧：“不易阇梨？”对曰：“生死事大和尚。”师曰：“何不向粟畲里去？”病僧曰：“若与摩则珍重。”峭然便去。问：“一切皆放舍犹若未生时如何？”师曰：“有一人不知庠梨手空。”

师示众云：“诸方有惊人之句，我这里有刮骨之言。”时有人问：“承和尚有言：‘诸方有惊人之句，我这里有刮骨之言’。岂不是？”师曰：“是也，将来与你刮。”僧曰：“四面八方请师刮。”师曰：“不刮。”僧曰：“幸是好手，为什摩不刮？”师曰：“汝不见道：‘世医拱手’。”云门到西峰，西峰问：“某甲只闻洞山刮骨之言，不得周旋，请上座与某举看。”云门具陈前话，西峰便合掌云：“得与摩周旋。”云门拈问西峰洞山前语道：“将来与你刮。宾家第二机来，为什摩道不刮？”西峰沉吟后云：“上座。”上座应嗟，西峰曰：“堆阜也。”

师示众曰：“展手而学，鸟道而学，玄路而学。”宝寿不肯，出法堂外道：“这老和尚有什摩事急？”云居便去和尚处，问：“和尚与摩道，有一人不肯。”师曰：“为肯者说，不为不肯底，只如不肯底人，教伊出头来，我要见。”居云：“无不肯底。”师曰：“阇梨适来道，有一人不肯，因什摩道无不肯？更道。”居云：“出来则肯也。”师曰：“灼然肯则不肯，出则不出。”问：“古人有言：‘青青翠竹，尽是真如；郁郁黄花，无非般苦。’此意如何？”师曰：“不遍色。”僧曰：“为什摩不遍色？”师曰：“不是真如，亦无般若。”僧曰：“还彰也无？”师曰：“不露世。”僧曰：“为什摩不露世？”师曰：“非世。”僧曰：“非世者如何？”师曰：“某甲则与摩道，阇梨如何？”对曰：“不会，将会与阇梨。”僧曰：“和尚为什摩不与施设？”师曰：“看看不奈何。”僧曰：“为什摩承当不得？”师曰：“汝为什摩泥他有言？”僧曰：“与摩则无言。”师曰：“非无言。”僧曰：“无言为什摩却非？”师曰：“不是无言。”问：“相逢不擎出，举意便知有，此意如何？”师合掌顶戴。报慈拈问僧：“只如洞山口里与摩道合掌顶戴，只与摩是合掌顶戴？”僧无对。自代曰：“一脉两中。”问：“清河彼岸是什摩草？”师曰：“不萌之草。”僧曰：“渡河就者如何？”师曰：“一切都尽。”师又云：“不萌之草为什摩能藏香象？香象者，今时功成果。草者，本来不萌之草。藏者，本不认圆满行相，故云藏。”

有一尼到僧堂前云：“如许多众生总是我兒子也。”众僧道不得。有人举似师，师代云：“我因所生。”有僧持钵家常，俗人问：“上座要个什摩？”僧云：“拣什摩？”俗人将草满钵盂著，云：“上座若解道得，则供养；若道不得，则且去。”其僧无对。有人举似师，师代云：“这个是拣底，不拣底把将来。”师问僧：“心法双亡性则真，是第几座？”对曰：“是第二座。”师曰：“为什摩不与他第一座？”僧曰：“非心非法。”师曰：“心法双亡，是非心非法也，何更如是道？”师代曰：“非真不得座。”问：“如何是父少？”师云：“阇梨春秋多少？”“如何是子老？”师曰：“某甲寻常向人道玄去。”问：“古人有言：‘但以神会，不可以事求。’此意如何？”师曰：“从门入者非宝。”曰：“不从门入者如何？”师曰：“此中无人领览。”问：“心法灭时如何？”师曰：“口里道得有什摩利益，莫信口头办，直得与摩去始得。设使与摩去，也是佛边事。”学进曰：“请师指示个佛向上人。”师曰：“非佛。”问：“四大违和，还有不病者也无？”师曰：“有。”僧曰：“不病者还看和尚不？”师曰：“某甲看他则有分，他谁彩某甲？”僧曰：“和尚病，争看得他？”师曰：“某甲若看，则不见有病。”问：“正与摩时如何？”师曰：“是阇梨窠窟。”僧曰：“不与摩时如何？”师曰：“不顾占。”僧云：“不顾占莫是和尚重处不？’师曰：“不顾占重什摩？”僧曰：“如何是和尚重处？”师曰：“不擎拳向阇梨。”僧曰：“如何是学人重处？”师曰：“莫合掌向某甲。”僧曰：“任摩则不相干也。”师曰：“谁共你相识？”僧曰：“毕竟如何？”师曰：“谁肯作大？谁肯作小？”

问：“牛头未见四祖时，百鸟衔花供养时如何？”师曰：“如珠在掌。”僧曰：“见后为什摩不衔花？”师云：“通身去也。”问：“如何是无心意识底人？”师曰：“非无心意识人。”僧曰：“还参请得也无？”师曰：“不曾闻人传语，不曾受人嘱托。”僧曰：“还亲近得也无？”师曰：“非但阇梨一人，老僧亦不得。”僧曰：“和尚为什摩不得？”师曰：“不是无心意识人。”问：“蛤中有珠，蛤还知不？”师曰：“知则失。”僧曰：“如何则得？”师曰：“莫依前言。”问：“古人有言：‘以虚空之心，合虚空之理。’如何是虚空之理？”师曰：“荡荡无边表。”“如何是虚空之心？”师曰：“不挂物。”“如何得合去？”师曰：“阇梨与摩道则不合也。”问：“古人有言：‘佛病最难治。’佛是病？佛有病？”师曰：“佛是病。”僧曰：“佛与什摩人为病？”师曰：“与渠为病。”僧曰：“佛还识渠也无？”师曰：“不识渠。”僧曰：“既不识渠，争得与他为病？”师曰：“你还闻道，带累他门风。”问：“语中取的时如何？”师曰：“的中取什摩？”僧曰：“与摩则的中非。”师曰：“非中还有的也无？”师问僧：“有一人在千万中，不向一人，不背一人，此唤作什摩人？”僧曰：“此人常在目前，不随于境。”师曰：“阇梨此语是父边道，子边道？”对曰：“据某甲所见，向父边道。”师不肯，师却问典座。“此是什摩人？”对曰：“此人无面［向］背。”师不肯，又别对曰：“此人无面目。”师曰：“不向一人，不背一人，便是无面目，何必更与摩道？”师代曰：“绝气息者。”问：“一切处不乖时如何？”师曰：“此犹是功勋边事，有无功之功，子何不问？”僧曰：“无功之功莫是那边人也无？”师曰：“已后有眼人笑阇梨与摩道。”僧云：“与摩则调然也。”师曰：“调然非调然，非不调然。”僧曰：“如何是调然？”师曰：“唤作那边人则不得。”僧曰：“如何是非调然？”师曰：“无弁处。”师蓦唤侍者，侍者来，师良久云：“传语大众：寒者向火，不寒者上堂来。”

师有时谓众曰：“这里直须句句不断始得，如似长安路上诸道信耗不绝。若有一道不通，便是不奉于君。此人命如悬丝，直饶学得胜妙之事，亦是不奉于君，岂况自余，有什摩用处？莫为人间小小名利，失于大事。假使起模尽样觅得片衣口食，总须作奴婢偿他定也。专甲敢保。先德云：‘随其诸类，各有分齐。’既得人身，的不皮衣土食。任运随缘，莫生住著。专甲家风只如此也。肯与不肯，终不仰勒阇梨，一任东西。珍重。”

师自咸通十年己丑岁三月一日剃发被衣，令击锺，俨然而往，大众号恸。师复觉曰：“夫出家兒心不依物是真修行，何有悲恋？”则呼主事僧，令办愚痴斋。主者仰恋，渐办斋筵，至七日备。师亦少食竟日。师云：“僧家何太粗率，临行之际，喧恸如斯。”至八日使开浴，浴讫，端坐长往。春秋六十二，僧夏四十一。敕谥悟本禅师慧觉之塔。勖励偈颂等并通流于参徒宝箧笥，此中不录矣。净修禅师赞曰：

师居洞山，聚五百众。

眼处闻声，境缘若梦。

涧畔贞筠，天边瑞凤。

不堕三身，吾于此痛。

祖堂卷六·渐源

渐源和尚嗣道吾，师讳仲兴。未睹实录，不决终始。师因随道吾往檀越家相看，乃以手敲棺木问：“生也，死也？”吾云：“生亦不道，死亦不道。”师云：“为什摩不道？”吾云：“不道，不道。”师不肯。去阳溪一宿次，半夜便醒悟，出声啼哭归寺，和尚便欢喜，自来迎接。师到石霜，将锹子向法堂前过来过去。霜云：“作什摩？”师云：“觅先师灵骨。”霜云：“洪水滔天，流浪去也。”师云：“与摩则正好著力。”霜云：“我这里无扎针之地，你向什摩处著力？”后太原孚上座代云：“先师灵骨犹在。”

祖堂卷六·石霜

石霜和尚嗣道吾。师讳庆诸，吉州新淦人也，俗姓陈。年十三于洪州西山出家，年二十于嵩山受戒。回参道吾，道吾问：“有一人无出入息，速道将来！”师云：“不道。”云：“为什摩不道？”师云：“不将口来。”

师年三十五而止石霜，更不他游。为洞上指唱，避不获乃旌法寺。四海玄徒奔凑，日夜围绕。师走避深山而不能免，众复寻出围栲。近半载间师无异说，然而无门可推。师不获已，乃有僧将杖子上。其僧云：“奉师一条杖，其形有九曲。则则为今时，上下长多少？”师云：“我道不出头。”僧云：“为什摩不出头？”师云：“汝道长多少？”大众一时云：“得也，得也。”师云：“汝若与摩，我有一句子盖却天下人舌头。”僧拈问师：“如何是盖却天下人舌头底句？”师云：“不可更教老僧答一转话。”问：“真身还出世也无？”师云：“真身不出世。”僧曰：“争奈真身何？”师云：“琉璃瓶子口。”问：“佛性如虚空时如何？”师曰：“卧时则有，坐时则无。”

师有时云：“我向前在一老宿处，有个师僧同过夏。夏满请益云：‘乞和尚指示个正因。’他老宿云：‘你莫栖东，正因中一字也无。’才与摩道，便失声齩齿两三下，悔与摩道。有一老宿隔窗闻，乃云：‘好个一镬羹，不净物污著作什摩？’福先拈问僧：‘如今须符他正因，不得污著，作摩生道？’僧无对。福先自代云：‘汝向后不得怪著我。’进曰：‘忽逢道伴，作摩生举？’先云：‘但问别人去。’”病僧问：“劫火洞然时如何？”师云：“来时不知有，去亦任从伊。”僧曰：“争奈即今羸劣何？”师云：“须知有不病者。”僧云：“病与不病相去几何？”师云：“悟即无分寸，迷则隔山歧。”僧云：“前程事如何？”云：“虽然黑似柒，成立在今时。”〔此僧峭然便去。〕师问张拙秀才：“汝名什摩？”对曰：“张拙。”师云：“世间文字有什摩限！名什摩拙！”对曰：“觅个巧处不可得。”师云：“也只是个拙。”张秀才有偈曰：

光明寂照遍恆沙，凡圣含灵共一家。

一念不生全体现，六情才动被云遮。

遣除烦恼重增病，趣向真如亦是邪。

任逐境缘无偏碍，真如凡圣等空华。

问：“道吾忌日，和尚何不设斋？”师云：“我因他得无三寸，所以不将这个供养。”有人问禾山：“古人云：‘我因他得无三寸，所以不将这个供养。’未审将什摩供养？”禾山云：“将无三寸供养。”僧云：“古人为什摩道‘不将这个供养’？”禾山云：“汝唤什摩作这个？”圆茶头问志圆：“为什摩勿奈何？”师云：“非但一个，阖国人亦勿奈何。”进曰：“和尚如何？”师云：“我亦勿奈何。”进曰：“师是人天师，为什摩勿奈何？”师云：“老僧不曾得他颜色，教我作摩生？”师问座主：“教中道：‘不可以智知，不可以识识。’此是什摩人次第？”对曰：“此是赞法身之言。”师云：“法身是赞，何必更赞乎？”座主无对。问：“忽有人问：‘百年后什摩处去’，作摩生向他道？”师云：“但向他道：‘二十年在世一千五百人’。”又云：“会摩？”对曰：“不会。”师云：“且归堂去。”师问大光：“除却今时还更有异时也无？”对云：“渠亦不道今日是。”师云：“我也拟道非今日。”雪峰问少师：“什摩处归？”对曰：“江西。”峰曰：“江西那里？”对曰：“石霜。”

雪峰举石霜病重时，有新到二百来人未参见和尚，惆怅出声啼哭。石霜问监院：“是什摩人哭声？”对云：“二百来个新到，不得参见和尚，因此啼哭。”师云：“唤他来隔窗相看。”侍者便唤他，新到一际上来隔窗礼拜问：“咫尺之间为什摩不睹尊颜？”师云：“遍界不曾藏。”雪峰举此话赞师后问：“‘遍界不曾藏’是什么界？”对云：“是什摩问和尚。”峰云：“问有横竖，是你因什摩与摩道，学人不会。”又问衷情，无可只对。峰造一句偈曰：

可怜徒勤子，时人笑你昏。

神清如镜像，迥然与物分。

师问僧：“从什摩处来？”对云：“雪峰来。”师云：“有什摩佛法因缘，你举看。”其僧便举。和尚示众云：“三世诸佛不能唱，十二分教载不起。三乘教外别传，十方老僧口，到这里百杂碎。”师便失声云：“堪作什摩？早被你蓦头拗却也。”师又云：“虽然如此，我也不一向。”其僧便问：“雪峰意旨如何？”师云：“我道梦人思不近，你作摩生？”问：“十方同一会，共谭何事？”师云：“在三寸上，何处有事在？”僧曰：“岂无拨端者？”师云：“时人眼不齐。”问：“如何是芥子纳须弥？”师云：“双双听你双双。”问：“臣之有功，王赐何物？”师云：“不转目。”师自僖宗皇帝特降紫衣，坚退不受。光启四年戊申岁二月十日迁化，报龄八十，僧夏五十九。平章事孙握撰碑文，敕谥普会大师见相之塔。


祖堂集卷七

祖堂卷七·夹山

夹山和尚嗣花亭，在澧州。师讳善会，姓廖氏，汉广岘亭人也。受业龙牙山，依年受戒于荆门。后通经论，时称学海聪辩天机。初曾京口已转法轮，后因道吾指，参承花亭，密契玄关，便栖夹岫。

师有时曰：“夫有佛、有法、有祖已来，时人错会谓言。佛边、祖边、法边递代相承，至于今日。须依佛祖法句意与汝为师言方是。因此天下出无眼狂人，却成无智。不然，他只如无法本来是道，无一法当情。没佛可成，没道可修，没法可舍。故目前无法，意在目前。他不是目前法，非耳目之所到。三乘十二分教是老僧坐具，祖师玄旨是破草鞋，宁可赤脚不著最好。目睹瞿昙犹如黄叶，汝若向佛边举法，此人未有眼目在。何以故？此皆属所依之法，不得自在，本只为生死忙忙。法法依著，识性无有自在分。他千里求善知识，须有眼目，永脱虚谬之见，不堕幻惑之法，方达后人直须目前生死。定取一言来看，为复实有，实无？若人定得，老僧许伊出头。所以老僧道‘垂丝千丈，意在深潭。语覆机而不顾，舌头去而不参。’”有人问：“如何是道？”师曰：“太阳溢目，万里不挂片云。”僧曰：“学人如何得会去？”师曰：“清潭之水，游鱼自迷。”有大德发心行脚，到先白马乃问：“承教中有言，一尘含法界之无边时如何？”师答曰：“如鸟二翼，如车二轮。”座主云：“将谓禅宗别有奇特之处，元来不出教乘。”便却归本寺。后闻师出世，遣少师持前问问师，师云：“雕砂无镂玉之谈，结草乖道人之思。”少师却归举似师，师遥礼夹山，赞曰：“将为禅宗与教不殊，天然有奇特之事。夹山不著后生。”

佛日到，维那不许参和尚。佛日云：“某甲暂来礼和尚，不宿。”维那白和尚云：“有个后生到来，暂礼和尚，不宿。”师乃许参见。佛日到法堂阶下未上，师云：“三道宝塔，阇梨从何而上？”佛日云：“三道宝阶，曲为今时，向上一路，请师速道，速道！”便上阶礼拜和尚了，师问：“从什摩处来？”对曰：“天台国清寺来。”师曰：“承闻天台有青青之水、绿绿之波。谢子远来，子意如何？”对曰：“久居岩谷，不挂森萝。”师曰：“此犹是春意，秋意如何？”佛日无对。师曰：“看君只是撑船汉，终归不是弄潮人。”福先代云：“凉风吹落叶，高低任意游。”凤池拈问僧：“作摩生只对免得撑船汉？”对曰：“待和尚自出来即商量。”凤池曰：“若出来时作摩生商量？”僧无对。自代：“不可预搔而待痒。”又代问：“若到有什摩难道？”师又问曰：“与什摩人为同行？”对曰：“木上座。”师曰：“在什摩处？”对曰：“在堂中。”师曰：“唤来。”佛日便归堂，取柱杖抛下师前。师云：“莫从天台采得来不？”对曰：“非五岳之所生。”师曰：“莫从须弥顶上采得来不？”对曰：“月宫不曾逢。”师曰：“与摩则从人得也。”对曰：“自己尚怨家，从人得堪作什摩？”师曰：“冷灰里豆子爆。”师唤维那：“安排向明灯下著。”又问：“你名什摩？”对曰：“佛日。”师曰：“日在什摩处？”对曰：“日在夹山顶上。”师曰：“与摩则超一句不得也。”师令大众酴地次，佛日倾茶与师。师伸手接茶次，佛日问：“酽茶三两碗，意在酴头边。远道，速道。”师云：“瓶有盂中意，蓝中几个盂？”对曰：“瓶有倾茶意，蓝中无一盂。”师曰：“手把夜明符，终不知天晓。”罗秀才问：“请和尚破题。”师曰：“龙无龙躯，不得犯于本形。”秀才云：“龙无龙躯者何？’师云：“不得道著老僧。”秀才曰：“不得犯于本形者何？”师云：“不得道著境地。”又问：“如何是夹山境地？”师答曰：“猿抱子归青嶂后，鸟衔花落碧岩前。”座主出来便问：“洞明三教底人，还通此理也无？”师云：“夜月明珠，不如天晓。”又问：“等妙三觉底人，还通此理也无？”师云：“金鸡玉兔，不堕鱼夫之手。”座主曰：“此意如何？”师云：“句中无法，意不度人。”座主曰：“步步踏莲花，犹是今时，升降螺髻向上事，乞师一言。”师云：“铁牛无声，不用闻之。”师问云盖：“近离什摩处？”对云：“近离朗州。”师曰：“此间无路，你争得到这里？”对云：“既无路，因什摩有人到这里？”师许之。师问法志：“近离什摩处？”对云：“近离朗州。”师曰：“作什摩来？”对云：“寻和尚迹。”师曰：“老僧不动步，你向什摩处寻？”对云：“咄！堕根汉！”师曰：“未屈阇梨在。”对曰：“不动步岂是不屈？”师便失声。师问僧：“从什摩处来？”对云：“新丰来。”师曰：“彼中是什摩人道首？”对云：“上字是良，下字是价。”师云：“吾识竟。”又问：“有什摩佛法因缘，汝举看。”其僧便举云：“和尚示众曰：‘欲行鸟道，须得足下无丝；欲得玄学，展手而学。’”师低却头，其僧便礼拜问：“某甲初入丛林，不会洞山意旨如何。”师云：“贵持千里抄，林下道人悲。”其僧礼拜退立。师云：“咄！者阿师近前来！”僧便近前而立。师云：“某甲初见先师，先师问某甲：‘阿那个寺里住？’某甲对云：‘寺则不住，住即不寺。’先师曰：‘为什摩故如此？’某甲对曰：‘目前无寺。’先师曰：‘什摩处学得此语来？’某甲对云：‘非耳目之所到。’先师云：‘一句合头意，万劫系驴橛。’如今改为四句偈曰：

目前无法，意在目前。

他不是目前法，非耳目之所到。

“某甲无赠物与阇梨，这个是老僧见先师因豫，囊中之宝，将去举似诺方。若有人弹得破，莫来；若也无人弹得破，却还老僧。”

其僧便辞，却归洞山。洞山问：“阿那里去来？”对云：“到夹山。”洞山曰：“有什摩佛法因缘，汝举看。”对云：“彼中和尚问当头因缘，某甲情切举似彼中和尚。”洞山曰：“举什摩因缘？”僧曰：“某甲举和尚示众曰：‘欲行鸟道，须得足下无丝；欲得玄学，展手而学。’”洞山便失声云：“夹山道什摩？”对云：“贵持千里抄，林下道人悲。”洞山云：“灼然夹山是作家。”

夹山小师当时在洞山。洞山教小师：“你速去！是你和尚在夹山，匡二百众，有如是次第。”小师对云：“某甲和尚无佛法，兼不在夹山。”其僧向小师云：“旧时则合山，如今改为夹山也。”小师方始得信，便辞洞山，却归本山。才到门前，高声哭入，向和尚说：“某甲是师初住山时，与和尚何事不造作？何事不经历？有与摩奇特之事，当时因什摩不与某甲说？”和尚云：“当初时，是你涛米，老僧烧火；是你行饭，老僧展受。又怪我什摩处？”小师便悟，是韶山和尚也。

问：“迷子归家时如何？”师云：“家破人亡，子归何处？”僧云：“不欲得见旧时人如何？”师答云：“庭前残雪日轮消，室内游尘教谁扫？”问：“迅速不停时如何？”师云：“有眼不窥王子乐，目前弁取老僧歌。”问：“南北则不问，和尚足下事如何？”师云：“雕砂无镂玉之机，结草亏道人之目。”

有一座主参师，师问：“久习何业？”对云：“《法花经》留心。”师曰：“《法花经》以何为极则？”对云：“露地白牛为极则。”师云：“爱著舍那之服、璎珞之衣，驾以白牛届此道场，岂不是座主家风？”对云：“是。”师曰：“旁边有个垛根迦叶，起来不肯，诸子幼稚，惟无所知。老僧者里百草头与一酴，座主向上一路富贵处因何不问？”座主曰：“与摩则有弟二月也。”师云：“老僧要坐却日头，天下黯黑，忙然者匝地普天。”座主问：“如何是向上一路富贵处？”师云：“滴雪峰外白云不挂，座主作摩生？”师又云：“一句子十方共参，一句子天下人不那何，一句子活却天下人，一句子死却天下人。巧拙临时自看。所以道：‘贵持千里抄，林下道人悲。’直得灵草不挂，犹非九五之位。明珠夜月，不是天晓。”问：“如何是沙门行？”师云：“动则影现，觉则病生。”钦山教侍者问师：“学人拟欲斩身千断，谁人下手？”师云：“道无横径，立者皆危。”侍者又问：“当风扬谷时如何？”师云：“者里无风，扬什摩？”侍者又问：“青山无霞，云从何生？”师云：“骏马不露峰骨，朗然清虚。”侍者云：“骏马何在？”师曰：“蒲麻作针，扎布袋不入。白云千丈之线，寄在碧潭，浮定有无，离钩三寸。子何不问？”侍者却归，举似钦山。钦山云：“夹山是作家。”漳南举此因缘，僧便问：“道无横径，立者皆危。与摩道只是说道话道，未审如何是道？”漳南云：“大家总觑汝。”师教僧问石霜：“如何是一老一不老？”霜云：“白云听你白云，青山听你青山。”其僧却归，举似师，师云：“门前把弄，不如老僧入理之谭。欠他三步。”

师自天门夹山首末十二年，通前凡三处转法轮。至中和初年辛丑岁十一月七日，自烧却门屋，请众曰：“苦哉！苦哉！石头一枝埋没去也。”乐蒲出来云：“听也埋没去，自有青龙在。”师问：“青龙意旨如何？”对曰：“贵人不借衣。”师便救火，因此造偈曰：

大江沉尽小江现，明月高讟法自流。

石牛水上卧，影落孤峰头。

荒田闻我语，如同不系舟。

师便示化矣。春秋七十七，僧夏五十七。塔于夹山，谥号传明大师永济之塔。韶州刺史金夔撰碑文。

祖堂卷七·岩头

岩头和尚嗣德山，在鄂州唐宁住。师讳全大/岁，俗姓柯，泉州南安县人也。受业灵泉寺义公下，于长安西明寺具戒，成业讲《涅盘经》。后参德山。初到参，始拟展坐具设礼。德山以杖挑之，远掷阶下。师因便下阶收坐具，相看主事参堂。德山谛视，久而自曰：“者阿师欲似一个行脚人。”私记在怀。来晨师上法堂参，德山问：“阇梨是昨晚新到，岂不是？”对云：“不敢。”德山云：“什摩处学得虚头来？”师云：“专甲终不自诳。”德山呵云：“他向后老汉头上屙著。”师礼而退藏密机。既盘泊数载，尽领玄旨。

初住卧龙，后居岩头。有人问：“去却仆从，直请卧龙相见。”师云：“眨上眉毛看。”曜日颂：

当机直下现前真，认语之徒未可亲。

本色先艹过如么罗，岩头柽桧镇长新。

时有三人同礼拜，未申问，师云：“三人俱错！”三人默而无言，师便喝出。东山代云：“只怕和尚无语。”云门代云：“和尚亦不得无过。”问：“如何是毗卢？”师云：“汝道什摩？”学人拟申问，师喝出，云：“钝汉！”问：“不历古今事如何？”师云：“卓朔底。”又问：“历古今事如何？”师云：“任烂底。”问：“三界竞起时如何？”师云：“坐却著。”僧曰：“未审师意如何？”师云：“移将庐山来，则向你道。”

罗山问：“和尚岂不是三十年在洞山又不肯洞山？”师云：“是也。”罗山云：“和尚岂不是法嗣德山又不肯德山？”师云：“是也。”罗山云：“不肯德山则不问，只如洞山有何亏阙？”师良久云：“洞山好个佛，只是无光奴。”雪峰问德山：“从上宗乘，和尚此间，如何禀授与人？”德山云：“我宗无语句，实无一法与人。”师闻举云：“德山老汉一条脊梁骨拗不折。虽然如此，于唱教中犹较些子。”保福拈问长庆：“岩头平生出世，有什摩言教过于德山，便道‘犹较些子’？”长庆举师示众云：“若是得意底人，自解作活计。举措悉皆索索底，时长恬恬底。触物则传，意在传处。住则铲住，去则铲去。须于欲去不去、欲住不住处体会。不执物，不据物。不同窒塞人紧把著事不解传得，恰似死人把玉擩玉相似。纵然传得，直到驴年有什摩用处？且愧伊向这里凑泊，不别运为。讶将去，钻将去，研将去，直教透过，直教通彻。不见道：‘如人学射，久久方中’？”有人问：“中时如何？”师云：“莫不识痛痒摩？”保福云：“今日非唯举话。”庆云：“是什摩心行？”问：“如何是祖师西来意？”师云：“移取庐山来，向你道。”师云：“德山老汉只凭目前一个白棒，曰：‘佛来也打，祖来也打。’虽然如此，交些子。”问：“如何是祖师西来意？”师云：“又与摩去也。”问：“如何是岩中的的意？”师云：“道什摩？”“请和尚答话。”师云：“谢阇梨指示。”

师共雪峰到山下鹅山院。压雪数日，师每日只管睡，雪峰只管坐禅。得七日后，雪峰便唤：“师兄且起。”师云：“作摩？”峰云：“今生不著便，共文遂个汉行数处，被他带累。今日共师兄到此，又只管打睡。”师便喝云：“你也噇眠去摩？每日在长连床上，恰似漆村里土地相似！他时后日，魔魅人家男女去在！”峰以手点胸云：“某甲这里未稳在，不敢自谩。”师云：“我将谓汝他时后日向孤峰顶上盘结草庵，播扬大教，犹作这个语话。”峰云：“实未稳在。”师云：“汝若实如此，据汝见处道将来。”峰云：“某甲初到盐官，因说观色空义，得个入处。又因洞山曰：‘切忌随他觅，迢迢与我疏。我今独自往，处处得逢渠。渠今正是我，我今不是渠。应须与摩会，方得契如如。’”师便喝云：“若与摩，则自救也未彻在。”峰云：“他时后日作摩生？”师云：“他时后日若欲得播扬大教去，一一个个从自己己胸襟间流将出来，与他盖天盖地去摩？”峰于此言下大悟，便礼拜，起来连声云：“便是鹅山成道也！”

二人分襟后，师在鄂州遇沙汰，只在湖边作渡船人。湖两边各有一片板，忽有人过，打板一下，师便提起楫子，云：“是阿谁？”对云：“要过那边去。”师便划船过。

雪峰往福州卓庵，过沙汰后，忽有两个纳僧来礼拜和尚。和尚才见上来，以手托木庵门，放身出外，云：“是什摩？”其僧对云：“是什摩？”峰便低头入庵里。其僧三五日后便辞。峰云：“什摩处去？”对云：“湖南去。”峰云：“我有同行在彼，付汝信子得摩？”僧云：“得。”雪峰遂作信，信云：“一自鹅山成道后，迄至于今。师兄一自鹅山成道后，迄至如今。同参某信付上师兄。”其僧到岩头，师问：“什摩处来？”云：“南方来。”师云：“到雪峰摩？”对云：“到。来时有信上和尚。”便抽书过与师。师接得便问：“他近日有什摩言教？”僧云：“某甲初到时，有一则因缘。”具举前话。师云：“他道什摩？”对云：“他无语，便低头入庵。”师便拍掌云：“噫！我当初悔不向伊道末后一句。我若向他道末后一句，天下人不奈何雪峰。”其僧到夏末具陈前因缘，问师云：“师道：‘我悔不向伊道末后一句。’如何是末后一句？”师云：“汝何不早问？”僧云：“某甲不敢容易。”师云：“虽则德山同根生，不与雪峰同枝死。汝欲识末后一句，只这个便是。”

师沙汰时，著蝠衫，戴席帽，去师姑院里。遇师姑吃饭次，便堂堂入厨下，便自讨饭吃。小师来见，报师姑，师姑把拄杖来。才跨门，师便以手拔席帽带起。师姑云：“元来是大/岁上座。”被师喝出去。

大彦上座初参见师，师在门前耘草次，彦上座戴笠子堂堂来，直到师面前，以手拍笠子，提起手，云：“还相记在摩？”师站得把草，拦面与一掷，云：“勿处，勿处。”他无语，便被师与三掴。后具威仪，始欲上法堂，师云：“已相见了，不要上来！”彦便转。到来朝，吃粥了，又上。始跨方丈门，师便透下床，拦胸一擒，云：“速道，速道。”无对，被师推出。大彦叹曰：“我将谓天下无人，元来有老大虫在。”

疏山参见师，师才见，却低头佯佯而睡。疏山近前立久。师并不管。疏山便以手拍禅床引手一下，师回头云：“作什摩？”山云：“和尚且瞌睡。”师呵呵大笑云：“我三十年弄马骑，今日被驴子扑。”

因沩山和尚于廊下泥壁次，李军容具公裳，直来请沩山访道，到沩山背后端笏而立。沩山回首便侧泥盘作接泥势，侍郎便转笏作进泥势。沩山当下抛泥盘，与侍郎把臂归方丈。师后闻此语，云：“噫！佛法已后淡薄去也！多少天下，沩山泥壁也未了在。”

夹山有僧到石霜，才跨门便问：“不审。”石霜云：“不必，阇梨。”僧云：“与摩则珍重。”其僧后到岩头，直上便云：“不审。”师云：“嘘！”僧云：“与摩则珍重。”始欲回身，师云：“虽是后生，亦能管带。”其僧却归，举似夹山。夹山上堂，云：“前日到岩头石霜底阿师出来，如法举著。”其僧才举了，夹山云：“大众还会摩？”众无对。夹山云：“若无人道，老咱不惜两茎眉毛道去也。”却云：“石霜虽有杀人之刀，且无活人之剑。岩头亦有杀人之刀，亦有活人之剑。”百丈垂语云：“与摩，不与摩。”有人举似师，师云：“我不与摩道。”便云：“与摩，与摩，不与摩，不与摩。与摩会千人万人之中，难得一个半个。”长庆与罗山在临水宅，举此因缘，便问罗山：“与摩，不与摩，则不问。与摩，与摩，不与摩，不与摩，意作摩生？”罗山云：“双明亦双暗。”庆云：“作摩生是双明亦双暗？”罗山云：“同生不同死。”此后有人问长庆：“如何是同生不同死？”庆云：“彼此合取口。”其僧却举似罗山，罗山便不肯。其僧便问：“如何是同生不同死？”罗山云：“如大虫著角。”“如何是同生同死？”罗山云：“如牛无角。”

师辞德山，德山问：“什摩处去？”对云：“暂辞和尚。”德山云：“子后作摩生？”对云：“不忘。”德山云：“既然如此，因什摩不肯山僧？”师对云：“岂不闻道：‘智慧过师，方传师教。’智慧若与师齐，他后恐减师德。”德山云：“如是，如是，应当善护持。”问：“如何是切急处？”师云：“道什摩？”僧无对。师便有颂：

适来和声送，低头不会事。

欲知此中意，云里有光彩。

问：“如何是佛法大意？”师云：“小鱼吞大鱼。”自余枢要，莫尽玄猷。

师平生预有一言：“者老汉去时，大吼一声了去。”以中和五年乙巳岁，天下罹乱，凶徒炽盛，师于四月四日偿债而终。临刃之时，大叫一声，四山回避之人悉闻其声。春秋六十，僧夏四十四。东吴僧玄泰制铭云：

善恶二境，逆顺取舍。

二祖大师，师子尊者。

敕谥清俨大师出尘之塔。

祖堂卷七·雪峰

雪峰和尚嗣德山，在福州。师讳义存，泉州南安县人也，俗姓曾。师生隔薰食，戏不群游，于识环之年居然异俗。及为童之岁辞亲，于莆田县玉涧寺依庆玄律师以受业焉。值武宗澄汰，变服而造芙蓉山，有若冥契，蒙圆照大师询而摄受。至大中即位，佛宇重兴，即四年庚午年，诣幽州宝刹寺具戒。自是不寻讲肆，唯访宗师，遍历法筵，方造武陵。才见德山，如逢宿契。便问：“从上宗乘事，学人还有分也无？”德山起来打之云：“道什摩？”师于言下顿承旨要，对云：“学人罪过。”德山云：“担负己身，询他轻重。”师礼谢而退，斯谓：“面临秦镜，目鉴亲躬。无猜非己之疑，复何言而属矣。”既而摩尼现掌，罢探沧溟，身役心闲，盘泊数载。后返锡瓯闽，卜于雪峰，众上一千余人。师神情恆荡而厉，容止怡怿而威。行则远近奔随，坐则森然拥绕。有时上堂云：“汝诸人来者里觅什摩？莫要相钝致摩？”便起去。有时上堂。众立久，师云：“便与摩承当却，最好省要。莫教更到这老师口里来。三世诸佛不能唱，十二分教载不起。如今嚼涕唾汉争得会？我寻常向师僧道是什摩？便近前来见答话处。驴年识得摩？事不得已，向汝与摩道，已是平欺汝了也。向汝道，未□〔跨步也，口化反〕门以前早共汝商量了。还会摩？亦是老婆心也。省力处不肯当荷，但知踏步向前觅言语。向汝道，尽乾坤是个解脱门，总不肯入，但知在里许乱走，逢著人便问：‘阿那个是？我还著摩？”只是自受屈，所以道：‘临河渴水，死人无数，饭箩里受饿人如恆河沙。’莫将等闲。和尚子若实未得悟入，直须悟入始得，不虚度时光，莫只是傍家相徼，掠虚嫌说。悟入且是阿谁分上事？亦须著精神好！菩提达摩来，道：‘我以心传心，不立文字。’且作摩生是汝诸人心？不可只是乱统了便休去。自己事若不明，且从何处出得如许多妄想？向这里见凡见圣，见有男女、僧俗、高低、胜劣，大地面上炒炒底铺砂相似。未尝一念暂返神光，流浪生死，劫尽不息。惭愧！大须努力好！”问：“寂然无依时如何？”师云：“犹是病。”进曰：“转后如何？”师云：“船子下扬州。”僧问：“承古人有言……”师便倒卧，良久起来。师云：“问什摩？问什摩？”学人再申问，师云：“虚生浪死汉。”问：“箭路投锋时如何？”师云：“好手不中的。“尽眼勿标时如何？”师曰：“不放随分好手。”保福拈问长庆：“既尽眼勿标，为什摩不许全好手？”庆云：“还与摩也无？”福云：“好手者作摩生？”庆云：“不当即道。”保福云：“谢和尚领话。”自云：“礼拜著！”问：“古人道‘路逢达道人，莫将语墨对。’未审将什摩对？”师云：“吃茶去。”师问僧：“此水牯牛年多少？”僧无对，师云：“七十七也。”僧曰：“和尚为什摩却作水牯牛？”师云：“有什摩罪过？”问：“古人有言：‘知有佛向上事，方有语话分。’如何是语话？”师把住云：“道什摩？”僧无对，被师踏。问：“学人道不得处请师道。”师云：“我为法惜人。”师举古来老宿行俗官巡堂云：“这里有二三百师僧，尽是学佛法僧。”官云：“古人道‘金屑虽贵’，又作摩生？”无对。师拈问镜清，镜清代云：“比来抛博引玉。”师问长庆：“古人道‘前三三后三三’，意作摩生？”庆便出去。鹅湖云：“喏。”师举拂子示僧，其僧便出去。长庆举似泉州太傅，却云：“此僧合唤转与一顿棒。”太傅云：“和尚是什摩心行？”庆云：“洎错放过。”沩山问仰山：“过去诸圣什摩处去？”仰云：“或在天上，或在人间。”师举问长庆：“仰山与摩道意作摩生？”庆云：“若问诸圣出没，与摩道即得。”师云：“汝浑来不肯。或有人问，汝作摩生对？”云：“但向他道错。”师云：“老僧却错，是你作摩生？”庆云：“何异于错？”师为书状头造偈：

苦屈世间错用心，低头曲躬寻文章。

妄情牵引何年了，辜负灵台一点光。

有俗士投师出家，师以偈住之：

万里无寸草，迥迥绝烟霞。

历劫常如是，何烦更出家？

师问僧：“什摩处来？”对云：“江西来。”师云：“这偈与江西相去多少？”对云：“不遥。”师拈起杖子云：“还隔这个摩？”对云：“不遥。”师肯之。又问僧：“什摩处来？”对云：“江西来。”师云：“这里与江西相去多少？”对云：“不遥。”师拈起拄杖云：“还隔这个摩？”对云：“若隔这个则遥。”师便打之。其僧却归，举似云居。云居云：“世谛则得，佛法则无过。”其僧却归雪峰，举似前话。峰云：“者老汉！老僧臂长，则便打二十棒。虽然如此，老僧这里留取十个。”双峰辞师时，造偈与师：

暂辞雪岭伴云行，谷口无关路坦平。

禅师莫愁怀别恨，犹如秋月月常明。

师和：

非怛抛僧去，云岭不相关。

虚空无隔碍，放旷任纵横。

神光迥物外，岂非秋月明？

禅子出身处，雷罢不停声。

师云：“世界阔一丈，古镜阔一丈；世界阔一尺，古镜阔一尺。”学人指火炉问：“阔多少？”师云：“恰似古镜阔。”天龙拈问：“为复火炉置于古镜与摩大，为复古镜置于火炉与与大？”庆代云：“与摩必弁人犹可在。”

师共双峰行脚，游天台过石桥，双峰造偈：

学道修行力未充，莫将此身险中行。

自从过得石桥后，即此浮生是再生。

师和：

学道修行力未充，须将此身险中行。

从此过得石桥后，即此浮生不再生。

问：“学人乍入丛林，乞师指示。”师云：“宁自碎身如微尘，终不敢瞎却一个师僧。”僧问：“四十九年后则不问，四十九年前事如何？”师以拂子蓦口打。师上堂良久，便起来云：“为你得彻困也。”孚上座云：“和尚败阙也。”僧问清座主：“雪峰过在什摩处，招得孚上座不肯？”座主云：“若不与摩道，争招得不肯？”又举似孚上座，上座云：“莫道是骨，皮也不识。”问：“但有施为，尽是傍通鬼眼。如何是正眼？”师良久。问：“古人有言：‘我眼本正，因师故邪。’如何是我眼本正？”师云：“末逢达摩。”僧云：“我眼何在？”师云：“不从师得。”问：“古人据个什摩事去却四十二本经论？”师云：“汝须礼拜始得。”师示僧云：“是什摩？”对云：“不似一物。”师便打。僧问苏州西禅：“三乘十二分教则不问，祖师西来的的意只请一言。”西禅竖起拂子，其僧不肯。后到雪峰，师问：“什摩处来？”对云：“西禅来。”师云：“有什摩佛法因缘？”僧举前话。师云：“你还肯也无？”对云：“作摩生肯？”师云：“作摩生说不肯底道理？”对云：“什摩生问，师将境示人？”师云：“是你从西禅与摩来，到这里过却多少林木总是境。你因什摩不不肯，只得不肯拂子？”僧无对。因此师云：“尽乾坤是一个眼，是你诸人向什摩处放不净？”庆对云：“和尚何得重重相欺！”有人持此语举似赵州，赵州云：“上座若入闽，寄上座一个锹子去。”翠岩持师语举似[王*祭]山，[王*祭]山云：“雪峰打二十捧，推向屎坑里著。”翠岩云：“和尚与摩道，岂不是打他雪峰过？”[王*祭]山云：“是也。”岩云：“眼又作摩生？”疏山云：“不见《心经》云‘无眼耳鼻舌身意’？”岩不肯云：“不是和尚。”[王*祭]山无言。师问僧：“什摩处人？”云：“磁州人。”师曰：“见说磁州出金，还是也无？”对曰：“不敢。”师曰：“还将得来也无？”对云：“将来。”师云：“若将来则呈似老僧看。”僧展手，师唾之。又问别僧：“什摩处人？”对云：“磁州人。”师曰：“见说磁州出金，还是也无？”对曰：“不敢。”师展手云：“把将金来！”僧便唾之，师便掴三五下。师问僧：“名什摩？”“惠全。”师云：“汝得入处作摩生？”对曰：“共和尚商量了也。”师云：“什摩处是商量处？”对云：“什摩处去来？”师曰：“汝得入处更作摩生？”僧无对，被棒。师举似长庆，长庆云：“前头两则也有道理，后头无主在。”师问：“什摩处来？”对曰：“蓝田来。”师曰：“何不入草？”长庆闻举云：“现。”

有僧辞，师问：“什摩处去？”僧曰：“浙中礼拜径山去。”“忽然径山问汝，向他道什摩？”对云：“待问则道。”师打之。师问镜清：“者个师僧过在什摩处？”清云：“径山问得彻困也。”师笑云：“径山在浙中，因何问得彻困？”清云：“不见道‘远问近对’？”师颂曰：

君觅路边花表柱，天下忙忙总一般。

琵琶拗捩随手转，广陵妙曲无人弹。

若有人能解弹得，一弹弹尽天下曲。

常敬长老初参时云：“休经罢论僧常敬等参。”师当时不造声。明日早朝来不审。师云：“休经罢论僧常敬在摩？”敬便出来，师云：“老僧唤休经罢论僧常敬，关公什么事？”敬云：“明君有诏，臣无不现。”师云：“适来诏不诏？”对云：“诏。”师便喝出。师有颂曰：

世中有一事，奉劝学者取。

虽无半钱活，流传历劫逼。

登天不借梯，遍地无行路。

包尽乾坤处，禅子火急悟。

寅朝不肯起，贪座昏黄晡。

鱼被纲裹却，张破獦帅肚。

朗上座问：“满目是生死。”师云：“满目是什摩？”上座便大悟。常敬长老问：“元正一旦万物唯新。未审真王还度春也无？”师云：“四相年老转，真王不度春。”敬云：“十二时中将何侍奉？”师云：“触食不受。”云：“忽然百味珍馔来时作摩生？”师云：“太与摩新鲜生！’

师入佛殿，见经案子问玄沙：“是什摩经？”对云：“《花严经》。”师云：“老僧在仰山时，仰山拈经中语问大众：‘刹说众生说，三世一切说，为什摩人说？”无人对。云：“养子代老，借此问阇梨，阇梨作摩生道？”玄砂迟疑，师问云：“你问我，我与你道。”玄沙便问，师便向面拶云：“掴！掴！”报慈拈问卧龙：“话是仰山话，举是雪峰举。为什摩雪峰招掴？”龙云：“养子代老。”慈云：“打草惊蛇。”师见僧云：“会摩？”对云：“不会。”师云：“老僧不出头，为什摩不会？”师问僧：“你还有父母摩？”对云：“有。”师云：“吐却著。”别僧云：“无。”师云：“吐却著！”又别僧云：“和尚问作什摩？”师云：“吐却著！”师示众云：“明镜相似，胡来胡现，汉来汉现。”有人举似玄沙，玄沙云：“明镜来时作摩生？”其僧却归雪峰，举似玄沙语。师云：“胡汉俱隐也。”其僧却归玄沙举此语，玄沙云：“山中和尚脚跟不踏实地。”又时玄沙上雪峰，师收一脚而行。沙问：“和尚作什摩？”师云：“脚跟不踏实地婆。”

师示众云：“我寻常道钝汉，还有人会摩？若也有人会，出来呈似我，我与你证明。”时有长生出来云：“觌面峻，临机俊。”师云：“老子方亲得山僧意。”顺德云：“打水鱼头痛。”师云：“是也。”

师示众云：“某甲共岩头、钦山行脚时，在店里宿次，三人各自有愿。岩头云：‘某甲从此分襟之后，讨得一个小船子，共钓鱼汉子一处座，过却一生。’钦山云：‘某甲则不然。在大州内，节度使与某礼为师。处分著锦袄子，坐金银床。斋时金花碟子、银花碟子大盘里，如法排批吃饭，过却一生也。’某云：‘某甲十字路头起院，如法供养师僧。若是师僧发去，老僧提钵囊、把拄杖送他。他若行数步，某甲唤上座。他若回头，某甲云途中善为。’自后岩头、钦山果然是不违于本愿，只是老僧违于本志，住在这里，造得地狱查滓。”又云：“江西、湖南、东蜀、西蜀总在这里。”当时无人出问，师教僧问，其僧出来礼拜问：“未审这里事如何？”师云：“入地狱去。”有人拈问报慈：“先师与摩道意作摩生？”慈云：“阎老断望。”问：“古人有言：‘欲得不招无间业，莫谤如来正法轮。’如何得不谤去？”师云：“入地狱去。”问：“如何是涅盘？”师云：“入地狱去。”

师示众云：“譬如世闻两个君子，一个君子从南方来，一个君子从北方来，广野之中相逢。南来君子问北来君子：‘何姓第几？’北来君子便掴，南来君子云：‘某甲行五常之礼，过在于何？’北来君子云：‘某甲早是不著便。’诸和尚若须这个况喻，住山也得，住城隍也得。”

师游西院了，归山次，问泯典座；“三世诸佛在什摩处？”典座无对。又问藏主，藏主对云：“不离当处常堪然。”师便唾之。师云：“你问我，我与你道。”藏主便问：“三世诸佛在什摩处？”师忽然见有个猪母子从山上走下来，恰到师面前，师便指云：“在猪母背上。”

师又时问：“僧堂中有一千余人，争委得他是龙是蛇，又不通个消息。”长庆云：“有个沁水杖子。”师云：“汝道我这里作摩生？”庆放身作倒势，师云：“这个师僧患风去也。”

沩山与仰山一夜语话次，沩山问仰山：“子一夜商量，成得什摩边事？”仰山便一划，沩山云：“若不是吾，洎被汝惑。”有人问长庆：“仰山一划意作摩生？”便竖起指。又问顺德，顺德又竖起指，其僧云：“佛法不可思议，十圣同辙。”其僧又举似师，师云：“两个总错会古人事。”其僧却问师，师云：“只是个横事。”

师初出家时，儒假大德送三首诗：

光阴轮谢又逢春，池柳亭梅几度新。

汝别家乡须努力，莫将辜负丈夫身。

又云：

鹿群相受岂能成，鸾凤终须万里征。

何况故园贫与贱，苏秦花锦事分明。

又云：

宪原守贫志不移，颜回安命更谁知。

嘉禾未必春前熟，君子从来用有时。

师问僧：“什摩处来？”对云：“不涉途中。”师云：“咄！这虾蟆叫。”又问僧：“什摩处来？”对云：“江西来。”师曰：“什摩处逢达摩？”对云：“非但达摩，更有亦不逢。”师云：“有达摩不逢，无达摩不逢？”对曰：“不逢说什摩有无！”师云：“既不说有无，你何道不逢？”僧无对。

师示众曰：“南山有鰲鼻蛇，是你诸人好看蛇。”众无对。庆代云：“和尚与摩道，堂中多有人丧身失命。”玄沙代云：“要那南山作什摩？”晖和尚颂曰：

雪峰义得一条蛇，寄著南山意若何？

不是寻常毒恶物，参玄领得会先陀。

报慈和：

劝君险处好看她，冲著临时争奈何？

欲得安身免负物，向南看北正先陀。

师指树橦子问长庆：“古人道：‘见色便见心，心外无余。’你还见树橦子不？”对云：“见什摩？”师云：“孤奴。”庆云：“不孤和尚。”师云：“你道不孤，我道孤。”庆退三步而立。师云：“你问我，我与你道。”庆便问：“和尚见树橦子不？”师云：“更见什摩？”问：“目击相扣，不言勃扌素者如何？”师云：“你也要急相投。”又值盲人，师云：“我盲。我盲。”

师平生厚心接物，行坐垂机。自天佑丙寅之间，众上一千七百，闽王四事供须，不替终始。开平二年戊辰岁五月二日夜三更初迁化，春秋八十七，僧夏五十九，出世三十九年。敕谥真觉大师难提之塔。


祖堂集卷八

祖堂卷八·云居

云居和尚嗣洞山，在洪州。师讳道膺，姓王，幽州蓟门玉田人也。师居龆龀，山/歧疑生知，匪狎竹马之朋，卓有乘羊之誉。年二十五于幽州延寿寺受戒。初习毗尼，喟然叹曰：“大丈夫兒焉局小道而晦大方？。”遂纳衣杖锡，径访翠微。一沐玄津，三移星律。因宴止石室，俄见二使[页*赤]素异裳。曰：“师其南方必过奇人。”果有毳侣自洪南而至，举洞山大师当世宗匠。师乃摄衣而造洞山。洞山大师格高调古，言筒旨玄。师一至毕其仪敬。洞山问：“阇梨名什摩？”师称名专甲。洞山云：“向上更道。”师云：“向上道则不名专甲。”洞山云：“如吾在云岩时只对无异。”遂朝询夕惕，励志怀冰，效赤水以求珠，踵温生之目击。

有因一日问洞山：“如何是祖师意？”洞山云：“阇梨他后住一方时，忽有人问作摩生向他道？”师云：“专甲罪过。”洞山又问师：“我闻思大和尚向倭国作王，虚实？”师云：“若是思大，佛亦不作，岂况国王乎？”洞山默然许之。”自是密须玄旨，闻所未闻，更不他游，学心并息。初住三峰，后住云居。钟陵大王仰德高重，殷勤异常，为奏紫衣师号，师再三坚止。由是法轩大敞，玄教高敷。十五余年，春秋不减千有余众。

师每上堂云：“夫出家人但据自己分上决择，切不得分外。到这里合作摩生行李？身上被什摩衣服？吃什摩饭食？合作什摩声音？身被高上衣，须取高事道。尔千乡万里行脚来，为个什摩事？更向这里容易过，则知不得。莫为小小因缘妨于大事。大事未办，日夜故合因修。所以道‘如对尊严长，须得兢兢底。’决择之次，如履轻冰；勤求至道，如救头然，更有什摩余暇？如火逼身，便须去离。一切事来，总须向这里荡罗，头头上须及，物物上须通。若有毫发事乃不尽，则被沉累，岂况于多道。你一步才失，便须却回一步，若不回冥然累劫。便是隔生隔劫、千生万生，事只为一向，若向这里不得，万劫千生著钝。”

问：“如何是曩劫事？”师云：“只在如今。”僧曰：“如今作摩生？”师云：“不见有曩劫事。”师上堂，只在绳床边立，大众亦在一畔立。良久便归去。俗士问僧：“某甲家中有小一铛子，寻常煮饭三人吃不足，千人食有余，上座作摩生？”僧无对。师代云：“争则不足，让则有余。”有尚书问：“古人有言‘世尊有密语，迦叶不覆藏。’如何是世尊有密语？”师唤尚书，尚书应喏。师云：“还会摩？”尚书云：“不会。”师曰：“汝若不会，世尊有密语；汝若会。迦叶不覆藏。”师问僧：“你名什摩？”对云：“行密。”师云：“是什摩行得与摩密？”僧无对。师代云：“虽则如此，有人未许专甲在。”师示众云：“如人将一百贯钱买得猎狗，只解寻得有踪迹底。忽遇灵羊挂角，莫道踪迹，气也不识。”僧便问：“灵羊挂角时如何？”师云：“六六三十六。”又云：“会摩？”对云：“不会。”师云：“不见道‘无踪迹’？”僧举似赵州。赵州云：“云居和尚犹在。”僧便问赵州：“灵羊挂角时如何？”州云：“六六三十六。”问：“大肯底人与大舍底人是一是二？”师云：“是二。”僧曰：“阿那个是轻？阿那个重？”师云：“大肯是重，大舍是轻。”僧曰：“大肯底人为什摩却重？”师云：“此人见自己向上事似不净物，所以不落功勋边。大舍底人则不见有身则是也，所以属向去功勋边事。岂不是轻？”问曰：“达摩未来时在什摩处？”师答曰：“只在这里。”进曰：“为什摩不见？”师曰：“过西天去。”问曰：“于耳不闻，于眼闻声时如何？”师曰：“眼还闻也无？”对曰：“闻者不是眼。”师自代曰：“眼闻非眼。”问：“被三衣即这边人，那边人事作摩生？”师云：“那边人被什摩衣服？”学人不会。师云：“不阙。”学人云：“不阙底事作摩生？”师云：“生生不拣。”有僧问：“总无人时，和尚还说话也无？”师曰：“未曾停此时。”进曰：“什摩人得闻？”师曰：“不说者得闻。”进曰：“师还闻也无？”师云：“闻即不说。”问：“游子归家时如何？”师云：“且喜得归来。”进曰：“将何奉献？”师云：“朝打三千，暮打八百。”有人问：“如何是清净茄蓝？”师曰：“合著什摩人？”僧无对。自代：“不是不著，渠不坐圆位。”有人问：“大业底人，为什摩阎罗天子觅不得？”师云：“是伊解藏身。”进曰：“忽然投著时作摩生？”“吃拳吃鸺。”师示众云：“孤迥且巍巍。”僧云：“便请。”师云：“孤迥且巍巍。”学人不会。师云：“是你面前桉山，岂不会？”师问僧：“什摩处去来？”对曰：“山下去来。”师云：“草还青也无？”对曰：“青也。”师云：“牛还吃也无？”僧无对。自代云：“有余，有余。”体云：“不希望。”又云：“自足即是。”有人问：“二祖截臂，当为何事？”师云：“不为少少苦。”进曰：“求还得也无？”师云：“此身当射。”师临顺世时，师问侍者：“今日是几？”侍者云：“三日。”师云：“三十年也只这个是。”有人问：“不出户者如何？”师云：“不著事。”进云：“为什摩不著事？”师云：“不出户不著事。”又云：“此是理用也。”问：“不逢不遇时如何？”师云：“也大屈在。”僧云：“得遇得逢时如何？”师云：“也大屈在。”进曰：“既得遇得逢，为什摩却成屈？”师云：“千劫不过来。”僧曰：“与摩则不逢不遇即是也。”师云：“路上行人绝。”保福拈问困山：“古人道：‘得逢得遇亦是屈，不逢不遇亦是屈。’不逢不遇时屈则且从，得逢得遇为什摩却是屈？”困山云：“上座行脚底事作摩生？”保福不肯，自云：“从来合作摩生？”又代前云：“且行脚去。”问：“文殊丈剑拟杀何人？”师云：“动者先死。”僧曰：“万里无寸草处作摩生？”师云：“谁人受杀？”僧曰：“不弁生死底人作摩生？”师云：“不由人。”问：“古人道：‘佛不会道，我自修行。’如何是佛不会道？”师云：“佛与众生总不会。”进曰：“是什摩人会？”师云：“是阇梨会。”僧云：“和尚道阇梨是什摩人？”师云：“非佛不众生者。”问：“纯石之山草从何生？”师云：“不理则不乱。”僧云：“忽然片云来时如何？”师云：“莫视。”僧云：“与摩则空然也。”师云：“何必！”同安问：“重玄不到处如何？”师云：“向上事作摩生？”安云：“则非重玄。”师云：“不得。”同安不肯。在后收过，改前语云：“谁言到不到？”

抚州刺史便问圆长老：“只如国王大臣未曾见有小福，未审曾供养什摩人来？”长老云：“曾供养佛。”刺史云：“有佛则供养，未有佛时供养什摩人？”长老无对。师代云：“贤者不隐。”报慈代云：“未有佛时何不问吾？”问：“举目便知意时如何？”师云：“什摩生事？”问：“欲采宝珠时如何？”师云：“漂入罗刹鬼国。”僧曰：“大悭惜生。”师云：“自是你无分。”

因兵马入云居山，众僧总走，唯有师端然不动。统军使不礼拜而对坐。便问：“世界什摩时得安？”师云：“待将军心足。”统军便礼拜为师。问：“松生三寸时如何？”师云：“不从他得。”僧云：“直拔云霄时如何？”师云：“不是本来身。”进云：“还假四时也无？”师云。“不涉诸有。”问：“不假言句，还达本源也无？”师云：“问取与摩人。”僧对云：“只今现问。”师云：“更讨一问。”有僧问：“三千里外久响云居，三千里内事如何？”师云：“三千里内尽是真如。”进曰：“如何是真如？”师云：“三千三千。”问：“雪山六年苦行当为何事？”师云：“自立其志，万法不依。”僧曰：“明星出时当何所见？”师云：“都无所见。”僧曰：“作何功课，则得外道归心？”师云：“一切俱息。”进曰：“著弊垢衣，彼中消息如何？”师云：“转高去也。”僧曰：“与摩则现化劝机也。”师云：“不将为有。”问：“古人道：‘我这里有刮骨禅也。’体也无如何刮？”师云：“直须刮。”僧曰：“体也无如何刮？”师云：“始得刮。”僧曰：“刮后如何？”师云：“则非骨髓。”佛日问：“二龙争珠，谁是得者？”师云：“舍却业身来。”佛日云：“业身已舍。”云居便云：“珠在什摩处？”佛日无对。佛日别时依前举：“某甲比来问和尚‘业身已舍，珠在什摩处’，与摩排批，和尚便夺，某甲道不得。忽有人问‘业身已舍，珠在什摩处。’和尚作摩生道？”师云：“转头则不得。”又云：“更有嗦路作摩生？”佛日无对。师云：“谁求珠者？”师示众云：“十度拟发言，九度却休去。为什摩却如此？只恐你诸人无利益。”长庆闻举，别云：“十度拟发言，十度却休去。莫道诸人无利益。”僧问长庆：“古人道‘十度拟发言，九度却休去。’古人为什摩却如此？”庆便掴之。又云：“这个是布袋和尚真。”又云：“更有一路汝自看。”问：“牛头未见四祖时如何？”师云：“在。”僧云：“见后如何？”师云：“忘却也。”问：“相逢欲相识，脉脉不能言时如何？”师云：“适来洎道得。”自余玄要，此不尽彰。

天复元年辛酉岁秋，忽有微疾，至十二月上旬累有教令。至二十八日夜，主事及三堂上座参省，师顾视云：“汝等在此，粗知远近。生死寻常，勿以忧虑。斩钉截铁，莫违佛法。出生入死，莫负如来。事宜无多，人各了取。”至二年壬戍岁正月二日，问侍者：“今日是几？”云：“新岁已二。”师曰：“吾出世来恰三十年，亦可行矣。”三日寅时终焉。

祖堂卷八·钦山

钦山和尚嗣洞山，师讳文遂。未睹行状，莫穷姓族。武陵雷相公礼以接足，不替终始。僧问：“如何是祖师西来意？”师曰：“梁公曲尺，志公剪刀。”问：“一切诸佛及诸法皆从此经出，如何是此经？”师曰：“常转。”僧问：“未审经中说什摩？”节曰：“有疑请问。”师与卧龙、雪峰煎茶次，见明月彻碗水。师曰：“水清则月现。”卧龙曰：“无水清则月不现。”雪峰便放却碗水了，云：“水月在什摩处？”因将江寺僧乞钱，有人问：“乞钱作什摩？”云：“掘井钱。”“既是将江，掘井作什摩？”无对。师代云。“不饮众流。”师问道士：“为法来，为礼拜来？”对云：“为法来。”师云：“若为法来，不得坐。”道士问：“粗言及细语皆归第一义，如何是第一义？”师云：“汝是佛家奴，是不？”对云：“和尚太粗生。”师云：“第一义何在？”进云：“和尚莫通三教也无？”师云：“三教且致老君什摩时生？”对云：“混沌未分时生。”师曰：“混沌未分前事作摩生？”道士无对，师便打之。

祖堂卷八·中山

中山和尚嗣洞山，在高安卧师韩道全。未睹行状，不决终始。师问洞山：“如何是出离之要？”洞山云：“阇梨足下烟生。”师便悟。后云居进云：“与摩则不敢辜负和尚也。”大光进云：“与摩则不敢造次。”所以文家赞第二和尚云：“师闻声耳之言，便息修证之路。”问：“清净行者不入涅盘，破戒比丘不坠地狱。古人意旨如何？”师云：“度尽无遗影，还他越涅盘。”问：“二龙争珠，谁是得者？”师云：“众类皆尽，但似目前。”僧曰：“与摩则二龙俱不得也。”师云：“非但二龙，千佛不得。”僧曰：“非佛还得也无？”师云：“得者不是明珠。”

祖堂卷八·曹山

曹山和尚嗣洞山，在杭州住。师讳本寂，泉州蒲田县人也，俗姓黄。少习九经，志求出家，年十九父母方听。受业于福唐县灵石山，年二十五，师方许受戒，而举措威仪，皆如旧习。便云游方外。初造洞山法筵，洞山问：“阇梨名什摩？”对曰：“专甲。”洞山云：“向上更道。”师云：“不道。”洞山曰：“为什摩不道？”师云：“不名专甲。”洞山深器之。盘泊数年，密室承旨。因一日辞去，洞山问：“什摩处去？”师曰：“不变异处去。”洞山曰：“不变异处去岂有去也？师云：“去亦不变异。”自尔之后，兀兀延时，依依放旷，非其道友，无得交言。稳不自由，化缘将至。初住曹山，后居荷玉。

钟陵大王响仰德高，再三降使迎请，师乃托疾而不从命。第三遣使去时，王日“此度若不得曹山大师来，更不要相见。”使奉旨到山，泣而告曰：“和尚大慈大悲，救度一切。和尚此度若也不赴王旨，弟子一门便见灰粉。”师云：“专使保无忧虑。去时贫道附一首古人偈上大王必保无事。”偈曰：

摧残枯木倚青林，几度逢春不变心。

樵客见之犹不顾，郢人那更苦追寻！

使回通偈，王遥望山顶礼曰：“弟子今生决定不得见曹山大师也。”如是二处法席咸二十年，参徒冬夏盈于二百三百。

师每上堂示众云：“诸人莫怪曹山不说。诸方多有说成底禅师在，你诸人耳里总满也。一切法不接不借，但与摩体会，他家差别知解，无奈阇梨何。天地洞然，一切事如麻如苇，如粉如葛。佛出世亦不奈何，祖出世亦不奈何，唯有体尽即无过患。你见他千经万论说成底事不得自在，不超始终，盖为不明自己事。若明自己事，即转他一切事，为阇梨自己受用具。若不明自己事，乃至庠梨亦与他诸圣为缘，诸圣与阇梨为境，境缘相涉，无有了时，如何得自由？若体会不尽，则转他一切事不去；若体会得妙，则转他一切事，向背后为僮仆者。是故先师云：‘体在妙处’。莫将作等闲，到这里不分贵贱，不别亲疏，如大家人守钱奴相似。及至用时，是渠总不得知东西。这里便是不辩缁素，不识清浊。若是下人出来著衣，更胜阿郎，奈何缘被人识得伊。专甲向诸人道：向去语则净洁，事上语却不净洁，且唤什摩事上语？这里没量大人弁不得。”

僧问：“学人自到和尚此间，觅个出身处不得。乞和尚指示个出身路。”师云：“阇梨曾行什摩路来？”云：“到这里弁不得。”师云：“第一不得出身处。”问：“古人道；‘从苗弁地，从语识人。’只今语也请师弁！”师云：“不弁！”僧曰：“为什摩不弁？”师云：“不见道‘曹山好手’？”问：“鲁祖面壁，用表何事？”师以手掩耳。问：“无言如何现？”云：“莫向这里现。”僧云：“向什摩处现？”师云：“昨夜三更失却三个钱。”问曰：“未出时如何？”师云：“昔日曹山亦曾与摩来。”进云：“日出后如何？”所云：“犹欠曹山三月粮。”问：“古人面壁，当为何事？”师云：“两株嫩桂久昌昌。”问：“承教中有言：‘未出轮回而弁圆觉，彼圆觉性则同轮回。’如何是未出轮回而弁圆觉？”师云：“如人在途中说家事。”“如何是彼圆觉性则同轮回？”师云：“宛然在途，不涉途程。”“还有弁处也无？”师曰：“若有弁处则不圆。”“只如无弁处还流转也无？”师曰：“亦有流转。”“如何流转？”曰：“要且不团团。”问：“眉与目还相识也无？”师云：“不相识。”进云：“为什摩不相识？”师云：“为同在一处。”僧云：“与摩则不分也。”师云：“眉且不是目。”“如何是目？”师云：“端的去。”“如何是眉？”师云：“曹山却疑。”僧曰：“和尚为什摩却疑？”师云：“我若不疑则端的去。”问：“常在生死海中沉没者是什摩人？”师云：“第二月。”僧曰：“还求出离也无？”师云：“也求出离，只是无路。”僧云：“出时什摩人接得伊？”师云：“将铁枷者。”问：“朗月当空时如何？”师云：“犹是阶下汉。”僧曰：“请师接阶上。”师曰：“月落后相见。”问：“罕如何假？”师云：“不希夷。”僧曰：“作何你？”师曰：“不申哂。”僧曰：“与摩则零去也。”师云：“不申哂，零什摩？”问：“一牛饮水，五马不嘶时如何？”师云：“曹山孝满。”问：“于相何真？”师云：“即相即真。”僧曰：“当示何者？”师便提起碗子。问：“国内按剑者谁？”师云：“曹山。”僧曰：“拟杀何人？”师曰：“但有一切总杀。”云：“忽逢本生父母时作摩生？”师云：“拣什摩？”僧云：“争奈自己何？”师云：“谁奈我何？”僧云：“为什摩不杀？”师云：“勿下手处。”俗士问：“古人道：‘人人尽有’，弟子在尘闬，还有也无？”师过手来，遂点头指云：“一二三四五足。”问：“古人有言：‘未有一人倒地不因地起’，如何是地？”师云：“一尺二尺。”“如何是倒？”云：“肯即是。”“如何是起？”师云：“起也。”问：“具何知解，尚能对众问难？”师云：“不呈言句。”僧曰：“既不呈言句，问难个什摩？”师云：“刀斧砍不入。”僧云：“解与摩问难，还更有不肯者也无？”师云：“有。”僧云：“是什摩人？”师云：“曹山。”问：“幻本何真？”云：“幻本元真。”僧曰：“当为何现？”师云：“即幻即现。”僧曰：“与摩则始终不离幻也。”师云：“觅幻相不可得。”僧问：“亲近什摩道伴即得常闻于未闻？”云：“共同一被盖。”僧云：“此犹是和尚得闻，如何是常闻于未闻？”师云：“不可同于木石。”僧曰：“何者在先，何者在后？”师云：“不见道‘常闻于未闻’？”问：“古人道：‘诸佛诸祖不知有，狸奴白牯却知有。’诸佛诸祖为什摩不知有？”师云：“佛为相似，祖为执印。”僧云：“狸奴白牯知有个什摩？”师云：“知有狸奴白牯。”云：“佛祖为什摩相似执印？”师云：“人无阻碍，此中妙会。”问：“教中有言：‘杀一阐提，获福无量。’如何是阐提？”师云：“起佛见、法见者。”云：“如何是杀？”云：“不起佛见、法见者是杀。”师却问僧：“是明阐提，是暗阐提？”僧无对。师代云：“白裹肚著皁祆。此意者起见是明，故云白；不起见者是暗，故云墨。”

师举教中事问大众：“‘无问而自说，称赞所行道。’作摩生是无问而自说？”云：“尽大地未有一人得闻。”师云：“虽然与摩，摘一个字，添一个宇，佛法大行。”众无对。师云：“尽大地未有一人不闻。”师垂语云：“此座高广，吾不能升，未审唤作什摩座？”强上座对云：“唤作此座，早是触污也。”师云：“还有升得者也无？”对云：“有。”师云：“是什摩人？”对云：“不举足者。”师曰：“升得者莫便是座上人也无？”对云：“也是左右。”师云：“如何是座上人？”对云：“不升此座。”师云：“既不升，用座何为？”对云：“无则不得。”师云：“只如座，为当别有人，为复转座为上身？”对云：“即转座为上身。”师云：“如是，如是。”师问僧：“从什摩处来？”对云：“从大光来。”师云：“来时光还现也无？”对云：“不现常现。”师云：“还照不？”对云：“不照。”师云：“大光何在？”僧无对。师云：“将谓是玉玺，元来只是天南角。”师代云：“直得不照，始得大光。”问：“古人道‘得座被衣’，如何是得座？”师云：“不顾东西。”“如何是被衣？”师云：“去离不得。”僧曰：“是个什摩衣去离不得？”师云：“人人尽有底衣即是。”僧云：“既是人人尽有底，用被作什摩？”师云：“岂不见道‘起倒相随，处处得活’？”僧云：“向后自看事如何？”师云：“不认被衣。”又云：“脱却衣来相见。”问：“如何是十年归不得、忘却来时路？”师云：“得乐忘忧。”僧云：“忘却什摩路？”师云：“十处即是。”僧曰：“还忘却本来路也无？”师云：“亦忘却。”僧云：“为什摩不言九年，要须十年？”师云：“若有一方不归，我不现身。”问：“教中有言：‘童子舍全身，夜叉说半偈。’如何是童子舍全身？”师云：“失却端正。”“如何是夜叉说半偈？”“白云缦荆棘。”“如何是失却端正？”师云：“只是失却少父便是。”问：“王殿苔生时如何？”答曰：“不居正位。”进曰：“八方来朝时如何？”云：“不受礼。”云：“与摩则何用来朝耶？”云：“违则暂违，顺是臣之分事。”云：“君意如何？”云：“枢密不得旨。”云：“与摩则治国之功全归臣相去也。”云：“还知君性不？”对云：“外方不敢论。”师问僧：“名什摩？”对云：“智轮。”师云：“智轮与法轮相去多少？”轮无对。邈公代云：“亦同亦不同。”绍公代云：“纤毫不隔。”强上座代云：“要近则近，要远则远。”师云：“作摩生是要近则近？”对云：“同辙载。”师云：“作摩生是要远则远？”云：“不同众辐即是。”师云：“阿那个是先？”云：“不同众辐者先。”师云：“如是，如是。”问：“如何是法身主？”师良久。问：“承先师有言：‘学处不玄，流俗阿师。’如何是玄？”师云：“未问前。”僧云：“与摩莫便是玄也无？”师云：“玄则不是流俗阿师。”僧云：“如何是玄？”师云：“换日问来。”问：“三乘十二分教还有祖师意也无？”师曰：“有。”僧曰：“既有祖师意，又用西来作什摩？”师云：“只为三乘十二分教有祖师意，所以西来。”问：“如何是和尚家风？”师云：“问与摩醉汉作什摩？”又云：“不因阇梨问，曹山也不知。”问：“如何是异类？”师云：“异中不答类。”又云：“我若向你道，驴年得异摩？”又云：“曹山只有一双眉。”问：“文殊为什摩仗剑于瞿昙？”师云：“为阇梨今时。”进曰：“如来为什摩却称善害？”师云：“大悲覆护群生。”云：“未审杀尽后如何？”师云：“方识不死者。”僧云：“只如不死者，为瞿昙是什摩眷属？”师云：“与阇梨安名即得，只恐不成眷属。”僧云：“时中如何给侍？”师云：“子当善害。”问：“《华严经》云‘大海不宿死尸。’如何是大海？”云：“包含百有。”“如何是死尸？”师云：“绝气者不著。”僧云：“既包含百有，绝气者为什摩不著？”师云：“大海非其功，绝气者有其德。”僧云：“未审大海还更有向上事也无？”师云：“道有道无即得，争奈龙王按剑何。”

师问僧：“手里是什摩物？”对云：“佛头上宝镜。”师云：“既是佛头上宝镜，争得到阇梨手里？”僧无对。师代云：“诸佛却是某甲兒孙。”问：“古人道：‘佛不会道，我自修行。’如何是佛不会道？”师云：“佛界里无会。”石门云：“更会作什摩？”“如何是我自修行？”师云：“向上无事。”僧云：“只这个，别更有也无？”师云：“只这个阿谁奈何？”问：“大保任底人失一念如何？”师云：“始得保任。”僧曰：“作大魔王时如何？”师云：“不见有佛。”云：“末后事如何？”师云：“佛亦不作。”问：“作大利益底人还得相似不？”师云：“不得相似。”僧云：“为什摩不得相似？”师云：“不见这‘作大利益’？”僧云：“此人还知有尊贵也无？”师云：“不知有尊贵。”僧云：“为什摩不知有尊贵？”师云：“是伊未识曹山。”僧云：“如何是曹山？”师云：“不作大利益。”问：“承甘泉有言‘牵耕人之牛，夺饥人之食。’如何是牵耕人之牛？”师云：“不与露地。”“如何是夺饥人之食？”师云：“去却醍醐。”问：“承古人有言：‘看时浅浅用时探。’浅则不问，如何是深？”师便叉手闭目。学人拟问，师云：“剑去远兮，何必克舟［刻舟］？”问：“如何是玄？”师云：“何不早问？”云：“如何是玄中又玄？”师云：“故有一人在。”问：“承师举新丰有言：‘一色处有分不分之理’，如何是分？”师云：“不同于一色。”僧曰：“与摩则不从今日去也。”师曰：“是也。”“如何是不分？”师云：“无弁处。”僧曰：“只如无弁处，这里岂不是父子通为一身？”师云：“是汝还会摩？”僧云：“正当一色时无向上。”师曰：“向上本来无一色。”云：“只如一色，还是宗门中意旨不？”师云：“不是。”僧云：“既不是，为什摩人说？”云：“我只为宗门中无人承当，所以为这个人说。”僧云：“与摩则有顿有弱去也。师云：“我若说顿说弱，则落那边去也。”僧云：“宗门中事如何承当？”师云：“须是其中人。”“如何是其中人？”师云：“我自住此山来，未曾遇见其中人。”僧云：“今时无其中人，和尚遇古人时如何承当？”师云：“不展手。”僧云：“古人意旨如何？”师云：“阇梨但莫展手也。”僧云：“与摩时和尚还分付也无？”师云：“古人骂汝。”问：“如何是无刃之剑？”师云：“非烹炼之所成也。”僧云：“用者如何？”师云：“来者皆尽。”借云：“不来者如何？”师云：“亦须尽也。”僧云：“不来者为什摩却须尽也？”师云：“不见道‘能尽一切’？”僧云：“尽后如何？”师云：“方知有此剑。”僧问“如何是沙门相？”云：“尽眼看不见。”“还被搭也无？”云：“若被搭则不是沙门相。”“如何是沙门行李处？”云：“头上戴角，身著毛衣。”“此人得什摩人力，则得如此？”云：“终日得他力，只是行不住。”“此人以何为贵？”云：“头上不戴角，身上不被毛。”

师自天复元年辛酉岁夏中，忽有一言：“云岩师翁年六十二，洞山先师亦六十二，曹山今年亦是六十二也。好趁惯作一解子。”至闰六月十五日夜，问主事曰：“今日是何日月？”对云：“闰六月十五日。”师云：“曹山一生行脚，到处只管九十日为一夏。至来日辰时，师当化矣。”春秋六十二，僧夏三十七，敕谥元证大师矣。

祖堂卷八·华严

华严和尚嗣洞山，在洛京，师讳休静。大化东都，禅林独秀，住花严寺。时有人问：“日未出时如何？”师云：“国乱思明主，道泰则寻常。”师在京中赴内斋，他诸名公悉皆转经，唯有师与弟子不转经。帝问师：“师也且从不转经，弟子为什摩不转经？”师云：“道泰不传天子令，时人尽唱泰平歌。”问：“王子未登九五时如何？”师云：“贪游六宅戏，不觉国内亏。”“王子正登九五时如何？”师云：“硃帘斋卷上，四相整朝仪。”“登九五后如何？”云：“金箱排玉玺，御辇四方归。”问：“大悟底人为什摩却迷？”师云：“破镜不重照，落花难上枝。”问：“师幸是后生，为什摩却作善知识？”师云：“三岁宅家龙凤子，百年阶下老朝臣。”问：“祖意与教意同别？”师云：“不入龙宫藏，众义岂能诠？”

师初见洞山时问：“见则见，争奈情识云伪何？”洞山云：“汝还见也无？”对云：“见。”洞山云：“既见为什摩情识云伪？”对云：“争奈情识云伪何？”洞山云：“若与摩则万里无寸草处立。”

溪林和尚把木剑云：“魔来挠我，魔来挠我。”有人问：“和尚寻常，为什摩却被魔挠？”云：“贼不打贫兒家。”有人举似师，师云：“我不与摩道。”僧问：“和尚如何？”云：“无魔来挠我。”云：“和尚为什摩无魔来挠？”云：“贼不打贫兒家。”禾山拈问僧：“作摩生道，通得两个和尚意，亦须自作主。”无对。自代云：“不因有，亦非无。”

后游河北，返锡平阳。迁化后，荼毗舍利四处起塔，敕谥宝智大师无为之塔。

祖堂卷八·本仁

本仁和尚嗣洞山，在高安县。师初住浙西，已张法席。后避众游方，到处虽匿玄谈，而参徒行住奔凑。王复之间，因住高安县白水禅院，数年徒众或至二百三百矣。镜清行脚时到，师问：“时寒道者？”对曰：“不敢。”师云：“还有卧单盖得也无？”对云：“设有，亦无展底功夫。”师云：“直饶道者滴水滴冻，亦不干他事。’”对曰：“滴水冰生，事不相涉。”师云：“是。”云：“此人意作摩生？”云：“此人不落意。”云：“不落意此人渐耳？”师云：“高山顶上，无可与道者啖啄。”

洪州西山诸行者来问：“今日不为别事，乞师指示。”师曰：“汝诸人求指示耶？”对曰：“是也。”师云：“教我分咐阿谁得？”

师临迁化时，先遍处辞人，人皆泣恋谓言“他去。”来晨令修斋，食毕声钟，集众焚香，缁素拥绕。师跏趺坐，香烟尽，师端然迁化矣。

祖堂卷八·青林

青林和尚嗣洞山，在江西。师讳师虔。初住青林，后住洞山。平生住持高节，宇内声扬。师在先师法席时，栽松树后造一首颂：

短短一尺余，纤纤覆绿草。

不知何世人，得见此松老。

先师见此偈后云：“此人三十年后，来住此山，香饭供养师僧。”果然是三十年后住洞山，每日细饭食供养师僧也。

问：“卷尽森萝不逢师时如何？”师云：“孤峰独秀。”僧云：“彼彼事如何？”师云：“两人掴大沩。”师举先师上堂示众云：“‘今时人不得相似，只为拟将心学。若欲得似他去，死人一息不来，阿那个人直似这个？’当时轨誓上座出来问：‘正当一色时还有向上事也无？’先师云：‘无。’其僧珍重便归僧堂。白槌云：‘五百来人在这里，莫是不为向上事？’当头和尚道：‘无。不可成持，合杀处折合了休去。若是某甲，不得在这里虚过一生，因此大众总装里。’主事向和尚说：‘僧众不肯和尚佛法，总发去。’和尚云：‘从伊。我事方得行。’先师教主事锁却僧堂门，处分后来烧茶阁里向某说：‘这个一队子，去也然转来。’果然是转，总啼哭。先师不开僧堂门，大众向主事说：‘某等实是凡夫，谬会和尚意旨，错不肯，一切在和尚。某等欲就和尚面前收过。’主事便去房丈，和尚闭却门面壁，不开房丈门。主事逼请，和尚方始得开门。主事具陈前事，和问许入僧堂。后大众一齐高声啼哭上来，请师上堂。先师升座，僧轨[巧*言]出来，礼拜起云：‘乞和尚杖啧。某甲等广大劫来出佛身血，破和合僧直至今日，谬会和尚意旨。若不改这个身心，难得再复。于今日伏乞和尚慈悲！’先师又悲声云：‘自少来不曾把手指柱［注］别人，岂况造次杖啧？夫一色有分不分之理，所以阇梨问某甲正当一色时还有向上事也无，某甲道无。有什摩罪过？’”

问：“省语易会，乞师一言。”师云：“释迦掩室，净名杜口。”

师迁化时遗嘱焚而扬于风，师不许安立坟塔。端然化矣。

祖堂卷八·疏山

疏山和尚嗣洞山，在抚州。师讳匡仁。未睹行录，不叙终始。师行脚时，到大安和尚处便问：“夫法身者理绝玄微，不堕是非之境，此是法身极则。如何是法身向上事？”安云：“只这个是。”师云：“和尚与摩道，还出得法身也无？”安云：“不是，也是。”又到香严问：“不从自己，不重他圣时如何？”答：“万机休摆，千圣不稳。”师不肯，便下来吐出云：“肚里吃不净洁物。”有人报和尚处，和尚便唤来，师便上来。香严云：“进问著！”师便问：“万机休罢则且置，千圣不携是何言？”香严云：“是也。你作摩生道？”师云：“肯重不得全。”香严云：“你不无道理也。虽然如此，向后若是住山，则无柴得烧；若是住江边，则无水得吃。欲临说法时，须得口里吐出不净。”后住疏山，如香严谶。

夹山到，问：“阃阈不点，请师不傍。”夹山云：“不似之句，目前无法。”师云：“不似之句则且置，目前无法是何言？”夹山云：“更添三尺，天下人勿奈何。”师云：“只今还奈何也无？”问：“如何是直指？”师曰：“珠中有水君不信，拟向天边问太阳。”师偈曰：

我有一宝琴，寄在旷野中。

不是不解弹，未有知音者。

问：“和尚百年后什摩人续绍和尚位？”云：“四脚朝天，背底茫丛。”有人问第三百丈：“作摩生是背底茫丛？”百丈云：“不续无贵位。”

镜清到，师举问：“肯重不得全话，道者作摩生会？”镜清云：“全归肯重。”师云：“不得全者作摩生？”清云：“个中无肯路。”师云：“始称病僧意。”鼓山到便问：“久响疏山，元来是若子大。”师云：“肉重千斤，智无铢两。”鼓山云：“与摩则学人不礼拜去也。”师云：“谁要你肉山倒地？’因鼓山说著威音王佛次，师问鼓山：“作摩生是威音王佛师？”鼓山云：“莫无惭愧好！”师云：“是阇梨与摩道则得，若约病僧则不然。”鼓山问：“作摩生是威音王佛师？”师云：“不坐无贵位。”问：“去时尽转去，何用却来三？”师云：“大唐难有木，却来第三柱。”问：“远见则圆，近见则方。此唤作什摩字？”师云：“东海有鲸鱼，斩头亦断脚，背上抽一骨，便是这个字。”问：“佛在世时度众生，佛灭后什摩人度众生？”疏山答曰：“疏山。”僧进曰：“还有度不尽者也无？”师曰：“无有不尽度者。”师因骑马行次，措大问：“既是骑马，为什摩不踏镫？”师云：“比来骑马歇足，踏镫何异步行？”师临迁化时偈曰：

我路碧空外，白云无处闲。

世有无根树，黄叶送风还。

祖堂卷八·龙牙

龙牙和尚嗣洞山，在潭州妙济。师讳居遁，俗姓郭，抚州南城人也。年十四于吉州蒲田寺出家，依年具戒于嵩岳。初参翠微、香严、德山、白马，虽请益已劳，而机缘末契。后闻洞山言玄格外，语峻时机，遂乃策节而造其席。师问曰：“有人持莫耶之剑拟取师头时如何？”洞山云：“取即且从，阇梨且唤什摩作老僧头？”师持此问，在处不契其机，忽闻洞山斯言，当时失对。遂有抠衣之意，不慕他游。既罢禅征，宁有请益。洞山问：“阇梨名什摩？”对云：“玄机。”“作摩生是玄底机？”又无对。洞山放三日，无对。师因此造偈：

学道蒙师指却闲，无中有路隐人间。

时人尽讲千经论，一句临时下口难。

洞山改未后语云：“一句教伊下口难。”从此改名也。

师问洞山：“如何是祖师意？”洞山云：“待洞水逆流则与汝说。”师于言下顿承玄旨，隐众栖息。七八年问，日斫精妙。

楚王殿下请赴妙济禅林，玄徒五百除人爰奏章服师号证空大师。师示众曰：“夫参学者，须透过祖佛始得，所以新丰和尚道：‘佛教、祖教如生怨家，始有学分。’汝若透过祖佛不得，则被祖佛谩。”有人问：“祖佛还有谩人之心也无？”云：“汝道江湖还有碍人之心也无？”师又云：“江湖虽无碍人之心，为时人透过不得，所以成碍人去，不得道江湖不碍人。祖佛虽无谩人之心，为时人透过祖佛不得，所以成谩人去，不得道祖佛不谩人。若与摩透得祖佛，此人却体得祖佛意，方与向上人同；如未透得，但学佛祖，则万劫无有得期。”问：“达摩未来时如何？”师答曰：“可怜生。”进曰：“任摩去时如何？”师曰：“二祖得什摩？”云居问洞山：“如何是祖师意旨？”洞山答曰：“忽有人问阇梨，阇梨作摩生道？”云居曰：“某甲罪过。”有僧持此语问师：“洞山还道得也无？”师曰：“洞山未道，云居也未得。”进曰：“既是未得，因什摩唤作云居？”云：“体得洞山意旨。”云：“洞山道什摩？”师云：“云居闻底。”又师云：“此是肉身成佛语。”问：“一心不生时如何？”师答曰：“什摩时不生心？”进曰：“与摩时鸟道何分？”师云：“正伊摩时行鸟道。”曰“如何弁？”师曰：“却须行鸟道。”问：“如何是道中用？”师答曰：“无心是道中用。”进曰：“无心还有用也无？”师云：“无心用即遍天下。”

师问德山：“远闻德山一句佛法。及至到来，未曾见和尚说一句佛法。”德山云：“嫌什摩？”师不肯，当时便发去。后到洞山，只问前话。洞山云：“争怪得专甲？”师当时便住。

问：“如何是祖师西来意？”师云：“待石乌龟解语即向汝道。”僧曰：“石鸟龟解语也。”师曰：“向道者道什摩？”又颂：

万般施设不如常，又不惊人又久长。

如常恰似秋风至，无意凉人人自凉。

问：“师见古人得个什摩？”师云：“如贼入空室。”又颂曰：

进道先须立自身，直交行处不生尘。

真僧不假俱严室，到处无心即在人。

参寻言道莫因修，学处须教皁白分。

千圣从来无异路，忘缘机智有多闻。

未了之时亲遍礼，不应端坐守清贫。

直似罗侯行密行，岂如迦叶不闻闻。

人若无心称道情，识得无明道已明。

人能弘道道能现，道在人中人自宁。

师出世近四十年，凡歌行偈颂，并广行于世，此不尽彰。至龙德三年癸未岁九月十三日归寂矣。

祖堂卷八·幽栖

幽栖和尚嗣洞山，在台州。未睹实绿，不决化缘终始。镜清问师：“如何是少父？”师云：“无标的。”进曰：“以何为少父？”云：“有什摩罪过？”进曰：“只如少父又作摩生？”云：“是什摩心行道者？”

师临顺世时。有僧问：“师百年后向什摩处去？”师云：“调然，调然。”

祖堂卷八·上蓝

上蓝和尚嗣夹山，在洪州。师讳令超。初住上蓝山，锺陵大王统霸预［预］章，迎师出府，构护国院，礼重为师。凡百亿所须，始终不替，奏紫衣师号妙觉大师。问：“二龙争珠，谁是得者？”师云：“明珠不向波中玩，龙与非龙争得珠？”

大顺元年正月十五日，声钟集众，遗诲讫，端然化矣。敕谥元真大师本空之塔。


祖堂集卷九

祖堂卷九·落浦

落浦和尚嗣夹山，在澧州。师讳元安，凤翔麟游人也，姓谈。自少歧阳怀恩寺从兄佑律师受业。至于论经，无不该通。先礼翠微，次谒临济，各有所进。后闻夹山直造澧阳。才展座具，时夹山问：“这里无残饭，不用展炊巾。”对曰：“非但无，有亦无著处。”夹山曰：“只今渐耳？”对曰：“非今。” 文山云：“什摩处得这个来？”对曰：“无这个。”夹山云：“这个犹被老僧坐却底。”云：“学人亦不见有和尚。”夹山云：“与摩则室内无老僧。”对曰：“画影亦不得。”夹山赞曰：“道者知音指其掌，锺期能听伯牙琴。”师问：“久响宗风，请师一言。”夹山云：“目前无法。”师云：“莫错？”夹山云：“缦缦阇梨，山溪各异。任你截断天下人舌头，争奈无舌人解语何？阇梨只知有杀人之刀，且无活人之剑。老僧这里亦有杀人之刀，亦有活人之剑。”师进问： “如何是和尚活人之剑？”夹山曰：“青山不挂剑，挂剑勿人知。”师又问： “佛魔不到处，犹未是学人本分事。如何是学人本分事？”文山云：“烛明千里像，暗室老僧迷。”师又问：“朝阳已升，夜月未现时如何？”夹山曰： “龙含海珠，游鱼不顾。”师闻此语，莫知所从，便止夹山。抠衣数载，不惮劳苦，日究精微。至夹山化缘毕，初开落浦，后住苏溪矣。

师有时上堂云：“夫学道先须弁得自己宗旨，方可临机免失。只如锋芒未兆已前，都无是个非个。瞥尔暂起见闻，便有张三李四，胡来汉去，四姓杂居，各亲其亲，相参是非互起，致使玄关固闭，识锁难开，疑网笼牢，智刀方剪。若不当扬晓示，迷子何以知归？欲得大用现前，但可顿亡诸见。见量苦尽，昏雾不生，智照洞然，更无物与非物。今时学人触目有滞，盖为依他数量作解，被他数量该括得定，分寸不能移易。所以见不逾色，听不越声。鼻香舌味身触意法亦然。假饶并当得门头净洁，自己未得通明，还同不了。若也单明自己，未明目前，此人只具一双眼，所以是非忻厌贯系，不得脱折自由。谓之深可伤愍矣。”

问：“如何救离生死？”师云：“执水救延生，不闻天乐妙。”问：“四大从何而有？”师曰：“湛水无波，沤因风击。”进曰：“沤则不问，如何是水？” 师云：“不浑不澄，鱼龙任跃。”问：“如何是一藏收不得者？”云：“雨滋三草秀，片玉本来晖。”问：“一毫吞尽巨海，于中更复何言？”云：“家有白择［白泽］之图，必无如是妖怪。”后保福云：“家无白择之图，亦无如是妖怪。”问：“凝然时如何？”师曰：“时雷应时节，震岳惊蛰户。”僧云：“千般运动，不异个凝然时如何？”师云：“灵鹤翥空外，钝鸟不离巢。”云：“如何？”师曰：“白首拜少颜，举世人难信。”师有神剑歌：

异哉神剑实标奇，自古求人得者稀。

在匣谓言无照耀，用来方觉转光辉。

破犹预，除狐疑，壮心胆兮定神姿。

六贼既因斯剪拂，八方尘劳尽乃挥。

斩邪徒，务妒孽，生死荣枯齐了决。

三尺灵蛇覆碧潭，一片晴光莹寒月。

愚人志剑克舟求，奔驰浊浪徒悠悠。

抛弃澄源逐浑沠，岂知神剑不随流。

他人剑兮带血腥。我之剑兮含灵鸣。

他人有剑伤物命，我之有剑救生灵。

君子得时离彼此，小人得处自轻生。

他家不用我家剑，世上高低早晚平。

须知神剑功难纪，慑魔威兮定生死。

未得之者易成难，得剑之人难却易。

展则周遍法界中，收乃还归一尘里。

若将此剑镇乾坤，四塞终无阵云起。

福先拈问：“一语中须道得在匣出匣底创，你作摩生道？”僧无对。自代云：“且出匣，与老兄商量，还会摩？”问：“诸圣与摩来，将何供养？” 师云：“土宿虽持锡，不是波罗门。”问：“西天一人传一人，彼此不垂委曲。谁是知音者？”师曰：“野老门前不话朝堂之事。”进曰：“不话朝堂之事，合谈何事？”师曰：“未逢别者，终不开拳。”进曰：“有一人不从朝堂门下来，合谈何事？”师曰：“量外之机，徒劳击目。”问：“如何是无惭无愧底人？”师曰：“不出家，不持戒。”进曰：“不出家、不持戒来多少时也？” 师曰：“劈破虚空看弁取。”进曰：“即今如何？”师曰：“不向你杜排行。” 进曰：“与摩即该括不得也。”师曰：“未藉艹/积你与摩道在。”问：“如何是大人相？”师曰：“坐端十方不点头。”问：“廓落世界，为什摩不弁目前法？” 师曰：“曙色未分人思觉，及乎天晓不当明。”云：“还留及也无？”师曰：“莫言及不及，但与我道。”云：“辩师宗不得。”师曰：“不辩即亲。”问：“凡圣不到处即不问，不尽凡圣处如何？”师曰：“师宗窟中无异兽，象王行处勿狐踪。”问：“瞥然便见时如何？”师曰：“晓星分曙色，争似太阳辉？”“如何是本来者？”师云：“一粒在荒田，不耘苗自秀。”僧云：“若一向不耘，莫草埋却去也无？”师云：“肥骨异艹/刍荛，颂稗终难映。”问：“如何是西来意？”师云：“丛丛当轩竹，经霜不自寒。”学人更拟申问，师云：“只闻风击响，不知几千竿。”问：“行到不思议处时如何？”师云：“青山常远步，白月不移轮。”问：“大众云集，师意如何？”师云：“开拳明旧宝，握手谢今时。”问：“如何是沙门行？”师云：“逢佛蓦头坐。”僧曰：“忽遇和尚时如何？”师曰：“阇梨来时，老僧不在。”问：“日未出时如何？”师云：“直木无乱枝，灵羊难挂角。”问：“如何是云水意？”师云：“一轮孤月，万像齐耀。”僧曰：“移轮事如何？”师云：“潭中无影，户外非珍。”问：“祖意与教意还同别？”师云：“出群不戴角，三韵况难同。”进曰：“投机凭意句，焉得不同轮？”师云：“迥技测海底，三湘深可酌。”问：“主人有言：‘动是法王苗，寂是法王根。’苗则不问，如何是法王根？”师竖起拂子。僧曰：“此犹是苗，如何是法王根？”师曰：“龙不出洞，谁人奈何？”问：“量郭无涯，为什摩不容自己？”师云：“末后一句始到牢关，锁断要津，不通凡圣。任你天下忻忻，老僧独然不顾。”却云：“庄周胡蝶，二俱是梦。汝道梦从何来？” 问：“孤灯不自照，室内事如何？”师云：“飞针走线时人会，两边透过却还希。”问：“满满龙宫该不得，一尘尘外事如何？”师云：“三跳出萝笼，不如云外者。”僧曰：“学人不重朝庭贵，不可条然只摩休。”师云：“去！你不会我语。”进曰：“三跳外事如何？”师云：“射虎不中，徒劳没羽。”问：“万法归一，一归何所？”师云：“击水动波澜，其中难见影。”问：“牛头未见四祖，百鸟衔花供养。见后为什摩不来？”师云：“古河泛起雪花浪，无焰孤灯明暗宵。”师有浮沤歌：

秋天雨滴庭中水，水中漂漂见沤起。

前者已灭后者生，前后相续何穷已。

本因雨滴水成沤，还缘风激沤归水。

不知沤水性无殊，随他转变将为异。

外明莹，内含虚，内外玲珑若宝珠。

正在澄波看似有，及乎动著又如无。

有无动静事难明，无相之中有相形。

只知沤向水中出，岂知水不从沤生。

权将沤体况余身，五蕴虚攒假立人。

解达蕴空沤不实，方能明见本来真。

师临迁化时云：“老僧有事问诸人，若道这个是，头上更安头，若道这个不是，斫头更觅活。”第一座云：“青山不举足，日下不挑灯。”师便喝出： “我这里无人对。众中还有新来达士，出来与老僧掇送！”从上座对云：“于此二途，请师不问。”师云：“更道。”对云：“某甲道不尽。”师云：“我不管你尽不尽，更道！”对云：“某甲无侍者，不能只对。”师便喝出：“诸阿师且归堂！”当日初夜后，师教侍者唤从上座，上座便上来侍立。师问：“从上座年多少？”对云：“二十八。”师云：“太嫩在！甚须保持。生缘什摩处？” 对云：“信州人。”师云：“今日事被阇梨道破，称得老僧意。我这里数年出世，并无一个。今日庠梨掇送老僧。某甲先师初见船子时，船子问先师只对因缘，改为颂曰：

目前无法，意在目前。

他不是目前法，非耳目之所到。

只如四句中阿那个是主句？”从上座迟拟。师云：“速与！速与！下头橛子冷，不欲得辜负，你莫形迹！”从上座云：“实不会。”师便槌胸哭苍天。从上座一走下，不去僧堂，直至如今更无消息。师前云：“慈舟不棹清波上，剑峡徒劳放木鹅。”

师光化二年戊午岁十二月二日迁化，春秋六十五，僧夏四十六矣。

祖堂卷九·盘龙

盘龙和尚嗣夹山，在洪州。师讳可文。初住盘龙山，后居上蓝。有僧问落浦：“一沤未发已前，如何弁其水脉？”浦云：“移舟谙水势，举棹别波澜。” 因此问师：“一沤未发已前，如何弁其水脉？”师云：“移舟不弁水，泭棹则迷源。”

祖堂卷九·逍遥

逍遥嗣夹山，在高安。未睹行录，不决始终。问：“烘炉猛焰，烹锻何物？”师曰：“烹佛烹祖。”云：“佛祖作摩生烹？”师曰：“业在其中。”进曰：“唤作什摩业？”师曰：“佛力不如。”问：“一切众生皆有佛性，为什摩有佛有众生？”师曰：“肯即同众异，不肯即异众同。”问：“古人有言：‘知有底人直须不知有’，不知有底人如何？”师曰：“识性共同，俱无兼戴。” 进曰：“不知有底人如何得知有？”师曰：“语取乃不人。”问：“如何是祖中祖？”师曰：“息不肯破，为有明人决。”师垂语曰：“大家去那里向火？” 又云：“火即从你向，不得烧著身。”对曰：“法身具四大，谁是向火者？” 更垂语曰：“古时传祖法，如今不传祖法。”

祖堂卷九·先洞安

先洞安和尚嗣夹山。未睹行录，不决化缘终始。有僧问：“如何是和尚家风？”师云：“金鸡抱子皈霄汉，玉兔怀胎入紫微。”僧曰：“忽遇客来时将何只对？”师云：“金果早朝猿摘去，玉花晚后凤衔来。”

祖堂卷九·黄山

黄山和尚嗣夹山，在抚州。师讳月轮，闽中人也。师初参夹山，夹山而问：“汝是什摩处人？”对曰：“闽中人。”夹山云：“还识老僧不？”对曰： “还识学人不？”夹山云：“不然，子且还老僧草鞋价，然后老僧还子江陵米价。”师云：“与摩则却不识和尚，未委江陵米作摩价。”夹山赞曰：“子善能哮吼。”

师初开堂示众曰：“祖师西来，特唱此事。自是诸人不荐向外驰求，投赤水以寻珠，就荆山而觅玉，所以道从门入者非宝。认影为头，岂非大错？” 问：“如何是祖师西来意？”师云：“梁殿不施功，魏邦没心迹。”问：“如何得见本来面？”师云：“不劳悬古镜，天晓鸡自鸣。”问：“宗乘一句，请师商量！”师云：“黄峰独脱物外秀，年来月往冷秋秋。”问：“如何是纳衣下事？”师云：“石牛水上卧，东西得自由。”

祖堂卷九·韶山

韶山和尚嗣夹山，在北地。师讳寰普，未睹实录，不决始终。有一僧礼拜，起来立地。师云：“大才藏拙户。”其僧又向一边立，云：“丧却练梁哉。” 问：“实际理地，如何运步？”师曰：“幽谷白云藏白雀，拟心栖处隔山迷。” 问：“祖意与教意如何？”师曰：“日晓昏韶山，不借其中事。”进曰：“师还借也无？”师曰：“灯后口无舌。”进曰：“与摩即句后不传也。”师曰：“影隔贷明月，不挂指南纵。”

充天布纳到韶山，韶山勘曰：“闻你有充天之气，是不是？”对曰：“不敢。”师曰：“汝有充天之气，我这里有啄地之锥。汝若把旗上来，我则钉柯相对。汝若横吞巨海，我则背挟须弥。向上一路，速道！速道！”如是三度嗦后云：“明镜当台，请师一照。”师便喝云：“死水无鱼，徒劳下钩。”

祖堂卷九·栖贤

栖贤和尚嗣石霜，师讲怀佑，仙游人。受业于九座山。依年具戒，便历遐方，而造普会之门，密契投针之旨。问：“如何是五老峰前句？”云：“万古千秋。”进曰：“与摩莫成嗣绝也无？”师云：“踌躇欲与谁？”

祖堂卷九·大光

大光和尚嗣石霜。师讳居让［诲］，俗姓王，长安人也。自摄衣访道，南来而造石霜普会门下一二年间，乃私于北塔栽植果木，麻衣草履，灰心尘面，志存于道。因一日普会垂问以徵浅深云：“国家每年放五百人及第，朝堂门下还得好也无？”师对云：“有一个人不求进。”会云：“凭何？”师云： “且不为名。”普会又因疾垂语云：”除却今日，别更有时也无？”师对云： “渠亦不道今日是。”霜云：“我也拟道非今日。”普会然之。如此往复凡数则，函盖无异，盘泊二十余载。

时有檀越胡公，尽室归依，请住大光山。有学人问：“混沌未分时如何？” 师云：“特教阿谁叙？”问：“古人有言：‘不出门而知天下事’，如何是不出门而知天下事？”师云：“犹是第二家主。”“如何是天下事？”师云：“情。” “如何是向上事？”师云：“不出户。”“如何是不出户？”师云：“别。”“为什摩却别？”师云：“不齐众。”

又每示徒云：“一代时教只是收拾一代时人。直饶剥得彻底，也只是成得个了，你不可便将当纳衣下事。所以向你道：四十九年明不尽，四十九年标不起。”僧问：“只如达摩是祖师不？”师云：“不是祖。”僧曰：“既不是祖，又来东土作什摩？”师云：“为汝不荐祖。”僧曰：“荐后如何？”师云： “方知不是祖。”问：“保任底人失一念时如何？”师云：“始得常在。”僧曰： “作大魔王时如何？”师云：“暂时间。”僧曰：“末后事如何？”师云：“不在这里。”问：“绝迹玄去时如何？”师云：“鸟道不曾闻。”问：“如何是沙门行？”师云：“过海不打船。”座主问径山：“万法归一，一亦不存时如何？” 径山云：“一亦不留。”座主不肯，便去江西问云居。居云：“则非万法。”亦不肯，便去大光问，师云：“除不尽。”座主肯之。问：“啐啄同时则不问，卵子里鸡鸣时如何？”师云：“还得音信不？”问：“如何是密室？”师云： “四不睹。”“如何是密室中人？”师云：“远无路。”自是玄言闻于遐迩。

师天复三年癸亥岁九月三日怡然告寂，年龄六十七，僧夏三十六矣。

祖堂卷九·肥田伏

肥田伏禅师嗣石霜，师讳慧光。未睹行录，不决终始。师有颂：

修多妙用勿功夫，返本还源是大愚。

古佛不从修证得，直饶玄妙也崎岖。

有人拈问长庆：“如何是‘修多妙用勿功夫？”’庆云。“用与摩作什摩？”“如何是‘返本还源是大愚’？”庆云：“何必？”“如何是‘古佛不从修证得’？”庆云：“从来是你，更修作什摩？”“如何是‘直饶玄妙也崎岖’？”庆云：“只为你妄外。”师又颂曰：

心静愁难入，无忧祸不侵。

道高龙虎伏，德重鬼神钦。

祖堂卷九·涌泉

涌泉和尚嗣石霜，在台州。师讲景忻，仙游县人也。受业于白云山。才具尸罗，便寻祖道而参见石霜，便问：“学人初入丛林，乞师指示个入路。” 霜云：“我道三只箸子抛不落。”师便契玄关，更无他往。

有康、德二僧来到院，在路上遇师看牛次，其僧不识。云：“蹄角甚分明，争奈骑牛者不识何。”其僧进前煎茶次，师下牛背，近前不审，与二上座一处坐。吃茶次，便问：“今日离什摩处？”僧云：“离那边。”师曰：“那边事作摩生？”僧提起茶盏子，师云：“此犹是蹄角甚分明，那边事作摩生？” 其僧无对。师云：“莫道不识。”便去。福先代云：“若不与摩，争识得道者？” 又代云：“且座吃茶。”招庆问：“从上宗乘中事，和尚此间如何言论？”师云：“不唱目前。”进曰“不唱目前则且置，宗乘中事如何言论？”师云：“待虚空落地则向道者道。”招庆不肯，进曰：“和尚如何？”庆曰：“专甲则不当，请兄弟检点！”报慈代曰：“寒天雪满阶。”问：“如何是冰中水？”师云： “凌霜结不成。”“如何是水中冰？”师云：“六月不曾融。”僧曰：“与摩则千日销不得也。”师云：“二鼠往来不关他。”

祖堂卷九·南际

南际和尚嗣石霜，在江西，师讳僧一。初住南际山，次锺陵大王请居末山。后闽王请住西院，奏紫衣谥号本净大师无尘之塔。处世时僧问：“千圣位中还有不陪位者也无？”师云：“有。”进曰：“如何是不陪位者？”师云： “明明是龙不带鳞，明明是牛不戴角，还会摩？”对云：“不会。”师云：“步行入水不知深，海底龙宫空摸索。”问：“学人幸获侍觐，乞师指示。”师云： “我若指旨［示］，则厄屈著你。”僧曰：“教学人作摩生则是？”师云：“切忌是非。”问：“如何何是纳僧气息？”师云：“还曾熏著你也无？”问：“如何是法身主？”师云：“不过来。”“如何是毗庐师？”云：“不超越。”

祖堂卷九·云盖

云盖和尚嗣石霜，在潭州。师讳源禅，未睹实录，不决化缘终始。

师在石霜时，因一日作礼而问：“万户俱开则不问，万户俱闭时如何？” 霜云：“当中事作摩生？”师曰：“无位。”霜曰：“凭何？”师当时无对，直得半年方始云：“无人接得渠。”霜云：“道也大杀道，只得八九成。”师却请和尚代语，霜云：“无人识得渠。”

祖堂卷九·九峰

九峰和尚嗣石霜，在江西。师讳道虔，俗姓刘，福州侯官县人也。自契石霜密旨，便住九峰，后化缘泐潭宝峰禅院矣。

僧问：“无间中人行什摩行？”师云：“畜生行。”僧曰：“畜生后行什摩行？”师云：“无间行。”僧曰：“此犹是长生路上人。”师云：“你须知有不共命者。”僧云：“不共什摩命？”师云：“长生气不恆。”师云：“诸兄弟还识得命摩？欲知命，流泉是命，湛寂是身。千波竞涌是文殊境界，一亘晴空是普贤床榻。其次借一句子是指月，于中事是话月。从上宗门中事如节度使信旗，且如诸方及先德未建立如许多名目、指陈已前，诸兄弟约什摩体格商量？到这里不假三寸，试话会看；不假耳根，试听声看；不假眼根，试弁白看。所以道声前抛不出，句后不藏形。尽乾坤都来是你当人个体，向什摩处安眼耳鼻舌？莫但向意根下图度，作想作解；尽未来际亦未有休歇分。所以古人道‘拟将心意学玄宗，状似西行却向东。’论劫违背兄弟。”问：“九重无信，恩赦何来？”师云：“流光虽过，阃内不周。”“流光与阃内相去多少？” 师云：“绿水腾波，青山秀色。”问“人人尽言请益，未审师将何拯济？”师云：“汝道巨岳还曾乏寸土也无？”僧云：“与摩则四海参寻当为何事？”师云：“演若迷头心自狂。”僧云：“还有不狂者也无？”师曰：“有。”进曰：“如何是不狂者？”师云：“突晓途中眼不开。”问：“如何是学人自己？”师云： “更是阿谁？”僧曰：“便与摩承当时如何？”师云：“须弥还更戴须弥也无？”问：“祖祖相传，复传何法？”师云：“释迦悭，迦叶富。”僧曰：“毕竟传持事如何？”师云：“同岁老人分夜灯。”问：“古人有言：‘诸佛非我道’，如何是我道？”师云：“我道非诸佛。”僧云：“既非诸佛，为什摩却立我道？”师云：“适来暂唤来，如今却遣出。”僧云：“为什摩却遣出？”师云：“若不遣出，眼里尘生。”问：“一切处觅不得，岂不是圣？”师云：“是圣也。”“牛头未见四祖，岂不是圣？”师云：“是也圣境未亡。”僧曰：“二圣相去多少？”师云：“尘中虽有隐形术，争似全身入帝乡。”问：“承古人有言：‘尽乾坤都来是个眼’，如何是乾坤眼？”师云：“乾坤在里许。”僧曰： “乾坤眼何在？”师云：“正是乾坤眼。”僧曰：“还照烛也无？”师云：“不借三光势。”进曰：“既不借三光势，凭何唤作乾坤眼？”师云：“若不如是，髑髅前见鬼无数。”问：“一笔丹青为什摩邈志公真不得？”师云：“僧瑶却许志公。”僧曰：“未审志公还肯僧瑶也无？”师云：“志公若肯，僧瑶不许。” 僧问：“僧瑶得什摩人证旨，却许志公？”师云：“乌龟稽首须弥柱。”问：“古人有言‘真心妄心’，此意如何？”师云：“是立真显妄。”“如何是真心？” 师云：“不杂食。”“如何是妄心？”师云：“攀缘起倒是。”僧曰：“离此二途，如何是学人本体？”师云：“本体不离。”僧曰：“为什摩不离？”师云：“不敬功德天，谁嫌黑暗女？”问：“对境不动时如何？”师云：“不是大力人。” 进曰：“如何是大力人？”师云：“对境不动。”僧曰：“前来为什摩道‘不是大力人’？”师云：“在舍只言为客易，临筌方觉取鱼难。”问：“古人道‘道超名外’，只如名外之道，谁当建立？”师云：“假名唱道，道不自名。”僧曰：“既不自名，庐行者为什摩却会？”师云：“会处不是庐家境界。”“如何是卢家境界？”师云：“明星背后倒骑牛。”问：“弥勒元是释迦师，释迦有何据验，即玄超九劫？”师云：“宝所无远近，迟速有殊伦。”僧曰：“迟速外还分也无？”师云：“作摩不分？”僧曰：“如何分？”师云：“释迦先不达，弥勒后不至。”僧曰：“任摩则鸡足持衣，更待何人？”师云：“达信只合通补处。”价曰：“通后如何？”师云：“龙华会上无慈氏。”僧曰：“补处又是何人？”师云：“却问取慈氏看。”师上堂，众集。师云：“空中有一人说法，声振梵天，诸人还闻摩？若也不闻，谛听谛听，久立珍重。”众才下。师召大众，众僧乃回顾。师云：“莫错举。”问：“日轮正当午时如何？”云： “似半夜。”僧曰：“与摩时日轮何在？”师云：“正当午。”僧曰：“既当午，为什摩却似半夜？”师云：“半夜亦当午。”僧对曰：“还照烛也无？”师云： “白云散光彩，轮中影不舒。”师乃再颂曰：“当午日轮圆不照，却指三更暂示人，莫将明暗消前事，不是灯边具足身。”问：“圣迷与凡迷如何弁？”师云：“圣迷黑似漆，凡迷明如日。”僧云：“圣迷为什摩黑似漆？”师云：“不见道‘立僧面前’？”僧曰：“凡迷为什摩明如日？”云：“为你结识处多。” 僧云：“不落凡圣如何弁？”师云。“千眼不到。”问：“古人有言‘世智佛智，名同体别。’未审世智与佛智相去多少？”师云：“你道萤光与日光又作摩生？”僧云：“与摩则胜劣有殊去也。”师云：“为你奴郎，所以有殊。”僧云： “既有殊，古人因什摩道‘身心一如，身外无余’？”师云：“事既若全，有何同异？”法照和尚问：“承师有言：‘文殊是用’。”师云：“是。”“又承和尚有言：‘文殊是方头’。”师云：“去是从今日去，不是方头是什摩？”进曰：“未审方头还回也无？”师云：“十人家活，九人作闹，一人不知。”进曰：“既不知，和尚为什摩道‘文殊是方头’？”师云：“千江分月彩，何曾下碧天？’进曰：“与摩时文殊在什摩处？”师云：“含中失却旧时名。”问： “九人与摩来，有何音信？”师云：“九人不得意。”曰：“既不得意，又何传语？”师云：“正是传语。”“未审传什摩人语？”师云：“宁当截舌，不犯国讳。”问：“法雨普润，枯木为什摩无花？”师云：“不见道‘高原陆地’？” 曰：“毕竟还有生花时也无？”师云：“若生花则不名枯木。”曰：“古人为什摩道‘枯木上生一朵花’？”师云：“你道一人不言一人刲，，阿那个无舌？” 问：“被毛戴角底人居何位次？”师云：“白银为地，黄金为墙。”云：“未审此人还有师也无？”师云：“有。”“如何是此人师？”云：“不被毛，不戴角。” 云：“古人因什摩道‘直得不被毛，不戴角，又勿交涉’？”师云：“古人为明异中异，所以重洗面。”间：“中下者即假断送。”师云：“是落在曲劝。” 僧云：“只如上者，还假断送也无？”师云：“家夫不吃嚼饭。”僧曰：“古人为什摩道‘直得上上者，亦须击发’？”云：“灼然撩著便去，谁有你刁刁？” 僧云：“与摩即刁刁犹须断送也。”师云：“是也。”僧曰：“只如上上者如何击发？”师云：“鸡子过时，有人不惊。”问：“大闸提人作何行李？”师云： “露刀擎剑。”僧曰：“拟杀何人？”师云：“凡圣祖佛总须尽却。”僧曰：“尽后此人向什摩处合杀？”师云：“合盘里合杀。”僧云：“合杀后如何？”师云：“鹭鸶不入雪林中。”问：“朝生之子还具年涯也无？”师云：“凤腾霄汉，青云不知。”僧云：“入门后事如何？”师云：“门里忘却白头兒。”僧曰：“与摩则不知有少年父。”师云：“鹭鸶已在雪林中。”进曰：“与摩时还有弁处也无？”师云：“不无鹭鸶。”问：“古人道‘向山下檀越家作一头水牯牛’，与狸奴白牯还分也无？”师云：“作摩不分？”僧曰：“如何分？”师云：“狸奴白牯头无角，山下牯牛再生角。”僧曰：“与摩则主人作一头水牯牛去也。” 师云：“若作一头水牯牛，则屈著古人也。”僧曰：“和尚前来为什摩道再生角？”师云：“再生角则悲不断，头无角则不入流。”问：“从上宗乘请益即是，不请益即是？”师云：“三年大旱，东海不知。”僧曰：“与摩则不从外得。”师云：“内亦不可得。”僧曰：“不内不外时如何？”师云：“不是具足，不是欠少。”僧曰：“毕竟如何？”师云：“穷不尽。”问：“佛法两字如似怨家时如何？”师云：“兔角从汝打，还我兔子来。”僧曰：“兔子岂是有角也？” 师云：“佛法两字从何而立？”“不立者如何？”云：“不可无兔子。”

祖堂卷九·玄泰

南岳玄泰和尚嗣石霜。师所居兰若在山之东，号七宝台。平生高洁，手下不立门徒。其游礼僧或聚或散，故无常准。师来晨迁化，今日并无僧到，自出山口，唤得一人，令备香薪于山所讫，被衣而坐，乃书二偈曰：

今年六十五，四大将离主。

其道自玄玄，个中无佛祖。

又曰：

不用剃头，不用澡浴。

一堆猛火，千足万足。

偈毕，垂一足而逝。荼毗收灵骨坟于坚固大师塔之左。平生所有歌行偈颂遍于寰海道流耳目，此不尽彰耳。

祖堂卷九·宝盖

宝盖和尚嗣石霜。未睹行录，不决化缘终始。僧问。“罢卷停书时如何？” 师云：“书卷不曾展。”僧曰：“再举者如何？”师云：“举人不得意，汝早落第二。”进曰：“不赴朝庭者如何？”师云：“还及第摩？”僧云：“争奈金榜名字何？”师云：“世号不曾通。”僧曰：“与摩则金箱玉印无分付处。”师云： “衔号不曾彰。”僧云：“直得阃阈不沾时如何？”师云：“龙床不曾卧，九五不曾登。”

祖堂卷九·玄泉彦

玄泉和尚嗣岩头。问：“如何是声前一句？”师：“底底。”进曰：“转后如何？”师曰：“什摩是太不塞道？”问：“青山不露顶时如何？”师曰：“玉兔不知春，不是无分晓。”进曰：“直得与摩时如何？”师曰：“恆仙生月宫，不处仙家调。”

祖堂卷九·乌岩

乌岩和尚嗣岩头。师讳师彦，未睹行录，莫穷始终。问：“头上宝盖现，足下有云时如何？”师云：“披枷带锁汉头上宝盖不见。”“足下无云生时如何？”“犹有木丑在。”“毕竟事如何”师云：“斋后困。”问：“天不覆，地不载岂不是？”师云：“若是则被覆盖。”学人云：“若不是乌岩，洎遭师称名。” 师彦问：“如何是诸佛出身处？”师云：“芦花沉海底，劫石过阳春。火焰长流水，佛从此出身。”师垂问：“尽十方世界唯属一人，或有急疾事如何相告？”广利和尚对云：“任汝世界烂坏，那人亦不彩［睬］汝。”报恩对曰： “若道和尚是龙头蛇尾，也只是个瞎汉。”

祖堂卷九·灵岩

灵岩和尚嗣岩头，在吉州。师讲慧宗，姓陈，福州长溪县人。受业于龟山。依年具戒，便慕宗师；一见岩头，密契旨要矣。僧问：“如何是学人自己本分事？”师云：“抛却真金，拾得瓦砾作什摩？”

祖堂卷九·罗山

罗山和尚嗣岩头，在福州。师讳道闲，姓陈，长溪人也。出家于龟山。才具尸罗，便寻祖道，契岩头之密旨。初开堂时，才揽衣升座，乃云“珍重”。时有学者出来拟申问，师便喝出去云：“什摩处去来？”

有僧与疏山和尚造延寿塔毕手，白和尚，和尚便问：“汝将多少钱与匠人？”僧云：“一切在和尚。”疏山云：“汝为复将三钱与匠人？为复将两钱与匠人？为复将一钱与匠人？若道得，与吾亲造塔。”僧无对。

师在大岭住庵时，其僧到，师问：“什摩处来？”对云：“疏山来？”师云：“疏山和尚近日有什摩言句？”其僧俱陈前事。师云：“还有人道得摩？” 对云：“未有人道得。”师云：“汝却回疏山道：‘大岭和尚闻举有语：若将三钱与匠人，和尚此生决定不得塔；若将两钱与匠人，和尚与匠人同出一手造塔；若将一钱与匠人，带累匠人眉须一时堕落。”其僧便回举似疏山，疏山便具威仪，望大岭叹曰：“将谓无人，大岭有古佛，光明射到此间。”却云： “汝去向大岭道：“犹如十二月莲花开也。”其僧却回举似师，师云：“早已龟毛长数丈也。”

师又时上堂云：“宗门深奥，合作摩生话会？真心难定，实理何诠？祖代褒扬，曲垂知见。俊士显于大事，次第施行，为破佛魔，撒归深际，灵光密布，撒教现前，举意明宗，光流大海。闻禅与道，削迹吞声，佛与祖师，明明古路。摩腾竺法，黄叶何殊？大藏教文，图书不得。若论宗乘一路，海口难宣。何不见释迦掩室，净名杜口？暂息波澜，接物应机，须通俊士，应时如风，应机如电。一点不来，犹同死汉，当锋一箭，谁肯承当？不是俊流，徒劳措口。上古流今，无过奇特。若也未逢匠伯，低首侧聆，意下寻思，卒搔不著。记举古话，系惑盲侣；送向空劫，未免轮回。将抵敲作家，驴年终无是处。珍重！”

因郑十三娘年十二，随一师姑参见西院沩和尚，才礼拜起，大沩问：“这个师姑什摩处住？”对云：“南台江边。”沩山便喝出。又问：“背后老婆子什摩处住？”十三娘放身进前三步，叉手而立。沩山再问：“这老婆子什摩处住？”十三娘云：“早个对和尚了也。”沩山云：“去！去！”才下到法堂外，师姑问十三娘：“寻常道‘我会禅’，口如铃相似，今日为什摩大师问著总无语？”十三娘云：“苦哉！苦哉！具这个眼目也道我行脚，脱取纳衣来，与十三娘著不得。”十三娘后举似师，便问：“只如十三娘参见大沩，与摩只对还得平稳也无？”师云：“不得无过。”娘云：“过在什摩处？”师乃叱之。娘云：“今日便是锦上更添花。”

又时上堂云：“理上通明，与佛齐肩；事上通明，咸同诸圣；事理俱通，唤作什摩？天下横行，罗笼自在，须是与摩汉临机隐现，搓搽临时自由，不是你呢呢惹惹底便解会得。若实未会，卒不可奈何三句至于四句罗笼交通。若不会向上事，什摩处得？不见道‘上士不领关’？会摩？若是超伦作者，瞥然便休。如今且有与摩汉摩？出来试弄一转看，作摩生精彩。若也不解纵夺，且须自识取旷劫已来不可思议底，常教现露自由自在。若论师子据地，且作摩生道千般设用未脱野干鸣？透古透今，声前看取。无事珍重。”轸上座问：“只如岩头和尚道：‘洞山好个佛，只是无光彩。’未审洞山有何亏阙便道无光彩？”师唤无轸，无轸应诺。师云：“酌然好个佛，只是无光彩。” 轸云：“大师因什摩拨无轸话？”师云：“什摩处是陈老师拨汝话？快道，快道。”无轸说不得，师便打之。问：“如何是宗门中流布？”师乃展手。问： “急急来投，请师一接。”师云：“会摩？”对云：“不会。”师云：“箭过也。” 又大德参师，师问：“大德号个什摩？”对云：“明教。”师云：“还会教也无？”对云：“随分。”师竖起拳云：“灵山会上与摩唤作什摩教？”对云：“唤作拳教。”师笑云：“与摩是拳教。”师却展足云：“与摩时唤作什摩？”大德无对。师却云：“莫是脚教摩？”

师临迁化时上堂升座，良久展开左手。主事云：“东面黑。”师僧退后，师又良久展开右手，主事又云：“西面黑。”师僧退后，师却云：“欲报师恩，无过守志；欲报王恩，无过流通大教。归去也！归去也！呵呵珍重！”


祖堂集卷十

祖堂卷十·玄沙

玄沙和尚嗣雪峰，在福州。师讳师备，俗姓谢，福州闻县人也。咸通初上芙蓉山出家，于锺陵开元寺道玄律师受戒，却归山门。凡所施为，必先于人。不惮风霜，岂倦寒暑。衣唯布纳，道在精专。语默有规，不参时伦。雪峰见师器质粹容，亦多相接，乃称师为备头施。如斯数载，陪仰亲依。

有一日普请开田，雪峰见一条蛇，以杖撩起，召众云：“看！看！”以刀芟为两段，师便以杖挑拖背后，更不顾视。众僧愕然，雪峰云：“俊哉！”

雪峰一日议曰：“备头陂未曾经历诸方，何妨看一转乎？”如是得四度。师见和尚切，依和尚处分，装裹一切了，恰去到岭上踢著石头，忽然大悟。后失声云：“达摩不过来，二祖不传持。”又上大树望见江西了，云：“奈是许你婆。”便归雪峰。雪峰见他来，问师：“教你去江西，那得与摩回速乎？”师对云：“到了也。”峰曰：“到那里？”师具陈前事，雪峰深异其器，重垂入室之淡。师即尽领玄机，如瓶泻水。初住普应，次卜玄沙。后闽王迎居安国寺，礼重为师，奏锡紫衣师号宗一大师。三处主持三十来年，匡八百众矣。

问：“如何是学人自己事？”师云：“用自己作什摩？”问：“从上宗门中事，此间如何言论？”师云：“少人听。”师云：“佛言：‘吾有正法眼付嘱摩诃迦叶。’我道犹如话月。曹溪竖起拂子，是指月。”问：“古人瞬视接人，师如何接人？”师云：“我不瞬视接人。”进曰：“师如何接人？”师视之。问：“古人拈槌竖拂，还当宗乘中事也无？”师云：“不当。”进曰：“古人意作摩生？”师竖起拂子。进曰：“宗门中事作摩生？”师云：“待你自悟始得。”师问长生：“维摩观佛，前际不来，后际不去。今则无住，长生老作摩生观？”对云：“放某甲过有个商量。”师曰：“放长老过作摩生？”长老良久。师云：“教阿谁委？”对云：“徒劳侧耳。”师云：“正知你鬼趣里作活计。”师闻鱼鼓声，乃云：“打我也。”

师游南州时与王太傅一房坐，时有一沙弥揭帘欲入，见师与太傅，便放帘抽身退步。师云：“者沙弥好吃二十棒。”太傅云：“与摩则延玭罪过。”师云：“［-无］佛法不是这个道理也。须子细好。”僧问中塔：“沙弥过在于何，打二十棒？”塔云：“更添三十棒，沙弥又无过。”又问兴化，兴化云：“若会二公坐处，此棒不从外来。”又问顺德：“玄沙与摩道，意作摩生？”顺德云：“不为水而打水。”僧曰：“与摩则太慰［尉］亦合先陀去也。”德云：“又成求他不肯。”进曰：“只如不为水而打水意作摩生？”德云：“青山碾为尘，敢保无闲人。”

天请问经曰：“云何利刀剑？云何碜毒药？云何炽盛火？云何极重暗？”尔时佛告彼天曰：“粗言利刀剑，贪欲碜毒药，嗔恚炽盛火，无明极重暗。”有人举问雪峰：“如来只说利刀剑，未曾当剑，请师当剑！”峰云：“咄！不识好恶汉。”有人持此语举似师，师云：“似则似，是则不是。”僧便问：“请和尚当剑！”师云：“咄，不识好恶汉。”有人举似中塔，中塔云：“不可思议古人与摩见知，虽然如此，欠进一间。”僧便问：“请和尚道！”塔云：“尊宿分上还有这个也无？”

志超上座为众乞茶去时，问师：“伏乞和尚提撕！”师云：“只是你不可更教我提撕。”进曰：“乞师直指，志超不是愚痴人。”师云：“是你是愚痴人，作摩生会？”进曰：“时不待人，乞师指示！”师云：“我这里有三棒，打你愚痴，会摩？”志超不会。中塔云：“自愚痴。”地藏云：“和尚愚痴教什摩人打？”遂偈曰：

三棒愚痴不思议，浩浩溶溶自打之。

行来目前明明道，七颠八倒是汝机。

师问灵云：“那里何似这里？”云云：“也只是桑梓，别无他故。”师曰：“何不道也要知？”云曰：“有什摩难道？”师云：“若实便请道！”灵云偈曰：

三十来年寻剑客，叶落几回再抽枝。

自从一见桃花后，直至如今更不疑。

师云：“灵云也什摩生桑梓之能？”云曰：“向道，故非外物。”师云：“不敢，不敢。”又云：“灵云谛当甚谛当，敢保未彻在。”云曰：“正是。和尚还彻也无？”师云：“若与摩即得。”云曰：“亘古亘今。”师云：“甚好。”云曰：“诺！诺！”师作一颂送灵云曰：

三十来年只如常，叶落几迥放毫光。

自此一去云霄外，圆音体性应法王。

师问招庆：“汝作摩生说驴使马使？”庆云：“某甲姓孙。”师云：“是即是，且作摩生是驴马？”庆云：“也只是桑梓。”师云：“知得也未？”庆云：“要且不是和尚。”师问：“作摩说大意？”庆云：“得与摩颠倒。”师云：“正是我颠倒。”庆云。“某甲也颠倒。”师云：“知得。”便有偈曰：

用处妙理不换机，问来答得不思议。

应现常明明知交，人人自在得功希。

又偈曰：

再睹道友话清源，人人问道无不全。

法法恆然皆如是，四生九类体中圆。

问：“如何是正妙心？”答：“尽十方世界都来是个真实之体。”

师开平二年戊辰岁十一月二十七日，身体极热，曰：“我是大悟底人，尽大地一时火发，是你小小之辈走却不难。”休长老便问：“和尚寻常骂十方，因什摩到与摩地？”师云：“达底人尚自如此，岂况是你诸人。”便顺化。春秋七十四，僧夏四十四。闽王崇塔矣。长兴元年庚寅岁，将十二郎林澄制碑文，净修禅师赞曰：

玄沙道孤，禅门楷模。

言一半偈，四海五湖。

巨鰲海面，金翅云衢。

岩崖险峻，佛法有无。

祖堂卷十·长生

长生和尚嗣雪峰，在福州。师讳皎然，福州人也。自造雪峰之门，密契传心之旨。于一日雪峰因读古人语到“光境俱亡复是何”，便问师：“这里合著什摩字？”师对云：“放某甲过，有个道处。”峰云：“放你过作摩生道？”对云：“某甲亦放和尚过。”又因古沙云：“一切森萝镜中像”，便提起杖问师：“这个是像，阿那个是镜？”师对云：“若不如是，争获圆通？”师在雪峰时为后生造偈曰：

素面相呈犹不识，更添暗彩竞斗看。

这里若论玄与实，与吾如隔万重山。

问：“从上宗乘如何言论？”师云：“不可为阇梨荒却长生路也。”问：“古人道：‘无明即佛性，烦恼不须除。’如何是无明即佛性？”师作嗔势，竖起拳，喝云：“今日打这个师僧。”“如何是烦恼不须除？”师以手〓头曰：“今日打这个师僧，得任摩发人业。”师巡堂后到厨下，雪峰曰：“我寻常向师僧曰：‘是什摩？’未有人对。阿你作摩生？”师对曰：“放某甲过，亦有商量。”峰云：“放你过，作摩商量？”对曰：“某甲亦放和尚过。”雪峰曰：“相识满天下，知心能几人。”

师到鹅湖，当门安下。忽然见灯头来挑灯，便造偈曰：

一灵孤灯当门悬，拟欲挑来历劫昏。

山声朴直人难见，此中会得处处全。

内侍问：“古人有言：‘一切众生日用而不知’，作摩生是众生日用而不知？”师乃指揖内侍曰：“吃橄榄子。”内侍又问：“作摩生是众生日用而不知？”师云：“内侍适来岂不是吃橄榄子？”对云：“是也。”师云：“古来众生日用而不知，如今内侍亦日用而不知。”问：“如何是王中主？”云：“昨日送一个去，今日迎一个来。”

祖堂卷十·鹅湖

鹅湖和尚嗣雪峰，在信州。师讳智孚，福州人也。未睹实录，不决化缘始终。僧问：“五逆之子还受父的［约］也无？”云：“虽有自裁，未免伤已。”问：“国无定乱之剑，为什摩四海宴清？”云：“君王无道。”“君王道合事如何？”云：“不令亦不行。”问：“如何是佛向上人？”云：“正知阇梨勿奈何。”进曰：“为什摩勿奈何？”云：“未必小兒得见君王。”问：“利娄相击不侧耳者如何？”云：“哲。”问：“虚空讲经，以何为宗？”云：“阇梨不是听众，去！”

祖堂卷十·大普

大普和尚嗣雪峰。师讳玄通，福州福唐县人也。出家于兜率山，依年具戒，便慕参游。见雪峰，数年盘泊，更不他往，承言领旨，而居大普矣。

有僧问：“巨海骊珠如何取得？”师乃抚堂瞬视。问：“拨尘见佛时如何？”师曰：“脱却枷来商量。”

祖堂卷十·镜清

镜清和尚嗣雪峰，在越州。师讳道宦，温州人也。师初入闽，参见灵云，便问：“行脚大事如何指南？”云云：“浙中米作摩价？”师曰：“洎作米价会。”却续到象骨，象骨问：“汝是什摩处人？”对云：“终不道温州生长。”峰云：“与摩则一宿觉是汝乡人也。”云：“只如一宿觉是什摩处人？”峰云：“者个子好吃一顿棒，且放过。”师又问：“从上祖德例说入路，还是也无？”峰云：“是。”“学人初心后学，乞师指示个入路。”峰云：“但从者里入。”师云：“学人朦昧，再乞指示。”峰云：“我今日不多安。”放身便倒。又问：“只如从上祖德岂不是以心传心？”峰云：“是。兼不立文字语句。”师曰：“只如不立文字语句，师如何传？”峰良久。遂礼谢起，峰云：“更问我一传，可不好？”对云：“就和尚请一传问头。”峰云：“只与摩，别更有商量也无？”对云：“在和尚与摩道则得。”峰云：“于汝作摩生？”对曰：“辜负杀人。”峰曰：“不辜负底事作摩生？”师便珍重。

又一日雪峰告众云：“当当［堂堂］密密底。”师便出，对云：“什摩当当密密底？”雪峰从卧床腾身起，云：“道什摩？”师便抽身退立。

又一日普请，雪峰沩山语“见色便见心，还有过也无？”师对云：“古人为什摩事？”峰云：“虽然如此，我要共汝商量。”对云：“与摩商量，不如某甲酴地。”

又一日行次，雪峰便问：“尽乾坤事不出一刹那，只如一刹那底事，今时向什摩处弁明则得？”师对云：“更共什摩人商量去？”雪峰云：“我亦有对，汝但问我！”师便问：“今时向什摩处弁明则得？”峰乃展手云：“但向这里弁明。”师对云：“此是和尚为物情切。”峰便笑。峰又时云：“争得与摩尊贵，得与摩绵密？”师对云：“某甲自到山门，今经数夏，可闻和尚与摩示徒？”峰云：“我向前虽无，如今已有，莫所妨摩？”对云：“不敢。此是和尚不已而已。”峰云：“置我如此。”又云：“量才处职。”于是承言领旨，遍历诸方。凡对机缘悉皆实契。旋回东越，初住镜清，后住天龙龙册。钱王钦仰德高，赐紫衣法号顺德大师。

见新到参次，拈起拂子。对云：“久响镜清，到来犹有文彩在。”师云：“今日遇人却不遇人。”后有人进问：“今日遇人却不遇人意作摩生？”师云：“一盘御饭反为庶食。”问：“无源不住，有路不归时如何？”师云：“这个师僧得座便坐。”问：“如何是心？”师云：“是则第二头。”云：“不是如何？”师云：“又成不是头。”僧曰：“是不是，总与摩时作摩生？”师云：“更多饶过。”问：“如何是玄中玄？”师云：“不是，是什摩？”僧曰：”还得当也无？”师云：“木头也语。”因此颂曰：

一向随他走，又成我不是。

设尔不与摩，伤著他牵匮。

欲得省要会，二途俱莫缀。

问：“古人有言：‘人无心合道’，如何是人无心合道？”师云：“何不问‘道无心合人’？”“如何是道无心合人？”师云：“白云乍可来青嶂，明月那堪下碧天！”

新到参次，师问：“阇梨从什摩处来？”对云：“佛国来。”师云：“只如佛以何为国？”对云：“清净庄严为国。”师云：“国何以为佛？”对云：“以妙静真常为佛。”师云：“阇梨从妙静来，从庄严来？”僧无不对答。师云：“嘘！嘘！到别处有人问汝，不可作这个语话。”

师有时上堂，众集。良久云：“来朝更献楚王看，珍重。”问：“明能相见，其理如何？”师云：“可惜与汝道知。”僧曰：“只如可惜道却意旨如何？”师云：“悭珍不免施。”“如何是悭珍？”师云：“可惜道。”僧曰：“不免施又如何？”师云：“对汝道却。”问：“宝在衣中为什摩伶俜辛苦？”师云：“过在阿谁？”僧曰：“只好认得又作摩生？”师云：“更是伶俜。”僧曰：“认得为什摩却伶俜？”师云：“不愧已有。”问：“如何是皮？”师云：“分明个底。”“如何是骨？”师云：“绵密个。”“如何是髓？”师云：“更密于密。”问：“如何是粪扫一纳衣？”师云：“迦叶被来久。”进曰：“纳衣事如何？”师云：“亲付阿难传。”问：“如何是天龙一句？”师云：“伏汝大胆。”进曰：“与摩则学人退一步。”师云：“覆水难收。”问：“如何是文殊剑？”师便作斫势。“只如一剑下得活底人又作摩生？”师云：“出身路险。”“与摩则大可畏。”师云：“不足惊怛。”

师问僧：“外边是什摩声？”学人云：“雨滴声。”师云：“众生迷己逐物。”学人云：“和尚如何？”师云：“洎不迷己。”后有人问：“和尚与摩道意作摩生？”师云：“出身犹可易，脱体道还难。”师又问僧：“离什处？”学云：“离应天。”师云：“还见鳗鲤不？”学人云：“不见。”师云：“阇梨不见鳗鲤，鳗鲤不见阇梨。”云：“总有［不］与摩？”云：“阇梨只解慎初，不解护末。”

师示众云：“好晴好雨。”又云：“不为好晴道好睛，不为好雨道好雨。若随语会，迷却神机。”僧问：“未审师尊意如何？”颂曰：

好晴好雨奇行持，若随语会落今时。

谈玄只要尘中妙，得妙还同不惜伊。

问：“经首第一唤作何字？”师曰：“穿耳胡僧笑点头。”问：“西来密旨如何通信？”师云：“出一人口，入千人耳。”“如何是出一人口？”师云：“释迦不说说。”“如何是入千人耳？”师云：“迦叶不闻闻。”问：“学人拟被纳，师意如何？’师云：“一任高飞。”僧曰：“争奈毛羽未备何？”师云：“唯宜低弄。”僧曰：“如何是低弄？”师云：“逢缘不作，对境无心。”僧曰：“如何是高飞？”师云：“目睹瞿昙，犹如黄叶。”“如何是优昙？”师云：“一劫一现。”“如何是黄叶？”师云：“此未为真。”僧曰：“与摩则更有向上事在。”师云：“灼然。”“如何是向上事？”师云：“待你一口吸尽镜湖水，我则向你道。”问：“惺惺为什摩却被热恼？”师云：“为不是那边人。”僧曰：“如何是那边人？”师云：“过这边来。”僧云：“未审这边如何过？”师云：“惺惺不惺惺。”僧曰：“惺惺不惺惺时如何？”师曰：“鲁班失却手。”问：“如何是声色中面目？”师云：“现人不见。”僧云：“太绵密生。”师云：“体自如此。”僧云：“学人如何趣向？”师云：“活人投机。”问：“闻处为什摩只闻不见？见处为什摩只见不闻？”师云：“各各自缘，不缘他。”师题象骨山颂曰：

密密谁知要，明明许也无。

森罗含本性，山岳尽如如。

问：“十二时中如何行李？”师云：“一步不得移。”僧曰：“学人不会，乞师指示个入路！”师云：“不过于此。”师乃颂云：

当此支荷得，胜于历却功。

多途终不到，一路妙圆通。

师问僧：“你名什摩？”对云：“省超。”师便作偈曰：

省超之时不守住，更须腾身俊前机。

太虚不碍金乌运，霄汉宁妨玉兔飞。

师因在帐里坐，僧问：“乍入业林，乞师指示个径直之路！”云：“子既如此，吾岂吝之？近前来。”学人遂近前，师以手拨开帐，云：“嘎。”学人礼拜，起云：“某甲得个入处。”师遂审之，浑将意解。师乃颂曰：

我适抑不已，汝领不当急。

机坚尚亏投，影没大难及。

因举长庆上堂。众僧立久，有僧出来云：“与摩则大众归堂去也。”长庆便打。后有僧举似中招庆，招庆云：“僧道什摩？”对云：“僧无语。”招庆云：“这个师僧为众竭力，祸出私门。”寻后有僧举似化度，化度却问其僧：“只如长庆行这个杖，还公当也无？”对云：“公当。”化度云：“或有人道不公当又作摩生？”对云：“若是与摩人，放他出头始得。”化度云：“在秦则护秦。”化度却举似师云：“只如长庆有与摩次第，不合行这个柱杖。”师云：“大师代长庆作摩生折合？”化度云：“但起来东行西行。”师云：“与摩则木杓落这个师僧手里去也。”时有人拈问师：“只如长庆这个柱杖意作摩生？”师云：“宗师老拦，兼自出身。”

师又时上堂云：“尽十方世界都来是金刚不坏之体，唯怕牯羊角。”时有人问：“如何是金刚不坏之体？”师云：“世界坏时作摩坏？”“为什摩唯怕牯羊角？”师云：“要汝尽却。”“如何是牯羊角？’师云：“洎道惊杀汝。”僧曰：“体坏时角还存也无？”师云：“不是过夏物。”僧曰：“只如牯羊角尽时，还得相应也无？”师云：“不同汝归意。”僧曰：“不同归意者如何？”师云：“千金不改耕。”僧曰：“只如牯羊角，明得什摩边事？”师云：“上士聊闻便了却，中下意思莫能知。”有人拈问资福：“作摩生是金刚不坏之体？”资福以手点胸。“作摩生是牯牛角？”资福以两手头上作羊角势。有人举似师，师因此示众云：“角锋不密，太露太现。金刚不坏体，唯怕牯羊角，提其角只要出其体，体角俱备，诸人作摩生会？”又谈体颂云：

体含众像像分明，离体含形形转精。

清明妙静谁能弁？释迦掩室竭罗城。

又曰《叹景禅吟》：

叹汝景禅去何速，虽不同道当眼目。

个今永却不曾亏，地水火风还故国。

好也好，也大奇，忙忙宇宙几人知。

莹净宁闲追路绝，青山绿嶂白云驰。

歌好歌，笑好笑，谁肯便作此中调。

难提既与君凑机，其旨无不谐其要。

格志异，气骨高，森萝咸会一灵毫。

虽然亦作皆同电，出岫藏峰徒思劳。

希奇地，剑吹毛，脱罩腾笼任性游。

此界他界如水月，几般应迹妙逍遥。

又《悟玄颂》曰：

有路省人心，学玄者好寻。

旋机现体骨，何用更沉吟。

莫嫌浅不食，犹胜意思深。

鱼若有龙骨，大小尽堪任。

问：“古人有言：‘切忌随他觅，迢迢与我疏’，如何是切忌随他觅？”师云。“犯今也。”“如何是迢迢与我疏？”师云：“不啻十万八千里。”“如何是我今独自往？”师云：“军马□骑。”“如何是处处得逢渠？”师云：“遍身是眼。”“如何是渠今正是我？”师云：“可杀端的。”“如何是我今不是渠？”师云：“识弁奴郎始得。”

祖堂卷十·翠岩

翠岩和尚嗣雪峰，在明州。师讳令参，湖州人也。未睹行录。钱王钦仰，赐紫［＋号］永明大师。问：“不借三寸请师道！”师云：“茶堂里贬剥去。”诸余即不散［敢］问。师良久，进曰：“如何举似于人？”师云：“侍者点灯来。”

师有时上堂曰：“三十年来，无有一日不共兄弟持论语话，看我眉毛还在摩？”众无对。有人举似长庆，长庆代云：“生也。”师示后学偈曰：

入门须有语，不语病栖芦。

应须满口道，莫教带有无。

明照和尚和：

人门通俊士，正眼密呈珠。

当机如电拂，方免病柄芦。

师再和：

入门如电拂，俊士合知无。

回头却问我，终是病栖芦。

师又劝学偈：

苦哉甚苦哉，波里觅乾灰。

劝君收取手，正与摩时徠。

祖堂卷十·报恩

报恩和尚嗣雪峰。师讳怀岳，泉州仙游人也。出家于莆田圣寿院，依年具戒，志慕祖筵而参见雪峰。密契玄关，化于漳浦。问：“宗乘不却，如何举唱？”云：”山不自称，水无间断。”师临迁化时，上堂云：“十二年来举扬宗教，诸人怪我什摩处？若要听三经五论，［＋此去］开元咫尺。”便告寂。

祖堂卷十·化度

化度和尚嗣雪峰，在西兴。师韩师郁，泉州莆田县人也。师号悟真大师。僧问：“如何是随色摩尼珠？”师云：“青黄赤白。”“如何是不随色摩尼？”师云：“非青黄赤白。”问：“如何是一尘？”师云：“九世刹那分。”“如何含法界？”师云：“法界在什摩处？”问：“六国未宁时如何？”师云：“是汝。”“宁后如何？”师云：“是汝。”问：“只如维摩登时，或有人问，和尚如何败遣？”师云：“唯有门前镜湖水，清风不改旧时波。”

祖堂卷十·鼓山

鼓山和尚嗣雪峰，在福州。师讳神晏，示生梁国。世姓李氏，则皇唐诸王之裔也。幼避荤膻，乐闻锺梵。年始十二，俗舍青灰之壁忽显白气数道。父曰：“此子必出家。”至年十五，偶因抱疾，梦神人与药，睡觉顿愈。年十七，梦一胡僧告云：“出家时至。”后累辞亲爱，方果其愿。遂依卫州白鹿山卯斋禅院道规禅师剃落。至中和二年，于嵩山琉璃坛受戒。因一日谓同学云：“古德云：‘才自四羯磨后，全体戒定慧’。何必拘恋准绳，犹同桎梏！”自此不穷律肆，拥毳遍参。先见白马超州，次历径山荷玉，虽谐请问，未契机缘。复遇雪峰，雪峰拦胸把驻云：“是什摩！”师乃豁然而已，寻便举手摇拽。峰云：“又作道理，作什摩？”师云：“作何道理？”峰乃呵曰：“大有人未到此境界，切须保任护持！”寻以雪峰顺寂，闽王于域左二十里开鼓山，请师为众。师云：“经有经师，论有论师，律有律师。有函有号，有部有帙，各有人传持。若是佛之与法，是建立化仪；禅之与道，是止啼之说。他诸圣兴来，盖为人心不等，巧开方便，遂展多门。为病不同，处方固异。在有破有，居空叱空。二患既除，中道须遣。鼓山所以道句不当机，言非展事。承言者丧，滞句则迷，不唱言前，宁谈句后？直圣释迦掩室，净名杜口。大士梁时，童子当日，一问二问三问尽有人了也，诸仁者作摩生？”时有人礼拜。师云。“高声问！”学云：“谘和尚。”师便喝出。师颂曰：

直下犹难会，寻言转更赊。

拟论佛与祖，特地隔天涯。

祖堂卷十·隆寿

隆寿和尚嗣雪峰，在漳州。师讳绍乡，姓郑，泉州莆田县人也。师号兴法大师。有人问：“古人道：‘摩尼宝殿有四角，一角常露，三角亦然。’如何是常露底角？”师便竖起佛子。问：“良禾不立米，如何济得万人矶？”云：“侠客面前如夺剑，看君不是黠兒郎。”

祖堂卷十·安国

安国和嗣雪峰，在福州。师讳弘韬，姓陈，泉州仙游县人也。初诞之时，胎衣紫色。朝感胡僧而来访之，志求出家。遂于龙华寺东禅依师染剃，依年具戒，便诣雪峰，密契玄关。寻离欧越，遍历楚吴。后再入雪峰，雪峰才见，便问：“什摩处来？”师云：“江西来。”峰云：“什摩处逢见达摩？”师云：“分明向和尚道。”峰云：“道什摩？”师云：“什摩处去来。”

又因一日峰见师，便拦胸把云：“尽乾坤是个解脱门。把手拽教伊入，争奈不肯入！”师云：“和尚怪某甲不得。”峰云：“虽然如此，争奈背后如许多师僧何！”自后闽王钦敬，请住安国阐扬宗教矣。

问：“如何是西来意？”师云：“如何是不西来意？”又云：“是即是，莫错会！”问：“学人上来未尽其机，请师尽其机。”师良久，学人礼拜。师云：“忽到别处，有人问汝作摩生举？”学云：“终不敢错举。”师云：“未出门便见笑具。”问：“如何是达摩传底心？”师云：“索非后胤。”众参，师云：“若有白纳衣，一时染却。”于时众中召出一僧，当阳而立。师指云：“这个便是样子也，还有人得相似摩？”众皆无对。别时僧侍立，师云：“你当此时作摩生？”僧云：“某甲向前僧边立。”云：“还得相似摩？”师云：“你不相似。”学人云：“为什摩不相似？”师云：“你带黑有。”

因长庆在招庆时，法堂东角立次，云：“者里好置一个问。”时有人便问：“和尚为什摩不居正位？”庆云：“为你与摩来。”僧云：“只今作摩生？”庆云：“用你眼作什摩？”师因举著云：“他个则与摩，别是个道理，只今作摩生道则得？”后安国云：“与摩则大众一时礼拜去也。”师亦代云：“与摩则大众一时散去得也。”

师在众时，举国师碑文云：

得之于心，伊兰作啃檀之树。

失之于旨，甘露乃蒺藜之园。

师拈问僧：“一语之中须具得失两意，作摩生道？”僧提起拳头云：“不可唤作拳头。”师不肯，自拈起拳头曰：“只为唤作拳头。”问：“如何是活人之剑？”师曰：“不敢瞎却汝。”“如何是杀人之刀？”师云：“只这个是。”因举《西域记》云：“西天有贼，盗佛额珠，欲取其珠，佛额渐高，取不得。遂啧云：‘佛因中有愿，我成佛果菩提，愿济一切贫乏众生。如今何得违于本愿，不与我珠？’佛遂低头与珠。”师拈问众：“向这里须得作主，又不违于本愿，合有济人。作摩生道？”众无对。师代云：“有愿不违。”长庆云：“适来岂是违于因中所愿摩？”

师上堂云：“达摩道：吾本来此土，传教救迷情。诸人且道是什摩教，莫是贝多之教摩？若是贝多之教，自是摩腾竺法兰二三藏，汉明帝永平年中已来了也。既不是此教，且是什摩教？还有人择得摩？若有人择得，便出来看；若无人择，我与你择，这个便是纳僧谙会处。得摩？只与达摩与摩道，遇著本色行脚人还得了摩？汝道达摩僭疣在什摩处，便不了处。我如今不识好恶，颠倒与汝诸和尚插偈、歌咏、告报，尚不能察得；倘若依于正令，汝向什摩处会去？何不抖擞眉毛，著些子精彩耶？尽乾坤界是你诸人家风，诸人一时体取，还有人体得摩？若无人体得，莫只与摩醉慢慢底，有什摩成办时？大须努力！”时有人问：“承师有言：‘尽乾坤界是你诸人家风’，学人到这里为什摩却不见？”师云：“是你到什摩处却不见？”学云：“请师指旨！”师云：“洎放过。”又问：“承师有言：‘若依于正令汝向什摩处会’，如何是正令？”师良久，学人罔措。师云：“不信道向什摩处会？”因举六祖为行者时，到刘志略家，夜听尼转《涅盘经》。尼便问：“行者还读得《涅盘经》不？”行者云：“文字则不解读，只解说义。”尼便将所疑文字问之，行者云：“不识。”尼乃轻言呵云：“文字尚不识，何解说义？”行者云：“岂不闻道‘诸佛理论不干文字’？”因举次，师云：“由欠一问。”便问：“如何是不干文字理论底事？”师云：“什摩处去来？”

师与长庆从江外再入岭。在路歇次，因举太子初下生时，目视四方，各行七步，一手指天，一手指地。云：“天上天下唯我独尊。”庆却云：“不委太子登时实有此语，为复是结集家语。直饶登时不与摩道，便是目视四方，犹较些子。”师问：“什摩处你？”庆云：“深领阇梨此一问。”师云：“领问则领问，太粗生！”庆拈得拄杖行三两步，回头云：“不妨是粗些子。”师云：“不错嫌粗。”

祖堂卷十·长庆

长庆和尚嗣雪峰，在福州。师讳慧冰，杭州海盐县人，姓孙。年十三出家。初参见雪峰，学业辛苦，不多得灵利。雪峰见如是次第，断他云：“我与你死马医法，你还甘也无？”师对云：“依师处分。”峰云：“不用一日三度五度上来，但知山里燎火度树橦子相似，息却身心，远则十年，中则七年，近则三年，必有来由。”师依雪峰处分，过得两年半。有一日，心造坐不得，却院外绕茶园三匝了，树下坐，忽底睡著。觉了却归院，从东廊下上。才入僧堂，见灯笼火，便有来由，便去和尚处。和尚未起，却退步依法堂柱立，不觉失声。大师听闻，问：“是什摩人？”师自称名，大师云：“你又三更半夜来者里作什摩？”对云：“某甲别有见处。”大师自起来开门，执手问衷情。师说衷情偈曰：

也大差，也大差，卷上帘来满天下。

有人问我会何宗，拈起拂子蓦口打。

大师便安排了，处分侍者，教伊煮粥。吃粥后，教侍者看堂里第二粥未行报。侍者去看，来报和尚，和尚令师来堂里打槌，云：“老汉在这裹住，聚得千七百人，今日之下，只得半个圣人。”

明朝索上堂，升座便唤师，师便出来。和尚云：“昨夜事，大众却疑你道，两个老汉预造斗合禅。你既有见处，大众前道得一句语。”师便有偈曰：

万象之中独露身，唯人自肯乃能亲。

昔日谬向途中学，今日看来火里冰。

师问：“从上诸圣，传授一路，请垂指示。”师答，良久，设礼而退。雪峰云：“宽尔大哉。”因此便住招庆也。师问：“大沩山久住诜上座，还曾到雪峰山摩？”对云：“不曾到。”师云：“为什摩不曾到。”对云：“某甲自有本分事在。”师云：“作摩生是上座本分事？”上座拈起纳衣角，师云：“只这个，为当别更有？”对云：“和尚适来见什摩？”师云：“龙头蛇尾。”师代云：“果然不见。”

师与保福游山次，保福问：“古人道妙峰顶，莫只这个便是不？”师云：“是即是，可惜许。”有僧举似鼓山，鼓山云：“若不然者，髑髅遍野，白骨连山。”因举体师叔古曲偈曰：

古曲发声雄，今古唱还同。

若论第一拍，祖佛尽迷踪。

师拈问：“只如祖佛尽迷踪，成得个什摩边事？”僧曰：“成得个佛未出世时事，黑豆未生萌时事。”云：“某甲到这里去不得，未审师如何？”师代云：“成得个绝痕缝边事”。僧问忠塔：“如何是诸佛？”师答曰：“一切人识不得。”有人举似师，师云：“是即是，只欠礼三拜。”

因僧举云岩补草鞋次，药山问：“作什摩？”岩对云：“将败坏补败壤。”药山不肯，云：“即败壤，非败坏。”师云：“药山与摩道，犹教一节在。”僧问：“和尚如何？”师云：“汝犹教一节在。”僧云：“学人则与摩教和尚一节在，未审作摩生则得尽于师机？”师云：“汝须亲自道始得。”时有学人问：“如何是败坏底？”师提起杖。“如何是非败坏底？”师亦举起杖。问：“古人道‘真金卖不受，卖受金不真。’既卖受，为什摩金不真？”师云：“只为被谩。”

师有时云：“与摩举扬，背地看来，却成返仄。”僧便问：“当众举扬为什摩却成返仄？”师云：“只为容易。”僧云：“不容易作摩生道？”师云：“当不当。”问：“如何是万法之源？”师云：“未用怪我，只这个是。”僧便礼拜，师却云：“忽有人不肯与摩道，你还肯也无？你若肯，过在什摩处？你若不肯，道理在什摩处？你若挥得，许你有这个眼；你若择不出；敢保你未具眼在。”问：“灵山会上百万众，唯有迦叶亲闻。如何是迦叶亲闻底事？”师良久。僧云：“若不问和尚，洎空过一生也。”师乃将杖打之，问：“师之捉象亦全其力，捉兔亦全其力。既是全力，为什摩救善星不得？”云：“汝道救不得，如今在什摩处？”

师患耳重，王太傅有书来问疾，兼有偈上师：

世人悟道非从早，耳患虽加道亦分。

灵鹫一机迦叶会，吾师传得岂关闻？

师回问云：“不及奉和，辄置问词。太傅若也吝，则显截流之作也。蒙示非从耳，云得岂关闻。不从闻得者，请露后来珍。”太傅答：“好晴好雨，宜花宜麦。得不得，请大师亲批。”师云：“与摩则大众有望，北院何忧。虽然如此，犹虑恐人笑在。”

又因举仰山与岑大虫话，师云：“前头彼此作家，后头却不作家。某甲于中下一句语云：邪法难扶。汝道向什摩人分上下语？”问：“如何得不疑不惑去？”师便展手向两边，却令学人再问：“我更与汝道。”学人再问，师乃露膊而坐，学人礼拜，师云：“汝且作摩生会？”对云：“今日东风起。”师云：“汝与摩道未定人见解，汝于古圣已来有什摩言教时节齐得长庆？你若举得，许你有这个话主。”问：“于一不谛，还解置得无过底事也无？”师云：“汝既问我，我亦问汝。”“与摩则不敢道和尚问某甲。”师云：“我也委汝来处，你亦不得错认定半星。”师代前，但言珍重。

孔子问诸弟子：“汝诸人以何为道？”一人云：“无心为道。”一人云：“触目为道。”有一人两手抚膝，雀跃而行。孔子判云：“无心为道是向去道，触目为道是明道，雀跃而行是现道。”师闻此语，拈问众：“孔子与摩判断，还称得三人意也无？”无人对，自云：“两个则得，一个则不得。”

师回清源，太傅问：“山中和尚近日有何言教？”师云：“山中和尚近日老婆心，教人向未开口已前会取。”太傅云：“与摩道还得当也无？”师云：“当不当则且置，太傅作摩生会得？”太傅云：“专甲亦有商量处。”大师云：“太傅作摩生商量？”太傅乃收足坐。师云：“教什么人委？”太傅云：“大师不委。”师云：“上来何在？”太傅云：“有什摩罪过？”师云：“亦须自检责好。”

师与王大王说今古成人立德底事，师向大王云：“世俗中亦有志人底苗稼，佛法中亦有志人底苗稼。”大王就师问：“作摩生是世俗中志人底苗稼？”师举云：“青云有路应须到，金榜无名誓不归。”大王云：“作摩生是佛法中志人底苗稼？”师举云：“努力此生须了却，莫交累劫受诸殃。”又云：“不得无生终不止取彻为期。”大王礼拜云：“若不遇和尚，岂知与摩次第！”

问僧：“不伤本柄，你作摩生道？”对云：“某甲有口，只解吃菜。”师云：“劈脊棒汝，还甘也无？”云：“争得不甘？”师云：“你过在什摩处，招得这个棒？”对云：“若不打专甲，何处有长庆？”师云：“是也，长庆意作摩生？”其僧珍重。

师有时云：“我若放你过，纵汝百般东道西道，口似悬河则得；我若不放你过，汝拟道个什摩？”对云：“乞和尚放某甲过，亦有道处。”师云：“我放你过作摩生道？”对云：“来日供养主设斋。”师云：“我若放你过，汝与摩道；我若不放你过，汝与摩道，过在什摩处？”无对。别人对云：“若不与摩道，争识得和尚？”师便讶之，又问别僧：“放你过作摩生道？”对云：“只这个。”

僧到参次，师便把住，云：“莫屈著兄弟摩？”对云：“不屈。”师推出僧，云：“如许多时，虚踏破草鞋作什摩？”又一日，僧参，师拦胸把住，云：“莫成相触忤摩？”僧无对，师便托出。

有借举似安国，安国云：“招庆今日有杀人之刀，亦有活人之剑。”僧举似保福，福云：“招庆杀活俱备。”中招庆云：“与摩则首者无过。”演侍者云：“赖得和尚与摩道。”师进云：“是也，不与摩道时作摩生？”侍者无对。师代云：“和尚若不与摩道百杂碎。”问：“学人近入丛林，乞师举唱宗乘。”师云：“是举扬？是不举扬？”学人礼拜，师云：“会摩？”学云：“不会。”师云：“赖汝不会。汝若会，何处更有招庆？”问：“塞雁衔芦为质，祖代凭何为信？”师云：“莫札竹/到，与摩则金口绝谈扬去也。”师云：“还得此消息摩？”学曰：“师还说也无？”师云：“且要问汝。”僧云：“与摩则不敢诳妄和尚去也。”师云：“还得不诳妄摩？”僧曰：“和尚诺即得。”师云：“识弁相访好。”问：“古人道：‘目击道存，不在言说。’和尚此间还著这个人不？”师云：“是我这里别有来由。”僧曰：“和尚如何？”师与一掴，云：“过与一脚，不解拈出。”问：“知古知今时人共委，如何是招庆截流之作？”师云：“酬你所问，不酬你所问。”僧云：“深委和尚道处。”师云：“是你委得，招庆落在什摩处？”僧云：“体悉则不可。”师云：“体悉作摩生？”学人礼拜：“虽有都头，且无副将。”师有时云：“灵利参学底人更不到这里来。”僧问：“既不到这里来，和尚争得委他灵利？”师云：“只见他不到这里来，委他灵利。”僧云：“向什摩处支荷？”师云：“看汝不是这个脚手。”问：“承和尚有言：一等是学，直交见处坐却天下人舌头。如何是坐却天下人舌头底见？”师云：“多少年在此住持，未曾不领个须索。”僧云：“不假三寸，还许学人通信也无？”师云：“许，汝作摩生通信？”僧云：“今日东风起。”师云：“涅盘堂里汉。”

师出世二十八年，众上一千五百人。以长兴三年壬辰岁五月十七日迁化，春秋七十九，僧夏六十。师号超觉大师。净修禅师赞：

缁黄深郑重，格峻实难当。

尽机相见处，立下闭僧堂。


祖堂集卷十一

祖堂卷十一·保福

保福和尚嗣雪峰，在漳州。师讳从展，姓陈，福州福唐县人也。年十五便投雪峰出家，十八于本州大中寺受戒。既师子之乳育，乃檀树之抽芽。片月新生，孤云出岫。海鹏成羽，望霄汉以胜身；善友临溟，探摩尼而近掌。暂游吴楚，寻复巾瓶。弟子之礼才施，接示之言便至。雪峰云：“还会摩？”师欲拟近前，雪峰以杖拄之。师顿契玄要，更无游心，凡有机缘，悉皆冥契。后以漳州王太傅仰师道德，请转法轮，师出世一十二年矣。

师上堂云：“有人问话高声问。”时有人出来问：“学人高声问，请和尚高声答。”师云：“道什摩？”学人再申前问，师云：“我不是患聋。”有人问：“摩腾入汉，一藏分明；达摩西来，将何指示？”师云：“上座行脚底事作摩生？”僧云：“不会。”师云：“会取好，莫傍家取人处分。”有人问：“才施三寸，尽涉[米*茶]胡，如何示徒免负于前机？”师云：“收舍看。”学云：“大众咸委。”师云：“汝也是天津桥上皱眉。”僧问：“祖祖相传，有何言属？”师云：“汝从什摩人边传得来？”进曰：“与摩则学人退一步。”师云：“你无端进前退后作什摩？”

有时上堂云：“夜来还有悟底摩？乞个消息。不悟底摩？乞个消息。悟底是，不悟底是？若便悟去，亦不分外；若便不悟去，亦不分外。莫见与摩道，便道非悟非不悟。莫错好，者风汉与摩道，莫屈著人摩。”问：“承师有言，若便悟去，亦不分外；若便不悟去，亦不分外。未审如何是不悟底事？”师云：“教我向阿谁道？”云：“如何是悟底事？”师云：“悟人即委。”有人问：“学人欲见和尚本来事时如何？”师云：“退后。”进曰：“与摩则非次也。”师曰：“汝亦知而故犯。”有人问：“不弁诸尘，如何端的？”师云：“亏汝问即道。”进曰：“与摩即学人有赖去也。”师云：“山鬼屈汝自作得。”僧问：“不将一物来时如何？”师云：“莫向这里污人田地。”云：“如何免得？”师云：“如何即不免？”有僧问：“十二中时如何据验？”师云：“恰好据验。”云：“学人为什摩不见？”师云：“不可更捏目也。”僧问：“至理幽微，如何得到？”师云：“别更梦见作什摩？”进曰：“幽微之说，犹是梦言，以何所示即得出于梦言？”师云：“还解怪笑得摩？”僧问：“十二分教是背后赞言，请师当赞便赞。”师云：“当不当。”云：“还得全也无？”师云：“莫呓语好。”

师昔在江外时，欲先归雪峰，遂问招庆云：“某甲先归山，山中和尚忽问上座‘有什摩信’，作摩生只对？”招庆云：“不避腥膻，亦有少许。”师云：“有信道什摩？”招庆云：“教某甲分付与阿谁？”师云：“虽有此语，未必有与摩事。”庆云：“若与摩则前呈全在阇梨。”招庆云：“阇梨先归山，山中或有异闻底事，乞个消息。”师云：“设使有，上座还肯摩？”招庆云：“是什摩心行，推人向泥里著？”招庆临赴清源请时，遂命安国与师同游。山行次，招庆云：“某甲来去山门，已经二十八年，此回住，心中也足。”师问：“于二十八年中，山中和尚有什摩枢要处，请和尚不费家才，举一两则。”云：“有一则，某甲收为方便。”师云：“什摩处？”招庆举首顾视师云：“这个则收为方便，只如宗脉中事作摩生？”良久，师云：“教什摩人委？”招庆云：“阇梨又与摩泥猪疥狗作什摩！”

招庆因举僧问石霜：“如何是一句？”云：“非句无句不是句。”师拈问：“古人与摩道，意作摩生？”答曰：“实即实。”师云：“还得实也无？”答曰：“委曲话似人即得。”师云：“非句无句不是句，委曲话似人即得，据本分作摩生？”师曰：“大众总委，兄弟有此问！”师云：“谢和尚领话。”招庆因举僧问德山：“从上宗乘，和尚此间如何禀受与人？”德山云：“我宗无语句，实无一法与人。”岩头云：“实即实，于唱教中犹交些子。”师拈问招庆：“岩头平生有什摩言教过于德山？”招庆举岩头云：“如人学射，久久方中。”时有人问：“中时如何？”云：“莫不识痛庠？”师云：“今日非唯举话。”招庆云：“是什摩心行？”招庆因举佛陀婆梨尊者从西天来，礼拜文殊，逢文殊化人，问：“还将得尊胜经来否？”云：“不将来。”文殊曰：“既不将来，空来何益！纵见文殊，亦何必识之！”拈问招庆：“将得经来，文殊在什摩处？”庆答云：“恰是。”庆却问师：“将得经来，文殊在什摩处？”师云：“互换之机且从，只今作摩生？”招庆因举古人道：“金屑银屑虽贵，肉眼里著不得，岂况法眼乎！”招庆拈师问：“只如著不得，还著得摩？”师对云：“未在，更道。”招庆遂喝。师却喝，招庆却问：“阇梨作摩生道？”师云：“某甲斋后未吃茶。”师举教中云：“宁说河不入海，不说如来有二种语；宁说罗汉有三毒，不说如来有二种语。不道如来无语，只道如来无二种语。”师拈问招庆：“作摩生是如来语？”招庆云：“聋人争得闻？”师云：“和尚向第二头道则得。”招庆问：“阇梨作摩生道？”师云：“吃茶去。”招庆举南泉玩月次，时有僧问：“何时得似这个月？”泉云：“王老僧二十年前亦曾与摩来。”招庆续起问：“如今作摩生？”师代云：“近日老迈，且摩过时。”招庆云：“不因阇梨举，洎成亡记。”师云：“宿习难忘。”

困山云：“今日可杀寒。”因举东寺问：“近离什摩处？”云：“近离江西。”东寺云：“还将得马师真来不？”对云：“只这个是。”云：“背后底。”师代云：“洎不到此间。”招庆云：“大似不知。”因举长庆云：“我有一个问，哑却天下人口。”又云：“汝且作摩生问？”师代云：“谢和尚重重相为。”因举无著和尚到五台山，见文殊化寺，共吃茶次，文殊提起茶垸子云：“南方还有这个不？”无著云：“无。”文殊云：“寻常将什摩吃茶？”无著无对。师代云：“几不与摩道。”又代云：“久向金毛，今日亲见。”招庆代云：“若与摩，则痴客劝主人：‘请尽茶’。”因举先洞山辞兴平，兴平问：“什摩处去？”洞山云：“沿流无所止。”兴平云。“法身沿流？报身沿流？”洞山云：“总不作如是见解。”师代云：“觅得几个？”因举耆婆向弟子云：“汝于山中觅不中为药草归来。”弟子归来云：“并无有不中为药底草。”师遂提起问：“这个还中为药摩？”对云：“有什摩病敢出头？”师不肯，自代云：“有什摩不冰消？”因举盐官问座主：“《花严经》有几种法界？”对云：“四种法界。”提起拂子：“这个向阿那个法界中收？”无对。师代云：“若只礼谢，则著和尚棒。”因举南泉云：“文殊普贤昨夜三更各打与二十捧，一时趁出院。”赵州云：“和尚棒教什摩人吃？”师代云：“不得不道。”因举先洞山问雪峰：“入门须得语，不得道‘早个入门了也’。”雪峰云：“某甲无口。”师曰：“无口则且从，还我眼来。”无对。师代云：“若问眼，和尚谨随状退。”因举僧问先洞山：“从上几人得入此门？”洞山云：“实无一人得入此门。”进曰：“与摩道，莫屈人也无？”洞山云：“若实如此，亦不屈著人。”时有学人问：“古人还扶入门，不扶入门？”保福云：“行脚得什摩人力？”

僧举盘山云：“光境俱亡，复是何物？”洞山云：“光境未亡，复是何物？”“据二彼商量，尽未得剿绝。”师拈问其僧：“作摩生道得剿绝？”僧云：“还解怪笑得摩？”师云：“非常怪笑得。”学人却问：“和尚如何道得剿绝去？”师云：“两手扶犁水过膝。”自后举似招庆：“保福道‘非常怪笑’意作摩生？”招庆云：“尽法无民。”因举曹山“三种阐提”云：“杀尽一切，名曰阐提；杀一阐提，得福无量。”僧问：“只如一阐提作摩生杀？”师云：“不杀。”进云：“为什摩不杀？”师云：“若杀，则同于阐提。”因举云居示徒云：“举得一百个话，不如拣得一个话；拣得一百个话，不如道取一个话；道得一百个话，不如行取一个话。”时有僧问：“只如一个作摩生行？”师云：“不行。”进云：“为什摩不行？”师云：“汝须礼拜。”因举曹山云：“佛既说一言五百害心生，如何是此言？”师云：“冷侵侵地。”进曰：“既有此言，为什摩却返怨？”师云：“汝唤什么作返怨？”对云：“唯不喜见父面。”时有学人问：“父有什摩过？”师云：“父无过。”云：“既无过，为什摩不喜见？”师云：“只为无过，所以不喜见。”因举南泉问座主：“讲什摩经？”座主云：“讲《上生经》。”南泉云：“弥勒在什摩处？”对云：“在兜率陀天。”南泉叱云：“天上无弥勒。”后僧举似洞山，洞山叱：“地下无弥勒。”有人问师：“弥勒在什摩处？”师乃叱之。因举教中有言：“应真菩萨内外俱作黄金色。”时有人问：“直得与摩时，是什摩人分上事？”师云：“不是兄分上事。”云：“与摩则有强有弱去也。”师云：“前话已堕。”

师因举初祖于少林寺里，面壁打坐九年。寺里三千个听徒口似悬河，只云：“此是西天小乘壁观婆罗门，有什摩雪处？直是有理无雪处！”时有人问：“既有理，为什摩无雪处？”师云：“只为如此，所以如此；若不如此，焉知如此？”僧云：“不如此事作摩生？”师云：“莫放我打睡。”

师有时云：“不座诸法，还得无过摩？”有时云：“欲得见诸圣，亦从此门入；不欲得见诸圣，亦从此门入。”师却问僧：“作摩生是汝入门底事？”僧云：“当不当。”师云：“是凡，是圣？”对曰：“未问已前，却疑和尚。”师叱之。问：“古人有言，‘欲达无生路，应须识本源。’如何是本源？”师良久，却问侍者：“适来僧问什摩？”其僧再举，师便喝出，云：“我不是患聋！”

师患漏次，僧问：“善知识诸漏已尽，为什摩患漏？”师云：“若是善知识，一物亦不违。”增云：“争奈苦楚何？”师云：“若见众生苦，则同受苦者。”因小师行脚归，师问：“汝乱走，还变也未？”对云：“不是神，不是鬼，变什摩？”师云：“又乱走作什摩？”对云：“也要和尚鉴。”师云：“放汝二十棒。”师代云：“和尚见走到什摩处？”师问僧：“我寻常道，莫道道不得，设而道得十成，犹是患謇。”既道得十成，为什摩却成患謇？”僧云：“从来岂是道得底事那作摩？”师抗声云：“脱却来！”其僧别云：“头上不可更安头。”师云：“停囚长智。”僧辞师，问：“什摩处去？”对云：“什摩处不是某甲去处？”师云：“忽然山河大地又作摩生？”对云：“唤什摩作山河大地？”师云：“汝话堕也。”问：“不问不答时如何？”师云：“不道。”进曰：“为什摩不道？”师云：“你也虚有这个问。”

师上堂云：“此事似个什摩？闪电相似，石火相似，火焰相似，霹雳相似。是你诸人著力，须得趁著始得；若不趁著，丧身失命。”有人便问：“承师有言：‘是你诸人著力，须得趁著始得；若不趁者，丧身失命。’直得趁著还不丧身失命也无？”师云：“失不失，即且置。是你还趁著也无？”对曰：“若道趁不著，招人怪笑。”师曰：“是你趁著底事作摩生？”对曰：“和尚还解怪笑得摩？”师曰：“汝是恶人。”僧曰：“何必！”师便打出去。师举曹山代无著曰：“久承大师按剑，何得处在一尘？”僧便问：“作摩是文殊剑？”对曰：“不道。”“为什摩不道？”曰：“道则在一尘。”鼓山问静道者：“古人道，这里则易，那里则难。’这里则且从，那里事作摩生？”道者曰：“还有这里那里摩？”鼓山打之。师云：“打有道理，打无道理？”学人云：“于静道者分上商量则得。”师云：“古人意作摩生？”学云：“不可道，某甲辜负古人。”师云：“不辜负古人事作摩生？”对云：“和尚惯得此便。”师云：“你也是惯得此便。”因举彦上座问九峰和尚：“又须道取柏树子，不得触著，和尚如何道？’和尚无对。彦上座举似长庆，长庆却问上座：“当此问，上座代和尚作摩生道？”上座对云：“不逐四时雕。”长庆举似保福，保福拈问长庆：“只如上座道‘不逐四时雕’，与摩道还得剿绝，为当不得剿绝？”庆云：“争得剿绝！”师云：“大众分明记取，向后举似作家第一机对。”困山云：“不是桄榔树。”师云：“桄榔树不是。”

师上堂，因示徒云：“过去如许多诸圣，乃至今时老宿，出头来尽道‘我愿度一切众生，成道成果，与我无异。’灼然吾徒等辈，为不承他先圣方便，今日向什摩处填沟塞壑？然虽如此，于中还有一人具眼也无？”师代云：“汝问天下人怪笑得摩？”因举古人道：“诸方只有杀人之刀，且无活人之剑。”时有学人问：“如何是活人之剑？”师答曰：“我老大汉，不能礼拜汝。”师问僧：“我都置一问，汝作摩生对？”曰：“与摩即退一步。”师云：“非时作摩生？”云：“和尚因什摩龙头蛇尾？”师云：“汝是作家。”对曰：“未在，更道。”师云：“我不辞向汝道，恐汝会去。”问：“教中有言，‘师子捉象，亦全其力’，未审全个什摩力？”师答曰：“若问全力，我怕。”进云：“和尚为什摩却怕学人？”师云：“为汝有全力。”问：“承古人有言，‘智不到处，切忌道著，道著则头角生。’和尚如何？”师答曰：“收。”进曰：“若向无头角处收，即招大众怪笑。”师云：“失钱遭罪。”因举《金刚经》云：“一切诸法，皆是如义。”师却问僧：“作摩生是如义？”对云：“和尚问阿谁？”师云：“忽遇道伴相借问，作摩生向伊道？”对云：“和尚是什摩心行？”师不肯，代云：“何处有与摩道伴？”

祖堂卷十一·云门

云门和尚嗣雪峰，在韶州，师讳偃禅，苏州中吴府嘉兴人也。姓张。年十七，依空王寺僜律禅师下受业。年登己卯，得具尸罗，习四分于南山，听三车于中道。

辞入闽岭，才登象骨，直大/乌鹏程，三礼欲施，雪峰便云：“何得到与摩？”师不移丝发，重印全机，虽等截流，还同戴角。每于参请，暗契知见。复出瓯闽，止于韶州灵树知圣大师。密怀通鉴，益固留连。去世后，付嘱住持。南朝钦崇玄化，赐紫号匡真大师。

问：“如何是透法身之句？”师云：“看山。”师上堂云：“汝若不会，三十年后，莫道不见老汉。”

师有十二时偈：

半夜子，命似悬丝犹未许。因缘契会刹那间，了了分明一无气。

鸡鸣丑，一岁孙兒大哮吼。实相圆明不思议，三世法身藏北斗。

平旦寅，三昧圆光证法身。大千世界掌中收，色透髑髅谁得亲？

日出卯，嘿说心传道实教。心心相印息无心，玄妙之中无拙巧。

食时辰，恆沙世界眼中人。万法皆从一法生，一法灵光谁是邻？

禺中巳，分明历历不相似。灵源独曜少人逢，达者方知无所虑。

日中午，一部笙歌谁解儛？逍遥顿入达无生，昼夜法螺击法鼓。

日昳未，灌顶醍醐最上味。一切诸佛及菩提，唯佛知之贵中贵。

晡时申，三坛等施互为宾。无漏果圆一念修，六度同归净土因。

日入酉，玄人莫向途中走。黄叶浮沤貦杀人，命尽慞惶是了手。

黄昏戍，把火寻牛是底物。素体相呈知道非，奴郎不弁谁受屈？

人定亥，莫把三乘相疋配。要知此意现真宗，密密心心超三昧。

又宗脉颂曰：

如来一大事，出现于世问。

五千方便教，流传几百年。

四十九年说，未曾忤出言。

如来灭度后，付嘱迦叶边。

西天二十八，祖佛印相传。

达摩观东土，五叶气相连。

九年来面璧，唯有吃茶言。

二祖为上首，达摩回西天。

六祖曹溪住，衣钵后不传。

派分三五六，各各达真源。

七八心忙乱，空花坠目前。

苦哉明眼士，认得止啼钱。

外道多毁谤，弟子得生天。

昔在灵山上，今日获安然。

六门俱休歇，无心处处闲。

如有玄中客，但除人我山。

一味醍醐药，百病悉皆安。

因缘契会者，无心便安禅。

师因把杖打柱问：“什摩处来？”对云：“西天来。”师云：“作什摩来？”对云：“教化唐土众生来。”师云：“欺我唐土众生。”却问：“大众还会摩？”对云：“不会。”师打柱云：“打你个两重败阙！”师良久，僧问：“何异释迦当时？”师云：“大众立久，快礼三拜。”

问：“如何是超佛越祖之谈？”师云：“蒲州麻黄，益州符子。”问：“一口吞尽时如何？”师云：“老僧在你肚里。”僧曰：“和尚为什摩在学人肚里？”师云：“还我话头来。”

问：“如何是禅？”师云：“露柱吞虾蟆。”僧云：“如何举唱，则不负于来机？”师云：“道什摩？”僧云：“还可来意也无？”师云：“且款款问。”

师问僧：“诸方行来道我知有，且与我拈三千大千世界，向眼睫上著。”学人应喏。师云：“钱唐去国，为什摩三千里？”师问僧：“一切声是佛声，一切色是佛色。拈却了与你道。”对云：“拈却了也。”师云：“与摩驴年去。”

祖堂卷十一·齐云

齐云和尚嗣雪峰，师讳灵照，东国人也。

自传雪峰密旨，便住浙江。钱王钦重，敬赐紫衣，号真觉大师。初居齐云，后住镜清、报慈、龙花。四海玄徒，长臻法席矣。

师有时上堂云：“尽令去也，如存若亡。私曲将来，碍著老学，与摩相告报，还解笑得我摩？”时有人问：“请师尽令。”师云：“底底。”

问：“如何是诸佛出身处？”师唤少兒老，法归亦庆幸。”僧云：“与摩则只今讳什摩？”师云：“到京不知有京风。”问：“此个门风，如何继绍？”师云：“昔年汉主，今日吾君。”

师住报慈时，开堂日云：“帝子王孙，及四众云集。金枝玉叶，未离王宫。及诸高班君子等，犹在贵居；乃至诸寺大师大德，只在本寺。正当与摩时，微僧早与相著了也，于中还有省察者摩？诸仁者才拟跨门，万里望乡关，岂况到报慈，何处更有也？与摩语话，莫轻角/牛上人摩？放过则万事绝言；若不放过，一场祸事。虽然如此，不可断绝。今时于中还有怀疑者摩？快出来！”时有人出来问：“承师有言，未离本处。早与相著了也。未审未离本处，什摩处是师与众人相著处？”师云：“阿你若不得我力，争解形得此问？”

问：“寸丝不露时如何？”师云：“隐密。”僧云：“与摩则无面可露也。”师云：“林下月彩足人撮。”

问：“诸圣会中，还有不排位者也无？”师云：“诸圣会中则且置，唤什摩作不排位？”僧云：“与摩则出身无路也。”师云：“玉不处雪，那辩坚贞？”因说百丈打侍者因缘。有人拈问：“百丈打侍者，为上座打，为侍者打？”师云：“理［里］正不了，累及家丁。”

师问招庆：“事须有与摩道，不被人检点，初机后学，又须得力。自古先德苗稼，是什摩次第，附得其中？此问请和尚择。”招庆择云：“放旷长如痴凡人，他家自有通人爱。”

问：“未纳问前，请师指示。”师云：“成什摩道理？”僧云：“已领师意。”师云：“献璧加刑。”困措多人主寺问僧：“此寺名什摩？”其僧不知名额，措多送作一首诗曰：

此寺何年造？问僧僧不知。

系马枯松下，拂尘读古碑。

有人拈问师：“碑文道什摩？”师云：“三藏入室。”

师问招庆：“作摩生是投机如未肯？”招庆曰：“遇茶即吃。”师曰：“适来立久脚疒@登痛。”招庆却问：“什摩处是成尘处？请兄择。”师云：“即此猛提取。”招庆肯之。

师有时上堂，蓦地起来伸手云：“乞取些子，乞取些子。”又云：“一人传虚，万人传实。”

问：“古人有言，‘无言无说，直入不二法门。’文殊与摩道，还称得长老意无？”师云：“比拟理国，却令家破。”

问：“灵山会上，法法相传。未审齐云将何付嘱于人？”云：“不可为汝一个荒却齐云山。”僧云：“莫便是亲付嘱也无？”师云：“莫令大众笑。”

师一日见僧上来立次，竖起物问：“你道这个与那个别不别？”僧无对。师代云：“别则眼见山，不别则山见眼。”

问：“‘向上一路，千圣不传。’未审是什摩人则能传得？”师云：“千圣也疑我。”僧云：“莫便是传底人无？”师云：“晋帝斩嵇康。”

师上堂，偏立告云：“莫不要升此座摩？”云禅大师云：“人义道中。”自代云：“大众还体悉摩？”

师初入龙华，上堂云：“宗门妙理，别时一论。若也大道玄网，包三界为一门，尽十方为正眼。世尊灵山说法之后，付嘱摩诃迦叶。祖祖相继，法法相传。自从南天竺国王太子舍荣出家，呼为达摩大师，传佛心印，特置十万八千里过来。告曰：‘吾本来此土，传教救迷情。’以经得二千来年贞风不替。我吴越国大祖世皇，崇敬佛法，当今殿下，敬重三宝，兴阐大乘，皆是灵山受佛付嘱来。大师令公迎请大士归朝，入内道场供善，兼宣下造寺功德。以当寺便是弥勒之内苑。宝塔安大士真身，又是令公兴建，地久天长，古今罕有。播在于四海，八方知闻。昨者伏蒙圣恩，宣赐当寺住持，许聚玄徒。敢不率以焚，修励一心而报答圣躬？许赐从容，有事近前。”

时有学人问：“只如龙花之会，何异于灵山？”师云：“化城教一级。”僧云：“与摩则彼彼不相羡也。”师云：“前言终不虚施。”僧云：“未审当初灵山合谈何法？”师云：“不见道‘世尊不说说，迦叶不闻闻’？”僧云：“与摩则‘不睹王居殿，焉知天子尊’？”师云：“酌然，瞻敬则有分。”

师问僧：“作什摩云‘扫佛身上尘’？”云：“既是佛，为什么却有尘？”僧无对。自代云：“不见道‘金屑虽贵’？”

问：“古人有言：佛有正法眼，付嘱摩诃迦叶。如何是‘正法眼’？”师云：“金屑虽贵。”僧云：“‘正法眼’又作摩生？”师云：“也须知有龙花惜人。”

有人问：“某甲下山去，忽有人问：‘龙花有什摩消息’，向他作摩生道？”师：“但向他道：‘马鸣龙树白槌下。’”

问：“不二之言，请师道。”师云：“不遵摩竭令，谁谈毗耶理？”

丽天和尚颂无著对文殊话。颂曰：

清凉感现圣伽蓝，亲对文殊接话谈。

言下不通好消息，回头只见翠山岩。

师和颂曰：

遍周沙界圣伽蓝，触处文殊共话谈。

若有门上觅消息，谁能敢道翠山岩？

问：“古人有言：‘粗中之细，细中之粗。’如何是‘粗中之细’？”师曰：“佛病最难治。”进曰：“师还治也无？”师云：“作摩不得？”僧曰：“如何治得？师曰：“吃茶吃饭。”

祖堂卷十一·永福

永福和尚嗣雪峰，在福州。师讳从徊，福州闽县人也，姓陈。于雪峰山出家。依年具戒，密契玄关。周游吴楚，却复瓯闽。初住漳南报恩，后居永福。闽王钦敬，赐紫号超证大师。

师有时上堂，向绳床一边立云：“二尊不并化。”便归方丈。问：“教中有言：‘十方佛土中，唯有一乘法，无二亦无三。’如何是‘一乘法’？”师云：“汝道‘我在这里’，为个什摩？”僧云：“与摩则不知古人去也。”师云：“虽然如此，却不辜负汝。”问：“诸余则不敢问，省要处乞师垂慈。”师云：“不快礼拜，更待何时？”因举：“长庆上堂：‘尽法则无民。’永福则不然：若不尽法，争得有民？”

有人问赵州：“古人道：‘至道无难，唯嫌拣择。’如何是不拣择底法？”赵州云：“天上天下，唯我独尊。”僧云：“此犹是拣择底法。”州云：“田舍奴。天上天下唯我独尊，什摩处是拣择？”有人举问长庆：“如何是不拣择底法？”庆云：“还我有异底法来。”师闻举云：“此两人总在拣择中收。”僧便问：“如何是不拣择底法？”师云：“今日是几？”

后长庆闻举云：“须道超证有亲疏不？无他与摩道。”

祖堂卷十一·福清

福清和尚嗣雪峰，在泉州，师讲玄讷，东国人也。

泉州王太尉仰师道德，请转法轮，敬奏紫衣。问：“如何是人王？”师云：“一手指天，一手指地。”“如何是法王？”师云：“无手指天，无手指地。”学曰：“人王与法王，相去几何？”师云：“汝自断看。”进云：“学人断不得。和请和尚断。”师云：“来年更有新条在，恼乱春光卒未休。”

问：“如何是菩提？”师云：“庠梨失却半年粮。”学云：“为什摩失却半年粮？”师云：“只为图他一斗米。”问：“圆伊三点人皆信，灵秀家风事若何？”师云：“灵秀家风也且从，是汝家风作摩生？”学云：“争奈学人未现何？”师云：“阿谁教你不会？”

祖堂卷十一·潮山

潮山和尚嗣雪峰，在吉州，师讳延宗，泉州莆田县人也。

僧问：“和尚是咸通前住，咸通后住？”师云：“嘎。”学人再申问，师乃云：“病鸟栖芦，困鱼止泊。”

问：“师久修何业，而隐此山？”师云：“什摩处得这个消息？”学人应诺，师叱之。问：“如何是学人自己？”师云：“争受人谩？”

祖堂卷十一·惟劲

惟劲禅师嗣雪峰，在南岳般舟道场，生缘福州永泰县人也。

自参见雪峰，便契玄旨。经游五顶，南北丛林，遍探宗师，推为匠伯。后栖南岳，平生苦节。寰海播名，编续《宝林》、《镜灯》、《漩澓》、《防邪论》，并《插释赞》，广流于世。楚王钦仰，迎请出岳，留驻府廷，为教网之纪纲，作祖天之日月，住持报慈东藏，奏赐紫衣号宝文大师矣。

师因赞《镜灯》曰：

伟哉真智士，能开方便津。

一灯明一体，十镜现十身。

身身相映涉，灯灯作互因。

层层身土广，重重理事□。

俨睹微尘佛，等逢毗目仙。

海印从兹显，帝网义由诠。

一尘说法界，一切尘亦然。

五蕴十八界，寂用体俱全。

圆光含镜像，一异不可宣。

达斯无碍境，遮那法报圆。

又述象骨偈曰：

象骨雄雄举世尊，统尽乾坤是一门。

词锋未接承当好，莫待言教句里传。

拟议终成山海隔，擗面浑机直下全。

更欲会他泥牛吼，审细须听木马嘶。

如体禅师雄颂曰：

古曲发声雄，今古唱还同。

若论第一拍，祖佛尽迷踪。

长庆拈问僧：“只如‘祖佛尽迷踪’，成得个什摩边事？”对云：“成得个佛未出世时事，黑豆未生芽时事。”庆云：“只如佛未出世时事，黑豆未生芽时事，成得个什摩边事？”对云：“某甲到这里举不得。未审和尚如何？”庆云：“成得个痕缝边事。”师又颂曰：

学道如钻火，逢烟且莫休。

直得金星现，归家始到头。

有人举问中招庆：“古人有言：‘直得金星现，归家始到头。’如何是‘金星现’？”庆云：“我道直得金星现，也未是到头在。”僧云：“作摩生？”庆云：“遇茶吃茶，遇饭吃饭。”

祖堂卷十一·越山鉴真

越山鉴真大师嗣雪峰，钱王钦敬赐紫，师因睹写真，有偈曰：

真之本源，顶足方圆。

弥沦不坏，实相无边。

恆沙劫数，古今现前。

沤起沤灭，空手空拳。

此之相貌，三界亦然。

师颂三种病人曰：

盲聋喑哑格调高，是何境界自担荷。

昔日曾向玄沙道，笑杀张三李四歌。

祖堂卷十一·睡龙

睡龙和尚嗣雪峰，在泉州，师号道溥，姓郑，福唐县人也。

出家于宝林院，依年具戒，便参见雪峰，密契玄关，更无他往。后清源王太尉，钦仰德高，请住五峰。旋奏紫衣锡号弘教大师矣。

有时僧参次，于时云：“莫道，空山无可只对。”便起归丈室。

有俗官问黄檗供养主：“黄檗和尚驴马相似，上座作供养主，作什摩？”僧无对。却归举似黄檗。黄檗云：“道薄人微，甚是难消。”有人举似南泉，南泉云：“池州麻黄，蜀地当归。”有人举似师，师云：“泉州葛布，好造汗衫。”

问：“古人有言：‘含珠不吐，谁知有宝？’含珠则不问，便请吐。”师云：“看者甚多，弁者甚少。”问：“如何是学人自己事？”师云：“不是你自己是什摩？”问：“太尉相公送绳床，和尚将何报答？”师云：“天津桥上无异路，报答之心性不殊。”僧云：“与摩则相公殷勤，师之不谬。”师云：“我道毗卢不点头，你作摩生？”僧云：“学人到这里，直得无言可进。”师云：“饶你与摩，亦与老师较一阶地。”

问：“学人乍入丛林，乞和尚指示个入路。”师良久，学人礼拜。师云：“汝礼拜阿谁？”学云：“礼拜和尚。”师云：“汝若会，即是汝礼拜汝；汝若不会，即是礼拜老僧。”

问：“如何是古佛心？”师云：“我委。你不问古佛心。”问：“如何是佛？”师云：“觌面相呈由不识，问佛之人焉能委？”师颂三种病人曰：

奇哉大师哑盲聋，善能方便唱真宗。

为报知音须带会，莫将意句竞来通。

问：“教中有言：‘罗侯罗密行。’如何是‘密行’？”师云：“汝是粗人，争得委？”学云：“和尚还委得也无？”师云：“不委。”学云：“和尚为什摩不委？”师云：“若委则不密去。”

问：“教中有言：‘开方便门，现真实相。’如何是‘方便门’？”师竖起拳。“如何是‘现真实相’？”师良久，学云：“若不置问，焉委得和尚慈悲？”师曰：“也须进步。”

太尉问：“如何是摩尼珠？”师云：“明日更献北禅看。”太尉云：“非北禅，还有鉴者也无？”外师云：“臣僧有幸得遇明君。”又述示学偈曰：

瞎眼善解通，聋耳却获功。

一体归无性，六处本来同。

我今齐举唱，方便示汝侬。

相传佛祖印，继续老胡宗。

因雪峰问玄沙：“汝还识国师无缝塔也无？”玄沙却问：“无缝塔阔多少？高多少？”雪峰顾示，玄沙云：“和尚何得自犯？”僧问师：“玄沙岂不是不诺雪峰？”师云：“是也。”僧云：“既然如此，请师代雪峰对玄沙。”师云：“向后不用修造。”

祖堂卷十一·佛日

佛日和尚嗣云居，在越州。

师到径山，径山问：“伏承长老，独处一方，何得再游峰顶？”师云：“朗月当空挂，冰霜不自寒。”使山云：“莫是长老家风也无？”师云：“峭峙万重山，此中含宝月。”径山曰：“此犹是文言，长老家风作摩生？”师云：“今日赖遇佛日，师别申一问。隐密全生时人知有道得，大省无辜时人知有道不得。于此二途，犹是时人升降处。未审长老亲道自道，云何道？”径山云：“我家道处无可道。”师云：“如来路上无私曲，更请玄音和一场。”径山云：“任你二轮更互照，碧宵云外不相干。”师云：“为报白头无限众，此中年少莫归乡。”径山云：“老少同轮无向背，我家玄路莫参差。”师云：“一言已定天下，四句为谁留？”径山云：“汝道有三四，我道其中一亦无。”径山因此偈曰：

东西不相愿，南北与谁留？

汝则言三四，我道其中一也无。

师颂曰：

遍学穷切抱死尸，出身不得病难治。

任汝入海常献宝，不如自治剑轮飞。

祖堂卷十一·水西南台

水西南台和尚嗣云居，在潭州。

问：“祖祖相传，未审传个什摩？”师云：“不因阇梨举，老僧亦不知。”

祖堂卷十一·中曹山

中曹山和尚嗣曹山，在抚州，师号慧遐，姓黄，泉州莆田县人也。

自造漕源法席，密契玄道，更无他往，而居荷王矣。

僧问：“抱璞投师时如何？”师云：“不是自家珍。”僧曰：“如何是自家珍？”师云：“不啄不成器。”

问：“佛未出世时如何？”师云：“曹山不如。”曰：“佛出世后如何？”师云：“不如曹山。”

问：“四山相逼时如何？”师云：“曹山在里许。”僧曰：“还求出离也无？”师云：“若在里许，则求出离。”

祖堂卷十一·金峰

金峰和尚嗣曹山，在杭州，师讳从志，福州古田县人也。

自离闽越，便造漕源，顿契玄猷，更不他往。初住金峰山，后住报恩寺，师号玄明禅师矣。

问：“四海晏清时如何？”师云：“犹是阶下汉。僧曰：“王还知也无？”师云：“王不少神。”

问：“如何是禅？”师云：“不动转。”“如何是道？”师云：“不同万物。”进曰：“禅与道相去近达？”师云：“近则近，远则远。”“如何是‘近则近’？”师云：“对面弁不得。”“如何是远则远？”师云：“过于兜率。”

问：“古人以调弦，以弁为希。只如熊耳与曹溪，以何为验？”师云：“无纹彩。”进曰：“既然如此，六叶从何来？”师云：“岂是有纹彩那作摩？”僧云：“古人还传也无？”师云：“若不传，争得到今日？”僧曰：“既无纹彩，作摩生传？”师云：“传是无纹彩。”僧曰：“和尚还传也无？”师云：“作摩不传？”僧云：“古人意如何？”师云：“曹溪门前力掌，直至如今不忘。”僧曰：“向后事如何？”师云：“千嘱万嘱。”

祖堂卷十一·鹿门

鹿门和尚嗣曹山，在襄州，师讳真禅。

问：“如何是得道底人？”师云：“有口似鼻孔。”僧曰：“忽有客来，将何败对？”师云：“柴户草门，谢你经过。”


祖堂集卷十二

祖堂卷十二·荷玉

荷玉和尚嗣曹山，在抚州。师讳匡慧，俗姓高，福州福唐县人也。

出家于罗汉院，具戒造曹源。因一日参次，曹山乃问师：“大人还在也无？”对云：“在。”曹山云：“略要相见，还得摩？”对云：“请和尚进。”曹山乃倒卧，师便珍重而出。于时却来。曹山云：“曹山适来问阇梨，与摩只对曹山？是什摩时节？但角/牛道角/牛道。”师云：“却是相见时节。”曹山深器之。自尔任性逍遥，化缘将至。初住龙泉，后居荷玉。于辛亥岁敕诏，再三辞免，赐号玄悟禅师矣。

师有时上堂云：“诸兄弟，莫只是走上为言为句，莽莽荡荡地大，难得相应。如今欲得省心力摩？不如直下休歇去，剥却从前如许多不净心垢，附托依解，回头看汝自家本分事，合作摩生著力。”师有时上堂，良久，云：“须道我好心。”学人便问：“如何是和尚好心？”师云：“好心无好报。”师见禾山来僧，拈起拂子云：“禾山还说得这个也无？”对云：“非但这个。”师云：“辜负禾山作什摩？”问：“如何是密传底心？”师良久，僧云：“若与摩，则徒劳侧耳也。”

师唤侍者，侍者来，师云：“烧火。”问：“古人道：‘若记著一句，论劫作野狐精。’未审古人意如何？”师云：“龙泉僧堂未曾锁。”僧曰：“和尚如何？”师云：“风吹耳埵。”师又时举起杖云：“从上来皆留此一路方便接人。”僧云：“和尚犹是从头起也。”师云：“更谢相悉。”问：“古人道：‘释迦掩室于摩竭，净名杜口于毗耶。’时人皆云不昧于真宗。未审古人意如何？”师云：“惜取眉毛好。”师有时示众云：“若向这里通得，未是自己眼目。”又云：“古人恐与蛇画足，眼中生翳，复若为？”问：“如何指示则得不昧于时中？”师云：“不可雪上更加霜。”僧曰：“与摩则全因和尚去也。”师云：“因什摩？”

云岩扫地次，叶寺主问：“何得自驱驱？”严云：“有人不驱驱。”寺主云：“何处有第二月？”岩提起帚云：“这个是第几月？”玄沙代云：“此由是第二月。”报慈拈问师：“忽然放下扫帚时作摩生道？”师云：“大家吃茶去。”

师有颂曰：

好心相待人少悉，开门来去何了期。

不如达取同风事，我自修行我自知。

问：“如何是客中主？”师云：“识取好。”“如何是主中主？”师良久。僧曰：“客中主与主中主相去多少？”师云：“作摩？”问：“古人道：‘山下檀越家作一头水牯牛去。’未审此理如何？”师云：“阇梨何不被毛戴角去？”僧云：“直得与摩还得相应也无？”师云：“吾早曾经多劫修，不是等闲相狂惑。”问：“作个什摩业，称得南泉路？”师云：“作水牯牛去。”僧云：“为什摩如此？”师云：“为鞔常住。”问：“有问有答则不当宗风，只如宗门中事如何？”师良久。僧云：“若不如是，争知如此？”师云：“也是半路人。”问：“六门未息，如何知有？”师云：“六门是什摩？”问：“十二时中如何与道相应？”师云：“莫造作。”僧曰：“争奈时中何？”师云：“时中是什摩？”问：“大藏教中还有宗门中事也无？”师云：“是什摩？”进云：”如何是宗门中事？”师云：“雷声甚大，雨点全无。”

祖堂卷十二·育王

育王和尚嗣曹山，在衡州，师号弘通，洪州高安县人也。出家青林寺，依年具戒，参见曹山。曹山问：“近离什摩处？”师云：“近离明水。”曹山云：“作摩生得到这里？”师云：“遇明则行，遇暗则止。”曹山肯之。

自尔逍遥云水，后栖衡岳，育王匡化，楚王钦仰。三降使人迎请，师誓不从，愿处林峦，寄安光景矣。

师有时上堂云：“释迦如来在灵山会上，四十九年说不到底句，今夜某甲不避著耻，与诸尊者共谈。”师倾间云：“莫错道者，珍重。”

祖堂卷十二·紫陵

紫陵和尚嗣花严，在襄州。

问：“如何是毗卢师？”师云：“木马呼吸和难同，被毛戴角终难契。”问：“如何识得自己佛？”师云：“一叶明时消不尽，松风韵节怨无人。”

问：“如何是王子舍王宫，出家出世事？”师云：“珠轮旷劫实难穷，毛头滴血终难契。”

师上堂云：“古琴普视目前音，谁人和得无丝曲？”学人对云：“千机千凑空王曲，无丝古格妙难穷。”

祖堂卷十二·长兴

长兴和尚嗣花严，在凤朔府。

周太传问：“未审大师年多少？”师云：“五六四三不得类，岂同一二实难穷。”

祖堂卷十二·报慈

报慈和尚嗣龙牙，在潭州，师号藏屿。屿，镇州人也。

初参赵州，次礼龙牙。密凑玄关，便驻湘江，更无他往。楚王钦敬，请住报慈，敷扬妙旨，赐紫号匡化大师矣。

僧问：“心眼相见时如何？”师云：“心向汝道什摩？”问：“如何是实见处？”师云：“丝毫不隔。”僧曰：“与摩则见也。”师云：“南泉甚好处去。”问：“如何是学人自己？”师云：“耳里风雷，眼中星月。”僧云：“学人会也。”师云：“汝道释迦老子眉毛长多少？”

祖堂卷十二·后疏山

后疏山和尚嗣先疏山，在杭州。

抚州李太傅请师疏：

伏以法眼髻珠，微妙乃明于佛日；心灯祖印，传来别在于人间。得之者瓦砾成金，悟之者醍醐灌顶。一乘良玉叮咛，来自于双林。六祖传衣血脉，广流于百代。只将烦恼便证菩提，讵可智知，良难拟议。

先疏山大师，以水中之月，物外谈四十余年。百千徒众，日东者沧溟浩渺，岱北者蜓儒齐攀。四远参寻，一言道断。今则光流异地，月照别天。故疏岭之萧条，望连云之霞。

盖长老和尚，玄珠自晓。慧剑方新，能令滋想之源，便证真如之地。愿将法雨普润人天，冀凭最胜之缘，上荐皇王之福。

幸徒众请，勿阻人心。谨疏。

因此住疏山也。

师行脚时，到投子。投子问：“近离什摩处？”对云：“近离延平。”投子云：“还将得剑来不？”对云：“将得来。”投子曰：“呈似老僧看。”师乃指面前地上，投子便休去。三日后问侍者：“这个师僧在摩？”侍者云：“去也。”投子云：“三十年学骑马，昨日被驴扑。”

问：“如何是就事学？”师云：“著衣扫地。”“如何是就理学？”师云：“骑牛去秽。”“向上事如何？”云：“溥际不收。”问：“如何是声色中混融一句？”师云：“不弁消不及。”“如何是声色外别行一句？”云：“难逢不可得。”

祖堂卷十二·禾山

禾山和尚嗣九峰，在洪州，师号无殷。福州连江县人也。姓吴，于雪峰山出家，才具尸罗，便寻祖道。出离闽越，造历宗筵，而造九峰。一言顿契于心源，万水无疑于别月。因编《十一位》，集数百言。求者填门，师多秘要。

师于一日辞往他游，九峰乃与偈送曰：

将宝类宝意不殊，琉璃线贯琉璃珠。

内外双通无异迳，饶我家园桂一株。

师初住禾山次，居祥光翠岩。于辛亥岁，敕赐洪州护国住持，号澄源禅师矣。

师有时良久云：“自作自受。”或时见僧入门来云：“患颠那作摩？”僧便问：“未审过在什摩处？”师云：“不是萧逸，争取兰亭。”

师云：“诸兄弟且莫二言三语，且待禾山与汝证明。诸人会摩？大难。如今第一不及，第二不到。须有言语指归。话出诸人，便有领览。且莫怪葛藤东说西说，可不闻，释迦在座上良久，众伫指归。其时鹫子出来，乃白槌云：‘大众当观法王法。’又云：‘法王法如是。’佛当时便下坐去，诸人道：‘置此一言合校多少，亦如阇王请迦叶说法，乃受请登坐。良久乃下。王乃问：‘师以何不为弟子说？’迦叶云：‘位崇名重，当时亦有纭纭者，如今尽会了也。’你道，古人意作摩生？八十老翁出场屋，还知摩？”

时有人问：“迦叶当时意作摩生？”师云：“不觉时迁变，萧然洞底风。”又时见僧云：“还知禾山恶发摩？”僧便问：“和尚无端恶发作什摩？”师云：“嗔拳不打笑面。”乃笑云：“大不容易。诸和尚不见他古老接示，一开一合便悟，此是有情中方便，更有灵云见桃花。仰山见天云，此是无情之物，应什摩便解令人得入。莫成思想底事摩？莫嫌古德夙根，悬铎相似。触著则应，是与摩根器始得。更有归宗敲鼎竖拳，拈布毛，抛拂子，当用无用，如啐啄之机，是他上上之流始得。”

问：“只如因物便得入意如何？”师云：“鱼透假一击，龙无变彩身。”又时把住僧云：“去则住，住则死。快道快道，是汝还具眼摩？如今一等是乱说，可不闻，六祖问让大师，从嵩山来，不污之语，与神会和尚本源佛性之理，古德配云：‘一人会祖师意，一人会大教意。’诸人道：是谁如此解会？须是鹅王之作始得。汝见华林被沩山问：‘专甲唤作这个铜瓶，师叔唤作什摩？’华林云：“我终不敢唤作木[木*突]。”沩山乃云：‘与摩则专甲沩山主也，且受用。’具谁不有？因什摩如此？又如云岩问道吾：‘专甲唤作这个草鞋，师兄唤作什摩？’吾云：‘你若唤作草鞋，则鞭胸打脊。’岩云：‘未容师兄唤作什摩？’吾云：‘不可唤作木[木*突]也。’且道此处还分也无？太不易辨白，须是龙精铁眼始得。”问：“末审此二人同别？”师云：“门外不见主，入室始知音。诸和尚不是天生自然。吾非圣人，经事多知矣。此个门中，也须精礭亲近高格者，不可断言语。若是声闻之辈，则有取舍之理。若是全收，一法不取，一法不舍。愧无偏见，皆取来往之次，方知有无。若也不通，如何弁识？一者须自己分明广大，二者时中行位相资，三者慱附道友。若无道友，向去如何成立？岂不见，石霜和尚到云岩，云岩问：‘从什摩处来？’对云：‘沩山来。’岩云：‘你在沩山多少时？’对云：‘五六夏。’岩云：‘与摩则是山长。”对云：‘某甲虽在彼中，却不知。’岩云：‘他家也非知非识。’石霜后到道吾，乃举前缘。道吾乃抗声而言：‘争得与摩无佛法身心？’且看，古人什摩处是无佛法身心处？好手亦不奈何，恰似丛林兄弟，学处不通，只执一问答，往来言语，殊不知，亦有时中问答，分为三般：一者现对缘，处机纵夺，亦得名为问答；二者亦有拟心是问，不续是答，是药病之语；三者亦有无问之问，无说之说，这个宗门正问正答之路，又不可类同。事须甄别。若论提掇，即是单行；若道收人，须承路布。”乃有僧问：“未审此三般分不分？”师云：“为物明缁素，谁知涉路迷？”师云：“莫取次好，禅师难作，须是其人。若不直下当荷得，也须三十二十年。丛林淹[氵*侵]气拍汉始得。纵不大用现前，亦是坯璞。岂同八月冬菰，销什摩霜雪？一种葛藤将去，且听，亦清人耳目。东引西证，忽因古德光贤，便有见处。岂不是疋上不足，比下有余？若拨无因果，便同谤于般若，出佛身血一般。此谤亦须区分；第一现今不信自己即佛，何处生灭坏烂之身？得成佛道，如此之辈，亦同出佛身血，唤作破和合僧；第二旷大劫来无明相随，习业颠倒，便须今日息念归真，坏除生死，六根销落，亦得为今时谤。谤是毁之异名也，始得无问。岂不见古德云：‘无问而自说’？”乃问云：“有问还说也无？”师曰：“有问则不说。”“只如不问，还说也无？”师云：“若不问时，则一切说。”所以先德云：‘古人百说而无一问，今时百问而无一说。’盖以明知力未充。”又有僧问古老：“如何是百问而无一说？”答云：“黑云叆[爱*逮]。”“如何是百说而无一问？”答云：“青天朗月。”

师云：“可不闻，僧问洞山：‘有问则有答，不问不答时如何？’洞山答云：‘持斋吃肉羹。’曹山云：‘吃酒吃肉。’只如曹山亦置此问于石霜，石霜乃对云：‘不折尺。’”

师云：“大难会。举者多，弁者少，第三知有自己本生父母，为有知解，却须鞔过，亦唤作大谤。不见当时亦有人问南山：‘谤般若底人，还有过也无？’答云：‘作摩无？’”师云：“不见道‘杀父害母，出佛身血，破和合僧’，不是过是什摩？”

僧问：“古人云：‘如人不吃饭。’未审此理如何？”师云：“不见道‘累劫受饥寒’？”僧云：“只如古人云‘不吃饭’，岂不是不知有谤？”师云：“无非论不知有谤，直得是知有不肯，亦是谤。”乃问僧：“汝还会不知有谤摩？岂不见古人见座主，乃唤座主云：‘是汝身中有佛，你还识不？’座主对云：‘何处得与摩屙尿放尿佛？’这个是不知有谤。大凡出言吐气，不可和泥合水去也。夫与人为师匠，岂是草草之流？且说一种本自真如，非同阶降，不假修证，何藉劬劳？众圣兴不加，千人退时难灭。既导其事，须赖其人。若不通明，焉知如理？然则二者既达，表里未亡。滞有法之所牵，遭无为之所束，则须泯其能所。妄虑俱销，如豁虚空。悠然无寄，始得功成德立，位称本情。果既将成，大事圆办，始得记位兜率，独尊超乎群品，亦如树果一般，方为称断。守此为解，暖瘵将冫麦，脱病不粘，谓言无辩。一色之义已立，双分之理须知，所以刘阳云：‘一色后如何？’答云：‘有人长欢喜，有人嗔迫迫地。’亦如泐潭云：‘猫兒口里雀兒飞。’须此一格始得，余则不可论也。”

因举南泉云：“祖佛不知有，狸奴自牯却知有，诸人尽知。诸方道出语句皆行。且如今禾山问诸人：‘作摩生是狸奴白牯’？”时有僧出来对云：“饥则吃草，渴则饮水。”

师云：“道则亦不教多，但却两字，则可行矣。岂不闻古人整理洞山礼兴平？兴平云：‘莫礼老朽。’洞山云：‘礼非老朽。’兴平云：‘他不受礼。’洞山云：‘亦不要止此一句错。古人云：‘当时洞山对云，亦不曾止。’看谓一般古人拈起，便有缁素，莫只与摩笼罩著争得？所以微细中更须子细始得。夫教道太不容易，个个须解主宰始得。见向前老宿示徒云：夫沙门者，十二时中一时不得失，一时不得背。上上者一拨便去，中下者落在功勋。直须日夜勤苦，乾却心识，教无线道，直得似他。犹是借句。”

僧乃问：“如何是借句？”师云：“金牌上无名，宜须向佛未出世时体会取。”僧问：“出世不出时如何？”师云：“与摩来，皆不到。”僧曰：“未审还出世不？”师云：“诸圣更有事在。”僧曰：“只如佛出世，为什摩人？”师云：“为未荐者。”僧曰：“未审佛向什摩处出世？”师云：“进身人难得，猛利人难得。”进曰：“如何是进身事？”师云：“事事总须打过。”进曰：“事事总须打过时如何？”师云：“他解传语。”进曰：“未审传什摩人语？”师云：“受他嘱不得他闻。”

僧曰：“和尚教学人承当，又如何承当？”师云：“直须似目前。”僧曰：“承当后如何？”师云：“不知有今日。”

问：“如何是古佛心？”师云：“世界崩陷。”僧曰：“世界为什摩崩陷？”师云：“宁无我身。”

问：“仰山插锹意作摩生？”师云：“汝问我。”“玄沙蹋倒锹。意作摩生？”师云：“我问汝。”问：“咫尺之间，为什摩不睹师颜？”师云：“且与阇梨通一半。”僧曰：“为什摩不全通？”师云：“尽法则无民。”僧曰：“不怕无民，请师尽法。”师云：“次到禾山。”

问：“如何是佛法大意？”师云：“为知己者丧身。”僧曰：“为什摩却丧身？’师云：“好心无好报。”

问：“尊者拨眉击目，示育王时如何？’师云：“即今也与摩。”僧云：“学人如何领会？”师云：“莫非摩利支山？”

问：“学人时中息尽境缘，未审当归何处？’师云：“落叶旋于地，却至始知休。”僧曰：“只如旋地知休，复何话论？”师云：“有截舌之刀，无活人之剑。”问：“见而不见，闻而不闻时如何？”师云：“既晓国师，须明洞山。”

问：“雪仲久思，为什摩相见无辞？”师云：“道且凭目击，知音复是谁？”僧曰：“钟期有韵时，又作摩生？”师云：“只爱伯牙琴，不续文侯志。”

问：“儒以洗耳为良，释以何为极则？”云：“不厌荣枯事，瓢提欲为谁？”僧曰：“争奈避世何？”师云：“不别巢父意，由忻许氏能。”

问：“居士不二之门，如何理论，则息于后学之疑？”师云：“乾时须好去，莫待雨霖头。”僧曰：“学人宁待雨霖头，未审师意如何？”师云：“山青凭秀色，水碧假波澜。”

问：“无影之言如何话论？”师云：“满口吐尽，已具知闻。”问：“不惜身命底人，当求何事？”师云：“舍命将无命，无希有所希。”云：“既舍命，为什摩却无命？”师云：“绝息无来往，宁知道已行？”

问：“大人相逢，则道个丑陋。未审和尚相逢，道个什摩？”师云：“未有藏深拙，言话又何妨？”僧曰：“不妨之事，乞师方便。”师云：“不触当今讳，无因断截舌。”

问：“初登雪岭，正觉道成。为什摩霜林方传王叶？”师云：“示有明星现，枝条异翠今。”僧曰：“与摩则枝枝不绝去也？”师云：“寻苗纵有路，终非解到根。”

问：“乘羊渐次，驾牛理穷。顾视四衢，此人还绍得家业也无？”师云：“三车出火宅，露地不当头。”僧曰：“既不当头，谁当露地？”师云：“未有跨日程，终须带影迹。”

问：“护明降迹，唯我独尊。明星现时，又言成道。未审此理如何？”师云：“为物权兴世，争知涉位驰？”僧曰：“涉位兴世，犹是今时方便。未审还有不降迹者也无？”师云：“不向兜率居，双林难变彩。”

问：“古人有言：‘拟心则差，况复有言。只如不拟又复无言时如何？”师云：“芭蕉重剥后，那知自不疑？”僧曰：“如何免招此过？”师云：“日从东岭上，月向西嶂沉。”

问：“古人云：‘盲聋喑哑，此人须救。若不救，佛法无灵验。’未审此人如何救？”师云：“虽有奇特意，还须反自招。”“学人则甘招，未审和尚又如何？”师云：“登山知水脉，入室坐温床。”

问：“古人有言：‘相逢欲相唤，脉脉不能语。’未审还相唤也无？”师云：“似却古人机，还同舌头备。”僧曰：“与摩则学人无端去也。”师曰：“但莫踏泥，何烦洗脚？”

祖堂卷十二·宝峰

宝峰和尚嗣九峰，在洪州，师号延茂，泉州仙游县人。姓郭，出家于三会寺，依年具戒。更不寻经讨论，便慕祖门，而参见九峰。

后因一日非时问：“观嘱将来，全无所有时如何？”九峰云：“来欲知此事如风。”师乃顿息疑情，更无他游。于壬辰岁，住于宝峰矣。

师才升堂，众集。于时有僧问：“大众云集，未审师有何赏赉？”师云：“不嫌粗弱。”僧曰：“便请。”师云：“什摩处去来？”

问：“如何是古佛心？”师云：“终不道土木瓦砾是。”问：“大众云集，从上宗乘，请师举唱。”师云：“不举唱。”僧云：“为什摩不举唱？”师云：“为国惜贤。”问：“如何是佛？”师云：“头戴中霄月，足步一莲花。看他圆成处，不如自归家。”

祖堂卷十二·光睦

光睦和尚嗣九峰，在都阙，师号行修，福州福唐县人也。姓林，瑞岩山出家，依年具戒，便离闽越，而造九峰。

峰才见师便问：“近离什摩处？”对云：“亦未到和尚此间。”峰云：“若是诸方，则有二十杖。”师云：“谢和尚放过。”峰叱之云：“参众去。”师云：“诺。”从此契会，廓净心源，遍历殊方，任缘泉石。

初请住南源时，有人问：“如何是和尚末上一句字？”师云：“如今觅什摩？”进曰：“与摩则学人脚短去也。”师云：“犹成亚次问。”

师一栖南源，已逾二纪。于辛未岁，皇帝遐飞紫诏，徵赴京都，赐“慧观禅师”。

祖堂卷十二·同安

同安和尚嗣九峰，在洪州建昌。师号常察，福州长溪县人也。姓彭，依年具戒，便离闽越，而参见九峰，密契玄关，而栖凤岭。

僧问：“如何是凤岭境地？”师云：“阇梨则今在什摩处？”问：“如何是从上来事？”师云：“从上提不起。”僧曰：“今日方便又如何？”师云：“万人吐不出。”

祖堂卷十二·泐潭

泐潭和尚嗣九峰，在洪州建昌。师号匡悟，泉州仙游县人也。

于保福院出家，依年受戒，自契九峰密旨。任性逍遥。于辛亥岁，请住泐潭矣。

问：“香烟匝地，大展法筵。从上宗乘，如何举唱？”师云：“莫错举似人。”僧曰：“与摩则一应如是去也。”师云：“还是勿交涉。”

问：“六叶芬芳，师传何叶？”师云：“六叶不相续，花开果不成。”僧曰：“岂无今日事？”师云：“若是今日则有。”僧曰：“今日事如何？”师云：“叶叶连枝秀，花开处处荣。”

祖堂卷十二·后云盖

后云盖和尚嗣先云峰，在潭州。师号景禅，泉州仙游县人也。姓田。

于祥云山出家，依年具戒，便离闽越，而凑萧湘，契云盖之真机。楚王之钦敬，赐紫号超法大师矣。

僧问：“如何是和尚家风？”师云：“四海不曾通。”问：“古人有言：‘一尘含法界’。如何是‘一尘含法界’？”师云：“通身体不圆。”“如何是九世刹那分？”师云：“繁兴不布彩。”问：“如何是宗门的的意？”师云：“万里胡僧，不入波澜。”

祖堂卷十二·黄龙

黄龙和尚嗣玄泉，在鄂州。师讳诲机。姓张，清河人也。师便栖江夏匡徒，吴朝钦敬，赐超慧大师矣。

师有时谓众云：“有一句，如山如岳；有一句子，如透网鱼；有一句子，如百川水。为当是一句，为当是三句？”有人拈问福先：“主人有言：‘有一句，如山如岳；有一句子，如透网鱼；有一句子，如百川水。’如何是如山如岳底句？”福先云：“凡圣近不得。”“如何是透网鱼底句？”先云：“汝不肯，又争得？”“如何是如百川水底句？”先云：“互用千差。”“如何是和尚一句？”先云：“莫错举似。”

师问香严：“如何是无表戒？”严云：“待阇梨还俗，则为汝说。”

师又时云：“诸和尚子，君王之剑，烈士之刀。若是君王之剑，不伤万类。烈士之刀，斩钉截铁。用则不无，不得佩著。为什摩故？忠言不避截舌，利刀则血浅梵天。久立，珍重。”

时有人问：“如何是君王剑？”师云：“不伤万类。”学云：“佩者如何？”师云：“血溅梵天。”学云：“大好不伤万类。”师打二十棒。

问：“明镜当台，还鉴物也无？”师云：“不鉴物。”僧云：“忽然胡汉来时作摩生？”师云：“胡汉俱现。”“大好不鉴物。”师便打之。

问：“如何是宝瓶？”师云：“无一物。”“如何是瓶中宝？”师云：“写不出。”‘学云：“大好无一物。”师便打之。

问：“如何是大疑底人？”师云：“对坐盘中弓落盏。”“如何是大不疑底人？”师云：“再坐盘中弓落盏。”问：“如何是西来意？”师曰：“波斯人失手巾。”

祖堂卷十二·龙光

龙光和尚嗣罗山，在金陵，师号隐微，吉州新淦县人也。姓杨，年八岁，于石头院出家。十六于洪州大安寺具戒，十七便慕祖筵，入闽初参见罗山。

罗山才见师器异，乃问：“汝是什摩处人？”对云：“江外人。”罗山云：“争得到这里？”师云：“吔吔。”罗山叱之，师便挂瓶囊，盘泊数载。

后因一日辞次，罗山于师身上脱下纳衣，披向绳床坐云：“若要去，取得纳衣，放汝去。”师从东边而向堂中礼三拜，从西边进前云：“就和尚请纳衣。”罗山忻然而脱，还师。师接得，礼谢而出。罗山遂把驻于师云：“却来一转。”师云：“不远辞违和尚则来。”从此契会，豁尔无疑。

次第离闽，遍历诸方。初住龙泉，于辛亥岁，敕旨徵诏赴京，赐龙光演法，仍锡觉寂禅师矣。

大师上堂云：“旷劫来事，只在如今。如今事作摩生？试通个消息看。有什摩来由？有摩有摩？诸和尚子，这个事古今排不到，老胡吐不出。祖师道什摩？还有人与祖师作得主摩？”时有人才礼拜，师便云：“珍重。”问：“如何是黄梅一句？”师云：“则今作摩生？”“如何通信？”师云：“九江路绝。”僧问：“国界安宁，为什摩明珠不现。”师云：“落在什摩处？”问：“如何是龙泉剑？”师云：“不出匣。”进曰：“便请。”师云：“辰星失度。”

祖堂卷十二·龙回

龙回和尚嗣罗山，在高安，师号从盛，福州闽县人也。于长生山出家，才具尸罗，便寻祖道。参见罗山，顿契玄机。出闽而住龙回。

僧问：“梵王诸佛，度尽一切众生，尚书今日殷勤接足。请师举唱。”师云：“处处太阳辉。”学云：“与摩则全因今日。”师云：“不礼更待何时？”

师到招庆，度上座问：“罗山寻常道，诸方尽是吃麨饭，唯有罗山是一味白饭。兄从罗山来，”却展手云：“白饭请些子。”师抬起手，打两掴。度上座云：“将谓是白饭，元来也只是麨饭。”师师云：“痴人棒打不死。”

度上座夜间举似诸禅客次，师近前来云：“不审。”度上座云：“今日便是这个上座下掴。”瑫上座云：“不用下掴，但就里许下取一转语。”师云：“就里许也道。”度上座无对。师云：“是汝诸人，一时缚作一束，倒竖不净处，来晨相见，珍重。”

师因天台山游时，初到紫凝，众僧一时出接，师以两手握杖子云：“国师本位在什摩处？”僧对云：“上面庵处便是。”师云：“与摩语话，虚吃却紫凝饭。”

问：“古人道：‘前三三后三三。’意作摩生？”师云：“西山日出，东山月没。”问：“古人因星得悟，意作摩生？”师以手撑开眉问：“丹霞烧木佛，意作摩生？”师向火。“翠微迎罗汉，意作摩生？”师散花。

师问罗山少师：“先师有声前一句，汝还解举得全也无？”僧拈起纳衣。师云：“汝也未梦见礼真在。”

师临迁化时，上堂良久云：“是什摩时也？诸上座，一百年中只看今日。今日事作摩生？吾四十年来，独镇此山，常持一剑活人天。”师却拈起手巾云：“如今更有纯陀供，提向他方任展看。”便掷却。

有僧问：“师百年后，向什摩处去？”师提起一足云：“足下看。”师问侍者：“昔日灵山会上，释迦牟尼佛展开双足，放百宝光。”师却展足云：“吾今放多少？”对云：“昔日灵山，今日和尚。”师以手拨眉云：“莫不辜负摩？”

祖堂卷十二·清平

清平和尚嗣罗山，在吉州，师讳惟旷，福州闽清县人也。姓黄。

于禅林院出家，依年具戒，而便参见罗山，密契玄关，更无他往。寻离闽岭，而住清平。于庚戍岁，征诏赴京，赐龙光住止，赐号寂照禅师矣。

问：“如何是第一句？”师云：“要头则斫将去。”问：“不历古今事如何？”师云：“落在什摩处？”“古今事如何？”师云：“莫乱道。”

祖堂卷十二·中塔

中塔和尚嗣玄沙，在福州，师讳慧救，泉州莆田县人也。

出家于龟洋山，依年具戒，便遇玄沙，密契心源，更无他往。后以闽王钦敬，请转法轮，奏赐紫衣矣。

师有时上堂云：“古今坦然，法尔如是。与摩道，还有过也无？”有人持此语，举以长庆。长庆云：“还得无过摩？”

问：“如何是大庾岭头事？”师云：“料汝承当不得。”学云：“重多少？”师云：“这般底论劫不奈何。”

师问了院主：“只如先师道：‘尽十方世界真实人体。’你还见这个僧堂不？”对云：“和尚莫眼花。”师云：“与摩则斫额望先师，未梦见在。”

师上堂云：“我此间粥饭因缘。纵然为兄弟举唱宗乘，终是不恆。如今欲得委省要，却是山河大地，与汝诸人举明其事，却常亦能究竟。”又云：“若从文殊门入者，则一切有为。土木瓦砾，悉皆助汝发机。若从观音门入者，则一切善恶音声，乃至虾蟆蛐鳝，助汝发明。若从普贤门入者，则不动步则到。我以此三处，示汝方便。如持一只箸，搅大海水，令彼鱼龙知水命，还会摩？若无智眼而审谛之，任汝百般巧妙，不为究竟。”问：“佛法大意，从何方便门得入？”师云：“入是方便。”问僧：“汝岂不是展兄少师？”对云：“不敢。”“汝和尚教伊行脚。”师便失声云：“汝和尚是什摩心行？”

师有时云：“满眼觑不见眼根昧，满耳听不闻耳根背。二途不晓，只是瞌睡汉。”曜日颂：

见物明明绝见尘，闻声浩浩亦非因。

宗师直示无闻见，未晓徒劳见月新。

因玄沙封白纸送雪峰，雪峰见云：“君子千里同风。”其僧却来，举似玄沙。玄沙云：“与摩则何异于孟春犹寒。”有人举似长庆，长庆云：“送书底人，还识好恶摩？”有人举似师，师云：“送书呈书了退身。”

祖堂卷十二·仙宗

仙宗和尚嗣长庆，在福州住。师讳玭禅。

师因见罗汉次，问：“古人有言：‘宁作心师，不师于心。’如何是师？”师以手指之。问：“学人常在昏沉，请师惊觉。”师以杖打之云：“若识痛痒，则古佛齐肩。”

师因见溪水云：“此水得与摩流急。”僧云：“喏。”师云：“还有脚手也无？”僧云：“有。”师云：“阿那个是？”僧以手指之。师云：“用不应。”

时僧却问师，师以水喷之。师问僧：“离什摩处？”对云：“离浙中。”师云：“来此间几年？”对云：“和尚试道看。”师云：“汝岂不是今夏在鼓山？”对云：“是冬是夏。”师别云：“谩村僧则得。”

师问僧：“汝平生成得什摩业次？”对云：“已前在众，东举西举。如今无业可成，总无般次。”师云：“如今活业作摩生？”僧对不中。师代云：“有粥无饭，有盐无醋。”

问：“古人有言：‘言语道断，心行处灭。’请师道。”师云：“阿弥陀拂！”僧云：“为什摩却如此？”师云：“汝子细检点。”

问：“古人有言：‘夜夜抱佛眠，朝朝相共起。’如何是佛？”师云：“汝还信古人摩？”“学人终不敢违背。”师云：“汝若信古人，叉手申问，非佛而谁？”

问：“久处沉沦，请师拯济。”师云：“你在沉沦几时？”“与摩则不假沉沦去也。”师云：“又与摩去也。”

问：“‘非言所及，非解所到。’什摩人能到？”师云：“阿谁教你担枷带索？”僧云：“今日得遇明师批判。”师云：“我则与摩批判。”“你到什摩处？”对云：“热则雪原取源，寒则烧火围炉。”

问：“尽十方世界是解脱门，更有疑者如何得入？”师云：“我不似汝巧恶。”僧云：“和尚也是惯得此便。”师云：“先撩者贱。”


祖堂集卷十三

祖堂卷十三·招庆

招庆和尚嗣长庆，在泉州，师讳道匡。汉国朝州人也。姓李。

入闽，参见怡山，密契心源。后以泉州王太尉请转法轮，闽王赐紫号法因大师矣。

师上堂，良久云：“大众谛听，与你真正举扬，还委落处摩？若委落处，出来，大家证明；若无，一时谩糊去也。”时有人问：“大众云集，请师真正举扬。”师良久云：“未委谁是闻者？”云：“闻者闻，如何是闻者？”师云：“雀逐凤飞。”

问：“灵山一会，迦叶亲闻，未审招庆筵中，谁当视听？”师云：“汝还闻摩？”僧云：“与摩则迦叶侧耳，虚得其名。”师云：“更有一著子，作摩生？”学人拟进问，师便喝出。

又时上堂云：“古人道：‘开门待知识，知识不相过。’招庆今日不惜身命，出门相访。还有知音者也无？”

问：“如何是招庆提宗之句？”云：“不得昧著招庆。”学人礼拜起，师又云：“不得昧著招庆，是嘱汝。什摩处是招庆提宗处？”

间：“凡有言句，尽属不了义。如何是了义？”师云：“若向阇梨道，还是不了义。”进曰：“为什摩如此？”师云：“阇梨适来问什摩？”

问：“师子未乳已前，为什摩众类同居？”师云：“不惊。”进曰：“只如乳后，为什摩毛羽脱落？”师云：“是阇梨分上事。”进曰：“除非师子，请和尚道一句。”师云：“向与摩时，置一问来。”

问：“诸佛出世，普润含生。未审招庆出世如何？”师云：“我不敢瞎却汝底。”

问：“无居止处，还许学人立身也无？”师云：“于上不足，疋下有余。”学云：“与摩则学人进一步也。”师云：“汝也莫口解脱。”

问：“如何是问？”师云：“不与摩来问。”“如何是答？”师云：“向你道什摩？”进曰：“不问不答时如何？”师云：“你亦须别头好。”

问：“古佛道场，如何得到？”师云：“更拟什摩处去？”学云：“与摩则学人退一步？”师云：“又是乱走作摩？”

问：“如何是学人本来心？”师云：“即今是什摩心？”学云：“争奈学人不识何？”师云：“不识，识取好。”

问：“此是和尚肉身，如何是和尚法身？”师以手搭胸，进曰：“与摩则分付去也？”师云：“是法身，是肉身？”

问：“环丹一颗，点铁成金；妙理一言，点凡成圣。请师点。”师云：“不点。”学云：“为什摩不点？”师云：“不欲得抑良为贱。”进曰：“与摩则不欺于学人去也？”师云：“莫闲言语。”

问：“四方归崇，凭何道理，消得人天应供？”师云：“若有一物所凭，一滴水也难消。”进曰：“直得一物不留，还消得也无？”师云：“于上不足，疋下有余。”进曰：“虽然如此，有赏有罚。”师云：“亦要汝委。”

问：“三界忙忙，如何得出？’师云：“不舍一法。”学云：“争奈忙忙何？”师云：“当直除，断不肯。”

问：“如何是与摩去底人？”师云：“还与摩问人摩？”又云：“不回头。”问：“如何是与摩来底人？”师云：“还会摩？”又云：“满面忻欢。”问：“如何是不来不去底人？”师云：“向与摩时，问将来。”又云：“还与摩问人摩？”

问：“菩萨如恆沙，为什摩不能知佛智？”师云：“不见道，‘唯佛与佛乃能知之’？”又云“汝还当得摩？”学云：“争奈不能恻得何？”师云：“如许多时，什摩处去来？”

问：“如何是沙门行李处？”师云：“莫教自委。”进曰：“还行李也无？”师云：“莫略虚。”问：“如何是沙门行？”师云：“非行不行。”学云：“如何保任？”师云：“汝适来问什摩？”

问：“请师不却来情。”师云：“虽然如此，更待什摩时？”进曰：“击电之机，难为措意。”师云：“何假烦词？”

问：“目瞪口肥底人来，师如何击发？”师云：“何处有与摩人？”学人云：“如今则无，忽有如何？”师云：“待有则得。”进曰：“终不道和尚不为人。”师云：“莫碗鸣声。”

问：“如何是无句中有句？”师云：“不道亦不道。”学人云：“请师举扬。”师云：“什摩处去来？”

问：“古佛之机，已有人置了也。未审师意如何？”师云：“古佛之机，已有人置了也。”进曰：“与摩则造次非宜。”师乃休去。

问：“浑仑提唱，学人根思迟回，曲运慈悲，开一线道。云：‘这个是老婆心。’与摩则悲花剖折，已须尊慈，未审从上宗乘如何举唱？”“与摩须索你亲问始得。”

问：“疑则途中作，不疑则坐家兒。离此二途，乞师方便。”师云：“未曾将曲与，汝离什摩？”进曰：“与摩则冰消瓦解。”师云：“动亦你置，静亦你置。”

问：“如何是眼处闻声？”师弹指，云：“若待答话，则落耳根去也。”云：“我道汝领处错。”

问：“‘佛魔不到处，未是学人自己。’如何是学人自己？”师云：“我道，你还信摩？”学人云：“便请师道。”师云：“你话堕也。”

问：“瞥起便息，此人于宗乘中如何？”师云：“困鱼止泊，病鸟栖芦。宗乘中不可作与摩语话。”学云：“如何是宗乘中事？”师云：“招庆道什摩？”问：“如何履饯，则得不负当人？”师云：“若求履践，则负当人。”进曰：“与摩则任性随流去也。”师云：“还向你与摩道摩？”问：“文殊剑下，不承当时如何？”师云：“未是好人。”学人云：“如何是好人？”师云：“是汝话堕也。”问：“诸缘则不问，如何是和尚家风？”师云：“宁可清贫长乐，不作浊富多忧。”问：“如何是南泉一线道？”师云：“不辞向汝道，恐较中又有较。”问：“如何是佛法大意？”师云：“七颠八倒。”

师有时云：“言前荐得，辜负平生。句后投机，殊乖道体。”僧便问：“为什摩却如此？”师云：“汝且道，从来事合作摩生？”

问：“古人有言：‘般若无知，遇缘而照。’如何是‘遇缘而照’？”师乃提起手。问：“古人相见，目击道存。今时如何相见？”师云：“如今不可更道目击道存。”学云：“与摩则适来已是非次去也。”师云：“知过必改。”

问：“古人有言：‘皮肤脱落尽，唯有真实在。’皮肤则不问，如何是‘真实’？”师云：“莫是将皮肤过与汝摩？”

问：“承教中有言：‘正直舍方便。’方便则不问，如何是‘正直’？”师云：“方便里收得摩？”

问：“常居大海，为什摩口里烟生？”师云：“非但大海，醍醐亦须吐却。”僧云：“与摩则学人不与摩去。”师云：“若不与摩去，阿谁罪过？”僧谢师答话，师云：“更不与你责状。”

问：“不假提网，还有提处也无？”师云：“试举与摩时看。”僧进曰：“不可道无提处。”师云：“你作摩生？”学人礼拜。师云：“虾跳不出斗。”

问：“教中有言：‘欲行大道，莫视小径。’未委如何是‘大道’？”师云：“行得摩？”僧云：“学人未会，乞师进向。”师云：“我若与汝进向，蹉却汝大道。”

问：“古人有言：‘阎浮有大宝，少见得人希。’如何是‘大’宝？”师云：“见摩？”僧谢师垂慈，师云：“大小。”

问：“古人有言：‘未有绝尘之行，徒为男子之身。’如何是‘绝尘之行’？”师云：“我若将一法如微尘许与汝受持，则不得绝。”僧云：“便与摩去，还得也无？”师云：“汝也莫贪头。”

问：“古人有言：‘一句了然超百亿。’如何是‘超百亿’底句？”师云：“不答汝这个话。”僧云：“为什摩不答？”师云：“适来问什摩？”

问：“古人有言‘不可以智知，不可以识识。’此是今时升降处。未审向上一路，和尚如何示及于学人？”师云：“不可道智知识识得。”僧云：“与摩则终不错举似于人。”师云：“你作摩生举？”学人云：“当不当？”师云：“此是答话，你作摩生举？”僧云：“和尚与摩道则得。”师云：“你作摩生合杀？”

师问僧：“你名什摩？”对云：“慧炬。”师便提起杖云：“还照得这个也无？”对云：“有物则照。”师云：“还见这个摩？”对云：“适来向和尚道什摩？”师云：“争奈这个何？”对云：“和尚是什摩心行？”因古时有一尊者，在山中住。自看牛次，忽遇贼斫头，其尊者把头觅牛次，见人问：只如无头人，还得活也无？对云：无头人争得活？其尊者当时抛头便死。师遂拈问僧：“尊者无头，什摩人觅牛？”对云：“那个人。”师云：“只如那个人，还觅牛也无？”僧无对。师代云：“不可同于死人。”

祖堂卷十三·报慈

报慈和尚嗣长庆，福州住，师讳光云，泉州莆田县人也。

于玄沙出家，才具尸罗，便参祖道，而造怡山，顿晓真心。后闽主请住报慈，赐紫号慧觉大师矣。

师升座，谓众云：“某甲道薄人微，叨奉皇恩请命，传持从上祖宗，贵得相承不令断绝。今日众中，还有堪任继踵底人摩？出来！若是利根底相投，不烦瞬视。何况更待历涉脣锋，方为知有。与摩道也，未免招他诸方明眼人不肯。”

问：“师承超觉锁口之诀，如何示人？”师云：“赖我柱杖不在。”学云：“与摩则深领尊慈。”师云：“待我肯，汝则得。”

问：“玄沙宝印，和尚亲传。未审今日一会，付嘱何人？”师云：“且就是。你还解承置得摩？”问：“不历诸位，如何与道相应？”师良久，学人罔措。师云：“虽有此问，何异于无问？”僧问：“和尚适来拈掇，犹是第二机，如何是第一机？”师良久，学人罔措。师遂云：“合消得汝三拜。”学云：“与摩则非但学人，大众有赖。”师云：“亦须讳却。”

师入朝，皇帝问：“报慈与圣众相去近远？”对云：“若说近远，不如亲到。”师知问：“皇帝陛下，日应万机，是什摩心？”皇帝云：“什摩处得心来？”师云：“岂有无心者？”帝云：“那边事作摩生？”师云：“请向那边问。”帝云：“道。”师云：“皇帝要谩众人，则不可。”

问：“大众臻凑，请师举扬。”师云：“更有几人未闻？”学云：“与摩则不假上来。”师云：“不假上来，也且从。汝向什摩处会？”僧云：“若有所在，则辜负和尚。”师云：“只恐不弁精粗。”

师问僧：“才有是非，纷然失心。祖师与摩道，还有过也无？”对云：“不可道无。”师云：“过在于何？”对云：“合与摩道不？”师云：“你只是担枷判事。”师代云：“只为自犯严条。”僧进云：“如何道得，免得此过？”师云：“雨顺风调，极有所济。”

师问僧：“灵利参学，与道伴交肩过，便得一生不喜见，为复宾不喜见主？为复主不喜见宾？”对云：“主不喜见宾。”师喝之。明朝却来云：“宾不喜见主。”师又喝。师代云：“不弁投机，则向宾主分上行。”僧进云：“只如不喜见底人，合到什摩田地？”师云：“药山道底，只是拙钝。”

师问僧曰：“近离什摩处？”对云：“近离莲花。”师云：“古人道：‘不见一相出莲花。’汝既离莲花，何烦更到这里？”对云：“参礼和尚。”师云：“汝是奴缘未尽，见婢殷勤。”师代云：“游山玩水来。”

问：“诸余则不问，请师尽其机。”师云：“不消汝三拜。对众道却。”僧云：“与摩则深领尊慈。”师云：“若是别处，则柱杖到来。”学云：“和尚宁不与摩？”师云：“又是不识痛庠。”

问：“名言妙义，教有所诠。不涉三科，请师指示。”师云：“消汝三拜。”

问：“得旨不存时如何？”师云：“若教更进一步，也是无端。”僧云：“与摩则粥饭随时去也。”师云：“或有人借问汝，汝且作摩生向他道？”僧云：“今日多好雨。”师云：“合吃棒，不合吃棒？”学人礼拜。

问：“机缘不到处，由是成瑕翳。未委和尚如何？”师云：“若问我，我则粥饭僧。”学云：“忽遇人问，作摩生向伊道？”师云：“遇寒则说寒，遇热则说热。”

又时上堂云：“四方来者，从头勘过，勿去处底，竹片痛决。直是道得十成，亦须痛决过。”学人便问：“既是道得十成，和尚为什摩亦劈脊打他？”师云：“不见道：‘一句合头语，万劫系驴橛’？”进云：“与摩则学人更进一步。”师云：“若更进一步，亦是乱走人。”学云：“在和尚与摩道则得。”师云：“若如是，竹片犹是到来。”

又时上堂云：“古人教向未启口已前会取。今日报慈同于古人，为复不同于古人？有明眼汉，出来断看。还有人断得摩？若断不得公当，任你便解放光，亦无用处。虽然如此，我亦未免少分腥膻在。”学人便问：“不啧上来，宗风如何举？”师良久，僧云：“久处沉疴，全因王膳。”师云：“待我肯则得。”

问：“如何是和尚广化？”师云：“非但一人，更有来者，我亦向他道。”学云：“忽有大阐提人来，又作摩生？”师云：“□个还问人摩？”僧云：“故问又作摩生？”师云：“但□□来。”僧云：“则今现来。”师便喝出。

师问僧：“尽□□□不塞人口，作摩生道则塞却人口？”对云：“□□□好喧。”师云：“扶提不扶提？”对云：“未却扶提。”师□：“□语不付前言。”师代云：“和尚吃茶也未？”

有僧辞，师问：“脚根未跨门限，四目相睹，一生更休去。更招人检点，为复不招人检点？汝若道得，我则提囊煎茶送汝。”无对。师以杖趁出法堂云：“这虚生浪死汉！”别僧代云：“亦招人检点。”师云：“过在什摩处？”对云：“一翳又作摩生？”师肯之。

师又问僧：“见处出一切人见，还有过也无？”对云：“官不容针。”师云：“不放过，过在什摩处？”对云：“还与摩也无？”师云：“汝与摩道，还解齐得见处，出一切人见也未？”无对。师云：“大凡行脚人，到处且子细好。”以杖趁出法堂。别僧代第二机云：“犹是今时置得。”

师上堂，众已集，云：“灵药不假多。”僧便出来：“吁吁！”师云：“我则肯你，别有人不肯。”僧云：“只如不肯底人，活业在什摩处？”师云：“吃茶吃饭。”僧云：“只如与摩人，还检点人也无？”师云：“若是与摩人，始解见你病痛。”其僧不肯，师云：“汝虽然如此，我道理在。”

师举佛日见夹山因缘云：“古人道：‘自己尚是怨家，岂况从人？’得与摩判断，堪与人为眼，为复不堪与人为眼？”对云：“虽然如此，犹较些子。”师云：“自己尚是怨家，为什摩道较些子？”对云：“唯有这个见解。”师云：“只如检点底人眼作摩生？”对云：“遇茶则吃茶。”师云：“此人还检点人也无？”对云：“传来则不可。”师云：“未传时作摩生？”无对。师代云：“吃茶吃饭。”

问：“教中有言：‘文殊赞维摩。’维摩还得究竟也无？”师云：“未也，犹是教尽处。”僧云：“究竟作摩生？”师云：“吃茶吃饭。”僧云：“文殊与维摩，还得究竟也无？”师云：“自少出家，粗识好恶。”

师问僧：“吃饭也未？”对云：“吃饭了也。”师云：“宾主二家，阿那个眼目最长？”对云：“请师鉴。”师云：“方木逗于圆孔。”师又问别僧：“这个只对作摩生？”对云：“这个不合与摩只对。”

师云：“阇梨作摩生？”对云：“据某甲所见，两个总是瞎汉。”师云：“只如判断底人，还有眼也无？”对云：“若无眼，争解与摩判断？”师云：“作摩生是此人眼？”对云：“还怪得某甲摩？”师不肯。师代云：“适来与摩判断，还成瞎汉得摩？”

因僧辞次，师问僧：“你到浙中，浙中道伴惜问，语附机而不顾，舌头玄而不参，且作摩生与报慈知音，是汝若为对他？”对云：“终不敢辜负和尚。”师云：“看汝。平生未脱笼在。”师代云：“和尚上堂，则随和尚上堂。”僧云：“还有知音分也无？”师云：“平生被人请益，口似扁担。”

师问僧：“离什摩处？”对云：“离莲花。”“在莲花多少时？”对云：“半月来日。”师云：“古人道：‘灵利参学，与道伴交肩过，便得不喜见。汝既在莲化半月来日，亲得见处作摩生？”对云：“专甲虽在彼中，只是吃粥吃饭。”师云：“好五六百人聚头，吃粥吃饭，为复见处一般，见处别？”对云：“大家担柴则担柴，大家捣米则捣米。”师云：“既然如此，何用行脚？”对云：“天长地阔，有什摩障碍？”师云：“不道你无道理，也须纯熟始得。”

同文节道场，三更时，僧俗俱集于应圣殿前。皇帝问师：“作摩生是纳僧本分事？”对云：“若问本分事，终不别道。”皇帝又问：“还见不？”师云：“是甚摩？”帝再问：“还见不？”对云：“不可更见。”皇帝别问：“如何是一切众生本来心？”师云：“不离当位。”帝云：“其中事如何？”对云：“即心是佛。”皇帝便礼拜。皇帝又别问：“作摩生是诸大师道不得底事？”对云：“臣到这里，缄口则有分。”

别日又于大安殿上，集百寮升殿，及两街僧录，名公大师。皇帝问：“诸佛还有师也无？”对云：“佛佛相传，作摩无师？”皇帝云：“如何是诸佛师？”云：“不过于此。”皇帝云：“大师佛法，亦无穷无尽。”对云：“湛湛亡言，法海之波澜浩瀚，有何穷尽？”皇帝遂礼拜。皇帝又问：“佛何不现？”对云：“佛身充满于法界，普现一切群生前，未尝不现。”时有两街首座，对御问师：“本自圆成，凝然湛寂。和尚对圣人，说个甚摩事？”师云：“汝更听看。”首座云：“那边事作摩生？”师云：“向那边来商量。”

因师说文殊院是报慈主山，僧拈问：“和尚寻常道：‘祖佛向这里出头不得。’为什摩却以文殊为主？”师云：“为他善能按剑。且留与后来。”僧云：“未委按剑时，还存也无？”师云：“拽出著。”

问：“古人道：‘因师故邪，为什摩宗承达摩？”师云：“若见达摩师，向什摩处出头？”因举《花严经》：“普眼菩萨，入三千三味门，觅普贤菩萨不见。”僧便问：“既是定观，为什摩不见？”师云：“只为妄想追求，未晓全真。”僧云：“只如退一步，还得见也无？”师云：“若于进前退后，则对面千里。”僧云：“既然如此，为甚摩举一念想，得见普贤？”师云：“不闻道‘繁兴大用，举必全真’？”

因师看经次，僧便问：“主人道：佛教祖教，如似怨家。’和尚为什摩却看经？”师云：“见若不见，触事何妨？”“与摩则超毗卢去也。”师云：“亦是傍助插嘴。”僧云：“何妨之义，凭何致得？”师云：“为你与摩。”

因僧辞，师问：“六根无用底人，还有行持佛法也无？”对云：“有。”师云：“既是六根无用，于佛法中，作摩生行持？”其僧叉手进前退后，师便喝出，云：“将为是作家，若与摩见知，更须行脚遇人去好。”别僧代良久，师肯之。

祖堂卷十三·龙潭

龙潭和尚嗣保福，在舒州，师号如新。福州福唐县人也。姓林，依灵握院出家。才具尸罗，志慕祖筵，而登保福之门，密契传心之旨。

数年盘泊后，因一日辞保福，出闽，保福云：“汝出岭去，几时却来？”师云：“待世界平宁，则归省觐。”福云：“与摩则与汝个护身符子。”师云：“虽然如此，虑恐有人不肯。”保福深器之。自尔遍游淮海，檀信倾瞻，俯徇人天，匡于禅刹矣。

师有时上堂，良久乃云：“礼烦则乱。”问：“如何是迦叶亲闻底事？”师云：“汝若领得，我则不怪。”学云：“与摩则不烦于师去也。”师云：“又须著棒，争得不烦？”问：“省要处，乞师指示。”师云：“不得说，也听他。”问：“古人道：‘横说竖说，犹未知有向上一关捩子。’如何是向上一关捩子？”师云：“赖遇娘生臂短。”僧问：“如何是祖师意？”师云：“要道有何难？”僧云：“便请师道。”师云：“将谓灵利，又却不先陀。”

师问僧：“古人借君臣父子，汝还信也无？”对云：“今日劳倦，勿心情。”师云：“待明朝，还祗对也无？”对云：“入丛林久矣。”

师癸巳之冬，甲午之春，丁卯之月二十一日，示诲遗诫诸徒，则以子时便当顺寂。住世四十一年，为僧二十五夏。

祖堂卷十三·福先招庆

福先招庆和尚嗣保福，在泉州。师讳省澄，泉州仙游县人也。俗姓阮氏，于彼龙花寺菩提院出家，依年具戒。

先穷律部，精讲上生。酬因虽超于净方，达理宁固于广岸，因而谓云：“我闻禅宗最上，何必扃然而失大理？”遂乃拥毳参寻，初见鼓山、长庆、安国，未凑机缘；以登保福之门，顿息他游之路。

后因一日，保福忽然入殿，见佛乃举手，师便问：“佛举手意作摩生？”保福举手而便掴，保福却问师：“汝道我意作摩生？”师云：“和尚也是横身。”保福云：“这一橛我自插取。”于时而［师］云：“和尚非唯是横身。”福深奇之。寻游吴楚，遍历水云，却旋招庆之筵，坚秘龙溪之旨。后以郡使钦仰，请转法轮，敬奏紫衣，师号净修禅师矣。

师初开堂日，升座，顷间云：“大众向后到别处遇道伴，作摩生举似他？若有举得，试对众举看。若举得，免辜负上祖，亦免埋没后来。古人道：‘通心君子，文外相见’，还有这个摩？况是曹溪门下子孙，合作摩生理论？合作摩生提唱？若欲问，向宗乘中置问来。”时有人始云：“谘和尚。”师云：“白云千里万里。”学云：“承和尚有言：‘向宗乘中置问来’，请和尚答。”师云：“与摩也可在。”问：“昔日觉城东际，象王回旋，今日闽领南方，如何提接？”师云：“会摩？”僧云：“与摩则一机启处，四句难追。未委从上宗乘，成得什摩边事？”师云：“退后礼拜，随众上下。”问：“昔日灵山会，匿王请佛；今日招庆，太尉迎师。人天交接于坐隅，至理愿垂于开演。”师云：“莫屈著者问摩？”僧云：“与摩则慈舟已驾，苦海何忧？”师云：“不敢。”问：“昔日梵王请佛，盖为奉法之心，今日太尉临筵，如何拯济？”师云：“不是不拯济，还肯也无？”学云：“既然如此，今日一会，当为何人？”师云：“不为老兄。”僧云：“为什摩人？”师云：“却为老兄。”问：“九年少室，五叶花开；十载白莲，今日如何垂示？”师云：“遇人作摩生举？”僧云：“与摩则法雨滂沱，群生有赖去也。”师云：“别时与摩道则得。”

师上堂云：“某甲东道西道也得，只是于人无利益。只如达摩大师，梁普通八年到此土来，向少林寺里冷坐地，时人唤作壁观婆罗门，直得九年方始得一人继续。只如他是观音圣人，岂无智辩？可不解说法摩？只如当时分付二祖，是个甚摩意旨？二祖于达摩边承领得个什摩事？还有人举得摩？若有人举得，出来举看；若无人举得，大众侧聆，待某甲为众举当时事。”于时众立辂然，师云：“久立珍重。”

问：“名言妙句，尽是教中之言，真实谤源，请师指示。”师云：“吃茶去。”僧云：“与摩则慧日乾坤朗，有昧悉皆明。”师云：“向后也须更遇作家。”问：“承和尚举古云：‘师坐真金地，常说真实义。回光而照我，令入三摩地。’如何是真实义？”师云：“览老兄此一问。”云：“与摩则不异于当时也。”师云：“说同说异，天与地犹是相近。”

师上堂，临下堂时云：“有人问话者出来。”其时无人问，良久之间，师云：“霜重方知松柏操，事难始见丈夫心。珍重。”师上堂云：“真实离言说，文字别时行。诸上座在教不在教？”又上堂云：“本自圆成，不劳机杼。诸上座出手不出手？”又上堂云：“古人道：‘拟心则差。’招庆道：‘拟心为什摩却成差？’”时有人出来，叉手而立。师肯之。

又上堂示众了，饷时却言：“诸上座看后莫看前，珍重。”问：“南泉道：‘三世诸佛不知有，狸奴白牯却知有。’只如三世诸佛，为什摩不知有？”师云：“只为慈悲利物。”僧云：“狸奴白牯为什摩却知有？”师云：“唯思水草，别也无求。”僧云：“未审南泉还知有也无？”师云：“知幻则离。”问：“才施三寸，尽落途中；不落途中，请师指示。”师云：“适来岂不是捣米归？”“与摩则不虚申此问也。”师云：“今日是真正。”问：“不啧非次，如何是和尚家风？”师云：“一瓶兼一钵，到处是生涯。”僧云：“与摩则后学之流皆承覆廕。”师云：“随众上下。”又上堂于时云：“大家识取混仑，莫识取劈破。竺土大仙心，东西密相付。是混仑？是劈破？”时有人便（问）：“承师有言：‘大家识取混仑，莫识取劈破。’如何是混仑？”师良久。问：“如何是劈破底？”师云：“只这个是。”僧问：“古人道：‘服像虽殊，妙机不二。’如何是不二底妙机？”师云：“你试分看。”僧云：“已蒙师指，如何保任？”师云：“适来作摩生会？”僧云：“是什摩？”师云：“若与摩则著衣吃饭。”问：“尽令提钢，末免受人检点。到别处有人相借访，如何知音？”师云：“茶饭延时。”僧云：“与摩则拈掇无功去也。”师云：“府庭过岁，春间却来。”问：“如何是佛法大意？”师云：“扰扰匆匆，晨鸡暮锺。”问：“从上宗承，如何举唱？”师云：“无老兄扫地又争得？”问：“全身振视，为什摩道犹执瓦砾？”师云：“你还有眼不？”僧云：“若不与摩问，争委得当时事？”师云：“汝道思和尚见知作摩生？”僧进前叉手，师云：“莫辜负思和尚。”僧云：“思和尚宁不与摩？”师云：“众眼难谩。”问：“温白［伯］夫子相见则且置，和尚作摩生相见？”师云：“嘎。”僧云：“若不是学人，招得和尚怪笑。”师云：“汝适来问什摩？”学人礼拜，师云：“虾跳不出斗，是汝不会。”

师有颂曰：

佛日冲天闲雾开，觉城东际象王回。

善财五众承当得，锾子虽逢似不来。

问：“巧妙之说，又涉三寸，不啧上来，若为指示。”师云：“我不责你上来。”僧云：“深须尊慈，师意如何？”师云：“我则且置，汝适来作摩生？”学人礼拜，师云：“我适来龙头蛇尾，是汝不知。”

师有颂曰：

大士梁天请讲开，始登莲座蹑梯回。

皇情未晓志公说，大士金刚已请来。

问：“普贤心洞晓，何不获圆通？”师云：“因地修心闻力大，初心争可得圆通？”僧云：“与摩则格高难凑泊，门普易相应。”

师有时颂曰：

吴坂当年塔未开，宋云葱岭见师回。

手携只履分明个，后代如何密荐来？

问：“未审和尚法嗣何人？”师云：“漳水深沉，宁穷浪底？”云：“与摩则龙溪一派，晋水分流。”师云：“甘言道薄，何置饰词？”问：“如何是古佛？”师云：“无金色。”僧又问：“如何是今佛？”师云：“带笑容。”僧云：“未审古佛与今佛还分也无？”师云：“向汝道：‘无金色，带笑容。’”僧云：“说古说今，因学人置得，和尚如何？”师云：“阳和布令，万物唯新。”府主太尉问：“僧众已蒙师指示，弟子进步，乞和尚垂慈悲。”师云：“太尉既进步，招庆不可不祗接。”“弟子常笼日久，军府事多不会，乞师方便。”师云：“太尉适来道进步，招庆道不可不祗接，太尉还会摩？”太尉设礼而退。问：“如何是般若？”师云：“是什摩？”僧云：“与摩则因师委得去也。”师云：“委得底事作摩生？”学云：“遇茶吃茶。”师云：“太深也。”

祖堂卷十三·山谷

山谷和尚嗣保福，在舒州三祖塔住。师讳行崇，福州长溪县人也。俗姓郑氏，于彼慈云出家具戒。

至于经论，无不博通。律部精严，长讲百法。久在浙江，后闻保福匡徒化盛，乃拥毳抠衣，密传心印。漳州太尉钦仰道风，请匡禅苑，敬奏紫衣，敷扬佛事。寻离漳浦，远届皇都，叠捧天恩，赐于山谷矣。

师初开堂时，僧问：“不责非次，乞师全示。”云：“若教全示，更是阿谁？”又时上堂云：“虽不在，未尝不为诸兄弟。若委报恩常为人处，许汝出意想知解五阴身田。若不委得，犹待报恩开者两片皮，方是为人，保汝未解出得意想知解。所以古人唤作鬼家之活计，虾蟆衣下客。汝欲得速疾相应，只如今立地便验取识取，有什摩罪过？不然，根思迟回，且须以日及夜，究竟将去。忽然一日觑见，更莫以少为足，更解研穷究竟，乃至屠坊酒肆，若[角*牛]若净，若好若恶。以汝所见事，觑尽教是，此境界入如入律。若更见一法，如丝发许，不是此个事。我说为无明翳障，直须不见有一法是别底法，方得圆备。到这里，更能翻掷自由，开合不成痕缝。如水入水，如火入火，如风入风，如空入空。若能如是，直下提一口剑，刺断天下人疑网，一如不作相似。所以，古人道：‘繁兴大用，起必全真。’若有一个汉到与摩境界，谁敢向汝面前，说是说非？何以故？此人是个汉，超诸限量，透出因果。一切处管束此人不得。兄弟若能如是，则不可。未得如此，直须好与，莫取次发言吐气，沉坠却汝无量劫。莫到与摩时，便道报恩不道。珍重。”

问：“不涉公私，如何言论？”云：“吃茶去。”问：“丹霞烧木佛，意作摩生？”云：“时寒烧向火。”“翠微递罗汉意作摩生？”云：“别是一家春。”问：“如何是佛法大意？”云：“碓捣磨磨。”问：“曹溪一路，请师举扬。”云：“莫屈著曹溪摩。”“与摩则群生有赖？”云：“汝也是老鼠吃盐。”


祖堂集卷十四

祖堂卷十四·马祖

江西马祖嗣让禅师，在江西。师讳道一，汉州十方县人也。姓马，于罗汉寺出家。

自让开心眼，来化南昌。每谓众曰：“汝今各信自心是佛，此心即是佛心。是故达摩大师从南天竺国来，传上乘一心之法，令汝开悟。又数引《楞伽经》文以印众生心地，恐汝颠倒不自信。此一心之法，各各有之，故《楞伽经》云：‘佛语心为宗，无门为法门。’又云：‘夫求法者，应无所求。心外无别佛，佛外无别心。不取善，不舍恶，净秽两边，俱不依怙。达罪性空，念念不可得，无自性故，三界唯心，森罗万像，一法之所印。凡所见色，皆是见心。心不自心，因色故有心。’汝可随时言说，即事即理，都无所碍。菩提道果，亦复如是。于心所生，即名为色。知色空故，生即不生。若体此意，但可随时著衣吃饭，长养圣胎，任运过时。更有何事？汝受吾教。听吾偈曰：

心地随时说，菩提亦只宁。

事理俱无碍，当生则不生。

有洪州城大安寺主，讲经讲论。座主只观诽谤马祖。有一日，夜三更时，鬼使来惜门。寺主云：“是什摩人？”对云：“鬼使来取寺主。”寺主云：“启鬼使：某甲今年得六十七岁，四十年讲经讲论，为众成持。只观贪讲经论，未得修行。且乞一日一夜，还得也无？”鬼使云：“四十年来贪讲经论，不得修行，如今更修行作什摩？临渴掘井有什摩交涉？寺主适来道：‘只观贪讲经论，为众成持。’无有是处。何以故？教有明文：‘自得度令他得度，自解脱令他解脱，自调伏令他调伏，自寂静令他寂静，自安隐令他安隐，自离垢令他离垢，自清净令他清净，自涅盘令他涅盘，自快乐令他快乐。’是汝自身尚乃未得恬静，何能令他道业成持？汝不见金刚藏菩萨告解脱月菩萨言：‘我当自修正行，亦劝于他，令修正行。’何以故？若自不能修行正行，令他修者，无有是处。汝将生死不净之心，口头取办，错传佛教，诳唬凡情。因此彼王嗔汝，教我取去彼中，便入刀树地狱，断汝舌根，终不得免。汝不见佛语：‘言词所说法，小智妄分别。是故生障碍，不了于自心。不能了自心，云何知正道？彼由颠倒慧，增长一切恶。’汝四十年来作口业，不入地狱作什摩？古教自有明文：‘言语说诸法，不能现实相。’汝将妄心，以口乱说，所以必受罪报。但啧自嫌，莫怨别人。如今速行，若也迟晚，彼王嗔吾。”其第二鬼使云：“彼王早知如是次第，何妨与他修行。”其第一鬼使云：“若与摩，则放一日修行。某等去彼中，谘白彼王。王若许，明日便来；王若不许，一饷时来。”

其鬼使去后，寺主商量：“这个事鬼使则设了也，某甲一日作摩生修行？”无可计，不待天明便去开元寺惜门。门士云：“是什摩人？”对云：“太安寺主来起居大师。”门士便开门，寺主便去和尚处，具陈前事后，五体投地礼拜，起云：“生死到来，作摩生即是？乞和尚慈悲，救某甲残命。”师教他身边立地。

天明了，其鬼使来太安寺里，讨主不见。又来开元寺，觅不得，转去也。师与寺主即见鬼使，鬼使即不见师与寺主也。僧拈问龙华：“只如寺主当时向什摩处去，鬼使见不得？”花云：“牛头和尚。”僧云：“与摩则国师当时也太奇。”龙花曰：“南泉和尚。”

有一日斋后，忽然有一个僧来，具威仪，便上法堂参师。师问：“昨夜在什摩处？”对曰：“在山下。”师曰：“吃饭也未？”对曰：“未吃饭。”师曰：“去库头觅吃饭。”其僧应略，便去库头。当时百丈造典座，却自个分饭与他供养。其僧吃饭了便去。百丈上法堂。师问：“适来有一个僧未得吃饭，汝供养得摩？”对曰：“供养了。”师曰：“汝向后无量大福德人。”对曰：“和尚作摩生与摩说？”师曰：“此是辟支弗僧，所以与摩说。”进问：“和尚是凡人，作摩生受他辟支弗礼？”师云：“神通变化则得。若是说一句佛法，他不如老僧。”

师有一日上禅床，才与摩坐便氵夷唾。侍者便问：“和尚适来因什摩氵夷唾？”师云：“老僧在这里坐，山河大地，森萝万像，总在这里，所以嫌他，与摩唾。”侍者云：“此是好事。和尚为什摩却嫌？”师云：“于汝则好，于我则嫌。”侍者云：“此是什摩人境界？”师云：“此是菩萨人境界。”后鼓山举此因缘云：“古人则与摩。是你诸人，菩萨境界尚未得，又故则嫌他菩萨。虽则是嫌，但以先证得菩萨之位，后嫌也嫌。老僧未解得菩萨之位，作摩生嫌他这个事？”

有西川黄三郎，教两个兒子投马祖出家。有一年，却归屋里，大人才见两僧，生佛一般礼拜，云：“古人道：‘生我者父母，成我者朋友。’是你两个僧便是某甲朋友，成持老人。”曰：“大人虽则年老，若有此心，有什摩难？”大人欢喜，从此便居士，相共男僧，便到马祖处，其僧具陈来旨，大师便上法堂。黄三郎到法堂前，师曰：“咄！西川黄三郎岂不是？”对曰：“不敢。”师曰：“从西川到这里，黄三郎如今在西川？在洪州？”云：“家无二主，国无二王。”师曰：“年几？”云：“八十五。”“虽则与摩，算什摩年岁？”云：“若不遇和尚，虚过一生；见师后，如刀划空。”师曰：“若实如此，随处任真。”

黄三郎有一日到大安寺庙下便啼哭，亮座主问：“有什摩事啼哭？”三郎曰：“啼哭座主。”座主云：“哭某等作摩？”三郎曰：“还闻道黄三郎投马祖出家，才蒙指示便契合，汝等座主说葛藤作什摩？”座主从此发心，便到开元寺。门士报大师曰：“大安寺亮座主来，欲得参大师，兼问佛法。”大师便升座。座主未参大师，大师问：“见说座主讲得六十本经论，是不？”对云：“不敢。”师云：“作摩生讲？”对云：“以心讲。”师云：“未解讲得经论在。”座主云：”作摩生？”云：“心如工技兒，意如和技者，争解讲得经论在？”座主云：“心既讲不得，将虚空还讲得摩？”师云：“虚空却讲得。”座主不在意，便出。才下阶大悟，回来礼谢。师云：“钝根阿师，礼拜作什摩？”亮座主起来，雨/脉雨/沐汗流。昼夜六日，在大师身边侍立。后谘白云：“某甲离和尚左右，自看省路修行。唯愿和尚久住世间，广度群生，伏惟珍重。”座主归寺，告众云：“某甲一生功夫，将谓无人过得。今日之下，被马大师可啧，直得情尽。”便散却学徒。一入西山，更无消息。座主偈曰：

三十年来作饿鬼，如今始得复人身。

青山自有孤云伴，童子从他事别人。

漳南拈问僧：“虚空讲经，什摩人为听众？”对云：“适来暂随喜去来。”漳南云：“是什摩义？”云：“若是别人，便教收取。”漳南曰：“汝也是把火之意。”师上堂良久，百丈收却面前席，师便下堂。

问：“如何是佛法旨趣？”师云：“正是你放身命处。”问：“请和尚离四句绝百非，直指西来意，不烦多说。”师云：“我今日无心情，不能为汝说。汝去西堂，问取智藏。”其僧去西堂，具陈前问。西堂云：“汝何不问和尚？”僧云：“和尚教某甲来问上座。”西堂便以手点头，云：“我今日可杀头痛，不能为汝说，汝去问取海师兄。”其僧又去百丈，乃陈前问。百丈云：“某甲到这里却不会。”其僧却里似师，师云：“藏头白，海头黑。”师遣人送书到先径山钦和尚处，书中只画圆相。径山才见，以笔于圆相中与一划。有人举似忠国师，忠国师云：“钦师又被马师惑。”有人于师前作四划，上一划长，下三划短，云：“不得道一长，不得道三短，离此四句外，请师答某甲。”师乃作一划，云：“不得道长，不得道短，答汝了也。”忠国师闻举，别答云：“何不问某甲？”

有座主问师：“禅宗传持何法？”师却问：“座主传持何法？”对曰：“讲得四十本经论。”师云：“莫是师子兒不？”座主云：“不敢。”师作嘘嘘声。座主云：“此亦是法。”师云：“是什摩法？”对云：“师子出窟法。”师乃嘿然。座主云：“此亦是法。”师云：“是什摩法？”对云：“师子在窟法。”师云：“不出不入，是什摩法？”座主无对，遂辞出门。师召云：“座主。”座主应喏，师云：“是什摩？”座主无对，师呵云：“这钝根阿师！”后百丈代云：“见摩？”师问僧：“从什摩处来？”对云：“从淮南来。”师云：“东湖水满也未？”对云：“未。”师云：“如许多时雨，水尚未满！”道吾云：“满也。”云岩云：“湛湛底。”洞山云：“什摩劫中曾欠少来？”

师明晨迁化，今日晚际，院主问：“和尚四体违和，近日如何？”师曰：“日面佛，月面佛。”

汾州和尚为座主时，讲四十二本经论，来问师：“三乘十二分教，某甲粗知，未审宗门中意旨如何？”师乃顾示云：“左右人多，且去。”汾州出门，脚才跨门阆，师召座主，汾州回头应喏。师云：“是什摩？”汾州当时便省，遂礼拜，起来，云：“某甲讲四十二本经论，将谓无人过得。今日若不遇和尚，洎合空过一生。”师问百丈：“汝以何法示人？”百丈竖起拂子对。师云：“只这个？为当别更有？”百丈抛下拂子。僧拈问石门：“一语之中便占马大师两意，请和尚道。”石门拈起拂子，云：“寻常抑不得已。”

大师下亲承弟子总八十八人出现于世，及隐道者莫知其数。大师志性慈愍，容相瑰奇，足下二轮，颈有三约。说法住世四十余年，玄徒千有余众。师贞元四年戊辰岁二月一日迁化，塔在泐潭宝峰山，敕谥大寂禅师大庄严之塔。裴相书额，左承相护得兴撰碑文，净修禅师颂曰：

马师道一，行全金石。

梧本超然，寻枝劳役。

久定身心，一时抛掷。

大化南昌，寒松千尺。

祖堂卷十四·大珠

大珠和尚嗣马大师，在越州。师讳慧海，建州人也。

师谓众曰：“汝心是佛，不用将佛求佛。汝心是法，不用将法求法。佛法和合为僧体，唤作一体三宝。经云：‘心佛及众生，是三无差别。’身口意业清净，名为佛出世。三业不净，名为佛灭度。喻如嗔时无喜，喜时无嗔。唯是一心，用无二体。本智法津尔，无漏现前。如蛇化为龙，不改其鳞。众生回心作佛，不改其面。性本清净，不待修成。有证有求，即同增上慢。真空无滞，应用无时。无始无终，利根先悟。用无等等，即是阿耨菩提。性无形相，即是微妙色身。无相即是实相，性体本空，则是无边法身。万行庄严具，即是功德法身，即是万化之本。随处立名，智用无尽，即是无尽藏。能生万法，是大法藏。具一切智，是智慧藏。万法同如，是如来藏。经云：‘如来者，则诸法如义。’一切世间生灭法，无有一法不归如。”

有王长史问：“法师、律师、禅师，阿那个最胜？”师云：“法师者，居师子座。泻县河之辩，对稠人匡众。启凿玄关，开般若之妙门，等三轮之空际，若非龙象蹴踏，安敢当人？律师者，启毗尼之法藏，名利双行，持犯开遮，威仪作则。叠三翻之羯摩，作四果之初因，若非宿德白眉，安敢造次？禅师者，扬其枢要，直了心源，出没卷舒，纵横应物，咸均事理。顿见如来，拔生死之深根，得现前之三昧。若不安禅静虑，到者里总须茫然。”

有座主问：“某甲拟问禅师义，得不？”师曰：“清潭月影，任意撮摩。”“如何是佛？”师曰：“清潭对面，非佛而谁？”座主茫然。却问：“禅师说何法度人？”师云：“未曾有法。”座主云：“禅师浑如此。”

师却问：“法师说何法？”对云：“讲《金刚经》二十余座。”师曰：“《金刚经》是谁说？”对云：“禅师。”“岂不知是佛说？”师云：“若言如来有所说法，则为谤佛。是人不能解我所说义。若言经不是佛说，即为谤经。离此之外，为老僧说。”法师无对。

师云：“其义且置。经云：‘若以二十二相观如来者，转轮圣王即是如来。’又云：‘若以色见我’，乃至‘不能见如来。’经且置，待小时徵大德，且道那个是如来？”对云：“到这里却迷去。”师呵云：“讲经二十余座，浑不识如来。”师云：“如来者则诸法如义，大德那得不知？”法师云：“若如是，则一切皆如。”师云：“未是未是。”师云：“经作此说，那得不是？”师云：“法师如不？”对云：“如。”师云：“木石如不？”对曰：“如。”师又云：“汝木石如不？”对曰：“无二如。”师云：“与摩则大德共草木何别？”法师无对。乃叹曰：“此上人极难酬对。”

时有俗官问：“法师何故不信禅法？”师云：“名相易解，至理难见。”有行者问：“即心即佛，那个是佛？”师云：“汝疑那个不是？指出看。”行者无对。师云：“达则遍境是，不悟则永乖疏。”

华严座主数人问：“禅师何不许‘青青翠竹是法身，郁郁黄花是般若’？”师曰：“法身无像，对翠竹以成形；般若无知，对黄花而现相。非彼黄花翠竹，而有般若法身乎？经云：‘佛真法身犹若虚空，应物现形，如水中月。黄花若是般若，般若则同无情。翠竹若是法身，翠竹还同应物不？”大德数人，杜口无言。

祖堂卷十四·百丈政

百丈政和尚嗣马大师，在江西。未睹行录，不决化缘始终。

师向僧道：“汝与我开田了，为汝说大义。”僧云：“开田了，请师说大义。”师乃展开两手。

有老清见日影透过窗，问：“为复窗就日，为复日就窗？”师云：“长老房内有客，且归去好。”

祖堂卷十四·杉山

杉山和尚嗣马大师，在池州。师讳智坚，未睹实录，不决化缘始终。

云岩见月，问师：“太好月。”师云：“还照也无？”云岩低却头。

师在南泉，造第一座。南泉收生次，云：“生。”师云：“无生。”泉云：“无生犹是末。”南泉行五六步，师召云：“长老。”南泉回头云：“作摩？”师云：“莫道是末。”

后有人拈问顺德：“南泉道‘生’意作摩生？”顺德云：“急水行舟。”杉山道：“无生意作摩生？”德云：“风若不来，树亦不动。”“无生犹是末意作摩生？”德云：“磨锋捺刃，汝且作摩生回避？”“唤南泉意作摩生？”德云：“要举胜今。”“别旋行持，南泉回头意作摩生？”德云：“象王回旋，师子曩呻。”“莫道是未意作摩生？”德云：“妙个出身，古今罕有。”

安国拈问明上座：“古人当无生，不当无生？”对曰：“不当无生。”安国云：“杉山意作摩生？”明上座无对。明真大师代云：“汝试举看。”

师与南泉向火次，南泉问师：“不用指东指西，本分事直下道将来。”师便把火箸放下。南泉云：“饶你与摩，犹较王老师一线道。”南泉又问赵州，赵州以手作圆相，中心一点。泉云：“饶你与摩，犹较王老师一线道。”

云门闻举云：“南泉只是步步登高，不解空里放下。”问：“如何是本来身？”师云：“举世不相似。”师提起蕨菜，问南泉：“这个太好供善。”南泉云：“非但这个，百味珍羞，他亦不顾。”师云：“虽然如此，个个总须偿［尝］他始得。”

祖堂卷十四·茗溪

茗溪和尚嗣马大师。未睹行录，不决化缘始终。

问：“如何是修行路？”师云：“好个阿师，莫作客。”僧云：“毕竟如何？”师云：“安置则不敢。”

师有时云：“吾有大病，非世所医。”有人问先曹山：“古人有言：‘吾有大病，非世所医。’未审唤作什摩病？”曹山云：“攒簇不得底病。”僧云：“一切众生，还有此病也无？”曹山云：“人人尽有。”僧云：“一切众生，为什摩不病？”山云：“众生若病，则非众生。”僧云：“和尚还有此病也无？”山云：“正觅起处不可得。”僧云：“未审诸佛还有此病也无？”山云：“有。”进曰：“既有，为什摩不病？”山云：“为伊惺惺。”

问：“如何是正修行路？”师云：“涅盘后有。”僧云：“如何是涅盘后有？”师云：“无洗面。”僧云：“学人不会。”师云：“无面可洗。”

祖堂卷十四·石巩

石巩和尚嗣马大师，在抚州。师讳慧藏。

未出家时，趁鹿从马大师庵前过，问和尚：“还见我鹿过摩？”马大师云：“汝是什摩人？”对云：“我是猎兒。”马师云：“汝解射不？”对云：“解射。”’马师云：“一箭射几个？”对曰：“一箭射一个。”马师云：“汝浑不解射。”进曰：“和尚莫是解射不？”马师云：“我解射。”进曰：“一箭射几个？”师云：“一箭射一群。”师云：“彼此生命，何得射他？”师云：“汝既知如此，何不自射？”师曰：“若教某甲自射，无下手处。”师云：“者汉无明烦恼一时顿消。”师当时拗折弓箭，将刀截发，投师出家。

师后因一日在厨作务次，马师问：“作什摩？”对云：“牧牛。”马师曰：“作摩生牧？”对曰：“一回入草去，便把鼻孔拽来。”马师云：“子真牧牛。”

师问西堂：“你还解捉得虚空摩？”西堂云：“捉得。”师云：“作摩生捉？”西堂以手捉虚空势。”师云：“与摩作摩生捉得虚空？”西堂却问师：“作摩生捉？”师便把西堂鼻孔拽著。西堂作忍痛声云：“太杀拽人鼻孔，直得脱去！”师曰：“直须与摩捉他虚空始得。”

有时僧参次，师云：“适来什摩处去来？”对云：“在。”师曰：“在什摩处？”僧弹指而对。有僧礼拜师，师云：“从什摩处来？”对曰：“某处来。”师云：“还将得那个来摩？”对云：“将得来。”师云：“在什摩处？”僧弹指两三下。

三平和尚参师，师架起弓箭，叫云：“看箭！”三平擗开胸受。师便抛下弓箭云：“三十年在者里，今日射得半个圣人。”三平住持后云：“登时将谓得便宜，如今看却输便宜。”

石门拈问明真：“作摩生道即得免被唤作半个圣人？”明真便喝云：“这野狐精！”石门云：“委得也，莫弄好手。”

师有《弄珠吟》，曰：

落落明珠耀百千，森萝万像镜中悬。

光透三千越大千，四生六类一灵源。

凡圣闻珠谁不羡？瞥起心求浑不见。

对面看珠不识珠，寻珠逐物当时变。

千般万般况珠喻，珠离百非超四句。

只这珠生是不生，非为无生珠始住。

如意珠，大圆镜，亦有人中唤作性。

分身百亿我珠分，无始本净如今净。

日用真珠是佛陀，何劳逐物浪波波。

隐现则今无二相，对面看珠识得摩？

祖堂卷十四·紫玉

紫玉和尚嗣马大师，在襄阳。师讳道通。未睹实录，不决生缘。

襄阳廉师于迪相公，处分界内，凡有行脚僧捉送，无有一僧得命便杀。如是得无数。师闻此消息，欲得去相公处，众中觅人随师，近有十来人。师领十人，恰到界首，十人怕，不敢进，师犹自入界内。

军人见师来，便捉，著枷送上。师著枷到门外，著纳衣便上。相公按剑大坐，便云：“咄！这阿师，还知道襄阳节度使，斩斫自由摩？”师云：“还知道法王不惧生死摩？”相公云：“和尚头边还有耳摩？”师云：“眉目无障碍。贫道与相公相见，有何障碍？”相公便抛却剑，著公衣服，便礼拜问：“承教中有言：‘黑风吹其船舫，漂堕罗刹鬼国。’此意如何？”师便唤于迪，相公颜色变异。师曰：“罗刹鬼国不远在。”又问：“如何是佛？”师唤于迪，相公应喏。师云：“更莫别求。”相公言下大悟，便礼为师。

有人举似药山，药山云：“缚杀者个漠。”僧便问：“和尚如何？”药山云：“是什摩？”僧问：“如何出三界？”师云：“你在里许多少时？”僧云：“如何得出离去？”师云：“青山不碍白云飞。”

祖堂卷十四·南源

南源和尚嗣马大师，在袁州。师讳道明。

洞山初到南源，便上法堂次。师才望见洞山，便云：“已相见了也，不用更上来。”洞山便归堂。

又去和尚处，便问：“适来道已相见了也，什摩处是与某甲相见处？”师云：“心心不间断，流入于性海。”洞山云：“洎错放过。”

洞山五日后辞师，师云：“有事嘱阇梨得摩？”洞山便礼拜云：“有什麽事？”师云：“多学佛法，广作利益。”洞山问：“多学佛法即不问，如何是广作利益？”师云：“一物也不为即是。”洞山便住两年矣。

祖堂卷十四·百丈

百丈和尚嗣马大师，在江西。师讳怀海，福州长乐县人也，姓黄。

童年之时，随母亲入寺礼佛，指尊像问母：“此是何物？”母云：“此是佛。”子云：“形容似人，不异于我。后亦当作焉。”自后为僧。志慕上乘，直造大寂法会。大寂一见，延之入室。师密契言关，更无他往。

师平生苦节高行，难以喻言。凡日给执劳，必先于众。主事不忍，密收作具，而请息焉。师云：“吾无德，争合劳于人？”师遍求作具，既不获，而亦忘喰。故有“一日不作，一日不食”之言，流播寰宇矣。

有僧人哭入法堂，师云：“作摩，作摩？”僧对曰：“父母俱丧，请师择日。”师云：“且去，明日来一时埋却。”师谓众曰：“我要一人传语西堂，阿谁去得？”五峰对云：“某甲去。”师云：“作摩生传语？”对云：“待见西堂即道。”师云：“道什摩？”对云：“却来说似和尚。”

师见沩山。因夜深来参次，师云：“你与我拨开火。”沩山云：“无火。”师云：“我适来见有。”自起来拨开。见一星火，夹起来云：“这个不是火是什摩？”沩山便悟。

师与沩山作务次，师问：“有火也无？”对云：“有。”师云：“在什摩处？”沩山把一枝木，吹两三下，过与师。师云：“如虫喰木。”问：“如何是佛？”师云：“汝是阿谁？”对云：“某甲”。师云：“汝识某甲不？”对云：“分明个。”师竖起拂子云：“汝见拂子不？”对曰：“见。”师便不语。

有一日，普请次。有一僧忽闻鼓声，失声大笑，便归寺。师曰：“俊哉俊哉！此是观音入理之门。”师问其僧：“适来见什摩道理，即便大笑？”僧对曰：“某甲适来闻鼓声动，得归吃饭，所以大笑。”师便休。

长庆代曰：“也是因斋庆赞。”问：“‘依经解义，三世佛怨。离经一宇，即同魔说。’如何？”师云：“固守动用，三世佛怨。此外别求，即同魔作。”僧问西堂：“有问有答则不同，不问不答时如何？”答曰：“怕烂却那，作摩？”师闻举云：“从来疑这个老汉。”

僧云：“请师道。”师云：“一合相不可得。”师教僧去章敬和尚处，见他上堂说法次，礼拜起来，收他一只履，以抽拂上尘，倒头覆下。其僧去到，一一依前师指。章敬云：“老僧罪过。”

师行脚时，到善劝寺。欲得看经，寺主不许，云：“禅僧衣服不得净洁，恐怕污却经典。”师求看经志切，寺主便许。师看经了，便去大雄山出世。出世后，供养主僧到善劝寺，相看寺主。寺主问：“离什摩处？”对曰：“离大雄山。”寺主问：“有什摩人住？”对曰：“恰似和尚行脚时，在当寺看经。”寺主曰：“莫是海上座摩？”对曰：“是也。”寺主便合掌：“某甲实是凡夫，当时不识他人天善知识。”又问：“来这里，为个什摩事？”对曰：“著疏。”

寺主自行疏，教化一切了，供养主相共上百丈。师委得这个消息，便下山来，迎接归山。一切了后，请寺主上禅状：“某甲有一段事，要问寺主。”寺主推不得，便升座。师问寺主：“正讲时作摩生？”主云：“如金盘上弄珠。”师云：“拈却金盘时，珠在什摩处？”寺主无对。又问：“教中道：‘了了见佛性，犹如文殊等。’既是了了见佛性，合等于佛，为什摩却等文珠？”又无对。因此便被纳学禅，号为“涅盘和尚”，便是第二百丈也。

师有一日深夜睡次，忽然便觉，欲得吃汤。然侍者亦是睡，唤不得。非久之间，有人敲门，唤侍者云：“和尚要吃汤。”侍者便起。煎汤来和尚处，和尚便惊问：“阿谁教你与摩煎汤来？”侍者具陈前事，师便弹指云：“老僧终不解修行。若是解修行人，人不觉，鬼不知。今日之下，被土地觑见我心识，造与摩次第。”师见云岩，便提起五指云：“何个而也？”云岩云：“非也。”师云：“岂然乎？”

师有一日法堂里坐，直到四更。当时侍者便是云岩和尚也。三度来和尚身边侍立，第三度来，和尚蓦底失声便唾。侍者便问：“和尚适来有什摩事唾？”师云：“不是你境界。”侍者云：“启师：某甲是和尚侍者。若不为某甲说，为什摩人说？”师云：“不用问，不是你问底事，兼不是老僧说底事。”侍者云：“启师：百年后要知，乞和尚慈悲。”师云：“苦杀人，老汉未造人在。适来忽然忆著菩提涅盘，所以与摩唾。”侍者云：“启师：若也如此，如许多时，因什摩说菩提涅盘了义不了义？”师云：“分付不著人，所以向你道，不是你问底事，兼不是你境界。”师垂语云：“并却咽喉脣吻，速道将来。”有人云：“学人道不得，却请师道。”师曰：“我不辞向你道，已后欺我兒孙。”云岩对曰：“师今有也。”师便失声云：“丧我兒孙。”师垂语云：“见河能漂香象。”僧便问：“师见不？”师云：“见。”僧云：“见后如何？”师云：“见见无二。”僧云：“既言见见无二，不以见见于见。若见更见，为前见为后见？”师云：“见见之时，见非是见。见犹离见，见不能及。”师垂语云：“古人举一手竖一指，是禅是道？此语击缚人，无有住时。假饶不说，亦有口过。宦上座拈问翠岩：“既不说，为什摩却有口过？”翠岩云：“只为不说。”宦上座便[扌*首*或]。隔两日，翠岩却问宦上座：“前日与摩祗对，不称上座意旨，便请上座不舍慈悲，曲垂方便。既不说，为什摩却有口过？”上座举起手，翠岩五体投地礼拜，出声啼哭。

师教侍者问第一座：“实际理地，不受一尘。佛事门中，不舍一法。是了义教里收，是不了义教里收？”第一座云：“是了义教里收。”侍者却来，举似和尚。和尚便打侍者，趁出院。问：“如何是大乘入道顿悟法？”师答曰：“汝先歇诸缘，休息万事。善与不善，世间一切诸法，并皆放却，莫记忆，莫缘念，放舍身心，令其自在。心如木石，口无所辩，心无所行，心地若空，慧日自现，犹如云开日出相似。俱歇一切攀缘，贪嗔爱取，垢净情尽。对五欲八风，不被见闻觉知所缚，不被诸境惑。自然具足神通妙用。是解脱人，对一切境，心无静乱，不摄不散。透一切声色，无有滞碍。名为道人，但不被一切善恶垢净，有为世间福智拘系，即名为佛慧。是非好丑，是理非理，诸知见总尽，不被系缚。处处自在，名为初发心菩萨，便登佛地。一切诸法，本不自言。空不自言，色亦不言。是非垢净，亦无心系缚人。但人自虚妄计著，作若干种解，起若干种知见。若垢净心尽，不住系缚，不住解脱，无一切有为无为解。平等心量，处于生死，其心自在。毕竟不与虚幻尘劳，蕴界生死诸入和合，迥然无寄。一切不拘，去留无碍。往来生死，如门开合相似。若遇种种苦乐，不称意事，心无退屈，不念名闻衣食，不贪一切功德利益，不与世法之所滞。心虽亲爱苦乐，不干于怀。粗食接命，补衣寒暑，兀兀如愚如聋相似。稍有相亲分，于生死中，广学知解，求福求智，于理无益。却被知解境风漂却，归生死海里。佛是无求人，求之则乖。理是无求理，求之则失。若取于无求，复同于有求。此法无实亦无虚，若能一生心如木石相似，不为阴界五欲八风之所漂溺，则生死因断，去住自由。不为一切有为因果所缚。他时还与无缚身同利物，以无缚心应一切。以无缚慧解一切缚，亦能应病与药。

问：“如今受戒，身口清净，已具诸善，得解脱不？”师答曰：“小分解脱，未得心解脱，未得一切解脱。”问：“如何是心解脱？”师答曰：“不求佛，不求知解。垢净情尽，亦不守此无求为是，亦不住尽处，亦不畏地狱缚，不爱天堂乐。一切法不拘，始名为解脱无碍。即身心及一切，皆名解脱。汝莫言，有小分戒，善将为便了。有恆沙无漏戒定慧门，都未涉一毫在。努力猛作早与，莫待耳聋眼暗，头白面皮皱，老苦及身，眼中流泪，心中慞惶，未有去处。到与摩时，整理脚手不得，纵有福智多闻，都不相救。为心眼未开，唯缘念诸境，不知返照，复不见道：一生所有恶业，悉现于前。或忻或怖，六道五蕴现前。尽见严好。舍□舟船车辇。光明现赫为纵自心贪爱，所见悉变为好境，随所见重处受生，都无自由分。龙畜良贱，亦总未定。”

问：“如何得自由？”师答曰：“如今对五欲八风，情无取舍。垢净俱亡，如日月在空，不缘而照。心如木石，亦如香象截流而过，更无疑滞。此人天堂地狱不能摄也。又云：“读经看教语言，皆须宛转归就自己。但是一切言教，只明如今鉴觉性，自己但不被一切有无诸境转，是故导师，能照破一切有无境，法是金刚，即有自由独立分。若不能任摩得，纵今诵得《十二围陀经》，只成增上慢，却是谤佛，不是修行。读经看教，若准世间是好善事，若向理明人边数，此是壅塞人。十地之人不脱去，流入生死河，但不用求觅知解语义句。知解属贪，贪变成病，只如今俱离一切有无诸法，透过三句外，自然与佛无差。既自是佛，何虑佛不解语？只恐不是佛，被有无诸法转，不得自由。是以理未立先，有福智载去，如贱使贵，不如于理先立。后有福智，临时作得，捉土为金，变海水为苏酪，破须弥山为微尘，于一义作无量义，于无量义作一义。自余化缘终始，备陈实录，敕谥大智禅师大宝胜之塔。

祖堂卷十四·鲁祖

鲁祖和尚嗣马大师，在池州。师讳宝云。

机格玄峻，学徒来参，面壁而坐。问：“如何是言不言？”师云：“汝口在什摩处？”对云：“某甲无口”。师云：“将何吃茶饭？”自后洞山代云：“他不饥，吃什摩？”问：“如何是诸佛师？”师云：“头上宝盖生者不是。”僧云：“如何则是？”师云：“头上无宝盖。”

南泉和尚到，师便面壁而坐。南泉以手拍师背，师云：“你是阿谁？”泉云：“普愿。”师云：“如何？”泉云：“也寻常。”师云：“汝何多事？”

南泉有一日看菜园，南泉把石打园头，僧回头看是师，其僧具威仪礼拜，便问：“和尚适来岂不是惊觉学人？”南泉便跷足云：“惊觉则且置。任摩时作摩生？”其僧无对。南泉教僧：“你去鲁祖处。到彼中，便有来由。”

其僧辞南泉，便去鲁祖处。师才见僧来，便面壁坐。其僧不在意，却归南泉。南泉问：“到鲁祖处摩？”对曰：“到。”泉曰：“回太速乎？”对曰：“鲁祖和尚才见某甲，便面壁坐。所以转来。”南泉便云：“王老僧初出世时，向你诸人道：‘向佛未出世时体会，尚自不得一个半个。’是伊与摩驴年得一个半个摩？”

安国和尚拈问云居：“鲁祖过在什摩处？”被南泉呵责，云居便呵。安国出声啼哭，云居云：“却成赞叹。”安国从此止哭。

保福拈问长庆：“鲁祖有什摩切峻处，招得南泉此语？”长庆云：“退己进于人，万中无一个。”长庆举此因缘云：“他家面壁坐，有个摸索处。忽然堂堂底坐，你向什摩处摸索？”

僧问龙泉：“只如怡山与摩道，意作摩生？”泉云：“持聋得哑。”

祖堂卷十四·高城

高城和尚嗣马大师，师讳法藏。未睹行录，不决化缘终始。师有歌行一首：

古人重义不重金，曲高和寡勿知音。

今时志士还如此，语默动用迹难寻。

所嗟世上歧路者，终日崎岖枉用心。

平坦啃檀不肯取，要须登险访桩林。

穷子舍父远逃逝，却于本舍绝知音。

贫女宅中无价宝，却将秤卖他人金。

心无相，用还深，无常境界不能侵。

运用能随高与下，灵光且不是浮沉。

无相无心能运曜，应声应色随方照。

虽在方而不在方，任运高低总能妙。

亦无头，复无尾，灵光运运从何起。

只今起者便是心，心用明时更何你。

不居方，无处觅，运用无踪复无迹。

识取如今明觅人，终朝莫慢别求的。

勤心学，近丛林，莫将病眼认花针。

说教本穷无相理，广读元来不识心。

了取心，识取境，了心识境禅河静。

但能了境便识心，万法都如闼婆影。

劝且学，莫为师，不用登高向下窥。

平源不用金刚钻，剑刃之中错下锥。

向前来，莫人我，山僧有曲无人和。

了空无相即法师，不用绫罗将作幡。

可中了，大希奇，大人幽邃不思议。

自家坏却真宝藏，终日从人乞布衣。

取境界，妄情生，只如水面一波成。

但能当境无情计，还同水面本来平。

应大躯，应小躯，运用只随如意珠。

被毛戴角形虽宙，能应之心体不殊。

应眼时，若千日，艹/修像不能逃影质。

凡夫只是未曾观，那得自轻而退屈。

应耳时，若幽谷，大小音声无不足。

什方钟鼓一时鸣，灵光运运常相续。

应意时，绝分别，照烛森罗长不歇。

透过山河石壁间，要且照时常寂灭。

境自虚，不须畏，终朝照烛无形对。

设使任持浮幻身，运用都无舌身意。

师又集《大乘经音义》，流通流藏矣。

祖堂卷十四·章敬

章敬和尚嗣马祖，在长安。师讳怀晖，姓谢，泉州同安县人也。

有僧持锡到，绕师三匝，振锡而立。帅云：“是，是。”其僧无对。长庆云：“和尚佛法心何在？”此僧又到南泉，绕师三匝，振锡而立。南泉云：“不是，不是。风力所转，终归败败。”僧云：“章敬和向某甲道是，和尚因什摩道不是？”南泉云：“章敬则是，汝则不是。”长庆代云：“和尚是什摩心行？”

问：“心法灭时如何？”师云：“郢人无污，徒劳运斤。”有人举似洞山，洞山云：“虽然如此，须亲近作家始得。”僧云：“此意如何？”洞山云：“须运斤始得。”僧云：“向什摩处运斤？”洞山云：“不到处。”

师到兴善大彻禅师处，禅师问：“从什摩处来？”师云：“从天台来。”禅师云：“天台高多少？”师云：“自看取。”云居进云：“尽眼看不见时，又作摩生？”自代云：“异于世间。”

师契大寂宗教，缁儒奔趋法会，自以道响天庭，闻于凤阙。元和初，奉徵诏对，位排僧录首座已下。圣上顾问，僧首对云：“僧依夏腊。”僧当时六十夏，敕奉迁为座首。对圣上言论禅门法教，圣颜大悦。殷敬殊常，恩泽面临，宣住章敬寺。大化京都，高悬佛日，都城名公，义学览集，击难者如云。师乃大震雷音，群英首伏，投针契意者，得意忘言。

元和十三年戊戌岁，十二月二十一日迁化。敕谥大觉禅师大宝光之塔。长沙贾岛碑铭曰：“实姓谢，称释子，名怀晖，未详字。家泉州安集里，无官品，有佛位。始丙申，终乙未。”


祖堂集卷第十五

祖堂卷十五·西堂

西堂和尚嗣马祖，在虔州。师讳智藏。

有一秀才问曰：“有天堂地狱不？”师云：“有。”又问曰：“有佛法僧宝不？”师云：“有。”秀才云：“但问处尽言‘有’，和尚与摩道，莫是错不？”师云：“秀才曾见什摩老宿？”秀才云：“曾见径山和尚。”师云：“径山向秀才作摩生说？”云：“说一切总无。”师云：“秀才唯独一身，还别有眷属不？”对曰：“某甲有山妻，兼有两颗血属。”师云：“径山和尚还有妻不？”对曰：“他径山和尚真素道人，纯一无杂。”师呵云：“径山和尚内外严护，理行相称，道‘一切悉无’即得。公具足三界，凡夫抱妻养兒，何种不作？是地狱柤滓，因什摩道‘一切悉无’？若似径山听公道无。”秀才礼而忏谢焉。

马祖遣师送书到国师处，在路逢见天使。天使遂留斋次，因驴啼，天使唤头陀。师乃举头，天使便指驴示师，师却指天使，天使无对。又到国师处，国师问：“汝师说什摩法？”师从东边过西边立。国师云：“只者个，为当别更有不？”师又过东边立。国师云：“这个是马师底，仁者作摩生？”师云：“早个呈似和尚了也。”

师曾烧一僧，有一日现身觅命，师云：“汝还死也无？”对云：“死也。”师云：“汝既死，觅命者谁？”其僧遂不见。

自外未睹行录，不知终始。敕谥宣教禅师元和正真之塔。

祖堂卷十五·鹅湖

鹅湖和尚嗣马大师，在信州。师讳大义，衢州须江县人也。姓徐，依年具戒。禅律具通，礼大寂于江西，一扣秘赜，廓然玄悟，契心于洪州。

应缘次上都，孝文皇帝诏入内，谘请问道。德宗朝麟德殿，大筵论义。有人问：“心有也，旷劫而滞凡夫。心无也，刹那而登妙觉。”师答曰：“此乃梁武帝言。然心有者，是滞有，有既有矣，安可解脱？心无也，何人而登妙觉？”

师以群英十号，等有为已迷者，终不复悟。等无为已悟者，终不却迷。于是群英执伏，佥日玄无以比。师问诸硕德曰：“行止偃息，毕竟以何为道？”有人云：“知者是道。”师云：“不可以识识，不可以智知。安得知者是道乎？”有人云：“无分别是道。”师云：“善能分别诸法相，于第一义而不动。安得无分别是道乎？”有人云：“四禅八定是道。”师云：“佛身无为，不堕众数，安得四禅八定是道耶？”大师之旨，一切法是，一切法非，于无性无像，而有得有丧，岂可以一方定趣决为道耶？所以不定之辩，遣不足之执，趣无方之道矣。”师颂曰：

直下识玄旨，罗纹结角是。

不识玄旨人，徒劳逐所示。

[甘*鸟][甘*鸟]鸟守空池，鱼从脚下过，

[甘*鸟][甘*鸟]总不知。

有经论供奉大德，对顺宗皇帝前问：“如何是四谛？”师指圣人云：“当今是一谛，三谛何在？”大德无对。供奉又问：“欲界无禅，禅居色界。此土凭何立禅？”师答曰：“法师只知有欲界无禅，不知有禅界无欲。”供奉云：“禅界无欲，如何是禅？”师以手空中点一下，供奉无对。皇帝云：“只这一点，法师尚勿奈何。”

师元和十三年戊戍岁，正月二日迁化，报龄七十四，敕谥慧觉大师见性之塔，国相韦厚制碑文。

祖堂卷十五·伏牛

伏牛和尚嗣马大师，在北京。师讳自在，未睹实录，莫究化缘终始。

师放少师行脚时，颂曰：

放汝南行入大津，碧潭深处养金鳞。

等闲莫与凡鱼伴，直透龙门便出身。

小师答曰：

鱼龙未变志常存，变了还教海气浑。

两眼不曾窥小水，一心专拟透龙门。

千回下网终难系，万度垂钓誓不吞。

待我一朝鳞甲备，解将云雨洒乾坤。

小师便是第二伏牛也。师有三个不归颂曰：

割爱辞亲异俗迷，如云似鹤更高飞。

五湖四海随缘去，到处为家一不归。

苦节劳形守法威，幸逢知识决玄微。

慧灯初照昏衢朗，唯报自亲二不归。

峭壁幽岩往复希，片云孤月每相依。

经行宴坐闲无事，无道逍遥三不归。

祖堂卷十五·盘山

盘山和尚嗣马大师，在北京。师讳宝积，未详姓氏。

师有时示众云：“心若无事，万法不生。境绝玄机，纤尘何立？道本无体，因道而得名。道本无名，因名而得号。若言即心即佛，今时未入玄微；若言非心非佛，犹是指踪之极则。向上一路，千圣不传。学者劳形，如猿捉影。大道无中，复谁前后？长空绝际，何用量之？空既如斯，道岂言哉？心月孤圆，光吞万象。光非照境，境亦非存。光境俱亡，复是何物？禅德譬如掷剑挥空，莫论及之不及，斯乃空轮无迹。剑刃非亏，若能如是，心心无知，全心即佛，全佛即人。人佛无异，始为道矣。禅德可学中［中学］道，似地擎山，不知山之高峻；如石含玉，不知玉之无瑕。若能如是，是名出家。故导师云：‘法本无相碍，三际亦复然。无为无事人，犹是金锁难。’所以古人道：‘灵源独耀，道本无生。大智非明，真空绝迹。真如凡圣，皆是梦言。佛及涅盘，并为增语，禅德切须自看，无人替代。三界无法，何处求心？四大本空，佛依何住？旋机不动，寂尔无根，觌面相呈，更无余事。’珍重。”

强大师拈问福先：

向上一路古人宗，学者徒劳捉影功。

若道不传早传了，不传之路请师通。

福先答曰：

盘岫高提向上宗，兴来诸圣舌无功。

吾师既问不传事，问当何愁不为通？

问：“牛头未见四祖时如何？”师云：“有量之事，龙鬼可寻。”进曰：“见四祖后如何？”师云：“脱量之机，龙鬼难寻。”进曰：“见后，为什摩百鸟不来？”师答曰：“丝在能歌舞，线断一时休。”

师临迁化时，谓众云：“还有人邈得吾真摩？若有人邈得吾真，呈似老僧看。”众皆将写真呈似和尚，师尽打。时有一少师普化，出来云：“某甲邈得师真。”师云。“呈似老僧看。”普化倒行而出。师云：“我不可著汝这般底，向后去别处打风颠去也。”

师平生住持执范，严整异常，海内闻名。敕谥凝寂大师真际之塔。

祖堂卷十五·麻谷

麻谷和尚嗣马大师，在莆州。师韩宝彻，未详姓氏。

师与丹霞游山，见水中鱼，师以手指丹霞，丹霞云：“天然。”师至明日来问：“昨日意作摩生？”丹霞便作卧势。师曰：“苍天苍天。”

师行脚时，到三角。三角和尚上堂云：“此事贬上眉毛，早已差过也。”师便问：“承和尚有言：‘此事眨上眉毛，早已差过。如何是此事？”三角云：“差过也。”师便担［《景德》作掀］倒绳床。三角和尚便打之，问：“十二分教某甲不疑。”师便起去。问：“如何是佛法大意？”师良久，其僧却举似石霜：“此意如何？”石霜云：“主人殷勤，滞累阇梨，拖泥涉水。”

祖堂卷十五·盐官

盐官和尚嗣马大师，在苏州。师讳齐安，未详姓氏。

有法空禅师到，问师经中诸义，师答了。师云：“禅师到来，贫道总未得作主人。”禅师云：“请和尚作主人。”师云：“日已将晚，且归本位安量［置］，明日却来。”

师明朝令沙弥屈法空禅师，禅师应时来。师呵沙弥云：“这沙弥不了事，教屈法空禅师来，何故屈得守堂人来？”僧参师，师云：“汝是阿谁？”对曰：“法忻。”师云：“我不识汝。”问：“如何是本身卢舍那佛？”师云：“与我将取那个铜瓶来。”僧取瓶来，师云：“却送本处安置。”僧便送本处已，再来问：“如何是本身卢舍那佛？”师云：“古佛也过去久矣。”

大中皇帝潜龙之日，曾礼为师。甚有对答，言论具彰别录。敕谥悟空禅师栖真之塔，真塔浩瀚非常，北有汾州，南有盐官矣。

祖堂卷十五·五泄

五泄和尚嗣马祖，在越州。

师讳灵嘿，姓宣，常州人也。师未出家时，入京选官去。到洪州开元寺，礼拜大师。大师问：“秀才什摩处去？”云：“入京选官去。”大师云：“秀才太远在。”对云：“和尚此间还有选场也无？”大师云：“目前嫌什摩？”秀才云：“还许选官也无？”大师云：“非但秀才，佛亦不著。”因此欲得投大师出家。大师云：“与你剃头即得，若是大事因缘即不得。”从此摄受，后具戒。

有一日，大师领大众出西墙下游行次，忽然野鸭子飞过去。大师问：“身边什摩物？”政上座云：“野鸭子。”大师云：“什摩处去？”对云：“飞过去。”大师把政上座耳拽，上座作忍痛声，大师云：“犹在这里，何曾飞过？”政上座豁然大悟。因此师无好气，便向大师说：“某甲抛却这个业次，投大师出家。今日并无个动情，适来政上座有如是次第，乞大师慈悲指示。”大师云：“若是出家师则老僧，若是发明师则别人，是你驴年在我这里也不得。”师云：“若与摩则乞和尚指示个宗师。”大师云：“此去七百里有一禅师，呼为南岳石头。汝若到彼中，必有来由。”师便辞，到石头，云：“若一言相契则住，若不相契则发去。”著鞋履，执座具，上法堂礼拜，一切了侍立。石头云：“什摩处来？’师不在意，对云：“江西来。”石头云：“受业在什摩处？”师不祗对便拂袖而出。才过门时，石头便咄。师一脚在外，一脚在内，转头看，石头便侧掌云：“从生至死，只这个汉，更转头恼作什摩？”师豁然大悟。在和尚面前给侍数载，呼为五泄和尚也。

后有人举似洞山，洞山云：“登时若不是五泄，大难得承当。虽然如此，犹涉途在。”自后长庆云：“掎。”净修禅师拈问僧：“只如长庆与摩道，意作摩生？”僧无对。自代云：“恐他认处错。”有人拈问漳南：“古人道：‘从生至死，只这个汉是。’和尚如何？”漳南云：“地狱柤滓只有人作了也。”僧云：“深领和尚尊旨。古人因什摩与摩道？”漳南云：“只为这般汉。”僧云：“与摩则忘前失后去。”漳南云：“头上不秃，肚里无毒。”僧云：“贪看天上月，忘却室中灯。”漳南便失声。僧问：“何物大于天地？”师云：“无人识得伊。”僧云：“还可雕啄也无？”师云：“你试下手看。”

越州观察使差人问师：“依禅住持？依律住持？”师以偈答曰：

寂寂不持律，滔滔不坐禅。

俨茶三两碗，意在酴头边。

观察使差人送百柄酴头，师才见送来，把棒趁出，却云：“我有一柄酴头，平生用不尽，谁要你送来！”专使却来，具说前事，观察使遥申礼拜。问：“此个门中始终事如何？”师云：“你道目前成来多少时？”僧云：“不会。”师云：“我此间无你适来问底。”僧云：“岂无和尚接人处？”师云：“待你求则接。”僧云：“请和尚接。”师云：“你欠少什摩？”

师元和十三年化缘周毕，澡浴焚香，端坐绳床，大集僧众，殷勤叮嘱。嘱累［毕］，开俞［喻］门徒云：

妙色真常，本无生灭。

法身圆寂，宁有去来。

千圣同源，万灵一辙。

吾今示灭，不假兴哀。

无强劳形，须存正念。

傥遵此命，真报我恩。

若固违言，非吾弟子。

有人问：“什摩处去？”师云：“无处去。”僧云：“某甲何以不见？”师云：“非眼所睹。”洞山闻举云：“作家。”师正坐叠掌收光，一刹那间便归圆寂，享龄七十二，僧腊三十一。沙门志闲撰碑文矣。

祖堂卷十五·大梅

大梅和尚嗣马大师，在明州。师讳注常，襄阳人也，荆州玉泉寺受业。才具尸罗，学通众典。讲大小本经论。多闻虽益，辩注虚张。觉爽情［精］神，游方访道。闻江西马大师诲学，师乃直造法筵。

因一日问：“如何是佛？”马师云：“即汝心是。”师进云：“如何保任？”师云：“汝善护持。”又问：“如何是法？”师云：“亦汝心是。”又问：“如何是祖意？”马师云：“即汝心是。”师进云：“祖无意耶？”马师云：“汝但识取汝心，无法不备。”师于言下顿领玄旨，遂杖锡而望云山。

因至大梅山下，便有栖心之意，乃求小许种粮。一入深幽，更不再出。后因盐官和尚出世，有僧寻柱杖迷山，见其一人，草衣结发，居小皮舍，见僧先言不审，而言语謇涩。僧穷其由。师云：“见马大师。”僧问：“居此多少年也？”师云：“亦不知多少年。只见四山青了又黄，青了又黄。如是可计三十余度。”僧问：“师于马祖处，得何意旨？”师云：“即心是佛。”其僧问出山路，师指随流而去。

其僧归到盐官处，具陈上事。盐官云：“吾忆在江西时，曾见一僧问马大师佛法祖意，马大师皆言‘即汝心是。’自三十余年，更不知其僧所在。莫是此人不？”遂令数人教依旧路，斫山寻觅。如见，云：“马师近日道：‘非心非佛。’”其数人依盐官教问。师云：“任你非心非佛，我只管即心即佛。”盐官闻而叹曰：“西山梅子熟也。汝曹可往彼，随意采摘去。”如是，不足二三年间，众上数百，凡应机接物，对答如流。

因夹山与定山去大梅山，路上行次。定山云：“生死中无佛，则非生死。”夹山不肯，自云：“生死中有佛，则不迷生死。”二人相不肯，去到大梅山。夹山自问：“此二人道，阿那个最亲？”师云：“一亲一疏。”夹山云：“阿那个是亲？”师见苦问，乃云：“且去，明日来。”夹山明日来问：“昨日未蒙和尚垂慈，未审阿那个是亲？”师云：“问者不亲，亲者不问。”

有人问盐官：“如何是西来意？”官云：“西来无意。”僧举似师，师云：“不可一个棺里著两个死尸。”

师临顺世时，鼯鼠叫，师告众曰：“即此物非他物。汝等诸人善护持，吾今逝矣。”师言已掩室，来辰化矣。括州刺史江勣撰碑文。

祖堂卷十五·永泰

永泰和尚嗣马大师，师讳灵瑞。姓黄，衡阳人也。

年十一，出家于南岳。年十八，为沙弥。问津于大寂，默领心要。年二十四，进具于双峰寺，却归大寂法会。贞元一年丙寅岁，游青州。州牧张胤请止龙兴寺。

元和中，青州人大饥，人多殍仆。师胁不不至席，视人如伤，乃率富屋，俾行檀度。繇是净名给孤，竞垂乘下。

师左臂有肉环，卧常右胁。占者曰：“溶人天师也。”后尚书萨平侍以为师，凡二十三年。大化青社，故号青州和尚焉。

及游襄阳，廉使牛元翼礼重曰：“人中师子王也。”请止感通寺。又至荆渚，仆射王潜请住永泰寺。布金阐道，大展化度。

大和三年戊子岁六月三日顺世，春秋六十九，荼毗得舍利五千余粒，塔于郭东。刘轲制碑文，敕谥道镜禅师宝真之塔。

祖堂卷十五·东寺

东寺和尚嗣马大师，在潭州。师讳如会，韶州始兴曲江县人也。

大历八年，止国一禅师门下。后归大寂，众皆仰德，臻凑如林。榻为之折，时称折床会也。

后止长沙东寺，大播洪规。每曰自大寂禅师去世，常病好事者录其语本，不能遗筌领意，认即心即佛，外无别说，曾不师于先匠。只徇影迹，且佛于何住，而曰即心，心如画师，贬佛甚矣，遂唱于言：“心不是佛，智不是道。剑去远矣，尔方刻舟。”时号东寺为“禅窟”。

承相崔公胤高其风韵，躬问师曰：“师何以得？”师曰：“见性为得。”公云：“师见性不？”师曰：“见性。”师当时方病眼，相公讥曰：“既言见性，其眼奈何？”师云：“见性非眼，眼病何害？”相公喜而礼拜。更与师到佛殿，见雀兒在佛头上放粪，相公问：“者个雀兒，还有佛性也无？”师云：“有。”相公云：“既有，为什摩向佛头上屙？”师云：“他若无，因什摩不向鹞子头上屙？”相公后此礼拜为师。

自后长庆闻云：“掎。”师问南泉：“近离什摩处？”对曰：“近离江西。”师云：“还将得马大师真来不？”对云：“将得来。”师云：“将来，则呈似老僧看。”对云：“只这个是。”师云：“背后底。”南泉登时休。后长庆云：“和尚大似不知。”保福代云：“洎不到和尚此间。”

师问仰山：“离什摩处？”对曰：“离广南。”师曰：“见说广南有镇海明珠，还是也无？”对曰：“是也。”师云：“此珠作摩生？”对曰：“白月则隐，黑月则现。”师曰：“还将得此珠来也无？”对云：“将得来。”师云：“若将得来，则呈似老僧看。”对云：“昨日到沩山，沩山和尚就某甲索此珠，直得无言可对。”师一跳抚背云：“真师子兒，真师子兒。”又云：“惭愧，惭槐！老僧不如沩山，汝便是沩山弟子也。”

仰山受戒后，再到相见。才入法堂，师便云：“已相见了也，不用更上来。”对云：“与摩相见莫不当摩？”师便入法堂，闭却门。仰山后举似沩山，沩山云：“子是什摩心行？”

师长庆癸卯岁终，春秋八十。时井泉个，异香馥郁。塔于城南，故廉使李公翱尽毁近城塔，唯留师塔，笔书曰：“独留此塔，以别贤愚。”刘轲撰碑文矣。

祖堂卷十五·邓隐峰

邓隐峰和尚嗣马大师，建州邵武县人也。

因南泉示众曰：“铜瓶是境，瓶中有水。我要水，不得动境。将水来！”师便将瓶到南泉前，写出水。

师因行至五台山，金刚窟前倒立而逝。众妨圣窟，拟易处荼毗，竟莫能动。先有亲妹，出家为尼在彼，及谙其兄行迹，遂近前呵云：“师兄平生为人，不依法律，死后亦不能徇于世情。”以手推倒，众获阇维。塔于北台之顶。平生在世，唯留一偈曰：

独弦琴子为君弹，松柏长青不怕寒。

金矿相和性自别，任向君前试取看。

祖堂卷十五·归宗

归宗和尚嗣马大师，在江州庐山。师讳智常，未详姓氏。

师久与南泉同道，神彩奇异，时人猜之，合有一人之分。师遂以药熏其眼令赤，时人号为赤眼归宗和尚焉。

白舍人为江州刺史，颇甚殷敬。舍人参师，师泥壁次。师回首云：“君子儒？小人儒？”白舍人云：“君子儒。”师以泥鎋敲泥板，侍郎以泥挑挑泥，送与师。师便接了云：“莫是俊机白侍郎以不？”对云：“不敢。”师云：“只有送泥之分。”

有李万卷，白侍郎相引，礼谒大师。李万卷问师：“教中有言：‘须弥纳芥子，芥子纳须弥。’须弥纳芥子，时人不疑；芥子纳须弥，莫成妄语不？”师却问：“于国家何艺出身？”抗声对云：“和尚岂不知弟子万卷出身？”师云：“公因何诳敕？”公云：“云何诳敕？”师三：“公四大身若子长大，万卷何处安著？”李公言下礼谢，而事师焉。万卷赞曰：

出廓送钱嫌不要，手提棕笠向庐山。

昔日曾闻青霄鹤，更有青霄鹤不如。

师偈曰：

归宗事理绝，日轮正当午。

自在如师子，不与物依怙。

独步四山顶，优游三大路。

吹嘘飞禽堕，颦呻众兽怖。

机竖箭易及，影没手难覆。

施张如工伎，剪截成尺度。

巧镂万盘名，归宗还似土。

语密音声绝，理妙言难措。

弃个耳还聋，取个眼还瞽。

一镞破三关，分明箭后路。

可怜个丈夫，先天为心祖。

师有时拈起帽子，问：“会摩？”对曰：“不会。”师曰：“莫怪。老僧头风，不下帽子。”问：“如何是诸佛玄旨？”师云：“无人能会。”僧云：“向者如何？”师云：“有向则乖。”僧云：“无向者如何？”师云：“谁求玄旨？”其僧于时无语。师云：“去，无子用功处。”僧云：“岂无方便门，令学人得入？”师曰：“有。”僧云：“如何是方便门？”师云：“观音妙智力，能救世间苦。”僧云：“如何是观音妙智力，能救世间苦？”师敲鼎盖三下，却问：“子还闻摩？”云：“闻。”“我为什摩不闻？”僧无对，师打之。

李万卷问：“大藏教明得个什摩边事？”师竖起拳，却问：“汝还会摩？”李公对云：“不会。”师云：“者李公，拳头也不识。”李公云：“某甲不会，请和尚指示。”师云：“遇人则途中授与，不遇人则世谛流布。”

师为众曰：“吾今合说禅，诸子总近前来。”大众尽近前，师云：

汝听观音行，善应诸方所。

弘誓深如海，历劫不思议。

侍多千亿佛，发大清净愿。

师又问：“阿那个是观音行？”师却弹指一下问：“诸人还闻摩？”众皆云：“闻。”师云：“者一队汉，向这里觅什摩？”趁出了，呵呵大笑。

师入园中，见一株菜，画圆相裹却，谓众曰：“辄不得损著者个。”众僧更不敢动著。师于时却来，见菜株犹在，便把杖趁打，呵云：“者一队汉，无一个有智慧。”

师问僧：“从什摩处来？”对云：“某处来。”师云：“还将得那个来不？”对云：“将得来。”师云：“在什摩处？”僧以手从顶上擎出，呈似师。师举手抛向後，僧无对。师去：“者野孤兒。”

师铲草次，有一座主来相看。忽见一条蛇，师便酴断。座主云：“久向归宗，元来只是粗行沙门。”

後有人举问长庆：“归宗酴蛇意作摩生？”长庆云：“错。”明真举似瑫庵主，庵主云：“把将性命来。”明真不肯。石门代云：“专甲在庵中，只是劈柴种菜。”

时有江州东林寺，长讲维摩经并学论。座主神建问：“如何是触目菩提？”师乃跷起一脚示他。座主云：“莫无礼。”师云：“不无礼。三个现在，座主一任拣取。”座主不会，遂置状於江州，陈论刺史李万卷李公判云：

伏以三乘至教，一藏严持。所载文词，唯穷佛性。事能幽现，理实通玄。统三教之根源，作群迷之依仰。既有辞亲弃俗，被褐讲经。经有明文，疏无不尽。自是智辩不到，谬判三身。体解不圆，滥转八识。将智辩智，枉用功夫。将文执文，岂非大错？况师乃深穷肇论，洞达维摩。肇有青青翠竹，尽是真如；郁郁黄花，无非般若。大士有菩提是障，能障诸愿。此之两教，既非谬词，且师辩菩提之路，尚未分明；郁郁黄花，争能见性？如斯之见，何用讲经？高座宣扬，欺他中下，何不自玄究竟？擅骋愚聪，抱垢问禅，发言不谛，尊宿垂念。触目相呈，理既共通，何不自会？只如三个，何异法身？师鉴了能略无般若，何不顿惺？便见无生，假相菩提，空有名字。信有法身，只共一源。改换形仪，凡心自乱，真心了了，无字无名。见性惺惺，何言何说？如师只问菩提之处，将言对敌，埋没达摩来踪。若须寂嘿为宗，维摩一生受屈。师岂不见，肇有四不迁之义，生有六不空之谈？乃知触目之义不？千智慧不迁之理，永在恆沙，体似琉璃，色如啐啄，随其大小，好丑何安？即色即空，将何言对？

奇哉空门，弟子不会色空，却置状词。投公断理，只如儒教，尚有不出户而知一切事，不窥窗而知天下。明知之为知，知之不知为知，俱归智也。辩智之义，尚以如斯，学佛之人，何迷佛性？见师之貌，举意昂藏，将为业蕴无生，道弘大觉。及乎动用，全是凡情。词状但有诽谤之言，出口全乖声闻之行。再三奉劝，旦自思惟。知识不屈於学徒，真如岂随於言句？真见无像，其像分明。实听无声，其声不绝。洞达如之，莫非一切。师之不肯，再把状来。忽以公穷，必无好事。聊申一判，略表玄猷。不出词锋，安能辩正？但执此判，将归寺中，集众声锺，诠谛真实。汝若不信，再将状来，若也定实，便自礼佛一百拜。仍更具威仪，往彼礼问知识。造罪忏侮，众罪如霜露。慧日忽顿，消前罪去。

报慈拈问僧：“作摩生道，则得不屈得古人？”僧对云：“这个僧将状出去。”报慈云：“据个什摩道理？”对云：“若是别人，大家吃饭。”

祖堂卷十五·汾州

汾州和尚嗣马大师，师讳无业。姓杜，商州上洛人也。

初，母李氏，忽闻空中有言曰：“寄住得不？”已而方娠。诞生之夕，异光满室。及至成童，不为兒戏。行必直视，坐则跏趺。商之缁徒，见皆叹曰：“此无上法器也。速令出家，绍隆三宝。”

九岁，启父母，依商州开元寺志本禅师。禅师授以《金刚》、《法华》、《维摩》、《涅盘》等经，一览无遗。年十二，剃落，具戒於襄州幽律师。禀四分律疏，一夏肆习，便能敷演。长讲《花严》、《涅盘》等经。时谓生肇不泯，琳远再兴。

后闻洪州马大师禅门上首，持往瞻礼。师身逾六尺，屹若立山。马大师一见，异之曰：“魏魏佛堂，其中无佛。”师礼而问曰：“三乘至教，粗亦研穷。常闻禅门即心是佛，实未能了。伏愿指示。”马大师曰：“即汝所不了心即是，更无别物。不了时即是迷，了时即是悟。迷即是众生，悟即是佛道。不离众生别更有佛也，亦如手作拳、拳作手也。”师言下豁然大悟，涕泪悲泣，白马大师言：“本将谓佛道长远，勤苦旷劫，方始得成。今日始知，法身实相，本自具足。一切万法，从心化生。但有名字，无有实者。”马大师云：“如是，如是。一切心性，不生不灭；一切诸法，本自空寂。是故经云：‘诸法从本来，常自寂灭相。’又云：‘毕竟空寂舍。’又云：‘诸法空为坐。’此则诸佛如来，住无所住处。若如是知，即是住空寂舍，坐法空座。举足下足，不离道场。言下便了，更无渐次。所谓不动足而登涅盘山。”

大师直造宝所，不栖化城，於元和皇帝御宇三年，两度诏请，师辞病不赴。至穆宗即位，重降旨。使日：‘此度圣恩，不并常时。”师笑云：“贫道有何德，累烦圣主？行则行矣，道途恐殊。”乃作行次，剃发沐浴，至中夜，告徒弟等云：“女等见闻觉知之性，与虚空同寿，犹如金刚不可破坏，一切诸法如影如响，无有实者，是故经云：‘唯此一事实，余二则非真。’”言已，跏趺，奄然而化。

长庆三年癸丑岁，十二月二十一日，荼毗塔于城西。敕谥大达禅师澄源之塔。汾州刺史杨灒撰碑文。

祖堂卷十五·大同

大同和尚嗣马大师，师讳广澄。未睹行录，不决化缘终始。

问：“如何是玄？”师云：“返去。”“如何是玄中又玄？”师云：“不返去。”

祖堂卷十五·金牛

金牛和尚嗣马大师。

师寻常自作饭，供养众僧。将饭来堂前了，乃抚掌作舞，大笑云：“菩萨子吃饭来！”后有僧举问长庆：“古人抚掌大笑，意作摩生？”长庆云：“太似因斋庆赞。”僧问洞山：“抚掌大笑是奴兒婢子不？”洞山云：“是。”僧云：“向上事，请师直指。”洞山云：“总未曾见你问在。”僧云：“只今现问。”洞山云：“咄！这奴兒婢子！”

祖堂卷十五·龟洋

龟洋和尚嗣马大师，师讳无了。俗姓沈，莆田县壶公宏塘人也。七岁出家。［?*家］君挈白之［之*白］重院，遽视院之如家。十八落发，清源灵泉寺受具。

好游山水，院之北樵采而无径，师乃振锡而行。遇六眸巨龟，须臾而失，乃结庵居。有一麈被虎逐来，师以杖约住其虎，后号龟洋也。

续有一僧，近从锺陵至，举马大师意旨。师曰：“吾得马大师之旨。”临迁化时，垂训有偈曰：

八十年来辩东西，如今不要白头公。

非长非短非大小，还与诸人性相同。

无来无去兼无住，了知本来自性空。

偈毕，俨然而寂，塔于正堂。

后二十载，塔下有水淹[氵*侵]，乃发看。见师全身水中而浮。闽王闻之，将辇取于府庭供善，拟造塔安图，士庶瞻敬。师放气，阖府皆闻。闽王乃焚香启告：“如若却复故山，乞收气。”师乃放香气，阖廓皆瞻礼。当时厚宣什物，仍安存现在本塔。

祖堂卷十五·陈禅师

陈禅师同住，师讳慧忠，仙游县人也。俗姓陈。九岁诣龟洋庵，出家，剃度后便游方。

遇庵和尚，问：“离自何方？”师云：“六眸峰庵。”“还具六通不？”师云：“患非重瞳。”便复故山。

遇会昌沙汰，避而几乎五六年。后宣宗中兴，师曰：“古之有言：‘上升道士不受裣，成佛沙弥不具戒。’”遂午而不粒，不宇而禅，终此山，门人葬于沈禅师塔之东隅二百步。

士庶皆云：“龟洋二真，至今香灯不绝。祈祷灵应不少。”亦是黄瑫先辈制碑文。

祖堂卷十五·黑涧

黑涧和尚嗣马大师，在洛京。

问：“如何是密室？”师云：“截耳卧街。”“如何是密室中人？”师以手惜胸。

祖堂卷十五·秘魔岩

秘魔岩和尚嗣马大师。

师常提杈子，每见僧参，蓦项便杈云：“那个魔魅教你出家？那个魔魅教你受戒？那个魔魅教你行脚？道得亦杈下死，道不得亦杈下死。速道速道。”其无对。师便打趁出。

祖堂卷十五·庞居士

庞居士嗣马大师。居士生自衡阳。

因问马大师：“不与万法为侣者，是什摩人？”马师云：“待居士一口吸尽西江水，我则为你说。”居士便大悟，便去库头，借笔砚，造偈曰：

十方同一会，各各学无为。

此是选佛处，心空及第归。

而乃驻留参承，一二载间，遂不变儒形，心游像外。旷情而行符真趣，浑迹而卓越人间。溶玄学之儒流，乃在家之菩萨。

初住襄阳东岩，后居郭西小舍。唯将一女扶侍，制造竹漉篱。每令女市货，以遣日给。平生乐道偈颂，可近三百余首，广行于世，皆以言符至理，句阐玄猷，为儒彦之珠金，乃缁流之箧宝。略陈一二，余不尽书。偈曰：

心如镜亦如，无实亦无虚。

有亦不管，无亦不居。

不是贤圣，了事凡夫。

又偈曰：

看经须解义，解义始修行。

若依了义教，即入涅盘城。

如其不解义，多见不如盲。

缘文广占地，心牛不肯耕。

田田皆是草，稻从何处生？

又偈曰：

易复易，即此五蕴有真智。

十方世界一乘同，无相法身岂有二？

若舍烦恼觅菩提，不知何方有佛地？

又偈曰：

无贪胜布施，无痴胜坐禅。

无嗔胜持戒，无念胜求缘。

尽现凡夫事，夜来安乐眠。

寒时向火坐，火溶本无烟。

不怕黑暗女，不求功德天。

任运生方便，皆同般若船。

若能如是学，功德实无边。

又偈曰：

世人嫌庞老，庞老不嫌他。

开门待知识，知识不来过。

一丸疗万病，不假药方多。

又偈曰：

心若如，神自虚。

不服药，病自除。

病既除，自见莲华如意珠

无劳事，莫驱驱。

智者观财色，了知如幻虚。

衣食支身命，相劝学如如。

时至移庵去，无物可盈余。

又偈曰：

贪嗔不肯舍，徒劳读释经。

看方不服药，病从何处除？

取空空是色，取色色无常。

色空非我有，端坐见家乡。

又偈曰：

人有一卷经，无相复无名。

无人解转读，有我不能听。

如能转读得，入理契无生。

非论菩萨道，佛亦不要成。

居士临迁化时，令女备汤水，沐浴著衣。于床端然趺坐，付嘱女已，告曰：“你看日午则报来。”女依言，看已，报云：“日当已午，而日蚀阳精。”居士云：“岂有任摩事？”遂起来自看。其女寻，则据床端然而化。父回见之，云：“俊哉，吾说之在前，行之在后。”因此居士隔七日而终矣。


祖堂集卷十六

祖堂卷十六·南泉

南泉和尚嗣马大师，在池州。师讳普愿，姓王，新郑人也。

母孕之时，不喜荤血。至德二年，投密县大隗山大慧禅师受业，后参大寂，密掌灵符。池阳宣城廉使陆亘请下礼事，大弘真教。

师每上堂云：“近日禅师太多生，觅一个痴钝底不可得。阿你诸人，莫错用心。欲体此事，直须向佛未出世已前，都无一切名字，密用潜通，无人觉知，与摩时体得，方有少分相应。所以道：‘祖佛不知有，狸奴白牯却知有。’何以如具？他却无如许多般情量，所以唤作如如，早是变也，直须向异类中行。只如五祖大师下，有五百九十九人尽会佛法，唯有卢行者一人不会佛法，他只会道。直至诸佛出世来，只教人会道，不为别事。江西和尚说‘即心即佛’，且是一时间语，是止向外驰求病，空拳黄叶止啼之词。所以言‘不是心，不是佛，不是物。’如今多有人唤心作佛，认智为道，见闻觉知，皆云是佛。若如是者演若达多，将头觅头，设使认得，亦不是汝本来佛。若言即心即佛，如兔马有角；若言非心非佛，如牛羊无角。你心若是佛，不用即他；你心若不是佛，亦不用非他。有无相形，如何是道？所以若认心决定，不是佛；若认智决定，不是道。大道无影，真理无对。等空不动，非生死流；三世不摄，非去来今。故明暗自去来，虚空不动摇；万象自去来，明镜何曾鉴？阿你今时尽说我修行作佛，且作摩生修行？但识取无量劫来，不变异性，是真修行。”有人拈问：“三世诸佛为什摩不知有？”师云：“争肯你喃喃！”进曰：“狸奴白牯为什摩却知有？”师云：“似他即会。”师又时谓众曰：“会即便会去，不会即王老师罪过。”

师初住庵时，有一僧到，师向僧云：“某甲入山去，一饷时为某送茶饭来。”其僧应喏。其僧待师去后，打破家具杀却火，长伸瞌睡。师小时归，见僧睡。师向他身边伴睡，其僧便起发去。师后住得数年，谓众曰：“我初住庵时，有个灵利僧，如今却不见。”师问僧：“空劫中还有人修行也无？”对云：“有。”师云：“是阿谁？”对曰：“良钦。”师曰：“居何国土？”僧无对。曹山代云：“若与摩，不是良钦。”报慈代云：“若与摩，则自出来相访。”长沙代云：“居常寂光土。”师有时云：“我行脚时，有一中老宿教某甲道：“返本还源，噫祸事也。我十八上解作活计，三乘十二分教因我所有。如今我向三乘十二分教且不是，所以解修行底人不落因果，不解修行底人落他因果。”

陆亘大夫问：“弟子从六合来，彼中还有专甲身也无？”师云：“分明记取，已后举似作家。”千顷寺院主到，师问：“汝和尚在日，如许多债负，教什摩人还？”院主无对。师代云：“教和尚一时还却。”道吾代云：“把将来。”石霜代云：“他无人天羁什摩债负？”

师欲顺世时，向第一座云：“百年后，第一不得向王老师头上污。”第一座对云：“终不敢造次。”师云：“或有人问：‘王老师什摩处去也？’作摩生向他道？”对云：“归本处去。”师云：“早是向我头上污了也。”却问：“和尚百年后向什摩处去？”师云：“向山下檀越家作一头水牯牛去。”第一座云：“某甲随和尚去，还许也无？”师云：“你若随我，衔一茎草来。”僧问逍遥：“如何是一头水牯牛？”逍遥云：“一身无两役。”进曰：“如何是衔一茎草来？”逍遥云：“新旧添不得。”僧云：“还许学人承当也无？”逍遥云：“你若承当，衔铁负鞍。”又僧问曹山：“只如水牯牛，成得个什摩边事？”曹山云：“只是饮水吃草底汉。”僧云：“此莫便是沙门边事也无？”曹山云：“此是沙门行李处，不是沙门边事。”僧云：“如何是沙门边事？”曹山云：“不见有祖佛。”进曰：“如何是沙门行李处？”曹山云：“常在尘中。”又问：“如何是沙门相？”曹山云：“尽眼看不见。”僧云：“还被搭也无？”曹山云：“若被搭则不是沙门相。”“如何是沙门行李处？”曹山云：“头上戴角，身上被毛。”僧云：“此人得什摩人力？”曹山云：“终日得他力，只是行不住。”僧云：“此人以何为贵？”曹山云：“头上不戴角，身上不被毛。”又问：“沙门行与行李处是一是二？”曹山云：“亦一亦二。”“如何是一？”曹山云：“杀佛杀祖。”“如何是二？”曹山云：“被毛戴角。”又问：“从凡入圣则不问，从圣入凡时如何？”曹山云：“成得个一头水牯牛。”“如何是水牯牛？”曹山云：“朦朦朣朣地。”僧云：“此意如何？”曹山云：“但念水草，余无所知。”僧云：“成得个什摩边事？”曹山云：“只是逢水吃水，逢草吃草。”又问：“如何是一头水牯牛？”曹山云：“不证圣果。”“如何是衔一茎草来？”曹山云：“毛羽相似。”

师又时拈起球子问僧：“那个何似这个？”对云：“不似。”师云：“你什摩处见那个，便道不似？”对云：“若约某甲见处，和尚亦须放下手中物。”师云：“许你具一只眼。”洞山代云：“若见则似他去。”

师行脚次，问村路：“此路到什摩处？”村公对云：“脚下底是什摩？”师云：“到岳不？”村公：“如许多时，又觅在。”师云：“有茶不？”对云：“有。”师云：“觅一碗茶得不？”对云：“觅则不得，但来。”

师示众曰：“王老师要卖身，阿谁买？”僧对云：“某甲要买。”师云：“他不作贱，亦不作贵，你作摩生买？”僧无对。安国代云：“与摩则嘱专甲去也。”问：“师归丈室，将何指南？”师云：“昨夜三更失却牛，天明失却火。”“作摩生是失却牛？”师云：“未问已前会取。”“作摩生是失却火？”师云：“但知就人觅取。”问：“祖祖相传，合传何法？”师云：“一二三四五。”师问陆亘大夫：“十二时中作摩生？”对云：“寸丝不挂。”师云：“堪作什摩？”［?*大］夫云：“什摩处有过？”师云：“还闻道：‘有道之君，不纳有智之臣。”问：“牛头未见四祖百鸟衔花供养时如何？”师云：“只为步步踏佛阶。”“见后为什摩不来？”师云：“直饶不来，犹较王老师一线道在。”

师与归宗同行二十年，行脚煎茶次，师问：“从前记持商量语句，已知离此，后有人问毕竟事，作摩生？”归宗云：“这一片田地，好个卓庵。”师云：“卓庵则且置，毕竟事作摩生？”归宗把茶铫而去，师云：“某甲未吃茶在。”归宗云：“作这个语话，滴水也消不得。”有人问：“和尚住此间来，还见作家也无？”师云：“作家则不见，两个石牛匽入海，直至如今不得回。”有人拈问龙花：“只如南泉与摩道，意作摩生？”龙花云：“谁敢向这里出头？”

师持锡到韶州，刺史问：“十二种头陀，和尚是第几种？”师乃振锡一下。刺史再问，师云：“大钝生！”师敲绳床，谓众云：“大众共他语话。”对云：“却请和尚共他语话。”师云：“我不共他语话。”僧云：“为什摩不共他语话？”师云：“不辞共他语话，恐他不解语。”师又时曰：“若是文殊、普贤，昨夜三更各打二十棒，趁出院了也。”赵州对云：“和尚合吃多少棒？”师云：“王老师有什摩罪过？”赵州礼拜出去。

师谓赵州云：“江西马大师道：‘即心即佛。’老僧这里则不与摩道。不是心，不是佛，不是物。与摩道还有过也无？”赵州礼拜出去。赵州在楼上打水，师从下过，赵州以手攀栏县脚，云：“乞师相救。”师踏道上云：“一二三四五。”赵州云：“谢师指示。”

南泉山下有僧住庵，有人向他道：“此间有南泉，近日出世，何不往彼中礼拜去？”庵僧云：“任你千圣现，我终不疑得。”有僧举似师，师令赵州看他。赵州到庵，便礼拜，起来，从东边过，西边立，从西边过，东边立。此僧总不动。赵州又拔破帘，其僧亦不动。赵州归，举似师，师云：“我从来疑他。”

师问黄檗：“笠子太小生？”黄檗云：“虽然小，三千大千世界总在里许。”师云：“王老师你？”黄檗无对。后有人举似长庆，长庆代云：“欺敌者亡。”保福代云：“洎不到和尚此间。”有人问曰：“三身中阿那个最尊？”师云：“三只投子掷下，失却一个。”有僧问：“古人道：‘摩尼珠，人不识，如来藏里亲收得。’如何是如来藏？”师云：“王老师共你与摩来去是藏。”进曰：“不来不去时如何？”师云：“亦是藏。”“如何是珠？”师唤僧，僧应喏，师云：“去，你不会。”

有人到归宗，归宗问：“从什摩处来？”对云：“从南泉来。”归宗云：“有什摩佛法因缘？”对云：“和尚上堂，告众曰：‘夫沙门者，须行畜生行；若不行畜生，无有是处。’”归宗沉吟底，僧便问：“只如南泉意如何？”归宗云：“虽然畜生行，不受畜生报。”其僧却归，举似师。师云：“实与摩道摩？”僧云：“实也。”师云：“孟八郎又与摩去。”赵州问：“知有底人向什摩处休歇去？”师云：“向山下作一头水牯牛去。”赵州云：“谢和尚指示。”

问：“如何是菩萨意旨？”师云：“黑如漆。”僧云：“眼在何处？”师云：“明如日。”僧辞时，问：“学人到山下，有人问著和尚近日如何，作摩生祗对？”师云：“但向他道：‘解相扑。’”僧云：“作摩生相扑？”师答云：“一拍双泯。”问：“父母未生时，鼻孔在什摩处？”云：“如今已生也，鼻孔在什摩处？”沩山别云：“则今阿那个是鼻孔？”

有僧在师身边叉手立，师云：“太俗生。”僧又合掌，师云：“太僧生！”僧无对。问：“十二时中以何为境？”师云：“何不问王老师？”僧云：“问了也。”师云：“还曾与你为境摩？”师见院主，遂唤，院主便近前叉手而立。师云。“佛九十日在忉利天为母说法，优填王思佛，故教目连神通三转，摄匠人往彼雕得三十一相；唯有梵音相雕不得。”院主便问：“如何是梵音相？”师云：“赚杀人。”僧见雀兒啄生，问：“师为什摩得与摩忙？”师便脱鞋打地一下，僧云：“和尚打地作什摩？”师云：“趁雀兒。”师问院主：“忽有人问：‘王老师什摩处去？’你作摩生道？”院主无对。曹山代云：“但道作摩？”疏山代云：“待有去处则向和尚道。”问：“如何是涅盘？”师云：“清犹清，急犹急，浮沙何处停？”僧拈问：“如何是‘清犹清’？”师云：“混他一点不得。”“如何是‘急犹急’？”师云：“转目看不见。”“如何是‘浮沙何处停’？”师云：“金屑虽贵，眼里著不得。”师问黄檗：“定慧等学，明见佛性，此理如何？”黄檗云：“不依一物。”师云：“莫便是长老家风也无？”檗云：“不敢。”师云：“浆水钱则且置，草鞋钱教阿谁还？”师又问：“长老什摩年中受戒？”檗云：“威音王佛同时受戒。”师云：“威音王佛是我兒孙。”黄檗却问：“和尚什摩年中受戒？”师云：“这后生莫礼！”黄檗无对。师又问：“白银为地，黄金为壁，此是什摩人居止处？”檗云：“圣人居止处。”师曰：“更有一人居什摩处？”檗云：“我则道不得。”师云：“王老师都道得。”檗云：“便请道。”师云：“王老师罪过。”

师共归宗行次，归宗先行，师落后。忽见大虫草里出，师怕，不敢行，便唤归宗。归宗转来一喝，大虫便入草。师问：“师兄见大虫似个什摩？”归宗云：“相似猫兒。”师云：“与王老师犹较一线道。”归宗却问：“师弟见大虫似个什摩？”师云：“相似大虫。”

道吾到南泉，师问曰：“阇梨名什摩？”道吾对云：“圆智。”师云：“智不到处作摩生？”道吾对云：“切忌说著。”师问曰：“灼然说著，则头角生也。”却后三五日间，道吾与云岩相共在僧堂前把针。师行游次，见道吾，依前问：“智阇梨前日道：‘智不到处，切忌说著。’说著则头角生也。如今合作摩生行李？”道吾便抽身起，却入僧堂内，待师过后却出来。云岩问道吾：“和尚适来问，何不祗对？”道吾云：“师兄得与摩灵利！”云岩却上和尚处问：“适来和尚问智师弟这个因缘，合作摩生祗对？”师云：“他却是异类中行。”云岩云：“作摩生是异类中事？”师云：“岂不见道：‘智不到处，切忌说著。’说著则头角生。唤作如如，早是变，宜须向异类中行。”云岩亦不先陀，道吾念言：“他与药山有因缘矣。”便却共他去药山。药山问：“阇梨到何处来？”岩云：“此回去到南泉来。”药山云：“南泉近日有什摩方便示诲学徒？”云岩举似前话。药山云：“汝还会他这个时节也无？”云岩云：“某甲虽在他彼中，只为是不会他这个时节，便特归来。”药山大笑，云岩便问：“作摩生是异类中行？”药山云：“我今日困，汝且去，别时来。”岩云：“某甲特为此事归来，乞和尚慈悲。”药山云：“阇梨且去，老僧今日身体痛，别时却来。”云岩礼拜了便出去。道吾在方丈外立，听闻他不领览，不觉知，咬舌得血。却后去问：“师兄去和尚处问因缘，和尚道个什摩？”岩云：“和尚并不为某甲说。”道吾当时低头不作声。

在后各在别处住，至临迁化时，见洞山密师伯来，道吾向师伯说：“云岩不知有这一则事，我当初在药山时悔不向他说。虽然如此，不违于药山之子。道吾却为师伯子细说此事。”师问僧：“什摩处去？”对云：“山下去。”师云：“第一不得谩王老僧。”对云：“终不敢谩和尚。”师遂将瓶喷水，云：“是多少？”僧无对。师代云：“非师本有。”又云：“非和尚境界。”保福代云：“和尚图他一斗米，失却半年粮。”

师问黄檗：“去什摩处？”对云：“择菜去。”师云：“将什摩择？”黄檗竖起刀子。师云：“只解作客，不解作主。”自代云：“更觅则不得。”有僧拈问长庆：“与古人作主如何道？”长庆便咄之。僧拈问顺德：“南泉见黄檗去什摩处？意旨如何？”顺德云：“也是黄檗招致得。”僧云：“只如黄檗后与摩祗对，南泉还得也无？”德云：“且自付则得。”僧云：“只如对南泉作摩生道？”德云：“汝作南泉来。”僧云：“将什摩择？”德放下刀。

师有一日法堂上坐，忽然喝一声，侍者惊讶，上和尚处看，并无人。大师曰：“汝去涅盘堂里看，有一僧死也无？”侍者到于半路，逢见涅盘堂主著纳衣走上来，侍者云：“和问教专甲看涅盘堂里有一人死也无。”堂主对曰：“适来有一僧迁化，特来报和尚。”两人共去向和尚说。停腾之间，更有一人来报和尚云：“适来迁化僧却来也。”和尚问其僧：“病僧道什摩？”其僧云：“要见和尚。”师便下涅盘堂里，问病僧：“适来什摩处去来？”病僧云：“冥中去来。”师曰：“作摩生？”僧云：“行得百里地，脚手疒@登痛，行不得，又渴水。忽然有玉女唤人大楼台阁上，某甲行乏辛苦，欲得上楼阁。始上次，傍有一个老和尚喝某甲：‘不许上！’才闻喝声，则便惊讶，抽身仰倒。今日再得见和尚也。”师喝啧云：“可谓好楼阁！若不遇老僧，洎入火客屋里造猪。”从此后，其僧修福作利益，日夜不停，直到手指三分只有一分底。年到七十后，坐化而去也。呼为南泉道者也。有一日，其道者提篮子摘梨。盛篮次，师问：“篮里底是什摩？”道者便覆却篮子。僧拈问龙花：“只如道者覆却篮子意旨如何？”龙花云：“阇梨举不圆。”

有讲经论大德来参师，师问：“教中以何为体？”对云：“如如为体。”师云：“以何为极则？”对云：“法身为极则。”师云：“实也无？”对云：“实也。”师云：“唤作如如，早是变也，作摩生是体？”大德无对。因此索上堂云：“今时学士类尚辩不得，岂弁得类中异？类中异尚弁不得，作摩生办得异中异？唤作如如，早是变也，直须向异类中行。”赵州和尚上堂，举者个因缘云：“这个是先师勘茱萸师兄因缘也。”有人便问：“如何是异中异？”赵州云：“直得不被毛，不戴角，又勿交涉。”

师大和八年甲寅岁十二月二十五日迁化，春秋八十七，僧夏五十九矣。刘轲撰碑铭矣。净修禅师赞曰：

出世南泉，为大因缘。

猫牛委有，佛祖宁传。

高提线道，异却言诠。

赵州入室，其谁踵焉？

祖堂卷十六·沩山

沩山和尚嗣百丈，在潭州。师讳灵佑，福州长溪县人也。姓赵。

师小乘略览，大乘精阅。年二十三，乃一日叹曰：“诸佛至论，虽则妙理□深，毕竟终未是吾栖神之地。”于是杖锡天台，礼智者遗迹，有数僧相随。

至唐兴路上，遇一逸士，向前执师手，大笑而言：“余生有缘，老而益光。逢潭则止，遇沩则住。”逸士者，便是寒山子也。

至国清寺，拾得唯喜重于师一人，主者呵责偏党，拾得曰：“此是一千五百人善知识，不同常矣。”自尔寻游江西，礼百丈。一凑玄席，更不他游。

师有时谓众曰：“是你诸人，只得大识，不得大用。”有一上座，在山下住。仰山自下来问：“和尚与摩道，意作摩生？”上座云：“更举看。”仰山举未了，被上座踏倒。却归来，举似师，师底底而笑。

师与仰山语话次，师云：“只闻汝声，不见子身。出来，要见。”仰山便把茶树摇对。师云：“只得其用，不得其体。”仰山却问：“某甲则任摩？和尚如何？”师良久，仰山云：“和尚只得其体，未得其用。”师云：“子与摩道，放你二十棒！”

师问道吾：“见火不？”吾云：“见。”师云：“见从何起？”道吾云：“除却行住坐卧，更请一问。”

有僧礼拜师，师作起势，僧云：“请和尚不起。”师云：“未曾坐，不要礼。”僧云：“某甲未曾礼。”师云：“何故无礼？”

师临迁化时，示众曰：“老僧死后，去山下作一头水牯牛，胁上书两行字云：‘沩山僧某专甲。与摩时，唤作水牯牛，唤作沩山僧某专甲？’若唤作沩山僧，又是一头水牯牛。若唤作水牯牛，又是沩山僧某专甲。汝诸人作摩生？”后有人举似云居，云居云：“师无异号。”曹山代云：“唤作水牯牛。”

师有时与仰山净瓶，仰山才接，师乃缩手云：“是什摩？”仰山云：“和尚见什摩？”师云：“你若任摩，因何更就我觅？”仰山云：“虽然如此，人义途中，与和尚提瓶挈水，亦是本分。”师过净瓶与仰山。又问：“如何是西来意？”师云：“太好灯笼。”山云：“莫只这个便是也无？”师云：“这个是什摩？”仰山云：“太好灯笼。”师云：“果然不见。”

师与仰山行次，师指枯树子云：“前头是什摩？”仰山云：“只是个枯树子。”师指背后插田公云：“这个公向后亦有五百众。”

隐峰到沩山，于上座头放下衣钵。师闻师叔来，先具威仪来相看。隐峰见师来，便倒佯睡，师归法堂，隐峰便发去。师问侍者：“师叔在摩？”对云：“去也。”师云：“师叔去时道什摩？”对云：“无语。”师云：“莫道无语，其声如雷。”

德山行脚时，到沩山。具三衣，上法堂前。东观西观了，便发去。侍者报和尚云：“适来新到不参和尚，便发去。”师云：“我早个相见了也。”

师令侍者唤第一座，第一座来。师云：“我唤第一座，干阇梨什摩事？”曹山代云：“和尚若教侍者唤，但恐不来。”

师问云岩：“承你久在药山，是不？”对云：“是。”师云：“药山大人相如何？”对云：“涅盘后有。”师云：“如何是‘涅盘后有’？”对云：“水洒不著。”云岩却问：“百丈大人相如何？”师云：“魏魏堂堂，炜炜煌煌。声前非声，色后非色。蚊子上铁牛，无你下嘴处。”

沩山提物问仰山：“正与摩时作摩生？”仰山云：“和尚还见摩？”沩山不肯，却教仰山问：“正与摩时作摩生？”师云：“正与摩时，亦无作摩生。”师却云：“与摩道亦不得。”从此而休。隔数年后，仰山有语，举似师云：“切忌勃素著。”师问云：“停囚长智。”

仰山在沩山时，看牛次，第一座云：“百亿毛头，百亿师子现。”仰山与第一座，便举前话问：“适来道：‘百亿毛头，百亿师子现。’岂不是上座？”云：“是。”仰山云：“毛前现，毛后现？”上座云：“现时不说前后。”仰山便出去。师云：“师子腰折也。”洞山问：“和尚在此间住，有什摩学禅契会底人？”师云：“某甲初住此山有一人，是石头之孙，药山之子。”

仰山从田中归，师云：“田中有多少人？”仰山遂插下锹子，叉手而立。师云：“今日南山大有人刈茅。”有人问顺德：“只如沩山道：‘南山大有人刈茅’，意作摩生？”顺德云：“狗衔赦书，诸臣避路。”

师问云岩：“寻常道什摩？”对云：“某甲父母所生口，道不得。”僧问：“某甲欲奉师去时如何？”师云：“向他道，直须绝渗漏去，始得似他。”僧云：“还得不违于尊旨也无？”师云：“向他道，第一不得道‘老僧在这里。’”

云岩到沩山，沩山泥壁次。问：“有句无句，如藤倚树。树倒藤枯时作摩生？”云岩无对。举似道吾，道吾便去。到沩山，师便置前问。问未了，道吾便夺云：“树倒藤枯时作摩生？”师不对，便入房丈。

师向仰山云：“寂阇梨，直须学禅始得。”仰山便□：“作摩生学？”师云：“单刀直入。”僧拈问石门：“只如沩山与摩道，意作摩生？”石门便顾示。

有京中大师，到沩山参和尚，后对座吃茶次，置问：“当院有多少人？”师云：“有千六百人。”大师云：“千六百人中，几人得似和尚？”师云：“大师与摩问，作什摩？”大师云：“要知和尚。”师云：“于中也有潜龙，亦有现人。”大师便问众僧：“三界为鼓，须弥为槌。什摩人击此鼓？”仰山云：“谁击你破鼓？”大师搜觅破处不得，因此被纳学禅。有人拈问报慈：“什摩处是破处？”报慈云：“什摩年中，向你与摩道？”僧云：“毕竟作摩生？”报慈便打一下。

师与仰山游山，一处坐，老鸦衔红柿子来，放师面前。师以手拈来，分破一片，与仰山。仰山不受云：“此是和尚感得底物。”师云：“虽然如此，理通同规。”仰山危手接得了，便礼谢吃。

师匡化四十二年，现扬宗教。自大中七年癸酉岁示化，春秋八十三，僧夏六十四，敕谥大圆禅师清净之塔。

祖堂卷十六·黄檗

黄檗和尚嗣百丈，在高安县。师讳希运，福州闽县人也。

自少于黄檗寺出家。身长七尺，额有肉珠，门@亢门@良天生，不拘小节。初与二三时流，游天台山，在途偶接一僧，与师同道，言笑便同囊故道。道到溪涧，遇时水泛涨，遂阻步而暂息。其僧频催师而共渡，师不疑之云：“要渡但自渡。”其僧敛衣，蹑波而渡。至彼岸已，回顾招手，令师渡来。师乃呵云：“这贼汉，悔不预知。若知，则便打折脚。”其僧叹曰：“大乘器者哉，吾辈不及也！”言已，忽然而隐。

后游上都，因行分卫，而造一门云：“家常。”屏后有老女云：“和尚大无厌生。”师闻其言，异探而拔之云：“饭犹未得，何责无厌？”女云：“只这个，岂不是无厌？”师闻驻而微笑。阿婆睹师容仪堂堂，特异常僧，遂命入内，供以斋。食毕，询问参学行止。师不能隐，竭露见知。阿婆提以再举微关，师则玄门顿而荡豁。师重致言谢，拟欲师承，阿婆曰：“吾是五障之身，故非法器。吾闻江西有百丈大师，禅林郢匠，特秀群峰。师可诣彼参承。所贵他日为人天师，法不轻硃［来］耳。”后人传说，此婆少年曾参见忠国师也。

师遂依言而造百丈，礼而问：“从上相承之事，和尚如何指示于人？”百丈良久，师曰：“不可教后人断绝去也。”百丈云：“我本将谓汝是一个人。”遂起入丈室，欲掩其户，师云：“某甲来，只要这个印信足矣。”大［丈］回言：“若然者，他后不得辜负于吾。”师遂驻泊，延于时岁。

后居黄檗山，玄徒竞凑，法鼓震于寰中，缁素奔风。智炬扬于海内。高安县令见已，方乃稽首泯伏，而有诗赞曰：

曾传达士心中印，额有圆珠七尺身。

挂锡十年栖蜀水，浮杯今日渡漳滨。

一千龙象随高步，万劫香花结胜因。

愿欲事师为弟子，不知将法付何人？

僧问：“如何是西来意？”师打之。师谓众曰：“是你诸人，患颠那作摩？”把棒一时趁出云：“尽是一队吃酒糟汉。与摩行脚，笑杀人去。兄弟莫只见八百一千人处去那里，不可只图热闹。这个老汉行脚时，或遇著草根下有个老汉，便从顶宁上啄一下锥看。他若识痛庠，便将布袋盛米供养他。古人个中总似你与摩容易，何处更有今日事也？兄弟行脚人，亦须著些子精神好，汝还知大唐国内无禅师。”有人问：“请方尊宿尽皆匡化，和尚为什摩道无禅师？”师云：“不道无禅，只道无师。”又云：“阇梨可不见，马大师下有八十八人坐道场，得马大师真正法眼者，只有一二。庐山是一人。夫出家者，须知有从上来事。不见四祖下有牛头融大师，横说竖说，未知有向上一个关捩子。若有此眼脑，不妨弁得邪正宗傥［党］。当人事不能会得，但知念言语学，向皮袋里，到处便道：‘我会禅会道，还替得你轮回摩？’轻忽老宿。入地狱如箭射，我亦见汝行脚人，入门便识得汝了也。还知摩？诸人亦须在意，急急努力。莫只拟取次容易事，持一片衣，口食过一生，明眼人笑你，久后总被俗汉弄将去在。切须自看近远，且是阿谁面上事？若会则便会，若不会则散去。珍重！”

保福举师语云：“不道无禅，只道无师。”福拈问殿主：“作摩生是与禅为师底人？”殿主指和尚手中杖云：“某甲惜这个柱杖。”保福不肯。殿主却问：“作摩生是与禅为师底人？”福云：“我不惜这个柱杖。”

莲花在潭州报恩时，僧问：“只如保福道：‘不惜柱杖。’意作摩生？”报恩云：“他大意则是，只是无凭执。”僧云：“只如有凭执，意作摩生？”报恩云：“惜柱杖则不肯。”僧却问：“作摩生是与禅为师底人？”报恩乃放下柱杖，归方丈。

僧问鼓山：“只如莲花放下柱杖，意作摩生？”师云：“什摩所在？”僧云：“只如事在放下往杖处，事在归方丈处？”鼓山趁出云：“莫向这里出头。”

保福闻举云：“更有一般底，锥又锥不动，召又召不应，此人作摩生委得虚之与实？”翠岩云：“兄则乞米，某甲则拾柴。”保福云：“与摩则[片*斥]布袋，造浴芡著？”

师行脚时，到盐官。盐官有一日云：“色即是空，空义不成；空即是色，色义不成。”师出来问：“承和尚有言：‘色即是空，空义不成；空即是色，色义不成。’岂不是和尚与摩道？”盐官云：“是也。”师敲禅床云：“这个是色，阿那个是空？”盐官不对。

师令八百来人到洪州见州主，州主手执越杖，便问师：“这个是什摩字？”师云：“欠一点。”便掴，州主便礼拜为师。

裴相公有一日微微底不安，非久之间便死。师恰在宅里，不抛相公头边底，坐看相公。相公无限时却惺，惺后说冥中事：“某一入冥界，有脚不普行，有眼不曾见。行得十四五十里困了，忽然见一池水。某甲拟欲入池，有一个老和尚，不与某甲入池里，便喝。因此再见和尚。”师云：“若不遇老僧，相公洎合造龙。”

师又时握拳云：“诸方老宿，性命总在这里，放也得，不放也得。”僧拈问招庆：“诸方老宿，性命总在这里，要放也得，不要放也得。如何是要放底事？”庆云：“恕你此问。”“如何是不要放底事？”招庆云“好与二十打。”

自余未睹行录，敕谥断际禅师广业之塔。

祖堂卷十六·西林操

西林操和尚嗣百丈。

师与大沩行次，忽然见驴吃草，师取驴吃底草，向大沩云：“底底。”大沩两手托地，便造驴声。师喝云：“这畜生。”大沩云：“适来见什摩？”师便掴。

有人拈问龙花：“作摩生道，则免得操禅师掴？”花云：“洎一向。”

自余不究化缘终始矣。

祖堂卷十六·古灵

古灵和尚嗣百丈，在福州。

师自少于福州大中寺出家。及至为僧，游参百丈，盘泊数年，密契玄旨。后归省侍本师，思欲发悟以报其恩，别俟方便。偶因一日为师澡浴，去垢之次，抚师背曰：“好个佛殿，而佛不圣。”其师乍闻异语，回头看之。弟子曰：“佛虽不圣，且能放光。”师深疑而不能问。

后得一日新糊窗，其日照窗陪明。师于窗下看经次，蝇子竞头打其窗，求觅出路。弟子侍立，云：“多少世界，如许多广阔，而不肯出头，撞故纸里，驴年解得出摩？”师闻此语，放下经卷，问：“汝行脚来见何人？得何事意？前后见汝发言盖不同常，汝子细向吾说看。”弟子见问，恰称本意，为说百丈大师指授《禅门心要》：灵光洞耀，迥脱根尘。体露真常，不拘文字。心性无染，本自圆明。离却妄缘，则如如佛。师于言下，万机顿息，叹曰：“不可思议！吾本闻佛，将谓独一，今始返照心源，有情皆尔。”因为同流，曰：“我弟子行脚，得上人法，我欲返答其恩，汝当佐助。”众为备筵敷法座毕，请弟子升座，略演百丈宗教。众闻所未闻，悉皆忻庆。师谓弟子曰：“吾为汝剃发之师，汝今为吾出世之师。吾今返礼汝，以答其恩耳。”弟子下座曰：“此乖世礼事，不可也。师若然者，当应面西遥礼百丈为师，即是同道不异也。”师则从之，遥礼百丈为师。

弟子后住古灵山，因为古灵和尚焉。聚徒十数年间，临迁化时，剃发澡浴，焚香声钟，集众告云：“汝等诸人还识得无声三味不？”众曰：“不识，请师指示。”师曰：“汝等静思静虑，谛听谛听。”师乃端坐而告寂。

祖堂卷十六·石霜

石霜性空和尚嗣百丈，在吉州。

僧问：“如何是西来意？”师曰：“如人在百丈井中，不假寸绳。出得此人，我则为答西来意。”僧云：“与摩则湖南近日亦有暢和尚为师。”僧东话西话，师唤沙弥：“拽出这个死尸著。”

自外未究终始矣。


祖堂集卷第十七

祖堂卷十七·大慈

大慈和尚嗣百丈，在抚州。师讳寰中。

有僧辞，师问：“什摩处去？”对云“江西去。”师云：“将取老僧去，得摩？”对云“非但和尚，更有过于和尚者，不能得将去。”后有人举似洞山，洞山云：“但道得。”

师上堂云：“说取一丈，不如行取一尺；说取一尺，不如行取一寸。说取那行处，行取那说处。”有人举似洞山，洞山欢喜云：“大慈和尚，为物情切。”僧便问：“彼中则如此，此间还有也无？”洞山云：“有。”僧云：“若与摩则便请。”洞山云：“行取那说不得处，说取那行不得处。”洞山又云：“离此二途作摩生？”僧对云：“离此二途，请师不问。”洞山云：“海上功秀，又作摩生？”对云：“石人唱歌，幻人抚掌。”

有人举似云居，云居云：“行时无说路，说时无行路。不说不行，合行什摩路？”有人举似乐浦，乐浦云：“行说俱到，本事［按：当作“本分事”］无。行说俱不到，本事在。”又云：“大慈和尚则古佛，洞山和尚则细□。” 师又闻举云：“作家。”

师行脚时，三人同行，逢见女人收稻次，问：“退山路何处去？”女人云：“蓦底去。”师云：“前头水深，过得摩？”女云：“不湿脚。”师云：“上岸稻得与摩好，下岸稻得与摩勿次第。”女云：“下岸稻总被螃蟹吃却。”师云：“太香生。”女云：“无气息。”师云：“住在什摩处？”女云：“只在这里。” 三人到屋里，其女见来，点一瓶茶，排批了云：“请上座用神通吃。”三人不敢倾茶。女云：“看老婆呈神通去也。”拈起盏子，便泄行茶。

自外未睹行录，不决化缘终始。敕谥性空禅师定慧之塔。

祖堂卷十七·西院

福州西院和尚嗣百丈，师讳大安。福州福唐县人也。未睹行状，不知姓族。

自少于黄檗寺出家，乃至为僧。本拟听习，因在洪州招提，偶闻行脚僧举百丈一二句玄机，似少省觉，从尔便造百丈。

既睹盛筵，深称志慕，礼问百丈曰：“学人欲求识佛，如何是佛？”百丈云：“太似骑牛觅牛。”师云：“识得后如何？”百丈云：“如人骑牛至家。” 师云：“未审始终如何保任，则得相应去？”百丈云：“譬如牧牛之人，执鞭视之，不令犯人苗稼。”师从兹领旨，顿息万缘。

性好辛勤，少亲言论，更不寻经讨论，放旷任情。夜则山野头陀，昼则倍加执役。后随佑禅师，同创沩山，则十数年间，僧众犹小。师乃头头耕耨，处处劳形，日夜忘疲，未尝辄暇。沩山见而语曰：“安，汝少劳役。”师云： “待和尚观五百众，安则休也。”不久之间，僧众果至五百。师乃劳心顿摆，或坐房廊，凝如株杌；或入灵洞，月十不归，如痴似狂。三十余祀，夜在第二第三座间。有同流私睹其身，焰尔通光，众人佥曰：“定光佛矣。”

问：“黄巢军来，和尚向什摩处回避？”师云：“五蕴山中。”僧云：“忽被捉著时作摩生？”师云“恼乱将军，恼乱将军。”

问：“此阴已谢，彼阴未生时，其中事如何？”师曰：“此阴未谢时，阿那个是大德？”对云：“不会。”师云：“此阴未谢尚不会，问与摩时事作什摩？”

有俗官问：“佛在什摩处？”师云：“不离心地。”又问：“双峰上人，有何所得？”师云：“法无所得。设有所得，得于本得。”问：“大用现前，不存轨则时如何？”师云：“用得便用。”其僧裸形，绕师三匝。师云：“向上何不道取？”僧才拟开口，师打之云：“这野狐精。”

罗汉和尚拈问僧：“当此之时，作摩生免得被他喝出？”僧对云：“便抽身出去。”罗汉云：“落脊棒又作摩生？”僧却回头：“今日赖遇某甲。”罗汉云：“识得阇梨骨也。”

问：“一切施为，尽是法身用。如何是法身？”师云：“一切施为，尽是法身用。”问：“离却五蕴，如何是本来身？”师云：“地水火风，受想行识。这个是五蕴。”

有僧到大沩，师指面前狗子云：“明明个，明明个。”僧便问师：“既是明明个，为什摩刺头在里许？”师云：“有什摩罪过？”有人举似雪峰，雪峰云：“沩山是古佛也。”

师又时上堂云：“汝诸人来就安觅什摩？若欲得作佛，汝自是佛。担却一个佛，傍家走扬扬。渴鹿趁阳焰相似，何时得相应去？阿你欲得作佛，汝但无如许多颠倒攀缘，妄想恶觉，垢欲不净、众生之心，则汝便是初心正觉佛，更去何处别讨？所以安在沩山，三十年来，吃沩山饭，屙获山屎，不学沩山禅，只是长看一头水牯牛，落路入草便牵出，侵犯人苗稼则鞭打。调来伏去，可怜生，受人言语。如今一时变作个露地白牛，常在面前，终日露迥迥地，趁亦不肯去。汝道什摩语话？汝诸人各自身中有无价大宝，从眼门放光，照山河大地；耳门放光，领览一切善恶音响，六门昼夜常放光明，亦名放光三昧，汝自有，何不识取？影在四大身中，内外扶持，不教倾侧。两脚若子大，担得二硕，从独木桥上过，亦不教伊倒地，且是什摩物？汝若觅毫发，则不可见，故志公云：‘内外追寻觅总无，境上施为浑大有。’”

有人拈问石门：“古人有言：‘安在沩山，三十年来，吃沩山饭，屙沩山屎，不学沩山禅。只是长看一头水牯牛，落路入草便牵出。侵犯人苗稼则鞭打。调来伏去，可怜生，受人言语。如今一时变作露地白牛，常在面前，终日露迥迥地，趁亦不肯去。’只如今古人与摩道，意作摩生？”石门云：“昔日话虎尚乃惊，如今见虎也不怕。”僧云：“古人分上则与摩，学上分上如何？”石门云：“取我与食，驴年得味摩？”

师垂化闽城二十载，至中和三年癸卯岁十月二十一日顺化。敕谥圆智大师正真之塔。

祖堂卷十七·处微

处微和尚嗣西堂。

师问仰山：“汝名什摩？”对曰：“慧寂。”师曰：“阿那个是惠？阿那个是寂？”对云：“只在目前。”师曰：“你犹有前后在？”对曰：“前后则且置，和尚还曾见未？”师曰：“吃茶去。”

问：“三乘十二分教，体理得妙。是祖师意，为复不是祖师意？”师云： “三乘十二分教，体理得妙。何处更有祖师意？虽然与摩，须向六句外鉴。若也鉴不得，随声色转也。”僧云：“作摩生是六旬？”师曰：“语底，嘿底；不嘿底，不语底；总是，总不是。”

祖堂卷十七·陈田寺元寂

雪岳陈田寺元寂禅师嗣西堂，在溟州，师讳道义，俗姓王氏，北汉郡人。

未妊之前，其父见白虹入室，又母梦中见僧同床而寝，觉闻香气芬馥，父母愕然，共相谓曰：“据斯嘉瑞，必得圣子。”经于半月，知有身。因在胎三十九月，方始产生。分娩之日，忽有异僧，杖锡到门曰：“今日所产兒胎，可置临河之山/弗。”言毕，忽然不见。遂从僧言，将胎埋之。大鹿来守，终年不去。经历人见，不起害心。因瑞出家，法号“明寂”。

以建中五年岁次甲子，随使韩粲号金让恭，过海入唐，直往台山，而感文殊。空闻圣锺之响，山见神鸟之翔。遂届广府宝坛寺，始受具戒。

后到曹溪，欲礼祖师之堂，门扇忽然自开，瞻礼三遍而出，门闭如故。

次诣江西洪州开元寺，就于西堂智藏大师处，顶谒为师，决疑释滞。大师犹若摭石间之美玉，拾蚌中之真珠，谓曰：“诚可以传法，非斯人而谁？” 改名道义，于是头陀而诣百丈山怀海和尚处，一似西堂。和尚曰：“江西禅脉，总属东国之僧欤？”

余如碑文。

祖堂卷十七·东国桐里

东国桐里和尚嗣西堂，师讳慧彻。谥号寂忍禅师，照轮清净之塔。

祖堂卷十七·东国实相

东国实相和尚嗣西堂，师讳洪直。谥号证觉大师凝寂之塔。

祖堂卷十七·东国慧目山

东国慧目山和尚嗣章敬，师讳玄昱。俗姓金氏，东溟冠族。父讳廉均，官至兵部侍郎。妣朴氏，能孕之际，梦得殊常，以贞元三年五月五日诞生。

才有童心，便知佛事。每汲水以供鱼，常聚沙而为塔。年至壮齿，志愿出家。既持浮海之囊，遂落掩泥之发。元和三年遂受具戒，长庆四年入于大唐。

至太原府，历居二寺，颇志巳成。随本国王子金义宗奉诏东归。以开成二年九月十二日达于本国。武州会津南岳实相安之、敏哀大王、神武大王、文圣大王、宪安大王，并执师资之敬，不徵臣伏之仪。每入王官，必命敷座诵法。自开成末，结苑于慧目山埵。景文大王命居高达寺，奇香妙药，闻阙必供。暑葛寒裘，待时而授。

九年秋解夏之始，忽告门人曰：“我今岁内法缘当尽，你等宜设无遮大会，以报百岩传授之恩，终吾志也。”

十一月十四日中夜，忽尔山谷震动，鸟兽悲呜，寺锺击而不响三日。十五日未曙，遽命侍者撞无常锺，胁席而终，享年八十二，僧腊六十耳。

祖堂卷十七·公畿

公畿和尚嗣章敬，在河中府。

有人问：“如何是禅？如何是道？”师云：“有名非大道，是非俱不禅。欲知此中意，黄叶止啼钱。”

祖堂卷十七·关南

关南和尚嗣盐官，在襄阳。师讳道常。

有《乐道歌》曰：

三界兮如焰，六道兮如幻。圣贤出世兮同电。

国土犹如水上泡，无常生灭频迁变。

唯有摩诃大般苦，坚如金刚是可羡。

软似兒罗大等空，极小纤尘不可见。

拥之令聚而不聚，拨之令散而不散。

侧耳欲闻而不闻，瞪口观之不能见。

歌复歌，盘陂石上笑呵呵；

笑复笑，青萝松下高声叫。

自从顿获此明珠，帝释轮王都不要。

不是山僧独施为，自古先贤作此调。

不坐禅，不修道，任运逍遥只摩好。

但知万法不干怀，无如何曾有生老？

祖堂卷十七·通晓

溟州[山*窟]山故通晓大师嗣盐官，法讳梵日，鸠林冠族金氏。祖讳述元，官至溟州都督，廉平察俗，宽猛临人，清风尚在于民谣，余列备于传乎。其母支氏，累叶豪门，世称妇范。及其怀娠之际，梦徵捧日之祥，爰以元和五年庚寅正月之辰，在胎十三月而诞生。螺髻殊姿，顶珠异相。

年至一五，誓愿出家。谘于父母，二亲共相谓曰：“宿缘善果，不可夺志。汝须先度吾未度也。”于是落采辞亲，寻山入道。年至二十，到于京师，受具足戒，净行圆备，精勤更励，为锱流之龟镜，作法侣之楷模。

洎乎大和年中，私发誓愿，往游中华，遂投入朝王子金公义琮，披露所怀。公以重善志，许以同行。假其舟楫，达于唐国。既谐宿愿，便发巡游，遍寻知识。

参彼盐官济安大师，大师问曰：“什摩处来？”答曰：“东国来。”大师进曰：“水路来，陆路来？”对云：“不踏两路来。”“既不踏两路，阇梨争得到这里？”对曰：“日月东西，有什摩障碍？”大师曰：“实是东方菩萨。”

梵日问曰：“如何即成佛？”大师答曰：“道不用修，但莫污染。莫作佛见菩萨见，平常心是道。”梵日言下大悟，殷勤六年。

后师到药山，药山问：“近离什摩处？”师对曰：“近离江西。”药山问： “作什摩来？”师对曰：“寻和尚来。”药山问：“此间无路，阇梨作摩生寻？” 师对曰：“和尚更进一步即得，学人亦不见和尚。”药山曰：“大奇大奇，外来青风冻杀人。”

欲恣游方，远投帝里。值会昌四年沙汰僧流，毁坼佛宇。东奔西走，窜身无所。感河伯之引道，遇山神之送迎。遂隐高山，独居禅定。拾坠果以充斋，掬流泉而止渴。形容枯槁，气力疲羸，未敢出行。直逾半载，忽梦异人云：“今可行矣。”于是强谋前行，力未可丈。须臾，山兽口衔饼食，放于座侧，虑其故与，收而食焉。

后以誓向韶州，礼祖师塔，不遥千里，得诣曹溪。香云忽起，盘旋于塔庙之前。灵鹤倏来，嘹唳于楼台之上。寺众愕然，共相谓曰：“如此瑞祥，实未曾有。应是禅师来仪之兆也。”于是思归故思，弘宣佛法。

却以会昌六年丁卯八月，还涉鲸浪，返于鹤林。亭亭戒月，光流玄兔之城；皎皎意珠，照彻青丘之境。暨大中五年正月，于白达山宴坐，溟州都督金公仍请住[山*窟]山寺。一坐林中，四十余载。列松为行道之廊，平石作安禅之座。

有问：“如何是祖师意旨？”答曰：“六代不曾失。”又问：“如何是纳僧所务？”答曰：“莫踏佛阶级，切忌随他悟。”

咸通十二年三月景文大王，广明元年宪康大王，光启三年定康大王，三王并皆特迂御礼，遥申钦仰，拟封国师。各差中使，迎赴京师。大师久蕴坚贞，礭乎不赴矣。

忽于文德二年酉西四月末，召门人曰：“吾将他往，今须永诀。汝等莫以世情浅意，乱动悲伤，但自修心，不坠宗旨也。”即以五月一日右胁累足，示灭于[山*窟]山寺上房。春秋八十，僧夏六十，谥号通晓大师，塔名延徽之塔。

祖堂卷十七·普化

普化和尚嗣盘山，在镇州。未睹行录，不决化缘始终。

师在市里，遇见马步使，便相扑势。马步使便打五棒。师云：“似则似，是则不是。”师寻常暮宿冢间，朝游城市。把铃云：“明头来也打，暗头来也打。”

林际和尚闻此消息，教侍者探师。侍者来问师：“不明不暗时事作摩生？”师曰：“明日大悲院有斋。”侍者归来举似。林际便欢喜云：“作摩生得见他？”

非久之间，普化自上来林际，林际便欢喜。排批饭食，对坐吃。师凡是下底物，总吃却。林际云：“普化吃食，似一头驴。”师便下座，两手托地，便造驴声。林际无语。师云：“林际厮兒，只具一只眼。”

后有人举似长庆，长庆代林际进语云：“也且从，更作摩生？”又代普化云：“被长老申此一问，直得酩酩酊酊。”

林际又问：“大悲菩萨，分身千百亿，便请现。”师便掷地卓子，便作舞势云：“底底。”便去。又林际上堂，师侍立次。有一僧在面前立，师蓦推倒林际前，林际便把杖子打三下。师云：“林际厮兒，只具一只眼。”又林际与师看圣僧次，林际云：“是凡是圣？”师云：“是圣。”林际便喝咄，师便抚掌大笑。

师得一日手擎函板，绕郭辞人云：“我迁化去。”众人云集相随东门而出，云：“今日不好。”二日南门，三日西门，人众渐少，不信。第四日北门而出，更无一人随之，自辟/瓦证[土*遂]门而卒矣。

祖堂卷十七·无染

嵩严山圣住寺故两朝国师嗣麻谷，法号无染，庆州人也。

俗姓金氏，以武烈大王为八代之祖，大父名周川，品在真骨，位在韩粲，高、曾皆为相为将。父名范清，族品降于真骨一等，乡谈得难。母华氏，梦感修臂天人，垂授藕花，因此有娠。又时梦中胡道人，授十戒为胎教，过其 /月而诞焉。以十二岁，落染于雪岳。五色石寺有法性禅师，尝扣楞伽门于其中夏，大师事师数年。

长庆之初入唐，到佛爽寺问道，如满印可于江西之印，而应对有惭色曰： “吾阅人多矣，罕有如是东国人，他日中国失禅之时，将问之东夷焉。”又到麻谷宝彻和尚处，服勤执役，无看所择，人所难者，必能易之。众人目曰： “禅门之中，异德高行。”彻公曰：“我师马和尚诀我曰：‘若得东人可目击者，畎渠道中，俾慧水丕胃于海隅，为德非浅。’师言在耳，吾喜汝来，今印焉。俾冠禅俟于东土，往钦哉。”已得心珠于麻谷。

会昌六年，回归本国。大中元年，始就居于嵩岩山圣住寺，僧徒千众，名震十方。于是大师吐珠于嵩严寺，内授印于祖师根中。繇是两朝圣主天冠倾于地边，一国臣寮，头面礼于足下。

大师禅定之余暇，应求之机缘。有人问曰：“无舌土中无师无弟，何故从西天二十八代，至于唐代六祖，传灯相照，至今不绝耶？”答曰：“皆是世上流布，故不是正传。”问曰：“一祖师中具二土耶？”答曰：“然也。是故仰山云：‘两口一无舌，即是吾宗旨。’”问曰：“一祖师中，见二土如何？” 答曰：“正传禅根，不求法故。”师亦不饷，是为无舌土也。应实求法之人，用假名言之说，是名有舌土矣。然则文孝康王，以为事师，然后定康大王即位，皆承前规奉迎，然而年当九十，不能上阙。

国师以文德元年暢月二十七日示灭，谥号大朗慧大师白月葆光之塔。

祖堂卷十七·天龙

天龙和尚嗣大梅。未睹行录，不决化缘始终。

祖堂卷十七·正原

正原和尚嗣五泄，同住龟山。姓蔡，宣州南陵县人也。

贞元十五年，落发于当州藉山。元和丁酉岁，建州乾元寺受具。

师灵苗间出，道器混成。桂芬少以呈香，松柏新而见节。始从稚子，不狎朋游。寻会稽之丛林，契五泄之密印。师有偈曰：

沧溟几度变桑田，唯有处空独湛然。

已到岸人休恋筏，未曾度者任须船。

又云：

寻师认得本心源，两岸俱玄一不全。

是佛何须更求佛，只因从此便忘言。

又云：

忍仙林下坐禅时，曾被歌王截四支。

况我圣明无此事，只令休道亦何悲。

又云：

心本绝尘何用洗，身中无病岂求医。

欲知是佛非身处，明镜高悬未照时。

师享龄七十八，为僧五十四夏。敕谥性空大师慧观之塔。后至天佑二年龙集乙丑八月，闽王重建塔，凡是国家祈祷，灵应生民，迄至于今，香灯续焰。天龙仰卫，士庶倾瞻，号龟山二真身。至梁开平四年庚午岁，省弁阝制碑文矣。

祖堂卷十七·芙蓉

芙蓉和尚嗣归宗，在福州。师讳灵训，福州侯官县人也。姓危。

初参见归宗，问：“如何是佛？”宗云：“向你道，你还信不？”对曰： “和尚若道，那敢不信。”宗云：“信即是佛，即汝便是。”师云：“如何保任？” 宗云：“一翳在目，空花乱堕。”

师领受玄旨，便创芙蓉。住持严整，海内闻名。

入灭之后，敕谥弘照大师圆相之塔。

祖堂卷十七·岑和尚

岑和尚嗣南泉，在湖南。未睹实录，不决化缘终始。

问：“如何是诸佛师？”师云：“不可拗直作曲。”问：“如何是向上一路？”师云：“一里二里。”僧云：“请师道。”师云：“三里四里。”问：“如何是学人心？”师云：“尽十方世界是汝心。”

僧云：“与摩则学人无着身处。”师云：“是汝著身处。”僧云：“如何是学人著身处？”师云：“大海水深又深。”僧云：“学人不会。”师云：“鱼龙出没任升沉。”

问：“古人有言：动是法王苗，寂是法王根。’如何是法王根？”师指露柱云：“何不问取大士？”僧云：“如何是法王苗？”师云：“道什摩？道什摩？”

问：“学人不据地时如何？”师云：“向什摩处安身立命？”僧云：“学人却据地时如何？”师云：“拽出死尸。”问：“如何是本来地？”师云：“一步两步。”僧云：“本来地是地不是地？”师云：“三步四步。”

会和尚云：“未有诸圣已前作摩生？”师云：“鲁祖开堂，亦与师僧东话西话。”三圣和尚问：“请和尚说向上。”师云：“阇梨眼瞎耳聋作什摩？”

问：“如何是玄旨？”师云：“虚空道得。”僧云：“虚空常道，还有断时也无？”师云：“徒劳念静。”问：“请和尚道。”师云：“不可重道。”

问：“如何是沙门眼？”师云：“长长出不得。”又云：“成佛成祖出不得，六道轮回亦出不得，汝道出什摩不得？”僧便问：“未审出什摩不得？”师云：“昼见日，夜见星。”僧云：“学人不会。”师云：“妙高山色青又青。”

问：“如何是异类？”师云：“尺短寸长，寸长尺短。”问：“上上人相见时如何？”师云：“如死人手。”“如何是上上人行李处？”师云：“如死人眼。”问：“如何是无情说法？”师指东边露柱云：“这个师僧说得。”僧云： “什摩人得闻？”师指西边露柱云：“这个师僧得闻。”僧云：“师还闻摩？” 师云：“我若闻，则教谁举？”师示众云：“富贵则易，贫穷则难。”又云：“今时禅师，只识得天子，终不识未作天子已前。”师《劝学偈》曰：

万丈竿头未得休，堂堂有路少人游。

禅师欲达南泉去，满目青山万万秋。

问：“如何是平常心？”师云：“要眠则眠，要坐则坐。”僧云：“学人不会。”师云：“热则取凉，寒则向火。”

问：“有人问和尚，和尚则随问答话。总无人问时，和尚如何？”师云： “困则睡，健则起。”僧云：“教学人向什摩处领会？”师云：“夏天赤骨身，冬天须得被”。

问：“南泉迁化，向什摩处去？”师云：“东家作驴，西家作马。”僧云： “学人不会。”师云：“要骑则骑，要下则下。”师《诫斫松竹人偈》曰：

千年竹，万年松，枝枝叶叶尽皆同。

为报四方参学者，动手无非触祖翁。

师《投机偈》曰：

处处真，处处真，尘尘尽是本来人。

真实说时声不现，正体堂堂没却身。

问：“如何是西来祖教？”师良久，学人不敢进语。师令侍者去会和尚处，问：“和尚见南泉后如何？”会和尚良久，侍者进云：“未见南泉已前事如何？”会和尚云：“不可别更有也。”侍者却归举似师，师当时有偈曰：

百尺竿头不动人，虽然得入未为真。

百尺竿头须进步，十方世界是全身。

三圣和尚问：“承师有言：‘百尺竿头须进步。’百尺竿头则不问，百尺竿头如何进步？”师云：“朗州山，澧州水。”进曰：“更请和尚道。”师云： “四海五湖王化里。”“亡僧迁化，向什摩处去？”师云：“历劫无言真性命，解语能行却死人。”

三圣和尚令秀上座问师：“南泉迁化，向什摩处去也？”师云：“石头作沙弥时，参见六祖。”上座云：“不问石头作沙弥时参见六祖。南泉迁化，向什摩处去也？”师云：“教伊寻思去。”上座云：“虽有千尺之松，且无抽条石笋。”师嘿然。上座礼拜起云：“谢师答话。师又嘿然。上座却归，举似三圣。三圣云：“若实如此，胜林际七步。虽然如此，待我更验看。”

至明日，三圣问讯曰：“昨日答那个师僧一转因缘，为只是光前绝后，古今罕闻。”师又不语。师因事颂曰：

自觉开佛堂，慧放五道光。

无人不佛佛，不悟意中藏。

师问僧：“从什摩处来？”对云：“从洞山来。”师云：“何不教洞山自来？”对云：“只与摩。”师云：“彼自无疮，勿以伤之。”

有人问：“如何是第二月？”师云：“正月第二月。”又云：“恰是。”师乃颂曰：

也大奇，也大奇，一月之中两月疑。

见与见缘无自性，常寂谁是复谁非？

又须弥纳芥子颂曰：

须弥本非有，芥子元来空。

将空纳非有，何处不相容。

皓月供奉问曰：“教中说幻意，是有耶？”师曰：“大德是何言欤？”云：” 是无耶？”云：“是何言欤？”云：“与摩则幻意是不有不无耶？”师曰：“大德是何言欤？”大德进曰：“如□甲三明，尽不契圣意。未审和尚如何明教中幻意？”师曰：“大德信一切法不思议不？”大德云：“佛之诚言，那敢不信？”师云：“大德言信，二信之中，是阿那个信？”大德云：“如某甲所信，二信之中，名为缘信。”师云：“依何教文，得生缘信？”大德云：“《花严经》云：‘菩萨摩诃萨，无障无碍智慧，信一切世间境界，是如来境界。’又曰： ‘诸佛世尊，悉知世间法。性无差别，决定无二。’又曰：‘佛法世间法，若见真实，一切无差别。’”师曰：“所起缘信，所引教文，甚有来处。老僧与大德明教中幻意。”偈曰：

若人见幻本来真，是即名为见佛人。

圆通法界无生灭，无灭无生是佛身。

问：“蚯蚓斩两段，两头俱动，佛性在阿［?*那］个头？”师答曰：“动与不动，是何境界？”大德云：“言不关典，非智者之所谈。只如和尚言，动与不动是何境界？出自何经？”师答曰：“灼然。言不关典，非智者之所谈。大德岂不见道《首楞严经》云：‘当知十方无边不动虚空，并动摇地水火风，均名六大性真圆融，皆如来藏，本无生灭。”师有偈曰：

最甚深，最甚深，法界人身便是心。

迷者迷心为众色，悟时刹海是真心。

身界二座无实性，分明达此号知音。

有大德问：“虚空为定有耶？虚空为定无耶？”师答曰：“言有亦得，言无亦得。虚空有时，但有假有。虚空无时，但无假无。”大德再问：“只如和尚所说，有何教文？”师答曰：“大德岂不闻《首楞严经》云：‘十方处空生汝心内，犹如片云点太清里。’岂不是虚空生时但有假有？汝等一人发真归源，此十方虚空悉皆消陨，岂不是虚空灭时但灭假灭？老僧所以道：‘有时假有，无时假无。’”

问：“天下善知识，为证大涅盘不？”师云：“为问因中三德，为问果上三德？”大德云：“为问果上三德。”师云：“若问果上三德。天下善知识未证大涅盘。”又问：“何故未证大涅盘？”师云：“功未齐于诸佛，所以未证大涅盘。”又问：“既功未齐于诸佛，何故名为善知识？”师答曰：“明见佛性，名为善知识。”皓月云：“若与摩则功齐何道，名为证大涅盘？”以偈曰：

摩诃般若照，解脱甚深香。

法身寂灭体，三一理圆常。

欲识功齐处，此名常寂光。

皓月再问：“果上涅盘，已蒙和尚指示。如何是本来涅盘？”师答曰：“大德是。”

问：“和尚承嗣何人？”师云：“我无人承嗣。”云：“师还参学不？”师云：“我自参。”“师意如何？”师偈曰：

虚空问万象，万象答虚空。

何人得亲问，木叉丫角童。

问：“如何是教？”师云：“五千四十八卷。”“如何是教意？”师曰：“祖意即是。”问：“如何是祖师意？”师云：“教意即是。”学云：“与摩即教意与祖意无二去也。”师云：“十方佛土中，唯有一乘法。无二亦无三。”大德便礼拜，师偈曰：

祖心即教意，教意即祖意。

欲识祖师意，祖师传佛心。

祖意与教意，一性一真心。

问：“第八识及七六识等，毕竟无体。云何得言‘转第八识为大圆镜’？” 师答曰：“岂不闻‘转名不转体’？”师偈曰：

七生依一灭，一灭持七生。

一灭灭亦灭，七六永无生。

第九真常识，非后亦非先。

非后非先义，常住永无迁。

问：“古人有言：‘了即业障本来空，未了应须尝宿债。’师子尊者与二祖大师，为甚摩却偿债？”师云：“大德不识本来空。”皓月云：“如何是本来空？”师云：“业障是。“如何是业障？”师云：“本来空是。”皓月礼谢。师偈曰：

假有元非有，假灭亦非无。

涅盘偿债义，一性更无殊。

问：“本心何故不离生灭心？生灭心何故不当本来心？”师以偈答曰：

妙空妙用不思议，无灭无生无所依。

本觉性真为智父，父生智子妙难思。

智智不觉元来妙，达见无观即本如。

父子本来无二相，即今即本更无时。

问：“如何是陀罗尼？”师云：“大德无问，老僧无答。”又问：“是何人诵得？”师指禅床左臂云：“这个师僧诵得。”又问：“如何得闻？”师指禅床右臂云：“这个师僧得闻。”大德云：“某甲为什摩不闻？”云：“岂不闻‘真诵无响，真听无闻’？”大德云：“与摩则音声不入法界性耶？”师云：“大德岂不闻道‘离色求观非正见，离声求闻是邪闻’？”又问：“如何是‘不离色是正见，不离声是真闻’？”师云：“大德听老僧相助明。”以颂曰：

满眼本非色，满耳本非声。

文殊常触目，观音塞耳根。

会三元一体，达四本同真。

堂堂法界性，无佛亦无人。

问：“善财童子，为什摩无量劫游普贤身中世界不遍？”师云：“从无量劫来，还游得遍摩？”又问：“如何是普贤身？”云：“含元殿里，更觅长安。” 问：“如何是文殊？”师云：“墙壁瓦砾即是。”问：“如何是观音？”师云： “音声语言即是。”问：“如何是普贤？”云：“众生心即是。”问：“如何是佛？”师云：“众生色身是佛。”问：“恆沙诸佛体皆同，何故说有种种名号？” 师云：“眼根返源，名为文殊；耳根返源，名为观音；意识返源，名为普贤。文殊是佛妙观察智，观音是佛无缘大悲，普贤是佛无为妙行，三圣是佛之妙用，佛是三圣之真体。用有恆沙假名，体总名为一博伽梵。”又问：“四圣为定是四耶？”师云：“灯分千室，元是一光。潮应万波，本来一水。迷人差别，智者同真。是故先德云：‘非唯我今独达了，恆沙诸佛体皆同’。”

问：“教中有言：‘十劫坐道场，不得成佛道’。未审此意如何？”师云： “佛是果，菩萨是因。释迦如来，于果地谈大通智胜佛因中事。大通智胜佛，虽十劫在著提树下，金刚座上，结跏趺坐，犹是菩萨未成佛故，为彼时众生寿命长故，根未熟故，过十劫已，众生根始熟。大凡菩萨，须待众生很熟。如鸡伺啐，啐啄同时。众生根熟，便成佛菩萨。故言‘过十劫已，证得无上菩提。’所以经曰：‘佛知时未至，受请嘿然坐。’”

有人问：“如何是触目菩提？”师答曰：“一切法常住。”“如何是一切法常住？”师曰：“触目菩提。”问：“如何转得山河大地归于自己去？”师答曰：“我却忧转自己归山河大地去。”学人礼谢，师偈曰：

谁问山河转，山河转向谁？

圆通无两畔，法性本无归。

问：“如何是色本殊质像？”师曰：“尽十方世是什摩？”进曰：“如何是声元异乐苦？”师答曰：“将来，将来。”

问：“教中有言：‘色不异空，空不异色。’未审教意如何？”师以偈答曰：

碍处无墙壁，通处勿虚空。

若能如是解，心色本来同。

自外具载别录，谥号招贤大师。

祖堂卷十七·白马

白马和尚嗣南泉，在江陵。师讳昙照。未睹实录。

问曰：“如何是学人自己？”师以杖当面指学人。长庆和尚举此因缘，以手指面前云：“古人只与摩。”又竖起指云：“何似与摩？顺德大师云：“虾跳不出斗。”庆不肯。自代云：“是什摩心行？”

祖堂卷十七·下堂

下堂和尚嗣南泉，在襄州。

有俗官问：“蚯蚓断，两头欲动，佛性在阿那个头？”师展开两手而示。洞山和尚云：“即今问底，在阿那个头？”

祖堂卷十七·双峰

双峰和尚在南泉。师讳道允，姓朴，汉州鵂岩人也。

累叶豪族，祖考仕宦，郡谱详之。母高氏，夜梦异光荧煌满室，愕然睡觉，有若怀身。父母谓曰：“所梦非常，如得兒子，盍为僧乎？”寄胎十有六月载诞。尔后日将月就，鸖貌鸾姿，举措殊侪，风规异格。竹马之年，摘花供佛；羊车之岁，累塔娱情，玄关之趣昭然，真境之机卓尔。年当十八，恳露二亲，舍俗为僧。适于鬼神寺，听于花严教。禅师窃请曰：“圆顿之筌蹄，岂如心印之妙用乎？”遂被毳挈瓶，栖云枕水。

洎于长庆五年，投入朝使，告其宿志，许以同行。既登彼岸，获觐于南泉普愿大师。伸师资之礼，目击道存。大师叹曰：“吾宗法印，归东国矣。”

以会昌七祀夏初之月，旋届青丘，便居枫岳。求投者风驰雾集，慕来者星逝波奔。于是景文大王闻名归奉，恩渥日崇。

咸通九载四月十八日，忽诀门人曰：“生也有涯，吾须远迈。汝等安栖云谷，永耀法灯。”语毕，怡然迁化，报年七十有一，僧腊四十四霜。五色之光，从师口出，蓬勃而散漫于天。伏以今上宠褒法侣，恩霈禅林，仍赐谥澈鉴禅师澄昭之塔矣。


祖堂集卷十八

祖堂卷十八·赵州

赵州和尚嗣南泉，在北地。师讳全谂，青社缁丘人也。

少于本州龙兴寺出家，嵩山琉璃坛受戒。不味经律，遍参丛林，一造南泉，更无他往。

既遭盛筵，宁无扣击？师问：“如何是道？”南泉云：“平常心是道。”师云：“还可趋向否？”南泉云：“拟则乖。”师云：“不拟时如何知是道？”南泉云：“道不属知不知，知是妄觉，不知是无记。若也真达不拟之道，犹如太虚，廓然荡豁，岂可是非？”师于是顿领玄机，心如朗月，自尔随缘任性，笑傲浮生，拥毳携筇，周游烟水矣。

师问座主：“所业什摩？”对云：“讲《维摩经》。”师云：“维摩还有祖父也无？”对云：“有。”师云：“阿那是维摩祖父？”对云：“则某甲便是。”师云：“既是祖父，为什摩却与兒孙传语？”座主无对。问：“学人拟作佛去时如何？”师云：“费心力。”僧云：“不费心力时如何？”师云：“作佛去。”问：“夜升兜率，昼降阎浮，其中摩尼为什摩不现？”师云：“道什摩？”僧再问，师云：“不见道，‘毗婆尸佛早留心，直至如今不得妙’？”有僧辞。“什摩处去？”对云：“南方去。”师云：“三千里外逢人莫喜。”僧云：“学人不会。”师云：“柳絮，柳絮！”问第一座：“堂中还有祖父摩？”对云：“有。”师云：“唤来与老僧洗脚。”

师示众云：“我这里亦有在窟师子，亦有出窟师子，只是无师子兒。”有僧出来弹指两三下，师云：“作什摩？”僧云：“师子兒。”师云：“我唤作师子，早是罪过，你又更蹴踏作什摩？”问：“与摩来底人，师还接也无？”师云：“接。”“不与摩来底人，师还接也无？”师云：“接。”僧云：“与摩来底人从师接，不与摩来底人，师如何接？”师云：“止止不须说，我法妙难思。”问：“如何是平常心？”师云：“虎狼野干是。”僧云：“还教化也无？”师云：“不历你门户。”僧云：“与摩莫平沉那个人也无？”师云：“大好平常心！”

大王礼拜师，师不下床。侍者问：“大王来，师为什摩不下地？”师云：“汝等不会。上等人来，上绳床接；中等人来，下绳床接；下等人来，三门外接。”师问座主：“久蕴什摩业？”对云：“《涅盘经》。”师问座主：“一段义得不？”对云：“得。”师以脚踢空中，口吹，却问：“这个是《涅盘经》中义不？”云：“是。”师云：“会摩？”“不会。”师云：“这个是五百力士结成［揭石］之义。”师示众云：“我三十年前在南方火炉头，举无宾主话，直至如今无人道著。”有人举问雪峰：“赵州无宾主话作摩生道？”雪峰便踏倒。

师又到一老宿处，老宿云：“老大人何不觅取住处？师云：“什摩处是某甲住处？”老宿云：“老大人住处也不识！”师云：“三十年学骑马，今日被驴扑。”问：“离教请师决。”师云：“与摩人则得。”僧才礼拜，师云：“好问，好问。”僧云：“谘和尚。”师云：“今日不答话。”问：“澄澄绝点时如何？”师云：“我此间不著这个客作汉。”问：“如何是和尚家风？”师云：“不向你道。”僧云：“为什摩不道？”师云：“是我家风。”问：“如何得报国王恩？”师云：“念佛。”僧云：“街头贫兒也念佛。”师拈一个钱与。问：“如何是本分事？”师指学人云：“是你本分事。”僧云：“如何是和尚本分事？”师云：“是我本分事。”问：“如何是佛向上事？”师云：“我在你脚底。”僧云：“师为什摩在学人脚底？”师云：“为你不知有佛向上事。”问：“如何是密室中人？”师展手云：“茶盐钱布施。”有人问云居：“赵州与摩道，意作摩生？”云居云：“八十老公出场屋。”问：“柏树子还有佛性也无？”师云：“有。”僧云：“几时成佛？”师云：“待虚空落地。”僧云：“处空几时落地？”师云：“待柏树成佛。”

新到展座具次，师问：“近离何方？”僧云：“无方面。”师起向僧背后立，僧把座具起，师云：“太好无方面！”僧辞次，师问：“外方有人问：‘还见赵州也无？’作摩生向他道？”僧云：“只道见和尚。”师云：“老僧似一头驴，汝作摩生见？”僧无对。师问新到：“近离什摩处？”云：“近离南方。”师云：“什摩人为伴子？”僧云：“畜生为伴子。”师云：“好个阇梨，为什摩却与畜生作伴子？”僧云：“无异故。”师云：“大好畜生！”僧云：“争肯？”师云：“不肯则一任，还我伴子来。”僧无对。有僧才礼拜，师云：“珍重。”僧申问，师云：“又是也，又是也。”问：“学人去南方，忽然雪峰问赵州意，作摩生祗对？”师云：“遇冬则寒，遇夏则热。”进曰：“究竟赵州意旨如何？”师云：“亲从赵州来，不是传语人。”其僧到雪峰，果如所问，其信一一如上举对。雪峰曰：“君子千里同风。”

问：“如何是祖师西来意？”师云：“亭前柏树子。”僧云：“和尚莫将境示人。”师云：“我不将境示人。”僧云：“如何是祖师西来意？”师云：“亭前柏树子。”问：“如何是学人师？”师云：“云有出山势，水无投涧声。”僧云：“不问这个。”师云：“是你师不问。”问：“头头到这里时如何？”师云：“犹较老僧一百步。”问：“方圆不就时如何？”师云：“不方不圆。”云：“与摩时作摩生？”师云：“是方是圆。”师有时云：“佛之一字，吾不喜闻。”僧问：“师还为人不？”师云：“佛也，佛也。”问：“一灯燃百千灯，未审一灯是什摩灯？”师跳出只履，又云：“若是作家，不与摩问。”问：“如何是本来人？”师云：“自从识得老僧后，只这个汉更无别。”僧云：“与摩则共和尚隔生也。”师云：“非但千生与万生，也不识老僧。”师问沩山：“如何是祖师意？”沩山唤侍者将床子来，“自住已来，未曾遇著一个本色禅师。”时有人问：“忽遇时如何？师云：“千钧之弩，不为奚鼠而发机。”有人问：“诸佛还有师也无？”师云：“有。”僧进曰：“如何是诸佛师？”师云：“阿弥陀佛。”又师云：“佛是弟子。”有僧问长庆：“赵州与摩道阿弥陀佛，是导底语，是嗟底语？”长庆云：“若向两头会，尽不见赵州意。”僧进云：“赵州意作摩生？”长庆便弹指一声。

镇州大王请师上堂，师升座便念经，有人问：“请和尚上堂，因什摩念经？”师云：“佛弟子念经不得摩？”又别时上堂，师念《心经》，有人云：“念经作什摩？”师云：“赖得阇梨道念经，老僧洎忘却。”问：“如何是玄中又玄？”师云：“那个师僧若在，今年七十四也。”问：“如何是玄中一句？”师云：“不是如是我闻。”问：“寸丝不挂时如何？”师云：“不挂什摩？”僧云：“不挂寸丝。”师云：“大好不挂！”问：“迦叶上行衣，什摩人合得被？”师云：“七佛虚出世，道人都不知。”师问僧：“还曾到这里摩？”云：“曾到这里。”师云：“吃茶去。”师云：“还曾到这里摩？”对云：“不曾到这里。”师云：“吃茶去。”又问僧：“还曾到这里摩？”对云：“和尚问作什摩？”师云：“吃茶去。”师问僧：“你在这里得几年？”对云：“五六年。”师云：“还见老僧也无？”对云：“见。”“见何似生？”对云：“似一头驴。”师云：“什摩处见似一头驴？”对云：“入法界见。”师云：“去！未见老僧在！”有人举似洞山，洞山代云：“吃水吃草。”问：“朗月处空时人尽委，未审室内事如何？”师云：“自少出家，不作活计。”学曰：“与摩则不为今时去也。”师云：“老僧自疾不能救，争能救得诸人疾？”学曰：“与摩则来者无依。”师云：“依则榻著地，不依则一任东西。”师问僧：“从什摩处来？”对云：“从五台山来。”师云：“还见文殊也无？”对云：“文殊则不见，只见一头水牯牛。”师云：“水牯牛还有语也无？”对云：“有。”师曰：“道什摩？”对云：“孟春犹寒，伏惟和尚尊体起居万福。”

师有一日向七岁兒子云：“老僧尽日来心造，与你相共论义。你若输，则买糊饼与老僧；老僧若输，则老僧买糊饼与你。”兒子云：“请师立义。”师云：“以劣为宗，不得静胜。老僧是一头驴。”兒子云：“某甲是驴粪。”师云：“是你与我买糊饼。”兒子云：“不得和尚，和尚须与某甲买糊饼始得。”师与弟子相争，断不得。师云：“者个事军国事一般，官家若判不得，须唤村公断。这里有三百来众，于中不可无人。大众与老僧断：宾主二家，阿那个是有路？”大众断不得。师云：“须是具眼禅师始得。”三日以后，沙弥觉察，买糊饼供养和尚矣。

古时有官长教僧拜，马祖下朗瑞和尚不肯拜，官长便嗔，当时打杀。有人问师：“瑞和尚为什摩却被打杀？”师云：“为伊惜命。”龙花拈问僧：“惜个什摩命？”无对，龙花代云：“嗔我不得。”问：“正与摩时作摩生？”师云：“生公忍死十年，老僧一时不可过。”

师唤沙弥，沙弥应喏，师云：“煎茶来。”沙弥云：“不辞煎茶，与什摩人吃？”师便动口，沙弥云：“大难得吃茶。”有人拈问漳南：“又须教伊煎茶，又须得吃茶，合作摩生道？”保福云：“虽然如此，何不学观音？”有人问老婆：“赵州路什摩处去？”婆云：“蓦底去。”僧云：“莫是西边去摩？”婆云：“不是。”僧云：“莫是东边去摩？”婆云：“也不是。”有人举似师，师云：“老僧自去勘破。”师自去，问：“赵州路什摩处去？”老婆云：“蓦底去。”师归院，向师僧云：“敢破了也。”

院主请上堂，师升座唱如来梵，院主云：“比来请上堂，这个是如来梵。”师云：“佛弟子唱如来梵不得摩？”问：“开口是一句，如何是半句？”师便开口。三峰见师云：“上座何不住去？”师云：“什摩处住好？”三峰指面前山，师云：“此是和尚住处。”

师为沙弥，扶南泉上胡梯，问：“古人以三道宝阶接人，未审和尚如何接？”南泉乃登梯云：“一二三四五。”师举似师伯，师伯云：“汝还会摩？”师云：“不会。”师伯云：“七八九十。”南泉指铜瓶问僧：“汝道内净外净？”僧云：“内外俱净。”却问师，师便剔却。师问南泉：“古人道：‘道非物外，物外非道’。如何是‘物外非道’？”泉便棒，师云：“莫错打。”南泉云：“龙蛇易弁，纳子难谩。”问：“如何是西来意？”师云：“仲冬严寒。”有人举似云居，便问：“只如赵州与摩道，意作摩生？”居云：“冬天则有，夏月则无。”僧举似师：“只如云居与摩道，意作摩生？”师因此便造偈曰：

石桥南，赵州北，中有观音有弥勒，

祖师留下一只履，直到如今觅不得。

祖堂卷十八·紫胡

紫胡和尚嗣南泉，在衢州。未睹实录，不决化缘始终。

师因勘刘铁磨云：“见说有刘铁蘑，莫便是不？”尼云：“什摩处得这个消息来？”师云：“左转右转。”尼云：“莫颠倒。”师打之。南泉代云：“贯得此便。”师有时云：“从来事非物，方便名为佛。中下竞是非，上士始知屈。”又云：“三十年来住紫胡，二时斋粥气力粗。每日上山三五转，回头问汝会也无？”

师于半夜时叫唤：“贼也，贼也！”大众皆走。师于僧堂后遇一僧，拦胸把住叫云：“捉得也，捉得也。唤维那来！”僧云：“不是贼，某甲。”师云：“你正是贼。只是你不肯承当。”

有人拈问漳南：“紫胡捉贼意作摩生？”云：“还肯受珝摩波吒摩？”又拈问石门：“紫胡捉贼意作摩生？”云：“承当则骇汉，不承当则紫胡打汝。”

祖堂卷十八·陆亘

陆亘大夫嗣南泉和尚。

公亲受南泉心戒。大夫问南泉：“弟子家中有一片石。或坐或踏，如今镌作佛像，还坐得不？”南泉云：“得得。”陆亘云：“莫不得不？”泉云：“不得不得。”云岩云：“坐则佛，不坐则非佛。”洞山云：“不坐则佛，坐则非佛。”

南泉云：“摘一个字，添两字，佛法大行。有人摘得摩？”无人对。泉代云：“只今是有是无？”

大夫问南泉：“为大众请和尚说法。”泉云：“教老僧作摩生说？”大夫云：“岂无和尚方便？”泉云：“大夫道：‘他个欠少什摩？”大夫别时云：“则今和尚，不可思议。到处世界成就。”师云：“适来问底，总是太夫分上事。”

大夫又因拈起掷投，问南泉：“与摩又不得，不与摩又不得。正与摩信彩去时如何？”南泉拈掷投，抛下云：“臭骨头打十八。”有人举似石霜：“只如臭骨头打十八，意作摩生？”霜云：“汝道一半，我道一半。”进曰：“请师全道。”云：“怕汝。”僧拈问长庆：“南泉与摩道，意作摩生？”庆便掴之云：“今日非唯明古人。”又云：“一彩两塞。”

祖堂卷十八·仰山

仰山和尚嗣沩山，在怀化。师讳慧寂，俗姓叶，韶州怀化人也。

年十五，求出家，父母不许。年至十七，又再求去，父母犹吝。其夜有白光二道，从曹溪发来，直贯其舍。父母则知是子出家之志，感而许之。师乃断左手无名指及小指，置父母前，答谢养育之恩。

初于南花寺通禅师下剃发，年十八为沙强，行脚先参宗禅师，次礼耽原，在左右数年，学境智明暗一相，一闻而不再问。

后舍之而造大沩。初到自参沩山，沩山曰：“者沙弥，是有主沙弥，无主沙弥？”师云：“有主沙弥。”沩山云：“主在什摩处？”师在西边立，却向东边立。沩山察其异器，与言引接。

师问：“如何是佛？”沩山云：“以思无思之妙，返灵焰之无穷。思尽还源，性相常住。理事不二，真佛如如。”师于语下顿悟，礼谢指要。

在沩山盘泊十四五年间。凡在众中，只对沩山，谈扬玄秘，可谓鹫子之利辨，光大雄之化哉。

年三十五，领众出世，住前后诸州府，节察刺使，相继一十一人礼为师。师三处转法轮，敕锡澄虚大师，并紫衣矣。

每日上堂，谓众云：“汝等诸人，各自回光返顾，莫纪吾语。吾悯汝无始旷劫来，背明投暗，逐妄根深，卒难顿拔，所以假设方便，夺汝诸人尘劫来粗识，如将黄叶止啼，亦如人将百种货物，杂浑金宝，一铺货卖，只拟轻重来机，所以道，石头是真金铺，我者里是杂货铺。有人来觅杂货铺，则我亦拈他与；来觅真金，我亦与他。”

时有人问：“杂货铺则不问，请和尚真金。”师云：“啮镞拟开口，驴年亦不会。”僧无对。又云：“索唤则有，交易则无。所以我若说禅宗旨，身边觅一人相伴亦无，说什摩五百七百？我若东说西说，则竞头向前采拾。如将空拳诱诳小兒，都无实处。我今分明向汝说圣边事，且莫将心凑泊，但向身前义海，如实而修。不要三明六通。此是圣末边事。如今且要识心达本。但得其本，不愁其末。他时后日，自具足去在。若未得其本，纵饶将情学他亦不得。汝何不见沩山和尚云：‘凡圣情尽，体露真心常住，理事不二，即是如如佛矣’。珍重！”

问：“法身还解说法也无？”师云：“我则说不得，别有人说得。”进曰：“说得底人，在什摩处？”师乃推出枕子。

僧后举似沩山，沩山云：“寂子用剑刃上事。”有人举似雪峰，雪峰云：“沩山和尚背后与摩道则得。”

有人拈问：“当衙时作摩生？”福先代以手作打势。报恩代云：“谁敢出头？”

师共僧说话次，傍僧云：“语是文殊，嘿底是维摩。师云：“不语不嘿，莫是公不？”其僧良久。师问曰：“何不现神通？”其僧云：“不辞现神通，恐和尚收入教。”师云：“鉴公来处，未有教外之眼。”

师问俗官：“至个什摩？”对云：“衙推。”师拈起柱杖云：“还推得这个不？”无对。师代云：“若是这个，待别时来。”兴化代云：“和尚有事在。”

师问上座：“不思善不思恶，正与摩时作摩生？”上座云：“正与摩时，□甲放身命处。”师云：“何不问某甲？”云：“与摩时，不见有和尚。”师云：“扶我教不起。”

师洗纳衣次，耽源问：“正与摩时作摩生？”师云：“了然二俱无为。”又云：“正与摩时，某甲不思量渠。”又云：“正与摩时，向什摩处见渠？”

师见京岑［景岑］上座在中庭向日次，师从边过云：“人人尽有这个事，只是道不得。”云：“恰似请汝道。”师云：“作摩生道？”岑上座便拦胸与一踏。师倒，起来云：“师叔用使直下是大虫相似。”

师在东平看经时，有僧侍立。师卷却经，回头问：“还会摩？”对云：“某甲不曾看经，争得会？”师云：“汝向后也会去在。”

师与韦曹相公相见后问：“院中有多少人？”师云：“五百人。”公云：“还切看读不？”师云：“曹溪宗旨，不切看读。”公云：“作摩生？”师云：“不收不摄不思。”

相公就沩山乞偈子，沩山云：“觌面相呈，犹是饨汉，岂况上于纸墨？”又就师乞偈子，师将纸画圆相，圆相中著：“某字谨答：左边思而知之，落第二头；右边不思而知之，落第三首。”乃封与相公。

问：“弯弓满月，啮镞意如何？”师云：“啮镞拟开口，驴年也不会。”南泉对侧身立，强大师拈问：“啮镞拟开口，驴年也不会。”国师云：“损益只可句安在？”净修禅师答曰：“仰山啮镞话，拟议都难会。指拟益后来，言损这边在。”

石门拈问僧：“古人留会不留会？”无对。门代云：“不留会。”进曰：“作摩生会？”

双峰离沩山，到仰山。师问：“兄近日作摩生？”双峰云：“某甲所见，无有一法可当情。”师云：“你所见不出心境。”进曰：“某甲所见，不出心境，和尚所见如何？”师云：“岂无能知溶无一法可当情乎？”有僧举似沩山，沩山云：“寂子此语，迷却天下人去在。”顺德颂：

双峰贤自粗，非是仰山屈。

挑汝解绳抽，把当宗徒说。

一盲引众盲，会古在今日。

师有时正与摩闭目坐次，有一僧潜步，到师身边侍立。师开门，便于地上作圆相，圆相中书“水”字顾示，其僧无对。问：“如何是祖师意？”师以手作圆相，圆相书“佛”字对。

有行者随法师入佛殿，行者向佛唾。法师云：“行者少去就，何以唾佛？”行者云：“还我无佛处来唾。”沩山闻云：“仁者却不仁者，不仁者却是仁者。”师代：“法师但唾行者。行者若有语，即云：‘还我无行者处来唾。’”

有俗官送物，充沩山赎锺，沩山谓仰山云：“俗子爱福也。”仰山云：“和尚将什摩酬他？”师把柱杖，敲丈床三两下云：“将这个酬得他摩？”仰山云：“若是这个，用作什摩？”师云：“汝嫌个什摩？”仰山云：“专甲即不嫌。这个是为大家底。”师云：“汝既知大家底，更就我觅什摩酬他？”仰山云：“怪和尚把大家底行人事。”沩山云：“汝不见，达摩从西天来，亦将此物行人事，汝诸人尽是受他信物者。”

师示众云：“与摩时且置，不与摩时作摩生？”有人举似沩山。沩山云：“寂子为人太早。”

因沩山与师游山，说话次，云：“见色便见心。”仰山云：“承和尚有言：‘见色便见心。’树子是色，阿那个是和尚色上见底心？”沩山云：“汝若见心，云何见色？见色即是汝心。”仰山云：“若与摩，但言先见心，然后见色。”云：“何见色了见心？”沩山云：“我今共树子语，汝还闻不？”仰山云：“和尚若共树子语，但共树子语。”又问：“某甲闻与不闻作什摩？”沩山云：“我今亦共子语，子还闻不？”仰山云：“和尚若共某甲语，但共某甲语。”又问：“某甲闻与不闻作什摩？若问某甲闻与不闻，问取树子闻与不闻，始得了也。”

师在沩山时，雪下之日，仰山置问：“除却这个色，还更有色也无？”沩山云：“有。”师云：“如何是色？”沩山指雪。仰山云：“某甲则不与摩。”沩山云：“是也理长则就，除却这个色，还更有色也无？”仰山云：“有。”沩山云：“如何是色？”仰山却指雪。

洞山遣人问师：“作摩生即是，作摩生则不是？”师云：“是则一切皆是，不是则一切不是。”洞山自云：“是则一切不是，不是则一切是。”师偈曰：

法身无作化身作，薄伽玄应诸病药。

埋微闻响拟嗥吠，焰水觅鱼痴老鹤。

师为沙弥时，在宗和尚处童行房里念经，宗和尚问：“谁在这里念经？”对云：“专甲独自念，别无人。”宗和尚喝云：“什摩念经，恰似唱曲唱歌相似，得与摩不解念经。”师便问：“某甲则如此，和尚还解念经也无？”云：“我解念经。”师曰：“和尚作摩生念？”宗和尚念：“如是我闻，……”师便云：“住住。”

问：“今日设沩山斋，未审沩山还来也无？”师云：“来则有去，去则有来。”沩山唤师，师诺。沩山云：“速道速道。子莫落阴。”云：“专甲信亦不立。”云：“汝何故不立信？”云：“若是专甲，更信阿谁？”云：“汝解故不立，不解故不立。”云：“若不立不说，解不解？”云：“汝是定性声缘。”云：“专甲佛亦不见。”

师举起一物，问沩山云：“与摩时如何？”沩山曰：“分别属色尘，我到这里，与摩不与摩？”仰山云：“和尚有身而无用。”沩山云：“子如何？”仰山云：“某甲信亦不立。”沩山云：“为什摩不立信？”仰山云：“若是某甲，更信阿谁？”沩山云：“有不立，无不立。”仰山云：“不立不说有无？”沩山云：“子是定性声闻。”仰山云：“专甲到这里，佛尚不见。”沩山云：“子向后传吾声教，行步阔狭，吾不及子也。”

师为沙弥时，在耽源唱礼次。耽源问：“作什摩？”师云：“唱礼。”源云：“礼文道什摩？”对云：“一切恭敬。”源云：“忽遇不净底作摩生？”师曰：“不审。”

第一，韦中承［丞］问和尚曰：“五祖云何分付衣钵与慧能，不分付神秀。既分付后，云何慧明又从五祖下，趁到大庾岭头，夺其衣钵？复有何意不得衣回。某甲在城，曾问师僧，悉各说不同。某甲常疑此事。和尚禀承有师，愿垂一决。”师答曰：“此是宗门中事。曾于先师处闻说。”

登时五祖下，有七百僧。五祖欲迁化时，觅人传法及分付衣钵。众中有一上座，名曰神秀，遂作一偈上五祖：

身是菩提树，心如明镜台。

时时勤拂拭，莫遣有尘埃。

后磨坊中卢行者，闻有此偈，遂作一偈上五祖曰：

菩提本无树，明镜亦非台。

本来无一物，何处有尘埃？

五祖亦见此偈，并无言语，遂于夜间教童子去碓坊中唤行者来。

行者随童子到五祖处，五祖发遣却童子后，遂改卢行者名为慧能，授与衣钵，传为六祖。向行者云：“秀在门外，能得入门。得座被衣，向后自看，二十年勿弘我教，当有难起。过此已后，善诱迷人。”慧能便问：“当往何处，而堪避难？”五祖云：“逢怀即隐，遇会即逃。异姓异名，即当安矣。”行者既得付嘱衣钵，五祖发遣，于时即发去岭南。

五日后，五祖集众人告曰：“此间无佛法也。”此语意显六祖。众僧问：“五祖衣钵分付何人？”五祖云：“能者即得。”众僧商议。碓坊中行者，又被童子泄语，众僧即知。

卢行者将衣钵归岭南，众僧遂趁。众中有一僧，舍官入道。先是三品将军，姓陈，字慧明，星夜倍程，至大庾岭头。行者知来趁，遂放衣钵，入林，向涮石上坐。其慧明岭上见其衣钵，向前已手抬之，衣钵不动，便自知力薄，即入山觅行者。于山高处林中，见行者在石上坐，行者遥见惠明，便知要夺衣钵，即云：“我祖分付衣钵，我苦辞不受。虽将来，见在岭头。上座欲要，便请将去。”慧明答：“不为衣钵来，只为法来，不知行者离五祖时，有何密意密语？愿为我说。”行者见苦囗囗囗与说，先教向石上端坐，静思静虑：“不思善不思恶，正与摩思不生时，还我本来明上座面目来。”惠明问云：“上来密意，即这个是，为当别更有意旨？”行者云：“我今分明与汝说著，却成不密。汝若自得自己面目，密却在汝边。”

慧明问行者云：“汝在黄梅和尚身边，意旨复如何？”行者云：“和尚看我对秀上座偈，即知我入门意，即印慧能云：‘秀在门外，能得入门，得座被衣，向后自看。此衣钵从上来分付，切须得人。我今付汝，努力将去。二十年勿弘吾教，当有难起。过此已后，善诱迷情。’慧能问云：‘当于何处而堪避难？’五祖云：‘逢怀即隐，遇会即逃。’‘怀’即怀州，‘会’即四会县。异姓异名，当即安矣。”时慧明虽在黄梅剃发，实不知禅宗面目：“今蒙指授入处，如人饮水，冷暖自知。从今日向后，行者即是慧明师。今便改名，号为道明。”行者曰：“汝若如是，吾亦如是。与汝同师黄梅不异，善自护持。”道明曰：“和尚好速向南去，在后大有人来趁和尚，待道明尽却指回。今便礼辞和尚，向北去。”

道明在岭头分首，便发向北去。于虎州，果见五十余僧来寻卢行者。道明向僧曰：“我在大庾岭头怀化镇左右，五六日等候，借访诸关津，并不见此色目人过，诸人却向北寻觅。”云：“其人石碓石＋垂损腰，行李恕［恐］难。”

众人分头散后，道明独往卢山布水台。经三年后，归蒙山修行。后出徒弟，尽教岭南礼拜六祖处。至今蒙山灵塔见在。

第二，菀陵僧道存问曰：“和尚沙汰后，再到湖南，礼觐沩山和尚，复有何微妙言说？”和尚云：“我难后到沩山，得一日问我：‘汝在仰山住持及说法，莫诳惑他人否’？”仰山云：“随自己眼目。”沩山云：“汝争辩得诸方师僧？知有师承，知无师承？知是义学，知是禅学？宗门事宜，说似我看。”

仰山谘和尚云：“辩得也。”沩山云：“有诸方学人来，问汝曹溪意旨。汝如何答渠？”仰山云：“大德近从何处来？”学人答：“近从诸方老宿处来。”仰山即举一境问云：“诸方老宿还说这个不说这个？”或时举一境云：“这个则且置，还诸方老宿意旨如何？”已上两则境智也。沩山闻说叹曰：“大好。此亦是从上来宗门牙爪。”

沩山又云：“忽有人问：‘一切众生，但有忙忙业识，无本可据。’汝云何答？”仰山云蓦呼于学人名，学人应诺。仰山问：“是什摩物？”学人答云：“不会。”仰云：“汝亦无本可据，非但忙忙业识。”沩山云：“此是师子一滴乳，六斛驴乳一时迸散。”

沩山又问仰山：“身边还有学禅僧不？”仰山云：“还有一两个，只是面前背后。”沩山问云：“何面前背后？”仰山云：“人前受持声教，只对别人，即似背后揩定著渠，自己照用处，业性亦不识。”沩山云：“我身边还有学禅人不？”仰山答云：“出山日早，有亦不识他。”沩山云：“以汝在日眼目，且沩山有不？”仰山答：“山中纵有诸同学兄弟，不曾子细共他论量，并不知眼目深浅。”沩云：“大安如何？”答云：“不识他。”“全谂如何？”“亦不识他。”“志和如何？”“亦不识他。”“志遇如何？”“亦不识他。”“法端如何？”“亦不识。”沩山咄云：“我问，汝总道不识。什摩意？”

仰山谘和尚：“为当欲得记他见解，为当欲得行解？”沩山云：“汝云何说他见解，云何说他行解？”仰山云：“若欲记他见解，上来五人。向后受持和尚声教，为人善知识，说示一切人，如泻之一瓶不失一滴。为人师有余，此是见解。”沩山云：“行解如何？”仰山云：“未具天眼他心，不知他照用处。缘行解自辩清浊业性，属于密意，所以不知他。只如慧寂，在江西时，尽头无惭无愧。今时和尚见了，唤作学禅人不？”沩山云：“是我向一切人前，说汝不解禅，得不？”仰山云：“慧寂是何虾蟆蛐蟮，云何解禅？”沩山云：“是汝光明，谁人障汝？”

仰山问沩山云：“西天二十七祖《般若多罗》，玄记禅宗向后三千年事。时至分寸不移，只如和尚今时，还得不？”沩山云：“此是行通边事，我今未得。我是理通学，亦是通自宗，所以未具六通。”

仰山谘沩山云：“只如六祖和尚临迁化时，付嘱诸子：‘取一钅＋是铤可重二斤，安吾颈中，然后漆之。’诸子问曰：‘安铁颈中，复有何意？’六祖云：‘将纸笔来，吾玄记之。五六年中，头上养亲，日里须餐。遇满之难，杨柳为官。’”沩山云：“汝还会祖师玄记意不？”仰山云：“会其事过也。”沩山云：“其事虽则过，汝试说看。”仰山云：“‘五六年中’者，三十年也；‘头上养亲’者，遇一孝子；‘口里须餐’者，数数设斋也；‘遇满之难’者，是汝州张净满也，被新罗僧金大悲将钱雇，六祖截头兼偷衣钵；‘杨柳为官’者，杨是韶州刺史，柳是曲江县令，惊觉后于石角台捉得。和尚今时有此见不？”沩山云：“此是行通，我亦未得。此亦是六通数。”

仰山云：“咨和尚：和尚今时，若记人见解即得。若记人行解，即属人情，不是佛法。”沩山喜云：“百丈先师记十数人，会佛法会禅。向后千百人围绕，及其自住数不？”仰山云：“虑恐如此。然则圣意难测，或逆或顺，亦非慧寂所知。”沩山云：“汝向后还记人不？”仰山云：“若记，只记见解，不记行解。见解属口密，行解属意密。未齐曹溪，不敢记人。”沩山云：“子何故不记？”仰山云：“燃灯身前事，这边属众生。行解无凭。”沩山云：“燃灯后，汝还记得渠不？”仰山云：“若燃灯后，他自有人记，亦不到慧寂记。”

仲山又问沩山：“和尚浮沤识，近来不知宁也未？”沩山云：“我无来经五六年。”仰山云：“若与摩，如今和尚身前，应普超三昧顶也。”沩山云：“未。”仰山云：“性地浮沤尚宁，燃灯身前何故未？”沩山云：“虽然理即如此，我亦未敢保任。”仰山云：“何处是未敢保任处？”沩山云：“汝莫口解脱，汝不闻，安、秀二禅师，被则天一试下水，始知有长人到这里，铁佛亦须汗流。汝大须修行，莫终日口密密底。”又云：“汝三生中，汝今在何生？实向我说看。”仰山云：“想生相生。仰山今时，早已淡泊也。今正在流注里。”沩山云：“若与摩，汝智眼犹浊在，未得法眼力人，何以知我浮沤中事？”仰山云：“大和三年，奉和尚处分令究理。顿穷实相性，实际妙理。当刹那时，身性清浊辨得，理行分明。从此已后，便知有师承宗旨。虽则行理力用，卒未可说，如今和尚得与不得即知，以海印三昧印定，前学后学无别有路。”沩山云：“汝眼目既如此，随处各自修行，所在出家一般。”

仰山咨沩山云：“初礼辞和尚时，和尚岂不有语处分？”沩山云：“有语。”云：“虽是机理，不无含其事。”沩山云：“汝也是秦时铎落钻。”仰山云：“此行李处，自谩不得。”沩山云：“仁子之心，亦合如此。”

道存问曰：“礼辞沩山时，有何言语？”仰山云：“我辞和尚时处分：‘五六年闻吾在即归来，闻吾不在，即自拣生路行，努力好去。’”道存问云：“和尚今时传持祖教，若不记向后，学人如何？”和尚云：“我分明向汝道：‘今时即试人见解，不试人行解。’他行解属意密，正涉境时，重处偏流，业田芽出，别人争知？何处记他？汝不闻大耳三藏从西天来，得对肃宗。肃宗问云：‘三藏解何法？’三藏云：‘善解他心。’肃宗遂令中使，送到国师忠和尚处，请试三藏实解他心不。国师遂将涉境心试三藏。三藏果见知心念去处，缘为涉境。后国师入三昧，心不涉境。三藏觅国师意不得，被呵云：“这野狐精！圣在何处？若入自受用三昧去，玄谁得知？’所以行解难知。故云：‘证者非见知，不证者非见知。’”

道存问云：“如何得行解相应？”和尚云：“汝须会得禅宗第三玄。初心即贵入门第一玄，向后两玄是得座被衣，汝须自看，亦须自知有种觉种智。种觉者即三身如一，亦云理无诤，亦云遮那湛寂；种智者即得身性圆明，后却向身前照用，不染不著，亦云舍那无依智，亦云一体三身，即行无诤。如是身性圆明，漏尽意解。身前无业，不住动静，出生入死，接物利生，亦云正行，亦云无住车。他时自具宿命他心，三明八解。此是圣末边事，汝莫将心凑泊。我分明向汝道：‘却向性海里修行，不要三明六通。’何故如此？然则有清有浊，但二俱是情，汝不见沩山道：‘凡圣情尽，体露真性常住。事用不二，即是如如佛。’”

第三，菀陵僧道存问和尚：“诸方大家说，达摩将四卷《楞伽经》来，未审虚实耶？”仰山云：“虚。”道存问：“云何知虚？”和尚云：“达摩粱时来。若将经来，在什摩朝翻译？复出何传记？其《楞伽经》前后两译，第一译是宋朝求那跋摩三藏，于南海始兴郡译。梵云‘质多’，此云‘数数生念’。又云‘乾栗’，此云‘无心’。此是一译，见上目录。又江陵新兴寺截头三藏译，胡云‘质多’，此云‘数数生念’。胡云‘乾栗’，此云‘无心’。此是二译。义即一般，胡云汉云则有差别。若言达摩将经来，具翻译义，复是何年？又复流行何土？汝不闻，六祖在曹溪说法时，‘我有一物，本来无字，无头无尾，无彼无此，无内无外，无方圆无大小，不是佛不是物。’返问众僧：‘此是何物？’众僧无对。时有小师神会出来，对云：‘神会识此物。’六祖云：‘这饶舌沙弥！既云识，唤作什摩物？’神会云：‘此是诸佛之本源，亦是神会佛性。’六祖索杖，打沙弥数下。‘我向汝道无名无字，何乃安置本源佛性？’登时神会唤作‘本源佛性’，尚被与杖，今时说道，达摩祖师将经来，此是谩糊达摩，带累祖宗，合吃其铁棒。只如佛法到此土三百余年，前王后帝，翻译经论，可少那？作摩？达摩特来，为汝诸人贪著三乘五性教义，汨没在诸义海中，所以达摩和尚，救汝诸人迷情，初到此土时，唯有梁朝宝志禅师一人识。梁帝问宝志曰：‘此是何人？’宝志答：‘此是传佛心印大师，观音圣人乎？’不云传《楞伽经》圣人也。”

道存问和尚云：“达摩《五行论》云：‘借教悟宗。’复借何教？”仰山云：“所言‘惜教悟宗’者，但借口门，言语牙齿，咽喉脣吻，云口放光，即知义也。‘悟宗’者，即答梁帝云：‘见性曰功，妙用曰德。功成德立，在于一念。’如是功德，净智妙用。非是世求，只如曹溪六祖对天使云：‘善恶都莫思量，自然得入心体。湛然常寂，妙用恆沙。’天使顿悟叹曰：‘妙尽故知佛性。不念善恶，妙用自在。待某甲若见圣人，与传妙旨。’皇帝闻之，当时顿悟。亦叹曰：‘朕在京城，不曾闻说此语，实为明据。’谨敬顶礼修行。”

道存问曰：“达摩和尚既不将《楞伽经》来，马大师语本及诸方老宿数引《楞伽经》，复有何意？”仰山云：“从上相承说，达摩和尚说法时，恐此土众生不信玄旨，数数引《楞伽经》来，缘经上有相似处。宗通说通诱童蒙，宗通修行者，及听惠婆罗门来，问佛三十六对，世尊并拨入世论，又有相似处。从缘所得觉，及本住法，如金银等性，如来出世及不出世，本性常住。故云：‘有佛无佛性相常住’。此是闲暇语话引来，非是达摩将此为祖宗的意。汝不闻，达摩在西天时问般若多罗云：‘我今得法，当往何土而可行化？’般若多罗云：‘汝今得法，且莫远去。待吾灭度后六十一年，当往震旦。’只得一九，如今便去。衰于日下，亦不闻分付将《楞伽经》来此土。我今告汝，若学禅道，直须稳审。若也不知原由，切不得妄说宗教中事。虽是善因，而招恶果。”

第四，幽州僧思益＋阝问和尚：“毕竟禅宗顿悟入理门的的意如何？”仰山云：“此意甚难。若见他祖宗苗裔，上上根性，如西天诸祖。此土从上祖相承，或一玄机，或一境智，他便肯去。玄得自理，不居惑地，更不随于文教，故相传云：‘诸佛理论，不干文墨。’此一根人难得，向汝道少有。学禅师僧，何处有不得佛法？只为无志。汝不闻先德道：‘若不安禅静虑，到这里总复忙然。’”

思益＋阝问云：“除此一格，别更有入处不？”仰山云：“有。”“如何即是？”仰山云：“汝是何处人？”思益＋阝云：“幽燕人。”仰山云：“汝还思彼处不？”答云：“思。”仰山云：“彼处是境，思是汝心。如今返思个思底，还有彼处不？”答云：“到这里，非但彼处，一切悉无。”仰山云：“汝见解，犹有心境在。信位即是，人位即不是。”思益＋阝问：“除却这里，别更有意旨不？”仰山云：“别有别无，即不安也。”思益＋阝问：“到这里作摩生即是？”仰山云：“据汝解处，还得一玄。得坐披衣，向后自看。汝不闻六祖云：‘道由心悟’，亦云‘悟心’。又云：‘善恶都莫思量，自然得入心体。湛然常寂，妙用恆沙。’若实如此，善自保任。故云：‘诸佛护念。’若有漏不忘，意根忆想，在身前义海，被五阴身所摄，他时自不奈何。故云‘如象溺深泥，并不见禅，亦非师子兒也。’”

第五，海东僧亭育问：“和尚禅决［禅诀］名函，不知所措。”仰山集云峰、迦叶弥伽、舍那［舍摩］遮那、三摩钵底、师地静虑、沙门慧寂。和尚云：“仰山集云峰者，即是卢舍那本身，及现在业根。分段身所招，外依报也，亦云僧宝住持处所。迦叶弥迦者，总也。迦叶者，禅宗初祖，从婆伽婆处密传三昧也。故云弘伽也。舍摩者，密受三昧也。”亭育问：“和尚禅决中云：‘还我本来面目。’莫是此三昧以不？”仰山云：“若是汝面目，更教我说。如石上裁花，亦如夜中树影。”问云：“夜中树决定信有。其树影，为有为无？”仰山云：“有无且置。汝今见树不？”“遮那者，身性如也；三摩钵底者，即戒定慧，亦云菩提妙花，亦云花藏庄严，即内依报。招外果者，即人相成佛是也。师地者通自宗，自宗通即三十三祖。静虑者，即四种无受三昧。”问：“此三昧有出入不？”仰山云：“有病即有出入，无病，药还气。初心即学出入，熟根即净明无住。”问：“出入其意如何？”仰山云：“入人如无受，即法眼三昧起，离外取受；入性如无受，即佛眼三昧起，即离内取受。入一体如无受，即智眼三昧起，即离中间取受。亦云：不著无取受，自入上来所解三昧，一切悉空，即惠眼所起；入无无三昧，即道眼所起，即玄通碍也。譬如虚空，诸眼不立，绝无眼翳，赞如上三昧。毕竟清净无依住，即净明三昧也。告诸学人，莫勤精进，懈怠懒惰，空心静坐，想一个无念无生，想一个无思无心。论他身前不生不灭，二边中道义海，是他人光影。抛却身前义海，紧抱执一个黑山。此是痴界，亦不是禅。沙门者，达本性，息缘虑，勤修上来三味，则通达一切三昧，故云沙门。天人阿修罗，顶戴恭敬，故云道德圆备。执此向后，堪受人天供养。若不如此修行，受人天供养，一生空过，大难大难。惠寂者在住持三宝中，与初解外招依报不别，并属假名空。”

自余法要，及化缘之事，多备《仰山行录》。敕赐智通大师妙光之塔。东平迁化，后归仰山矣。


祖堂集卷十九

祖堂卷十九·香严

香严和尚嗣沩山，在登州。师讳智闲。未睹实录。时云青州人也。

身方七尺，博闻利辩，才学无当。在沩山众中时，击论玄猷，时称“禅匠”。前后数数扣击沩山，问难对答如流。沩山深知其浮学，未达根本，而未能制其词辩。

后因一朝，沩山问曰：“汝从前所有学，解以眼耳。于他人见闻及经卷册子上，记得来者，吾不问汝。汝初从父母胞胎中出，未识东西时本分事，汝试道一句来，吾要记汝。”师从兹无对，低头良久，更进数言，沩山皆不纳之。遂请为道，沩山云：“吾道不当，汝自道得，是汝眼目。”师送归堂中，遍捡册子，亦无一言可对，遂一时烬之。有学人近前乞取，师云：“我一生来被他带累，汝更要之奚为？”并不与之，一时烬矣。师曰：“此生不学佛法也。余自生来谓无有当，今日被沩山一扑净尽，且作一个长行粥饭僧过一生。”遂礼辞沩山，两泪出门。

因到香严山忠国师遗迹，栖心憩泊，并除草木散闷。因击掷瓦砾次失笑，因而大悟，乃作偈曰：

一扌＋至忘所知，更不自修持。

处处无踪迹，声色外威仪。

十方达道者，咸言上上机。

便罢归室，焚香具威仪，五体投地，遥礼沩山赞曰：“真善知识，具大慈悲，拔济迷品。当时若为我道却，则无今日事也。”便上沩山，具陈前事，并发明偈子呈似。和尚便上堂，令堂维那呈似大众，大众总贺。唯有仰山，出外未归。

仰山归后，沩山向仰山说前件因缘，兼把偈子见似仰山。仰山见了，贺一切后，向和尚说：“虽则与摩发明，和尚还验得他也无？”沩山云：“不验他。”

仰山便去香严处，贺喜一切后，便问：“前头则有如是次第了也。然虽如此，不息众人疑，作摩生疑渐/耳，将谓预造，师兄已是发明了也。别是气道造道将来。”香严便造偈对曰：

去年未是贫，今年始是贫。

去年无卓锥之地，今年锥亦无。

仰山云：“师兄在知有如来禅，且不知有祖师禅。”师问僧：“如人在高树上，口衔树枝，脚下踏树，手不攀枝，下有人问：‘如何是西来意？’又须向伊道，若道又被扑杀，不道违于他问。汝此时作摩生指他，自免丧身失命？”虎头招上座返问：“上树时则不问，未上树时作摩生？”师笑嘘嘘。

问：“如何是据现在学？”师以扇子旋转示云：“见摩见摩？”问：“如何是无表戒？”云：“待庠梨还俗则为你说。”问：“如何是声色外相见一句？”云：“某甲未住香严时，且道在什摩处？与摩时亦不敢道在。”云：“如幻人心心所念法。”问：“如何是声前一句？”师云：“大德未问时则答。”进曰：“即今时如何？”云：“即今时问也。”问：“如何是直截根原佛所印？”师把杖抛下，撮手而去，指古人迹颂曰：

古人语，语中骨，

如云映秋月，光明时出没。

句里隐，不当当。

人玄会，暗商量。

唯自肯，意不伤。

似一物，不相妨。

师与乐普同行，欲得相别时，乐普云：“同行什摩处去？”师云：“去东京。”普曰：“去作什摩？”师云：“十字路头卓庵去。”普曰：“卓庵作什摩？”师云：“为人。”普曰：“作摩生为人？”师举起拂子。普举拂子：“作摩生为人？”师便抛下佛。普云：“荒处犹过在，净地为什摩却迷人？”师云：“怪伊作什摩？”励学吟：

满口语，无处说，

明明向道人不决。

急著力，勤咬啮，

无常到来救不彻。

日里话，暗嗟切，

快磨古锥净挑揭。

理尽觉，自护持。

此生事，吾不说。

玄旨求他古老吟，

禅学须穷心影绝。

师诫宗教接物颂曰：

三句语，究人玄。

迅面目，示豁然。

开两路，备机缘。

投不遇，说多年。

洞山问僧：“离什摩处来？”对云：“离香严来。”山云：“有什摩佛法因缘？”对云：“佛法因缘即多，只是爱说三等照。”山云：“举看。”学人举云：“恆照常照本来照。”洞山云：“有人问此三等照也无？”对云：“有。”山云：“作摩生问？”对云：“作摩生是恆照？”又问“常照”。山云：“好问处不问。”僧问：“请师垂个问头。”洞山云：“问则有，不用拈出。缘作摩故？庠梨千乡万里来，乍到者里，且歇息。”其僧才得个问头，眼泪落。洞山云：“哭作什摩？”对云：“启和尚，末代后生，伏蒙和尚垂方便。得这个气道，一则喜不自胜，二则恋和尚法席，所以与摩泪下。”洞山云：“唐三藏又作摩生？从唐国去西天十万八千里。为这个佛法因缘，不惜身命。过得如许多险难，所以道，五天犹未到，两眼泪先枯。虽则是从此香严千乡万里，为佛法因缘，怕个什摩？”其僧下山，却归香严。

从容得二日，师戴帽子上堂，其僧便出来问：“承师有言：‘恆照常照本来照。’三等照则不问，不照时唤作什摩？”师便却下帽子，抛放众前。其僧却归洞山，具陈前事。洞山却低头后云：“实与摩也无？”对云：“实与摩。”洞云：“若也实与摩，斫头也无罪过。”其僧却归香严，具陈前事。师下床，向洞山合掌云：“新丰和尚是作家。”最后颂曰：

有一语，全规矩。

休思量，不自许。

路逢同道人，扬眉省来处。

踏不著，多疑虑。

却思量，带伴侣。

一生参学事无成，殷勤抱得啃檀树。

常在颁：

管带历历，诸边宁息。

平常见闻，不入榛棘。

四威仪中，净洁析析。

机感相投，一时抛掷。

嘿处对缘，声前显迹。

同道相知，不劳势力。

修行颂曰：

天寒宜曝日，归堂一食倾［顷］。

思著未生时，宜然任他清。

只摩寻时，明镜非明镜；

独坐觉雪凉，行时也只宁。

郑郎中问颂：

既无人解，又无人缚。

出此路歧，入何城廓？

师颂答：

语中埋迹，声前露容。

即时妙会，古人道同。

响应机劝，无自他宗。

诃起骇足＋奔，曩迅成龙。

郑郎中又问：

来无他彻［辙］迹，去是非我途。

并逐猿猴尽，山川境在无。

大师以发机颂答：

语里埋筋骨，音声染道容。

即时才妙会，拍手趁乖龙。

清思颂曰：

尽日坐虚堂，静思绝参详。

更无回顾意，争肯置平常？

谈玄颂曰：

的的无兼带，独运何依赖。

路逢达道人，莫将语嘿对。

香＋曷学人玄机颂曰：

妙旨迅速，言说来迟。

才随语会，迷却神机。

扬眉当问，对面熙怡。

是何境界，同道方知。

浑仑语颂曰：

一束茅，草六分。

盖得庵，无子门。

藏头人，入去却。

转头来，语浑仑。

师为众曰：“此世界日月短促，则须急急底事了却去。平治如许多不如意事，直须如地相似，安然不动，一切殊胜境不随转，只摩寻常，不用造作，独脱现前，不带伴侣。皎然秋月明，内外通透。克＋寸念寸阴，直须此生了却。今生不了，阿谁替代？大德莫待头白齿黄，耳聋眼暗，无常到来，悔当何及？大德身上是他衣，堂里是他食。灯油大炭，床榻卧具，什方信心供须，将何道业消受？一念迹不尽，个个是债负。特达丈夫，气志坚固。心如断绳，休去三界因果。无断现时富贵贫穷，苦乐之事，尽未来际，纵恣贪爱，织造有漏。至于今日应当知足。过去诸佛，还从凡夫中修持去，无天生圣人。大德本离歹＋帚［乡］中，抛却父母出家，为什摩事？莫因循，莫犹预［豫］，虚度光阴。古人道：‘寄语参玄人，光阴莫虚度。’百丈云：‘努力一生须了却，谁能累劫受诸殃。’”明古颂曰：

古人骨，多灵异。

贤子孙，密安置。

此一门，成孝义。

人未达，莫差池。

须志固，遣狐疑。

得安静，不倾危。

向即远，求即离。

取即失，急即迟。

无计校，忘觉知。

浊流识，今古伪。

一刹那，通变异。

嵯峨山，石火起。

内里发，焚巅山/累。

无遮拦，烧海底。

法网疏，灵焰细。

六月卧，去被衣。

盖不得，无假伪。

达道人，唱祖意。

我师宗，古来讳。

唯此人，善安置。

足法财，具惭愧。

不虚施，用处谛。

有人问，小呵气。

更寻来，说米贵。

香＋曷崔大夫暢玄颂曰：

达人多随显，不定露形仪。

语下不遗迹，密密潜护持。

动容扬古路，明妙乃方知。

应物但施设，莫道不思议。

宝明颂曰：

思清人少虑，风规自然足。

影落在音容，孤明绝撑触。

出家颂：

从来求出家，未详出家称。

起坐只寻常，更无小殊胜。

寄法堂颂：

东问里入寂，西间里语话。

中间里睡眠，通间里行道。

向前即检拔，向后即隐形。

时人都不措，问：“什摩精灵？”答曰：“净地上鼓怒，怡然中伴嗔，平坦处不守，危险中藏身。盲聋遇之眼开，僧瑶［僧繇］驻笔凝神。”

玄旨颂曰：

去去无标的，来来只摩来。

有人相借问，不语笑咳咳。

赠同住归寂颂：

同住道人七十余，共辞城郭乐山居。

身如寒木心芽绝，不话唐言休梵书。

心期尽处身虽丧，如来弟子沙门样。

深信共崇钵塔成，巍巍置在青山蟑。

观夫参道不虚然，脱去形骸甚高上。

从来不说今朝事，暗里埋头隐玄暢。

不留踪迹异人间，深妙神光饱明亮。

观学颂曰：

出家修道莫求安，失念求安学道难。

未得直须求大道，觉了无安无不安。

志守得破颂云：

十五日已前，师僧莫离此间；

十五日已后，师僧莫住此间。

去即打汝头破，住即亦复如然。

不去不住，事意如何？

是即是，拟即差。

辞见闻颂曰：

好住至@辶分离，幽宗人迹稀。

从来未登涉，无计遣狐疑。

分明颂：

顿丧命根，威德自足。

一物不似，规矩现前。

遵古路颂，香＋曷郎中：

虚心越境净思量，句里无踪声外详。

文字影像骇惊觉，动容弹指饱馨香。

香＋曷董兵马使说示偈：

宿静心意到山中，为求半偈契神踪。

向道却思思不得，却被寻思碍不通。

专志颂：

宛转宛转，究尽疑见。

只摩分明，无生己恋。

内外不思，未露眉面。

如梦踏蛇，惊人顿变。

香＋曷学人宗教宗如：

满寺释迦子，未详释迦经。

唤来试共语，开口杂音声。

三句后意颂：

书出语多虚，虚中带有无。

却向书前会，放却意中珠。

自余化缘终始年月，悉彰实录。敕谥袭灯大师延福之塔。

祖堂卷十九·径山

径山和尚嗣沩山，师讳鸿徠。未睹实录。师两浙尚父大王礼重为师，赐号法齐大师。

师初出世时，未具方便，不得稳便。因此不说法。过得两年后，忽然回心向徒弟曰：“我闻湖南石霜是作家知识。我一百来少师中，岂无灵利者？谁去彼中，勤学彼中气道，转来密教老汉？”时有一僧名全表，便辞发到石霜。

恰遇上堂日，便置问曰：“三千里外，久响石霜。到来为什摩寸步千里？”霜云：“我道落带手不长。”从此亲近石霜四十余日，后却归本山，成持和尚。便有来由，上堂说法。时有人问：“如何是短？”师云：“桀螟眼里著不满。”进曰：“如何是长？”师云：“千圣不能量。”全表却归石霜，举似前话。石霜微笑曰：“是你和尚真实道人。”全表却问石霜：“如何是短？”霜云：“莫屈曲。”进曰：“如何是长？”霜云：“双陆盘中不喝彩。”

全表持此因缘来举似师，师欢喜便上堂，告众曰：“南风吹来，饱鼻＋句鼻＋句底。任你横来竖来，十字纵横，也不怕你。”时有人问：“香＋曷摩去底人，还有却未分也无？”师云：“我道金锁闭不得。”

全表持此话来举似石霜，石霜当日便上堂，告众曰：“今日有径山消息来，诸上座总去径山。径山是真善知识，具举前话后，却向众曰：‘只如径山与摩道，还得十成也无？’虽然如此，只道得八分。”全表便出来问：“香＋曷摩去底人，还有却来分也无？”云：“金锁闭不得，来作什摩？”

石霜久住，道明上座欲去径山，辞石霜。临发时，便问：“一毫穿众穴时如何？”霜云：“须得万年。”进曰：“直得万年后如何？”霜云：“光靴听你光靴，白俊听你白俊。”明上座持此问来径山，便问曰：“一毫穿众穴时如何？”云：“须得老。”进曰：“直得老后如何？”云：“登科听你登科，拔髓听你拔髓。”

祖堂卷十九·灵云

灵云和尚嗣沩山，在福州。师讳志阖。福州人也。

一造大沩，闻其示教，昼夜亡疲，如丧考妣，莫能为喻，偶睹春时花蕊繁花，忽然发悟，喜不自胜，乃作一偈曰。

三十年来寻剑客，几逢花发几抽枝。

自从一见桃花后，直至如今更不疑。

因白沩山和尚，说其悟旨。沩山云：“从缘悟达，永无退失。汝今既尔，善自护持。”进而返锡瓯闽。举似玄沙，玄沙云：“谛当甚谛当，敢保未彻在。”僧进问：“正是也。和尚还彻也无？”玄沙云：“须与摩始得。”师云：“亘古亘今。”玄沙云：“甚好甚好。”师云：“诺诺。”玄沙送师颂曰：

三十年来只如常，几回落叶放毫光。

从此一去云霄外，圆音体性应法王。

中塔颂曰：

谛当恆然亘古今，未彻见闻实甚深。

现现运转三十载，春尽萎花示君心。

师初创灵应，后住灵云，玄徒臻凑矣。长庆初参见问：“如何是佛法大意？”师云：“驴使未了，马使到来。”雪峰僧来问：“如何是佛出世时事？”师竖起拂子。进曰：“如何是佛未出世时事？”师又竖起拂子。其僧便发上雪峰。雪峰问：“回太速乎？”其僧云：“问佛法不相当，所以却归来。”雪峰云：“你举看。”其僧便举前话。雪峰云：“你问我，我与你道。”僧便问：“如何是佛出世时事？”雪峰竖起拂子。进曰：“如何是佛未出世时事？”雪峰放下拂子，僧便礼拜。雪峰便打之喝出。

僧举似玄沙，玄沙云：“譬如一片地，作契卖与你总了。东西四畔，并属你了也。唯有中心一树，由属我在。”

雪峰示众云：“山上鸟，水里鱼。什摩人取得？”有僧举似，师云：“前三三后三三。”雪峰闻举云：“灵云顶上孤月明。”问：“诸方尽皆杂食，未审和尚如何？”师云：“唯有闽中异，雄雄镇海捱。”

问：“如何是西来意？”师云：“彩气夜常动，精灵日少逢。”问：“久战沙场，为什摩功名不就？”师云：“君王有道三边静，何劳万里筑长城？”进曰：“罢息干戈，缩手皈朝时如何？”师云：“慈云普润无边际，枯树无花争奈何？”问：“混沌未分时如何？”师云：“如露柱怀兒。”进曰：“含生来后如何？”师云：“如一片云点太清。”进曰：“只如太清，还受点也无？”师云：“香＋曷摩则含生不来。”进曰：“直得纯清绝点时如何？”师云：“由是真常流注。”进曰：“如何是真常流注？”师云：“如镜常明。”进曰：“未审向上还有事也无？”师曰：“有。”进曰：“如何是向上事？”师云：“打破镜来相见。”问：“摩尼不随众色。未审作什摩色？”师云：“作白色。”进曰：“这个是众也。”师云：“玉本无瑕，相如诳于秦主。”问：“君主出阵时如何？”师云：“吕才葬虎耳。”进曰：“如何是吕才葬虎耳？”师云：“坐见自衣天。”进曰：“王今何在？”师云：“莫触龙颜。”

祖堂卷十九·王敬初

王敬初常侍嗣沩山。

因见米和尚来，公竖起笔。米和尚云：“还解判得虚空不？”天官抛笔案上，便入宅，更不出见。米乃致疑。

公制襄州延庆寺祖师堂双声碑文者是也。称扬祖教，洞契玄猷。理含金石之声，文抱风云之韵，广行于世矣。

祖堂卷十九·临济

临济和尚嗣黄檗，在镇州。师讳义玄，姓刑［邢］，曹南人也。

自契黄斥锋机，乃阐化于河北，提网峻速，示教幽深。其于枢秘，难陈示诲，略申少分。

师有时谓众云：“山僧分明向你道，五阴身田内，有无位真人，堂堂露现，无毫发许间隔，何不识取！”时有僧问：“如何是无位真人？”师便打之，云：“无位真人是什摩不净之物！”雪峰闻举，云：“林际大似好手。”师问落浦：“从上有一人行棒，有一人行喝，还有亲疏也无？”落浦云：“如某甲所见，两人总不亲。”师云：“亲处作摩生？”落浦遂喝，师便打之。

因德山见僧参爱趁打。师委得，令侍者到德山，“打汝，汝便接取柱杖，以柱杖打一下。”侍者遂到德山，皆依师指。德山便归丈室。侍者却归举似，师云：“从来疑这个老汉。”因僧侍立次，师竖起拂子，僧便礼拜，师便打之。后因僧侍立次，师竖起拂子，其僧并不顾，师亦打之。云门代云：“只宜专甲。”

黄檗和尚告众曰：“余昔时同参大寂道友，名曰大愚。此人诸方行脚，法眼明彻，今在高安，愿不好群居，独栖山舍。众余相别时叮嘱云：‘他后或逢灵利者，指一人来相访。’”于时，师在众，闻已，便往造谒。既到其所，具陈上说。至夜间，于大愚前说《瑜珈论》，谭唯识，复申问难。大愚毕夕峭［悄］然不对，及至旦来，谓师曰：“老僧独居山舍，念子远来，且延一宿，何故夜间于吾前无羞惭，放不净？”言讫，杖之数下推出，关却门。师回黄斥，复陈上说，黄斥闻已，稽首曰：“作者如猛火燃，喜子遇人，何乃虚往？”师又去，复见大愚，大愚曰：“前时无惭愧，今日何故又来？”言讫便棒，推出门。师复返黄斥，启闻和尚：“此回再返，不是空归。”黄斥曰：“何故如此？”师曰：“于一棒下入佛境界。假使百劫，粉骨碎身，顶擎绕须弥山，经无量匝，报此深恩，莫可酬得。”黄斥闻已，喜之异常，曰：“子且解歇。”更自出身。师过旬日，又辞黄斥，至大愚所。大愚才见，便拟棒师。师接得棒子，则便抱倒大愚，乃就其背，殴之数拳。大愚遂连点头曰：“吾独居山舍，将谓空过一生，不期今日却得一子。”先招庆和尚举终，乃问师演侍者曰：“既因他得悟，何以却将拳打他？”侍者曰：“当时教化全因佛，今日威拳总属君。”师因此侍奉大愚，经十余年。大愚临迁化时嘱师云：“子自不负平生，又乃歹＋冬吾一世，已后出世传心，第一莫忘黄檗。”

自后师于镇府匡化，虽承黄斥，常赞大愚。到于化门，多行喝棒。有时谓众云：“但一切时中，更莫间断，触目皆是，因何不会？只为情生智隔，想［相］变体殊，所以三界轮回，受种种苦。大德心法无形，通贯十方，在眼曰见，在耳曰闻，在手执捉，在脚云［运］奔。本是一精明，分成六和合。心若不生，随处解脱。大德欲得山僧见处，坐断报化佛头，十地满心犹如客作兒。何以如此？盖为不达三败劫空，所以有此障。若是真正道流，尽不如此。大德，山僧略为诸人大约话破纲宗，切须自看。可惜时光，各自努力。”

自余应机对答，广彰别录矣。咸通七年丙戍岁四月十日示化，谧号慧照大师澄虚之塔。

祖堂卷十九·观和尚

观和尚嗣黄檗，在福州。

师出家黄檗寺，密承黄檗宗教。后复瓯闽，于丁墓山居小兰若。每扃其户，学者无由辄造其门。唯有日给饷食清信儒流，至时则号扣之，乃一开耳。

后因雪峰和尚初入岭，久钦高峻，遂往祗候，手扣其门，师才出门。雪峰一见，拦胸把住便问：“是凡是圣？”师蓦面与一唾云：“野狐精！”便推出却闭其户。雪峰云：“只要识老兄。”

曹山到洞山，洞山问：“近离什摩处？”对云：“近离闽中。”洞山云：“有什摩佛法因缘？”对云：“某甲问西院：‘如何是大人相？’西院云：‘安三藏［岁］时则有。’”洞山向西院合掌云：“作家。”

洞山又云：“某甲行脚时，遇著南泉。南泉也有似这个因缘。”有僧问：“如何是大人相？”南泉答曰：“王老师三岁时则有，如今无。”洞山又问：“什摩处人？”对云：“莆田县人。”洞山云：“什摩处出家？”对云：“碎石院。”山云：“碎石院近黄檗，你曾到不？”对云：“曾到。”洞山云：“有什摩佛法因缘？”对云：“某甲自问：‘如何是毗卢师法身主？’云：‘我若向你道，则别更有也。’”洞山闻此语，便合掌云：“你见古佛。虽然如此，只欠一问。”

曹山礼拜，便请问头。曹山再三苦切问，三度方得问头。入岭参师，举前话。进问：“为什摩故不道？”师云：“若道我不道，则哑却我口。若道我道，则秃却我舌。”曹山便归洞山，具陈前事。洞山执手抚背云：“汝甚有雕啄之分。”便下床，向黄檗合掌云：“古佛古佛。”

师问安和尚：“只这一片由地，合著什摩人好？”安和尚云：“好著个无相佛。”师云：“早是污却也。”

师住庵时，有一僧吃粥了，便辞师。师问：“汝去什摩处？”僧云：“礼拜大沩。”师云：“近那，吃饭了去也。”其僧便住。吃饭了便辞。师恰得见庵前树上，有青蛇开口，便指云：“汝若去大沩，只这青蛇是。”

自外枢要不一，故不尽彰。乾府五年，遇黄巢兵马偿债而终。临刃之时，白乳涌高数尺，盖大权化迹，莫可测。

祖堂卷十九·陈和尚

陈和尚嗣黄檗，在睦州龙兴寺。

师平生行密行，常制造莆鞋，暗遗于人。因此称为陈莆鞋和尚是也。

有时谓众曰：“汝诸人，还得个入处摩？若未得入，即向这里入。向后不得辜负老僧，珍重！”师有时云：“明明向你道，尚乃不知。岂况盖覆将来！”时有一座主问：“三乘十二分教，某甲粗已留心。宗门中事，乞师提纲。”师云：“问著宗门中事，有什摩难道？恰问著。老僧鼻孔头上漫漫，脚下底漫漫。教家唤作什摩？”座主：“教家无这个意旨。”师便打之。

师问：“大德什摩经论？”答曰：“讲《十本经论》。”“作摩生讲？”云：“依文讲。”“你不解讲经。”“某甲则不解讲，请师讲。”云：“你不是听经人。”“某甲不会，乞师说。”教云：“三段不同，今当第一。”又问：“大德讲什摩经论？”云：“曾讲十数本经语。”“何得妄说？”对云：“某甲实语。”师云：“雪上更加霜，担枷过状来。我与你道不妄语。近前来。”便近前。师云：“得与摩？”墨大德隔三月后便悟。

又问：“什摩处来？”云：“江西来。”“夏在什摩处？”云：“云居。”“云居切要处作摩生？”云：“只今作摩生拈上大人？”对云：“有什摩罪过？”师云：“云居与摩道，是你与摩道？”云：“云居与摩道。”师云：“三家村里老婆禅。造主不得，自领出去。”

师见僧上来云：“破也。”“什摩处是破处？”师云：“破也。”临济见僧上来便喝。有僧问：“古人才见人便喝，意作摩生？”师唤僧正，僧正应喏。师云：“有什摩共语处？”又云：“来来会摩？”对云：“不会。”“不会则念经持斋。”

又问僧：“什摩处来？”云：“游台山去来。”“还见文殊摩？”云：“见。”什摩处见？”对云：“台阁上见。”师云：“见泥堆。”又云：“近前，你识文殊摩？”云：“不识。”师云：“年高腊长，占得上座头，并无气息。”问：“祖意馤教意，还同别？”师云：“教意是教意，祖意是祖意。”问：“如何是学人自己？”师云：“一怕你不问，二恐你不会。”“便请。”师云：“心不负人，面无惭愧。”

祖堂卷十九·大随

大随和尚嗣安和尚，师讳法真，俗姓陈，东川人也。

心行慈悯，道德高峻，赈饥□俭，割己于人。而天性敖于林峦，守道不趣于浮世也。大蜀皇帝响其德高，敕书请诏。师辞老病不赴，渥泽须送紫衣法号神照大师。

问僧：“什摩处去？”对云：“去娥媚礼拜普贤。”师提起拂子云：“文殊普贤，总在这里。”其僧便作圆相，抛向背后。师唤侍者。师云：“将一贴茶来与师僧。”

师欲顺世时患口㖞。师乃集众，上堂告云：“还有人医得吾口摩？有人医得，出来！”再三徵，无人只对。师云：“若无人解医，老僧自医。”师遂以手推正。告寂。

祖堂卷十九·灵树

灵树和尚嗣西院安禅师，在韶州。师讳如敏，冥州人也。

自四十余年，大化汉国，其道行孤峻。一方贤儒，敬重极矣。多有异行，南北礼为师，赐号知圣大师。

有僧问：“和尚生缘在什摩处？”云：“日出东山，月落西山。”“年多少？”师云：“今日生明日死。”问：“如何是法身？”云：“鼓鸣也吃饭去。”问：“佛法毕竟事如何？”师展开两手。

镇州大王请赵州，共师斋次。师问赵州：“大王请和尚斋，和尚将何报答？”赵州云：“念佛。”师云：“门前乞兒也解也摩道。”州云：“大王，将钱来与灵树。”

祖堂卷十九·倩山

倩山和尚嗣西院安禅师，在饶州。未睹行录，不决化缘终始。

问：“如何是西来意？”云：“中冬严寒。”问：“如何是深深处？”师云：“待你舌头落地，则向你道。”

祖堂卷十九·道吾休

道吾休和尚嗣关南。

师每日上堂，戴莲花笠子，身著拦简，击鼓吹笛，口称鲁三郎云：“打动关南鼓，尽唱德山歌。”法乐自娱者是也。

有人拈问东山：“古人有言：‘打动关南鼓，尽唱德山歌。’如何是‘关南鼓’？”云：“听。”“如何是‘德山歌’？”云：“还解和得摩？”“忽遇同道者，作摩生？”云：“教他作舞应声。”“便作舞时，作摩生？”云：“知音者不无，亦须讳却。”“讳却后如何？”云：“萎萎羸羸，且与摩过时。”

师上僧堂，问第一座：“上座是什摩人？”对云：“东国人。”“彼中还有这个样人也无？”对云：“有。”“既有，来这里作什摩？”对云：“只为有，所以回避来。今日恰遇著。”师便呵呵大笑，却归房丈。

祖堂卷十九·俱胝

俱胝和尚嗣天龙，在敬安州。未睹行录，不决始终。

师因住庵时，有尼众名实际，戴笠子执锡，绕师三匝，卓锡前立，问师曰：“和尚若答，某甲则下笠子。”师无对，其尼便发去。师云：“日势已晚，且止一宿。”尼云：“若答得便宿，若答不得，则进前行。”师叹曰：“我是沙门，被尼众所笑。滥处丈夫之形，而无丈夫之用。”

欲出山参寻知识，宴寂之中，忽然神人报言：“三五日间，有大菩萨人到来，为和尚说法。”未逾旬日，天龙和尚到来，师接足前迎，侍立之次，具陈上事。“未审如何对他？”天龙竖起一指，师当时大悟。后为众云：“某甲得天龙和尚一指头禅，一生用不尽。”

祖堂卷十九·胜光

胜光和尚嗣紫湖，在台州。

问：“如何是和尚家风？”云：“福州荔枝，泉州刺桐。”问：“如何是‘佛法’两字？”云：“即便道。”进曰：“请师道。”云：“穿耳胡僧笑点头。”

祖堂卷十九·资福

资福和尚嗣仰山和尚，在吉州。师讳贞邃，韶州浈昌县人也。

师有时把团子，向面前云：“诸佛菩萨，及入理圣人，皆从这里出。”却折破抛下，拍开胸云：“作摩生？”问：“如何是古佛心？”云：“山河大地。”问：“如何是纳僧切急处？”云：“不过于此。”问：“室内呈丧时如何？”师云：“好个问头。”

学人礼拜，师云：“苦痛苍天。”学人云：“此时学人重揲和尚，如何？”云：“明日来，向你道。”学人云：“苦痛苍天。”师便打之。问：“古人拈槌竖拂，此理如何？”“哑。”

又僧过夏问师：“某甲新入丛林，在此间过夏，未曾蒙和尚指教，亦须往问。”遂至和尚所，述其意，则被师拦胸托出云：“某甲自住此山，未曾瞎却一个师僧眼。”

问：“如何是一路涅盘门？”师弹指一下，却展手。“如何领会？”云：“不是秋月不明，子自横行八九。”


祖堂集卷二十

祖堂卷二十·瑞云寺

五冠山瑞云寺和尚嗣仰山寂禅师，师讳顺之。俗姓朴氏，浿江人也。

祖考并家业雄豪，世为边将，忠勤之誉，遗庆在乡。母昭氏，柔范母仪，芬芳闾里。怀娠之日，频梦吉祥。免腹之时，即多异瑞。昔贤知此，今又徵焉。及乎竹马之期，渐有牛车之量。凡为嬉戏，必表殊常，已至十岁，精勤好学；属词咏志，即见凌云；剖义谈玄，如同照镜。既登弱冠，道牙早熟。厌处喧华之地，长游静默之中，遂乃恳告二亲，将随缁侣。志不可夺，所天容许，便投五冠山剃发，乃适俗离山，受具足戒，行同结草，心比护鹅。因游公岳，忽遇神人邀请，化成官阙，若兜率天，说法应缘，倏焉殄灭。若非德至行圆，孰能致感如此也？

洎乎大中十二年，私发誓愿，拟游上国。随入朝使利涉云溟，乘一只之舟＋公，过万重之浪，曾无惧念，不动安禅，迳到仰山慧寂和尚处，虔诚礼足，愿为弟子，和尚宽尔笑曰：“来何迟？缘何晚？既有所志，任汝住留。”禅师不离左右，谘禀玄宗，若颜回于夫子之下，如迦叶于释尊之前。彼中禅侣，皆增叹伏。

乾符初，松岳郡女檀越元昌王后，及子威武大王，施五冠山龙严寺，便往居焉，今改瑞云寺也。

师有时表相现法，示徒证理迟疾。此中四对八相。

○此相者，所依涅般相，亦名理佛性相，与群生众圣，皆依此相。相虽不异，迷悟不同。故有凡夫有圣，谓识此相者名为圣人，迷此相者名为凡流。是故龙树在南印土，则为说法，对诸大众而现异相，身如月轮，当于坐上。唯闻说法，不见其形。彼众之中，有一长者，名曰提婆，谓诸众曰：“识此瑞不？”众曰：“非其长圣，谁能辩耶？”尔时提婆心根宿静，亦见相默然契会，乃告众曰：“今此瑞者，师现佛性，非师身者。无相三昧，形如满月。佛性之义……”语犹未讫，师现本身，座上偈曰：

身现圆月相，以表诸佛体。

说法无其形，用辩非声色。

若有人将此月轮相来问，相中心著牛字对也。

○@牛此相者，牛食忍草相，亦名见性成佛相。何以故？经云：“雪山有草，名为忍辱。牛若食者，则出醍醐。”又云：“众生若能听受，咨启大涅般，则见佛性故。当知草喻妙法，牛喻顿机，醍醐喻佛。如是则牛若食草，则出醍醐。人若解法，则成正觉。故云牛食忍草相，亦名见性成佛相也。

○牛＋牛＋牛，此相者，三乘求空相。何以故？三乘人间说真空，有心趣向，未证入真空，故表围相下画三牛也。若将此相来问，以渐次见性成佛相对之。

○@牛此相者，露地白牛相，谓露地者佛地，亦名第一义空。白牛者谘法身之妙慧也，是故表一牛入圆相也。问：“何故月轮相下著三兽，又月轮相中心著牛字对之耶？”答：“月轮相下三兽，是表三乘。月轮相中心一牛，是表一乘，是故举权乘来，现实入证对之。”问：“向前已说，月轮相中心著牛，是牛食忍草相。何故又言月轮相中心著牛者？”“露地白牛相也。”“两处皆是同相同牛，何故说文不同耶？”答：“说文虽别，相及牛则不异。”问：“若也不异，何故两处各现同相同牛耶？”答：“虽相及牛则不异，见性迟疾不同，故两处各现同相同牛。”问：“若论见性迟疾各别者，食忍草牛与露地白牛谁迟谁疾耶？”答：“食忍草牛，则明花严会中顿见实性之牛，故疾；露地白牛，则明法华会中，会三归一牛故，是故说文虽则不同，证理不异。故举同相同牛，明理智不异，不言来处全同也。

牛○，此相者，契果修因相。何以故？初发心住，虽成正觉，而不碍众行。慧等佛地，行不过位，故表此相也。古人云：“履践如来所行之迹”，则此相也。若有人将此相来问，又作月轮相中心著橑字对之。

○@橑，此相者，因圆果满相也。问：“何故月轮相上头著牛字来，月轮相中心著橑字对之？”答：“月轮相上头著牛者，契果修因相。日［月］轮相中心著橑字者，因圆果满相。举因来现果对之。

○牛，此相者，求空精行相，谓门前草庵菩萨求空故。经云：“三僧败修菩萨行，难忍能忍，难行能行。”求心不歇，故表此相也。若有人将此相来问，月轮相中心著王字对之。

○@王，此相者，渐证实际相。何以故？若有菩萨经劫修行，坏四魔贼，始得无漏真智，证人佛地，更无余习所恆［忄＋且］，似圣王降伏群贼，国界安宁，更无怨贼所忄＋且。故表此相也。此下两对四相，遣虚指实。

牛○@人，此相者，想解遣教相。谓：若有人依佛所说一乘普法，善能讨寻，善能解脱，实不错谬，而不了自己理智，全依他人所说。故表此相也。若有人将此相来问，则袪上头牛字对之。

○@人，此相者，识本还源相。经云：“回神住空窟，降伏难调伏。”解脱魔所缚，超然露地坐，识阴般涅般者，即此相也。问：“何故袪上头牛字，不袪圆相中心人字耶？”答：“圆相中心人字者，表理智；上头牛字音，喻人想解。若有人虽依教分析三藏教典，而未显自己理智者，尽是想解。想解不生，则理智现前。故袪上头牛字，不袪圆相中心人字，是故经云：“但除其病，而不除法。”问：“何故不许凡人依教学法耶？”答：“若是智者依教，何用识心？凡人依教无益。”问：“诸佛所说三藏经典，有所用不？”答：“不是不许，依教悟入，依教想解，只是虚妄。是故佛告阿难，虽复忆持，十方如来十二部经，清净妙理如恆河沙，只益戏论，当知依教想解无益。”问：“何故教云‘闻佛教者，尽成圣果’？又云‘一毫之善，发迹驻佛’”？答：“约上根人，依教便梧。直现理智，决定明了。若约下根，依教不悟，想解无益。此下根人，依教动［薰］种。待后世者，谁言无益？闻佛教者，尽成圣果。一毫之善，发迹驻佛。何况广学经论，及讲说者？”

○@人牛，此相者，迷头认影相。何以故？若有人不了自己佛及净土，情知他方佛净土，一心专求往生净土。见佛闻法，故勤修善行。念佛名号，及净土名相。故表此相也。志公笑云：“不解即心即佛，真似骑驴觅驴者。”即此相也。若有人将此相来问，则袪圆相下牛字对之。

○@人，此相者，背影认头相。问：“何故袪下头牛字，不袪圆相中心人字耶？”答：“众生未发真智，未达真空，故专求他方净土及佛，往生净土，见佛闻法。众生若回光发智，达得真空，自己佛及净土，一时齐现。不求心外净土佛，故不袪圆相中心人字，袪下牛字也。”问：“如何是自己佛及自己净土？”答：“众生若发真智，达得真空，即真智是佛，空是净土。若能如是体会，何处更求他方净土及佛也？是故经云：‘将闻持佛佛，何不自闻闻？’”

又此下四对五相：

□，此相者，举函索盖相，亦名半月待圆相。若有人将此相来问，更添半月对之。此则问者举函索盖，答者将盖著函，函盖相称故，已现圆月相也。圆相则表诸佛体也。

□，此相者，把玉觅契相。若有人将此相来问，圆月中心著某对之。此则问者把玉觅契，故答者识珠便下手。

□，此相者，钓入索续相。若有人将此相来问，某字边添著人字对之。此则问者钓入索续，故答续成宝器也。

○@佛，此相者，已成宝器相。若有人将此相来问，又作圆月相中心著土字对之。

○@士，此相者，玄印旨相，迥然超前现众相。更不属教意所摄。若有人似个对面付，果然不见。故三祖云：“毫厘有错，天地玄隔。”然不无玄会之，谁能识此相也？若是其人，见而谙会，如子期听百牙之琴，提婆见龙树之相。不是其人，对面不识，似巴人闻白雪之歌，锾子入净名之会。假使后学根机玄利，将是则顿晓。如鸡把卵，啐啄同时。相性迟钝者，学而难晓。似盲人相色而转错耳。

师有时说三遍成佛篇，于中有三意。云何为三？一者证理成佛，二者行满成佛，三者示显成佛。言证理成佛者，知识言下，回光返照，自己心原，本无一物，便是成佛。不从万行渐渐而证，故云证理成佛。是故经云：“初发心时，便成正觉。”又古人云：“佛道不远，回心即是。”即此义也。此证理成佛中，若说体性，都无一物。通论三身，不无一佛二菩萨。虽有三人，而今见性成佛，故得成佛，功在文殊，故古人云：“文殊是诸佛母。”所谓诸佛从文殊生，故言文殊者，即实智也。一切诸佛，因其实智，而证菩提。是故文殊是诸佛母耳。

言行满成佛者，虽已穷其真理，而顺普贤行愿。历位广修菩萨之道，所行周备，悲智圆满。故云行满成佛也。故古人云：“行到处即是从来处。”是故明知，所行已周，还至本处。本处者即理也。此行满成佛所证之理，不异于前证理成佛之理。理虽不异，行因至果，故云行满成佛也。此行满成佛中，若举果德，但以普贤，行成佛道。论三身亦有一佛二菩萨，虽有三人，而今别取行满成佛，故得成佛功在普贤。故古人云：“普贤是诸佛父也。”所谓诸佛从普贤生。故言普贤者，即万行也。一切诸佛，因其万行而证菩提，是故普贤是诸佛父耳。

言一佛二菩萨者，遮那是理，文殊是智，普贤是行。此理、智、行，三人同体，故一不可舍也。又，一佛二菩萨，互为主伴，以本体无上，遮那为主；以见性智功，文殊为主；以万行福力，普贤为主。是故李玄通云：“一切诸佛，皆以文殊普贤二大士成佛菩提也。”又云：“文殊普贤，为诸佛作少男长子。”故知三人互为主伴耳。

言示显成佛者，如前证理行满，自行成佛已毕，今为众生，示显成佛，八相成道矣。言八相者，从兜率天退、入胎、住胎、出胎、出家、成道、转法轮、入涅般等八相成佛，故云示显成佛当知八相成道，是报化非真。是故经云：“如来不出世，亦无有涅般。”以本愿力，故示显自在法，此经报化佛中指真佛也。又经云：“吾从成佛已来，经无量阿僧只劫。故知释迦如来，无量劫前，已成行满大觉，而为众生故。示显始成正觉，今此释迦，是贤劫千佛之中第四佛也。过去庄严劫中一千佛，现在贤劫中一千佛，未来星宿劫中一千佛。如是三劫中，一切诸佛出现于世，摄化群生，相传授记，分毫不错矣。观看教典，推寻古迹，通观一人成佛方样，应知三遍成佛耳。伏请欲磨佛位者，略看筌蹄，却自思惟。前佛后佛，皆同此路。如人行路，新旧同辙，故记而［而记］之也。

师有时说三篇，于中有三意。第一《顿证实际笃》，第二《回渐证实际篇》，第三《渐证实际篇》。

广野中有一仙人，名日该通。为大众说：“若有众生，无始已来，不悟性地，轮回三界，随缘受报。忽遇智者，演说真教。顿悟性地，便成正觉，不依渐次，故名为顿证实际。是故经云：‘雪山有草，名曰忍辱。牛若食者，即出醍醐。’是其意也。”

众中有一隐士，名曰智通，启仙人曰：“信知群品自有性地，又一切智者，演说真教，不为一人。何以故？同闻真教，悟与不悟，各各不同？”仙人告隐士言：“众生虽有自性清净圆明之体，背本逐末，多劫多时，受别异身，根性利钝不等，故同闻真教，悟与不悟各各不同，不是智者说真教祸。故经云：‘犹如明净日，瞽者莫能见。’无有智慧心，终不能见。”隐士启仙人曰：“谛观高指，且寻来言，智者说法，不为一人。悟与不悟，唯在愚智。然则愚智本来各各不同。说法有何所用？”仙人告隐士言：“汝今谛听，吾为汝说。智人不是本悟，愚人不是长迷。愚人忽悟真说，智人不是外来。若也不用真教，愚争成智人？若也不用真教，何处辩得利钝？是故众生若是根钝者，再闻真教，不晓性地。众生若是利根者，忽闻真教，顿晓性地，便是智人也。何处愚智有隔？是故当知凡圣不隔，根有利钝。智者说法，亦不为一人，犹如母鸡抱卵，众卵皆发。赞窠不发，可即母鸡唯不爱众卵，爱赞［占］窠。是则发与不发，唯在卵性，不是母鸡抱卵之祸。一切智者，亦复如是。广为大众演说真教，根利者顿晓，根钝者不晓，可则智者唯爱利根，不爱钝根，是即晓与不晓唯在根性，不是智者说教之祸。是故经云：‘所有闻法，不由他悟。’然即知假方便，智者常说妙法，悟与不悟，此在学人，不在智者。”隐士问曰：“众生若是利根，忽闻真教，言下慧发，顿悟性地。此是何人？”仙人答曰：“此是智照文殊。”隐士问曰：“文殊智照在何处？”仙人答曰：“文殊智照是在性之隐士。”问曰：“照智与性地同异若何？”仙人答曰：“智照与性地不同不异。”隐士问曰：“智照与性地不同不异，其义如何？”仙人答曰：”智照是能证之人，性地是所证之法，故不无能所。是故古人云：‘以此无知之般苦，证被无相之真谛。’故智与性不同。又能证智照无知，所证性地无体，不有能所。是故古人云：‘智穷真际，能所两亡。’故智照与性地不异照。”隐士智通闻仙人说，奉契高指，顿决疑网也。

于时该通仙人为大众说，先为智通已说见性，若论众行，不必如此。此众中有游子，名曰行通，启仙人曰：“见性如此，众行若何？”仙人告游子言：“若有众生，忽闻真教，顿见性地，不住此处，随缘行，自利利他悲智，故名为众行。”游子启仙人曰：“我等曾闻仙人演说法，忽闻真教，顿悟性地，名为智照文殊。今承仙人说，顿悟性地，不住此处。随缘行自利利他悲智，故名为众行。行此行者，此是何人？”仙人答曰：“行此行者，寄位普贤。”游子问曰：“普贤大士，寄何等位？”仙人答言：“寄因五位，乃至果位。虽寄此位，不住此位。”

众行行时，三等普贤。游子问曰：“寄位于因位，乃至果位。何等名为三等普贤？”仙人答曰：“一者出缠普贤，二者入缠普贤，三者果后普贤。”游子问曰：“此三普贤，胜劣等级，其义如何？”仙人答言：“此三普贤，胜劣等级，其义不同。谓所言出缠普贤者，见性之后，行于众行。对前万境，不无瞥起之心。已达心源，不滞幻化之境。故古人云：‘不无所断之障，还有能断之智。’”游子问曰：“古人云：‘若发能证之智，全无所断之障。’其义如何？”仙人答曰：“‘若发能证之智，全无所断之障’者，此是文殊断惑。何以故？文殊当性之时，体中不有异相，故今言不无所断之障，还有能断之智。此是普贤断惑。何以故？普贤历位之时，不无断惑成德故。是故两人断惑成德不同，不会两人断惑成德，相诤断惑成德之义。”游子问曰：“已知文殊断惑如此，若论普贤断惑，断现行耶？断习气耶？”仙人答言：“若言普贤位中，全无现行烦恼，普贤寄位断惑，此是习气烦恼。”游子问：“现行与习气如何？普贤全无现行之惑，唯有习气之障。”仙人答言：“凡夫对境起心，不识前境后境作业，即是现行。智者对境起心，知境虚幻，不滞前境习气，故是普贤是见性之后，行行之人，故全无现行之惑，唯有习气之障。若无习气可断，何用难忍能忍？若无悲智成佛，何用难行能行？虽行悲智，二门所作，依体成行，是故古人云：‘所作皆依性，修成功德林，终无取寂意，唯有济群心。行悲悲广大，用智智能深。利他兼自利，少圣讵能任？’然却知出缠普贤，众行悲智，而依体修行，又细说普贤众行，即行布圆融齐现，断惑成德俱有，自利利他双修，智门悲门并成。言行也，繁兴大用，起必全真，言行相也。不无依位断惑，位高则习气渐薄，行广则悲智增深。从十住乃至十地，出缠菩提已满也。所言入缠普贤者，一切群品中，同类大悲是。前出缠普贤位中，广行悲智，而自利利他行故，不无断惑成德之功。虽断成德之功，出缠已满，而不信出缠无患之处，故于四生六趣，广行大悲，同断化物之名入缠普贤，以此入缠化物之德，与前出缠成行之功，二心功齐平等，故名为等觉。悲智圆满，故名为等觉。不取出缠入缠，不取大智大悲，故名为妙觉。虽不取悲智出缠入缠，若论果德，无行不取，无位不收也。所言果后普贤者，通行三昧是也。谓：妙觉位中，虽不取出缠大智大悲，而不住此，还向出缠大缠，大智大悲，逆顺纵横，于诸位中同类同心，亦不定守位，随缘任运，广作大悲。于诸类中，何位定不受，于能作能受，不作不受，故名为果后普贤也。若定取此人所行者，未会此人行处也。所言三等普贤者，不是三人，一人行行，依行胜劣大义，三等普贤也。所言一人者，初顿证实际之时即文殊，今随缘行行之时即普贤，故名为一人也。此是通取内证外化也。若以内证外化不同，故文殊普贤两人。若以通取能证所证，及众行不同，即为三人也。此大教意说也。

谓大经题云：大方广者所说之法故，即遮那是也。佛者，能证之人也，故即文殊是也；花严者，随缘之行，故普贤是也。此且一佛二菩萨，即为三人也。苦欲修行普贤行者，先穷真理。随缘行行，即今行与古迹相应，如似闭门造车，出门合撤耳。

《回渐证实际篇》第二，时该通仙人为大众说法。若有众生，无始已来，不悟性地，轮回三界，闻三乘渐教，悟三乘法，三界患，故有三乘人。此忽闻真教，回成妙惠，穷证实际，故名为回渐证实际也。是故古人云：‘门前三驾车是权乘，露地白牛方明实际。’即其意也。”

隐士智通启仙人曰：“此回渐证实际之者，与彼顿证实际之人同异如何？”仙人答曰：“虽先已落三乘，不在三乘故，来处玄殊，而今回渐证实际，故与彼顿证实际者不异。是故古人云：‘百川归大海，无百川名，三乘归一乘，无三乘名也。然即知此回渐证实际之人，与彼顿证之人不异也。莫愁回渐与顿证同异，自回随缘之心，还照实际之理也。”隐士智通奉领真说，寂然无言也。

于时游子行通启仙人曰：“我等曾问仙人演说，若有众生，顿证悟性地，不住此处，随缘行行，名为众行。行此行者，名为普贤。今此回渐证实之后，有人行众行耶？无人行众行耶？”仙人答曰：“不无行众行者，所以者何？回渐证实者，即露地白牛故。白牛运转，不住露地故，不无行众行人，所言露地白牛者，露地是所证之法故，即遮那是也。白牛是能证之人故，即是文殊是也。白牛运转，不住此处故，即普贤是也。普贤所行，即是众行也。二篇大意如此，汝自谛观，同异自看耳。”

《渐证实际篇》第三，时该通仙人为大众说：“若有众生，无始已来，不悟性地。轮回三界，随缘受报。忽闻渐教，信解渐发，寄因六位，经三败劫，难忍能忍，难行能行，断惑成德，始得无漏真智。露现法身，故名为渐证实际也。是故古人云：“信根生一念，诸佛尽应知。修因于此日，证果未来时。三大僧败劫，六度久安施。薰成无漏种，方号不思议。”是其意也。

时隐士智通启仙人曰：“今此渐证实际之人，顿悟实际之人，同异如何？”仙人告隐士言：“虽渐顿不同，而终归一耳。所以者何？小川归海，全同一味。渐解归源，岂有两般也？是故渐顿虽异，归源无二耳。”隐士智通，奉仙人教，不生异解，退身默然也。

于时游子行通，启仙人曰：“于前篇中闻仙人说顿证实际后有行人。此篇所明渐证实际之者，渐证实际已后，有行人耶？”仙人答曰：“虽不无行行，不同前篇所明者，顿证实际已后，随位行时，出缠入缠，乃至果后，三等普贤行。今此《渐证实际篇》意者，依渐教方便，经三僧败修菩萨行，始得无漏真智。以此无漏真智，露现法身，故名为渐证实际。渐证实际已后，虽不无行行，而全依位等级故。是故不同前篇所明也。”

游子问曰：“曾闻前两篇中，俱明能证之人，所证之法，乃至随缘行人，各各有名。此篇中还有能证所证，及随缘行人名耶？请为指出。”仙人答曰：“不无能证所证，及随缘行人名也。”谓能证之人者，即是无漏真智，亦报身佛是也。所证之法者，即是实际，亦名法身佛是也。行之人即是无漏真智，不守果位，随缘利物，名为行人，亦名化身佛是也。”

和尚享年六十五迁化也，谥号了悟禅师真原之塔。

祖堂卷二十·米和尚

米和尚嗣襄州王敬初常侍，在西京。未睹行录，莫穷氏族。

师因教僧问仰山：“令时还假悟也无？”仰山云：“悟则不无，争奈落第二头何？”师肯之。

有老宿屈师斋，师来不排座位。老宿在一边坐，师便展座具，礼拜老宿。老宿便起，师便坐，老宿都不作声。乃展席地上而坐。到夜间，告众曰：“他家若在佛法中，用心三日，便合见，若不见则不知。”师到三日后，来云：“前日著贼。”僧问镜清：‘米和尚回意如何？’”云：“只见锥头利，不见凿头平。”

临济问师：“十二面观音，岂不是圣？”师云：“是也。”“作摩生是本来面？”临济一掴。师云：“长老且宽宽。”济侧掌，师归受业寺。

有老宿问：“月中断井索，时人唤作蛇。未审吾师唤作甚摩？”师云：“若有佛见，则同众生见。”其老宿云：“千年桃核。”

祖堂卷二十·宝寿

宝寿和尚嗣临济，师讳沼，在镇州。未睹行录，不决化缘终始。

师问胡钉铰：“见说解钉铰，是不？”对曰：“是也。”师曰：“还解钉铰得虚空摩？”对曰：“请和尚打破将来。”师便打之。对曰：“莫错打某甲。”师云：“向后有多口阿师与你点破在。”

有人举似赵州。赵州云：“只者一缝，尚不奈何。”东山代第一云：“若是某甲手里，阿那个缝门@下不钉？”

师初开堂时，三圣推出一僧，师便打之。三圣云：“长老与摩识弁人，瞎却镇州城里人眼去在。”

祖堂卷二十·灌溪

灌溪和尚嗣林济，在潭州。师讳志闲。未睹行录，不决化缘始终。

后道吾参师，不礼拜便问：“什摩生？”师云：“无位。”吾云：“与摩则同空去也。”师云：“咄，这屠兒！”吾云：“有生可杀则不倦。”

师到末山师姑处，师姑问：“从什摩处来？”师云：“露口来。”师姑云：“何不盖覆？”师却问：“如何是末山？”师姑云：“不露顶。”进曰：“如何是末山中人？”姑云：“非男非女相。”进曰：“还变也无？”姑云：“不是鬼神，变什摩？”师肯之。

洞山问夹山：“作摩生？”对云：“只与。”洞山肯之。有人举似师，师云：“金打金，水洗水。”云门拈问僧：“作摩生是金打金，水洗水？”僧云：“吃胡饼。””与摩道，还得摩？”僧云：“捶了莫闹。”云门肯之。问：“如何是不伤之句？”师云：“满口道不触。”

师初住灌溪山，次化岳麓。每有一言：五阴山中古佛堂，毗卢昼夜放圆光。”

塔于岳麓山。

祖堂卷二十·兴化

兴化和尚嗣林济，师在魏府，师讳存奖。未睹行录，莫决终始。敕谥广济大师通寂之塔。

师问僧：“甚摩处来？”对云：“崔禅师处来。”师云：“还将得喝来也无？”对云：“不将来。”师云：“与摩则不从崔禅师处来。”僧便喝，师便棒打。

师又时唤，僧应喏。师云：“点则不到。”又唉别僧。僧云：“作摩？”师云：“到则不点。”问：“国师唤侍者意作摩生？”师云：“一盲引众盲。”怡山拈问众：“什摩处是国师盲处？”自代云：“他家欠少甚摩？”

同光帝问师：“朕昨来河南，取得一个宝珠，无人著价。”师云：“请皇帝宝珠看。”帝以两手拨开幞头角。师云：“皇帝是万代之宝珠，谁敢著价？”

祖堂卷二十·后鲁祖

后鲁祖和尚嗣灌溪，在邓州。

问：“如何是双林树？”师云：“有相身中无相身。”进曰：“如何是无相身？”师云：“金香炉下铁昆仑。”问：“如何是高峰独宿底人？”师云：“夜半日头明，午时打三更。”问：“格外事如何？”师云：“化道缘终后，虚空更那边。”僧问：“进向无门时如何？”师云：“太钝生。”进曰：“不是钝生，直下进向无门时如何？”师云：“灵机未曾论边际，执法无［元］来在暗中。”问：“如何是学人著力处？”云：“春来草自青，日上已天明。”进曰：“如何是不著力处？”云：“山头石崩落，平川烧火行。”

祖堂卷二十·隐山

洞山行脚时，迷路入山，恰到师处。师问：“此山无路，从什摩处来？”对云：“来处则不无。和尚从什摩处入此山？”隐山云：“我不从云水来。”“和尚是先住，此山是先住？”云：“不知。”“和尚为什摩不知？”云：“春秋不到来。”洞山便问：“如何是宾中主？”云：“白云盖青山。”“如何是主中主？”云：“长年不出户。”“宾主相去几何？”云：“长江水上波。”“宾主相见，有何言说？”云：“清风拂白月。”又偈曰：

青山白云父，白云青山兒。

白云终日依，青山都不知。

欲知此中意，寸步不相离。

洞山因此颂曰：

道无心合人，人无心合道。

欲知此中意，一老一不老。

因此，龙牙大师造颂曰：

心空不及道空安，道与心空状一般。

参玄不是道空士，一乍相逢不易看。

因此，曹山大师造颂曰：

今年田不熟，来年种有期。

爱他年少父，须得白头兒。

祖堂卷二十·兴平

洞山礼拜，师云。“莫礼老朽。”洞云：“礼非老朽者。”师云：“他不受礼。”洞山云：“亦未曾止。”洞又辞，师云：“何处去？”云：“沿流无所止。”师云：“法身沿流，报身沿流？”云：“总不作如是见解。”师拍掌讶之。

保福云：“觅不得几个。”又问：“如何是古佛心？”师云：“即汝心是。”“虽然如此，犹未是某甲问处。”师云：“若与摩，问取木人去。”“某甲有一句子，不借诸圣口。”师云：“汝试道看。”洞山云：“不是某甲，有人问。”

祖堂卷二十·米岭

问：如何是纳衣下事？师云：“丑陋任君嫌，不挂云霞色。”

全书完