New Page 2

此网页使用了框架，但您的浏览器不支持框架。


New Page 4

<< 地藏菩萨本愿经 >>

香赞

炉香乍　 法界蒙熏 诸佛海会悉遥闻 随处结祥云 诚意方殷 诸佛现全身 南无香云盖菩萨摩诃萨 南无香云盖菩萨摩诃萨 南无香云盖菩萨摩诃萨

觉林菩萨偈

华严第四会，夜摩天宫，无量菩萨来集，说偈赞佛。尔时觉林菩萨承佛威力，遍观十方，而说颂言：『

譬如工画师，分布诸彩色。虚妄取异相，大种无差别。 大种中无色，色中无大种。亦不离大种，而有色可得。

心中无彩画，彩画中无心。然不离於心，有彩画可得。 彼心恒不住，无量难思议。示现一切色，各各不相知。

譬如工画师，不能知自心。而由心故画，诸法性如是。 心如工画师，能画诸世间。五蕴悉从生，无法而不造。

如心佛亦尔，如佛众生然。应知佛与心，体性接无尽。 若人知心行，普造诸世间。是人则见佛，了佛真实性。

心不住於身，身亦不住心。而能作佛事，自在未曾有。 若人欲了知，三世一切佛。应观法界性，一切唯心造。 』

赞

稽首本然清净地 无尽佛藏大慈尊 南方世界涌香云 香雨花云及花雨 宝雨宝云无数种 为祥为瑞遍庄严 天人问佛是何因 佛言地藏菩萨至 三世如来同赞叹 十方菩萨共皈依 我今宿植善因缘 称扬地藏真功德

慈因积善，誓救众生，手中金锡，振开地狱之门。掌上明珠，光摄大千世界。智慧音里，吉祥云中，为阎浮提苦众生，作大证明功德主。大悲大愿，大圣大慈，本尊地藏菩萨摩诃萨。

南无本师释迦牟尼佛 南无本师释迦牟尼佛 南无本师释迦牟尼佛

开经偈

无上甚深微妙法 百千万劫难遭遇 我今见闻得受持 愿解如来真实义

    地藏菩萨本愿经卷上

    忉利天宫品第一

    如是我闻。

    一时佛在忉利天，为母说法。

    尔时十方无量世界，不可说不可说一切诸佛及大菩萨，皆来集会。赞叹释迦牟尼佛，能於五浊恶世，现不可思议大智慧神通之力，调伏刚强众生，知苦乐法，各遣侍者，问讯世尊。

      是时，如来含笑，放百千万亿大光明云，所谓大圆满光明云、大慈悲光明云、大智慧光明云、大般若光明云、大三昧光明云、大吉祥光明云、大福德光明云、大功德光明云、大皈依光明云、大赞叹光明云。

    放如是等不可思议光明云已，又出种种微妙之音，所谓檀波罗蜜音、尸波罗蜜音、羼提波罗密音、毗离耶波罗蜜音、禅波罗蜜音、般若波罗密音、慈悲音、喜舍音、解脱音、无漏音、智慧音、大智慧音、师子吼音、大师子吼音、云雷音、大云雷音。

    出如是等不可说不可说音已，娑婆世界，及他方国土，有无量亿天龙鬼神，亦集到忉利天宫，所谓四天王、忉利天、须焰摩天、兜率陀天、化乐天、他化自在天、梵众天、梵辅天、大梵天、少光天、无量光天、光音天、少净天、无量净天、遍净天、福生天、福爱天、广果天、无想天、无烦天、无热天、善见天、善现天、色究竟天、摩醯首罗天、乃至非想非非想处天，一切天众、龙众、鬼神等众，悉来集会。

    复有他方国土，及娑婆世界，海神、江神、河神、树神、山神、地神、川泽神、苗稼神、昼神、夜神、空神、饮食神、草木神，如是等神，皆来集会。

    复有他方国土及娑婆世界、诸大鬼王、所谓恶目鬼王、啖血鬼王、啖精气鬼王、啖胎卵鬼王、行病鬼王、摄毒鬼王、慈心鬼王、福利鬼王、大爱敬鬼王，如是等鬼王、皆来集会。

    尔时释迦牟尼佛、告文殊师利法王子菩萨摩诃萨：「汝观是一切世界诸佛菩萨摩诃萨及天龙鬼神，此世界、他世界，此国土、他国土，如今集会到忉利天者，汝知数否？」

    文殊师利白佛言：「世尊，若以我神力，千劫测度，不能得知。」

    佛告文殊师利：「吾以佛眼观故，犹不尽数。此皆是地藏菩萨久远劫来，已度、当度、未度，已成就、当成就、未成就。」

    文殊师利白佛言：「世尊，我已过去久修善根、证无碍智、闻佛所言，即当信受。小果声闻、天龙八部、及未来世诸众生等，虽闻如来诚实之语，必怀疑惑。设使顶受，未免兴谤。唯愿世尊、广说地藏菩萨摩诃萨，因地作何行、立何愿，而能成就不思议事。」

    佛告文殊师利：「譬如三千大千世界所有草木丛林、稻麻竹苇、山石微尘，一物一数，作一恒河；一恒河沙，一沙一界；一界之内、一尘一劫，一劫之内，所积尘数，尽充为劫，地藏菩萨证十地果位以来，千倍多於上喻。何况地藏菩萨在声闻、辟支佛地。

    文殊师利，此菩萨威神誓愿，不可思议。若未来世，有善男子、善女人，闻是菩萨名字，或赞叹、或瞻礼、或称名、或供养，乃至彩画刻镂塑漆形像，是人当得百返生於三十三天，永不堕恶道。

    文殊师利，是地藏菩萨摩诃萨，於过去久远不可说、不可说劫前，身为长者子。时世有佛，号曰「师子奋迅具足万行如来」。时长者子，见佛相好，千福庄严，因问彼佛：「作何行愿，而得此相？」时师子奋迅具足万行如来告长者子：「欲证此身，当须久远度脱一切受苦众生。

    文殊师利，时长者子，因发愿言：「我今尽未来际不可计劫，为是罪苦六道众生，广设方便，尽令解脱，而我自身，方成佛道。」以是於彼佛前，立斯大愿，于今百千万亿那由他不可说劫，尚为菩萨。

    又於过去，不可思议阿僧只劫，时世有佛，号曰「觉华定自在王如来」，彼佛寿命，四百千万亿阿僧只劫。像法之中，有一婆罗门女，宿福深厚，众所钦敬；行住坐卧，诸天护卫。其母信邪，常轻三宝。

是时圣女广设方便，劝诱其母，令生正见，而此女母，未生全信。不久命终，魂神堕在无间地狱。时婆罗门女，知母在世，不信因果。计当随业，必生恶趣。遂卖家宅，广求香华，及诸供具，於先佛塔寺，大兴供养。见觉华定自在王如来，其形像在一寺中，塑画威容，端严毕备。

时婆罗门女，瞻礼尊容，倍生敬仰。私自念言：「佛名大觉，具一切智。若在世时，我母死後，傥来问佛，必知处所。」时婆罗门女，垂泣良久，瞻恋如来。忽闻空中声曰：「泣者圣女，勿至悲哀，我今示汝母之去处。」婆罗门女合掌向空，而白空曰：「是何神德，宽我忧虑。我自失母以来，昼夜忆恋，无处可问知母生界。」时空中有声，再报女曰，我是汝所瞻礼者，过去觉华定自在王如来，见汝忆母，倍於常情众生之分，故来告示。」

婆罗门女闻此声已，举身自扑，肢节皆损。左右扶侍，良久方苏。而白空曰：「愿佛慈愍，速说我母生界，我今身心，将死不久。」时觉华定自在王如来，告圣女曰：「汝供养毕，但早返舍，端坐思惟吾之名号，即当知母所生去处。」

    时婆罗门女寻礼佛已，即归其舍。以忆母故，端坐念觉华定自在王如来。经一日一夜，忽见自身到一海边。其水涌沸，多诸恶兽，尽复铁身，飞走海上，东西驰逐。见诸男子女人，百千万数，出没海中，被诸恶兽争取食啖。又见夜叉，其形各异，或多手多眼、多足多头、囗牙外出，利刃如剑。驱诸罪人，使近恶兽，复自搏攫，头足相就。其形万类，不敢久视。

    时婆罗门女，以念佛力故，自然无惧。有一鬼王，名曰无毒，稽首来迎，白圣女曰：「善哉，菩萨，何缘来此？」

    时婆罗门女问鬼王曰：「此是何处？」

    无毒答曰：「此是大铁围山西面第一重海。」

    胜女问曰：「我闻铁围之内，地狱在中，是事实否？」

    无毒答曰：「实有地狱。」

    圣女问曰：「我今云何到达狱所？」

    无毒答曰：「若非威神，即须业力，非此二事，终不能到。」

    圣女又问：「此水何缘，而乃涌沸，多诸罪人，及以恶兽？」

    无毒答曰：「此是阎浮提造恶众生，新死之者，经四十九日後，无人继嗣，为作功德，救拔苦难，生时又无善因。当据本业所感地狱，自然先渡此海。海东十万由旬，又有一海，其苦倍此。彼海之东，又有一海，其苦复倍。三业恶因之所招感，共号业海，其处是也。」

圣女又问鬼王无毒曰:「地狱何在？」

    无毒答曰：「三海之内，是大地狱，其数百千，各各差别。所谓大者，具有十八。次有五百，苦毒无量。次有千百，亦无量苦。」

    圣女又问大鬼王曰：「我母死来未久，不知魂神当至何趣？」

    鬼王问圣女曰：「菩萨之母，在生习何行业？」

    圣女答曰：「我母邪见，讥毁三宝。设或暂信，旋又不敬。死虽日浅，未知生处。」

    无毒问曰：「菩萨之母，姓氏何等？」

    圣女答曰：「我父我母，俱婆罗门种，父号尸罗善现，母号悦帝利。」

    无毒合掌启菩萨曰：「愿圣者却返本处，无至忧忆悲恋。悦帝利罪女，生天以来，经今三日。云承孝顺之子，为母设供修福，布施觉华定自在王如来塔寺。非唯菩萨之母，得脱地狱，应是无间罪人，此日悉得受乐，俱同生讫。」

    鬼王言毕，合掌而退。婆罗门女，寻如梦归。悟此事已，便於觉华定自在王如来塔像之前，立弘誓愿，愿我尽未来劫，应有罪苦众生，广设方便，使令解脱。」

    佛告文殊师利：「时鬼王无毒者，当今财首菩萨是。婆罗门女者，即地藏菩萨是。」

    地藏菩萨本愿经卷上

    分身集会品第二

尔时百千万亿不可思、不可议、不可量、不可说无量阿僧只世界，所有地狱处，分身地藏菩萨，俱来集在忉利天宫。以如来神力故，各以方面，与诸得解脱从业道出者，亦各有千万亿那由他数，共持香华，来供养佛。

彼诸同来等辈，皆因地藏菩萨教化，永不退转於阿耨多罗三藐三菩提。是诸众等，久远劫来，流浪生死，六道受苦，暂无休息。以地藏菩萨广大慈悲，深誓愿故，各获果证。既至忉利，心怀踊跃，瞻仰如来，目不暂舍。

尔时，世尊舒金色臂，摩百千万亿不可思、不可议、不可量、不可说、无量阿僧只世界诸分身世界地藏菩萨摩诃萨顶，而作是言：『吾於五浊恶世，教化如是刚强众生，令心调伏，舍邪归正，十有一二，尚恶习在。吾亦分身百千万亿，广设方便。或有利根，闻即信受；或有善果，勤劝成就；或有暗钝，久化方归；或有业重，不生敬仰。如是等辈众生，各各差别，分别度脱。

或现男子身、或现女人身、或现天龙身、或现神鬼身、或现山林川原、河池泉井，利及於人，悉皆度脱。或现天帝身、或现梵王身、或现转轮王身、或现居士身、或现国王身、或现宰辅身、或现官属身、或现比丘、比丘尼、优婆塞、优婆夷身、乃至声闻、罗汉、辟支佛、菩萨等身、而以化度。非但佛身，独现其前。

汝观吾累劫勤苦，度脱如是等难化刚强罪苦众生。其有未调伏者，随业报应。若堕恶趣，受大苦时，汝当忆念吾在忉利天宫，殷勤付嘱。令娑婆世界，至弥勒出世已来众生，悉使解脱，永离诸苦，遇佛授记。』

尔时，诸世界分身地藏菩萨，共复一形，涕泪哀恋，白其佛言：『我从久远劫来，蒙佛接引，使获不可思议神力，具大智慧。我所分身，遍满百千万亿恒河沙世界，每一世界化百千万亿身，每一身度百千万亿人，令归敬三宝，永离生死，至涅盘乐。但於佛法中所为善事，一毛一　，一沙一尘，或毫发许，我渐度脱，使获大利。唯愿世尊，不以後世恶业众生为虑。』

如是三白佛言：『唯愿世尊，不以後世恶业众生为虑。』

尔时，佛赞地藏菩萨言：『善哉！善哉！吾助汝喜。汝能成就久远劫来，发弘誓愿，广度将毕，即证菩提。』

    地藏菩萨本愿经卷上

观众生业缘品第三

尔时佛母摩耶夫人，恭敬合掌问地藏菩萨言：『圣者，阎浮众生，造业差别，所受报应，其事云何？』

地藏答言：『千万世界，乃及国土，或有地狱、或无地狱；或有女人、或无女人；或有佛法、或无佛法，乃至声闻辟支佛，亦复如是，非但地狱罪报一等。』

摩耶夫人重白菩萨：『且愿闻於阎浮罪报所感恶趣。』

地藏答言：『圣母，唯愿听受，我粗说之。』

佛母白言：『愿圣者说。』

尔时地藏菩白圣母言：『南阎浮提，罪报名号如是。若有众生不孝父母，或至杀害，当堕无间地狱。若有众生出佛生血，毁谤三宝，不敬尊经，亦当堕於无间地狱，千万亿劫，求出无期。若有众生侵损常住，玷污僧尼，或伽蓝内恣行淫欲，或杀或害，如是等辈，当堕无间地狱，千万亿劫，求出无期。若有众生，伪作沙门，心非沙门，破用常住，欺诳白衣，违背戒律，种种造恶，如是等辈，当堕无间地狱，千万亿劫，求出无期。若有众生，偷窃常住财物谷米，饮食衣服，乃至一物不与取者，当堕无间地狱，千万亿劫，求出无期。』

地藏菩白言：『圣母，若有众生，作如是罪，当堕五无间地狱，求暂停苦一念不得。』

摩耶夫人重白地藏菩萨言：『云何名为无间地狱？』

地藏菩白言：『圣母，诸有地狱在大铁围山之内，其大地狱有一十八所，次有五百，名号各别，次有千百，名字亦别。无间狱者，其狱城周匝八万馀里，其城纯铁，高一万里，城上火聚，少有空缺。其狱城中，诸狱相连，名号各别，独有一狱，名曰无间，其狱周匝万八千里，狱墙高一千里，悉是铁围，上火彻下，下火彻上。铁蛇铁狗，吐火驰逐狱墙之上，东西而走。

狱中有床，遍满万里。一人受罪，自见其身遍卧满床。千万人受罪，亦各自见身满床上。众业所感获报如是。

又诸罪人，备受众苦。百千夜叉及以恶鬼，囗牙如剑，眼如电光，手复铜爪，拖拽罪人。复有夜叉执大铁戟，中罪人身，或中囗鼻，或中腹背。复有铁蛇绞罪人颈。百肢节内，悉下长钉，拔舌耕犁，抽肠　斩，烊铜灌囗，热铁缠身。万死千生，业感如是。动经千劫，求出无期。

此界坏时，转寄他方；他方坏时，辗转相寄。此界成後，还复而来。无间罪报，其事如是。

又五事业感，故称无间。何等为五？

一者、日夜受罪，以至劫数，无时间绝，故称无间。

二者、一人亦满，多人亦满，故称无间。

三者、罪器叉棒，鹰蛇狼犬，碓磨锯凿，　砟镬汤，铁网铁绳，铁驴铁 马，生革络首，热铁浇身，饥吞铁丸，渴饮铁汁，从年竟劫，数 那由他，苦楚相连，更无间断，故称无间。

四者、不问男子女人，羌胡夷狄，老幼贵贱，或龙或神，或天或鬼，罪 行业感，悉同受之，故称无间。

五者、若堕此狱，从初入时，至百千劫，一日一夜，万死万生，求一念 间暂住不得，除非业尽，方得受生，以此连绵，故称无间。』

地藏菩萨白圣母言：『无间地狱，粗说如是。若广说地狱罪器等名，及诸苦事，一劫之中，求说不尽。』

摩耶夫人闻已，愁忧合掌，顶礼而退。

    地藏菩萨本愿经卷上

阎浮众生业感品第四

尔时地藏菩萨摩诃萨白佛言：『世尊，我承佛如来威神利故，遍百千万亿世界，分是身形，救拔一切业报众生。若非如来大慈力故，即不能作如是变化。我今又蒙佛付嘱，至阿逸多成佛以来，六道众生，遣令度脱。唯然世尊，愿不有虑。』

    尔时佛告地藏菩萨：『一切众生未解脱者，性识无定，恶习结业，善习结果。为善为恶，逐境而生。转轮五道，暂无休息，动经尘劫，迷祸障难。如鱼游网。将是长流，脱入暂出，又复遭网。以是等辈，吾当忧念。汝既毕是往愿，累劫重誓，广度罪辈，吾复何虑。』

说是语时，会中有一菩萨摩诃萨，名定自在王，白佛言：『世尊，地藏菩萨累劫以来，各发何愿，今蒙世尊殷勤赞叹。唯愿世尊，略而说之。』

尔时世尊告定自在王菩萨：『谛听谛听，善思念之，吾当为汝分别解说。乃往过去无量阿僧只那由他不可说劫，尔时有佛，号一切智成就如来，应供、正遍知、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊，其佛寿命六万劫。未出家时为小国王，与一邻国王为友，同行十善，饶益众生。其邻国内所有人民，多造众恶。二王计议，广设方便。一王发愿，早成佛道，当度是辈，令使无馀。一王发愿，若不先度罪苦，令是安乐，得至菩提，我终未愿成佛。』

佛告定自在王菩萨：『一王发愿早成佛者，即一切智成就如来。一王发愿永度罪苦众生，未愿成佛者，即地藏菩萨是。』

『复於过去无量阿僧只劫，有佛出世，名清净莲华目如来，其佛寿命四十劫。像法之中，有一罗汉，福度众生。因次教化，遇一女人，字曰光目，设食供养。』

『罗汉问之：「欲愿何等？」』

『光目答曰：「我以母亡之日，资福救拔，未知我母生处何趣？」』

『罗汉愍之，为入定观，见光目女母堕在恶趣，受极大苦。罗汉问光目言：「汝母在生做何行业？今在恶趣受极大苦。」』

『光目答言：「我母所习，唯好食啖鱼鳖之属。所食鱼鳖，多食其子，或炒或煮，恣情食啖，计其命数，千万复倍。尊者慈愍，如何哀救？」』

『罗汉愍之，为作方便，劝光目言：「汝可志诚念清净莲华目如来，兼塑画行像，存亡或报。」』

『光目闻已，即舍所爱，寻画佛像而供养之，复恭敬心，悲泣瞻礼。忽於夜後，梦见佛身金色晃耀，如须弥山，放大光明。而告光目：「汝母不久当生汝家，才觉饥寒，即当言说。」』

『其後家内婢生一子，未满三日，而乃言说。稽首悲泣，告於光目：「生死业缘，果报自受，我是汝母，久处暗冥。自别汝来，累堕大地狱。蒙汝福力，方得受生。为下贱人，又复短命。寿年十三，更落恶道。汝有何计，另吾脱免？」』

『光目闻说，知母无疑，哽咽悲啼而白婢子：「既是吾母，合知本罪，作何行业，堕於恶道。」』

『婢子答言：「以杀害毁骂二业受报。若非蒙福，救拔吾难，以是业故，未合解脱。」』

『光目问言：「地狱罪报，其事云何？」』

『婢子答言：「罪苦之事，不忍称说，百千岁中，卒白难竟。」』

『光目闻已，啼泪号泣而白空界：「愿我之母，永脱地狱，毕十三岁，更无重罪，及历恶道。十方诸佛慈哀愍我，听我为母所发广大誓愿。若得我母永离三途及斯下贱，乃至女人之身永劫不受者。愿我自今日後，对清净莲华目如来像前，却後百千万亿劫中，应有世界，所有地狱及三恶道诸罪苦众生，誓愿救拔，令离地狱恶趣，畜生饿鬼等，如是罪报等人，尽成佛竟，我然後方成正等正觉。」』

『发誓愿已，俱问清净莲华目如来而告之曰：「光目，汝大慈愍，善能为母发如是大愿。吾观汝母十三岁毕，舍此报已，生为梵志，寿年百岁。过是报後，当生无忧国土，寿命不可计劫。後成佛果，广度人天，数如恒河沙。」』

佛告定自在王：『尔时罗汉福度光目者，即无尽意菩萨是。光目女者，即地藏菩萨是。过去久远劫中，如是慈愍，发恒河沙愿，广度众生。未来世中，若有男子女人，不行善者行恶者，乃至不信因果者，邪淫妄语者，两舌恶囗者，毁谤大乘者，如是诸业众生，必堕恶趣。若遇善知识，劝令一弹指间，皈依地藏菩萨，是诸众生，即得解脱三恶道报。若能志心归敬及瞻礼赞叹，香华衣服，种种珍宝，或复饮食，如是奉事者。未来百千万亿劫中，常在诸天受胜妙乐。若福尽，下生人间，犹百千劫常为帝王，能忆宿命因果本末。』

『定自在王。如是地藏菩萨有如是不可思议大威神力，广利众生。汝等诸菩萨当记是经，广宣流布。』

定自在王白佛言：『世尊，愿不有虑。我等百千万亿菩萨摩诃萨，必能承佛威神广演是经，於阎浮提利益众生。』定自在王白世尊已，合掌恭敬作礼而退。

尔时四方天王俱从座起，合掌恭敬白佛言：『世尊，地藏菩萨於久远劫来，发如是大愿，云何至今犹未度绝，更发广大誓言。唯愿世尊为我等说。』

佛告四天王：『善哉善哉。吾今为汝及未来现在天人众等，广利益故，说地藏菩萨於娑婆世界阎浮提内生死道中，慈哀救拔度脱一切罪苦众生方便之事。』

四天王言：『唯然世尊，愿乐欲闻。』

佛告四天王：『地藏菩萨久远劫来，迄至於今，度脱众生，犹未毕愿，慈愍此世罪苦众生。复观未来无量劫中，因蔓不断，以是之故，又发重愿。如是菩萨於娑婆世界，阎浮提中，百千万亿方便，而为教化。四天王，地藏菩萨 --

若遇杀生者， 说宿殃短命报。 若遇窃盗者， 说贫穷苦楚报。 若遇邪淫者， 说雀鸽鸳鸯报。 若遇恶囗者， 说眷属斗诤报。 若遇毁谤者， 说无舌疮囗报。 若遇瞠恚者， 说丑陋聋残报。 若遇悭吝者， 说所求违愿报。 若遇饮食无度者， 说饥渴咽病报。 若遇畋猎恣情者， 说惊狂丧命报。 若遇悖逆父母者， 说天地灾杀报。 若遇烧山林木者， 说狂迷取死报。 若遇前後父母恶毒者， 说返生鞭挞现受报。 若遇网补生雏者， 说骨肉分离报。 若遇毁谤三宝者， 说盲聋　哑报。 若遇轻法慢教者， 说永处恶道报。 若遇破用常住者， 说亿劫轮回地狱报。 若遇污梵诬僧者， 说永在畜牲道。 若遇汤火斩斫伤者， 说轮回递偿报。 若遇破戒犯斋者， 说禽兽饥恶报。 若遇非理毁用者， 说所求阙绝报。 若遇吾我贡高者， 说卑使下贱报。 若遇两舌斗乱者， 说无舌百舌报。 若遇邪见者， 说边地受生报。 』

『如是等阎浮提众生，身囗意业，恶息结果，百千报应，今粗略说。如是等阎浮提众生业感差别，地藏菩萨百千方便而教化之。是诸众生，先受如是等报，後堕地狱，动经劫数，无有出期。是故汝等护人护国，无令是诸众业迷惑众生。』

四天王闻已，涕泪悲叹合掌而退。

    地藏菩萨本愿经卷上

赞

如来慈愍 转大法轮 婆罗门女救慈亲 觉华度迷津 摩耶夫人 请问地藏因

南无常住十方佛 南无常住十方佛 南无常住十方佛

    地藏菩萨本愿经卷中

地狱名号品第五

尔时普贤菩萨摩诃萨白地藏菩萨言：『仁者，愿为天龙四众，及未来现在一切众生，说娑婆世界，及阎浮提罪苦众生，所受报处，地狱名号，及恶报等事，使未来世末法众生，知是果报。』

地藏答言：『仁者，我今承佛威神，及大士力，略说地狱名号，及罪报恶报之事。

仁者，阎浮提东方有山，号曰铁围，其山黑邃，无日月光。

有大地狱，号极无间， 又有地狱，名大阿鼻， 复有地狱，名曰四角， 复有地狱，名曰飞刀， 复有地狱，名曰火箭， 复有地狱，名曰夹山， 复有地狱，名曰通枪， 复有地狱，名曰铁车， 复有地狱，名曰铁床， 复有地狱，名曰铁牛， 复有地狱，名曰铁衣， 复有地狱，名曰千刃， 复有地狱，名曰铁驴， 复有地狱，名曰烊铜， 复有地狱，名曰抱柱， 复有地狱，名曰流火， 复有地狱，名曰耕舌， 复有地狱，名曰　首， 复有地狱，名曰烧脚， 复有地狱，名曰啖眼， 复有地狱，名曰铁丸， 复有地狱，名曰诤论， 复有地狱，名曰铁　， 复有地狱，名曰多瞠。』

地藏白言：『仁者，铁围之内，有如是等地狱，其数无限。更有

叫唤地狱， 拔舌地狱， 粪尿地狱， 铜锁地狱， 火象地狱， 火狗地狱， 火马地狱， 火牛地狱， 火山地狱， 火石地狱， 火床地狱， 火梁地狱， 火鹰地狱， 锯牙地狱， 剥皮地狱， 饮血地狱， 烧手地狱， 烧脚地狱， 倒刺地狱， 火屋地狱， 铁屋地狱， 火狼地狱， 如是等地狱。

其中各各复有诸小地狱，或一、或二、或三、或四、乃至百千，其中名号，各各不同。』

地藏菩萨告普贤菩萨言：『仁者，此者皆是南阎浮提行恶众生，业感如是。业力甚大，能敌须弥，能深巨海，能障圣道。是故众生莫轻小恶，以为无罪，死後有报，纤毫受之。父子至亲，歧路各别，纵然相逢，无肯代受。我今承佛威力，略说地狱罪报之事，唯愿仁者暂听是言。』

普贤菩萨言：『吾已久知三恶道报，望仁者说，令後世末法一切恶行众生，闻仁者说，使令归佛。』

地藏白言：『仁者，地狱罪报，其事如是。

或有地狱，取罪人心，夜叉食之。 或有地狱，镬汤盛沸，煮罪人身。 或有地狱，赤烧铜柱，使罪人抱。 或有地狱，使诸火烧，趁及罪人。 或有地狱，一向寒冰。 或有地狱，无限粪尿。 或有地狱，纯飞戢　。 或有地狱，多钻火枪。 或有地狱，唯撞胸背。 或有地狱，但烧手足。 或有地狱，盘绞铁蛇。 或有地狱，驱逐铁狗。 或有地狱，尽驾铁骡。

仁者，如是等报，各各狱中，有百千种业道之器，无非是铜是铁，是石是火，此四种物，众业行感。若广说地狱罪报等事，一一狱中更有百千种苦楚，何况多狱。我今承佛威神及仁者问，略说如是。若广解说，穷劫不尽。』

    地藏菩萨本愿经卷中

如来赞叹品第六

尔时世尊举身放大光明，遍照百千万亿恒河沙等诸佛世界。出大音声，普告诸佛世界一切诸菩萨摩诃萨，及天、龙、鬼、神、人、非人等：『听吾今日称扬赞叹地藏菩萨摩诃萨，於十方世界，现大不可思议威神慈悲之力，救护一切罪苦之事。吾灭度後，汝等诸菩萨大士，及天龙鬼神等，广作方便，卫护是经，令一切众生证涅盘乐。』

    说是语已，会中有一菩萨，名曰普广，合掌恭敬而白佛言：『今见世尊赞叹地藏菩萨，有如是不可思议大威神德，唯愿世尊为未来世末法众生，宣说地藏菩萨利益人天因果等事，使诸天龙八部，及未来世众生，顶受佛语。』

    尔时世尊告普广菩萨及四众等：『谛听谛听，吾当为汝略说地藏利益人天福德之事。』

    普广白言：『唯然世尊，愿乐欲闻。』

    佛告普广菩萨：『未来世中，若有善男子、善女人，闻是地藏菩萨摩诃萨名者，或合掌者、赞叹者、作礼者、恋慕者，是人超越三十劫罪。

    普广，若有善男子、善女人，或彩画行像，或土石胶漆，金银铜铁、作此菩萨，一瞻一礼者，是人百返生於三十三天，永不堕於恶道。假如天福尽故，下生人间，犹为国王，不失大利。

    若有女人，厌离女身，尽心供养地藏菩萨画像，及土石胶漆铜铁等像，如是日日不退，常一华香、饮食、衣服、缯彩、幢　、钱、宝物等供养。是善女人，尽此一报女身，百千万劫，更不生有女人世界，何况复受。除非慈愿力故，要受女身，度脱众生，承斯供养地藏力故，及功德力，百千万劫不受女身。』

    复次普广：『若有女人，厌是丑陋，多疾病者，但於地藏像前，志心瞻礼，食顷之间。是人千万劫中所受生身，相貌圆满。是丑陋女人，如不厌女身，即百千万亿生中，常为女王，乃及王妃，宰辅大姓，大长者女，端正受生，诸相圆满。由志心故，瞻礼地藏菩萨，获福如是。』

    复次普广：『若有善男子、善女人，能对菩萨像前，作诸伎乐，乃至劝於一人多人。如是等辈，现在世中及未来世，常得百千鬼神日夜卫护，不令恶事辄闻其耳，何况亲受诸横。』

    复次普广：『未来世中，若有恶人及恶神恶鬼，见有善男子、善女人，归敬供养赞叹瞻礼地藏菩萨形像，或妄生讥毁，谤无功德及利益事，或露齿笑，或背面非，或劝人共非，或一人非，或多人非，乃至一念生讥毁者。如是之人，贤劫千佛灭度，讥毁之报，尚在阿鼻地狱受极重罪。过是劫已，方受饿鬼。又经千劫，复受畜牲。又经千劫，方得人身。纵受人身，贫穷下贱，诸根不具，多被恶业来结其心。不久之间，复堕恶道。是故普广，讥毁他人供养，尚获此报，何况别生恶见毁灭。』

    复次普广：『若未来世，有男子女人，久处床枕，求生求死，了不可得。或夜梦恶鬼，乃至家亲、或游险道、或多魇魅、共鬼神游。日月岁深，转复　瘵，眠中叫苦，凄惨不乐者。此皆是业道论对，未定轻重，或难舍寿，或不得愈，男女俗眼，不辨是事。

    但当对诸佛菩萨像前，高声转读此经一遍。或取病人可爱之物，或衣服宝贝，庄园舍宅，对病人前，高声唱言，我某甲等，为是病人对经像前舍诸等物，或供养经像，或造塔寺，或燃油灯，或施常住。如是三白病人，遣令闻知。

    假令诸识分散，至气尽者，乃至一日、二日、三日、四日至七日已来。但高声白，高声读经。是人命终之後。宿殃重罪，至于五无间罪，永得解脱，所受生处，常知宿命。何况善男子善女人自书此经或教人书、或自塑画菩萨形像。所受果报，必获大利，是故普广，若见有人读诵是经，乃至一念赞叹是经，或恭敬者。汝须百千方便，劝是等人，勤心莫退，能得未来、现在千万亿不思议功德。』

复次普广：『若未来世诸众生等，或梦或寐，见诸鬼神乃及诸形，或悲、或啼、或愁、或叹、或恐、或怖。此皆是一生十生百生千生过去父母、男女弟妹、夫妻眷属，在於恶趣，未得出离，无处希望福力救拔，当告宿世骨肉，使作方便，愿离恶道。

    普广，汝以神力，遣是眷属，令对诸佛菩萨像前，志心自读此经，或请人读，其数三遍或七遍。如是恶道眷属，经声毕是遍数，当得解脱，乃至梦寐之中，永不复见。』

    复次普广：『若未来世，有诸下贱等人，或奴或婢，乃至诸不自由之人，觉知宿业，要忏悔者。志心瞻礼地藏菩萨形像，乃至一七日中，念菩萨名，可满万遍。如是等人，尽此报後，千万生中，常生尊贵，更不经三恶道苦。』

    复次普广：『若未来世中，阎浮提内，刹利、婆罗门、长者、居士、一切人等，及异姓种族，有新产者，或男或女，七日之中，早与读诵此不可思议经典，更为念菩萨名，可满万遍。是新生子，或男或女，宿有殃报，便得解脱，安乐易养，寿命增长。若是承福生者，转增安乐，及与寿命。』

    复次普广：『若未来世众生，於月一日、八日、十四日、十五日、十八日、二十三、二十四、二十八、二十九、乃至三十日，是诸日等，诸罪结集，定其轻重。南阎浮提众生，举止动念，无不是业，无不是罪，何况恣情杀害、窃盗、邪淫、妄语、百千罪状。能於是十斋日，对佛菩萨诸圣贤圣像前，读是经一遍，东西南北百由旬内，无诸灾难。

    当此居家，若长若幼，现在未来百千岁中，永离恶趣，能於十斋日每转一遍，现世令此居家无诸横病，衣食丰溢。是故普广，当知地藏菩萨有如是等不可说百千万亿大威神力，利益之事。

    阎浮提众生，於此大士有大因缘。是诸众生，闻菩萨名，见菩萨像，乃至闻是经三字五字，或一偈一句者，现在殊妙安乐，未来之世，百千万生，常得端正，生尊贵家。』

    尔时普广菩萨闻佛如来称扬赞叹地藏菩萨已，胡跪合掌复白佛言：『世尊，我久知是大士有如此不可思议神力，及大誓愿力，为未来众生遣知利益，故问如来，唯然顶受。』

    『世尊，当何名此经，使我云何流布？』

    佛告普广：『此经有三名： 一名 地藏本愿， 亦名 地藏本行， 亦名 地藏本誓力经。

    缘此菩萨，久远劫来，发大重愿，利益众生，是故汝等，依愿流布。』

    普广闻已，合掌恭敬作礼而退。

    地藏菩萨本愿经卷中

利益存亡品第七

尔时地藏菩萨摩诃萨白佛言：『世尊，我观是阎浮提众生，举心动念，无非是罪。脱获善利，多退出心。若遇恶缘，念念增益。是等辈人，如履泥涂，负於重石，渐困渐重，足步深邃。若得遇善知识，替与减负，或全与负。是知识有大力故，复相扶持，劝令牢脚。若达平地，须省恶路，无再经历。』

『世尊，习恶众生，从纤毫间，便至无量。是诸众生有如此习，临命终时，父母眷属，宜为设福，以资前路。或悬翻盖及燃油灯。或转读尊经、或供样佛像及诸圣像，乃至念佛菩萨，及辟支佛名字，一名一号，历临终人耳根，或闻在本识。是诸众生所造恶业，计其感果，必堕恶趣，缘是眷属为临终人修此圣因，如是众罪，悉皆消灭。』

『若能更为身死之後，七七日内，广造众善。能使是诸众生永离恶趣，得生人天，受胜妙乐，现在眷属，利益无量。』

『是故我今对佛世尊，及天龙八部人非人等，劝於阎浮提众生临终之日，慎勿杀害，及造恶缘，拜祭鬼神，求诸魍魉。』

『何以故？尔所杀害乃至祭拜，无纤毫之力，利益亡人，但结罪缘，转增深重。假使来世或现在生，得获圣分，生人天中。缘是临终被诸眷属造是恶因，亦令是命终人殃累对辩，晚生善处。何况临命终人，在生未曾有少善根，各据本业，自受恶趣，何忍眷属更为增业。』

『譬如有人从远处来，绝粮三日，所负担物，强过百今，忽遇邻人，更附少物，以是之故，转复困重。』

『世尊，我观阎浮提众生，但能於诸佛教中，乃至善事，一毛一　，一沙一尘，如是利益，悉皆自得。』

说是语时，会中有一长者，名曰大辩，是长者久证无生，化度十方，现长者身，合掌恭敬，问地藏菩萨言：『大士，是南阎浮提众生，命终之後，小大眷属，为修功德，乃至设斋，造众善因，是命终人，得大利益及解脱不？』

地藏答言：『长者，我今为未来现在一切众生，承佛威力，略说是事。长者，未来现在诸众生等，临命终日，的闻一佛名、一菩萨名、一辟支佛名，不问有罪无罪，悉得解脱。若有男子女人，在生不修善因多造众罪。命终之後，眷属大小，为造福利一切圣事，七分之中而乃获一分，六分功德，生者自利。以是之故，未来现在善男女等，闻健自修，分分己获。无常大鬼，不期而到，冥冥游神，未知罪福。七七日内，如痴如聋，或在诸司辩论业果。审定之後，据报受生。未测之间，千万愁苦，何况堕於诸恶趣等。』

『是命终人，未得受生，在七七日内，念念之间，望诸骨肉眷属，与造福力救拔。过是日後，随业受报。若市罪人，动经千百岁中，无解脱日。若是五无间罪，堕大地狱，千劫万劫，永受众苦。』

复次长者：『如是罪业众生，命终之後，眷属骨肉，为修营斋，资助道业未斋食竟，及营齐之次，米泔菜叶，不弃於地，乃至诸食为献佛僧，勿得先食。如有违食，及不精勤，是命终人，了不得力。如精勤护净奉献佛僧，是命终人，七分获一。是故长者，阎浮众生，若能为其父母乃至眷属，命终之後，设斋供养，志心勤恳。如是之人，存亡获利。』

说是语时，忉利天宫，有千万亿那由他阎浮鬼神，悉发无量菩提之心，大辩长者作礼而退。

    地藏菩萨本愿经卷中

阎罗王众赞叹品第八

尔时铁围山内，有无量鬼王，与阎罗天子，俱诣忉利，来到佛前。所谓

恶毒鬼王、 多恶鬼王、 大诤鬼王、 白虎鬼王、 白虎鬼王、 血虎鬼王、 赤虎鬼王、 散殃鬼王、 飞身鬼王、 电光鬼王、 狼牙鬼王、 千眼鬼王、 啖兽鬼王、 负石鬼王、 主耗鬼王、 主祸鬼王、 主食鬼王、 主财鬼王、 主畜鬼王、 主禽鬼王、 主兽鬼王、 主魅鬼王、 主产鬼王、 主命鬼王、 主疾鬼王、 主险鬼王、 三目鬼王、 四目鬼王、 五目鬼王、 祁利失王、 大祁利失王、 祁利叉王、 大祁利叉王、 阿那吒王、 大阿那吒王、

如是等大鬼王，各各与百千诸小鬼王，尽居阎浮提，个有所执，各有所主。是诸鬼王与阎罗天子，承佛威神，及地藏菩萨摩诃萨力，俱诣忉利，在一面立。

尔时阎罗天子胡跪合掌白佛言：『世尊，我等今者与诸鬼王，承佛威神，及地藏菩萨摩诃萨力，方得诣此忉利大会，亦是我等获善利故。我今有小疑事，敢问世尊。唯愿世尊慈悲宣说。』

佛告阎罗天子：『恣汝所问，吾为汝说。』

是时阎罗天子瞻礼世尊，及回视地藏菩萨，而白佛言：『世尊，我观地藏菩萨在六道中，百千方便而度罪苦众生，不辞疲倦，是大菩萨有如是不可思议神通之事。然诸众生获脱罪报，未久之间，又堕恶道。世尊，是地藏菩萨既有如是不可思议神力世尊，云何众生而不依止善道世尊，永取解脱世尊？唯愿世尊为我解说。』

佛告阎罗天子：『南阎浮提众生，其性刚强，难调难服。是大菩萨，於百千劫，头头救拔如是众生，早另解脱。是罪报人乃至堕大恶趣，菩萨以方便力，拔出根本业缘，而遣悟宿世之事。自是阎浮提众生结恶习重，旋出旋入，劳斯菩萨久经劫数而作度脱。』

『譬如有人迷失本家，误入险道，其险道中，多诸夜叉、及虎狼狮子、
  蛇蝮蝎。如是迷人，在险道中，须臾之间，即遭诸毒。有一知识，多解大术，善禁是毒，乃及夜叉诸恶毒等。忽逢迷人欲进险道，而语之言：「咄哉男子，为何事故而入此路，有何异术，能制诸毒。」是迷路人忽闻是语，方知险道，即便退步，求出此路。是善知识，提携接手，引出险道，免诸恶毒。』

『至於好道，令得安乐。而语之言：「咄哉迷人，自今以後，勿履是道。此路入者，卒难得出，复损性命。」是迷路人亦生感重。临别之时，知识又言：「若见亲知及诸路人，若男若女，言於此路多诸毒恶，丧失性命。无令是众自取其死。」』

『是故地藏菩萨俱大慈悲，救拔罪苦众生，生人天中，令受妙乐。是诸罪众，知业道苦，脱出得离，永不再历。如迷路人，误入险道，遇善知识引接令出，永不复入。逢见他人，复劝莫入。自言因是迷故，得解脱竟，更不复入。若再履践，犹尚迷误，不觉旧曾所落险道，或致失命。如堕恶趣，地藏菩萨方便力故，使另解脱，生人天中。旋又再入，若业结重，永处地狱，无解脱时。』

尔时恶毒鬼王合掌恭敬白佛言：『世尊，我等诸鬼王，其数无量，在阎浮提，或利益人，或损害人，各各不同。然是业报，使我眷属游行世界，多恶少善。过人家庭，或城邑聚落，庄园房舍。或有男子女人，修毛发善事，乃至悬一　一盖，少香少华，供养佛像及菩萨像。或转读尊经，烧香供养一句一偈。我等鬼王敬礼是人，如过去现在未来诸佛。敕诸小鬼，各有大力，及土地分，便令卫护，不令恶事横事、恶病横病，乃至不如意事，近於此舍等处，何况入门。』

佛赞叹鬼王：『善哉善哉。汝等及与阎罗，能如是拥护善男女等，吾亦告梵王帝释，令卫护汝。』

说是语时，会中有一鬼王，名曰主命，白佛言：『世尊，我本业缘，主阎浮人命，生时死时，我皆主之。在我本愿，甚欲利益。自是众生不会我意，致令生死俱不得安。何以故。是阎浮提人初生之时，不问男女，或欲生时，但作善事，增益宅舍，自令土地无量欢喜，拥护子母，得大安乐，利益眷属。或已生下，慎勿杀害，取诸鲜味供给产母，及广聚眷属，饮酒食肉，歌乐弦管，能令子母不得安乐。』

『何以故。是产难时，有无数恶鬼及魍魉精魅，欲食腥血。是我早令舍宅土地灵只。荷护子母，使令安乐，而得利益。如是之人，见安乐故，便合设福，答诸土地。翻为杀害，聚集眷属。以是之故，犯殃自受，子母俱损。』

『又阎浮提临命终人，不问善恶，我欲令是命终之人，不落恶道。何况自修善根增我力故。是阎浮提行善之人，临命终时，亦有百千恶道鬼神，或变作父母，乃至诸眷属，引接亡人，令落恶道。何况本造恶者。』

『世尊，如是阎浮提男子女人临命终时，神识　昧，不辨善恶，乃至眼耳更无见闻。是诸眷属，当须设大供养，转读尊经，念佛菩萨名号。如是善缘，能令亡者离诸恶道，诸魔鬼神悉皆退散。』

『世尊，一切众生临命终时，若得闻一佛名，一菩萨名，或大乘经典，一句一偈。我观如是辈人，除五无间杀害之罪，小小恶业，合堕恶趣者，寻即解脱。』

佛告主命鬼王：『汝大慈故，能发如是大愿，於生死中，护诸众生。若未来世中，有男子女人至生死时，汝莫退是愿，总令解脱，永得安乐。』

鬼王白佛言：『愿不有虑。我毕是形，念念拥护阎浮众生，生时死时，俱得安乐。但愿诸众生於生死时，信受我语，无不解脱，获大利益。』

尔时佛告地藏菩萨：『是大鬼王主命者，已曾经百千生，作大鬼王，於生死中，拥护众生。是大士慈悲愿故，现大鬼身，实非鬼也。却後过一百七十劫，当得成佛，号曰「无相如来」，劫名「安乐」，世界名「净住」，其佛寿命不可计劫。地藏，是大鬼王，其事如是不可思议，所度人天亦不可限量。』

    地藏菩萨本愿经卷中

称佛名号品第九

尔时地藏菩萨摩诃萨白佛言：『世尊，我今为未来众生演利益事，於生死中，得大利益，唯愿世尊听我说之。』

佛告地藏菩萨：『汝今欲兴慈悲，救拔一切罪苦六道众生，演不思议事，今正是时，唯当速说。吾即涅盘，使汝早毕是愿，吾亦无忧现在未来一切众生。』

地藏菩萨白佛言：『世尊，过去无量阿僧只劫，有佛出世，号无边身如来。若有男子女人闻是佛名，暂生恭敬，即得超越四十劫生死重罪。何况塑画形像，恭敬赞叹，其人或福无量无边。』

『又於过去恒河沙劫，有佛出世，号宝性如来。若有男子女人闻是佛名，一弹指顷，发心皈依，是人於无上道永不退转。』

『又於过去有佛出世，号波头摩胜如来。若有男子女人闻是佛名，历於耳根，是人当得千返生於六欲天中，何况志心称念。』

『又於过去不可说不可说阿僧只劫，有佛出世，号师子吼如来。若有男子女人闻是佛名，一念皈依，是人得遇无量诸佛摩顶授记。』

『又於过去有佛出世，号拘留孙佛。若有男子女人闻是佛名，志心瞻礼或复赞叹，是人於贤劫千佛会中，为大梵王，得授上记。』

『又於过去有佛出世，号毗罗尸。若有男子女人闻是佛名，永不堕恶道，常生人天，受胜妙乐。』

『又於过去无量无数恒河沙劫，有佛出世，号宝胜如来。若有男子女人闻是佛名，毕竟不堕恶道，常在天上受胜妙乐。』

『又於过去有佛出世，号宝相如来。若有男子女人闻是佛名，生恭敬心，是人不久得阿罗汉果。』

『又於过去无量阿僧只劫，有佛出世，号袈裟幢如来。若有男子女人闻是佛名，超一百大劫生死之罪。』

『又於过去有佛出世，号大通山王如来。若有男子女人闻是佛名者，是人得遇恒河沙佛广为说法，必成菩提。』

『又於过去有净月佛、山王佛、智胜佛、净名王佛、智成就佛、无上佛、妙声佛、满月佛、月面佛有如是等不可说佛。世尊，现在未来一切众生，若天若人，若男若女，但念得一佛名号，功德无量，何况多名。』

『是众生等，生时死时，自的大利，终不堕恶道。若有临命终人，家中眷属，乃至一人，为是病人高声念一佛名，是命终人，除五无间罪，馀业报等悉得消灭。是五无间罪，虽至极重，动经亿劫，了不得出，承斯临命终时，他人为其称念佛名，於是罪中，亦渐消灭。何况众生自称自念，获福无量，灭无量罪。』

    地藏菩萨本愿经卷中

赞

普贤启问 地藏宏开 三途六道绝尘埃 普广问如来 授记十斋 接引上莲台

南无常住十方法 南无常住十方法 南无常住十方法

    地藏菩萨本愿经卷下

校量布施功德缘品第十

尔时地藏菩萨摩诃萨承佛威神，从座而起，胡跪合掌白佛言：『世尊，我观业道众生，校量布施，有轻有重，有一生受福，有十生受福，有百生千生受大福利者。是事云何，唯愿世尊为我说之。』

尔时佛告地藏菩萨：『吾今於忉利天宫一切会众，说阎浮提布施较量功德轻重，汝当谛听，吾为汝说。』

地藏白佛言：『我疑是事，愿乐欲闻。』

佛告地藏菩萨：『南阎浮提，有国王、宰辅大臣、大长者、大刹利、大婆罗门等，若遇最下贫穷，乃至癃残　哑，聋痴无目，如是种种不完具者。是大国王等欲布施时，若能具大慈悲下心含下，亲手遍布施，或使人施，软语慰谕，是国王等所获福利，如布施百恒河沙佛功德之力。何以故。缘是国王等，於最贫贱辈及不完具者，发大慈心，是故福利有如此报。百生千生中，常得七宝具足，何况衣食受用。』

复次地藏：『若未来世，有诸国王，至婆罗门等，遇佛塔寺，或佛形像，乃至菩萨声闻辟支佛像，躬自营办供养布施。是国王等，当得三劫为帝释身，受胜妙乐。若能以此布施福利，回向法界，是大国王等，於十劫中，常为大梵天王。』

复次地藏：『若未来世，有诸国王，至婆罗门等，遇先佛塔庙，或至经像，毁坏破落，乃能发心修补。是国王等，或自营办，或劝他人，乃至百千人等布施结缘。是国王等，百生千生中常为转轮王身。如是他人同布施者，百生千生中常为小国王身。更能於塔庙前，发回向心。如是国王乃及诸人，尽成佛道，以此果报无量无边。』

复次地藏：『未来世中，有诸国王及婆罗门等，见诸老病及生产妇女，若一念间，具大慈心，布施医药饮食卧具，使令安乐。如是福利最不思议，一百劫中常为净居天主，二百劫中常为六欲天主，毕竟成佛，永不堕恶道，乃至百千生中，耳不闻苦声。』

复次地藏：『未来世中，有诸国王及婆罗门等，能作如是布施，获福无量。更能回向，不问多少，毕竟成佛，何况帝释转轮之报。是故地藏，普劝众生当如是学。』

复次地藏：『未来世中，若善男子善女人，於佛法中，种少善根，毛发沙尘等许，所受福利，不可为喻。』

复次地藏：『未来世中，若有善男子善女人，遇佛形像、辟支佛形像、转论王形像，布施供养得无量福，常在人天受胜妙乐。若能回向法界，是人福利不可为喻。』

复次地藏：『未来世中，若有善男子善女人，遇大乘经典，或听闻一偈一句，发殷重心，赞叹恭敬，布施供养。是人或大果报，无量无边。若能回向法界，其福不可为喻。』

复次地藏：『若未来世中，有善男子善女人，遇佛塔寺，大乘经典。新者布施供养，瞻礼赞叹，恭敬合掌。若遇故者，或毁坏者，修补营理，或独发心，或劝多人同共发心。如是等辈，三十生中常为诸小国王，檀越之人，常为轮王，还以善法教化诸小国王。』

复次地藏：『未来世中，若有善男子善女人，於佛法中所种善根，或布施供养，或修补塔寺，或装理经典，乃至一毛一尘，一沙一　。如是善事，但能回向法界，是人功德，百千生中受上妙乐。但如回向自家眷属，或自身利益，如是之果，即三生受乐，舍一得万报。是故地藏，布施因缘，其事如是。』

    地藏菩萨本愿经卷下

地神护法品第十一

尔时坚牢地神白佛言：『世尊，我从昔来瞻视顶礼无量菩萨摩诃萨，皆是大不可思议神通智慧，广度众生。是地藏菩萨摩诃萨，於阎浮提有大因缘。如文殊、普贤、观音、弥勒，亦化身百千身形，度於六道，其愿尚有毕竟。是地藏菩萨教化六道一切众生，所发誓愿劫数，如千百亿恒河沙。』

『世尊，我观未来及现在众生，於所住处，於南方清洁之地，以土石竹木作其龛室，是中能塑画，乃至金银铜铁，作地藏形像，烧香供养，瞻礼赞叹，是人居处，即得十种利益。何等为十？』

『 一者、土地丰壤； 二者、家宅永安； 三者、先亡生天； 四者、现存益寿； 五者、所求遂意； 六者、无水火灾； 七者、虚耗辟除； 八者、杜绝恶梦； 九者、出入神护； 十者、多遇圣因。 』

『世尊，未来世中，及现在众生，若能於所住方面，作如是供养，得如是利益。』

复白佛言：『世尊，未来世中，若有善男子善女人，於所住处，有此经典及菩萨像，是人更能转读经典，供养菩萨。我常日夜以本神力，卫护是人，乃至水火盗贼，大横小横，一切恶事，悉皆消灭。』

佛告坚牢地神：『汝大神力，诸神少及。何以故。阎浮土地，悉蒙汝护，乃至草木沙石，稻麻竹苇，谷米宝贝，从地而有，皆因汝力。又常称扬地藏菩萨利益之事。汝之功德，及以神通，百倍於常分地神。若未来世中，有善男子善女人，供养菩萨，及转读是经，但依地藏本愿经一事修行者。汝以本神力而拥护之，勿令一切灾害及不如意事，辄闻於耳，何况令受。非但汝独护是人故，以有释梵眷属，诸天眷属，拥护是人。何故得如是圣贤拥护，皆由瞻礼地藏形像，及转读是本愿经故，自然毕竟出离苦海，证涅盘乐。以是之故，得大拥护。』

    地藏菩萨本愿经卷下

见闻利益品第十二

尔时世尊从顶门上放百千万亿大毫相光，所谓白毫相光、大白毫相光、瑞毫相光、大瑞毫相光、玉毫相光、大玉毫相光、紫毫相光、大紫毫相光、青毫相光、大青毫相光、碧毫相光、大碧毫相光、红毫相光、大红毫相光、绿毫相光、大绿毫相光、金毫相光、大金毫相光、庆云毫相光、大庆云毫相光、千轮毫光、大千轮毫光、宝轮毫光、大宝轮毫光、日轮毫光、大日轮毫光、月轮毫光、大月轮毫光、宫殿毫光、大宫殿毫光、海云毫光、大海云毫光。

於顶门上放如是等毫相光已，出微妙音，告诸大众，天龙八部、人非人等：『听吾今日於忉利天宫，称扬赞叹地藏菩萨於人天中，利益等事、不思议事、超圣因事、证十地事、毕竟不退阿耨多罗三藐三菩提事。』

说是语时，会中有一菩萨摩诃萨，名观世音，从座而起，胡跪合掌白佛言：『世尊，是地藏菩萨摩诃萨具大慈悲，怜愍罪苦众生，於千万亿世界，化千万亿身。所有功德及不思议威神之力，我闻世尊与十方无量诸佛，异囗同音赞叹地藏菩萨云：「正使过去现在未来诸佛说其功德，犹不能尽。」向者又蒙世尊普告大众：「欲称扬地藏菩萨利益等事。」唯愿世尊为现在未来一切众生，称扬地藏菩萨不思议事，令天龙八部，瞻礼获福。』

佛告观世音菩萨：『汝於娑婆世界有大因缘。若天若龙、若男若女、若神若鬼、乃至六道罪苦众生，闻汝名者、见汝形者、恋慕汝者、赞叹汝者。是诸众生，於无上道，必不退转。常生人天，具受妙乐。因果将熟，遇佛受记。汝今具大慈悲，怜愍众生，及天龙八部，听吾宣说地藏菩萨不思议利益之事。汝当谛听，吾今说之。』

观世音言：『唯然，世尊，愿乐欲闻。』

佛告观世音菩萨：『未来现在诸世界中，有天人受天福尽，有五衰相现，或有堕於恶道之者。如是天人，若男若女，当现相时，或见地藏菩萨形相、或闻地藏菩萨名，一瞻一礼。是诸天人，转增天福，受大快乐，永不堕三恶道。何况见闻菩萨，以诸香华，衣服、饮食、宝贝、璎珞，布施供养，所获功德福利，无量无边。』

复次观世音：『若未来现在诸世界中，六道众生临命终时，得闻地藏菩萨名，一声历耳根者。是诸众生，永不历三恶道苦。何况临命终时，父母眷属，将是命终人舍宅、财物、宝贝、衣服，塑画地藏形像。或使病人未终之时，眼耳见闻，知道眷属将舍宅、宝贝等为其自身塑画地藏菩萨形像。是人若受重病者，承斯功德，寻即除愈，寿命增益。是人若是业报命尽，应有一切罪障业障，合堕恶趣者。承斯功德，命终之後，即生人天，受胜妙乐，一切罪障，皆悉消灭。』

复次观世音菩萨：『若未来世，有男子女人，或乳哺时、或三岁、五岁、十岁以下，亡失父母，乃及亡失兄弟姐妹，是人年既长大，思忆父母及诸眷属，不知落在何趣、生何世界、生何天中，是人若能塑画地藏菩萨形像，乃至闻名，一瞻一礼，一日至七日，末退初心，闻名见形，瞻礼供养。是人眷属，假因业故，堕恶趣者，计当劫数，承斯男女，兄弟姊妹，塑画地藏形像，瞻礼功德，寻即解脱，生人天中，受胜妙乐。是人眷属，如有福力，已生天，受胜妙乐者，即承斯功德，转增圣因，受无量乐。』

『是人更能三七日中，一心瞻礼地藏形像，念其名字，满於万遍。当得菩萨现无边身，具告是人，眷属生界。或於梦中，菩萨现大神力，亲领是人，於诸世界，见诸眷属。更能每日念菩萨名千遍，至於千日。是人当得菩萨遣所在土地鬼神，终身卫护，现世衣食丰溢，无诸集苦。乃至横事不入其门，何况及身。是人毕竟的菩萨摩顶授记。』

复次观世音菩萨：『若未来世有善男子善女人，欲发广大慈心、救度一切众生者、欲修无上菩提者、欲出离三界者。是诸人等，见地藏形像，及闻名者，至心皈依，或以香华、衣服、宝贝、饮食、供养瞻礼。是善男女等，所愿速成，永无障碍。』

复次观世音：『若未来世，有善男子善女人，欲求现在未来百千万亿等愿，百千万亿等事。但当皈依瞻礼、供养赞叹，地藏行像。如事所愿所求，悉皆成就。复愿地藏菩萨具大慈悲，永拥护我。是人於睡梦中，即得菩萨摩顶受记。』

复次观世音菩萨：『若未来世，善男子善女人，於大乘经典，深生珍重，发不思议心，欲读欲诵。纵遇明师教视令熟，旋得旋忘，动经年月，不能读诵。市善男子等，有宿业障，未得消除，故於大乘经典，无读诵性。如是之人，闻地藏菩萨名、见地藏菩萨像，具以本心恭敬陈白，更以香华、衣服、饮食、一切玩具，供养菩萨。以净水一盏，经一日一夜安菩萨前，然後合掌请服，回首向南。临入囗时，至心郑重，服水既毕，慎五辛酒肉，邪淫妄语，及诸杀害，一七日或三七日。是善男子善女人，於睡梦中，具见地藏菩萨现无边身，於是人处，授灌顶水。其人梦觉，即获聪明，应是经典，一历耳根，即当永记，更不忘失一句一偈。』

复次观世音菩萨：『若未来世，有诸人等，衣食不足，求者乖愿、或多疾病、或多凶衰、家宅不安、眷属分散、或诸横事，多来忤身、睡梦之间，多有惊怖。如是人等，闻地藏名、见地藏形，至心恭敬，念满万遍。是诸恶不如意事，渐渐消灭，即得安乐、衣食丰溢，乃至睡梦中，悉皆安乐。』

复次观世音菩萨：『若未来世，有善男子善女人，或因治生、或因公私、或因生死、或因急事入山林中、过渡河海、乃及大水、或经险道。是人先当念地藏菩萨名万遍，所过土地，鬼神卫护，行住坐卧，永保安乐。乃至逢於虎狼狮子，一切毒害，不能损之。』

佛告观世音菩萨：『是地藏菩萨，於阎浮提有大因缘，若说於诸众生见闻利益等事，百千劫中，说不能尽。是故观世音，汝以神力流布是经，令娑婆世界众生，百千万劫永受安乐。』

尔时世尊而说偈言：『

吾观地藏威神力， 恒河沙劫难说尽， 见闻瞻礼一念间， 利益天人无量事。 若男若女若龙神， 报尽应当堕恶道。 至心皈依大士身， 寿命转增除罪障。 少失父母恩爱者， 未知魂神在何趣， 兄弟姊妹及诸亲， 生长以来皆不识。 或塑或画大士身， 悲恋瞻礼不暂舍， 三七日中念其名， 菩萨当现无边体， 示其眷属所生界， 纵堕恶趣寻出离。 若能不退是初心， 即获摩顶受圣记。 欲修无上菩提者， 乃至出离三界苦。 是人既发大悲心， 先当瞻礼大士像， 一切诸愿速成就， 永无业障能遮止。 有人发心念经典， 欲度群迷超彼案， 虽立斯愿不思议， 旋读旋忘多废失， 斯人有业障惑故， 於大乘经不能记。 供养地藏以香华， 衣服饮食诸玩具， 以净水安大士前， 一日一夜求服之， 发殷重心慎五辛， 酒肉邪淫及妄语， 三七日内勿杀害， 至心思念大士名， 即於梦中见无边， 觉来便得利耳根， 应是经教历耳闻， 千万生中永不忘。 以是大士不思议， 能使病人获此慧。 贫穷众生及疾病， 家宅凶衰眷属离， 睡梦之中悉不安， 求者乖违无称遂。 至心瞻礼地藏像， 一切恶事皆消灭， 至於梦中尽得安， 衣食丰饶神鬼护。 欲入山林及渡海， 毒恶禽兽及恶人， 恶神恶鬼并恶风， 一切诸难诸苦恼。 但当瞻礼及供养， 地藏菩萨大士像， 如是山林大海中， 应是诸恶皆消灭。 观音至心听吾说， 地藏无尽不思议， 百千万劫说不周， 广宣大士如是力。 地藏名字若人闻， 乃至见像瞻礼者， 香华一服饮食奉， 供养百千受妙乐。 若能以此回法界， 毕竟成佛超生死。 是故观音汝当知， 普告恒沙诸国土。 』

    地藏菩萨本愿经卷下

嘱累人天品第十三

尔时世尊举金色臂，又摩地藏菩萨模诃萨顶，而作是言：『地藏地藏，汝之神力不可思议、汝之慈悲不可思议、汝之智慧不可思议、汝之辩才不可思议，正使十方诸佛赞叹宣说乳之不可思议事，千万劫中不能得尽。』

『地藏地藏，记吾今日在忉利天中，於百千万亿不可说不可说一切诸佛菩萨，天龙八部，大会之中，再以人天诸众生等，未出三界，在火宅中者，付嘱於汝。无令是诸众生，堕恶趣中，一日一夜，何况更落五无间及阿鼻地狱，动经千万亿劫，无有出期。』

『地藏，是南阎浮提众生，志性无定，习恶者多。纵发善心，须臾即退。若遇恶缘，念念增长。以是之故，吾分是形，百千万亿化度，随其根性而度脱之。』

『地藏，吾今殷勤，以天人众，付嘱於汝。未来世中，若天若人，随业报应，落在恶趣。临堕恶趣中，或至门首，是诸众生，若能念得一佛名，一菩萨名，一句一偈大乘经典。是诸众生，汝以神力，方便救拔，於是人所，现无边身，为碎地狱，遣令生天，受胜妙乐。』

尔时世尊而说偈言：『

现在未来天人众， 吾今殷勤付嘱汝， 以大神通方便度， 勿令堕在诸恶趣。 』

尔时地藏菩萨摩诃萨胡跪合掌白佛言：『世尊，唯愿世尊不以为虑。未来世中，若有善男子善女人，於佛法中，一念恭敬，我亦百千方便，度脱是人，於生死中速得解脱。何况闻诸善事，念念修行，自然於无上道永不退转。』

说是语时，会中有一菩萨，名虚空藏，白佛言：『世尊，我自忉利天，闻於如来赞叹地藏菩萨，威神势力，不可思议。未来世中，若有善男子善女人，乃及一切天龙，闻此经典及地藏菩萨名字，或瞻礼形像，得几种福利，唯愿世尊，为未来现在一切众等，略而说之。』

佛告虚空藏菩萨：『谛听谛听，吾当为汝分别说之。若未来世，有善男子善女人，见地藏形像，及闻此经，乃至读诵，香华饮食，衣服珍宝，布施供养，赞叹瞻礼者，得二十八种利益：

一者、天龙护念， 二者、善果日增， 三者、集圣上因， 四者、菩提不退， 五者、衣食丰足， 六者、疾疫不临， 七者、离水火灾， 八者、无盗贼恶， 九者、人见钦敬， 十者、神鬼助持， 十一者、女转男生， 十二者、为王臣女， 十三者、端正相好， 十四者、多生天上， 十五者、或为帝王， 十六者、宿智命通， 十七者、有求皆从， 十八者、眷属欢乐， 十九者、诸横消灭， 二十者、业道永除， 二十一者、去处尽通， 二十二者、夜梦安乐， 二十三者、先亡离苦， 二十四者、宿福受生， 二十五者、诸圣赞叹， 二十六者、聪明利根， 二十七者、饶慈愍心， 二十八者、毕竟成佛。』

『虚空藏菩萨，若现在未来，天龙鬼神，闻地藏名，礼地藏形，或闻地藏本愿事行，赞叹瞻礼，得七种利益：

一者、速超圣地， 二者、恶业消灭， 三者、诸佛临护， 四者、菩提不退， 五者、增长本力， 六者、宿命接通， 七者、毕竟成佛。』

尔时，十方三世一切诸来，不可说不可说诸佛如来，及大菩萨天龙八部，闻释迦牟尼佛，称扬赞叹地藏菩萨，大威神力，不可思议，叹未曾有。

是时，忉利天，雨无量香华，天衣珠璎，供养释迦牟尼佛及地藏菩萨已，一切众会，俱复瞻礼，合掌而退。

地藏菩萨本愿经卷下

赞

地藏本誓 校量经因 癃残　哑是前生 今世讽大乘 福利无穷 决定宝莲生

南无常住十方僧 南无常住十方僧 南无常住十方僧

地藏赞

地藏菩萨妙难伦 化现金容处处分 三途六道闻妙法 四生十类蒙慈恩 明珠照彻天堂路 金锡振开地狱门 累劫亲姻蒙接引 九莲台畔礼慈尊

南无九华山幽冥世界 大慈大悲 地藏王菩萨

南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨 南无地藏王菩萨..................... [数百千声 -- 并绕佛] 南无地藏王菩萨

三皈依

自皈依佛 当愿众生 体解大道 发无上心 自皈依法 当愿众生 深入经藏 智慧如海 自皈依僧 当愿众生 统理大众 一切无碍 和南圣众

回向偈

愿以此功德 装严佛净土 上报四重恩 下济三涂苦 若有见闻者 悉发菩提心 尽此一报身 同生极乐国

补阙真言

南谟喝罗怛那 哆罗夜耶 伽罗伽罗 俱住俱住 摩罗摩罗 虎罗 　 贺贺 苏怛孥 娑婆诃

补阙圆满真言

   呼　呼　 社曳穆契娑诃

七佛灭罪真言

离婆离婆帝 求诃求诃帝 陀罗尼帝 尼诃罗帝 毗黎你帝 真陵乾帝 娑婆诃

灭定业真言

   钵罗末邻陀宁娑婆诃 　 钵罗末邻陀宁娑婆诃 　 钵罗末邻陀宁娑婆诃 (第三遍向中问讯)

佛子所造诸恶业 皆由无始贪瞠痴 从身语意之所生 一切佛子皆忏悔

有情所造诸恶业 皆由无始贪瞠痴 从身语意之所生 一切有情皆忏悔

孤魂所造诸恶业 皆由无始贪瞠痴 从身语意之所生 一切孤魂皆忏悔

众生无边誓愿度 烦恼无尽誓愿断 法门无量誓愿学 佛道无上誓愿成

自性众生誓愿度 自性烦恼誓愿断 自性法门誓愿学 自性佛道誓愿成 (问讯出位)

_________________________________________________

无上甚深微妙法 百千万劫难遭遇

我今见闻得受持 愿解如来真实意_________________________________________________

*注：以上空缺处因为无此字！


New Page 3

Earth Store Bodhisattva

Translated into Chinese by Tripitaka Master Shikshananda of Udyana
in the Tang Dynasty (ca A.D. 700)
Translated from the Chinese into English
by Buddhist Text Translation Society (2000)

Part One of Sutra of the Past Vows
of Earth Store Bodhisattva

Chapter I
Spiritual Penetrations in the Palace of the Trayastrimsha Heaven

Chapter II
The Division Bodies Gather

Chapter III
Contemplating the Karmic Conditions of Beings

Chapter IV
Karmic Retributions of Beings of Jambudvipa

Mantra and Praise

Part Two of Sutra of the Past Vows
of Earth Store Bodhisattva

Chapter V
Names of Hells

Chapter VI
The Thus Come One's Praises

Chapter VII
Benefiting the Living and the Dead

Chapter VIII
Praises of King Yama and His Followers

Chapter IX
The Names of Buddhas

Mantra and Praise

Part Three of Sutra of the Past Vows
of Earth Store Bodhisattva

Chapter X
The Conditions and Comparative Merits and Virtues of Giving

Chapter XI
The Dharma Protection of an Earth Spirit

Chapter XII
Benefits Derived from Seeing and Hearing

Chapter XIII
The Entrustment of People and Gods

Mantra and Praise

Earth Store Bodhisattva

Part One of Sutra
of the Past Vows of Earth Store Bodhisattva

CHAPTER I
Spiritual Penetrations in the Palace of the Trayastrimsha Heaven

Thus I have heard:

At one time, the Buddha was in the Trayastrimsha Heaven speaking Dharma for his mother.

At that time, uncountably many Buddhas and Great Bodhisattvas, Mahasattvas from infinite worlds in the Ten Directions assembled to praise how Shakyamuni Buddha is able to manifest powerfully great wisdom and spiritual penetrations in the evil world of the Five Turbidities. They lauded how he regulates and subdues obstinate beings so they learn what causes suffering and what brings bliss. Each sent his attendants to pay their respects to the World Honored One.

At that time the Thus Come One smiled and emitted billions of great light clouds. There was

a light cloud of great fullness, a light cloud of great compassion, a light cloud of great wisdom, a light cloud of great prajna, a light cloud of great samadhi, a light cloud of great auspiciousness, a light cloud of great blessings, a light cloud of great merit, a light cloud of great refuge, and a light cloud of great praise.

After emitting indescribably many light clouds, he also uttered many wonderful, subtle sounds

There was the sound of dana paramita, the sound of shila paramita, the sound of kshanti paramita, the sound of virya paramita, the sound of dhyana paramita, and the sound of prajna paramita.

There was the sound of compassion, the sound of joyous giving, the sound of liberation, the sound of no-outflows, the sound of wisdom, the sound of great wisdom, the sound of the Lion's roar, the sound of the Great Lion's roar, the sound of thunderclouds, and the sound of great thunderclouds.

After he uttered indescribably many sounds, countless millions of gods, dragons, ghosts, and spirits from the Saha and other worlds also gathered in the Palace of the Trayastrimsha Heaven.

They came from the Heaven of the Four Kings, the Trayastrimsha Heaven, the Suyama Heaven, the Tushita Heaven, the Blissful Transformations Heaven, and the Heaven of Comfort Gained Through Others' Transformations.

They came from the Heaven of the Multitudes of Brahma, the Heaven of the Ministers of Brahma, the Heaven of the Great Brahma Lord, the Heaven of Lesser Light, the Heaven of Limitless Light, the Heaven of Light Sound, the Heaven of Lesser Purity, the Heaven of Limitless Purity, and the Heaven of Universal Purity.

They came from the Birth of Blessings Heaven, the Love of Blessings Heaven, the Abundant Fruit Heaven, the No Thought Heaven, the No Affliction Heaven, the No Heat Heaven, the Good Views Heaven, the Good Manifestation Heaven, the Ultimate Form Heaven, the Maheshvara Heaven, and so forth, to the Heaven of the Station of Neither Thought Nor Non-Thought.

All those groups of gods, dragons, ghosts and spirits came and gathered together.

Moreover, sea spirits, river spirits, stream spirits, tree spirits, mountain spirits, earth spirits, brook and marsh spirits, sprout and seedling spirits, day, night, and space spirits, heaven spirits, food and drink spirits, grass and wood spirits, and other such spirits from the Saha and other worlds came and gathered together.

In addition, all the great Ghost Kings from the Saha and other worlds came and gathered together. They were:

the Ghost King Evil 'Eyes, the Ghost King Blood-drinker, the Ghost King Essence and Energy-eater, the Ghost King Fetus and Egg-eater, the Ghost King Spreader of Sickness, the Ghost King Collector of Poisons, the Ghost King Kind-hearted, the Ghost King Blessings and Benefits, the Ghost King Great Regard and Respect, and others.

At that time, Shakyamuni Buddha said to the Dharma Prince, Bodhisattva, Mahasattva, Manjushri, "As you regard these Buddhas, Bodhisattvas, gods, dragons, ghosts and spirits from this land and other lands who are now gathered in the Trayastrimsha Heaven, do you know their number?"

Manjushri said to the Buddha, "World Honored One, even if I were to measure and reckon with my spiritual powers for a thousand eons I would not be able to know their number."

The Buddha told Manjushri, "Regarding them with my Buddha Eye, I also cannot count them all. Those beings have been taken across, are being taken across, will be taken across, have been brought to accomplishment, are being brought to accomplishment, or will be brought to accomplishment by Earth Store Bodhisattva, throughout many eons."

Manjushri said to the Buddha, "World Honored One, throughout many eons I have cultivated good roots and my wisdom was certified as unobstructed. When I hear what the Buddha says, I immediately accept it with faith.

But Sound-hearers of small attainment, gods, dragons, and the rest of the Eightfold Division, and beings in the future who hear the Thus Come One's true and sincere words will certainly harbor doubts. Even if they receive the teaching most respectfully, they will still be unable to avoid slandering it.

My only wish is that the World Honored One will proclaim for everyone what practices Earth Store Bodhisattva did. Tell us what vows he made while on the level of planting causes that now enable him to succeed in doing such inconceivable deeds."

The Buddha said to Manjushri, "By way of analogy suppose that each blade of grass, tree, forest, rice plant, hemp stalk, bamboo, reed, mountain, rock and mote of dust in a Three Thousand Great Thousand-World System were a Ganges River. Then suppose that each grain of sand in each of those Ganges Rivers were a world and that each mote of dust in each of those worlds were an eon. Then suppose each mote of dust accumulated in each of those eons were itself an eon.

The time elapsed since Earth Store Bodhisattva was certified to the position of the Tenth Ground is a thousand times longer than that in the above analogy. Even longer was the time he dwelled on the levels of Sound-hearer and Pratyekabuddha.

Manjushri, the awesome spiritual strength and vows of this Bodhisattva are inconceivable.

If good men or women in the future hear this Bodhisattva's name, praise him, behold and bow to him, call his name, make offerings to him, or if they draw, carve, cast, sculpt or make lacquered images of him, such people will be reborn in the Heaven of the Thirty-Three one hundred times and will never fall into the Evil Paths.

"Manjushri, indescribably many eons ago, during the time of a Buddha named Lion Sprint Complete in the Ten Thousand Practices Thus Come One, Earth Store Bodhisattva, Mahasattva was the son of a great Elder.

That Elder's son, upon observing the Buddha's hallmarks and fine features and how the thousand blessings adorned him, asked that Buddha what practices and vows made him so magnificent.

Lion Sprint Complete in the Ten Thousand Practices Thus Come One then said to the Elder's son. If you wish to have a body like mine, you must first spend a long time liberating beings who are undergoing suffering.'

"Manjushri, that comment caused the Elder's son to make a vow: 'From now until the ends of future time throughout uncountable eons I will use expansive expedient means to help beings in the Six Paths who are suffering for their offenses. Only when they have all been liberated, will I myself become a Buddha.'

From the time he made that great vow in the presence of that Buddha until now, hundreds of thousands of nayutas of inexpressibly many eons have passed and still he is a Bodhisattva.

"Another time, inconceivable Asamkhyeya eons ago there was a Buddha named Enlightenment-Flower Samadhi Self-Mastery King Thus Come One. That Buddha's llfespan was four hundred billion Asamkhyeya eons.

During his Dharma-lmage Age, there lived a Brahman woman endowed with ample blessings from previous lives who was respected by everyone. Whether she was walking, standing, sitting, or lying down, gods surrounded and protected her.

Her mother, however, embraced a deviant faith and often slighted the Triple Jewel.

Her worthy daughter made use of many expedients in trying to convince her mother to hold right views, but her mother never totally believed. Before long the mother's life ended and her consciousness fell into the Relentless Hell.

"When that happened, the Brahman woman, knowing that her mother had not believed in cause and effect while alive, feared that her karma would certainly pull her into the Evil Paths.

For that reason, she sold the family house and acquired many kinds of incense, flowers, and other gifts. With those she performed a great offering in that Buddha's stupas and monasteries.

She saw an especially fine image of the Thus Come One Enlightenment Flower Samadhi Self-Mastery King in one of the monasteries.

As the Brahman woman beheld the honored countenance she became doubly respectful while thinking to herself, 'Buddhas are called Greatly Enlightened Ones who have gained All-Wisdom. If this Buddha were in the world I could ask him where my mother went after she died. He would certainly know.'

"The Brahman woman then wept for a long time as she gazed longingly upon the Thus Come One.

Suddenly a voice in the air said, '0 weeping, worthy woman, do not be so sorrowful. I shall now show you where your mother has gone."

"The Brahman woman placed her palms together as she addressed space saying, 'Which Virtuous Divinity is comforting me in my grief? From the day I lost my mother onward I have held her in memory day and night, but there is nowhere I can go to ask about the realm of her rebirth.'

"The voice in the air spoke to the woman again, I am the one you behold and worship, the former Enlightenment-Flower Samadhi Self-Mastery King Thus Come One. Because I have seen your regard for your mother is double that of ordinary beings, I have come to show you where she is.'

"The Brahman woman suddenly lunged toward the voice she was hearing and then fell, injuring herself severely. Those around her supported and attended upon her and after a long time she was revived.

Then she addressed the air saying, I hope the Buddha will be compassionate and quickly tell me into what realm my mother has been reborn. I am now near death myself.'

"Enlightenment-Flower Samadhi Self-Mastery King Thus Come One told the worthy woman, After you make your offerings, return home quickly. Sit upright and concentrate on my name. You will soon know where your mother has been reborn.'

"The Brahman woman bowed to the Buddha and returned home. The memory of her mother sustained her as she sat upright recollecting Enlightenment-Flower Samadhi Self-Mastery King Thus Come One.

"After doing so for a day and night, she suddenly saw herself beside a sea whose waters seethed and bubbled. Many evil beasts with iron bodies flew swiftly back and forth above the sea.

She saw hundreds of thousands of men and women bobbing up and down in the sea, being fought over, seized, and eaten by the evil beasts.

She saw Yakshas with different shapes. Some had many hands, some many eyes, some many legs, some many heads. With their sharp fangs they drove the offenders on towards the evil beasts. Or the Yakshas themselves seized the offenders and twisted their heads and feet together into shapes so horrible that no one would dare even look at them for long.

During that time the Brahman woman was naturally without fear due to the power of recollecting the Buddha.

"A ghost king named Poisonless bowed his head in greeting and said to the worthy woman, 'Welcome, 0 Bodhisattva. What conditions bring you here?'

"The Brahman woman asked the ghost king, 'What is this place?'

"Poisonless replied, 'We are on the western side of the Great Iron Ring Mountain and this is the first of the seas that encircle it.'

"The worthy woman said, 'I have heard that the hells are within the Iron Ring. Is that actually so?'

"Poisonless answered, 'Yes, the hells are here.'

"The worthy woman asked, 'How have I now come to the hells?'

"Poisonless answered, If it wasn't awesome spiritual strength that brought you here, then it was the power of karma. Those are the only two ways anyone comes here. "

The worthy woman asked, 'Why is this water seething and bubbling, and why are there so many offenders and evil beasts?'

Poisonless replied. These are beings of Jambudvipa who did evil deeds. They have just died and passed through forty-nine days without any surviving relatives doing any meritorious deeds on their behalf to rescue them from their distress. Besides that, during their lives they themselves didn't plant any good causes. Now their own karma calls forth these hells. Their first task is to cross this sea.

Ten thousand yojanas east of this sea is another sea in which they will undergo twice as much suffering. East of that sea is yet another sea where the sufferings are doubled still again.

What the combined evil causes of the three karmic vehicles evoke is called the sea of karma. This is that place.'

"The worthy woman asked the Ghost King Poisonless, 'Where are the hells?'

"Poisonless answered, 'Within the three seas are hundreds of thousands of great hells, each one different. Eighteen of those are known as the great hells. Five hundred subsequent ones inflict limitless cruel sufferings. Following those are hundreds of thousands that inflict limitless further sufferings.'

"The worthy woman again questioned the great ghost king, 'My mother died recently and I do not know where she has gone.'

"The ghost king asked the worthy woman, 'When the Bodhisattva's mother was alive, what habits did she have?"

"The worthy woman replied, 'My mother held deviant views and ridiculed and slandered the Triple Jewel. Even if she occasionally believed, she would soon become disrespectful again. She died recently and I still do not know where she was reborn.'

"Poisonless asked, 'What was the Bodhisattva's mother's name and clan?'

"The worthy woman replied, 'My parents were both Brahmans; my father's name was Shila Sudarshana, my mother's name was Yue Di Li.'

"Poisonless placed his palms together and implored the worthy woman, 'Please, Worthy One, quickly return home. There is no need for you to grieve further. The offender Yue Di Li was born in the heavens three days ago.

It is said that she received the benefit of offerings made and blessings cultivated by her filial child who practiced giving to Enlightenment-Flower Samadhi Self-Mastery King Thus Come One at stupas and monasteries.

Not only was the Bodhisattva's mother released from the hells. All the other offenders who were destined for the Relentless Hell received bliss and were reborn together with her.'

Having finished speaking, the ghost king put his palms together and withdrew.

"The Brahman woman returned swiftly as if from a dream, understood what had happened, and then made a profound and far-reaching vow before the stupas and images of Enlightenment-Flower Samadhi Self-Mastery King Thus Come One, saying, 'I vow that until the end of future eons I will respond to beings suffering for their offenses by using many expedient means to bring about their liberation.'"

The Buddha told Manjushri, "The Ghost King Poisonless is the present Bodhisattva Foremost Wealth. The Brahman woman is now Earth Store Bodhisattva."
Earth Store Bodhisattva

CHAPTER II
The Division Bodies Gather

At that time the division bodies of Earth Store Bodhisattva began gathering in the Palace of the Trayastrimsha Heaven from billions of inexpressible, unutterable, immeasurable, ineffable, limitless Asamkhyeyas of worlds. They came from wherever hells were found.

Due to the spiritual powers of the Thus Come One, each came from his own direction and was joined by billions of nayutas of those who had obtained liberation from the force of bad karma. All came holding incense and flowers as offerings to the Buddha.

Those groups that came were irreversible from Anuttara- samyaksambodhi because they had been taught and transformed by Earth Store Bodhisattva.

For long eons they had wandered in birth and death, undergoing suffering within the Six Paths without even temporary respite. Now they had reached levels of Sagehood due to the great compassion and deep vows of Earth Store Bodhisattva.

They felt joyful as they arrived at the Trayastrimsha Heaven and gazed at the Thus Come One, their eyes not leaving him for a moment.

At that time, the World Honored One stretched forth his golden colored arm and rubbed the crowns of all the division bodies of Earth Store Bodhisattva, Mahasattva, gathered from billlons of Inexpressible, Inconceivable, immeasurable, ineffable, limitless Asamkhyeyas of worlds, and said,

"I teach and transform obstinate beings such as these within the evil worlds of the Five Turbidities, causing their minds to be regulated and subdued so they renounce the deviant and return to the proper.

But one or two of ten still cling to their bad habits. For them I again divide into billions of bodies and use numerous additional expedient means.

Those with keen roots will listen and immediately believe. Those with good rewards will respond to exhortation and strive to succeed. Those who are dark and dull will return only after being taught for a long time. Those whose karma is heavy fail to show any respect.

My division bodies take across and liberate all those different kinds of beings. I may appear in a male body. I may appear in a female body. I may appear in the body of a god or dragon. I may appear in the body of a spirit or ghost. I may appear as a mountain, as a forest, as a stream, as a spring, as a river, as a lake, as a fountain, or as a well in order to benefit people. I use all these ways to save beings.

I may appear in the body of God Shakra.
I may appear in the body of Lord Brahma.
I may appear in the body of a Wheel-Turning King.
I may appear in the body of a lay person.
I may appear in the body of a national leader.
I may appear in the body of a prime minister.
I may appear in the body of an official.
I may appear in the body of a Bhikshu, a Bhikshuni, an Upasaka, an Upasika, and so forth to my appearing in the body of a Sound-hearer, an Arhat, a Pratyekabuddha, or a Bodhisattva in order to teach and rescue beings.

It is not that I only appear to them in the body of a Buddha.

"Reflect on how I have toiled for repeated eons and endured acute suffering to take across and free stubborn beings who resist being taught and who continue to suffer for their offenses.

Those not yet subdued undergo retributions according to their karma. If they fall into the evil destinies and are enduring tremendous suffering, then you should remember the gravity of this entrustment I am now giving you here in the palace of the Trayastrimsha Heaven:

Find ways to liberate all beings in the Saha world from now until the time when Maitreya comes into the world. Help them escape suffering forever, encounter Buddhas, and receive predictions."

At that time all the division bodies of Earth Store Bodhisattva that came from all those worlds merged into single form. Then he wept and said to the Buddha, "Throughout long eons I have been receiving the Buddha's guidance and from that have developed inconceivable spiritual power and great wisdom.

My division bodies fill worlds as many as grains of sand in billions of Ganges Rivers. In each of those worlds, I transform myself into billions of bodies. Each body takes across billions of people, helping them to return respectfully to the Triple Jewel, escape birth and death forever, and reach the bliss of Nirvana.

Even if their good deeds within the Buddhadharma amount to as little as a strand of hair, a drop of water, a grain of sand, or a mote of dust, I will gradually take them across, liberate them, and help them gain great benefit.

I only hope that the World Honored One will not be concerned about beings of the future who have bad karma. " In that way he addressed the Buddha three times: "I only hope that the World Honored One will not be concerned about beings of the future who have bad karma."

At that time the Buddha praised Earth Store Bodhisattva and said, "Excellent! Excellent! I will help you in this work you so willingly undertake. When the vast vows that you keep making throughout so many eons are fulfilled and all those beings have been saved, then I will certify your ultimate Bodhi."

Earth Store Bodhisattva

CHAPTER III
Contemplating the Karmic Conditions of Beings

At that time the Buddha's mother. Lady Maya, placed her palms together respectfully and asked Earth Store Bodhisattva, "Great Sage, could you tell us about the different kinds of karma that beings of Jambudvipa create and the resulting retributions that they undergo?"

Earth Store replied, "There are millions of worlds and lands that may or may not have hells, may or may not have women, may or may not have Buddhadharma, and so forth to having or not having Sound-hearers and Pratyekabuddhas. Since the worlds differ, the retributions in the hells also differ."

Lady Maya spoke again to the Bodhisattva, "Could you please tell us about the offenses done by those in Jambudvipa that result in retributions in the evil destinies?"

Earth Store replied, "Worthy Mother, please listen as I speak briefly about that."

The Buddha's mother answered, "Great Sage, please tell us about it."

Then Earth Store Bodhisattva said to the Worthy Mother, "Retributions that result from offenses done in Jambudvipa are described like this.

"Beings who are not filial to their parents, even to the extent of harming or killing them, will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who shed the Buddha's blood, slander the Triple Jewel, and do not venerate Sutras will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who usurp or damage the property of the Eternally Dwelling, who defile Bhikshus or Bhikshunis, who commit sexual-acts within the Sangharama, or who kill or harm beings there will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who seem to be Shramanas but in their minds are not Shramanas, who destroy the things of the Eternally Dwelling, who deceive lay people, who go against the precepts, and who do many other evil deeds will fall into the Relentless Hell where for billions of eons they will seek escape in vain.

"Beings who steal the wealth and property of the Eternally Dwelling including its grains, its food and drink, its clothing, or take anything at all that was not given to them will fall into the Relentless Hell where for billions of eons they will seek escape in vain."

Earth Store continued, "Worthy Mother, beings who commit such offenses will fall into the Fivefold Relentless Hell where they will constantly seek for temporary relief from their suffering but will never receive even a moment's respite."

Lady Maya further asked Earth Store Bodhisattva, "Why is that hell called Relentless?"

Earth Store replied, "Worthy Mother, the hells are all within the Great Iron Ring Mountain.

The eighteen great hells and the five hundred subsequent ones each have their own names. There are hundreds of thousands more that also have their own names.

The Relentless Hell is found within a city of hells that encompasses more than eighty thousand square miles. That city is made entirely of iron. Ten thousand miles above the city is an unbroken mass of fire.

Within the city are many interconnected hells, each with a different name.

"There is just one hell called Relentless. Its circumference is eighteen thousand miles.

The wall of that hell is a thousand miles high, totally made iron, and covered with a fire burning downward that is joined by a fire burning upward.

Iron snakes and dogs spewing fire race back and forth atop that wall.

"In that hell is a bed that extends for ten thousand miles. One person undergoing punishment sees his or her own body filling the entire bed. When millions of people undergo punishment simultaneously, each still sees his or her own body filling the bed. That is how retributions are undergone by those with the same karma.

"What is more, these offenders undergo extreme suffering. Thousands of Yakshas and other evil ghosts display fangs like swords and eyes like lightning as they pull and drag the offenders using their brass-clawed hands.

Other Yakshas wield huge iron halberds that they use to pierce the offenders' mouths and noses or stab their bellies and backs. They toss the offenders into the air and then catch them by skewering them with the halberds or they let them drop onto the bed.

Iron eagles peck at the offenders' eyes and iron serpents wrap around their necks. Long nails are driven into all their limbs. Their tongues are pulled out, stretched, and then plowed through. Their internal organs are gouged out, sliced, and minced. Molten copper is poured into their mouths, and their bodies are bound with hot iron.

Responses to their karma go on like that throughout thousands of deaths and rebirths. They pass through millions of eons seeking escape in vain.

"When this world is destroyed, they find themselves in another world. When that world is destroyed, they pass to another one. When that world, too, is destroyed, they move on to another. When this world comes into being again, they return here.

The situation involving Relentless retribution for offenses is like that.

"Moreover, five karmic responses account for the name Relentless. What are the five?

First, it is said to be Relentless since punishment is undergone day and night throughout many eons without ceasing for a moment.

Second, it is said to be Relentless since one person fills it in the same way that many people fill it.

Third, it is said to be Relentless since repeated punishments continue without cease throughout years that stretch into nayutas of eons. Those punishments are inflicted by instruments of torture such as forks and clubs; or by eagles, serpents, wolves, and dogs; or by pounding, grinding, sawing, drilling, chiseling, cutting and chopping; or by boiling liquids, iron nets, iron ropes, iron asses, and iron horses; or by raw hide bound around one's head and hot iron poured over one's body; or by meals of iron pellets and drinks of iron fluids.

Fourth, it is said to be Relentless since everyone undergoes karmic responses based on the offenses they committed, whether they be men, women, savages, old, young, honorable, or lowly; whether they be dragons, spirits, gods or ghosts.

Fifth, it is said to be Relentless since offenders continually undergo ten thousand deaths and as many rebirths each day and night from the moment they first enter this hell and on through thousands of eons. During that time they seek even a moment's relief but it never happens. Only when their karma is finished can they attain rebirth."

Earth Store Bodhisattva said to the Worthy Mother, "That is a brief description of the Relentless Hell. If I were to speak extensively about the names of all the implements of punishment in the hells and all the sufferings there, I could not finish speaking in an entire eon."

After hearing that, Lady Maya placed her palms together sorrowfully, made obeisance, and withdrew.

Earth Store Bodhisattva

CHAPTER IV
Karmic Retributions of Beings of Jambudvipa

At that time Earth Store Bodhisattva said to the Buddha, "World Honored One, because I receive the awesome spiritual strength of the Buddha, Thus Come One, I am able to divide my body and rescue beings who are undergoing karmic retributions everywhere in billions of worlds. If it were not for the great compassionate strength of the Thus Come One, I would be unable to perform such changes and transformations.

Now the World Honored One has entrusted me with rescuing and liberating beings in the Six Paths until Ajita becomes a Buddha. I accept the entrustment, World Honored One. Please have no further concern.

Then the Buddha told Earth Store Bodhisattva, "Beings who have not yet obtained liberation have unfixed natures and consciousnesses.

Their bad habits reap karma; their good habits bring rewards. Reacting to situations by doing good or evil acts causes them to turn in the Five Paths without a moment's rest. Throughout eons as numerous as motes of dust they remain confused, deluded, obstructed, and afflicted by difficulties.

They are like fish swimming through waters laced with nets. They may slip through and keep their freedom temporarily, but sooner or later they will be caught. I am concerned about such beings.

But since you keep making extensive vows repeatedly throughout successive eons to take such offenders across, what further worries need I have?

After that was said, a Bodhisattva, Mahasattva in the assembly named Samadhi Self-Mastery King said to the Buddha, "World Honored One, what vows has Earth Store Bodhisattva made during so many successive eons that he now receives the World Honored One's special praise? We hope the World Honored One will tell us about that."

Then the World Honored One said to Samadhi Self-Mastery King, "Listen attentively, listen attentively, and reflect well on the examples I am about to give you.

One time, limitless Asamkhyeyas of nayutas of inexpressible eons ago, a Buddha named All-Knowledge-Accomplished Thus Come One, One Worthy of Offerings, One of Proper and Pervasive Knowledge, One Perfect in Clarity and Conduct, Well-Gone One, Unsurpassed Knight Who Understands the World, Taming and Subduing Hero, Teacher of Gods and Humans, Buddha, World Honored One appeared in the world.

"That Buddha's lifespan was sixty thousand eons.

Before he became a monk, he was the king of a small country and was friendly with the king of a neighboring country. Both of them practiced the Ten Wholesome Acts and benefited beings.

Because the citizens of those two neighboring countries did many bad things, the two kings made a plan using far-reaching expedients.

"One king vowed to quickly become a Buddha and then cross over absolutely all the others.

"The other king vowed, 'I do not want to become a Buddha until I first take across all those who are suffering for their offenses, enable them to gain peace, and finally to reach Bodhi.'"

The Buddha told the Bodhisattva Samadhi Self-Mastery King, "The king who vowed to become a Buddha quickly is All-Knowledge-Accomplished Thus Come One.

The king who vowed to keep crossing over beings who are suffering for their offenses rather than to become a Buddha is Earth Store Bodhisattva.

"Another time, limitless Asamkhyeya eons ago, a Buddha named Pure-Lotus-Eyes Thus Come One appeared in the world. His lifespan was forty eons.

In his Dharma-image age, an Arhat who had blessings from rescuing beings met a woman named Bright Eyes who offered a meal to him once while he was teaching and transforming beings.

"'What is your wish?' asked the Arhat.

"Bright Eyes replied, 'On the day of my mother's death I performed meritorious deeds for her rescue, but I do not know where my mother is now.'

"Sympathizing with her, the Arhat entered into samadhi to contemplate and saw that Bright Eyes' mother had fallen into a bad destiny where she was undergoing extreme suffering.

The Arhat asked, 'Bright Eyes, what karma did your mother commit while alive that makes her now have to undergo such terrible suffering in a bad destiny?'

"Bright Eyes replied, 'My mother enjoyed eating fish, turtles, and the like. She especially liked to fry or broil the eggs of fish and turtles. Every time she ate those she took thousands of lives. Oh, Venerable One, please be compassionate and tell me how she can be saved."

"The Arhat took pity on Bright Eyes and used a skillful means. He urged Bright Eyes, saying, 'With sincere resolve, be mindful of Pure-Lotus-Eyes Thus Come One and also make carved and painted images of him. By doing so both the living and the dead will be rewarded.'

"Bright Eyes heard that, quickly renounced everything she loved, and swiftly commissioned painted images of the Buddha. Then she made offerings before them. The reverence she felt moved her to tears and she wept in grief as she beheld and bowed to the Buddha.

Suddenly near the end of night in a dream she saw that Buddha's body, dazzling gold in color and as large as Mount Sumeru, emitting great light. He said to Bright Eyes, 'Your mother will be born in your household before long and as soon as that child can feel hunger and cold he will speak.'

"Shortly thereafter a maidservant in the house bore a son who spoke before he was three days' old. Lowering his head and weeping he said to Bright Eyes, 'The karmic conditions we create during our lives and deaths result in retributions that we ourselves must undergo.

I am your mother and have been in darkness for a long time. Since you and I parted, I have repeatedly fallen into the great hells. Upon receiving the power of your blessings, I have been reborn as a servant's child with a short lifespan. Thirteen years from now, I will fall into the Evil Paths again. Do you have some way to free me so that I can avoid them?'

"When Bright Eyes heard those words, she knew without a doubt that they were her mother's. Choked with sobs, she said to the servant's child, 'Since you were my mother, you should know your own past offenses. What karma did you create that made you fall into the Evil Paths?'

"The maidservant's child answered, 'I am undergoing retribution for two kinds of karma: killing and slandering. Had I not received the blessings you earned to rescue me from difficulty, I would not yet be released from that karma.'

"Bright Eyes asked, 'What happens in the hells when beings undergo retributions for their offenses?'

"The maidservant's son answered, 'I can't bear to speak of the ways in which beings suffer for their offenses. Even if I lived for a hundred thousand years, I would find it hard to talk about.'

"When Bright Eyes heard that she wept bitterly and spoke into the air saying, 'I vow that my mother will be released from the hells forever. At the end of these thirteen years, she will be finished with her heavy offenses and will not go back to the Evil Paths.

0 Buddhas of the Ten Directions, with your compassion and sympathy, please listen to the vast and mighty vow that I am making for the sake of my mother.

If my mother will never again enter the Three Evil Paths, never again be born into low stations, and never again be female, then here before the image of Pure-Lotus-Eyes Thus Come One, I vow that from this day on, throughout billions of eons I will respond to all beings who are undergoing suffering for their offenses in the hells or the Three Evil Paths of any world.

'I vow to rescue them from the bad destinies of the hells, hungry ghosts, animals, and the like. Only after beings with such retributions have all become Buddhas will I myself achieve Proper Enlightenment.'

"After making that vow, she clearly heard Pure-Lotus-Eyes Thus Come One say to her, 'Bright Eyes, your own great compassion and sympathy reaches your mother by this mighty vow that you are making.

My contemplation shows me that after thirteen years your mother will finish this retribution and will be born a Brahman with a lifespan of one hundred years. After that retribution she will be born in the Land of No Concern with a lifespan of uncountable eons. Later she will realize the fruition of Buddhahood and cross over people and gods numbering as many as sand grains in the Ganges.'"

Shakyamuni Buddha told Samadhi Self-Mastery King, "The Arhat whose blessings helped Bright Eyes then is now Inexhaustible Intention Bodhisattva. The mother of Bright Eyes is now Liberation Bodhisattva. Bright Eyes herself is now Earth Store Bodhisattva. He has been extending his compassion and sympathy like that from distant eons onward by making vows as many as Ganges's sands, to rescue vast numbers of beings.

"Men and women in the future may fail to do good deeds and only do evil; may not believe in cause and effect; may indulge in sexual misconduct and false speech; may use divisive and harsh speech; and may slander the Great Vehicle. Beings with karma like that should certainly fall into bad destinies.

But if they encounter Good and Wise Advisors who exhort them and lead them quickly to take refuge with Earth Store Bodhisattva, those beings will just as quickly be released from their retributions in the Three Evil Paths.

If those beings are resolved and respectful, if they behold, bow to, and praise the Bodhisattva, and if they make offerings of flowers, incense, clothing, jewels, food and drink to him, they will enjoy supremely wonderful bliss in the heavens for billions of eons.

When their blessings in the heavens end and they are born as people, they will have the potential to be leaders of nations throughout billions of eons who are able to remember all aspects of causes and effects from previous lives.

"0,Samadhi Self-Mastery King, Earth Store Bodhisattva has such inconceivably great awesome spiritual power that he uses expansively for the benefit of beings. All of you Bodhisattvas should remember this Sutra and proclaim and widely spread it."

Samadhi Self-Mastery King said to the Buddha, "World Honored One, please do not be concerned. We billions of Bodhisattvas, Mahasattvas, based on the Buddha's awesome spiritual strength, will certainly proclaim this Sutra widely throughout Jambudvipa for the benefit of beings."

Having spoken thus to the World Honored One, Samadhi Self-Mastery King Bodhisattva put his palms together respectfully, bowed, and withdrew.

At that time the Four Heavenly Kings arose from their seats, put their palms together respectfully, and said to the Buddha, "World Honored One, Earth Store Bodhisattva has been making such great vows from distant eons onward.

Why is it that up to now he has not yet finished taking beings across? Why does he continue to renew his vast and mighty vows? Please, World Honored One, explain that for us."

The Buddha told the Four Heavenly Kings, "Excellent, excellent. Now to bring benefit to you and to extend that benefit to people and gods of the present and future, I will speak about how Earth Store Bodhisattva uses his compassion and sympathy within the paths of birth and death in Jambudvipa in the Saha world to rescue, take across, and liberate beings who are undergoing suffering for their offenses.

The Four Heavenly Kings replied, "Please, World Honored One, we would like to hear about his work."

The Buddha told the Four Heavenly Kings, "From distant eons onward to the present. Earth Store Bodhisattva has been taking across and liberating beings. Since his vows are still not finished, he continues with compassion and sympathy to help beings suffering for their offenses in this world.

Moreover, he sees the ceaseless tangle of their causes extending on through infinite, future eons. Because of that he renews his vows. Thus, in this Saha world on the continent of Jambudvipa, this Bodhisattva teaches and transforms beings by means of billions of expedient means.

"Four Heavenly Kings, To killers, Earth Store Bodhisattva says that short lifespans will be the retribution.

To robbers he says that poverty and acute suffering will be the retribution.

To those who indulge in improper sex he says that rebirth as pigeons or mandarin drakes or ducks will be the retribution.

To those who use harsh speech he says that quarrelling families will be the retribution.

To those who slander he says that being tongueless and having cankerous mouths will be the retribution.

To the hateful he says that being ugly and crippled will be the retribution.

To the stingy he says that not getting what they seek will be the retribution.

To gluttons he says that hunger, thirst and sicknesses of the throat will be the retribution.

To hunters he says that a frightening insanity that destroys one's life will be the retribution.

To those who oppose their parents he says that being killed in natural disasters will be the retribution.

To arsons who burn mountains and forests he says that trying to take one's own life in the confusion of insanity will be the retribution.

To cruel parents or step-parents, he says that being flogged in future lives will be the retribution.

To those who net and trap animals, he says that being separated from one's own relatives will be the retribution.

To those who slander the Triple Jewel he says that being blind, deaf, or mute will be the retribution.

To those who slight the Dharma and regard the teachings with arrogance, he says that remaining in the bad paths forever will be the retribution.

To those who destroy or misuse possessions of the Eternally Dwelling he says that revolving in the hells for billions of eons will be the retribution.

To those who defile the pure conduct of others and bear false witness against members of the Sangha he says that remaining in the animal realm forever will be the retribution.

To those who scald, burn, behead, maim, or otherwise harm beings he says that undergoing repayment in kind will be the retribution. To those who violate precepts and the regulations of pure eating he says that being born as birds or beasts that must suffer hunger and thirst will be the retribution.

To those who make unprincipled and destructive use of things he says that being unable to ever obtain what they seek will be the retribution.

To the arrogant and haughty he says that being servile and of low station will be the retribution.

To those who use back-biting to cause discord among others he says that being tongueless or having speech impediments will be the retribution.

To those with deviant views he says that being reborn in undeveloped regions will be the retribution.

"The bad habits involving body, mouth, and mind karma that beings of Jambudvipa perpetuate, result in hundreds of thousands of retributions like those. I have listed only a few examples here.

Since the karma created by beings of Jambudvipa calls forth different responses, Earth Store Bodhisattva uses hundreds of thousands of expedient means to teach and transform them.

Those beings must first undergo retributions such as those and then fall into the hells, where they pass through eons without being able to escape. You should therefore protect people and protect nations. Do not allow the accumulation of karma to confuse beings."

On hearing that, the Four Heavenly Kings wept in sorrow, placed their palms together, and withdrew.

End of Part One of Sutra of
the Past Vows of Earth Store Bodhisattva

Earth Store Bodhisattva

Part Two of Sutra of the Past Vows
of Earth Store Bodhisattva

CHAPTER V
Names of Hells

At that time Universal Worthy Bodhisattva, Mahasattva said to Earth Store Bodhisattva, "Humane One, for the sake of gods and dragons, those in the Fourfold Assembly, and all other beings of the present and future, please tell us the names of the hells where beings in the Saha world on the continent of Jambudvipa must suffer retributions for offenses they commit.

Please also describe what happens during retributions undergone for evil deeds so that beings in the future Dharma Ending Age will know what those retributions are."

Earth Store Bodhisattva replied, "Humane One, based on the awesome spiritual power of the Buddha and relying on your strength, Great Bodhisattva, I will give a general list of the names of hells and describe some of what happens during retributions undergone for offenses and evil deeds.

"Humane One, in Eastern Jambudvipa is mountain range called Iron Ring. The mountain is pitch black because the light of sun and moon do not shine on it. A great hell is located there named Ultimately Relentless. Another hell is called Great Avichi.

There is also a hell called Four Horns, a hell called Flying Knives, a hell called Fiery Arrows, a hell called Squeezing Mountains,

a hell called Piercing Spears, a hell called Iron Carts,
a hell called Iron Beds, a hell called Iron Oxen,
a hell called Iron Clothing, a hell called Thousand Blades,
a hell called Iron Asses, a hell called Molten Copper,
a hell called Embracing Pillar, a hell called Flowing Fire,
a hell called Plowing Tongues, a hell called Hacking Heads,
a hell called Burning Feet, a hell called Pecking Eyes,
a hell called Iron Pellets, a hell called Quarreling,
a hell called Iron Ax, and a hell called Massive Hatred."

Earth Store Bodhisattva said, "Humane One, within the Iron Ring are endless hells like that.

There is also the hell of Crying Out, the hell of Pulling Tongues,
the hell of Dung and Urine, the hell of Copper Locks,
the hell of Fire Elephants, the hell of Fire Dogs,
the hell of Fire Horses, the hell of Fire Oxen,
the hell of Fire Mountains, the hell of Fire Rocks,
the hell of Fire Beds, the hell of Fire Beams,
the hell of Fire Eagles, the hell of Sawing Teeth,
the hell of Flaying Skin, the hell of Drinking Blood,
the hell of Burning Hands, the hell of Burning Feet,
the hell of Hanging Hooks, the hell of Fire Rooms,
the hell of Iron Cells, and the hell of Fire Wolves.

"Each of those hells contains lesser hells numbering from one, or two, or three, or four, to hundreds of thousands. Each of those lesser hells has its own name."

Earth Store Bodhisattva told Universal Worthy Bodhisattva, "Humane One, such are the karmic responses of beings in Jambudvipa who commit evil deeds.

The power of karma is extremely great. It rivals Mount Sumeru in its heights. It surpasses the great oceans in its depth. It obstructs the path leading to Sagehood. For that reason, beings should never think that minor bad deeds are unimportant or assume that they do not count as offenses. After death there will be retributions to undergo that cover all those details.

Fathers and sons have the closest relationship, but their roads diverge and each must go his own way. Even if they met, neither would consent to undergo suffering in the other's place.

Now, based on the awesome spiritual power of the Buddha, I will describe some of the retributions for offenses that take place in the hells. Please, Humane One, listen for a moment to what I am going to say."

Universal Worthy replied, "I have long known of the retributions that happen in the Three Evil Paths. My hope in asking the Humane One to describe them is that when beings in the future Dharma Ending Age who are doing evil deeds hear the Humane One's descriptions they will be moved to take refuge with the Buddha."

Earth Store said, "Humane One, this is what happens during retributions in the hells. Offenders may go to a hell in which their tongues are stretched out and plowed through by cattle;
or to a hell in which their hearts pulled out and eaten by Yakshas;
or to a hell in which their bodies are cooked In cauldrons of boiling liquid;
or to a hell in which they are forced to embrace red-hot copper pillars;
or to a hell in which they are burned by fire that constantly pursues them;
or to a hell in which cold and Ice are all-pervasive;
or to a hell in which excrement and urine are endless;
or to a hell in which flying maces are unavoidable;
or to a hell in which fiery spears stab them repeatedly;
or to a hell in which they are constantly beaten on the chests and backs;
or to a hell in which their hands and feet are burned;
or to a hell in which they are bound by Iron snakes that coil around them;
or to a hell in which they are pursued by racing Iron dogs;
or to a hell in which their bodies are stretched by Iron mules.

"Humane One, to inflict these retributions in each hell hundreds of thousands of instruments made of copper, iron, stone, or fire arise from karmic force. Those four materials come into being in response to the kinds of karma offenders created.

If I were to explain in detail what happens during retributions in the hells, then I would need to tell of the hundreds of thousands of sufferings that must be undergone in each specific hell. How much more would that be the case for the sufferings in all the many hells!

Now, having based myself upon the awesome spiritual power of the Buddha, I have given a general answer to the Humane One's question, for if I were to speak in detail, it would take eons."

Earth Store Bodhisattva

CHAPTER VI
The Thus Come One's Praises

At that time the World Honored One emitted a great bright light from his entire body, totally illuminating Buddhalands as many as grains of sand in billions of Ganges Rivers.

His strong voice reached to all the Bodhisattvas, Mahasattvas in those Buddhalands, as well as to the gods, dragons, ghosts and spirits, humans, non-humans and others, saying, "Listen today, as I praise Earth Store Bodhisattva, Mahasattva, who displays an inconceivable awesome spiritual strength and compassionate power throughout the Ten Directions as he rescues and protects beings when things happen to them as they suffer for offenses they have committed.

After I pass into Nirvana, all of you Bodhisattvas, Mahasattvas and all of you gods, dragons, ghosts, spirits, and others should use vast numbers of expedient means to protect this Sutra and to cause all beings to realize the bliss of Nirvana."

After that was said a Bodhisattva named Universally Expansive arose in the assembly, placed his palms together respectfully, and said to the Buddha, "We are now about to witness the World Honored One praise Earth Store Bodhisattva's inconceivably great awesome spiritual virtue.

We hope the World Honored One will also aid beings in the future Dharma Ending Age by telling us about how Earth Store Bodhisattva benefits people and gods and about the working out of cause and effect. That will help the gods, dragons, and the rest of the Eightfold Division, along with beings of the future to receive the Buddha's teaching respectfully."

At that time the World Honored One said to the Bodhisattva Universally Expansive, to the Fourfold Assembly, and others, "Listen attentively, listen attentively. I will briefly describe to you how Earth Store Bodhisattva's virtuous deeds keep benefiting people and gods."

Universally Expansive replied, "Excellent, World Honored One. We are happy to listen."

The Buddha told the Bodhisattva Universally Expansive, "If, in the future, good men or good women who, upon hearing Earth Store Bodhisattva, Mahasattva's name, place their palms together, praise him, bow to him, or gaze in worship, they will overcome thirty eon's worth of offenses.

Universally Expansive, if good men or good women gaze upon and bow but once to painted or drawn images of the Bodhisattva or images made using clay, stone, lacquer, gold, silver, copper and iron, they will be reborn one hundred times in the Heaven of the Thirty-Three and will eternally avoid falling into the Evil Paths.

If their blessings in the heavens come to an end and they are born in the human realm, they will become national leaders who suffer no loss of benefits.

"There may be women who dislike having female bodies. Suppose they whole-heartedly make offerings to images of Earth Store Bodhisattva that are paintings or are made using clay, stone, lacquer, copper, iron, or other materials.

If they continually make such offerings day after day without fail, using flowers, incense, food, drink, clothing, colored silks, banners, money, jewels, and other items as offerings, when those good women finish their current female retributions, then throughout hundreds of thousands of eons they will never again be born in worlds where there are women, much less be one, unless it be through the strength of their compassionate vows to liberate beings.

Based on the strength of their offerings to Earth Store Bodhisattva and the power of their meritorious virtues, they will not be born into female bodies throughout hundreds of thousands of eons.

"Moreover, Universally Expansive, women who are ugly or prone to sickness will dislike those problems. If they gaze at and bow to images of Earth Store Bodhisattva with sincere resolve for even just a few minutes, then throughout millions of eons, they will always be born with full and perfect features.

If those woman who are ugly do not dislike having female bodies, then throughout billions of lives they will always be born as women of royal lineage, or will marry into royalty, or will become daughters of prime ministers, prominent families, or great Elders.

They will be of upright birth and full-featured. They will receive such blessings from having sincerely beheld and worshipped Earth Store Bodhisattva.

"Moreover, Universally Expansive, there may be good men or good women who are able to play music, sing, or chant praises, and make offerings of incense and flowers before images of the Bodhisattva or who are able to exhort one or more others to do likewise.

Now and in the future, such people will be surrounded day and night by hundreds of thousands of ghosts and spirits who will even prevent bad news from reaching their ears, much less allow them to be personally involved in any accidents.

"Moreover, Universally Expansive, in the future, evil people, evil spirits, or evil ghosts may see good men or good women taking refuge with, respectfully making offerings to, praising, beholding, and bowing to images of Earth Store Bodhisattva.

Those beings may make the mistake of ridiculing such acts of worship, saying that they are of no merit. They may sneer at those good people, condemn them behind their backs, or get a group or even one other person to have even as little as one thought of condemnation.

Such beings will fall into the Avichi Hell and the extreme misery they will undergo as retribution for their slander will not end even after the thousand Buddhas of the Worthy Eon have passed into tranquility.

Only after that eon will they be reborn among the hungry ghosts, where they will pass a thousand more eons before being reborn as animals. Only after another thousand eons will they obtain human bodies, but they will be poor and lowly with incomplete faculties, and their evil karma will cause them to suffer mental afflictions. Before long they will fall into the Evil Paths again.

Universally Expansive, such are the retributions that will undergo those who ridicule and slander others' acts of worship. How much worse will the retributions be if besides their slandering, they have other evils views.

"Moreover, Universally Expansive, in the future, men or women may be bedridden for years and in spite of their wishes be unable either to get well or to die. At night they may dream of evil ghosts, or of family and relatives, or of wandering on dangerous paths. In numerous nightmares they may roam with ghosts and spirits.

As days, months, and years go by, such people may weaken and waste away, cry out in pain in their sleep, and become progressively depressed and melancholy.

Those things happen when the force of karma has not yet been determined, which makes it difficult for them to die and impossible for them to be cured. The ordinary eyes of men and women cannot recognize such things.

"In that situation some people should recite this Sutra aloud once before images of the Buddhas and Bodhisattvas.

They should also offer possessions which those sick people cherish, such as clothing, jewels, gardens, or houses. They should speak distinctly to the sick people saying, 'Now before this Sutra or these images, we are offering these items on behalf of these sick people.' They may offer sutras or images, or commission images of Buddhas or Bodhisattvas, or build stupas or monasteries, or light oil lamps, or give to the Eternally Dwelling.

They should tell the sick people three times about the offerings that are being made, informing them so they both hear and understand what is being done.

"If their consciousnesses are already scattered and their breathing has stopped, then for one, two, three, four, and on through seven days, others should continue to inform them clearly and to read this Sutra aloud.

When those people's lives end, they will gain liberation from all heavy and disastrous offenses they committed in previous lives, even offenses warranting Fivefold Relentless Retribution. They will be born in places where they will always know past lives.

How much greater will the karmic reward be if good men or good women can write out this Sutra themselves or commission others to do so. If they can carve or paint images themselves or commission others to do so, the benefits they receive will be great indeed!

"Therefore, Universally Expansive, if you see people reading and reciting this Sutra or even having a single thought of praise for it, or if you meet someone who reveres it, you should employ hundreds of thousands of expedients to exhort such people to be diligent and not retreat.

In both the present and the future they will be able to obtain billions of inconceivable meritorious virtues.

"Moreover, Universally Expansive, beings in the future may, while dreaming or drowsy, see ghosts, spirits, and other forms that are either sad, weeping, or worried, fearful, or terrified.

Those are all fathers, mothers, sons, daughters, brothers, sisters, husbands, wives, and relatives from one, ten, a hundred, or a thousand lives past who have not yet been able to leave the bad destinies.

They have no place from which to hope for the power of blessings to rescue them, and so they try to communicate with their closest descendants, hoping that those relatives will use some skillful means to help them get out of the Evil Paths.

"Universally Expansive, using your spiritual powers, exhort those descendants to recite this Sutra with sincere resolve before the images of Buddhas or Bodhisattvas or to request others to recite it, either three or seven times.

When the Sutra has been read aloud the proper number of times, relatives in the Evil Paths will obtain liberation and never again be seen by those who are dreaming or drowsy.

"Moreover, Universally Expansive, people of low station, and those who are slaves, or who are bonded, or who are deprived of their freedom in other ways may be aware of their past deeds and wish to repent of them and to reform.

If while beholding and bowing to Earth Store Bodhisattva's image with sincere resolve for seven days they are able to recite his name a full ten thousand times, then when their current retribution ends, those people will always be born into wealth and honor for thousands lives. How much the more will they avoid any of the sufferings of the Three Evil Paths.

"Moreover, Universally Expansive, in the future in Jambudvipa when the wives of Kshatriyas, Brahmans, Elders, Upasakas, and those of other names and clans are about to give birth to sons or daughters, the family members should recite this inconceivable Sutra and recite the Bodhisattva's name a full ten thousand times during the seven days before the birth of their children.

If those infants, whether male or female, were destined to undergone a terrible retribution for things done in past lives, they will be liberated from those retributions. They will be peaceful, happy, easily raised, and will have long lives.

If those children were due to receive blessings, then their peace and happiness will increase, as will their lifespans.

"Moreover, Universally Expansive, on the first, eighth, fourteenth, fifteenth, eighteenth, twenty-third, twenty-fourth, twenty-eighth, twenty-ninth, and thirtieth days of the lunar month, the offenses of beings are tabulated and their gravity assessed.

"Every single movement or stirring of thought on the part of beings of Jambudvipa creates karma and offenses. How much more is that the case when they blatantly indulge in killing, stealing, sexual misconduct, false speech and hundreds of thousands of other kinds of overt offenses.

"If they are able to recite this Sutra once on those ten vegetarian days, before the images of Buddhas, Bodhisattvas, or worthy one and sages, then there will be no disasters for within a radius of one hundred yojanas.

The relatives of those who recite, both old and young, now and in the future, will be apart from the Evil Paths throughout hundreds of thousands of years.

If they can recite this sutra once on each of these ten vegetarian days, then there will be no accidents or illnesses in the family, and there will be food and clothing in abundance.

"Universally Expansive, you should know of the beneficial deeds done by Earth Store Bodhisattva as he makes use of his indescribably many billions of great awesome spiritual powers.

The beings of Jambudvipa have strong affinities with this Bodhisattva. If they hear the Bodhisattva's name, see the Bodhsattva's image, or hear but a few words, a verse, or sentence of this Sutra, then they will enjoy particularly wonderful peace and happiness in this present life.

Through hundreds of thousands of ten thousands of future lives, they will always be handsome or beautiful, and they will be born into honorable and wealthy families."

Having heard the Buddha, Thus Come One, praise Earth Store Bodhisattva in that way. Universally Expansive Bodhisattva knelt, placed his palms together, and again addressed the Buddha, saying, "World Honored One, I have long known that this Bodhisattva has both inconceivable spiritual powers and mighty vows. I have questioned the Thus Come One so that beings in the future will know of these benefits. I receive this answer most respectfully.

World Honored One, how should this Sutra be titled and how should we propagate it?"

The Buddha said to Universally Expansive, "This Sutra has three titles:
the first is The Past Vows of Earth Store Bodhisattva;
it is also called Earth Store's Past Conduct; and
it is called Sutra of the Power of Earth Store's Past Vows.

Because this Bodhisattva repeatedly makes such great and mighty vows throughout long eons to benefit beings, you should all propagate this Sutra in accord with his vows."

After Universally Expansive had heard that, he placed his palms together respectfully, made obeisance, and withdrew.

Earth Store Bodhisattva

CHAPTER VII
Benefiting the Living and the Dead

At that time Earth Store Bodhisattva, Mahasattva said to the Buddha, "World Honored One, I see that every single movement or stirring of thought on the part of beings of Jambudvipa is an offense. Beings tend to use up the wholesome benefits they gain; many of them end up retreating from their initial resolve. If they encounter evil conditions, they augment them with every thought.

They are like people trying to carry heavy rocks while walking through mud. Each step becomes more difficult and the rocks more cumbersome as their feet sink deeper. If they meet a mentor, he may be strong enough to lighten or even totally remove their burdens. Helping them thus, the mentor will urge them to step on solid ground, pointing out that once they reach a level place they should remain aware of that bad path and never traverse it again.

"World Honored One, the bad habits of beings range from minor to major. Since all beings have such habits, their parents or relatives should create blessings for them when they are on the verge of dying in order to assist them on the road ahead.

That may be done by hanging banners and canopies; lighting oil lamps; reciting the sacred Sutras; making offerings before the images of Buddhas or sages.

Another way to assist them is by reciting the names of Buddhas, Bodhisattvas, and Pratyekabuddhas so that the recitation of each name passes by the ear of the dying one and is heard in his fundamental consciousness.

"Suppose the evil karma created by beings were such that they should fall into the evil destinies. If their relatives cultivate wholesome causes on their behalf when they are close to death, then their manifold offenses can be dissolved.

If relatives can further do many good deeds during the first forty-nine days after the death of such beings, then the deceased can leave the evil destinies forever, be born as humans and gods, and receive supremely wonderful bliss. The surviving relatives will also receive limitless benefits.

"Therefore, before the Buddhas, World Honored Ones, as well as before the gods, dragons, and the rest of the Eightfold Division, humans and non-humans, I now exhort beings of Jambudvipa to be careful to avoid harming, killing, and doing other unwholesome deeds; to refrain from worshipping ghosts and spirits or making sacrifices to them; and to never call on mountain sprites on the day of death.

Why is that?

"Killing, harming, and making sacrifices are not the least bit helpful to the deceased. Such acts only bind up the conditions of offenses so that they grow ever more deep and heavy.

The deceased might have been due to increase his potential for Sagehood or gain birth among humans or gods in his next life or in the future. But when his family commits offenses in his name, he will resent the disasters he inherits, and his good rebirth will be delayed.

How much more would that be the case for people on the verge of death who during their lives had planted few good roots. Each offender has to undergo the bad destinies according to his own karma. How could anyone bear to have relatives add to that karma?

"That would be like having a neighbor add a few more things to a load of over a hundred pounds being carried by someone who had already traveled a long distance and who had not eaten for three days. By adding that extra weight, that person's burden would become even more unbearable.

"World Honored One, I see that beings of Jambudvipa will themselves receive the benefit of any good deeds they are able to do within the Buddha's teaching. That holds true even when the deeds are as small as a strand of hair, a drop of water, a grain of sand, or a mote of dust."

After that had been said, an Elder named Great Eloquence arose in the assembly. He had long since realized Non-production and was only appearing in the body of an Elder to teach and transform those in the Ten Directions.

Placing his palms together respectfully, he asked Earth Store Bodhisattva, "Great Lord, after people in Jambudvipa die and their close and distant relatives generate merit by making meal offerings and doing other such good deeds, will the deceased obtain merit and virtue significant enough to bring about their liberation?

Earth Store replied, "Elder, based on the awesome power of the Buddhas, I will now proclaim this principle for the sake of beings of the present and future.

Elder, if beings of the present and future when on the verge of dying hear the name of one Buddha, one Bodhisattva, or one Pratyekabuddha, they will attain liberation whether they have offenses or not.

"When men or women laden with offenses who failed to plant good causes die, even they can receive one-seventh of any merit dedicated to them by relatives who do good deeds on their behalf. The other six-sevenths of the merit will return to the living relatives who did the good deeds.

It follows that men and women of the present and future who cultivate while they are strong and healthy will receive every portion of the benefit derived."

"The arrival of the Great Ghost of Impermanence is so unexpected that the deceased ones' consciousnesses first roam in darkness and obscurity, unaware of offenses and blessings.

For forty-nine days they are as if deluded or deaf, or as if in courts where their karmic retributions are being decided. Once judgment is fixed, rebirths are undergone according to their karma.

In the time before rebirths are determined, the deceased suffer thousands of myriads of concerns. How much more is that the case for those who are to fall into the bad destinies.

"Throughout forty-nine days those whose lives have ended and who have not yet been reborn will be hoping every moment that their immediate relatives will earn blessings powerful enough to rescue them.

At the end of that time the deceased will undergo retribution according to their karma. If someone is an offender, he may pass through hundreds of thousands of years without even a day's liberation.

If someone's offenses deserve Fivefold Relentless Retribution, he will fall into the great hells and undergo incessant suffering throughout hundreds of thousands of eons."

"Moreover, Elder, when beings who have committed karmic offenses die, their relatives may prepare vegetarian offerings to aid them on their karmic paths.

In the process of preparing the vegetarian meal and before it has been eaten, rice-washing water and vegetable leaves should not be thrown on the ground. Before the food is offered to the Buddhas and Sangha no one should eat it.

If there is laxness or transgression in this matter, then the deceased will receive no strength from it.

If purity is vigorously maintained in making the offering to the Buddhas and Sangha, the deceased will receive one-seventh of the merit.

Therefore, Elder, by performing vegetarian offerings on behalf of deceased fathers, mothers, and other relatives while making earnest supplication on their behalf, beings of Jambudvipa benefit both the living and the dead."

After that was said, hundreds of thousands of millions of nayutas of ghosts and spirits of Jambudvipa who were in the palace of the Trayastrimsha Heaven, made the unlimited resolve to attain Bodhi.

The Elder Great Eloquence made obeisance and withdrew.

Earth Store Bodhisattva

CHAPTER VIII
Praises of King Yama and His Followers

At that time from within the Iron Ring Mountain, Lord Yama and his following of infinite ghost kings came before the Buddha in the Trayastrimsha Heaven. They were

the Ghost King Evil Poison, the Ghost King Many Evils,
the Ghost King Great Argument, the Ghost King White Tiger,
the Ghost King Blood Tiger, the Ghost King Crimson Tiger,
the Ghost King Spreading Disaster, the Ghost King Flying Body,
the Ghost King Lightning Flash, the Ghost King Wolf Tooth,
the Ghost King Thousand Eyes, the Ghost King Animal Eater,
the Ghost King Rock Bearer, the Ghost King Lord of Bad News,
the Ghost King Lord of Calamities, the Ghost King Lord of Food,
the Ghost King Lord of Wealth, the Ghost King Lord of Domestic Animals,
the Ghost King Lord of Birds, the Ghost King Lord of Beasts,
the Ghost King Lord of Mountain Sprites, the Ghost King Lord of Birth,
the Ghost King Lord of Life, the Ghost King Lord of Sickness,
the Ghost King Lord of Danger, the Ghost King Three Eyes,
the Ghost King Four Eyes, the Ghost King Five Eyes,
the Ch'i Li Shih King, the Great Ch'i Li Shih King,
the Ch'i Li Ch'a King, the Great Ch'i Li Ch'a King,
the No Ch'a King, the Great No Ch'a King,
and other such great ghost kings.

With them were hundreds of thousands of minor ghost kings who dwelt throughout Jambudvipa; each presiding over certain jurisdictions.

Aided by the Buddha's awesome spiritual strength and the power of Earth Store Bodhisattva, Mahasattva all these ghost kings joined Lord Yama in the Trayastrimsha Heaven and together they stood to one side.

Then Lord Yama knelt down, placed his palms together, and said to the Buddha, "World Honored One, aided by the Buddha's awesome spiritual strength and the power of Earth Store Bodhisattva, I have been able to come to this great assembly in the Trayastrimsha Heaven, with all these ghost kings and, to our benefit, join in together.

There is now a small doubt that I should like to express, and we hope the World Honored One will be compassionate and resolve it."

The Buddha told Lord Yama, "I will answer whatever you want to ask."

At that time Lord Yama looked respectfully at the World Honored One, made obeisance, turned his head to acknowledge Earth Store Bodhisattva, and then said to the Buddha, "World Honored One, I observe that Earth Store Bodhisattva uses hundreds of thousands of expedient means to take across beings who are suffering for their offenses within the Six Paths of rebirth. I see that he does so unstintingly, without the least fatigue.

Although this Great Bodhisattva uses his inconceivable spiritual penetrations to do such deeds, it doesn't take long for the beings whom he has helped in gaining release from retributions to fall again into the bad paths.

"World Honored One, since Earth Store Bodhisattva has such great inconceivable spiritual power, why are beings not able to rely on it, to stay in the good paths, and to be freed once and for all?

Please, World Honored One, explain that for us."

The Buddha told Lord Yama, "The beings of Jambudvipa have stubborn and obstinate natures, difficult to tame, difficult to subdue.

This Great Bodhisattva continually rescues such beings throughout hundreds of thousands of eons and causes them to obtain liberation quickly.

For those beings undergoing retributions even in the worst destinies, the Bodhisattva applies the strength of expedients to extricate them from their own basic karmic conditions and lead them to understand the events of their past lives.

But because beings of Jambudvipa are so bound by their own heavy bad habits, they keep revolving in and out of the various paths over and over as this Bodhisattva labors throughout many long eons to entirely effect their rescue and release.

"They are like people who in confusion, lost their way home and took a bad road by mistake. On that treacherous road were many Yakshas, tigers, wolves, lions, serpents, and vipers.

Those confused people were sure to be harmed in an instant on that dangerous path.

But then they met a knowledgeable guide, skilled in neutralizing all harm, including the toxins of the Yakshas and others.

The mentor began to guide the travelers off that road and told them, 'Beware, everyone! What business brought you onto this road? What kinds of special skills do you have to avoid all that harm?'

Hearing that, the confused travelers realized they were on a dangerous path and turned back, attempting to escape.

"The kind guide then told them to join hands, led them off the dangerous path, and helped them avoid the deadly peril. When they reached a safe path, the travelers grew happy and at peace.

Their mentor then said to them. 'Take care, confused ones, never to go back into that road again. Once on it, it is hard to get off; it can destroy a person's very nature and life.'

The travelers who had been confused expressed their deep gratitude and as they were about to part the mentor said to them, 'If you see any other travelers, whether you know them personally or not, be they men or women, tell them that the poisons and evils on that path could harm their natures and lives. Do not allow them to unwittingly bring about their own deaths.'

In the same way, Earth Store Bodhisattva, replete with great compassion, rescues beings who are suffering for their offenses and enables them to be born among humans and gods where they enjoy wonderful bliss.

"Once those offenders obtain release from the suffering they experienced in the paths where their karma took them, they should never go down those roads again.

They are like the lost people who mistakenly took a wrong road and were lead off it by a kind mentor. They now know to never take that road again.

Moreover, they exhort others not to enter that road by saying, 'We took that road ourselves when we got confused, but we escaped and now we know better than to ever enter that road again. If we were to set foot on it again, we would get confused and be unable to recognize it as the dangerous path we descended into before. That being the case, we might lose our lives.'

The same holds true for falling into the bad destinies. Due to the powerful expedient means of Earth Store Bodhisattva, beings can be freed and can gain rebirth as humans or gods.

If they were to then turn around and enter into the bad destinies again, then those with heavy karmic bonds might remain in the hells forever with no chance of escape."

At that time the Ghost King Evil Poison placed his palms together respectfully, addressed the Buddha, and said, "World Honored One, each of us countless ghost kings of Jambudvipa bestows benefit or inflicts harm on beings differently. But our karmic retributions are such that we and our followers roam in the world doing much evil and little good.

When we pass a household, a city, a town, a garden, a cottage or a hut where there are men or women who have cultivated as little as a hair's worth of good deeds, who have hung but one banner or one canopy, who have used a little incense or a few flowers as offerings to images of Buddhas or Bodhisattvas, or who have recited the sacred Sutras or burned incense as an offering to even one sentence or gatha in them, we ghost kings will respect such people as we would the Buddhas of the past, present, and future.

We will instruct the smaller ghosts, each of whom has great power, as well as the earth spirits, to protect such people. Bad situations, accidents, severe or unexpected illnesses, and all other unwelcome events will not even come near their residences or other places they may be, much less enter the door."

The Buddha praised the ghost kings, "Excellent, excellent, that all of you ghost kings join Lord Yama in protecting good men and women in that way. I shall tell Lord Brahma and Lord Shakra to see that you are protected as well."

When that was said, a ghost king in the assembly named Lord of Life said to the Buddha, "World Honored One, my karmic conditions are such that I have jurisdiction over the lifespans of people in Jambudvipa, governing both the time of their births and their deaths.

My fundamental vows are based on a great desire to benefit them, but people do not understand my intent and go through birth and death in distress. Why is that?

"When women in Jambudvipa have just borne children, be they boys or girls, or when they are just about to give birth, good deeds should be done to increase the benefits of the household, thus causing the local earth spirits to be immeasurably pleased. The spirits will then protect the mother and child so that they experience peace and happiness; they will bring benefit to the entire family.

After the birth, all killing for the purpose of offering fresh meat to the mother should be carefully avoided, as should parties that involve consumption of alcohol, eating of meat, singing, and playing musical instruments. All those things can keep the mother and child from being peaceful and happy. Why is that?

At the difficult time of birth, uncountable evil ghosts, including mountain sprites, goblins, and spirit-beings, desire to eat the strong-smelling blood. I quickly order the local earth spirits of that household to protect the mother and child, allowing them to be peaceful and happy and to receive other benefits.

When people in such households witness those benefits, they should do meritorious deeds to express their gratitude to the earth spirits. If instead, they harm and kill, and have big parties involving feasting and entertainment, then the retributions that result from such offenses will be born by they themselves and will bring harm to the mother and child as well.

"Moreover, when people of Jambudvipa are on the verge of death, I wish to keep them from falling into the Evil Paths, regardless of whether they have done good or evil.

But how much is this power of mine to help them increased when they have personally cultivated good roots!

When those who do good in Jambudvipa are about to die, hundreds of thousands of ghosts and spirits from the Evil Paths transform themselves and appear as the parents or other relatives in an attempt to lead such people to fall into the Evil Paths.

How much more is that the case for those who have done evil deeds!

"World Honored One, when men or women in Jambudvipa are on the verge of death, their consciousnesses and spirits become confused and dark. They are unable to discriminate between good and evil, and their eyes and ears are unable to see or hear.

That is why relatives of those deceased should make generous offerings, recite the sacred Sutras, and recite the names of Buddhas and Bodhisattvas. Such good conditions can cause the deceased to leave the Evil Paths, and all the demons, ghosts, and spirits will withdraw and disperse.

"World Honored One, if at the time of death beings of any kind have an opportunity to hear the name of one Buddha or Bodhisattva or to hear a sentence or gatha of a Mahayana Sutra, I observe that such beings can quickly be freed from the pull of their accumulated minor bad deeds that would otherwise send them to the bad paths.

The exception to that is crimes involving killing that warrant Fivefold Relentless Retribution."

The Buddha told the Ghost King Lord of Life, "Because of your great compassion, you are able to make such great vows and protect all beings in the midst of life and death.

When men or women in the future undergo birth and death, do not withdraw from your vow, but liberate them all so they gain eternal peace."

The ghost king told the Buddha, "Please do not be concerned. Until the end of my life I shall in every thought protect beings of Jambudvipa both at the time of birth and at the time of death, so that they all gain tranquility. I only wish that at the time of birth and of death they will believe what I say, so that they all can be liberated and gain many benefits."

At that time the Buddha told Earth Store Bodhisattva, "This great Ghost King Lord of Life has already passed through hundreds of thousands of lives as a ghost king, protecting beings during both birth and death. Only because of this Great Being's compassionate vows does he appear in the body of a ghost, for in reality he is not a ghost.

After one hundred seventy eons have passed, he will become a Buddha named No Appearance Thus Come One. His eon will be called Happiness, and his world will be named Pure Dwelling. That Buddha's lifespan will be incalculable eons.

Earth Store, the circumstances surrounding this great ghost king are thus. They are inconceivable, and the people and gods whom he takes across are countless."

Earth Store Bodhisattva

CHAPTER IX
The Names of Buddhas

At that time, Earth Store Bodhisattva, Mahasattva said to the Buddha, "World Honored One, I want to discuss some practices that will be helpful to beings of the future and will enable them to gain great benefit throughout their lives and deaths. World Honored One, please hear my words."

The Buddha told Earth Store Bodhisattva, "Now with your expansive compassion you wish to discuss the inconceivable events involved in rescuing all those in the Six Paths who are suffering for their offenses. This is the right time. Speak now, since my Nirvana is near, so that I may soon help you complete your vows. Then I too will have no need to be concerned about beings of the present or future."

Earth Store Bodhisattva said to the Buddha, "World Honored One, countless Asamkhyeya eons ago a Buddha named Boundless Body Thus Come One appeared in the world.

If men or women hear this Buddha's name and have a momentary thought of respect, those people will overstep the heavy offenses involved in birth and death for forty eons. How much more will that be the case for those who sculpt or paint this Buddha's image or praise and make offerings to him. The merit they obtain will be limitless and unbounded.

"Furthermore, in the past as many eons ago as there are grains of sand in the Ganges River, a Buddha named Jewel Nature Thus Come One appeared in the world.

If men or women hear this Buddha's name and instantly decide to take refuge, those people will never retreat from the Unsurpassed Path.

"Furthermore, in the past a Buddha named Padma Supreme Thus Come One appeared in the world. If men or women hear this Buddha's name or if the sound of the name merely passes into their ears, those people will be reborn one thousand times in the Six Desire Heavens. How much more will that be the case if those people sincerely recite the name of that Thus Come One.

"Furthermore, in the past inexpressibly ineffable Asamkhyeya eons ago, a Buddha named Lion's Roar Thus Come One appeared in the world. If men or women hear this Buddha's name and in a single thought take refuge, those people will encounter numberless Buddhas who will rub the crowns of their heads and bestow predictions of enlightenment upon them.

"Furthermore, in the past a Buddha named Krakucchanda appeared in the world. If men or women hear this Buddha's name and sincerely behold, worship, or praise him, those people will become Great Brahma Heaven kings in the assemblies of the thousand Buddhas of the Worthy Eon and will there receive superior predictions.

"Furthermore, in the past a Buddha named Vipashin appeared in the world. If men or women hear this Buddha's name, those people will eternally avoid falling into the Evil Paths, will always be born among people or gods, and will abide in supremely wonderful bliss.

"Furthermore, in the past as many eons ago as there are grains of sand in limitless and countless Ganges Rivers, a Buddha named Jewel Supreme appeared in the world. If men or women hear this Buddha's name, those people will never fall into the Evil Paths and will always abide in the heavens experiencing supremely wonderful bliss.

"Furthermore, in the past a Buddha named Jeweled Appearance Thus Come One appeared in the world. If men or women hear this Buddha's name and give rise to a thought of respect, those people will soon attain the fruitions of Arhatship.

"Furthermore, limitless Asamkhyeya eons ago, a Buddha named Kashaya Banner Thus Come One appeared in the world. If men or women hear this Buddha's name, those people will overcome the offenses of birth and death for one hundred great eons.

"Furthermore, in the past a Buddha named Great Penetration Mountain King Thus Come One appeared in the world. If men or women hear this Buddha's name, those people will encounter as many Buddhas as there are grains of sand in the Ganges, who will speak Dharma extensively for them, making certain that they realize Bodhi.

"Furthermore, in the past there were Buddhas named Pure Moon Buddha, Mountain King Buddha, Wise Victory Buddha, Pure Name King Buddha, Accomplished Wisdom Buddha, Unsurpassed Buddha, Wonderful Sound Buddha, Full Moon Buddha,

Moon-Face Buddha, and indescribably many other Buddhas.

"World Honored One, beings of the present and future, both gods and humans, both male and female, can amass such limitless merit and virtue by reciting only one Buddha's name. How much more merit will they amass by reciting many names.

Those beings will personally obtain benefits in their lives and deaths significant enough to keep them from ever falling into the Evil Paths.

"When people are on the verge of dying, a group of their relatives, or even just one of them, should recite Buddhas' names aloud for the people who are sick. By doing so, the karmic retributions of those people who are about to die will be dissolved, even offenses deserving Fivefold Relentless Retribution.

Offenses warranting Fivefold Relentless Retribution are so extremely heavy that those who commit them should not escape retribution for millions of eons. If, however, at the time of such offenders' deaths, someone recites the names of Buddhas on their behalf, then their offenses can gradually be dissolved.

How much more will that be the case for beings who recited those names themselves. The merit they attain will be limitless and will eradicate measureless offenses."

End of Part Two of Sutra of
the Past Vows of Earth Store Bodhisattva

Earth Store Bodhisattva

Part Three of Sutra of
the Past Vows of Earth Store Bodhisattva

CHAPTER X
The Conditions and Comparative Merits and Virtues of Giving

At that time. Earth Store Bodhisattva, Mahasattva, based on the Buddha's awesome spiritual strength, arose from his seat, knelt on one knee, placed his palms together and said to the Buddha, "World Honored One, I have observed beings within the paths of karma and compared their acts of giving. Some do a little and some do a lot. Some receive blessings for one life, some for ten lives, and some receive great blessings and benefits for hundreds or thousands of lives. Why is that? Please, World Honored One, explain that for us."

At that time the Buddha told Earth Store Bodhisattva, "Here in this assembly in the palace of the Trayastrimsha Heaven, I will now discuss the comparative merit and virtue derived from acts of giving done by the beings in Jambudvipa. Listen attentively to what I say."

Earth Store said to the Buddha, "I have wondered about this matter and will be pleased to listen."

The Buddha told Earth Store Bodhisattva, "In Jambudvipa, leaders of nations, prime ministers, high officials, great Elders, great Ksatriyas, great Brahmans, and others may encounter those who are poor,

hunchbacked, crippled, dumb, mute, deaf, retarded, blind or handicapped in other ways.

Those leaders and good people may wish to give to those people and may be able to do so with great compassion, a humble heart, and a smile. They may arrange to give generously, either personally with their own hands, or by arranging for others to do so, using gentle words and sympathetic speech.

The blessings and benefits that such leaders and good people will accrue will be comparable to the meritorious virtues derived from giving to as many Buddhas as there are grains of sand in a hundred Ganges Rivers. Why is that?

Those leaders and good people will receive such rewards of blessings and benefits for having shown a great compassionate heart toward the most impoverished and handicapped individuals.

Throughout hundreds of thousands of lives to come they will always have an abundance of the seven gems, not to mention clothing, food, and the necessities of life.

"Moreover, Earth Store, in the future the leaders of nations, Brahmans, and others may encounter Buddhist stupas, monasteries, or images of Buddhas, Bodhisattvas, Sound-hearers, or Pratyekabuddhas and personally make offerings or give gifts to them.

From doing that, those leaders and good people will serve as Lord Shakra for a duration of three eons, enjoying supremely wonderful bliss.

If they are able to transfer the blessings and benefits of that giving and dedicate it to the Dharma Realm, then those leaders of nations and good people will reign as great Brahma Heaven kings for ten eons.

"Moreover, Earth Store, in the future leaders of nations, Brahmans, and others may, upon encountering ancient Buddhist stupas and monasteries or sutras and images that are damaged, decaying, or broken, resolve to restore them.

Those leaders and good people may then do so themselves or encourage others, as many as hundreds of thousands of people to help and thereby establish affinities.

Those leaders and good people will become Wheel-Turning Kings for hundreds of thousands of successive lives and those who made offerings with them will be leaders of small nations for as many lives.

If, before the stupas or monasteries, they resolve to dedicate that merit, then, based on that limitless and unbounded reward, those leaders, good people, and their helpers will eventually all complete the path to Buddhahood.

"Moreover, Earth Store, in the future, leaders of nations, Brahmans, and others may have compassionate thoughts upon seeing the old, the sick, or women in child birth, and may provide them with medicinal herbs, food, drink, and bedding so as to make them peaceful and comfortable.

The blessings and benefits derived from doing that are quite inconceivable. For one hundred eons they will always be lords of the Pure Dwelling Heavens, for two hundred eons they will be lords in the Six Desire Heavens, and they will ultimately attain Buddhahood. They will never fall into the Evil Paths, and for hundreds of thousands of lives they will hear no sounds of suffering.

"Moreover, Earth Store, if in the future, leaders of nations, Brahmans, and others can give in that way, they will receive limitless blessings.

"If they are in addition, able to dedicate that merit, be it great or small, they will ultimately attain Buddhahood. How much more easily will they be able to attain the rewards of becoming Shakra, Brahma, or a Wheel-Turning King.

Therefore, Earth Store, you should urge beings everywhere to learn to give in those ways.

"Moreover, Earth Store, in the future if good men or good women only manage to plant a few good roots within the Buddhadharma, equivalent to no more than a strand of hair, a grain of sand, or a mote of dust, they will receive incomparable blessings and benefits.

"Moreover, Earth Store, good men or women in the future may, upon encountering images of Buddhas, Bodhisattvas, Pratyekabuddhas, or Wheel-Turning Kings, give gifts or make offerings to them.

Such persons will attain limitless blessings and will always enjoy supremely wonderful bliss among people and gods.

If they can dedicate that merit to the Dharma Realm, their blessings and benefits will be beyond compare.

"Moreover, Earth Store, good men or good women in the future may, upon encountering Great Vehicle sutras or upon hearing but a single gatha or a sentence, be inspired to praise, venerate, give gifts, and make offerings to them.

Those people will attain great limitless and unbounded rewards. If they can dedicate that merit to the Dharma Realm, their blessings will be beyond compare.

"Moreover, Earth Store, in the future, good men or good women may, upon encountering new Buddhist stupas, monasteries, or sutras of the Great Vehicle, give gifts and make offerings to them, gaze at them in worship, and respectfully make praises with joined palms.

They may, upon encountering old ones or those that have been destroyed or damaged, either do the repairing or rebuilding themselves or encourage others to help them.

Those who help will become leaders of small nations throughout thirty successive lives. The donors themselves will always be Wheel-Turning Kings who will use the good Dharma to teach and transform those leaders of small nations.

"Moreover, Earth Store, in the future, good men or good women may plant good roots in the Buddhadharma by giving, making offerings, repairing stupas or monasteries, rebinding sutras, or doing other good deeds amounting to no more than a strand of hair, a mote of dust, a grain of sand, or a drop of water. Merely by transferring the merit from such deeds to the Dharma Realm, those people's meritorious virtues will enable them to enjoy superior and wonderful bliss for hundreds of thousands of lives.

If they dedicate the merit only to their immediate or extended families or to their own personal benefit, then the rewards received will be only three lives of happiness. By giving up one, a ten-thousandfold reward is obtained.

"So it is. Earth Store. The circumstances involved in the causes and conditions of giving are like that."

Earth Store Bodhisattva

CHAPTER XI
The Dharma Protection of an Earth Spirit

At that time the Earth Spirit Firm and Stable spoke to the Buddha and said, "World Honored One, from long ago I have personally beheld and bowed to limitless numbers of Bodhisattvas, Mahasattvas. All of them have inconceivable and great spiritual penetrations and wisdom that they use in taking vast numbers of beings across. Among all the Bodhisattvas, Earth Store Bodhisattva, Mahasattva has the deepest and most weighty vows.

"World Honored One, Earth Store Bodhisattva has great affinities in Jambudvipa. Manjushri, Samantabhadra, Avalokiteshvara, and Maitreya, also produce by transformation, hundreds of thousands of bodies to take across those in the Six Paths, but their vows have an end.

Earth Store Bodhisattva has made these vows to teach and transform beings in the Six Paths throughout eons as many as the number of sand grains in hundreds of thousands of millions of Ganges Rivers.

"World Honored One, as I regard beings of the present and future, I see those who make shrines of clay, stone, bamboo, or wood and set them on pure ground in the southern part of their dwellings. They place within the shrines images of Earth Store Bodhisattva, either sculpted, painted, or made of gold, silver, copper, or iron. They then light incense, make offerings, behold, worship, and praise him.

By doing those things, such people will receive ten kinds of benefits.

"What are those ten?
First, their lands will be fertile.
Second, their families and homes will always be peaceful.
Third, their ancestors will be born in the heavens.
Fourth, those of the current generation will enjoy benefits and long lives.
Fifth, they will easily obtain what they want.
Sixth, they will not encounter disasters of water and fire.
Seventh, they will avoid unforeseen calamities.
Eighth, they will never have nightmares.
Ninth, they will be protected by spirits in their daily comings and goings.
Tenth, they will encounter many causes that pertain to Sagehood.

World Honored One, beings of the present and future who make offerings in their homes in the prescribed manner will attain benefits like those."

He further said to the Buddha, "World Honored One, good men or good women in the future may keep this Sutra and an image of the Bodhisattva where they live. Further, they may recite the Sutra and make offerings to the Bodhisattva.

For those who do that, I shall constantly use my own spiritual powers to guard and protect them day and night so that nothing bad happens to them, including floods, fire, robbery and theft, major disasters, and minor accidents."

The Buddha told the Earth Spirit Firm and Stable, "There are few spirits who can match your great spiritual power. Why do I say that?

"All the lands in Jambudvipa receive your protection. All the grasses, woods, sands, stones, paddy fields, hemp, bamboo, reeds, grains, rice, and gems come forth from the earth because of your power.

Moreover, your constant praising of the beneficial deeds of Earth Store Bodhisattva makes your meritorious virtues and spiritual penetrations hundreds of thousands of times those of ordinary earth spirits.

"If good men or good women in the future make offerings to this Bodhisattva, or recite the Sutra of the Past Vows of Earth Store Bodhisattva and rely upon even a single aspect of it in their cultivation, you should use your own spiritual powers to protect them. Do not allow any disasters or unwelcome events even to be heard, much less undergone, by them.

Not only will those people be protected by you, they will also be protected by the followers of Shakra, Brahma, and other gods. Why will they receive protection from sages and worthies such as those?

It will be due to their having beheld and worshipped an image of Earth Store Bodhisattva and from having recited this Sutra of his past vows. Such people will quite naturally be able to leave the sea of suffering and ultimately be certified to the bliss of Nirvana. For those reasons they receive great protection."

Earth Store Bodhisattva

CHAPTER XII
Benefits Derived from Seeing and Hearing

At that time the World Honored One emitted hundreds of thousands of millions of great rays of light from the opening at the crown of his head. They were
the White Ray, the Great White Ray,
the Auspicious Ray, the Great Auspicious Ray,
the Jade Ray, the Great Jade Ray,
the Purple Ray, the Great Purple Ray,
the Blue Ray, the Great Blue Ray,
the Azure Ray, the Great Azure Ray,
the Red Ray, the Great Red Ray,
the Green Ray, the Great Green Ray,
the Gold Ray, the Great Gold Ray,
the Celebration Cloud Ray, the Great Celebration Cloud Ray,
the Thousand-wheeled Ray, the Great Thousand-wheeled Ray,
the Jeweled Wheel Ray, the Great Jeweled Wheel Ray,
the Solar Disc Ray, the Great Solar Disc Ray,
the Lunar Disc Ray, the Great Lunar Disc Ray,
the Palace Ray, the Great Palace Ray,
the Ocean Cloud Ray, and the Great Ocean Cloud Ray.

After emitting such rays of light from the opening at the crown of his head, he spoke in subtle and wonderful sounds to the great assembly of gods, dragons, the rest of the Eightfold Division, humans, non-humans and others, "Hear me today in the palace of the Trayastrimsha Heaven as I praise Earth Store Bodhisattva, telling of his beneficial deeds, of inconceivable events, of the matter of his transcendence to Sagehood, of the circumstances of his certification to the Tenth Ground, and of the situation leading to his being irreversible from Anuttarasamyaksambodhi."

As that was said, a Bodhisattva, Mahasattva named Contemplator of the World's Sounds arose from his seat in the assembly, knelt on one knee, and with palms together said to the Buddha, "World Honored One, Earth Store Bodhisattva, Mahasattva is replete with great compassion and pities beings who are suffering for their offenses.

In thousands of millions of worlds he creates thousands of millions of transformation bodies through the strength of his meritorious virtues and inconceivable awesome spiritual strength.

I have heard the World Honored One and the numberless of Buddhas of the Ten Directions praise Earth Store Bodhisattva with different mouths but in unison, saying that even if all the Buddhas of the past, present, and future were to speak of his meritorious qualities, they could never finish describing them.

Upon hearing the World Honored One tell the great assembly that he now wants to praise Earth Store Bodhisattva's beneficial deeds and so forth, I am beseeching the World Honored One to praise the inconceivable events pertaining to Earth Store Bodhisattva for the sake of beings of the present and future and to cause the gods, dragons, and the rest of the Eightfold Division to gaze in worship and attain blessings."

The Buddha replied to the Bodhisattva Contemplator of the World's Sounds, "You have great affinity with the Saha World. If gods, dragons, men, women, spirits, ghosts, or any other beings who are suffering for offenses within the Six Paths hear your name, see your image, behold you, or praise you, they will definitely become irreversible on the Unsurpassed Way.

They will always be born among people and gods and there experience wonderful bliss. When the effects of their causes come to maturity, they will encounter Buddhas who will give them predictions.

You now are replete with great compassion and pity for beings, for gods, dragons, and the rest of the Eightfold Division. Listen as I discuss events involving the inconceivable benefits bestowed by Earth Store Bodhisattva. Listen attentively, I will describe them for you."

The Contemplator of the World's Sounds said, "So be it. World Honored One, I will be pleased to hear."

The Buddha told the Bodhisattva Contemplator of the World's Sounds, "In worlds of the present and future, gods whose heavenly blessings are ending may be manifesting the Five Signs of Decay, indications that they may be about to fall into Evil Paths.

When those signs appear, if those gods, whether male or female, see Earth Store Bodhisattva's image or hear his name and gaze at him or bow once to him, their heavenly blessings will thereby increase. They will experience great happiness and will never have to undergo retributions in the Three Evil Paths.

How much more will that be the case for those who upon seeing and hearing the Bodhisattva use incense, flowers, clothing, food, drink, jewels, and necklaces as gifts and offerings to him. The meritorious virtues, blessings, and benefits they gain will be limitless and unbounded.

"Moreover, Contemplator of the World's Sounds, in the worlds in the present and future, when beings in the Six Paths are on the verge of death, if they can hear the name of Earth Store Bodhisattva, even the sound of it passing through their ears only once, such beings will never have to endure the sufferings of the Three Evil Paths again.

"How much more will that be the case if the parents and other relatives use the houses, wealth, property, jewels, and clothing of such people who are on the verge of death to commission the carving or painting of images of Earth Store Bodhisattva.

"If those sick people have not yet died, their relatives can try to help them see, hear, and understand that their houses, jewels, and so forth have been used for the carving or painting of images of Earth Store Bodhisattva.

If those people's karmic retributions were such that they should have to undergo severe sickness, then with such merit they can quickly be cured and their lifespans prolonged.

If those people's retributions send them to the evil destinies at death due to their karma and obstacles, then with such merit they can, when their lives end, be born among people or gods and there enjoy extremely wonderful bliss. All their obstacles due to offenses will dissolve.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future men or women may have lost their fathers, mothers, brothers, or sisters while still an infant or as a child of three, or five, or under ten years of age.

As adults, such people may think about those parents and other relatives, not knowing into what paths or worlds or heavens they have been born.

Suppose such people are able to sculpt or paint images of Earth Store Bodhisattva or to gaze upon and worship him once or for one through seven days without retreating. Upon hearing his name and seeing his image they gaze in worship and make offerings.

"If such people's relatives had fallen into bad paths and were destined to remain there for many eons, those relatives will quickly gain release, be born among people or gods, and experience supremely wonderful bliss.

That will happen because of the meritorious virtue generated by their sons, daughters, brothers, or sisters who carved or painted images of Earth Store Bodhisattva and then gazed upon and worshipped them.

If such people's relatives had already been born among people or gods on the strength of their own blessings and were already experiencing supremely wonderful bliss, then upon receiving that additional merit, their causes leading to Sagehood will increase, and they will experience limitless bliss.

"If such people are able to behold and worship images of Earth Store Bodhisattva single-mindedly during three weeks, reciting his name a full ten thousand times, the Bodhisattva may then manifest a boundless body and describe to those people the realms into which their relatives have been born. Or in their dreams the Bodhisattva may manifest great spiritual power and personally lead them to those worlds to see their relatives.

"If they can further recite the Bodhisattva's name one thousand times a day every day for one thousand days, the Bodhisattva will send the ghosts and earth spirits in the vicinity of such people to guard and protect them for their entire lives.

In this world their clothing and food will be abundant and they will have no suffering from sickness or other causes. No accidents will occur in their households, much less affect them personally. Finally, the Bodhisattva will rub the crowns of their heads and bestow predictions upon them.

"Moreover, Contemplator of the World's Sounds Bodhisattva, good men or good women in the future may want to practice great compassion in rescuing and taking across beings. They may want to cultivate unsurpassed Bodhi, and may want to leave the Triple World.

Those people may see Earth Store Bodhisattva's image, hear his name, and in their hearts take refuge with him. They may use incense, flowers, clothing, jewels, food and drink to make offerings while beholding and worshipping him. Such good people's wishes will quickly be realized and they will never have any further obstructions.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future, good men and women may want to fulfill hundreds of thousands of millions of vows and to succeed in as many undertakings in both the present and future.

They need only take refuge with, gaze upon, worship, make offerings to, and praise images of Earth Store Bodhisattva. In such a way, their vows and goals can all be realized.

Moreover, they may hope that Earth Store Bodhisattva, being endowed with great compassion, will always protect them. In dreams the Bodhisattva will rub the crowns of their heads and bestow predictions upon them.

"Moreover, Contemplator of the World's Sounds Bodhisattva, good men and women in the future may have high regard for the Great Vehicle Sutras and make the inconceivable resolve to read them and to recite them from memory.

They may then encounter a bright master who instructs them so that they may become familiar with the texts. But as soon as they learn them, they forget them. They may try for months or years and yet still be unable to read or recite them from memory.

Because those good men and good women have karmic obstructions from past lives that have not yet been resolved, they are unable to read and memorize Sutras of the Great Vehicle.

"Upon hearing Earth Store Bodhisattva's name or seeing his image, such people should, with deep respect and honesty, state their situation to the Bodhisattva.

In addition, they should use incense, flowers, clothing, food and drink, and other material objects they enjoy to make offerings to the Bodhisattva.

They should place a bowl of pure water before the Bodhisattva for one day and one night.

Afterwards, placing their palms together, they should state their request and then, while facing south, prepare to drink the water. As the water is about to enter their mouths they should be particularly sincere and solemn.

After drinking the water they should abstain from the five pungent plants, wine, meat, improper sexual activity, false speech, and all killing and harming for one to three weeks.

"In dreams those good men and good women may then see Earth Store Bodhisattva manifesting a boundless body and anointing the crowns of their heads with water.

When they awaken they may be endowed with keen intelligence.

Upon hearing this Sutra but one time, they will eternally remember it and never forget or lose a single sentence or verse.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future there may be people whose food and clothing are insufficient, who find their efforts thwarted, who endure much sickness or misfortune, whose families are not peaceful, whose relatives are scattered, who are accident prone, or who are often startled in their sleep by dreams.

Upon hearing Earth Store's name and seeing his image, such people should recite his name a full ten thousand times with extreme sincerity and respect. Those inauspicious circumstances will gradually disappear, and they will gain peace and happiness. Their food and clothing will be abundant and even in their dreams they will be peaceful and happy.

"Moreover, Contemplator of the World's Sounds Bodhisattva, in the future, good men or good women may have to enter mountain forests, cross over rivers, seas, or other large bodies of water, or take dangerous routes either for the sake of earning their own livelihood, or for public or personal affairs, or matters of life and death, or other urgent business.

Such people should first recite the name of Earth Store Bodhisattva a full ten thousand times. The ghosts and spirits of the lands they pass through will then guard and protect them in their walking, standing, sitting, and lying down.

The peace and happiness of those people will constantly be preserved, so that even if they encounter tigers, wolves, lions, or any other harmful or poisonous creatures, they will not be harmed."

The Buddha told the Contemplator of the World's Sounds Bodhisattva, "Earth Store Bodhisattva has great affinities with beings in Jambudvipa. Hundreds of thousands of eons would not be time enough to describe the benefits derived by beings who see this Bodhisattva and hear his name.

"Therefore, Contemplator of the World's Sounds Bodhisattva, you should use your spiritual powers to propagate this Sutra, thus enabling beings in the Saha World to receive peace and happiness always, throughout hundreds of thousands of eons."

At that time the World Honored One spoke verses, saying:

I observe that Earth Store's awesome spiritual strength, Could not be fully described even in Ganges sands' eons. Seeing, hearing, beholding and bowing to him even once Benefits people and gods in endless numbers of ways.

Men and women, gods or dragons who are near the end Of their rewards and on the verge of falling into Evil Paths, Can, by sincerely taking refuge with this Great Being, Have their lifespans lengthened; their offenses dissolved.

Sometimes youngsters lose their kind and loving parents And do not know what paths they took. Quite often lost brothers, sisters, and other kin Were never known by their surviving relatives.

If such people sculpt or paint this Bodhisattva's image And then beseech, behold and bow to him intently, And if they hold his name in mind a full three weeks The Bodhisattva may display a boundless body.

He may reveal the realms where relatives were born And even quickly free those in bad destinies. If those praying can sustain their initial resolve, He may rub their heads and predict their Sagehood.

Since those determined to cultivate unsurpassed Bodhi And escape the suffering here in the Triple World, Have already discovered their great compassionate hearts, They should first behold and bow to this Great Being. Then every vow they make will soon be fulfilled And no karmic obstructions will ever hinder or stop them.

Some people may resolve to read the sutra texts Hoping to help those confused to reach the other shore. Although the vows they make are quite remarkable, Try as they may, they cannot remember what they read.

Because of their karmic obstructions and delusions, Those people cannot memorize the Mahayana sutras. But they can offer scents and flowers to Earth Store. They can give him clothing, food, and other things they like.

They can place pure water on an altar to the Bodhisattva, And leave it there a day and night before they drink it. With diligent intent they should abstain from pungent plants, Alcohol, meat, improper sex and false speech.

For three weeks they should not kill or harm any creature, While being mindful of the name of that Great Being. Then suddenly in a dream their vision may become boundless. Awakening, they may discover that they now have keen hearing.

From then on, once they hear the teachings of the sutras, They will never forget them throughout thousands of lives. How inconceivable this Bodhisattva is In helping people like that gain such wisdom!

Beings may be impoverished or plagued with disease, Their homes may be troubled; their relatives scattered. They may find no peace even in sleep or dreams. Their efforts may be thwarted so that nothing goes their way.

But if they earnestly behold and bow to Earth Store's image All those evil situations will simply disappear. And even their dreams will be totally peaceful. Food and clothes will be ample; spirits and ghosts protective.

People may need to enter mountain forests, cross great seas, Or go among venomous or evil birds and beasts, evil people, Evil spirits, evil ghosts, and even evil winds Or put themselves in other distressing situations.

They need only gaze in worship and make offerings To an image of the Great Being, Earth Store Bodhisattva. In response, all the evils in those mountain forests And on those vast seas will simply disappear.

Contemplator of Sounds, listen well to what I say. Earth Store Bodhisattva is an unending wonder! Hundreds of thousands of eons is time too brief To describe fully the powers of this Great Being.

If people can but hear the name "Earth Store," And when seeing his image revere him and bow in worship, And offer incense, flowers, clothing, food, and drink, Those gifts will bring them hundreds of thousands of joys.

If they can dedicate such merit to the Dharma Realm, They will become Buddhas, transcending birth and death. Contemplator of Sounds, know this well, And tell everyone everywhere in lands like Ganges sands."

Earth Store Bodhisattva

CHAPTER XIII
The Entrustment of People and Gods

At that time the World Honored One extended his gold-colored arm, and again rubbed the crown of the head of Earth Store Bodhisattva while saying, "Earth Store, Earth Store, your spiritual powers, compassion, wisdom, and eloquence are inconceivable.

Even if all the Buddhas of the Ten Directions were to proclaim their praise of your inconceivable deeds, they could not finish in thousands eons.

"Earth Store, Earth Store, remember this entrustment that I am again making here in the Trayastrimsha Heaven in this great assembly of hundreds of thousands of millions of indescribably many Buddhas, Bodhisattvas, gods, dragons, and the rest of the Eightfold Division.

I again entrust to you the gods, people, and others who are still in the burning house and have not yet left the Triple World.

Do not allow those beings to fall into the evil destinies even for a single day and night, much less fall into the Fivefold Relentless Hell or the Avichi Hell, where they would have to pass through thousands of millions of eons with no chance of escape.

"Earth Store, the beings of southern Jambudvipa have irresolute wills and natures. They habitually do many evil deeds. Even if they resolve to do good, they soon renounce that resolve. If they encounter evil conditions, they tend to become increasingly involved in them.

For those reasons I reduplicate hundreds of thousands of millions of bodies to transform beings, take them across, and liberate them, all in accord with their own fundamental natures.

"Earth Store, I now earnestly entrust the multitudes of gods and people to you.

If in the future among gods and people there are good men or good women who plant a few good roots in the Buddhadharma, be they as few as a strand of hair, a mote of dust, a grain of sand, or a drop of water, then you should use your powers in the Way to protect them so that they gradually cultivate the Unsurpassed Way and do not get lost or retreat from it.

"Moreover, Earth Store, in the future, gods or people, according to the responses of their karmic retributions, may be due to fall into the evil destinies. They may be on the brink of falling or may already be at the very gates to those paths.

But if they can recite the name of one Buddha or Bodhisattva or a single sentence or verse of a Great Vehicle Sutra, then you should use your spiritual powers to rescue them with expedient means.

Display a boundless body in the places where they are, smash the hells, and lead them to be born in the heavens and to experience supremely wonderful bliss."

At that time the World Honored One spoke in verse, saying

I am entrusting to your care the multitudes
Of gods and people both now and in the future.
Use great spiritual powers and expedients to save them.
Do not allow them to fall into the evil destinies.

At that time Earth Store Bodhisattva, Mahasattva, knelt on one knee, placed his palms together, and said to the Buddha, "World Honored One, I beg the World Honored One not to be concerned.

In the future if good men and women have a single thought of respect toward the Buddhadharma, I shall use hundreds of thousands of expedients to take them across and free them. They will quickly be liberated from birth and death.

How much more will that be the case for those who, having heard about all these good matters, are inspired to cultivate. They will naturally become irreversible from the Unsurpassed Way."

After he finished speaking, a Bodhisattva named Empty Space Treasury, who was in the assembly, spoke to the Buddha, "World Honored One, I personally have come to the Trayastrimsha Heaven and have heard the Thus Come One praise Earth Store Bodhisattva's awesome spiritual strength, saying that it is inconceivable.

If in the future, good men, good women, gods, and dragons hear this Sutra and the name of Earth Store Bodhisattva and if they behold and bow to his image, how many kinds of blessings and benefits will they obtain?

Please, World Honored One, say a few words about this for the sake of beings of the present and future."

The Buddha told Empty Space Treasury Bodhisattva, "Listen attentively, listen attentively, I shall enumerate them and describe them to you.

"Good men or women in the future may see images of Earth Store Bodhisattva and hear this Sutra or read or recite it. They may use incense, flowers, food and drink, clothing, and gems to give gifts and make offerings. They may praise, behold and bow to him. Such beings will benefit in twenty-eight ways:

First, they will be protected by gods and dragons.
Second, their good roots will increase daily.
Third, they will amass supreme causes pertaining to Sagehood.
Fourth, they will not retreat from Bodhi.
Fifth, their clothing and food will be abundant.
Sixth, they will never be infected by epidemics.
Seventh, they will never be in disasters of fire and water.
Eighth, they will never be threatened by thieves.
Ninth, they will be respected by all who see them.
Tenth, they will be aided by ghosts and spirits.
Eleventh, women who want to can be reborn as men.
Twelfth, women who want to can be daughters of leaders of nations and officials.
Thirteenth, they will have an upright and proper appearance.
Fourteenth, they will often be born in the heavens.
Fifteenth, they may be emperors or leaders of nations.
Sixteenth, they will have the wisdom to know past lives.
Seventeenth, they will attain whatever they seek.
Eighteenth, their families will be happy.
Nineteenth, they will never undergo any disasters.
Twentieth, they will leave the bad karmic paths forever.
Twenty-first, they will always arrive at their destination.
Twenty-second, their dreams will be peaceful and happy.
Twenty-third, their deceased relatives will leave suffering behind.
Twenty-fourth, they will enjoy blessings earned in previous lives.
Twenty-fifth, they will be praised by sages.
Twenty-sixth, they will be intelligent and have keen faculties.
Twenty-seventh, they will be magnanimous and empathic.
Twenty-eighth, they will ultimately realize Buddhahood.

"Moreover, Empty Space Treasury Bodhisattva, if gods, dragons, or spirits of the present or future hear Earth Store's name, bow to Earth Store's image, or hear of Earth Store's past vows and the events of his practices, and then praise him, behold, and bow to him, they will benefit in seven ways:

First, they will quickly transcend to levels of Sagehood.
Second, their evil karma will dissolve.
Third, all Buddhas will protect and be near them.
Fourth, they will not retreat from Bodhi.
Fifth, their inherent powers will increase.
Sixth, they will know past lives.
Seventh, they will ultimately realize Buddhahood."

At that time, all the indescribable, indescribable, numbers of Buddhas, Thus Come Ones who had come from the Ten Directions, and Great Bodhisattvas, gods, dragons and the rest of the Eightfold Division, having heard Shakyamuni Buddha's praise of Earth Store Bodhisattva's great awesome spiritual powers, praised this unprecedented event.

Following that, incense, flowers, heavenly garments, and pearl necklaces rained down in the Trayastrimsha Heaven as offerings to Shakyamuni Buddha and Earth Store Bodhisattva, and everyone in the assembly joined together in beholding and making obeisance to them. Then they placed their palms together and withdrew.

End of Part Three of
Sutra of the Past Vows of Earth Store Bodhisattva