New Page 1

此网页使用了框架，但您的浏览器不支持框架。


稱讚淨土佛攝受經

大正藏No. 367 [No. 366]

稱讚淨土佛攝受經

        大唐三藏法師玄奘奉　詔譯

如是我聞。一時薄伽梵。在室羅筏住誓多林給孤獨園。與大苾芻眾千二百五十人俱。一切皆是尊宿聲聞。眾望所識。大阿羅漢。其名曰尊者舍利子。摩訶目犍連。摩訶迦葉。阿泥律陀。如是等諸大聲聞而為上首。復與無量菩薩摩訶薩俱。一切皆住不退轉位。無量功德眾所莊嚴。其名曰妙吉祥菩薩。無能勝菩薩。常精進菩薩。不休息菩薩。如是等諸大菩薩而為上首。復有帝釋大梵天王。堪忍界主。護世四王。如是上首。百千俱胝那庾多數諸天子眾。及餘世間無量天人。阿素洛等。為聞法故。俱來會坐

爾時世尊告舍利子。汝今知不。於是西方去此世界。過百千俱胝那庾多佛土。有佛世界名曰極樂。其中世尊名無量壽及無量光如來應正等覺。十號圓滿。今現在彼安隱住持。為諸有情宣說甚深微妙之法。令得殊勝利益安樂

又舍利子。何因何緣。彼佛世界名為極樂。舍利子。由彼界中諸有情類無有一切身心憂苦。唯有無量清淨喜樂。是故名為極樂世界。又舍利子。極樂世界淨佛土中處處皆有七重行列妙寶欄楯七重行列寶多羅樹。及有七重妙寶羅網。周匝圍繞四寶莊嚴。金寶銀寶。吠琉璃寶。頗胝迦寶。妙飾間綺。舍利子。彼佛土中有如是等眾妙綺飾功德莊嚴。甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。處處皆有七妙寶池。八功德水彌滿其中。何等名為八功德水。一者澄淨。二者清冷。三者甘美。四者輕軟。五者潤澤。六者安和。七者飲時除飢渴等無量過患。八者飲已定能長養諸根四大。增益種種殊勝善根。多福眾生常樂受用。是諸寶池底布金沙。四面周匝有四階道。四寶莊嚴甚可愛樂。諸池周匝有妙寶樹。間飾行列香氣芬馥。七寶莊嚴甚可愛樂。言七寶者。一金。二銀。三吠琉璃。四頗胝迦。五赤真珠。六阿濕摩揭拉婆寶。七牟娑落揭拉婆寶。是諸池中。常有種種雜色蓮華。量如車輪。青形青顯青光青影。黃形黃顯黃光黃影。赤形赤顯赤光赤影。白形白顯白光白影。四形四顯四光四影。舍利子。彼佛土中。有如是等眾妙綺飾。功德莊嚴甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。自然常有無量無邊眾妙伎樂。音曲和雅甚可愛樂。諸有情類聞斯妙音。諸惡煩惱悉皆消滅。無量善法漸次增長。速證無上正等菩提。舍利子。彼佛土中。有如是等眾妙綺飾。功德莊嚴甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。周遍大地真金合成。其觸柔軟香潔光明。無量無邊妙寶間飾。舍利子。彼佛土中。有如是等眾妙綺飾。功德莊嚴甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。晝夜六時。常雨種種上妙天華。光澤香潔細軟雜色。雖令見者身心適悅。而不貪著。增長有情無量無數不可思議殊勝功德。彼有情類晝夜六時。常持供養無量壽佛。每晨朝時持此天華。於一食頃。飛至他方無量世界。供養百千俱胝諸佛。於諸佛所。各以百千俱胝樹花。持散供養。還至本處。遊天住等。舍利子。彼佛土中。有如是等眾妙綺飾。功德莊嚴甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。常有種種奇妙可愛雜色眾鳥。所謂鵝鴈鶖鷺。鴻鶴孔雀。鸚鵡羯羅頻迦。命命鳥等。如是眾鳥。晝夜六時恒共集會。出和雅聲。隨其類音宣揚妙法。所謂甚深念住正斷。神足根力。覺道支等。無量妙法。彼土眾生聞是聲已。各得念佛念法念僧。無量功德熏修其身。汝舍利子。於意云何。彼土眾鳥。豈是傍生惡趣攝耶。勿作是見。所以者何。彼佛淨土無三惡道。尚不聞有三惡趣名。何況有實罪業所招傍生眾鳥。當知皆是無量壽佛變化所作。令其宣暢無量法音。作諸有情利益安樂。舍利子。彼佛土中有如是等眾妙綺飾。功德莊嚴甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。常有妙風。吹諸寶樹及寶羅網。出微妙音。譬如百千俱胝天樂同時俱作。出微妙聲甚可愛玩。如是彼土常有妙風。吹眾寶樹及寶羅網。擊出種種微妙音聲。說種種法。彼土眾生聞是聲已。起佛法僧念作意等無量功德。舍利子。彼佛土中有如是等眾妙綺飾。功德莊嚴甚可愛樂。是故名為極樂世界

又舍利子極樂世界淨佛土中。有如是等無量無邊不可思議甚希有事。假使經於百千俱胝那庾多劫。以其無量百千俱胝那庾多舌。一一舌上出無量聲。讚其功德亦不能盡。是故名為極樂世界

又舍利子。極樂世界淨佛土中。佛有何緣名無量壽。舍利子。由彼如來及諸有情壽命無量無數大劫。由是緣故。彼土如來名無量壽。舍利子。無量壽佛證得阿耨多羅三藐三菩提已來。經十大劫。舍利子。何緣彼佛名無量光。舍利子。由彼如來恒放無量無邊妙光。遍照一切十方佛土。施作佛事無有障礙。由是緣故。彼土如來名無量光。舍利子。彼佛淨土成就如是功德莊嚴。甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。無量壽佛常有無量聲聞弟子。一切皆是大阿羅漢。具足種種微妙功德。其量無邊不可稱數。舍利子。彼佛淨土成就如是功德莊嚴。甚可愛樂。是故名為極樂世界

又舍利子。極樂世界淨佛土中。無量壽佛常有無量菩薩弟子。一切皆是一生所繫。具足種種微妙功德。其量無邊不可稱數。假使經於無數量劫。讚其功德終不能盡。舍利子。彼佛土中。成就如是功德莊嚴。甚可愛樂。是故名為極樂世界

又舍利子。若諸有情生彼土者。皆不退轉。必不復墮諸險惡趣邊地下賤蔑戾車中。常遊諸佛清淨國土。殊勝行願念念增進。決定當證阿耨多羅三藐三菩提。舍利子。彼佛土中。成就如是功德莊嚴。甚可愛樂。是故名為極樂世界

又舍利子。若諸有情聞彼西方無量壽佛清淨佛土無量功德眾所莊嚴。皆應發願生彼佛土。所以者何。若生彼土。得與如是無量功德眾所莊嚴。諸大士等同一集會。受用如是無量功德。眾所莊嚴清淨佛土。大乘法樂常無退轉。無量行願念念增進。速證無上正等菩提故。舍利子。生彼佛土諸有情類。成就無量無邊功德。非少善根諸有情類當得往生無量壽佛極樂世界清淨佛土

又舍利子。若有淨信諸善男子或善女人。得聞如是無量壽佛無量無邊不可思議功德名號極樂世界功德莊嚴。聞已思惟。若一日夜。或二或三。或四或五。或六或七。繫念不亂。是善男子或善女人。臨命終時。無量壽佛與其無量聲聞弟子菩薩眾俱。前後圍繞來住其前。慈悲加祐令心不亂。既捨命已隨佛眾會。生無量壽極樂世界清淨佛土

又舍利子。我觀如是利益安樂大事因緣。說誠諦語。若有淨信諸善男子或善女人。得聞如是無量壽佛不可思議功德名號極樂世界淨佛土者。一切皆應信受發願。如說修行生彼佛土

又舍利子。如我今者稱揚讚歎無量壽佛無量無邊不可思議佛土功德。如是東方亦有現在不動如來。山幢如來。大山如來。山光如來。妙幢如來。如是等佛如殑伽沙住在東方。自佛淨土各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是南方亦有現在日月光如來。名稱光如來。大光蘊如來。迷盧光如來。無邊精進如來。如是等佛如殑伽沙住在南方。自佛淨土各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是西方亦有現在無量壽如來。無量蘊如來。無量光如來。無量幢如來。大自在如來。大光如來。光焰如來。大寶幢如來。放光如來。如是等佛如殑伽沙住在西方。自佛淨土各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是北方亦有現在無量光嚴通達覺慧如來。無量天鼓震大妙音如來。大蘊如來。光網如來。娑羅帝王如來。如是等佛如殑伽沙住在北方。自佛淨土各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是下方亦有現在示現一切妙法正理常放火王勝德光明如來。師子如來。名稱如來。譽光如來。正法如來。妙法如來。法幢如來。功德友如來。功德號如來。如是等佛如殑伽沙。住在下方自佛淨土。各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是上方。亦有現在梵音如來。宿王如來。香光如來。如紅蓮華勝德如來。示現一切義利如來。如是等佛如殑伽沙。住在上方自佛淨土。各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是東南方。亦有現在最上廣大雲雷音王如來。如是等佛如殑伽沙。住東南方自佛淨土。各各示現廣長舌相。遍覆三千大千世界。周匝圍繞說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是西南方。亦有現在最上日光名稱功德如來。如是等佛如殑伽沙。住西南方自佛淨土。各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是西北方。亦有現在無量功德火王光明如來。如是等佛如殑伽沙。住西北方自佛淨土。各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。如是東北方。亦有現在無數百千俱胝廣慧如來。如是等佛如殑伽沙。住東北方自佛淨土。各各示現廣長舌相。遍覆三千大千世界。周匝圍繞。說誠諦言。汝等有情。皆應信受如是稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。何緣此經。名為稱讚不可思議佛土功德一切諸佛攝受法門。舍利子。由此經中。稱揚讚歎無量壽佛極樂世界不可思議佛土功德。及十方面諸佛世尊。為欲方便利益安樂諸有情故。各住本土。現大神變。說誠諦言。勸諸有情信受此法。是故此經。名為稱讚不可思議佛土功德一切諸佛攝受法門

又舍利子。若善男子或善女人。或已得聞。或當得聞。或今得聞。聞是經已深生信解。生信解已。必為如是住十方面。十殑伽沙諸佛世尊之所攝受。如說行者。一切定於阿耨多羅三藐三菩提。得不退轉。一切定生無量壽佛極樂世界清淨佛土。是故舍利子。汝等有情。一切皆應信受領解。我及十方佛世尊語。當勤精進如說修行。勿生疑慮

又舍利子。若善男子或善女人。於無量壽極樂世界清淨佛土。功德莊嚴。若已發願。若當發願。若今發願。必為如是住十方面。十殑伽沙諸佛世尊之所攝受。如說行者。一切定於阿耨多羅三藐三菩提。得不退轉。一切定生無量壽佛極樂世界清淨佛土。是故舍利子。若有淨信諸善男子或善女人。一切皆應於無量壽極樂世界清淨佛土。深心信解。發願往生。勿行放逸

又舍利子。如我今者稱揚讚歎無量壽佛極樂世界不可思議佛土功德。彼十方面諸佛世尊。亦稱讚我不可思議無邊功德。皆作是言。甚奇希有。釋迦寂靜。釋迦法王如來應正等覺明行圓滿善逝世間解無上丈夫調御士天人師佛世尊。乃能於是堪忍世界。五濁惡時。所謂劫濁。諸有情濁。諸煩惱濁。見濁。命濁。於中證得阿耨多羅三藐三菩提。為欲方便利益安樂諸有情故。說是世間極難信法。是故舍利子。當知我今於此雜染堪忍世界五濁惡時。證得阿耨多羅三藐三菩提。為欲方便利益安樂諸有情故。說是世間極難信法。甚為希有不可思議

又舍利子。於此雜染堪忍世界五濁惡時。若有淨信諸善男子或善女人。聞說如是一切世間極難信法。能生信解。受持演說。如教修行當知是人。甚為希有。無量佛所曾種善根。是人命終。定生西方極樂世界。受用種種功德莊嚴清淨佛土大乘法樂。日夜六時。親近供養無量壽佛。遊歷十方供養諸佛。於諸佛所聞法受記。福慧資糧疾得圓滿。速證無上正等菩提。時薄伽梵說是經已。尊者舍利子等。諸大聲聞。及諸菩薩摩訶薩眾。無量天人阿素洛等。一切大眾聞佛所說。皆大歡喜信受奉行

稱讚淨土佛攝受經


The Sutra On Praise Of The Pure Land And Protection By Shakyamuni Translated on Imperial order in Chinese by Tripitaka Master

The Sutra On
Praise Of The Pure Land And Protection By Shakyamuni

Translated on Imperial order in Chinese
by Tripitaka Master Hsuan-Tsang
of Great T'ang Dynasty

Translated from Chinese by Hisao Inagaki

[1] Thus have I heard. At one time the Bhagavat was staying in Jeta Grove monastery in Anathapindada's Garden at Shravasti, together with a large company of twelve hundred and fifty monks, who were all venerable shravakas and well-known great arhats. They were headed by eminent shravakas, such as the Venerable Shariputra, Mahamaudgalyayana, Mahakashyapa and Aniruddha. He was also accompanied by innumerable bodhisattvas, mahasattvas, who were all dwelling in the Stage of Non-retrogression and were adorned with immeasurable merits and virtues, headed by great bodhisattvas, such as Bodhisattva Manjushri, Bodhisattva Ajita, Bodhisattva Nityodyukta and Bodhisattva Aniksipta-dhura. Also in the assembly were a hundred thousand kotis of nayutas [of devas] headed by Shakra along with the King of Mahabrahma Heaven, the Lord of Saha world, as well as the Four Guardian Kings and others. Many demi-gods, innumerable heavenly and human beings, asuras and others assembled and took their seats to hear the Dharma.

[2] The Bhagavat said to Shariputra: "Do you know that if you travel westward from here, passing a hundred thousand kotis of nayutas of Buddha-lands, you come to the land called 'Utmost Bliss,' where there is a Bhagavat named 'Amitayus' or 'Amitabha' with ten titles, including Tathagata, Arhat and Samyaksambuddha. He is living there at this very moment, teaching the profound and wonderful Dharma to sentient beings to give them supreme benefit and bliss.

[3] "Why, Shariputra, is that land called 'Utmost Bliss'? Shariputra, beings in that land suffer no afflictions and pain but experience only pure immeasurable joy and happiness. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, in the pure Buddha-land of Utmost Bliss there are seven rows of jewelled balustrades, seven rows of jewelled tala-trees, and sevenfold jewelled nets, which surround everywhere and are completely decorated with four jewels, namely, gold, silver, beryl and crystal. Shariputra, that Buddha-land is full of such glorious adornments of supreme qualities, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'

"Again, Shariputra, in the pure Buddha-land of Utmost Bliss here and there are many seven-jewelled ponds filled with water of eight excellent qualities, namely, (1) pure, (2) cool, (3) sweet-tasting, (4) soft, (5) moistening, (6) comforting, (7) quenching thirst, hunger and many other needs, and (8) nourishing the senses, increasing the activities of the four elements and producing superior goodness. Sentient beings with a large stock of merits always enjoy using such water. The bottom of these ponds is lined with gold sand, and from the four sides of each pond rise stairs made of the four jewels, most pleasing to the mind. Marvelous jewelled trees surrounding the ponds are evenly spaced, scented with rich fragrance and decorated with the seven delightful jewels, namely, gold, silver, beryl, crystal, rosy pearls, carnelian and sapphire.
"In the ponds, at all times, lotuses of various colors as large as chariot-wheels are in bloom. Blue flowers radiate blue light, brilliance and splendor; yellow ones radiate yellow light, brilliance and splendor; red ones radiate red light, brilliance and splendor; white ones radiate white light, brilliance and splendor; four-colored ones radiate four-colored light, brilliance and splendor. Shariputra, that Buddha-land is full of such glorious adornments of supreme qualities, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, in that pure Buddha-land of Utmost Bliss limitless exquisite music is spontaneously played at all times. The sound is harmonious and most pleasant to hear. When sentient beings hear its excellent sound, their evil passions are completely removed, numerous good acts multiply, and they soon attain the highest perfect Enlightenment. Shariputra, that Buddha-land is full of such glorious adornments of supreme qualities, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, the ground throughout that pure Buddha-land of Utmost Bliss is of true gold. It is soft to the touch and refreshing, shining boundlessly and adorned with rare jewels. Shariputra, that Buddha-land is full of such glorious adornments of supreme qualities, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, in that pure Buddha-land of Utmost Bliss, six times during the day and night, various heavenly blossoms of rare beauty continuously rain down from the sky. They are brilliant and refreshing, soft and variegated, pleasing to the mind and the senses. They do not rouse greedy attachment, but increase countless inconceivable merits in sentient beings. Six times during the day and night, the beings in that land offer those blossoms to Amitayus in homage. Every morning they take those heavenly blossoms and, in such a short time it takes for a meal, fly to innumerable other lands to pay homage to a hundred, thousand kotis of Buddhas. They offer to each Buddha a hundred thousand kotis of such blossoms and return home to the Pure Land, as if to enjoy leisure in a heavenly abode. Shariputra, that Buddha-land is full of such glorious adornments of supreme qualities, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, in that pure Buddha-land of Utmost Bliss there are always many rare species of beautiful birds of various colors, such as swans, geese, herons, storks, cranes, peacocks, parrots, kalavinkas and jivamjivakas. Six times during the day and night, those birds form a flock and sing with melodious and delicate tones, producing diverse sounds to proclaim numerous wonderful teachings, such as the [four] mindful acts, the [four] ways of stopping evils, the [four] miraculous powers, the [five] roots of goodness, the [five] powers, the [seven] factors of wisdom, and the [Eightfold] Noble Path. Having heard their singing, the sentient beings in that land gain innumerable merits through mindfulness of the Buddha, Dharma and Sangha, and their bodies long retain the perfume of virtue. Shariputra, do you think that the birds in that land belong to the evil realm of animals? Do not hold such a view! The reason is that none of the three evil realms, not even their names, exist in that Buddha's Pure Land; how much less should there be real birds belonging to the realm of animals born as retribution for evil karma? You should know that they are manifestations created by Amitayus so that they can proclaim innumerable sounds of the Dharma to give benefit and bliss to sentient beings. Shariputra, that Buddha-land is full of such wonderful glorious adornments, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, in that pure Buddha-land of Utmost Bliss soft breezes always blow. When they waft through the jewelled trees and jewelled nets, wonderful sounds are produced. As if a hundred thousand kotis of celestial musical instruments were playing together to produce exquisite sounds, when soft breezes which constantly arise in that land waft through the jewelled trees and jewelled nets, they produce various excellent sounds, which proclaim many teachings of the Dharma. Having heard those sounds, sentient beings in that land give rise to numerous meritorious acts, such as mindfulness of the Buddha, Dharma and Sangha. Shariputra, that Buddha-land is full of such glorious adornments of supreme qualities, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Shariputra, in that pure Buddha-land of Utmost Bliss there are wonderful manifestations such as those, which are innumerable and inconceivable. Even if a hundred thousand kotis of nayutas of innumerable tongues should praise their excellent qualities for a hundred thousand kotis of nayutas of kalpas, each tongue producing immeasurable voices, they would not be able to praise them to the full. For this reason, [that land] is called the Land of Utmost Bliss.

[4] "Again, Shariputra, why is the Buddha of the pure Buddha-land of Utmost Bliss called 'Amitayus'? Because, Shariputra, the life-span of that Tathagata and all beings living there last for immeasurable and innumerable great kalpas, the Tathagata of that land is called 'Amitayus.' Shariputra, why is the Buddha also called 'Amitabha'? Shariputra, the Tathagata always emits boundless and innumerable rays of glorious light, illuminating all the Buddha-lands of the ten directions without hindrance, so as to display Buddhist activities. For this reason, the Tathagata of that land is called 'Amitabha.' Shariputra, the Pure Land of that Buddha is full of such glorious adornments, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, the Buddha Amitayus of that pure Buddha-land of Utmost Bliss always has shravaka disciples, all of them arhats, who are possessed of various excellent merits and whose number is unlimited and incalculable. Shariputra, the Pure Land of that Buddha is full of such glorious adornments, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, the Buddha Amitayus of that pure Buddha-land of Utmost Bliss always has innumerable bodhisattva disciples, all of them in the Stage of Becoming a Buddha after One More Life. They are possessed of various excellent merits, and their number is unlimited and incalculable. Even if one praised their merits for innumerable kalpas, one would not be able to praise them fully. Shariputra, that Buddha-land is filled with such glorious adornments, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'

[5] "Again, Shariputra, sentient beings born in that land all dwell in the Stage of Non-retrogression, and will not fall again into an evil realm, be born in a border-land or in the state of debased people or mlecchas. They always enjoy visiting pure lands of other Buddhas. With their excellent vows and practice advancing and developing every moment, they will unfailingly realize the highest, perfect Enlightenment. Shariputra, that Buddha-land is full of such glorious merits, which are most pleasing to the mind. For this reason, that land is called 'Utmost Bliss.'
"Again, Shariputra, if sentient beings hear of the glorious manifestations of countless merits in that pure Buddha-land of Amitayus, they should all awaken aspiration to be born there. The reasons are: first, those born there will meet those Great Beings adorned with such countless merits as mentioned above; second, they will enjoy the pleasure of the Mahayana Dharma intrinsic to this pure Buddha-land adorned with such innumerable merits; and third, with their own immeasurable vows and practice advancing and developing every moment, they will quickly realize the highest perfect Enlightenment. Shariputra, those who are to be born in that Buddha-land do not have few but already countless and unlimited merits, so such sentient beings can attain birth in the pure Buddha-land of Utmost Bliss of the Buddha Amitayus.
"Again, Shariputra, if good men or women of pure faith, having heard Amitayus Buddha's name of innumerable, boundless and inconceivable merits and also heard of the glorious adornments of the Land of Utmost Bliss, concentrate their thoughts on them with undistracted mind even for one day, two days, three, four, five, six or seven days, then, at the hour of death, Amitayus, surrounded by innumerable shravaka disciples and bodhisattvas, will appear before those good men or women and give them compassionate protection to keep their minds from falling into confusion. Thus, after death, following the Buddha Amitayus and his retinue, they will be born in his Pure Land of Utmost Bliss.
"Shariputra, as I perceive that such blissful benefits are matters of great importance, I pronounce these words of truth: Good men and good women of pure faith who hear Amitayus Buddha's name of inconceivable merits and also learn of the pure Buddha-land of Utmost Bliss should all receive [the teaching] in faith, arouse aspiration, practice the method as prescribed, and attain birth in that Buddha-land.

[6] "Shariputra, just as I praise the innumerable, unlimited and inconceivable merits of the Buddha-land of Amitayus, so do the Buddhas of the eastern direction as numerous as the sands of the Ganges, such as Aksobhya Tathagata, Meru-dhvaja Tathagata, Mahameru Tathagata, Meru-prabhasa Tathagata, and Manju-dhvaja Tathagata. While dwelling in their own pure lands of the east, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[7] "Again, Shariputra, there are in the southern direction Buddhas as numerous as the sands of the Ganges, such as Candra-surya-pradipa Tathagata, Yashah-prabha Tathagata, Maharci-skandha Tathagata, Meru-pradipa Tathagata and Ananta-virya Tathagata. While dwelling in their own pure lands of the south, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[8] "Again, Shariputra, there are in the western direction Buddhas as numerous as the sands of the Ganges, such as Amitayus Tathagata, Amita-skandha Tathagata, Amita-prabha Tathagata, Amita-dhvaja Tathagata, Maheshvara Tathagata, Mahaprabha Tathagata, Jvalana Tathagata, Maharatna-ketu Tathagata and Sphuta-rashmi Tathagata. While dwelling in their own pure lands of the west, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[9] "Again, Shariputra, there are in the northern direction Buddhas as numerous as the sands of the Ganges, such as Amita-prabha-vyuha-abhijna-buddhi Tathagata, Mahaskandha Tathagata, Amita-divya-dundubhi-vaishvanara- nirghosa Tathagata, Jaleni-prabha Tathagata and Salendra-raja Tathagata. While dwelling in their own pure lands of the north, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[10] "Again, Shariputra, there are in the nadir Buddhas as numerous as the sands of the Ganges, such as Sarva-saddharma-darshana-yukti-sada-jvalana- rajottama-shri-prabha Tathagata, Simha Tathagata, Yashas Tathagata, Yashah-prabhasa Tathagata, Dharma Tathagata, Saddharma Tathagata, Dharma-dhvaja Tathagata, Guna-mitra Tathagata and Guna-nama Tathagata. While dwelling in their own pure lands of the nadir, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this Dharma-gate expounding praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[11] "Again, Shariputra, there are in the zenith Buddhas as numerous as the sands of the Ganges, such as Brahma-ghosa Tathagata, Naksatra-raja Tathagata, Gandha-prabhasa Tathagata, Utpala-shri-kalpa Tathagata and Sarvartha-darsha Tathagata. While dwelling in their own pure lands of the zenith, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[12] "Again, Shariputra, there are in the south-eastern direction Buddhas as numerous as the sands of the Ganges, such as Uttama-vipula-megha-ghosa-raja Tathagata. While dwelling in their own pure lands of the south-east, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[13] "Again, Shariputra, there are in the south-western direction Buddhas as numerous as the sands of the Ganges, such as Uttama-surya-prabha-yasho-guna Tathagata. While dwelling in their own pure lands of the south-west, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[14] "Again, Shariputra, there are in the north-western direction Buddhas as numerous as the sands of the Ganges, such as Amita-guna-jvalanadhipati- prabhasa Tathagata. While dwelling in their own pure lands of the north-west, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[15] "Again, Shariputra, there are in the north-eastern direction Buddhas as numerous as the sands of the Ganges, such as Asamkhya-shata-sahasra-koti- nayuta-vipula-buddhi Tathagata. While dwelling in their own pure lands of the north-east, they extend their long, broad tongues and, encompassing with them the universe of a thousand million worlds, pronounce these words of truth: Sentient beings should all receive in faith this gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.

[16] "Shariputra, why is this sutra named 'the Dharma-gate expounding praise of the inconceivable merits of the Buddha-land and protection by all Buddhas? Shariputra, it is revealed in this sutra that the inconceivable merits of Amitayus Buddha's Land of Utmost Bliss are praised and glorified and that all Buddhas, Bhagavats, of the ten directions, while dwelling in their own lands, display glorious and wonderful manifestations and pronounce words of truth, urging sentient beings to receive this teaching in faith, in order to guide and benefit them and give them peace and bliss. For this reason, this sutra is called 'the gate of the Dharma concerning praise of the inconceivable merits of the Buddha-land and protection by all Buddhas.'
"Shariputra, if good men or women, who have heard this sutra, now hear or will hear it, have already awakened or will awaken deep faith, they are embraced by those Buddhas, Bhagavats, dwelling in the ten directions, as numerous as ten times the number of the sands of the Ganges. All who practice as prescribed will not regress but will definitely attain the highest perfect Enlightenment and be born in the Pure Land of Utmost Bliss of Amitayus. For this reason, Shariputra, all sentient beings should receive in faith and understand well my words and the words of the Buddhas, Bhagavats, of the ten directions, and should make great efforts and diligently practice as prescribed. Do not allow any doubt to arise.
"Again, Shariputra, if good men or women have already aspired or will aspire or now aspire to the glorious adornments in the Pure Land of Utmost Bliss of Amitayus, they will be definitely embraced by those Buddhas, Bhagavats, dwelling in the ten directions, as numerous as the sands of the Ganges, even ten times that number. All who practice as prescribed will not regress but will definitely attain the highest perfect Enlightenment and be born in the Pure Land of Utmost Bliss of Amitayus. For this reason, Shariputra, good men and women of pure faith should all believe deeply in Amitayus Buddha's Pure Land of Utmost Bliss and aspire to be born there. Do not be indolent.

[17] "Shariputra, just as I now praise and glorify the inconceivable merits of Amitayus Buddha's Land of Utmost Bliss, all other Buddhas, Bhagavats, of the ten directions likewise praise my boundless inconceivable merits, saying: 'How marvelous it is that Shakyamuni, Shakya Dharma-King, Tathagata, Arhat, Samyaksambuddha, Possessed of Wisdom and Practice, Sugata, Knower of the World, the Unsurpassed, Tamer of Men, Teacher of Gods and Humans, Buddha and Bhagavat, has appeared in this Saha world during the period of the five corruptions: namely, those of time, sentient beings, passions, views and life-span, and that, having attained the highest perfect Enlightenment, delivered this teaching, most difficult for the world to accept, in order to guide and benefit sentient beings and give them peace and bliss.'"Thus, Shariputra, you should know that I have appeared in this Saha world of various defilements during the period of the five corruptions and, having attained the highest perfect Enlightenment, delivered this teaching, most difficult for the world to accept, in order to guide and benefit sentient beings and give them peace and bliss. This is indeed a rare and marvelous task, which is beyond comprehension. "If, Shariputra, there are good men or women of pure faith who, having heard this teaching, most difficult for the world to accept, receive it in faith, uphold and expound it to others, and practice it as prescribed, you should know that such people are extremely rare. In the past they have planted roots of goodness in the presence of innumerable Buddhas. After death they will surely be born in the Western Land of Utmost Bliss, where they will enjoy various glorious adornments and the pleasure of Mahayana Dharma embodied in the Buddha's Pure Land. They can approach Amitayus Buddha and make offerings to him six times during the day and night. They can also fly to [the lands in] the ten directions to make offerings to Buddhas, where they will hear the Dharma taught by them and will receive assurances of their attainment of Buddhahood. Thus they will be able to perfect quickly the merits and wisdom and realize the highest perfect Enlightenment."

[18] When the Bhagavat had delivered this sutra, all the great shravakas, such as the Venerable Shariputra, and bodhisattvas, mahasattvas, together with all beings, including innumerable devas, humans and asuras, greatly rejoiced at the Buddha's exposition and received it in faith.

Translated by Charles Patton

Thus have I heard. One time, the Bhagavat was residing at the Anathapindada retreat in the Jetavana Grove near Sravasti, with a great bhiksu congregation of 1,250 people, all of whom were venerable voice hearers, respected by the community, and great Arhats. Their names were: the Venerable Sariputra, Mahamaudgalyayana, Mahakasyapa, and Aniruddha. These were among the great voice hearers the foremost leaders.

Further, he was accompanied by an immeasurable number of bodhisattva-mahasattvas, all of whom resided in the seat of irreversibility [*] and were myriadly adorned by measureless merits. Their names were: Wondrous Fortune Bodhisattva, Undefeatable Bodhisattva, Always Diligent Bodhisattva, and Uninterrupted Peace Bodhisattva. These were among the great bodhisattvas the foremost leaders.

Further, Indra, the great King of the Brahma heaven, was present, as was the Lord of the Saha world, and the four defenders of the world (lokapalas). These were the foremost leaders among the hundreds of thousands of kotis of nayutas in the assembly of Gods. And from the remaining worlds a measureless number of Gods, men, and Asuras came to hear the Dharma, and who as a group seated themselves.

At that time, the World Honored One addressed Sariputra, "You should know that to the West of this realm, beyond hundreds of thousands of kotis of nayutas of Buddha lands, there is a Buddha realm named 'Blissful'. In that realm is a World Honored One whose name is 'Infinite Lifespan' and 'Infinite Light'; a Tathagata, an Arhat of perfect awakening, who completely fulfills the ten epithets of the Buddhas. There presently he resides with body and mind at rest, abides and upholds [that realm], and for the sentient beings expounds and propagates the Dharma which is most deep, minute, and wondrous, causing them to attain that most excellent blessing of peaceful happiness.

"Furthermore, Sariputra, what are the causes and what are the conditions of that Buddha realm being called 'Blissful'? Sariputra, it originated from the sort of sentient beings in that realm, who are devoid of all bodily and mental anguish and affliction; but who instead possess an infinitely pure joyful happiness. This is why it is called the realm of bliss.

"Furthermore, Sariputra, everywhere in the blissful realm, that pure Buddha land, there are seven kinds of paths lined with wondrous and precious hand railings, seven kinds of paths lined with rows of precious Tala trees, and there are seven kinds of precious netting. Everywhere there are gardens encircled with four treasured adornments: golden treasures, silver treasures, emerald treasures, and crystalline treasures; all being wondrously ornate and beautiful. Sariputra, in that Buddha land, such are the myriads of finely ornate and beautiful meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, everywhere in the blissful realm, that pure Buddha land, there are seven wondrous treasure lakes and eight meritorious waters which fill them. What are called the eight meritorious waters? 1) clarity, 2) clear ice, 3) sweetly beautiful, 4) light and soft, 5) glistening, 6) serene, 7) when drank, it quenches the inestimable pangs of hunger and thirst, and 8) having drank it, it supports the continuation of the roots of the four gross elements. These increase the blessings of the various and most excellent good roots, and so the many deeds of the myriad beings function to bring about constant happiness. The bottoms of the treasure lakes are covered with golden sands. On each of their four sides, entirely encircling them, there are four sets of stairs [leading into them]. These four adornments are very lovely and delightful. The lakes have all around them wondrously jeweled trees and among them are ornamented pathways with perfumed airs of a sweet aroma. The seven treasures adorn the trees are very lovely and delightful. What are the seven treasures? 1) Gold, 2) silver, 3) emerald, 4) crystal, 5) ruby, 6) marble (asman) [?], and 7) white coral (musaragalva). In these lakes, there are always variously hued lotus blossoms whose diameter was like that of cart wheels:-- blue ..., yellow ..., red ..., white ..., and all four .... Sariputra, in that Buddha land, such are the myriads of finely ornate and beautiful meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, spontaneously in the blissful realm, that pure Buddha land, there are constant, measureless, and boundless myriads of wondrously delightful talents. There are voices singing harmoniously, being lovely and delightful. The sentient beings who hear these wondrous voices have their unwholesome afflictions entirely and completely annulled. The infinite number of good dharmas gradually advance throughout in their long lives and speed them along to the realization of the supreme and perfect bodhi. Sariputra, in that Buddha land, such are the myriads of finely ornate and beautiful meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, everywhere in the blissful realm, that pure Buddha land, pervasively the entire mass of the great earth consists of pure gold. Its touch is soft and pliable, the smell clean, and the light radiant. Measurelessly and boundlessly wondrous treasures decorate it throughout. Sariputra, in that Buddha land, such are the myriads of finely ornate and beautiful meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, constantly in the realm of bliss, that pure Buddha land, day and night throughout the six periods, there rains down various sorts of wondrous Heavenly flowers which are in light blessed, in smell sweet, in feel delicate and pliable, and variously hued. Although they lead the viewer's body and mind to be pleased and joyful, there is no craving or attachment. Growing into old age, the sentient beings' most excellent merits are measureless, boundless, and inconceivable. Those sentient beings who day and night through the six periods constantly uphold and support the Infinite Lifespan Buddha, each morning collect these heavenly flowers. In the time of taking a single meal, they fly off in all directions into other infinite realms to give offerings to the hundreds of thousands of kotis of Buddhas in those Buddha places. Each, with the hundreds of thousands of kotis of flowers which they were carrying, scattered flower offerings and then returned to their original dwellings, frolicking in heavenly abodes [on the way]. Sariputra, in that Buddha land, such are the myriads of finely ornate and beautiful meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, constantly in the realm of bliss, that pure Buddha land, there are various sorts of extraordinarily fine and lovely myriads of variously colored birds: geese, hawks, herons, swans, cranes, peacocks, sparrows, parrots, kalavinkas, [all] birds of varying lifespan. These myriad birds, day and night throughout the six periods, always are gathering together in flocks to produce peaceful bird song. According to each's species, their voices promulgate and popularize the subtle Dharma, which is known as the deep, profound thought, abiding in the proper detachment. According to their spiritual capacity, the strength of their roots, are their branches of enlightenment in the measureless and subtle Dharma. The myriad beings of that land having heard their singing, each then think of the Buddha, think of the Dharma, and think of the Sangha, cultivating and sharing among themselves measureless merits. You, Sariputra:-- What do you think? Could the myriad birds of that land have come to be born into such an evil destiny and accumulate there? You should not hold this view. Why is that? That Buddha's pure land is devoid of the three evil paths. Further, the names of the three evil destinies are unknown [in that land]. How much more, then, could truly evil karma be incurred by and cause rebirth [of sentient beings as] these myriads of birds? You should know that all of them the Infinite Lifespan Buddha has conjured into being and sent off by him to propagate the measureless Dharma voice and, by so doing, bless sentient beings with a peaceful happiness. Sariputra, in that Buddha land, such are the myriads of finely ornate and beautiful meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, always in the realm of bliss, that pure Buddha land, there are wondrous winds blowing through the treasure trees and the treasure nettings, producing a fine and wondrous sound, like hundreds of thousands of kotis of heavenly musical instruments playing simultaneously. They produce minutely fine sounds which are very lovely and delightful. Such are the constant and wondrous winds that are in that land. In the myriad beings of that land, who have heard this sound, there arises the thought of the Buddha, Dharma, and Sangha, with the intention of measureless merit. Sariputra, in that Buddha land, such are the myriads of finely ornate and beautiful meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, in the realm of bliss, that pure Buddha land, there are measureless, boundless, inconceivably profound and extraordinary happenings, such as the provisional explanation of the Sutras throughout hundreds of thousands of kotis of nayutas of kalpas, using their measureless hundreds of thousands of kotis of nayutas of languages. Each and every one of these languages producing immeasurable voices praising their merit and also their inexhaustibility. This is why is it called the realm of bliss.

"Furthermore, Sariputra, what are the circumstances in the realm of bliss, that pure Buddha land, leading to the Buddha there being named 'Infinite Lifespan'? Sariputra, it is from that tathagata and the sentient beings lifespan spanning infinitely countless kalpas. It is because of this circumstance that that land's tathagata is named 'Infinite Lifespan'. Sariputra, the Infinite Lifespan Buddha having come to realize the attainment of the supremely unexcelled bodhi, he has since governed his land for ten great kalpas. Sariputra, what are the circumstances leading to that Buddha being called 'Infinite Light'? Sariputra, it is from that tathagata's always emitting infinite, boundless, and wondrous lights which pervasively illuminate all the Buddha lands in the ten directions, offering those lands [a view of] that Buddha's activity without there being any obstacles. It is because of this circumstance that that land's tathagata is called 'Infinite Light'. Sariputra, the Buddha of that pure land has consummated thusly such meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, in the realm of bliss, that pure Buddha land, the Infinite Lifespan Buddha always has an infinite number of voice hearer disciples, all of whom are great Arhats and have consummated various kinds of wondrous merits. Their measure is boundless, their number inestimable. Sariputra, the Buddha of that pure land has consummated thusly such meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, in the realm of bliss, that pure Buddha land, the Infinite Lifespan Buddha always has an infinite number of bodhisattva disciples, all of whom have only one life bound by fetters and have consummated various sorts of wondrous merits. Their measure is boundless, and their inestimable. They have provisionally explained the Sutras throughout a countless number of kalpas, praising their merit, and the inexhaustibility of all. Sariputra, in that Buddha land, there is consummated thusly such meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, if the sentient beings are to born into that land, it is necessary for them to be irreversible, never again falling into the evil destinies in the lands bordering [the pure land] down to the base, neglectful, contrary forms of transmigration. Always relaxing with the Buddhas of the Pure Land, they are extremely proficient in practicing the vows and making progress. Resolute and firm shall be their realization of the supremely unexcelled bodhi. Sariputra, in that Buddha land, there is consummated thusly such meritorious adornments which are very lovely and delightful. This is why it is called the realm of bliss.

"Furthermore, Sariputra, if sentient beings should hear of that Western pure Buddha land of the Infinite Lifespan Buddha's myriad adornments of immeasurable merits, all shall respond by initiating the vow to be born in the Buddha land. Why is that? If they are to be born into that land, they will have attained such immeasurable merits with which they are myriadly adorned, they would be great worthies gathered into a single assembly, receiving the function of such immeasurable merits which myriadly adorn the Pure Buddha land. Their delight in the Mahayana Dharma would be constant and irreversible and measureless would be their practice of vows, their concentration increasing progressive, and so they shall quickly realize the supremely unexcelled bodhi. Sariputra, the kind of sentient beings who are born into that Buddha land will have accomplished measureless and boundless merits. Not of lesser good roots are the sentient beings who will be reborn into the Infinite Lifespan Buddha's blissful realm, that Pure Buddha Land.

"Furthermore, Sariputra, suppose there is a good son or good daughter of pure faith, who hears thusly of the Infinite Lifespan Buddha's immeasurable, boundless, and inconceivable merit, the name of his realm of 'bliss', and its meritorious adornments. Having heard of it, they will meditate upon it -- whether for one day and night, or two, or three, or four, or five, or six, or seven [days and nights] -- they think about its essence, devoid of confusion. When this good son or good daughter is on the verge of the end of their lifespan, the Infinite Lifespan Buddha accompanied by his measureless voice hearer and bodhisattva disciples will circle him front and back, and come to rest before him. Compassionately conferring aid upon them, they will cause his mind to be without disorder. When he has left his current life, he will follow that Buddha and his assembly and be born into the Infinite Lifespan Buddha's realm of bliss, that pure Buddha land.

"Furthermore, Sariputra, I have examined the circumstances leading to the blessing of peaceful happiness of that great event. And I speak sincerely and truthfully when I say that if there are good sons and good daughters of pure faith who hear thusly of the Infinite Lifespan Buddha's inconceivable merit, the name of his realm of 'bliss', that pure Buddha land, all of them will respond by faithfully receiving [this teaching] and initiate the vow to cultivate their practice to be born in that Buddha land as I have instructed.

"Furthermore, Sariputra, as I now am praising the Infinite Lifespan Buddha's measureless, boundless, and inconceivable Buddha land and merit, so to the East also there presently resides the Imperturbable Tathagata, Mountain Pendant Tathagata, Great Mountain Tathagata, Mountain Light Tathagata, and Wondrous Pendant Tathagata. These are among the Buddhas who like the sands of the Ganges reside in the East. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them, and speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the South there also presently resides the Moon and Sun Light Tathagata, the Famed Light Tathagata, the Great Light Hoard Tathagata, Vessel of Intoxicating Light Tathagata [?], Boundless Diligence Tathagata. These are among the Buddhas who like the sands of the Ganges reside to the South. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them, and speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the West there also presently resides the Infinite Lifespan Tathagata, Infinite Treasury Tathagata, Infinite Light Tathagata, Infinite Pendant Tathagata, Great Sovereign Tathagata, Great Light Tathagata, and Blazing Light Tathagata, Great Treasure Pendant Tathagata, and Light Emitter Tathagata. These are among the Buddhas who like the sands of the Ganges reside to the West. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them, and speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the North there are also presently resides the Infinite Light Adornment of Penetrating Awakened Wisdom Tathagata, Infinite Heavenly Drum Beat and Great Voice Tathagata, Great Treasury Tathagata, Network of Lights Tathagata, and Salendraraja Tathagata. These are among the Buddhas who like the sands of the Ganges reside to the North. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them and, speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the Nadir there also presently resides the Constantly Emitted Light which Demonstrates All Subtle Dharmas of the True Principle King's Extremely Virtuous Light Tathagata, Lion Tathagata, Praiseworthy Light Tathagata, True Dharma Tathagata, Subtle Dharma Tathagata, Dharma Pendant Tathagata, Meritorious Friend Tathagata, and Meritorious Epithet Tathagata. These are among the Buddhas who like the sands of the Ganges reside to the Nadir. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them and, speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the Zenith there also presently resides the Brahma Voice Tathagata, Long Cherished King Tathagata, Incense and Light Tathagata, Very Virtuous Like the Crimson Lotus Blossom Tathagata, and Demonstration of All the Meanings of Blessing Tathagata. These are among the Buddhas who like the sands of the Ganges reside to the Zenith. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them and, speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the Southeast there also presently resides the Supreme and Extensively Great Thundercloud Voice King Tathagata. He is among the Buddhas who like the sands of the Ganges reside to the Southeast. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them and, speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the Southwest there also presently resides the Supreme Sunray Called 'Merit' Tathagata. He is among the Buddhas who like the sands of the Ganges reside to the Southwest. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them and, speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the Northwest there also presently resides the Flame of Infinite Merit King's Light Tathagata. He is among the Buddhas who like the sands of the Ganges reside to the Northwest. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them and, speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, thusly to the Northeast there also presently resides the Countless Hundreds of Thousands of Kotis of Nayutas of Extensive Wisdoms Tathagata. He is among the Buddhas who like the sands of the Ganges reside to the Northeast. Each one has his own pure Buddha land presently, and their long and broad tongues completely cover the billion realms all around them and, speaking sincerely and truthfully, say: 'You sentient beings! All of you should faithfully receive thusly the Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, what the conditions of this Sutra being named 'Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'? Sariputra, it is because in this Sutra there is praise and commendation of the Infinite Lifespan Buddha's blissful realm, that inconceivable Buddha land's merits, as well as the Buddha World Honored Ones in the other ten directions. Because they desire to expeditiously bless with peaceful happiness the sentient beings, each resides in his own land demonstrating the great spiritual transformation, speaking sincerely and truthfully the words: 'O, sentient beings, faithfully receive this Dharma, etc'. This is why this Sutra is called 'Praise for the Inconceivable Buddha land's Merit Accumulated by All the Buddhas Dharma-Entrance'.

"Furthermore, Sariputra, if there is a good son or good daughter, whether having already heard this, or shall hear it, or who is now hearing it:-- once hearing this Sutra, profoundly is there born an understanding faith. Once there is born an understanding faith, a certainty about the accumulations of merit residing in the ten directions with the Buddha World Honored Ones whose number is like the sands of ten Ganges Rivers, and they practice as instructed, all will be firmly in the supremely unexcelled bodhi. Attaining irreversibility in it, all will certainly be born in the Infinite Lifespan Buddha's blissful realm, that purified Buddha land. This is why, Sariputra, you sentient beings all should faithfully receive and understand what I as well as the Buddha World Honored Ones of the ten directions say: 'Be always diligent as instructed and cultivate your practice. Do not allow doubts and anxieties arise.'

"Furthermore, Sariputra, if there is a good son or good daughter who regarding the Infinite Lifespan Buddha's blissful realm, that purified Buddha land of meritorious adornments:-- whether they have initiated the vow, or they will initiate the vow, or they now are initiating the vow to be certain about the accumulations of merit residing in the ten directions with the Buddha World Honored Ones whose number is like the sands of ten Ganges Rivers, and they practice as instructed, all will firmly be in the supremely unexcelled bodhi. Attaining irreversibility in it, all will certainly be born in the Infinite Lifespan Buddha's blissful realm, that purified Buddha land. This is the reason, Sariputra, that if there are good sons or good daughters of pure faith, all should regarding the Infinite Lifespan Buddha's blissful realm, that purified Buddha land [have] the profound thought of understanding faith and initiate the vow to be reborn there, and not to go elsewhere.

"Furthermore, Sariputra, as I now have praised and commended the Infinite Lifespan Buddha's blissful realm, the inconceivable merits of that Buddha land, and those Buddha World Honored Ones of the ten directions, also they have commended my own inconceivable and boundless merits, composing the statement: 'Most extraordinary is Shakyamuni's tranquil purity; Shakyamuni, the Dharma king, a Tathagata, an Arhat, a perfectly enlightened one, one whose wisdom and conduct are complete, a Well Gone One, A Knower of Worlds, Unsurpassed, a Tamer of Men, a Teacher of Gods and Men, and a Buddha World Honored One. He is able in the realm of endurance, during the five periods of unwholesome decay, which are: the kalpa's decay, the decay of sentient beings, the decay of affliction, the decay of capacity, and the decay of the lifespan. Amidst this, he has realized the attainment of the supremely unexcelled bodhi. Because of his desire to expediently bestow the blessing of peaceful happiness on the sentient beings, he preaches in this world where it is extremely difficult to have faith in the Dharma. It is most extraordinary and inconceiveable.'

"Furthermore, Sariputra, in this variously defiled realm of endurance, during the five periods of decay, if there are good sons or good daughters of pure faith who hear the preaching thusly of the Dharma in all the realms where it is difficult to believe, and are able to give rise an understanding faith, receive and uphold the extensive teachings, cultivating themselves according to the teachings:-- these persons shall be known to be most extraordinary. Having with measureless buddhas accumulated their good roots, when these persons' lifetimes come to an end, they certainly will be born in the Western realm of bliss and receive the effect of the various sorts of meritorious adornments of that Pure Buddha land where the Mahayana Dharma is a delight. Day and night, throughout the six periods, they will befriend and support the Infinite Lifespan Buddha. They will frolic throughout the ten directions supporting Buddhas, and with those Buddhas hearing the Dharma and receiving prediction [of future Buddhahood]. Their deeds, wisdom, wealth, provisions, and urgency becoming completely fulfilled, they advance quickly to the realization of the unsurpassed and perfect bodhi."

When the Bhagavat had finished preaching this Sutra, the Venerable Sariputra, the great voice hearers, as well as the bodhisattva-mahasattva congregation and the measureless gods, men, and asuras:-- all in the great assembly hearing the Buddha's lecture were greatly elated, and faithfully received, transmitted, and practiced it.