New Page 1

此网页使用了框架，但您的浏览器不支持框架。


New Page 2

    No. 475

    维摩诘所说经(一名不可思议解脱上卷)
    姚秦三藏鸠摩罗什译
    佛国品第一
    如是我闻。一时佛在毗耶离庵罗树园。与大比丘众八千人俱。菩萨三万二千。众所知识。大智本行皆悉成就。诸佛威神之所建立。为护法城受持正法。能师子吼名闻十方。众人不请友而安之。绍隆三宝能使不绝。降伏魔怨制诸外道。悉已清净永离盖缠。心常安住无碍解脱。念定总持辩才不断。布施持戒忍辱精进禅定智慧。及方便力无不具足。逮无所得不起法忍。已能随顺转不退轮。善解法相知众生根。盖诸大众得无所畏。功德智慧以修其心。相好严身色像第一。舍诸世间所有饰好。名称高远踰于须弥。深信坚固犹若金刚。法宝普照而雨甘露。于众言音微妙第一。深入缘起断诸邪见。有无二边无复余习。演法无畏犹师子吼。其所讲说乃如雷震。无有量已过量。集众法宝如海导师。了达诸法深妙之义。善知众生往来所趣及心所行。近无等等佛自在慧十力无畏十八不共。关闭一切诸恶趣门。而生五道以现其身。为大医王善疗众病。应病与药令得服行。无量功德皆成就。无量佛土皆严净。其见闻者无不蒙益。诸有所作亦不唐捐。如是一切功德皆悉具足
    其名曰等观菩萨。不等观菩萨。等不等观菩萨。定自在王菩萨。法自在王菩萨。法相菩萨。光相菩萨。光严菩萨。大严菩萨。宝积菩萨。辩积菩萨。宝手菩萨。宝印手菩萨。常举手菩萨。常下手菩萨。常惨菩萨。喜根菩萨。喜王菩萨。辩音菩萨。虚空藏菩萨。执宝炬菩萨。宝勇菩萨。宝见菩萨。帝网菩萨。明网菩萨。无缘观菩萨。慧积菩萨。宝胜菩萨。天王菩萨。坏魔菩萨。电德菩萨。自在王菩萨。功德相严菩萨。师子吼菩萨。雷音菩萨。山相击音菩萨。香象菩萨。白香象菩萨。常精进菩萨。不休息菩萨。妙生菩萨。华严菩萨。观世音菩萨。得大势菩萨。梵网菩萨。宝杖菩萨。无胜菩萨。严土菩萨。金髻菩萨。珠髻菩萨。弥勒菩萨。文殊师利法王子菩萨。如是等三万二千人
    复有万梵天王尸弃等。从余四天下来诣佛所而听法。复有万二千天帝。亦从余四天下来在会坐。并余大威力诸天．龙神．夜叉．乾闼婆．阿修罗．迦楼罗．紧那罗．摩睺罗伽．等悉来会坐。诸比丘比丘尼优婆塞优婆夷俱来会坐。彼时佛与无量百千之众恭敬围绕而为说法。譬如须弥山王显于大海。安处众宝师子之座。蔽于一切诸来大众
    尔时毗耶离城有长者子。名曰宝积。与五百长者子俱。持七宝盖来诣佛所。头面礼足。各以其盖共供养佛。佛之威神令诸宝盖合成一盖。遍覆三千大千世界。而此世界广长之相悉于中现。又此三千大千世界。诸须弥山雪山。目真邻陀山摩诃目真邻陀山。香山宝山金山黑山。铁围山大铁围山。大海江河川流泉源。及日月星辰。天宫龙宫。诸尊神宫。悉现于宝盖中。又十方诸佛诸佛说法亦现于宝盖中。尔时一切大众。睹佛神力叹未曾有。合掌礼佛瞻仰尊颜目不暂舍。于是长者子宝积。即于佛前以偈颂曰
目净修广如青莲 心净已度诸禅定
久积净业称无量 导众以寂故稽首
既见大圣以神变 普现十方无量土
其中诸佛演说法 于是一切悉见闻
法王法力超群生 常以法财施一切
能善分别诸法相 于第一义而不动
已于诸法得自在 是故稽首此法王
说法不有亦不无 以因缘故诸法生
无我无造无受者 善恶之业亦不亡
始在佛树力降魔 得甘露灭觉道成
已无心意无受行 而悉摧伏诸外道
三转法轮于大千 其轮本来常清净
天人得道此为证 三宝于是现世间
以斯妙法济群生 一受不退常寂然
度老病死大医王 当礼法海德无边
毁誉不动如须弥 于善不善等以慈
心行平等如虚空 孰闻人宝不敬承
今奉世尊此微盖 于中现我三千界
诸天龙神所居宫 乾闼婆等及夜叉
悉见世间诸所有 十力哀现是化变
众睹希有皆叹佛 今我稽首三界尊
大圣法王众所归 净心观佛靡不欣
各见世尊在其前 斯则神力不共法
佛以一音演说法 众生随类各得解
皆谓世尊同其语 斯则神力不共法
佛以一音演说法 众生各各随所解
普得受行获其利 斯则神力不共法
佛以一音演说法 或有恐畏或欢喜
或生厌离或断疑 斯则神力不共法
稽首十力大精进 稽首已得无所畏
稽首住于不共法 稽首一切大导师
稽首能断众结缚 稽首已到于彼岸
稽首能度诸世间 稽首永离生死道
悉知众生来去相 善于诸法得解脱
不着世间如莲华 常善入于空寂行
达诸法相无挂碍 稽首如空无所依
    尔时长者子宝积。说此偈已白佛言。世尊。是五百长者子。皆已发阿耨多罗三藐三菩提心。愿闻得佛国土清净。唯愿世尊。说诸菩萨净土之行。佛言。善哉宝积。乃能为诸菩萨问于如来净土之行。谛听谛听善思念之。当为汝说。于是宝积及五百长者子。受教而听。佛言。宝积。众生之类是菩萨佛土。所以者何。菩萨随所化众生而取佛土。随所调伏众生而取佛土。随诸众生应以何国入佛智慧而取佛土。随诸众生应以何国起菩萨根而取佛土。所以者何。菩萨取于净国。皆为饶益诸众生故。譬如有人欲于空地造立宫室随意无碍。若于虚空终不能成。菩萨如是。为成就众生故愿取佛国。愿取佛国者非于空也。宝积。当知直心是菩萨净土。菩萨成佛时不谄众生来生其国。深心是菩萨净土。菩萨成佛时具足功德众生来生其国。菩提心是菩萨净土。菩萨成佛时大乘众生来生其国。布施是菩萨净土。菩萨成佛时一切能舍众生来生其国。持戒是菩萨净土。菩萨成佛时行十善道满愿众生来生其国。忍辱是菩萨净土。菩萨成佛时三十二相庄严众生来生其国。精进是菩萨净土。菩萨成佛时勤修一切功德众生来生其国。禅定是菩萨净土。菩萨成佛时摄心不乱众生来生其国。智慧是菩萨净土。菩萨成佛时正定众生来生其国。四无量心是菩萨净土。菩萨成佛时成就慈悲喜舍众生来生其国。四摄法是菩萨净土。菩萨成佛时解脱所摄众生来生其国。方便是菩萨净土。菩萨成佛时于一切法方便无碍众生来生其国。三十七道品是菩萨净土。菩萨成佛时念处正勤神足根力觉道众生来生其国。回向心是菩萨净土。菩萨成佛时得一切具足功德国土。说除八难是菩萨净土。菩萨成佛时国土无有三恶八难。自守戒行不讥彼阙是菩萨净土。菩萨成佛时国土无有犯禁之名。十善是菩萨净土。菩萨成佛时命不中夭。大富梵行所言诚谛。常以软语眷属不离。善和诤讼言必饶益。不嫉不恚正见众生来生其国。如是宝积。菩萨随其直心则能发行。随其发行则得深心。随其深心。则意调伏。随意调伏则如说行。随如说行则能回向。随其回向则有方便。随其方便则成就众生。随成就众生则佛土净。随佛土净则说法净。随说法净则智慧净。随智慧净则其心净。随其心净则一切功德净。是故宝积。若菩萨欲得净土当净其心。随其心净则佛土净
    尔时舍利弗。承佛威神作是念。若菩萨心净则佛土净者。我世尊本为菩萨时意岂不净。而是佛土不净若此。佛知其念即告之言。于意云何。日月岂不净耶。而盲者不见。对曰不也。世尊。是盲者过非日月咎。舍利弗。众生罪故不见如来佛土严净。非如来咎。舍利弗。我此土净而汝不见。尔时螺髻梵王语舍利弗。勿作是意。谓此佛土以为不净。所以者何。我见释迦牟尼佛土清净。譬如自在天宫。舍利弗言。我见此土。丘陵坑坎荆蕀沙砾。土石诸山秽恶充满。螺髻梵言。仁者心有高下。不依佛慧故。见此土为不净耳。舍利弗。菩萨于一切众生。悉皆平等。深心清净。依佛智慧则能见此佛土清净。于是佛以足指按地。即时三千大千世界若干百千珍宝严饰。譬如宝庄严佛无量功德宝庄严土。一切大众叹未曾有。而皆自见坐宝莲华。佛告舍利弗。汝且观是佛土严净。舍利弗言。唯然世尊。本所不见。本所不闻。今佛国土严净悉现。佛语舍利弗。我佛国土常净若此。为欲度斯下劣人故。示是众恶不净土耳。譬如诸天共宝器食随其福德饭色有异。如是舍利弗。若人心净便见此土功德庄严。当佛现此国土严净之时。宝积所将五百长者子皆得无生法忍。八万四千人皆发阿耨多罗三藐三菩提心。佛摄神足。于是世界还复如故。求声闻乘三万二千天及人。知有为法皆悉无常。远尘离垢得法眼净。八千比丘不受诸法漏尽意解

    维摩诘所说经方便品第二
    尔时毗耶离大城中有长者名维摩诘。已曾供养无量诸佛深植善本。得无生忍。辩才无碍。游戏神通逮诸总持。获无所畏降魔劳怨。入深法门善于智度。通达方便大愿成就。明了众生心之所趣。又能分别诸根利钝。久于佛道心已纯淑决定大乘。诸有所作能善思量。住佛威仪心大如海。诸佛咨嗟弟子。释梵世主所敬。欲度人故以善方便居毗耶离。资财无量摄诸贫民。奉戒清净摄诸毁禁。以忍调行摄诸恚怒。以大精进摄诸懈怠。一心禅寂摄诸乱意。以决定慧摄诸无智。虽为白衣奉持沙门清净律行。虽处居家不着三界。示有妻子常修梵行。现有眷属常乐远离。虽服宝饰而以相好严身。虽复饮食而以禅悦为味。若至博弈戏处辄以度人。受诸异道不毁正信。虽明世典常乐佛法。一切见敬为供养中最。执持正法摄诸长幼。一切治生谐偶虽获俗利不以喜悦。游诸四衢饶益众生。入治政法救护一切。入讲论处导以大乘。入诸学堂诱开童蒙。入诸淫舍示欲之过。入诸酒肆能立其志。若在长者长者中尊为说胜法。若在居士居士中尊断其贪着。若在刹利刹利中尊教以忍辱。若在婆罗门婆罗门中尊除其我慢。若在大臣大臣中尊教以正法。若在王子王子中尊示以忠孝。若在内官内官中尊化政宫女。若在庶民庶民中尊令兴福力。若在梵天梵天中尊诲以胜慧。若在帝释帝释中尊示现无常。若在护世护世中尊护诸众生。长者维摩诘。以如是等无量方便饶益众生。其以方便现身有疾。以其疾故。国王大臣长者居士婆罗门等。及诸王子并余官属。无数千人皆往问疾。其往者。维摩诘因以身疾广为说法。诸仁者。是身无常无强无力无坚。速朽之法不可信也。为苦为恼众病所集。诸仁者。如此身明智者所不怙。是身如聚沫不可撮摩。是身如泡不得久立。是身如炎从渴爱生。是身如芭蕉中无有坚。是身如幻从颠倒起。是身如梦为虚妄见。是身如影从业缘现。是身如响属诸因缘。是身如浮云须臾变灭。是身如电念念不住。是身无主为如地。是身无我为如火。是身无寿为如风。是身无人为如水。是身不实四大为家。是身为空离我我所。是身无知如草木瓦砾。是身无作风力所转。是身不净秽恶充满。是身为虚伪。虽假以澡浴衣食必归磨灭。是身为灾百一病恼。是身如丘井为老所逼。是身无定为要当死。是身如毒蛇如怨贼如空聚。阴界诸入所共合成。诸仁者。此可患厌当乐佛身。所以者何。佛身者即法身也。从无量功德智慧生。从戒定慧解脱解脱知见生。从慈悲喜舍生。从布施持戒忍辱柔和勤行精进禅定解脱三昧多闻智慧诸波罗蜜生。从方便生。从六通生。从三明生。从三十七道品生。从止观生。从十力四无所畏十八不共法生。从断一切不善法集一切善法生。从真实生。从不放逸生。从如是无量清净法生如来身。诸仁者。欲得佛身断一切众生病者。当发阿耨多罗三藐三菩提心。如是长者维摩诘。为诸问疾者如应说法。令无数千人皆发阿耨多罗三藐三菩提心

    维摩诘所说经弟子品第三
    尔时长者维摩诘自念。寝疾于床。世尊大慈宁不垂愍。佛知其意。即告舍利弗。汝行诣维摩诘问疾。舍利弗白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔曾于林中宴坐树下。时维摩诘来谓我言。唯舍利弗。不必是坐为宴坐也。夫宴坐者。不于三界现身意。是为宴坐。不起灭定而现诸威仪。是为宴坐。不舍道法而现凡夫事。是为宴坐。心不住内亦不在外。是为宴坐。于诸见不动而修行三十七品。是为宴坐。不断烦恼而入涅槃。是为宴坐。若能如是坐者。佛所印可。时我世尊。闻说是语默然而止不能加报。故我不任诣彼问疾
    佛告大目犍连。汝行诣维摩诘问疾。目连白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔入毗耶离大城。于里巷中为诸居士说法。时维摩诘来谓我言。唯大目连。为白衣居士说法。不当如仁者所说。夫说法者当如法说。法无众生离众生垢故。法无有我离我垢故。法无寿命离生死故。法无有人前后际断故。法常寂然灭诸相故。法离于相无所缘故。法无名字言语断故。法无有说离觉观故。法无形相如虚空故。法无戏论毕竟空故。法无我所离我所故。法无分别离诸识故。法无有比无相待故。法不属因不在缘故。法同法性入诸法故。法随于如无所随故。法住实际诸边不动故。法无动摇不依六尘故。法无去来常不住故。法顺空随无相应无作。法离好丑。法无增损。法无生灭。法无所归。法过眼耳鼻舌身心。法无高下。法常住不动。法离一切观行。唯大目连。法相如是岂可说乎。夫说法者无说无示。其听法者无闻无得。譬如幻士为幻人说法当建是意而为说法。当了众生根有利钝。善于知见无所挂碍。以大悲心赞于大乘。念报佛恩不断三宝。然后说法。维摩诘说是法时。八百居士发阿耨多罗三藐三菩提心。我无此辩。是故不任诣彼问疾。佛告大迦叶。汝行诣维摩诘问疾。迦叶白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔于贫里而行乞。时维摩诘来谓我言。唯大迦叶。有慈悲心而不能普。舍豪富从贫乞。迦叶。住平等法应次行乞食。为不食故应行乞食。为坏和合相故应取揣食。为不受故应受彼食。以空聚想入于聚落。所见色与盲等。所闻声与响等。所嗅香与风等。所食味不分别。受诸触如智证。知诸法如幻相无自性无他性。本自不然今则无灭。迦叶。若能不舍八邪入八解脱。以邪相入正法。以一食施一切。供养诸佛及众贤圣。然后可食。如是食者非有烦恼非离烦恼。非入定意非起定意。非住世间非住涅槃。其有施者无大福无小福。不为益不为损。是为正入佛道不依声闻。迦叶。若如是食为不空食人之施也。时我世尊。闻说是语得未曾有。即于一切菩萨深起敬心。复作是念。斯有家名辩才智慧乃能如是。其谁闻此不发阿耨多罗三藐三菩提心。我从是来不复劝人以声闻辟支佛行。是故不任诣彼问疾
    佛告须菩提。汝行诣维摩诘问疾。须菩提白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔入其舍从乞食。时维摩诘取我钵盛满饭。谓我言。唯须菩提。若能于食等者诸法亦等。诸法等者于食亦等。如是行乞乃可取食。若须菩提。不断淫怒痴亦不与俱。不坏于身而随一相。不灭痴爱起于明脱。以五逆相而得解脱。亦不解不缚。不见四谛非不见谛。非得果非不得果。非凡夫非离凡夫法。非圣人非不圣人。虽成就一切法而离诸法相。乃可取食。若须菩提。不见佛不闻法。彼外道六师。富兰那迦叶。末伽梨拘赊梨子。删阇夜毗罗胝子。阿耆多翅舍钦婆罗。迦罗鸠驮迦旃延。尼犍陀若提子等。是汝之师因其出家。彼师所堕汝亦随堕。乃可取食。若须菩提。入诸邪见不到彼岸。住于八难不得无难。同于烦恼离清净法。汝得无诤三昧。一切众生亦得是定。其施汝者不名福田。供养汝者堕三恶道。为与众魔共一手作诸劳侣。汝与众魔及诸尘劳等无有异。于一切众生而有怨心。谤诸佛毁于法不入众数。终不得灭度。汝若如是乃可取食。时我世尊。闻此语茫然不识是何言。不知以何答。便置钵欲出其舍。维摩诘言。唯须菩提取钵勿惧。于意云何。如来所作化人。若以是事诘。宁有惧不。我言。不也。维摩诘言。一切诸法如幻化相。汝今不应有所惧也。所以者何。一切言说不离是相。至于智者不著文字故无所惧。何以故。文字性离无有文字。是则解脱。解脱相者则诸法也。维摩诘说是法时。二百天子得法眼净。故我不任诣彼问疾
    佛告富楼那弥多罗尼子。汝行诣维摩诘问疾。富楼那白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔于大林中在一树下。为诸新学比丘说法。时维摩诘来谓我言。唯富楼那。先当入定观此人心然后说法。无以秽食置于宝器。当知是比丘心之所念。无以琉璃同彼水精。汝不能知众生根源。无得发起以小乘法。彼自无疮勿伤之也。欲行大道莫示小径。无以大海内于牛迹。无以日光等彼萤火。富楼那。此比丘久发大乘心。中忘此意。如何以小乘法而教导之。我观小乘智慧微浅犹如盲人。不能分别一切众生根之利钝。时维摩诘即入三昧。令此比丘自识宿命。曾于五百佛所植众德本。回向阿耨多罗三藐三菩提。即时豁然还得本心。于是诸比丘稽首礼维摩诘足。时维摩诘因为说法。于阿耨多罗三藐三菩提不复退转。我念声闻不观人根不应说法。是故不任诣彼问疾
    佛告摩诃迦旃延。汝行诣维摩诘问疾。迦旃延白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念昔者佛为诸比丘略说法要。我即于后敷演其义。谓无常义苦义空义无我义寂灭义。时维摩诘来谓我言。唯迦旃延。无以生灭心行说实相法。迦旃延。诸法毕竟不生不灭。是无常义。五受阴洞达空无所起。是苦义。诸法究竟无所有。是空义。于我无我而不二。是无我义。法本不然今则无灭。是寂灭义。说是法时彼诸比丘心得解脱。故我不任诣彼问疾
    佛告阿那律。汝行诣维摩诘问疾。阿那律白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔于一处经行。时有梵王名曰严净。与万梵俱放净光明来诣我所。稽首作礼问我言。几何阿那律天眼所见。我即答言。仁者。吾见此释迦牟尼佛土三千大千世界。如观掌中庵摩勒果。时维摩诘来谓我言。唯阿那律。天眼所见为作相耶。无作相耶。假使作相则与外道五通等。若无作相即是无为不应有见。世尊。我时默然。彼诸梵闻其言得未曾有。即为作礼而问曰。世孰有真天眼者。维摩诘言。有佛世尊得真天眼。常在三昧悉见诸佛国不以二相。于是严净梵王及其眷属五百梵天。皆发阿耨多罗三藐三菩提心。礼维摩诘足已忽然不现。故我不任诣彼问疾
    佛告优波离。汝行诣维摩诘问疾。优波离白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念昔者有二比丘。犯律行以为耻。不敢问佛。来问我言。唯优波离。我等犯律诚以为耻。不敢问佛。愿解疑悔得免斯咎。我即为其如法解说。时维摩诘来谓我言。唯优波离。无重增此二比丘罪。当直除灭勿扰其心。所以者何。彼罪性不在内不在外不在中间。如佛所说。心垢故众生垢。心净故众生净。心亦不在内不在外不在中间。如其心然。罪垢亦然。诸法亦然。不出于如。如优波离。以心相得解脱时。宁有垢不。我言。不也。维摩诘言。一切众生心相无垢亦复如是。唯优波离。妄想是垢无妄想是净。颠倒是垢。无颠倒是净。取我是垢。不取我是净。优波离。一切法生灭不住。如幻如电诸法不相待。乃至一念不住。诸法皆妄见。如梦如炎如水中月如镜中像以妄想生。其知此者是名奉律。其知此者是名善解。于是二比丘言。上智哉。是优波离所不能及。持律之上而不能说。我即答言。自舍如来未有声闻及菩萨能制其乐说之辩。其智慧明达为若此也。时二比丘疑悔即除。发阿耨多罗三藐三菩提心。作是愿言。令一切众生皆得是辩。故我不任诣彼问疾
    佛告罗睺罗。汝行诣维摩诘问疾。罗睺罗白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念昔时毗耶离诸长者子。来诣我所稽首作礼问我言。唯罗睺罗。汝佛之子。舍转轮王位出家为道。其出家者有何等利。我即如法为说出家功德之利。时维摩诘来谓我言。唯罗睺罗。不应说出家功德之利。所以者何。无利无功德是为出家。有为法者可说有利有功德。夫出家者为无为法。无为法中无利无功德。罗睺罗。出家者无彼无此亦无中间。离六十二见处于涅槃。智者所受圣所行处。降伏众魔度五道。净五眼得五力立五根。不恼于彼。离众杂恶摧诸外道。超越假名出淤泥。无系着无我所。无所受无扰乱。内怀喜护彼意。随禅定离众过。若能如是是真出家。于是维摩诘语诸长者子。汝等于正法中宜共出家。所以者何。佛世难值。诸长者子言。居士。我闻佛言。父母不听不得出家。维摩诘言。然汝等便发阿耨多罗三藐三菩提心是即出家。是即具足。尔时三十二长者子。皆发阿耨多罗三藐三菩提心。故我不任诣彼问疾
    佛告阿难。汝行诣维摩诘问疾。阿难白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念昔时世尊身小有疾当用牛乳。我即持钵诣大婆罗门家门下立。时维摩诘来谓我言。唯阿难。何为晨朝持钵住此。我言。居士。世尊身小有疾当用牛乳。故来至此。维摩诘言。止止阿难。莫作是语。如来身者金刚之体。诸恶已断众善普会。当有何疾当有何恼。默往阿难。勿谤如来。莫使异人闻此粗言。无令大威德诸天及他方净土诸来菩萨得闻斯语。阿难。转轮圣王以少福故尚得无病。岂况如来无量福会普胜者哉。行矣阿难。勿使我等受斯耻也。外道梵志若闻此语当作是念。何名为师。自疾不能救而能救诸疾。仁可密速去勿使人闻。当知阿难。诸如来身即是法身非思欲身。佛为世尊过于三界。佛身无漏诸漏已尽。佛身无为不堕诸数。如此之身当有何疾当有何恼。时我世尊实怀惭愧。得无近佛而谬听耶。即闻空中声曰。阿难。如居士言。但为佛出五浊恶世。现行斯法度脱众生。行矣阿难。取乳勿惭。世尊。维摩诘智慧辩才为若此也。是故不任诣彼问疾。如是五百大弟子。各各向佛说其本缘。称述维摩诘所言。皆曰不任诣彼问疾

    维摩诘所说经菩萨品第四
    于是佛告弥勒菩萨。汝行诣维摩诘问疾。弥勒白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔为兜率天王及其眷属。说不退转地之行。时维摩诘来谓我言。弥勒。世尊授仁者记一生当得阿耨多罗三藐三菩提。为用何生得受记乎。过去耶未来耶现在耶。若过去生过去生已灭。若未来生未来生未至。若现在生现在生无住。如佛所说。比丘汝今即时亦生亦老亦灭。若以无生得受记者。无生即是正位。于正位中亦无受记。亦无得阿耨多罗三藐三菩提。云何弥勒受一生记乎。为从如生得受记耶。为从如灭得受记耶。若以如生得受记者如无有生。若以如灭得受记者如无有灭。一切众生皆如也。一切法亦如也。众圣贤亦如也。至于弥勒亦如也。若弥勒得受记者。一切众生亦应受记。所以者何。夫如者不二不异。若弥勒得阿耨多罗三藐三菩提者。一切众生皆亦应得。所以者何。一切众生即菩提相。若弥勒得灭度者。一切众生亦应灭度。所以者何。诸佛知一切众生毕竟寂灭即涅槃相不复更灭。是故弥勒。无以此法诱诸天子。实无发阿耨多罗三藐三菩提心者。亦无退者。弥勒当令此诸天子舍于分别菩提之见。所以者何。菩提者。不可以身得。不可以心得。寂灭是菩提。灭诸相故。不观是菩提离诸缘故。不行是菩提无忆念故。断是菩提舍诸见故。离是菩提离诸妄想故。障是菩提障诸愿故。不入是菩提无贪着故。顺是菩提顺于如故。住是菩提住法性故。至是菩提至实际故。不二是菩提离意法故。等是菩提等虚空故。无为是菩提无生住灭故。知是菩提了众生心行故。不会是菩提诸入不会故。不合是菩提离烦恼习故。无处是菩提无形色故。假名是菩提名字空故。如化是菩提无取舍故。无乱是菩提常自静故。善寂是菩提性清净故。无取是菩提离攀缘故。无异是菩提诸法等故。无比是菩提无可喻故。微妙是菩提诸法难知故。世尊。维摩诘说是法时。二百天子得无生法忍。故我不任诣彼问疾
    佛告光严童子。汝行诣维摩诘问疾。光严白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔出毗耶离大城。时维摩诘方入城。我即为作礼而问言。居士从何所来。答我言。吾从道场来。我问道场者何所是。答曰。直心是道场无虚假故。发行是道场能办事故。深心是道场增益功德故。菩提心是道场无错谬故。布施是道场不望报故。持戒是道场得愿具故。忍辱是道场于诸众生心无碍故。精进是道场不懈退故。禅定是道场心调柔故。智慧是道场现见诸法故。慈是道场等众生故。悲是道场忍疲苦故。喜是道场悦乐法故。舍是道场憎爱断故。神通是道场成就六通故。解脱是道场能背舍故。方便是道场教化众生故。四摄是道场摄众生故。多闻是道场如闻行故。伏心是道场正观诸法故。三十七品是道场舍有为法故。谛是道场不诳世间故。缘起是道场无明乃至老死皆无尽故。诸烦恼是道场知如实故。众生是道场知无我故。一切法是道场知诸法空故。降魔是道场不倾动故。三界是道场无所趣故。师子吼是道场无所畏故。力无畏不共法是道场无诸过故。三明是道场无余碍故。一念知一切法是道场成就一切智故。如是善男子。菩萨若应诸波罗蜜教化众生。诸有所作举足下足。当知皆从道场来住于佛法矣。说是法时五百天人皆发阿耨多罗三藐三菩提心。故我不任诣彼问疾。佛告持世菩萨。汝行诣维摩诘问疾。持世白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔住于静室。时。魔波旬从万二千天女。状如帝释鼓乐弦歌来诣我所。与其眷属稽首我足。合掌恭敬于一面立。我意谓是帝释。而语之言。善来憍尸迦。虽福应有不当自恣。当观五欲无常以求善本。于身命财而修坚法。即语我言。正士。受是万二千天女可备扫洒。我言。憍尸迦。无以此非法之物要我沙门释子此非我宜。所言未讫时维摩诘来谓我言。非帝释也。是为魔来娆固汝耳。即语魔言。是诸女等可以与我。如我应受。魔即惊惧念。维摩诘将无恼我。欲隐形去而不能隐。尽其神力亦不得去。即闻空中声曰。波旬。以女与之乃可得去。魔以畏故俯仰而与。尔时维摩诘语诸女言。魔以汝等与我。今汝皆当发阿耨多罗三藐三菩提心。即随所应而为说法令发道意。复言。汝等已发道意。有法乐可以自娱。不应复乐五欲乐也。天女即问。何谓法乐。答言。乐常信佛。乐欲听法。乐供养众。乐离五欲。乐观五阴如怨贼。乐观四大如毒蛇。乐观内入如空聚。乐随护道意。乐饶益众生。乐敬养师。乐广行施。乐坚持戒。乐忍辱柔和。乐勤集善根。乐禅定不乱。乐离垢明慧。乐广菩提心。乐降伏众魔。乐断诸烦恼。乐净佛国土。乐成就相好故修诸功德。乐严道场。乐闻深法不畏。乐三脱门不乐非时。乐近同学。乐于非同学中心无恚碍。乐将护恶知识。乐亲近善知识。乐心喜清净。乐修无量道品之法。是为菩萨法乐。于是波旬告诸女言。我欲与汝俱还天宫。诸女言。以我等与此居士。有法乐我等甚乐。不复乐五欲乐也。魔言。居士可舍此女。一切所有施于彼者。是为菩萨。维摩诘言。我已舍矣。汝便将去。令一切众生得法愿具足。于是诸女问维摩诘。我等云何止于魔宫。维摩诘言。诸姊有法门名无尽灯。汝等当学。无尽灯者。譬如一灯燃百千灯。冥者皆明。明终不尽。如是诸姊。夫一菩萨开导百千众生。令发阿耨多罗三藐三菩提心。于其道意亦不灭尽。随所说法而自增益一切善法。是名无尽灯也。汝等虽住魔宫。以是无尽灯。令无数天子天女发阿耨多罗三藐三菩提心者。为报佛恩。亦大饶益一切众生。尔时天女。头面礼维摩诘足。随魔还宫忽然不现。世尊。维摩诘有如是自在神力智慧辩才。故我不任诣彼问疾
    佛告长者子善德。汝行诣维摩诘问疾。善德白佛言。世尊我不堪任诣彼问疾。所以者何。忆念我昔自于父舍设大施会。供养一切沙门婆罗门及诸外道贫穷下贱孤独乞人。期满七日。时维摩诘来入会中。谓我言。长者子。夫大施会不当如汝所设。当为法施之会。何用是财施会为。我言。居士。何谓法施之会。答曰。法施会者。无前无后一时供养一切众生。是名法施之会。曰何谓也。谓以菩提起于慈心。以救众生。起大悲心。以持正法起于喜心。以摄智慧行于舍心。以摄悭贪起檀波罗蜜。以化犯戒起尸罗波罗蜜。以无我法起羼提波罗蜜。以离身心相起毗梨耶波罗蜜。以菩提相起禅波罗蜜。以一切智起般若波罗蜜。教化众生而起于空。不舍有为法而起无相。示现受生而起无作。护持正法起方便力。以度众生起四摄法。以敬事一切起除慢法。于身命财起三坚法。于六念中。起思念法。于六和敬起质直心。正行善法起于净命。心净欢喜起近贤圣。不憎恶人起调伏心。以出家法起于深心。以如说行起于多闻。以无诤法起空闲处。趣向佛慧起于宴坐。解众生缚起修行地。以具相好及净佛土起福德业。知一切众生心念如应说法起于智业。知一切法不取不舍。入一相门起于慧业。断一切烦恼一切障碍一切不善法起一切善业以得一切智慧一切善法。起于一切助佛道法。如是善男子。是为法施之会。若菩萨住是法施会者。为大施主。亦为一切世间福田。世尊。维摩诘说是法时。婆罗门众中二百人皆发阿耨多罗三藐三菩提心。我时心得清净叹未曾有。稽首礼维摩诘足。即解璎珞价直百千。以上之。不肯取。我言居士。愿必纳受随意所与。维摩诘乃受璎珞分作二分。持一分施此会中一最下乞人。持一分奉彼难胜如来。一切众会皆见光明国土难胜如来。又见珠璎在彼佛上变成四柱宝台四面严饰不相障蔽。时维摩诘。现神变已作是言。若施主等心施一最下乞人。犹如如来福田之相无所分别。等于大悲不求果报。是则名曰具足法施。城中一最下乞人。见是神力闻其所说。皆发阿耨多罗三藐三菩提心。故我不任诣彼问疾。如是诸菩萨各各向佛说其本缘。称述维摩诘所言。皆曰不任诣彼问疾

    维摩诘经卷上

    维摩诘所说经卷中
    姚秦三藏鸠摩罗什译
    文殊师利问疾品第五
    尔时佛告文殊师利。汝行诣维摩诘问疾。文殊师利白佛言。世尊。彼上人者难为詶对。深达实相善说法要。辩才无滞智慧无碍。一切菩萨法式悉知。诸佛秘藏无不得入降伏众魔游戏神通。其慧方便皆已得度。虽然当承佛圣旨诣彼问疾。于是众中诸菩萨大弟子释梵四天王等咸作是念。今二大士文殊师利维摩诘共谈。必说妙法。即时八千菩萨五百声闻。百千天人皆欲随从
    于是文殊师利与诸菩萨大弟子众及诸天人恭敬围绕入毗耶离大城
    尔时长者维摩诘心念。今文殊师利与大众俱来。即以神力空其室内。除去所有及诸侍者。唯置一床以疾而卧。文殊师利既入其舍。见其室空无诸所有独寝一床。时维摩诘言。善来文殊师利。不来相而来。不见相而见
    文殊师利言。如是居士。若来已更不来。若去已更不去。所以者何。来者无所从来去者无所至所可见者更不可见。且置是事。居士。是疾宁可忍不。疗治有损不至增乎。世尊殷勤致问无量。居士。是疾何所因起。其生久如。当云何灭。维摩诘言。从痴有爱则我病生。以一切众生病是故我病。若一切众生病灭则我病灭。所以者何。菩萨为众生故入生死。有生死则有病。若众生得离病者。则菩萨无复病。譬如长者唯有一子其子得病父母亦病。若子病愈父母亦愈。菩萨如是。于诸众生爱之若子。众生病则菩萨病。众生病愈菩萨亦愈。又言。是疾何所因起。菩萨病者以大悲起。文殊师利言。居士。此室何以空无侍者。维摩诘言。诸佛国土亦复皆空。又问。以何为空。答曰。以空空。又问。空何用空。答曰。以无分别空故空。又问。空可分别耶。答曰。分别亦空。又问。空当于何求。答曰。当于六十二见中求。又问。六十二见当于何求。答曰。当于诸佛解脱中求。又问。诸佛解脱当于何求。答曰。当于一切众生心行中求。又仁所问何无侍者。一切众魔及诸外道皆吾侍也。所以者何。众魔者乐生死。菩萨于生死而不舍。外道者乐诸见。菩萨于诸见而不动。文殊师利言。居士所疾。为何等相。维摩诘言。我病无形不可见。又问。此病身合耶心合耶。答曰。非身合身相离故。亦非心合心如幻故。又问。地大水大火大风大。于此四大何大之病。答曰。是病非地大亦不离地大。水火风大亦复如是。而众生病从四大起。以其有病是故我病。尔时文殊师利问维摩诘言。菩萨应云何慰喻有疾菩萨。维摩诘言。说身无常不说厌离于身。说身有苦不说乐于涅槃。说身无我而说教导众生。说身空寂不说毕竟寂灭。说悔先罪而不说入。于过去。以己之疾愍于彼疾。当识宿世无数劫苦。当念饶益一切众生忆所修福。念于净命。勿生忧恼常起精进。当作医王疗治众病。菩萨应如是慰喻有疾菩萨令其欢喜。文殊师利言。居士。有疾菩萨云何调伏其心。维摩诘言。有疾菩萨应作是念。今我此病皆从前世妄想颠倒诸烦恼生。无有实法谁受病者。所以者何。四大合故假名为身。四大无主身亦无我。又此病起皆由着我。是故于我不应生着。既知病本即除我想及众生想。当起法想。应作是念。但以众法合成此身。起唯法起灭唯法灭。又此法者各不相知。起时不言我起。灭时不言我灭。彼有疾菩萨为灭法想。当作是念。此法想者亦是颠倒。颠倒者是即大患。我应离之。云何为离。离我我所。云何离我我所。谓离二法。云何离二法。谓不念内外诸法行于平等。云何平等。为我等涅槃等。所以者何。我及涅槃此二皆空。以何为空。但以名字故空。如此二法无决定性。得是平等无有余病。唯有空病空病亦空。是有疾菩萨以无所受而受诸受。未具佛法亦不灭受而取证也。设身有苦念恶趣众生起大悲心。我既调伏亦当调伏一切众生。但除其病而不除法。为断病本而教导之。何谓病本。谓有攀缘。从有攀缘则为病本。何所攀缘谓之三界。云何断攀缘以无所得。若无所得则无攀缘。何谓无所得。谓离二见。何谓二见。谓内见外见是无所得。文殊师利。是为有疾菩萨调伏其心。为断老病死苦是菩萨菩提。若不如是己所修治为无慧利。譬如胜怨乃可为勇。如是兼除老病死者菩萨之谓也。彼有疾菩萨应复作是念。如我此病非真非有。众生病亦非真非有。作是观时。于诸众生若起爱见大悲。即应舍离。所以者何。菩萨断除客尘烦恼而起大悲。爱见悲者则于生死有疲厌心。若能离此无有疲厌。在在所生不为爱见之所覆也。所生无缚能为众生说法解缚。如佛所说。若自有缚能解彼缚无有是处。若自无缚。能解彼缚斯有是处。是故菩萨不应起缚。何谓缚何谓解。贪着禅味是菩萨缚。以方便生是菩萨解。又无方便慧缚。有方便慧解。无慧方便缚。有慧方便解。何谓无方便慧缚。谓菩萨以爱见心。庄严佛土成就众生。于空无相无作法中而自调伏。是名无方便慧缚。何谓有方便慧解。谓不以爱见心庄严佛土成就众生。于空无相无作法中。以自调伏而不疲厌。是名有方便慧解。何谓无慧方便缚。谓菩萨住贪欲嗔恚邪见等诸烦恼。而植众德本。是名无慧方便缚。何谓有慧方便解。谓离诸贪欲嗔恚邪见等诸烦恼。而植众德本。回向阿耨多罗三藐三菩提。是名有慧方便解。文殊师利。彼有疾菩萨应如是观诸法。又复观身无常苦空非我。是名为慧。虽身有疾常在生死。饶益一切而不厌倦。是名方便。又复观身身不离病病不离身。是病是身非新非故。是名为慧。设身有疾而不永灭。是名方便。文殊师利。有疾菩萨应如是调伏其心不住其中。亦复不住不调伏心。所以者何。若住不调伏心是愚人法。若住调伏心是声闻法。是故菩萨不当住于调伏不调伏心。离此二法是菩萨行。在于生死不为污行。住于涅槃不永灭度。是菩萨行。非凡夫行非贤圣行。是菩萨行。非垢行非净行。是菩萨行。虽过魔行。而现降众魔。是菩萨行。求一切智无非时求。是菩萨行。虽观诸法不生而不入正位。是菩萨行。虽观十二缘起而入诸邪见。是菩萨行。虽摄一切众生而不爱着。是菩萨行。虽乐远离而不依身心尽。是菩萨行。虽行三界而不坏法性。是菩萨行。虽行于空而植众德本。是菩萨行。虽行无相而度众生。是菩萨行。虽行无作而现受身。是菩萨行。虽行无起而起一切善行。是菩萨行。虽行六波罗蜜而遍知众生心心数法。是菩萨行。虽行六通而不尽漏。是菩萨行。虽行四无量心而不贪着生于梵世。是菩萨行。虽行禅定解脱三昧而不随禅生。是菩萨行。虽行四念处而不永离身受心法。是菩萨行。虽行四正勤而不舍身心精进。是菩萨行。虽行四如意足而得自在神通。是菩萨行。虽行五根而分别众生诸根利钝。是菩萨行。虽行五力而乐求佛十力。是菩萨行。虽行七觉分而分别佛之智慧。是菩萨行。虽行八圣道而乐行无量佛道。是菩萨行。虽行止观助道之法而不毕竟堕于寂灭。是菩萨行。虽行诸法不生不灭而以相好庄严其身。是菩萨行。虽现声闻辟支佛威仪而不舍佛法。是菩萨行。虽随诸法究竟净相而随所应为现其身。是菩萨行。虽观诸佛国土永寂如空而现种种清净佛土。是菩萨行。虽得佛道转于法轮入于涅槃而不舍于菩萨之道。是菩萨行。说是语时文殊师利所将大众。其中八千天子皆发阿耨多罗三藐三菩提心

    维摩诘所说经不思议品第六
    尔时舍利弗。见此室中无有床座。作是念。斯诸菩萨大弟子众当于何坐。长者维摩诘知其意。语舍利弗言。云何仁者。为法来耶求床座耶。舍利弗言。我为法来非为床座。维摩诘言。唯舍利弗。夫求法者不贪躯命。何况床座。夫求法者。非有色受想行识之求。非有界入之求。非有欲色无色之求。唯舍利弗。夫求法者。不着佛求不着法求不着众求。夫求法者。无见苦求无断集求。无造尽证修道之求。所以者何。法无戏论。若言我当见苦断集证灭修道。是则戏论非求法也。唯舍利弗。法名寂灭。若行生灭是求生灭非求法也。法名无染。若染于法乃至涅槃。是则染着非求法也。法无行处。若行于法是则行处非求法也。法无取舍。若取舍法是则取舍非求法也。法无处所。若着处所。是则着处非求法也。法名无相。若随相识是则求相非求法也。法不可住。若住于法是则住法非求法也。法不可见闻觉知。若行见闻觉知。是则见闻觉知非求法也。法名无为。若行有为是求有为非求法也。是故舍利弗。若求法者。于一切法应无所求。说是语时。五百天子于诸法中得法眼净
    尔时长者维摩诘问文殊师利。仁者。游于无量千万亿阿僧祇国。何等佛土有好上妙功德成就师子之座。文殊师利言。居士。东方度三十六恒河沙国有世界。名须弥相。其佛号须弥灯王。今现在。彼佛身长八万四千由旬。其师子座高八万四千由旬严饰第一。于是长者维摩诘。现神通力。即时彼佛遣三万二千师子座高广严净。来入维摩诘室。诸菩萨大弟子释梵四天王等昔所未见。其室广博悉皆包容三万二千师子座。无所妨碍。于毗耶离城及阎浮提四天下。亦不迫迮。悉见如故
    尔时维摩诘语文殊师利。就师子座。与诸菩萨上人俱坐。当自立身如彼座像。其得神通菩萨即自变形。为四万二千由旬坐师子座。诸新发意菩萨及大弟子皆不能升
    尔时维摩诘语舍利弗。就师子座。舍利弗言。居士。此座高广吾不能升。维摩诘言。唯舍利弗。为须弥灯王如来作礼乃可得坐。于是新发意菩萨及大弟子。即为须弥灯王如来作礼。便得坐师子座。舍利弗言。居士未曾有也。如是小室乃容受此高广之座。于毗耶离城无所妨碍。又于阎浮提聚落城邑及四天下诸天龙王鬼神宫殿。亦不迫迮。维摩诘言。唯舍利弗。诸佛菩萨有解脱名不可思议。若菩萨住是解脱者。以须弥之高广内芥子中无所增减。须弥山王本相如故。而四天王忉利诸天。不觉不知己之所入。唯应度者乃见须弥入芥子中。是名住不思议解脱法门。又以四大海水入一毛孔。不娆鱼鳖鼋鼍水性之属。而彼大海本相如故。诸龙鬼神阿修罗等不觉不知己之所入。于此众生亦无所娆。又舍利弗。住不可思议解脱菩萨。断取三千大千世界。如陶家轮着右掌中。掷过恒河沙世界之外。其中众生不觉不知己之所往。又复还置本处。都不使人有往来想。而此世界本相如故。又舍利弗。或有众生乐久住世而可度者。菩萨即延七日以为一劫。令彼众生谓之一劫。或有众生不乐久住而可度者。菩萨即促一劫以为七日。令彼众生谓之七日。又舍利弗。住不可思议解脱菩萨。以一切佛土严饰之事。集在一国示于众生。又菩萨以一佛土众生置之右掌。飞到十方遍示一切。而不动本处。又舍利弗十方众生供养诸佛之具。菩萨于一毛孔皆令得见。又十方国土所有日月星宿。于一毛孔普使见之。又舍利弗。十方世界所有诸风。菩萨悉能吸着口中而身无损。外诸树木亦不摧折。又十方世界劫尽烧时。以一切火内于腹中。火事如故而不为害。又于下方过恒河沙等诸佛世界。取一佛土举着上方。过恒河沙无数世界。如持针锋举一枣叶而无所娆。又舍利弗。住不可思议解脱菩萨。能以神通现作佛身。或现辟支佛身。或现声闻身。或现帝释身。或现梵王身。或现世主身。或现转轮王身。又十方世界所有众声。上中下音皆能变之令作佛声。演出无常苦空无我之音。及十方诸佛所说种种之法。皆于其中。普令得闻。舍利弗。我今略说菩萨不可思议解脱之力。若广说者穷劫不尽。是时大迦叶。闻说菩萨不可思议解脱法门。叹未曾有。谓舍利弗。譬如有人于盲者前现众色像非彼所见。一切声闻闻是不可思议解脱法门。不能解了为若此也。智者闻是。其谁不发阿耨多罗三藐三菩提心。我等何为永绝其根。于此大乘已如败种。一切声闻闻是不可思议解脱法门。皆应号泣声震三千大千世界。一切菩萨应大欣庆顶受此法。若有菩萨信解不可思议解脱法门者。一切魔众无如之何。大迦叶说是语时。三万二千天子皆发阿耨多罗三藐三菩提心
    尔时维摩诘语大迦叶。仁者。十方无量阿僧祇世界中作魔王者。多是住不可思议解脱菩萨。以方便力教化众生现作魔王。又迦叶。十方无量菩萨。或有人从乞手足耳鼻头目髓脑血肉皮骨聚落城邑妻子奴婢象马车乘金银琉璃车磲马瑙珊瑚琥珀真珠珂贝衣服饮食。如此乞者多是住不可思议解脱菩萨。以方便力而往试之令其坚固。所以者何。住不可思议解脱菩萨。有威德力故现行逼迫。示诸众生如是难事。凡夫下劣无有力势。不能如是逼迫菩萨。譬如龙象蹴踏非驴所堪。是名住不可思议解脱菩萨智慧方便之门

    维摩诘所说经观众生品第七
    尔时文殊师利问维摩诘言。菩萨云何观于众生。维摩诘言。譬如幻师见所幻人。菩萨观众生为若此。如智者见水中月。如镜中见其面像。如热时焰。如呼声响。如空中云。如水聚沫。如水上泡。如芭蕉坚。如电久住。如第五大。如第六阴。如第七情。如十三入。如十九界。菩萨观众生为若此。如无色界色。如焦谷牙。如须陀洹身见。如阿那含入胎。如阿罗汉三毒。如得忍菩萨贪恚毁禁。如佛烦恼习。如盲者见色。如入灭尽定出入息。如空中鸟迹。如石女儿。如化人起烦恼。如梦所见已寤。如灭度者受身。如无烟之火。菩萨观众生为若此
    文殊师利言。若菩萨作是观者。云何行慈。维摩诘言。菩萨作是观已自念。我当为众生说如斯法。是即真实慈也。行寂灭慈无所生故。行不热慈无烦恼故。行等之慈等三世故。行无诤慈无所起故。行不二慈内外不合故行不坏慈毕竟尽故。行坚固慈心无毁故。行清净慈诸法性净故。行无边慈如虚空故。行阿罗汉慈破结贼故。行菩萨慈安众生故。行如来慈得如相故。行佛之慈觉众生故。行自然慈无因得故。行菩提慈等一味故。行无等慈断诸爱故。行大悲慈导以大乘故。行无厌慈观空无我故。行法施慈无遗惜故。行持戒慈化毁禁故。行忍辱慈护彼我故。行精进慈荷负众生故。行禅定慈不受味故。行智慧慈无不知时故。行方便慈一切示现故。行无隐慈直心清净故。行深心慈无杂行故。行无诳慈不虚假故。行安乐慈令得佛乐故。菩萨之慈为若此也
    文殊师利又问。何谓为悲。答曰。菩萨所作功德。皆与一切众生共之。何谓为喜。答曰。有所饶益欢喜无悔。何谓为舍。答曰。所作福祐无所悕望。文殊师利又问。生死有畏菩萨当何所依。维摩诘言。菩萨于生死畏中。当依如来功德之力。文殊师利又问。菩萨欲依如来功德之力。当于何住。答曰。菩萨欲依如来功德力者。当住度脱一切众生。又问。欲度众生当何所除。答曰。欲度众生除其烦恼。又问。欲除烦恼当何所行。答曰。当行正念。又问。云何行于正念。答曰。当行不生不灭。又问。何法不生何法不灭。答曰。不善不生善法不灭。又问。善不善孰为本。答曰身为本。又问。身孰为本。答曰。欲贪为本。又问。欲贪孰为本。答曰。虚妄分别为本。又问。虚妄分别孰为本。答曰。颠倒想为本。又问。颠倒想孰为本。答曰。无住为本。又问。无住孰为本。答曰。无住则无本。文殊师利。从无住本立一切法
    时维摩诘室有一天女。见诸大人闻所说法便现其身。即以天华散诸菩萨大弟子上。华至诸菩萨即皆堕落。至大弟子便着不堕。一切弟子神力去华不能令去。尔时天女问舍利弗。何故去华。答曰。此华不如法是以去之天曰。勿谓此华为不如法。所以者何。是华无所分别。仁者自生分别想耳。若于佛法出家有所分别为不如法。若无所分别是则如法。观诸菩萨华不著者已断一切分别想故。譬如人畏时非人得其便。如是弟子畏生死故。色声香味触得其便也。已离畏者一切五欲无能为也。结习未尽华着身耳。结习尽者华不着也。舍利弗言。天止此室其已久如。答曰。我止此室如耆年解脱。舍利弗言。止此久耶。天曰。耆年解脱亦何如久。舍利弗默然不答。天曰。如何耆旧大智而默。答曰。解脱者无所言说故吾于是不知所云。天曰。言说文字皆解脱相。所以者何。解脱者不内不外不在两间。文字亦不内不外不在两间。是故舍利弗。无离文字说解脱也。所以者何。一切诸法是解脱相。舍利弗言。不复以离淫怒痴为解脱乎。天曰。佛为增上慢人。说离淫怒痴为解脱耳。若无增上慢者。佛说淫怒痴性即是解脱。舍利弗言。善哉善哉。天女。汝何所得以何为证辩乃如是。天曰。我无得无证故辩如是。所以者何。若有得有证者即于佛法为增上慢
    舍利弗问天。汝于三乘为何志求。天曰。以声闻法化众生故我为声闻。以因缘法化众生故我为辟支佛。以大悲法化众生故我为大乘。舍利弗。如人入瞻卜林唯嗅瞻卜不嗅余香。如是若入此室。但闻佛功德之香。不乐闻声闻辟支佛功德香也。舍利弗。其有释梵四天王诸天龙鬼神等入此室者。闻斯上人讲说正法。皆乐佛功德之香发心而出。舍利弗。吾止此室十有二年。初不闻说声闻辟支佛法。但闻菩萨大慈大悲不可思议诸佛之法。舍利弗。此室常现八未曾有难得之法。何等为八。此室常以金色光照昼夜无异。不以日月所照为明。是为一未曾有难得之法。此室入者不为诸垢之所恼也。是为二未曾有难得之法。此室常有释梵四天王他方菩萨来会不绝。是为三未曾有难得之法。此室常说六波罗蜜不退转法。是为四未曾有难得之法。此室常作天人第一之乐弦出无量法化之声。是为五未曾有难得之法。此室有四大藏众宝积满。赒穷济乏求得无尽。是为六未曾有难得之法。此室释迦牟尼佛．阿弥陀佛．阿閦佛．宝德．宝炎．宝月．宝严．难胜．师子响．一切利成。如是等十方无量诸佛。是上人念时。即皆为来广说诸佛秘要法藏说已还去。是为七未曾有难得之法。此室一切诸天严饰宫殿诸佛净土皆于中现。是为八未曾有难得之法。舍利弗。此室常现八未曾有难得之法。谁有见斯不思议事。而复乐于声闻法乎。舍利弗言。汝何以不转女身。天曰。我从十二年来。求女人相了不可得。当何所转。譬如幻师化作幻女。若有人问何以不转女身。是人为正问不。舍利弗言。不也。幻无定相当何所转。天曰一切诸法亦复如是无有定相。云何乃问不转女身。即时天女以神通力。变舍利弗令如天女。天自化身如舍利弗。而问言。何以不转女身。舍利弗以天女像而答言。我今不知何转而变为女身。天曰。舍利弗。若能转此女身。则一切女人亦当能转。如舍利弗非女而现女身。一切女人亦复如是。虽现女身而非女也。是故佛说一切诸法非男非女。即时天女还摄神力。舍利弗身还复如故。天问舍利弗。女身色相今何所在。舍利弗言。女身色相无在无不在。天曰。一切诸法亦复如是。无在无不在。夫无在无不在者佛所说也。舍利弗问天。汝于此没当生何所。天曰。佛化所生吾如彼生。曰佛化所生非没生也。天曰。众生犹然无没生也。舍利弗问天。汝久如当得阿耨多罗三藐三菩提。天曰。如舍利弗还为凡夫。我乃当成阿耨多罗三藐三菩提。舍利弗言。我作凡夫无有是处。天曰。我得阿耨多罗三藐三菩提亦无是处。所以者何。菩提无住处。是故无有得者。舍利弗言。今诸佛得阿耨多罗三藐三菩提。已得当得。如恒河沙。皆谓何乎。天曰。皆以世俗文字数故说有三世。非谓菩提有去来今。天曰。舍利弗。汝得阿罗汉道耶。曰无所得故而得。天曰。诸佛菩萨亦复如是。无所得故而得
    尔时维摩诘。语舍利弗。是天女已曾供养九十二亿佛已。能游戏菩萨神通。所愿具足得无生忍住不退转。以本愿故随意能现教化众生

    维摩诘所说经佛道品第八
    尔时文殊师利问维摩诘言。菩萨云何通达佛道。维摩诘言。若菩萨行于非道。是为通达佛道。又问。云何菩萨行于非道。答曰。若菩萨行五无间而无恼恚。至于地狱无诸罪垢。至于畜生无有无明憍慢等过。至于饿鬼而具足功德。行色无色界道不以为胜。示行贪欲离诸染着。示行嗔恚于诸众生无有恚阂。示行愚痴而以智慧调伏其心。示行悭贪而舍内外所有不惜身命。示行毁禁而安住净戒。乃至小罪犹怀大惧。示行嗔恚而常慈忍。示行懈怠而勤修功德。示行乱意而常念定。示行愚痴而通达世间出世间慧。示行谄伪而善方便随诸经义。示行憍慢而于众生犹如桥梁。示行诸烦恼而心常清净。示入于魔而顺佛智慧不随他教。示入声闻而为众生说未闻法。示入辟支佛而成就大悲教化众生。示入贫穷而有宝手功德无尽。示入刑残而具诸相好以自庄严。示入下贱而生佛种姓中具诸功德。示入羸劣丑陋而得那罗延身。一切众生之所乐见。示入老病而永断病根超越死畏。示有资生而恒观无常实无所贪。示有妻妾采女而常远离五欲淤泥。现于讷钝而成就辩才总持无失。示入邪济而以正济度诸众生。现遍入诸道而断其因缘。现于涅槃而不断生死。文殊师利。菩萨能如是行于非道。是为通达佛道
    于是维摩诘问文殊师利。何等为如来种。文殊师利言。有身为种。无明有爱为种。贪恚痴为种。四颠倒为种。五盖为种。六入为种。七识处为种。八邪法为种。九恼处为种。十不善道为种。以要言之。六十二见及一切烦恼皆是佛种。曰何谓也。答曰。若见无为入正位者。不能复发阿耨多罗三藐三菩提心。譬如高原陆地不生莲华卑湿淤泥乃生此华。如是见无为法入正位者。终不复能生于佛法。烦恼泥中乃有众生起佛法耳。又如殖种于空终不得生。粪壤之地乃能滋茂。如是入无为正位者不生佛法。起于我见如须弥山。犹能发于阿耨多罗三藐三菩提心生佛法矣。是故当知一切烦恼为如来种。譬如不下巨海不能得无价宝珠。如是不入烦恼大海。则不能得一切智宝
    尔时大迦叶叹言。善哉善哉文殊师利。快说此语诚如所言。尘劳之畴为如来种。我等今者不复堪任发阿耨多罗三藐三菩提心。乃至五无间罪。犹能发意生于佛法。而今我等永不能发。譬如根败之士其于五欲不能复利。如是声闻诸结断者。于佛法中无所复益永不志愿。是故文殊师利。凡夫于佛法有返复。而声闻无也。所以者何。凡夫闻佛法能起无上道心不断三宝。正使声闻终身闻佛法力无畏等。永不能发无上道意
    尔时会中有菩萨名普现色身。问维摩诘言。居士。父母妻子亲戚眷属吏民知识悉为是谁。奴婢僮仆象马车乘皆何所在。于是维摩诘以偈答曰
智度菩萨母 方便以为父
一切众导师 无不由是生
法喜以为妻 慈悲心为女
善心诚实男 毕竟空寂舍
弟子众尘劳 随意之所转
道品善知识 由是成正觉
诸度法等侣 四摄为伎女
歌咏诵法言 以此为音乐
总持之园苑 无漏法林树
觉意净妙华 解脱智慧果
八解之浴池 定水湛然满
布以七净华 浴此无垢人
象马五通驰 大乘以为车
调御以一心 游于八正路
相具以严容 众好饰其姿
惭愧之上服 深心为华鬘
富有七财宝 教授以滋息
如所说修行 回向为大利
四禅为床座 从于净命生
多闻增智慧 以为自觉音
甘露法之食 解脱味为浆
净心以澡浴 戒品为涂香
摧灭烦恼贼 勇健无能踰
降伏四种魔 胜幡建道场
虽知无起灭 示彼故有生
悉现诸国土 如日无不见
供养于十方 无量亿如来
诸佛及己身 无有分别想
虽知诸佛国 及与众生空
而常修净土 教化于群生
诸有众生类 形声及威仪
无畏力菩萨 一时能尽现
觉知众魔事 而示随其行
以善方便智 随意皆能现
或示老病死 成就诸群生
了知如幻化 通达无有碍
或现劫尽烧 天地皆洞然
众人有常想 照令知无常
无数亿众生 俱来请菩萨
一时到其舍 化令向佛道
经书禁咒术 工巧诸伎艺
尽现行此事 饶益诸群生
世间众道法 悉于中出家
因以解人惑 而不堕邪见
或作日月天 梵王世界主
或时作地水 或复作风火
劫中有疾疫 现作诸药草
若有服之者 除病消众毒
劫中有饥馑 现身作饮食
先救彼饥渴 却以法语人
劫中有刀兵 为之起慈心
化彼诸众生 令住无诤地
若有大战阵 立之以等力
菩萨现威势 降伏使和安
一切国土中 诸有地狱处
辄往到于彼 勉济其苦恼
一切国土中 畜生相食啖
皆现生于彼 为之作利益
示受于五欲 亦复现行禅
令魔心愦乱 不能得其便
火中生莲华 是可谓希有
在欲而行禅 希有亦如是
或现作淫女 引诸好色者
先以欲钩牵 后令入佛道
或为邑中主 或作商人导
国师及大臣 以祐利众生
诸有贫穷者 现作无尽藏
因以劝导之 令发菩提心
我心憍慢者 为现大力士
消伏诸贡高 令住无上道
其有恐惧众 居前而慰安
先施以无畏 后令发道心
或现离淫欲 为五通仙人
开导诸群生 令住戒忍慈
见须供事者 现为作僮仆
既悦可其意 乃发以道心
随彼之所须 得入于佛道
以善方便力 皆能给足之
如是道无量 所行无有涯
智慧无边际 度脱无数众
假令一切佛 于无量亿劫
赞叹其功德 犹尚不能尽
谁闻如是法 不发菩提心
除彼不肖人 痴冥无智者

    维摩诘所说经入不二法门品第九
    尔时维摩诘。谓众菩萨言。诸仁者。云何菩萨入不二法门。各随所乐说之。会中有菩萨名法自在。说言。诸仁者。生灭为二。法本不生今则无灭。得此无生法忍。是为入不二法门
    德守菩萨曰。我我所为二。因有我故便有我所。若无有我则无我所。是为入不二法门
    不眴菩萨曰。受不受为二。若法不受则不可得。以不可得故无取无舍无作无行。是为入不二法门
    德顶菩萨曰。垢净为二。见垢实性则无净相顺于灭相。是为入不二法门
    善宿菩萨曰。是动是念为二。不动则无念。无念则无分别。通达此者。是为入不二法门
    善眼菩萨曰。一相无相为二。若知一相即是无相。亦不取无相入于平等。是为入不二法门
    妙臂菩萨曰。菩萨心声闻心为二。观心相空如幻化者。无菩萨心无声闻心。是为入不二法门
    弗沙菩萨曰。善不善为二。若不起善不善。入无相际而通达者。是为入不二法门
    师子菩萨曰。罪福为二。若达罪性则与福无异。以金刚慧决了此相无缚无解者。是为入不二法门
    师子意菩萨曰。有漏无漏为二。若得诸法等则不起漏不漏想。不着于相亦不住无相。是为入不二法门
    净解菩萨曰。有为无为为二。若离一切数则心如虚空。以清净慧无所碍者。是为入不二法门
    那罗延菩萨曰。世间出世间为二。世间性空即是出世间。于其中不入不出不溢不散。是为入不二法门
    善意菩萨曰。生死涅槃为二。若见生死性则无生死。无缚无解不生不灭。如是解者。是为入不二法门
    现见菩萨曰。尽不尽为二。法若究竟尽若不尽皆是无尽相。无尽相即是空。空则无有尽不尽相。如是入者。是为入不二法门
    普守菩萨曰。我无我为二。我尚不可得非我何可得。见我实性者不复起二。是为入不二法门
    电天菩萨曰。明无明为二。无明实性即是明。明亦不可取离一切数。于其中平等无二者。是为入不二法门
    喜见菩萨曰。色色空为二。色即是空非色灭空色性自空。如是受想行识识空为二。识即是空非识灭空识性自空。于其中而通达者。是为入不二法门
    明相菩萨曰。四种异空种异为二。四种性即是空种性。如前际后际空故中际亦空。若能如是知诸种性者。是为入不二法门
    妙意菩萨曰。眼色为二。若知眼性于色不贪不恚不痴。是名寂灭。如是耳声鼻香舌味身触意法为二。若知意性于法不贪不恚不痴。是名寂灭。安住其中。是为入不二法门
    无尽意菩萨曰。布施回向一切智为二。布施性即是回向一切智性。如是持戒忍辱精进禅定智慧。回向一切智为二。智慧性即是回向一切智性。于其中入一相者。是为入不二法门
    深慧菩萨曰。是空是无相是无作为二。空即无相无相即无作。若空无相无作则无心意识。于一解脱门即是三解脱门者。是为入不二法门
    寂根菩萨曰。佛法众为二。佛即是法法即是众。是三宝皆无为相与虚空等。一切法亦尔。能随此行者。是为入不二法门
    心无碍菩萨曰。身身灭为二。身即是身灭。所以者何。见身实相者不起见身及见灭身。身与灭身无二无分别。于其中不惊不惧者。是为入不二法门
    上善菩萨曰。身口意善为二。是三业皆无作相。身无作相即口无作相。口无作相即意无作相。是三业无作相即一切法无作相。能如是随无作慧者。是为入不二法门
    福田菩萨曰。福行罪行不动行为二。三行实性即是空。空则无福行无罪行无不动行。于此三行而不起者。是为入不二法门
    华严菩萨曰。从我起二为二。见我实相者不起二法。若不住二法则无有识。无所识者。是为入不二法门
    德藏菩萨曰。有所得相为二。若无所得则无取舍。无取舍者。是为入不二法门
    月上菩萨曰。闇与明为二。无闇无明则无有二。所以者何。如入灭受想定无闇无明一切法相亦复如是。于其中平等入者。是为入不二法门
    宝印手菩萨曰。乐涅槃不乐世间为二。若不乐涅槃不厌世间则无有二。所以者何。若有缚则有解。若本无缚其谁求解。无缚无解则无乐厌。是为入不二法门
    珠顶王菩萨曰。正道邪道为二。住正道者则不分别是邪是正。离此二者。是为入不二法门
    乐实菩萨曰。实不实为二。实见者尚不见实何况非实。所以者何。非肉眼所见慧眼乃能见。而此慧眼无见无不见。是为入不二法门
    如是诸菩萨各各说已。问文殊师利。何等是菩萨入不二法门
    文殊师利曰。如我意者。于一切法无言无说。无示无识离诸问答是为入不二法门于是文殊师利。问维摩诘。我等各自说已。仁者当说。何等是菩萨入不二法门
    时维摩诘默然无言
    文殊师利叹曰。善哉善哉。乃至无有文字语言。是真入不二法门
    说是入不二法门品时。于此众中五千菩萨。皆入不二法门得无生法忍

    维摩诘所说经卷中

    维摩诘所说经卷下
    姚秦三藏鸠摩罗什译
    香积佛品第十
    于是舍利弗心念。日时欲至。此诸菩萨当于何食。时维摩诘。知其意而语言。佛说八解脱。仁者受行。岂杂欲食而闻法乎。若欲食者且待须臾。当令汝得未曾有食。时维摩诘即入三昧。以神通力示诸大众。上方界分过四十二恒河沙佛土。有国名众香。佛号香积。今现在。其国香气比于十方诸佛世界人天之香最为第一。彼土无有声闻辟支佛名。唯有清净大菩萨众。佛为说法。其界一切皆以香作楼阁。经行香地苑园皆香。其食香气周流十方无量世界。时彼佛与诸菩萨方共坐食。有诸天子皆号香严。悉发阿耨多罗三藐三菩提心。供养彼佛及诸菩萨。此诸大众莫不目见。时维摩诘问众菩萨言。诸仁者。谁能致彼佛饭。以文殊师利威神力故咸皆默然。维摩诘言。仁此大众无乃可耻。文殊师利曰。如佛所言勿轻未学。于是维摩诘。不起于座居众会前化作菩萨。相好光明威德殊胜蔽于众会。而告之曰。汝往上方界。分度如四十二恒河沙佛土。有国名众香。佛号香积。与诸菩萨方共坐食。汝往到彼如我辞曰。维摩诘稽首世尊足下。致敬无量问讯起居少病少恼气力安不。愿得世尊所食之余。当于娑婆世界施作佛事。令此乐小法者得弘大道。亦使如来名声普闻。时化菩萨即于会前升于上方。举众皆见其去到众香界礼彼佛足。又闻其言。维摩诘稽首世尊足下。致敬无量问讯起居少病少恼气力安不。愿得世尊所食之余。欲于娑婆世界施作佛事。使此乐小法者得弘大道。亦使如来名声普闻。彼诸大士见化菩萨叹未曾有。今此上人从何所来。娑婆世界为在何许。云何名为乐小法者。即以问佛。佛告之曰。下方度如四十二恒河沙佛土。有世界名娑婆。佛号释迦牟尼。今现在于五浊恶世。为乐小法众生敷演道教。彼有菩萨名维摩诘。住不可思议解脱。为诸菩萨说法。故遣化来称扬我名并赞此土。令彼菩萨增益功德。彼菩萨言。其人何如乃作是化。德力无畏神足若斯。佛言。甚大。一切十方皆遣化往施作佛事饶益众生。于是香积如来。以众香钵盛满香饭与化菩萨。时彼九百万菩萨俱发声言。我欲诣娑婆世界供养释迦牟尼佛。并欲见维摩诘等诸菩萨众。佛言可往。摄汝身香。无令彼诸众生起惑着心。又当舍汝本形。勿使彼国求菩萨者而自鄙耻。又汝于彼莫怀轻贱而作碍想。所以者何。十方国土皆如虚空。又诸佛为欲化诸乐小法者。不尽现其清净土耳。时化菩萨既受钵饭。与彼九百万菩萨俱。承佛威神及维摩诘力。于彼世界忽然不现。须臾之间至维摩诘舍。时维摩诘。即化作九百万师子之座严好如前。诸菩萨皆坐其上。是化菩萨以满钵香饭与维摩诘。饭香普熏毗耶离城及三千大千世界。时毗耶离婆罗门居士等。闻是香气身意快然叹未曾有。于是长者主月盖。从八万四千人来入维摩诘舍。见其室中菩萨甚多诸师子座高广严好。皆大欢喜礼众菩萨及大弟子。却住一面。诸地神虚空神及欲色界诸天。闻此香气亦皆来入维摩诘舍。时维摩诘语舍利弗等诸大声闻。仁者可食如来甘露味饭大悲所熏无以限意食之使不消也。有异声闻念。是饭少而此大众人人当食。化菩萨曰。勿以声闻小德小智称量如来无量福慧。四海有竭此饭无尽。使一切人食揣若须弥乃至一劫犹不能尽。所以者何。无尽戒定智慧解脱解脱知见功德具足者。所食之余。终不可尽。于是钵饭悉饱众会犹故不[歹*斯]。其诸菩萨声闻天人食此饭者。身安快乐。譬如一切乐庄严国诸菩萨也。又诸毛孔皆出妙香。亦如众香国土诸树之香
    尔时维摩诘问众香菩萨。香积如来以何说法。彼菩萨曰。我土如来无文字说。但以众香令诸天人得入律行。菩萨各各坐香树下闻斯妙香。即获一切德藏三昧。得是三昧者。菩萨所有功德皆悉具足。彼诸菩萨问维摩诘。今世尊释迦牟尼以何说法。维摩诘言。此土众生刚强难化故。佛为说刚强之语以调伏之。言是地狱是畜生是饿鬼。是诸难处。是愚人生处。是身邪行是身邪行报。是口邪行是口邪行报。是意邪行是意邪行报。是杀生是杀生报。是不与取是不与取报。是邪淫是邪淫报。是妄语是妄语报。是两舌是两舌报。是恶口是恶口报。是无义语是无义语报。是贪嫉是贪嫉报。是嗔恼是嗔恼报。是邪见是邪见报。是悭吝是悭吝报。是毁戒是毁戒报。是嗔恚是嗔恚报。是懈怠是懈怠报。是乱意是乱意报。是愚痴是愚痴报。是结戒是持戒是犯戒。是应作是不应作。是障碍是不障碍。是得罪是离罪。是净是垢。是有漏是无漏。是邪道是正道。是有为是无为。是世间是涅槃。以难化之人心如猨猴故。以若干种法制御其心乃可调伏。譬如象马[怡-台+龙]悷不调加诸楚毒乃至彻骨然后调伏。如是刚强难化众生故。以一切苦切之言乃可入律。彼诸菩萨闻说是已。皆曰未曾有也。如世尊释迦牟尼佛。隐其无量自在之力。乃以贫所乐法度脱众生。斯诸菩萨亦能劳谦。以无量大悲生是佛土。维摩诘言。此土菩萨于诸众生大悲坚固。诚如所言。然其一世饶益众生。多于彼国百千劫行。所以者何。此娑婆世界有十事善法。诸余净土之所无有。何等为十。以布施摄贫穷。以净戒摄毁禁。以忍辱摄嗔恚。以精进摄懈怠。以禅定摄乱意。以智慧摄愚痴。说除难法度八难者。以大乘法度乐小乘者。以诸善根济无德者。常以四摄成就众生。是为十。彼菩萨曰。菩萨成就几法。于此世界行无疮疣生于净土。维摩诘言。菩萨成就八法。于此世界行无疮疣生于净土。何等为八。饶益众生而不望报。代一切众生受诸苦恼。所作功德尽以施之。等心众生谦下无碍。于诸菩萨视之如佛。所未闻经闻之不疑。不与声闻而相违背。不嫉彼供不高己利。而于其中调伏其心。常省己过不讼彼短。恒以一心求诸功德。是为八法。维摩诘文殊师利。于大众中说是法时。百千天人皆发阿耨多罗三藐三菩提心。十千菩萨得无生法忍

    维摩诘所说经菩萨行品第十一
    是时佛说法于庵罗树园。其地忽然广博严事。一切众会皆作金色。阿难白佛言。世尊。以何因缘有此瑞应。是处忽然广博严事。一切众会皆作金色。佛告阿难。是维摩诘文殊师利。与诸大众恭敬围绕。发意欲来故先为此瑞应。于是维摩诘语文殊师利。可共见佛与诸菩萨礼事供养。文殊师利言。善哉行矣。今正是时。维摩诘即以神力。持诸大众并师子座置于右掌。往诣佛所到已着地。稽首佛足右绕七匝。一心合掌在一面立。其诸菩萨即皆避座稽首佛足。亦绕七匝于一面立。诸大弟子释梵四天王等。亦皆避座稽首佛足在一面立。于是世尊如法慰问诸菩萨已各令复坐。即皆受教众坐已定。佛语舍利弗。汝见菩萨大士自在神力之所为乎。唯然已见。于汝意云何。世尊。我睹其为不可思议。非意所图非度所测。尔时阿难白佛言。世尊。今所闻香自昔未有。是为何香。佛告阿难。是彼菩萨毛孔之香。于是舍利弗语阿难言。我等毛孔亦出是香。阿难言。此所从来。曰。是长者维摩诘。从众香国取佛余饭于舍食者。一切毛孔皆香若此。阿难问维摩诘。是香气住当久如。维摩诘言。至此饭消。曰。此饭久如当消。曰。此饭势力至于七日然后乃消。又阿难。若声闻人未入正位食此饭者。得入正位然后乃消。已入正位食此饭者。得心解脱然后乃消。若未发大乘意食此饭者。至发意乃消。已发意食此饭者。得无生忍然后乃消。已得无生忍食此饭者。至一生补处然后乃消。譬如有药名曰上味其有服者身诸毒灭然后乃消。此饭如是灭除一切诸烦恼毒然后乃消。阿难白佛言。未曾有也。世尊。如此香饭能作佛事。佛言。如是如是。阿难。或有佛土以佛光明而作佛事。有以诸菩萨而作佛事。有以佛所化人而作佛事。有以菩提树而作佛事。有以佛衣服卧具而作佛事。有以饭食而作佛事。有以园林台观而作佛事。有以三十二相八十随形好而作佛事。有以佛身而作佛事。有以虚空而作佛事。众生应以此缘得入律行。有以梦幻影响镜中像水中月热时炎如是等喻而作佛事。有以音声语言文字而作佛事。或有清净佛土寂寞无言无说无示无识无作无为而作佛事。如是阿难。诸佛威仪进止。诸所施为无非佛事。阿难。有此四魔八万四千诸烦恼门。而诸众生为之疲劳。诸佛即以此法而作佛事。是名入一切诸佛法门。菩萨入此门者。若见一切净好佛土。不以为喜不贪不高。若见一切不净佛土。不以为忧不碍不没。但于诸佛生清净心。欢喜恭敬未曾有也。诸佛如来功德平等。为化众生故。而现佛土不同。阿难。汝见诸佛国土。地有若干而虚空无若干也。如是见诸佛色身有若干耳其无碍慧无若干也。阿难。诸佛色身威相种性。戒定智慧解脱解脱知见。力无所畏不共之法。大慈大悲威仪所行。及其寿命说法教化。成就众生净佛国土。具诸佛法。悉皆同等。是故名为三藐三佛陀。名为多陀阿伽度。名为佛陀。阿难。若我广说此三句义。汝以劫寿不能尽受。正使三千大千世界满中众生。皆如阿难多闻第一得念总持。此诸人等以劫之寿亦不能受。如是阿难。诸佛阿耨多罗三藐三菩提无有限量。智慧辩才不可思议。阿难白佛言。我从今已往不敢自谓以为多闻。佛告阿难。勿起退意。所以者何。我说汝于声闻中为最多闻。非谓菩萨。且止阿难。其有智者不应限度诸菩萨也。一切海渊尚可测量。菩萨禅定智慧总持辩才一切功德不可量也。阿难。汝等舍置菩萨所行。是维摩诘一时所现神通之力。一切声闻辟支佛。于百千劫尽力变化所不能作
    尔时众香世界菩萨来者。合掌白佛言。世尊。我等初见此土生下劣想。今自悔责舍离是心。所以者何。诸佛方便不可思议。为度众生故。随其所应现佛国异。唯然世尊。愿赐少法还于彼土当念如来。佛告诸菩萨。有尽无尽解脱法门。汝等当学。何谓为尽。谓有为法。何谓无尽。谓无为法。如菩萨者。不尽有为不住无为。何谓不尽有为。谓不离大慈不舍大悲。深发一切智心而不忽忘。教化众生终不厌惓。于四摄法常念顺行。护持正法不惜躯命。种诸善根无有疲厌。志常安住方便回向。求法不懈说法无吝。勤供诸佛故。入生死而无所畏。于诸荣辱心无忧喜。不轻未学敬学如佛。堕烦恼者令发正念。于远离乐不以为贵。不着己乐庆于彼乐。在诸禅定如地狱想。于生死中如园观想。见来求者为善师想。舍诸所有具一切智想见毁戒人起救护想。诸波罗蜜为父母想。道品之法为眷属想。发行善根无有齐限。以诸净国严饰之事成己佛土行无限施具足相好。除一切恶净身口意。生死无数劫意而有勇。闻佛无量德志而不倦。以智慧剑破烦恼贼出阴界入。荷负众生永使解脱。以大精进摧伏魔军。常求无念实相智慧行。于世间法少欲知足。于出世间求之无厌。而不舍世间法不坏威仪法而能随俗。起神通慧引导众生。得念总持所闻不忘。善别诸根断众生疑。以乐说辩演法无碍。净十善道受天人福。修四无量开梵天道。劝请说法随喜赞善。得佛音声身口意善。得佛威仪深修善法所行转胜。以大乘教成菩萨僧。心无放逸不失众善。行如此法。是名菩萨不尽有为。何谓菩萨不住无为。谓修学空不以空为证。修学无相无作。不以无相无作为证。修学无起不以无起为证。观于无常而不厌善本。观世间苦而不恶生死。观于无我而诲人不倦。观于寂灭而不永灭。观于远离而身心修善。观无所归而归趣善法。观于无生而以生法荷负一切。观于无漏而不断诸漏。观无所行而以行法教化众生。观于空无而不舍大悲。观正法位而不随小乘。观诸法虚妄无牢无人无主无相。本愿未满而不虚福德禅定智慧。修如此法。是名菩萨不住无为。又具福德故不住无为。具智慧故不尽有为。大慈悲故不住无为。满本愿故不尽有为。集法药故不住无为。随授药故不尽有为。知众生病故不住无为。灭众生病故不尽有为。诸正士菩萨以修此法。不尽有为不住无为。是名尽无尽解脱法门。汝等当学。尔时彼诸菩萨闻说是法皆大欢喜。以众妙华若干种色若干种香。散遍三千大千世界。供养于佛及此经法并诸菩萨已。稽首佛足叹未曾有言。释迦牟尼佛。乃能于此善行方便。言已忽然不现还到彼国

    维摩诘所说经见阿閦佛品第十二
    尔时世尊问维摩诘。汝欲见如来。为以何等观如来乎。维摩诘言。如自观身实相。观佛亦然。我观如来。前际不来后际不去今则不住。不观色不观色如。不观色性。不观受想行识。不观识如。不观识性。非四大起。同于虚空。六入无积。眼耳鼻舌身心已过不在三界。三垢已离顺三脱门。具足三明与无明等。不一相不异相。不自相不他相。非无相非取相。不此岸不彼岸不中流。而化众生。观于寂灭亦不永灭。不此不彼。不以此不以彼。不可以智知。不可以识识。无晦无明无名无相。无强无弱非净非秽。不在方不离方。非有为非无为。无示无说。不施不悭。不戒不犯。不忍不恚。不进不怠。不定不乱。不智不愚。不诚不欺。不来不去。不出不入。一切言语道断。非福田非不福田。非应供养非不应供养。非取非舍。非有相非无相。同真际等法性。不可称不可量。过诸称量。非大非小。非见非闻非觉非知。离众结缚。等诸智同众生。于诸法无分别。一切无失。无浊无恼。无作无起无生无灭。无畏无忧无喜无厌无著。无已有无当有无今有。不可以一切言说分别显示。世尊。如来身为若此。作如是观。以斯观者名为正观。若他观者名为邪观
    尔时舍利弗问维摩诘。汝于何没而来生此。维摩诘言。汝所得法有没生乎。舍利弗言。无没生也。若诸法无没生相。云何问言汝于何没而来生此。于意云何。譬如幻师幻作男女。宁没生耶。舍利弗言。无没生也。汝岂不闻佛说诸法如幻相乎。答曰如是。若一切法如幻相者。云何问言汝于何没而来生此。舍利弗。没者为虚诳法败坏之相。生者为虚诳法相续之相。菩萨虽没不尽善本。虽生不长诸恶。是时佛告舍利弗。有国名妙喜。佛号无动。是维摩诘于彼国没而来生此。舍利弗言。未曾有也。世尊。是人乃能舍清净土。而来乐此多怒害处。维摩诘语舍利弗。于意云何。日光出时与冥合乎。答曰。不也。日光出时即无众冥。维摩诘言。夫日何故行阎浮提。答曰欲以明照为之除冥。维摩诘言。菩萨如是。虽生不净佛土为化众生故不与愚闇而共合也。但灭众生烦恼闇耳。是时大众渴仰。欲见妙喜世界无动如来及其菩萨声闻之众。佛知一切众会所念。告维摩诘言。善男子。为此众会。现妙喜国无动如来及诸菩萨声闻之众。众皆欲见。于是维摩诘心念。吾当不起于座接妙喜国。铁围山川溪谷江河。大海泉源须弥诸山。及日月星宿。天龙鬼神梵天等宫。并诸菩萨声闻之众。城邑聚落男女大小。乃至无动如来及菩提树诸妙莲华。能于十方作佛事者。三道宝阶从阎浮提至忉利天以此宝阶诸天来下。悉为礼敬无动如来听受经法。阎浮提人。亦登其阶。上升忉利见彼诸天。妙喜世界成就如是无量功德上至阿迦腻吒天。下至水际。以右手断取如陶家轮。入此世界犹持华鬘示一切众。作是念已入于三昧现神通力。以其右手断取妙喜世界置于此土。彼得神通菩萨及声闻众并余天人。俱发声言。唯然世尊。谁取我去。愿见救护。无动佛言。非我所为。是维摩诘神力所作。其余未得神通者。不觉不知己之所往。妙喜世界虽入此土而不增减。于是世界亦不迫隘如本无异
    尔时释迦牟尼佛告诸大众。汝等且观妙喜世界无动如来其国严饰。菩萨行净弟子清白。皆曰。唯然已见。佛言。若菩萨欲得如是清净佛土。当学无动如来所行之道。现此妙喜国时。娑婆世界十四那由他人发阿耨多罗三藐三菩提心。皆愿生于妙喜佛土。释迦牟尼佛即记之曰。当生彼国。时妙喜世界于此国土。所应饶益其事讫已。还复本处举众皆见。佛告舍利弗。汝见此妙喜世界及无动佛不。唯然已见。世尊。愿使一切众生得清净土如无动佛。获神通力如维摩诘。世尊。我等快得善利。得见是人亲近供养。其诸众生若今现在若佛灭后。闻此经者亦得善利。况复闻已信解受持读诵解说如法修行。若有手得是经典者。便为已得法宝之藏。若有读诵解释其义如说修行。即为诸佛之所护念。其有供养如是人者。当知即为供养于佛。其有书持此经卷者。当知其室即有如来。若闻是经能随喜者。斯人即为取一切智。若能信解此经乃至一四句偈为他说者。当知此人即是受阿耨多罗三藐三菩提记

    维摩诘所说经法供养品第十三
    尔时释提桓因于大众中白佛言。世尊。我虽从佛及文殊师利闻百千经。未曾闻此不可思议自在神通决定实相经典。如我解佛所说义趣。若有众生闻是经法。信解受持读诵之者。必得是法不疑。何况如说修行。斯人即为闭众恶趣开诸善门。常为诸佛之所护念。降伏外学摧灭魔怨。修治菩提安处道场。履践如来所行之迹。世尊。若有受持读诵如说修行者。我当与诸眷属供养给事。所在聚落城邑山林旷野有是经处。我亦与诸眷属。听受法故共到其所。其未信者当令生信。其已信者当为作护。佛言。善哉善哉。天帝。如汝所说。吾助尔喜。此经广说过去未来现在诸佛不可思议阿耨多罗三藐三菩提。是故天帝。若善男子善女人。受持读诵供养是经者即为供养去来今佛。天帝。正使三千大千世界如来满中。譬如甘蔗竹[竺-二+韦]稻麻丛林。若有善男子善女人。或一劫或减一劫。恭敬尊重赞叹供养奉诸所安。至诸佛灭后。以一一全身舍利起七宝塔。纵广一四天下高至梵天表刹庄严。以一切华香璎珞幢幡伎乐微妙第一。若一劫若减一劫而供养之。于天帝意云何。其人植福宁为多不。释提桓因言。多矣世尊。彼之福德若以百千亿劫说不能尽。佛告天帝。当知是善男子善女人。闻是不可思议解脱经典信解受持读诵修行福多于彼。所以者何。诸佛菩提皆从是生。菩提之相不可限量。以是因缘福不可量
    佛告天帝。过去无量阿僧祇劫时。世有佛号曰药王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名大庄严。劫曰庄严。佛寿二十小劫。其声闻僧三十六亿那由他。菩萨僧有十二亿。天帝。是时有转轮圣王名曰宝盖。七宝具足主四天下。王有千子。端正勇健能伏怨敌。尔时宝盖与其眷属供养药王如来。施诸所安至满五劫。过五劫已告其千子。汝等亦当如我以深心供养于佛。于是千子受父王命。供养药王如来。复满五劫一切施安。其王一子名曰月盖。独坐思惟。宁有供养殊过此者。以佛神力空中有天曰。善男子。法之供养胜诸供养。即问。何谓法之供养。天曰。汝可往问药王如来。当广为汝说法之供养。即时月盖王子行诣药王如来稽首佛足。却住一面白佛言。世尊。诸供养中法供养胜。云何为法供养。佛言。善男子。法供养者。诸佛所说深经。一切世间难信难受。微妙难见清净无染。非但分别思惟之所能得。菩萨法藏所摄。陀罗尼印印之。至不退转成就六度。善分别义顺菩提法。众经之上入大慈悲。离众魔事及诸邪见。顺因缘法。无我无人无众生无寿命。空无相无作无起。能令众生坐于道场而转法轮。诸天龙神乾闼婆等所共叹誉。能令众生入佛法藏摄诸贤圣一切智慧。说众菩萨所行之道。依于诸法实相之义。明宣无常苦空无我寂灭之法。能救一切毁禁众生。诸魔外道及贪著者能使怖畏。诸佛贤圣所共称叹。背生死苦示涅槃乐。十方三世诸佛所说。若闻如是等经。信解受持读诵。以方便力为诸众生分别解说显示分明。守护法故。是名法之供养。又于诸法如说修行。随顺十二因缘。离诸邪见得无生忍。决定无我无有众生。而于因缘果报。无违无诤离诸我所。依于义不依语。依于智不依识。依了义经不依不了义经。依于法不依人。随顺法相无所入无所归。无明毕竟灭故。诸行亦毕竟灭。乃至生毕竟灭故。老死亦毕竟灭。作如是观。十二因缘无有尽相。不复起见。是名最上法之供养
    佛告天帝。王子月盖从药王佛。闻如是法得柔顺忍。即解宝衣严身之具。以供养佛白佛言。世尊。如来灭后我当行法供养守护正法。愿以威神加哀建立。令我得降魔怨修菩萨行。佛知其深心所念。而记之曰。汝于末后守护法城。天帝。时王子月盖见法清净。闻佛授记以信出家。修集善法精进不久。得五神通逮菩萨道。得陀罗尼无断辩才。于佛灭后以其所得神通总持辩才之力。满十小劫。药王如来所转法轮随而分布。月盖比丘以守护法勤行精进。即于此身化百万亿人。于阿耨多罗三藐三菩提立不退转。十四那由他人深发声闻辟支佛心。无量众生得生天上。天帝。时王宝盖岂异人乎。今现得佛号宝炎如来。其王千子即贤劫中千佛是也。从迦罗鸠孙驮为始得佛。最后如来号曰楼至。月盖比丘即我身是。如是天帝。当知此要。以法供养于诸供养为上。为最第一无比。是故天帝。当以法之供养供养于佛

    维摩诘所说经嘱累品第十四
    于是佛告弥勒菩萨言。弥勒。我今以是无量亿阿僧祇劫所集阿耨多罗三藐三菩提法。付嘱于汝。如是辈经于佛灭后末世之中。汝等当以神力广宣流布于阎浮提无令断绝。所以者何。未来世中当有善男子善女人。及天龙鬼神乾闼婆罗刹等。发阿耨多罗三藐三菩提心乐于大法。若使不闻如是等经则失善利。如此辈人闻是等经。必多信乐发希有心当以顶受随诸众生所应得利而为广说。弥勒当知。菩萨有二相。何谓为二。一者好于杂句文饰之事。二者不畏深义如实能入。若好杂句文饰事者。当知是为新学菩萨。若于如是无染无著甚深经典。无有恐畏能入其中。闻已心净受持读诵如说修行。当知是为久修道行。弥勒。复有二法。名新学者。不能决定于甚深法。何等为二。一者所未闻深经。闻之惊怖生疑不能随顺。毁谤不信而作是言。我初不闻从何所来。二者若有护持解说如是深经者。不肯亲近供养恭敬。或时于中说其过恶。有此二法。当知是为新学菩萨。为自毁伤。不能于深法中调伏其心。弥勒。复有二法。菩萨虽信解深法。犹自毁伤而不能得无生法忍。何等为二。一者轻慢新学菩萨而不教诲。二者虽解深法而取相分别。是为二法
    弥勒菩萨闻说是已白佛言。世尊。未曾有也。如佛所说。我当远离如斯之恶奉持如来无数阿僧祇劫所集阿耨多罗三藐三菩提法。若未来世善男子善女人求大乘者当令手得如是等经。与其念力。使受持读诵为他广说。世尊。若后末世有能受持读诵为他说者。当知皆是弥勒神力之所建立。佛言。善哉善哉弥勒。如汝所说。佛助尔喜
    于是一切菩萨合掌白佛。我等亦于如来灭后。十方国土广宣流布阿耨多罗三藐三菩提法。复当开导诸说法者令得是经
    尔时四天王白佛言。世尊。在在处处城邑聚落山林旷野。有是经卷读诵解说者。我当率诸官属为听法故往诣其所拥护其人。面百由旬令无伺求得其便者
    是时佛告阿难。受持是经广宣流布。阿难言唯然。我已受持要者。世尊。当何名斯经。佛言。阿难。是经名为维摩诘所说。亦名不可思议解脱法门。如是受持。佛说是经已。长者维摩诘．文殊师利．舍利弗．阿难等。及诸天人阿修罗一切大众。闻佛所说皆大欢喜

    维摩诘经卷下


Library

    Library: Sutra: Vimalakirti Nirdesa Sutra

    VIMALAKIRTI NIRDESA SUTRA
    1. Purification of the Buddha-Field
    Translated by Robert A. F. Thurman
    copyright 1976, The Pennsylvania State University
    Reverence to all Buddhas, Bodhisattvas, Aryasravakas, and Pratyekabuddhas, in the past, the present, and the future.

    Thus have I heard at one time. The Lord Buddha was in residence in the garden of Amrapali, in the city of Vaisali, attended by a great gathering. Of bhikshus there were eight thousand, all saints. They were free from impurities and afflictions, and all had attained self-mastery. Their minds were entirely liberated by perfect knowledge. They were calm and dignified, like royal elephants. They had accomplished their work, done what they had to do, cast off their burdens, attained their goals, and totally destroyed the bonds of existence. They all had attained the utmost perfection of every form of mind control.

    Of bodhisattvas there were thirty-two thousand, great spiritual heroes who were universally acclaimed. They were dedicated through the penetrating activity of their great superknowledges and were sustained by the grace of the Buddha. Guardians of the city of Dharma, they upheld the true doctrine, and their great teachings resounded like the lion's roar throughout the ten directions.

    Without having to be asked, they were the natural spiritual benefactors of all living beings. They maintained unbroken the succession of the Three Jewels, conquering devils and foes and overwhelming all critics.

    Their mindfulness, intelligence, realization, meditation, incantation, and eloquence all were perfected. They had attained the intuitive tolerance of the ultimate incomprehensibility of all things. They turned the irreversible wheel of the Dharma. They were stamped with the insignia of signlessness. They were expert in knowing the spiritual faculties of all living beings. They were brave with the confidence that overawes all assemblies. They had gathered the great stores of merit and of wisdom, and their bodies, beautiful without ornaments, were adorned with all the auspicious signs and marks.

    They were exalted in fame and glory, like the lofty summit of Mount Sumeru. Their high resolve as hard as diamond, unbreakable in their faith in Buddha, Dharma and Sangha, they showered forth the rain of ambrosia that is released by the light rays of the jewel of the Dharma, which shines everywhere.

    Their voices were perfect in diction and resonance, and versatile in speaking all languages. They had penetrated the profound principle of relativity and had destroyed the persistence of the instinctual mental habits underlying all convictions concerning finitude and infinitude. They spoke fearlessly, like lions, sounding the thunder of the magnificent teaching. Unequaled, they surpassed all measure. They were the best captains for the voyage of discovery of the treasures of the Dharma, the stores of merit and wisdom. They were expert in the way of the Dharma, which is straight, peaceful, subtle, gentle, hard to see, and difficult to realize.

    They were endowed with the wisdom that is able to understand the thoughts of living beings, as well as their comings and goings. They had been consecrated with the anointment of the peerless gnosis of the Buddha. With their high resolve, they approached the ten powers, the four fearlessnesses, and the eighteen special qualities of the Buddha.

    They had crossed the terrifying abyss of the bad migrations, and yet they assumed reincarnation voluntarily in all migrations for the sake of disciplining living beings. Great Kings of medicine, understanding all the sicknesses of passions, they could apply the medicine of the Dharma appropriately. They were inexhaustible mines of limitless virtues, and they glorified innumerable buddha-fields with the splendor of these virtues. They conferred great benefit when seen, heard, or even approached. Were one to extol them for innumerable hundreds of thousands of myriads of aeons, one still could not exhaust their mighty flood of virtues.

    These bodhisattvas were named: Samadarsana, Asamadarsana, Samadhivikurvitaraja, harmesvara, Dharmaketu, Prabhaketu, Prabhavyuha, Ratnavyuha, Mahavyuha, Pratibhanakuta, Ratnakuta, Ratnapani, Ratnamudrahasta, Nityapralambahasta, Nityotksipthasta, Nityatapta, Nityamuditendriya, Pramodyaraja, Devaraja, Pranidhanapravesaprapta, Prasiddhapratisamvitprapta, Gaganaganja, Ratnolkaparigrhita, Ratnasura, Ratnapriya, Ratnasri, Indrajala, Jaliniprabha, Niralambanadhyana, Prajnakuta, Ratnadatta, Marapramardaka, Vidyuddeva, Vikurvanaraja, Kutanimittasamatikranta, Simhanadanadin, Giryagrapramardiraja, Gandhahastin, Gandhakunjaranaga, Nityodyukta, Aniksiptadhura, Pramati, Sujata, Padmasrigarbha, Padmavyuha, Avalokitesvara, Mahasthamaprapta, Brahmajala, Ratnadandin, Marakarmavijeta, Ksetrasamalamkara, Maniratnacchattra, Suvarnacuda, Manicuda, Maitreya, Manjusrikumarabhuta, and so forth, with the remainderof the thirty-two thousand.

    There were also gathered there ten thousand Brahmas, at their head Brahma Sikhin, who had come from theAsoka universe with its four sectors to see, venerate, and serve the Buddha and to hear the Dharma from hisown mouth. There were twelve thousand Sakras, from various four-sector universes. And there were otherpowerful gods: Brahmas, Sakras, Lokapalas, devas, nagas, yaksas, gandharvas, asuras, garudas, kimnaras, and mahoragas. Finally, there was the fourfold community, consisting of bhikshus, bhikshunis, laymen, and laywomen.

    The Lord Buddha, thus surrounded and venerated by these multitudes of many hundreds of thousands of living beings, sat upon a majestic lion-throne and began to teach the Dharma. Dominating all the multitudes, just as Sumeru, the king of mountains, looms high over the oceans, the Lord Buddha shone, radiated, and glittered as he sat upon his magnificent lion-throne.

    Thereupon, the Licchavi bodhisattva Ratnakara, with five hundred Licchavi youths, each holding a precious parasol made of seven different kinds of jewels, came forth from the city of Vaisali and presented himself at the grove of Amrapali. Each approached the Buddha, bowed at his feet, circumambulated him clockwise seven times, laid down his precious parasol in offering, and withdrew to one side.

    As soon as all these precious parasols had been laid down, suddenly, by the miraculous power of the Lord, they were transformed into a single precious canopy so great that it formed a covering for this entire billion-world galaxy. The surface of the entire billion-world galaxy was reflected in the interior of the great precious canopy, where the total content of this galaxy could be seen: limitless mansions of suns, moons, and stellar bodies; the realms of the devas, nagas, yaksas, gandharvas, asuras, garudas, kimnaras, and mahoragas, as well as the realms of the four Maharajas; the king of mountains, Mound Sumeru; Mount Himadri, Mount Mucilinda, Mount

    Mahamucilinda, Mount Gandhamadana, Mount Ratnaparvata, Mount Kalaparvata, Mount Cakravada, Mount Mahacakravada; all the great oceans, rivers, bays torrents, streams, brooks, and springs; finally, all the villages, suburbs, cities, capitals, provinces, and wildernesses. All this could be clearly seen by everyone. And

    the voices of all the Buddhas of the ten directions could be heard proclaiming their teachings of the Dharma in all the worlds, the sounds reverberating in the space beneath the great precious canopy.

    At this vision of the magnificent miracle effected by the supernatural power of the Lord Buddha, the entire host was ecstatic, enraptured, astonished, delighted, satisfied, and filled with awe and pleasure. They all bowed down to the Tathagata, withdrew to one side with palms pressed together, and gazed upon him with fixed attention. The young Licchavi Ratnakara knelt with his right knee on the ground, raised his hands, palms pressed together in salute of the Buddha, and praised him with the following hymn.

    Pure are your eyes, broad and beautiful, like the petals of a blue lotus.

    Pure is your thought, having discovered the supreme transcendence of all trances.

    Immeasurable is the ocean of your virtues, the accumulation of your good deeds.

    You affirm the path of peace.

    Oh, Great Ascetic, obeisance to you!

    Leader, bull of men, we behold the revelation of your miracle.

    The superb and radiant fields of the Sugatas appear before us,

    And your extensive spiritual teachings, that lead to immortality

    Make themselves heard throughout the whole reach of space.

    Dharma-King, you rule with the Dharma your supreme Dharma-kingdom,

    And thereby bestow the treasures of the Dharma upon all living beings.

    Expert in the deep analysis of things, you teach their ultimate meaning.

    Sovereign Lord of Dharma, obeisance to you.

    All these things arise dependently, from causes,

    Yet they are neither existent nor nonexistent.

    Therein is neither ego, nor experiencer, nor doer,

    Yet no action, good or evil, loses its effects.

    Such is your teaching.

    O Sakyamuni, conquering the powerful host of Mara,

    You found peace, immortality, and the happiness of that supreme enlightenment,

    Which is not realized by any among the heterodox,

    Though they arrest their feeling, thought and mental processes.

    O Wonderful King of Dharma,

    You turned the wheel of Dharma before men and gods,

    With its threefold revolution, its manifold aspects,

    Its purity of nature, and its extreme peace;

    And thereby the Three Jewels were revealed.

    Those who are well disciplined by your precious Dharma

    Are free of vain imaginings and always deeply peaceful.

    Supreme doctor, you put an end to birth, decay, sickness, and death.

    Immeasurable ocean of virtue, obeisance to you!

    Like Mount Sumeru, you are unmoved by honor or scorn.

    You love moral beings and immoral beings equally.

    Poised in equanimity, your mind is like the sky.

    Who would not honor such a precious jewel of a being?

    Great Sage, in all these multitudes gathered here,

    Who look upon your countenance with hearts sincere in faith,

    Each being beholds the Victor, as if just before him.

    This is a special quality of the Buddha.

    Although the Lord speaks with but one voice,

    Those present perceive that same voice differently,

    And each understands in his own language according to his own needs.

    This is a special quality of the Buddha.

    From the Leader's act of speaking in a single voice,

    Some merely develop an instinct for the teaching, some gain realization,

    Some find pacification of all their doubts.

    This is a special quality of the Buddha.

    Obeisance to you who command the force of leadership and the ten powers!

    Obeisance to you who are dauntless, knowing no fear!

    Obeisance to you, leader of all living beings,

    Who fully manifests the special qualities!

    Obeisance to you who have cut the bondage of all fetters!

    Obeisance to you who, having gone beyond, stand on firm ground!

    Obeisance to you who save the suffering beings!

    Obeisance to you who do not remain in the migrations!

    You associate with living beings by frequenting their migrations.

    Yet your mind is liberated from all migrations.

    Just as the lotus, born of mud, is not tainted thereby,

    So the lotus of the Buddha preserves the realization of voidness.

    You nullify all signs in all things everywhere.

    You are not subject to any wish for anything at all.

    The miraculous power of the Buddhas is inconceivable.

    I bow to you, who stand nowhere, like infinite space.

    Then, the young Licchavi Ratnakara, having celebrated the Buddha with these verses, further addressed him:

    "Lord, these five hundred young Licchavis are truly on their way to unexcelled, perfect enlightenment, and they have asked what is the bodhisattvas' purification of the buddha-field. Please, Lord, explain to them the bodhisattvas' purification of the buddha-field!"

    Upon this request, the Buddha gave his approval to the young Licchavi Ratnakara: "Good, good, young man!

    Your question to the Tathagata about the purification of the buddha-field is indeed good. Therefore, young man, listen well and remember! I will explain to you the purification of the buddha-field of the bodhisattvas."

    "Very good, Lord," replied Ratnakara and the five hundred young Licchavis, and they set themselves to listen.

    The Buddha said, "Noble sons, a buddha-field of bodhisattvas is a field of living beings. Why so? A bodhisattva embraces a buddha-field to the same extent that he causes the development of living beings. He embraces a buddha-field to the same extent that living beings become disciplined. He embraces a buddha-field to the same extent that, through entrance into a buddha-field, living beings are introduced to the buddha-gnosis. He embraces a buddha-field to the same extent that, through entrance into that buddha-field, living beings increase their holy spiritual faculties. Why so? Noble son, a buddha-field of bodhisattvas springs from the aims of living beings.

    "For example, Ratnakara, should one wish to build in empty space, one might go ahead in spite of the fact that it is not possible to build or to adorn anything in empty space. In just the same way, should a bodhisattva, who knows full well that all things are like empty space, wish to build a buddha-field in order to develop living beings, he might go ahead, in spite of the fact that it is not possible to build or to adorn a buddha-field in empty space.

    "Yet, Ratnakara, a bodhisattva's buddha-field is a field of positive thought. When he attains enlightenment, living beings free of hypocrisy and deceit will be born in his buddha-field.

    "Noble son, a bodhisattva's buddha-field is a field of high resolve. When he attains enlightenment, living beings who have harvested the two stores and have planted the roots of virtue will be born in his buddha-field.

    "A bodhisattva's buddha-field is a field of virtuous application. When he attains enlightenment living beings who live by all virtuous principles will be born in his buddha-field.

    "A bodhisattva's buddha-field is the magnificence of the conception of the spirit of enlightenment. When he attains enlightenment, living beings who are actually participating in the Mahayana will be born in his buddha-field.

    "A bodhisattva's buddha-field is a field of generosity. When he attains enlightenment, living beings who give away all their possessions will be born in his buddha-field.

    "A bodhisattva's buddha-field is a field of tolerance. When he attains enlightenment, living beings with the transcendences of tolerance, discipline, and the superior trance - hence beautiful with the thirty-two auspicious signs - will be born in his buddha-field.

    "A bodhisattva's buddha-field is a field of meditation. When he attains enlightenment, living beings who are evenly balanced through mindfulness and awareness will be born in his buddha-field.

    "A bodhisattva's buddha-field is a field of wisdom. When he attains enlightenment, living beings who are destined for the ultimate will be born in his buddha-field.

    "A bodhisattva's buddha-field consists of the four immeasurables. When he attains enlightenment, living beings who live by love, compassion, joy, and impartiality will be born in his buddha-field.

    "A bodhisattva's buddha-field consists of the four means of unification. When he attains enlightenment, living beings who are held together by all the liberations will be born in his buddha-field.

    "A bodhisattva's buddha-field is skill in liberative technique.

    When he attains enlightenment, living beings skilled in all liberative techniques and activities will be born in his buddha-field.

    "A bodhisattva's buddha-field consists of the thirty-seven aids to enlightenment. Living beings who devote their efforts to the four foci of mindfulness, the four right efforts, the four bases of magical power, the five spiritual faculties, the five strengths, the seven factors of enlightenment, and the eight branches of the holy path will be born in his buddha-field.

    "A bodhisattva's buddha-field is his mind of total dedication. When he attains enlightenment, the ornaments of all virtues will appear in his buddha-field.

    "A bodhisattva's buddha-field is the doctrine that eradicates the eight adversities. When he attains

    enlightenment, the three bad migrations will cease, and there will be no such thing as the eight adversities in his buddha-field.

    "A bodhisattva's buddha-field consists of his personal observance of the basic precepts and his restraint in blaming others for their transgressions. When he attains enlightenment, even the word 'crime' will never be mentioned in his buddha-field.

    "A bodhisattva's buddha-field is the purity of the path of the ten virtues. When he attains enlightenment, living beings who are secure in long life, great in wealth, chaste in conduct, enhanced by true speech, soft-spoken, free of divisive intrigues and adroit in reconciling factions, enlightening in their conversations, free of envy, free of malice, and endowed with perfect views will be born in his buddha-field.

    "Thus, noble son, just as is the bodhisattva's production of the spirit of enlightenment, so is his positive thought. And just as is his positive thought, so is his virtuous application.

    "His virtuous application is tantamount to his high resolve, his high resolve is tantamount to his determination, his determination is tantamount to his practice, his practice is tantamount to his total dedication, his total

    dedication is tantamount to his liberative technique, his liberative technique is tantamount to his development of living beings, and his development of living beings is tantamount to the purity of his buddha-field.

    "The purity of his buddha-field reflects the purity of living beings; the purity of the living beings reflects the purity of his gnosis; the purity of his gnosis reflects the purity of his doctrine; the purity of his doctrine reflects the purity of his transcendental practice; and the purity of his transcendental practice reflects the purity of his own mind."

    Thereupon, magically influenced by the Buddha, the venerable Sariputra had this thought: "If the buddha-field is pure only to the extent that the mind of the bodhisattva is pure, then, when Sakyamuni Buddha was engaged in the career of the bodhisattva, his mind must have been impure. Otherwise, how could this buddha-field appear to be so impure?"

    The Buddha, knowing telepathically the thought of venerable Sariputra, said to him, "What do you think, Sariputra? Is it because the sun and moon are impure that those blind from birth do not see them?"

    Sariputra replied, "No, Lord. It is not so. The fault lies with those blind from birth, and not with the sun and moon."

    The Buddha declared, "In the same way, Sariputra, the fact that some living beings do not behold the splendid display of virtues of the buddha-field of the Tathagata is due to their own ignorance. It is not the fault of the Tathagata. Sariputra, the buddha-field of the Tathagata is pure, but you do not see it."

    Then the Brahma Sikhin said to the venerable Sariputra, "Reverend Sariputra, do not say that the buddha-field of the Tathagata is impure. Reverend Sariputra, the buddha-field of the Tathagata is pure. I see the splendid expanse of the buddha-field of the Lord Sakyamuni as equal to the splendor of, for example, the abodes of the highest deities."

    Then the venerable Sariputra said to the Brahma Sikhin, "As for me, O Brahma, I see this great earth, with its highs and lows, its thorns, its precipices, its peaks, and its abysses, as if it were entirely filled with ordure."

    Brahma Sikhin replied, "The fact that you see such a buddha-field as this as if it were so impure, reverend Sariputra, is a sure sign that there are highs and lows in your mind and that your positive thought in regard to the buddha-gnosis is not pure either. Reverend Sariputra, those whose minds are impartial toward all living beings and whose positive thoughts toward the buddha-gnosis are pure see this buddha-field as perfectly pure."

    Thereupon the Lord touched the ground of this billion-world-galactic universe with his big toe, and suddenly it was transformed into a huge mass of precious jewels, a magnificent array of many hundreds of thousands of clusters of precious gems, until it resembled the universe of the Tathagata Ratnavyuha, called

    Anantagunaratnavyuha. Everyone in the entire assembly was filled with wonder, each perceiving himself seated on a throne of jeweled lotuses.

    Then, the Buddha said to the venerable Sariputra, "Sariputra, do you see this splendor of the virtues of the buddha-field?"

    Sariputra replied, "I see it, Lord! Here before me is a display of splendor such as I never before heard of or beheld!"

    The Buddha said, "Sariputra, this buddha-field is always thus pure, but the Tathagata makes it appear to be spoiled by many faults, in order to bring about the maturity of the inferior living beings. For example, Sariputra, the gods of the Trayastrimsa heaven all take their food from a single precious vessel, yet the nectar which nourishes each one differs according to the differences of the merits each has accumulated. Just so, Sariputra, living beings born in the same buddha-field see the splendor of the virtues of the buddha-fields of the Buddhas according to their own degrees of purity."

    When this splendor of the beauty of the virtues of the buddha-field shone forth, eighty-four thousand beings conceived the spirit of unexcelled perfect enlightenment, and the five hundred Licchavi youths who had accompanied the young Licchavi Ratnakara all attained the conformative tolerance of ultimate birthlessness.

    Then, the Lord withdrew his miraculous power and at once the buddha-field was restored to its usual appearance. Then, both men and gods who subscribed to the disciple-vehicle thought, "Alas! All constructed things are impermanent."

    Thereby, thirty-two thousand living beings purified their immaculate, undistorted Dharma-eye in regard to all things. The eight thousand bhikshus were liberated from their mental defilements, attaining the state of nongrasping. And the eighty-four thousand living beings who were devoted to the grandeur of the buddha-field, having understood that all things are by nature but magical creations, all conceived in their own minds the spirit of unexcelled, totally perfect enlightenment.


Library

《维摩诘所说经》 Vimalakirti Nirdesa Sutra